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Confluence Documentation Home

Confluence is where you create, organize and discuss work with your team. Learn

more or try it for free.
Capture the knowledge that's too often lost in email inboxes and shared network drives in Confluence instead
— where it's easy to find, use, and update. Give every team, project, or department its own space to create

the things they need, whether it's meeting notes, product requirements, file lists, or project plans, you can get
it done in Confluence.
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Upgrade Confluence
Get started

Welcome to the Confluence getting started documentation. In this section, you'll find tutorials and other
information that'll be useful for evaluating Confluence, and getting to know it when you're starting out.

Teams in Space

For each tutorial in this section, we'll use a fictional organisation known as 'Teams in Space'. Their mission is to:

"Perform flight research and technology integration to revolutionize aviation and pioneer aerospace
technology. Also, land the first humans on Mars by 2020."

You're an astronaut in the 'See Space EZ' team, which is working on the upcoming colonisation of Mars.
Go ahead - dive into the tutorials, and let us show you around Confluence and some of its handy features.

® Tutorial: Navigate Confluence
® The dashboard
® The space directory
® The space sidebar
® Keyboard shortcuts
® Complete your mission
® Tutorial: Space ace
® Create a project space
® Create your personal space
® Create the team's PR space
® Delete and archive spaces
® Confluence Mobile

Tutorial: Navigate Confluence

Confluence is pretty simple to use, once you get to know it. This tutorial aims to get you acquainted with the
Confluence user interface, and show you how and where to perform some common tasks.

Teams in Space

In this tutorial,you'll be working with some new Teams in Space recruits. Let's get to know them.
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Alana Baczewski Emma Silvetti William Vladinov
Tech Lead Launch Specialist Aerospace Engineer

Now that you've met your team, let's take a look at your mission.

Mission brief

Your mission commander has thrown you a curveball: this week you'll be training new recruits at Teams in
Space HQ on your collaboration tool — Confluence. You just need to know the basics, so we'll go through the
main things you need to know to complete your mission.

Your mission is broken up into the following components:

® Get to know the dashboard

® Find your way in the space directory

® Master the space sidebar

® |mpress everyone with keyboard shortcuts

Those new recruits will be here tomorrow; we better get started!

Let's go!

The dashboard

The dashboard

The space directory
The space sidebar
Keyboard shortcuts
Complete your
mission

agrwnE

The dashboard is the hub of your Confluence site, providing you with access to information and updates that
are important to you. It's also the first thing your new recruits will see, so you need to make a good
impression on this one.

You can get to the dashboard from anywhere in Confluence by choosing the site logo at the left of the
Confluence header.

The dashboard has a collapsible sidebar that helps you get around:

® Discover
Watch the action unfold in real time with All updates or check out pages with lots of likes and activity
in the Popular feed.

* My Work
Get lightning fast access to your recently created and edited pages in Recently worked on, get back
to that page you stumbled across yesterday in Recently viewed, and have mission critical pages on
speed dial under Favourites.

® My Spaces
This is where you can keep links to the spaces that you hop in and out of several times a day.

If you're a Confluence admin you can give the dashboard some personality by adding useful announcements,
links, or a photo from your last mission (or office party). The the whole right hand column is ready and waiting
for you to customise.
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Try clicking one of the spaces on the sidebar, then return to the dashboard by clicking the site logo. Even
when your shuttle is spinning out of control, the dashboard is there to orient you.

You'll discover more about the dashboard as you get to know Confluence, but, for now, let's move on to the
space directory.

Pro tips
® You can choose to set any page as your personal home page
® You can always get to the dashboard at https://yoursite.conlw ki/dashboard. ac

tion

® Your Confluence admin can customise the global dashboard that all users see

The space directory

The dashboard

The space directory
The space sidebar
Keyboard shortcuts
Complete your
mission

agrwnE

The space directory won't let you look up ET in the intergalactic phone book, but it will let you see and filter
all the spaces in your Confluence site. Spaces are places to collect pages with a common theme — you can
create as many spaces as you like — and you can find them all in the space directory.

Here are some tasks to get you comfortable using the space directory:

1. Visit the space directory — To get to the space directory, choose Spaces > Space directory in the
Confluence header.

2. Choose the spaces you'll use the most — No doubt there'll be a space or two that you'll use on a
regular basis. Click the star to the right of a space to make it appear under My Spaces on the
dashboard.

3. Choose space categories — Once you're there, you'll see a list of all the spaces in your Confluence
site. Choose the 'My Spaces' category on the left to see only the spaces you marked with a star. Then
choose all spaces again.

4. Filter the list of spaces — Type part of a space name in the Filter field at the top right. That'll quickly
narrow down the list of spaces if there are a lot of them.
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X Confluence Spaces~ People Create

Space Directory

All Spaces Site Spaces
Site Spaces Space
Personal Spaces

@ IT Knowledge Base
My Spaces
Archived Spaces '& Social
CATEGORIES g Teams in Space

Knowledge-base
Hint: Your space administrator can organise spaces into categories. Learn more.

14

@) Create

Filter

knowledge-base @

@
@

You can also categorise spaces with labels you create yourself. We're not going to cover that here,

but, if you'd like to know more, you can check out Use Labels to Categorise Spaces.

Understanding and using the space directory will make it much easier to find pages and blog posts that are
relevant to you.

You're ready to impress those new recruits with your knowledge of Confluence's space directory; now it's
time to sneak a peek at the space sidebar.

The space sidebar

agrwnE

The dashboard

The space directory
The space sidebar
Keyboard shortcuts
Complete your
mission

What's in the sidebar?

The sidebar is a feature of every Confluence space;
it's where you'll find the page tree (a hierarchical list
of pages in the space), customisable space
shortcuts, and a link to the space's blog.

The See Space EZ team will find their meeting
notes, decisions, requirements, and other pages in
the sidebar. Basically any page you create in the
space will appear in the sidebar by default.

When you use certain page templates, like
meeting notes, Confluence will automatically
add an index page to your space shortcuts.
The index page is just a place where you
can view all pages of the same type —
meeting notes in this example — in one
place.

The space's blog is great for announcements and
what's new-type updates.
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Configure the sidebar g Teams in Space
You can expand or collapse the sidebar using the & Pages

left square bracket ( [ ) on your keyboard, or by

dragging it with your mouse. Blog

SPACE SHORTCUTS
Meeting Notes

Product Requirements

Team Scrum Board Space shortcuts
o Link to Confluence
File Lists pages or other

pages on the web
PAGE TREE

v Meeting Notes
2014-07-10 SeeSpaceEZ Team Mee

> Product Planning

> Product Requirements

Page tree
> Teams in Space PR Hierarchical view
of pages in this
File Lists space

Meet the SeeSpaceEZ Team

¥ Space tools v «

There are lots of things you can change in the sidebar, but we'll stick to the basics — just enough to train your
new recruits.

You need to be a space admin to complete this task. Take a look, but feel free to skip it if you're not
an admin of any space.

Try this out:

1. Choose Space tools > Configure sidebar from the bottom of the sidebar (or the cog menu if your
sidebar is collapsed)

2. Add a space shortcut by clicking +Add link
Shortcuts can be to Confluence pages or spaces, or to any other content on the web. Try linking to thi
s blog post, which mentions Teams in Space (we're always after a plug at Teams in Space HQ!)

You can also hide things — like the space's blog — in the sidebar, if they're of no use in the space.

The sidebar is pretty easy, right? You'll be schooling those recruits in no time. Next up: Impress them with

your knowledge of keyboard shortcuts.

Keyboard shortcuts

The dashboard

The space directory
The space sidebar
Keyboard shortcuts
Complete your
mission

agrwbnE

Give a person some space food, and they'll eat for a day; teach a person to rehydrate their own space food,
and they're set for the whole mission. Or something like that. Keyboard shortcuts fall into this basket. We
could give you a list here, but then you'd need to keep referring to this page. The best way to go is to show
you how to find the list of keyboard shortcuts within Confluence.

Your recruits also need to work fast, so you'll need to pass this wisdom on to them.
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Find the keyboard shortcuts

To open the list of keyboard shortcuts in Confluence, do any of the following:

® Choose the help icon

at top right of the screen, then choose Keyboard Shortcuts
®* When viewing a page, press Shift+?
* While editing a page, choose the question mark icon
2

in the editor toolbar

What you'll see is a dialog listing the available keyboard shortcuts in Confluence.

Keyboard Shortcuts

General To configure Autocomplete, go to your editor settings
Editor
Editor Autoformatting Font Formatting Autocomplete
Bold text *Bold* Image/Media
Underline text +Underline+ Link
Italic text _Italic_ Macro
Monospace text {{Monospace}} Mention
Date
Tables Styles
first [111] + enter Heading
cell Heading
heading heading |[heading||heading]| Quote
Emoticons Lists
(] (/) 1. list
) ) o bullets

hl. H

h3. H

bg. Q

# lis

* bul

The keyboard shortcuts are broken up into 3 categories:

® General — Global, page and blog post shortcuts.
® Editor — Text editing and formatting shortcuts.
® Editor Autoformatting — Wiki markup and autoformatting shortcuts.

You can turn the 'General' keyboard shortcuts off when you visit the General tab in the keyboard
shortcuts dialog.

Take some time to open the dialog and take a look at the shortcuts, and maybe find some you'll use a lot.
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Then, start practising!

Next, we'll wrap up this mission and give you some ideas about where to head from here.

Complete your mission

The dashboard

The space directory
The space sidebar
Keyboard shortcuts
Complete your
mission

aprwNE

Well done, astronaut, you've acquitted yourself admirably. I'm sure those new recruits will be mightily
impressed with your knowledge of Confluence.

In this tutorial, we've:

® Explored the anatomy of the dashboard

® Navigated using the space directory and favourited a space

® Taken a look at and customised the space sidebar

® Found a handy list of keyboard shortcuts to help you work faster

Just look at your team's adoring faces...

If you'd like to take things to the next level, check out our tutorial on becoming a space ace.

Tutorial: Space ace

This tutorial will take you on a journey through Confluence to create and customise spaces, and delete them
if you want to, so you can achieve the rank of 'Space Ace'l

You'll need to have the 'Create space' and 'Create personal space' permission to complete this tutorial. If
you've just set up Confluence, you won't have any trouble; if you're using an existing instance and you're not
an admin, speak to your Confluence admin to make sure you have the right permissions.

Teams in Space

In this tutorial you're a new recruit on
the Teams in Space crew, but, even
though you're new, you'll be given a lot
of responsibility. You need the power
to go with it.

Mission brief

You're in charge of organising information and resources for the planned mission to Mars. There's going to
be plenty of important information, and it must be readily available to the people who need it. Some
information, though, will be sensitive, and may be 'for your eyes only.' You'll use the power and flexibility of
Confluence spaces to organise information, and make sure it's visible to the right people.
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Your mission is broken up into the following components:

® Create a space to house all of the important information related to the mission
® Create your own space to keep yourself organised
® Create a public relations space, where you'll introduce your team the world

What's a space?

Well, being an astronaut, | hope you know what space is, but what's a Confluence space all about? It's really
just a place to put related things, like information pages and files. But spaces also give you a place to
collaborate with groups of people, whether that's your team, people working on a common project, or the
whole world.

Every space has its own permissions, allowing you to grant access and other privileges to the right people.
They also have a blog, so you can post important messages and updates to whoever can see the space. You
can have as many Confluence spaces as you like, and you can archive or delete spaces when you no longer
need them.

Enough about that; let's begin.

Start the mission!

Create a project space

1. Create a project space

2. Create your personal
space

3. Create the team's PR
space

4. Delete and archive
spaces

The Mars colonisation crew needs a place to put all their mission-critical information and resources, and
you're charged with setting it up. This part is going to be easy, because the information needs to be viewable
by the entire Teams in Space organisation. That means we can set up the project space without any special
permissions.

If you haven't done so already, open up Confluence and log in so we can get started.

Create the space

1. Choose Spaces > Create space from the Confluence header

2. Select the Blank space option and choose Next

3. Enter a Space name - for this space, we'll call it 'Mars Colony', as it's being used for the Mars
colonisation project.

4. Change the Space key to 'MARS' — this step isn't absolutely necessary, but it helps people if they're
navigating to this space by name. The space key forms part of the URL, so making it a word or name
makes it much easier to associate with your project.

5. Click Create

You now have a space set up for the Mars colonisation project. Because everyone at Teams in Space HQ
needs access to the information in this space, you don't need to do anything with the space's default
permissions. It's visible to everyone in your organisation, but not to the general public.

Every space has a default home page, which you can customise to suit your needs. Add the following image
and text to your space's home page to get things started. Just click Edit (or press E on your keyboard) to edit
the home page, and copy and paste the text. For the image it's best to drag it to your desktop and save it
there, then drag it into your page. That'll make sure the image is attached directly to the page.

Hit Save when you're happy with the home page.

A human mission to Mars ha
s been the subject of science
fiction, engineering, and
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scientific proposals throughout
the 20th century and into the
21st century. The plans
comprise proposals to land on
Mars, eventually settling on an
d terraforming the planet, while
exploiting its moons, Phobos a
nd Deimos.

Exploration of Mars has been a
goal of national space
programs for decades.
Preliminary work for missions
that would involve human
explorers has been undertaken
since the 1950s, with planned
missions typically being cited
as taking place 10 to 30 years
in the future when they are drafted. The list of manned Mars mission plans in the 20th century shows the
various mission proposals that have been put forth by multiple organizations and space agencies in this field
of space exploration.

Your 'Mars colony' space is ready for your team to add pages to. If you want to find it again, choose Spaces i
n the Confluence header, and select it from the list; to add a page to it, navigate to the space and hit Create i
n the header.

Now it's on to your personal space; a place where you can work in peace, and be sure that no one's looking

over your shoulder.

Create your personal space

1. Create a project space

2. Create your personal
space

3. Create the team's PR
space

4. Delete and archive
spaces

As a newbie on the team, you might want to keep some work to yourself until you're ready to present it.
There's always the chance your mission commander will also send you some information that's 'for your eyes
only," and you'll need to keep that in a safe place.

For this part of the mission, we'll be creating a special type of space: a personal space. We'll be using your
personal space like a sandbox, at least to start with — somewhere you can play around, draft pages, try out
features, and generally see what spaces are capable of.

Create your personal space

1. Choose your profile picture at the right side of the Confluence header
2. Select Add Personal Space...
3. Hit Create

You've now got a space that you can call your own. But we still need to lock it down to make sure it's
only visible to you.
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° Admin Istrator Pages # Edit Watch = Share
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Admin Istrator’'s Home

. )

& Profile Created by Admin Istrator just a moment ago

() Pages

. About Me (Admin Istrator)

RN B|09

- _ You may edit this page to include additional information about yourself.

| Questions
E-mail: tisadmin@veryrealemail.com

SPACE SHORTCUTS

Here you can add shortcut links to the Recently Updated Nawgate Space
most important content for your team

or project. Configure sidebar. As you and your team create

content this area will fill up and Search

PAGE TREE display the latest updates.

Get started by adding some pages to

this space. Create page.

$# Space tools ~ « ) Like  Be the first to like this No labels #

Choose Space tools > Permissions from the bottom of the siderbar
Hit Edit Permissions (enter your password if prompted)

You should see the conf | uence- user s group listed under Groups. To the left of the list of
permissions is the View permission, which determines whether everyone in that group can see your
space.

Uncheck View and hit Save all at the bottom of the page

You're now the only one that can view this space. Feel free to try anything in this space, and store super
secret stuff here.

Create the team's PR space

1.
2.

3.

4,

Create a project space
Create your personal
space

Create the team's PR
space

Delete and archive
spaces

Now it's time to go public; the world needs to know about the mission and its brave participants.

In this step, we'll create a team space and open it up to everyone. That's right — you can open Confluence
spaces up to anonymous (not logged in) users.

In order to allow anonymous access to your Confluence site, a site admin needs to grant anonymous
users the 'Use Confluence' permission. Don't worry if you can't do that, or if it's not done; it's just
something to note if you're opening up your Confluence site for real.

Create a Team space

1.
2.

Choose Spaces > Create space from the header
Select Team Space and hit Next

3. Enter a Space name (let's call it 'Mars PR")
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»

Change the Space key to 'MarsPR'

5. If there are other people using Confluence with you, feel free to add them as Team members (you
can remove them later), or just stick with yourself for now

6. Paste this in as the Description: Follow the progress of the brave Teams in Space astronauts as they

embark on their mission to colonise Mars.

Great! You now have a team space, again with its own home page. This home page is a little different to the
project space and your personal space — you'll see any team members you added, listed on the home page.

Create Team Space

Space name’ | Mars PR About Team Spaces

Share knowledge and collaborate on
projects, processes and procedures with
your team. They will be notified about this
space and all updates. Team members will
be granted permissions and added as
watchers of the space.

Space key | MarsPR ©)

Team members || (@ Admin Istrator % || [} Alana Grant x
@ Emma Paris * | gg Ryan Lee x

Description | Follow the progress of the brave Teams in
Space astronauts as they embark on their
mission to colonise Mars.

Back Close

Each space you create also has its own blog, so your social media team will be able to create posts in this
space and speak directly to all those adoring fans. But none of those fans can see this space. Yet.

Allow anonymous access

It's time to let the world in by changing the permissions on this space.

1. Choose Space tools > Permissions from the bottom of the sidebar
2. Scroll down until you see Anonymous, then hit Edit Permissions
3. Tick the View permission for anonymous users and hit Save all

That's it. You can now share the space's URL, which will be
http(s)://<your_confluence_site>/display/MarsPR. Visitors to that space don't need to log in, or have a licence

for Confluence.

Delete and archive spaces

=

Create a project space

2. Create your personal
space

3. Create the team's PR
space

4. Delete and archive

spaces

We hope you've had a successful mission, and learned a bit about the power and versatility of Confluence
spaces. Flash forward 18 months, and just look how well the colony is coming along!
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If you need to clean up old spaces (or destroy the evidence of a failed mission!), you can either archive or delete
a space. Archiving just means it won't show up in the regular search, whereas deleting is obviously a lot more
permanent.

To archive a space:

1. Choose Space tools > Overview from the bottom of the sidebar
2. Click Edit Space Details
3. Change the Status from 'Current' to 'Archived' and hit Save

To delete a space:

1. Choose Space tools > Overview from the bottom of the sidebar
2. Select the Delete Space tab

What next?

If you'd like to know more about spaces and the permissions that govern them, check out Spaces and Permissio
ns and Restrictions in the Confluence documentation.

Teams in Space HQ, signing off.
Confluence Mobile

When you access Confluence on a mobile device, you'll see a version of
Confluence which is optimised for mobile viewing. Confluence chooses the
mobile or desktop interface based on your device, but you can still switch to
the desktop site on your mobile by choosing menu

then choosing Switch to desktop version.

You can also swap from the desktop view to the mobile view if you're on a
mobile device, by choosing Switch to Confluence Mobile at the top of the

page.
On your supported mobile device, you can:

View the Confluence dashboard, pages, blog posts, and user profiles.
Add or reply to a comment on a page or blog post.

Like a page, blog post or comment.

Watch a page or blog post.

See your notifications and tasks.

Created in 2015 by Atlassian. Licensed under a Creative Commons Attribution 2.5 Australia License.

22


http://creativecommons.org/licenses/by/2.5/au/

Confluence 5.9 Documentation

On this page:

® The
dashboard
— the first
thing you
see

® Searching
for content
and people

® Viewing
pages,
blog posts
and
comments

® Viewing
people's
profiles

® Following
up on
notification
S

® Viewing
tasks

® More
things you
may need
to know

You can't add or edit pages or blog posts, or edit existing comments, using the mobile interface.

The dashboard — the first thing you see —

Choose a tab to see:

Popular Recent Blogs Network
® Popular content — what people like in your
wiki. L
* Recent blogs — the latest blog posts. E JIRA 5.2 Bug Fixing ®o
* Network — updates by people in your network. ' 1 '
Tap the links to view the full content of a page, blog e Re: On culture and ideas
post or comment. ﬂ : _ 3 1
Workshop - "The Business
Case" - Why is Customer .
Experience Important? Rl =

Searching for content and people

Tap the menu icon

to open the menu panel on the left of the page. Then
type text or a person's name in the Search box. The
mobile interface offers the quick navigation search,
which returns matches on page title only. (See Search.)
To use the full search, switch to desktop mode.
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Viewing pages, blog posts and comments

Tap a link on the dashboard or on any other page.
Confluence will display the linked page, blog post or
comment.

You can:

® View the content, tap a link to move to another
page, and interact with the page using the
standard functionality supported by mobile
browsers.

® Like or unlike a page, blog post or comment.

® Watch or stop watching a page or blog post.

® Add or reply to a comment.

Viewing people's profiles

Search for a person's name, then view that person's
user profile. Tap the options to phone, SMS or email a
colleague directly from your mobile device.

Following up on notifications

You can view and respond to your notifications on
your phone or other mobile device. Tap the menu
icon

=

to open the menu panel on the left of the page.
Choose Notifications, and tap a notification to see
its details. You can reply, watch or like via the inline
actions. Tap Open to open the page or blog post in
a new page. For full details, see Workbox
Notifications.

Viewing tasks

You can view and manage your tasks on your
phone or other mobile device too. Tap the menu
icon

to open the menu panel on the left of the page.
Choose Tasks then tap a task to see its details.

Q Search people and content

Dashboard

Recently viewed

Notifications

Tasks

Give Atlassian feedback
Switch to desktop version

Log out

— Notifications

7 likes of Feedback requested - all ...

Joe Clark liked Last chance for a da...

- Re: Ul Text Guidelines

Atlassian Foundation's bush regene...

- EOFY 2012: Choose your own Adv...

- 2 comments on Confluence for tech ..

More
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More things you may need to know — Tasks
Some macros may not appear To D ¢ Latad
o Do omple
Confluence macros are not yet fully supported in
Confluence mobile. If you view a page that contains , o
an unsupported macro, you will see a message Atlassian Foundation's bush rege... >
inviting you to click through to the desktop version of
the page. Overview of FY12 Speaking Events  »
Screenshot: Macro not rendered in Confluence
mobile Leave work early to pick up choco... >

Sarah Maddox — buy the chocolates >

Sarah Maddox — write the docum... >

View macro in desktop version
Recommended database migratio... »

Administrators can disable Confluence mobile on

your site

The mobile functionality is provided by a plugin called the ‘Confluence Mobile Plugin'. To remove the
functionality from your site, you can disable the plugin.

Confluence mobile is a web interface, not a native app

Atlassian does not supply a native mobile application that you can download and install onto your mobile
device. Confluence mobile is a web-based user interface, which Confluence displays when it detects a
mobile client.See Supported Platforms for supported mobile browsers.

Spaces
. On this page:
Confluence Spaces are containers for pages and blo pag
g posts with related content, and they come in two ®* What's a space admin?
main varieties: ®* How is content arranged in
spaces?

® Site spaces — Sometimes called 'global’

® View all spaces in Confluence
spaces, these are areas where you can

create content and collaborate with other Related pages:
users.

* Personal spaces — You, and other * Create a Space
Confluence users, can set up a personal : Create a Personal Space
space. You can keep it private, or open it up . Space Permissions Overview
for other users to view or edit. Personal . Configure the Sidebar

Export Content to Word, PDF,
HTML and XML

Delete a Space

Administer a Space

spaces are listed in the People Directory.
Create a space any time you need a place to store
related content by choosing Spaces > Create space
in the Confluence header. Two of the main ways
people use Confluence spaces are for teams and/or
projects.

Create a space for the Marketing team, Dev team, IT
team, HR team, and any team that needs to
collaborate on work, and store information and files.
If you have projects, big or small, that would benefit
from having a place people can work together and
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store related files, make a space for them too.
There's no limit to the number of spaces you can
create in Confluence.

What's a space admin?

Every space has at least one space admin — usually
the person that created the space — and that person
can grant permissions to that space, including
granting space admin privileges to others. Space
admins don't have to be Confluence admins; they
can be a regular Confluence users, and may only
have special permissions for a single space. For
example, you'll be the space admin for your personal
space.

How is content arranged in spaces?

Each space you create, including your personal space, is automatically created with a home page — the first
page you'll see when you navigate to the space — which you can edit to suit your needs, and you can create
any number of child pages to store the content and information you need. Spaces don't nest — you can't have
a space within a space — but pages do, so you can create as many levels of hierarchy as you need using
pages.

Each space also has its own blog, allowing you to share news and make announcements. Blog posts are a
great way to keep people involved in what's going on in your team or project.

You can set different levels of access for each space using its permissions.

Diagram: Arrangement of spaces, pages, and attachments
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View all spaces in Confluence
There are two main ways to view spaces in Confluence:

® The space directory - choose Spaces > Space directory for a list of all the site and personal spaces
you have permission to see. Filter the list of spaces by selecting from the categories on the left of the
space directory.

® The dashboard — you can make your most useful spaces appear under My spaces on the
dashboard. Choose the star icon in the space sidebar or space directory to add a space to My spaces
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The Spaces menu in the header also displays a list of your recently viewed spaces, allowing you to quickly

navigate to the things you view most often.

The Spaces List macro allows you to display a list of spaces on a Confluence page
category, if you need to.

Create a Space

When you create spaces in Confluence, you can choose to set up a space
for each team, project, or a mix of both depending on your needs. You can
always move pages and blog posts between spaces later if you need to.

Confluence allows you to set up a blank space, or use the handy space
blueprints to make the process of setting up team, documentation, or
knowledge base spaces quick and easy.

Create a space

1. Choose Spaces > Create space in the Confluence header

2. Select the type of space you would like to create, then choose Next

3. Enter details of your space including Name and Space Key , and any
other information you're prompted for depending on the blueprint you
choose

4. Choose Create

Each space you create will automatically have a home page, which you can
customise to display relevant information for people viewing the space.
Space blueprints have a home page with extra features like team members
in the case of the 'team space' blueprint.

You can also set up a personal Create Team Space
space to store your own work,
which you can share with others Space name” | Marketing Team

or make private. Choose your pro
file picture at top right of the

Team members & Gil Admin % Karen User x
screen, then choose Add & Josh User
Personal Space.... See Create a
Personal Space for more
information. P

Space key” | MARKETING @

Description | This is the space for all things marketing!

Space keys

Each Confluence space has a sp
ace key, which is a short, unique

, and filter them by

On this page:

® Create a
space

® Space
keys

® Space
blueprints

® Space
permission
S

®* Notes

Related pages:

® Spaces

®* Create a
Personal
Space

® Configure
the
Sidebar

® Edit Space
Details

® Delete a
Space

About Team Spaces

Share knowledge and collaborate on
projects, processes and procedures with
your team. They will be notified about this
space and all updates. Team members will
be granted permissions and added as
watchers of the space.

identifier for a space, and forms part of the URL for that space. Each time you create a space, Confluence
will create the space key for you, but you can override the default space key if you want to make it something

more memorable.

For example, you might give your marketing team's space a key of 'marketing'. You
directly to the space using a URL like this:

can then navigate

http://ny.confluenceSite.con display/ marketing/

Choosing a space key
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Each space key:

® Must be unique
® Can contain any alphanumeric character (A-Z, a-z, 0-9)
® Can be up to 255 characters long

You can't change the space key after you create your space, so choose your space key
carefully! Personal spaces use your username as the space key.

Space blueprints

A space created using a space blueprint will have a customised homepage, sidebar and may contain page
blueprints or sample content that's specific to that type of space.

When you create a space using a blueprint, a wizard will prompt you to enter information to help set up your
space. For example, the Team Space blueprint asks for the members of your team, and displays them on the

homepage.
The types of space blueprints available are:

® Team space — A great building block if you are using Confluence as an intranet or to manage teams.
Team spaces highlight the members of the team, and grant permissions to those users accordingly.

®* Knowledge Base space — This space blueprint uses search and page labels to make content easier
to find, right from the space homepage. It also contains two page blueprints for creating how-to and
troubleshooting articles. The templates used in these page blueprints are completely customisable to
meet your needs. The Knowledge Base space blueprint also integrates with JIRA Service Desk.

® Documentation space — This space blueprint displays the full page tree in the sidebar and hides
other sidebar features including blogs and shared links. The homepage uses search and page labels
to make content easy to find. Add the 'featured' label to any page you want to highlight on the
homepage. This space does not include any page blueprints but you can create and promote
templates for your documentation authors to use.

Space permissions

Each space is created with a set of default permissions. The user who created a site space is automatically
granted 'space admin' permissions for that space, meaning they can then grant permissions to other users
and groups. See Space Permissions Overview for more information.

ﬂ To create a site space you need the 'Create Space' global permission; to create a personal space you
need the 'Personal Space' global permission.

Note: System Administrators can edit the permissions of spaces in their Confluence site at any time.

Notes

® |f you've set a specific theme (such as the Documentation or other third party theme) for your whole
site, spaces will be created with that theme. You may not see some space blueprint-specific sidebar
customisation if you're not using the default theme.

® Administrators can disable individual space blueprints - see Administering Site Templates.

® Spaces can't be nested (you can't have a space within a space), but can be grouped using space
categories.

® You can export a whole space, or part of a space, to PDF, HTML or XML .

Create a Personal Space

Your personal space is a place where you can create your own pages and
publish your own blog posts. Once you've set up your personal space,
Confluence users can reach it by clicking your name in the People Directory.
Visit your personal space by choosing your profile picture at the right side of
the Confluence header and choosing Personal Space.

Create your personal space

Created in 2015 by Atlassian. Licensed under a Creative Commons Attribution 2.5 Australia License.


http://creativecommons.org/licenses/by/2.5/au/
https://confluence.atlassian.com/display/SERVICEDESK

Confluence 5.9 Documentation

ﬂ To set up your personal space, you need the 'Personal Space'
permission which is assigned by a Confluence administrator. See Permissio
ns and Restrictions and Global Permissions Overview.

To create your personal space:

1. Choose your profile picture at top right of the screen, then choose
Add Personal Space...
2. Choose Create

On this page:

®* Create
your
personal
space

®* Change
the look
and feel of
your space

Related pages:

® Configure
the
Sidebar

® Your
Profile and
Settings

® Spaces

You can now go ahead and update
your space by customising the
home page, creating more pages,
and adding blog posts.

Change the permissions on your
space at any time to determine

Create a personal space

With a personal space, you can...

1 Stay organised
Keep your notes, task lists, files
and other personal content

Share news
Use your blog to make
announcements, capture ideas

organised. and share leamings.

who can and can't access the
content. So if you want it to be a
private sanctuary, that's no
problem.

Change the look and feel of

your space

Introduce yourself
Customise your personal
homepage and introduce yourself
to the team.

For a really personal space, apply a different theme, or modify its colour scheme. You can also add and

arrange links in the sidebar.

Space Permissions Overview

Each space in Confluence has its own set of permissions, which can be
granted and revoked by a space administrator. The user that creates a
space, like when you create your personal space, is automatically an
administrator of that space, and they can add other space admins if they
want to by adding the Space Admin permission to another user or group.

How do you find out who the space admin is for a particular space? Choose
Spaces > Space directory in the Confluence header, then choose the Spa
ce Details

®

icon beside a space.

If you're one of those lucky space admins, you can assign permissions for
the space to individual users, groups, or anonymous users. To change
permissions for a space, choose Space tools > Permissions from the
bottom of the sidebar, then choose Edit Permissions to change permission
settings.

If your space is using the Documentation theme, choose Browse > Space
Admin > Permissions.

On this page:

® Permission
S
Summary
®* Notes

Related pages:

® Confluenc
e Groups

® Assign
Space
Permission
S

® Page
Restriction
S

® Global
Permission
s Overview
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ﬂ' Space admins can also manage watchers for that space by choosing Watch at the top-right of any page

in the space.

Permissions Summary

The following permissions can be assigned for each space:

Permission
View
Pages Add
Restrict
Delete
Blog Add
Delete

Comments Add

Delete

Attachments Add

Delete
Mail Delete
Space Export
Admin

Notes

The user or group can:

View the space's content, including the space's details, its pages, and blog
posts.

Create and edit pages in the space.

Apply page-level restrictions.

Delete pages in the space.

Add and edit blog posts in the space.

Delete blog posts in the space.

Make comments in the space.

Delete comments from the space.

Add attachments to pages in the space.

Delete attachments from pages in the space.

Delete individual mail items.

Export content from the space via the space-level export screens. Note that this
permission doesn't affect the exporting of a single page's content. Anyone who

has permission to view the page also has permission to export its content.

Administer this space, including granting permissions to other users. This
permission can't be granted to anonymous users (users who aren't logged in).

@ confluence administrators aren't necessarily space administrators.

® A user who has the 'Confluence Administrator' global permission isn't automatically a space admin for
a particular space. In order for them to be a space admin, they must belong to a group which has
space admin and view permission for the space, or their username must be specifically granted space
admin and view permission for the space.

® If you deny all admin access to a space by mistake, so that nobody has access to administer the
space any more, you'll need to ask someone with Confluence Administrator global permission to
restore the permissions for you.

® A user who has the 'System Administrator' global permission does automatically have space admin
permissions for all spaces.

Assign Space Permissions

You can assign space permissions to groups or to individual users. You
need to be a space administrator to assign space permissions. In addition, C
onfluence administrators can set the default permissions that will be applied
to new spaces as described below.

To access the permissions for a space:

1. Go to the space and choose Space tools > Permissions from the
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bottom of the sidebar
2. Choose Edit Permissions
~ Using the Documentation theme?

1. Go to the 'Space Permissions' page:
® Choose Browse > Space Admin from the header

Note: The Space Admin option appears only if you have s
pace admin permissions, or if you're part of the
‘confluence-administrators' group.

® Choose Permissions from the space administration
options.

2. Choose Edit Permissions
The Edit Space Permissions page is divided into the following sections:

® |icensed Users - this is where you grant permissions to groups and
individual users.

® Anonymous Access - this is where you grant permissions to users
who are not logged in (essentially making the space public)

On this page:

Assign
space
permission
S

Remove
space
permission
S
Anonymou
S users
Set default
space
permission
S

Manage
and
recover
space
admin
permission
S
Managing
unlicensed
users from
JIRA
Service
Desk

Related pages:

Space
Permission
s Overview
Global
Permission
s Overview
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Permissions = Restricted Pages

Licensed Users
Groups
Grant permissions for this space to all the members of a group.
All Pages Blog Comments Attachments  Restrictions Mail Space

View @ Add Delete Add Delete Add Delete Add Delete Add/Delete Delete = Export Admin

confluence-users o (] [ x| o x| o a o [ x | a [ x| o x|
developers © B B B B 0 6 B B ] [ %] ] %]
Edit Permissions
Individual Users
Grant permissions to individual users, regardless of which groups they are a member of.
All Pages Blog Comments Attachments Restrictions Mail Space
View @ Add Delete Add Delete Add Delete Add Delete Add/Delete Delete = Export Admin

Administrator (robins) @ @ @ (] (] (] (] (] (] o (] (] (] (]

Edit Permissions

Anonymous Access

If your Confluence site is public, you can grant permissions to people who are not logged in. Anonymous users can be granted almost any permission,
but we recommend you limit this to viewing and commenting.

All Pages Blog Comments Attachments  Restrictions  Mail Space

View @ Add Delete Add Delete Add Delete Add Delete Add/Delete Delete = Export Admin

Anonymous B B B B B B B B @ a a [ x] a

Edit Permissions

Assign space permissions

To add a new user or group to the permissions list, search for either a group or user in their respective
sections and choose Add. The group or user will appear in the list of groups; select the appropriate
checkboxes to assign them permissions, then choose Save all.

If you're unsure of a group or user's name, you can search by choosing the

Q

icon. You can use an asterisk *' as a wildcard if you need to.
To bulk assign or revoke permissions, choose either Select All or Deselect All.

There's no way to change permissions for multiple spaces at once. Permissions are managed on a space by
space basis.

Remove space permissions

To remove a user or group from the space permissions list, deselect all the checkboxes for that user or group
and save the changes. The user or group won't appear in the list once you save.

Anonymous users

Anonymous users are users that aren't signed in to your Confluence site, and, by default, they won't have
access to any of your content. If you want to grant access to a space for anonymous users, you can edit the
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'Anonymous Access' section at the bottom of the permissions page.

Tick or un-tick the checkboxes to suit your preference for anonymous users, then choose Save All to apply
the changes.

ﬂ You can't grant space administration rights or page restriction rights to anonymous users.

Set default space permissions

If you're a Confluence Administrator, you can set the default permissions that will be applied to new spaces.
Default permissions are configurable for groups only, not for individual users or anonymous users.

To set the default space permissions:

1. Goto

> General Configuration > Space Permissions
2. Choose Edit Permissions

Screenshot: Default space permissions

Default Space Permissions # Edit Permissions

These are the default permissions that will be assigned to groups when someone adds a new space. The ‘confluence-administrators' group always has all permissions for all spaces, and
any permissions set for it here will be ignored.

All Pages Blog Comments Aftachments  Restrictions  Mail Space

View Add Delete Add Delete Add Delete Add Delete Add/Delete Delete  Export  Admin

confluence-users © 6 B 6 B8 6 B o o a a ] [ %]

Individual Spaces

These are the current wiki spaces.

Name Key Operations
Demonstration Space ds Manage Permissions
Product Team prod Manage Permissions

Manage and recover space admin permissions

Users with System Administrator permissions are able to manage permissions for spaces, including adding
or removing Space Admin permissions for a space.

To manage space permissions:

1. Goto

> General Configuration > Space Permissions.
2. Locate the space in the individual spaces list and choose Manage Permissions.
There may be some instances where a space administrator has removed Space Admin permissions from all
other users and groups for a space, meaning no other user can administer the space. Users with Confluence
Administrator permissions can recover permissions for the space in this instance.

To recover Space Admin permissions:

1. Goto

> General Configuration > Space Permissions.
2. Locate the space in the Individual Spaces list and choose Recover Permissions

The user will then be able to choose Manage Permissions, and add any appropriate permissions to the
space. Requests to recover permissions are recorded in the Confluence log files.

Managing unlicensed users from JIRA Service Desk
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If you're using Confluence as a knowledge base for JIRA Service Desk, you can choose to allow all active
users and customers (that is logged in users who do not have a Confluence license) to view specific spaces.
This is an alternative to making your knowledge base space public, and can only be turned on via JIRA
Service Desk.

When a space is accessible to all active users, you'll see the following message in the space permission
screen.

Permissions = Restricted Pages

J' Any active user can view this space

Any active user can view pages in this space, including users who don't have a Confluence license. This was
enabled through JIRA Service Desk so people can view knowledge articles when raising a help request.

Edit this permission

It's important to note that this permission overrides all existing space permissions, so any logged in
Confluence user will also be able to see the space (regardless of their group membership). This is due to the
way Confluence inherits permissions.

You can edit this permission at any time to revoke access to a space. It can only be re-enabled from JIRA
Service Desk.

Active users, who don't hold a Confluence license, have very limited access to Confluence. They can view
pages, but can't like, comment, edit, view the dashboard, use the space directory, see user profiles or search
your full site.

See Use JIRA applications and Confluence together for more information about JIRA Service Desk
integration.

Change the Look and Feel of a Space

You can customise the 'look and feel' of a space on your Confluence site through options available in the Space
Administration menu. By default, the look and feel of a space is based on site-wide settings configured from
the Administration Console.

You need to be a space administrator to change the look and feel of a space.

® Change the Space Logo

® Apply a Theme to a Space

® Edit a Space's Colour Scheme
Related pages:

® Changing the Look and Feel of Confluence
® Spaces
® Styling Confluence with CSS

Change the Space Logo

In Confluence, you can replace the default space logo with an image of your Related pages:
choice. If you have team spaces, you can use an icon that represents the . i
team, or if it's a space for a client, add their company logo to really impress Configure
the
them. .
Sidebar
The instructions below apply to site spaces. For your personal space, your p ® Change
rofile picture is used as the space icon. the Look
. . and Feel of
You need to be a space administrator to replace a space's logo. a Space

To change a space's logo, in spaces
using the default theme:
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1. Go to the space and choose Spa
ce tools > Configure sidebar fro
m the bottom of the sidebar

2. Choose the edit icon Space details
F

next to the space name

3. Choose Upload an image

4. Select an image from your
computer

5. Adjust the size of the image to fit
within the highlighted circle PRODUCT

6. Choose Save

Name Product Team

Space avatar

To change a space's logo, in spaces
using the Documentation theme: o ]

Upload animage = Restore default

Save Cancel

1. Choose Browse > Space Admin
from the header

Note: The Space Admin option
appears only if you have space
admin permissions, or if you're
part of the 'confluence-administrators' group.
Choose Change Space Logo in the left-hand panel
Click Choose File

Select an image from your computer

Choose Upload Logo

aprwn

Notes

® Minimum dimensions: Space logos are set at 48 x 48px. Logos less than these dimensions will be
centred with whitespace around them.

® Space logos in the default theme are circular.

* Dimensions of image when using the Documentation theme: The documentation theme does not
provide an option to resize or crop your image. Uploading a square image will give the best results.

Apply a Theme to a Space

Themes allow you to personalise the ‘look and feel' of Confluence. You can Related pages:
apply a theme to your entire Confluence site or to individual spaces. Choose )
a specific theme if you want to add new functionality or significantly alter the * Applying a
appearance of Confluence. Theme to
a Site
Confluence comes with a selection of themes. In addition, a site ® Edita
administrator can install new themes as plugins via the Confluence Space's
Administration Console. Provided that the theme is installed into your Colour
Confluence site, any space administrator can apply a theme to a space. Scheme
(]
By default when you create a new space, the space will have the tc:;acgjk
Confluence default theme. -~
a Space

To apply atheme to a space:

1. Go to the space and choose Space tools > Look and Feel from the bottom of the sidebar
You'll need Space Admin permissions to do this.

2. Choose Themes and select a theme option

3. Choose Confirm

Screenshot: Applying a theme
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Themes | Colour Scheme Layout Stylesheet PDF Layout PDF Stylesheet

Current Theme

The current theme controls the layout and colours of this space.
I
p— Global Look and Feel

The globally configured look and feel. You can customise colour-schemes and layouts manually.

Choose New Theme
To change the default theme of this Confluence site, select one below:

Documentation Theme

This theme is well suited for structured content, such as documentation. It features a table of contents
(page tree) on the left, making it easier to see the structure of a space and move from page to page. You
can customise the left-hand panel, page header and page footer.

£ Find more themes...

Confirm

If your space is using the Documentation theme:
1. Choose Browse > Space Admin from the header

Note: The Space Admin option appears only if you have space admin permissions, or if you're part of
the 'confluence-administrators' group.

2. Choose Themes from the space administration options

Select a theme option

4. Choose Confirm

w

Want to customise Confluence or make it even more beautiful? Try a Confluence theme from the
Atlassian Marketplace.

§ Marketplace

The Documentation Theme

The Documentation theme is going away in
Confluence 6.0.
Read more about this change.

The Documentation theme is one of the themes bundled with Confluence. It
provides an inbuilt table of contents for your space, a configurable header
and footer, and text styles suited to documentation. You can also configure it
to restrict the search results to the current space, rather than searching the
entire Confluence site.

Created in 2015 by Atlassian. Licensed under a Creative Commons Attribution 2.5 Australia License.

36


http://creativecommons.org/licenses/by/2.5/au/
https://marketplace.atlassian.com/search?q=confluence+theme
https://marketplace.atlassian.com/search?q=confluence+theme

Confluence 5.9 Documentation

I Please note, the Documentation theme doesn't support the JIRA links On this page:

feature. .
® Customise

the
Document
ation
Theme

® Search the
space or
the site

®* Hints and
tips

®* Notes

Related pages:

® Configure
the
Document
ation
Theme

® Space
Jump
Macro

® Move and
Reorder
Pages

Quick guide to using the Documentation theme:

®* The left-hand panel contains a page tree. This is a table of contents that shows the pages in the
space.

® Pages with arrow symbols to their left have child pages. Choose the arrow(s) to show and hide child
pages.

® Drag the thick vertical bar between the left-hand panel and the page to change its width.

® Choose the left-hand panel icon
in the header, next to the search field, to hide or show the left-hand panel.
Alternatively, press '[' on your keyboard to show/hide the left-hand panel.

® OQverriding a space-restricted search: If your theme is configured to restrict the search to the current
space, you can enter 'all:' and your search term to search the entire site.
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X Confluence Spaces -~ People Browse - Create =+

Confluence header
Create pages, visit Search g Teams in Space & /Edit  © Wat
spaces or your profile, , yeeing Notes Teams in Space Home

and use the Browse
menu to administer the
space

Product Planning Created by Alana Grant, last modified by Admin Istrator on Jul 01, 2014

Product Requirements

Teams in Space PR © Welcome to your new space!

File Lists Confluence spaces are great for sharing content and news with your team. Thi
for Teams in Space. Right now it shows recent space activity, but you can custi
anyway you like. Scan along the lefthand side to see important pages in this sg

Meet the SeeSpaceEZ Team

Team Sprint Calendar
Left hand panel You can customize the left navigation to fit your team.

The sidebar is for
accessing pages and
searching within the

Space Z Admin Istrator

Recent space activity Space contributors

Ryan Lee (6 days ago,
Alana Grant (7 days ag
Harvey Jennings (7 da
Admin Istrator (19 day:
Emma Paris (65 days :

(3] We're colonising Mars created Aug
06, 2015

I Ryan Lee
(3) Summer Saturn Sizzle Blog

Announcement updated Aug 03, 2015
* view change

[] Teams in Space Analyst Deck.pdf
commented Aug 03, 2015

n Emma Paris
[J Teams in Space Analyst Deck.pdf

Customise the Documentation Theme
A space administrator can customise the Documentation theme as follows:

® Change the content in the left-hand panel and add a header and footer to the page.
® Restrict the search so that it will show results from the current space only, not from the entire
Confluence site.

For more, see Configure the Documentation Theme

Search the space or the site
When using the Documentation theme, the Confluence search offers a few options as described below.
Using the search box at the top right of the page:

® By default, the main Confluence search is configured to search the entire Confluence site.
* You will see the words 'Search Confluence' in the search box at top right of the page.
® The Confluence search will look for matches in the entire Confluence site. This is the default
behaviour for other themes too.
® A space administrator can configure the Documentation theme to restrict the search to the current
space.
® You will see the words 'Search this space' in the search box at top right of the page.
® The search will return results from the current space only.
® You can override the search restriction. Enter 'all:' and your search term to search the entire
site. For example, enter the following into the search box at top right of the page to search the
entire site for 'technical writing'":

all: technical witing

Using the search box in the left-hand panel:

® By default, the Documentation theme's left-hand panel includes a search box. Enter your search term
there, to restrict the search to the current space. Specifically, this will search only the pages that are
children of the space’'s home page.

® If your administrator has restricted the main search to the current space, there will not be a search box
in the left-hand panel.

Created in 2015 by Atlassian. Licensed under a Creative Commons Attribution 2.5 Australia License.


http://creativecommons.org/licenses/by/2.5/au/

Confluence 5.9 Documentation

Hints and tips

Below are some hints that you may find useful when using the Documentation theme.Where can | see a
working example of the Documentation theme?

The Confluence documentation uses the Documentation theme. If you are reading this documentation online
on the Atlassian documentation wiki, you are seeing a working version of the Documentation theme.

Which pages will appear in the Documentation theme's table of contents?

The theme constructs the page tree in the left-hand panel from all pages that are child pages of the space’s
home page. Each space has a single page designated as the 'Home' page. You can specify the home page
in the space administration section.

Help, my pages do not appear in the Documentation theme table of contents

Cause 1: Your pages are not under the space's home page. The most probable reason why your pages
do not appear in the page tree in the left-hand panel is this: The theme constructs that table of contents from
all pages that are child pages of the space’s home page. If your pages are above the home page in the page
tree, they will not appear in the left-hand panel.

There are two ways to fix the problem:

® You can change the designated space home page in the space administration section.

® Oryou can drag and drop all your pages to make them children of the current home page. You can
drag and drop pages in the 'Pages' section of the space 'Browse' screen. See Move and Reorder
Pages.

Cause 2: Problem with upgrade from Confluence 3.1, with Documentation theme as plugin, to
Confluence 3.2 or later with Documentation theme bundled. If your existing Confluence installation
already has the Documentation theme plugin installed, you may find that after upgrading to Confluence 3.2
the left-hand navigation bar is empty in the spaces that use the theme. The fix is to enable all modules of the
Documentation theme plugin. See the knowledge base article.

Help, my left-hand panel has disappeared

If your entire left-hand panel has disappeared when using the Documentation theme, this is probably
because you have clicked the sidebar icon

at top right, next to the search box. Click the icon again to restore the panel.

Can | change the default width of the left-hand navigation panel?

The Confluence user interface does not offer a way to change the default width of the left-hand navigation
panel supplied by the Documentation theme. Users can change the width by dragging the middle bar, but the
default width is not configurable. This post on Atlassian Answers gives a way to do it with CSS: Documentati
on Theme - Default Width (in px) of left panel.

Notes

® The Confluence default theme supplies a sidebar, which is different to the left-hand panel in the
Documentation theme. For information about the sidebar, see Configure the Sidebar.

® The Documentation theme supplies a Browse menu in the Confluence header, which gives access to
the space administration and advanced options.

Configure the Documentation Theme

The Documentation theme is going away in
Confluence 6.0.
Read more about this change.

The Documentation theme is designed for spaces containing technical
documentation, but you may find it useful for other types of structured
content. It provides a table of contents for your space, a configurable header
and footer, and text styles suited to documentation. (See features below.)
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Quick guide to applying and customising the Documentation theme:

® Go to the space and choose Space tools > Look and Feel from the
bottom of the sidebar
® Choose Themes.
¢ Select Documentation Theme and choose Confirm.
* If you want to customise the theme, choose Configure theme.
® Select or deselect the default page tree.
® Select or deselect the space-restricted search.
® Enter the text and wiki markup for your custom left-hand panel
header and footer.
® Choose Save.

The rest of this page gives more details of the above procedure.

On this page:

Applying
the
Document
ation
theme to
your space
Applying
the
Document
ation
theme to
your site
Customisin
g the
Document
ation
theme
® Cus
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sing
the
the
me
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site
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I
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ation
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Hints and
tips
Notes

Related pages:

The
Document
ation
Theme
Space
Jump
Macro
Apply a
Theme to
a Space
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Edit a
Space's
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Change
the Look
and Feel of
a Space
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Screenshot: The Documentation theme showing the space sidebar replaced by a navigation sidebar.
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Applying the Documentation theme to your space

Follow the steps below to apply the Documentation theme to your space. All pages in the space will start
using the theme immediately.

To apply atheme to a space:

1. Go to the space and choose Space tools > Look and Feel from the bottom of the sidebar
You'll need Space Admin permissions to do this.

2. Choose Themes and select a theme option

3. Choose Confirm

Screenshot: Applying a theme
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Themes Colour Scheme Layout Stylesheet PDF Layout PDF Stylesheet

Current Theme
The current theme controls the layout and colours of this space
]
e Global Lock and Feel
The globally configured look and feel. You can customise colour-schemes
&%  and layouts manually.

Choose New Theme

To change the theme of this space, select one below

I @ pocumentation Theme
i
— This theme is well suited for structured content, such as documentation. It
_ features a table of contents (page tree) on the left, making it easier to see
the structure of a space and move from page to page. You can customise
the left-hand panel, page header and page footer.
Confirm

If your space is using the Documentation theme:

1.

Choose Browse > Space Admin from the header

Note: The Space Admin option appears only if you have space admin permissions, or if you're part of
the 'confluence-administrators' group.

2. Choose Themes from the space administration options
3.
4,

Select a theme option
Choose Confirm

Applying the Documentation theme to your site

If you have site administrator permissions, you can apply the theme at site level. It will then be the default
theme for all spaces in the site. See the administrator's guide to applying a theme.

Customising the Documentation theme

The theme works well without any customisation. If necessary, you can restrict the search to just one space,
change the content of the left-hand navigation panel and add your own header and footer. The following
instructions assume you have already applied the Documentation theme.

To customise the Documentation theme:

1. Choose Browse > Space Admin from the header

Note: The Space Admin option appears only if you have space admin permissions, or if you're part of
the 'confluence-administrators' group.

Choose Themes in the left-hand panel under the heading 'Look and Feel'".

Choose Configure theme in the yellow area of the '‘Current Theme' section at the top of the page.
See screenshot below. The 'Documentation Theme Configuration' screen appears. See screenshot be
low.

Select or deselect the Page Tree check box. This determines whether your space will display the
default search box and table of contents (page tree) in the left-hand panel.
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5. Select or deselect the Limit search results to the current space check box.
® |f you select the check box:

® The Confluence search will look for matches only in the current space by default. Users
can override this restriction when entering their search term. See The Documentation
Theme.

® The default page tree in the left-hand panel will not include a search box.

® |f you do not select the check box:

® The Confluence search will look for matches in the entire Confluence site. This is the
default behaviour for other themes too.

® The default page tree in the left-hand panel will include a search box, which restricts
search results to the current space.

6. Enter text, images, macros and other wiki markup into any or all of the three text boxes.
ﬂ' You can use the Include or Excerpt Include to include re-usable content into your footer. See hint b
elow.
® 'Navigation' — This text box contains content for the left-hand panel.

* |fthe Page Tree check box is selected, the navigation panel contains the default search
box and page tree. Any content you enter into the 'Navigation' text box will appear above
the page tree and search box.

® You can include your own content underneath the page tree as well as above. See hint b
elow. In summary: Deselect the Page Tree check box. Insert your own page tree using
the Pagetree macro, then add your own content under the macro.

® 'Header' — This text box contains content for a page header that will appear above the page title
on all pages in the space. See example screenshot below.
® 'Footer' — This text box contains content for a page footer that will appear after the comments
and above the site footer, on all pages in the space. See example screenshot below.
7. Choose Save.

Screenshot: The 'Configure theme' option
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Current Theme

The current theme controls the layout and colours of this space

Documentation Theme

This theme is well suited for structured content, such as
documentation. It features a table of contents (page tree) on the left,
making it easier to see the structure of a space and move from page
to page. You can customise the left-hand panel, page header and
page footer.

——
—
[T

Configure theme - further customise this theme's options

Choose New Theme

To change the theme of this space, select one below

' Global Look and Feel
The globally configured look and feel. You can customise colour-
schemes and layouts manually.

| I'l
B

€ Find more themes

Confirm

Screenshot: Customising the Documentation theme
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Navigation
[] Page Tree
Show the page tree in the sidebar.
Limit search results to the current space
Limit search results returned by the top right search field to the current space.
Mavigation | *[Latest Confluence o
Documentation|Confluence |ﬂ
Documentation Home]*
{pagetree:root=Confluence
Documentation
Home | searchBox=false}
*[Downloads (PDF, HTML &
Add your own links and content to the sidebar using wiki markup.
Messages
Header | {section} |~
{column:width=1%}{column} |ﬂ
{column}{panel}

*{finclude: MajorReleaseNumb

erConfluence |nopanel=true}*
-- This documentation is

for *Confluence 5.8*%

developer (EAP) releases -

only. Mot for you? *[See

Display a banner or text at the top of every page in this space by entering wiki markup here.

Footer | {include: Documentation
Footer|nopanel=true}
{include:ALLDOC: Copyright
MNotice|nopanel=true}

Display a banner or text at the bottom of every page in this space by entering wiki markup here.

Save Cancel

Customising the theme at site level
If you have site administrator permissions, you can apply and customise the theme at site level. The
customisation options are the same as the space level options, as described above.

Features of the Documentation theme
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Here's a summary of the features that the Documentation theme provides:

® By default, the left-hand panel contains a search box and a table of contents (page tree) showing all
the pages in your space. Specifically, it shows the pages that are children of the space's home page.

® The left-hand panel is fully customisable. You can choose to include or exclude the search box and
page tree. You can enter your own text, images and wiki markup.

® People viewing the page can drag the thick bar between the left-hand panel and the content, to
increase or decrease the width of the panel. They can also remove the panel altogether, by clicking
tEIejsidebar icon
at top right, next to the search box.

® The left-hand and right-hand panels scroll independently of each other.

®* The page title is neatly above the page content, and not uncomfortably above the navigation panel as
tends to happen when you insert the navigation panel yourself.

® Because the left-hand panel is part of the theme, it will be upgraded whenever Confluence is
upgraded. There is no need to remove and then re-apply your customisations on each upgrade, as
you would do if you added your own left-hand navigation bar.

® The theme also provides a customisable header and footer, which will appear at the top and bottom of
every page.

® The text and heading styles are designed to enhance the content typically found in a documentation
space.

® You can use the Space Jump macro to link from a page in one wiki space to a page with the same
name in another space, without knowing the name of the page when you create the link.

® You can limit the Confluence search results to the current space. If you choose this option, the
Confluence search will look for matches only in the current space by default. Users can override the
restriction. See The Documentation Theme.

Hints and tips

Below are some hints that you may find useful when using the Documentation theme.Where can | see a
working example of the Documentation theme?

The Confluence documentation uses the Documentation theme. If you are reading this documentation online
on the Atlassian documentation wiki, you are seeing a working version of the Documentation theme.

Which pages will appear in the Documentation theme's table of contents?

The theme constructs the page tree in the left-hand panel from all pages that are child pages of the space’s
home page. Each space has a single page designated as the '"Home' page. You can specify the home page
in the space administration section.

Help, my pages do not appear in the Documentation theme table of contents

Cause 1: Your pages are not under the space's home page. The most probable reason why your pages
do not appear in the page tree in the left-hand panel is this: The theme constructs that table of contents from
all pages that are child pages of the space’s home page. If your pages are above the home page in the page
tree, they will not appear in the left-hand panel.

There are two ways to fix the problem:

® You can change the designated space home page in the space administration section.

® Oryou can drag and drop all your pages to make them children of the current home page. You can
drag and drop pages in the 'Pages' section of the space 'Browse' screen. See Move and Reorder
Pages.

Cause 2: Problem with upgrade from Confluence 3.1, with Documentation theme as plugin, to
Confluence 3.2 or later with Documentation theme bundled. If your existing Confluence installation
already has the Documentation theme plugin installed, you may find that after upgrading to Confluence 3.2
the left-hand navigation bar is empty in the spaces that use the theme. The fix is to enable all modules of the
Documentation theme plugin. See the knowledge base article.

Help, my left-hand panel has disappeared

If your entire left-hand panel has disappeared when using the Documentation theme, this is probably
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because you have clicked the sidebar icon

at top right, next to the search box. Click the icon again to restore the panel.
Can | change the default width of the left-hand navigation panel?

The Confluence user interface does not offer a way to change the default width of the left-hand navigation
panel supplied by the Documentation theme. Users can change the width by dragging the middle bar, but the
default width is not configurable. This post on Atlassian Answers gives a way to do it with CSS: Documentati
on Theme - Default Width (in px) of left panel.

Hiding pages from the left-hand table of contents
You can 'hide' pages by putting them at the same level as or higher than the space home page.

Each space has a single page designated as the 'Home' page. You can specify the home page in the space
administration section.

The theme constructs the page tree in the left-hand panel from all pages that are child pages of the space’s
home page.

If your documentation pages are at the same level as the space home page, they will not appear in the
left-hand navigation bar. So you can 'hide' pages by putting them at the same level as or higher than the
space home page. The pages will show up in the search results and people can see the content if they open
the page, but the pages will not appear in the left-hand panel.

More detail: The theme uses the Pagetree macro to produce the table of contents. When entering the
Pagetree macro, you can choose the top page in the page tree. The Documentation theme chooses the
space home page as the top page.

Using reusable content in your header, footer or sidebar

You can use any text or wiki markup in your theme header, footer or left-hand panel. One useful hint is to use
the Include or Excerpt Include to include re-usable content into your footer.

The screenshot above shows the theme customisation options, with examples of the macros used to include
content from other pages. And the example screenshot also above shows the resulting header, footer and
left-hand panel.

Adding content below the page tree in your sidebar

If you want to include your own content underneath the page tree, you can deselect the 'Page Tree' check
box, add your own page tree using the Pagetree macro in the 'Navigation' text box, and then add your own
content under the macro.

The screenshot above shows the theme customisation options, with the default page tree deselected and a
custom page tree inserted, along with additional content in the left-hand panel. The example screenshot also
above shows the resulting left-hand panel.

Adding an expanding All Versions section to the sidebar

If you want to include a an expanding list of links to other spaces, as we have included in this space (see
'Docs for all Confluence releases' in the sidebar), you can use an Expand Macro and an Include Page Macro
in the 'Navigation' text box. For example:

*[ Docs for all Confluence rel eases| Latest Versions of Confluence
Docunent ati on] *

{expand: Choose a version...}

{include: _Latest Versions of Confluence Docunentation}

{ expand}

If you would like this to display below the page tree, follow the steps above.
Adding underlines to your links

By default, the Documentation theme does not underline hyperlinks. If you prefer to have your links
underlined, you can edit the CSS stylesheet for your space and add the following CSS code:
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.wi ki-content a:link, .wiki-content a:visited, .wki-content a:active

{

text-decorati on: underline;

}

To edit a space's CSS style sheets:

1. Go to the space and choose Space tools > Look and Feel from the bottom of the sidebar
2. Choose Stylesheet then Edit.

3. Paste your custom CSS into the text field.

4. Save your changes. The new CSS will be visible on all content pages in the space.

If your space uses the Documentation theme:
1. Choose Browse > Space Admin from the header

Note: The Space Admin option appears only if you have space admin permissions, or if you're part of
the 'confluence-administrators' group.

Click Stylesheet in the left-hand panel under the heading 'Look and Feel'.

Choose Edit.

Paste your custom CSS into the text field.

Save your changes. The new CSS will be visible on all content pages in the space.

aprwd

Note: By default, only system administrators can edit the CSS for a space or for the site. To allow any user
with Space Admin permissions to edit the CSS for a space, go to

> General Configuration > Security Configuration and select Custom Stylesheets for Spaces.
Jumping to the same page in another space

The {spacejump} macro is provided along with the Documentation theme. You can use space jumping to link
from a page in one wiki space to a page with the same name in another space, without knowing the name of
the page when you create the link. When a reader is viewing a page and chooses the link provided by the
macro, they will go to a page with the same name, but in the space specified in the macro. See more about
the Space Jump macro.

Hiding the left-hand panel completely

It's not possible to remove the left-hand panel entirely, using the user interface supplied by the theme. There
is an improvement request here:
CONF-25923 - Provide option to hide the left-hand panel entirely in the Documentation theme
RESOLVED If you like, you can
comment on and/or vote for that request. In the meantime, Atlassian Answers is a good place to ask the
guestion and see if other people can help you with custom code to remove the panel.

Notes

® The Confluence default theme supplies a sidebar, which is different to the left-hand panel in the
Documentation theme. For information about the sidebar, see Configure the Sidebar.

® The Documentation theme supplies a Browse menu in the Confluence header, which gives access to
the space administration and advanced options.

Switch to the Default Theme

If you use the Documentation theme in your spaces,
it's time to consider switching to the Confluence
default theme.

A growing number of great features (such as JIRA
links button, space shortcuts and sticky table
headers) are not available in the Documentation
theme, and we plan to retire this theme altogether in
the near future.
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This page will show you how to turn on the default On this page:
theme, and keep any existing header, footer or

sidebar content. ® Understanding global look and feel

® Switch your space to the default

Here's an example of the documentation theme, and theme
default theme with the same custom content side by ®* Make the default theme available
side: across the whole site

® Hints and tips for the sidebar

® Edit the header, footer or custom
sidebar content

® Documentation theme features
that aren't available in the default
theme

® Troubleshooting

= XoConfluence Spaces~ Peopls Browse - | Create
Not sure where to start?
Sample Space

Read the Getling Startea guide first. Sample Spa ce Home

@ Created by Rach Admin [Administrator], last modified 2 minutes ago

= XoConfluence Spaces~ People  Create

. @ Sample Space Pages b
Documentation Sample Space Home
th eme 3 Pages Created by Rach Admin [Administrator], last modified 6 minutes ago
. Blog
With custom
. SPACE SHORTCUTS

sidebar content s Default theme
Not sure where to start? With the same
Read the Getting Started guide first. CUStom Content
PAGE TREE in the sidebar

> Project Roadmap
> Meeting notes

Survey results

Understanding global look and feel

Before you start, it's important to understand the idea of "global look and feel". Confluence allows you to
apply most themes to an individual space, or to the whole site. When a space says it is using the 'global look
and feel' it means it is using whichever theme has been applied for the whole site, and inheriting any
customisations from the site level.

The Confluence default theme, however, can only be applied to a space if it is currently applied to the entire
site (it must be the current global look and feel).

Switch your space to the default theme
To turn on the default theme and keep any existing header, footer or custom sidebar content:

1. Goto Browse > Space Admin > Theme and then Configure theme.

2. Copy the wiki markup from the Navigation, Header and Footer fields to somewhere safe (like a
document or text file) then Cancel.
(If these fields are empty, you can go straight to the next step).

3. Select Global look and feel (that's the default theme) and choose Confirm.
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Current Theme
The current theme controls the layout and colours of this space.

Documentation Theme

This theme is well suited for structured content, such as documentation. It fea
page. You can customise the left-hand panel, page header and page footer.

Configure theme - further customise this theme's options

Choose New Theme

To change the default theme of this Confluence site, select one below:

I Global Look and Feel

= The globally configured look and feel. You can customise colour-schemes ant Choose G |0ba|
= Look and Feel

Confirm to switch to the

default theme

(If Global Look and Feel is already listed as your current theme you'll need to follow the steps below
to change your Site theme first).

4. The default theme is now enabled - you'll notice the space admin options have moved.
Choose the Header, Footer and Sidebar tab.

Overview Permissions Content Tools  Look and Feel Integrations

Themes | Colour Scheme  Sidebar, header and footer  PDF Layout PDF Stylesheet

Current Theme Add your
The current theme controls the layout and colours of this space. header! footer
NN Global Look and Feel Olr custom
: The globally configured look and feel. You can customise colour-schemes ai sidebar content
achh

Choose New Theme

To change the default theme of this Confluence site, select one below:

Documentation Theme

5. Paste the wiki markup for your custom sidebar content (navigation), header and footer into the fields
provided then Save.

6. Use the space name link in the sidebar to get to the space homepage and check the appearance of
your space.

= XUConfluence spaces -

9 Sample Space

Back to your

o pames space's home
\ Blog
SPACE SHORTCUTS page
CUStOmlsab|e [2) Meeting notes
S.hortCUtS and Not sure where to start?
links

Read the Getting Started guide first.

PAGE TREE

> Project Roadmap
> Meeting notes

= Survey results

£¥ Spacs tools ~ «

Space admin
options
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The default theme includes some extras in the sidebar, such as shortcuts and index pages for blogs and
blueprints. Your custom content will appear between the shortcuts and page tree.

To choose what you'd like to show or hide:

1. Goto Space Tools (at the bottom of the sidebar) and select Configure Sidebar.
2. Use the

and

icons to show and hide each section.
3. This is where you can change the site logo too.

You can't hide the space name, logo or page tree.

Make the default theme available across the whole site

If the Documentation theme is enabled for the entire site, you won't see an option to switch to the default
theme in each space. This means that before you can switch each space over to the default theme, you'll
need to make it available for the whole site.

To make the default theme available across your whole site:

1. Goto

> General Configuration> Themes
2. Choose Configure theme beside the Documentation theme
3. Copy any wiki markup from your header, footer and sidebar fields to somewhere safe (like a document

or text file) then Cancel.
(If these fields are empty, the Documentation theme has not been customised for the entire site)
4. Select the Default theme and choose Confirm.
The default theme is now the global look and feel. If you did not need to copy over any wiki markup,
the process is now complete.
5. If you have wiki markup to migrate, go to

> General Configuration > Sidebar, header and footer
6. Paste the wiki markup for your custom sidebar content (navigation), header and footer into the fields
provided then Save.

All new spaces will now be created with the default theme.
The impact on existing spaces depends on how the theme is applied:

® All spaces that used the Documentation theme because it was the global look and feel will now use
the default theme. You don't need to do anything.

® All spaces that have the Documentation theme explicitly applied (for example to enable different wiki
markup in the sidebar, header or footer) the documentation theme will still be applied, and you'll need
to migrate each one separately.

Hints and tips for the sidebar

Here's a few hints and tips for making your sidebar migration as easy as possible.

Do you need to use wiki markup?

If the wiki markup in the Documentation theme for your space was simple, for example just adding a page
tree and a couple of links to useful spaces or external sites, chances are you don't need to continue to
customise the sidebar at all. The default theme comes with a page tree option, and you can add links to
pages, spaces or websites. These space shortcuts are much easier to keep up to date (and are safe from
page renames).

Are you using space CSS to style the theme?

If you're overriding the space CSS to change the appearance of the doc theme sidebar, you'll probably need
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to make some changes to your CSS, as some class and ID names are different between the two themes.

For example, instead of specifying #spl i tt er - si debar, you'll need to use . acs- si de- bar.

Edit the header, footer or custom sidebar content

You can update the wiki markup for the sidebar, header and footer at any time. Go to Space Tools > Look
and Feel > Sidebar, Header and Footer.

These fields use wiki markup, check our guide to wiki markup for help, or check out some common
customisations below.
~ Add a search field to your sidebar...
To add a search field to the sidebar:

1. Goto Space Tools > Look and Feel > Sidebar, Header and Footer
2. In the Sidebar field add the wiki markup for either the Livesearch or Page Tree Search macros

{l'i vesear ch}

{paget r eesear ch}

3. The search field will appear above the page tree.

~ Add a panel with some content...
To add a panel with some custom content to the sidebar:

1. Goto Space Tools > Look and Feel > Sidebar, Header and Footer
2. In the Sidebar field add the wiki markup for the Panel Macro then add some text:

{panel } This is some customcontent to appear in the sidebar{panel}

3. Your content will appear above the page tree.

Documentation theme features that aren't available in the default theme
Not all documentation theme features are available in the default theme.
Limit search results to the current space

We've decided not to add the ability to restrict the Confluence search on the header to a single space for
now. You will still be able to add the Live Search or Page Tree Search macros to the sidebar or homepage of
your space, and set these macros to only return results from the current space.

Space jump macro

This macro is part of the documentation theme. It is still available for now, but is likely to be removed when
we remove the Documentation theme.

Child pages below the page content

In the Documentation theme, children of the current page are listed below the page content. This is not
available in the default theme, however you could choose to add a Children Display Macro to the footer in the
default theme.

View pages alphabetically

In the Documentation theme you could choose to view all pages in a site alphabetically. This isn't available in
the default theme.
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Troubleshooting

Find out which spaces are using the Documentation theme

There's no simple way to see a list of spaces using the Documentation theme in Confluence itself, however if
you have a very large site, your Confluence Administrator can use the following query to get a list of spaces
directly from the database.

SELECT *

FROM BANDANA B, SPACES S

WHERE B. BANDANAKEY=' at | assi an. confl uence. t hene. setti ngs'
AND S. SPACEKEY=B. BANDANACONTEXT

AND B. BANDANAVALUE LI KE (' %docunent ati on% )

ORDER BY S. SPACENAME;

This query will only find spaces that are explicitly using the documentation theme. It doesn't include spaces
using the global look and feel (these spaces automatically change when you change the Site Theme, you
wont need to change the theme space by space).

Check for layout changes

If the underlying layout templates for your spaces have been customised, you may find that your space looks
strange or broken when you apply the default theme.

If this happens, you can reset the templates back to the default. You'll need to be a Site Administrator to do
this.

1. Switch back to the Documentation theme temporarily.
(If you're unable to use the space navigation, use this URL, replacing YOURSPACEKEY with the space
key for the space.

http://<yoursite>/spaces/chooset hene. acti on?key=YOURSPACEKEY

2. Goto Browse > Administration > Layouts or use the following link if you're unable to get there via
the space navigation.

http://<yoursite>/spaces/|istdecorators. acti on?key=YOURSPACEKEY

3. Choose Reset Default next to any template that have been customised.
4. Return to the Themes page and try applying the default theme again.

Edit a Space's Colour Scheme

Confluence allows you to customise the colour scheme of a space. By Related pages:
default, a space's colour scheme is based on global settings configured from .
the Administration Console. Change
the Look
You need to be a space administrator to edit a space's colour scheme. and Feel of
) a Space
To change the colour scheme for a space: o Apply a
1. Go to the space and choose Space tools > Look and Feel from the Theme to
bottom of the sidebar a Space

N

Choose Colour Scheme

3. Choose Select next to a scheme listed under Custom Colour
Scheme (if not already selected)

4. Choose Edit

5. Enter standard HTML/CSS2 colour codes or use the colour-picker
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=
to choose a new colour from the palette provided
If your space uses the Documentation theme:

1. Choose Browse > Space Admin from the header

Note: The Space Admin option appears only if you have space admin permissions, or if you're part of

the 'confluence-administrators' group.
2. Choose Colour Scheme under the heading Look and Feel
3. Follow the steps above to select a custom colour scheme and edit the colours

The colour scheme allows you to edit the colours of Ul elements including the top bar, tabs and
backgrounds.

Some Ul elements below are for specific themes, and colour changes may not take effect for other themes.
Top Bar - the top navigation bar background

Top Bar Text - the text on the top navigation bar

Header Button Background - buttons on the top navigation bar (e.g. Create button)

Header Button Text - the text on buttons on the top navigation bar

Top Bar Menu Selected Background - background colour of top navigation bar menu items when
selected (e.g. spaces)

Top Bar Menu Selected Text - text colour of top navigation bar menu items when selected

Top Bar Menu Item Text - text on top navigation bar drop down menus (e.g. help or cog)

Menu Item Selected Background - highlight colour on top navigation bar drop down menu items
Menu Item Selected Text - text colour on highlighted top navigation bar drop down menu items
Search Field Background - the background colour of the search field on the header

Search Field Text - the colour of the text in the search field on the header

Page Menu Selected Background - the background colour of the drop down page menu when
selected

Page Menu Item Text - the text of the menu items in the drop down page menu

Heading Text - all heading tags throughout the space

Space Name Text - the text of the current space name located above the page title

Links - all links throughout the space

Borders and Dividers - table borders and dividing lines

Tab Navigation Background - the background colour of the tab navigation

Tab Navigation Text - the text of the tab navigation when highlighted

Tab Navigation Background Highlight - the background colour of the tab navigation when
highlighted

® Tab Navigation Text Highlight - the text of the tab navigation elements when highlighted

Screenshot: Editing the colour scheme
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Custom Colour Scheme

Edit

Top Bar [}

Top Bar Text
Header Button Background -
Header Button Text
Top Bar Menu Selected Background -
Top Bar Menu Selected Text
Top Bar Menu Item Text [}
Menu ltem Selected Background -
Menu Item Selected Text
Search Field Background
Search Field Text
Page Menu Selected Background -
Page Menu ltem Text [}

Heading Text [}

Space Name Text [
Links [}
Borders and Dividers
Tab Navigation Background -
Tab Navigation Text
Tab Navigation Background Highlight [

Tab Navigation Text Highlight

Reset Save Cancel

A custom colour scheme which can be edited.

The following colours can be customised for this colour scheme.

#205081
#FFFFFF
#357280
#FFFFFF
#3B73AF
#FFFFFF
#333333
#3B73AF
#FFFFFF
RGBA(0, 0, 0, 0.2)
#FFFFFF
#3B73AF
#333333
#333333
#999999
#357280
#CCCCCC
#3B73AF
#FFFFFF
#205081

#FFFFFF

H B B B B B B B B B B B B B B B B B B B

1]

Selected

Handy Hint

If you mess things up, just choose Reset then try again.
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Administer a Space
If you're a space admin, for either a site or personal space, there are various

things you can change about that space. For example, you can change the On this page:
space's name, description, look and feel, and permissions. You can even cr * Administer
eate templates to speed up page creation in the space. Gl
® Administer
The space's sidebar is another area you can customise to suit your needs, a space
by adding shortcut links or changing the space logo. that uses
the
. Document
Administer a space Ao
theme

To view the space tools page:

1. Go to the space and choose Space tools > Permissions from the
bottom of the sidebar
2. The 'Space Permissions' page displays.

The administration options are divided into the following categories. Some options may not be applicable for

personal spaces.

® Overview
® Space Details - see Edit Space Details
® Space Categories - see Use Labels to Categorise Spaces
® Delete Space - see Delete a Space
® Permissions
® Permissions - see Assign Space Permissions
® Restricted Pages - see Page Restrictions
¢ Content Tools
Templates - see Page Templates
Orphaned Pages - see Orphaned Pages
Undefined Pages - see Undefined Page Links
Attachments - see Manage Files
Trash - see Delete or Restore a Page.
Export - see Export Content to Word, PDF, HTML and XML
RSS Feeds - see Subscribe to pre-specified RSS feeds

® Import - see Import a Text File. Not available for personal spaces.

* Look and Feel

Themes — see Apply a Theme to a Space

Colour Scheme — see Edit a Space's Colour Scheme
Layout - see Customise Space Layouts

Stylesheet - see Styling Confluence with CSS

PDF Layout — see Customise Exports to PDF

PDF Stylesheet — see Customise Exports to PDF

® |ntegrations
® Application Links — see Linking to Another Application

Related pages:

Configure
the
Sidebar

® Spaces
® Space

Permission
s Overview
Assign
Space
Permission
S

Mail Accounts — see Mail Archives. Not available for personal spaces.
Mailbox Import — see Import Mail from an mbox. Not available for personal spaces.
Mail — see Mail Archives. Not available for personal spaces.

You can also customise the sidebar, including changing the space logo and adding shortcuts to other spaces
- see Configure the Sidebar for more information.
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Administer a space that uses the Documentation theme

In this theme, the standard Confluence sidebar is replaced by a page navigation sidebar. As a result, the

layout of the space administration options are slightly different.
To view the space admin page:

1. Go to the space you wish to manage
2. Choose Browse > Space Admin from the header

Note: The Space Admin option appears only if you have space admin permissions, or if you're part of

the 'confluence-administrators' group.

The 'Space Details' page displays. For spaces using the Documentation theme, the administration options

are divided into the following categories:

® General
® Space Details — see Edit Space Details.
® Space Categories — see Use Labels to Categorise Spaces.
® Templates — see Page Templates.
® Delete Space — see Delete a Space.
® Trash — see Delete or Restore a Page.
® Security
® Permissions — see Assign Space Permissions.
® Restricted Pages — see Page Restrictions.
® Application Links — see Linking to Another Application.

* Mail
® Mail Accounts — see Mail Archives
® Mailbox Import — see Import Mail from an mbox

® ook and Feel

® Themes — see Apply a Theme to a Space.
Colour Scheme — see Edit a Space's Colour Scheme.
PDF Layout — see Customise Exports to PDF.
PDF Stylesheet — see Customise Exports to PDF.
Change Space Logo — see Change the Space Logo.

Import

®* |mport Pages from Disk — see Import a Text File.

Configure the Sidebar

If you're an admin for a space, _
Documentation L
you can make changes to the

Change space

space's sidebar like changing the name and logo
space's name, logo, or the way FELE
the page hierarchy is displayed. Blog .
You can also add shortcut linksto  Drag to reorder Hide pages, blogs
the sidebar to help you and shortcuts | SPACE SHORTCUTS or all shortcuts
others navigate to important = (3 Delivery Dashboard
content quickly. Add shortcuts Roadmap o -

to the sidebar emove a
@ The default and e + Add link shortcut

documentation themes in

NAVIGATION DISPLAY OPTIONS
Confluence both feature a

sidebar. If you're using a third o © Child pages
party theme, it may not feature a Change page © Page tree
sidebar. display options

Done

On this page we'll cover how to
customise the sidebar in the
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default theme. If you want
information on the sidebar in the Documentation theme, see Configure the Documentation Theme.

Configure a space's sidebar

To start configuring the sidebar, choose Space tools at the bottom of the sidebar, then choose Configure
sidebar.

From there you can:

® Change the space name and/or space logo:
1. Choose the edit icon

next to the space name
2. Type in a space Name and/or choose Upload an image to change the space logo
3. Choose Save
® Configure the Pages and Blog links:
® Choose the icons to hide or show the 'Pages’ or 'Blog' link.
For example, you may want your space to be used primarily as a blog (hide the 'Pages' link), or
you may not need a blog in your space (hide the 'Blog’ link).
* Drag the links to a different sequence within the section (you can't move a link from one section to
another).
ﬂ Add-ons may add other links in this section of the sidebar. For example, the Team Calendars
add-on may put a link in this location.
® Add or remove the shortcut links:
® Choose Add link to add a shortcut link to the sidebar. This can be a link to an important page for
your team, or to an external site, for example.
® Choose the icon to remove a shortcut link.
® Drag the links to a different sequence within the section. Note that you cannot move a link from
one section to another.
® Choose the hide or show icon beside the 'Space Shortcuts' heading to show or hide all shortcuts
on the sidebar.
® Change the navigation display options:
® Choose Child pages to see the current page and its children in the sidebar.
® Choose Page tree to see the page tree for the entire space, expanded to the current page.

Edit Space Details

Space details are the name, description, home page, and archived status of Related pages:
a space, which you can edit if you're an administrator of the space.

® Configure
You can also view the space key and the space creator's name, but the
you can't edit them. Sidebar
. . ® Spaces
To edit a space's details: o AFchive 2
1. Go to the space and choose Space tools > Overview from the Space

bottom of the sidebar
If your space uses the Documentation theme, choose Browse > Spa
ce Admin in the header.

2. Choose Edit Space Details

3. Update any of the following:

Name

Description

Status — Set the status to 'Archived’ if you want to archive the space.

Home page — Start typing the name of a page in the space, then select it to set it as the new
home page. This is the page you'll see when you navigate to the space. If you set this field to
blank (no selection) the default home page will be the 'Pages' page.

ﬂ The space fields don't accept wiki markup; if you enter wiki markup in these fields, it'll be displayed as
plain text. You can also change the name of a space via the sidebar.
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Space Details = Delete Space

Edit Space Details

Name: | Information Experience

Description: | The dudes and dudettes who develop
the docs that rock and drink the doc
hot chocs.

4»

Status: Current
Space status

Choose 'Archived' Home page:  Atlassian Technical Writers
to hide the space Home page
from search The page that displays when users navigate to this space. Start typing the name of
the space's homepage,
m Cancel then select it from the list

Use Labels to Categorise Spaces

A space category is a label that you can apply to a space for the purpose of On this page:
grouping your spaces in the the space directory, and in the recent activity
area of the dashboard.

® Categorise

a space
For example, if you have a space for each of your projects, you can add a ® Categories
category of 'project' to each of those spaces. It'll mean they're easy to find if in the
your Confluence site has a lot of spaces, which are a mix of project, team, space
personal, and other spaces. directory
: : s : . ® Remove a
Add as many space categories as you think you need; it's just like adding space from
labels to a page or blog post. a category

You need to be an administrator of the space to add categories to it. Related pages:

* Add,
Categorise a space Remove
and
1. Go to the space and choose Space tools > Overview from the Search for
bottom of the sidebar Labels
2. Choose Edit next to Space Categories ® Spaces
3. Under Space Categories, enter your category name and choose Ad
d
Alternatively, choose a category in the list of 'Suggested Space
Categories

4. Choose Done

~ Is your space using the Documentation theme?
If your space is using the Documentation theme:

1. Choose Browse > Space Admin from the header

Note: The Space Admin option appears only if you have space admin permissions, or if you're
part of the 'confluence-administrators' group.
Choose Space Labels in the space administration options
3. Under Space Categories, enter your category name and choose Add
Alternatively, choose a category in the list of Suggested Space Categories.
4. Choose Done

N

Categories in the space directory
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Once you've categorised some spaces, you can view your categories by choosing Spaces > Space
directory in the Confluence header, then choosing one of your categories from the list on the left.

You can also view spaces by category in the Space Categories tab of the recent activity section on the dash
board, or embed the Spaces List Macro on any page and allow filtering by category.

Remove a space from a category

To remove a space from a category, follow the above steps to add a space category but, instead of adding a

new category, choose the x next to the space category you want to remove.

category, the category will also be removed.

Screenshot: Space categories

If you remove all spaces from a

Space Details | Remove Space

Space Categories

They can be used to group together related spaces

Labels confluence = development x

Add

Space Categories will appear inside the categories tab on your dashboard and as tabs in the space directory

Delete a Space

Deleting a space permanently removes the space and all of its contents. To
delete a space you must be an administrator of the space.

I Deleting a space is permanent. If you're unsure, always create an XML
backup of the space before proceeding. You can also choose to backup the
attachments if you need to.

Once you've deleted the space, there is no way to restore it unless you've
made an XML space backup.

See Restoring a Space.

To delete a space: Space Tools

1. Go to the space and choose Space tools > O
verview from the bottom of the sidebar
2. Choose Delete Space

Overview Permissions

3. Choose OK Space Details = Delete Space

If your space is using the Documentation theme: # Edit Space Details

1. Choose Browse > Space Admin from the

header Name
Key
Note: The Space Admin option appears only
. . .. . Home page
if you have space admin permissions, or if
you're part of the 'confluence-administrators' Created by
group.
. Categories
2. Choose Delete Space in the space -
administration options Description
3. Choose OK

Related pages:

® Archive a
Space

®* Export
Content to
Word,
PDF,
HTML and
XML

Content Tools  Look and Fe

Delete space
Choose the
Delete space
tab to
Project Space permanently
. delete a space
(® Project Space Home

Gil Admin
(2015-06-04)

(None) [Edit]

Members of the conf | uence- admi ni st rat or s group can also delete spaces, including personal

spaces.
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Archive a Space

You can archive a space, so that its content is less visible but it's still On this page:

available in your Confluence site. You need to be an administrator of the i

space to archive it. ® Archive a
space

If you want the space to be fully visible again, you can change its status ® The effect

from archived to current at any time. of
archiving a
space

Archive a space

Related pages:

1. Go to the space and choose Space tools > Overview from the
bottom of the sidebar * Spaces
2. Choose Edit Space Details * Delete a
3. Select Archived in the Status dropdown menu Space
4. Choose Save ¢ Export
Content to
Word,
PDF,
HTML and
XML
If your space uses the Documentation Space Details = Delete Space
theme:
1. Choose Browse > Space Edit Space Details
Admin from the header
) ) Name:  Demonstration Space
Note: The Space Admin option
appears only if you have space Description:
admin permissions, or if you're
part of the
‘confluence-administrators'
group. 4
The 'Edit Space Details' screen Current
appears. M—
2. Select Archived from the Statu
s dropdown menu Home page: | Welcome to Confluence
3. Choose Save The page that displays when users navigate to this space.
- m Cancel
The effect of archiving a space

If a space is archived:

The pages and other content don't appear in the Confluence quick navigation aid, which drops down
when you enter text in the search box.

By default, the pages and other content don't appear in the Confluence search results. If a Confluence
site contains any archived spaces, the search screen will provide an option to include them in the
search results.

® The space and its pages don't appear on the dashboard.
® Updates to the space's content don't appear in activity streams, such as the recent updates section of

the dashboard.

The space doesn't appear in space-selection dropdown menus. Similarly, its pages and other content
don't appear in any dropdown menus in the Confluence user interface.

In the space directory, the archived space won't appear in the general space lists. Archived spaces
appear in the archived spaces tab. They'll also appear in the category tabs, as determined by their
labels.

These functions remain available for archived spaces:

You can view the content as usual, by following a link or typing in a URL belonging to the archived
space.
You can edit the content as usual, as determined by the space permissions.
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® RSS feeds, watches and notifications remain active.

o Archiving a space has no effect on search results of external search engines. For example, the space will
still appear in Google search results.

View Space Activity
Space activity information is disabled by default, and the 'Activity' tab won't

be visible unless the Confluence Usage Stats plugin is enabled. See notes b Related pages:
elow. * Page
If enabled, the space activity screen displays statistics on the activity in each History
space. These include: and Page
Compariso
®* How many pages and blog posts have been viewed, added or n Views
updated over a given period. ® Watch
®* Which content is the most popular (most frequently viewed). Pages,
® Which content is the most active (most frequently edited). Spaces
® Which people are the most active contributors/editors of content. and Blogs
. S ) ® Howdol
To view the activity in a space: get more
1. Go to the space and choose Space Tools at the bottom of the statistics
sidebar from
2. Choose Activity Cg)nﬂuenc
e’

You'll see a graphic display of the number of pages and blog posts that have been viewed, added, and
edited, showing trends over a period of time.

Screenshot: The Space Activity tab

Space Activity

Overview Permissions Content Tools Look and Feel Integrations  Activity

Activity

Activity for week starting 10 February 2013

Period: month | week | day Week: << Previous | Now | Next >=

See also: Global Confluence activity

In addition to the graphical representation of Views and Edits, the top ten most popular and most active
pages and/or blog posts will be listed, with a link to each.

Screenshot: Popular content, active content, and active contributors.
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Most popular content (Views) Most active content (Edits) Most active contributors (Edits)
1. [#) Angry Nerds Home (6) 1. [2) Ideas for Angry Nerds 2 - 1. & Josh User (5)
2. Which nerd are you? (3) revenge of the. . (2) 2. & Ewan User (3)
3. (3 Step 1 - download the game (2) 2. [8] Why | loved Angry Nerds (1) 3. & Rach Admin (1)
4. Why | loved Angry Nerds (2) 3. Which nerd are you? (1)
5. [2) Step 2 - Play (2) 4. [2) Step 2 - Play (1)
6. (3 Ideas for Angry Merds 2 - revenge 5. [g) status update (1)

of the... (2) 6. [S) Games as a communication
7. [3 Status update (1) medium (1)
8. (2 Games as a communication

medium (1)

Notes

® To view Space Activity the Confluence Usage Stats system plugin must be enabled. This plugin is
known to cause performance problems on large installations and in Confluence Cloud, and is disable
d by default. System administrators can enable this plugin (go to add-ons, select System add-ons a
nd search for ‘Confluence Usage Stats').

® The plugin collects data only when it's activated.
If you're using Confluence Data Center, space activity information isn't available.

® Page hits aren't unique - the graph on the Space Activity screen includes all page hits, including
multiple visits by the same user.
® The Activity tab does not appear in spaces that use the Documentation theme.

View Recently Updated Content

The 'Recently Updated' view is a useful way of keeping track of the changes Related pages:
being made in a space. It displays links to the most recently added or
modified content within the space, including pages, blog posts, mail * Recently
messages and comments. Updated
Macro

If you want to display a list of recently updated content on a page, try the Re * View
cently Updated Macro. Space

. . Activity
To view the recently updated content in a space, go to the space and e Favourite
choose Pages in the sidebar. If the space is using the Documentation Pages

theme, choose Browse > Pages in the header, then choose Recently
Updated.

You'll see a list of the most recently added or modified content in the space. Choose any of the links to open
the corresponding content.

Customise Space Layouts

You can modify Confluence's look and feel by editing the layout files. This page tells you how to customise the
layout files for a space. You will require need space administrator permissions for that space.

If you're a Confluence system administrator, you can also customise the layout of your entire Confluence site.
For more information, see Customising Site and Space Layouts. Site layout customisations modify the default
layout of all spaces in the Confluence site.

Any space layout customisations will override the equivalent site customisations.

If you modify the look and feel of Confluence by following these instructions, you'll need to update your
customisations when you upgrade Confluence. The more dramatic the customisations are, the harder it'll
be to reapply your changes when upgrading. Please take this into account before proceeding with any
customisations.

For more information on updating your customisations, please refer to Upgrading Customised Site and
Space Layouts.
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Related pages:

® Change the Look and Feel of a Space
®* Apply a Theme to a Space
® Styling Confluence with CSS

Confluence is built on top of the Open Source SiteMesh library, a web-page layout system that provides a
consistent look and feel across a site. SiteMesh works through 'decorators' that define a page's layout and
structure.

To edit the layout of Confluence, you will need to modify these decorator files. A decorator file is a .vmd file and
is written in a very simple programming language called Velocity. Learn more about Velocity. Once you become
familiar with Velocity, you can edit the decorator files to personalise the appearance of Confluence.

The decorator files in Confluence are grouped into the following categories:

® Site layouts: These are used to define the controls that surround each page in the site. For example, if
you want to make changes to the header and the footer, you will need to modify these layouts.

® Content layouts: These control the appearance of content such as pages and blog posts. They do not
change the way the pages themselves are displayed, but they allow you to alter the way the surrounding
comments or attachments are shown.

® Export layouts: These control the appearance of spaces and pages when they are exported to HTML. If
you are using Confluence to generate a static website, for example, you will need to modify these layouts.

Learn more about using decorators.
To edit a decorator file:

1. Go to the space and choose Space tools > Look and Feel from the bottom of the sidebar
2. Choose Layout (Layout is displayed only if you are a Confluence system administrator.)
You'll see a list of the layouts for the space
3. Click Create Custom to edit the default vmd file
This will open up the vmd file in edit mode. If you only want to view the vmd file, click View Default.
4. Make any changes and click Update

You can't update the layout templates if your space is using the Documentation theme.

Screenshot : Edit Layouts Example

Content Layouts

Content layouts control the appearance of content such as pages and blog posts: they don't change the way the
pages themselves are displayed, but they allow you to alter the way the surrounding comments or attachments

are shown.
Decorator Operations
Space Layout < default > - Create custom - View Default

Controls how a space is displayed.

Page Layout < default > - Create custom - View Default
Controls how a page is displayed.

Export Content to Word, PDF, HTML and XML

You can export all or part of a Confluence space to various formats,
including Microsoft Word, HTML, PDF and XML.

To use the space export functionality, you need the 'Export Space'
permission. See the guide to space permissions.
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Export single pages to Word or PDF On this page:
' * Export

If you need to send content to people who don't have access to Confluence, single
you can export a single page as a Word document or a PDF. You can also pages to
export a single blog post to PDF. Word or

If you've got permission to view the page in Confluence, you'll be able to PDF
export it in this way; go to the page and choose either Tools > Export to ® Exportto

Word or Tools > Export to PDF. HTML,
XML, or

PDF

® Customisin
g the
appearanc
e of PDF
exports

Related pages:

® Customise
Exports to
PDF

When you export a single page to PDF, the PDF stylesheet customisations are applied, but any PDF layout
customisations aren't. To make your PDF layout customisations apply to a single page exported to PDF,
you'll need to use the 'multiple page' method described below to export the single page. See Customise
Exports to PDF.

Export to HTML, XML, or PDF

If you want to export a space — or selected pages in a space — to HTML, XML, or PDF, Confluence can
create a zipped archive of the HTML or XML files, or a single, downloadable PDF file.

The HTML export is useful if you want convert your space into a static website, or you can use the XML
export option if you need to import the space into another Confluence site, or use the data from the space in
another application. You might use the PDF option if you're producing a user manual from your technical
documentation in Confluence.

To export pages to HTML, XML, or PDF:

1. Go to the space and choose Space tools > Content Tools from the bottom of the sidebar
2. Choose Export
3. Select either HTML, XML, or PDF, then choose Next
4. Select either a normal or custom export for HTML or PDF, or a Full or Custom XML export:
® Normal Export (HTML and PDF) — to produce an HTML file containing all the pages that you
have permission to view.
® Full Export (XML) — to produce an XML file containing all the pages in the space, including
those that you do not have permission to view.
® Custom Export — if you want to export selected pages only, or if you want to exclude
comments from the export.
5. Choose Export

ﬂ' Blog posts aren't included when exporting to PDF using this method, and comments are never included
when exporting to PDF.

When the export process has finished, you can download the zipped archive or PDF.

If your space uses the Documentation theme, choose Browse > Space Operations, then choose either HT
ML, XML, or PDF Export from the left menu, and follow the steps above to export the Space.
Customising the appearance of PDF exports

You can add a title page, table of contents, and customised headers and footers to the PDF output. For more
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advanced customisations, you can apply Cascading Style Sheet (CSS) modifications. These customisations
are specific to each space, and you need the 'Space Administrator' permission to apply these customisations.
For more information, see Customise Exports to PDF.

Notes on PDF exporting

® To export a PDF containing international text, see Create a PDF in Another Language

® Confluence's PDF export feature is designed to handle a wide variety of content, but on rare
occasions the PDF Export process may fail due to an unrecognised customisation. If that happens, the
PDF export screen will indicate the title of the page in which the problem occurred, to help you
diagnose the cause of the failure.

Notes on HTML exporting

® Inthe zip file, page attachments are placed in individual folders with names in the following format:
... \downl oad\ at t achment s\ xxxxxXx
where 'xxxxxx" is the page ID of the page containing the attachments.

® Blog posts aren't included in the HTML export. See the feature request:

CONF-14684 - Export news to HTML
OPEN

® To customise the HTML output, you'll need to modify the file conf | uence-x.y. z-jar/com atl as
si an/ conf | uence/ pages/ Page. ht nl export.vm To learn how to repackage this file, see How to
Edit Files in Confluence JAR Files

Notes on XML exporting

® See Restoring a Space for notes on restrictions when importing a space.

® |f you're doing the export for backup purposes, consider another means of backup. See Production
Backup Strategy.

® |f you are running Confluence behind Apache HTTP Server and are facing timeout errors, please
consider creating the export directly from Tomcat, instead of going through Apache. This will speed up
the process and prevent timeouts

Customise Exports to PDF

Confluence administrators and space administrators
can customise the PDF exports for individual
spaces.

Please note:

* PDF customisations are unigue to each
space.
® PDF customisation only applies to space
exports (not single page exports via Tools >
Export to PDF)
® Confluence's PDF customisations use a
combination of HTML and CSS (Cascading
Style Sheets).
® To achieve a particular requirement in the
exported PDF file, you make changes in one
or both of the following:
® The PDF Layout, where HTML is used
to define the structure of the exported
content, including features such as the
title page, headers and footers.
® The PDF Stylesheet, where CSS is
used to define the style of elements in
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the exported content, such as page On this page:
size and margins, font, colour, and list o
numbering. Q Customlsmg the PDF Layout
® Setting a global PDF layout
For further customisations, see the Advanced PDF ® Setting the PDF layout at
Export Customisations page. space level

® Customising the PDF Stylesheet
® Setting a global PDF
Stylesheet
® Setting a space PDF
stylesheet
® Example Customisations
®* Page Size
® Page Orientation:
Landscape or Portrait
Page Margins
Page Breaks
Title Page
Table of Contents
Headers and Footers
Page Numbering
Wrapping Long Words
® General Formatting
®* Notes

Related pages:

® Advanced PDF Export
Customisations

Customising the PDF Layout
You can add your own HTML to customise the title page, page headers and page footers in the PDF output.

Setting a global PDF layout

1. Choose the cog icon

, then choose General Configuration under Confluence Administration
2. Choose PDF Layout. You can enter HTML and CSS that will be rendered on the PDF title page, as
well as page headers and footers.

Setting the PDF layout at space level

1. Go to the space and choose Space tools > Look and Feel from the bottom of the sidebar You'll
need Space Admin permissions to do this.

2. Choose PDF Layout.

3. Choose Edit.

If your space uses the Documentation theme:
1. Choose Browse > Space Admin from the header

Note: The Space Admin option appears only if you have space admin permissions, or if you're part of
the 'confluence-administrators' group.

2. Choose PDF Layout in space administration options.

3. Choose Edit.

You can customise the HTML that is generated for the following areas when the space is exported to PDF:

®* PDF Space Export Title Page — title page.
®* PDF Space Export Header — page headers.
® PDF Space Export Footer — page footers.
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Enter your customisations into each text box as required. The PDF layout section accepts HTML code. You
can include inline CSS in the HTML too.

Customising the PDF Stylesheet

You can adjust the appearance of the PDF pages by customising the CSS in the PDF Stylesheet screen.
To get started, download the default CSS rules for the PDF stylesheet - confluencedefaultpdf.css.

Any rule defined in this file can be customised and added to the PDF Export Stylesheet section. Your
customisations override any default CSS rule. If no customisations are defined, the default CSS rules will be
applied.

By default, the export does not include a title page, headers or footers. You can define these in the PDF
layout.

To customise the PDF Stylesheet:

Setting a global PDF Stylesheet

1. Choose the cog icon

, then choose General Configuration under Confluence Administration
2. Choose Look and Feel > PDF Stylesheet. The following screen allows you to enter and save CSS
code that will render content on each page.

Setting a space PDF stylesheet

1. Go to the space and choose Space tools > Look and Feel from the bottom of the sidebar You'll
need Space Admin permissions to do this.

2. Choose PDF Stylesheet.

3. Choose Edit.

4. Enter your customisations.

If your space uses the Documentation theme:
1. Choose Browse > Space Admin from the header

Note: The Space Admin option appears only if you have space admin permissions, or if you're part of
the 'confluence-administrators' group.

2. Choose PDF Stylesheet in the space administration options.

3. Choose Edit.

4. Enter your customisations.

The PDF Export Stylesheet field accepts Cascading Style Sheets (CSS) rules. The 'PDF Export Stylesheet'
page shows the current (e.g. customised) contents of your PDF stylesheet.

Example Customisations

This section provides examples of typical customisations that you can add. See also Advanced PDF
Customisations.

Page Size

The default page size is based on the location of your Confluence server. For example, if this server is
located in the US then the default paper size of your PDF export will be US Letter (8.5 inches wide by 11
inches long). If the server is located in Australia, the default paper size will be A4 (210 mm wide by 297 mm
long). More information about paper sizes can be found on Wikipedia.

To modify the page size to A4, edit the PDF Stylesheet to add a si ze property to the CSS@age rule, like
this:
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CSS - PDF Stylesheet

@age
{
/*The A4 paper size is 210 mm w de by 297 mm | ong*/

size: 210mm 297mm
}

Page Orientation: Landscape or Portrait

To change the page orientation of your PDF document, simply reverse the order of the values declared in the
@age rule's si ze property. The first and second values of this property represent the width and height of

the page, respectively.

For example, to generate PDF space exports in A4-sized landscape orientation, your @age rule might look
like this:

CSS - PDF Stylesheet

@age
{

/*A4-sized pages in | andscape orientation are 297 mmw de by 210 mm | ong*/
size: 297mm 210mm
}

Page Margins

To set all margins to 15 mm, with a paper size of A4, edit the CSS @age rule in the PDF Stylesheet, like
this:

CSS - PDF Stylesheet

@age
{
size: 210mm 297mm

mar gi n: 15mm
}

To set the margins independently, edit the @age rule as follows:

CSS - PDF Stylesheet

@age

{

mar gi n-top: 2.54cm
mar gi n-bottom 2.54cm
margin-left: 1.27cm
margin-right: 1.27cm
}

To set margins to provide a gutter for binding a printed document, use the : | eft and : ri ght pseudo-class
es, as follows:
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CSS - PDF Stylesheet

@age :left

{

margin-left: 4cm
margi n-right: 3cm
}

@age :right

{

margin-left: 3cm
margi n-right: 4cm

}

@age :first

{

margi n-top: 10cm/* Top margin on first page 10cm */
}

Note the use of the : fi r st pseudo-class in the example above to define distinct margins for a cover or title
page.
Page Breaks

By default, Confluence pages are exported without page breaks, so that shorter pages will appear on the
same PDF page.

To make each Confluence page appear on a separate page in the PDF file, add the following rule in the PDF
Stylesheet:

CSS - PDF Stylesheet

. pagetitle
{

page- br eak- bef ore: al ways;

}

Title Page

You can add a title page to your PDF document by adding HTML to the Title Page section of the PDF Layout
screen. The following example creates the title page and adds a title:

HTML - PDF Layout: Title Page Section

<div class="fsTitl ePage">

<ing src="/downl oad/ attachment s/ 590719/titl| epage. png" />
<div class="fsTitle">Pl anning for Confluence 4.0</div>
</ di v>

Use CSS rules in the PDF Stylesheet to control the appearance of the title page and the title text:
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CSS - PDF Stylesheet

.fsTitl ePage
{

margi n-left: auto;

mar gi n-top: 50mMm

mar gi n-right: auto;
page- br eak-after: al ways

}

fsTitle
{

font-size: 42px;
font-wei ght: bold;
margin: 72px 0 4px O;
text-align:center;

}

Adding an Image to the Title Page

In the example above, the title page includes an image called 'titlepage.png’, centred in the middle of the
page. The "590719" in the sr ¢ attribute is the ID number of the page to which the image is attached.

Follow these instructions to include an image on your title page:

1. Attach the image to a Confluence page.

2. View the list of attachments on that page, then right-click the image and copy its location.

3. Paste the link into the appropriate src="" attribute in your PDF Stylesheet, as shown above.

4. Edit the image URL so that it is relative, by removing the first part of the URL before / downl oad/ . . ..

Table of Contents

By default, a table of contents will be generated after the title page, or at the beginning of the PDF document
if no title page is defined in the PDF Layout. To see the default CSS rules applied to the table of contents,
download the default CSS rules (confluencedefaultpdf.css) and examine the specific rules with t oc in their

name.

To make changes to the appearance of the table of contents, define CSS rules in the PDF Stylesheet.

Disabling the Table of Contents

To prevent the table of contents from being generated in your PDF document, add the di v. t oc- macr o rule
to the PDF Stylesheet and set its di spl ay property to none:

CSS - PDF Stylesheet

di v.toc-nacro

{

di spl ay: none;

}

Changing the Leader Character in the Table of Contents

The leader character is used to link a heading in the table of contents with its page number. By default, the
leader character is the '." (dot) character. Leader values of dot t ed, sol i d and space are allowed. You can

also use a string, for example | eader (". . . ").

To change the leader character to a solid line, modify the | eader () value on the cont ent property of the
CSS rule as follows:
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CSS - PDF Stylesheet

span. tocl ead: bef ore

{

content: |eader(solid);

}

Headers and Footers

You can add headers and footers to your PDF pages using the 'Header' and 'Footer' sections of the PDF Layout
screen. By default, headers and footers only apply to a space export and not to exports of single pages
(however, see Advanced PDF Export Customisations). The following example adds a simple copyright notice.

HTML - PDF Layout: Footer Section
Copyright © 2013, Atlassian Pty Ltd.

Page Numbering

To add page numbering, you need to combine customised HTML in the PDF Layout with customised CSS in the
PDF Stylesheet.

1. PDF Layout HTML: In the Footer section (or the Header section), use an empty span element with a
unigue ID, for example pageNum to act as a place holder for the page number.

HTML - PDF Layout: Footer Section

<span i d="pageNunt/>

2. PDF Stylesheet CSS: Create the following CSS selector rule for the empty span:

CSS - PDF Stylesheet

#pageNum bef ore

{

content: counter(page);

}

Analysing the above CSS selector rule in more detail:

® The #pageNumrule selects the HTML element with the specified ID of "pageNum®”, which is the span

element we created for the header or footer.

® The: bef or e part of the selector is a pseudo class that allows the insertion of content before the spa
n element is processed.

®* The count er ( page) is a function that returns the current page number as its content.

® The cont ent property tells the CSS processor that dynamic content (that is, an incrementing page
number) is to be inserted at the span tag.

Wrapping Long Words

In order to break long words or words that are not separated by whitespace, add a selector to the PDF
stylesheet containing the wor d- wr ap property with a value of br eak- wor d:
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CSS - PDF Stylesheet
div
{

wor d-wr ap: break-word;

}

General Formatting

You can use the stylesheet to customise the output of just about anything else that will influence the look and
feel of the final document. This includes fonts, tables, line spacing, macros, etc. The export engine works
directly from the HTML output produced by Confluence. Therefore, the first step in customising something is
to find a selector for the HTML element produced by Confluence or the Confluence macro. Then add a CSS

rule to the PDF stylesheet. Your customisation will appear in the PDF export.

Notes

®* Demotion of heading elements: h1, h2, and so on. Due to the hierarchical manner in which a space
is exported, Confluence will modify the heading elements to generate a uniform appearance for the

entire space export. This means that headings will be demoted. This will affect the application of

custom PDF Stylesheets. It is possible to calculate the amount by which a heading will be demoted in
order to have the correct CSS styling applied. A heading will be demoted by the value of its depth in
the export tree. A page at the first level will be demoted by 1 (all <h1> elements will become <h2> ele

ments, and so on). A page at the second level will be demoted by 2, and so on.

® Atlassian support for PDF customisation is limited. We support the mechanism for customising
the PDF layout with HTML and CSS, and we will help if the mechanism is broken or does not work as

we say it should in our published examples. But, since custom HTML and CSS offer potentially
limitless possibilities, Atlassian will not support issues that are caused by or related to PDF

customisations.

Advanced PDF Export Customisations

This page provides information about ‘advanced'
PDF export customisations. These expand upon the
regular customisations described in Customise
Exports to PDF.

. The information below is for advanced users. Be
aware that the advanced customisations described
below require knowledge of certain parts of
Confluence, and of CSS and HTML. Customisations
are not supported by Atlassian, so our support
engineers won't be able to help you with these
modifications.

Header and Footer

Adding Headers and Footers to Single Page Exports

Single page exports don't support adding HTML headers and footers via the PDF Layout page, but you can

On this page:
® Header and Footer
® Adding Headers and
Footers to Single Page
Exports
® Adding Images to Headers
and Footers
® Incorporating Other Fonts
® Adding a Dynamic Title to the Title
Page
® Hiding Text from the PDF Output
® Indexing
* Notes

Related pages:

® Customise Exports to PDF
® Create a PDF in Another
Language
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use CSS rules in the PDF Stylesheet page (Space tools > Look and Feel > PDF Stylesheet) to produce
headers and/or footers for a single page export.

For custom headers, define any of the following rules within your @age rule: @ op-1 eft, @op-center, a
nd @ op-ri ght . These rules allow you to define the cont ent of the left-hand side, centre and right-hand
side of your page's header area, respectively.

For custom footers, define @ottom | ef t , @ott om cent er and @ottonmri ght rules within your @ag
e rule.

For example, the following rules add a document title at the centre of the header and a page number at the
centre of the footer:

CSS - PDF Stylesheet

@age
{

@ op- cent er

{

content: "Docurment Title CGoes Here"; /* This is the content that wll
appear in the header */
font-famly: ConfluencelnstalledFont, Helvetica, Arial, sans-serif;
font-size: 8pt;
}

@ottom center

{

content: "Page " counter(page); /* This is the content that will appear
in the footer */

font-famly: ConfluencelnstalledFont, Helvetica, Arial, sans-serif;

font-size: 8pt;

}

/* Any other page-specific rules */

Notes:

® Thefont-fam |y andfont-size properties ensure that the header and footer text is rendered in
the same default font style used for the body text, based on the default CSS rules.

® |tis not possible to use this method to insert images (stored as attachments within your Confluence
instance) into the headers and footers of single page exports.

Adding Images to Headers and Footers

To insert an image into the header or footer, add HTML to the Header or Footer section of the PDF Layout
screen.

The following example uses an HTML i ng element with sr ¢ attribute to add an image to the left of the
header. The sr ¢ attribute refers to an image attached to a Confluence page. The image element is usually
placed within a di v element container.

HTML - PDF Layout: Header Section

<div style="nargin-top: 10.0nm ">

<i ng
src="https://confluence. atl assi an. com downl oad/ att achnment s/ 12346/ header - i nage. png
C s
</ di v>

In the example above, the header includes an image called 'header-image.png'. The "12346" in the sr c attrib
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ute is the ID number of the page to which the image is attached.
Follow these instructions to include an image on your page:

1. Attach the image to a Confluence page.

2. View the list of attachments on that page, then right-click the image and copy its location.

3. Paste the link into the appropriate src="" attribute in your PDF Stylesheet, as shown above.

4. Edit the image URL so that it is relative, by removing the first part of the URL before / downl oad/ . . ..

Notes:

® This example uses an inline CSS property mar gi n-t op in the st yl e attribute to force the image
away from the top of the page by 10mm. This comes in handy when your header image is large
enough to touch or spill over the top of the page.

® |ikewise, for footers, you can use the mar gi n- bot t om XXnmmproperty to force an image away from
the bottom of the page by 'XX' mm.

® Very large images can spill over into the body of a page or alter the position of text or other elements
used within a header or footer. In such situations, it is recommended that you reduce the size of the
image and then attach it to your Confluence page again. If you prefer to keep the image size and want
to move the content lower instead, you can do so by configuring the mar gi n-t op properties in the @
age CSSrule.

® By default, a header or footer image is aligned to the left-hand side of the page. However, you can
align this image to the centre or right-hand side of a page by adding either the t ext - al i gn: cent er
ortext-align:right properties to your st yl e attribute. For example, to align the header image to
the right-hand side of the page, your st yl e attribute would look similar to this: st yl e="mar gi n-t op
:10mm text-align:right".

Incorporating Other Fonts

By default, Confluence provides Times New Roman, Helvetica or Courier fonts for use in PDF exports. You
can use your own fonts for PDF exports by declaring them in a @ ont - f ace CSS rule in your PDF
Stylesheet.

The following CSS rule example shows how to declare the Consolas font and apply it to some elements for
your PDF export:

CSS - PDF Stylesheet

@ont-face { src: url(file:///usr/share/fonts/Consolas.ttf); -fs-pdf-font-enbed:
enbed; } .code pre, .preformatted pre, tt, kbd, code, sanp { font-famly:
Consol as, nonospace; font-size: 9pt; }

The font path specified in the CSS must be the path to the font on the Confluence server.

Adding a Dynamic Title to the Title Page

When you export an arbitrary set of pages from Confluence, you may like to have a corresponding title added
to the cover (or title) page automatically. This can be done (in a somewhat irregular way) by using the top
level item from the default table of contents as the title. This method relies on having the exported pages
structured as sub-pages of the top-level page. In other words, the pages to be exported should consist of a
page (at the top-level) and all of its child pages. The result is that the title that appears on the cover page
changes depending on the top-level page that is used for the export.

The CSS below moves, and styles, the top-level TOC item for use as the title on the cover page, and turns
off the leader and page number normally associated with this item in the TOC.

Created in 2015 by Atlassian. Licensed under a Creative Commons Attribution 2.5 Australia License.


http://creativecommons.org/licenses/by/2.5/au/

76

Confluence 5.9 Documentation

CSS - PDF Stylesheet

.fsTitlePage { position:relative; left:0px; } /* Turn off the default section
nunbering for this TOC item*/ .toclvlO:before { content: &quot; &quot;;
counter-reset: chapter 0; } /* Hide the default page nunbering for this TOC item
*/ .toclvlO .tocnum{ display: none; } /* Move and style this TOC item */
.toclvl O { position:absolute; top:250px; font-size: 42px; font-weight: bold;
margi n: 72px 0 4px 0; text-align:center; }

Hiding Text from the PDF Output

This section describes a way to hide text from your PDF export. In other words, you can have text on the
Confluence page that will not appear in the PDF export.

There are three steps:

1. Follow the instructions to define the NoPrint user macro.
2. Use the NoPrint macro to mark some text on a Confluence page.
3. Add the following CSS to your PDF stylesheet to make the PDF export recognise the NoPrint macro:

CSS - PDF Stylesheet

.noprint { display: none ; }

Indexing
To obtain an index at the end of the exported PDF file, consider using the Scroll Wiki PDF Exporter plugin tha
tis produced by K15t Software GmbH.

Notes
If styling is not working as expected, it is useful to look at the intermediary HTML source to which the CSS is

applied. This intermediary HTML is created whenever you create an HTML export that contains multiple
pages, and is stored in the t enp directory in Confluence's home directory. For example:

/tenp/ ht M export-20110308- 154047- 1/ export-i nternedi at e- 154047-2. ht

Create a PDF in Another Language

To export a Confluence page written in a language :
other than English, you'll need the necessary font for Related pages:

that language.

® Export Content to Word, PDF,
HTML and XML

Upload a Font File to Confluence

1. Find the appropriate font file:
®* Windows users:All font files in Windows are stored in a directory called:

C. \ W NDOW6S\ Font s

® Unix users:All font files in Unix are stored in:
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/usr/share/fonts

® Microsoft True Type core fonts such as Verdana can be downloaded from this page: http://coref
onts.sourceforge.net/
Copy the font file into a temporary folder, for example a folder on your desktop.
3. Choose the cog icon

, then choose General Configuration under Confluence Administration

N

then choose PDF Export Language Support.
4. Upload the file you copied in step 2.
5. Choose Install.

® The only font files supported are true type fonts and true type collections. The accepted file extensions
are *.ttf and *.ttc.

® Confluence can only store one font file at any one time. Please create a collection to install more than
one *.ttf files.

®* We recommend that you use Unicode font Verdana for correct character encoding and exporting to
PDF.

® If the font file size is bigger than your current attachment size limit, you will not be able to upload it.
Please increase the attachment size limit temporarily and re-upload again. An improvement of the

CONF-24706

error messaging is tracked at |RESOLVED

® To make use of an installed font in your PDF Export style sheet (CSS) refer to it by the font-family
ConfluencelnstalledFont.

Pages and Blogs

When you create any content in Confluence — whether it's taking down some Related pages:
quick notes from a meeting, writing a requirements page, or letting your

teammates know about the company's latest marketing push — you'll either * Create and

be creating it as a page or a blog post. You may be shocked to know that Edit Pages
this page you're reading now, is, in fact, a Confluence page! ® Blog Posts
® The Editor
Pages and blog posts are the two things that allow you to capture and share ®* Page
information in Confluence, and which one you use depends on what you Templates
want to do with your content. If you want the information to last, and possibly ® Delete or
evolve over time, then you likely want to create a page; if the information is Restore a
specific mainly to the current time-frame, and isn't going to change over Page
time, then you'll most likely want to create it as a blog post. These aren't ® Spaces

hard-and-fast rules; they're just pointers to give you a place to start.

Each Confluence space, including your personal space, allows you to create pages in it, and has its own blog
where you can create posts. If you're not sure what a space is, or what you can do with spaces, check out
our page on Spaces.

Take a look at the below pages to learn more about pages and blog posts in Confluence.

Create and Edit Pages

Blog Posts

The Editor

Move and Reorder Pages

Copy a Page

Delete or Restore a Page

Add, Remove and Search for Labels
Drafts

Page Restrictions

Links
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Anchors

Tables

Add, Assign, and View Tasks
Autocomplete for links, files, macros and mentions
Page Layouts, Columns and Sections
Create Beautiful and Dynamic Pages
Page Templates

Blueprints

Import Content Into Confluence

Orphaned Pages

Undefined Page Links

View Page Information

Page History and Page Comparison Views
Confluence Markup

Create and Edit Pages

Create a page

You can create a page from anywhere in Confluence; just choose Create in
the header and you're ready to go. Pages are the place to capture all your
important (and unimportant) information; start with a blank page and use it
like a word processor to add rich text, tasks, images, macros and links, or
use one of the useful blueprints to capture meeting notes, decisions, and

more.

Create blank page n Create from template

Screenshot: The create dialog

Create

Select space Teams in Space v

Select space

Choose the space
where you'll create
the content

Blank page
Start with a blank page.

Ask a question
Get answers from experts in your company.
Discuss and vote on the best answer.

2]

Page templates
Create a page from a
template or create
other types of content

File list
Upload, preview and share files with your team.

-

[_b]

Add or customise templates for the selected space

JIRA report

Pavamaiinianta DA lnfavosationn ln cnau ba sand

D@ &) @

On this page:

® Create a
page

® Collaborat
e or restrict

® QOrganise
and move

® Other page
actions

If you want to quickly create a blank page, hit the Create button in the header; if you want to create a
page from a template, hit the Create from template button.

Filter

Parent: Teams

Blog post
Share news and announcements with y
team.

Decision
Record important project decisions and
communicate them with your team.

How-to article
Provide step-by-step guidance for comg
task.

Meeting notes

Dlan simiin mmantinss and abava scaban ~e

Once you decide on a blank page or blueprint, you'll be taken straight into the Confluence editor. The editor
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is where you'll name or rename your page, add the content, and format it to look great. When you've added
some content, choose Preview to take a peek at what your finished page will look like, and choose Save wh
en you've finished your edits.

After you save you'll see the page in 'view' mode. You can re-enter the editor any time by choosing Edit or
pressing E on your keyboard.

= XConfluence Spaces -~ People Create =+

Confluence header

Create blank pages, g Teciia 7 <asie Pages « # Edit © Watch 2
pages from templates, Teams in Space Home
and ViSit spaces or yOUF @ Pages Created by Alana Grant, last modified by Admin Istrator on Jul 01, 2014
profile Blog

SPACE SHORTCUTS ©@ Welcome to your new spacel

Confluence spaces are great for sharing content and news with your

Meeting Notes ; ) : -
is the home page for Teams in Space. Right now it shows recent spa

Product Requirements but you can customize this page in anyway you like. Scan along the |
The space sidebar Team Scrum Board side to see important pages in this space.
The sidebar is for File Lists You can customize the left navigation to fit your team.
accessing pages, the PAGE TREE
blOg, and for > Meeting Notes R S b
- . ecent space activit ace contributors
administering the > Product Planning P y P
Space > Product Requirements Admin Istrator * Ryan Lee (6 days ago
) [) We're colonising Mars e Alana Grant (7 days a
> Teams in Space PR created Aug 06, 2015 e Harvey Jennings (7 da
. Admin Istrator (19 day
File Lists ¢
! ; Ryan Lee e Emma Paris (65 days
Meet the SeeSpaceEZ Team [ Summer Saturn Sizzle Blog .

Announcement updated Aug

Team Sprint Calendar 03, 2015 » view change

[J Teams in Space Analyst
Deck.pdf commented Aug

¥ Space tools ~ «“ 03, 2015

Another useful way to create a page is to use the Create from Template Macro. This macro allows
you to choose a page template, and adds a button to the page allowing one-click page creation. If
you want others to create pages using this template, this is a great option.

Collaborate or restrict

Once you've created a page, you can decide if you want to keep it private, using restrictions, or collaborate
on it with others using @mentions, sharing, and comments.

Organise and move

You can also organise pages in a hierarchy, with child and/or parent pages for closely related content. When
you navigate to a Confluence page and choose the Create button in the header, the page you're creating will
by default be a child of the page you're viewing. Have as many child pages and levels in the hierarchy as you
need to, and move pages if you want to change their location.

If you want to view all pages in a Confluence space, choose Pages in the sidebar, or choose Browse > Pag
es at the top of the screen if you're using the Documentation theme. If the space is using the Default theme,
you'll see recent updates to pages and a page tree displaying all pages in the space; if it's using the
Documentation theme, you can choose either Recently Updated, Alphabetical, or Tree view of the pages in
the space.

Each time you create a page, you're creating it in a space. Spaces are containers used to contain
pages with related content, so you can set them up for each team in your organisation, for projects, a
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combination of both, or for any reason you want to group pages together. See Spaces for more
information.

Other page actions

Copy a page

Delete a page or remove a specific version of a page

Monitor page updates and other activity through page notifications
View page history, and manage and compare versions of a page
Search page content, including attachments

Export pages to Word, PDF, HTML or XML

Like a page

I We recommend you don't use special characters in page or attachment names, as the page or
attachment may not be found by Confluence search, and may cause some Confluence functions to behave
unexpectedly.

If you rename a page, Confluence will automatically update all relative links to the page, except in
some macros. Links from external sites will be broken, unless they use the permanent URL. See Wor
king with Links for more information.

Blog Posts
Blog posts are an easy way to share announcements, journal entries, status On this page:
reports, or any other timely information. Others can join in by commenting ®* Create a
on and/or liking your blog post and, if you get enough of either, your post blog post
might make it to the popular feed on the dashboard! ®* Move a
. . . . blog post
Each space in Confluence, including your personal space, has it's own blog. A Regtr!?ct g
To view a space's blog, go to a space and choose Blog in the sidebar; if blog post
you're using the Documentation theme, choose Browse > Blog at the top of O Bralee
the screen. You'll see a list of the latest blog posts, and you can click blog post
through to earlier posts via the navigation area in the sidebar. * Exporta
blog post

Create a blog post Related pages:
You can follow the same process to create a blog post as when you create a ® Subscribe
Confluence page. to RSS
Feeds
within
Confluenc
e

You can create blog posts from the Dashboard, but you'll need to make sure * Blog Posts

you choose the space it's going to appear in in the create dialog. Macro
® Collaborati

on

®* Export
Content to
Word,
PDF,
HTML and
XML

1. Navigate to the space where you want to create your blog post
2. Choose Create in the Confluence header and select Blog post
3. Add your content and choose Publish

Blog posts can be attractive and engaging in the same way a page can be, so go ahead and add images,
YouTube clips (preferably of cats), and tables to your post to really grab your audience.

To create a blog post, you need the 'Add Blog' permission. See Space Permissions.
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Move a blog post

If you create a blog post in the wrong space, or want to reorganise your spaces, you can move an individual
blog post to another space.

To move a blog post, go to the post and choose

ane

> Move and select the new destination space.

You'll need the 'Delete blog' permission in the current space, and 'Add blog' permission in the new
(destination) space to do this.

Restrict a blog post

You can restrict a blog post so that it is only available to specific users or groups. Blog post restrictions work
in the same way as page restrictions.

To restrict a blog post prior to publishing it, choose the Unrestricted button in the footer and apply your
restrictions. To restrict a blog post after publishing, choose

LE L]

> Restrictions and apply your restrictions.
Notes:

® Notifications are sent at the point a blog post is created - removing restrictions does not trigger a new
notification.
® As a blog post has no parent, restrictions aren't inherited.

Delete a blog post

To delete a blog post, choose

> Delete. Deleting a blog post follows the same rules as deleting a page.

Export a blog post

You can export individual blog posts to PDF. This is useful, for example, if you want to email an internal blog
post to people outside your organisation.

See Export Content to Word, PDF, HTML and XML for more information on exporting blog pages to PDF.

The Editor

The Confluence editor is what you'll use to create and edit Confluence
pages, blog posts, and comments. You can enter content as you would in a
Word document, apply formatting, and embed other content and files on the

page.

Note: To edit a page, you need the 'Add Pages' permission for the space.
See space permissions. Someone may also apply page restrictions that
prevent you from editing the page.

Edit a page or blog post

You'll be taken to the editor whenever you create a new page or blog post,
or add a comment. To edit an existing page or blog post, choose Edit at the
top of a page or press E on your keyboard.

Confluence automatically saves drafts of your page as you work. If another
user begins editing the same page as you, Confluence will display a
message and will try to merge the changes when you save your page. To
see changes between different versions of the page, look at the history of
the page.
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The editor

The editor allows you to enter or change the title of your page; insert content
including text, images, and links; and format your content using the toolbar.

If you're renaming your page, there are some things you should take into
account.

Paragraph - B I U A~ ‘A~ E

Demonstration Space / Pages / Welcome to Confluence

Page title

Add your page

On this page:

Edit a
page or
blog post

® The editor
® Editor

toolbar
Restriction
s, labels,
and
notification
S

Things to
help you
work faster
Find and
replace
text
Record
change
comments
and notify
watchers

Related pages:

® Tables
® Page

Layouts,
Columns
and
Sections
Display
Files and
Images

® Links
® Symbols,

Emoticons
and
Special
Characters

S J

title and body
text

Capture the knowledge that's too often lost in email inboxes and shared network driv
team, project, or department its own space with its own permissions and theme. Kee

Create anything with a rich content editor in your web browser. Whether it's meeting
Confluence.Target feedback on any Confluence page or file — project plans, Office fil
place, so you don't waste time connecting feedback in email with your work done els
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(] @ HB~ +~ ¥ Draft autosaved at 2:16 ... Q@ 72

e

2d network drives in Confluence instead — where it's easy to find, use, and update. Give every
nd theme. Keep information organized and accessible with a flexible page hierarchy.

er it's meeting notes, product requirements, file lists, or project plans, you can get it done in
plans, Office files, images, anything — with inline comments. Feedback is in context and in one
"work done elsewhere.

What did you change? 2 Notify watchers Preview m Close

A T X N e

Editor toolbar

The editor toolbar is where you format your page layout and text, and add links, tables, images, attachments
and macros. You can also perform a find and replace, or get help using the editor by choosing the help icon

?

Screenshot: The editor toolbar

Paragraph - B I u A - ¥ - = = ~ = = = = [m] &fFiles @ Link ETable~  <+Insert~ < O
Paragraph Strikethrough & Files and images
Head‘lng 1 mo Space Home [/ Sar Subscript & Link
Heading 2 Superscript [ Attachment
Heading 3 Monospace 0 Symbol
Emoticon

Heading 4 Clear formatting ©

€3 Markup
Heading 5

= Horizontal rule
Heading 6 X

i= Task list
Preformatted

@ User mention

¥ JIRA Issue/Filter
@ Info

== Status

Gallery

‘= Table of Contents

Quote

=) Team Calendar

12 Cther macros

The Insert menu

The Insert menu is particularly useful. Use the Insert menu to include any of the following content types on
your page:

® Animage
® Alink to another Confluence page or external URL, or a link to an attachment or image
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® An emoticon or symbol, or a horizontal line
® A macro (choose a specific macro, or Other Macros, from the Insert menu)

You can also use keyboard shortcuts to insert links, images, and macros. Try out the shortcuts listed below:

® Type [ (square bracket) to insert a link.
® Type ! (exclamation mark) to insert an image or other media.
® Type { (curly bracket) to insert a macro.

Typing any of the above shortcuts will trigger the autocomplete functionality, prompting you with a list of
suggestions to finish off the entry. For more shortcuts, click the help icon

?

on the editor toolbar.

Restrictions, labels, and notifications

When editing a page, you may want to set restrictions on who can view or edit the page, or add labels to the
page to make it easily searchable.

Once you're ready to save, you can enter change comments to let others know what you've changed, and, if
you like, send an email notification to anyone watching the page.

Things to help you work faster

Auto-formatting

You can type Confluence wiki markup directly into the editor to have Confluence auto-format your text as you
type. To learn more, choose help icon
>

in the toolbar, then choose Editor Autoformatting.

Autoconvert for pasted links

When you paste certain URLs into Confluence, the editor will analyse what you're pasting and automatically
convert it into something that will display well in Confluence. Examples include:

YouTube videos

JIRA issue queries

Google Maps

Confluence pages, blog posts, comments, user statuses, user profiles.
Shared screenshot links from Skitch

And more.

Drag-and-drop for external images and files

You can drag files, like images, multimedia, Office files and PDFs, from your computer and drop them directly
into the editor. The contents of the file will be embedded into the page or blog post.

Drag-and-drop within the editor

In the editor panel, you can drag an image or a macro from one location to another on the page. Hover your
cursor over the image or the macro placeholder and your cursor changes to a drag-and-drop icon

&

. Click the image or macro and drag it to a new location.
Note: For the drag-and-drop of images and macros in the editor, Confluence supports the following
browsers: Chrome, Firefox, and Internet Explorer 10 (desktop mode).

Keyboard shortcuts
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To view the available keyboard shortcuts, choose the help icon
?

in the editor toolbar.

Find and replace text

Click the
Q

icon on the toolbar, or use the keyboard shortcut Ctrl+F (Windows) or Cmd+F (Mac OS).

Search matches are highlighted in yellow. You can step through the results one by one, replace the matching
text strings one by one, or replace all matching strings at once. Find and replace works only within the

current page.

Record change comments and notify watchers

When you finish editing a page, you can add a comment to let others know what you changed. Type a short
message in the change comments field in the footer. The comment will be visible in the page history.

If you want to send a notification to people watching the page, select Notify watchers. The change comment
will be included in the notification email. The Notify watchers checkbox remembers your last selection, so if
you choose not to notify people, the checkbox will be deselected for you next time.

What did you change? « Notify watchers Preview m Close
Symbols, Emoticons and Special Characters
You can add various symbols and special characters to Confluence pages. On this page:
You can also use them in other places that display content, such as blog ® Insert
posts, comments, and the dashboard welcome message. symbols
and
Insert symbols and special characters special
characters
1. Edit the page (if you're viewing the page, press E on your keyboard) ® Insert
2. Choose Insert > Symbol . emoticons
3. Choose a symbol to insert it Prevent
emoticons
Screenshot : Available symbols from
appearing

Related pages:

® The Editor
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Cancel

Insert emoticons

There are two ways to add an ematicon, or smiley, to your page.
By choosing an emoticon from those available:

1. Choose Insert > Emoticon
2. Choose an emaoticon to insert it

By typing a character combination:
You can insert emoticons by typing commonly-used character combinations. The below table shows the
emoticons (and other icons) available in Confluence, and the character combinations that create them:

D) :(PD) MO OEEOE®E @ (n)of ) ¢ (fg) (b) (*y)

Prevent emoticons from appearing

To undo the conversion of a character combination into an emoticon, press Ctrl+Z (Windows) or Cmd+Z (Ma
C).

To prevent Confluence from converting text to emoticons automatically, disable 'Autoformatting' in your user
profile. See Edit Your User Settings.

Move and Reorder Pages

The easiest way to set a page's location in Confluence is to navigate to the
space where you want the page to live and, if necessary, find its parent
page and choose Create. Sometimes though, you'll want to change a page's
location either while you're creating it, or after it's been created.

You can also move and reorder pages in the page tree (hierarchy).

Set page location or move a page

1. Do either of the following:

® While creating a page — choose the location icon

D'(I
-0

at the top of the page
® Once apage is created — choose

LE L
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> Move On this page:
2. Use the tabs on the left of the 'Set Page Location' dialog to help you
find the new space and/or parent page for your page (the Current * Setpage
location and New location breadcrumbs at the bottom of the dialog 'rﬁ‘;?/te'(): or

indicate the current parent page and new parent page)
3. Select Reorder if you want to move the page to a different position P

amongst the child pages (when you choose Move in the next step, * Reorder
you'll be able to reorder the page) pages
4. Choose Move (If you're reordering the child pages, choose the new within a
position for the page and choose Reorder) sSpace
®* Notes
about
permission
s

Related pages:

® Create and
Edit Pages

®* Copya
Page

® Delete or
Restore a
Page

® Orphaned
Pages

The page — along with any attachments, comments, and child pages — is moved to your chosen location.
Confluence will automatically adjust all links to the moved pages, to point to the page(s) in its new location.

When completing the New parent page field, you need to select the page suggested by
Confluence's autocomplete. Typing or pasting the page name (or using your browser's autocomplete)
won't work.

Screenshot: Setting the location or moving a page
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Set Page Location

Advanced Specify the new parent page for this page and its children by space :
Search

Recently Viewed New space: | Confluence Development

Browse New parent page: | Confluence Development home

Start typing a page title to see a list of suggestions.

Current location: Dev Team ' Dev Team ' Product requirements

New location: Confluence Development * Confluence Develop

Reorder pages within a space
You can change the location of a page within its space, and reorder pages in the hierarchy. This allows you
to:

® Move a single page, or a family of pages, to a different parent within the space.

® Reorder pages that are children of the same parent.

All links to the page are maintained. When you move a parent page, the entire hierarchy of child pages will
move too.

To move or reorder a page:

1. Go to the space and choose Space tools > Reorder pages from the bottom of the sidebar
2. Expand the branches to locate the page you want to move
3. Drag the page to a new position in the tree

If you're using the Documentation theme go to Browse > Pages > Tree and then drag the pages to a
new position as above.

Alternatively, you can choose to
order a group of child pages
alphabetically by choosing the So
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rt Alphabetically (A-Z) icon. The . . . ,
Sort Alphabetically (A-Z) icon v |=] Confluence User's Guide 7|
only appears next to the parent - , ,

page if the page family is v |=) Getting Started with Confluence ¥)
currently sorted manually.

Sort alphabetically

Undo sorting
(=) Dashboard
If you change your mind, you can .
use the Undo Sorting icon to i=) Keyboard Shortcuts
revert back to the previous
manual page order. This option is
only available immediately after sorting the page, while you're still on the Reorder Pages tab, and haven't
performed any other action.

Notes about permissions

To move a page, you need the following permissions:

® 'Add' permission on the page you're moving, and
® 'View' permission on the page's parent page. If you're moving the page to a different parent, you need
'View' permission on the new parent.

To move a page into a different space, you also need:

® 'Delete’ permission on the space you're moving from, and
® 'Add' permission on the space you're moving to.

If the page has restrictions, and you want to keep the page restrictions in the new location, you'll also need
'Restrict' permission on the space you're moving to. Alternatively, remove the page restrictions before
performing the move.

Copy a Page

If you need to duplicate the content of a page, the easiest way is to copy the Related pages:
page.

® Create and
When you copy the page it'll need to be renamed if you intend to keep it in Edit Pages
the same space — and Confluence will rename the page 'Copy of ® Move and
[originalPageName]' by default — as pages in a space must have unique Reorder
names. If you plan on moving it to another space, you can keep the same Pages

name as long as you set the location while you're creating the copy. See Mo
ve and Reorder Pages for more information.

ﬂ You need the 'Create Pages' permission in a space to copy pages within that space. See space
permissions for more information.

To copy a page:

1. Goto a page in the space and choose

> Copy
Confluence will open a copy of the page in the editor. By default, Confluence will name the page 'Copy
of [originalPageName]'.

2. Rename the page and make any other changes required in the body of the page
If you need to move the new page to a different space or a different parent, choose Location at the
bottom-left of the page. Refer to the instructions on moving a page.

3. Choose Save

Notes

® Copying a page will duplicate all of the original page's attachments and labels, but won't copy
comments from the original page.

® This method of copying a page doesn't copy the child pages. Please add your vote to issue CONF-281
4 if you'd like to see this improvement.

® You can copy an entire space, including all pages in the space (parents and children) — refer to these
instructions on copying a space.
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Delete or Restore a Page

When you delete a Confluence page, it moves to the space's trash much like On this page:
an email moves to your email trash or a file moves to the trash on your ® Delete a
computer. It's not permanently deleted, and is still retrievable, until you purg page
e the page from the trash. ® Delete a
page with
| children
Delete a page ® Restore a
. . . . deleted
When you delete a page in Confluence, you're deleting all versions of the age
page. If you only want to delete a specific version of a page, take a look at o Eu?ge
the instructions below for deleting a specific version. d
eleted
To delete a page and all its versions: pages
Go to the page and choose Related pages:

aee

® Pages and
Blogs

® Editing or
Deleting a
Page That
Won't
Render

®* Copya
Page

> Delete (confirm you want to delete the page when prompted)
Note: The Delete option will only appear if you have permission to delete
this page. See Space permissions.

If someone has applied page restrictions to the page, the restrictions may also prevent you from deleting the
page.

To delete a specific version of a page:

If you want to delete a specific version of a page, you need to be a space administrator.

I Deleting a page version is permanent. It won't be moved to the trash, so you can't restore a deleted
version.

1. Go to the page and choose

LE L]

> Page History
2. Choose Delete next to the version you want to delete (confirm the action when prompted)

Once you've deleted a version, the other versions are re-numbered where necessary. For example, if you
delete version 2, version 3 will become the new version 2.

Delete a page with children

If you delete a page that has any child pages, the child pages moves up to the nearest parent page. If you
want to keep the child pages under another parent, it's a good idea to move them before deleting their former
parent.

Screenshot: Warning when deleting a page with children
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Warning

A This page has 1 child page(s). Removing this page will result in the parent page
adopting all this pages child pages.

OK | Cancel

If you want to remove a parent page and a large number of child pages:

1. Create a temporary new space
2. Move the parent page to the new space (the child pages will move too)
3. Delete the space

Restore a deleted page

When you restore a Confluence page, you're moving it from the trash to the root of the space. You may want
to move the page to another location after you've restored it, as it won't be easy to find at the root of the
space.

You need to be a space administrator to restore a deleted page.
To restore a deleted page:

1. Go to the space and choose Space tools > Content Tools from the bottom of the sidebar
2. Choose Content Tools > Trash
A list of deleted pages and blog posts for the space displays.
3. Choose Restore for the page you wish to restore
~ |s your space using the Documentation theme?

If your space is using the Documentation theme:
1. Choose Browse > Space Admin from the header

Note: The Space Admin option appears only if you have space admin permissions, or if you're
part of the ‘confluence-administrators' group.

2. Choose Trash from the space administration options
A list of deleted pages and blog posts for the space displays.

3. Choose Restore for the page you wish to restore

To find the page after you've restored it, choose Pages to go to the root of the space (the page isn't restored
to its original position in the page hierarchy). See Move and Reorder Pages for more information.

If a new page has already been created in that space with the same name as the page you're restoring, you'll
be given an option to rename the page before it's restored.

Purge deleted pages

If you want to permanently get rid of a page, you need to purge it from the trash. That'll mean the page, and
all its versions and attachments, are gone for good.

I, Attachments of deleted pages will remain in the database (allowing potential retrieval) until the trash is
purged. Once the trash is purged, all attachments on the page(s) are permanently removed.

You need to be a space administrator to purge deleted pages.
To purge deleted pages:

1. Go to the space and choose Space tools > Content Tools from the bottom of the sidebar

Created in 2015 by Atlassian. Licensed under a Creative Commons Attribution 2.5 Australia License.


http://creativecommons.org/licenses/by/2.5/au/

Confluence 5.9 Documentation

2. Choose Trash
A list of deleted pages and blog posts for the space displays.

3. Choose Purge for a specific page or Purge All to permanently clear all deleted pages and news items

~ Is your space using the Documentation theme?
If your space is using the Documentation theme:

1. Choose Browse > Space Admin from the header

Note: The Space Admin option appears only if you have space admin permissions, or if you're

part of the 'confluence-administrators' group.
2. Choose Trash from the space administration options
A list of deleted pages and blog posts for the space displays.

3. Choose Purge for a specific page or Purge All to permanently clear all deleted pages and news

items

Add, Remove and Search for Labels

Labels are key words or tags that you can add to pages, blog posts and
attachments. You can define your own labels and use them to categorise,
identify or bookmark content in Confluence.

For example, you could assign the label 'accounting' to all accounts-related
pages on your site. You can then browse all pages with that label in a single
space or across the site, display a list of pages with that label, or search
based on the label.

Because labels are user-defined, you can add any word that helps you
identify the content in your site.

You can also apply labels (known as categories) to spaces, to help organise
your Confluence spaces. See Use Labels to Categorise Spaces.
Label a page or blog post

Any user with permission to edit a page can add labels to it. Any existing
labels appear at the bottom-right of the page, below the page content.

To add a label to a page or blog post:

On this page:

® Labela
page or
blog post

® |Labelan
attachment

®* The
Labelled
content
page

® Search by
label

® Search for
labelled
pages
using a
URL

®* Remove
labels

Related pages:

® Use Labels
to
Categorise
Spaces

® Display
Pages with
Label
Macros

1. Go to the page Labels
choose the

edit icon

4

beside the list

of labels or

press L on

your keyboard
2. Type in a new

label (existing

labels are

new label Add

label =  example * confluence-labelfilter =

Shortcut tip: In page view, pressing | also opens this dialog box

Help

Close

suggested as

you type)
3. Choose Add
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If you're editing or creating a page, and you want to add labels, choose the label icon
L
at the top of the page.

Label an attachment

1. Do either of the following:
® Go to the page that contains the attachment and choose Go to

> Attachments
® Go to the space and choose Space tools > Content Tools from the bottom of the sidebar,
then choose Attachments
You'll see a list of attachments, with any existing labels listed in the Labels column.

2. Choose the edit icon
&

beside the list of labels and type in a new label (existing labels are suggested as you type)
3. Choose Add

You can also add labels in a list of attachments displayed by the Attachments macro, by choosing the edit
icon

r

beside each label.

o If you add one or more labels to a template, that label will be copied to the page when someone adds a
page based on that template. See Creating a Template.

The Labelled content page

If you're viewing a page or post that has labels or displays the Attachments macro, you can choose any label
to go to the Labelled content page for the space. Choose Popular Labels or All Labels from the cog at the
top-right — to view the most-used labels or all labels in the space — or choose See content from all spaces fr
om the cog to view labelled content from all spaces in your Confluence site.

Screenshot: The Labelled content page

Labelled content -

See content from all spaces

Every content item in this list is tagged with all the required labels: | - 20% | | - planning FPopuIarLabeIs

To add a label to the list of required labels, choose '+ labelname’ from Related Labels. All Labels
To remove a label from the required labels, choose - labelname’ from above.

+ plugins
(2) 20% Planning

Apr 30, 2008 » Agnes Ro
20% | | planning + fedex8 | | + spike | | + editor

+ atlassian-plugins

+ proposal | | + batching
+ confluence | | + tinymce

The Popular Labels option displays a word cloud, where the bigger a label is displayed, the more popular it
is. Choose any label to view content tagged with that label.

You can also navigate to the labels view for a space by entering the following URL (replace SPACEKEY with
the space's key):
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<your. Confl uence. site>/1 abel s/l i stl abel s-al phavi ew. acti on?key=SPACEKE
Y

~ |s the space using the Documentation theme?

If the space is using the Documentation theme, access the Labelled content page by choosing Browse
> Labels

Search by label

You can use the 'l abel Text : ' prefix to search specifically for content that has a specific label. For example,
if you're looking for pages with the label ‘chocolate’, type | abel Text : chocol at e into the search field in
the Confluence header. For more examples of searching by label, see Confluence Search Syntax.

Search for labelled pages using a URL

Entering a URL with an appended label or labels is another way to search for pages with particular labels.

In your browser's address bar, enter the following URL and press enter: ht t p: / / <your . Conf | uence. sit
e>/| abel / f oo+bar

The Labelled content page will load, showing search results for pages with the both labels, 'foo’ and 'bar'.
Replace 'foo' and 'bar' with the label(s) you want to search for, and separate multiple labels with a + symbol.

Adding a label to your results:

Once you're on the Labelled content page, you can add more labels to your search by choosing them from
the Related Labels list at the top-right of the page. Each label is listed with a plus (+) sign.

If you want to remove labels from your search, locate the included labels at the top of the page and choose
the label(s) you want to remove. Each included label will be listed with a minus (-) sign.

Remove labels

When viewing page, blog post, or attachment labels, an x appears alongside each label. Choose the x to
remove the label.

If you have deleted pages that contain a label, you may need to purge the deleted pages from the
space's trash to ensure that the label disappears too.

Display Pages with Label Macros

Using labels and macros, you can categorise pages and then display them Related pages:
in Confluence in a number of ways.

* Add,
As an example, you could label all pages relevant to the marketing team Remove
with 'marketing’, and then add more specific labels like 'online’, 'mobile’, and and
‘physical’ to different pages where required. Search for
You could then use the Content by Label Macro to display different o k/lilbcerlcfs
combinations of pages with the marketing label. Some combinations you O ke ek
could use would be: o
® All pages with the label 'marketing'. Categorise
® Pages with all of the following labels: 'marketing’, 'mobile’, and Spaces
‘online’.
® Pages with either the 'mobile’ or 'online' labels, in the Marketing
space.

There are a lot of ways you can filter the content, making it easier for you to find content that's relevant to
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you.

Other label macros
Here are some other macros that use labels, and can help you categorise and display your content.

Navigation Map macro

The Navigation Map macro renders the list of pages associated with a specified label as a navigation map.

Related Labels macro

The Related Labels macro lists labels commonly associated with the current page's labels.

Content by Label macro

The Content by Label macro displays a list of content marked with specified labels.

Content Report Table macro

The Content Report Table macro displays a set of pages and blog posts in tabular format, based on the
specified labels.

Labels List macro

The Labels List macro lists all labels of a space, grouped alphabetically.

Recently Used Labels macro

The Recently Used Labels macro lists labels most recently used in a specified scope - global (site), space, or
personal.

Popular Labels macro

The Popular Labels macro displays popular labels in a list or in a heatmap (also called a cloud).

Drafts

A draft is a 'snapshot' of unsaved page content, which Confluence creates On this page:
automatically at regular intervals while you're creating or editing a page or

blog post. Drafts can minimise the loss of work if your Confluence site ® View drafts

experiences a problem, as you can retrieve the page content from the last * Resume

saved draft. editing a
draft

By default, Confluence saves a draft of your page once every thirty seconds, ® View your

however, a Confluence administrator can configure how often drafts are unsaved

saved. In addition, whenever you edit a page and then move to another changes

screen, Confluence will automatically save a draft. Each new draft replaces

the previously saved draft. Related pages:

Each time Confluence saves a draft, it displays a message and the time of * Configurin
the last save, to the right of the undo and redo buttons in the editor g the Time
toolbar. When you edit a page that wasn't successfully saved, Confluence Interval at
will let you know that a version of the page you're editing wasn't saved, and which
will give you the option to resume editing it from the draft. [S);?/f(t:(’j el
Screenshot: Message displaying the time when the draft was last saved ® Concurrent
Editing and
EH~ 4+~ | ¥) Draft autosaved at 3:44 PM Merging
Changes
®* Your
Profile and
Settings

More about drafts:

Created in 2015 by Atlassian. Licensed under a Creative Commons Attribution 2.5 Australia License.

95


http://creativecommons.org/licenses/by/2.5/au/

Confluence 5.9 Documentation

® You only have access to drafts of pages you've been working on, and whose content hasn't yet been
saved.

® You can't create a draft explicitly.

® Your drafts are listed in the 'Drafts' tab of your profile.

® Once you've resumed editing a draft, or chosen to discard it, the draft is removed from your drafts tab.

View drafts

Your drafts are listed on the Drafts tab of your user profile. To see your drafts, choose your profile picture a
t top right of the screen, then choose Drafts.

Resume editing a draft

There are two ways to resume editing an unsaved page or blog post:

1. Using your drafts view. To resume editing a draft from this view:
a. Choose your profile picture at top right of the screen, then choose Drafts.
b. Choose Resume Editing next to the appropriate draft to resume editing that draft.
ﬂ If you hadn't entered a page title, the draft will be named 'Untitled'.

2. If you create a new page or blog post and didn't save it, but a draft is saved, when you next add a
page or blog post in that space, Confluence will ask you if you want to resume editing the page. If you
choose resume editing, the draft and its unsaved content will be restored, allowing you to continue
editing it.

What happens if I'm editing the draft of a page that has since been updated?

Confluence will display a message informing you that you're editing an outdated page. If there are no
conflicts between the two versions, Confluence will give you the option to Merge and Resume editing.

If there are conflicts, Confluence will give you the option to View the Conflict or to Discard your changes.

View your unsaved changes

When you edit a page or blog post, you can view any 'unsaved' changes you've made since the last
automatically saved draft, by clicking the Draft autosaved at message in the toolbar.

Screenshot: Segment of the unpublished changes window

Unpublished Changes for 'Sample Page' Help

Two penguins find themselves together on an ice floe, drifting helplessly into warmer waters. The penguins are very fond of each
other. Suddenly cra-a-a-a-ck the ice flow splits in half, right between the penguins. As they drift apart, one penguin sadly waves a
flipper and calls out "Chocolate milk!"

What happens Do you know what happened next?

@j Image Removed

Close

Concurrent Editing and Merging Changes
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Sometimes, another user may edit the same page as you're editing, at the Related pages:
same time you do. When this happens, Confluence will do its best to ensure .
nobody's changes are lost. Page
History
How will | know if someone else is editing the same page as | am? and Page
. " - Compariso

If another user is editing the same page as you, Confluence will display a n Vie?/vs
message above your edit screen letting you know who the other user is and

. ® Drafts
when the last edit was made.
Screenshot: Notification of Simultaneous Page Editing

(D This page is also being edited by Ewan User. Your changes will be merged with theirs when you save. x

What happens if two of us are editing the same page and the other user saves before | do?

If someone else has saved the page before you, when you click Save, Confluence will check if there are any
conflicts between your changes and theirs. If there are no conflicting changes, Confluence will merge the
changes.

If there are conflicts, Confluence will display them for you and give you the option to:

® Continue editing - Continue to edit the page; useful if you want to manually merge the changes.

® Overwrite - Replace the other person's edits with yours (their edits will not be included in the latest
version).

® Cancel - Discard your changes and exit the editor, keeping the other person's edits.

Example Scenario
For example, Alice and Bob both edit the same page at the same time.

If Alice clicks save before Bob, Bob is now effectively editing an out-of-date version of the page. When Bob
clicks save, Confluence will examine his changes to see if any overlap with Alice's. If the changes don't
overlap (i.e. Alice and Bob edited different parts of the page), Bob's changes will be merged with Alice's
automatically.

If Bob's changes overlap with Alice's, Confluence will display an error message to Bob showing where Alice
has changed the page, and giving Bob the options to overwrite Alice's changes with his own, to re-edit the
document to incorporate Alice's work, or to cancel his own changes entirely, maintaining Alice's changes.

Page Restrictions

Page restrictions allow you to control who can view
and/or edit individual pages in a space. So, if you're
working on a page that shouldn't be viewed by just
anybody, it's easy to lock it down to the people who
need to know. You can add restrictions for
individuals or for Confluence groups.

On this page:
® Restrict a page or blog post
® Remove restrictions from a page
® Request and grant access to view
a restricted page
® View all restricted pages in a
To add or remove page restrictions, you'll need to space
have permissions to edit the page and 'Restrict’ or ®* Notes
'Admin' permission in the space.

Restrict a page or blog post

To restrict who can view or edit a page or blog post:

1. Chose the Restrictions

Y

icon at the top of the page.
2. Choose whether you just want to limit only who can Edit, or who
can View and / or Edit
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3. Enter users or groups then click Add to add them to the list. o
If you chose Viewing and Editing restricted you can further Restrictions
specify for each person or group whether they can edit or just
view the page.

L. #' Mo restrictions - Everyon
4. Apply the restrictions.

&' No restrictions

You can add as many users and/or groups as you need. Evaryona can view and adit
' Editing restricted
Everyone can view, only some can edit
& Viewing and editing restricted
Only some can view or edit

Right now everyone cal
Use the dropdown aboy

Learn more about restri

In this example, some users and groups can view only, others can also edit, plus there are inherited
restrictions that might impact who can view the page.

Restrictions Help
& Viewing and editing restricted - Only some people can view or edit this page. There are inherited view restrictions.

Watch out
| ifl Edith Tom x| | & Valter Fatia X | [ administrators % Can view K Add Restrictions on
Speed it up — other pages can
Apply the same {2} Everyone Can't view affect this one
restriction to r; Rachel Robins Can view and edit
multiple people _

Giles Brunning Can view and edit v Remove .
and groups & Be specific
g developers Can view v Remove Choose exactly

what each group
or person can do

Who is ‘everyone'?

When we say "everyone can view this page" everyone means all the people who can view the page by
default. There's two things that can affect who can view a page - the space permissions, and view restrictions
on any parent pages that are being inherited.

Restrictions don't override a person's space permission. For example, if you say a person 'can view' in the
restrictions dialog and they don't have 'view' permissions for the space, they won't be able to see the page.

How do inherited restrictions work?

View restrictions are inherited, which means a restriction applied to one page will cascade down to any child
pages. Edit restrictions are not inherited, which means pages need to be restricted individually.

The restrictions dialog will tell you when there are inherited restrictions that might affect who can view your
page.

Here's the basics:

® |f you restrict viewing to a person or group, only they will be able to see that page and all its child
pages (unless there are further restrictions on the child pages)

® |f you restrict editing to a person or group, they'll be able to see and edit that page, plus see its child
pages.

® Parent pages (higher up in the page hierarchy) can have their own view restrictions that may prevent
people from viewing your page.

If the person you've listed as a viewer or editor can't see the page, check to make sure:

® they have View space permission for that space, or
® there's no view restriction on a page higher up the page hierarchy that prevents them seeing any
children of that page.
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View current page restrictions

The restrictions icon at the top of the page gives you a clue that the page has restrictions:
“ Viewing this page is not restricted. Everyone can see this page (but editing may be restricted).
E The page is restricted. Click the icon to see the list of who can view and edit this page.

“ The page is inheriting restrictions from another page. Click the icon then choose Inherited
Restrictions to see a list of pages this page is inheriting restrictions from.

Remove restrictions from a page

Removing restrictions is easy. Choose No restrictions to remove all restrictions, or click Remove next to
each person or group in the list if you want to change who can view or edit the page.

Request and grant access to view a restricted page

If you navigate to a page that
you're not able to view You do not have permission to view the page.
because it has page Request access below, and you will receive an

restrictions appllgd (for email notifying that your access has been granted.
example from a link or page

URL) you may be able to

request access to the page.

To request access to a
restricted page:

1. On the restricted page
choose Request access
2. Wait for an email confirming that access has been granted

If the request access message doesn't appear, you're not able to request access for that particular page.
This usually is because the page has inherited view restrictions from a parent page, or you may not have
adequate space permissions.

To grant access to a restricted page:

1. Inthe request access email, Pages @&
choose Grant access sarr
:2;;' gi;a;?j?atlgéhvi":?;;ggd oo Ewan User requested access to view
with the access request the page

2. Choose Grant access @ w Grantaccess fo the page. or deny it explicitly

our tean|
Grant access | Deny ¥
The user will receive an email
confirming that access has been
granted.

This process is the same as navigating to

ane

> Restrictions and adding a 'View' restriction for the user.

Who can grant access?

To grant access to a restricted page you will need to have permission to edit that page, and have the
'Restrict' or 'Admin’ permission for the space.
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Confluence will send an email to a user who can grant permissions. The sequence that Confluence will use
to search for the appropriate user is:

1. The last person to edit the page

2. All non-admin users that can set permissions on the page (given that an admin user can always set
permissions)

3. The page creator

4. All the space administrators

Confluence will try each of these roles in turn, emailing the first user that has appropriate permissions.

View all restricted pages in a space

You need space admin permissions to view the list of restricted pages in a space.
To view restricted pages:

1. Go to the space and choose Space tools > Permissions from the bottom of the sidebar
2. Choose Restricted Pages

If your space uses the Documentation theme:
1. Choose Browse > Space Admin from the header

Note: The Space Admin option appears only if you have space admin permissions, or if you're part of
the 'confluence-administrators' group.

2. Choose Restricted Pages in the space administration options

Screenshot: Restricted pages in a space

Permissions =~ Restricted Pages

This report shows all the pages where access is restricted to specific groups or users by page level permissions

Title (Space) Type Permitted Creator Created Operations
User/Group
[ Induction plan - Edit leah Leah Admin  Feb 18, 2013 iy

Sophie User (Stars)

[% Induction plan - Edit leah Leah Admin Feb 18, 2013 -
Ewan User (Stars)

[% Draft status report View admin Rach Admin Feb 18, 2013 -
(Stars)
View sophie Rach Admin Feb 18, 2013 -
Notes

® You can't exclude yourself
When you apply a restriction, Confluence will automatically add you to the list. You can't remove
yourself from this list.

® Space Admin and System Administrator access to restricted pages
Users with 'Admin’ permissions in a space, or users with the System Administrator global permission
can remove restrictions from pages, even if the page restriction prevents them from viewing the
page. Goto Space Administration > Restricted Pages.

Links
You can create links to pages, blog posts, anchors, attachments, external
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websites, JIRA issues and more. Links can be text or images, and can be
added in many different ways.

Links to pages within your Confluence site are relative, which means that
you can move pages and rename pages without breaking links.

This page explains the most common ways to create links.

Insert a text link

To insert a link on a page:

1.

5.

Select some text or position your cursor where you want to insert the
link

Choose Link on the toolbar or use the keyboard shortcut Ctrl+K
Select a page, blog post or attachment, or enter an external URL (see
below for how to link to particular types of content)

Enter or modify the link text (this is the text that will appear on the
page. If this field is left blank, the page name or URL will be used as
the link text.)

Choose Insert

Alternatively you can type [ followed by the page or attachment name. Autoc
omplete will suggest matching items for you.

You can also paste a URL directly onto your page. Confluence will automatically create the link, and if the

URL is for a page in the current site, the page name will be set as the link text.

Insert an image link

N

Modify a link

1.
2.
3.

On this page:

® |nserta
text link

® |nsert an
image link

®* Modify a
link

®* Remove a
link

® Linkto
specific
types of
content

® Linkto
Confluenc
e pages
from other
websites

® Linktoa
comment

® Using
shortcut
Links

®* Trackback

Related pages:

® Anchors

® |nserting
JIRA
Issues

®* The Editor

Select an image on your page

Choose Link on the Image Properties toolbar
Select a page, blog post or attachment, or
enter an external URL (see below for how to
link to particular types of content)

Choose Insert

150px + @ @ original Border

| ink

Select the link text or image
Choose Edit from the link properties toolbar Click to find out more
Modify the link and choose Save

=0 to Link

Edit | Unlink

Remove a link

1.
2.

Select the link text or image
Choose Unlink from the properties toolbar

Created in 2015 by Atlassian. Licensed under a Creative Commons Attribution 2.5 Australia License.

101


http://creativecommons.org/licenses/by/2.5/au/

Confluence 5.9 Documentation

Link to specific types of content

Confluence supports many methods for creating links. Some of the common ones are listed here.

Type of link

Link to a page

Link to a page in
another space

Link to a blog post

Link to an
attachment or
image on this page

Link to an
attachment on
another page

Link to a website

Link to an email
address

Link to an anchor
on a page

Ways to do this

Choose Link > Search then enter part of the page name.

Choose Link > Recently viewed and select a page from the list.

Type [ and enter part of the page name then select the page from the list.

Paste the URL of the page onto your page (Confluence will automatically create the
link).

Choose Link > Search enter part of the page name and select All Spaces from the
drop down.

Choose Link > Advanced then enter the space key followed by the page name spa
cekey: nypage.

Type [ and enter part of the page name then select the page from the list.
(you can hover over each suggestion to see which space the page is from).

Choose Link > Search and enter part of the blog post name.

Type [ and enter part of the blog post hame then select the blog post from the list.

Choose Link > Attachment then upload or select an attachment from the list.

Type [ and enter part of the attachment file name then select the attachment from
the list.

Choose Link > Search and enter part of the attachment name.

Type [ and enter part of the attachment file name then select the attachment from
the list
(you can hover over each suggestion to see which space the page is from).

Choose Link > Web Link then enter the website URL.

Type or paste the URL onto the page (Confluence will automatically create the link).

Choose Link > Web Link then enter the email address.

Type or paste the email address onto the page (Confluence will automatically create
a 'mailto:' link).

Choose Link > Advanced then enter the anchor name in one of the formats below.
For an anchor on this page: #anchor name.
For an anchor on another page in this space: page nane#anchor nane.

For an Anchor on another page in another space: spacekey: page name#anchor
nane.

See Anchors for more information on using anchors.
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Link to a heading Choose Link > Advanced then enter the heading in one of the formats below.
on a page Heading text is case sensitive and must be entered without spaces.

For a heading on this page: #MyHeadi ng.
For a heading on another page in this space: Page Nane#MyHeadi ng.

For a heading on another page in another space: spacekey: Page
Name#MyHeadi ng.

Be aware that these links will break if you edit the heading text. Consider using the
Table of Contents macro or an Anchor instead.

Link to a comment  Go to the comment, right click the Date at the bottom of the comment and copy the
on a page link. Paste the link directly onto your page or choose Link > Web Link and paste in
the URL.

Type [$ then enter the Comment ID ('12345' in this example): [ $12345]

Link to an Choose Link > Advanced then enter the new page name (a page will be created on
undefined page click).
(a page that does

not exist yet) Type [ then enter the new page name then choose Insert link to create page .

See Undefined Page Links for more information on undefined pages.

Link to a personal Choose Link > Search then enter the user's name and select their personal space
space or user homepage or their profile from the list.
profile

Type [ then enter the user's name and select their personal space homepage or
their profile from the list.

Link to a JIRA issue Paste the JIRA issue URL - Confluence will automatically create a JIRA Issue
(where Confluence  macro.

is connected to

JIRA)

Link to Confluence pages from other websites

The best way to link to a Confluence page from outside Confluence, for example on a website or in an email
message, is to use the tiny link which is a permanent URL. This ensures that the link to the page is not
broken if the page name changes.

To access the permanent URL for a page:

1. View the page you wish to link to.

2. Choose Tools > Link to this page.

3. Copy the Tiny Link.

4. Use the tiny link in your website or email message.

You do not need to use the tiny link to link to pages within your Confluence site. Confluence automatically
updates links when you rename or move a page to another space.

If you want to link to specific content such as anchors, headings or comments you need to use the following
link syntax. Note that there are no spaces in the page name, anchor name or heading text.

In the examples below, the anchor name is 'InsertLinkAnchor' and the heading text is 'Insert a link'.

Purpose Link syntax
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Link to
an
anchor
(from an
external
website)

Link to a
heading
(from an
external
website)

Link to a
comment
(from an
external
website)

http:// nyconfl uence. com di spl ay/ spacekey/ pagenane#pagenane- anchor name
Example from this page:

https://confl uence. atl assi an. com di spl ay/ DOC/ Wor ki ng+wi t h+Li nks#Wor ki ngwi

http://nyconfl uence. com di spl ay/ spacekey/ pagenane#pagenane- headi ngt ext
Example from this page:

https://confl uence. atl assi an. com di spl ay/ DOC/ Wor ki ng+wi t h+Li nks#Wor ki ngwi

http://nyconfl uence. com di spl ay/ spacekey/ pagenane?f ocusedConment | d=conmretl

Example from this page:
htt ps://confl uence. atl assi an. coni di spl ay/ DO Wor ki ng+wi t h+Li nks?f ocusedC

Some things to note when linking to anchors from a website or email message:

® The page name is repeated in the URL, after the # sign. The second occurrence of the page name is
concatenated into a single word, with all spaces removed.

® There is a single dash (hyphen) between the concatenated page name and the anchor name.

® The anchor name in the full URL is concatenated into a single word, with all spaces removed.

® The anchor name is case sensitive. You must use the same pattern of upper and lower case letters as
you used when creating the Anchor.

Link to a comment

You can add a link to a comment by using the comment URL (a permanent link), or by using wiki markup to
link to the Comment ID.

To find out the comment URL and comment ID:

1. Go to the comment you wish to link to
2. Choose the Date at the bottom of the comment and examine the URL

The number after ‘comment-' is the Comment ID. An example is shown here.

htt ps://confl uence. atl assi an. contf di spl ay/ DOC/ Wor ki ng+wi t h+Li nks?f ocus
edConment | d=368640803#conment - 368640803

You can use wiki markup directly in the editor to link to a comment. Enter [$ followed by the Comment ID, for
example [ $12345] where '12345' is the Comment ID.

Using shortcut Links

If you have configured shortcut links on your Confluence site, then you can link to an external site using a
shortcut link that looks like this:CONF- 17025@ i r a.

Our Confluence site (where this documentation is housed) is configured to allow shortcut links to our JIRA
site, using the shortcut @ i r a. So the shortcut link CONF- 17025@ i r a produces this link.

To add a shortcut link using the 'Insert Link' dialog:

1. Choose Link > Advanced and enter or paste the shortcut link into the Link field (shortcut links are
case-insensitive)

2. Modify or enter link text (this is the text that will appear on the page)

3. Choose Insert
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You can also type '[' and choose Insert Web Link > Advanced to enter a shortcut link.

See Configuring Shortcut Links for more details.

Trackback

Trackback enables two sites can stay informed each time one site refers to the other using trackback 'pings’.

In Confluence, Trackback can be enabled by a site administrator in the Administration Console. When
Trackback is enabled, any time you link to an external webpage that supports Trackback Autodiscovery,
Confluence will send a Trackback ping to that page to inform it that it has been linked to.

Confluence pages also support Trackback Autodiscovery, and when Trackback is enabled, can receive
trackback pings sent by other sites.

To see who has sent a Trackback ping to a Confluence page:

1. Go to the page
2. Choose Tools > Page Information

Any Trackback pings the page has received will be listed under the page's Incoming Links.

Confluence incoming trackback pings only work with referenced pages that are public (anonymously

viewable).
Anchors
- . . On this page:
You can use anchors to enable linking to specific locations on a page, and
they can be especially useful for allowing your readers to navigate to ® Step 1:
specific parts of a long document. Anchors are invisible to the reader when Create the
the page is displayed. anchor
Th two steps to usi hor: * Step2:
ere are two steps to using an anchor: ey
Step 1: Create the anchor link to the
anchor
Step 2: Create a link to the anchor * Notes

Related pages:

Step 1: Create the anchor
® Links

Add the Anchor Macro to mark the location you want to link to:

1. Do either of the following in the Confluence editor:
® Choose Insert > Other Macros, then find and select the
Anchor macro
® Type { and the beginning of the macro name, then select the
Anchor macro
2. Enter the Anchor Name (For example, 'bottom' or 'important
information')
3. Choose Insert

Macro options (parameters)

Parameters are options that you can set to control the content or format of the macro output. Where the
parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro
browser, it will be listed below in brackets (exanpl e).

Parameter Default Description
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Anchor None This is the anchor name that you will use when creating the link.

Name . .
® The anchor name can include spaces. Confluence will remove the spaces

automatically when building a URL that points to this anchor.

® The anchor name is case sensitive. You must use the same pattern of upper
and lower case letters when creating the link as you used when creating the
Anchor macro.

Step 2: Create a link to the anchor
You can link to an anchor from:
® A page on the same Confluence site. The link may be on the same page as the anchor, another page

in the same space, or a page in another space on the same Confluence site.
® Another web page or another Confluence site, using a specifically formatted URL.

Link to an anchor on the same Confluence site:

1. Select some text or position your cursor where you want to insert the link
2. Choose Link in the toolbar or press Ctrl+K
3. Choose Advanced and enter the anchor name in the Link field, following the format below.

Anchor location Link syntax for anchor Examples

Same page #anchor name #bottom

#important information

Page in same space  page hame#anchor name My page#bottom

My page#important information

Page in different spacekey: page nane#anchor DOC:My page#bottom

space name )
DOC:My page#important

information

ﬂ The anchor name is case sensitive, so you need to use the same pattern of upper and lower case
letters as you used when creating the Anchor macro. You need to enter page and anchor names with
spaces when you link to them in the same Confluence site.

4. Enter or modify the Link Text (this is the text that will appear on the page. If this field is left blank, the
page name or URL will be used as the link text)

5. Choose Save

Screenshot: The 'Advanced’ option in the link dialog

Edit link Help

Search Here you can insert a link into the page using wiki markup.

Recently viewed

Attachments Link | #goodstuff

To insert a link to a new page, type in the desired page title.

Web link
To insert an anchor link, type #anchorname.
Advanced
Link text | Link to the good stuff!
Browse
Hint: type "[" in the editor to see a list of suggested pages and insert a link. Save | Cancel

Link to an anchor from another web page or another Confluence site:

Use a full URL in the following format:
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Link syntax Examples
http:// nyconfl uence. com di spl ay/ spacekey/ pagenane#pagenane- anchor nanme http://myconfl

http://myconfl

Notes about the full URL:

® The page name is repeated in the URL, after the # sign. The second occurrence of the page name is
concatenated into a single word, with all spaces removed.

® There is a single dash (hyphen) between the concatenated page name and the anchor name.

® The anchor name in the full URL is concatenated into a single word, with all spaces removed.

® The anchor name is case sensitive.

Notes

® Table of contents on a page: Consider using the Table of Contents Macro to generate a list of links
pointing to the headings on the page. The list of links will appear on the page, and will be
automatically updated each time someone changes the wording of a heading.

® Linking to headings: You can link directly to the headings of a page. See Links. However, if
someone changes the wording of a heading, those direct links will be broken. Use the Anchor macro
to ensure a lasting link within the body of a page.

® Site welcome message: If you are adding an anchor to a page that you are using in the site welcome
message, you can only link to that anchor from another page. Internal links within that page will not
work.

® Templates: When you are previewing a template, a link to an anchor is displayed as a 'broken’ link.
However, when you create a page using the template the resulting page will have the correct link.

Tables
Confluence pages can include multi-row and On this page:
multi-column tables. You can highlight cells, rows ® |nsert a table
and columns in different colours. When viewing the ® What you can do with your table in
page, people can sort the table by clicking the the editor
column headers. ® Shortcut keys

® Sort the table in view mode

o o . o
Insert a table Sticky table headings in view

mode
To create a table: Related pages:
1. While editing the page, place your cursor at ® Page Layouts, Columns and
the point where you want to insert the table. Sections
2. Choose Table on the toolbar. ® The Editor

3. A dropdown menu will appear, showing a
table with a variable number of rows and
columns. Click in a cell to set the number of
columns and rows for your table.

4. Add content and more rows and columns as
needed. See below for guidelines on what
you can do with your table in the editor.

Screenshot: Inserting a table with 3 rows and 3 columns

HE Table -

Jx3d
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What you can do with your table in the editor

While editing a page, place your cursor inside a table to see the table toolbar. Here's a summary of the tools:

él- ?_ = Rows
®* |nsert rows before or after the current
row
= -E] -E] ® Delete the current row
® Cut, copy and paste the current row
® Mark a row as a header row (shaded

BB with bold text)

Columns

® |nsert columns before or after the
current column

L 7 M * Delete the current column
® Cut, copy and paste the current column

Mark a column as a header column

EH (shaded with bold text)
— Cells
B
®* Merge selected cells

® Split selected cells

| i v| * Change cell colour

Table

® Delete table
¢ Add a numbering column to
automatically number each row

TABLE SETTINGS

Insert numbering column
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Shortcut keys

Windows Action

Ctrl+Shift+c Copy the current table row, or the selected rows.

Ctrl+Shift+i Insert a table. (Opens the Insert Table dialog.)

Ctrl+Shift+v Paste the table rows from your clipboard, placing them above the

current row.
Ctrl+Shift+x Cut the current table row, or the selected rows.
Alt+Up Arrow  Add a row above the current row.

Alt+Down Add a row below the current row.
Arrow

For more editor keyboard shortcuts, see Keyboard shortcuts.

Sort the table in view mode

Mac OS X
Cmd+Shift+c
Cmd+Shift+i

Cmd+Shift+v

Cmd+Shift+x
Alt+Up Arrow

Alt+Down
Arrow

When readers view a table on a page, they can sort the table by clicking the sort icons in the header row.

Screenshot: A colourful, sortable table

Document Author - Reviewer
Getting Started Sandy Joan
Installation Guide  Sandy Pete

Upgrade Guide Juan Lise

Sticky table headings in view mode

In some instances table header rows will stick to the top when you're viewing a page, making those really lon

g tables easier to read. There are a few exceptions though. Table headers aren't sticky when:

the space is using the documentation theme.
your table is inside a page layout, or inside another table.

your table contains another table, that has its own header row.

Add, Assign, and View Tasks

Keep track of the things that need to get done with tasks. With the ability to
give each task an assignee and due date, and plenty of ways to see your
tasks, you can make sure nothing slips through the cracks.

Add a task

You can add tasks on any page in Confluence. For example, you might add
tasks under action items on a meeting notes page, or in a project planning p
age — anywhere you need a lightweight task management solution.

To create a task:

your table has no header row or there are cells in the top row that aren't marked as headers.
your table has a header column, instead of a header row, and scrolls horizontally.

On this page:
®* Add atask
®* View tasks
®* Notes
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1. In the editor, choose the Task list
r 4

button or use the keyboard shortcut [ ]
2. Start typing your task — @mention someone to assign the task to them, and type // and choose a due
date

The first person you mention in a task is the assignee; you can even assign tasks to yourself.

Note: If you assign a task to someone who doesn't have permission to view the page or space, they won't
see the task.

View tasks

There are a number of ways to keep track of tasks assigned to you, or tasks you've created for others.

On a page

The simplest way to see a task is on the page it was originally created on. It's easy to see if a task is
complete, who it's assigned to, and when it's due. If a task is nearing or passed its due date, the colour of the

date will change (red for overdue, orange for due in the next 7 days).

Action items

¥ |@Rach Admin| o decide on name of project space
Ewan User to finish creating the new project space by (5115 Apr 2014
¥ |@ Sophie| to investigate venues for offsite and prepare costings for at least three
different options by [ 02 Apr 2014

Sophie User| distribute agenda for offsite = 23 Apr 2014

In your profile

The tasks page in your profile gives you a place to see all the tasks relevant to you. Easily keep track of the
status of tasks assigned to you, and tasks you've created and assigned to others.

To view the tasks page, go to Profile > Tasks. Use the filters to show tasks that were assigned to you or
created by you in the last 6 months, and toggle between complete or incomplete tasks.

Assigned to me = Created by me Incomplete  Complete
Description Due date Task appears on
Organise venue for project offsite |07 Apr 2014 |@ Sophie User 07 Apr 2014 2014-04-09 Meeting notes
Organise customer interviews - |@ Sophie User| |[z]17 Apr 2014 17 Apr 2014 Project Offsite
Sophie  schedule a follow up meeting £ 30 Apr 2014 30 Apr 2014 2014-03-25 Meeting notes
Sophie| to prepare talk about new campaign Project Offsite
1 For a custom view create a task report

If you need to see more than just your last 6 months of tasks, use a Task Report.

In a Task Report

If you're looking for a more custom view of tasks, the Task Report blueprint is a great way to track tasks
assigned to a specific team or project.

To create a task report:
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1. Choose Create > Task Report
2. Select the type of report:

® Assigned to my team — for tasks assigned to particular people.
®* In my project — for tasks that appear in a specific space or page.
® Custom - for a wide range of filtering options, including by date or page label.

3. Follow the prompts to create the report.

This blueprint uses the Task Report Macro. You can also choose to use this macro on an existing page, for

example, on a project or team space homepage.

Meeting actions this month
Created and last modified by Rach Admin a minute ago
Description Due date ~
Leah Admin fo schedule a follow up meeting
Ewan User|to finish creating the new project space by |10 Mar 2014 10 Mar 2014
Josh User add designs to the project space's file list by (5102 Apr 2014 02 Apr 2014

Assignhee
Leah Admin
Ewan User

Josh User

Task appears on
2014-03-25 Meeting notes
2014-03-25 Meeting notes

2014-03-29 Meeting notes

Notes

® The date picker can be triggered by typing // or by typing a date in the format dd/mm/yyyy or
dd-mm-yyyy. Typing other date formats in the editor won't trigger the date picker.

® Personal Tasks (created in the Workbox in older versions of Confluence) don't appear in the Tasks
view or Task Report. To migrate any incomplete personal tasks, go to Workbox > Personal Tasks an

d follow the prompts.

® The wiki markup based Tasklist Macro has been removed from the macro browser. If you have a
Tasklist macro on a page it will continue to work, but you will be unable to add new Tasklists using this

macro.

Autocomplete for links, files, macros and mentions

When using the Confluence editor, you can type a trigger character or press
a keyboard shortcut to see a list of suggested links, files or macros to add to
your page, or to mention another user (and automatically notify them of this).

Summary of autocomplete

What you want  Trigger Keyboard Description

to do character shortcut

Add a link on [ Ctrl+Shift+K See a list of

your page suggested
pages or other
locations to link
to from your
page. More...

Display an ! Ctrl+Shift+M See a list of

image, video, suggested

audio file or images,

document on multimedia files

your page and documents

to embed in your
page. More...
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Add amacroon  {
your page

Notify another @
user by email

that you have
mentioned them

on your page

Using autocomplete for links

Type T, or press Ctrl+Shift+K, to see a list of suggested pages or other locations to link to from your page.
You can link to pages, user profiles, images, documents and other file attachments.

To autocomplete a link:

1. Edit the page.

None

None

See a list of
suggestions as
you begin typing
a macro name.
More...

See a list of
suggested users
to mention. Mor
e...

2. Click where you want to insert a link and do one of the following:
® Type T and then the first few characters of the page title, user's name, image name or file

name.

® Type the first few characters of the page title, user's name, image name or file name (or select

On this page:

Summary
of
autocompl
ete

Using
autocompl
ete for
links
Using
autocompl
ete for
images,
videos,
audio files
and
documents
Using
autocompl
ete for
macros
Using
autocompl
ete for
mentions
Cancelling
autocompl
ete
Enabling
and
disabling
autocompl
ete
Ignoring
autocompl
ete

Related pages:

® Links
® Using

Images

® Macros
® Keyboard

shortcuts
Your
Profile and
Settings
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relevant text) and then press Ctrl+Shift+K.
3. Click the relevant link from the list of suggestions.

If the item you need is not in the list, either:

® Choose Search for 'xxx' to continue looking for the page within Confluence, or
® Choose Insert Web Link to insert a link to an external web page using the link browser.

Screenshot: Autocomplete for a link

| want to add a link to [ sam|

Link suggestions
(5] sample Page
fZ) Sample Space

Q, Search for ‘'sam’
& Insert Web Link

+ Insert Link to Create Page

Using autocomplete for images, videos, audio files and documents

You can use the autocomplete as a fast way of embedding images, videos, audio files and documents into
your page. Type an exclamation mark or press Ctrl+Shift+M to see a list of suggested images, multimedia
files and documents to display on your page. You can use autocomplete to embed the following file types:

® Images — any format that Confluence supports.

® Videos, audio files and all multimedia formats that Confluence supports.

® Office documents supported by the Confluence Office Connector: Word, Excel and PowerPoint.
®* PDF files.

ﬂ' Autocomplete works most efficiently for files that are already attached to the Confluence page.
To embed an image, video, audio file or document:

1. Edit the page.
2. Click where you want to insert the image, video, audio file or document and do one of the following:
® Type 'I"and then the first few characters of the image, file or document name.
® Type the first few characters of the name of the image, file or document (or select relevant text)
and then press Ctrl+Shift+M.
3. Choose the relevant file from the list of suggestions.

If the item you need is not in the list, either:

® Choose Open Image Browser to find images and documents using the image browser, or
® Choose Insert Other Media to embed videos, audio and other multimedia files using the macro
browser. Insert the 'Multimedia' macro to display your multimedia file.

Screenshot: Autocomplete for an image or document
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| want to add an image !
Media suggestions
&5 iBugs. gif
eg'}ga iAngryNerdsGr.png

i DefaultSpaceLogo_AngryNerds.png

Open Image Browser

2L Insert Other Media

Using autocomplete for macros

Type '{' to see a list of suggested macros to add to your page.

Autocomplete provides access to all available macros in your Confluence site, including any user macros that
your administrator has added and made visible to all.

o You need to know the name of macro. Autocomplete for macros will only match the name of the macro,
not the description.

To autocomplete a macro using '{":

1. Edit the page.

2. Click where you want to insert the macro.

3. Type '{ and then the first few characters of the macro name.

4. Choose the relevant macro from the list of suggestions.

5. Configure the macro by completing the form fields as prompted.

If the macro you need is not in the list, choose Open Macro Browser in the list of suggestions to continue
looking for the macro in the macro browser. See Macros.

Screenshot: Autocomplete for a macro

| want to add a macro {
Macro suggestions
@ Info
= Stafus
= Gallery

= Table of Contents

=2 Open Macro Browser

Using autocomplete for mentions

You can use autocomplete to automatically notify another Confluence user that you have mentioned them in
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a page, blog post, or comment. Type ‘@' and part of the person's name, to see a list of suggested users.

Note: Use the person's full name. Autocomplete will recognise users' full names only, not their usernames.

Cancelling autocomplete

The autocomplete starts automatically when you press the trigger characters. You may want to close the
autocomplete menu or escape from autocomplete once it has started.

There are a few different ways to stop the autocomplete once it has started:

Press the escape key, 'Esc’, on your keyboard.

Click somewhere else in the editor panel.

Press an arrow key to move out of the autocomplete area.

For the link autocomplete only: enter a right-hand square bracket, like this: ]

Enabling and disabling autocomplete

You can turn off the triggering of autocomplete by the ' and ' characters. This will prevent the autocomplete
from starting automatically when you press one of the trigger characters. You can also turn it back on again.

Notes:

® This setting does not affect the keyboard shortcuts for autocomplete (Ctrl+Shift+K and Ctrl+Shift+M).
Even if the trigger characters are disabled, you can still use the keyboard shortcuts for autocomplete.

® This setting affects only you. Other people using Confluence can enable or disable the setting on their
user profiles independently.

* Note that autocomplete is enabled by default.

To enable or disable the autocomplete trigger characters:

1. Choose your profile picture at top right of the screen, then choose Settings
2. Choose Editor under "Your Settings' in the left-hand panel.
3. Choose Edit.
4. Either:

® Disable autocompletion by selecting Disable Autocomplete.

® Enable autocompletion by clearing Disable Autocomplete.
5. Choose Submit.

Screenshot: User settings for the editor

Profile  Network Status Updates Favourites Waiches Drafis Settings

GADGETS
View OAuth Access Tokens . .
Editor Settings
YOUR SETTINGS Disable Autocomplete
Password Disable Autocomplete in the Editor, where it allows links to be inserted
. with the trigger [ and images with the trigger 1.
Email
Editor Disable Autoformatting

Disable Autoformatting in the Editor, where it allows wiki-formatted text to
be converted to its Rich Text equivalent (e.g. "h1. title™ for a heading).

Edit
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Ignoring autocomplete

You can add macros, links and images by wiki markup alone. Type the macro, including its parameters and
the closing curly bracket. Add a link, such as an anchor link, and end it with a square bracket. Insert an
image or other embedded object, enclosed between exclamation marks. As soon as you close the macro,
link, or embedded image, Confluence will convert it to rich text format and add it to the page.

For more information about mouse-free macros, links and images, choose Help

> Keyboard Shortcuts from the Confluence header.

Page Layouts, Columns and Sections

The layout of your pages can have a big impact on how they're read, and On this page:
layouts, used well, allow you to position text, images, macros, charts, and .
much more, to have the best visual impact. The _
Section
There are two ways to modify the layout of a Confluence page: and
. Column
® Use page layouts to add sections and columns
. macros
® Use macros to add sections and columns.

Page layouts provide a simple, visual representation of your page layout in
the editor, while the macros are more flexible and allow for greater
complexity in your layout.

Use page layouts

The page layouts tool allows you to structure your page using horizontal sections and vertical columns. By
adding multiple sections with different column configurations you can build quite complex layouts very easily.

Screenshot: Editor view of a page showing three sections with different column configurations.

=+ Add section @ Remove section + Move up + Move down

e

Demo Space / Pages / Demo Space Home / Sample Page Title Tz % o

Sample Page Title

Capture the knowledge that's too often lost in email inboxes and shared network drives in Confluence

instead — where it's easy to find, use, and update. Distribute a clear agenda before, take notes during,

and assign tasks afterward. With all your notes and action items in one place, you can give email a

break. Great products require equally great planning. Document, discuss, and track product

requirements so your developers can hit the ground running | q

Set up your fully functional knowledge base space in a few clicks. We did the heavy lifting so you don't have to.

Start by adding a horizontal section to your page.
To add a section:

1. Choose the Page Layout
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(]

button in the toolbar

The Page Layout toolbar appears.
2. Choose Add Section

The new section appears below your current content, with the boundaries of the section(s) indicated by
dotted lines (the dotted lines aren't visible when you view the page).

To change the column layout in a section:

1. Place your cursor in the section you wish to change
2. Choose a layout from the page layout toolbar (for example, two columns or three columns)

Any text, images or macros in your section are not lost when you change the column layout. When you
decrease the number of columns, Confluence will move your content to the left. When you increase the
number of columns, Confluence will add blank columns to the right of your existing content.

To move a section to another part of the page:

1. Place your cursor in the section you wish to move
2. Choose the Move up or Move down buttons

The section and all of its content will be moved above or below other sections on the page.
To delete a section:

1. Place your cursor in the section you wish to remove
2. Choose Remove section

The section and all of its content will be removed.

Notes about Page Layouts

® Column width — The width of the columns are fixed. If you need more than three columns, or columns
of a specific width, you should use the Section and Column macros described below.

* Very wide tables — The width of each column is set to a percentage of the page width. The icons in
the drop-down menu indicate the relative widths for each layout. In most cases, Confluence will adapt
the width of the columns to fit the width of the page. If a column includes an item that's too wide for it,
you'll see a horizontal scroll bar when viewing the page.

The Section and Column macros

You can use the Section and Column macros to add a set of columns to the page. The Section macro
defines an area that will contain the columns. You can have as many sections as you like. Within each
section, you can have as many columns as you like.

The Section and Column macros are useful if you want to define a specific percentage or pixel width for each
column.

To add a section and some columns to a page:

1. In the Confluence editor, choose Insert > Other Macros

2. Find the Section macro, select it and insert it onto the page
3. Choose Insert > Other Macros again

4. Find and insert the Column macro

5. Add your content to the column

Insert as many columns as you like within the section.

You should always have at least one column macro within a section macro. Using a section macro
without any column macros can negatively affect page loading time.

Screenshot: A section and two columns in the editor
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Section | border = true

Column

Content for column 1 goes here

Column

Content for column 2 goes here

When you see the page in view mode, the above layout is displayed like this:
Content for column 1 goes here
Content for column 2 goes here

Macro parameters

Parameters are options that you can set to control the content or format of the macro output. Where the
parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro
browser, it will be listed below in brackets (exanpl e).
Parameters of the Section macro

Parameter Default Description

Show Border false Select this option to draw a border around the section and columns.

Note: Without a Column macro , the border will not be displayed correctly.

Parameters of the Column macro

Parameter Default Description

Column 100% of the page width, divided Specify the width of the column, in pixels (for example,

Width equally by the number of columns 400px) or as a percentage of the available width (for
in the section. example, 50%).

All content within your section must be enclosed within a Column macro, otherwise the section layout
will not work as expected.

Create Beautiful and Dynamic Pages

Confluence has a number of features that help you
build attractive pages to engage your readers and
give them the opportunity to interact with up-to-date
information. This page summarises those features
and provides links to detailed instructions.
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Add visual appeal

Pictures, photographs and
screenshots. Confluence pages
can display images from your
Confluence site and from other
websites. To put an image into
Confluence, you can upload it
and attach it to a page or blog
post, then display it on any page,
blog post or comment.

Alternatively, display a remote image using its web
address (URL). See Displaying Images.

Galleries. Use the Gallery Macro to display a set of
images. When viewing the page, people can click
any of the pictures to zoom in and view the images

as a slide show.
People. Add a Profile Picture Macro to show a picture of a Confluence user, or a User Profile Macro to show
a summary of the person's profile as well as their avatar.

Multimedia. You can display movies, animations and videos, and embed audio files on your Confluence
page. For example, Confluence supports Adobe Flash, MP3, MP4, and various other movie formats. See Em

bedding Multimedia Content.

Social video and image sharing. The Widget macro displays live content from social sites such as YouTub
e and other video sharing sites, and Flickr for shared photographs. See the guide to the Widget Connector
Macro.

Bring numbers to life

The Chart Macro offers a variety of graphs and charts that you can use to illustrate statistics and other
numerical data.

On this page:
® Add visual appeal
® Bring numbers to life
® Display presentations and

documents
Pull in content from JIRA
applications

® Tell a story in pictures
® Vary the structure of your pages
® Integrate your content with social

media
Show activity streams

Related pages:

Macros
The Editor
Create and Edit Pages

lllustration: A 3-dimensional bar chart produced by the Chart macro

45

40

20059

il

2010 2011

B Fevenue W Expense

Display presentations and documents

Display your Office documents and other
presentations directly in Confluence.

® Attach your Office documents to a Confluence

Illustration: A PowerPoint slide deck
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page then display them on the page, using
the View File Macro. This works for Excel
spreadsheets, PowerPoint presentations and
Word documents.

® Display PDF files in Confluence too, also with
the View File Macro.

® Use the Widget Connector Macro to show
slide decks hosted on SlideShare and other
online presentation sites.

Pull in content from JIRA applications

Many project teams and customers also use JIRA applications such as JIRA Software or JIRA Service Desk.
Rather than copying and pasting issues onto your Confluence page, you can display it directly from the
source, thus ensuring that the information shown in Confluence is always up to date.

Link to a feature request in your issue tracker, or display a list of fixed issues — useful for release notes and
project planning. See the JIRA Issues Macro.

Tell a story in pictures lllustration: A Gliffy diagram

A number of Confluence add-ons provide
sophisticated tools for creating diagrams and
mockups.

Space

For example:

Balsamiq Mockups for Confluence |
Creately for Confluence [ } [ ]

Gliffy Confluence Plugin
Graphviz Plugin for Confluence
Lucidchart for Confluence —I— —l—

Search the Atlassian Marketplace for more add-ons. }
Files Files Files Files
Before installing an add-on (also called a plugin) into
your Confluence site, please check the add-on's
information page to see whether it is supported by

Atlassian, by another vendor, or not at all. See our
guidelines on add-on support.

Vary the structure of your pages

You can build up a custom layout by using the page
layout tool to add sections and columns to your
page. See the detailed guidelines to Page Layouts,
Columns and Sections.

Do you need to display tabular data, which your
readers can sort when viewing the page? See Table
s.

Use other macros to highlight and format sections of
your page:

Panel

Info, Tip, Note, and Warning
Code block

Noformat
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Integrate your content with social media

People share information on various social sites. You can make Confluence
a focal point where people collect their shared information and see what is
happening in the areas that matter to them.

Use the Widget Connector macro:

® Show a live stream of tweets from a Twitter user, or tweets matching
a Twitter search.
Display a video from YouTube or other online movie sites.

® Share photographs from Flickr.

® See what else the Widget Connector macro can do.

Show activity streams

Make your Confluence pages dynamic and interactive with:

® An activity stream showing updates and comments on Confluence
and other linked applications. See Gadgets.

®* An RSS feed from within Confluence or an external site. See Subscri
be to RSS Feeds within Confluence.

® Alist of recent blog posts from within Confluence. See Blog Posts
Macro.

Page Templates

When you add a new page, you don't have to start from scratch. Instead,
you can base your new page on a template — a Confluence page with
predefined content. Some templates are provided by blueprints or add-ons,
and you can even create your own templates.

Some examples of useful templates are:

® The meeting notes template will help you and your team collaborate
on notes and follow-up tasks

® The requirements template allows you to capture your
software/hardware product requirements, and create related JIRA
issues from the page

Global templates and space templates

In Confluence, there are two categories of page templates:

® Space templates: These page templates are available in a specific
space only. If you have space administrator permission, you can
define templates via the space administration screen.

® Global templates: These page templates are available in every
space on your site. If you have Confluence Administrator permission,
you can define global templates via the Confluence Administration
Console.

If you're a system administrator, you can also download predefined
templates.

Create a template

Illustration: Twitter stream
via the Widget macro

Tweets ¥ Follow @confluence

Y Atlassian Confluence 2 Jul
< @confluence

Walking the requirements
documentation tightrope in an agile
world atlss.in/13hgGlh via @atlassian

Expand

% Atlassian Confluence 27 Jun
™ @eonfluence

Keep up-to-date with the new Watch
button in Confluence — available
today! ow.ly/mgm-1l #collaboration
#atlassian

-

Tweet to @confluence

On this page:

® Global
templates
and space
templates

® Create a
template

® Usea
template

® Templates
provided
by
blueprints

®* Promote
templates
in the
Create
dialog

® System
templates

Related pages:

®* Create a
Template
® Administeri
ng Site

Templates
® Importing
Templates
®* Create a
Page from
a Template
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You can write your template using the Confluence editor. You can also add special variables to the page, if
you want to include fields that the author will complete when adding the page. See Create a Template for
more information.

Use a template

Page templates are used only when adding a page. It is not possible to apply a template to an
already-existing page. Once a page has been added using a template, the template is no longer linked to the
page. All further editing is performed as if the template was never used. Some plugins provide enhanced
template functionality. You can search the Atlassian Marketplace for template add-ons. See Create a Page
from a Template for more information.

Templates provided by blueprints

A blueprint is a page template with added functionality to help you create, manage and organise content in
Confluence, and there's a collection of predefined ones that ship with Confluence. You can also download
additional blueprints from the Atlassian Marketplace. You can customise the blueprint templates to suit your
individual needs, disable particular blueprints or even develop your own blueprints.

Promote templates in the Create dialog

If you're a space administrator, you can choose to promote specific templates and blueprints in the Create
dialog. Promoting items can help ensure consistency in a space by encouraging users to create particular
types of content, instead of blank pages.

The promoted templates or blueprints will appear at the top, with all other content types, including Blank
Page and Blog Post collapsed under them. To view the other types of content available choose the Show
more link.

Create Filte

Select space Demonstration Space - Pan

_%  How-to article 5 Troubleshooting article
= | Provide step-by-step guidance for completing a Provide solutions for commo

task. problems.

T

Show more

Show more
To see more
templates and
blueprints

To promote a template or blueprint:

1. Goto Space Tools > Content Tools
If your space is using the Documentation theme choose Browse > Space Admin > Templates
2. Choose Promote next to the templates or blueprints you want to appear in the Create dialog

Remember, by promoting a blueprint or template you'll be hiding all other items, including blank page and
blog post, under the Show more link.

If you use the Show more link in the create dialog more than three times in a single space, the dialog will
show you all templates by default from then on.

System templates

Confluence also provides 'system templates' containing content like the site welcome message and default
space content. See Administering Site Templates.

Create a Template

In Confluence, there are two categories of page templates:
® Space templates: These page templates are available in a specific
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space only. If you have space administrator permission, you can
define templates via the space administration screen.

®* Global templates: These page templates are available in every
space on your site. If you have Confluence Administrator permission,
you can define global templates via the Confluence Administration
Console.

Add a space template

1. Go to the space and choose Space tools > Content Tools from the
bottom of the sidebar
2. Choose Templates > Create new template.

If your space uses the Documentation theme:
1. Choose Browse > Space Admin from the header

Note: The Space Admin option appears only if you have space
admin permissions, or if you're part of the 'confluence-administrators
group.

2. Choose Templates from the space administration options.

3. Choose Create new template.

Add a global template

1. Choose the cog icon

, then choose General Configuration under Confluence
Administration
2. Choose Global Templates and Blueprints in the left-hand panel
3. Choose Add New Global Template

Check out the article How to document releases and share release notes to see how helpful creating

templates in Confluence can be.

The template editor

On this page:

Add a
space
template
Add a
global
template
The
template
editor
®* Tem
plat
e
vari
able
S
® Lab
els
®* Ima
ges
and
othe
r
atta
chm
ents
® |nstr
ucti
onal
text
Add a
description
to your
template
Edit or
delete a
template
Notes

Related pages:

Create a
Page from
a Template
Page
Templates
Add,
Remove
and
Search for
Labels

® Macros
®* The Editor
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When you create or edit a template, you'll be using the editor in much the same way as when you edit a
page or blog post. In addition you can add variables, which will produce a form for data collection when

anyone adds a page based on the template.

Screenshot: The template editor with an image, table, text, and variables

g 3 2x =X 48 &9 HITITTH s ) W

Confluence Docs / Templates S

Minutes for (TIITIITETTD
Date [§ date]
Time [§time}
Location
gliandees Text Multidine Text List
Apologies

Paragraph - B I Uu A ~ A ~ i= i=

=
=

i}
4

m | &Files

BR |

& Link

EH Table ~

[j Template ~

Instructional text

New variable
$date

$location
$meetingName

$time

Screenshot: The form displayed when you create a page based on the template
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Confluence Docs / Pages / Confluence Docs Home / Confluence top 50 pages

Page Template Wizard

Step 2: Fill in template variables

The information you supply will become part of the content in your new page.

P e - e T

Minutes for

m (meetingName)

Date (date)

Time (time)
Location Meeting room 1 | (location)
Attendees

Apologies

Minutes

e Add your first meeting minute, here.

____________________________________________________________________________________

<< Back Next>>

Template variables

When you add variables to your template, they will act as form fields. When you create a page based on a
template, you'll see a text entry box for each field. Enter data into each field, and it'll be added to the page.

You can add the same variable more than once in the same template, which is useful if you need the same
information in more than one place on the page.

To insert a variable into a template:

1. Choose Template > New Variable from the editor toolbar (or choose an existing variable to add it to
the page)

2. Enter a name for the variable

3. Press Enter (by default this will create a single-line text input field)

To change the variable type, click the variable placeholder and the variable's property panel will appear.
Choose one of the variable types: Text, Multi-line Text, or List.

You can change the number of lines and width in characters of a Multi-line Text field. If you choose List,
enter each of the items in your list, separated by commas.
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5 X 100 Text Multi-line Text List

kick-off,standup,sparring Text  Multi-line Text = List

Hint: Type $ and the variable name, then press Enter to add a new variable or to select an existing variable
from a list of suggestions. The suggestions dialogue shows variables already defined in this template.

Labels
If you'd like all pages created using this template to have one or more labels, choose the labels icon

%

next to the breadcrumbs at the top of the page to add them.

Images and other attachments
You can't upload an image or other file into a template directly. First you'll need to upload the file to a page in
your site, then in your template, choose Insert > Files > Search on other pages to embed the file or image.

Instructional text
Instructional text is placeholder content in a template, and is only visible while you're editing the page. Use it

to give guidance to whoever is creating a page from the template.

To insert instructional text:

1. Choose Template > Instructional Text in the toolbar
2. Type in your instructional text (for example, Insert an image of the interface here.)

Instructional text appears in italics with a shaded background, to distinguish it from normal paragraph text.

You can also change the placeholder type from Text to either:

® User mention — Opens the user mention dialogue.
* JIRA Macro — Opens a dialogue that allows you to create a new JIRA issue, or search for one or

more JIRA issues to include on the page.

Add a description to your template
The template description displays in the 'Create’ dialog, and is useful for explaining the purpose of your
template to other users.

To add a description to a template:

® Go to the space or global templates page (as described above)
® Choose the Edit icon in the 'Description’ column
® Enter your description and choose Save
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User Created Templates Create New Template
Name Description Last Updated By Updated Operations
Meeting Minutes M ti
9 y new meeting Gil User Aug 27,2014  Promote - Edit - Delete

Template minutes template. #
Choose the
pencil to edit
your template's
description

Edit or delete a template

If you need to change anything about your template, or want to delete it, navigate to either your space or
global template (as described above) and choose either Edit or Delete.

Notes

® Page templates are used only when adding a page. It is not possible to apply a template to an
already-existing page. Once a page has been added using a template, the template is no longer linked
to the page. All further editing is performed as if the template was never used. Some plugins provide
enhanced template functionality. You can search the Atlassian Marketplace for template add-ons.

* When you use a Table of Contents macro in a template, you'll see an error when you preview the
template, but the Table of Contents macro works on the pages that people create from the template.

® The editor for templates is available only in Confluence 4.3 and later. Please refer to the earlier
documentation for a description of the wiki markup editor templates.

® Confluence also provides 'system templates' containing content like the site welcome message and
default space content. See Administering Site Templates.

Create a Page from a Template

You can create a page based on a global template (available to all spaces) On this page:
or a space template (available only to that space). ® |nformation
copied
If you want to quickly create a blank page, hit the Create button in from the
the header; if you want to create a page from a template, hit the Cre template to
ate from template button. the page
® Form fields
displayed
Create blank page n Create from template by the
template
® Using a
template to
create a
Information copied from the template to the page page
®* Notes
When you create a page based on a template, Confluence will copy the
following content and information from the template to the new page: Related pages:
® |abels ® Create a
® Text and styles Template
* Layouts and formatting ¢ The Editor
® Macros * Add,
®* Embedded images and other files. Note that you cannot attach an Remove
image or other file to a template. But if the template displays an and
image or file from another page, the new page will display that image Search for
or file too. Labels

Form fields displayed by the template

If the template author included variables in the template, Confluence will display a form prompting you to
supply values for the variables when you add the page.
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Using a template to create a page

To create a page based on a template:

1. Choose Create from template

in the Confluence header
2. Select a space and the template you want to use and choose Next
If the template contains variables, you'll see a form allowing you to add values for the form variables.
3. Type the relevant information into the form fields, and choose Next
Now you'll see a new page based on the template. If you added information in the form fields, the
page content will include that information.
4. Name your page, add content or make any other changes required and hit Save

Screenshot: Form showing template variables when creating a page from a template

Page Template Wizard

Step 2: Fill in template variables

The information you supply will become part of the content in your new page.

_____________________________________________________________________________________________

Minutes for

Status Meeting (Meetinghlame)

. Date 15/02/2013  (Date)
. Time 9:00 AM| (Time)
| Location MeetingRoom 1 ~ (Location)
Attendees
. Apologies
Minutes

* Add the first item here._.

_____________________________________________________________________________________________

Notes

Page templates are used only when adding a page. It is not possible to apply a template to an
already-existing page. Once a page has been added using a template, the template is no longer linked to the
page. All further editing is performed as if the template was never used. Some plugins provide enhanced
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template functionality. You can search the Atlassian Marketplace for template add-ons.

Blueprints
What's a blueprint? On this page:
o ) _ _ ®* What's a
A blueprint is a set of page templates with added functionality to help you blueprint?
create, manage and organise content in Confluence more easily. * Create
Create meeting notes, shared file lists and requirements documentation out content
of the box, and Customise the blueprint templates to suit your individual using a
needs. You can even develop your own blueprints. blueprint
¢ Customise
blueprint
Create content using a blueprint templates
®* Promote
1. Choose Create from template blueprints
- in the
Create
in the Confluence header dialog
2. Select a blueprint from the create dialog ® Add more
3. Hit Create blueprints
. . . . ® Disable a
The editor will open, and, depending on the blueprint selected, a prompt to blueprint
enter information or the page will appear. You can now follow the e Eull list of
instructions built in to the blueprint to add content. blueprints
Related pages:
®* Page
Templates
® Request
Add-ons

The first time a blueprint is used in a space, Confluence creates an index page and adds a shortcut to your
sidebar (if you're using the default theme). The index displays a list of pages made with the blueprint, and
information selected information from your blueprint pages. For example, the meeting notes index displays a
list of all meeting notes pages in the space, who created them, and when they were last modified.

Screenshot: Index page for the Meeting Notes blueprint
Meeting notes

Created by Rachel Robins [Atiassian Technical Writer] 2 minute ago

Create meeting note

Start a new
Incomplete tasks from meetings meetin g
Description Due date ~ Assignee Task appears on Create a new
Giles Brunning to arrange venue for team outing Giles Brunning 2015-08-01 Meeting notes meeting notes
page here

All meeting notes

Title Creator Modified

Easy to find
Notes from all
your meetings
are listed here @) Like  Bo the fst (o like this Nolabels #

2015-06-01 Meeting notes Rachel Robins [Atlassian Technic... less than a minute ago

2015-06-04 Meeting notes Rachel Robins [Atlassian Technic.. a minute ago

If you're using the Documentation theme, your blueprint index page(s) will appear in the sidebar as children
of the homepage.

Customise blueprint templates

Blueprints are made up of templates that can be customised for an individual space or the whole site. This
means you can adapt the content of the blueprint pages to suit your specific needs. For example, you might
update the Meeting Notes blueprint templates to include a heading for apologies.

If you have space administrator permissions, you can customise blueprint templates for the spaces you are
an administrator of. You must be a Confluence Administrator to customise blueprint templates for a whole
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site. See Administering Site Templates for more information.
To customise a blueprint template for a space:

1. Go to the space and choose Space tools > Content Tools from the bottom of the sidebar
2. Choose Edit beside the blueprint template you wish to edit
3. Make your changes to the template and choose Save

Editing a blueprint template is very similar to editing a page template, except:

® Be careful not to remove any macros that the blueprint page or index page may use to store and
display information
® You can't remove a blueprint template or change the template name

To reset a blueprint template back to the default:

1. Go to the space and choose Space tools > Content Tools from the bottom of the sidebar
2. Choose Reset to default beside the blueprint template you wish to reset

See Working With Templates and Administering Site Templates for more information on templates.

As with user created space and site templates, editing a blueprint template will not change existing pages,
but any new blueprint pages will be based on the updated template.

Promote blueprints in the Create dialog

If you're a space administrator, you can choose to promote specific templates and blueprints in the Create
dialog. Promoting items can help ensure consistency in a space by encouraging users to create particular
types of content, instead of blank pages.

The promoted templates or blueprints will appear at the top, with all other content types, including Blank
Page and Blog Post collapsed under them. To view the other types of content available choose the Show

more link.
Create Filt¢
Select space Demonstration Space - Parn

_% How-to article 5 Troubleshooting article
= | Provide step-by-step guidance for completing a Provide solutions for commo

task. problems.

T

Show more

Show more
To see more
templates and
blueprints

To promote a template or blueprint:

1. Goto Space Tools > Content Tools
If your space is using the Documentation theme choose Browse > Space Admin > Templates
2. Choose Promote next to the templates or blueprints you want to appear in the Create dialog

Remember, by promoting a blueprint or template you'll be hiding all other items, including blank page and
blog post, under the Show more link.

If you use the Show more link in the create dialog more than three times in a single space, the dialog will
show you all templates by default from then on.

Add more blueprints

You can find more blueprints for Confluence in the Atlassian Marketplace. Blueprints are managed using
add-ons (also known as plugins).

See Request Add-ons for information on how you can search for new blueprint add-ons and send a request
to your System Administrator.
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If you are a System Administrator, see Managing Add-ons or Plugins for information on how to install new
blueprint add-ons.

You can also develop your own blueprints. See our developer documentation on Writing a Blueprint.

Disable a blueprint

You may want to disable particular blueprints. For example, you may not want to see the Product
Requirements blueprint in the create dialog in an HR or Social space. If you are a Confluence Administrator
you can also disable particular page and space blueprints for the whole site.

To disable a blueprint in a space:

® Go to the space and choose Space tools > Content Tools from the bottom of the sidebar
® Choose Disable next to the blueprint you wish to disable in that space

You can re-enable the blueprint at any time.
To disable a blueprint across a whole site:

® Choose the cog icon

, then choose General Configuration under Confluence Administration (You need Confluence
Administrator permissions to do this)

® Choose Global Templates and Blueprints

® Choose Disable next to the page or space blueprint you wish to disable

The blueprint will not appear in the 'Create’ or '‘Create Space' dialogs.

Full list of blueprints
Here's the full list of blueprints bundled with Confluence.

Page blueprints Space blueprints

Meeting notes ®* Documentation space
File list ® Team space

Decision ® Knowledge base space
How-to article

Troubleshooting article

JIRA report

Product requirements

Retrospective

Share a link

Task report

Decisions Blueprint

The Decisions blueprint helps you make decisions and record the outcomes Related pages:
with your team. _
® Blueprints
The first time you use the Decisions blueprint in a space, Confluence will ® File List
create an index page and add a shortcut on your space sidebar (if you're Blueprint
using the default theme). The index acts as your Decision Register and lists ®* Meeting
all the decisions in that space. Notes
Blueprint
If you want to quickly create a blank page, hit the Create button in ® Product
the header; if you want to create a page from a template, hit the Cre Requireme
ate from template button. nts
Blueprint

Create blank page n Create from template
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To create a decision page:

1. Choose Create from template

in the Confluence header

2. Select Decision and hit Next

3. Enter information about the decision and relevant stakeholders (the
blueprint will prompt you) and hit Create

Once you save your first decision page, Confluence will create a decision
register page for the space you're in, and add a shortcut to it in the space's
sidebar.

Screenshot: Decision Register showing a series of Decision pages

Pages / Confluence Docs Home A~ # Edit

Decision register

Created by Rachel Robins, last modified on Aug 15, 2013

Decision Status Stakeholders Outcome
How should we divide up BT  |@Rachel Robins| @ Giles Brunning| @ Nick Doherty Split for 5.7 onwards
confluence teams between decided here
tal writers
Decision pages
T Should we retire Planning for ~ [[IEESNZ |@Rachel Robins), |@Giles Brunning Move pages with
YOUr exl Stlng Confluence 4 and 5 doc from comments to CONF40
deClSlonS appear the latest space and CONF50 archive
spaces.

here
Where should CQ developer

doc live

IN
PROGRESS

Screenshot: Editing a Decision page

132

© Watch =

[}
{22}

Due date

08 Oct 2014

03 Oct 2014

03 Oct 2014

What is our target launch date?

| Page properties | label

Status IN PROGRESS

Stakeholders = Rosie Admin, Josh User, Sophie User

Outcome What did you decide?

Due date 119 Mar 2015

Owner Rosie Admin
Background

* Summit will be on again in 2015, so we need to be locked-in well in advance.
* Rosie Admin will be on leave in February, so that may hold things up. Can Josh User take on the leadership role?
« We have 4 teams working on this throughout that period. Is this enough?

The Decisions blueprint uses these Confluence features:

® Page Properties and Page Properties Report macro - content that you enter within the page properties

macro can appear on the index page.

Created in 2015 by Atlassian. Licensed under a Creative Commons Attribution 2.5 Australia License.


http://creativecommons.org/licenses/by/2.5/au/

Confluence 5.9 Documentation 133

® Mentions - add a user as a stakeholder, owner or @mention them on the page and they will be notified
in their workbox.

For an example of the Decisions Blueprint, and some other great page elements, check out: How to
make better decisions as a development team.

Customising this blueprint

You can customise the templates that are used by the Decisions blueprint - see Customising the blueprint
templates. For example, you might choose to edit the decisions index page in a space to change the
columns displayed by the Page Properties Report macro.

You can also edit the page template to add headings or instructional text to the background section, or even
add rows to the Page Properties macro. For example, a row for the date the decision was made.

See Instructional text to find out more about using instructional text in templates.

File List Blueprint

The File List blueprint helps you to create lists of files to share with your Related pages:
team. Great for organising documents, images and presentations. .
® Blueprints
The first time you use the File List blueprint in a space, Confluence will ®* Meeting
create an index page and add a shortcut to your space sidebar (if you're Notes
using the default theme). The index page lists the latest File List pages in Blueprint
that space. You can have as many File List pages as you need. ® Product
Requireme
If you want to quickly create a blank page, hit the Create button in nts .
the header; if you want to create a page from a template, hit the Cre Blueprint

ate from template button.

Create blank page n Create from template

To create afile list:

1. Choose Create from template

in the Confluence header
2. Select File List and hit Next
3. Enter the details for your file list and hit Create
4. Drag files from your desktop or choose browse for files to search for files on your computer

Attachments appear on the page, and you can expand each attachment to preview the file and/or view its
details.

In this example, three file list pages have been created to store project related presentations, images and
customer feedback. Confluence looks after the versioning of the files, so there's no need to use the
document file name to mark version numbers.

Screenshot: Index page showing File List pages
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Space shortcut

A quick way to find all
of your file lists in this
space

Screenshot: A File List page

Pages / Blue Sky Project Home

File lists

Created by Rosie Admin 16 minutes ago

e Blue Sky Project

2 Pages

=\ Blog

SPACE SHORTCUTS
Decision log Title

2] Meeting notes
Customer Feedback
s Retrospectives

o Project Images
File lists

Presentations
PAGE TREE

Presentations
Created by Rosie Admin 32 minutes ago
File
> [E] Atlassian presentation graphic assets key.zip
> (] IX Image Tools.key.zip

> (£) 10 tech writing tips key.zip

Expand

View each file's
details and
preview

~ (9] 10 tech writing tips .pptx

Atlassian

10 tech writing tips:

Don't do what Donny Don't does

Labels
No labels #

Version history

Version 3 (current version)

Version 2 Modified by Administrator

Version 1 Created by Rosie Admin

View Edit in Office Properties Delete

Modified by Frank Admin

Drag and drop to upload or browse for files

# Edit @ Watch [ Share

Creator Modifie
Frank Admin a minute
Frank Admin a minute
Rosie Admin 16 minu
Modified *

30 minutes ago by Rosie Admin
30 minutes ago by Rosie Admin
30 minutes ago by Rosie Admin

24 minutes ago by Frank Admin

24 minutes ago _—
26 minutes ago

29 minutes ago

Upload and Download

Drop files or browse to + Downioad Al
upload, and download all

files

Customising this blueprint

You can customise the templates that are used by the File List blueprint - see Customising blueprint

templates.

The File List blueprint template uses the attachments macro. You can customise the macro to change the
sort order or hide features such as version history and the upload attachment fields.

You can also edit the Content Report Table macro used on the Index page to specify the number of pages

you want to display.

Meeting Notes Blueprint
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The Meeting Notes blueprint helps you to plan your meetings and share

notes and actions with your team.

The first time you use the Meeting Notes blueprint in a space, Confluence
will create an index page and add a shortcut on your space sidebar (if you
are using the default theme). The index page lists the latest Meeting Notes

pages in that space.

If you want to quickly create a blank page, hit the Create button in the header; if you want to create a

page from a template, hit the Create from template button.

Related pages:

® Blueprints

® File List
Blueprint

® Product
Requireme
nts
Blueprint

Create blank page - Create from template

To create a meeting notes page:

1. Choose Create from template

in the Confluence header
2. Select Meeting Notes and hit Next

3. Enter the information required by the template and hit Create
4. Save your page and get ready to attend your meeting

You can edit the page during or after your meeting, and enter your notes, action items and @mention users

to assign tasks to them.

Screenshot: A Meeting Notes index page

Pages / Marketing team home

Meeting notes

Created by Gil User, last modified just a moment ago

All meeting notes

Title
Gil and Nick 1:1 2015-04-28
Cloud space relaunch kick-off meeting

Cloud relaunch - product stakeholder meeting

# Edit

© Watch [2 Share  ee-

Creator

Gil User

Gil User

Gil User

Create meeting note

Moaodified
Apr 29, 2015
Apr 24, 2015

Apr 14, 2015

Screenshot: A blank Meeting Notes page showing instructional text
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People / Gil User / Pages /... / Testingpage T2 % o

2015-05-04 Meeting notes

Date

04 May 2015

Attendees

« Gil User
* @mention a person to add them as an attendee and they will be notified.

Goals

» Set goals, objectives or some context for this meeting.

Discussion items

Time [Item Who Notes

5min = Agenda item = Name o Notes for this agenda item

Action items

Type your task here. Use "@" to assign a user and "//" to select a due date.

The Meeting Notes blueprint uses some cool Confluence features:

® Instructional text - this handy text prompts you to enter information and disappears when you start
typing or view the page.
Mentions - @mention a user on the page and they will be notified in their workbox.

® Task lists - @mention a user in a task to assign it to them — the task will appear as a personal task in
their workbox. You can also add a due date by typing //, then choosing a date from the calendar.

Customising this blueprint

You can customise the templates that are used by the Meeting Notes blueprint — see Customising the
blueprint templates.

You might choose to edit the headings or add additional headings, or change the instructional text that
prompts users to enter information to suit your context. To find out more about using instructional text in a
template, see Instructional text.

You can also edit the Content Report Table macro used on the Index page to specify the number of pages
you want to display.

Product Requirements Blueprint

The Product Requirements blueprint helps you to define, scope and track
requirements for your product or feature.

The first time you use the Product Requirements blueprint in a space,
Confluence will create an index page and add a shortcut on your space
sidebar (shortcut only available in the default theme). The index lists all the
Product Requirements pages in that space, and displays a summary of the
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information on each page (such as status and owner). You can have as Related pages:
many Product Requirements pages as you need. .
® Blueprints
® File List
Blueprint
® Meeting
Notes
Blueprint

If you want to quickly create a blank page, hit the Create button in the header; if you want to create a
page from a template, hit the Create from template button.

Create blank page - Create from template

To create a requirements page:

1. Choose Create from template

in the Confluence header
2. Select Product Requirements and hit Next
3. Enter information about your product or feature (the instructional text will prompt you) and hit Create

You can @mention team members to bring them into the conversation about the page.

Screenshot: Index showing a series of Product Requirements pages and summary information

Pages / Project Inception Home A~
e Project Inceplion g g B # Edit © Watch [28§
Product Requirements
(3 Pages Created by Sherif Mansour, last modified on Mar 18, 2013
= Bleg
(e Add Proi
SRS Title Desig Develop Documentowner  Documentstatus QA Target releas¢
1] Meeting Notes
Share with friends feature @ Valter Fatia TBA @ Sherif Mansour TBA 44
File Lists
. Pluggable Notifications @ Valter Fatia @ Niraj Bhawnani @ Bill Arconati IN PROGRESS @ Joey Corea 4.4
Product Requirements
iPad Client @Henry Tapia|  |@Chris Kiehl @ John Masson @GClenn Martin 4.3
CHILD PAGES
Project Inception Home Signup via Facebook @ Henry Tapia @ Anna Dominguez @ Sherif Mansour DRAFT @ Glenn Martin 5.0

ProductRequirements ) Like  Be the first fo like this

Screenshot: Editing a Product Requirements page
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Pluggable Notifications

) Page properties

Target release 4.4
Epic x JIRA | CONF-1
Document status IN PROGRESS

Document owner  Frank Admin

Designer Rosie Admin Josh User
Developers Lead developer
QA Lead tester

Goals

o E.g. Simplify the user experience, reduce friction efc...

Background and strategic fit

Why are you doing this? How does this relate to your overall product strategy?

The Product Requirements blueprint uses these Confluence features:

® Page Properties and Page Properties Report macro - content that you enter within the page properties
macro can appear on the index page.

® Instructional text - this handy text prompts you to enter information or create a JIRA issue
and disappears when you start typing or view the page.

® Mentions - @mention a user on the page and they will be notified in their workbox.

Customising this blueprint

As no two products or projects are alike, you can customise the templates that are used by the Product
Requirements blueprint - see Customising the blueprint templates.

You might choose to edit the index page in a space to change the columns to be displayed by the Page
Properties Report macro.

You might choose to edit the page template to:

® edit the headings or add additional headings
® change the instructional text that prompts users to enter information to suit your context
® add or remove rows within the Page Properties macro.

See Instructional text to find out more about using instructional text in templates.

Shared Links Blueprint

The Shared Links blueprint helps you take content from the web and share it
with your team. You can use Shared Links to share and collaborate on web
content, or to create a centralised repository of useful links.

The first time you use the Shared Links blueprint in a space, Confluence will
create an index page and add a shortcut on your space sidebar (if you're
using the default theme). The index lists all the shared links in that space.

If you want to quickly create a blank page, hit the Create button in
the header; if you want to create a page from a template, hit the Cre
ate from template button.
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Related pages:
Create blank page n Create from template * Blueprints
® Decisions
Blueprint
i ® File List
To create a shared links page: Blueprint
1. Choose Create from template * Meeting
Notes
- Blueprint
in the Confluence header * ;rodgct
2. Select Share a link and hit Next mequweme
3. Enter the URL of the web content you want to share, then hit Create Bllsjeprint

You can also:

® Include topics to help categorise your links — these are added as labels to your page.
® Share the link immediately with another user or group — users will receive a notification.

® Add a comment to start the discussion.

To make sharing links even faster, you can add a Share on Confluence button to your browser's
toolbar. Click this button and the webpage you're currently viewing will be added as a shared link!

To add the Share on Confluence button to your browser:

1. Choose Create from template

, then select Share a link

2. Drag the Share on Confluence button to your browser toolbar

Now, when you want to share a link in Confluence, choose the Share on Confluence button in your browser

and follow the prompts.

Screenshot: Share a link from the Create dialog.

Share a Link

Link" | Paste a link to any website
Lk .
Title" | Title of the page
Topics | Topics for the
Share with

Comment | Share your thoughts about this link

JIRA Report Blueprint

About sharing Links

Share links to anything you find on the web. To
make sharing easier, drag this bookmarklet to
your bookmarks bar.

&, Share on Confluence

It will appear like this in your browser.

® 00 J New Tab
€ > Cla

ﬁ Atlassian ¥ Share on Confluence

Back m Close
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The JIRA Report blueprint helps you create easy to read reports to

communicate the progress of your JIRA Software projects and releases. Yo On this page:
u can choose from a Change Log report that generates a list of JIRA issues ¢ Create a
or a Status Report that includes charts to visually communicate your Change
progress. Log
® Create a
The first time you use the JIRA Reports blueprint in a space, Confluence will Status
create an index page and add a shortcut on your space sidebar (if you're Report
using the default theme). ® Customisin
g this
If you want to quickly create a blank page, hit the Create button in blueprint

the header; if you want to create a page from a template, hit the Cre
ate from template button.

Create blank page - Create from template

To use the JIRA Report Blueprint your Confluence and JIRA application
(such as JIRA Software) must be connected via Application Links .

Create a Change Log

The Change Log report displays a list of issues from your JIRA application. This list can be static or dynamic,
automatically updating as the status of your issues change in JIRA.

To create a static change Log:

1. Choose Create from template

in the Confluence header
2. Select JIRA report and hit Next
3. Select a Change log and hit Next
4. Enter the information required for the change log and hit Create

A report page will be created with sample text and a list of all issues for the project and fix versions selected,
organised by issue type. This list of issues is static; it won't be updated when the issues are updated, and is
visible to users who don't have JIRA access or permissions to view that project.

Screenshot: Creating a Change Log in simple mode.

Change log

Server | JAC = About Change Log

Keep a log of your teams progress or
communicate deliverables. Generate a static
or dynamic list of JIRA issues from a saved
Fix Version(s) 54 % search, JIRA URL or JaL query.

F'roject’ Confluence -

Switch to advanced

Title = Confluence 5.4

Screenshot: Static list of JIRA Issues displaying in the Change Log.
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All updates for this release
Improvement

¢ CONF-29057 - Automatically embed WuFoo forms and Reports in Confluence when pasting a URL
Bug

¢ CONF-31163 - Cursor doesn't appear in editor in Chrome 30

s CONF-27451 . Login should say "Log in"”

To create a dynamic change log:

1. Choose Create from template

in the Confluence header

Select JIRA report and hit Next

Select a Change log and hit Next

Choose Switch to advanced

Enter a JQL query or paste in the URL of a JIRA search (find out about using JQL in the JIRA
Documentation)

6. Hit Create

aprwdN

A report page will be created with sample text and a JIRA issues macro that's configured to show your
issues. The macro is dynamic and will update when the issues are updated. For more information on
changing the information displayed, refer to the JIRA Issues macro.

Screenshot: Dynamic list of JIRA Issues displaying in the Change Log.

All updates for this release

Key sSummary Type Updated Priority  Status
CONF-31163  Cursor doesn't appear in editor in Chrome 30 [ Oct 21,2013 1+ ¥ Resolved
CONF-29057  Automatically embed WuFoo forms and Oct 18, 2013 & Resolved

Reports in Confluence when pasting a URL
CONF-27451  Login should say "Log in' [ oct02, 2013 &> Resolved

3issues ¥ Refresh

Create a Status Report

The Status Report displays the progress of a JIRA project and fix version in pie charts by status, priority,
component and issue type. The Status Report uses the JIRA Chart macro, and is dynamic.

To create a status report:

1. Choose Create from template

in the Confluence header
2. Select JIRA report and hit Next
3. Select a Status report and hit Next
4. Enter the information required for the report and hit Create

A report page will be created with sample text and a series of pie charts, using the JIRA Chart macro. The
macro is dynamic and will update when the issues in JIRA are updated. For more information refer to the JIR
A Chart macro.
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As with the Change Log, you can switch to Advanced mode and use JQL or paste in a JIRA URL to search

for issues to display in the report.

Screenshot: Excerpt from the Status Report.

Confluence 5.3

Release Confluence 5.3

Status Oct 28, 2013 - GREEN

Report summary

Overall status for 70 issues

Resolved
8

Awaiting
Quality
o Review =

- 1

T Open=1

This is the report summary - you can add a summary or some commentary on the status of your project here.

Priority

_ lrrelevant
. =16

Major=
18

~__ Critical =
13

<

~———_EBlocker =
2

- Trivial =2

Customising this blueprint

You can customise the templates used by this blueprint. The Change Log uses the Snapshot JIRA Report
Template (for static list of issues) and the Dynamic JIRA Report Template, and the Status Report uses the
Status Report Template. See Customising the blueprint templates. Variables represent the JIRA Issues
and JIRA Chart Macros. While these can't be edited, they can be moved around the page or deleted if you

don't want every chart to be included.

You can also choose to edit the page template to modify the format of the page, change some headings, or

modify the instructional text. To See Instructional text to find out more about using instructional text in

templates.

Retrospective Blueprint

Retrospective pages help you track team successes and opportunities after
projects or at the end of a sprint. Use this blueprint to document what went
well, what needed improvement, and assign actions for the future.

The first time you create a retrospective page in a space, Confluence will
automatically create an 'index' page, which will list all retrospectives in the
space, and add a shortcut to it in the space sidebar.

If you want to quickly create a blank page, hit the Create button in the header; if you want to create a

page from a template, hit the Create from template button.

Create blank page n Create from template

To create a retrospective page:

1. Choose Create from template

Related pages:

® Blueprints

® File List
Blueprint

® Meeting
Notes
Blueprint

Created in 2015 by Atlassian. Licensed under a Creative Commons Attribution 2.5 Australia License.

142


http://creativecommons.org/licenses/by/2.5/au/
https://confluence.atlassian.com/display/DOC/Blueprints#Blueprints-CustomiseTemplate
https://confluence.atlassian.com/display/DOC/Create+a+Template#CreateaTemplate-InstructionalText
https://confluence.atlassian.com/display/DOC/Blueprints
https://confluence.atlassian.com/display/DOC/File+List+Blueprint
https://confluence.atlassian.com/display/DOC/File+List+Blueprint
https://confluence.atlassian.com/display/DOC/Meeting+Notes+Blueprint
https://confluence.atlassian.com/display/DOC/Meeting+Notes+Blueprint
https://confluence.atlassian.com/display/DOC/Meeting+Notes+Blueprint

Confluence 5.9 Documentation 143

in the Confluence header
2. Select Retrospective and hit Next
3. Add participants, change the title if you want to and click Create

Run a Retrospective

Tille | 2013-10-24 Retrospective About retrospectives
Brainstorm and vote on what went well and
Participants A Ruth Buchanan % what could be improved in your last sprint or
project with your team, then set out some
action items.

Screenshot: The 'retrospective' template page

2014-10-13 Retrospective

V/ Page properties

Date 14 Oct 2014

Participants  Rosie Admin Josh User

Retrospective

= Panel

What did we do well?

o List all items that you did well.

=: Panel

What should we have done better?

o List all items that you should have done better.

Actions

@mention a person to assign them an action item

The Retrospective blueprint uses the following Confluence features:

® Page Properties and the Page Properties Report macro make content listed within the macro visible
on the index page.

® |nstructional text prompts you to enter information and disappears when you start typing or view the
page.
® Mention a user on the page to notify them in their workbox.

Check out how the retrospectives blueprint can be used in the article Create sprint retrospective and
demo pages (like a BOSS).

Customise this blueprint

Every team conducts retrospective meetings differently, so you can customise the Retrospective blueprint
template to match your team's culture and practices. You can:
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® Edit headings and pre-populated text
® Add instructional text to capture specific information
® Add additional sections and content

See Customising blueprint templates for instructions.

Create a Blueprint-Style Report

Using a combination of templates and macros you can make a wide range of reports for managing anything from
customer interviews, product requirements to IT service catalogues and more. In this tutorial we'll guide you
through the process of creating a blueprint-style report.

In this example, we'll create a multi-team status report. Here's the scenario we'll use for this tutorial.

The Design, Development and QA teams working on the Blue Sky Project need to produce a short
status update page each week, containing the focus area for the week, contact person, risks and
overall status for each team. They like the way the Product Requirements blueprint works and want
to be able to manage their status updates in a similar way.

What do each of the players want out of this report?

Project Lead — Wants an at-a-glance report that shows only the status for each team.

Team Leads — Want a summary report, including the focus areas and risk, just for their team.
All team members — Want it to be easy to create the new page each week.

Management Team — Want to see all the details for a week on one page, and don't want to
have to look at a different page for each team.

With this scenario in mind, this tutorial will guide you through how to:

1.

N

Create a status update template containing a separate page properties macro for each team's section of
the report.

. Create a high level status report, showing just the status of all teams.
. Create a summary report for each team.
. Create your first status update page.

You'll need Space Administrator permissions to complete some of the steps in this tutorial.

Part 1: Create a status update template

First we'll create a page template and add the Page Properties macros.

1.
2. Choose Create Template

3. Give the template a name (in this example the template will be called 'Status Update’)
4,
5

Go to Space Admin > Content Tools > Templates

Add the skeleton of your status report to the page
. Choose the label icon

%

at the top of the page to add a label to the template (in this example, we'll add the label: 'status-update")

Screenshot: Adding teams to our status update template
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Heading2 ~ B I U A~ ‘A~ Ho = v sE FE = =E W | &F @ B B +~ 9 Q 7

Gil User / Templates %

Status update

Executive Summary
Text summary of the week's status, to be completed by the project lead.
Design Team

Development Team

QA Team

Preview m Cancel

Now we'll add a Page Properties macro to record the status of the Design team.
Choose Insert > Other Macros > Page Properties to add the Page Properties macro to the page
7. In the macro body create a two column table and remove the heading row
8. In the left column enter the column headings for your report (these are known as metadata 'keys')
In this example we'll add 'Design Focus', 'Design Status', 'Design Contact' and 'Design Risks").
9. In the right column, leave the cells blank, or enter some instructional text to prompt your users (Choose T
emplate > Instructional Text)
We've also added a status macro.
10. Edit the Page Properties macro and enter a Page Properties ID for this macro (in this example we'll use
'status-update-design'. This will allow us to report on the status of just the Design team later on)
Repeat this process for the Development and QA teams, remembering to specify a different ID for each
macro (we used 'status-update-dev' and 'status-update-qa’).
11. Finally, add any other headings, instructional text or content to your template and Save.
You can enter a Description for your template - this appears in the Create dialog.

o

Screenshot: Our status update template
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Design Team

N Page properties | id = status-update-design
Design Focus What was your team's main focus this week?
Design Status STATUS

Design Contact  Who is the contact person?

Design Risks Risks that have emerged this week

Development Team

) Page properties | id = status-update-de
Dev Focus What was your team's main focus this week?
Dev Status STATUS

Dev Contact Who is the contact person?

Dev Risks Risks that have emerged this week

Part 2: Create a report showing the high level status of each team

Next we'll create an index page, just like you see in many blueprints.

1.

2.

In your space create a new blank page (this will be our 'Status Report - all teams' page, showing just the
status of each team)

Choose Insert > Other Macros > Page Properties Report to add the Page Properties Report macro to
the page

Enter the Label to report on (in this example, it'll be the 'status-update' label we added to the template
page)

Leave the Display options > Page Properties ID field blank (we want to report on all the macros on the
page)

In the Columns to Show field, list the 'keys' from each macro that you want to include in the report (in

this example, we only want to show the values of 'Design Status', 'Dev Status', 'QA Status')
Choose Save to add the macro to the page

Screenshot: The page properties report macro on the 'Status Report - all teams' page
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10.

11.
12.
13.

Edit ‘Page properties report’ Macro

¥ Preview

Options
Page properties 1D (optional) Title

No content found.

Title column heading

Change the heading of the Title column
which contains links to pages. Maximum
35 characters.

Columns to show

Design Status, Dev Status, QA Sta

Comma separated list of columns to
include in the table. Page title is always
shown.

Number of items to display

Select macro Save @ Cancel

Now we'll add a button to the page to allow team leads to easily create new status update pages from the
template we created earlier.

Choose Insert > Other Macros > Create from Template to add the Create from Template macro to the
page

Enter the text for the button (in this example we'll call the button ‘New Status Update Page')

Select the template from the Template Name drop down (in this example our template was called 'Status
Update")

Specify the title of any pages to be created (This is a great way to keep your titles consistent. In this
example we'll call the page 'Status update week ending @currentDate', which will append the current date
when the page is created, as in the meeting notes blueprint)

Choose Insert

Add any other content, links or images to the page and Save

Choose Space Tools > Configure Sidebar > Add Link to add a shortcut to the page on the sidebar

Part 3: Create a separate report for each team

Now we'll create some index pages that show a more detailed summary for each team, starting with the Design

team.

1.

2.

o

Create a new blank page — this will be the 'Design Status Report' index page, showing just information for
that team.

Choose Insert > Other Macros > Page Properties Report to add the Page Properties Report