Documentation for Confluence 5.7
## Contents

- Confluence User’s Guide .................................................. 6
- Getting Started with Confluence ....................................... 7
  - Dashboard ...................................................................... 8
  - Keyboard Shortcuts ........................................................ 9
  - Using Confluence on a Mobile Device ................................. 13
- Working with Spaces ........................................................ 18
  - Create a Space .............................................................. 19
  - Create a Personal Space .................................................. 21
  - Administering a Space .................................................... 22
  - Edit Space Details .......................................................... 24
  - Using Labels to Categorise Spaces ................................... 25
  - Delete a Space .............................................................. 26
  - Archive a Space ............................................................ 26
  - View Space Activity ....................................................... 28
  - View Recently Updated Content ..................................... 29
- Change the Look and Feel of a Space .................................... 29
  - Applying a Theme to a Space .......................................... 30
    - Using the Documentation Theme .................................. 32
    - Configuring the Documentation Theme ............................ 35
  - Configure the Sidebar ..................................................... 44
  - Change the Space Logo ................................................... 45
  - Customising Space Layouts .............................................. 46
  - Editing a Space’s Colour Scheme ...................................... 48
  - Styling Confluence with CSS .......................................... 51
    - Basic Styling Tutorial .................................................. 53
    - Styling Fonts in Confluence .......................................... 55
- Pages and Blog Posts ...................................................... 56
- Working with Pages ........................................................ 57
- Blog Posts ....................................................................... 59
- Using the Editor ............................................................. 61
  - Using Symbols, Emoticons and Special Characters ................. 64
- Move and Reorder Pages ................................................... 65
- Copy a Page .................................................................... 67
- Delete or Restore a Page .................................................. 68
- Add, Remove and Search for Labels .................................... 69
  - Displaying Pages with Label Macros ................................. 72
- Working with Drafts ........................................................ 72
  - Concurrent Editing and Merging Changes ............................ 74
- Page Restrictions .......................................................... 75
- Working with Links ......................................................... 78
- Working with Anchors ..................................................... 83
- Working with Tables ....................................................... 85
- Using Autocomplete ......................................................... 87
- Working with Page Layouts and Columns and Sections ............... 92
- Creating Beautiful and Dynamic Pages ................................ 95
- Working with Templates .................................................. 98
  - Creating a Template ...................................................... 99
  - Creating a Page using a Template .................................... 104
- Working with Blueprints ................................................ 107
  - Decisions Blueprint ..................................................... 110
  - File List Blueprint ...................................................... 112
  - JIRA Report Blueprint ................................................... 115
  - Meeting Notes Blueprint ............................................... 118
  - Product Requirements Blueprint .................................... 121
  - Retrospectives Blueprint ............................................... 123
  - Shared Links Blueprint ................................................ 125
<table>
<thead>
<tr>
<th>Title</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Creating a Blueprint-Style Report</td>
<td>126</td>
</tr>
<tr>
<td>Importing Content Into Confluence</td>
<td>132</td>
</tr>
<tr>
<td>Importing Content from Another Wiki 1</td>
<td>133</td>
</tr>
<tr>
<td>Importing a Word Document into Confluence</td>
<td>133</td>
</tr>
<tr>
<td>Importing Content from Another Wiki</td>
<td>135</td>
</tr>
<tr>
<td>Importing Pages from Disk</td>
<td>135</td>
</tr>
<tr>
<td>Orphaned Pages</td>
<td>136</td>
</tr>
<tr>
<td>Undefined Page Links</td>
<td>137</td>
</tr>
<tr>
<td>View Page Information</td>
<td>138</td>
</tr>
<tr>
<td>Page History and Page Comparison Views</td>
<td>140</td>
</tr>
<tr>
<td>Using a WebDAV Client to Work with Pages</td>
<td>142</td>
</tr>
<tr>
<td>Working with Macros</td>
<td>143</td>
</tr>
<tr>
<td>Task Report Macro</td>
<td>146</td>
</tr>
<tr>
<td>Roadmap Planner Macro</td>
<td>148</td>
</tr>
<tr>
<td>Activity Stream Macro</td>
<td>149</td>
</tr>
<tr>
<td>Anchor Macro</td>
<td>149</td>
</tr>
<tr>
<td>Attachments Macro</td>
<td>150</td>
</tr>
<tr>
<td>Blog Posts Macro</td>
<td>152</td>
</tr>
<tr>
<td>Change-History Macro</td>
<td>155</td>
</tr>
<tr>
<td>Chart Macro</td>
<td>156</td>
</tr>
<tr>
<td>Confluence Storage Format Examples for Chart Macro</td>
<td>174</td>
</tr>
<tr>
<td>Wiki Markup Examples for Chart Macro</td>
<td>192</td>
</tr>
<tr>
<td>Cheese Macro</td>
<td>198</td>
</tr>
<tr>
<td>Children Display Macro</td>
<td>199</td>
</tr>
<tr>
<td>Child Page 1</td>
<td>201</td>
</tr>
<tr>
<td>Child Page 2</td>
<td>201</td>
</tr>
<tr>
<td>Code Block Macro</td>
<td>201</td>
</tr>
<tr>
<td>Column Macro</td>
<td>204</td>
</tr>
<tr>
<td>Content by Label Macro</td>
<td>205</td>
</tr>
<tr>
<td>Content by User Macro</td>
<td>208</td>
</tr>
<tr>
<td>Content Report Table Macro</td>
<td>209</td>
</tr>
<tr>
<td>Contributors Macro</td>
<td>210</td>
</tr>
<tr>
<td>Contributors Summary Macro</td>
<td>213</td>
</tr>
<tr>
<td>Create from Template Macro</td>
<td>217</td>
</tr>
<tr>
<td>Create Space Button Macro</td>
<td>220</td>
</tr>
<tr>
<td>Excerpt Include Macro</td>
<td>221</td>
</tr>
<tr>
<td>Excerpt Macro</td>
<td>222</td>
</tr>
<tr>
<td>Expand Macro</td>
<td>224</td>
</tr>
<tr>
<td>Favourite Pages Macro</td>
<td>225</td>
</tr>
<tr>
<td>Gadget Macro</td>
<td>226</td>
</tr>
<tr>
<td>Gallery Macro</td>
<td>229</td>
</tr>
<tr>
<td>Global Reports Macro</td>
<td>232</td>
</tr>
<tr>
<td>HTML Include Macro</td>
<td>233</td>
</tr>
<tr>
<td>HTML Macro</td>
<td>235</td>
</tr>
<tr>
<td>IM Presence Macro</td>
<td>236</td>
</tr>
<tr>
<td>Include Page Macro</td>
<td>237</td>
</tr>
<tr>
<td>Sample Include Page</td>
<td>238</td>
</tr>
<tr>
<td>Info Macro</td>
<td>238</td>
</tr>
<tr>
<td>JIRA Chart Macro</td>
<td>240</td>
</tr>
<tr>
<td>JIRA Issues Macro</td>
<td>242</td>
</tr>
<tr>
<td>JUnit Report Macro</td>
<td>250</td>
</tr>
<tr>
<td>Labels List Macro</td>
<td>252</td>
</tr>
<tr>
<td>Livesearch Macro</td>
<td>253</td>
</tr>
<tr>
<td>Loremipsum Macro</td>
<td>254</td>
</tr>
<tr>
<td>Multimedia Macro</td>
<td>255</td>
</tr>
<tr>
<td>Navigation Map Macro</td>
<td>257</td>
</tr>
<tr>
<td>Network Macro</td>
<td>258</td>
</tr>
<tr>
<td>Noformat Macro</td>
<td>260</td>
</tr>
<tr>
<td>Note Macro</td>
<td>261</td>
</tr>
<tr>
<td>Office Excel Macro</td>
<td>262</td>
</tr>
<tr>
<td>Office PowerPoint Macro</td>
<td>263</td>
</tr>
<tr>
<td>Office Word Macro</td>
<td>264</td>
</tr>
<tr>
<td>Section</td>
<td>Page</td>
</tr>
<tr>
<td>------------------------------------------------------------------------</td>
<td>------</td>
</tr>
<tr>
<td>Watching Pages, Spaces and Blogs</td>
<td>373</td>
</tr>
<tr>
<td>Managing Watchers</td>
<td>376</td>
</tr>
<tr>
<td>Subscribing to Email Notifications of Updates to Confluence Content</td>
<td>377</td>
</tr>
<tr>
<td>Subscribing to RSS Feeds within Confluence</td>
<td>380</td>
</tr>
<tr>
<td>Using pre-specified RSS feeds</td>
<td>382</td>
</tr>
<tr>
<td>Using the RSS Feed Builder</td>
<td>382</td>
</tr>
<tr>
<td>Subscribing to a Network RSS Feed</td>
<td>384</td>
</tr>
<tr>
<td>Working with Tasks</td>
<td>385</td>
</tr>
<tr>
<td>Managing Notifications in Confluence</td>
<td>387</td>
</tr>
<tr>
<td>Searching Confluence</td>
<td>390</td>
</tr>
<tr>
<td>Confluence Search Syntax</td>
<td>394</td>
</tr>
<tr>
<td>Confluence Search Fields</td>
<td>398</td>
</tr>
<tr>
<td>Searching the People Directory</td>
<td>401</td>
</tr>
<tr>
<td>Recently Viewed Pages and Blog Posts</td>
<td>403</td>
</tr>
<tr>
<td>Working with Mail Archives</td>
<td>404</td>
</tr>
<tr>
<td>Adding a Mail Account</td>
<td>406</td>
</tr>
<tr>
<td>Delete and Restore Mail</td>
<td>408</td>
</tr>
<tr>
<td>Import Mail from an mbox</td>
<td>409</td>
</tr>
<tr>
<td>Permissions and Restrictions</td>
<td>410</td>
</tr>
<tr>
<td>Space Permissions Overview</td>
<td>412</td>
</tr>
<tr>
<td>Assign Space Permissions</td>
<td>413</td>
</tr>
<tr>
<td>Confluence Groups</td>
<td>416</td>
</tr>
<tr>
<td>Use JIRA and Confluence together</td>
<td>417</td>
</tr>
<tr>
<td>Use JIRA Agile and Confluence together</td>
<td>420</td>
</tr>
<tr>
<td>Using HipChat and Confluence together</td>
<td>421</td>
</tr>
<tr>
<td>Advanced and Special Uses of Confluence</td>
<td>422</td>
</tr>
<tr>
<td>Working with Confluence Markup</td>
<td>423</td>
</tr>
<tr>
<td>Confluence Storage Format</td>
<td>423</td>
</tr>
<tr>
<td>Confluence Wiki Markup</td>
<td>436</td>
</tr>
<tr>
<td>Working with Confluence Gadgets</td>
<td>444</td>
</tr>
<tr>
<td>Adding a Confluence Gadget to a JIRA Dashboard</td>
<td>446</td>
</tr>
<tr>
<td>Configuring Confluence Gadgets for Use in Other Applications</td>
<td>450</td>
</tr>
<tr>
<td>Confluence Gadgets</td>
<td>454</td>
</tr>
<tr>
<td>Activity Stream Gadget</td>
<td>456</td>
</tr>
<tr>
<td>Confluence News Gadget</td>
<td>457</td>
</tr>
<tr>
<td>Confluence Page Gadget</td>
<td>457</td>
</tr>
<tr>
<td>Confluence Quicknav Gadget</td>
<td>460</td>
</tr>
<tr>
<td>Adding JIRA Gadgets to a Confluence Page</td>
<td>461</td>
</tr>
<tr>
<td>Developing Technical Documentation on Confluence Wiki</td>
<td>461</td>
</tr>
<tr>
<td>Creating your Technical Documentation Space</td>
<td>462</td>
</tr>
<tr>
<td>Using Templates in Technical Documentation</td>
<td>469</td>
</tr>
<tr>
<td>Re-using Content in Technical Documentation</td>
<td>471</td>
</tr>
<tr>
<td>Managing the Life Cycle of your Technical Documentation</td>
<td>475</td>
</tr>
<tr>
<td>Providing PDF Versions of your Technical Documentation</td>
<td>481</td>
</tr>
<tr>
<td>Exporting and Printing Technical Documentation</td>
<td>486</td>
</tr>
<tr>
<td>Essential Confluence Features for Technical Documentation</td>
<td>490</td>
</tr>
<tr>
<td>Confluence Add-ons for Technical Documentation</td>
<td>501</td>
</tr>
<tr>
<td>Further Reading about Developing Technical Documentation on Confluence</td>
<td>509</td>
</tr>
<tr>
<td>Using Confluence as a Knowledge Base</td>
<td>509</td>
</tr>
<tr>
<td>Use Confluence as your Intranet</td>
<td>511</td>
</tr>
</tbody>
</table>
Confluence User's Guide

About the Confluence User's Guide

This guide covers features and functions that are available to Confluence users and space administrators.

For information on administering your Confluence site, including customising your site, refer to the Confluence Administrator's Guide.

This guide assumes that you are using the Confluence default theme. If your Confluence site has been customised the header may look different, and menu items appear in different locations to the examples given in this guide.

- Getting Started with Confluence
  - Dashboard
  - Keyboard Shortcuts
  - Using Confluence on a Mobile Device
- Working with Spaces
  - Create a Space
  - Create a Personal Space
  - Administering a Space
  - Edit Space Details
  - Using Labels to Categorise Spaces
  - Delete a Space
  - Archive a Space
  - View Space Activity
  - View Recently Updated Content
  - Change the Look and Feel of a Space
- Pages and Blog Posts
  - Working with Pages
  - Blog Posts
  - Using the Editor
  - Move and Reorder Pages
  - Copy a Page
  - Delete or Restore a Page
  - Add, Remove and Search for Labels
  - Working with Drafts
  - Page Restrictions
  - Working with Links
  - Working with Anchors
  - Working with Tables
  - Using Autocomplete
  - Working with Page Layouts and Columns and Sections
  - Creating Beautiful and Dynamic Pages
  - Working with Templates
  - Working with Blueprints
  - Importing Content Into Confluence
  - Orphaned Pages
  - Undefined Page Links
  - View Page Information
  - Page History and Page Comparison Views
  - Using a WebDAV Client to Work with Pages
  - Working with Macros
- Working with Files
  - Displaying Files and Images
  - Uploading Files
  - Managing Files
  - Collaborating on Files
  - Office Connector Prerequisites

Downloads

Download the Confluence documentation in PDF format.

Other Resources

Confluence Administrator's Guide
Confluence Knowledge Base
Atlassian Answers
• Editing Office Files
• Sharing Content
  • Network Overview
  • Likes and Popular Content
  • User Status Updates
  • Using Mentions
  • Share a Page or Blog Post
  • Commenting on pages and blog posts
  • Exporting Content to Word, PDF, HTML and XML
• Your Confluence
  • Change Your Password
  • Edit Your User Settings
  • Your User Profile
  • Set Your Profile Picture
  • Favourite Spaces and Pages
  • View and Revoke OAuth Access Tokens
  • Request Add-ons
  • Choose Your Home Page
• Managing Changes and Notifications and Tasks
  • Watching Pages, Spaces and Blogs
  • Managing Watchers
  • Subscribing to Email Notifications of Updates to Confluence Content
  • Subscribing to RSS Feeds within Confluence
  • Working with Tasks
  • Managing Notifications in Confluence
• Searching Confluence
  • Confluence Search Syntax
  • Confluence Search Fields
  • Searching the People Directory
  • Recently Viewed Pages and Blog Posts
• Working with Mail Archives
  • Adding a Mail Account
  • Delete and Restore Mail
  • Import Mail from an mbox
• Permissions and Restrictions
  • Space Permissions Overview
  • Confluence Groups
• Use JIRA and Confluence together
• Use JIRA Agile and Confluence together
• Using HipChat and Confluence together
• Advanced and Special Uses of Confluence
  • Working with Confluence Markup
  • Working with Confluence Gadgets
  • Developing Technical Documentation on Confluence Wiki
  • Using Confluence as a Knowledge Base
  • Use Confluence as your Intranet

Getting Started with Confluence
Dashboard

The dashboard is the front page of your Confluence site, and provides you with an overview of the site, access to the spaces you have permission to view, and provides lists of recently updated content.

You can go to the dashboard from anywhere in Confluence by choosing the site logo at the top left of the page. This may be the Confluence logo, or a customised logo set by your Confluence Administrator.

Overview of the dashboard

The dashboard is divided into these sections:

- **Welcome message**: The information that appears in the top left section of the dashboard. Confluence Administrators can customise this message.

- **Get started**: A quick-start guide for administrators. This section of the dashboard is visible to Confluence administrators and system administrators only.

  It is not configurable via the web interface, but you can update or remove it by editing the site layout.

- **Spaces, Pages, Network**: These tabs display your favourite content and people, displayed in the lower left section of the dashboard.
  - **Spaces** – displays the spaces you have marked as favourites, followed by all the spaces that you have permission to view.
  - **Pages** – displays the pages you have marked as favourites.
  - **Network** – displays the users that you are following (or who are following you).

- **Recent activity**: Tabs on the right-hand side of the dashboard, displaying recently-updated content:
  - **Popular** – displays content (that you have permission to view) that has been recently created, liked or commented on. See below for more details.
  - **All Updates** – displays updates from all spaces that you have permission to view.
  - **Favourite Spaces** – displays updates from your favourite spaces.
  - **Network** – displays updates made by the users that you are following (or who are following you).
• **Space Categories** – allows you to select a space category, and view recent updates from spaces in that category.

**Screenshot: The dashboard**

![Dashboard screenshot](image)

**More about popular content**

The **Popular** tab on the dashboard displays recent activity of the following types:

- Pages, blog posts and comments that people have recently **liked**.
- Pages and blog posts that people have recently **commented** on, and threaded comments that people have recently replied to.
- Pages and blog posts that have recently been **created**.

**Recent** means any activity in the last seven days. A **bold** link means that you have not yet visited the page.

Activity is listed in order of popularity, with the most popular at the top; likes, comments and content creations are scored equally. Activity involving people in your network ranks higher, and recent activity ranks higher than earlier activity.

**Notes**

- You can **add a new space** from the dashboard provided you have the correct permission. Choose **Create Space** at the top right of the dashboard, or on the **Spaces** tab.
- By default, the dashboard is the home page for the Confluence site. However, you can set any other page in Confluence as your home page via your **user profile** settings.
- If your site has a custom homepage, the site logo will take you to the homepage not the dashboard. You can still access the dashboard by invoking a URL like this one: https://yoursite.com/wiki/dashboard.action. See **Configuring the Site Home Page** for more details.
- Are you looking for a way to build an **RSS feed**? Choose **Help > Feed Builder**.
- Are you looking for a list of the **people** in your site? Choose **People** on the header.
- Administrators can **customise the global dashboard** that all users see.

**Keyboard Shortcuts**
Keyboard shortcuts are a great way for you to speed up your editing and viewing in Confluence.

ℹ️ This page describes the keyboard shortcuts for the English language. The shortcut keys (letters of the alphabet) may be different in other languages.

View keyboard shortcuts in Confluence

To view available keyboard shortcuts in Confluence, do any of the following:

- Choose the help icon at top right of the screen, then choose Keyboard Shortcuts.
- When viewing a page, press Shift+?.
- In the editor, choose the question mark icon on the editor toolbar.

The keyboard shortcuts dialog shows the following information:

- **General** – global, page and blog post shortcuts.
- **Editor** – text editing and formatting shortcuts.
- **Editor Autoformatting** – wiki markup and autoformatting shortcuts.

Keyboard shortcuts

Below is a list of keyboard shortcuts available in various situations in Confluence.

**Note:** If you're using Chrome or Firefox on OS X, you can use 'Cmd' or 'Control' for the shortcuts below. Safari users can only use 'Control'.

### All screens

<table>
<thead>
<tr>
<th>Shortcut</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>/</td>
<td>Enable the quick search</td>
</tr>
</tbody>
</table>
| Ctrl+S   | • Submit (where a form is active).  
|          | • Editor -- save the Confluence page.  
|          | • Outside the editor -- save the browser page. |
| G then D | Go to the dashboard |
| G then S | Browse the current space |
| G then G | Position cursor in the search box. See Searching Confluence. |
| ?        | Open the Keyboard Shortcut help |
| [        | Toggle the sidebar. |

### In the editor

<table>
<thead>
<tr>
<th>Shortcut</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Ctr+0</td>
<td>Apply the paragraph style.</td>
</tr>
<tr>
<td>Ctr+(1–6)</td>
<td>Apply a heading level (of the number chosen) to the current line.</td>
</tr>
<tr>
<td>Ctr+7</td>
<td>Apply the preformatted style.</td>
</tr>
<tr>
<td>Hotkey</td>
<td>Action</td>
</tr>
<tr>
<td>----------------</td>
<td>------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Ctr+8</td>
<td>Apply the block quote style.</td>
</tr>
<tr>
<td>Ctrl+Shift+A</td>
<td>Open the Macro Browser.</td>
</tr>
<tr>
<td>Ctrl+B</td>
<td>Make the selected text <strong>bold</strong>.</td>
</tr>
<tr>
<td>Ctrl+Shift+B</td>
<td>Format text as a bulleted list.</td>
</tr>
<tr>
<td>Ctrl+Shift+D</td>
<td>Insert wiki markup. (Opens the Wiki Markup dialog.)</td>
</tr>
<tr>
<td>Ctrl+Shift+E</td>
<td>Preview the page you are editing.</td>
</tr>
<tr>
<td>Ctrl+F</td>
<td>Open the Find and Replace toolbar.</td>
</tr>
<tr>
<td>Ctr+I (letter i, not number 1)</td>
<td>Make the selected text <em>italic</em>.</td>
</tr>
<tr>
<td>Ctrl+Shift+J</td>
<td>Insert a JIRA issue. (Opens the Insert JIRA Issue dialog.)</td>
</tr>
<tr>
<td>Ctrl+K</td>
<td>Insert a link. (Opens the Insert Link dialog.)</td>
</tr>
<tr>
<td>Ctrl+Shift+K</td>
<td>See a list of suggested pages or other locations to link to from your page. More about autocomplete...</td>
</tr>
<tr>
<td>Ctrl+M</td>
<td>Insert an image. (Opens the Insert Files and Images dialog.)</td>
</tr>
<tr>
<td>Ctrl+Shift+M</td>
<td>See a list of suggested images, documents and other files to embed in your page. More about autocomplete...</td>
</tr>
<tr>
<td>Ctrl+Shift+N</td>
<td>Format text as a numbered list.</td>
</tr>
<tr>
<td>Ctrl+S</td>
<td>Save the page you are editing.</td>
</tr>
<tr>
<td>Ctrl+Shift+S</td>
<td>Format text with a strike through.</td>
</tr>
<tr>
<td>Ctrl+U</td>
<td>Make the selected text <em>underlined</em>.</td>
</tr>
<tr>
<td>Ctrl+Y</td>
<td>Revert an action that was undone.</td>
</tr>
<tr>
<td>Ctrl+Z</td>
<td>Undo the most recent action.</td>
</tr>
<tr>
<td>Tab</td>
<td>Indent current line (only in bulleted lists and numbered lists).</td>
</tr>
<tr>
<td>Shift+Tab</td>
<td>'Outdent' current line (only in bulleted lists and numbered lists).</td>
</tr>
<tr>
<td>Shift+Enter</td>
<td>Force a line break without a paragraph break. This is a line break with no extra space.</td>
</tr>
<tr>
<td>[ then ]</td>
<td>Add a task.</td>
</tr>
</tbody>
</table>

### Tables in the editor

<table>
<thead>
<tr>
<th>Hotkey</th>
<th>Action</th>
<th>Mac OS X</th>
</tr>
</thead>
<tbody>
<tr>
<td>Ctrl+Shift+c</td>
<td>Copy the current table row, or the selected rows.</td>
<td>Cmd+Shift+c</td>
</tr>
<tr>
<td>Ctrl+Shift+i</td>
<td>Insert a table. (Opens the Insert Table dialog.)</td>
<td>Cmd+Shift+i</td>
</tr>
<tr>
<td>Ctrl+Shift+v</td>
<td>Paste the table rows from your clipboard, placing them above the current row.</td>
<td>Cmd+Shift+v</td>
</tr>
<tr>
<td>Ctrl+Shift+x</td>
<td>Cut the current table row, or the selected rows.</td>
<td>Cmd+Shift+x</td>
</tr>
</tbody>
</table>
### Adding Rows

<table>
<thead>
<tr>
<th>Shortcut</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Alt+Up Arrow</td>
<td>Add a row above the current row.</td>
</tr>
<tr>
<td>Alt+Down Arrow</td>
<td>Add a row below the current row.</td>
</tr>
</tbody>
</table>

### Autocomplete in the Editor

<table>
<thead>
<tr>
<th>Shortcut</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>[</td>
<td>See a list of suggested pages or other locations to link to from your page.</td>
</tr>
<tr>
<td>!</td>
<td>See a list of suggested images, multimedia files and documents to embed in your page.</td>
</tr>
<tr>
<td>{</td>
<td>See a list of suggestions as you begin typing a macro name.</td>
</tr>
<tr>
<td>@</td>
<td>See a list of suggested users to mention.</td>
</tr>
<tr>
<td>//</td>
<td>Insert a date using the date picker. The date picker can also be triggered by typing a date in the format dd/mm/yyyy or dd-mm-yyyy.</td>
</tr>
</tbody>
</table>

See [Using Autocomplete](#) for more information.

### View Screen

<table>
<thead>
<tr>
<th>Shortcut</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>B</td>
<td>Create a blog post.</td>
</tr>
<tr>
<td>C</td>
<td>Create a child page of your current page.</td>
</tr>
<tr>
<td>E</td>
<td>Edit a page or blog post, or return to Edit mode when previewing.</td>
</tr>
<tr>
<td>K</td>
<td>Open the Link To dialog.</td>
</tr>
<tr>
<td>L</td>
<td>Add or edit labels.</td>
</tr>
<tr>
<td>M</td>
<td>Add a comment to a page or blog post.</td>
</tr>
<tr>
<td>S</td>
<td>Share the current page</td>
</tr>
<tr>
<td>T</td>
<td>View attachments.</td>
</tr>
<tr>
<td>V</td>
<td>Return to page view (only if you are viewing page attachments).</td>
</tr>
<tr>
<td>W</td>
<td>Add or edit watchers.</td>
</tr>
</tbody>
</table>

### Workbox

<table>
<thead>
<tr>
<th>Shortcut</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>g then n</td>
<td>Open the Confluence workbox.</td>
</tr>
<tr>
<td>j</td>
<td>Move down to the next entry in the notification list.</td>
</tr>
<tr>
<td>k</td>
<td>Move up to the previous entry in the notification list.</td>
</tr>
<tr>
<td>n</td>
<td>Move down to the next notification for a particular page or blog post.</td>
</tr>
<tr>
<td>p</td>
<td>Move up to the previous notification for a particular page or blog post.</td>
</tr>
<tr>
<td>Enter</td>
<td>Open the selected notification.</td>
</tr>
</tbody>
</table>
Disabling and re-enabling keyboard shortcuts

Keyboard shortcuts are enabled by default, but you can disable general keyboard shortcuts for your personal editing sessions if you choose to. This setting won't affect other Confluence users. Editor keyboard shortcuts can't be disabled.

To disable or re-enable general keyboard shortcuts:

1. Log in to Confluence.
2. Open the keyboard shortcuts dialog, by doing one of the following:
   - Choose the help icon at top right of the screen, then choose Keyboard Shortcuts.
   - When viewing a page, press Shift+?
   - In the editor, choose the question mark icon on the editor toolbar.
3. Choose the General tab.
4. Select or clear the Enable General Shortcuts check box as required.

Notes

- **Note about supported web browsers**: Please ensure that you are using one of the web browsers supported by Confluence. If you are using an unsupported browser or browser version, some features may not work correctly. Check the Supported Platforms page to find the list of supported web browsers and browser versions on this page.
- The keyboard shortcuts dialog also displays the trigger characters for the Confluence autocomplete feature. See Using Autocomplete.
- Confluence keyboard shortcuts are consistent with JIRA keyboard shortcuts.

Using Confluence on a Mobile Device

When you access Confluence on a mobile device, you'll see a version of Confluence which is optimised for mobile viewing. Confluence chooses the mobile or desktop interface based on your device, but you can still switch to the desktop site on your mobile by choosing menu then choosing Switch to desktop version.

You can also swap from the desktop view to the mobile view if you're on a mobile device, by choosing Switch to Confluence Mobile at the top of the page.

On your supported mobile device, you can:

- View the Confluence dashboard, pages, blog posts, and user profiles.
- Add or reply to a comment on a page or blog post.
- Like a page, blog post or comment.
- Watch a page or blog post.
- See your notifications and tasks.
You can't add or edit pages or blog posts, or edit existing comments, using the mobile interface.

**The dashboard – the first thing you see**

*Screenshot: The dashboard in Confluence mobile*

Choose a tab to see:

- Popular content – what people like in your wiki.
- Recent blogs – the latest blog posts.
- Network – updates by people in your network.

Tap the links to view the full content of a page, blog post or comment.

**Searching for content and people**

Tap the menu icon to open the menu panel on the left of the page. Then type text or a person's name in the Search box. The mobile interface offers the quick navigation search, which returns matches on page title only. (See Searching Confluence.) To use the full search, switch to desktop mode.

*Screenshot: The menu in Confluence mobile*
Viewing pages, blog posts and comments

Tap a link on the dashboard or on any other page. Confluence will display the linked page, blog post or comment.

You can:

- View the content, tap a link to move to another page, and interact with the page using the standard functionality supported by mobile browsers.
- Like or unlike a page, blog post or comment.
- Watch or stop watching a page or blog post.
- Add or reply to a comment.
Viewing people’s profiles

Search for a person's name, then view that person's user profile. Tap the options to phone, SMS or email a colleague directly from your mobile device.

Following up on notifications

You can view and respond to your notifications on your phone or other mobile device. Tap the menu icon to open the menu panel on the left of the page. Choose Notifications, and tap a notification to see its details. You can reply, watch or like via the inline actions. Tap Open to open the page or blog post in a new page. For full details, see Managing Notifications in Confluence.

*Screenshot: Notifications in Confluence mobile*

Viewing tasks

You can view and manage your tasks on your phone or other mobile device too. Tap the menu icon to open the menu panel on the left of the page. Choose Tasks then tap a task to see its details.

*Screenshot: Tasks in Confluence mobile*
More things you may need to know

Some macros may not appear

Confluence macros are not yet fully supported in Confluence mobile. If you view a page that contains an unsupported macro, you will see a message inviting you to click through to the desktop version of the page.

Screenshot: Macro not rendered in Confluence mobile

Administrators can disable Confluence mobile on your site

The mobile functionality is provided by a plugin called the 'Confluence Mobile Plugin'. To remove the functionality from your site, you can disable the plugin.

Confluence mobile is a web interface, not a native app
Atlassian does not supply a native mobile application that you can download and install onto your mobile device. Confluence mobile is a web-based user interface, which Confluence displays when it detects a mobile client. See Supported Platforms for supported mobile browsers.

Working with Spaces

Confluence Spaces are containers for pages and blog posts with related content, and they come in two main varieties:

- **Site spaces** – Sometimes called ‘global’ spaces, these are areas where you can create content and collaborate with other users.
- **Personal spaces** – You, and other Confluence users, can set up a personal space. You can keep it private, or open it up for other users to view or edit. Personal spaces are listed in the People Directory.

Create a space any time you need a place to store related content by choosing **Spaces > Create space** in the Confluence header. Two of the main ways people use Confluence spaces are for teams and/or projects.

Create a space for the Marketing team, Dev team, IT team, HR team, and any team that needs to collaborate on work, and store information and files.

If you have projects, big or small, that would benefit from having a place people can work together and store related files, make a space for them too. There’s no limit to the number of spaces you can create in Confluence.

**What’s a space admin?**

Every space has at least one space admin – usually the person that created the space – and that person can grant permissions to that space, including granting space admin privileges to others. Space admins don’t have to be Confluence admins; they can be a regular Confluence user, and may only have special permissions for a single space. For example, you’ll be the space admin for your personal space.

**How is content arranged in spaces?**

Each space you create, including your personal space, is automatically created with a home page – the first page you’ll see when you navigate to the space – which you can edit to suit your needs, and you can create any number of child pages to store the content and information you need. Spaces don’t nest – you can’t have a space within a space – but pages do, so you can create as many levels of hierarchy as you need using pages.

Each space also has its own blog, allowing you to share news and make announcements. Blog posts are a great way to keep people involved in what’s going on in your team or project.

You can set different levels of access for each space using its permissions.

*Diagram: Arrangement of spaces, pages, and attachments*
View all spaces in Confluence

There are two main ways to view spaces in Confluence:

- **The dashboard** – The bottom left of the dashboard displays the first few spaces, and a list of your favourite spaces if you have any, with a link to view all spaces in the space directory.

- **The space directory** – Choose Spaces > Space directory in the Confluence header. The space directory displays a list of all the site and personal spaces you have permission to see. Filter the list of spaces by selecting from the categories on the left of the space directory.

You can mark a space as a favourite by choosing the star icon to the right of it, or categorise the space to get easy access to the content that’s most relevant to you.

The Spaces menu in the header also displays a list of your recently viewed spaces, allowing you to quickly navigate to the things you view most often.

The Spaces List macro allows you to display a list of spaces on a Confluence page, and filter them by category, if you need to.

Create a Space

When you create spaces in Confluence, you can choose to set up a space for each team, project, or a mix of both depending on your needs. You can always move pages and blog posts between spaces later if you need to.

Confluence allows you to set up a blank space, or use the handy space blueprints to make the process of setting up team, documentation, or knowledge base spaces quick and easy.
Create a space

1. Choose **Spaces > Create space** in the Confluence header
2. Select the type of space you would like to create, then choose **Next**
3. Enter details of your space including **Name** and **Space Key**, and any other information you’re prompted for depending on the blueprint you choose
4. Choose **Create**

Each space you create will automatically have a home page, which you can customise to display relevant information for people viewing the space. Space blueprints have a home page with extra features like team members in the case of the ‘team space’ blueprint.

You can also **set up a personal space** to store your own work, which you can share with others or make private. Choose **your profile picture** at top right of the screen, then choose **Add Personal Space**. See **Create a Personal Space** for more information.

Space keys

Each Confluence space has a **space key**, which is a short, unique identifier for a space, and forms part of the URL for that space. Each time you create a space, Confluence will create the space key for you, but you can override the default space key if you want to make it something more memorable.

For example, you might give your marketing team's space a key of 'marketing'. You can then navigate directly to the space using a URL like this:

```plaintext
http://my.confluenceSite.com/display/marketing/
```

Choosing a space key

Each space key:

- Must be unique
- Can contain any alphanumeric character (A-Z, a-z, 0-9)
- Can be up to 255 characters long

You can’t change the space key after you create your space, so choose your space key carefully! Personal spaces use your username as the space key.
Space blueprints

A space created using a space blueprint will have a customised homepage, sidebar and may contain page blueprints or sample content that's specific to that type of space.

When you create a space using a blueprint, a wizard will prompt you to enter information to help set up your space. For example, the Team Space blueprint asks for the members of your team, and displays them on the homepage.

The types of space blueprints available are:

- **Team space** – A great building block if you are using Confluence as an intranet or to manage teams. Team spaces highlight the members of the team, and grant permissions to those users accordingly.

- **Knowledge Base space** – This space blueprint uses search and page labels to make content easier to find, right from the space homepage. It also contains two page blueprints for creating how-to and troubleshooting articles. The templates used in these page blueprints are completely customisable to meet your needs. The Knowledge Base space blueprint also integrates with JIRA Service Desk.

- **Documentation space** – This space blueprint displays the full page tree in the sidebar and hides other sidebar features including blogs and shared links. The homepage uses search and page labels to make content easy to find. Add the 'featured' label to any page you want to highlight on the homepage. This space does not include any page blueprints but you can create and promote templates for your documentation authors to use.

Space permissions

Each space is created with a set of default permissions. The user who created a site space is automatically granted 'space admin' permissions for that space, meaning they can then grant permissions to other users and groups. See [Space Permissions Overview](#) for more information.

 соседи

## Notes

- If you've set a specific theme (such as the Documentation or other third party theme) for your whole site, spaces will be created with that theme. You may not see some space blueprint-specific sidebar customisation if you're not using the default theme.

- Administrators can disable individual space blueprints - see Administering Site Templates.

- Spaces can't be nested (you can't have a space within a space), but can be grouped using space categories.

- You can export a whole space, or part of a space, to PDF, HTML or XML.

### Create a Personal Space

Your personal space is a place where you can create your own pages and publish your own blog posts. Once you've set up your personal space, Confluence users can reach it by clicking your name in the People Directory. Visit your personal space by choosing your profile picture at the right side of the Confluence header and choosing Personal Space.

### Create your personal space

To set up your personal space, you need the 'Personal Space' permission which is assigned by a Confluence administrator. See Permissions and Restrictions and Global Permissions Overview.

To create your personal space:

1. Choose your profile picture at top right of the screen, then choose **Add Personal Space**...

2. Choose Create
You can now go ahead and update your space by customising the home page, creating more pages, and adding blog posts.

Change the permissions on your space at any time to determine who can and can't access the content. So if you want it to be a private sanctuary, that's no problem.

Change the look and feel of your space

For a really personal space, apply a different theme, or modify its colour scheme. You can also add and arrange links in the sidebar.

Administering a Space

If you're a space admin, for either a site or personal space, there are various things you can change about that space. For example, you can change the space's name, description, look and feel, and permissions. You can even create templates to speed up page creation in the space.

The space's sidebar is another area you can customise to suit your needs, by adding shortcut links or changing the space logo.

Administer a space

To view the space tools page:

1. Go to the space and choose Space tools > Permissions from the bottom of the sidebar
2. The 'Space Permissions' page displays.
The administration options are divided into the following categories. Some options may not be applicable for personal spaces.

- **Overview**
  - Space Details - see Edit Space Details
  - Space Categories - see Using Labels to Categorise Spaces
  - Delete Space - see Delete a Space
- **Permissions**
  - Permissions - see Assign Space Permissions
  - Restricted Pages - see Page Restrictions
- **Content Tools**
  - Templates - see Working with Templates
  - Orphaned Pages - see Orphaned Pages
  - Undefined Pages - see Undefined Page Links
  - Attachments - see Managing Files
  - Trash - see Delete or Restore a Page.
  - Export - see Exporting Content to Word, PDF, HTML and XML
  - RSS Feeds - see Using pre-specified RSS feeds
  - Import - see Importing Pages from Disk. Not available for personal spaces.
- **Look and Feel**
  - Themes – see Applying a Theme to a Space
  - Colour Scheme – see Editing a Space's Colour Scheme
  - Layout - see Customising Space Layouts
  - Stylesheet - see Styling Confluence with CSS
  - PDF Layout – see Customising Exports to PDF
  - PDF Stylesheet – see Customising Exports to PDF
- **Integrations**
  - Application Links – see Linking to Another Application
  - Mail Accounts – see Working with Mail Archives. Not available for personal spaces.
  - Mailbox Import – see Import Mail from an mbox. Not available for personal spaces.
  - Mail – see Working with Mail Archives. Not available for personal spaces.

You can also customise the sidebar, including changing the space logo and adding shortcuts to other spaces - see Configure the Sidebar for more information.
Administer a space that uses the Documentation theme

In this theme, the standard Confluence sidebar is replaced by a page navigation sidebar. As a result, the layout of the space administration options are slightly different.

To view the space admin page:

1. Go to the space you wish to manage
2. Choose Browse > Space Admin from the header

Note: The Space Admin option appears only if you have space admin permissions, or if you’re part of the 'confluence-administrators' group.

The 'Space Details' page displays. For spaces using the Documentation theme, the administration options are divided into the following categories:

- **General**
  - Space Details – see Edit Space Details.
  - Space Categories – see Using Labels to Categorise Spaces.
  - Templates – see Working with Templates.
  - Delete Space – see Delete a Space.
  - Trash – see Delete or Restore a Page.
- **Security**
  - Permissions – see Assign Space Permissions.
  - Restricted Pages – see Page Restrictions.
  - Application Links – see Linking to Another Application.
- **Mail**
  - Mail Accounts – see Working with Mail Archives
  - Mailbox Import – see Import Mail from an mbox
- **Look and Feel**
  - Themes – see Applying a Theme to a Space.
  - Colour Scheme – see Editing a Space's Colour Scheme.
  - PDF Layout – see Customising Exports to PDF.
  - PDF Stylesheet – see Customising Exports to PDF.
  - Change Space Logo – see Change the Space Logo.
- **Import**
  - Import Pages from Disk – see Importing Pages from Disk.

**Edit Space Details**

Space details are the name, description, home page, and archived status of a space, which you can edit if you're an administrator of the space.

You can also view the space key and the space creator's name, but you can't edit them.

To edit a space's details:

1. Go to the space and choose Space tools > Overview from the bottom of the sidebar
   If your space uses the Documentation theme, choose Browse > Space Admin in the header.
2. Choose Edit Space Details
3. Update any of the following:
   - Name
   - Description
   - Status – Set the status to 'Archived' if you want to archive the space.
   - Home page – Start typing the name of a page in the space, then select it to set it as the new home page. This is the page you'll see when you navigate to the space. If you set this field to blank (no selection) the default home page will be the 'Pages' page.

The space fields don't accept wiki markup; if you enter wiki markup in these fields, it'll be displayed as
plain text. You can also change the name of a space via the sidebar.

Using Labels to Categorise Spaces

A space category is a label that you can apply to a space for the purpose of grouping your spaces in the space directory, and in the recent activity area of the dashboard.

For example, if you have a space for each of your projects, you can add a category of 'project' to each of those spaces. It'll mean they're easy to find if your Confluence site has a lot of spaces, which are a mix of project, team, personal, and other spaces.

Add as many space categories as you think you need; it's just like adding labels to a page or blog post.

You need to be an administrator of the space to add categories to it.

Categorise a space

1. Go to the space and choose Space tools > Overview from the bottom of the sidebar
2. Choose Edit next to Space Categories
3. Under Space Categories, enter your category name and choose Add
   Alternatively, choose a category in the list of Suggested Space Categories
4. Choose Done

Is your space using the Documentation theme?

If your space is using the Documentation theme:

1. Choose Browse > Space Admin from the header
   Note: The Space Admin option appears only if you have space admin permissions, or if you're part of the 'confluence-administrators' group.
2. Choose Space Labels in the space administration options
3. Under Space Categories, enter your category name and choose Add
Alternatively, choose a category in the list of **Suggested Space Categories**.

4. Choose **Done**

### Categories in the space directory

Once you’ve categorised some spaces, you can view your categories by choosing **Spaces > Space directory** in the Confluence header, then choosing one of your categories from the list on the left.

You can also view spaces by category in the **Space Categories** tab of the recent activity section on the dashboard, or embed the **Spaces List Macro** on any page and allow filtering by category.

### Remove a space from a category

To remove a space from a category, follow the above steps to **add a space category** but, instead of adding a new category, choose the **x** next to the space category you want to remove. If you remove all spaces from a category, the category will also be removed.

*Screenshot: Space categories*

### Delete a Space

Deleting a space permanently removes the space and all of its contents. To delete a space you must be an administrator of the space.

⚠️ Deleting a space is permanent. If you’re unsure, always create an XML backup of the space before proceeding. You can also choose to backup the attachments if you need to.

Once you’ve deleted the space, there is no way to restore it unless you’ve made an XML space backup.

See **Restoring a Space**.

**To delete a space:**

1. Go to the space and choose **Space tools > Overview** from the bottom of the sidebar
2. Choose **Delete Space**
3. Choose **OK**

If your space is using the Documentation theme:

1. Choose **Browse > Space Admin** from the header
   
   **Note:** The **Space Admin** option appears only if you have space admin permissions, or if you’re part of the ‘confluence-administrators’ group.

2. Choose **Delete Space** in the space administration options
3. Choose **OK**

   **Note:** Members of the confluence-administrators group can also delete spaces, including personal spaces.

**Related pages:**

- Archive a Space
- Copying or Renaming a Space
- Exporting Content to Word, PDF, HTML and XML
Archive a Space

You can archive a space, so that its content is less visible but it's still available in your Confluence site. You need to be an administrator of the space to archive it.

If you want the space to be fully visible again, you can change its status from archived to current at any time.

Archive a space

1. Go to the space and choose Space tools > Overview from the bottom of the sidebar
2. Choose Edit Space Details
3. Select Archived in the Status dropdown menu
4. Choose Save

If your space uses the Documentation theme:

1. Choose Browse > Space Admin from the header
   
   **Note:** The Space Admin option appears only if you have space admin permissions, or if you're part of the 'confluence-administrators' group.
   
   The 'Edit Space Details' screen appears.
2. Select Archived from the Status dropdown menu
3. Choose Save

The effect of archiving a space

If a space is archived:

- The pages and other content don't appear in the Confluence quick navigation aid, which drops down when you enter text in the search box.
- By default, the pages and other content don't appear in the Confluence search results. If a Confluence site contains any archived spaces, the search screen will provide an option to include them in the search results.
- The space and its pages don't appear on the dashboard.
- Updates to the space's content don't appear in activity streams, such as the recent updates section of the dashboard.
- The space doesn't appear in space-selection dropdown menus. Similarly, its pages and other content don't appear in any dropdown menus in the Confluence user interface.
- In the space directory, the archived space won't appear in the general space lists. Archived spaces appear in the archived spaces tab. They'll also appear in the category tabs, as determined by their labels.

These functions remain available for archived spaces:

- You can view the content as usual, by following a link or typing in a URL belonging to the archived
You can edit the content as usual, as determined by the space permissions. RSS feeds, watches and notifications remain active.

Archiving a space has no effect on search results of external search engines. For example, the space will still appear in Google search results.

**View Space Activity**

Space activity information is **disabled by default**, and the ‘Activity’ tab won’t be visible unless the Confluence Usage Stats plugin is enabled. See notes below.

If enabled, the space activity screen displays statistics on the activity in each space. These include:

- How many pages and blog posts have been viewed, added or updated over a given period.
- Which content is the most popular (most frequently viewed).
- Which content is the most active (most frequently edited).
- Which people are the most active contributors/editors of content.

**To view the activity in a space:**

1. Go to the space and choose **Space Tools** at the bottom of the sidebar.
2. Choose **Activity**

You'll see a graphic display of the number of pages and blog posts that have been viewed, added, and edited, showing trends over a period of time.

*Screenshot: The Space Activity tab*

In addition to the graphical representation of Views and Edits, the top ten most popular and most active pages and/or blog posts will be listed, with a link to each.

*Screenshot: Popular content, active content, and active contributors.*
Notes

- To view Space Activity the Confluence Usage Stats system plugin must be enabled. This plugin is known to cause performance problems on large installations and in Confluence Cloud, and is disabled by default. System administrators can enable this plugin (go to add-ons, select System add-ons and search for 'Confluence Usage Stats').
- The plugin collects data only when it's activated.
- If you're using Confluence Data Center, space activity information isn't available.
- Page hits aren't unique - the graph on the Space Activity screen includes all page hits, including multiple visits by the same user.

View Recently Updated Content

The 'Recently Updated' view is a useful way of keeping track of the changes being made in a space. It displays links to the most recently added or modified content within the space, including pages, blog posts, mail messages and comments.

If you want to display a list of recently updated content on a page, try the Recently Updated Macro.

To view the recently updated content in a space, go to the space and choose Pages in the sidebar. If the space is using the Documentation theme, choose Browse > Pages in the header, then choose Recently Updated.

You'll see a list of the most recently added or modified content in the space. Choose any of the links to open the corresponding content.

Change the Look and Feel of a Space

You can customise the 'look and feel' of a space on your Confluence site through options available in the Space Administration menu. By default, the look and feel of a space is based on site-wide settings configured from the Administration Console.

You need to be a space administrator to change the look and feel of a space.

- Applying a Theme to a Space
- Configure the Sidebar
- Change the Space Logo
Applying a Theme to a Space
Themes allow you to personalise the 'look and feel' of Confluence. You can apply a theme to your entire Confluence site or to individual spaces. Choose a specific theme if you want to add new functionality or significantly alter the appearance of Confluence.

Confluence comes with a selection of themes. In addition, a site administrator can install new themes as plugins via the Confluence Administration Console. Provided that the theme is installed into your Confluence site, any space administrator can apply a theme to a space.

By default when you create a new space, the space will have the Confluence default theme.

To apply a theme to a space:
1. Go to the space and choose Space tools > Look and Feel from the bottom of the sidebar. You'll need Space Admin permissions to do this.
2. Choose Themes and select a theme option.
3. Choose Confirm.

Want to customise Confluence or make it even more beautiful? Try a Confluence theme from the Atlassian Marketplace.
If your space is using the Documentation theme:

1. Choose **Browse > Space Admin** from the header

   **Note:** The **Space Admin** option appears only if you have space admin permissions, or if you're part of the 'confluence-administrators’ group.

2. Choose **Themes** from the space administration options

3. Select a theme option.

4. Choose **Confirm**.
Using the Documentation Theme

The Documentation theme is one of the themes bundled with Confluence. It provides an inbuilt table of contents for your space, a configurable header and footer, and text styles suited to documentation. You can also configure it to restrict the search results to the current space, rather than searching the entire Confluence site.

⚠️ Please note, the Documentation theme doesn’t support the JIRA links feature.

Advance warning of plans to merge Documentation theme with the default theme

This is an advance notice that we plan to merge the functionality of the Confluence Documentation theme with the Confluence default theme. We do not yet have a specific date for this plan, and we are interested in your feedback. The new default theme, introduced with Confluence 5.0, includes a sidebar with contextual navigation. Our plan is to include features from the Documentation theme in the default theme, and then remove the Documentation theme from Confluence.

If you are interested in this change and would like to give us feedback, please add a comment on this blog post: Advance warning of plans to merge Documentation theme with the default theme. We are especially interested to know which features of the Documentation theme you use and value the most.

Quick guide to using the Documentation theme:

- The left-hand panel contains a page tree. This is a table of contents that shows the pages in the space.
- Pages with arrow symbols to their left have child pages. Choose the arrow(s) to show and hide child pages.
- Drag the thick vertical bar between the left-hand panel and the page to change its width.
- Choose the left-hand panel icon in the header, next to the search field, to hide or show the left-hand panel.
  Alternatively, press '[' on your keyboard to show/hide the left-hand panel.
- Overriding a space-restricted search: If your theme is configured to restrict the search to the current space, you can enter 'all:' and your search term to search the entire site.

Diagram: The Documentation theme with default settings
Customise the Documentation Theme

A space administrator can customise the Documentation theme as follows:

- Change the content in the left-hand panel and add a header and footer to the page.
- Restrict the search so that it will show results from the current space only, not from the entire Confluence site.

For more, see Configuring the Documentation Theme

Diagram: The Documentation theme with space-restricted search

Search the space or the site

When using the Documentation theme, the Confluence search offers a few options as described below.

Using the search box at the top right of the page:

- By default, the main Confluence search is configured to search the entire Confluence site.
- You will see the words ‘Search Confluence’ in the search box at top right of the page.
The Confluence search will look for matches in the entire Confluence site. This is the default behaviour for other themes too.

A space administrator can configure the Documentation theme to restrict the search to the current space.

- You will see the words **Search this space** in the search box at top right of the page.
- The search will return results from the current space only.
- You can override the search restriction. Enter 'all:' and your search term to search the entire site. For example, enter the following into the search box at top right of the page to search the entire site for 'technical writing':

  all: technical writing

Using the search box in the left-hand panel:

- By default, the Documentation theme's left-hand panel includes a search box. Enter your search term there, to restrict the search to the current space. Specifically, this will search only the pages that are children of the space's home page.
- If your administrator has restricted the main search to the current space, there will not be a search box in the left-hand panel.

**Hints and tips**

Below are some hints that you may find useful when using the Documentation theme.

Where can I see a working example of the Documentation theme?

The Confluence documentation uses the Documentation theme. If you are reading this documentation online on the Atlassian documentation wiki, you are seeing a working version of the Documentation theme.

Which pages will appear in the Documentation theme's table of contents?

The theme constructs the page tree in the left-hand panel from all pages that are child pages of the space's home page. Each space has a single page designated as the 'Home' page. You can specify the home page in the space administration section.

Help, my pages do not appear in the Documentation theme table of contents

**Cause 1: Your pages are not under the space's home page.** The most probable reason why your pages do not appear in the page tree in the left-hand panel is this: The theme constructs that table of contents from all pages that are child pages of the space's home page. If your pages are above the home page in the page tree, they will not appear in the left-hand panel.

There are two ways to fix the problem:

- You can change the designated space home page in the space administration section.
- Or you can drag and drop all your pages to make them children of the current home page. You can drag and drop pages in the 'Pages' section of the space 'Browse' screen. See Move and Reorder Pages.

**Cause 2: Problem with upgrade from Confluence 3.1, with Documentation theme as plugin, to Confluence 3.2 or later with Documentation theme bundled.** If your existing Confluence installation already has the Documentation theme plugin installed, you may find that after upgrading to Confluence 3.2 the left-hand navigation bar is empty in the spaces that use the theme. The fix is to enable all modules of the Documentation theme plugin. See the knowledge base article.

Help, my left-hand panel has disappeared

If your entire left-hand panel has disappeared when using the Documentation theme, this is probably because you have clicked the sidebar icon at top right, next to the search box. Click the icon again to restore the panel.

Can I change the default width of the left-hand navigation panel?

The Confluence user interface does not offer a way to change the default width of the left-hand navigation panel supplied by the Documentation theme. Users can change the width by dragging the middle bar, but the default width is not configurable. This post on Atlassian Answers gives a way to do it with CSS: Documentati
Notes

- The Confluence default theme supplies a sidebar, which is different to the left-hand panel in the Documentation theme. For information about the sidebar, see Configure the Sidebar.
- The Documentation theme supplies a Browse menu in the Confluence header, which gives access to the space administration and advanced options.

Configuring the Documentation Theme

The Documentation theme is one of the themes bundled with Confluence.

Advance warning of plans to merge Documentation theme with the default theme

This is an advance notice that we plan to merge the functionality of the Confluence Documentation theme with the Confluence default theme. We do not yet have a specific date for this plan, and we are interested in your feedback. The new default theme, introduced with Confluence 5.0, includes a sidebar with contextual navigation. Our plan is to include features from the Documentation theme in the default theme, and then remove the Documentation theme from Confluence.

If you are interested in this change and would like to give us feedback, please add a comment on this blog post: Advance warning of plans to merge Documentation theme with the default theme. We are especially interested to know which features of the Documentation theme you use and value the most.

The Documentation theme is designed for spaces containing technical documentation, but you may find it useful for other types of structured content. It provides a table of contents for your space, a configurable header and footer, and text styles suited to documentation. (See features below.)

Quick guide to applying and customising the Documentation theme:

- Go to the space and choose Space tools > Look and Feel from the bottom of the sidebar.
- Choose Themes.
- Select Documentation Theme and choose Confirm.
- If you want to customise the theme, choose Configure theme.
  - Select or deselect the default page tree.
  - Select or deselect the space-restricted search.
  - Enter the text and wiki markup for your custom left-hand panel header and footer.
  - Choose Save.

The rest of this page gives more details of the above procedure.

On this page:

- Applying the Documentation theme to your space
- Applying the Documentation theme to your site
- Customising the Documentation theme
  - Customising the theme at site level
- Features of the Documentation theme
- Hints and tips
- Notes

Related pages:

- Using the Documentation Theme
- Space Jump Macro
- Applying a Theme to a Space
- Applying a Theme to a Site
- Editing a Space's Colour Scheme
- Change the Look and Feel of a Space
- Confluence User's Guide

Screenshot: The Documentation theme showing the space sidebar replaced by a navigation sidebar.
Applying the Documentation theme to your space

Follow the steps below to apply the Documentation theme to your space. All pages in the space will start using the theme immediately.

**To apply a theme to a space:**

1. Go to the space and choose **Space tools > Look and Feel** from the bottom of the sidebar. You'll need **Space Admin permissions** to do this.
2. Choose **Themes** and select a theme option
3. Choose **Confirm**

*Screenshot: Applying a theme*
If your space is using the Documentation theme:

1. Choose Browse > Space Admin from the header
   
   **Note:** The Space Admin option appears only if you have space admin permissions, or if you're part of the 'confluence-administrators’ group.
2. Choose Themes from the space administration options
3. Select a theme option
4. Choose Confirm

*Applying the Documentation theme to your site*
If you have site administrator permissions, you can apply the theme at site level. It will then be the default theme for all spaces in the site. See the administrator's guide to applying a theme.

Customising the Documentation theme

The theme works well without any customisation. If necessary, you can restrict the search to just one space, change the content of the left-hand navigation panel and add your own header and footer. The following instructions assume you have already applied the Documentation theme.

To customise the Documentation theme:

1. Choose Browse > Space Admin from the header

   Note: The Space Admin option appears only if you have space admin permissions, or if you’re part of the 'confluence-administrators' group.

2. Choose Themes in the left-hand panel under the heading 'Look and Feel'.

3. Choose Configure theme in the yellow area of the 'Current Theme' section at the top of the page. See screenshot below. The 'Documentation Theme Configuration' screen appears. See screenshot below.

4. Select or deselect the Page Tree check box. This determines whether your space will display the default search box and table of contents (page tree) in the left-hand panel.

5. Select or deselect the Limit search results to the current space check box.
   - If you select the check box:
     - The Confluence search will look for matches only in the current space by default. Users can override this restriction when entering their search term. See Using the Documentation Theme.
     - The default page tree in the left-hand panel will not include a search box.
   - If you do not select the check box:
     - The Confluence search will look for matches in the entire Confluence site. This is the default behaviour for other themes too.
     - The default page tree in the left-hand panel will include a search box, which restricts search results to the current space.

6. Enter text, images, macros and other wiki markup into any or all of the three text boxes. You can use the Include or Excerpt Include to include re-usable content into your footer. See hint below.
   - 'Navigation' – This text box contains content for the left-hand panel.
     - If the Page Tree check box is selected, the navigation panel contains the default search box and page tree. Any content you enter into the 'Navigation' text box will appear above the page tree and search box.
     - You can include your own content underneath the page tree as well as above. See hint below. In summary: Deselect the Page Tree check box. Insert your own page tree using the Page Tree macro, then add your own content under the macro.
   - 'Header' – This text box contains content for a page header that will appear above the page title on all pages in the space. See example screenshot below.
   - 'Footer' – This text box contains content for a page footer that will appear after the comments and above the site footer, on all pages in the space. See example screenshot below.

7. Choose Save.

Screenshot: The 'Configure theme' option
Current Theme

The current theme controls the layout and colours of this space.

**Documentation Theme**
This theme is well suited for structured content, such as documentation. It features a table of contents (page tree) on the left, making it easier to see the structure of a space and move from page to page. You can customise the left-hand panel, page header and page footer.

Configure theme - further customise this theme's options

Choose New Theme

To change the theme of this space, select one below.

- **Global Look and Feel**
The globally configured look and feel. You can customise colour-schemes and layouts manually.

Find more themes...

Confirm

Screenshot: Customising the Documentation theme
Navigation

- Page Tree
  Show the page tree in the sidebar.

- Limit search results to the current space
  Limit search results returned by the top right search field to the current space.

Add your own links and content to the sidebar using wiki markup.

Messages

Header
{section}
{column:width=1%}{column}
{column}{panel}
{include:_MajorReleaseNumberConfluence|nopanel=true}*

-- This documentation is for *Confluence 5.0*
developer (EAP) releases only. Not for you? *See

Display a banner or text at the top of every page in this space by entering wiki markup here.

Footer
{include:_DocumentationFooter|nopanel=true}
{include:ALLDOC:_CopyrightNotice|nopanel=true}

Display a banner or text at the bottom of every page in this space by entering wiki markup here.
Customising the theme at site level

If you have site administrator permissions, you can apply and customise the theme at site level. The customisation options are the same as the space level options, as described above.

Features of the Documentation theme

Screenshot: A customised header, footer and left-hand panel

The above screenshot shows a wiki space with a customised left-hand panel, header and footer.

Here is a summary of the features that the Documentation theme provides:

- By default, the left-hand panel contains a search box and a table of contents (page tree) showing all the pages in your space. Specifically, it shows the pages that are children of the space’s home page.
- The left-hand panel is fully customisable. You can choose to include or exclude the search box and page tree. You can enter your own text, images and wiki markup.
- People viewing the page can drag the thick bar between the left-hand panel and the content, to increase or decrease the width of the panel. They can also remove the panel altogether, by clicking the sidebar icon at top right, next to the search box.
- The left-hand and right-hand panels scroll independently of each other.
- The page title is neatly above the page content, and not uncomfortably above the navigation panel as tends to happen when you insert the navigation panel yourself.
- Because the left-hand panel is part of the theme, it will be upgraded whenever Confluence is upgraded. There is no need to remove and then re-apply your customisations on each upgrade, as you would do if
Hints and tips

Below are some hints that you may find useful when using the Documentation theme. Where can I see a working example of the Documentation theme?

The Confluence documentation uses the Documentation theme. If you are reading this documentation online on the Atlassian documentation wiki, you are seeing a working version of the Documentation theme.

Which pages will appear in the Documentation theme’s table of contents?

The theme constructs the page tree in the left-hand panel from all pages that are child pages of the space’s home page. Each space has a single page designated as the ‘Home’ page. You can specify the home page in the space administration section.

Help, my pages do not appear in the Documentation theme table of contents

Cause 1: Your pages are not under the space’s home page. The most probable reason why your pages do not appear in the page tree in the left-hand panel is this: The theme constructs that table of contents from all pages that are child pages of the space’s home page. If your pages are above the home page in the page tree, they will not appear in the left-hand panel.

There are two ways to fix the problem:

- You can change the designated space home page in the space administration section.
- Or you can drag and drop all your pages to make them children of the current home page. You can drag and drop pages in the ‘Pages’ section of the space ‘Browse’ screen. See Move and Reorder Pages.

Cause 2: Problem with upgrade from Confluence 3.1, with Documentation theme as plugin, to Confluence 3.2 or later with Documentation theme bundled. If your existing Confluence installation already has the Documentation theme plugin installed, you may find that after upgrading to Confluence 3.2 the left-hand navigation bar is empty in the spaces that use the theme. The fix is to enable all modules of the Documentation theme plugin. See the knowledge base article.

Help, my left-hand panel has disappeared

If your entire left-hand panel has disappeared when using the Documentation theme, this is probably because you have clicked the sidebar icon at top right, next to the search box. Click the icon again to restore the panel.

Can I change the default width of the left-hand navigation panel?

The Confluence user interface does not offer a way to change the default width of the left-hand navigation panel supplied by the Documentation theme. Users can change the width by dragging the middle bar, but the default width is not configurable. This post on Atlassian Answers gives a way to do it with CSS: Documentation Theme - Default Width (in px) of left panel.

Hiding pages from the left-hand table of contents

You can ‘hide’ pages by putting them at the same level as or higher than the space home page.

Each space has a single page designated as the ‘Home’ page. You can specify the home page in the space administration section.

The theme constructs the page tree in the left-hand panel from all pages that are child pages of the space’s home page.
If your documentation pages are at the same level as the space home page, they will not appear in the left-hand navigation bar. So you can ‘hide’ pages by putting them at the same level as or higher than the space home page. The pages will show up in the search results and people can see the content if they open the page, but the pages will not appear in the left-hand panel.

More detail: The theme uses the Pagetree macro to produce the table of contents. When entering the Pagetree macro, you can choose the top page in the page tree. The Documentation theme chooses the space home page as the top page.

Using reusable content in your header, footer or sidebar

You can use any text or wiki markup in your theme header, footer or left-hand panel. One useful hint is to use the Include or Excerpt Include to include re-usable content into your footer.

The screenshot above shows the theme customisation options, with examples of the macros used to include content from other pages. And the example screenshot also above shows the resulting header, footer and left-hand panel.

Adding content below the page tree in your sidebar

If you want to include your own content underneath the page tree, you can deselect the ‘Page Tree’ check box, add your own page tree using the Pagetree macro in the ‘Navigation’ text box, and then add your own content under the macro.

The screenshot above shows the theme customisation options, with the default page tree deselected and a custom page tree inserted, along with additional content in the left-hand panel. The example screenshot also above shows the resulting left-hand panel.

Adding an expanding All Versions section to the sidebar

If you want to include a an expanding list of links to other spaces, as we have included in this space (see ‘Docs for all Confluence releases’ in the sidebar), you can use an Expand Macro and an Include Page Macro in the ‘Navigation’ text box. For example:

```
*{Docs for all Confluence releases|_Latest Versions of Confluence Documentation}*
{expand:Choose a version...}
{include:_Latest Versions of Confluence Documentation}
{expand}
```

If you would like this to display below the page tree, follow the steps above.

Adding underlines to your links

By default, the Documentation theme does not underline hyperlinks. If you prefer to have your links underlined, you can edit the CSS stylesheet for your space and add the following CSS code:

```
.wiki-content a:link, .wiki-content a:visited, .wiki-content a:active {
  text-decoration: underline;
}
```

To edit a space’s CSS style sheets:

1. Go to the space and choose Space tools > Look and Feel from the bottom of the sidebar.
2. Choose Stylesheet then Edit.
3. Paste your custom CSS into the text field.
4. Save your changes. The new CSS will be visible on all content pages in the space.

If your space uses the Documentation theme:

1. Choose Browse > Space Admin from the header

Note: The Space Admin option appears only if you have space admin permissions, or if you’re part of the ‘confluence-administrators’ group.
2. Click **Stylesheet** in the left-hand panel under the heading 'Look and Feel'.
3. Choose **Edit**.
4. Paste your custom CSS into the text field.
5. Save your changes. The new CSS will be visible on all content pages in the space.

**Note:** By default, only system administrators can edit the CSS for a space or for the site. To allow any user with Space Admin permissions to edit the CSS for a space, go to **Administration** > **General Configuration** > **Security** > **Configuration** and select **Custom Stylesheets for Spaces**.

Jumping to the same page in another space

The `{spacejump}` macro is provided along with the Documentation theme. You can use space jumping to link from a page in one wiki space to a page with the same name in another space, without knowing the name of the page when you create the link. When a reader is viewing a page and chooses the link provided by the macro, they will go to a page with the same name, but in the space specified in the macro. See more about the Space Jump macro.

Hiding the left-hand panel completely

It's not possible to remove the left-hand panel entirely, using the user interface supplied by the theme. There is an improvement request here:

[CONF-25923](https://confluence.atlassian.com/conf-25923) - Provide option to hide the left-hand panel entirely in the Documentation theme

RESOLVED If you like, you can comment on and/or vote for that request. In the meantime, Atlassian Answers is a good place to ask the question and see if other people can help you with custom code to remove the panel.

**Notes**

- The Confluence default theme supplies a sidebar, which is different to the left-hand panel in the Documentation theme. For information about the sidebar, see **Configure the Sidebar**.
- The Documentation theme supplies a **Browse** menu in the Confluence header, which gives access to the space administration and advanced options.

**Configure the Sidebar**

If you're an **admin for a space**, you can make changes to the space's sidebar like changing the space's name, logo, or the way the page hierarchy is displayed. You can also add shortcut links to the sidebar to help you and others navigate to important content quickly.

The default and documentation themes in Confluence both feature a sidebar. If you're using a third party theme, it may not feature a sidebar.

On this page we'll cover how to customise the sidebar in the default theme. If you want information on the sidebar in the Documentation theme, see **Configuring the Documentation Theme**.

Configure a space's sidebar

To start configuring the sidebar, choose **Space tools** at the bottom of the sidebar, then choose **Configure sidebar**.

From there you can:

- Change the space name and/or space logo:
1. Choose the edit icon next to the space name
2. Type in a space Name and/or choose Upload an image to change the space logo
3. Choose Save

- Configure the Pages and Blog links:
  - Choose the icons to hide or show the 'Pages' or 'Blog' link.
  - Drag the links to a different sequence within the section (you can't move a link from one section to another).
  - Add-ons may add other links in this section of the sidebar. For example, the Team Calendars add-on may put a link in this location.

- Add or remove the shortcut links:
  - Choose Add link to add a shortcut link to the sidebar. This can be a link to an important page for your team, or to an external site, for example.
  - Choose the icon to remove a shortcut link.
  - Drag the links to a different sequence within the section. Note that you cannot move a link from one section to another.

- Change the navigation display options:
  - Choose Child pages to see the current page and its children in the sidebar.
  - Choose Page tree to see the page tree for the entire space, expanded to the current page.

### Change the Space Logo

In Confluence, you can replace the default space logo with an image of your choice. If you have team spaces, you can use an icon that represents the team, or if it's a space for a client, add their company logo to really impress them.

The instructions below apply to site spaces. For your personal space, your profile picture is used as the space icon.

You need to be a space administrator to replace a space’s logo.

**To change a space's logo, in spaces using the default theme:**

1. Go to the space and choose Space tools > Configure sidebar from the bottom of the sidebar
2. Choose the edit icon next to the space name
3. Choose Choose File
4. Browse to find and upload an image
5. Adjust the size of the image to fit within the highlighted circle
6. Choose Save

**To change a space's logo, in spaces using the Documentation theme:**

1. Choose Browse > Space Admin from the header
   
   **Note:** The Space Admin option appears only if you have space admin permissions, or if you’re part of the 'confluence-administrators' group.
2. Choose Change Space Logo in the left-hand panel
3. Use the browse option to locate the new logo and choose Upload

**Screenshot: Changing a space logo in the default theme**
Customising Space Layouts

You can modify Confluence's look and feel by editing the layout files. This page tells you how to customise the layout files for a space. You will require need space administrator permissions for that space.

If you're a Confluence system administrator, you can also customise the layout of your entire Confluence site. For more information, see Customising Site and Space Layouts. Site layout customisations modify the default layout of all spaces in the Confluence site.

Any space layout customisations will override the equivalent site customisations.

Notes

- **Minimum dimensions:** Space logos are set at 48 x 48px. Logos less than these dimensions will be centred with whitespace around them.
- **Space logos in the default theme are circular.**
- **Dimensions of image when using the Documentation theme:** The documentation theme does not provide an option to resize or crop your image. Uploading a square image will give the best results.
If you modify the look and feel of Confluence by following these instructions, you will need to update your customisations when Confluence is upgraded. The more dramatic the customisations are, the harder it will be to reapply your changes when upgrading. Please take this into account before proceeding with any customisations.

For more information on updating your customisations, please refer to Upgrading Customised Site and Space Layouts.

Related pages:
- Change the Look and Feel of a Space
- Applying a Theme to a Space
- Confluence User's Guide

Confluence is built on top of the Open Source SiteMesh library, a web-page layout system that provides a consistent look and feel across a site. SiteMesh works through 'decorators' that define a page's layout and structure.

To edit the layout of Confluence, you will need to modify these decorator files. A decorator file is a .vmd file and is written in a very simple programming language called Velocity. Learn more about Velocity. Once you become familiar with Velocity, you can edit the decorator files to personalise the appearance of Confluence.

The decorator files in Confluence are grouped into the following categories:

- **Site layouts**: These are used to define the controls that surround each page in the site. For example, if you want to make changes to the header and the footer, you will need to modify these layouts.

- **Content layouts**: These control the appearance of content such as pages and blog posts. They do not change the way the pages themselves are displayed, but they allow you to alter the way the surrounding comments or attachments are shown.

- **Export layouts**: These control the appearance of spaces and pages when they are exported to HTML. If you are using Confluence to generate a static website, for example, you will need to modify these layouts.

Learn more about using decorators.

To edit a decorator file:

1. Go to the space and choose Space tools > Look and Feel from the bottom of the sidebar.
2. Choose Layout (Layout is displayed only if you are a Confluence system administrator.)
3. You will see a list of the layouts for the space.
   - Click View Default to view the vmd file.
   - Click Create Custom to edit the default vmd file. This will open up the vmd file in edit mode. Make changes and click Update.

If your space uses the Documentation theme:

1. Choose Browse > Space Admin from the header

   **Note:** The Space Admin option appears only if you have space admin permissions, or if you're part of the 'confluence-administrators' group.

2. Choose Layout in the left-hand panel (Layout is displayed only if you are a Confluence system administrator.)
3. You will see a list of the layouts for the space.
   - Click View Default to view the vmd file.
   - Click Create Custom to edit the default vmd file. This will open up the vmd file in edit mode. Make changes and click Update.

Screenshot: Edit Layouts Example
**Export Layouts**

Export layouts control the appearance of spaces and pages when they are exported to HTML. If you are generate a static website, or you commonly distribute HTML exports of pages or spaces, you will probably layout.

<table>
<thead>
<tr>
<th>Decorator</th>
<th>Operations</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Space Export Layout</strong></td>
<td>&lt; default &gt; - Create custor</td>
</tr>
<tr>
<td>When you export a space to HTML, this layout is used to create the index page.</td>
<td></td>
</tr>
<tr>
<td><strong>Page Export Layout</strong></td>
<td>&lt; default &gt; - Create custor</td>
</tr>
<tr>
<td>When you perform an export, each page is converted to HTML using this layout.</td>
<td></td>
</tr>
</tbody>
</table>

Click the thumbnail to see an example of a vmd file:

**Editing a Space’s Colour Scheme**

Confluence allows you to customise the colour scheme of a space. By default, a space’s colour scheme is based on global settings configured from the Administration Console.

You need to be a space administrator to edit a space’s colour scheme.

- Change the Look and Feel of a Space
- Confluence User’s Guide

To change the colour scheme for a space:

1. Go to the space and choose **Space tools > Look and Feel** from the bottom of the sidebar.
2. Choose **Colour Scheme**.
3. Choose **Select** next to a scheme listed under **Custom Colour Scheme** (if not already selected).
4. Choose **Edit**.
5. Enter standard HTML/CSS2 colour codes, or use the colour-picker to choose a new colour from the palette provided. Any changes you make will immediately be reflected in this space.

If your space uses the Documentation theme:

1. Choose **Browse > Space Admin** from the header.
Note: The Space Admin option appears only if you have space admin permissions, or if you're part of the 'confluence-administrators' group.

2. Choose Colour Scheme under the heading Look and Feel.
3. Follow the steps above to select a custom colour scheme and edit the colours.

The colour scheme allows you to edit the colours of UI elements including the top bar, tabs and backgrounds.

Some UI elements below are for specific themes, and colour changes may not take effect for other themes.

- **Top Bar** - the top navigation bar background
- **Top Bar Text** - the text on the top navigation bar
- **Header Button Background** - buttons on the top navigation bar (e.g. Create button)
- **Header Button Text** - the text on buttons on the top navigation bar
- **Top Bar Menu Selected Background** - background colour of top navigation bar menu items when selected (e.g. spaces)
- **Top Bar Menu Selected Text** - text colour of top navigation bar menu items when selected
- **Top Bar Menu Item Text** - text on top navigation bar drop down menus (e.g. help or cog)
- **Menu Item Selected Background** - highlight colour on top navigation bar drop down menu items
- **Menu Item Selected Text** - text colour on highlighted top navigation bar drop down menu items
- **Search Field Background** - the background colour of the search field on the header
- **Search Field Text** - the colour of the text in the search field on the header
- **Page Menu Selected Background** - the background colour of the drop down page menu when selected
- **Page Menu Item Text** - the text of the menu items in the drop down page menu
- **Heading Text** - all heading tags throughout the space
- **Space Name Text** - the text of the current space name located above the page title
- **Links** - all links throughout the space
- **Borders and Dividers** - table borders and dividing lines
- **Tab Navigation Background** - the background colour of the tab navigation
- **Tab Navigation Text** - the text of the tab navigation when highlighted
- **Tab Navigation Background Highlight** - the background colour of the tab navigation when highlighted
- **Tab Navigation Text Highlight** - the text of the tab navigation elements when highlighted

Screenshot: Editing the colour scheme
Custom Colour Scheme

A custom colour scheme which can be edited.

Edit

The following colours can be customised for this colour scheme.

- **Top Bar**: #205081
- **Top Bar Text**: FFFFFF
- **Header Button Background**: #3572B0
- **Header Button Text**: FFFFFF
- **Top Bar Menu Selected Background**: #3B73AF
- **Top Bar Menu Selected Text**: FFFFFF
- **Top Bar Menu Item Text**: #333333
- **Menu Item Selected Background**: #3B73AF
- **Menu Item Selected Text**: FFFFFF
- **Search Field Background**: RGBA(0, 0.2, 0.1, 0.2)
Styling Confluence with CSS

The information in this page relates to customisations or development changes in Confluence. Consequently, Atlassian Support cannot guarantee to provide any support for the steps described on this page. Please be aware that this material is provided for your information only and that you use it at your own risk.

This page explains the facility for changing the look and feel of Confluence with CSS.

Introduction

Cascading Style Sheets (CSS) are an industry-standard way of styling a web page. The content of a page is rendered with HTML, and its look and feel is determined by CSS files. You can upload a CSS text file, or simply type in a stylesheet, and apply it to a space or even a whole Confluence site.

Note: By default, only system administrators can edit the CSS for a space or for the site. To allow any user with Space Admin permissions to edit the CSS for a space, go to General Configuration > Security Configuration and select Custom Stylesheets for Spaces.

Creating CSS styles that work seamlessly across different browsers is a delicate task for basic web sites, and reasonably challenging when customising web applications like Confluence. It is important to test each change that you make and ensure it works as expected in all areas of Confluence – for example, on the Confluence dashboard as well as on regular pages.

In order to get you started, we have compiled this introduction, a basic styling tutorial.
Considerations for Using Custom CSS

CSS Knowledge is Required

If you are not familiar with CSS, see the links in the CSS Resources section below. You should spend some time to become confident with Cascading Style Sheets before you start editing your Confluence style sheets.

Security

Custom CSS can be used to inject scripts into a page, opening the risk of cross-site scripting (XSS) attacks. With this feature enabled, space administrators could upload styles that steal other users' login credentials, trick their browsers into performing actions on the wiki without their knowledge, or even obtain global administration privileges. As such, this feature is disabled by default. Confluence administrators should only enable custom CSS if they are comfortable with the risks listed in this paragraph.

Scaling

Each page needs to scale. Depending on the resolution of the user's screen, the content should render intelligently. Your designs needs to degrade gracefully. Try resizing each page that exists in Confluence. There are quite a few pages in the browse-space-section, like drafts, labels, page hierarchy, and so on. Your style has to work everywhere, not just in the first page you happen to be looking at.

Features Cannot Be Disabled

It is easy to turn off certain links, headers, or even menu items by simply setting their style to 'hidden'. This can help you to roll out Confluence to users that may not be very Wiki-savvy yet. The simpler the UI, the easier it may be for them to use. However, please remember that removing the link to a part of the application does not mean that the functionality is not available. Every user can still change their style from within their browsers, or access the URL directly. Don't rely on CSS to disable parts of Confluence.

Features Should Not Be Disabled

Users familiar with Confluence will expect to find the same controls that they are accustomed to. Removing buttons or controls from the interface is not advised as it may frustrate your users and cause them to circumvent your design by using direct URL access, as mentioned above.

Custom CSS does not apply to Admin screens

Any CSS styling applied to your site will not be applied to the Administration console. This is to ensure changes to CSS do not prevent administrators from accessing Admin functions in future.

Confluence Version Compatibility

Be aware of any plans to upgrade your Confluence instance. Future versions of Confluence may not be compatible with your custom CSS — this may cause your CSS to break, requiring maintenance when Confluence is upgraded. Ask your Confluence administrator for more information.

Test on Different Web Browsers

As a rule you should test your modifications on different web browsers. Internet Explorer, Firefox, Opera and
Safari (on Mac OS X) are some of the more popular browsers.

**Note about supported web browsers:** Please ensure that you are using one of the web browsers supported by Confluence. If you are using an unsupported browser or browser version, some features may not work correctly. Check the Supported Platforms page to find the list of supported web browsers and browser versions on this page.

**CSS Customisation is Not Supported**

As creating custom CSS has potentially limitless possibilities, Atlassian will not support issues that are caused by or related to CSS customisation.

### Getting Started

**Editing the CSS**

**To edit a space's CSS style sheets:**

1. Go to the space and choose **Space tools > Look and Feel** from the bottom of the sidebar.
2. Choose **Stylesheet** then **Edit**.
3. Paste your custom CSS into the text field.
4. Save your changes. The new CSS will be visible on all content pages in the space.

If your space uses the Documentation theme:

1. Choose **Browse > Space Admin** from the header
   
   **Note:** The **Space Admin** option appears only if you have space admin permissions, or if you're part of the 'confluence-administrators' group.
2. Click **Stylesheet** in the left-hand panel under the heading 'Look and Feel'.
3. Choose **Edit**.
4. Paste your custom CSS into the text field.
5. Save your changes. The new CSS will be visible on all content pages in the space.

**To edit your global CSS stylesheet:**

1. Choose the cog icon, then choose **General Configuration** under Confluence Administration
2. Choose **Stylesheet**.
3. Choose **Edit**.
4. Paste your custom CSS into the text field.
5. Choose **Save**.

**Note:**

- The new CSS will be visible across all spaces, provided they do not define their own custom stylesheet and are not using a theme. This CSS will also overwrite all styles defined in custom global themes.
- You may be able to add CSS to your site by choosing **Custom HTML** in the administration section, and adding your CSS definitions to the HEAD or BODY of the page. You should only use this option if you cannot achieve the desired results via the global stylesheet.

**Follow the Tutorial**

Follow the examples in the Basic Styling Tutorial to get started.

**CSS Resources**

- W3C CSS Standards
- W3schools CSS Introduction
- Mozilla Developer Network
- W3resource.com

**Basic Styling Tutorial**

This page contains instructions on how to get started with custom CSS styling in Confluence.

**CSS Editing Quick-Start**
To edit a space's CSS style sheets:

1. Go to the space and choose **Space tools > Look and Feel** from the bottom of the sidebar.
2. Choose **Stylesheet** then **Edit**.
3. Paste your custom CSS into the text field.
4. Save your changes. The new CSS will be visible on all content pages in the space.

If your space uses the Documentation theme:

1. Choose **Browse > Space Admin** from the header

   **Note:** The **Space Admin** option appears only if you have **space admin permissions**, or if you're part of the 'confluence-administrators' group.
2. Click **Stylesheet** in the left-hand panel under the heading 'Look and Feel'.
3. Choose **Edit**.
4. Paste your custom CSS into the text field.
5. Save your changes. The new CSS will be visible on all content pages in the space.

---

**On this page:**
- CSS Editing Quick-Start
- Tutorial: Changing the Header Background
- CSS Editing Tips
- Notes

**Related pages:**
- Styling Confluence with CSS
- Confluence User's Guide

⚠️ The information on this page does not apply to Confluence Cloud.

---

**Tutorial: Changing the Header Background**

The header is the menu area at the top of a default Confluence page where the Breadcrumb Links, Browse menu, User menu and the Quick Search box reside. In this example, we are going to change the background of the header to include a custom graphic.

1. Create a custom graphic. For this example, we created a custom header graphic of 1046 x 61 pixels.
2. Upload the custom graphic to a page in the space that you are customising.
3. Note the page ID of the page where you uploaded the new graphic. (in this example, the page ID was '658833839'.)
4. Compose your custom CSS for the header. The example below loads the new graphic (called 'header.png') from a specific page (denoted by page ID '658833839') in the same space.

```css
#header .aui-header {
    background-image:url('..//download/attachments/658833839/header.png');
    background-repeat: no-repeat;
}
```

5. Log in as the Space Administrator.
6. Open the Space Admin page.
7. Click **Stylesheet**.
8. Click **Edit** to change the code in the text field.
9. Paste your custom CSS into the text field.
10. Click **Save** and then reload the page (you may have to shift-reload). The background of the header will change.
11. The custom header will be visible on all content pages in the space. To revert your change, simple delete the custom code from the ‘Stylesheet’ page and click **Save**.
**CSS Editing Tips**

Begin With a Space Stylesheet

A space stylesheet is a good starting point for CSS customisation, as it already includes all of the elements that can be changed. When you work on the space stylesheet it styles all content pages in the space. Build and test it at space-level, before considering applying the new stylesheet to your entire site. Once you are satisfied with your space design, test it thoroughly until you are confident that it has no problems. Then, you can look into advanced customisation of the Confluence CSS such as adjusting the Search page, the Dashboard and other integral pages.

Use the Right Tools

As the Confluence CSS is reasonably sophisticated, web development applications will help you to understand how the page styles have been created. In particular, you will need to view the existing source for the pages you're starting to work on. If you don't already have some, tools such as the following free applications will allow you to do this.

1. **Firebug**
   Firebug, a plugin for the Firefox web browser, allows you to take a look at the style of each element on your page. This is very useful to see what styles are currently applied, for example styles applied to the header only.

2. **Web Developer**
   The Web Developer plugin for Firefox allows you to edit CSS inline and create new page designs.

3. **CSS Edit**
   CSS Edit is a stand-alone CSS editor for Macintosh that extracts all existing styles from a given page and allows you to overwrite these.

Edit Simple Elements First

Begin by editing simple elements and checking that they work. By making changes, then checking that each one worked, you can easily isolate any CSS code that is causing problems. Be aware that some page elements are more suited to customisation than others. For example, adding a gradient to the toolbar is less likely to ‘break’ the page than changing the page width. Editing reasonably static elements such as background graphics will render more predictably than designs which attempt to completely change the user interface or the Javascript-powered drop-down menus (which we don't recommend editing).

**Notes**

**Note:** By default, only system administrators can edit the CSS for a space or for the site. To allow any user with Space Admin permissions to edit the CSS for a space, go to > General Configuration > Security Configuration and select Custom Stylesheets for Spaces.

**Styling Fonts in Confluence**

Confluence provides the ability to adjust its visual style via Cascading Style Sheets (CSS). This tutorial shows you to change the fonts and font sizes of a Confluence page, using a few lines of CSS.

**Screenshot 1: Default font in a Confluence page**

**Screenshot 2: Custom font in a Confluence page**
Below is the code for the custom font. Copy and paste it into the Space Stylesheet form within the Space Administration section.

```css
body {
  font-family: Times, "Times New Roman", serif;
  font-size: 14px;
}
.wiki-content, .wiki-content p, .wiki-content table, .wiki-content tr, .wiki-content td, .wiki-content th, .wiki-content ol, .wiki-content ul, .wiki-content li {
  font-size: 14px;
}
```

**Changing the fonts**

In order to customise the fonts in Confluence, you first need to set the body font to the font you want. Secondly, you may want to adjust the font size because different fonts have different relative sizes.

The relevant CSS is shown below. It changes Confluence's font from the default of Helvetica/Arial – *sans serif* to Times/Times New Roman – *serif*. To adjust for the fact that Times is a bit smaller than Helvetica, we increase the font size to 14 pixels. The many styles that 'wiki-content' in their definition are necessary to change the font size for all the tags in the wiki content.

**Notes**

**Note:** By default, only system administrators can edit the CSS for a space or for the site. To allow any user with Space Admin permissions to edit the CSS for a space, go to `Security` > `General Configuration` > `Security Configuration` and select `Custom Stylesheets for Spaces`.  

---

Created in 2015 by Atlassian. Licensed under a [Creative Commons Attribution 2.5 Australia License](https://creativecommons.org/licenses/by/2.5/au/).
Pages and Blog Posts

When you create any content in Confluence – whether it's taking down some quick notes from a meeting, writing a requirements page, or letting your teammates know about the company's latest marketing push – you'll either be creating it as a page or a blog post. You may be shocked to know that this page you're reading now, is, in fact, a Confluence page!

Pages and blog posts are the two things that allow you to capture and share information in Confluence, and which one you use depends on what you want to do with your content. If you want the information to last, and possibly evolve over time, then you likely want to create a page; if the information is specific mainly to the current time-frame, and isn't going to change over time, then you'll most likely want to create it as a blog post. These aren't hard-and-fast rules; they're just pointers to give you a place to start.

Each Confluence space, including your personal space, allows you to create pages in it, and has its own blog where you can create posts. If you're not sure what a space is, or what you can do with spaces, check out our page on Working with Spaces.

Take a look at the below pages to learn more about pages and blog posts in Confluence.

- Working with Pages
- Blog Posts
- Using the Editor
- Move and Reorder Pages
- Copy a Page
- Delete or Restore a Page
- Add, Remove and Search for Labels
- Working with Drafts
- Page Restrictions
- Working with Links
- Working with Anchors
- Working with Tables
- Using Autocomplete
- Working with Page Layouts and Columns and Sections
- Creating Beautiful and Dynamic Pages
- Working with Templates
- Working with Blueprints
- Importing Content Into Confluence
- Orphaned Pages
- Undefined Page Links
- View Page Information
- Page History and Page Comparison Views
- Using a WebDAV Client to Work with Pages
- Working with Macros

Working with Pages

Create a page

You can create a page from anywhere in Confluence; just choose Create in the header and you're ready to go. Pages are the place to capture all your important (and unimportant) information; start with a blank page and use it like a word processor to add rich text, tasks, images, macros and links, or use one of the useful blueprints to capture meeting notes, decisions, and more.
Once you choose Create and decide on a blank page or blueprint, you'll be taken straight into the Confluence editor. The editor is where you'll name or rename your page, add the content, and format it to look great. When you’ve added some content, choose Preview to take a peek at what your finished page will look like, and choose Save when you’ve finished your edits.

After you save you’ll see the page in ‘view’ mode. You can re-enter the editor any time by choosing Edit or pressing E on your keyboard.

Another useful way to create a page is to use the Create from Template Macro. This macro allows you to choose a page template, and adds a button to the page allowing one-click page creation. If you want others to create pages using this template, this is a great option.

Collaborate or restrict

Once you’ve created a page, you can decide if you want to keep it private, using restrictions, or collaborate on it with others using @mentions, sharing, and comments.
Organise and move

You can also organise pages in a hierarchy, with child and/or parent pages for closely related content. When you navigate to a Confluence page and choose the **Create** button in the header, the page you’re creating will by default be a child of the page you’re viewing. Have as many child pages and levels in the hierarchy as you need to, and **move pages** if you want to change their location.

If you want to view all pages in a Confluence space, choose **Pages** in the sidebar, or choose **Browse > Pages** at the top of the screen if you’re using the Documentation theme. If the space is using the Default theme, you’ll see recent updates to pages and a page tree displaying all pages in the space; if it’s using the Documentation theme, you can choose either **Recently Updated, Alphabetical**, or **Tree** view of the pages in the space.

ℹ️ Each time you create a page, you’re creating it in a **space**. Spaces are containers used to contain pages with related content, so you can set them up for each team in your organisation, for projects, a combination of both, or for any reason you want to group pages together. See [Working with Spaces](#) for more information.

Other page actions

- **Copy** a page
- **Delete** a page or remove a specific version of a page
- Monitor page updates and other activity through **page notifications**
- **View page history**, and manage and compare versions of a page
- **Search** page content, including attachments
- Export pages to **Word, PDF, HTML or XML**
- **Like** a page

⚠️ We recommend you don’t use special characters in page or attachment names, as the page or attachment may not be found by Confluence search, and may cause some Confluence functions to behave unexpectedly.

**Note:** If you rename a page, Confluence will automatically update all relative links to the page, except in some **macros**. Links from external sites will be broken, unless they use the permanent URL. See [Working with Links](#) for more information.

Blog Posts

Blog posts are an easy way to share announcements, journal entries, status reports, or any other timely information. Others can join in by **commenting on** and/or **liking** your blog post and, if you get enough of either, your post might make it to the popular feed on the **dashboard**!

Each **space** in Confluence, including your **personal space**, has it’s own blog. To view a space’s blog, go to a space and choose **Blog** in the sidebar; if you’re using the Documentation theme, choose **Browse > Blog** at the top of the screen. You’ll see a list of the latest blog posts, and you can click through to earlier posts via the navigation area in the sidebar.

Create a blog post

You can follow the same process to create a blog post as when you create a Confluence page.

1. Navigate to the space where you want to create your blog post
2. Choose **Create** in the Confluence header and select **Blog post**
3. Add your content and choose **Publish**

You can create blog posts from the Dashboard, but you’ll need to make sure you choose the space it’s going to appear in in the create dialog.
Blog posts can be attractive and engaging in the same way a page can be, so go ahead and add images, YouTube clips (preferably of cats), and tables to your post to really grab your audience.

To create a blog post, you need the 'Add Blog' permission. See Space Permissions.

Move a blog post

If you create a blog post in the wrong space, or want to reorganise your spaces, you can move an individual blog post to another space.

To move a blog post, go to the post and choose *** > Move and select the new destination space.

You'll need the 'Delete blog' permission in the current space, and 'Add blog' permission in the new (destination) space to do this.

Restrict a blog post

You can restrict a blog post so that it is only available to specific users or groups. Blog post restrictions work in the same way as page restrictions.

To restrict a blog post prior to publishing it, choose the Unrestricted button in the footer and apply your restrictions. To restrict a blog post after publishing, choose *** > Restrictions and apply your restrictions.

Notes:

- Notifications are sent at the point a blog post is created - removing restrictions does not trigger a new notification.
- As a blog post has no parent, restrictions aren't inherited.
Delete a blog post

To delete a blog post, choose **Delete**. Deleting a blog post follows the same rules as deleting a page.

Export a blog post

You can export individual blog posts to PDF. This is useful, for example, if you want to email an internal blog post to people outside your organisation.

See Exporting Content to Word, PDF, HTML and XML for more information on exporting blog pages to PDF.

Using the Editor

The Confluence editor is what you’ll use to create and edit Confluence pages, blog posts, and comments. You can enter content as you would in a Word document, apply formatting, and embed other content and files on the page.

**Note:** To edit a page, you need the 'Add Pages' permission for the space. See space permissions. Someone may also apply page restrictions that prevent you from editing the page.

Edit a page or blog post

You’ll be taken to the editor whenever you create a new page or blog post, or add a comment. To edit an existing page or blog post, choose **Edit** at the top of a page or press **E** on your keyboard.

Confluence automatically saves drafts of your page as you work. If another user begins editing the same page as you, Confluence will display a message and will try to merge the changes when you save your page. To see changes between different versions of the page, look at the history of the page.

The editor

The editor allows you to enter or change the title of your page; insert content including text, images, and links; and format your content using the toolbar.

If you’re renaming your page, there are some things you should take into account.

---

**On this page:**
- Edit a page or blog post
- The editor
- Editor toolbar
- Restrictions, labels, and notifications
- Things to help you work faster
- Find and replace text
- Record change comments

**Related pages:**
- Working with Tables
- Working with Page Layouts and Columns and Sections
- Displaying Files and Images
- Working with Links
- Using Symbols, Emoticons and Special Characters
- Confluence User’s Guide
Editor toolbar

The editor toolbar is where you format your page layout and text, and add links, tables, images, attachments and macros. You can also perform a find and replace, or get help using the editor by choosing the help icon.

The Insert menu

The Insert menu is particularly useful. Use the Insert menu to include any of the following content types on your page:

- An image
- A link to another Confluence page or external URL, or a link to an attachment or image
- An emoticon or symbol, or a horizontal line
- A macro (choose a specific macro, or Other Macros, from the Insert menu)

You can also use keyboard shortcuts to insert links, images, and macros. Try out the shortcuts listed below:

- Type [ (square bracket) to insert a link.
- Type ! (exclamation mark) to insert an image or other media.
- Type { (curly bracket) to insert a macro.

Typing any of the above shortcuts will trigger the autocomplete functionality, prompting you with a list of suggestions to finish off the entry. For more shortcuts, click the help icon on the editor toolbar.
Restrictions, labels, and notifications

When editing a page, you may want to set restrictions on who can view or edit the page, or add labels to the page to make it easily searchable.

Once you're ready to save, you can enter change comments to let others know what you've changed, and, if you like, send an email notification to anyone watching the page.

Things to help you work faster

Auto-formatting

You can type Confluence wiki markup directly into the editor to have Confluence auto-format your text as you type. To learn more, choose help icon in the toolbar, then choose Editor Autoformatting.

Autoconvert for pasted links

When you paste certain URLs into Confluence, the editor will analyse what you’re pasting and automatically convert it into something that will display well in Confluence. Examples include:

- YouTube videos
- JIRA issue queries
- Google Maps
- Confluence pages, blog posts, comments, user statuses, user profiles.
- Shared screenshot links from Skitch
- And more.

Drag-and-drop for external images and files

You can drag files, like images, multimedia, Office files and PDFs, from your computer and drop them directly into the editor. The contents of the file will be embedded into the page or blog post.

Drag-and-drop within the editor

In the editor panel, you can drag an image or a macro from one location to another on the page. Hover your cursor over the image or the macro placeholder and your cursor changes to a drag-and-drop icon. Click the image or macro and drag it to a new location.

Note: For the drag-and-drop of images and macros in the editor, Confluence supports the following browsers: Chrome, Firefox, and Internet Explorer 10 (desktop mode).

Keyboard shortcuts

To view the available keyboard shortcuts, choose the help icon in the editor toolbar.

Find and replace text

Click the icon on the toolbar, or use the keyboard shortcut Ctrl+F (Windows) or Cmd+F (Mac OS). Search matches are highlighted in yellow. You can step through the results one by one, replace the matching text strings one by one, or replace all matching strings at once. Find and replace works only within the current page.

Record change comments

When you finish editing a page, you can add a comment to let others know what you changed. Type a short message in the change comments field in the footer, and the comment will be visible to anyone viewing versions of the page in page history.
Using Symbols, Emoticons and Special Characters

You can add various symbols and special characters to Confluence pages. You can also use them in other places that display content, such as blog posts, comments, the dashboard welcome message and the configuration panels offered by the Documentation theme.

Inserting symbols and special characters

To add a symbol to your page:

1. Edit the page.
2. Choose Insert > Symbol. This will display the 'Insert Custom Character' window.
3. Choose a symbol to insert it.

Inserting emoticons

There are two ways to add an emoticon, or smiley, to your page.

By choosing an emoticon from those available:

1. Choose Insert > Emoticon.
2. Choose an emoticon to insert it.
By typing a character combination:
You can insert emoticons by typing commonly-used character combinations. For example, the following code appears as an emoticon when the page is rendered.

\);

The above example creates this emoticon: 😃

This table shows the emoticons (and other icons) available in Confluence, and the character combinations that create them:

<table>
<thead>
<tr>
<th>Image</th>
<th>Notation</th>
</tr>
</thead>
<tbody>
<tr>
<td>😏</td>
<td>:)</td>
</tr>
<tr>
<td>😇</td>
<td>:(</td>
</tr>
<tr>
<td>😎</td>
<td>:D</td>
</tr>
<tr>
<td>😆</td>
<td>;)</td>
</tr>
<tr>
<td>😈</td>
<td>(y)</td>
</tr>
<tr>
<td>😩</td>
<td>(n)</td>
</tr>
<tr>
<td>😎</td>
<td>(i)</td>
</tr>
<tr>
<td>😄</td>
<td>(/)</td>
</tr>
<tr>
<td>😤</td>
<td>(+)</td>
</tr>
<tr>
<td>😣</td>
<td>(-)</td>
</tr>
<tr>
<td>😞</td>
<td>(?)</td>
</tr>
<tr>
<td>😭</td>
<td>(on)</td>
</tr>
<tr>
<td>😱</td>
<td>(off)</td>
</tr>
<tr>
<td>😄</td>
<td>(*)</td>
</tr>
<tr>
<td>😄</td>
<td>(*r)</td>
</tr>
<tr>
<td>😄</td>
<td>(*g)</td>
</tr>
<tr>
<td>😄</td>
<td>(*b)</td>
</tr>
<tr>
<td>😄</td>
<td>(*y)</td>
</tr>
</tbody>
</table>

Preventing emoticons from appearing

To undo the conversion of a character combination into an emoticon, press Ctrl+Z (Windows) or Cmd+Z (Mac).

To prevent Confluence from converting text to emoticons automatically, disable ‘Autoformatting’ in your user profile. See Edit Your User Settings.

The Confluence knowledge base has an article on disabling emoticons for the Confluence site as a whole.

Move and Reorder Pages

The easiest way to set a page's location in Confluence is to navigate to the space where you want the page to live and, if necessary, find its parent page and choose Create. Sometimes though, you'll want to change a page's location either while you're creating it, or after it's been created.

You can also move and reorder pages in the page tree (hierarchy).

Set page location or move a page

1. Do either of the following:
   - **While creating a page** – choose Location at the bottom-left of the page
   - **Once a page is created** – choose *** > Move
2. Use the tabs on the left of the 'Set Page Location' dialog to help you find the new space and/or parent page for your page (the Current location and New location breadcrumbs at the bottom of the dialog indicate the current parent page and new parent page)
3. Select Reorder if you want to move the page to a different position amongst the child pages (when you choose Move in the next step, you'll be able to reorder the page)
4. Choose Move (If you're reordering the child pages, choose the new position for the page and choose Reorder)

The page – along with any attachments, comments, and child pages – is moved to your chosen location. Confluence will automatically adjust all links to the moved pages, to point to the page(s) in its new location.

When completing the New parent page field, you need to select the page suggested by Confluence’s autocomplete. Typing or pasting the page name (or using your browser's autocomplete) won't work.

Screenshot: Setting the location or moving a page
Reorder pages within a space

You can change the location of a page within its space, and reorder pages in the hierarchy. This allows you to:

- Move a single page, or a family of pages, to a different parent within the space.
- Reorder pages that are children of the same parent.

All links to the page are maintained. When you move a parent page, the entire hierarchy of child pages will move too.

**To move or reorder a page:**

1. Go to the space and choose **Space tools > Reorder pages** from the bottom of the sidebar
2. Expand the branches to locate the page you want to move
3. Drag the page to a new position in the tree

If you’re using the Documentation theme go to **Browse > Pages > Tree** and then drag the pages to a new position as above.

Alternatively, you can choose to order a group of child pages alphabetically by choosing the **Sort Alphabetically (A-Z)** icon. The **Sort Alphabetically (A-Z)** icon only appears next to the parent page if the page family is currently sorted manually.
If you change your mind, you can use the **Undo** icon to revert back to the previous manual page order. This option is only available immediately after sorting the page, while you’re still on the **Reorder Pages** tab, and haven’t performed any other action.

### Notes about permissions

To move a page, you need the following permissions:

- ‘Add’ permission on the page you’re moving, and
- ‘View’ permission on the page’s parent page. If you're moving the page to a different parent, you need ‘View’ permission on the new parent.

To move a page into a different space, you also need:

- ‘Delete’ permission on the space you're moving from, and
- ‘Add’ permission on the space you're moving to.

If the page has restrictions, and you want to keep the page restrictions in the new location, you’ll also need 'Restrict' permission on the space you're moving to. Alternatively, remove the page restrictions before performing the move.

### Copy a Page

If you need to duplicate the content of a page, the easiest way is to copy it by choosing Go to a page in the space and choose *** > **Copy**.

When you copy the page it'll need to be renamed if you intend to keep it in the same space – and Confluence will rename the page ‘Copy of [originalPageName]’ by default – as pages in a space must have unique names. If you plan on moving it to another space, you can keep the same name as long as you set the location while you're creating the copy. See **Move and Reorder Pages** for more information.

You need the ‘Create Pages’ permission in a space to copy pages within that space. See **space permissions** for more information.

#### To copy a page:

1. Go to a page in the space and choose *** > **Copy**
   Confluence will open a copy of the page in the editor. By default, Confluence will name the page ‘Copy of [originalPageName]’.
2. Rename the page and make any other changes required in the body of the page
   If you need to move the new page to a different space or a different parent, choose **Location** at the bottom-left of the page. Refer to the instructions on moving a page.
3. Choose **Save**

### Notes

- Copying a page will duplicate all of the original page's attachments and labels, but won’t copy comments from the original page.
• This method of copying a page doesn't copy the child pages. Please add your vote to issue CONF-281 if you'd like to see this improvement.
• You can copy an entire space, including all pages in the space (parents and children) — refer to these instructions on copying a space.

Delete or Restore a Page

When you delete a Confluence page, it moves to the space’s trash much like an email moves to your email trash or a file moves to the trash on your computer. It’s not permanently deleted, and is still retrievable, until you purge the page from the trash.

Delete a page

When you delete a page in Confluence, you’re deleting all versions of the page. If you only want to delete a specific version of a page, take a look at the instructions below for deleting a specific version.

To delete a page and all its versions:

Go to the page and choose *** > Delete (confirm you want to delete the page when prompted)

Note: The Delete option will only appear if you have permission to delete this page. See Space permissions.

If someone has applied page restrictions to the page, the restrictions may also prevent you from deleting the page.

To delete a specific version of a page:

If you want to delete a specific version of a page, you need to be a space administrator.

Deleting a page version is permanent. It won't be moved to the trash, so you can't restore a deleted version.

1. Go to the page and choose *** > Page History
2. Choose Delete next to the version you want to delete (confirm the action when prompted)

Once you've deleted a version, the other versions are re-numbered where necessary. For example, if you delete version 2, version 3 will become the new version 2.

Delete a page with children

If you delete a page that has any child pages, the child pages will move to the root of the space. The child pages won't be deleted, but they will lose the parent-child relationship with the deleted page.

If you want to keep the child pages under another parent, it’s a good idea to move them first, then delete their former parent.

Hint: If you do want to remove a parent page and a large number of child pages:

1. Create a temporary new space
2. Move the parent page to the new space (the child pages will move too)
3. Delete the space

Restore a deleted page

When you restore a Confluence page, you're moving it from the trash to the root of the space. You may want to move the page to another location after you've restored it, as it won't be easy to find at the root of the space.

You need to be a space administrator to restore a deleted page.

To restore a deleted page:

1. Go to the space and choose Space tools > Content Tools from the bottom of the sidebar
2. Choose Content Tools > Trash
   A list of deleted pages and blog posts for the space displays.
3. Choose Restore for the page you wish to restore

Is your space using the Documentation theme?

If your space is using the Documentation theme:

1. Choose Browse > Space Admin from the header
   
   Note: The Space Admin option appears only if you have space admin permissions, or if you're part of the 'confluence-administrators' group.
2. Choose Trash from the space administration options
   A list of deleted pages and blog posts for the space displays.
3. Choose Restore for the page you wish to restore

To find the page after you've restored it, choose Pages to go to the root of the space (the page isn't restored to its original position in the page hierarchy). See Move and Reorder Pages for more information.

If a new page has already been created in that space with the same name as the page you're restoring, you'll be given an option to rename the page before it's restored.

Purge deleted pages

If you want to permanently get rid of a page, you need to purge it from the trash. That'll mean the page, and all its versions and attachments, are gone for good.

Attachments of deleted pages will remain in the database (allowing potential retrieval) until the trash is purged. Once the trash is purged, all attachments on the page(s) are permanently removed.

You need to be a space administrator to purge deleted pages.

To purge deleted pages:

1. Go to the space and choose Space tools > Content Tools from the bottom of the sidebar
2. Choose Trash
   A list of deleted pages and blog posts for the space displays.
3. Choose Purge for a specific page or Purge All to permanently clear all deleted pages and news items

Is your space using the Documentation theme?

If your space is using the Documentation theme:

1. Choose Browse > Space Admin from the header
   
   Note: The Space Admin option appears only if you have space admin permissions, or if you're part of the 'confluence-administrators' group.
2. Choose Trash from the space administration options
   A list of deleted pages and blog posts for the space displays.
3. Choose Purge for a specific page or Purge All to permanently clear all deleted pages and news items

Add, Remove and Search for Labels
Labels are key words or tags that you can add to pages, blog posts and attachments. You can define your own labels and use them to categorise, identify or bookmark content in Confluence.

For example, you could assign the label 'accounting' to all accounts-related pages on your site. You can then browse all pages with that label in a single space or across the site, display a list of pages with that label, or search based on the label.

Because labels are user-defined, you can add any word that helps you identify the content in your site.

You can also apply labels (known as categories) to spaces, to help organise your Confluence spaces. See Using Labels to Categorise Spaces.

Label a page or blog post

Any user with permission to edit a page can add labels to a page. Any existing labels appear at the bottom-right of the page, below the page content.

To add a label to a page or blog post:

1. Go to the page
2. Choose the edit icon b
3. eside the list of labels or press L on your keyboard
4. Type in a new label (existing labels are suggested as you type)
5. Choose Add

Label an attachment

1. Do either of the following:
   - Go to the page that contains the attachment and choose Go to  Attachments
   - Go to the space and choose Space tools > Content Tools from the bottom of the sidebar, then choose Attachments

   You’ll see a list of attachments, with any existing labels listed in the Labels column.

2. Choose the edit icon b
3. eside the list of labels and type in a new label (existing labels are suggested as you type)
4. Choose Add

You can also add labels in a list of attachments displayed by the Attachments macro, by choosing the edit icon b beside each label.
If you add one or more labels to a template, that label will be copied to the page when someone adds a page based on that template. See Creating a Template.

The Labelled content page

If you’re viewing a page or post that has labels or displays the Attachments macro, you can choose any label to go to the Labelled content page for the space. Choose Popular Labels or All Labels from the cog at the top-right – to view the most-used labels or all labels in the space – or choose See content from all spaces from the cog to view labelled content from all spaces in your Confluence site.

Screenshot: The Labelled content page

The Popular Labels option displays a word cloud, where the bigger a label is displayed, the more popular it is. Choose any label to view content tagged with that label.

You can also navigate to the labels view for a space by entering the following URL (replace SPACEKEY with the space’s key):

<your.Confluence.site>/labels/listlabels-alphaview.action?key=SPACEKEY

Is the space using the Documentation theme?
If the space is using the Documentation theme, access the Labelled content page by choosing Browse > Labels

Search by label

You can use the 'labelText:' prefix to search specifically for content that has a specific label. For example, if you’re looking for pages with the label 'chocolate', type labelText:chocolate into the search field in the Confluence header. For more examples of searching by label, see Confluence Search Syntax.

Search for labelled pages using a URL

Entering a URL with an appended label or labels is another way to search for pages with particular labels.

In your browser’s address bar, enter the following URL and press enter: http://<your.Confluence.site>/label/foo+bar

The Labelled content page will load, showing search results for pages with the both labels, 'foo' and 'bar'. Replace ‘foo’ and ‘bar’ with the label(s) you want to search for, and separate multiple labels with a + symbol.

Adding a label to your results:

Once you’re on the Labelled content page, you can add more labels to your search by choosing them from the Related Labels list at the top-right of the page. Each label is listed with a plus (+) sign.
If you want to remove labels from your search, locate the included labels at the top of the page and choose the label(s) you want to remove. Each included label will be listed with a minus (−) sign.

Remove labels

When viewing page, blog post, or attachment labels, an x appears alongside each label. Choose the x to remove the label.

If you have deleted pages that contain a label, you may need to purge the deleted pages from the space's trash to ensure that the label disappears too.

Displaying Pages with Label Macros

Using labels and macros, you can categorise pages and then display them in Confluence in a number of ways.

As an example, you could label all pages relevant to the marketing team with 'marketing', and then add more specific labels like 'online', 'mobile', and 'physical' to different pages where required.

You could then use the Content by Label Macro to display different combinations of pages with the marketing label. Some combinations you could use would be:

- All pages with the label 'marketing'.
- Pages with all of the following labels: 'marketing', 'mobile', and 'online'.
- Pages with either the 'mobile' or 'online' labels, in the Marketing space.

There are a lot of ways you can filter the content, making it easier for you to find content that's relevant to you.

Other label macros

Here are some other macros that use labels, and can help you categorise and display your content.

**Navigation Map macro**

The Navigation Map macro renders the list of pages associated with a specified label as a navigation map.

**Related Labels macro**

The Related Labels macro lists labels commonly associated with the current page's labels.

**Content by Label macro**

The Content by Label macro displays a list of content marked with specified labels.

**Content Report Table macro**

The Content Report Table macro displays a set of pages and blog posts in tabular format, based on the specified labels.

**Labels List macro**

The Labels List macro lists all labels of a space, grouped alphabetically.

**Recently Used Labels macro**

The Recently Used Labels macro lists labels most recently used in a specified scope - global (site), space, or personal.

**Popular Labels macro**

The Popular Labels macro displays popular labels in a list or in a heatmap (also called a cloud).
Working with Drafts

A draft is a 'snapshot' of unsaved page content, which Confluence creates automatically at regular intervals while you're creating or editing a page or blog post. Drafts can minimise the loss of work if your Confluence site experiences a problem, as you can retrieve the page content from the last saved draft.

By default, Confluence saves a draft of your page once every thirty seconds, however, a Confluence administrator can configure how often drafts are saved. In addition, whenever you edit a page and then move to another screen, Confluence will automatically save a draft. Each new draft replaces the previously saved draft.

Each time Confluence saves a draft, it displays a message and the time of the last save, to the right of the undo and redo buttons in the editor toolbar. When you edit a page that wasn't successfully saved, Confluence will let you know that a version of the page you're editing wasn't saved, and will give you the option to resume editing it from the draft.

More about drafts:

- You only have access to drafts of pages you've been working on, and whose content hasn't yet been saved.
- You can't create a draft explicitly.
- Your drafts are listed in the 'Drafts' tab of your profile.
- Once you've resumed editing a draft, or chosen to discard it, the draft is removed from your drafts tab.

Viewing drafts

Your drafts are listed on the Drafts tab of your user profile. To see your drafts, choose your profile picture at top right of the screen, then choose Drafts.

Resume editing a draft

There are two ways to resume editing an unsaved page or blog post:

1. Using your drafts view. To resume editing a draft from this view:
   a. Choose your profile picture at top right of the screen, then choose Drafts.
   b. Choose Resume Editing next to the appropriate draft to resume editing that draft.

2. If you create a new page or blog post and didn't save it, but a draft is saved, when you next add a page or blog post in that space, Confluence will ask you if you want to resume editing the page. If you choose resume editing, the draft and its unsaved content will be restored, allowing you to continue editing it.

What happens if I'm editing the draft of a page that has since been updated?

Confluence will display a message informing you that you're editing an outdated page. If there are no conflicts between the two versions, Confluence will give you the option to Merge and Resume editing.
If there are conflicts, Confluence will give you the option to **View the Conflict** or to **Discard** your changes.

Viewing your unsaved changes

When you edit a page or blog post, you can view any ‘unsaved’ changes you’ve made since the last automatically saved draft, by clicking the **Draft autosaved at** message in the toolbar.

**Screenshot: Segment of the unpublished changes window**

Unpublished Changes for ‘Sample Page’

Two penguins find themselves together on an ice floe, drifting helplessly into warmer waters. The penguins are very fond of each other. Suddenly **cra-a-a-a-a-ck** the ice floe splits in half, right between the penguins. As they drift apart, one penguin sadly waves a flipper and calls out “Chocolate milk!”

What happens? Do you know what happened next?

Image Removed

Concurrent Editing and Merging Changes

Sometimes, another user may edit the same page as you’re editing, at the same time you do. When this happens, Confluence will do its best to ensure nobody’s changes are lost.

**How will I know if someone else is editing the same page as I am?**

If another user is editing the same page as you, Confluence will display a message above your edit screen letting you know who the other user is and when the last edit was made.

**Screenshot: Notification of Simultaneous Page Editing**

This page is also being edited by Ewan User. Your changes will be merged with theirs when you save.

What happens if two of us are editing the same page and the other user saves before I do?

If someone else has saved the page before you, when you click **Save**, Confluence will check if there are any conflicts between your changes and theirs. If there are no conflicting changes, Confluence will merge the changes.

If there are conflicts, Confluence will display them for you and give you the option to:

- **Continue editing** - Continue to edit the page; useful if you want to manually merge the changes.
- **Overwrite** - Replace the other person's edits with yours (their edits will be lost).
- **Cancel** - Discard your changes and exit the editor, keeping the other person's edits.

**Example Scenario**

For example, Alice and Bob both edit the same page at the same time.

If Alice clicks save before Bob, Bob is now effectively editing an out-of-date version of the page. When Bob
clicks save, Confluence will examine his changes to see if any overlap with Alice’s. If the changes don’t overlap (i.e. Alice and Bob edited different parts of the page), Bob’s changes will be merged with Alice’s automatically.

If Bob’s changes overlap with Alice’s, Confluence will display an error message to Bob showing where Alice has changed the page, and giving Bob the options to overwrite Alice’s changes with his own, to re-edit the document to incorporate Alice’s work, or to cancel his own changes entirely, maintaining Alice’s changes.

**Page Restrictions**

Page restrictions allow you to control who can view and/or edit individual pages in a space. So, if you’re working on a page that shouldn’t be viewed by just anybody, it’s easy to lock it down to the people who need to know. You can add restrictions for individuals or for Confluence groups.

To add or remove page restrictions, you’ll need to have permissions to edit the page and ‘Restrict’ or ‘Admin’ permission in the space.

If you restrict viewing of a page to a user or group, all children of that page are also restricted to the user or group. Edit page restrictions on the other hand, are not inherited.

**Add restrictions to a page**

1. Go to the page and choose *** > Restrictions
2. Choose Restrict viewing of this page or Restrict editing of this page
3. Enter part of user or group name and choose the appropriate user or group from the autocomplete drop down
   Add as many users and/or groups as you need to.

Once you add restrictions, only those people and groups listed in the restrictions dialog will be able to view and/or edit the page.

**View current page restrictions**

Confluence displays a padlock icon in the byline when a page has view or edit restrictions.

To view the page’s restrictions, go to the page and do any of the following:

- choose *** > Restrictions
- choose the padlock icon in the byline
- choose the Restricted button at the bottom-left of the page if you’re in the editor

You’ll see the page restrictions dialog listing the users and/or groups that have permission to view and/or edit the page.

*Screenshot: Page Restrictions dialog showing viewing restricted to the ‘developers’ group and editing restricted to two users.*
Remove restrictions from a page

If you need to remove existing restrictions, choose **Remove restriction** to the right of the relevant restriction.

About page restrictions and space permissions

Page restrictions won’t override **space permissions** for a user or group. For example, if you restrict viewing or editing of a page to a user who doesn’t have ‘view’ permissions for the space, they won’t be able to see the page.

Request and grant access to view a restricted page

If you navigate to a page that you’re not able to view because it has page restrictions applied (for example from a link or page URL) you may be able to request access to the page.

**To request access to a restricted page:**

1. On the restricted page, choose **Request access**
2. Wait for an email confirming that access has been granted

If the request access message doesn't appear, you're not able to request access for that particular page. This usually is because the page has inherited view restrictions from a parent page, or you may not have adequate space permissions.

**To grant access to a restricted page:**

1. In the request access email, choose **Grant access**.
2. You will be taken to the restricted page, a dialog will appear with the access request.
3. Choose **Grant access**.
The user will receive an email confirming that access has been granted.

This process is the same as navigating to *** > Restrictions and adding a 'View' restriction for the user.

Who can grant access?

To grant access to a restricted page you will need to have permission to edit that page, and have the 'Restrict' or 'Admin' permission for the space.

Confluence will send an email to a user who can grant permissions. The sequence that Confluence will use to search for the appropriate user is:

1. The last person to edit the page
2. All non-admin users that can set permissions on the page (given that an admin user can always set permissions)
3. The page creator
4. All the space administrators

Confluence will try each of these roles in turn, emailing the first user that has appropriate permissions.

View all restricted pages in a space

You need space admin permissions to view the list of restricted pages in a space.

To view restricted pages:

1. Go to the space and choose Space tools > Permissions from the bottom of the sidebar
2. Choose Restricted Pages

If your space uses the Documentation theme:

1. Choose Browse > Space Admin from the header
   
   **Note:** The Space Admin option appears only if you have space admin permissions, or if you're part of the 'confluence-administrators' group.

2. Choose Restricted Pages in the space administration options

*Screenshot: Restricted pages in a space*
Notes

- **Inherited restrictions**
  If a page has a 'View' restriction set, that restriction will be inherited by all its children (and their children, and so on). If a 'View' restriction is added to a child page that has already inherited page restrictions from its parent, users must satisfy both restrictions in order to see the page.

- **You can’t exclude yourself**
  As creator or editor of a page, you can’t use page restrictions to deny yourself access to the page. Confluence will automatically add your username into the list of users/groups allowed to view/edit the page. If you remove your username, Confluence will put it back again.

- **Space Admin and System Administrator access to restricted pages**
  Users with 'Admin' permissions in a space, or users with the System Administrator global permission can remove restrictions from pages, even if the page restriction prevents them from viewing the page. Go to Space Administration > Restricted Pages.

Working with Links

You can create links to pages, blog posts, anchors, attachments, external
websites, JIRA issues and more. Links can be text or images, and can be added in many different ways.

Links to pages within your Confluence site are relative, which means that you can move pages and rename pages without breaking links.

This page explains the most common ways to create links.

**Insert a text link**

To insert a link on a page:

1. Select some text or position your cursor where you want to insert the link
2. Choose **Link** on the toolbar or use the keyboard shortcut **Ctrl+K**
3. Select a page, blog post or attachment, or enter an external URL (see below for how to link to particular types of content)
4. Enter or modify the link text (this is the text that will appear on the page. If this field is left blank, the page name or URL will be used as the link text.)
5. Choose **Insert**

Alternatively you can type `[` followed by the page or attachment name. **Autocomplete** will suggest matching items for you.

You can also paste a URL directly onto your page. Confluence will automatically create the link, and if the URL is for a page in the current site, the page name will be set as the link text.

**Insert an image link**

1. Select an image on your page
2. Choose **Link** on the Image Properties toolbar
3. Select a page, blog post or attachment, or enter an external URL (see below for how to link to particular types of content)
4. Choose **Insert**

**Modify a link**

1. Select the link text or image
2. Choose **Edit** from the link properties toolbar
3. Modify the link and choose **Save**

**Remove a link**
1. Select the link text or image
2. Choose **Unlink** from the properties toolbar

## Link to specific types of content

Confluence supports many methods for creating links. Some of the common ones are listed here.

<table>
<thead>
<tr>
<th>Type of link</th>
<th>Ways to do this</th>
</tr>
</thead>
<tbody>
<tr>
<td>Link to a page</td>
<td>Choose <strong>Link &gt; Search</strong> then enter part of the page name.</td>
</tr>
<tr>
<td></td>
<td>Choose <strong>Link &gt; Recently viewed</strong> and select a page from the list.</td>
</tr>
<tr>
<td></td>
<td>Type [ and enter part of the page name then select the page from the list.</td>
</tr>
<tr>
<td></td>
<td>Paste the URL of the page onto your page (Confluence will automatically create the link).</td>
</tr>
<tr>
<td>Link to a page in another space</td>
<td>Choose <strong>Link &gt; Search</strong> enter part of the page name and select <strong>All Spaces</strong> from the drop down.</td>
</tr>
<tr>
<td></td>
<td>Choose <strong>Link &gt; Advanced</strong> then enter the space key followed by the page name spacekey:mypage.</td>
</tr>
<tr>
<td></td>
<td>Type [ and enter part of the page name then select the page from the list.</td>
</tr>
<tr>
<td></td>
<td>(you can hover over each suggestion to see which space the page is from).</td>
</tr>
<tr>
<td>Link to a blog post</td>
<td>Choose <strong>Link &gt; Search</strong> and enter part of the blog post name.</td>
</tr>
<tr>
<td></td>
<td>Type [ and enter part of the blog post name then select the blog post from the list.</td>
</tr>
<tr>
<td>Link to an attachment or image on this page</td>
<td>Choose <strong>Link &gt; Attachment</strong> then upload or select an attachment from the list.</td>
</tr>
<tr>
<td></td>
<td>Type [ and enter part of the attachment file name then select the attachment from the list.</td>
</tr>
<tr>
<td>Link to an attachment on another page</td>
<td>Choose <strong>Link &gt; Search</strong> and enter part of the attachment name.</td>
</tr>
<tr>
<td></td>
<td>Type [ and enter part of the attachment file name then select the attachment from the list</td>
</tr>
<tr>
<td></td>
<td>(you can hover over each suggestion to see which space the page is from).</td>
</tr>
<tr>
<td>Link to a website</td>
<td>Choose <strong>Link &gt; Web Link</strong> then enter the website URL.</td>
</tr>
<tr>
<td></td>
<td>Type or paste the URL onto the page (Confluence will automatically create the link).</td>
</tr>
<tr>
<td>Link to an email address</td>
<td>Choose <strong>Link &gt; Web Link</strong> then enter the email address.</td>
</tr>
<tr>
<td></td>
<td>Type or paste the email address onto the page (Confluence will automatically create a 'mailto:' link).</td>
</tr>
<tr>
<td>Link to an anchor on a page</td>
<td>Choose <strong>Link &gt; Advanced</strong> then enter the anchor name in one of the formats below.</td>
</tr>
<tr>
<td></td>
<td>For an anchor on this page: #anchor name.</td>
</tr>
<tr>
<td></td>
<td>For an anchor on another page in this space: page name#anchor name.</td>
</tr>
<tr>
<td></td>
<td>For an Anchor on another page in another space: spacekey:page name#anchor name.</td>
</tr>
<tr>
<td></td>
<td>See <strong>Working with Anchors</strong> for more information on using anchors.</td>
</tr>
</tbody>
</table>
| **Link to a heading on a page** | Choose **Link > Advanced** then enter the heading in one of the formats below. Heading text is case sensitive and must be entered without spaces.  
For a heading on this page: `#MyHeading`.  
For a heading on another page in this space: `Page Name#MyHeading`.  
For a heading on another page in another space: `spacekey:Page Name#MyHeading`.  
Be aware that these links will break if you edit the heading text. Consider using the **Table of Contents** macro or an **Anchor** instead. |
| **Link to a comment on a page** | Go to the comment, right click the **Date** at the bottom of the comment and copy the link. Paste the link directly onto your page or choose **Link > Web Link** and paste in the URL.  
Type `$` then enter the Comment ID (‘12345’ in this example): `[$12345]` |
| **Link to an undefined page (a page that does not exist yet)** | Choose **Link > Advanced** then enter the new page name (a page will be created on click).  
Type `[` then enter the new page name then choose **Insert link to create page**.  
See **Undefined Page Links** for more information on undefined pages. |
| **Link to a personal space or user profile** | Choose **Link > Search** then enter the user’s name and select their personal space homepage or their profile from the list.  
Type `[` then enter the user’s name and select their personal space homepage or their profile from the list. |
| **Link to a JIRA issue (where Confluence is connected to JIRA)** | Paste the JIRA issue URL - Confluence will automatically create a JIRA Issue macro. |

**Link to Confluence pages from other websites**

The best way to link to a Confluence page from outside Confluence, for example on a website or in an email message, is to use the tiny link which is a permanent URL. This ensures that the link to the page is not broken if the page name changes.

To access the permanent URL for a page:

1. View the page you wish to link to.  
2. Choose **Tools > Link to this page**.  
3. Copy the Tiny Link.  
4. Use the tiny link in your website or email message.

You do not need to use the tiny link to link to pages within your Confluence site. Confluence automatically updates links when you rename or move a page to another space.

If you want to link to specific content such as anchors, headings or comments you need to use the following link syntax. Note that there are no spaces in the page name, anchor name or heading text.

In the examples below, the anchor name is ‘InsertLinkAnchor’ and the heading text is ‘Insert a link’.

| **Purpose** | **Link syntax** |
Link to an anchor (from an external website) | http://myconfluence.com/display/spacekey/pagename#pagename-anchornam
---|---
Example from this page: | https://confluence.atlassian.com/display/DOC/Working+with+Links#Workingw:

Link to a heading (from an external website) | http://myconfluence.com/display/spacekey/pagename#pagename-headingtext
---|---
Example from this page: | https://confluence.atlassian.com/display/DOC/Working+with+Links#Workingw:

Link to a comment (from an external website) | http://myconfluence.com/display/spacekey/pagename?focusedCommentId=commentid#comment-commentid
---|---
Example from this page: | https://confluence.atlassian.com/display/DOC/Working+with+Links?focusedCommentId=368640803#comment-368640803

Some things to note when linking to anchors from a website or email message:

- The page name is repeated in the URL, after the # sign. The second occurrence of the page name is concatenated into a single word, with all spaces removed.
- There is a single dash (hyphen) between the concatenated page name and the anchor name.
- The anchor name in the full URL is concatenated into a single word, with all spaces removed.
- The anchor name is case sensitive. You must use the same pattern of upper and lower case letters as you used when creating the Anchor.

### Link to a comment

You can add a link to a comment by using the comment URL (a permanent link), or by using wiki markup to link to the Comment ID.

To find out the comment URL and comment ID:

1. Go to the comment you wish to link to
2. Choose the Date at the bottom of the comment and examine the URL

The number after 'comment-' is the Comment ID. An example is shown here.

https://confluence.atlassian.com/display/DOC/Working+with+Links?focusedCommentId=368640803#comment-368640803

You can use wiki markup directly in the editor to link to a comment. Enter [$ followed by the Comment ID, for example [$12345] where ‘12345’ is the Comment ID.

### Using shortcut Links

If you have configured shortcut links on your Confluence site, then you can link to an external site using a shortcut link that looks like this:CONF-17025@jira.

Our Confluence site (where this documentation is housed) is configured to allow shortcut links to our JIRA site, using the shortcut @jira. So the shortcut link CONF-17025@jira produces this link.

To add a shortcut link using the 'Insert Link' dialog:

1. Choose Link > Advanced and enter or paste the shortcut link into the Link field (shortcut links are case-insensitive)
2. Modify or enter link text (this is the text that will appear on the page)
3. Choose Insert
You can also type ‘[]’ and choose **Insert Web Link > Advanced** to enter a shortcut link.

See **Configuring Shortcut Links** for more details.

**Trackback**

Trackback enables two sites can stay informed each time one site refers to the other using trackback 'pings'.

In Confluence, Trackback can be enabled by a site administrator in the Administration Console. When Trackback is enabled, any time you link to an external webpage that supports Trackback Autodiscovery, Confluence will send a Trackback ping to that page to inform it that it has been linked to.

Confluence pages also support Trackback Autodiscovery, and when Trackback is enabled, can receive trackback pings sent by other sites.

To see who has sent a Trackback ping to a Confluence page:

1. Go to the page
2. Choose **Tools > Page Information**

Any Trackback pings the page has received will be listed under the page’s **Incoming Links**.

Confluence incoming trackback pings only work with referenced pages that are public (anonymously viewable).

**Working with Anchors**

You can use anchors to enable linking to specific locations on a page, and they can be especially useful for allowing your readers to navigate to specific parts of a long document. Anchors are invisible to the reader when the page is displayed.

There are two steps to using an anchor:

**Step 1: Create the anchor**

**Step 2: Create a link to the anchor**

**On this page:**
- **Step 1: Create the anchor**
- **Step 2: Create a link to the anchor**
- **Notes**

**Related pages:**
- **Working with Links**

**Step 1: Create the anchor**

**Add the Anchor Macro to mark the location you want to link to:**

1. Do either of the following in the Confluence editor:
   - Choose **Insert > Other Macros**, then find and select the Anchor macro
   - Type `{ and the beginning of the macro name, then select the Anchor macro
2. Enter the **Anchor Name** (For example, 'bottom' or 'important information')
3. Choose **Insert**

**Macro options (parameters)**

Parameters are options that you can set to control the content or format of the macro output. Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
</table>

---

*Created in 2015 by Atlassian. Licensed under a Creative Commons Attribution 2.5 Australia License.*
Anchor Name | None  
---|---  
This is the anchor name that you will use when creating the link.  
- The anchor name can include spaces. Confluence will remove the spaces automatically when building a URL that points to this anchor.  
- The anchor name is case sensitive. You must use the same pattern of upper and lower case letters when creating the link as you used when creating the Anchor macro.

Step 2: Create a link to the anchor
You can link to an anchor from:
- A page on the same Confluence site. The link may be on the same page as the anchor, another page in the same space, or a page in another space on the same Confluence site.  
- Another web page or another Confluence site, using a specifically formatted URL.

Link to an anchor on the same Confluence site:
1. Select some text or position your cursor where you want to insert the link  
2. Choose Link in the toolbar or press Ctrl+K  
3. Choose Advanced and enter the anchor name in the Link field, following the format below.

<table>
<thead>
<tr>
<th>Anchor location</th>
<th>Link syntax for anchor</th>
<th>Examples</th>
</tr>
</thead>
<tbody>
<tr>
<td>Same page</td>
<td>#anchor name</td>
<td>#bottom</td>
</tr>
<tr>
<td></td>
<td></td>
<td>#important information</td>
</tr>
<tr>
<td>Page in same space</td>
<td>page name#anchor name</td>
<td>My page#bottom</td>
</tr>
<tr>
<td></td>
<td></td>
<td>My page#important information</td>
</tr>
<tr>
<td>Page in different space</td>
<td>spacekey:page name#anchor name</td>
<td>DOC:My page#bottom</td>
</tr>
<tr>
<td></td>
<td></td>
<td>DOC:My page#important information</td>
</tr>
</tbody>
</table>

The anchor name is case sensitive, so you need to use the same pattern of upper and lower case letters as you used when creating the Anchor macro. You need to enter page and anchor names with spaces when you link to them in the same Confluence site.

4. Enter or modify the Link Text (this is the text that will appear on the page. If this field is left blank, the page name or URL will be used as the link text)  
5. Choose Save

Screenshot: The ‘Advanced’ option in the link dialog

Link to an anchor from another web page or another Confluence site:
Use a full URL in the following format:
<table>
<thead>
<tr>
<th>Link syntax</th>
<th>Examples</th>
</tr>
</thead>
<tbody>
<tr>
<td><a href="http://myconfluence.com/display/DOCS/My+page#Mypage-bottom">http://myconfluence.com/display/DOCS/My+page#Mypage-bottom</a></td>
<td></td>
</tr>
<tr>
<td><a href="http://myconfluence.com/display/DOCS/My+page#Mypage-importantinformation">http://myconfluence.com/display/DOCS/My+page#Mypage-importantinformation</a></td>
<td></td>
</tr>
</tbody>
</table>

Notes about the full URL:

- The page name is repeated in the URL, after the # sign. The second occurrence of the page name is concatenated into a single word, with all spaces removed.
- There is a single dash (hyphen) between the concatenated page name and the anchor name.
- The anchor name in the full URL is concatenated into a single word, with all spaces removed.
- The anchor name is case sensitive.

Notes

- **Table of contents on a page**: Consider using the Table of Contents Macro to generate a list of links pointing to the headings on the page. The list of links will appear on the page, and will be automatically updated each time someone changes the wording of a heading.
- **Linking to headings**: You can link directly to the headings of a page. See Working with Links. However, if someone changes the wording of a heading, those direct links will be broken. Use the Anchor macro to ensure a lasting link within the body of a page.
- **Site welcome message**: If you are adding an anchor to a page that you are using in the site welcome message, you can only link to that anchor from another page. Internal links within that page will not work.
- **Templates**: When you are previewing a template, a link to an anchor is displayed as a 'broken' link. However, when you create a page using the template the resulting page will have the correct link.

**Working with Tables**

Confluence pages can include multi-row and multi-column tables. You can highlight cells, rows and columns in different colours. When viewing the page, people can sort the table by clicking the column headers.

**Inserting a table**

**To create a table:**

1. While editing the page, place your cursor at the point where you want to insert the table.
2. Choose Table on the toolbar.
3. A dropdown menu will appear, showing a table with a variable number of rows and columns. Click in a cell to set the number of columns and rows for your table.
4. Add content and more rows and columns as needed. See below for guidelines on what you can do with your table in the editor.

*Screenshot: Inserting a table with 3 rows and 3 columns*
What you can do with your table in the editor

While editing a page, place your cursor inside a table to see the table toolbar.

Using the table toolbar you can:

- Insert an empty row above the current one.
- Insert an empty row below the current one.
- Remove the current row.
- Cut the current row and copy it to the clipboard.
- Copy the current row to the clipboard.
- Paste the row from the clipboard to the current row.
- Insert an empty column to the left of the current one.
- Insert an empty column to the right of the current one.
- Remove the current column.
- Merge the selected cells.
- Split the selected merged cells.
- Mark a row as a table header. The cells in the row will be highlighted in grey and the text will be bold.
- Mark a column as a table header. The cells in the column will be highlighted in grey and the text will be bold.
- Highlight cells with a background colour.
- Remove the table.

Shortcut keys

<table>
<thead>
<tr>
<th>Windows</th>
<th>Action</th>
<th>Mac OS X</th>
</tr>
</thead>
<tbody>
<tr>
<td>Ctrl+Shift+c</td>
<td>Copy the current table row, or the selected rows.</td>
<td>Cmd+Shift+c</td>
</tr>
<tr>
<td>Ctrl+Shift+i</td>
<td>Insert a table. (Opens the Insert Table dialog.)</td>
<td>Cmd+Shift+i</td>
</tr>
<tr>
<td>Ctrl+Shift+v</td>
<td>Paste the table rows from your clipboard, placing them above the current row.</td>
<td>Cmd+Shift+v</td>
</tr>
<tr>
<td>Ctrl+Shift+x</td>
<td>Cut the current table row, or the selected rows.</td>
<td>Cmd+Shift+x</td>
</tr>
<tr>
<td>Alt+Up Arrow</td>
<td>Add a row above the current row.</td>
<td>Alt+Up Arrow</td>
</tr>
</tbody>
</table>
Alt+Down Arrow  |  Add a row below the current row.  |  Alt+Down Arrow

For more editor keyboard shortcuts, see Keyboard Shortcuts.

Sorting the table in view mode

When readers view a table on a page, they can sort the table by clicking the sort icons in the header row.

_Screenshot: A colourful, sortable table_

### Using Autocomplete

When using the Confluence editor, you can type a trigger character or press a keyboard shortcut to see a list of suggested links, files or macros to add to your page, or to mention another user (and automatically notify them of this).

**Summary of autocomplete**

<table>
<thead>
<tr>
<th>What you want to do</th>
<th>Trigger character</th>
<th>Keyboard shortcut</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Add a link on your page</td>
<td>[</td>
<td>Ctrl+Shift+K</td>
<td>See a list of suggested pages or other locations to link to from your page. More...</td>
</tr>
<tr>
<td>Display an image, video, audio file or document on your page</td>
<td>!</td>
<td>Ctrl+Shift+M</td>
<td>See a list of suggested images, multimedia files and documents to embed in your page. More...</td>
</tr>
<tr>
<td>Add a macro on your page</td>
<td>{</td>
<td>None</td>
<td>See a list of suggestions as you begin typing a macro name. More...</td>
</tr>
<tr>
<td>Notify another user by email that you have mentioned them on your page</td>
<td>@</td>
<td>None</td>
<td>See a list of suggested users to mention. More...</td>
</tr>
</tbody>
</table>
Using autocomplete for links

Type '[' or press Ctrl+Shift+K, to see a list of suggested pages or other locations to link to from your page. You can link to pages, user profiles, images, documents and other file attachments.

To autocomplete a link:

1. Edit the page.
2. Click where you want to insert a link and do one of the following:
• Type '[' and then the first few characters of the page title, user's name, image name or file name.
• Type the first few characters of the page title, user's name, image name or file name (or select relevant text) and then press Ctrl+Shift+K.

3. Click the relevant link from the list of suggestions.

If the item you need is not in the list, either:
• Choose **Search for 'xxx'** to continue looking for the page within Confluence, or
• Choose **Insert Web Link** to insert a link to an external web page using the link browser.

**Screenshot: Autocomplete for a link**

Using autocomplete for images, videos, audio files and documents

You can use the autocomplete as a fast way of embedding images, videos, audio files and documents into your page. Type an exclamation mark or press Ctrl+Shift+M to see a list of suggested images, multimedia files and documents to display on your page. You can use autocomplete to embed the following file types:

• Images – any format that Confluence supports.
• Videos, audio files and all multimedia formats that Confluence supports.
• Office documents supported by the Confluence Office Connector: Word, Excel and PowerPoint.
• PDF files.

![Autocomplete works most efficiently for files that are already attached to the Confluence page.](image)

To **embed an image, video, audio file or document:**

1. Edit the page.
2. Click where you want to insert the image, video, audio file or document and do one of the following:
   • Type '[' and then the first few characters of the image, file or document name.
   • Type the first few characters of the name of the image, file or document (or select relevant text) and then press Ctrl+Shift+M.
3. Choose the relevant file from the list of suggestions.

If the item you need is not in the list, either:

• Choose **Open Image Browser** to find images and documents using the image browser, or
• Choose **Insert Other Media** to embed videos, audio and other multimedia files using the macro browser. Insert the 'Multimedia' macro to display your multimedia file.

**Screenshot: Autocomplete for an image or document**
Using autocomplete for macros

Type '{' to see a list of suggested macros to add to your page.

Autocomplete provides access to all available macros in your Confluence site, including any user macros that your administrator has added and made visible to all.

ℹ️ You need to know the name of macro. Autocomplete for macros will only match the name of the macro, not the description.

To autocomplete a macro using '{':

1. Edit the page.
2. Click where you want to insert the macro.
3. Type '{' and then the first few characters of the macro name.
4. Choose the relevant macro from the list of suggestions.
5. Configure the macro by completing the form fields as prompted.

If the macro you need is not in the list, choose Open Macro Browser in the list of suggestions to continue looking for the macro in the macro browser. See Working with Macros.

Screenshot: Autocomplete for a macro
Using autocomplete for mentions

You can use autocomplete to automatically notify another Confluence user that you have mentioned them in a page, blog post, or comment. Type '@' and part of the person's name, to see a list of suggested users.

**Note:** Use the person's full name. Autocomplete will recognise users' full names only, not their usernames.

Cancelling autocomplete

The autocomplete starts automatically when you press the trigger characters. You may want to close the autocomplete menu or escape from autocomplete once it has started.

There are a few different ways to stop the autocomplete once it has started:

- Press the escape key, 'Esc', on your keyboard.
- Click somewhere else in the editor panel.
- Press an arrow key to move out of the autocomplete area.
- For the link autocomplete only: enter a right-hand square bracket, like this: ]

Enabling and disabling autocomplete

You can turn off the triggering of autocomplete by the '[' and ']' characters. This will prevent the autocomplete from starting automatically when you press one of the trigger characters. You can also turn it back on again.

Notes:

- This setting does not affect the keyboard shortcuts for autocomplete (Ctrl+Shift+K and Ctrl+Shift+M).
- Even if the trigger characters are disabled, you can still use the keyboard shortcuts for autocomplete.
- This setting affects only you. Other people using Confluence can enable or disable the setting on their user profiles independently.
- Note that autocomplete is enabled by default.

**To enable or disable the autocomplete trigger characters:**

1. Choose *your profile picture* at top right of the screen, then choose *Settings*.
2. Choose *Editor* under *Your Settings* in the left-hand panel.
3. Choose *Edit*.
4. Either:
   - Disable autocompletion by selecting *Disable Autocomplete*.
   - Enable autocompletion by clearing *Disable Autocomplete*.
5. Choose *Submit*.

*Screenshot: User settings for the editor*
Ignoring autocomplete

You can add macros, links and images by wiki markup alone. Type the macro, including its parameters and the closing curly bracket. Add a link, such as an anchor link, and end it with a square bracket. Insert an image or other embedded object, enclosed between exclamation marks. As soon as you close the macro, link, or embedded image, Confluence will convert it to rich text format and add it to the page.

For more information about mouse-free macros, links and images, choose Help > Keyboard Shortcuts from the Confluence header.

Working with Page Layouts and Columns and Sections

The layout of your pages can have a big impact on how they're read, and layouts, used well, allow you to position text, images, macros, charts, and
much more, to have the best visual impact.

There are two ways to modify the layout of a Confluence page:

- Use page layouts to add sections and columns
- Use macros to add sections and columns.

Page layouts provide a simple, visual representation of your page layout in the editor, while the macros are more flexible and allow for greater complexity in your layout.

Using page layouts

The page layouts tool allows you to structure your page using horizontal sections and vertical columns. By adding multiple sections with different column configurations you can build quite complex layouts very easily.

Screenshot: Editor view of a page showing three sections with different column configurations.

Start by adding a horizontal section to your page.

To add a section:

1. Choose the Page Layout button in the toolbar
   The Page Layout toolbar appears.
2. Choose Add Section

The new section appears below your current content, with the boundaries of the section(s) indicated by dotted lines (the dotted lines aren't visible when you view the page).

To change the column layout in a section:

1. Place your cursor in the section you wish to change
2. Choose a layout from the page layout toolbar (for example, two columns or three columns)

Any text, images or macros in your section are not lost when you change the column layout. When you decrease the number of columns, Confluence will move your content to the left. When you increase the number of columns, Confluence will add blank columns to the right of your existing content.

To move a section to another part of the page:
1. Place your cursor in the section you wish to move
2. Choose the Move up or Move down buttons

The section and all of its content will be moved above or below other sections on the page.

To delete a section:
1. Place your cursor in the section you wish to remove
2. Choose Remove section

The section and all of its content will be removed.

Notes about Page Layouts

- **Column width** – The width of the columns are fixed. If you need more than three columns, or columns of a specific width, you should use the Section and Column macros described below.
- **Very wide tables** – The width of each column is set to a percentage of the page width. The icons in the drop-down menu indicate the relative widths for each layout. In most cases, Confluence will adapt the width of the columns to fit the width of the page. If a column includes an item that's too wide for it, you'll see a horizontal scroll bar when viewing the page.

Using the Section and Column macros

You can use the Section and Column macros to add a set of columns to the page. The Section macro defines an area that will contain the columns. You can have as many sections as you like. Within each section, you can have as many columns as you like.

The Section and Column macros are useful if you want to define a specific percentage or pixel width for each column.

To add a section and some columns to a page:
1. In the Confluence editor, choose Insert > Other Macros
2. Find the **Section** macro, select it and insert it onto the page
3. Choose Insert > Other Macros again
4. Find and insert the **Column** macro
5. Add your content to the column

Insert as many columns as you like within the section.

*Screenshot: A section and two columns in the editor*

When you see the page in view mode, the above layout is displayed like this:
Macros

Parameters

Parameters are options that you can set to control the content or format of the macro output. Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).

Parameters of the Section macro

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Show Border</td>
<td>false</td>
<td>Select this option to draw a border around the section and columns.</td>
</tr>
<tr>
<td></td>
<td></td>
<td><strong>Note:</strong> Without a Column macro, the border will not be displayed correctly.</td>
</tr>
</tbody>
</table>

Parameters of the Column macro

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Column Width</td>
<td>100% of the page width, divided equally by the number of columns in the section.</td>
<td>Specify the width of the column, in pixels (for example, 400px) or as a percentage of the available width (for example, 50%).</td>
</tr>
</tbody>
</table>

Notes about sections and columns

- All content within your section must be enclosed within a Column macro, otherwise the section layout will not work as expected.
- You can put tables inside columns.

Creating Beautiful and Dynamic Pages

Confluence has a number of features that help you build attractive pages to engage your readers and give them the opportunity to interact with up-to-date information. This page summarises those features and provides links to detailed instructions.

Adding visual appeal

**Pictures, photographs and screenshots.** Confluence pages can display images from your Confluence site and from other websites. To put an image into Confluence, you can upload it and attach it to a page or blog post, then display it on any page, blog post or comment.

Alternatively, display an image from a remote location via the web address (URL). See .

**Displaying Images**

**Galleries.** Use the Gallery Macro to display a set of images. When viewing the page, people can click any of the pictures to zoom in and view the images as a slide show.

**People.** Add a Profile Picture Macro to show a picture of a Confluence user, or a User Profile Macro to show a summary of the person's profile as well as

On this page:

- Adding visual appeal
- Bringing numbers to life
- Displaying presentations and documents
- Pulling in content from your issue tracker
- Telling a story in pictures
- Varying the structure of your pages
- Integrating your content with social media
- Showing activity streams

Related pages:

- Working with Macros
- Using the Editor
- Confluence User’s Guide
their avatar.

**Multimedia.** You can display movies, animations and videos, and embed audio files on your Confluence page. For example, Confluence supports Adobe Flash, MP3, MP4, and various other movie formats. See Embedding Multimedia Content.

**Social video and image sharing.** The Widget macro displays live content from social sites such as YouTube and other video sharing sites, and Flickr for shared photographs. See the guide to the Widget Connector Macro.

**Bringing numbers to life**

The Chart Macro offers a variety of graphs and charts that you can use to illustrate statistics and other numerical data.

*Illustration: A 3-dimensional bar chart produced by the Chart macro*

Displaying presentations and documents

Display your Office documents and other presentations directly in Confluence.

- Attach your Office documents to a Confluence page then display them on the page, using the View File Macro. This works for Excel spreadsheets, PowerPoint presentations and Word documents.
- Display PDF files in Confluence too, also with the View File Macro.
- Use the Widget Connector Macro to show slide decks hosted on SlideShare and other online presentation sites.

**Pulling in content from your issue tracker**

Many project teams and customers have useful information on a JIRA issue tracker. Rather than copying and pasting it onto your Confluence page,
you can display it directly from the source, thus ensuring that the information shown in Confluence is always up to date.

Link to a feature request in your issue tracker, or display a list of fixed issues – useful for release notes and project planning. See the JIRA Issues Macro.

Telling a story in pictures

A number of Confluence add-ons provide sophisticated tools for creating diagrams and mockups.

For example:

- Balsamiq Mockups for Confluence
- Creately for Confluence
- Gliffy Confluence Plugin
- Graphviz Plugin for Confluence
- Lucidchart for Confluence

Search the Atlassian Marketplace for more add-ons.

Before installing an add-on (also called a plugin) into your Confluence site, please check the add-on’s information page to see whether it is supported by Atlassian, by another vendor, or not at all. See our guidelines on add-on support.

Varying the structure of your pages

You can build up a custom layout by using the page layout tool to add sections and columns to your page. See the detailed guidelines to Working with Page Layouts and Columns and Sections.

Do you need to display tabular data, which your readers can sort when viewing the page? See Working with Tables.

Use other macros to highlight and format sections of your page:

- Panel
- Tip
- Info
- Note
- Warning
- Code block
- Noformat

Integrating your content with social media

People share information on various social sites. You can make Confluence a focal point where people collect their shared information and see what is happening in the areas that matter to them.

Use the Widget Connector macro:

- Show a live stream of tweets from a Twitter user, or tweets matching a Twitter search.
- Display a video from YouTube or other online movie sites.
- Share photographs from Flickr.
• Display slide decks hosted on SlideShare and other online presentation sites.
• See what else the Widget Connector macro can do.

Showing activity streams

Make your Confluence pages dynamic and interactive with:
• An activity stream showing updates and comments on Confluence and other linked applications. See Working with Confluence Gadgets.
• An RSS feed from within Confluence or an external site. See Subscribing to RSS Feeds within Confluence.
• A list of recent blog posts from within Confluence. See Blog Posts Macro.

Working with Templates

When you add a new page, you do not have to write the content from scratch. Instead, you can base your new page on a template. A template is a Confluence page with predefined content. Some templates are provided by blueprints or add-ons, others are defined by Confluence users.

Some examples of where templates are useful:
• A software development project may have a template for use cases.
• A systems administration space may have a template for defining what information is kept about each server.

Global templates and space templates

In Confluence, there are two categories of page templates:
• **Space templates:** These page templates are available in a specific space only. If you have **space administrator permission**, you can define templates via the space administration screen.
• **Global templates:** These page templates are available in every space on your site. If you have **Confluence Administrator permission**, you can define global templates via the Confluence Administration Console.

System administrators can also **download predefined templates**.

Creating a template

You can write your template using the Confluence editor. You can also add special variables to the page, if you want to include fields that the author will complete when adding the page. See Creating a Template for more information.

Using a template
Page templates are used only when adding a page. It is not possible to apply a template to an already-existing page. Once a page has been added using a template, the template is no longer linked to the page. All further editing is performed as if the template was never used. Some plugins provide enhanced template functionality. You can search the Atlassian Marketplace for template add-ons. See Creating a Page using a Template for more information.

Templates provided by blueprints

A blueprint is a page template with added functionality to help you create, manage and organise content in Confluence.

Confluence ships with some predefined blueprints. You can also download additional blueprints from the Atlassian Marketplace. You can customise the blueprint templates to suit your individual needs, disable particular blueprints or even develop your own blueprints. See Working with Blueprints.

Promoting templates in the Create dialog

If you're a space administrator, you can choose to promote specific templates and blueprints in the Create dialog. Promoting items can help ensure consistency in a space by encouraging users to create particular types of content, instead of blank pages.

The promoted templates or blueprints will appear at the top, with all other content types, including Blank Page and Blog Post collapsed under them. To view the other types of content available choose the Show more link.

To promote a template or blueprint:

1. Go to Space Tools > Content Tools
   If your space is using the Documentation theme choose Browse > Space Admin > Templates
2. Choose Promote next to the templates or blueprints you want to appear in the Create dialog

Remember, by promoting a blueprint or template you'll be hiding all other items, including blank page and blog post, under the Show more link.

System templates

Confluence also provides 'system templates' containing content like the site welcome message and default space content. See Administering Site Templates.

Creating a Template

In Confluence, there are two categories of page templates:

- **Space templates**: These page templates are available in a specific space only. If you have space administrator permission, you can
define templates via the space administration screen.

- **Global templates**: These page templates are available in every space on your site. If you have Confluence Administrator permission, you can define global templates via the Confluence Administration Console.

Add a space template

1. Go to the space and choose **Space tools > Content Tools** from the bottom of the sidebar
2. Choose **Templates > Create new template**.

If your space uses the Documentation theme:

1. Choose **Browse > Space Admin** from the header
   
   **Note**: The **Space Admin** option appears only if you have space admin permissions, or if you’re part of the ‘confluence-administrators’ group.
2. Choose **Templates** from the space administration options.
3. Choose **Create new template**.

Add a global template

1. Choose the **cog icon** , then choose **General Configuration** under Confluence Administration
2. Choose **Global Templates and Blueprints** in the left-hand panel
3. Choose **Add New Global Template**
The template editor

When you create or edit a template, you'll be using the editor in much the same way as when you edit a page or blog post. In addition you can add variables, which will produce a form for data collection when anyone adds a page based on the template.

Screenshot: The template editor with an image, table, text, and variables

Enter your template title

Set the variable type

Add labels

Use the editor to format text, add images, tables and macros

Screenshot: The form displayed when you create a page based on the template
Page Template Wizard

Step 2: Fill in template variables

The information you supply will become part of the content in your new page.

<table>
<thead>
<tr>
<th>Minutes for</th>
</tr>
</thead>
<tbody>
<tr>
<td>Status Meeting (MeetingName)</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Date</th>
<th>15/02/2013 (Date)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Time</td>
<td>9:00 AM (Time)</td>
</tr>
<tr>
<td>Location</td>
<td>Meeting Room 1    (Location)</td>
</tr>
<tr>
<td>Attendees</td>
<td></td>
</tr>
<tr>
<td>Apologies</td>
<td></td>
</tr>
</tbody>
</table>

Minutes

- Add the first item here...
Template variables

When you add variables to your template, they will act as form fields. When you create a page based on a template, you'll see a text entry box for each field. Enter data into each field, and it'll be added to the page.

You can add the same variable more than once in the same template, which is useful if you need the same information in more than one place on the page.

To insert a variable into a template:

1. Choose Template > New Variable from the editor toolbar (or choose an existing variable to add it to the page)
2. Enter a name for the variable
3. Press Enter (by default this will create a single-line text input field)

To change the variable type, click the variable placeholder and the variable's property panel will appear. Choose one of the variable types: Text, Multi-line Text, or List.

You can change the number of lines and width in characters of a Multi-line Text field. If you choose List, enter each of the items in your list, separated by commas.

Hint: Type $ and the variable name, then press Enter to add a new variable or to select an existing variable from a list of suggestions. The suggestions dialogue shows variables already defined in this template.

Labels

If you'd like all pages created using this template to have a certain label or labels, choose Labels at the bottom-left of the page to add them.

Images and other attachments

You can't attach an image or other file to a template. Instead, attach the file to another page, and insert it into the body of the template.

For example:

- You can attach an image to a page and then choose Insert > Files and Images to embed the image into the template.
- You can attach a PDF to a page and then choose Insert > Other Macros > PDF to embed the PDF into the template.

Instructional text

Instructional text is placeholder content in a template, and is only visible while you're editing the page. Use it to give guidance to whoever is creating a page from the template.

To insert instructional text:

1. Choose Template > Instructional Text in the toolbar
2. Type in your instructional text (for example, *Insert an image of the interface here.*).

Instructional text appears in italics with a shaded background, to distinguish it from normal paragraph text.

You can also change the placeholder type from **Text** to either:

- **User mention** – Opens the user mention dialogue.
- **JIRA Macro** – Opens a dialogue that allows you to create a new JIRA issue, or search for one or more JIRA issues to include on the page.

Add a description to your template

The template description displays in the 'Create' dialog, and is useful for explaining the purpose of your template to other users.

**To add a description to a template:**

- Go to the space or global templates page (as described above)
- Choose the **Edit** icon in the 'Description' column
- Enter your description and choose **Save**

---

**User Created Templates**

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
<th>Last Updated By</th>
<th>Updated At</th>
</tr>
</thead>
<tbody>
<tr>
<td>Meeting Minutes Template</td>
<td>My new meeting minutes template.</td>
<td>John User</td>
<td>At</td>
</tr>
</tbody>
</table>

---

**Edit or delete a template**

If you need to change anything about your template, or want to delete it, navigate to either your space or global template (as described above) and choose either **Edit** or **Delete**.

**Notes**

- Page templates are used only when adding a page. It is not possible to apply a template to an already-existing page. Once a page has been added using a template, the template is no longer linked to the page. All further editing is performed as if the template was never used. Some plugins provide enhanced template functionality. You can search the [Atlassian Marketplace](https://marketplace.atlassian.com) for template add-ons.
- When you use a **Table of Contents macro** in a template, you'll see an error when you preview the template, but the Table of Contents macro works on the pages that people create from the template.
- The editor for templates is available only in **Confluence 4.3 and later**. Please refer to the [earlier documentation](https://confluence.atlassian.com/display/CONFLUENCE/Confluence+4.3+Documentation) for a description of the wiki markup editor templates.
- **Confluence also provides 'system templates' containing content like the site welcome message and default space content. See [Administering Site Templates](https://confluence.atlassian.com/display/CONFLUENCE/Administering+Site+Templates).**

**Creating a Page using a Template**

You can create a page based on a global template (available to all spaces) or a space template (available only to that space). Before reading this page, make sure that someone has already **created a template** on your Confluence site.

**Information copied from the template to the page**

When you create a page based on a template, Confluence will copy the following content and information from the template to the new page:

- Labels
- Text and styles
- Layouts and formatting
- Macros
• Embedded images and other files. Note that you cannot attach an image or other file to a template. But if the template displays an image or file from another page, the new page will display that image or file too.

Form fields displayed by the template

If the template author included variables in the template, Confluence will display a form prompting you to supply values for the variables when you add the page.

On this page:
• Information copied from the template to the page
• Form fields displayed by the template
• Using a template to create a page
• Notes

Related pages:
• Creating a Template
• Using the Editor
• Add, Remove and Search for Labels
• Confluence User's Guide

Using a template to create a page

To create a page based on a template:

1. Choose Create on the header
2. Select a space and the template you want to use and choose Next
3. If the template contains variables, you will now see a form. Type the relevant information into the form fields, and choose Next.
4. Now you will see a new page based on the template. If you added information in the form fields, the page content will include that information.
5. Type a name for the page where you see 'New Page'.
6. Add more content or make any other changes required.
7. Choose Save.

Screenshot: Form showing template variables when creating a page from a template
Page Template Wizard

Step 2: Fill in template variables

The information you supply will become part of the content in your new page.

Minutes for

- **Status Meeting** *(MeetingName)*

<table>
<thead>
<tr>
<th>Date</th>
<th>15/02/2013 <em>(Date)</em></th>
</tr>
</thead>
<tbody>
<tr>
<td>Time</td>
<td>9:00 AM <em>(Time)</em></td>
</tr>
</tbody>
</table>

Location: Meeting Room 1 *(Location)*

Minutes

- Add the first item here...
Notes

Page templates are used only when adding a page. It is not possible to apply a template to an already-existing page. Once a page has been added using a template, the template is no longer linked to the page. All further editing is performed as if the template was never used. Some plugins provide enhanced template functionality. You can search the Atlassian Marketplace for template add-ons.

Working with Blueprints

What is a blueprint?

A blueprint is a set of page templates with added functionality to help you create, manage and organise content in Confluence more easily.

Create meeting notes, shared file lists and requirements documentation out of the box, and Customise the blueprint templates to suit your individual needs. You can even develop your own blueprints.

Creating content using a blueprint

You create a page from a blueprint in the same way as other pages in Confluence. All blueprints are different and most contain instructions to guide you.

To create a page from a blueprint in the current space:

1. Choose Create in the Confluence header
2. Choose a blueprint from the 'Create' dialog
3. Choose Create

The editor will open, and, depending on the blueprint selected, a prompt to enter information or the page will appear. You can now follow the instructions built in to the blueprint to add content.

On this page:
- What is a blueprint?
- Creating content using a blueprint
- Customising blueprint templates
- Promoting blueprints in the Create dialog
- Adding more blueprints
- Disabling a blueprint
- Full list of blueprints

Related pages:
- Working with Templates
- Confluence User's Guide
- Request Add-ons

The first time a blueprint is used in a space, Confluence creates an index page and adds a shortcut to your sidebar (if you’re using the default theme). The index displays a list of pages made with the blueprint, and information selected information from your blueprint pages. For example, the meeting notes index displays a list of all meeting notes pages in the space, who created them, and when they were last modified.

Screenshot: Index page for the Meeting Notes blueprint
If you're using the Documentation theme, your blueprint index page(s) will appear in the sidebar as children of the homepage.

Customising blueprint templates

Blueprints are made up of templates that can be customised for an individual space or the whole site. This means you can adapt the content of the blueprint pages to suit your specific needs. For example, you might update the Meeting Notes blueprint templates to include a heading for apologies.

If you have space administrator permissions, you can customise blueprint templates for the spaces you are an administrator of. You must be a Confluence Administrator to customise blueprint templates for a whole site. See Administering Site Templates for more information.

To customise a blueprint template for a space:

1. Go to the space and choose Space tools > Content Tools from the bottom of the sidebar
2. Choose Edit beside the blueprint template you wish to edit
3. Make your changes to the template and choose Save

Editing a blueprint template is very similar to editing a page template, except:

- Be careful not to remove any macros that the blueprint page or index page may use to store and display information.
- You can't remove a blueprint template or change the template name.

To reset a blueprint template back to the default:

1. Go to the space and choose Space tools > Content Tools from the bottom of the sidebar
2. Choose **Reset to default** beside the blueprint template you wish to reset

See [Working With Templates](#) and [Administering Site Templates](#) for more information on templates.

As with user created space and site templates, editing a blueprint template will not change existing pages, but any new blueprint pages will be based on the updated template.

**Promoting blueprints in the Create dialog**

If you're a space administrator, you can choose to promote specific templates and blueprints in the Create dialog. Promoting items can help ensure consistency in a space by encouraging users to create particular types of content, instead of blank pages.

The promoted templates or blueprints will appear at the top, with all other content types, including Blank Page and Blog Post collapsed under them. To view the other types of content available choose the **Show more** link.

**To promote a template or blueprint:**

1. Go to [Space Tools > Content Tools](#)
   If your space is using the Documentation theme choose [Browse > Space Admin > Templates](#)
2. Choose **Promote** next to the templates or blueprints you want to appear in the Create dialog

Remember, by promoting a blueprint or template you'll be hiding all other items, including blank page and blog post, under the **Show more** link.

**Adding more blueprints**

You can find more blueprints for Confluence in the [Atlassian Marketplace](#). Blueprints are managed using add-ons (also known as plugins).

See [Request Add-ons](#) for information on how you can search for new blueprint add-ons and send a request to your System Administrator.

If you are a System Administrator, see [Managing Add-ons or Plugins](#) for information on how to install new blueprint add-ons.

You can also develop your own blueprints. See our developer documentation on [Writing a Blueprint](#).

**Disabling a blueprint**

You may want to disable particular blueprints. For example, you may not want to see the Product Requirements blueprint in the Create dialog in a HR or Social space. If you are a Confluence Administrator you can also disable particular page and space blueprints for the whole site.

**To disable a blueprint in a space:**
• Go to the space and choose Space tools > Content Tools from the bottom of the sidebar
• Choose Disable next to the blueprint you wish to disable in that space

You can re-enable the blueprint at any time.

**To disable a blueprint across a whole site:**

• Choose the cog icon, then choose General Configuration under Confluence Administration (You need Confluence Administrator permissions to do this)
• Choose Global Templates and Blueprints
• Choose Disable next to the page or space blueprint you wish to disable

The blueprint will not appear in the 'Create' or 'Create Space' dialogs.

**Full list of blueprints**

Here's the full list of blueprints bundled with Confluence.

<table>
<thead>
<tr>
<th>Page blueprints</th>
<th>Space blueprints</th>
</tr>
</thead>
<tbody>
<tr>
<td>Meeting notes</td>
<td>Documentation space</td>
</tr>
<tr>
<td>File list</td>
<td>Team space</td>
</tr>
<tr>
<td>Decision</td>
<td>Knowledge base space</td>
</tr>
<tr>
<td>How-to article</td>
<td></td>
</tr>
<tr>
<td>Troubleshooting article</td>
<td></td>
</tr>
<tr>
<td>JIRA report</td>
<td></td>
</tr>
<tr>
<td>Product requirements</td>
<td></td>
</tr>
<tr>
<td>Retrospective</td>
<td></td>
</tr>
<tr>
<td>Share a link</td>
<td></td>
</tr>
<tr>
<td>Task report</td>
<td></td>
</tr>
</tbody>
</table>

**Decisions Blueprint**

The Decisions blueprint helps you make decisions and record the outcomes with your team.

The first time you use the Decisions blueprint in a space, Confluence will create an index page and add a shortcut on your space sidebar (if you're using the default theme). The index acts as your Decision Register and lists all the decisions in that space.

**To use the Decisions blueprint:**

• Create a Decisions blueprint page (choose Create > Decision)
• Enter information about the decision and relevant stakeholders – the blueprint will prompt you.

*Screenshot: Decision Register showing a series of Decision pages*
### Decision register

Created by Rachel, last modified on Aug 15, 2013

<table>
<thead>
<tr>
<th>Decision</th>
<th>Status</th>
<th>Stakeholders</th>
<th>Outcome</th>
<th>Due Date</th>
</tr>
</thead>
<tbody>
<tr>
<td>How should we divide up confluence teams between writers</td>
<td>DECIDED</td>
<td>@Rachel @Giles @Nick</td>
<td>Split for 5.7 onwards decided here</td>
<td>08</td>
</tr>
<tr>
<td>Should we retire Planning for Confluence 4 and 5 doc from the latest space</td>
<td>DECIDED</td>
<td>@Rachel @Giles</td>
<td>Move pages with comments to CONF40 and CONF50 archive spaces.</td>
<td>03</td>
</tr>
<tr>
<td>Where should CQ developer doc live</td>
<td>IN PROGRESS</td>
<td></td>
<td></td>
<td>03</td>
</tr>
</tbody>
</table>

**Screenshot: Editing a Decision page**
The Decisions blueprint uses these Confluence features:

- **Page Properties** and **Page Properties Report** macro - content that you enter within the page properties macro can appear on the index page.
- **Mentions** - add a user as a stakeholder, owner or @mention them on the page and they will be notified in their workbox.

Customising this blueprint

You can customise the templates that are used by the Decisions blueprint - see Customising the blueprint templates. For example, you might choose to edit the decisions **index page** in a space to change the columns displayed by the Page Properties Report macro.

You can also edit the **page template** to add headings or instructional text to the background section, or even add rows to the Page Properties macro. For example, a row for the date the decision was made.

See [Instructional text](#) to find out more about using instructional text in templates.

**File List Blueprint**

The File List blueprint helps you to create lists of files to share with your team. Great for organising documents, images and presentations.

The first time you use the File List blueprint in a space, Confluence will create an index page and add a shortcut to your space sidebar (if you're using the default theme). The index page lists the latest File List pages in that space. You can have as many File List pages as you need.
To use this blueprint:

1. Choose **Create > File List** to create a File List page
2. Drag files from your desktop or choose Browse to attach files to the page

Attachments appear on the page. Expand each attachment to preview the file and/or view its details.

In this example, three file list pages have been created to store project related presentations, images and customer feedback. Confluence looks after the versioning of the files, so there's no need to use the document file name to mark version numbers.

*Screenshot: Index page showing File List pages*

*Screenshot: A File List page*
Presentations
Created by Rosie Admin 32 minutes ago

File

▶ 3 Atlassian presentation graphic assets.key.zip
▶ 3 IX Image Tools.key.zip
▶ 3 10 tech writing tips.key.zip

Click to expand

File preview

10 tech writing tips:
Don’t do what Donny Don’t does
Customising this blueprint

You can customise the templates that are used by the File List blueprint - see Customising blueprint templates.

The File List blueprint template uses the attachments macro. You can customise the macro to change the sort order or hide features such as version history and the upload attachment fields.

You can also edit the Content Report Table macro used on the Index page to specify the number of pages you want to display.

JIRA Report Blueprint

The JIRA Report blueprint helps you create easy to read reports to communicate the progress of your JIRA projects and releases. You can choose from a Change Log report that generates a list of JIRA issues or a Status Report that includes charts to visually communicate your progress.

The first time you use the JIRA Reports blueprint in a space, Confluence will create an index page and add a shortcut on your space sidebar (if you're using the default theme).

To use the JIRA Report Blueprint your Confluence and JIRA sites must be connected via Application Links.

Creating a Change Log

The Change Log report displays a list of issues from JIRA. This list can be static or dynamic, automatically updating as the status of your issues change in JIRA.

To create a static Change Log:

- Choose Create > JIRA Reports
- Select a Report Type
- Select your JIRA server
Choose a **Project** and **Fix Version** to report on

Choose **Create**

A report page will be created with sample text and a list of all issues for the project and fix versions selected, organised by issue type. This list of issues is static; it won't be updated when the issues in JIRA are updated, and is visible to users who don't have JIRA access or permissions to view that project.

**Screenshot: Creating a Change Log in simple mode.**

![Static list of JIRA Issues displaying in the Change Log.](image)

**Screenshot: Static list of JIRA Issues displaying in the Change Log.**

**To create a dynamic change log:**

- Choose **Create > JIRA Reports**
- Select a **Report Type**
- Choose **Advanced**
- Enter a JQL query or paste in the URL of a JIRA search (find out about using JQL in the [JIRA Documentation](#))
- Choose **Create**

A report page will be created with sample text and a JIRA issues macro that's configured to show your issues. The macro is dynamic and will update when the issues in JIRA are updated. For more information on changing the information displayed, refer to the [JIRA Issues macro](#).

**Screenshot: Dynamic list of JIRA Issues displaying in the Change Log.**
Creating a Status Report

The Status Report displays the progress of a JIRA project and fix version in pie charts by status, priority, component and issue type. The Status Report uses the JIRA Chart macro, and is dynamic.

To create a status report:

- Choose Create > JIRA Reports
- Select Status Report
- Select your JIRA server
- Choose a Project and Fix Version to report on or enter a JQL query or JIRA URL
- Choose Create

A report page will be created with sample text and a series of pie charts, using the JIRA Chart macro. The macro is dynamic and will update when the issues in JIRA are updated. For more information refer to the JIRA Chart macro.

As with the Change Log, you can switch to Advanced mode and use JQL or paste in a JIRA URL to search for issues to display in the report.

Screenshot: Excerpt from the Status Report.
Customising this blueprint

You can customise the templates used by this blueprint. The Change Log uses the **Snapshot JIRA Report Template** (for static list of issues) and the **Dynamic JIRA Report Template**, and the Status Report uses the **Status Report Template**. See **Customising the blueprint templates**. Variables represent the JIRA Issues and JIRA Chart Macros. While these can't be edited, they can be moved around the page or deleted if you don't want every chart to be included.

You can also choose to edit the **page template** to modify the format of the page, change some headings, or modify the instructional text. To See **Instructional text** to find out more about using instructional text in templates.

**Meeting Notes Blueprint**

The Meeting Notes blueprint helps you to plan your meetings and share notes and actions with your team.

The first time you use the Meeting Notes blueprint in a space, Confluence will create an index page and add a shortcut on your space sidebar (if you are using the default theme). The index page lists the latest Meeting Notes pages in that space.
To use the Meeting Notes blueprint:

1. Choose Create > Meeting Notes
2. Enter goals, agenda items, and @mention attendees (the instructional text will prompt you)
3. Save your page and get ready to attend your meeting
4. Edit the page during or after your meeting, and enter your notes, action items and @mention users to assign tasks to them.

Screenshot: Index showing three Meeting Notes pages.

<table>
<thead>
<tr>
<th>Title</th>
<th>Creator</th>
</tr>
</thead>
<tbody>
<tr>
<td>2014-10-17 Meeting notes</td>
<td>Rosie Admin</td>
</tr>
<tr>
<td>2014-10-15 Meeting notes</td>
<td>Frank Admin</td>
</tr>
<tr>
<td>2014-10-13 Meeting notes</td>
<td>Josh User</td>
</tr>
</tbody>
</table>

Screenshot: A blank Meeting Notes page showing instructional text.
The Meeting Notes blueprint uses some cool Confluence features:

- **Instructional text** - this handy text prompts you to enter information and disappears when you start typing or view the page.
- **Mentions** - @mention a user on the page and they will be notified in their workbox.
- **Task lists** - @mention a user in a task to assign it to them – the task will appear as a personal task in their workbox. You can also add a due date by typing //, then choosing a date from the calendar.
Customising this blueprint

You can customise the templates that are used by the Meeting Notes blueprint – see Customising the blueprint templates.

You might choose to edit the headings or add additional headings, or change the instructional text that prompts users to enter information to suit your context. To find out more about using instructional text in a template, see Instructional text.

You can also edit the Content Report Table macro used on the Index page to specify the number of pages you want to display.

Product Requirements Blueprint

The Product Requirements blueprint helps you to define, scope and track requirements for your product or feature.

The first time you use the Product Requirements blueprint in a space, Confluence will create an index page and add a shortcut on your space sidebar (shortcut only available in the default theme). The index lists all the Product Requirements pages in that space, and displays a summary of the information on each page (such as status and owner). You can have as many Product Requirements pages as you need.

To use the Product Requirements blueprint:

1. Choose Create > Product Requirements to create a Product Requirements blueprint page
2. Enter information about your product or feature – the instructional text will prompt you.

You can @mention team members to bring them into the conversation about the page.

Screenshot: Index showing a series of Product Requirements pages and summary information

Related pages:

- Working with Blueprints
- File List Blueprint
- Meeting Notes Blueprint

Screenshot: Editing a Product Requirements page
The Product Requirements blueprint uses these Confluence features:

- **Page Properties** and **Page Properties Report** macro - content that you enter within the page properties macro can appear on the index page.
- **Instructional text** - this handy text prompts you to enter information or create a JIRA issue and disappears when you start typing or view the page.
- **Mentions** - @mention a user on the page and they will be notified in their workbox.

Customising this blueprint

As no two products or projects are alike, you can customise the templates that are used by the Product Requirements blueprint - see [Customising the blueprint templates](#).

You might choose to edit the **index** page in a space to change the columns to be displayed by the Page Properties Report macro.
You might choose to edit the page template to:

- edit the headings or add additional headings
- change the instructional text that prompts users to enter information to suit your context
- add or remove rows within the Page Properties macro.

See Instructional text to find out more about using instructional text in templates.

Retrospectives Blueprint

Retrospective blueprints help you track team successes and opportunities after projects or at the end of a sprint. Use this blueprint to document what went well, what needed improvement, and assign actions for the future.

Using Retrospective blueprints

Here’s how to use this blueprint for your next retrospective:

1. Choose Create in the Confluence header
   The Run a Retrospective dialog appears with today’s date populated in the title.
2. Add participants

   ![Run a Retrospective dialog](image)

   Choose Create in the Run a Retrospective dialog
   Your new Retrospective blueprint loads.

Related pages:

- Working with Blueprints
- File List Blueprint
- Meeting Notes Blueprint
The Retrospective blueprint uses the following Confluence features:

- **Page Properties** and the **Page Properties Report** macro make content listed within the macro visible on the index page.
- **Instructional text** prompts you to enter information and disappears when you start typing or view the page.
- **Mention** a user on the page to notify them in their workbox.

**Customising this blueprint**

Every team conducts retrospective meetings differently. You can customise the Retrospectives blueprint template to match your team's culture and practices. You can:
• Edit headings and pre-populated text.
• Add instructional text to capture specific information.
• Add additional sections and content.

See Customising blueprint templates for instructions.

Shared Links Blueprint

The Shared Links blueprint helps you take content from the web and share it with your team. You can use Shared Links to share and collaborate on web content, or to create a centralised repository of useful links.

The first time you use the Shared Links blueprint in a space, Confluence will create an index page and add a shortcut on your space sidebar (if you’re using the default theme). The index lists all the shared links in that space.

To use the Shared Links blueprint:

• Choose Create > Share a link
• Enter the URL of the web content you want to share
• Choose Create

You can also:

• Include topics to help categorise your links – these are added as labels to your page.
• Share the link immediately with another user or group – users will receive a notification.
• add a comment to start the discussion.

To make sharing links even faster, you can add a Share on Confluence button to your browser’s toolbar. Click this button and the webpage you’re currently viewing will be added as a shared link!

To add the Share on Confluence button to your browser:

• Choose Create > Share a link
• Drag the Share on Confluence button to your browser toolbar

Now, when you want to share a link on Confluence, you can choose the Share on Confluence button in your browser and follow the prompts.

Screenshot: Share a link from the Create dialog.
Creating a Blueprint-Style Report

Using a combination of templates and macros you can make a wide range of reports for managing anything from customer interviews, product requirements to IT service catalogues and more. In this tutorial we'll guide you through the process of creating a blueprint-style report.

In this example, we'll create a multi-team status report. Here's the scenario we'll use for this tutorial.
The Design, Development and QA teams working on the Blue Sky Project need to produce a short status update page each week, containing the focus area for the week, contact person, risks and overall status for each team. They like the way the Product Requirements blueprint works and want to be able to manage their status updates in a similar way.

What do each of the players want out of this report?

- **Project Lead** – Wants an at-a-glance report that shows only the status for each team.
- **Team Leads** – Want a summary report, including the focus areas and risk, just for their team.
- **All team members** – Want it to be easy to create the new page each week.
- **Management Team** – Want to see all the details for a week on one page, and don’t want to have to look at a different page for each team.

With this scenario in mind, this tutorial will guide you through how to:

1. Create a status update template containing a separate page properties macro for each team's section of the report.
2. Create a high level status report, showing just the status of all teams.
3. Create a summary report for each team.
4. Create your first status update page.

⚠️ You’ll need Space Administrator permissions to complete some of the steps in this tutorial.

Part 1: Create a status update template

First we’ll create a page template and add the Page Properties macros.

1. Go to **Space Admin > Content Tools > Templates**
2. Choose **Create Template**
3. Give the template a name (in this example the template will be called ‘Status Update’)
4. Add the skeleton of your status report to the page
5. Add a **Label** to the template (in this example we’ll add 'status-update' as the label)

![Screenshot: Adding teams to our status update template](image)

Now we’ll add a Page Properties macro to record the status of the Design team.

6. Choose **Insert > Other Macros > Page Properties** to add the Page Properties macro to the page
7. In the macro body create a two column table and remove the heading row
8. In the left column enter the column headings for your report (these are known as metadata 'keys')
   - In this example we’ll add 'Design Focus', 'Design Status', 'Design Contact' and 'Design Risks').
9. In the right column, leave the cells blank, or enter some instructional text to prompt your users (Choose Template > Instructional Text)
   We’ve also added a status macro.
10. Edit the Page Properties macro and enter a Page Properties ID for this macro (in this example we’ll use 'status-update-design'). This will allow us to report on the status of just the Design team later on.
    Repeat this process for the Development and QA teams, remembering to specify a different ID for each macro (we used 'status-update-dev' and 'status-update-qa').
11. Finally, add any other headings, instructional text or content to your template and Save.
   You can enter a Description for your template - this appears in the Create dialog.

   Screenshot: Our status update template

Part 2: Create a report showing the high level status of each team

Next we'll create an index page, just like you see in many blueprints.

1. In your space create a new blank page – this will be our 'Status Report - all teams' page, showing just the status of each team.
2. Choose Insert > Other Macros > Page Properties Report to add the Page Properties Report macro to the page
3. Enter the Label to report on (in this example it will be 'status-update', the label we added to the template page earlier)
4. Leave the Page Properties ID field blank – we want to report on all the macros on the page.
5. In the Columns to Show field, list the 'keys' from each macro that you want to include in the report (in this example we only want to show the values of 'Design Status', 'Dev Status', 'QA Status')
6. Choose Save to add the macro to the page

   Screenshot: The page properties report macro on the 'Status Report - all teams' page
Now we'll add a button to the page to allow team leads to easily create new status update pages from the template we created earlier.

7. Choose **Insert > Other Macros > Create from Template** to add the Create from Template macro to the page.
8. Enter the text for the button (in this example we'll call the button 'New Status Update Page').
9. Select the template from the **Template Name** drop down (in this example our template was called 'Status Update')
10. Specify the title of any pages to be created – this is a great way to keep your titles consistent. (in this example we'll call the page 'Status update week ending @currentDate' which will append the current date when the page is created, as in the meeting notes blueprint)
11. Choose **Insert**
12. Add any other content, links or images to the page and **Save**
13. Choose **Space Tools > Configure Sidebar > Add Link** to add a shortcut to the page on the sidebar.

Part 3: Create a separate report for each team

Now we'll create some index pages that show a more detailed summary for each team, starting with the Design team.

1. Create a new blank page – this will be the 'Design Status Report' index page, showing just information for that team.
2. Choose **Insert > Other Macros > Page Properties Report** to add the Page Properties Report macro to the page.
3. Enter the **Label** (the page label is once again 'status-update', the label we added to the template)
4. Enter the **Page Properties ID** that was specified in the Page Properties macro in the template (in this example it was 'status-update-design') – this allows us to report on just information in that macro.
5. Leave all of the other fields blank (we want to show all columns from this Page Properties macro)
6. Choose **Save** to add the macro to the page.
7. Add any other content, links or images to the page and **Save**
8. Choose **Space Tools > Configure Sidebar > Add Link** to add a shortcut to the page on the sidebar
9. Create a new page and repeat this process for each team
   Remember to specify a different Page Properties ID each time (in this example 'status-report-dev' and 'status-report-qa').

If your Design, Dev and QA teams have their own team spaces, this summary report could even be created in their team spaces. Just be sure to specify the space where the Status Updates pages are created in the **Restrict to spaces** field, to make sure the macro can find the pages to report on.

**Part 4: Create your first status update page**

That's it! Choose **Create > Status Update** or use the **Create a new status update** button to make your first status update page. Just like a blueprint, but 100% made by you.

Here's how our finished pages look.

**Screenshot: Team Leads and the management team still have a single page for the weekly status update.**
Screenshot: The Project Lead can see the status of each team, each week, at a glance in the All Teams status report.
Each team can see their focus, risks and status at a glance in their status report.

Remember, these concepts don't just apply to status updates - you can use them for any purpose at all. Tell us about how you've made your own blueprint-style reports in comments.

Importing Content Into Confluence

There are a number of ways you can get existing content, such as text, images and other content into Confluence.

On this page:
- Importing content from other Confluence sites
- Importing content from a Microsoft Word document
- Importing web content
- Importing other content
To import content from another Confluence site you can:

- Import a backup of the entire Confluence site
- Import an XML export of an individual space. Page history, attachments, and page content will be preserved.

See Restoring a Site and Restoring a Space for more information.

Importing content from a Microsoft Word document

The Office Connector allows you to create pages by importing Word documents. The document content is copied onto one or more Confluence pages. See Importing a Word Document into Confluence.

Importing web content

To displaying web content on a page:

- Use the Widget Connector Macro to display videos, slide shows, twitter chats, documents and more, sourced from other web sites and displayed on your Confluence page.
- Embed an external web page into Confluence with the HTML Include macro.
- Use HTML code in a page with the HTML macro.

Importing other content

Importing non-wiki markup into Confluence requires a conversion process:

- Text with basic formatting can be pasted directly into the editor. This includes simple Word documents or web pages.
- Confluence pages saved to disk can be imported from disk.
- Files can be uploaded in bulk using the Confluence WebDav Plugin
- Full featured customisation is available using the Confluence remote APIs.

Importing Content from Another Wiki 1

Please note, the Universal Wiki Converter (UWC) does not support Confluence versions after 4.3.7.

Importing a Word Document into Confluence

The Office Connector allows you to import Word documents and create one or more Confluence pages from the content.

You can create a single page, or divide the contents up into multiple pages, based on the headings in your document.

This is useful if you have a lot of content stored in existing documents, or if you are migrating from another system or platform that allows you to export to Word format.

⚠️ The Office Connector is only available for some browsers, operating systems and applications, so
you'll need to check the Office Connector
Prerequisites before you start.

**Importing a Word document**

**To import a Word document:**

1. Create a page in Confluence or go to an existing page (you want to view the page, not edit it).
2. Choose "Import Word Document"
3. Choose Browse and locate the Word document you want to import then choose Next.
   The import document options appear.
4. Enter a title for the new page (useful if you do not want to use the file name as your page title).
5. Choose where you want to import the file (as a brand new page, or overwriting an existing page with the same title).
6. Choose how to handle title conflicts (rename the new pages or replace existing pages).
7. Choose whether to create a single page or multiple pages based on the heading styles in the file (this option is only available if the file contains heading styles).
8. Click Import.

When the upload has finished, pages will be created with the content of the Word documents. You can then view and edit this page as normal. There’s no connection between the original Word document and this page.

**Import options**

There are a number of options when importing a Word document that control how pages are created, whether the import should overwrite existing pages in the space, and how it should handle page name conflicts.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Root page title</strong></td>
<td>This is the title of the page that will be created or updated by the import.</td>
</tr>
<tr>
<td><strong>Where to import</strong></td>
<td>Controls whether the document is imported into the current page (the page you were viewing when you selected Tools &gt; Import) or created as a new page. Choose from</td>
</tr>
<tr>
<td></td>
<td>• Import as a new page in the current space - a new page will be created as a child of the current page.</td>
</tr>
<tr>
<td></td>
<td>• Replace &lt;page name&gt; - content will be imported into the current page. The title of this page will change to the title you specified in the Root page title field.</td>
</tr>
<tr>
<td></td>
<td>• Delete existing children of &lt;pagename&gt; - any existing children of the current page will be removed when the content of the page is replaced.</td>
</tr>
<tr>
<td><strong>Title conflicts</strong></td>
<td>Controls how page name conflicts (a page with the same title already exists in the space) are handled.</td>
</tr>
<tr>
<td></td>
<td>• Rename imported pages if page name already exists - new pages get a new name (a number added to the end of the page title). Existing pages will be unchanged.</td>
</tr>
<tr>
<td></td>
<td>• Replace existing pages with imported pages of the same title - overwrite the content of existing pages. The change will be shown in the Page History for the page.</td>
</tr>
<tr>
<td></td>
<td>• Remove existing pages with the same title as imported pages - remove original pages and then create new pages. The change is not shown in the Page History for the page.</td>
</tr>
<tr>
<td><strong>Split by heading</strong></td>
<td>If the document contains Word heading styles you can choose to create multiple pages based on the heading. Options are:</td>
</tr>
<tr>
<td></td>
<td>• Don't split - creates a single page.</td>
</tr>
<tr>
<td></td>
<td>• Level Headings - creates multiple pages in a hierarchy based on the heading levels in the document.</td>
</tr>
</tbody>
</table>

A preview of the pages that will be created appears under **Document Outline**.
Importing Content from Another Wiki

Please note, the Universal Wiki Converter (UWC) does not support Confluence versions after 4.3.7.

Importing Pages from Disk

Confluence allows you to import text files from a directory on the Confluence server, and convert them into Confluence pages. Each file will be imported as a separate Confluence page with the same name as the file.

Notes:

- The text file may contain plain text, HTML or Confluence Storage Format.
- You need to be logged in as a System Administrator to import text files.
- You can import pages from disk into site spaces, but not into personal spaces. Please see Working with Spaces for information about differences between site spaces and personal spaces.

To import text files:

1. Go to the space and choose Space tools > Content Tools from the bottom of the sidebar
2. Choose Import.
3. Type the your directory path into the Import directory box.
4. Select Trim file extensions to remove file extensions from the page titles when converting the files to Confluence pages. Note that the Confluence pages will take their titles from the files' names (including their extensions). To avoid having page titles with a suffix like '.txt' check this box.
5. Select Overwrite existing pages if you want to replace existing Confluence pages that have the same page title as one you are importing.
6. Choose Import.

If your space uses the Documentation theme:
1. Choose **Browse > Space Admin** from the header

   **Note:** The **Space Admin** option appears only if you have **space admin permissions**, or if you're part of the 'confluence-administrators' group.

2. Choose **Import** from the space administration options.
3. Follow the steps above.

Confluence will place the new pages at the root of the space.

**Screenshot: Importing text files**

You can use this action to import text files from a directory on the Confluence server.

These text files become pages in Confluence, with the following features:

- The page title is taken from the filename
- The content is the entire page body

![Import directory](image)

Trim file extensions

Overwrite existing pages

[Import] [Cancel]

**Orphaned Pages**

An orphaned page is a page without any incoming links and is located at what's called the 'root of the space', meaning it sits alongside the space's home page. This means that, unless you know the page exists, you're not likely to come across it during the natural course of navigation.

There may be a legitimate reason you want to have a page at the root of a space. For example, you may be effectively hiding it in the navigation. If you don't want orphaned pages though, you can easily view all orphaned pages in a space so you can tidy delete the pages or reorganise them so they're no longer orphaned.

**To view the orphaned pages in a space:**

1. Go to the space and choose **Space tools > Content Tools** from the bottom of the sidebar
2. Choose **Orphaned Pages**.

If your space uses the Documentation theme:

1. Choose **Browse > Space Operations** at the top of the screen.
2. Choose **Orphaned Pages** in the space operations options.

While in the orphaned pages view, you can do any of the following:

- Delete an orphaned page by choosing the 'trash can' icon next to the page name.
- Edit a page by choosing the 'pencil' icon next to the page name.
- Give an orphaned page a parent — see **Move and Reorder Pages**.

**Screenshot: Managing orphaned pages**
Undefined Page Links

You can add links to pages that don't yet exist in Confluence, but you intend to create later. Known as links to 'undefined pages', they allow you to create a link which, when clicked, will create a page with the name you specify in the link.

Create an undefined page link

1. Choose Insert > Link or press Ctrl+K on your keyboard
2. Choose Advanced
3. Enter the name of the page to be created in the Link field

A link to an undefined page is shown in dark red while in the editor. When anyone clicks the link, Confluence will create a new page with the name you typed in the Link field.

View undefined pages in a space

The Undefined Pages view shows you all undefined pages in your space. The undefined page links are badged with a ♦ icon to remind you that those pages are yet to be created.

To view a list of the undefined links in a space:

1. Go to the space and choose Space tools > Content Tools from the bottom of the sidebar
2. Choose Undefined Pages
If your space uses the Documentation theme:

1. Choose **Browse > Space Operations** at the top of the screen.
2. Choose **Undefined Pages** in the space operations options.

You can choose the link for an undefined page to create the page and add content to it.

**View Page Information**

The Page Information view for a page shows you useful information about the page.

**To see the information about the page:**

1. View the page.
2. Choose *** > Page Information

You will see the following information:

- **Page details**: Title, author, date of creation, date of last modification and the tiny link (permalink) of the page.
- **Page hierarchy**: Parent-child relationships of the page.
- **Incoming links**: Lists other pages in your Confluence Site that have links to this page, or reference this page in an Include Page or Excerpt Include macro.
- **Labels**: Any labels (tags) that have been applied to this page. See Add, Remove and Search for Labels.
- **Page Permissions**: Displays page-level security restrictions that apply to the page (if present). See Page Restrictions.
- **Hot Referrers**: The external website pages which send the most viewers to the page. See Managing External Referrers.
- **Recent Changes**: Links to the five most recent versions of the page along with the name of the editor and the date of modification. See Page History and Page Comparison Views. Choose View page history to see the page history view, all the versions of the page in reverse chronological order and allows you to compare versions or to restore a previous version.
- **Outgoing links**: A summary of the links contained on this page, pointing to other pages on the Confluence site or to external websites.

Note: if there is no information to report (for example the page has no restrictions or no incoming links), that section of the Page Information won’t appear.

*Screenshot: Page information for this page*
Confluence Latest /... / Viewing Page Information

**Page Information**

<table>
<thead>
<tr>
<th>Title:</th>
<th>Viewing Page Information</th>
</tr>
</thead>
<tbody>
<tr>
<td>Author:</td>
<td>Vidya Madabushi</td>
</tr>
<tr>
<td>Last Changed by:</td>
<td>Sarah Maddox [Atlassian]</td>
</tr>
<tr>
<td>Tiny Link:</td>
<td><a href="https://confluence.stg.internal.atlassian.com/x/kCAC">https://confluence.stg.internal.atlassian.com/x/kCAC</a></td>
</tr>
<tr>
<td>Export As:</td>
<td>Word</td>
</tr>
<tr>
<td>Operations:</td>
<td>Copy</td>
</tr>
</tbody>
</table>

**Recent Changes**

<table>
<thead>
<tr>
<th>Time</th>
<th>Author</th>
<th>Event Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Feb 18, 2013 21:05</td>
<td>Sarah Maddox</td>
<td>Migrated to Confluence 5.3</td>
</tr>
<tr>
<td>Feb 18, 2013 21:05</td>
<td>Sarah Maddox</td>
<td>Updated for Confluence 5.0</td>
</tr>
<tr>
<td>Dec 21, 2012 03:26</td>
<td>Sarah Maddox</td>
<td>Removed obsolete link</td>
</tr>
<tr>
<td>Sep 07, 2011 06:19</td>
<td>Paul Watson [A]</td>
<td>Corrected links that should have been re</td>
</tr>
<tr>
<td>Sep 07, 2011 06:19</td>
<td>Paul Watson [A]</td>
<td></td>
</tr>
</tbody>
</table>

**Outgoing Links**

- Confluence Latest (5)
- Page Restriction
- Page History and Page Comparison
- Confluence User's Guide
- Working with Confluence Labels
- Working with Pages
- Viewing Page Information
- Managing External Referers
- Confluence Glossary

**Incoming Links**

- Confluence Latest (2)
  - Page History and Page Comparison Views
  - Recording Change Comments
- Confluence 4.1 (1)
  - Recording Change Comments

**Hierarchy**

| Parent Page      | Working with Pages |

**Labels**

- Global Labels (3)
  - metadata
  - referrers
  - incoming-links

**Page Permissions**
Page History and Page Comparison Views

Confluence tracks the history of changes to each page by creating a new version of the page each time it's modified. You can view the changes between different versions, and roll back to a previous version if you need to.

Access the page history

To view the history of a page:

1. Go to the page and choose **Page History**
2. Choose a version number to view the content of that version

**Screenshot: Page history**

View an older version

When you select a previous version of the page, you'll see a header like this at the top of the page:

![Warning message]

If you want to send this page version to someone, copy and paste the URL from your browser. The link will look something like this: `http://confluence.atlassian.com/pages/viewpage.action?pageId=12345`

When you're viewing a specific version of the page, the following functions are available:

- Access the page history
- View an older version
- Restore a previous version
- Delete a specific version
- View the changes made in two versions
- More about the comparison view

**Related pages:**
- View Page Information
- Working with Pages
- Tracking Updates
### Function | Description
--- | ---
**current version** | View the latest version of the page.
**Compare with Current** | Compare the differences between the version of the page you are viewing and the current version.
**Restore this Version** | Roll back the content of the page to the previous version that you are viewing.
**View Page History** | Return to the list of page versions.
<< Previous and Next >> | View the previous or next version of the page.

### Restore a previous version

1. Go to the page and choose *** > Page History
2. Choose Restore this version beside the version you want to restore (or at the top of the page if you've opened the version)
3. Change the default change comment if necessary, and choose OK

*All page history is retained; restoring an older version creates a copy of that version. For example, if you restore version 39, Confluence will create a copy of version 39 and the copy will become the new, current version.*

### Delete a specific version

Choose **Delete** next to a version in the page history, to remove that version.

### View the changes made

Using the page history view or the page information view, you can see the recent changes made to a page.

**To view recent changes made to a page:**

1. Choose *** > Page Information
   In the section titled 'Recent Changes' you'll see the most recent versions of the page, along with the date of their modification and the name of the modifying author.
2. Choose View Changes beside the required version
   The page comparison view is displayed, showing the differences between the selected and previous versions.

### Compare two versions

1. Go to the page and choose *** > Page History
2. Choose the versions you want to compare by selecting the check boxes beside them
3. Choose Compare selected versions

You'll see the page comparison view showing the differences between the selected versions. Changes are highlighted as follows:

<table>
<thead>
<tr>
<th>Highlighted colour</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>Green</td>
<td>Added content</td>
</tr>
<tr>
<td>Red</td>
<td>Deleted content</td>
</tr>
</tbody>
</table>
More about the comparison view

When you view a page comparison, all large sections of unchanged text are hidden and reduced to an ellipsis (...).

You can view page changes between versions which are adjacent to your current page comparison view. Click the link containing:

- `<` to view the page comparison with the earlier adjacent version
- `>` to view the page comparison with the more recent adjacent version.

For example, if your page comparison view is between v. 30 and v. 34 of a page, you can view changes between:

- v. 29 and v. 30 by clicking `Changes from 29 to 30`
- v. 34 and v. 35 by clicking `Changes from 34 to 35`

Using a WebDAV Client to Work with Pages

Create, move and delete pages and attachments in Confluence using a file manager like Finder (OS X), Explorer (Windows) or Dolphin (Linux) or other WebDav compatible local client like CyberDuck.

For example, if you need to delete a lot of pages you can bulk delete them in your local file manager (like Finder or Explorer), rather than one by one in your browser.

Access to Confluence through a native client is provided by the WebDav plugin. Your administrator may have disabled the WebDav plugin, or may have restricted the actions that you can perform using a local client. See Configuring a WebDAV client for Confluence for more information on how to set it up.

Managing pages and files in a native client

Accessing Confluence through a native client is useful for performing bulk actions. Before you can start creating and moving things around, it's useful to understand how the content is organised.

The hierarchy in the file system looks like this:

- Type of space (global or personal)
Essentially the file structure is the same as the page tree in your space. Here's how the Confluence demonstration space looks in Finder.

Here's some things you might choose to do in a local client, rather than in your browser:

- **Move pages to another space**
  Select the page folders, and drag them into the other space's folder (drag them from Space A to Space B)

- **Delete multiple pages**
  Select all the page folders you want to delete and delete them.

- **Delete multiple attachments from a page**
  Navigate down to the page folder, select the attachments you want to delete and delete them.

- **Upload multiple attachments**
  Navigate to the page folder, and drag the files into the folder (note you can attach multiple files through the insert dialog as well).

**Working with Macros**

Using macros helps you to expand the capabilities of your Confluence pages, allowing you to add extra functionality or include dynamic content. For example, use the **Attachments macro** to list files attached to a page, or use the **Widget Connector macro** to include things like a YouTube video or Twitter feed.

**Adding a Macro to your Page**

*Including Macros with the Macro Browser*
To add a macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

**Speeding up macro entry with autocomplete:** Type `{` and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

**To edit an existing macro:** Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

**Macro Parameters**

Many macros have optional parameters you can use to control the macro's output.

With the Attachments Macro, for instance, you have two optional parameters allowing you to:

- Specify the file formats of the attachments displayed.
- Choose whether or not you want old versions of the attachments displayed.

**Macro Placeholders**

Macro placeholders are displayed in the editor where you have added a macro to the page.

When editing a page, you can:

- Double-click a macro placeholder (or click the placeholder and choose Edit) to open the macro dialog window, where you can edit the macro's parameters.
- Select a macro placeholder to cut, copy and paste the macro.

**Confluence macros**

Below is a list of the macros currently bundled with Confluence. Click a macro name for details of the usage, including optional parameters and examples.

- Activity Stream Macro
- Anchor Macro
- Attachments Macro
- Blog Posts Macro
- Change-History Macro
- Chart Macro
- Cheese Macro
- Children Display Macro
- Code Block Macro
- Column Macro
- Content by Label Macro
- Content by User Macro
- Content Report Table Macro
- Contributors Macro
- Contributors Summary Macro
- Create from Template Macro
- Create Space Button Macro
- Excerpt Include Macro
- Excerpt Macro
- Expand Macro
- Favourite Pages Macro
- Gadget Macro
- Gallery Macro
- Global Reports Macro
- HTML Include Macro
- HTML Macro
- IM Presence Macro
- Include Page Macro
- Info Macro
- JIRA Chart Macro
- JIRA Issues Macro
- JUnit Report Macro
- Labels List Macro
- Livesearch Macro
- Loremipsum Macro
- Multimedia Macro
- Navigation Map Macro
- Network Macro
- Noformat Macro
- Note Macro
- Office Excel Macro
- Office PowerPoint Macro
- Office Word Macro
- Page Index Macro
- Page Properties Macro
- Page Properties Report Macro
- Page Tree Macro
- Page Tree Search Macro
- Panel Macro
- PDF Macro
- Popular Labels Macro
- Profile Picture Macro
- Recently Updated Dashboard Macro
- Recently Updated Macro
- Recently Used Labels Macro
- Related Labels Macro
- Roadmap Planner Macro
- RSS Feed Macro
- Search Results Macro
- Section Macro
- Space Attachments Macro
- Space Details Macro
- Space Jump Macro
- Spaces List Macro
- Status Macro
- Table of Contents Macro
- Table of Content Zone Macro
- Task Report Macro
- Tip Macro
- User List Macro
- User Profile Macro
- User Status List Macro
- View File Macro
- Warning Macro
- Widget Connector Macro
Creating your own macros

Users with System Administrator permissions can create user macros - see Writing User Macros.
If you want to create something more complex, you can develop your own plugin - see Writing Confluence Plugins.

Getting more macros from The Marketplace

You can find a wide range of Atlassian and third party macros at The Marketplace. These are distributed as add-ons and can be installed by a Confluence Administrator.

Task Report Macro

Use the Task Report macro to display a list of tasks on a page. Filter the tasks by space, page, user, label, created date and more.

See Working with Tasks for more information on creating and assigning tasks. You can also use the Task Report blueprint, which will create a page and add this macro for you.

Using the Task Report macro

To add the Content Report Table macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Speeding up macro entry with autocomplete: Type { and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

Task Report macro showing incomplete tasks, on pages with the label 'meeting-notes'.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Required</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
</table>

Parameters

Parameters are options that you can set to control the content or format of the macro output. Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).
<table>
<thead>
<tr>
<th>Space(s) and Page(s)</th>
<th>No</th>
<th>None</th>
<th>Filter by the task location. The macro will only display tasks in the pages or spaces specified. You can enter a combination of spaces and pages.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Label(s)</td>
<td>No</td>
<td>None</td>
<td>Filter by Label. The macro will only display tasks on pages with this label. You can enter multiple labels, separated by a comma.</td>
</tr>
<tr>
<td>Assigned to</td>
<td>No</td>
<td>None</td>
<td>Filter by Assignee. The macro will only display tasks assigned to the users specified.</td>
</tr>
<tr>
<td>Created by</td>
<td>No</td>
<td>None</td>
<td>Filter by Creator. The macro will only display tasks created by the users specified.</td>
</tr>
<tr>
<td>Created after</td>
<td>No</td>
<td>None</td>
<td>Filter by created date. The macro will only display tasks created on or after the date specified. Date must be entered as <strong>dd-mm-yyyy</strong>.</td>
</tr>
<tr>
<td>Task status</td>
<td>No</td>
<td>None</td>
<td>Show complete, incomplete or all tasks.</td>
</tr>
<tr>
<td>Number of tasks to display</td>
<td>No</td>
<td>20</td>
<td>The number of tasks to display on each page of results in the table. Choose from 10, 20 or 40.</td>
</tr>
<tr>
<td>Display columns</td>
<td>No</td>
<td>description,duedate,assignee,location</td>
<td>Columns to include in the table. Available columns include <code>description</code>, <code>duedate</code>, <code>assignee</code>, <code>location</code>, <code>completedate</code> and <code>labels</code>.</td>
</tr>
<tr>
<td>Sort by</td>
<td>No</td>
<td>Due date</td>
<td>Sort tasks by due date, assignee or page title. Select the Reverse Sort check box to sort the table in reverse order.</td>
</tr>
</tbody>
</table>

**Code examples**

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a Confluence page.

**Macro name:** tasks-report-macro

**Macro body:** None.

**Storage format example**

Note: The `spaceAndPage` multi-picker parameter populates the `spaces` and `pages` parameters.
Wiki markup

Wiki markup is not available for this macro. You cannot add this macro via wiki markup.

Roadmap Planner Macro

Create simple, visual timelines that are useful for planning projects, software releases and much more with the Roadmap macro.

Roadmaps are made up of:

- **bars** to indicate phases of work
- **lanes** to differentiate between teams, products or streams
- **markers** to highlight important dates and milestones
- a **timeline** showing months, defined by the start and end date of the roadmap.

You can provide more information about items on your roadmap by linking a bar to a page.

Adding the Roadmap macro

**To add the Roadmap macro to a page:**

1. In the Confluence editor, choose **Insert > Other Macros**.
2. Find and select the required macro.

**Speeding up macro entry with autocomplete:** Type { and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

**To edit an existing macro:** Click the macro placeholder and choose **Edit**. A macro dialog window will open, where you can edit the parameters of the macro.

Editing your Roadmap

**To edit your roadmap:**

- Select the roadmap and choose **Edit**.
- **Add** lanes, bars and markers.
- Drag bars, bars and markers to the desired location on the roadmap.
- Select lanes, bars and markers to add text, change colours and remove from the roadmap.
- Select bars to add links to existing pages, create new pages or add a description.
- Choose **Timeline options** to set the start and end dates for the roadmap.
**Parameters**

This macro does not use the macro browser to set parameters. You also cannot add this macro via wiki markup or by editing the storage format directly.

**Notes**

The Roadmap macro was previously available as an add-on from The Marketplace. The macro has changed significantly. If you had an older version of the macro installed you will be able to view your existing roadmaps but not edit them.

**Activity Stream Macro**

The Activity Stream macro is a specific instance of the Gadget macro. It inserts an Activity Stream gadget onto your page. For instructions, see Activity Stream Gadget.

**Related pages:**
- Activity Stream Gadget
- Gadget Macro
- Confluence User's Guide

**Anchor Macro**

Allows you to link to a specific part of a page. For more information on using anchors see Working with Anchors.

**Code Examples**

The following examples are provided for advanced users who want to edit the underlying markup for a Confluence page.

**Macro name:** anchor

**Macro body:** None.
Storage format example

```xml
<ac:structured-macro ac:name="anchor">
  <ac:parameter ac:name="">here</ac:parameter>
</ac:structured-macro>
```

Wiki markup example

```
{anchor:here}
```

Attachments Macro

The Attachments macro displays a list of files attached to a page.

It also allows users (with appropriate permissions) to:

- upload a file to the page, directly from the list
- edit attachment properties and labels
- delete an attached file (this deletes all versions of the file)
- preview image attachments
- edit attached Office and PDF documents using the Office Connector.
- download all files attached to the page.

Note: you can use the macro parameters to turn off previews if you have very large attachments.

*Screenshot: The Attachments macro, showing details of an attachment*

Using the Attachments Macro

**To add the Attachments macro to a page:**
1. In the Confluence editor, choose **Insert > Other Macros**.
2. Find and select the required macro.

**Speeding up macro entry with autocomplete:** Type `{` and the beginning of the macro name, to see a list of suggested macros. Details are in **Using Autocomplete**.

**To edit an existing macro:** Click the macro placeholder and choose **Edit**. A macro dialog window will open, where you can edit the parameters of the macro.

### Parameters

Parameters are options that you can set to control the content or format of the macro output. Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (**example**).

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
</table>
| **Filename Patterns**         | all     | A comma-separated list of regular expressions, used to filter the attachments by file name. Note that the parameter values must be regular expressions. For example:
  - To match a file suffix of 'jpg', use `.jpg` (not `*.jpg`).
  - To match file names ending in 'jpg' or 'png', use `*.jpg,.png` |
| **Attachment Labels**         | (none)  | A list of labels, used to filter the attachments to display. If you wish to enter more than one label, separate the labels with commas. Confluence will show only attachments that have all the labels specified. (The match is an AND, not an OR.) For information on labelling the attachments, see **Add, Remove and Search for Labels**. |
| **Include Old Attachment Versions** | false  | A value of `true` will include previous attachment versions in the list. |
| **Sort By**                   | date    | The sort order for attachments. Note that people viewing the page can change the sort order by clicking the column headings. Valid values are:
  - `date` – sorts by updated date in reverse chronological order (newest first)
  - `size` – sorts largest to smallest
  - `name` – sorts alphabetically
  - `created date` - sorts by creation date in reverse chronological order (newest first) |
| **Sort Order**                | ascending | Used in combination with the **Sort By** parameter, to sort the attachments in ascending or descending order. |
| **Allow Upload**              | true    | If selected, the list of attachments will include options allowing users to browse for, and attach, new files. |
| **Page Title**                | (none)  | Used to display attachments from another page. If you do not enter a page title, the macro will display the files attached to the current page. |
| **Show Previews**             | true    | Used to display a preview of the attached file. If true, preview will be visible when the list item is expanded. |

**Code examples**

The following examples are provided for advanced users who want to edit the underlying markup for a
**Confluence page.**

**Macro name:** attachments

**Macro body:** None.

**Storage format example**

```xml
<ac:structured-macro ac:name="attachments">
  <ac:parameter ac:name="old">false</ac:parameter>
  <ac:parameter ac:name="patterns">.*png,.*jpg</ac:parameter>
  <ac:parameter ac:name="sortBy">name</ac:parameter>
  <ac:parameter ac:name="page">
    <ac:link>
      <ri:page ri:content-title="My page about chocolate"/>
    </ac:link>
  </ac:parameter>
  <ac:parameter ac:name="sortOrder">descending</ac:parameter>
  <ac:parameter ac:name="labels">chocolate,cookies</ac:parameter>
  <ac:parameter ac:name="upload">false</ac:parameter>
</ac:structured-macro>
```

**Wiki markup example**

```
{attachments:old=false|patterns=.*png,.*jpg|sortBy=name|page=My page about chocolate|sortorder=descending|labels=chocolate,cookies|upload=false|preview=false}
```

**Blog Posts Macro**

The Blog Posts macro allows you to display blog posts on a Confluence page. Clicking on a title takes you to the blog post.

**Using the Blog Posts Macro**

**To add the Blog Posts macro to a page:**

1. In the Confluence editor, choose **Insert > Other Macros**.
2. Find and select the required macro.

**Speeding up macro entry with autocomplete:** Type `{ and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

**To edit an existing macro:** Click the macro placeholder and choose **Edit**. A macro dialog window will open, where you can edit the parameters of the macro.

**Parameters**

Parameters are options that you can set to control the content or format of the macro output. Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Required</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
</table>

**Created in 2015 by Atlassian. Licensed under a Creative Commons Attribution 2.5 Australia License.**
| Content Type to Display | No | titles | Available values:  
|-------------------------|----|--------|--------------------------|
|                         |    |        | - **titles** — Display only the title of each blog post.  
|                         |    |        | - **excerpts** — Display a short excerpt from each blog post. If the post contains an Excerpt macro, the Blog Posts macro will display the content defined in the Excerpt macro. If the post does not contain an Excerpt macro, the Blog Posts macro will display the first few sentences of the post.  
|                         |    |        | - **entire** - Display the whole content of each blog post.  
| Time Frame | No | no limit | Specify how far back in time Confluence should look for the blog posts to be displayed.  
|            |    |         | Available values:  
|            |    |         | - m — Minutes  
|            |    |         | - h — Hours, so ‘12h’ displays blog posts created in the last twelve hours.  
|            |    |         | - d — Days, so ‘7d’ displays blog posts created in the last seven days.  
|            |    |         | - w — Weeks  
| Restrict to these Labels | No | None | Filter the results by label. The macro will display only the blog posts which are tagged with the label(s) you specify here.  
|                         |    |         | You can specify one or more label values, separated by a comma or a space.  
|                         |    |         | - To exclude content which matches a given label, put a minus sign (-) immediately in front of that label value. For example: If you specify a label value of ‘badpage’ you will get only content which is not labelled with ‘badpage’.  
|                         |    |         | - To indicate that the results **must** match a given label value, put a plus sign (+) immediately in front of that label value. For example: If you specify a label value of ‘superpage’, you will get only content which has at least two labels, being ‘superpage’ and ‘goodpage’.  
| Restrict to these Authors | No | None | Filter the results by author. The macro will display only the blog posts which are written by the author(s) you specify here.  

Created in 2015 by Atlassian. Licensed under a Creative Commons Attribution 2.5 Australia License.
<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Restrict to these Spaces</strong></td>
<td>No</td>
<td>@self, i.e. the space which contains the page on which the macro is coded.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>This parameter allows you to filter content by space. The macro will display only the pages which belong to the space(s) you specify here. You can specify one or more space keys, separated by a comma or a space.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• To exclude content in a specific space, put a minus sign (-) immediately in front of that space key. For example: If you specify a space key of BADSPACE you will get only content which is not in the BADSPACE.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• To indicate that the results must come from a specific space, put a plus sign (+) immediately in front of that space key. For example: If you specify a space key of GOODSPACE you will get only content in GOODSPACE. (Note that this is not particularly useful, because each content item belongs to one space only. If you put a plus sign next to one space key and list other space keys too, the other space keys will be ignored.)</td>
</tr>
<tr>
<td><strong>Special values:</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td>@self</td>
<td></td>
<td>The current space.</td>
</tr>
<tr>
<td>@personal</td>
<td></td>
<td>All personal spaces.</td>
</tr>
<tr>
<td>@global</td>
<td></td>
<td>All site spaces.</td>
</tr>
<tr>
<td>@favorite</td>
<td></td>
<td>The spaces you have marked as favourite.</td>
</tr>
<tr>
<td>@favourite</td>
<td></td>
<td>The same as @favorite above.</td>
</tr>
<tr>
<td>@all</td>
<td></td>
<td>All spaces in your Confluence site.</td>
</tr>
<tr>
<td>*</td>
<td></td>
<td>The same as @all above.</td>
</tr>
<tr>
<td><strong>Maximum Number of Blog Posts</strong></td>
<td>No</td>
<td>15</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Specify the maximum number of results to be displayed. Note that the results are sorted first, and then the maximum parameter is applied.</td>
</tr>
<tr>
<td><strong>Sort By</strong></td>
<td>No</td>
<td>creation</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Specify how the results should be sorted. If this parameter is not specified, the sort order defaults to descending order (newest first) based on the creation date.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Values:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• title — Sort alphabetically by title.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• creation — Sort by the date on which the content was added.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• modified — Sort by the date on which the content was last updated.</td>
</tr>
<tr>
<td><strong>Reverse Sort</strong></td>
<td>No</td>
<td>false</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Select to change the sort from descending to ascending order (oldest first). Use this parameter in conjunction with the Sort By parameter. This parameter is ignored if the Sort By parameter is not specified.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>In storage format and wikimarkup a value of true changes the sort order.</td>
</tr>
</tbody>
</table>

**Code examples**

The following examples are provided for advanced users who want to edit the underlying markup for a Confluence page.

**Macro name:** blog-posts
**Macro body:** None.

**Storage format example**

```xml
<ac:structured-macro ac:name="blog-posts">
  <ac:parameter ac:name="content">titles</ac:parameter>
  <ac:parameter ac:name="spaces">
    <ri:space ri:space-key="ds"/>
  </ac:parameter>
  <ac:parameter ac:name="author">
    <ri:user ri:userkey="12345678912345678912345678912345"/>
  </ac:parameter>
  <ac:parameter ac:name="time">4w</ac:parameter>
  <ac:parameter ac:name="sort">creation</ac:parameter>
  <ac:parameter ac:name="max">10</ac:parameter>
  <ac:parameter ac:name="labels">chocolate,cookies</ac:parameter>
</ac:structured-macro>
```

**Wiki markup example**

```
(blog-posts:content=titles|spaces=@self,ds|author=jsmith|time=4w|reverse=true|sort=creation|max=10|label=chocolate,cookies)
```

**Change-History Macro**

The Change-History macro shows the history of updates made to a page: version number, author, date and comment. It displays the information inline.

**Screenshot: The Change-History macro in Confluence**

<table>
<thead>
<tr>
<th>Version</th>
<th>Date</th>
<th>Comment</th>
</tr>
</thead>
<tbody>
<tr>
<td>Current Version (v. 4)</td>
<td>Feb 19, 2013 16:27</td>
<td>Rach Admin: Formatting change</td>
</tr>
<tr>
<td>v. 3</td>
<td>Feb 19, 2013 16:27</td>
<td>Rach Admin: Added the change history macro</td>
</tr>
<tr>
<td>v. 2</td>
<td>Feb 19, 2013 16:26</td>
<td>Rach Admin: Added a macro</td>
</tr>
<tr>
<td>v. 1</td>
<td>Feb 19, 2013 16:25</td>
<td>Rach Admin</td>
</tr>
</tbody>
</table>

**To add the Change-History macro to a page:**

1. In the Confluence editor, choose **Insert > Other Macros**.
2. Find and select the required macro.

**Speeding up macro entry with autocomplete:** Type `{` and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

**To edit an existing macro:** Click the macro placeholder and choose **Edit**. A macro dialog window will open, where you can edit the parameters of the macro.

**Note:** There are no parameters for this macro.

**Code examples**

The following examples are provided for advanced users who want to edit the underlying markup for a Confluence page.
Macro name: change-history

Macro body: None.

Parameters: None.

Storage format example

```xml
<ac:structured-macro ac:name="change-history"/>
```

Wikimarkup example

```
{change-history}
```

Chart Macro

The Chart macro allows you to display a chart based on tabular data. When you add the macro to a page, you:

- supply the data to be charted by the macro as a table in the placeholder of the macro.
- edit the macro parameters in the Macro Browser to configure the format of the chart.

Screenshot 1: A table of data in the Chart macro placeholder

<table>
<thead>
<tr>
<th>Weeks</th>
<th>Issues Burndown</th>
</tr>
</thead>
<tbody>
<tr>
<td>04/07/2011</td>
<td>81</td>
</tr>
<tr>
<td>11/07/2011</td>
<td>68</td>
</tr>
<tr>
<td>18/07/2011</td>
<td>67</td>
</tr>
<tr>
<td>25/07/2011</td>
<td>66</td>
</tr>
<tr>
<td>01/08/2011</td>
<td>65</td>
</tr>
<tr>
<td>08/08/2011</td>
<td>65</td>
</tr>
<tr>
<td>15/08/2011</td>
<td>64</td>
</tr>
<tr>
<td>22/08/2011</td>
<td>44</td>
</tr>
<tr>
<td>29/08/2011</td>
<td>24</td>
</tr>
<tr>
<td>05/09/2011</td>
<td>0</td>
</tr>
</tbody>
</table>

Screenshot 2: The resulting chart
Using the Chart Macro

To add the Chart macro to a page:

1. Edit the page and use autocomplete to add the Chart macro. (Type '{chart}').
2. Enter your chart data as one or more tables in the body of the macro placeholder. (See the screenshot above.)
3. Click the macro placeholder and choose **Edit**.
4. Select a chart type using the **Type** parameter (see below).
5. Choose other parameter settings in the macro browser, as described below.
6. Click **Refresh** in the 'Preview' area, to check that the chart appears as you expect.
7. Click **Save** to add the chart to your page.
8. Click **Save** again when you are ready to save the page.

**Parameters**

**Chart Type Parameters | Display Control Parameters | Title and Label Parameters | Data Specification Parameters | Colour Parameters | Axis Parameters | Pie Chart Parameters | Attachment Parameters**

**Chart Type Parameters**

These parameters determine the type of chart to display and the way the chart looks.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Type</strong></td>
<td>pie</td>
<td>The type of chart to display. XY charts have numerical x- and y-axes. The x values may optionally be time-based (see the <strong>Time Series</strong> parameter).</td>
</tr>
<tr>
<td><strong>Display Orientation</strong></td>
<td>vertical</td>
<td>Applies to area, bar and line charts.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• <strong>vertical</strong> — y-axis is vertical</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• <strong>horizontal</strong> — x-axis is vertical</td>
</tr>
<tr>
<td><strong>Show in 3D</strong></td>
<td>false</td>
<td>Applies to area, bar and line charts.</td>
</tr>
<tr>
<td><strong>Stacked Values</strong></td>
<td>false</td>
<td>Applies to area and bar charts.</td>
</tr>
<tr>
<td><strong>Show shapes</strong></td>
<td>true</td>
<td>Applies to line charts. Shapes are shown at each data point.</td>
</tr>
<tr>
<td><strong>Opacity</strong></td>
<td></td>
<td>• 75 percent for 3D charts</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• 50 percent for non-stacked area charts</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• 100 percent for all other charts</td>
</tr>
<tr>
<td></td>
<td></td>
<td>A percentage value between 0 (transparent) and 100 (opaque) that determines how opaque the foreground areas and bars are.</td>
</tr>
</tbody>
</table>

**Display Control Parameters**

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Width</strong></td>
<td>300</td>
<td>The width of the chart in pixels.</td>
</tr>
<tr>
<td><strong>Height</strong></td>
<td>300</td>
<td>The height of the chart in pixels.</td>
</tr>
</tbody>
</table>
### Display rendered data

<table>
<thead>
<tr>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>false</td>
<td>Sets whether to display the rendered body of the macro (usually the data tables). By default, the chart data table isn't rendered.</td>
</tr>
<tr>
<td></td>
<td>- <strong>before</strong> — the data are displayed before the chart.</td>
</tr>
<tr>
<td></td>
<td>- <strong>after</strong> — the data are displayed after the chart.</td>
</tr>
</tbody>
</table>

### Image format

<table>
<thead>
<tr>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>png</td>
<td>The image format to be used for the chart.</td>
</tr>
<tr>
<td>jpg</td>
<td></td>
</tr>
</tbody>
</table>

### Title and Label Parameters

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Chart Title</td>
<td>none</td>
<td>The title of the chart.</td>
</tr>
<tr>
<td>Chart Subtitle</td>
<td>none</td>
<td>A subtitle for the chart, using a smaller font than for <strong>Title</strong>.</td>
</tr>
<tr>
<td>Horizontal-axis Label</td>
<td>none</td>
<td>The label for the x-axis (domain).</td>
</tr>
<tr>
<td>Vertical-axis Label</td>
<td>none</td>
<td>The label for the y-axis (range).</td>
</tr>
<tr>
<td>Show Legend</td>
<td>true</td>
<td>Show a legend or key.</td>
</tr>
</tbody>
</table>

### Data Specification Parameters

The data for the chart is taken from tables found when the macro body is rendered. These options control how this data is interpreted. By default, numeric and date values are interpreted according to the Confluence global default language (locale) formats. If conversion fails, other languages defined in Confluence will be tried. Additional conversion options can be specified using the parameters below.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Tables</td>
<td>all first level tables</td>
<td>Comma separated list of table ids and/or table numbers (starting at 1) contained within the body of the macro that will be used as the data for the chart. If data tables are embedded in other tables, then table selection will be required. This occurs when more complex formatting is done (for example using section and column macros).</td>
</tr>
<tr>
<td>Columns</td>
<td>all columns</td>
<td>Comma separated list of column labels and/or column titles and/or column numbers for tables used for chart data. This applies to all tables processed. Columns are enumerated starting at 1. Column label is the text for the column in the header row. Column title is the (html) title attribute for the column in the header row.</td>
</tr>
<tr>
<td>Content Orientation</td>
<td>horizontal</td>
<td>• <strong>vertical</strong> — data table columns will be interpreted as series.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• <strong>horizontal</strong> — data tables rows will be interpreted as series.</td>
</tr>
<tr>
<td>Time Series</td>
<td>false</td>
<td>• true — the x values in an XY plot will be treated as time series data and so will be converted according to date formats.</td>
</tr>
<tr>
<td>Date format</td>
<td>Confluence language defined date formats</td>
<td>For time series data, the date format allows for additional customization of the conversion of data to date values. If a <strong>Date format</strong> is specified, it will be the first format used to interpret date values. Specify a format that matches the time series data. See <strong>simple date format</strong>.</td>
</tr>
<tr>
<td>Time Period</td>
<td>Day</td>
<td>The time period for time series data. Defines the granularity of how the data is interpreted. Valid values are: <strong>Millisecond</strong>, <strong>Second</strong>, <strong>Minute</strong>, <strong>Hour</strong>, <strong>Day</strong>, <strong>Week</strong>, <strong>Month</strong>, <strong>Quarter</strong>, <strong>Year</strong>.</td>
</tr>
<tr>
<td>Parameter</td>
<td>Default</td>
<td>Description</td>
</tr>
<tr>
<td>--------------</td>
<td>---------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Language</td>
<td>none</td>
<td>Use in combination with the Country parameter to form a locale. These additional number and date formats will be used for data conversion before the default languages. Valid values are 2 character ISO 639-1 alpha-2 codes.</td>
</tr>
<tr>
<td>Country</td>
<td>none</td>
<td>Use in combination with the Language parameter to form a locale. Valid values are 2 character ISO 3166 codes.</td>
</tr>
</tbody>
</table>
| Forgive      | true    | • true — the macro tries to convert numeric and date values that do not totally match any of the default or user-specified formats.  
• false — enforce strict data format. Data format errors will cause the chart to not be produced. |

Usage of language and country parameters together:

```markdown
Language

Country
```

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Background Colour</td>
<td>White</td>
<td>Background of the chart.</td>
</tr>
<tr>
<td>Border Colour</td>
<td>no border</td>
<td>Border around the chart.</td>
</tr>
<tr>
<td>Colours</td>
<td>Comma-separated list of colours used to customise category, sections, and series colours.</td>
<td></td>
</tr>
</tbody>
</table>

**Colour Parameters**

Colours are specified using hexadecimal notation or HTML colour names.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Parameter</td>
<td>Default</td>
<td>Description</td>
</tr>
<tr>
<td>Range Minimum Value</td>
<td>none</td>
<td>Range axis lower bound.</td>
</tr>
<tr>
<td>Range Maximum Value</td>
<td>none</td>
<td>Range axis upper bound.</td>
</tr>
<tr>
<td>Range Axis Tick Unit</td>
<td>none</td>
<td>Range axis units between axis tick marks.</td>
</tr>
<tr>
<td>Range Axis Label Angle</td>
<td>none</td>
<td>Angle for the range axis label in degrees.</td>
</tr>
<tr>
<td>Domain Axis Lower Bound</td>
<td>none</td>
<td>Only applies to XY plots. Domain axis lower bound. For a date axis, this value must be expressed in the date format specified by the Date format parameter.</td>
</tr>
<tr>
<td>Domain Axis Upper Bound</td>
<td>none</td>
<td>Only applies to XY plots. Domain axis upper bound. For a date axis, this value must be expressed in the date format specified by the Date format parameter.</td>
</tr>
<tr>
<td>Parameter</td>
<td>Default</td>
<td>Description</td>
</tr>
<tr>
<td>-----------</td>
<td>---------</td>
<td>-------------</td>
</tr>
<tr>
<td><strong>Domain Axis Tick Unit</strong></td>
<td>none</td>
<td>Only applies to XY plots. Domain axis units between axis tick marks. For a date axis, this value represents a count of the units specified in the Time Period parameter. The Time Period unit can be overridden by specifying a trailing character: y (years), M (months), d (days), h (hours), m (minutes), s (seconds), u (milliseconds).</td>
</tr>
<tr>
<td><strong>Domain Axis Label Angle</strong></td>
<td>none</td>
<td>Only applies to XY plots. The angle for the domain axis label, in degrees.</td>
</tr>
<tr>
<td><strong>Category Label Position</strong></td>
<td>none</td>
<td>Placement of the axis label text for categories.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• up45 — 45 degrees going upward</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• up90 — 90 degrees going upward</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• down45 — 45 degrees going downward</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• down90 — 90 degrees going downward</td>
</tr>
<tr>
<td><strong>Date Tick Mark Position</strong></td>
<td>start</td>
<td>Placement of the date tick mark.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• start — tick mark is at the start of the date period.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• middle — tick mark is in the middle of the date period.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• end — tick mark is at the end of the date period.</td>
</tr>
</tbody>
</table>

### Pie Chart Parameters

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Pie Section Label</strong></td>
<td>Show only the pie section key value</td>
<td>Format for how pie section labels are displayed. The format uses a string with special replacement variables:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• %0% is replaced by the pie section key.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• %1% is replaced by the pie section numeric value.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• %2% is replaced by the pie section percent value.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Example 1: &quot;%0% = %1%&quot; would display something like &quot;Independent = 20&quot;</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Example 2: &quot;%0% (%2%)&quot; would display something like &quot;Independent (20%)&quot;</td>
</tr>
<tr>
<td><strong>Pie Section Explode</strong></td>
<td>No exploded sections</td>
<td>Comma separated list of pie keys that are to be shown exploded. Note: requires jFreeChart version 1.0.3 or higher.</td>
</tr>
</tbody>
</table>

### Attachment Parameters

These are advanced options that can be used for chart versioning, to enable automation and to improve performance. Use these options carefully! Normally, the chart image is regenerated each time the page is displayed. These options allow for the generated image to be saved as an attachment and have subsequent access re-use the attachment. This can be useful especially when combined with the Cache Plugin to improve performance. Depending on the options chosen, chart images can be versioned for historical purposes.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Attachment</strong></td>
<td>none</td>
<td>The name and location with which the chart image will be saved as an attachment. The user must be authorised to add attachments to the page specified.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• ^attachmentName.png — the chart is saved as an attachment to the current page.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• page^attachmentName.png — the chart is saved as an attachment to the page name provided.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• space:page^attachmentName.png — the chart is saved as an attachment to the page name provided in the space indicated.</td>
</tr>
<tr>
<td>Attachment Version</td>
<td>new</td>
<td>Defines the the versioning mechanism for saved charts.</td>
</tr>
<tr>
<td>---------------------</td>
<td>-----</td>
<td>-------------------------------------------------------</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• new — creates new version of the attachment.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• replace — replaces all previous versions of the chart. To replace an existing attachment, the user must be authorized to remove attachments for the page specified.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• keep — only saves a new attachment if an existing export of the same name does not exist. An existing attachment will not be changed or updated.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Attachment Comment</th>
<th>none</th>
<th>Comment used for a saved chart attachment.</th>
</tr>
</thead>
</table>

| Thumbnail | false | • true — the chart image attachment will be shown as a thumbnail. |

### Chart Type Parameters | Display Control Parameters | Title and Label Parameters | Data Specification Parameters | Colour Parameters | Axis Parameters | Pie Chart Parameters | Attachment Parameters

**Examples**

**Pie Chart**

<table>
<thead>
<tr>
<th>Parameters in Macro Browser</th>
<th>Data Table in Macro Placeholder</th>
<th>Rendered Chart</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Type</strong></td>
<td>pie</td>
<td></td>
</tr>
<tr>
<td><strong>Chart Title</strong></td>
<td>Fish Sold 2011</td>
<td></td>
</tr>
<tr>
<td><strong>Show Legend</strong></td>
<td>true</td>
<td></td>
</tr>
<tr>
<td><strong>Content Orientation</strong></td>
<td>vertical</td>
<td></td>
</tr>
<tr>
<td><strong>Fish Type</strong></td>
<td>2011</td>
<td></td>
</tr>
<tr>
<td>Herring</td>
<td>9,500</td>
<td></td>
</tr>
<tr>
<td>Salmon</td>
<td>2,900</td>
<td></td>
</tr>
<tr>
<td>Tuna</td>
<td>1,500</td>
<td></td>
</tr>
</tbody>
</table>

**Fish Sold 2011**

- Herring (9,500 – 68%)
- Salmon (2,900 – 21%)
- Tuna (1,500 – 11%)

**Bar Chart**

<table>
<thead>
<tr>
<th>Parameters in Macro Browser</th>
<th>Data Table in Macro Placeholder</th>
<th>Rendered Chart</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Type</strong></td>
<td>bar</td>
<td></td>
</tr>
<tr>
<td><strong>Chart Title</strong></td>
<td>Fish Sold</td>
<td></td>
</tr>
<tr>
<td><strong>Show Legend</strong></td>
<td>true</td>
<td></td>
</tr>
<tr>
<td><strong>Fish Type</strong></td>
<td>2010</td>
<td></td>
</tr>
<tr>
<td>Herring</td>
<td>9,500</td>
<td></td>
</tr>
<tr>
<td>Salmon</td>
<td>2,900</td>
<td></td>
</tr>
<tr>
<td>Tuna</td>
<td>1,500</td>
<td></td>
</tr>
<tr>
<td><strong>Fish Type</strong></td>
<td>2011</td>
<td></td>
</tr>
<tr>
<td>Herring</td>
<td>8,300</td>
<td></td>
</tr>
<tr>
<td>Salmon</td>
<td>4,200</td>
<td></td>
</tr>
<tr>
<td>Tuna</td>
<td>1,500</td>
<td></td>
</tr>
</tbody>
</table>
### 3D Bar Chart

<table>
<thead>
<tr>
<th>Parameters in Macro Browser</th>
<th>Data Table in Macro Placeholder</th>
<th>Rendered Chart</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Type</strong></td>
<td><strong>2009 2010 2011</strong></td>
<td></td>
</tr>
<tr>
<td>Show in 3D</td>
<td>Revenue: 12.4 31.8 41.1</td>
<td></td>
</tr>
<tr>
<td>Opacity</td>
<td>Expense: 43.6 41.8 31.1</td>
<td></td>
</tr>
<tr>
<td>Show Legend</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

### Time Series Chart

<table>
<thead>
<tr>
<th>Parameters in Macro Browser</th>
<th>Data Tables in Macro Placeholder</th>
<th>Rendered Chart</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Type</strong></td>
<td><strong>Month Revenue</strong></td>
<td></td>
</tr>
<tr>
<td><strong>Date Format</strong></td>
<td>1/2011 31.8</td>
<td></td>
</tr>
<tr>
<td><strong>Time Period</strong></td>
<td>2/2011 41.8</td>
<td></td>
</tr>
<tr>
<td><strong>Content Orientation</strong></td>
<td>3/2011 51.3</td>
<td></td>
</tr>
<tr>
<td><strong>Month Expenses</strong></td>
<td>4/2011 33.8</td>
<td></td>
</tr>
</tbody>
</table>
XY Line Chart

**Parameters in Macro Browser**
- Type: xyLine
- Show Legend: true

**Data Table in Macro Placeholder**

<table>
<thead>
<tr>
<th>Date</th>
<th>Revenue</th>
<th>Expense</th>
</tr>
</thead>
<tbody>
<tr>
<td>5/2011</td>
<td>27.6</td>
<td></td>
</tr>
<tr>
<td>6/2011</td>
<td>49.8</td>
<td></td>
</tr>
<tr>
<td>7/2011</td>
<td>51.8</td>
<td></td>
</tr>
<tr>
<td>8/2011</td>
<td>77.3</td>
<td></td>
</tr>
<tr>
<td>9/2011</td>
<td>73.8</td>
<td></td>
</tr>
<tr>
<td>10/2011</td>
<td>97.6</td>
<td></td>
</tr>
<tr>
<td>11/2011</td>
<td>101.2</td>
<td></td>
</tr>
<tr>
<td>12/2011</td>
<td>113.7</td>
<td></td>
</tr>
</tbody>
</table>

**Rendered Chart**

XY Area Chart

**Parameters in Macro Browser**
- Type: xyArea
- Show Legend: true

**Data Table in Macro Placeholder**

<table>
<thead>
<tr>
<th>Date</th>
<th>Revenue</th>
<th>Expense</th>
</tr>
</thead>
<tbody>
<tr>
<td>5/2011</td>
<td>44.6</td>
<td></td>
</tr>
<tr>
<td>6/2011</td>
<td>43.8</td>
<td></td>
</tr>
<tr>
<td>7/2011</td>
<td>51.8</td>
<td></td>
</tr>
<tr>
<td>8/2011</td>
<td>52.3</td>
<td></td>
</tr>
<tr>
<td>9/2011</td>
<td>53.8</td>
<td></td>
</tr>
<tr>
<td>10/2011</td>
<td>55.6</td>
<td></td>
</tr>
<tr>
<td>11/2011</td>
<td>61.2</td>
<td></td>
</tr>
<tr>
<td>12/2011</td>
<td>63.7</td>
<td></td>
</tr>
</tbody>
</table>

**Rendered Chart**
### Area Charts

**Example 1**

<table>
<thead>
<tr>
<th>Parameters in Macro Browser</th>
<th>Data Table in Macro Placeholder</th>
<th>Rendered Chart</th>
</tr>
</thead>
<tbody>
<tr>
<td>Type</td>
<td>area</td>
<td></td>
</tr>
<tr>
<td>Show Legend</td>
<td>true</td>
<td></td>
</tr>
<tr>
<td>Width</td>
<td>300</td>
<td></td>
</tr>
<tr>
<td>Height</td>
<td>300</td>
<td></td>
</tr>
<tr>
<td>Opacity</td>
<td>50</td>
<td></td>
</tr>
<tr>
<td>Satisfaction</td>
<td>2009</td>
<td>2010</td>
</tr>
<tr>
<td>Very satisfied</td>
<td>20</td>
<td>23</td>
</tr>
<tr>
<td>Satisfied</td>
<td>40</td>
<td>34</td>
</tr>
<tr>
<td>Dissatisfied</td>
<td>25</td>
<td>26</td>
</tr>
<tr>
<td>Very dissatisfied</td>
<td>15</td>
<td>17</td>
</tr>
</tbody>
</table>

**Example 2**

<table>
<thead>
<tr>
<th>Parameters in Macro Browser</th>
<th>Data Table in Macro Placeholder</th>
<th>Rendered Chart</th>
</tr>
</thead>
<tbody>
<tr>
<td>Type</td>
<td>area</td>
<td></td>
</tr>
<tr>
<td>Show Legend</td>
<td>true</td>
<td></td>
</tr>
<tr>
<td>Width</td>
<td>300</td>
<td></td>
</tr>
<tr>
<td>Height</td>
<td>300</td>
<td></td>
</tr>
<tr>
<td>Satisfaction</td>
<td>2009</td>
<td>2010</td>
</tr>
<tr>
<td>Very satisfied</td>
<td>12</td>
<td>23</td>
</tr>
<tr>
<td>Satisfied</td>
<td>1</td>
<td>34</td>
</tr>
</tbody>
</table>
### Parameters in Macro Browser

<table>
<thead>
<tr>
<th>Type</th>
<th>gantt</th>
</tr>
</thead>
<tbody>
<tr>
<td>Width</td>
<td>300</td>
</tr>
<tr>
<td>Height</td>
<td>200</td>
</tr>
<tr>
<td>Columns</td>
<td>,1,2,3,4</td>
</tr>
<tr>
<td>Date format</td>
<td>MM/dd/yyyy</td>
</tr>
</tbody>
</table>

### Data Table in Macro Placeholder

<table>
<thead>
<tr>
<th>Plan</th>
<th>Start</th>
<th>End</th>
<th>Status</th>
</tr>
</thead>
<tbody>
<tr>
<td>Stage 1</td>
<td>6/25/2013</td>
<td>7/10/2013</td>
<td>30%</td>
</tr>
<tr>
<td>Stage 2</td>
<td>7/13/2013</td>
<td>11/28/2013</td>
<td>40%</td>
</tr>
<tr>
<td>Stage 3</td>
<td>12/1/2013</td>
<td>12/25/2013</td>
<td></td>
</tr>
</tbody>
</table>

### Rendered Chart

- Very satisfied
- Satisfied
- Dissatisfied
- Very dissatisfied

---

**Code examples**

The following examples are provided for advanced users who want to edit the underlying markup for a Confluence page.

**Macro name:** chart

**Macro body:** Accepts rich text, consisting of tables that hold the chart's data.

This macro recognises a large number of parameters, listed here by type for convenience.

- See all parameters...
Chart type parameters

These parameters determine the type of chart to display and how the chart looks.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Required</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
</table>
| **type**  | No       | pie     | The type of chart to display. XY charts have numerical x- and y-axes. The x values may optionally be time-based. See the `timeSeries` parameter. Available values:  
  - *Standard charts* – pie, bar, line, area  
  - *XY plots* – xyArea, xyBar, xyLine, xyStep, xyStepArea, scatter, timeSeries  
  - *Other charts* – gantt |
| **orientation** | No | vertical | The display orientation. Applies to area, bar and line charts. Available values:  
  - vertical – y-axis is vertical  
  - horizontal – x-axis is vertical |
| **3D** | No | false | Show in three dimensions. Applies to area, bar and line charts. |
| **stacked** | No | false | Stacked values. Applies to area and bar charts. |
| **showShapes** | No | true | Applies to line charts. Shapes are shown at each data point. |
| **opacity** | No | • 75 percent for 3D charts  
  • 50 percent for non-stacked area charts  
  • 100 percent for all other charts | A percentage value between 0 (transparent) and 100 (opaque) that determines how opaque the foreground areas and bars are. |

Chart display parameters

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Required</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>width</strong></td>
<td>No</td>
<td>300</td>
<td>The width of the chart in pixels.</td>
</tr>
<tr>
<td><strong>height</strong></td>
<td>No</td>
<td>300</td>
<td>The height of the chart in pixels.</td>
</tr>
</tbody>
</table>
| **dataDisplay** | No | false | Determines whether to display the body of the macro, consisting of the data table. By default, the chart data table is not displayed. Available values:  
  - false – the data is not displayed.  
  - true or after – the data is displayed after the chart.  
  - before – the data is displayed before the chart. |
<table>
<thead>
<tr>
<th>Parameter</th>
<th>Required</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>imageFormat</td>
<td>No</td>
<td>png</td>
<td>The image format to be used for the chart. Available values: * png * jpg</td>
</tr>
</tbody>
</table>

### Chart title and label parameters

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Required</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>title</td>
<td>No</td>
<td>(None)</td>
<td>The title of the chart.</td>
</tr>
<tr>
<td>subTitle</td>
<td>No</td>
<td>(None)</td>
<td>A subtitle for the chart.</td>
</tr>
<tr>
<td>xLabel</td>
<td>No</td>
<td>(None)</td>
<td>The label for the x-axis (domain).</td>
</tr>
<tr>
<td>yLabel</td>
<td>No</td>
<td>(None)</td>
<td>The label for the y-axis (range).</td>
</tr>
<tr>
<td>legend</td>
<td>No</td>
<td>false</td>
<td>Determines whether to show a legend (key) for the chart.</td>
</tr>
</tbody>
</table>

### Chart data parameters

The data for the chart is taken from tables found in the macro body. The parameters below control how this data is interpreted. By default, numeric and date values are interpreted according to the Confluence global default language (locale) formats. If conversion fails, other languages defined in Confluence will be tried. You can specify additional conversion options using the parameters below.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Required</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>tables</td>
<td>No</td>
<td>All first level tables</td>
<td>You can supply a comma-separated list of table IDs and/or table numbers (starting at 1) contained within the body of the macro that will be used as the data for the chart. If data tables are embedded in other tables, then table selection will be required. This occurs when more complex formatting is done (for example using section and column macros).</td>
</tr>
<tr>
<td>columns</td>
<td>No</td>
<td>All columns</td>
<td>You can supply a comma-separated list of column labels and/or column titles and/or column numbers for tables used for chart data. This applies to all tables processed. Columns are enumerated starting at 1. Column label is the text for the column in the header row. Column title is the HTML title attribute for the column in the header row.</td>
</tr>
<tr>
<td>dataOrientation</td>
<td>No</td>
<td>horizontal</td>
<td>The content orientation. By default, the data tables will be interpreted as columns (horizontally) representing domain and x values. Available values: * vertical – data table columns will be interpreted as series. * horizontal – data tables rows will be interpreted as series.</td>
</tr>
<tr>
<td>timeSeries</td>
<td>No</td>
<td>false</td>
<td>If 'true', the x values in an XY plot will be treated as time series data and so will be converted according date formats.</td>
</tr>
</tbody>
</table>
### DateFormat

- **Parameter**: `dateFormat`
- **Required**: No
- **Default**: Confluence language defined date formats
- **Description**: For time series data, the date format allows for additional customisation of the conversion of data to date values. If a `dateFormat` is specified, it will be the first format used to interpret date values. Specify a format that matches the time series data. See simple date format.

### Time Period

- **Parameter**: `timePeriod`
- **Required**: No
- **Default**: day
- **Description**: The time period for time series data. Defines the granularity of how the data is interpreted.

**Available values**: millisecond, second, minute, hour, day, week, month, quarter, year

### Language

- **Parameter**: `language`
- **Required**: No
- **Default**: (None)
- **Description**: Use in combination with the `country` parameter to form a locale. These additional number and date formats will be used for data conversion before the default languages.

**Available values** are the two-character ISO 639-1 alpha-2 codes.

### Country

- **Parameter**: `country`
- **Required**: No
- **Default**: (None)
- **Description**: Use in combination with the `language` parameter to form a locale. Valid values are the two-character ISO 3166 codes.

### Forgive

- **Parameter**: `forgive`
- **Required**: No
- **Default**: true
- **Description**: Determines whether the macro will forgive (allow) some data formatting errors.

**Available values**:
- `true` — the macro tries to convert numeric and date values that do not totally match any of the default or user-specified formats.
- `false` — the macro enforces strict data formatting. If there are data format errors, the chart will not be produced.

### Chart Colour Parameters

Colours are specified using hexadecimal notation or HTML colour names.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Required</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>bgColor</td>
<td>No</td>
<td>White</td>
<td>Background colour of the chart.</td>
</tr>
<tr>
<td>borderColor</td>
<td>No</td>
<td>No border</td>
<td>Colour of the border around the chart.</td>
</tr>
<tr>
<td>colors</td>
<td>No</td>
<td></td>
<td>A comma-separated list of colours used to customise the colours of categories, sections, and series.</td>
</tr>
</tbody>
</table>

### Chart Axis Parameters

Depending on the chart type, the range and domain axis may be customised. These values are automatically generated based on the data but can be overridden by specifying one or more more of these parameters.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Required</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>rangeAxisLowerBound</td>
<td>No</td>
<td>(None)</td>
<td>Minimum value for the range axis.</td>
</tr>
<tr>
<td>rangeAxisUpperBound</td>
<td>No</td>
<td>(None)</td>
<td>Maximum value for the range axis.</td>
</tr>
<tr>
<td>rangeAxisTickUnit</td>
<td>No</td>
<td>(None)</td>
<td>Range axis units between axis tick marks.</td>
</tr>
<tr>
<td>Parameter</td>
<td>Required</td>
<td>Default</td>
<td>Description</td>
</tr>
<tr>
<td>-------------------------</td>
<td>----------</td>
<td>---------</td>
<td>-------------</td>
</tr>
<tr>
<td>rangeAxisLabelAngle</td>
<td>No</td>
<td>(None)</td>
<td>Angle for the range axis label in degrees.</td>
</tr>
<tr>
<td>domainAxisLowerBound</td>
<td>No</td>
<td>(None)</td>
<td>Only applies to XY plots. Domain axis lower bound. For a date axis, this value must be expressed in the date format specified by the <code>dateFormat</code> parameter.</td>
</tr>
<tr>
<td>domainAxisUpperBound</td>
<td>No</td>
<td>(None)</td>
<td>Only applies to XY plots. Domain axis upper bound. For a date axis, this value must be expressed in the date format specified by the <code>dateFormat</code> parameter.</td>
</tr>
<tr>
<td>domainAxisTickUnit</td>
<td>No</td>
<td>(None)</td>
<td>Only applies to XY plots. Domain axis units between axis tick marks. For a date axis, this value represents a count of the units specified in the <code>timePeriod</code> parameter. The <code>timePeriod</code> unit can be overridden by specifying a trailing character: y (years), M (months), d (days), h (hours), m (minutes), s (seconds), u (milliseconds).</td>
</tr>
<tr>
<td>domainAxisLabelAngle</td>
<td>No</td>
<td>(None)</td>
<td>Only applies to XY plots. The angle for the domain axis label, in degrees.</td>
</tr>
<tr>
<td>categoryLabelPosition</td>
<td>No</td>
<td>(None)</td>
<td>Placement of the axis label text for categories. Available values: • up45 — 45 degrees going upward • up90 — 90 degrees going upward • down45 — 45 degrees going downward • down90 — 90 degrees going downward</td>
</tr>
<tr>
<td>dateTickMarkPosition</td>
<td>No</td>
<td><code>start</code></td>
<td>Placement of the date tick mark. Available values: • <code>start</code> — tick mark is at the start of the date period. • <code>middle</code> — tick mark is in the middle of the date period. • <code>end</code> — tick mark is at the end of the date period.</td>
</tr>
<tr>
<td>Parameter</td>
<td>Required</td>
<td>Default</td>
<td>Description</td>
</tr>
<tr>
<td>----------------------</td>
<td>----------</td>
<td>---------</td>
<td>--------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>pieSectionLabel</td>
<td>No</td>
<td></td>
<td>Show only the pie section key value. Format of pie section labels. The format uses a string with special replacement variables:  \n  * %0% is replaced by the pie section key.  \n  * %1% is replaced by the pie section numeric value.  \n  * %2% is replaced by the pie section percent value.  \n  Example 1: To display something like 'Independent = 20':  \n  %0% = %1%  \n  Example 2: To display something like 'Independent (20%)':  \n  %0% (%2%)</td>
</tr>
<tr>
<td>pieSectionExplode</td>
<td>No</td>
<td></td>
<td>No exploded sections. A comma-separated list of pie keys that are to be shown exploded. Note: requires jFreeChart version 1.0.3 or higher.</td>
</tr>
<tr>
<td>attachment</td>
<td>No</td>
<td>(None)</td>
<td>The name and location where the chart image will be saved as an attachment. The user must be authorised to add attachments to the page specified. \n  Available syntax for this parameter:  \n  * ^attachmentName.png — the chart is saved as an attachment to the current page.  \n  * page name^attachmentName.png — the chart is saved as an attachment to the page name provided.  \n  * spacekey:page name^attachmentName.png — the chart is saved as an attachment to the page name provided in the space indicated.</td>
</tr>
</tbody>
</table>
| attachmentVersion | No | new | Defines the versioning mechanism for saved charts. Available values:
|                  |    |     | • new — creates new version of the attachment.
|                  |    |     | • replace — replaces all previous versions of the chart.
|                  |    |     |   To replace an existing attachment, the user must be authorised to remove attachments for the page specified.
|                  |    |     | • keep — only saves a new attachment if an existing export of the same name does not exist. An existing attachment will not be changed or updated. |
| attachmentComment | No | (None) | Comment used for a saved chart attachment. |
| thumbnail        | No | false | If true, the chart image attachment will be shown as a thumbnail (small, expandable) image. |

**Storage format example**

Below is a simple example of a pie chart. See more examples in Storage Format Examples for Chart Macro.
Wiki markup example

Below is a simple example of a pie chart. See more examples in Wiki Markup Examples for Chart Macro.
Confluence Storage Format Examples for Chart Macro

This page is an extension of the documentation for the Chart Macro. This page contains additional examples for the Chart macro.

**Pie chart**

Here is a simple example of a pie chart.

Storage format
<ac:structured-macro ac:name="chart">
<ac:parameter ac:name="title">Fish Sold</ac:parameter>
<ac:parameter ac:name="type">pie</ac:parameter>
<ac:rich-text-body>
<table>
<tbody>
<tr>
<th>Fish Type</th>
<th>2004</th>
<th>2005</th>
</tr>
<tr>
<th>Herring</th>
<td>9,500</td>
<td>8,300</td>
</tr>
<tr>
<th>Salmon</th>
<td>2,900</td>
<td>4,200</td>
</tr>
<tr>
<th>Tuna</th>
<td>1,500</td>
<td>1,500</td>
</tr>
</tbody>
</table>
</ac:rich-text-body>
</ac:structured-macro>

Resulting chart
**Fish Sold**

![Bar chart](chart.png)

Here is a simple example of a bar chart.

**Storage format**
<ac:macro ac:name="chart">
  <ac:parameter ac:name="title">Fish Sold</ac:parameter>
  <ac:parameter ac:name="type">bar</ac:parameter>
  <ac:rich-text-body>
    <table>
      <tbody>
        <tr>
          <th>Fish Type</th>
          <th>2004</th>
          <th>2005</th>
        </tr>
        <tr>
          <td>Herring</td>
          <td>9,500</td>
          <td>8,300</td>
        </tr>
        <tr>
          <td>Salmon</td>
          <td>2,900</td>
          <td>4,200</td>
        </tr>
        <tr>
          <td>Tuna</td>
          <td>1,500</td>
          <td>1,500</td>
        </tr>
      </tbody>
    </table>
  </ac:rich-text-body>
</ac:macro>

Resulting chart
**Time series chart**

Here is an example of a time series chart.

**Storage format**

```xml
<ac:structured-macro ac:name="chart">
  <ac:parameter ac:name="timePeriod">Month</ac:parameter>
  <ac:parameter ac:name="dataOrientation">vertical</ac:parameter>
  <ac:parameter ac:name="rangeAxisLowerBound">0</ac:parameter>
  <ac:parameter ac:name="dateFormat">MM/yyyy</ac:parameter>
  <ac:parameter ac:name="type">timeSeries</ac:parameter>
  <ac:parameter ac:name="domainaxisrotateticklabel">true</ac:parameter>
  <ac:rich-text-body>
    <table>
      <tbody>
        <tr>
          <th>Month</th>
          <th>Revenue</th>
        </tr>
        <tr>
          <td>1/2005</td>
          <td>31.8</td>
        </tr>
        <tr>
          <td>2/2005</td>
          <td>41.8</td>
        </tr>
        <tr>
          <td>3/2005</td>
        </tr>
      </tbody>
    </table>
  </ac:rich-text-body>
</ac:structured-macro>
```
<table>
<thead>
<tr>
<th>Date</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>4/2005</td>
<td>33.8</td>
</tr>
<tr>
<td>5/2005</td>
<td>27.6</td>
</tr>
<tr>
<td>6/2005</td>
<td>49.8</td>
</tr>
<tr>
<td>7/2005</td>
<td>51.8</td>
</tr>
<tr>
<td>8/2005</td>
<td>77.3</td>
</tr>
<tr>
<td>9/2005</td>
<td>73.8</td>
</tr>
<tr>
<td>10/2005</td>
<td>97.6</td>
</tr>
<tr>
<td>Month</td>
<td>Expenses</td>
</tr>
<tr>
<td>------------</td>
<td>----------</td>
</tr>
<tr>
<td>1/2005</td>
<td>41.1</td>
</tr>
<tr>
<td>2/2005</td>
<td>43.8</td>
</tr>
<tr>
<td>3/2005</td>
<td>45.3</td>
</tr>
<tr>
<td>4/2005</td>
<td>45.0</td>
</tr>
<tr>
<td>5/2005</td>
<td></td>
</tr>
<tr>
<td>Month</td>
<td>Year</td>
</tr>
<tr>
<td>-------</td>
<td>------</td>
</tr>
<tr>
<td>4/2005</td>
<td>44.6</td>
</tr>
<tr>
<td>6/2005</td>
<td>43.8</td>
</tr>
<tr>
<td>7/2005</td>
<td>51.8</td>
</tr>
<tr>
<td>8/2005</td>
<td>52.3</td>
</tr>
<tr>
<td>9/2005</td>
<td>53.8</td>
</tr>
<tr>
<td>10/2005</td>
<td>55.6</td>
</tr>
<tr>
<td>11/2005</td>
<td>61.2</td>
</tr>
<tr>
<td>12/2005</td>
<td>63.7</td>
</tr>
</tbody>
</table>
Resulting chart

![XY line chart](image)

**XY line chart**

Here is an example of an XY line chart.

Storage format
Resulting chart
**XY bar chart**

Here is an example of an XY bar chart.
Resulting chart
**XY area chart**

Here is an example of an XY area chart.

**Storage format**
<ac:structured-macro ac:name="chart">
  <ac:parameter ac:name="type">xyarea</ac:parameter>
  <ac:rich-text-body>
    <table>
      <tbody>
        <tr>
          <th></th>
          <th>12</th>
          <th>14</th>
          <th>23</th>
        </tr>
        <tr>
          <td>Revenue</td>
          <td>41.1</td>
          <td>31.8</td>
          <td>12.4</td>
        </tr>
        <tr>
          <td>Expense</td>
          <td>31.1</td>
          <td>41.8</td>
          <td>43.6</td>
        </tr>
      </tbody>
    </table>
  </ac:rich-text-body>
</ac:structured-macro>

Resulting chart
Area chart

Here are two examples of area charts.

Storage format for area chart 1

```xml
<ac:structured-macro ac:name="chart">
  <ac:parameter ac:name="height">300</ac:parameter>
  <ac:parameter ac:name="legend">true</ac:parameter>
  <ac:parameter ac:name="width">300</ac:parameter>
  <ac:parameter ac:name="opacity">50</ac:parameter>
  <ac:parameter ac:name="type">area</ac:parameter>
  <ac:parameter ac:name="dataDisplay">true</ac:parameter>
  <ac:rich-text-body>
    <table>
      <tbody>
        <tr>
          <th>Satisfaction</th>
          <th>2002</th>
          <th>2003</th>
          <th>2004</th>
        </tr>
        <tr>
          <td>Very satisfied</td>
          <td>20</td>
          <td>23</td>
          <td>34</td>
        </tr>
      </tbody>
    </table>
  </ac:rich-text-body>
</ac:structured-macro>
```
<table>
<thead>
<tr>
<th></th>
<th>Satisfied</th>
<th>Disatisfied</th>
<th>Very dissatisfied</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>40</td>
<td>25</td>
<td>15</td>
</tr>
<tr>
<td></td>
<td>34</td>
<td>26</td>
<td>17</td>
</tr>
<tr>
<td></td>
<td>23</td>
<td>25</td>
<td>18</td>
</tr>
</tbody>
</table>
Resulting area chart 1

<table>
<thead>
<tr>
<th>Satisfaction</th>
<th>2002</th>
<th>2003</th>
<th>2004</th>
</tr>
</thead>
<tbody>
<tr>
<td>Very satisfied</td>
<td>20</td>
<td>23</td>
<td>34</td>
</tr>
<tr>
<td>Satisfied</td>
<td>40</td>
<td>34</td>
<td>23</td>
</tr>
<tr>
<td>Dissatisfied</td>
<td>25</td>
<td>26</td>
<td>25</td>
</tr>
<tr>
<td>Very dissatisfied</td>
<td>15</td>
<td>17</td>
<td>18</td>
</tr>
</tbody>
</table>

Storage format for area chart 2

```xml
<ac:structured-macro ac:name="chart">
    <ac:parameter ac:name="stacked">true</ac:parameter>
    <ac:parameter ac:name="height">300</ac:parameter>
    <ac:parameter ac:name="legend">true</ac:parameter>
    <ac:parameter ac:name="width">300</ac:parameter>
    <ac:parameter ac:name="type">area</ac:parameter>
    <ac:parameter ac:name="dataDisplay">true</ac:parameter>
    <ac:rich-text-body>
        <table>
            <thead>
                <th>Satisfaction</th>
                <th>2002</th>
                <th>2003</th>
                <th>2004</th>
            </thead>
            <tbody>
                <tr>
                    <td>Very satisfied</td>
                    <td>20</td>
                    <td>23</td>
                    <td>34</td>
                </tr>
                <tr>
                    <td>Satisfied</td>
                    <td>40</td>
                    <td>34</td>
                    <td>23</td>
                </tr>
                <tr>
                    <td>Dissatisfied</td>
                    <td>25</td>
                    <td>26</td>
                    <td>25</td>
                </tr>
                <tr>
                    <td>Very dissatisfied</td>
                    <td>15</td>
                    <td>17</td>
                    <td>18</td>
                </tr>
            </tbody>
        </table>
    </ac:rich-text-body>
</ac:structured-macro>
```
<table>
<thead>
<tr>
<th>Rating</th>
<th>Count</th>
<th>Count</th>
<th>Count</th>
<th>Count</th>
</tr>
</thead>
<tbody>
<tr>
<td>Very satisfied</td>
<td>12</td>
<td>23</td>
<td>31</td>
<td></td>
</tr>
<tr>
<td>Satisfied</td>
<td>1</td>
<td>34</td>
<td>36</td>
<td></td>
</tr>
<tr>
<td>Dissatisfied</td>
<td>4</td>
<td>6</td>
<td>22</td>
<td></td>
</tr>
<tr>
<td>Very dissatisfied</td>
<td>2</td>
<td>7</td>
<td>12</td>
<td></td>
</tr>
</tbody>
</table>
### Wiki Markup Examples for Chart Macro

This page is an extension of the documentation for the [Chart Macro](https://confluence.xxxx.com/wiki/display/DOC/Chart+Macro). This page contains additional examples for the Chart macro.

**Pie chart**

Here is a simple example of a pie chart.

Wiki markup

```markdown
{chart:type=pie|title=Fish Sold}
| Fish Type | 2004 | 2005 |
| Herring | 9,500 | 8,300 |
| Salmon | 2,900 | 4,200 |
| Tuna | 1,500 | 1,500 |
{chart}
```

Resulting chart

![Resulting area chart 2](image_url)
Here is a simple example of a bar chart.

**Wiki markup**

```
{chart:type=bar|title=Fish Sold}
|| Fish Type || 2004 || 2005 ||
|| Herring | 9,500 | 8,300 |
|| Salmon | 2,900 | 4,200 |
|| Tuna | 1,500 | 1,500 |
{chart}
```

**Resulting chart**

Here is an example of a time series chart.

**Wiki markup**

```
{chart:type=line|title=Fish Sold}

2004: Herring: 9,500, Salmon: 2,900, Tuna: 1,500
2005: Herring: 8,300, Salmon: 4,200, Tuna: 1,500
```

**Time series chart**
<table>
<thead>
<tr>
<th>Month</th>
<th>Revenue</th>
</tr>
</thead>
<tbody>
<tr>
<td>1/2005</td>
<td>31.8</td>
</tr>
<tr>
<td>2/2005</td>
<td>41.8</td>
</tr>
<tr>
<td>3/2005</td>
<td>51.3</td>
</tr>
<tr>
<td>4/2005</td>
<td>33.8</td>
</tr>
<tr>
<td>5/2005</td>
<td>27.6</td>
</tr>
<tr>
<td>6/2005</td>
<td>49.8</td>
</tr>
<tr>
<td>7/2005</td>
<td>51.8</td>
</tr>
<tr>
<td>8/2005</td>
<td>77.3</td>
</tr>
<tr>
<td>9/2005</td>
<td>73.8</td>
</tr>
<tr>
<td>10/2005</td>
<td>97.6</td>
</tr>
<tr>
<td>11/2005</td>
<td>101.2</td>
</tr>
<tr>
<td>12/2005</td>
<td>113.7</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Month</th>
<th>Expenses</th>
</tr>
</thead>
<tbody>
<tr>
<td>1/2005</td>
<td>41.1</td>
</tr>
<tr>
<td>2/2005</td>
<td>43.8</td>
</tr>
<tr>
<td>3/2005</td>
<td>45.3</td>
</tr>
<tr>
<td>4/2005</td>
<td>45.0</td>
</tr>
<tr>
<td>5/2005</td>
<td>44.6</td>
</tr>
<tr>
<td>6/2005</td>
<td>43.8</td>
</tr>
<tr>
<td>7/2005</td>
<td>51.8</td>
</tr>
<tr>
<td>8/2005</td>
<td>52.3</td>
</tr>
<tr>
<td>9/2005</td>
<td>53.8</td>
</tr>
<tr>
<td>10/2005</td>
<td>55.6</td>
</tr>
<tr>
<td>11/2005</td>
<td>61.2</td>
</tr>
<tr>
<td>12/2005</td>
<td>63.7</td>
</tr>
</tbody>
</table>

Resulting chart

---

**XY line chart**

Here is an example of an XY line chart.
Here is an example of an XY bar chart.

**Wiki markup**

{chart:type=xybar|opacity=60}

| | | 2005 | 2006 | 2007 |
| Revenue | 41.1 | 31.8 | 12.4 |
| Expense | 31.1 | 41.8 | 43.6 |

Resulting chart
**XY area chart**

Here is an example of an XY area chart.

Wiki markup

```wiki
{chart:type=xyarea}

<table>
<thead>
<tr>
<th></th>
<th>12</th>
<th>14</th>
<th>23</th>
</tr>
</thead>
<tbody>
<tr>
<td>Revenue</td>
<td>41.1</td>
<td>31.8</td>
<td>12.4</td>
</tr>
<tr>
<td>Expense</td>
<td>31.1</td>
<td>41.8</td>
<td>43.6</td>
</tr>
</tbody>
</table>

{chart}
```

Resulting chart

**Area chart**

Here are two examples of area charts.

Wiki markup for area chart 1
<table>
<thead>
<tr>
<th>Satisfaction</th>
<th>2002</th>
<th>2003</th>
<th>2004</th>
</tr>
</thead>
<tbody>
<tr>
<td>Very satisfied</td>
<td>20</td>
<td>23</td>
<td>34</td>
</tr>
<tr>
<td>Satisfied</td>
<td>40</td>
<td>34</td>
<td>23</td>
</tr>
<tr>
<td>Disatisfied</td>
<td>25</td>
<td>26</td>
<td>25</td>
</tr>
<tr>
<td>Very dissatisfied</td>
<td>15</td>
<td>17</td>
<td>18</td>
</tr>
</tbody>
</table>

**Resulting area chart 1**

**Wiki markup for area chart 2**

```wiki
{chart:type=area|dataDisplay=true|legend=true|width=300|height=300|opacity=50}
<table>
<thead>
<tr>
<th>Satisfaction</th>
<th>2002</th>
<th>2003</th>
<th>2004</th>
</tr>
</thead>
<tbody>
<tr>
<td>Very satisfied</td>
<td>12</td>
<td>23</td>
<td>31</td>
</tr>
<tr>
<td>Satisfied</td>
<td>1</td>
<td>34</td>
<td>36</td>
</tr>
<tr>
<td>Dis satisfied</td>
<td>4</td>
<td>6</td>
<td>22</td>
</tr>
<tr>
<td>Very dissatisfied</td>
<td>2</td>
<td>7</td>
<td>12</td>
</tr>
</tbody>
</table>
{chart}
```
The Cheese macro simply displays the words "I like cheese!" You can use this macro to test the Confluence macro functionality.

**To add the Cheese macro to a page:**

1. In the Confluence editor, choose **Insert > Other Macros**.
2. Find and select the required macro.

**Speeding up macro entry with autocomplete:** Type `{ and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

**To edit an existing macro:** Click the macro placeholder and choose **Edit**. A macro dialog window will open, where you can edit the parameters of the macro.

**Note:** There are no parameters for this macro.

**Code examples**

The following examples are provided for advanced users who want to edit the underlying markup for a Confluence page.

**Macro name:** cheese

**Macro body:** None.

**Parameters:** None

**Storage format example**

```
<ac:structured-macro ac:name="cheese"/>
```
Wiki markup example

{cheese}

Children Display Macro

Use the Children Display macro to list the child pages of a page and the further descendants (children's children). By default, the macro displays links to the child pages as shown in the screenshot below. People viewing the page will see only the links for pages that they have permission to view.

Screenshot: The Children Display macro in Confluence

Using the Children Display macro

To add the Children Display macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Speeding up macro entry with autocomplete: Type { and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

Example

This list of child pages is generated by a Children Display macro on this page:

- Child Page 1
- Child Page 2

Parameters

Parameters are options that you can set to control the content or format of the macro output. Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Show Descendants (all)</td>
<td>false</td>
<td>Choose whether to display all the parent page's descendants. If true shows the complete tree of pages underneath the parent page, regardless of Depth of Descendants</td>
</tr>
</tbody>
</table>
### Parent Page (page)
- current

Specify the page to display children for, from either the current space or a different space. Enter:
- ‘/’ — to list the top-level pages of the current space, i.e. those without parents.
- ‘pagename’ — to list the children of the specified page.
- ‘spacekey:' — to list the top-level pages of the specified space.
- ‘spacekey:pagename’ — to list the children of the specified page in the specified space.

### Number of Children (first)
- none

Restrict the number of child pages that are displayed at the top level.

### Depth of Descendants (depth)
- none

Enter a number to specify the depth of descendants to display. For example, if the value is 2, the macro will display 2 levels of child pages.

This setting has no effect if Show Descendants is enabled.

### Heading Style (style)
- none

Choose the style used to display descendants.

### Include Excerpts (excerpt)
- false

If you have an excerpt macro on any of the returned pages, checking this option will display the first line of the excerpt.

For pages without an excerpt macro, nothing is displayed.

### Sort Children By (sort)
- Manual if manually ordered, otherwise alphabetical

Optional. Choose:
- creation — to sort by content creation date
- title — to sort alphabetically on title
- modified — to sort of last modification date.

### Reverse Sort (reverse)
- false

Use with the Sort Children By parameter. When set, the sort order changes from ascending to descending.

---

**Code examples**

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a Confluence page.

**Macro name:** children

**Macro body:** None.

**Storage format example**
Wiki markup example

{(children:reverse=true|sort=creation|style=h4|page=Home|excerpt=true|first=99|depth=2|all=true)

Child Page 1

Grandchild

Child Page 2

This page is used to test the {children} macro.

Related Topics

Children Display Macro

Code Block Macro

The Code Block macro allows you to display source code in your document with the appropriate syntax highlighting. The code block displays on the page as shown below:

```java
public static void main(String[] args) {
    System.out.println("Hello World!");
}
```

Using the Code Block Macro

To add the Code Block macro to a page:

1. In the Confluence editor, choose **Insert > Other Macros**.
2. Find and select the required macro.

Speeding up macro entry with autocomplete: Type `{ and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

To edit an existing macro: Click the macro placeholder and choose **Edit**. A macro dialog window will open, where you can edit the parameters of the macro.

You type the code block directly into the macro placeholder in the editor. Note that any white space contained in the placeholder is not manipulated in any way by the Code Block macro. This is to provide the writer with flexibility over code indentation.
Parameters

Parameters are options that you can set to control the content or format of the macro output. Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Syntax highlighting (language)</td>
<td>java</td>
<td>Specifies the language (or environment) for syntax highlighting. The default language is Java but you can choose from one of the following languages/environments:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• actionscript3</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• bash</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• csharp (C#)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• coldfusion</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• cpp (C++)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• css</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• delphi</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• diff</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• erlang</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• groovy</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• html/xml</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• java</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• javafx</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• javascript</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• none (no syntax highlighting)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• perl</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• powershell</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• python</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• ruby</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• scala</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• sql</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• vb</td>
</tr>
<tr>
<td>Title</td>
<td>none</td>
<td>Adds a title to the code block. If specified, the title will be displayed in a header row at the top of the code block.</td>
</tr>
<tr>
<td>Collapsible (collapse)</td>
<td>false</td>
<td>If selected, the code macro’s content will be collapsed upon visiting or refreshing the Confluence page. Clicking the expand source link allows you to view this content. If false, the code macro’s content is always displayed in full.</td>
</tr>
<tr>
<td>Show line numbers (linenumbers)</td>
<td>false</td>
<td>If selected, line numbers will be shown to the left of the lines of code.</td>
</tr>
<tr>
<td>First line number (firstline)</td>
<td>1</td>
<td>When Show line numbers is selected, this value defines the number of the first line of code.</td>
</tr>
</tbody>
</table>
### Theme

<table>
<thead>
<tr>
<th>Theme</th>
<th>Default</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Specifies the colour scheme used for displaying your code block. Many of these themes are based on the default colour schemes of popular integrated development environments (IDEs). The default theme is Confluence (also known as Default), which is typically black and coloured text on a blank background. However, you can also choose from one of the following other popular themes:</td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>• DJango</td>
</tr>
<tr>
<td></td>
<td>• Emacs</td>
</tr>
<tr>
<td></td>
<td>• FadeToGrey</td>
</tr>
<tr>
<td></td>
<td>• Midnight</td>
</tr>
<tr>
<td></td>
<td>• RDark</td>
</tr>
<tr>
<td></td>
<td>• Eclipse</td>
</tr>
<tr>
<td></td>
<td>• Confluence</td>
</tr>
</tbody>
</table>

### Configuring the Code Block macro

You can configure the Code Block macro to use a specific language and theme by default and also upload new languages. You need Confluence Administrator permissions to change the default theme and language and System Administrator permissions to upload new languages.

**To set the default appearance of code blocks in your site:**

1. Choose the cog icon, then choose General Configuration under Confluence Administration
2. Choose Configure Code Macro.
3. Select a Default Theme and Default Language.
4. Choose Save.

All new code blocks will use the default theme and language unless you specify otherwise. Existing code blocks will be unchanged.

**To add an additional language:**

1. Choose the cog icon, then choose General Configuration under Confluence Administration
2. Choose Configure Code Macro.
3. Choose Add a new language.
4. Locate your language file and enter a Name for the new language (this will appear when selecting the language).
5. Choose Add.

Language files must be correctly formatted JavaScript files and adhere to the Custom Brush syntax. You can find some examples of language files here.

**To disable or remove a user-installed language:**

1. Choose the cog icon, then choose General Configuration under Confluence Administration
2. Choose Manage Add-ons.
3. Go to User-installed Add-ons and locate the add-on for your uploaded language - it will appear like this 'Custom Code Macro Highlighting for...'
4. Choose Uninstall or Disable.

The language will no longer appear in the Code Macro.

### Code examples

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a Confluence page.

**Macro name:** code

**Macro body:** Accepts plain text.

**Storage format example**
The following example shows all parameters and a body:

```xml
<ac:structured-macro ac:name="code">
    <ac:parameter ac:name="title">This is my title</ac:parameter>
    <ac:parameter ac:name="theme">FadeToGrey</ac:parameter>
    <ac:parameter ac:name="linenumbers">true</ac:parameter>
    <ac:parameter ac:name="language">xml</ac:parameter>
    <ac:parameter ac:name="firstline">0001</ac:parameter>
    <ac:parameter ac:name="collapse">true</ac:parameter>
    <ac:plain-text-body><![CDATA[<b>This is my code</b>]]></ac:plain-text-body>
</ac:structured-macro>
```

Below are three examples of the Code Block macro with various optional parameters used.

<table>
<thead>
<tr>
<th>Description</th>
<th>Markup</th>
<th>What you will get</th>
</tr>
</thead>
</table>
| Code block macro with a body and no optional parameters                    | <ac:structured-macro ac:name="code">
    <ac:plain-text-body><![CDATA[this is my code]]></ac:plain-text-body>
</ac:structured-macro>                                                      | this is my code    |
| Code block macro with a body and the optional language parameter defined   | <ac:structured-macro ac:name="code">
    <ac:parameter ac:name="language">html/xml</ac:parameter>
    <ac:plain-text-body><![CDATA[this is my code]]></ac:plain-text-body>
</ac:structured-macro>                                                      | this is my code    |
| Code block macro with a body and optional title, line numbers and language parameters defined | <ac:structured-macro ac:name="code">
    <ac:parameter ac:name="title">This is my title</ac:parameter>
    <ac:parameter ac:name="linenumbers">true</ac:parameter>
    <ac:parameter ac:name="language">html/xml</ac:parameter>
    <ac:plain-text-body><![CDATA[this is my code]]></ac:plain-text-body>
</ac:structured-macro>                                                      | This is my title   |

Wiki markup example

```
{code:title=This is my title|theme=FadeToGrey|linenumbers=true|language=html/xml|firstline=0001|collapse=true}
This is my code
{code}
```

Column Macro
Used with the Section macro to define columns on a page. See Working with page layouts and columns and sections.

Code examples

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a Confluence page.

**Macro name:** column

**Macro body:** Accepts rich text.

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
<tbody>
<tr>
<td>width</td>
<td>No</td>
<td>100% of the page width, divided equally by the number of columns in the section.</td>
<td>The width of the column. Can be specified either in pixels (for example, 400px) or as a percentage of the available page width (for example, 50%).</td>
</tr>
</tbody>
</table>

**Storage format example**

```xml
<ac:structured-macro ac:name="column">
  <ac:parameter ac:name="width">100px</ac:parameter>
  <ac:rich-text-body>
    <p>This is the content of <strong>column 1</strong>.</p>
  </ac:rich-text-body>
</ac:structured-macro>
```

**Wiki markup example**

```
{column:width=100px}
This is the content of *column 1*.
{column}
```

**Content by Label Macro**

The Content by Label macro displays links to pages, blog posts and attachments that have been tagged with specific labels.

**Using the Content by Label Macro**

**To add the Content by Label macro to a page:**

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

**Speeding up macro entry with autocomplete:** Type `{` and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

**To edit an existing macro:** Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

**Parameters**

Parameters are options that you can set to control the content or format of the macro output. Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro
browser, it will be listed below in brackets (example).

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Label(s) (labels)</strong></td>
<td>None</td>
<td>Filter by label(s). The macro will display only the content tagged with the label(s) specified here. See also the Operator parameter below.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>This parameter is required. Specify one or more labels, separated by a comma or a single space.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• To exclude content which matches a given label, put a minus sign (-) immediately in front of that label value. For example: If you specify a label value of <code>-badpage</code> you will get only content which is not labelled with <code>badpage</code>.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• To indicate that the results must match a given label value, put a plus sign (+) immediately in front of that label value. For example: If you specify a label value of <code>+superpage,+goodpage</code> you will get only content which has at least two labels, being <code>superpage</code> and <code>goodpage</code>.</td>
</tr>
<tr>
<td><strong>Author(s) (author)</strong></td>
<td>None</td>
<td>Filter by author. The macro will display only the content created or updated by the author(s) specified here.</td>
</tr>
<tr>
<td><strong>Include this Content Type Only (type)</strong></td>
<td>all</td>
<td>Filter by content type. The macro will display only the content of the type specified here.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Specify one or more content types, separated by a comma or a space.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>To exclude content of a given content type, put a minus sign (-) immediately in front of that content type. For example: If you specify a content type of <code>-blogpost</code> you will get pages and all other content except for blog posts.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Available values:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• page – Pages.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• blogpost or news – Blog posts, also known as news items.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• attachment – Attachments</td>
</tr>
<tr>
<td><strong>Show Labels for Each Page (showLabels)</strong></td>
<td>true</td>
<td>Show or hide labels in the results.</td>
</tr>
<tr>
<td><strong>Show Space Name for Each Page (showSpace)</strong></td>
<td>true</td>
<td>Show or hide spaces in the results.</td>
</tr>
<tr>
<td><strong>List Title (title)</strong></td>
<td>None</td>
<td>Add a title or heading to the list.</td>
</tr>
<tr>
<td><strong>Maximum Number of Pages (max)</strong></td>
<td>15</td>
<td>Limit the maximum number of results to be displayed. Note that the results are sorted first, and then the maximum parameter is applied.</td>
</tr>
<tr>
<td><strong>Display Excerpts (excerpt)</strong></td>
<td>false</td>
<td>Include excerpts from each page listed. Note that you must have defined excerpts on each of those pages, by adding the excerpt macro to the page. Only the first few lines of the excerpt for each page are displayed.</td>
</tr>
</tbody>
</table>
| **Restrict to these Spaces (spaces)** | @all | Filter by space. The macro will display only the content which belongs to the space(s) specified here. Specify one or more space keys, separated by a comma or a space.  
- To exclude content in a specific space, put a minus sign (-) immediately in front of that space key. For example: If you specify a space key of -BADSPACE you will get only content which is not in the BADSPACE.  
- To indicate that the results must come from a specific space, put a plus sign (+) immediately in front of that space key. For example: If you specify a space key of +GOODSPACE you will get only content in GOODSPACE. (Note that this is not particularly useful, because each content item belongs to one space only. If you put a plus sign next to one space key and list other space keys too, the other space keys will be ignored.) Special values:  
  - @self — The current space.  
  - @personal — All personal spaces.  
  - @global — All site spaces.  
  - @favorite — The spaces you have marked as favourite.  
  - @favourite — The same as @favorite above.  
  - @all — All spaces in your Confluence site.  
  - * — The same as @all above. When specifying a personal space, remember to use the tilde (~) sign in front of the username, such as ~jbloggs or ~jbloggs@example.com. |
| **Operator (operator)** | OR | The operator to apply when matching content against the labels specified in the Label(s) parameter:  
- OR — Display content with any of the non-prefixed labels.  
- AND — Display content with all of the specified non-prefixed labels. Note that this parameter only modifies the behaviour of the Label(s) parameter and only affects label values without a plus (+) or minus (-) sign prefix. |
| **Sort By (sort)** | modified | Specify how the results should be sorted. Values:  
- title — Sort alphabetically by title.  
- creation — Sort by the date on which the content was added.  
- modified — Sort by the date on which the content was last updated. Note: If this parameter is not specified, the sort order defaults to descending, based on the last modification date (latest first). To change the sort order from ascending to descending, use the Reverse Sort parameter. |
| **Reverse Sort (reverse)** | false | Select Reverse Sort to change the sort from descending to ascending. Use this parameter in conjunction with the Sort By parameter. Reverse Sort is ignored if Sort By is not specified. |

**Code examples**

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a Confluence page.

**Macro name:** contentbylabel  
**Macro body:** None.
## Storage format example

```xml
<ac:structured-macro ac:name="contentbylabel">
    <ac:parameter ac:name="spaces"/>
    <ac:parameter ac:name="author">admin, smaddox</ac:parameter>
    <ac:parameter ac:name="title">My labelled pages</ac:parameter>
    <ac:parameter ac:name="showLabels">false</ac:parameter>
    <ac:parameter ac:name="reverse">true</ac:parameter>
    <ac:parameter ac:name="sort">creation</ac:parameter>
    <ac:parameter ac:name="max">10</ac:parameter>
    <ac:parameter ac:name="excerpt">true</ac:parameter>
    <ac:parameter ac:name="labels">chocolate, cake</ac:parameter>
    <ac:parameter ac:name="showSpace">false</ac:parameter>
    <ac:parameter ac:name="type">page</ac:parameter>
    <ac:parameter ac:name="operator">AND</ac:parameter>
</ac:structured-macro>
```

## Wikimarkup example

```
{contentbylabel:spaces=@personal,@self|author=admin,smaddox|title=My labelled pages|showLabels=false|reverse=true|sort=creation|max=10|excerpt=true|labels=chocolate,cake|showSpace=false|type=page|operator=AND}
```

### Content by User Macro

The Content by User macro generates a tabulated list of the content items, throughout the Confluence installation, that have been created by a specified Confluence user. The list includes all current pages, comments and spaces created by the user. Each item in the table is linked to its corresponding page, page comment or space dashboard.

Note that items for page comments contain a link to the page, followed by a second link to the comment itself, with these separated by a greater-than sign (>).

### Using the Content by User macro

**To add the Content by User macro to a page:**

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

**Speeding up macro entry with autocomplete:** Type `{` and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

**To edit an existing macro:** Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

### Parameters

Parameters are options that you can set to control the content or format of the macro output. Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Required</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Username (name)</td>
<td>yes</td>
<td>none</td>
<td>The Confluence username for a person who has created content. Parameter is unnamed in wikimarkup.</td>
</tr>
</tbody>
</table>

### Code examples
The following examples are provided for advanced users who want to inspect or edit the underlying markup for a Confluence page.

**Macro name:** content-by-user

**Macro body:** None.

**Storage format example**

```xml
<ac:structured-macro ac:name="content-by-user">
  <ac:parameter ac:name="">
    <ri:user ri:userkey="12345678912345678912345678912345"/>
  </ac:parameter>
</ac:structured-macro>
```

**Wikimarkup example**

```
{content-by-user:jsmith}
```

---

**Content Report Table Macro**

The Content Report Table macro displays a set of pages and blog posts in tabular format, based on the labels specified in the macro parameters.

**A working example**

Below is a working example of the Content Report Table macro, displaying content with the label 'LDAP'.

Error rendering macro 'content-report-table': In template Confluence.Templates.User.userLinkUrl: When evaluating "contextPath()": Error while computing function "contextPath()": null

**Using the Content Report Table Macro**

**To add the Content Report Table macro to a page:**

1. In the Confluence editor, choose **Insert** > **Other Macros**.
2. Find and select the required macro.

**Speeding up macro entry with autocomplete:** Type `{` and the beginning of the macro name, to see a list of suggested macros. Details are in **Using Autocomplete**.

**To edit an existing macro:** Click the macro placeholder and choose **Edit**. A macro dialog window will open, where you can edit the parameters of the macro.

**Parameters**

Parameters are options that you can set to control the content or format of the macro output. Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Required</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Label(s)</strong></td>
<td>No</td>
<td>None</td>
<td>This parameter is required. Specify one or more labels, separated by a comma. The macro will display the content tagged with any of the label(s) specified here. For example, if you specify labels 'A' and 'B', the macro will display all pages that have the label 'A', and all pages that have the label 'B', and all pages that have both those labels.</td>
</tr>
</tbody>
</table>
### Space(s) (spaces)
| Yes | (All spaces) |
| Space(s) (spaces) | Specify one or more space keys, separated by a comma or a space. The macro will display only the content which belongs to the space(s) specified here. When specifying a personal space, remember to use the tilde (~) sign in front of the username, such as ~jbloggs or ~jbloggs@example.com. |

### Maximum Number of Pages (maxResults)
| No | 20 |
| Maximum Number of Pages (maxResults) | Define the maximum number of pages that the macro will show in a single set of results. If there are more pages to be shown, the macro will display a link labelled 'Find more results'. People viewing the page can choose the link to go to a search view, which shows all pages tagged with the specified label(s). Which pages will appear? Before displaying the results, Confluence will sort them by the date the page was last modified. The most-recently created/updated pages will appear first. |

#### Code examples

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a Confluence page.

**Macro name:** content-report-table

**Macro body:** None.

**Storage format example**

```xml
<ac:structured-macro ac:name="content-report-table">
  <ac:parameter ac:name="spaces">
    <ri:space ri:space-key="DOC"/>
  </ac:parameter>
  <ac:parameter ac:name="labels">LDAP</ac:parameter>
  <ac:parameter ac:name="analytics-key">meeting-notes</ac:parameter>
  <ac:parameter ac:name="maxResults">5</ac:parameter>
</ac:structured-macro>
```

**Wiki markup**

Wiki markup is not available for this macro. You cannot add this macro via wiki markup.

**Contributors Macro**

The Contributors macro displays a list of Confluence users who have made a contribution of some type to a page. It can also be used to list watchers of the page.

The scope of this macro can be extended to include the immediate children or descendants of the specified page. The list of contributors can be based on people who have:

- authored or edited the page(s)
- contributed comments or added labels to the page(s), or
- are simply watching the page(s).

**Screenshot: Example list of Contributors**
In this example, the Display Format parameter has been set to list.

Using the Contributors Macro

To add the Contributors macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Speeding up macro entry with autocomplete: Type { and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

Parameters

Parameters are options that you can set to control the content or format of the macro output. Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
</table>
| Contribution Type (include) | authors | Filters by either the type of contribution made to a page (and optionally its descendant pages), or the watches on the page. Contribution types are:
  - authors - includes people who created or have edited the page(s)
  - comments - includes people who have added comments to the page(s)
  - labels - includes people who have added labels to the page(s)
  - watches - includes people who are watching the page(s).
  You can specify one or more contribution types, separated by commas. |
| Sort By (order) | count  | Specifies the criteria used to sort contributors. Sort criteria are:
  - count - sorts people based on the total number of contributions to the page(s)
  - name - sorts people into alphabetical order
  - update - sorts people based on the date of their last contribution to the page(s). |
| Reverse Sort (reverse) | false  | Reverses the sort order of contributors in the list. Must be used in conjunction with the Sort By parameter. |
| **Maximum Number of Contributors**<br>(limit) | no limit | Limits the number of contributors in the list. If a number is not specified, all contributors are included. |
| **Display Format**<br>(mode) | inline | Sets how the list of contributor's names is formatted:  
• **inline** — a comma-separated list  
• **list** — a bullet list. |
| **Show Anonymous Contributions?**<br>(showAnonymous) | false | Sets whether to include those who contributed anonymously to a page. |
| **Show Count?**<br>(showCount) | false | Sets whether to show the number of times each person made a contribution of the specified Contribution Type. |
| **Show Last Contribution Time?**<br>(showLastTime) | false | Sets whether to show the last time each person made a contribution of the specified Contribution Type. |
| **Page Name**<br>(page) | current | Specifies the page to use when generating the list of contributors. If Page Name and Space(s) are left blank, the current page is assumed. |
| **Label(s)**<br>(labels) | none | Filters the list of contributors to those who created the specified labels from a page. You can specify one or more labels, separated by commas. |
| **Space(s)**<br>(spaces) | current | Specifies the space key of the Confluence space that contains the page set in Page Name or alternatively, specifies the spaces to search. Space keys are case-sensitive.  
This parameter also takes special values, including:  
• @global — All site spaces.  
• @personal — All personal spaces.  
• @all — All spaces in your Confluence site.  
You can specify one or more space keys or special values, separated by commas.  
If no Page Name and Label(s) are specified, all pages from the specified set of spaces are included. |
| **Content Type**<br>(contentType) | both pages and blog posts | Restricts the content type to use when generating the list of contributors:  
• **pages** — pages  
• **blogposts** — blog posts. |
| **Blog Post Date**<br>(publishDate) | none | Specifies the publish date for a blog post. The date format required is: YYYY/MM/DD. |
| **Include Page Hierarchy**<br>(scope) | specified page only | Specifies additional pages to include when generating the list of contributors:  
• **children** — just the child pages of the specified page  
• **descendants** — all descendants of the specified page. |
| **Show Selected Pages**<br>(showPages) | false | Sets whether to show a list of the pages used to generate the list of contributors. |
Custom "None Found" Message (noneFoundMessage)

| default message | Specifies the message to be used to override the default message that is displayed when no contributors are found. |

Code examples

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a Confluence page.

**Macro name:** contributors

**Macro body:** None.

**Storage format example**

This example specifies a content type of blog posts:

```xml
<ac:macro ac:name="contributors">
    <ac:parameter ac:name="limit">10</ac:parameter>
    <ac:parameter ac:name="spaces">ds,@personal</ac:parameter>
    <ac:parameter ac:name="reverse">true</ac:parameter>
    <ac:parameter ac:name="labels">chocolate,cake</ac:parameter>
    <ac:parameter ac:name="showPages">true</ac:parameter>
    <ac:parameter ac:name="noneFoundMessage">Oh dear, no contributors found</ac:parameter>
    <ac:parameter ac:name="showCount">true</ac:parameter>
    <ac:parameter ac:name="contentType">blogposts</ac:parameter>
    <ac:parameter ac:name="include">authors,comments,labels,watches</ac:parameter>
    <ac:parameter ac:name="mode">list</ac:parameter>
    <ac:parameter ac:name="showAnonymous">true</ac:parameter>
    <ac:parameter ac:name="order">update</ac:parameter>
    <ac:parameter ac:name="showLastTime">true</ac:parameter>
    <ac:parameter ac:name="publishDate">2012/06/30</ac:parameter>
</ac:macro>
```

**Wikimarkup example**

This example specifies a content type of blog posts:

```
{contributors:limit=10|spaces=ds,@personal|reverse=true|labels=chocolate,cake|showPages=true|noneFoundMessage=Oh dear, no contributors found|showCount=true|contentType=blogposts|include=authors,comments,labels,watches|mode=list|showAnonymous=true|order=update|showLastTime=true|publishDate=2012/06/30}
```

This example specifies a content type of pages:

```
{contributors:limit=10|spaces=ds,@personal|reverse=true|scope=descendants|labels=chocolate,cake|showPages=true|noneFoundMessage=Oh dear, no contributors found|showCount=true|contentType=pages|include=authors,comments,labels,watches|mode=list|showAnonymous=true|order=update|page=ds:Advanced Topics|showLastTime=true}
```

**Contributors Summary Macro**

The Contributors Summary macro displays a table of contribution-based statistics for a set of pages. These statistics can be grouped according to individual pages or individual contributors.

The default scope for this macro is an individual page, but this can be extended to include the immediate
children or descendants of a specified page. The statistics cover the following types of contributions:

- edits to the page(s)
- comments added to the page(s)
- labels added to the page(s)
- people watching the page(s)

A simple example of the Contributors Summary macro is shown in the screenshot below. It lists statistics for the number of times each contributor has edited, added comments and added labels to this page.

Screenshot: Example Contributors Summary table of statistics

<table>
<thead>
<tr>
<th>User</th>
<th>Edits</th>
<th>Comments</th>
<th>Labels</th>
</tr>
</thead>
<tbody>
<tr>
<td>Sarah Maddox</td>
<td>2</td>
<td>2</td>
<td>0</td>
</tr>
<tr>
<td>Edwin Dawson</td>
<td>2</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>Giles Gaskell</td>
<td>2</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>Rosie Jameson</td>
<td>2</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>Andrew Lui</td>
<td>2</td>
<td>0</td>
<td>1</td>
</tr>
<tr>
<td>Charles Miller</td>
<td>1</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>Andrew Prentice</td>
<td>0</td>
<td>0</td>
<td>1</td>
</tr>
</tbody>
</table>

In this example, all default parameter settings are used. For more information about this macro's parameters, refer to the Parameters section below.

Using the Contributors Summary Macro

To add the Contributors Summary macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

**Speeding up macro entry with autocomplete:** Type { and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

Parameters

Parameters are options that you can set to control the content or format of the macro output. Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Group By (groupby)</td>
<td>contributors</td>
<td>Specifies the basis for grouping contribution-based statistics:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• contributors — group by the people who have contributed</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• pages — group by the pages used to find contributors.</td>
</tr>
</tbody>
</table>
### Columns to Display (columns)

<table>
<thead>
<tr>
<th>Column</th>
<th>Options</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>edits, comments, labels</td>
<td></td>
<td>Sets the columns that should appear in the table. The statistics or type of information presented depends on the basis for grouping set with the <strong>Group By</strong> parameter. Statistics may be calculated for:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• edits — the number of times each contributor has edited the page(s) or the number of edits made to each page.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• edited — a list of the pages edited by each contributor or a list of contributors who have edited each page.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• comments — the number of times each contributor has added comments to the page(s) or the number of comments on each page.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• commented — a list of pages to which each contributor has added comments or a list of contributors who have commented on each page.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• labels — the number of times each contributor has added labels to the page(s) or the number of labels on each page.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• labeled — a list of pages to which each contributor has added labels or a list of contributors who have added a label to each page.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• labellist — a list of labels either added by each contributor or on each page.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• watches — the number of pages being watched by each contributor/person or the number of contributors/people watching each page.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• watching — a list of pages being watched by each contributor/person or a list of contributors/people watching each page.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• lastupdate — the last time each contributor made an update or when each page was last updated. Valid updates can include edit, comment or label modifications to a page.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>One or more columns can be used.</td>
</tr>
</tbody>
</table>

### Sort By (order)

<table>
<thead>
<tr>
<th>Sort By</th>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>edits</td>
<td></td>
<td>Sets the criterion used for sorting items in the table. The items sorted depend on the basis for grouping set with the <strong>Group By</strong> parameter. Sort criteria are:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• edits — sorts items in the table based on the total number of edits made, either by a contributor or to a page.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• name — sorts items in the table in alphabetical order, either by contributor or page name.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• editTime — sorts items in the table based on when the contributor last edited a page (or a specified set of pages) or when the page was last edited.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• update — sorts items in the table based on when the contributor last made any contribution to a page (or a specified set of pages) or when the page last had any contribution made to it.</td>
</tr>
</tbody>
</table>

### Reverse Sort (reverse)

<table>
<thead>
<tr>
<th>Reverse Sort</th>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>reverse</td>
<td>false</td>
<td>Reverses the sort order of items in the table, as specified using the <strong>Sort By</strong> parameter. (Used only in conjunction with the <strong>Sort By</strong> parameter.)</td>
</tr>
</tbody>
</table>

### Maximum Number of Items (limit)

<table>
<thead>
<tr>
<th>Maximum Number of Items</th>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>limit</td>
<td>no limit</td>
<td>Limits the number of contributors or pages in the table to the value specified. If no number is specified, all items are included.</td>
</tr>
<tr>
<td>Parameter</td>
<td>Value</td>
<td>Description</td>
</tr>
<tr>
<td>---------------------------------</td>
<td>--------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Show Anonymous Contributions?</td>
<td>false</td>
<td>Includes individuals who have made anonymous contributions to a page.</td>
</tr>
<tr>
<td>(showAnonymous)</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Show Zero Counts?</td>
<td>false</td>
<td>Sets whether contributors or pages are included for which a calculated statistic is zero.</td>
</tr>
<tr>
<td>(showZeroCounts)</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Page Name</td>
<td>current</td>
<td>Sets the page for which to calculate the contribution-based statistics. If no values for Page Name and Space(s) are specified, the current page is assumed.</td>
</tr>
<tr>
<td>(page)</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Label(s)</td>
<td>none</td>
<td>Restricts the contribution-based statistics to the specified labels only. You can specify one or more labels, separated by commas.</td>
</tr>
<tr>
<td>(labels)</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Space(s)</td>
<td>current</td>
<td>Specifies the space key of the Confluence space which contains the specified page name or alternatively, specifies a scope of spaces to search. Space keys are case-sensitive. This parameter also takes special values, including:</td>
</tr>
<tr>
<td>(spaces)</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>• @global — All site spaces.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• @personal — All personal spaces.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• @all — All spaces in your Confluence site.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>You can specify one or more space keys or special values, separated by commas.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>If no Page Name and Label(s) are specified, all pages from the specified set of spaces are included.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Content Type</td>
<td>both pages and blog posts</td>
<td>Restricts page types to either pages (pages) or blog posts (blogposts). If no value is specified in the Macro Browser, both pages and blog posts are included. Available values pages and blogposts.</td>
</tr>
<tr>
<td>(contentType)</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Blog Post Date</td>
<td>none</td>
<td>Specifies the publish date for a blog post. The date format required is: YYYY/MM/DD.</td>
</tr>
<tr>
<td>(publishDate)</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Include Page Hierarchy</td>
<td>specified page only</td>
<td>Includes either the immediate children or all descendants of the specified page. If no value is indicated in the Macro Browser, only the specified page is included.</td>
</tr>
<tr>
<td>(scope)</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

**Code examples**

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a Confluence page.

**Macro name:** contributors-summary

**Macro body:** None.

**Storage format example**

This example specifies a content type of blog posts:
This example specifies a content type of pages:

```
<ac:structured-macro ac:name="contributors-summary">
  <ac:parameter ac:name="limit">10</ac:parameter>
  <ac:parameter ac:name="spaces">
    <ri:space ri:space-key="ds"/>
    <ri:space ri:space-key="@personal"/>
  </ac:parameter>
  <ac:parameter ac:name="reverse">true</ac:parameter>
  <ac:parameter ac:name="showAnonymous">true</ac:parameter>
  <ac:parameter ac:name="order">update</ac:parameter>
  <ac:parameter ac:name="labels">chocolate,cake</ac:parameter>
  <ac:parameter ac:name="columns">edits,comments,labels,lastupdate</ac:parameter>
  <ac:parameter ac:name="groupby">pages</ac:parameter>
  <ac:parameter ac:name="contentType">pages</ac:parameter>
  <ac:parameter ac:name="showZeroCounts">true</ac:parameter>
  <ac:parameter ac:name="publishDate">2012/06/07</ac:parameter>
</ac:structured-macro>
```

This example specifies a content type of blog posts:

```
{contributors-summary:limit=10|spaces=ds,@personal|reverse=true|showAnonymous=true|
order=update|labels=chocolate,cake|columns=edits,comments,labels,lastupdate|groupby=
pages|contentType=blogposts|showZeroCounts=true|publishDate=2012/06/07}
```

This example specifies a content type of pages:

```
{contributors-summary:limit=10|spaces=ds,@personal|reverse=true|showAnonymous=true|
scope=descendants|order=update|page=ds:Advanced Topics|labels=chocolate,cake|columns=edits,comments,labels,lastupdate|groupby=pages
|contentType=pages|showZeroCounts=true}
```
Create from Template Macro

The Create from Template macro displays a button on a page, linked to a specific template. When someone clicks the button, the macro opens the editor, ready to add a new page, and adds content to the page based on the given template.

When adding the macro to the page, you can specify a blueprint or a user-created template in the macro. You will also specify the name of the button displayed, and the space in which the new page will appear.

Example

Screenshot: A page with three buttons, all displayed by the 'Create from Template' macro

Using the Create from Template Macro

To add the Create from Template macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Speeding up macro entry with autocomplete: Type { and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

Parameters

Parameters are options that you can set to control the content or format of the macro output. Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Required</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Button Text</td>
<td></td>
<td>'Create from Template'</td>
<td>The description that people will see when viewing this macro on the page.</td>
</tr>
<tr>
<td>Template Name</td>
<td></td>
<td>None</td>
<td>Select the template or blueprint to base the new page on. Only global and user-created templates for the current space appear (unless you have specified a different space in the 'Space Key' field).</td>
</tr>
<tr>
<td>Template Title</td>
<td></td>
<td>Blank</td>
<td>Specify a default title for pages created using this macro (optional). You can include @currentDate, @spaceName and @spaceKey variables in the title.</td>
</tr>
<tr>
<td>Space Key</td>
<td></td>
<td>The space where the current page is located</td>
<td>Supply the unique space identifier (space key), to determine where the new page will be created when someone uses this macro to create a page.</td>
</tr>
</tbody>
</table>

Created in 2015 by Atlassian. Licensed under a Creative Commons Attribution 2.5 Australia License.
Code examples

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a Confluence page.

**Macro name:** create-from-template

**Macro body:** None.

Parameters for storage format differ from those available in the macro browser as follows.

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
<tbody>
<tr>
<td>templateId</td>
<td>Required for user-created templates</td>
<td>(None)</td>
<td>The ID of a user-created template. This is the unique identifier that Confluence assigns when you create a template. For example, 299630593. To find the ID of a template, edit the template and look at the URL in your browser. The template ID is given in the URL parameter named entityId.</td>
</tr>
<tr>
<td>blueprintModuleCompleteKey</td>
<td>Required for blueprints</td>
<td>(None)</td>
<td></td>
</tr>
<tr>
<td>templateName</td>
<td>Yes</td>
<td>(None)</td>
<td>The ID of a user-created template (for example, 299630593) or the qualified name of the add-on that defines the blueprint (for example, com.atlassian.confluence.plugins.confluence-shared-files-plugin:file-list-blueprint).</td>
</tr>
<tr>
<td>buttonLabel</td>
<td>Yes</td>
<td>'Create from Template'</td>
<td>The description that people will seeing when viewing this macro on the page.</td>
</tr>
<tr>
<td>spaceKey</td>
<td>Yes</td>
<td>The unique space identifier, to determine where the current page is located</td>
<td>The title for pages created using this macro. You can include @currentDate, @spaceName and @spaceKey variables. This title will override any title specified in a blueprint.</td>
</tr>
<tr>
<td>Title</td>
<td>No</td>
<td>(None)</td>
<td></td>
</tr>
</tbody>
</table>

Storage format example

This example specifies a user-created template:

```xml
<ac:structured-macro ac:name="create-from-template">
  <ac:parameter ac:name="templateId">299630593</ac:parameter>
  <ac:parameter ac:name="buttonLabel">Blitz test</ac:parameter>
  <ac:parameter ac:name="spaceKey">
    <ri:space ri:space-key="DOCTHEME"/>
  </ac:parameter>
  <ac:parameter ac:name="templateName">299630593</ac:parameter>
</ac:structured-macro>
```

This example uses a blueprint:
<ac:structured-macro ac:name="create-from-template">

<ac:parameter ac:name="blueprintModuleCompleteKey">com.atlassian.confluence.plugins.confluence-shared-files-plugin:file-list-blueprint</ac:parameter>
<ac:parameter ac:name="buttonLabel">Shared files</ac:parameter>
<ac:parameter ac:name="spaceKey">
    <ri:space ri:space-key="DOCTHEME"/>
</ac:parameter>
<ac:parameter ac:name="templateName">com.atlassian.confluence.plugins.confluence-shared-files-plugin:file-list-blueprint</ac:parameter>
</ac:structured-macro>

Wikimarkup

Wiki markup is not available for this macro. You cannot add this macro via wiki markup.

Create Space Button Macro

The Create Space Button macro displays a create space icon that links to the 'Create Space' page. To see this icon, viewers need the 'Create Space' permission which is assigned by a site administrator.

Using the Create Space Button macro

To add the Create Space Button macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Speeding up macro entry with autocomplete: Type `{` and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

Parameters

Parameters are options that you can set to control the content or format of the macro output. Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Icon Size</td>
<td>large</td>
<td>Specify whether to use large or small icon. Available values:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- large</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- small</td>
</tr>
</tbody>
</table>

Code examples

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a Confluence page.

Macro name: create-space-button

Macro body: None.

The following additional parameters are available in storage format and wikimarkup.

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
<tbody>
<tr>
<td>width</td>
<td>No</td>
<td>Natural size of icon (1:1 pixel ratio)</td>
<td>The width of the icon to be displayed, specified in pixels. Confluence will stretch or shrink the width of the icon to the number of pixels specified. Note: This parameter is not available via the macro browser.</td>
</tr>
<tr>
<td>-------</td>
<td>----</td>
<td>---------------------------------------</td>
<td>------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>height</td>
<td>No</td>
<td>Natural size of icon (1:1 pixel ratio)</td>
<td>The height of the icon to be displayed, specified in pixels. Confluence will stretch or shrink the height of the icon to the number of pixels specified. Note: This parameter is not available via the macro browser.</td>
</tr>
</tbody>
</table>

Storage format example

```xml
<ac:structured-macro ac:name="create-space-button">
  <ac:parameter ac:name="size">small</ac:parameter>
  <ac:parameter ac:name="height">50px</ac:parameter>
  <ac:parameter ac:name="width">50px</ac:parameter>
</ac:structured-macro>
```

Wikimarkup example

```
{create-space-button:size=small}
{create-space-button:height=50px|width=50px}
```

Excerpt Include Macro

The Excerpt Include macro is used to display 'excerpted' (that is, a segment of) content from one page in another.

Before you can use this macro, the excerpt must have been defined using the Excerpt macro. Note that you can have more than one Excerpt Include macro on a page (although you can have only one Excerpt macro on a page).

Example

The paragraph below shows an example of an Excerpt Include macro, containing content from an excerpt which we have defined on the Excerpt Macro page. On the Excerpt Include macro below, we have set the options to show both the title of the page and the panel surrounding the content.

Define a part of a page as the page's 'excerpt' which can then be displayed in another page.

Using the Excerpt Include Macro

To add the Excerpt Include macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Speeding up macro entry with autocomplete: Type `{ and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.
Parameters

Parameters are options that you can set to control the content or format of the macro output. Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Page Containing the Excerpt</td>
<td>none</td>
<td>Type the name of the page that contains the excerpt to be displayed. You can use an excerpt from a page in the same space or another space in the same wiki. When you type the name of the page into the Excerpt Include macro dialog, Confluence will offer a list of matching pages, including those from other spaces. Alternatively, you can type the space key followed by a colon (:) and the page name, like this: SPACEKEY:Page name. This parameter is unnamed in wikimarkup.</td>
</tr>
<tr>
<td>Remove Surrounding Panel</td>
<td>false</td>
<td>Determines whether Confluence will display a panel around the excerpted content. The panel includes the title of the page containing the excerpt, and the border of the panel. By default, the panel and title are shown.</td>
</tr>
</tbody>
</table>

Code examples

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a Confluence page.

**Macro name:** excerpt-include

**Macro body:** None.

**Storage format example**

```xml
<ac:macro ac:name="excerpt-include">
  <ac:parameter ac:name="nopanel">true</ac:parameter>
  <ac:default-parameter>My page name</ac:default-parameter>
</ac:macro>
```

**Wikimarkup example**

```text
{excerpt-include:My page name|nopanel=true}
```

**Excerpt Macro**

The Excerpt macro is used to mark a part of a page’s content for re-use. Defining an excerpt enables other macros, such as the Excerpt Include and Blog Posts macros, to display the marked content elsewhere.

You can only define one excerpt per page. In other words, you can only add the Excerpt macro once to a page.
Using the Excerpt Macro

To add the Excerpt macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Speeding up macro entry with autocomplete: Type `{` and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

To add reusable content to the macro:

1. Add your content inside the Excerpt macro placeholder.
2. Choose the macro placeholder to see the options panel, and select the option to Display on new line or to Display inline. The default is to display the content of the macro on a new line. If you choose the inline option, the content of the macro will form part of the same paragraph as the text preceding and following it. Note that this option affects only the page that contains the Excerpt macro. It does not affect any pages where the content is reused.

Screenshot: The Excerpt macro placeholder and options panel

Parameters

Parameters are options that you can set to control the content or format of the macro output. Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Hide Excerpted Content (hidden)</td>
<td>false</td>
<td>Controls whether the page content contained in the Excerpt macro placeholder is displayed on the page. Note that this option affects only the page that contains the Excerpt macro. It does not affect any pages where the content is reused.</td>
</tr>
</tbody>
</table>

Code examples

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a Confluence page.

**Macro name:** excerpt

**Macro body:** Accepts rich text.

The following additional parameter is available in storage format and wikimarkup. It performs the same function as the options panel in the editor.
<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
</table>
| atlassian-macro-output-type        | No       | BLOCK   | Determines whether the content of the Excerpt macro body is displayed on a new line or inline. Available values:  
  - BLOCK – Displays the content of the macro on a new line.  
  - INLINE – Displays the content of the macro as part of the same paragraph as the text preceding and following it.  
  Note that this option affects only the page that contains the Excerpt macro. It does not affect any pages where the content is reused. |

Storage format example

```xml
<ac:structured-macro ac:name="excerpt">
  <ac:parameter ac:name="hidden">true</ac:parameter>
  <ac:parameter ac:name="atlassian-macro-output-type">BLOCK</ac:parameter>
  <ac:rich-text-body>
    <p>This is the <strong>text</strong> I want to reuse in other pages. This text is inside an Excerpt macro.</p>
  </ac:rich-text-body>
</ac:structured-macro>
```

Wikimarkup example

```
{excerpt:hidden=true|atlassian-macro-output-type=BLOCK}
This is the *text* I want to reuse in other pages. This text is inside an Excerpt macro.
{excerpt}
```

Expand Macro

The Expand macro displays an expandable/collapsible section of text on your page.

Here is an example:

> Expand me...

This text is hidden until you expand the section.

Using the Expand Macro

To insert the Expand macro into a page using the macro browser:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

**Speeding up macro entry with autocomplete:** Type `{` and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

**To edit an existing macro:** Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

**Parameters**

Parameters are options that you can set to control the content or format of the macro output. Where the
parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Title</td>
<td>Click here to expand...</td>
<td>Defines the text that appears next to the expand/collapse icon.</td>
</tr>
</tbody>
</table>

Code examples

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a Confluence page.

**Macro name:** expand

**Macro body:** Accepts rich text.

**Storage format example**

```xml
<ac:structured-macro ac:name="expand">
  <ac:parameter ac:name="title">Expand me...</ac:parameter>
  <ac:rich-text-body>
    <p>This text is hidden until you expand the section.</p>
  </ac:rich-text-body>
</ac:structured-macro>
```

**Wikimarkup example**

```wiki
{expand:This is my message}
This text is _hidden_ until you expand it.
{expand}
```

Notes

- **Text is expanded in PDF and HTML exports.** When you export the page to PDF or HTML, the text between the macro tags is expanded so that readers can see it in the PDF and HTML versions of the page.
- **Nesting your Expand macros.** You can put one Expand macro inside another, and Confluence will correctly show and hide the contents of all Expand macros, including the nested ones.

**Favourite Pages Macro**

Use the Favourite Pages macro to display a list of your favourite pages.

The output of the Favourite Pages macro appears as in the following screenshot.

*Screenshot: The Favourite Pages Macro in Confluence*
Using the Favourite Pages Macro

To insert the favourite pages macro into a page using the Macro Browser:

1. In the Confluence editor, choose **Insert > Other Macros**.
2. Find and select the required macro.

**Speeding up macro entry with autocomplete:** Type `{` and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

**To edit an existing macro:** Click the macro placeholder and choose **Edit**. A macro dialog window will open, where you can edit the parameters of the macro.

There are no parameters for this macro.

Code examples

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a Confluence page.

**Macro name:** favpages

**Macro body:** None.

**Parameters:** None.

**Storage format example**

```
<ac:structured-macro ac:name="favpages"/>
```

**Wiki markup example**

```
{favpages}
```

Gadget Macro

Gadgets are small applications that can offer dynamic content. They are typically served from a web application server and can be re-used in many other web applications. In Confluence, use the Gadget macro to add gadgets to pages or blog posts.

Confluence comes bundled with a few of its own gadgets that you can add to your pages or blog posts. The Confluence gadgets are listed in Confluence Gadgets. However, you can access additional gadgets in this list if your Confluence Administrator has:

- Installed additional gadgets in Confluence (typically as a Confluence plugin) or
- Registered gadgets served from an external web application or website (such as those from a JIRA)
Unlike other macros, the name of each gadget macro is unique and follows the convention "<gadget-name>macro", where <gadget-name> is the name supplied by the gadget itself.

Inserting gadgets into a Confluence page or blog post

To add a gadget to a page:

1. Edit your page or blog post.
2. Choose Insert > Other Macros.
3. Click External Content to see a list of gadgets configured for use in your Confluence installation.
   (Some Confluence macros like the JIRA Issues, RSS Feed, and Widget Connector macros also appear in this category because they can also access external content.)
4. Click the desired gadget to access its parameters and properties.
   Almost all gadgets allow you to set basic parameters (listed below), which appear in the macro dialog. Some gadgets also have their own set of parameters, that can only be set in the gadget itself. You can use the preview in the macro browser to access them.
5. Set the parameters to your requirements.
6. Click Refresh to preview your changes.
7. Click Insert to add the gadget to the page.

Editing gadgets on a Confluence page or blog post

To edit an existing gadget on a page or blog post:

1. Edit your page or blog post.
2. Click the Gadget macro placeholder and choose Edit (or double-click the placeholder).
3. Set the gadget's parameters to your requirements.
4. Click Refresh to preview your changes.
5. Save the gadget.

Standard gadget parameters

Almost all gadgets allow you to set basic parameters (listed below), which appear on the right of the macro dialog. Each gadget may also have its own set of parameters, which appear on the left of the macro dialog.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
</table>
| Width     | 450 pixels  | Set the width of the gadget, using one of the following conventions:  
  • Width in pixels, using px or plain numbers. For example, 500px or 500
  • A percentage of the page width, using %. For example, 50%
  • Automatic resizing of the gadget to fit 100% of the page width: auto |
| Border    | true        | Places a thin grey border around the gadget. |

Contents of a Gadget macro

In the addition to the standard parameters, the gadget macro contains 'parameter-like' content, which represents specific property settings that are particular to each gadget. Hence they are not documented here. Typically, this content would only be changed by customising the gadget's default properties using the macro browser.

Code examples

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a Confluence page.

Macro name: gadget
Macro body: None.

The following additional parameters are available in storage format and wikimarkup.

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
<tbody>
<tr>
<td>url</td>
<td>Yes</td>
<td>(none)</td>
<td>This is the location of the gadget specification (XML file).</td>
</tr>
<tr>
<td>preferences</td>
<td>No</td>
<td>(Gadget-dependent)</td>
<td>Specific property settings that are particular to each gadget.</td>
</tr>
</tbody>
</table>

A note about editing a gadget’s properties (preferences) in markup: It is possible to edit the values of these properties directly in the wiki markup or storage format. However, this will allow the entry of invalid values. If a gadget property supports a certain set of values, the macro browser will restrict the user to selecting only valid values for that property. For that reason, we recommend that you use the macro browser to edit a gadget’s properties.

Storage format example

This example shows the Confluence Page gadget:

```xml
<ac:structured-macro ac:name="gadget">
    <ac:parameter ac:name="width">500</ac:parameter>
    <ac:parameter ac:name="border">false</ac:parameter>
    <ac:parameter ac:name="url">rest/gadgets/1.0/g/com.atlassian.confluence.plugins.gadgets:confluence-page-gadget/gadgets/confluence-page-gadget.xml</ac:parameter>
    <ac:parameter ac:name="preferences">spaceName=Documentation&spaceKey=DOC&quickfind-space=Documentation&pageId=753666&pageName=Documentation%20Home&quickfind-page=Documentation%20Home&isEditable=true&isConfigured=true&refresh=15&showLink=false</ac:parameter>
</ac:structured-macro>
```

This example shows the Confluence News gadget:

```xml
<ac:structured-macro ac:name="gadget">
    <ac:parameter ac:name="url">rest/gadgets/1.0/g/com.atlassian.confluence.plugins.gadgets:confluence-news-gadget/gadgets/confluence-news-gadget.xml</ac:parameter>
    <ac:parameter ac:name="preferences"/>
</ac:structured-macro>
```

Wiki markup example

This example shows the Confluence Page gadget:

```
{gadget:width=500|border=false|url=rest/gadgets/1.0/g/com.atlassian.confluence.plugins.gadgets:confluence-page-gadget/gadgets/confluence-page-gadget.xml}
spaceName=Documentation&spaceKey=DOC&quickfind-space=Documentation&pageId=753666&pageName=Documentation%20Home&quickfind-page=Documentation%20Home&isEditable=true&isConfigured=true&refresh=15&showLink=false {gadget}
```
This example shows the Confluence News gadget:

```
{gadget:url=rest/gadgets/1.0/g/com.atlassian.confluence.plugins.gadgets:confluence-news-gadget/gadgets/confluence-news-gadget.xml} {gadget}
```

**Gallery Macro**

The Gallery macro displays a collection of thumbnail images in a table, based on the images attached to a Confluence page. When viewing the page, a user can click a thumbnail image to zoom into a screen-sized image and then view the images as a slide show.

**Overview:**

- The images shown in the gallery are taken from the files attached to the Confluence page. You can also specify a different page where the attachments are located. For information about attaching images to a page, see [Uploading Files](#).
- The captions below the images are drawn from the comments on the attachments. For information about adding comments to attachments, see [Uploading Files](#).
- By default, the gallery will include all the images attached to the page. You can also exclude or include images using parameters.
- You can sort your images into a particular order.
- You can specify a title for the gallery and also configure how many columns you want for the table in which your images are displayed.

*Illustration: Live example of the Gallery macro*
Using the Gallery macro

To insert the Gallery macro onto a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Speeding up macro entry with autocomplete: Type { and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

Parameters

Parameters are options that you can set to control the content or format of the macro output. Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).

The full list of parameters is shown in the following table. If the name of an attached file or page contains a comma, you can refer to it in the relevant parameters below by enclosing it in single or double quotes, for example "this,that.jpg", theother.png

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
</table>

Here's an office photo

Here is the waterfall photo
<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Gallery Title (title)</td>
<td>Specify a title for your gallery.</td>
</tr>
<tr>
<td>Number of Columns (columns)</td>
<td>Specify the number of columns for your table.</td>
</tr>
<tr>
<td>Images to Exclude (exclude)</td>
<td>The gallery will ignore any pictures specified. You can specify more than one picture, separated by commas. Note: The filename and filetype for this parameter are case-sensitive. For example, 'my picture.PNG' will not be recognised as 'my picture.png'.</td>
</tr>
<tr>
<td>Include these Images Only (include)</td>
<td>If you specifically include one or more pictures, the gallery will show only those pictures. You can specify more than one picture, separated by commas. Note: The filename and filetype for this parameter are case-sensitive. For example, 'my picture.PNG' will not be recognised as 'my picture.png'.</td>
</tr>
<tr>
<td>Exclude Images with these Labels (excludeLabel)</td>
<td>The gallery will ignore any pictures that have the specified label. You can specify more than one label, separated by commas. For information on labelling the attachments, see Add, Remove and Search for Labels.</td>
</tr>
<tr>
<td>Include Images with these Labels Only (includeLabel)</td>
<td>Filters the images to display, based on a list of labels. If you wish to enter more than one label, separate the labels with commas. Confluence will show only images that have all the labels specified. (The match is an AND, not an OR.) For information on labelling the attachments, see Add, Remove and Search for Labels.</td>
</tr>
<tr>
<td>Use Images in these Pages (page)</td>
<td>Specify the title of the page which contains the images you want displayed. You can specify more than one page name, separated by commas. To specify a page in a different space, use the following syntax: SPACEKEY:Page Title</td>
</tr>
<tr>
<td>Sort Images By (sort)</td>
<td>Specify an attribute to sort the images by. Sort order is ascending, unless you select the Reverse Sort parameter (see below). Options are:</td>
</tr>
<tr>
<td></td>
<td>• name – file name.</td>
</tr>
<tr>
<td></td>
<td>• comment – comment linked to the attached file.</td>
</tr>
<tr>
<td></td>
<td>• date – date/time last modified.</td>
</tr>
<tr>
<td></td>
<td>• size – size of the attached file.</td>
</tr>
<tr>
<td>Reverse Sort (reverse)</td>
<td>Used in combination with the Sort Images By parameter above. Use Reverse Sort to reverse the sort order, from ascending to descending. Available values in storage format and wikimarkup:</td>
</tr>
<tr>
<td></td>
<td>• true – Sort order is descending.</td>
</tr>
<tr>
<td></td>
<td>• false – Sort order is ascending.</td>
</tr>
</tbody>
</table>

**Image file formats**

You can attach image files of any format to a page. Confluence supports the following image formats in the Gallery macro and when displaying an image on a page:
• gif
• jpeg
• png
• bmp (depending on browser support)

Code examples

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a Confluence page.

**Macro name:** gallery

**Macro body:** None.

**Storage format example**

```xml
<ac:structured-macro ac:name="gallery">
  <ac:parameter ac:name="title">My holiday pictures</ac:parameter>
  <ac:parameter ac:name="reverse">true</ac:parameter>
  <ac:parameter ac:name="sort">size</ac:parameter>
  <ac:parameter ac:name="page">My page1, ds:Welcome to Confluence</ac:parameter>
  <ac:parameter ac:name="excludeLabel">badlabel1, badlabel2</ac:parameter>
  <ac:parameter ac:name="columns">3</ac:parameter>
  <ac:parameter ac:name="exclude">badpicture.png</ac:parameter>
</ac:structured-macro>
```

**Wiki markup example**

```
{gallery:title=My holiday pictures|reverse=true|sort=size|page=My page1, ds:Welcome to Confluence|excludeLabel=badlabel1, badlabel2|columns=3|exclude=badpicture.png}
```

**Global Reports Macro**

The Global Reports macro displays a list of links to some reports about content on your site.

These reports include a list of new or updated pages, orphan pages, undefined pages, and RSS feeds for new pages and blog posts.

**Screenshot: The Global Reports macro**

```
This is the Global Reports macro

**Global Reports**

- New or updated pages since your last login.
- Find all pages that aren't linked from anywhere.
- Find all undefined pages.
- Feed for new pages and blogs.
```

**Using the Global Reports Macro**

To add the Global Reports macro to a page:
1. In the Confluence editor, choose **Insert > Other Macros**.
2. Find and select the required macro.

**Speeding up macro entry with autocomplete:** Type `{` and the beginning of the macro name, to see a list of suggested macros. Details are in **Using Autocomplete**.

**To edit an existing macro:** Click the macro placeholder and choose **Edit**. A macro dialog window will open, where you can edit the parameters of the macro.

**Parameters**

Parameters are options that you can set to control the content or format of the macro output. Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Width of Table</strong></td>
<td>99%</td>
<td>Specify the width of the table in which the links are displayed, as a percentage of the window width.</td>
</tr>
</tbody>
</table>

**Code examples**

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a Confluence page.

**Macro name:** global-reports

**Macro body:** None.

**Storage format example**

```xml
<ac:structured-macro ac:name="global-reports">
  <ac:parameter ac:name="width">50%</ac:parameter>
</ac:structured-macro>
```

**Wikimarkup example**

```
{global-reports:width=50%}
```

**HTML Include Macro**

The HTML Include macro allows you to include the contents of an external HTML file (a webpage) in a Confluence page.

**HTML macros are disabled by default**

The HTML macro will only be available if it has been enabled by an administrator. Enabling these macros can make your Confluence site vulnerable to cross-site scripting attacks.

**Using the HTML Include Macro**

**To insert the HTML Include macro into a page:**

1. In the Confluence editor, choose **Insert > Other Macros**.
2. Find and select the required macro.

**Speeding up macro entry with autocomplete:** Type `{` and the beginning of the macro name, to see a list of
suggested macros. Details are in Using Autocomplete.

**To edit an existing macro:** Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

**Parameters**

Parameters are options that you can set to control the content or format of the macro output. Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Required</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>HTML Page's URL (url)</td>
<td>Yes</td>
<td>None</td>
<td>The URL of the page to include.</td>
</tr>
</tbody>
</table>

**Enabling the HTML Include Macro**

The HTML Include macro is disabled by default. You'll need Confluence Administrator or System Administrator permissions to enable this macro.

⚠️ Enabling these macros can make your Confluence site vulnerable to cross-site scripting attacks. You should only turn on these macros if you trust all your users not to attempt to exploit them. We strongly recommend leaving this macro disabled if you allow self-signed up or anonymous users to create content.

**To enable the HTML Include macro:**

1. Go to > Add-ons
2. Select System from the drop down and search for the Confluence HTML Macros add-on.
3. Expand the add-on and enable the html-include (html-include-xhtml) module.

Administrators can also choose to use the whitelist to restrict URLs that can be displayed in the HTML Include macro.

**Troubleshooting**

- Administrators can define a whitelist of trusted URLs. If a URL is not in the whitelist, you will see an error message in the HTML Include macro.
- You can only use the HTML Include macro for pages with absolute links. If you use the macro to include an HTML page that has relative links, you will see a 'Page Not Found' error. See CONF-6567 - HTML Include macro should rewrite relative links to point to remote site [OPEN].

**Code examples**

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a Confluence page.

**Macro name:** html-include

**Macro body:** None.

**Storage format example**

```xml
<ac:structured-macro ac:name="html-include">
  <ac:parameter ac:name="url">
    <ri:url ri:value="http://www.example.com"/>
  </ac:parameter>
</ac:structured-macro>
```
HTML Macro

The HTML macro allows you to add HTML code to a Confluence page.

**HTML macros are disabled by default**
The HTML macro will only be available if it has been enabled by an administrator. Enabling these macros can make your Confluence site vulnerable to cross-site scripting attacks.

Using the HTML Macro

**To add the HTML macro to a page:**

1. In the Confluence editor, choose **Insert > Other Macros**.
2. Find and select the required macro.

**Speeding up macro entry with autocomplete:** Type `{` and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

**To edit an existing macro:** Click the macro placeholder and choose **Edit**. A macro dialog window will open, where you can edit the parameters of the macro.

There are no parameters for this macro.

Enter the HTML code into the body of the macro placeholder.

Enabling the HTML Macro

The HTML macro is disabled by default. You'll need Confluence Administrator or System Administrator permissions to enable this macro.

⚠️ Enabling these macros can make your Confluence site vulnerable to cross-site scripting attacks. You should only turn on these macros if you trust all your users not to attempt to exploit them. We strongly recommend leaving this macro disabled if you allow self-signed up or anonymous users to create content.

**To enable the HTML macro:**

1. Go to **Settings > Add-ons**.
2. Select **System** from the drop down and search for the **Confluence HTML Macros** add-on.
3. Expand the add-on and enable the **html (html-xhtml)** module.

Code examples

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a Confluence page.

**Macro name:** html

**Macro body:** Text, consisting of HTML code.

**Parameters:** None.

**Storage format example**

```<ac:structured-macro ac:name = "html">
   <ac:plain-text-body><![CDATA[<a href="http://www.atlassian.com">Click here</a> to see the Atlassian website.]]></ac:plain-text-body></ac:structured-macro>```
IM Presence Macro

The IM Presence macro indicates graphically when a contact is signed into an Instant Messaging (IM) service. The IM Presence macro appears as a small icon on the page.

Using the IM Presence Macro

**To add the IM Presence macro to a page:**

1. In the Confluence editor, choose **Insert > Other Macros**.
2. Find and select the required macro.

**Speeding up macro entry with autocomplete:** Type `{` and the beginning of the macro name, to see a list of suggested macros. Details are in the Using Autocomplete.

**To edit an existing macro:** Click the macro placeholder and choose **Edit**. A macro dialog window will open, where you can edit the parameters of the macro.

Parameters

Parameters are options that you can set to control the content or format of the macro output. Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>User ID/Screen Name</td>
<td>Identify the user by their ID, account name or screen name.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Service (service)</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>aim – AOL Instant Messenger</td>
<td></td>
</tr>
<tr>
<td>gtalk – Google Talk</td>
<td></td>
</tr>
<tr>
<td>icq – ICQ</td>
<td></td>
</tr>
<tr>
<td>jabber – Jabber</td>
<td></td>
</tr>
<tr>
<td>msn – MSN Instant Messenger</td>
<td></td>
</tr>
<tr>
<td>sametime – IBM Lotus Sametime</td>
<td></td>
</tr>
<tr>
<td>skype – Skype</td>
<td>Note: Skype requires 'Show my status on the web' to be checked under 'Privacy' preferences</td>
</tr>
<tr>
<td>skypeme – Skype</td>
<td></td>
</tr>
<tr>
<td>wildfire – Openfire Server</td>
<td></td>
</tr>
<tr>
<td>yahoo – Yahoo! Messenger</td>
<td></td>
</tr>
</tbody>
</table>

| Show User ID (showid) | Shows or hides the User ID of the contact.                                     |

Code examples

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a Confluence page.
Macro name: im

Macro body: None.

Storage format example

```xml
<ac:structured-macro ac:name="im">
  <ac:parameter ac:name="showid">false</ac:parameter>
  <ac:parameter ac:name="service">skype</ac:parameter>
  <ac:parameter ac:name">MySkypeName</ac:parameter>
</ac:structured-macro>
```

Wiki markup example

```
{im:MySkypeName|service=skype|showid=false}
```

Include Page Macro

You can use the Include Page macro to display the contents of one Confluence page or blog post in another page or blog post.

Using the Include Page Macro

To add the Include Page macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Speeding up macro entry with autocomplete: Type `{ and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

Parameters

Parameters are options that you can set to control the content or format of the macro output. Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
</table>
| Page to Include    | None    | This is the name of the Confluence page or blog post that you want to include in the current page. Start typing a page title, and Confluence will suggest matching pages from the current space and other spaces. Alternatively you can specify the page as follows:  
  - If the page or blog post is located in another space, add the space key and a colon in front of the page name. For example, DOC:My page name. The space key is case sensitive.  
  - To include a blog post, specify the date as well as the title of the blog post. For example: /2010/12/01/My blog post.  
  - You can include pages from personal spaces using ~username as the space key, where 'username' is the person's username. For example, ~jsmith:My page name. |

Code examples
The following examples are provided for advanced users who want to inspect or edit the underlying markup for a Confluence page.

**Macro name:** include

**Macro body:** None.

**Storage format example**

```xml
<ac:structured-macro ac:name="include">
  <ac:parameter ac:name="">
    <ac:link>
      <ri:page ri:content-title="My chocolate page" ri:space-key="DOC"/>
    </ac:link>
  </ac:parameter>
</ac:structured-macro>
```

**Wiki markup example**

```
{include:DOC:My chocolate page}
```

**Notes**

- If you want to include part of a page rather than the whole page, use the Excerpt and Excerpt Include macros.
- To display a page’s contents, you need ‘View’ permission for that page. Similarly, people who view the page will need ‘View’ permissions for the embedded page as well as the page into which it is embedded. See space permissions or contact your Confluence space administrator for more information.
- If you want to embed an external page into a Confluence page, you need the HTML Include Macro.

**Sample Include Page**

Start of sample page content


End of sample page content

**Info Macro**

The Info macro allows you to highlight helpful information on a Confluence page. It creates a blue-coloured box surrounding your text, as shown below.

**Info Macro Example**

This text is rendered inside the info macro.

**Using the Info Macro**

**To add the Info macro to a page:**

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

**Speeding up macro entry with autocomplete:** Type `{` and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.
To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

Parameters

Parameters are options that you can set to control the content or format of the macro output. Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Optional Title</td>
<td>none</td>
<td>The title of the information box. If specified, the title text will be displayed in bold next to the icon.</td>
</tr>
<tr>
<td>title</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Show Information</td>
<td>true</td>
<td>If “false”, the icon will not be displayed.</td>
</tr>
<tr>
<td>Icon</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Code examples

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a Confluence page.

Macro name: info

Macro body: Accepts rich text.

Storage format example

The following example shows all parameters and a body:

```xml
<ac:structured-macro ac:name="info">
  <ac:parameter ac:name="icon">false</ac:parameter>
  <ac:parameter ac:name="title">This is my title</ac:parameter>
  <ac:rich-text-body>
    <p>This is <em>important</em> information.</p>
  </ac:rich-text-body>
</ac:structured-macro>
```

Below are some examples of the Info macro with various optional parameters used.

<table>
<thead>
<tr>
<th>Description</th>
<th>Markup</th>
<th>What you will get</th>
</tr>
</thead>
</table>
| Info macro with a body defined and no optional parameters  | `<ac:structured-macro ac:name="info">
  <ac:rich-text-body>
    <p>This is <em>important</em> information.</p>
  </ac:rich-text-body>
</ac:structured-macro>` | This is important information.                                         |
### Info macro with with a body and an optional Title parameter defined

```html
<ac:structured-macro ac:name="info">
  <ac:parameter ac:name="title">This is my title</ac:parameter>
  <ac:rich-text-body>
    This is _important_ information.
  </ac:rich-text-body>
</ac:structured-macro>
```

### Info macro with a body and optional Title and Icon parameters defined

```html
<ac:structured-macro ac:name="info">
  <ac:parameter ac:name="icon">false</ac:parameter>
  <ac:parameter ac:name="title">This is my title</ac:parameter>
  <ac:rich-text-body>
    This is _important_ information.
  </ac:rich-text-body>
</ac:structured-macro>
```

### Wiki markup example

```
{info:title=This is my title|icon=false}
This is _important_ information.
{info}
```

### JIRA Chart Macro

**JIRA** is Atlassian's issue tracking and project management system. By adding the JIRA Chart macro to a Confluence page, you can display information about JIRA issues and projects as pie charts.

Before you can use this macro, your Confluence and JIRA sites must be connected via Application Links. People viewing the page will see charts for publicly accessible issues from the JIRA site. If your JIRA site has restricted viewing (that is, people need permission to view issues) then they will need to authenticate before seeing the charts. This macro is compatible with JIRA 5.x and later.

**Adding the JIRA Chart macro to a page**

Quick guide to using the macro on a Confluence page:

1. In the Confluence editor, choose *Insert > Other Macros*.
2. Find and select the required macro.

**Speeding up macro entry with autocomplete:** Type `{ and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

**To edit an existing macro:** Click the macro placeholder and choose *Edit*. A macro dialog window will open, where you can edit the parameters of the macro.
Using the JIRA Chart Macro

To add a JIRA chart to your page:

1. Insert the JIRA Chart macro (see above).
2. Select your JIRA server.
   
   If you have multiple JIRA instances linked to Confluence the drop down will default to the primary application link.
3. Search for issues - you can enter the query in JQL or paste a JIRA URL directly into the search field.
4. Choose Preview to see the chart.
5. Choose Insert.

To find out more about searching for issues see Displaying issues via a JIRA Query Language (JQL) search.

You can further control how the chart appears on your page. Choose Display options:

- **Chart by** - select the JIRA field you want to segment the pie chart by.
- **Width** - define the total width of the chart area. You can enter values in pixels or percent. Leave blank to auto fit.
- **Show border** - add a border around the chart area
- **Show chart information** - include a text summary under the chart with the total issues count and chart by value.

Screenshot: The JIRA Chart Macro in the macro browser

Disabling the JIRA Chart macro

The functionality is provided by an add-on (plugin) called ‘JIRA Macros’. This macro is also used for the JIRA Issues macro. To make the macro unavailable on your site, you can disable the add-on. See Disabling and enabling add-ons.

Notes

**HTTPS**: The JIRA Chart macro can access a JIRA site running under SSL provided the Confluence server is configured to accept the JIRA SSL certificate. See Connecting to LDAP or JIRA or Other Services via SSL.

**Authentication**: If the query includes issues that require authentication (issues that are not visible to anonymous users in JIRA), users will be prompted to authenticate to view charts on the Confluence page.
In order to search for issues in the macro browser you may need to authenticate. With JIRA 5.x you will be able to search for unrestricted issues as an anonymous user, however with JIRA 6.x you must be authenticated to search for any issues.

Code examples

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a Confluence page.

**Macro name:** jirachart

**Macro body:** None.

The following parameters are available in storage format.

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
<tbody>
<tr>
<td>chartType</td>
<td>Yes</td>
<td>Pie</td>
<td>Type of chart to display. Currently Pie is the only available chart type. Other types may be added in future.</td>
</tr>
<tr>
<td>statType</td>
<td>Yes</td>
<td>statuses</td>
<td>The JIRA field to segment the pie chart by:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>statType</td>
<td>* statuses* - displays a breakdown of issues by Status.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>* allFixfor* - displays a breakdown of issues by chart by all Fix Versions (useful if issues have more than one fix version).</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>* assignees* - displays a breakdown of issues by the Assignee name.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>* priorities* - displays a breakdown of issues by Priority.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>* components* - displays a breakdown of issues by Component.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>* issueType* - displays a breakdown of issues by Issue Type.</td>
</tr>
<tr>
<td>showinfo</td>
<td>No</td>
<td>False</td>
<td>Displays text information about the data below the chart. Includes the Total value and the Chart By value.</td>
</tr>
<tr>
<td>jql</td>
<td>Yes</td>
<td>JQL query for the chart to display.</td>
<td></td>
</tr>
<tr>
<td>width</td>
<td>600</td>
<td>(blank)</td>
<td>This is the total width of the chart area. Width can be entered in pixels, percent or left blank to fit to the available space.</td>
</tr>
<tr>
<td>border</td>
<td>No</td>
<td>False</td>
<td>Displays a border around the chart area.</td>
</tr>
</tbody>
</table>

Storage format example

Example chart by Issue Type - note that Confluence will insert the `server` and `serverId` parameters, based on settings in Application Links:

```xml
<ac:structured-macro ac:name="jirachart">
    <ac:parameter ac:name="chartType">pie</ac:parameter>
    <ac:parameter ac:name="statType">issuetype</ac:parameter>
    <ac:parameter ac:name="showinfo">true</ac:parameter>
    <ac:parameter ac:name="jql">project%20%3D%20CONF%20and%20fixVersion%20in%20('5.3')</ac:parameter>
    <ac:parameter ac:name="width">600</ac:parameter>
    <ac:parameter ac:name="server">JAC</ac:parameter>
    <ac:parameter ac:name="serverId">144880e9-a353-312f-9412-ed028e8166fa</ac:parameter>
    <ac:parameter ac:name="border">true</ac:parameter>
</ac:structured-macro>
```

JIRA Issues Macro
JIRA is the issue tracking and project management system supplied by Atlassian. By adding the JIRA Issues macro to a Confluence page, you can display one or more issues from a JIRA site. You can also choose to create an issue in JIRA, at the time of adding the macro to the Confluence page.

Before you can use this macro, your Confluence and JIRA sites must be connected via Application Links. People viewing the page will see the publicly accessible issues from the JIRA site. If your JIRA site has restricted viewing (that is, people need permission to view issues) then they will need to authenticate before seeing the restricted issues. See more about restricted JIRA issues below.

What you can do with the JIRA Issues macro

Using the JIRA Issues macro, you can:

- Display a table of JIRA issues on your page, based on the results of a search using JIRA Query Language (JQL).
- Display a table of JIRA issues onto your page, using a JIRA URL.
- Display a single issue from the JIRA site, or a subset of selected issues from your JIRA search results.
- Display a count of issues from the JIRA site.
- Create new issues in JIRA and display the issues on your page without leaving Confluence.

Adding and updating the JIRA Issues macro – an overview

Quick guide to using the macro on a Confluence page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

**Speeding up macro entry with autocomplete:** Type `{` and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

**To edit an existing macro:** Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

**Screenshot: Example of JIRA issues macro on a Confluence page**

<table>
<thead>
<tr>
<th>Key</th>
<th>Summary</th>
<th>T</th>
<th>Updated</th>
<th>P</th>
<th>Status</th>
<th>Resolved</th>
</tr>
</thead>
<tbody>
<tr>
<td>CONF-30864</td>
<td>User is not prompted before overwriting changes of another user if attempting to save after an editor error is thrown</td>
<td>Oct 22, 2013</td>
<td>↑</td>
<td></td>
<td>RESOLVED</td>
<td>Fixed</td>
</tr>
<tr>
<td>CONF-30865</td>
<td>TableOfContents Macros navigation is not working in Firefox 23.x / 24.x and Opera 12.15</td>
<td>Sep 24, 2013</td>
<td>↓</td>
<td></td>
<td>RESOLVED</td>
<td>Fixed</td>
</tr>
<tr>
<td>CONF-30663</td>
<td>Left panel overlaps custom banner in Chrome</td>
<td>Sep 23, 2013</td>
<td>↓</td>
<td></td>
<td>RESOLVED</td>
<td>Fixed</td>
</tr>
<tr>
<td>CONF-30690</td>
<td>Dashboard popular stream won't render when it contains content from an anonymous user</td>
<td>Sep 19, 2013</td>
<td>↑</td>
<td></td>
<td>RESOLVED</td>
<td>Fixed</td>
</tr>
</tbody>
</table>

4 issues  ⏳ Refresh

Displaying issues via a JIRA Query Language (JQL) search

You can use the macro to display a table of JIRA issues on your page, based on the results of a search using JIRA Query Language (JQL).

JQL is a simple query language, similar to SQL, which works in JIRA. A basic JQL query consists of a field, followed by an operator (such as `=` or `>`) followed by one or more values or functions.

Examples:

- The following query will find all issues in the ‘TEST’ project:
The following query will find all issues in the 'documentation' component of the 'CONF' project:

```
project = CONF and component = documentation
```

For more information about JQL syntax, see the JIRA documentation: Advanced Searching.

To display a table of issues based on a JQL search:

1. Insert the JIRA Issues macro onto your Confluence page, as described above.
2. Choose a JIRA server next to the Search button.
3. If prompted, log in to the JIRA server.
4. Enter the JQL query into the Search box.
5. Choose Search.
6. If you want to customise the display, choose Display options and adjust the columns and number of issues that will appear in your table of issues.
7. Choose Insert.

Screenshot: Display options in the JIRA Issues macro browser.

Displaying issues via a JIRA URL

You can paste any of the following JIRA URLs into the JIRA Issues macro. Confluence will immediately convert the URL to a JQL search:

- Any URL for a JIRA issue search or filter.
- A URL for a single issue.
- The URL of the XML view of a JIRA search.

Auto-convert: You can paste a JIRA URL directly into the Confluence editor (without calling up the macro browser). Confluence will automatically convert the URL into a JIRA Issues macro.

Displaying a single JIRA issue, or selected JIRA issues

To display a single JIRA issue, choose one of the following methods:

- Paste the URL of the issue directly onto the Confluence page. (There is no need to use the macro browser.) Confluence will auto-convert the link to a JIRA Issues macro.
1. Or: Add the JIRA issues macro to the page as described above, and choose Recently Viewed to see the JIRA issues you have visited recently. Select an issue and choose Insert.

2. Or: Add the JIRA issues macro to the page as described above, and past the issue URL into the search box in the macro browser.

3. Or: Add the JIRA issues macro to the page, define your search criteria in the macro browser via JQL as described above, then select the check box next to the issue in the search results, within the macro browser.

**To display a subset of JIRA issues from your search results:**

1. Add the JIRA issues macro to the page.
2. Define your search criteria in the macro browser via JQL, as described above.
3. Select the check boxes next to the required issues in the search results, within the macro browser.

**Screenshot: Selecting a subset of issues to display**

**Displaying a count of issues**

You can choose to display the number of issues returned by your search, rather than a table of issues. The JIRA Issues macro will display a count of issues, linked to the search in JIRA.

**Screenshot: The JIRA Issues macro displaying an issue count on a Confluence page**

**To display an issue count:**

1. Add the JIRA issues macro to the page.
2. Define your search criteria in the macro browser via JQL, as described above.
3. Choose Display options, then choose Total issue count next to 'Display options' in the macro browser.
4. Choose Insert.

Creating a new JIRA issue in the editor

While editing a Confluence page, you can create an issue in JIRA and display it on your Confluence page, without leaving the Confluence editor.

To insert an issue into JIRA:

1. Add the JIRA Issues macro to the page, as described above.
2. Choose Create New Issue.
3. Supply the information about your JIRA server, project, and issue, as prompted.
4. Choose Insert.

Confluence will send a request to JIRA, to add the issue to the JIRA site. Confluence will also display the resulting JIRA issue on the Confluence page.

Limitations

The JIRA Issues macro will notify you if it is unable to create an issue in the selected project. This may be because the project has a required field, field configuration or other customisation that is not supported by the JIRA Issues macro. In this situation you will need to create the issue directly in JIRA.

Configuring Application Links to display restricted JIRA issues

Before you can use this macro, your Confluence and JIRA sites must be connected via Application Links.

If the JIRA site allows anonymous viewing of issues, you must configure an application link, but there is no need to configure any incoming or outgoing authentication between JIRA and Confluence. People viewing the Confluence page will see the publicly accessible issues from the JIRA site.

If your JIRA site has restricted viewing, or if some JIRA projects or issues are restricted to viewing by certain people, then people will need to log in before seeing the restricted issues.

In such a case, the outgoing authentication in the Confluence Application Links determines how the JIRA Issues macro handles restricted issues:

- If the outgoing authentication is set to Trusted Applications, people can see restricted issues in JIRA if their username is the same in JIRA and Confluence, and if they have permission in JIRA to see the issue.
- If the outgoing authentication is set to OAuth, people may need to choose Login & Approve, to gain access to the JIRA server and restricted issues.
- If the outgoing authentication is set to Basic Access, people can see the JIRA issues that are visible to the user account configured in JIRA's outgoing authentication setting.

Rendering HTML from JIRA

Formatted fields from JIRA can be displayed in Confluence if you set up a Confluence-to-JIRA application link. Otherwise, such formatted fields will be escaped within the output of the JIRA issues macro. This is to prevent the possibility of malicious HTML being served by an untrusted JIRA server. The most likely field where you will notice this is in the description field.

This example shows how a description column may be displayed in JIRA:

<table>
<thead>
<tr>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>This is</td>
</tr>
<tr>
<td>• the description</td>
</tr>
<tr>
<td>• of my issue</td>
</tr>
</tbody>
</table>

If there is no application link between JIRA and Confluence, the description will appear in the JIRA issues macro like this:
Disabling the JIRA Issues macro

The functionality is provided by an add-on (plugin) called 'JIRA Macros'. To make the macro unavailable on your site, you can disable the add-on. See Disabling and enabling add-ons.

Notes

HTTPS: The JIRA Issues macro can access a JIRA site running under SSL provided the Confluence server is configured to accept the JIRA SSL certificate. See Connecting to LDAP or JIRA or Other Services via SSL.

Custom fields can be added as columns to the table simply by using the name of the field with no quotes. Earlier versions of the macro required you to use the custom field id, e.g. customfield_10100.

Code examples

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a Confluence page.

**Macro name:** jiraissues

**Macro body:** None.

Note: A number of additional parameters that are not available via the macro browser are available in storage format and wikimarkup.

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
<tbody>
<tr>
<td>anonymous</td>
<td>No</td>
<td>false</td>
<td>If this parameter is set to 'true', JIRA will return only the issues which allow unrestricted viewing. That is, the issues which are visible to anonymous viewers, as determined by JIRA's viewing restrictions. If this parameter is omitted or set to 'false', then the results depend on how your administrator has configured the communication between JIRA and Confluence. By default, Confluence will show only the JIRA issues which the user is authorised to view. <strong>Note:</strong> This parameter is available only if you insert the macro via wiki markup or by editing the storage format of the page. The graphic user interface (macro browser) for the JIRA Issues macro does not offer this parameter.</td>
</tr>
<tr>
<td>baseurl</td>
<td>No</td>
<td>The value of the 'url' parameter</td>
<td>If you specify a 'baseurl', then the link in the header, pointing to your JIRA site, will use this base URL instead of the value of the 'url' parameter. This is useful when Confluence connects to JIRA with a different URL from the one used by other users.</td>
</tr>
<tr>
<td>columns</td>
<td>No</td>
<td>By default, the following columns are shown: type, key, summary, assignee, reporter, priority, status, resolution, created, updated, due</td>
<td>A list of JIRA column names, separated by semi-colons (;). You can include any columns recognised by your JIRA site, including custom columns. See the JIRA documentation for a list of names.</td>
</tr>
<tr>
<td>count</td>
<td>No</td>
<td>false</td>
<td>If this parameter is set to 'true', the issue list will show the number of issues in JIRA. The count will be linked to your JIRA site.</td>
</tr>
</tbody>
</table>
| cache | No | on | The macro maintains a cache of the issues which result from the JIRA query. If the 'cache' parameter is set to 'off', the relevant part of the cache is cleared each time the macro is reloaded. (The value 'false' also works and has the same effect as 'off'.)  
**Note:** This parameter is available only if you insert the macro via wiki markup or by editing the storage format of the page. The graphic user interface (macro browser) for the JIRA Issues macro does not offer this parameter. |
| height | No | 480 (if render mode is dynamic) | The height in pixels of the table displaying the JIRA issues. Note that this height specification is ignored in the following situations:  
- If the 'renderMode' parameter (see below) is set to 'static'.  
- When the JIRA issues are displayed in a PDF or Word document, in an email message or in an RSS feed.  
**Note:** This parameter is available only if you insert the macro via wiki markup or by editing the storage format of the page. The graphic user interface (macro browser) for the JIRA Issues macro does not offer this parameter. |
| renderMode | No | static | If the value is 'dynamic', the JIRA Issues macro offers an interactive display which people can manipulate as follows:  
- Click the column headers to sort the output.  
- Drag and drop the columns into a different order.  
- Temporarily remove a column from the display.  
- View a page of issues at a time, for faster response times.  
A value of 'static' will disable the dynamic display features.  
**Note:** This parameter is available only if you insert the macro via wiki markup or by editing the storage format of the page. The graphic user interface (macro browser) for the JIRA Issues macro does not offer this parameter. |
<table>
<thead>
<tr>
<th>title</th>
<th>No</th>
<th>JIRA Issues</th>
</tr>
</thead>
<tbody>
<tr>
<td>You can customise the title text at the top of the JIRA issues table with this parameter. For instance, setting the title to 'Bugs-to-fix' will replace the default 'JIRA Issues' text. This can help provide more context to the list of issues displayed. <strong>Note:</strong> This parameter is available only if you insert the macro via wiki markup or by editing the storage format of the page. The graphic user interface (macro browser) for the JIRA Issues macro does not offer this parameter.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>url</td>
<td>Yes</td>
<td>none</td>
</tr>
<tr>
<td>The URL of the XML view of your selected issues in JIRA Issue Navigator. <strong>Note:</strong> If the URL in the 'url' parameter does not contain a <code>tempMax</code> argument, then the value of <code>tempMax</code> will default to 500. If your JIRA server is version 3.12 or earlier, this means that the JIRA Issues macro will return a maximum of 500 issues. If your JIRA server is version 3.13 or later, a value of 500 means that the JIRA Issues macro will return a maximum of 500 issues per page.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>width</td>
<td>No</td>
<td>100%</td>
</tr>
<tr>
<td>The width of the table displaying the JIRA issues. Can be indicated either as a percentage (%) or in pixels (px). <strong>Note:</strong> This parameter is available only if you insert the macro via wiki markup or by editing the storage format of the page. The graphic user interface (macro browser) for the JIRA Issues macro does not offer this parameter.</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

**Storage format example**

**Example using a URL that points to the XML view of a JIRA search:**

```xml
<ac:structured-macro ac:name="jiraissues">
  <ac:parameter ac:name="anonymous">true</ac:parameter>
  <ac:parameter ac:name="columns">type;key;summary</ac:parameter>
  <ac:parameter ac:name="url">
    <ri:url ri:value="http://jira.atlassian.com/sr/jira.issueviews:searchrequest-xml/temp/SearchRequest.xml?jqlQuery=project+%3D+CONF+AND+%28summary+%7E+jiraissues+OR+description+%7E+jiraissues+OR+comment+%7E+jiraissues%29+%26+tempMax=10"/>
  </ac:parameter>
</ac:structured-macro>
```

**Example using JQL – note that Confluence will insert the server and serverId parameters, based on settings in Application Links:**

```xml
<ac:structured-macro ac:name="jira">
  <ac:parameter ac:name="columns">key,summary,type,created,assignee,status</ac:parameter>
  <ac:parameter ac:name="server">Atlassian JIRA</ac:parameter>
  <ac:parameter ac:name="serverId">144880e9-a111-333f-9412-ed999a9999fa</ac:parameter>
  <ac:parameter ac:name="jqlQuery">project = CONF AND component = documentation AND resolution = unresolved</ac:parameter>
</ac:structured-macro>
```
JUnit Report Macro

The JUnit Report macro displays a summary of JUnit test results from a directory accessible by the Confluence server. JUnit is a unit testing framework which allows programmers to ensure that individual units of Java source code are functioning correctly. For security reasons JUnit test result files can only be imported from a specified location in the Confluence server's file system. We recommend administrators create a folder in their Confluence home directory, add the system property `confluence.junit.report.directory` and specify the location for JUnit test result files to be imported from. JUnit Test result files cannot be imported from the server until this system property is set.The JUnit Report macro appears as shown in the screenshot below.

**Screenshot: The JUnit Report macro in Confluence**

<table>
<thead>
<tr>
<th>Test</th>
<th>Time</th>
<th>Messages</th>
</tr>
</thead>
<tbody>
<tr>
<td>MoneyTest</td>
<td>100%</td>
<td>00:03.391</td>
</tr>
<tr>
<td>testAdd</td>
<td>00:03.0</td>
<td>Tests: Failures:Exceptions:</td>
</tr>
</tbody>
</table>

**Note:** When generating reports from the JUnit Report macro, set the Apache Ant formatter to 'XML'.

Using the JUnit Report macro

**To add the JUnit Report macro to a page:**

1. In the Confluence editor, choose **Insert > Other Macros**.
2. Find and select the required macro.

**Speeding up macro entry with autocomplete:** Type `{` and the beginning of the macro name, to see a list of suggested macros. Details are in **Using Autocomplete**.

**To edit an existing macro:** Click the macro placeholder and choose **Edit**. A macro dialog window will open, where you can edit the parameters of the macro.

**Parameters**

Parameters are options that you can set to control the content or format of the macro output. Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Required</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
</table>

---

Created in 2015 by Atlassian. Licensed under a [Creative Commons Attribution 2.5 Australia License](http://creativecommons.org/licenses/by/2.5/au/).
<table>
<thead>
<tr>
<th><strong>URL of the test result XML file (url)</strong></th>
<th>Must include either the directory or the url parameter</th>
<th>None</th>
<th><strong>URL of a particular test result XML file. Is overridden by the Directory (URL) of your test result files parameter if you use both.</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Example, from a Confluence instance:</strong></td>
<td><a href="http://yourConfluence.com/download/attachments/">http://yourConfluence.com/download/attachments/</a>&lt;page id&gt;/file.xml</td>
<td></td>
<td></td>
</tr>
<tr>
<td>For Confluence installations without anonymous user access, you can specify logon credentials as part of this parameter in the form of URL parameters:</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>• <code>os_username</code> — The username of a Confluence user with permission to access to the JUnit test results.</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>• <code>os_password</code> — The password of the Confluence user specified in the <code>os_username</code> parameter.</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Directory (URL) of your test result files (directory)</strong></td>
<td>Must include either the directory or the url parameter</td>
<td>None</td>
<td><strong>URL of a directory containing your test result files. This must be a directory and not the XML file itself. Overrides the URL of the test result files parameter if you use both.</strong></td>
</tr>
<tr>
<td><strong>Example, file:///C:/TEMP/</strong></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Example, for a network drive:</strong></td>
<td>http://<em>host</em>/<em>path</em></td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Report Detail (reportdetail)</strong></td>
<td>No</td>
<td>all</td>
<td><strong>Detail for the report. Can be all, fixture, summary or failuresonly.</strong></td>
</tr>
<tr>
<td><strong>Debug (debug)</strong></td>
<td>No</td>
<td>None</td>
<td><strong>Shows the content of failures, as well as the error messages.</strong></td>
</tr>
</tbody>
</table>

### Code examples

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a Confluence page.

**Macro name:** `junitreport`

**Macro body:** None.

**Storage format example**

```
<ac:structured-macro ac:name="junitreport">
  <ac:parameter ac:name="reportdetail">summary</ac:parameter>
  <ac:parameter ac:name="directory">
    <ri:url ri:value="http://confluence.com/download/attachments/123/*"/>
  </ac:parameter>
  <ac:parameter ac:name="debug">true</ac:parameter>
  <ac:parameter ac:name="url">
    <ri:url ri:value="http://confluence.com/download/attachments/123/file.xml"/>
  </ac:parameter>
</ac:structured-macro>
```

**Wiki markup examples**

**Loading JUnit reports from a local drive:**

```
{junitreport:directory=file:///C:/TEMP/}
```

**Loading JUnit reports from a network drive:**
Loading JUnit reports from a Confluence site:

{JUnitReport:url=http://yourConfluenceInstance.com/download/attachments/<page id>/file.xml}

Loading JUnit reports from a Confluence site that requires authentication:

If your Confluence site is not accessible by anonymous users, specify login credentials with the os_username and os_password URL parameters (as part of the macro’s url parameter). In this case, we are specifying a username of ‘admin’ and a password of ‘secret’.

{JUnitReport:url=http://yourConfluenceInstance.com/download/attachments/<page id>/file.xml?os_username=admin&os_password=secret}

Labels List Macro

The Labels List macro displays a list of all labels within the current space. Each label in the list links to a page that displays all pages in the current space that contain that label.

Using the Labels List macro

To add the Labels List macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Speeding up macro entry with autocomplete: Type { and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

Parameters

Parameters are options that you can set to control the content or format of the macro output. Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
<tbody>
<tr>
<td>Restrict to this Space Key (spaceKey)</td>
<td>No</td>
<td>Current space</td>
<td>The key of the space whose labels you want to display.</td>
</tr>
<tr>
<td>Excluded label(s) (excludedLabels)</td>
<td>No</td>
<td>Blank</td>
<td>The labels that you do not want to appear in the list.</td>
</tr>
</tbody>
</table>

Code examples

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a Confluence page.

Macro name: listlabels
Macro body: None.

Storage format example

```
<ac:structured-macro ac:name="listlabels">
  <ac:parameter ac:name="spaceKey">
    <ri:space ri:space-key="DOC"/>
  </ac:parameter>
  <ac:parameter ac:name="excludedLabels">not-this-label</ac:parameter>
</ac:structured-macro>
```

Wiki markup example

```
{listlabels:spaceKey=DOC}
```

Livesearch Macro

The Livesearch macro allows you to add a search box to a Confluence page. When users enter a search term into the search box, Confluence will dynamically display matching results as they type.

Using the Livesearch macro

To add the Livesearch macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Speeding up macro entry with autocomplete: Type `{ and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

Parameters

Parameters are options that you can set to control the content or format of the macro output. Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Restrict to this Space Key</td>
<td>all spaces</td>
<td>Specify a space key to limit the search to the given space. Case-sensitive.</td>
</tr>
<tr>
<td>(spaceKey)</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Restrict to label(s)</td>
<td></td>
<td>Specify labels to limit the search to content with that label. If unspecified will search all content regardless of label.</td>
</tr>
<tr>
<td>(labels)</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Size</td>
<td>medium</td>
<td>Choose a medium or large search field size.</td>
</tr>
<tr>
<td>(size)</td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Placeholder text</strong> (placeholder)</td>
<td>Specify the placeholder text to appear in the search field, for example ‘Search this space’</td>
<td></td>
</tr>
<tr>
<td>-------------------------------</td>
<td>------------------------------------------------------------------------------------------------</td>
<td></td>
</tr>
<tr>
<td><strong>Type</strong> (type)</td>
<td>all Specify the content types to be included in the search - choose from pages, blogs, comments, space descriptions, or all content types.</td>
<td></td>
</tr>
<tr>
<td><strong>Additional</strong> (additional)</td>
<td>space name Display the space name, a page excerpt or nothing under the search result.</td>
<td></td>
</tr>
</tbody>
</table>

**Code examples**

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a Confluence page.

**Macro name:** livesearch

**Macro body:** None.

**Storage format example**

```xml
<ac:structured-macro ac:name="livesearch">
  <ac:parameter ac:name="additional">page excerpt</ac:parameter>
  <ac:parameter ac:name="placeholder">Search this space</ac:parameter>
  <ac:parameter ac:name="labels">myLabel</ac:parameter>
  <ri:space ri:space-key="SS"/>
  <ac:parameter ac:name="type">page</ac:parameter>
  <ac:parameter ac:name="size">large</ac:parameter>
</ac:structured-macro>
```

**Wikimarkup example**

```
{livesearch:spaceKey=DOC|size=large|placeholder=Search this space}
```

**Loremipsum Macro**

The Loremipsum macro displays paragraphs of pseudo-Latin text ([more information](#)). You can use this macro to generate more-or-less meaningless text for demonstration purposes in pages showing a draft layout or arrangement of page elements. The text is deliberately non-meaningful so that it does not influence the viewer's perception of the page arrangement or design.

A basic example of the Loremipsum text:

```
```

**Using the Loremipsum macro**

To add the Loremipsum macro to a page:

1. In the Confluence editor, choose **Insert > Other Macros**.
2. Find and select the required macro.
Speeding up macro entry with autocomplete: Type `{` and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

Parameters

Parameters are options that you can set to control the content or format of the macro output. Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Number of Paragraphs</td>
<td>3</td>
<td>Determines the amount of pseudo-Latin (space-filler) text to display. The macro will display a maximum number of 30 paragraphs. Parameter is unnamed in storage format and wikimarkup.</td>
</tr>
</tbody>
</table>

Code examples

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a Confluence page.

Macro name: loremipsum

Macro body: None.

Storage format example

```xml
<ac:structured-macro ac:name="loremipsum">
  <ac:parameter ac:name="">2</ac:parameter>
</ac:structured-macro>
```

Wikimarkup example

```
(loremipsum:2)
```

Multimedia Macro

The multimedia macro is used to embed attached video, animation and other multimedia files on a Confluence page.

Confluence supports the following multimedia formats:

- Adobe Flash (.swf)
- Apple QuickTime (.mov)
- Windows Media (.wma, .wmv)
- Real Media (.rm, .ram)
- MP3 and MP4 files (.mp3, .mp4)
- MPEG files (.mpeg, .mpg)
- AVI files (.avi) You may need to enable an avi decoder within your browser.

See the Widget Connector Macro if you want to display online multimedia content, such as YouTube and Vimeo videos on a page.

To add the Multimedia macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.
**Speeding up macro entry with autocomplete:** Type `{` and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

**To edit an existing macro:** Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

You can also drag a supported multimedia file directly on to the page. Confluence will attach the file and add the macro for you.

**Parameters**

Parameters are options that you can set to control the content or format of the macro output. Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
<tbody>
<tr>
<td>Page Name</td>
<td>Yes</td>
<td>Current page</td>
<td>Name of the page to which the multimedia file is attached. Start typing the name of the page and then select it from list of suggested pages. Include the spacekey if you want to specify a page in another space (for example MYSPACE:My Page Title)</td>
</tr>
<tr>
<td>Attachment</td>
<td>Yes</td>
<td>None</td>
<td>File name of the attached multimedia file.</td>
</tr>
<tr>
<td>Width</td>
<td>No</td>
<td>If not specified, the browser will determine the width based on the file type.</td>
<td>Width of the movie window to be displayed on the page. By default, this value is specified in pixels. You can also choose to specify a percentage of the window's width, or any other value accepted by HTML.</td>
</tr>
<tr>
<td>Height</td>
<td>No</td>
<td>If not specified, the browser will determine the height based on the file type.</td>
<td>Height of the movie window to be displayed on the page. By default, this value is specified in pixels. You can also choose to specify a percentage of the window's height, or any other value accepted by HTML.</td>
</tr>
<tr>
<td>Autoplay</td>
<td>No</td>
<td>false</td>
<td>If the parameter is set to true then the video or audio file will start playing as soon as the page is loaded. If this option is set to false then the file will not play until the user clicks the icon or image on the page.</td>
</tr>
</tbody>
</table>

**Code examples**

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a Confluence page.

**Macro name:** multimedia

**Macro body:** None.

**Storage format example**
<ac:structured-macro ac:name="multimedia">
  <ac:parameter ac:name="width">500</ac:parameter>
  <ac:parameter ac:name="name">
    <ri:attachment ri:filename="Ninjas.MOV"/>
  </ac:parameter>
</ac:structured-macro>

Wikimarkup example

{multimedia:space=DOC|page=My macros|name=ninjas.swf|autostart=true}

Notes

- **You will need the relevant multimedia plugin for your browser.** Your browser may need a plugin to play the video or audio file on a Confluence page.
- **Autoplay may not always work as expected.** Some browsers may not autoplay the attached file.
- If you get the error, "Unable to embed content of type application/octet-stream", this means the MIME type is not recognised.
- **Advanced users can try styling via CSS.** By default, each embedded object is wrapped in a div tag. If you wish to style the div and its contents, override the embeddedObject CSS class. Specifying an ID as a property also allows you to style different embedded objects differently. CSS class names in the format embeddedObject-ID are used.

Navigation Map Macro

The Navigation Map macro displays a navigable map of the pages tagged with a given label.

Using the Navigation Map Macro

To add the Navigation Map macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

**Speeding up macro entry with autocomplete:** Type { and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

**To edit an existing macro:** Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

Parameters

Parameters are options that you can set to control the content or format of the macro output. Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Label</td>
<td>none</td>
<td>Specify the label associated with the pages you want to show in the navigation map. This parameter is unnamed in storage format and wikimarkup.</td>
</tr>
<tr>
<td>Map Title</td>
<td>none</td>
<td>Specify a title for the navigation map.</td>
</tr>
<tr>
<td>(title)</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
Number of Cells Per Row (wrapAfter) | 5 | Specify the number of cells in a row
---|---|---
Cell Width (Pixels) (cellWidth) | 90 px | Specify the cell width
Cell Height (Pixels) (cellHeight) | 60 px | Specify the cell height
Navigation Map Theme (theme) | Confluence | Define a theme for the navmap.

If you want to create your own navmap 'look and feel' (for example, one with rounded corners), you need to add a customised navmap macro theme file to the WEB-INF/classes/templates/macros directory. The file name convention to use is navmap-mytheme.vm. Use the name of your choice for the mytheme part of the file name, which is also the value you use for this parameter. Hence, if your theme was called navmap-roundededges.vm, use the value of roundededges for this parameter.

Code examples

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a Confluence page.

**Macro name:** navmap

**Macro body:** None.

**Storage format example**

```xml
<ac:structured-macro ac:name="navmap">
    <ac:parameter ac:name="wrapAfter">4</ac:parameter>
    <ac:parameter ac:name="title">My map name</ac:parameter>
    <ac:parameter ac:name="cellHeight">50px</ac:parameter>
    <ac:parameter ac:name="theme">navmap-mytheme.vm</ac:parameter>
    <ac:parameter ac:name="cellWidth">80px</ac:parameter>
    <ac:parameter ac:name="">mylabel</ac:parameter>
</ac:structured-macro>
```

**Wiki markup example**

```
{navmap:mylabel|wrapAfter=4|title=My map name|cellHeight=50px|theme=navmap-mytheme.vm|cellWidth=80px}
```

**Network Macro**

The Network macro displays a list of Network activity on a Confluence page or blog post. You can specify the user whose network activity you wish to show. These interactions include the users that the specified user is following or users who are following the specified user. The Network macro shows each listed user by their
profile picture. It also provides a choice of two themes and the ability to limit the number of users in the list.

Screenshot: Network macro

Using the Network macro

To add the Network macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Speeding up macro entry with autocomplete: Type { and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

Parameters

Parameters are options that you can set to control the content or format of the macro output. Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Username</td>
<td>Current user's username</td>
<td>The username of the Confluence user whose network interactions you wish to show. If no username is specified, then current user's (that is, your) network interactions are shown.</td>
</tr>
</tbody>
</table>
| Mode            | following                | Determines which users are listed, with respect to the specified user:  
|                 |                          | • following – those who the user is following.  
|                 |                          | • followers – those who are following the user.  
|                 |                          | This parameter is unnamed in storage format and wikimarkup. |
| Theme           | full                     | Determines how the user's network is displayed:  
|                 |                          | • full – shows a large version of user's profile pictures and, if the following mode is set, provides an entry field function to follow more users.  
|                 |                          | • tiny – shows only the small version of user's profile pictures. |
| Maximum Results | No limit imposed up to a maximum of 30 | Restricts the number of users displayed. If the number of users exceeds the specified maximum, then a Show All link is provided. This link leads to the specified user's Network view, showing the complete list of network interactions. |

Disabling the Network macro

The Network macro is provided by the 'network' module in the 'Profile Macros' plugin. To remove the macro from your site, you can disable the module in the plugin. See Disabling and enabling add-ons.

Code examples
The following examples are provided for advanced users who want to inspect or edit the underlying markup for a Confluence page.

**Macro name:** network

**Macro body:** None.

**Storage format example**

```
<ac:structured-macro ac:name="network">
<ac:parameter ac:name="username">
<ri:user ri:userkey="12345678912345678912345"/>
</ac:parameter>
<ac:parameter ac:name="max">10</ac:parameter>
<ac:parameter ac:name="theme">full</ac:parameter>
<ac:parameter ac:name="">followers</ac:parameter>
</ac:structured-macro>
```

**Wiki markup example**

```
{network:followers|username=admin|max=10|theme=full}
```

**Noformat Macro**

The Noformat macro displays a block of text in monospace font with no other formatting.

**Using the Noformat Macro**

**To add the Noformat macro to a page:**

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

**Speeding up macro entry with autocomplete:** Type `{ and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

**To edit an existing macro:** Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

Enter the content that is to be unformatted into the body of the macro placeholder.

**Parameters**

Parameters are options that you can set to control the content or format of the macro output. Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>No Panel</td>
<td>False</td>
<td>Removes the panel around the content.</td>
</tr>
</tbody>
</table>

**Code examples**

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a Confluence page.
Macro name: noformat

Macro body: Accepts plain text.

Storage format example

```xml
<ac:structured-macro ac:name="noformat">
  <ac:parameter ac:name="nopanel">true</ac:parameter>
  <ac:plain-text-body><![CDATA[http://www.example.com]]></ac:plain-text-body>
</ac:structured-macro>
```

Wiki markup example

```
{nopanel=true}http://www.example.com{nopanel}
```

Note Macro

The Note macro displays a block of text in a yellow highlighted box. This is useful for emphasising important information.

Example:

```
My note
This is the content of my note.
```

Using the Note Macro

To add the Note macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Speeding up macro entry with autocomplete: Type `{` and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

Add the text of the note to the body of the macro placeholder.

Parameters

Parameters are options that you can set to control the content or format of the macro output. Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Optional Title (title)</td>
<td>none</td>
<td>If specified, the title is displayed in bold next to the icon.</td>
</tr>
</tbody>
</table>
| Show Exclamation Mark Icon (icon) | true    | • true – displays the warning icon  
  • false – the icon is not displayed  |

Code examples
The following examples are provided for advanced users who want to inspect or edit the underlying markup for a Confluence page.

**Macro name:** note

**Macro body:** Accepts rich text.

**Storage format example**

```xml
<ac:structured-macro ac:name="note">
  <ac:parameter ac:name="icon">false</ac:parameter>
  <ac:parameter ac:name="title">My title</ac:parameter>
  <ac:rich-text-body>
    <p>This is the content of my note.</p>
  </ac:rich-text-body>
</ac:structured-macro>
```

**Wiki markup example**

```markdown
{note:icon=false|title=My title}
This is the content of my note.
{note}
```

**Office Excel Macro**

The Office Excel macro displays the content of an Excel spreadsheet on a wiki page. First attach the spreadsheet to a Confluence page, then use the macro to display the content. When viewing the page, people will see the content of the spreadsheet, without needing to have Office installed.

For details, see the View File Macro.

**Code examples**

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a Confluence page.

**Macro name:** viewxls

**Macro body:** None.

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
<tbody>
<tr>
<td>name</td>
<td>Yes</td>
<td>(None.)</td>
<td>The file name of the Excel spreadsheet to be displayed. The document must be attached to a page on your Confluence site.</td>
</tr>
<tr>
<td>page</td>
<td>No</td>
<td>The page containing the macro</td>
<td>The name of a Confluence page to which the Excel spreadsheet is attached.</td>
</tr>
<tr>
<td><strong>col</strong></td>
<td>No</td>
<td>Last column with content</td>
<td>The number of the last column you want displayed, starting from '0' as the first column. <strong>Hint for reducing the size of the spreadsheet:</strong> Use the <strong>col</strong> and <strong>row</strong> parameters to reduce the size of the spreadsheet displayed on the wiki page. This is especially useful to prevent the display from showing empty cells. This will also help to prevent 'out of memory' errors.</td>
</tr>
<tr>
<td>---</td>
<td>---</td>
<td>---</td>
<td>---</td>
</tr>
<tr>
<td><strong>row</strong></td>
<td>No</td>
<td>Last row with content</td>
<td>The number of the last row you want displayed, starting from '0' as the first row.</td>
</tr>
</tbody>
</table>
| **grid** | No | true | Determines whether the macro will show borders around the cells in the spreadsheet. 

**Accepted values:**

- **true** – Shows borders.
- **false** – Does not show borders. |
| **sheet** | No | The most-recently viewed worksheet | The name of the worksheet that you want displayed. |

**Storage format example**

```
<ac:structured-macro ac:name="viewxls">
  <ac:parameter ac:name="col" value="E"/>
  <ac:parameter ac:name="name">
    <ri:attachment ri:filename="Spreadsheet.xls"/>
  </ac:parameter>
  <ac:parameter ac:name="sheet" value="Sheet1"/>
  <ac:parameter ac:name="row" value="5"/>
</ac:structured-macro>
```

**Wiki markup example**

```
{viewxls:col=5|page=Docs|name=My document.xls|grid=false|sheet=mysheet|row=5}
```

**Office PowerPoint Macro**

The Office PowerPoint macro displays the content of a PowerPoint presentation on a wiki page. First attach the presentation to a Confluence page, then use the macro to display the content. When viewing the page, people will see the content of the presentation, without needing to have Office installed.

For details, see the View File Macro.

**Code examples**

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a Confluence page.

**Macro name:** `viewppt`

**Macro body:** None.
## Parameter name, Required, Default, Parameter description and accepted values

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
<tbody>
<tr>
<td>name</td>
<td>Yes</td>
<td>(None.)</td>
<td>The file name of the PowerPoint presentation to be displayed. The document must be attached to a page on your Confluence site.</td>
</tr>
<tr>
<td>page</td>
<td>No</td>
<td>The page containing the macro</td>
<td>The name of a Confluence page to which the PowerPoint presentation is attached.</td>
</tr>
<tr>
<td>height</td>
<td>No</td>
<td></td>
<td>The height of the macro display, specified in pixels (for example: 10 px, or just 10) or as a percentage (for example: 20%) of the window's height.</td>
</tr>
<tr>
<td>width</td>
<td>No</td>
<td></td>
<td>The width of the macro display, specified in pixels (for example: 10 px, or just 10) or as a percentage (for example: 20%) of the window's height.</td>
</tr>
<tr>
<td>slide</td>
<td>No</td>
<td>All slides, starting with the first, as a slide show</td>
<td>The number of the slide that you want displayed on the Confluence page, where the first slide is numbered zero. Instead of a slide show, the page will display just the single slide, represented as a JPEG image.</td>
</tr>
</tbody>
</table>

### Storage format example

```xml
<ac:structured-macro ac:name="viewppt">
  <ac:parameter ac:name="height">250</ac:parameter>
  <ac:parameter ac:name="width">250</ac:parameter>
  <ac:parameter ac:name="name">
    <ri:attachment ri:filename="101_samplepresentation.pptx"/>
  </ac:parameter>
</ac:structured-macro>
```

### Wiki markup example

```
{viewppt:height=20%|page=Docs|width=20%|name=My document.ppt|slide=4}
```

### Office Word Macro

The Office Word macro displays the content of a Word document on a wiki page. First attach the document to a Confluence page, then use the macro to display the content. When viewing the page, people will see the content of the document, without needing to have Office installed.

For details, see the View File Macro.

### Code examples

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a Confluence page.

**Macro name:** viewdoc

**Macro body:** None.
### Parameter name

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
<tbody>
<tr>
<td>name</td>
<td>Yes</td>
<td>(None.)</td>
<td>The file name of the Word document to be displayed. The document must be attached to a page on your Confluence site.</td>
</tr>
<tr>
<td>page</td>
<td>No</td>
<td>The page containing the macro</td>
<td>The name of a Confluence page to which the Word document is attached.</td>
</tr>
</tbody>
</table>

**Storage format example**

```xml
<ac:structured-macro ac:name="viewdoc">
  <ac:parameter ac:name="name">
    <ri:attachment ri:filename="Chocolate.doc"/>
  </ac:parameter>
</ac:structured-macro>
```

**Wiki markup example**

```
{viewdoc:page=Docs|name=My document.doc}
```

### Page Index Macro

The Page Index macro creates a hyperlinked alphabetical index of all page titles within the current space.

The top section of the index contains a cell for each letter of the alphabet, with cells for numbers and symbols. Each cell indicates how many pages are in the corresponding list.

The lower section contains lists of page titles followed by the first few sentences of content on that page.

Each letter, number or symbol in the top section is hyperlinked to the corresponding cell in the lower section. Each page title in the lower section is hyperlinked to the page in the space.

**Screenshot: Page Index macro (partial view)**
Using the Page Index macro

To add the Page Index macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.
**Speeding up macro entry with autocomplete:** Type `{` and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

**To edit an existing macro:** Click the macro placeholder and choose **Edit**. A macro dialog window will open, where you can edit the parameters of the macro.

This macro accepts no parameters.

---

**Code examples**

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a Confluence page.

**Macro name:** index

**Macro body:** None.

**Parameters:** None.

**Storage format example**

```
<ac:structured-macro ac:name="index"/>
```

**Wiki markup example**

```
{index}
```

---

**Page Properties Macro**

The Page Properties and Page Properties Report macro work together to enable you to show summary information from one page on another page. You can see examples of these two macros in action in the Decisions Blueprint and Product Requirements blueprints.

This macro was previously known as the Metadata Details macro.

**Adding the Page Properties macro to a page**

The Page Properties macro uses key value pairs. The body of the macro must be set up correctly for your information to appear in the Page Properties Report.

To add the Page Properties macro to a page:

1. In the editor, choose **Insert > Other Macros > Page Properties**.
2. In the macro body create a two column table and remove the header row.
3. In the left column list your 'keys' - these will be the column headings in your report table.
4. In the right column list the value for each key - these will populate the rows in your report table.
5. Add a **label** to your page - you will need to specify this label in the page properties report macro.
6. Save your page.

---

**On this page:**
- Adding the Page Properties macro to a page
- Using multiple Page Properties macros on one page
- Parameters
- Code examples

**Related pages:**
- Page Properties Report Macro
- Decisions Blueprint
- Product Requirements Blueprint
Don’t forget to add a label to your page, or your page will not appear in the Page Properties Report macro.

Next you need to add the Page Properties Report macro to another page.

Screenshot: Page Properties macro in the editor. Deadline, Current Status and Team will be column headings in the report.

Screenshot: The example above as it appears in the Page Properties Report

Using multiple Page Properties macros on one page

You can add multiple Page Properties macros on a single page, and choose whether to include all or only specific macros in the report. You might use multiple macros because you want the information in the macro to display in context with the rest of the page, or because you want to be able to report on individual Page Properties macros separately.

The Page Properties macro includes an optional ID parameter that can be used to identify specific Page Properties macros.

To show the contents of all Page Properties macros in the report:

- Add a label to the page containing the Page Properties macros.
- Specify this label in the Page Properties Report macro.

To show the contents of selected Page Properties macros in the report:

- Add a label to the page containing the Page Properties macros.
- Specify an ID in the Page Properties macro that you want to report on.
- Specify both the label and ID in the Page Properties Report macro.

Note: The Page Properties Report macro can only accept one page label, and one ID.
Parameters

Parameters are options that you can set to control the content or format of the macro output. Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Page Properties ID</td>
<td>(None)</td>
<td>Optional ID used to identify a particular Page Properties macro on a page. Specify this ID in the Page Properties Report to include summary information from macros with this ID only.</td>
</tr>
<tr>
<td>Hidden</td>
<td>False</td>
<td>Determines whether the data in the Page Properties macro will be displayed on the current page. This setting does not affect the display of the detail in the Page Properties Report macro.</td>
</tr>
</tbody>
</table>

Code examples

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a Confluence page.

**Macro name:** details

**Macro body:** Accepts rich text.

**Storage format example**

The following example contains two pieces of data - Owner and Date.

```xml
<ac:structured-macro ac:name="details">
  <ac:rich-text-body>
    <table>
      <tbody>
        <tr>
          <td>Owner</td>
          <td>Rach Admin</td>
        </tr>
        <tr>
          <td>Date</td>
          <td>1 May</td>
        </tr>
      </tbody>
    </table>
  </ac:rich-text-body>
</ac:structured-macro>
```

**Notes**

- You cannot use text formatting or macros in the left column as the data in this column is used to populate the column headings in your Page Properties Report macro.
- If your table has a header row, this row will be ignored by the Page Properties Report macro. You should remove the header row.
- It is not possible to reference the metadata using the metadata key from within the page, or anywhere else on a Confluence page.

**Page Properties Report Macro**

The Page Properties and Page Properties Report macro work together to enable you to show summary information from one page on another page. You can see examples of these two macros in action on the Decision and Product Requirements blueprints.

This macro was previously known as the Details Summary macro.
Adding the Page Properties Report macro to a page

To add the Page Properties Report macro to a page:

1. In the editor, choose Insert > Other Macros > Page Properties Report.
2. Enter the Label you want to report on - this is the label added to pages containing the Page Properties macro.
3. Restrict the report by ID, space or specify column headings or sort order - see the Parameters table below for more details.
4. Choose Insert.

Note: If your report is empty, check:

- You have specified the label correctly and the label appears on pages containing the Page Properties macros.
- The Page Properties macros on each page are configured correctly.

Screenshot: Page Properties Report

Reporting on specific Page Properties macros

You can add multiple Page Properties macros on a page, and choose whether to include all or only specific macros in the report. The Page Properties macro includes an optional ID parameter that can be used to identify specific Page Properties macros.

To show the contents of:

- All Page Properties macros in the report - specify just the label for the page.
- Selected Page Properties macros in the report - specify both the label for the page and the ID of the particular Page Properties macro.
Note: The Page Properties Report macro can only accept one page label, and one ID.

Parameters

Parameters are options that you can set to control the content or format of the macro output. Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Label</td>
<td>(None)</td>
<td>Identifies the label to be used in the Page Properties Report. The report will show data from all pages in the current space containing a Page Properties macro with the same label.</td>
</tr>
<tr>
<td>Page Properties ID</td>
<td>(None)</td>
<td>If not specified, the report will show data from all Page Properties macros on a page, where there are multiple macros. Specify an ID to include only data from Page Properties macros with the same ID.</td>
</tr>
<tr>
<td>Restrict to spaces</td>
<td>(None)</td>
<td>If not specified, the report will only show data from the current space. You can specify a comma separated list of space keys, or use @all to show data from all spaces.</td>
</tr>
<tr>
<td>Title column heading</td>
<td>Title</td>
<td>The heading to display on the first column in the report table. This column contains links to pages displayed by the report. The default column heading is 'Title'.</td>
</tr>
<tr>
<td>Columns to show</td>
<td>(None)</td>
<td>If not specified, the report will show all columns. You can specify a comma separated list of columns to include. If your column heading includes commas, use double quotes around the column name. If your column heading includes quotes, use double quotes. For example, A column, &quot;My &quot;new&quot; column, yes&quot;, Third column</td>
</tr>
<tr>
<td>Number of items to display</td>
<td>30</td>
<td>Number of items to display in the table before displaying pagination options for additional items.</td>
</tr>
<tr>
<td>Sort by</td>
<td>Last modified date</td>
<td>Sort the table by a specific column heading. Enter the column name, exactly as it appears in the corresponding Page Properties macro. Select the Reverse Sort check box to sort the table in reverse order.</td>
</tr>
<tr>
<td>Show Comments Count</td>
<td>No</td>
<td>Displays the number of comments for each page in the table.</td>
</tr>
<tr>
<td>Show Likes Count</td>
<td>No</td>
<td>Displays the number of likes for each page in the table.</td>
</tr>
</tbody>
</table>

Code examples

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a Confluence page.

Macro name: detailssummary

Macro body: None.

Storage format example
Page Tree Macro

The Page Tree macro displays a dynamic, hierarchical list of pages starting from a specified parent (root) page. It can act as a table of contents or a list of related topics. When viewing the page tree, your reader can click a link to view the relevant page. The page's current position is highlighted in the page tree.

**Note:** The Page Tree macro is used in the Confluence Documentation theme, to create a navigation panel showing a table of contents for your space. Read the instructions on Configuring the Documentation Theme.

Using the Page Tree Macro

**To add the Page Tree macro to a page:**

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

**Speeding up macro entry with autocomplete:** Type `{` and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

**To edit an existing macro:** Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

Click Refresh in the Macro Browser to see the effect of changes to the macro parameters.

Macro Parameters

Parameters are options that you can set to control the content or format of the macro output. Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
</table>
| Root Page     | The home page of the space| Specify the parent page for the page tree. The tree will include all children of the given page, plus their children and grand-children etc. The tree will *not* include the root page itself. Specify the page title or a special value as follows:  
  - Your page title — to specify a page name for the parent or root of the tree. The tree will include all children and grand-children of the specified root. The tree will *not* include the specified root page itself.  
  - '@home' — will include all pages under the home page of the space (default).  
  - '@self' — will include all pages under the current page.  
  - '@parent' — will include all pages under the parent of the current page, including the current page.  
  - '@none' — will include all pages in the space, including orphaned pages and the home page. |
<table>
<thead>
<tr>
<th>Feature</th>
<th>Value</th>
<th>Description</th>
</tr>
</thead>
</table>
| **Sort Pages By** (sort)                     | position | Specify the order to display the pages in the tree. This sort order is for display purposes only. It does not permanently re-arrange the page order. The value may be one of the following:  
  - bitwise — sort alphabetically, for example: title1, title10, title2.  
  - creation — sort by date of creation.  
  - modified — sort by order of date last modified.  
  - natural — sort in 'natural' alphabetical order, for example: title1, title2, title10.  
  - position — sort by the default Confluence sorting rules. If your pages have been ordered manually, this sort will respect the defined order. Otherwise the pages will be displayed in the 'natural' alphabetical order, such as: title1, title2, title10. |
| **Include Excerpts in Page Tree** (excerpt)  | false | Select if you want the page tree to show excerpts from each page. The excerpts must be defined on each page by the Excerpt macro. |
| **Reverse Order** (reverse)                  | false | Select to show the pages in reverse (descending) natural order. Must be used in combination with the **Sort Pages By** parameter. |
| **Include Search Box above Page Tree** (searchBox) | false | Select if you want to include a search box above the page tree. The search box allows your readers to search within the page tree for the specified value. |
| **Show Expand/Collapse Links** (expandCollapseAll ) | false | Select if you want to display the ‘expand all’ and ‘collapse all’ links at the top of your page tree. Your readers can click these links to open or close all branches of the tree at once.  
Available values in wikimarkup and storage format:  
  - true — Show the 'expand all' and 'collapse all' options.  
  - false — Do not show the options. |
| **Start Depth** (startDepth)                 | 1     | Enter any number greater than 0 to set how many levels of children the tree should show when it opens for the first time. |

**Code examples**

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a Confluence page.

**Macro name:** pagetree

**Macro body:** None.

**Storage format example**

```
<ac:structured-macro ac:name="pagetree">
  <ac:parameter ac:name="reverse">false</ac:parameter>
  <ac:parameter ac:name="sort">natural</ac:parameter>
  <ac:parameter ac:name="root">
    <ac:link>
      <ri:page ri:content-title="Page Name"/>
    </ac:link>
  </ac:parameter>
  <ac:parameter ac:name="startDepth">3</ac:parameter>
  <ac:parameter ac:name="excerpt">true</ac:parameter>
  <ac:parameter ac:name="searchBox">true</ac:parameter>
  <ac:parameter ac:name="expandCollapseAll">true</ac:parameter>
</ac:structured-macro>
```
Wiki markup example

{pagetree:root=Page
  Name|sort=natural|excerpt=true|reverse=false|startDepth=3|expandCollapseAll=true|searchBox=true}

Sample Page Tree

This page is a sample, used to demonstrate the Pagetree macro.

For more information, take a look at the main page on the Page Tree Macro.

<table>
<thead>
<tr>
<th>What you need to type</th>
<th>What you will get</th>
</tr>
</thead>
<tbody>
<tr>
<td>{pagetree:root=@parent</td>
<td>expandCollapseAll=false}</td>
</tr>
</tbody>
</table>

Another Sample Page Tree

We're using this page to demonstrate the Pagetree macro.

For more information, take a look at the main page on the Page Tree Macro.

<table>
<thead>
<tr>
<th>What you need to type</th>
<th>What you will get</th>
</tr>
</thead>
<tbody>
<tr>
<td>{pagetree:root=@parent</td>
<td>expandCollapseAll=true}</td>
</tr>
<tr>
<td></td>
<td>Collapse all</td>
</tr>
</tbody>
</table>

Sample Page Tree 2

This is another sample page, used to demonstrate the Pagetree macro.

For more information, take a look at the main page on the Page Tree Macro.

<table>
<thead>
<tr>
<th>What you need to type</th>
<th>What you will get</th>
</tr>
</thead>
<tbody>
<tr>
<td>{pagetree:root=@parent</td>
<td>expandCollapseAll=true}</td>
</tr>
<tr>
<td></td>
<td>Collapse all</td>
</tr>
</tbody>
</table>

Page Tree Search Macro

Using the Page Tree Search macro, you can add a search box to your Confluence page. When a viewer enters a search term, Confluence will search a hierarchy of pages starting from a specified parent (root) page and return the search results.

You can also add a search box as part of a dynamic page tree, which looks like a table of contents. See the Page Tree macro.

Using the Page Tree Search macro

To add the Page Tree Search macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Speeding up macro entry with autocomplete: Type {} and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.
Parameters are options that you can set to control the content or format of the macro output. Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name of Root Page</td>
<td>none</td>
<td>The name of the root page whose hierarchy of pages will be searched by this macro. If this not specified, the root page is the current page. Note: Unlike the Page Tree macro, the Page Tree Search macro does not accept the special values that start with an @ sign, such as @home or @self.</td>
</tr>
</tbody>
</table>

Code examples

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a Confluence page.

**Macro name:** pagetreesearch

**Macro body:** None.

**Storage format example**

```xml
<ac:structured-macro ac:name="pagetreesearch">
  <ac:parameter ac:name="root">My page name</ac:parameter>
</ac:structured-macro>
```

**Wikimarkup example**

```
{pagetreesearch:root=My page name}
```

**Panel Macro**

The Panel macro displays a block of text within a customisable panel, like a text box.

**Handy hint:** You can use panels within columns, in table cells and in the sections defined by page layouts.

Here is an example of a Panel macro:

```
My Title
```

**A formatted panel.**

Using the Panel macro

**To add the Panel macro to a page:**

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

**Speeding up macro entry with autocomplete:** Type { and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

**To edit an existing macro:** Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

**Parameters**

Parameters are options that you can set to control the content or format of the macro output. Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro
browser, it will be listed below in brackets (example).

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Panel Title (title)</td>
<td>none</td>
<td>The title of the panel. If specified, this title will be displayed in its own title row.</td>
</tr>
<tr>
<td>Border Style (borderStyle)</td>
<td>solid</td>
<td>The style of the panel's border. Accepted values are solid, dashed and other valid CSS border styles.</td>
</tr>
<tr>
<td>Border Colour (borderColor)</td>
<td></td>
<td>The colour of the panel's border. Colours can be specified as HTML colour names or hexadecimal codes.</td>
</tr>
<tr>
<td>Border Pixel Width (Value Only) (borderWidth)</td>
<td></td>
<td>The width of the panel's border (in pixels).</td>
</tr>
<tr>
<td>Background Colour (bgColor)</td>
<td></td>
<td>The background colour of the panel. Colours can be specified as HTML colour names or hexadecimal codes.</td>
</tr>
<tr>
<td>Title Background Colour (titleBGColor)</td>
<td></td>
<td>The background colour of the title row of the panel. Colours can be specified as HTML colour names or hexadecimal codes.</td>
</tr>
<tr>
<td>Title Text Colour (titleColor)</td>
<td></td>
<td>The colour of the text in the title row of the panel. Colours can be specified as HTML colour names or hexadecimal codes.</td>
</tr>
</tbody>
</table>

Code examples

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a Confluence page.

**Macro name:** panel

**Macro body:** Accepts rich text.

**Storage format example**

```xml
<ac:structured-macro ac:name="panel">
  <ac:parameter ac:name="bgColor">#72bc72</ac:parameter>
  <ac:parameter ac:name="titleBGColor">#00a400</ac:parameter>
  <ac:parameter ac:name="title">My title</ac:parameter>
  <ac:parameter ac:name="borderStyle">dashed</ac:parameter>
  <ac:parameter ac:name="borderColor">blue</ac:parameter>
  <ac:parameter ac:name="titleColor">white</ac:parameter>
  <ac:rich-text-body>
    <p>A formatted panel</p>
  </ac:rich-text-body>
</ac:structured-macro>
```

**Wiki markup example**

```markdown
{panel:title=My title|borderStyle=dashed|borderColor=blue|titleBGColor=#00a400|titleColor=white|bgColor=#72bc72}
A formatted panel
```

Created in 2015 by Atlassian. Licensed under a Creative Commons Attribution 2.5 Australia License.
PDF Macro

The PDF macro displays the content of a PDF document on a page. First attach the document to a Confluence page, then use the macro to display the document.

For details, see the View File Macro.

Code examples

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a Confluence page.

**Macro name:** viewpdf

**Macro body:** None.

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
<tbody>
<tr>
<td>name</td>
<td>Yes</td>
<td>(None.)</td>
<td>The file name of the PDF document to be displayed. The document must be attached to a page on your Confluence site.</td>
</tr>
<tr>
<td>page</td>
<td>No</td>
<td>The page containing the macro</td>
<td>The name of a Confluence page to which the PDF document is attached.</td>
</tr>
</tbody>
</table>

Storage format example

```
<ac:structured-macro ac:name="viewpdf">
    <ac:parameter ac:name="name">
        <ri:attachment ri:filename="My_document.pdf"/>
    </ac:parameter>
</ac:structured-macro>
```

Wiki markup example

```
{viewpdf:page=Docs|name=My document.pdf}
```

Popular Labels Macro

The Popular Labels macro displays the most popular labels used throughout your Confluence site or within a space. A popular label is a label that has been added to many pages.

Using the Popular Labels Macro

**To add the Popular Labels macro to a page:**

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

**Speeding up macro entry with autocomplete:** Type { and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

**To edit an existing macro:** Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.
Parameters

Parameters are options that you can set to control the content or format of the macro output. Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Number of Labels to Display (count)</td>
<td>100</td>
<td>Specifies the total number of labels to display in the heatmap.</td>
</tr>
<tr>
<td>Restrict Labels to this Space Key (spaceKey)</td>
<td>none</td>
<td>Restricts the list of popular labels to the specified space.</td>
</tr>
</tbody>
</table>
| Style of Labels (style)            | list    | • list – displays the popular labels as a bulleted list, ordered by popularity (highest first).
|                                    |         | • heatmap – displays the popular labels using different font sizes for each label depending on the label's popularity, ordered by label names. |

Code examples

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a Confluence page.

**Macro name**: popular-labels

**Macro body**: None.

**Storage format example**

```xml
<ac:structured-macro ac:name="popular-labels">
  <ac:parameter ac:name="count">20</ac:parameter>
  <ac:parameter ac:name="spaceKey">
    <ri:space ri:space-key="ds"/>
  </ac:parameter>
</ac:structured-macro>
```

**Wikimarkup example**

```wikimarkup
{popular-labels:style=heatmap|count=20|spaceKey=ds}
```

Profile Picture Macro

You can use the Profile Picture macro to display a user's profile picture on a page, and it's useful for things like creating team pages that show all members of a project team.

Hover your mouse-over the picture to see the Hover Profile for the user, and choose the user's picture or name to view their user profile. When editing the page, you can also select the macro and choose View User Profile to see the profile for the user.

Add the Profile Picture Macro

1. In the Confluence editor, choose **Insert > Oth**
**Profile Macros**

1. Find and select the 'Profile picture' macro
2. Search for and select the user and choose Save

**Speeding up macro entry with autocomplete:** Type `{` and the beginning of the macro name, then select the macro from a list of suggested macros. For more information, see Using Autocomplete.

**Code examples**

The following example is provided for advanced users who want to inspect or edit the underlying markup for a Confluence page.

**Macro name:** profile-picture

**Macro body:** None.

**Storage format example**

```xml
<ac:structured-macro ac:name="profile-picture">
   <ac:parameter ac:name="User">
      <ri:user ri:userkey="12345678912345678912345678912345"/>
   </ac:parameter>
</ac:structured-macro>
```

**Wiki markup**

Wiki markup is not available for this macro. You cannot add this macro via wiki markup.

**Recently Updated Dashboard Macro**

The Recently Updated Dashboard macro displays a list of the most recently changed content within Confluence. It is similar to the Recently Updated macro but is intended for use on the Confluence dashboard.
Using the Recently Updated Dashboard macro

To add the Recently Updated Dashboard macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Speeding up macro entry with autocomplete: Type `{` and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

Parameters

Parameters are options that you can set to control the content or format of the macro output. Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Space(s) (spaces)</td>
<td>The space which contains the page on which the macro is added</td>
<td>Filter content by space. The macro will display only the pages etc which belong to the space(s) you specify here. You can specify one or more space keys, separated by commas. &quot;*&quot; means all spaces.</td>
</tr>
<tr>
<td>Include these Content Types Only (types)</td>
<td>all types</td>
<td>Filter content by type. You can specify one or more types, separated by commas. Available types are: page, blogpost or news, spacedesc, attachment, comment, mail, userinfo.</td>
</tr>
<tr>
<td>Label(s) (labels)</td>
<td>none</td>
<td>Filter content by label. The macro will display only the pages etc which are tagged with the label(s) you specify here. You can specify one or more labels, separated by commas. Note: If there are no pages matching any of the specified labels, then Confluence will ignore the labels and will list all recently updated pages, as well as showing a message, “These labels don’t exist and were ignored: xxx ”. This unexpected behaviour is noted in issue <a href="CONF-13860">CONF-13860 - recently-updated-dashboard macro doesn’t return an empty result when no pages match the specified label(s)</a> [RESOLVED]</td>
</tr>
<tr>
<td>User(s) (users)</td>
<td>all users</td>
<td>Filter by username of the user who updated the content. The macro will only display content created and updated by the user(s) you specify here. You can specify one or more usernames separated by commas.</td>
</tr>
<tr>
<td>Width of Table (width)</td>
<td>100%</td>
<td>Specify the width of the macro display, as a percentage of the window width.</td>
</tr>
<tr>
<td>Show User Profile Pictures (showProfilePic)</td>
<td>false</td>
<td>Select whether profile pictures of the users who updated the content are displayed.</td>
</tr>
</tbody>
</table>

Code examples

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a Confluence page.
**Macro name:** recently-updated-dashboard

**Macro body:** None.

### Storage format example

```xml
<ac:structured-macro ac:name="recently-updated-dashboard">
  <ac:parameter ac:name="spaces">
    <ri:space ri:space-key="ss"/>
  </ac:parameter>
  <ac:parameter ac:name="users">
    <ri:user ri:userkey="12345678912345678912345"/>
  </ac:parameter>
  <ac:parameter ac:name="width">50%</ac:parameter>
  <ac:parameter ac:name="labels">choc</ac:parameter>
  <ac:parameter ac:name="types">page</ac:parameter>
</ac:structured-macro>
```

### Wiki markup example

```
{recently-updated-dashboard:spaces=ds|users=admin|width=50%|showProfilePic=true|labels=choc|types=page}
```

### Recently Updated Macro

The Recently Updated macro displays a list of the most recently changed content within Confluence.

#### Using the Recently Updated Macro

**To add the Recently Updated macro to a page:**

1. In the Confluence editor, choose **Insert > Other Macros**.
2. Find and select the required macro.

**Speeding up macro entry with autocomplete:** Type `{ and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

**To edit an existing macro:** Click the macro placeholder and choose **Edit**. A macro dialog window will open, where you can edit the parameters of the macro.

### Parameters

Parameters are options that you can set to control the content or format of the macro output. Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Author(s) by username</strong> (author)</td>
<td>None specified. That is, display all content</td>
<td>Filter the results by author. The macro will display only the pages etc which were last modified by the author(s) you specify here. You can specify multiple users.</td>
</tr>
<tr>
<td><strong>Space(s)</strong> (spaces)</td>
<td><code>@self</code></td>
<td></td>
</tr>
<tr>
<td>-----------------------</td>
<td>----------</td>
<td></td>
</tr>
<tr>
<td>That is, the space which contains the page on which the macro is used</td>
<td>This parameter allows you to filter content by space. The macro will display only the pages etc which belong to the space(s) you specify here. You can specify one or more space keys, separated by a comma or a space.</td>
<td></td>
</tr>
<tr>
<td></td>
<td>• To exclude content in a specific space, put a minus sign (-) immediately in front of that space key. For example: If you specify a space key of -BADSPACE you will get only content which is not in the BADSPACE.</td>
<td></td>
</tr>
<tr>
<td></td>
<td>• To indicate that the results <strong>must</strong> come from a specific space, put a plus sign (+) immediately in front of that space key. For example: If you specify a space key of +GOODSPACE you will get only content in GOODSPACE. (Note that this is not particularly useful, because each content item belongs to one space only. If you put a plus sign next to one space key and list other space keys too, the other space keys will be ignored.)</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Special values:</td>
<td></td>
</tr>
<tr>
<td></td>
<td>• <code>@self</code> — The current space.</td>
<td></td>
</tr>
<tr>
<td></td>
<td>• <code>@personal</code> — All personal spaces.</td>
<td></td>
</tr>
<tr>
<td></td>
<td>• <code>@global</code> — All site spaces.</td>
<td></td>
</tr>
<tr>
<td></td>
<td>• <code>@favorite</code> — The spaces you have marked as <strong>favourite</strong>.</td>
<td></td>
</tr>
<tr>
<td></td>
<td>• <code>@favourite</code> — The same as <code>@favorite</code> above.</td>
<td></td>
</tr>
<tr>
<td></td>
<td>• <code>@all</code> — All spaces in your Confluence site.</td>
<td></td>
</tr>
<tr>
<td></td>
<td>• <code>*</code> — The same as <code>@all</code> above.</td>
<td></td>
</tr>
<tr>
<td></td>
<td>When specifying a personal space, remember to use the tilde (~) sign in front of the username, such as ~jbloggs or ~<a href="mailto:jbloggs@example.com">jbloggs@example.com</a>.</td>
<td></td>
</tr>
<tr>
<td><strong>Label(s)</strong> (labels)</td>
<td>None specified i.e. display all content</td>
<td>Filter the results by label. The macro will display only the pages etc which are tagged with the label(s) you specify here. You can specify one or more label values, separated by a comma or a space.</td>
</tr>
<tr>
<td></td>
<td>• To exclude content which matches a given label, put a minus sign (-) immediately in front of that label value. For example: If you specify a label value of -badpage you will get only content which is not labelled with 'badpage'.</td>
<td></td>
</tr>
<tr>
<td></td>
<td>• To indicate that the results <strong>must</strong> match a given label value, put a plus sign (+) immediately in front of that label value. For example: If you specify a label value of +superpage,+goodpage you will get only content which has at least two labels, being 'superpage' and 'goodpage'.</td>
<td></td>
</tr>
<tr>
<td></td>
<td>The labels parameter only applies to the <strong>page</strong> and <strong>blog</strong> content types.</td>
<td></td>
</tr>
<tr>
<td><strong>Width of Table</strong> (width)</td>
<td>100%</td>
<td>Specify the width of the macro display, as a percentage of the window width.</td>
</tr>
</tbody>
</table>
## Include these Content Types Only (types)

<table>
<thead>
<tr>
<th>All types</th>
<th>This parameter allows you to filter content by content type. The macro will display only the content of the type you specify here. You can specify one or more types, separated by a comma or a space. To exclude content of a given content type, put a minus sign (-) immediately in front of that content type. For example: If you specify a content type of -blogpost you will get pages and all other content except for blog posts. Available values:</th>
</tr>
</thead>
<tbody>
<tr>
<td>page — Pages.</td>
<td>blogpost or news — Blog posts, also known as news items.</td>
</tr>
<tr>
<td>comment — Comments on pages and blog posts.</td>
<td>attachment — Attachments.</td>
</tr>
<tr>
<td>status — Status updates made by other users.</td>
<td></td>
</tr>
</tbody>
</table>

## Maximum Number of Results (max)

| 15 | Specify the maximum number of results to be displayed. If this parameter is omitted, then a maximum of 15 results are displayed. The theoretical maximum value that this parameter can accept is 2 to the power of 31, minus 1 (or 2147483647), though this has been limited to 200 in the code, for performance reasons. More details are here. |

## theme (theme)

<table>
<thead>
<tr>
<th>concise</th>
<th>Choose the appearance of this macro:</th>
</tr>
</thead>
<tbody>
<tr>
<td>concise — the default list, showing the names of pages which were updated or commented on, the users who made the page modifications and time when the modifications occurred.</td>
<td>social — lists recent modifications in reverse chronological order, but groups them by user into short time segments. A 'sub' list appears within each user's time segment, showing the names of pages which they updated or commented on and time when these modifications occurred.</td>
</tr>
<tr>
<td>sidebar — lists recent updates in reverse chronological order, showing the names of pages which were updated or commented on and time when the page modifications occurred. This theme does not show authorship.</td>
<td></td>
</tr>
</tbody>
</table>

## Show User Profile Pictures (showProfilePic)

| false | Specify showProfilePic=true to display the profile pictures of the users who updated the content. |

## Hide Title (hideHeading)

<table>
<thead>
<tr>
<th>False</th>
<th>Determines whether the macro hides or displays the text 'Recently Updated' as a title above the list of content. Only available in wikimarkup and storage format. Accepted values:</th>
</tr>
</thead>
<tbody>
<tr>
<td>true — Title is hidden.</td>
<td>false — Title is shown.</td>
</tr>
</tbody>
</table>

### Notes

- The **Recently Updated Dashboard macro** is similar to this macro, but is intended for display on the Confluence dashboard. **If you would like to change the wording displayed by the Recently Updated macro, please refer to the document on modifying the Confluence interface text.**

### Code examples
The following examples are provided for advanced users who want to inspect or edit the underlying markup for a Confluence page.

**Macro name:** recently-updated

**Macro body:** None.

**Storage format example**

```xml
<ac:structured-macro ac:name="recently-updated">
<ac:parameter ac:name="spaces">
  <ri:space ri:space-key="ss"/>
</ac:parameter>
<ac:parameter ac:name="author">
  <ri:user ri:userkey="12345678912345678912345"/>
</ac:parameter>
<ac:parameter ac:name="users"/>
<ac:parameter ac:name="max">10</ac:parameter>
<ac:parameter ac:name="width">50%</ac:parameter>
<ac:parameter ac:name="theme">sidebar</ac:parameter>
<ac:parameter ac:name="labels">choc</ac:parameter>
<ac:parameter ac:name="types">page</ac:parameter>
</ac:structured-macro>
```

**Wikimarkup example**

```
{recently-updated:spaces=ds|author=admin|max=10|hideHeading=true|width=50%|theme=sidebar|showProfilePic=true|labels=choc|types=page}
```

**Recently Used Labels Macro**

The Recently Used Labels macro displays a list of the labels that have been most recently added to a page, blog post or attachment. You can define the number of labels to be displayed and the scope (the current space, your personal space or site spaces, also known as 'global' spaces).

**Using the Recently Used Labels macro**

**To add the Recently Used Labels macro to a page:**

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

**Speeding up macro entry with autocomplete:** Type { and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

**To edit an existing macro:** Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

**Parameters of this macro**

Parameters are options that you can set to control the content or format of the macro output. Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
</table>
Number of Labels to Display (count) | 10 | Specifies the total number of labels to display in the list.

Scope for Retrieving Labels (scope) | global | Specifies the scope of labels to be displayed in the list. Valid values include:

- **global** — covers all site spaces (non-personal) in the Confluence installation.
- **space** — the current space.
- **personal** — your own personal space.

List Style (style) | list | Specifies the style of the list:

- **list** — displays the list of labels horizontally.
- **table** — includes additional information such as the page to which the label was added and the user who added it.

Table Title (title) | none | Adds a title to the top of the list in table style. Titles are only visible when the List Style parameter is set to **table**.

Code examples

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a Confluence page.

**Macro name:** recently-used-labels

**Macro body:** None.

**Storage format example**

```xml
<ac:structured-macro ac:name="recently-used-labels">
  <ac:parameter ac:name="title">My title</ac:parameter>
  <ac:parameter ac:name="scope">space</ac:parameter>
  <ac:parameter ac:name="style">table</ac:parameter>
  <ac:parameter ac:name="count">20</ac:parameter>
</ac:structured-macro>
```

**Wiki markup example**

```
(recently-used-labels:title=My title|scope=space|style=table|count=20)
```

Related Labels Macro

The Related Labels macro lists all labels from every page which has one or more labels in common with the current page.

Using the Related Labels Macro

**To add the Related Labels macro to a page:**

1. In the Confluence editor, choose **Insert > Other Macros**.
2. Find and select the required macro.

**Speeding up macro entry with autocomplete:** Type `{ and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

**To edit an existing macro:** Click the macro placeholder and choose **Edit**. A macro dialog window will open, where you can edit the parameters of the macro.

Parameters
Parameters are options that you can set to control the content or format of the macro output. Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Restrict to these Labels</strong></td>
<td>none</td>
<td>Specify the labels for which you want to view related labels. For example, documentation, my:stuff.</td>
</tr>
</tbody>
</table>

**Code examples**

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a Confluence page.

**Macro name:** related-labels

**Macro body:** None.

**Storage format example**

```xml
<ac:structured-macro ac:name="related-labels">
    <ac:parameter ac:name="labels">choc,cake</ac:parameter>
</ac:structured-macro>
```

**Wiki markup example**

```
{related-labels:labels=choc,cake}
```

**RSS Feed Macro**

The RSS Feed macro embeds an RSS feed on a page. It can display the contents of external feeds, or of internal feeds generated by Confluence. To display blog posts or to list recently updated pages in a space, use the Feed Builder to create an internal feed, then render it using this macro.

**CAUTION: Including unknown HTML inside a webpage is dangerous.**

HTML inside an RSS feed can contain active scripting components. This means that it would be possible for a malicious attacker to present a user of your site with script that their web browser would believe came from you. Such code could be used, for example, to steal a user’s authentication cookie and give the attacker their Confluence login password.

The RSS Feed macro may be disabled by your Confluence administrator. Also, your Confluence administrator can define a whitelist of trusted URLs. You will see an error message on the Confluence page, if the included URL is not in the whitelist.

**Using the RSS Feed macro**

**To add the RSS Feed macro to a page:**

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

**Speeding up macro entry with autocomplete:** Type `{ and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

**To edit an existing macro:** Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.
Parameters

Parameters are options that you can set to control the content or format of the macro output. Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>RSS Feed URL (url)</td>
<td>none</td>
<td>The URL of the RSS feed link you want to show.</td>
</tr>
<tr>
<td>Maximum Number of Entries (max)</td>
<td>15</td>
<td>Limit the number of entries displayed.</td>
</tr>
<tr>
<td>Show Item Titles Only (showTitlesOnly)</td>
<td>false</td>
<td>Show only the titles of the news items, not the content.</td>
</tr>
<tr>
<td>Show Name/Title of RSS Feed (titleBar)</td>
<td>true</td>
<td>Hide the feeds title bar.</td>
</tr>
</tbody>
</table>

How up to date is the feed?

By default, the RSS Feed macro caches the feed results for 60 minutes before fetching the data again.

If you wish to change the default caching, use the Cache macro to define how often the RSS Feed macro fetches the feed updates. You will need to install the [Cache plugin](https://confluence.atlassian.com/plugins) onto your Confluence site.

What happens to a page containing a disallowed URL?

Your Confluence Administrator can set up a whitelist of allowed URLs. If this is the case, you may see an error on the pages which contain the RSS Feed macro.

A user can add the RSS Feed macro or the HTML-include macro to a Confluence page. The macro code includes a URL from which the content is drawn. When the page is displayed, Confluence will check the URL against the whitelist. If the URL is not allowed, Confluence will display an error message on the page.

The error message says that Confluence "could not access the content at the URL because it is not from an allowed source" and displays the offending URL. If the person viewing the page is a Confluence Administrator, they will also see a link to the Administration page where they can configure the URL whitelist.

Here is an example of the error message, including the link shown only to Confluence Administrators:

```
Could not access the content at the URL because it is not from an allowed source.
http://feathers.wordpress.com
Configure whitelist >>
```

Here is an example of the error message, but without the link.

```
Could not access the content at the URL because it is not from an allowed source.
http://feathers.wordpress.com
You may contact your site administrator and request that this URL be added to the list of allowed sources.
```

Authentication

*Private feeds from external sites*
RSS feeds which require authentication cannot be accessed using the RSS Feed macro.

Accessing internal HTTPS feeds

This applies only to Confluence instances which have enabled HTTPS for all content. If your site is fully HTTPS, the RSS Feed macro cannot access internal feeds. To enable the RSS Feed macro to access internal feeds without affecting your HTTPS setup, enable local-only HTTP access:

1. Shut down Confluence.
2. Consult the SSL guide to enable HTTP access to Confluence. You'll want to ensure that you have an HTTP connector and an SSL connector, both commented in. This means that Confluence will be accessible via both HTTP and HTTPS. However, you should not have a redirect port, nor rules in web.xml to redirect all traffic.
3. Instead of using web.xml to redirect traffic, insert a firewall rule to redirect all HTTP requests not from the Confluence server to the equivalent HTTPS URL. This ensures that users will only be able to access Confluence via HTTPS, as intended. If you have still left HTTP access for attachments enabled (to avoid the IE download bug) you must selectively enable those URLs as well.
4. Modify your Confluence RSS Feed macro feed link to use the HTTP URL, and restart Confluence.

Enabling the RSS Feed macro

The RSS Feed macro is disabled by default.

To enable the RSS Feed macro:

1. Go to Add-ons.
2. Select System from the drop down and search for the Confluence HTML Macros add-on.
3. Expand the add-on and enable the rss (rss-xhtml) module.

Code examples

Macro name: rss

Macro body: None.

Storage format example

```xml
<ac:structured-macro ac:name="rss">
    <ac:parameter ac:name="max">10</ac:parameter>
    <ac:parameter ac:name="showTitlesOnly">true</ac:parameter>
    <ac:parameter ac:name="url">
        <ri:url ri:value="http://myblog.com/feed"/>
    </ac:parameter>
    <ac:parameter ac:name="titleBar">false</ac:parameter>
</ac:structured-macro>
```

Wikimarkup example

```wikimarkup
{rss:max=10|showTitlesOnly=true|url=http://myblog.com/feed|titleBar=false}
```

Search Results Macro

The Search Results macro searches your Confluence site based on search terms specified in the macro parameters, and displays the results on the wiki page.

Using the Search Results macro

To add the Search Results macro to a page:
1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

**Speeding up macro entry with autocomplete:** Type `{` and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

**To edit an existing macro:** Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

### Parameters

Parameters are options that you can set to control the content or format of the macro output. Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Search Terms (query)</td>
<td>none</td>
<td>The search terms which this macro will use to generate its results.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>You can refine your search query by using operators such as 'AND' and 'OR'.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>For example: my_query1 AND my_query2</td>
</tr>
<tr>
<td></td>
<td></td>
<td>For more information, take a look at the documentation on the Confluence search syntax.</td>
</tr>
<tr>
<td>Maximum Number of Results (maxLimit)</td>
<td>10</td>
<td>Set a limit to the number of search results displayed.</td>
</tr>
<tr>
<td>Restrict to this Space Key</td>
<td>all</td>
<td>Start typing the space name to find the space, or specify the key of the space you want to search in. Note that the key is case sensitive.</td>
</tr>
<tr>
<td>Content Type (type)</td>
<td>all</td>
<td>Specify the content type. The content types are: page, comment, blogpost, attachment, userinfo (the content of user profiles only) and spacedesc (the content of space descriptions only).</td>
</tr>
<tr>
<td>Last Modified (lastModified)</td>
<td>all</td>
<td>Specify a period of time in weeks, days, hours and/or minutes, to see the content modified within that time frame. These are the values you can use:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• w = weeks</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• d = days</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• h = hours</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• m = minutes</td>
</tr>
<tr>
<td></td>
<td></td>
<td>For example:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• 2h 35m</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• 3d 30m</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Notes:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• If no time category is specified, Confluence assumes minutes.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• If you specify more than one time period (for example, weeks and days), you must separate the periods with a space. You can put them in any order.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• The time categories are not case sensitive. For example, '4d' is the same as '4D'.</td>
</tr>
<tr>
<td>Restrict to this Username (contributor)</td>
<td>all</td>
<td>Specify the username of a Confluence user, to show only content created or updated by that user.</td>
</tr>
</tbody>
</table>
Notes

Permissions: When a user views the page containing the Search Results macro, the search results will show only pages and other content types for which the user has 'View' permission.

Code examples

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a Confluence page.

Macro name: search

Macro body: None.

Storage format example

```xml
<ac:structured-macro ac:name="search">
    <ac:parameter ac:name="lastModified">3w</ac:parameter>
    <ac:parameter ac:name="query">choc</ac:parameter>
    <ac:parameter ac:name="contributor">
        <ri:user ri:userkey="1235678912345678912345678912345"/>
    </ac:parameter>
    <ac:parameter ac:name="maxLimit">10</ac:parameter>
    <ac:parameter ac:name="type">page</ac:parameter>
    <ac:parameter ac:name="spacekey">
        <ri:space ri:space-key="ss"/>
    </ac:parameter>
</ac:structured-macro>
```

Wiki markup example

```
{search:lastModified=3w|query=choc|contributor=admin|maxLimit=10|type=page|spacekey =ds}
```

Section Macro

Used with the Column macro to define columns on a page. See Working with page layouts and columns and sections.

Code examples

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a Confluence page.

Macro name: section

Macro body: Rich text, consisting of one or more Column macros.

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Required</th>
<th>Default</th>
<th>Parameter description and accepted values</th>
</tr>
</thead>
<tbody>
<tr>
<td>border</td>
<td>No</td>
<td>False</td>
<td>If the value is true, the columns in this section will have a dashed border.</td>
</tr>
</tbody>
</table>

Storage format example
The following example shows a section and column macro together.

```
<ac:structured-macro ac:name="section">
   <ac:parameter ac:name="border">true</ac:parameter>
   <ac:rich-text-body>
      <ac:structured-macro ac:name="column">
         <ac:parameter ac:name="width">100px</ac:parameter>
         <ac:rich-text-body>
            This is the content of <strong>column 1</strong>.
         </ac:rich-text-body>
      </ac:structured-macro>
      <ac:structured-macro ac:name="column">
         <ac:rich-text-body>
            This is the content of <strong>column 2</strong>.
         </ac:rich-text-body>
      </ac:structured-macro>
   </ac:rich-text-body>
</ac:structured-macro>
```

Wiki markup example

```
{section:border=true}
{column:width=100px}
This is the content of *column 1*.
{column}
{column}
This is the content of *column 2*.
{column}
{section}
```

**Space Attachments Macro**

The Space Attachments macro displays a list of all files attached to pages in a space. It shows details of the file and the includes a link to the page a file is attached to.

Filters allow you to show only files with a particular label or file extension.

*Screenshot: The Space Attachments macro*
Using the Space Attachments macro

To add the Space Attachments macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Speeding up macro entry with autocomplete: Type `{` and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

Parameters

The Space Attachments macro displays a list of all the attachments in a space. You can choose to show attachments from the current space, or another space.

Parameters are options that you can set to control the content or format of the macro output. Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Space</td>
<td>(none)</td>
<td>Selects the Confluence space to display attachments for. If you do not specify a space, the current space will be used.</td>
</tr>
<tr>
<td>Show Filter Controls</td>
<td>true</td>
<td>Determines whether or not the filter panel is shown. If you select this option, people viewing the page will be able to filter the list of attachments by file type (extension) and by label.</td>
</tr>
<tr>
<td>(showFilter)</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Code examples

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a Confluence page.

Macro name: `space-attachments`
Macro body: None.

Storage format example

```xml
<ac:structured-macro ac:name="space-attachments">
  <ac:parameter ac:name="showFilter">false</ac:parameter>
  <ac:parameter ac:name="space">
    <ri:space ri:space-key="ds"/>
  </ac:parameter>
</ac:structured-macro>
```

Wiki markup example

```
{space-attachments:showFilter=false|space=ds}
```

Space Details Macro

The Space Details macro displays the details of a Confluence space, including the space name, description, and more.

Using the Space Details macro

To add the Space Details macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Speeding up macro entry with autocomplete: Type `{` and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

Parameters

Parameters are options that you can set to control the content or format of the macro output. Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Width of Table</td>
<td>100%</td>
<td>The width of the space details table, specified as a percentage (%) of the page width.</td>
</tr>
</tbody>
</table>

Code examples

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a Confluence page.

Macro name: space-details

Macro body: None.

Storage format example
Wiki markup example

```{space-details:width=50%}

Space Jump Macro

This page describes the Space Jump macro, which is provided with the Documentation theme. You can use space jumping to link from a page in one space to a page with the same name in another space, without knowing the name of the page when you create the link.

**Advance warning of plans to merge Documentation theme with the default theme**

This is an advance notice that we plan to merge the functionality of the Confluence Documentation theme with the Confluence default theme. We do not yet have a specific date for this plan, and we are interested in your feedback. The new default theme, introduced with Confluence 5.0, includes a sidebar with contextual navigation. Our plan is to include features from the Documentation theme in the default theme, and then remove the Documentation theme from Confluence.

If you are interested in this change and would like to give us feedback, please add a comment on this blog post: [Advance warning of plans to merge Documentation theme with the default theme](https://confluence.atlassian.com/blog/advance-warning-of-plans-to-merge-documentation-theme-with-the-default-theme-1173354951.html). We are especially interested to know which features of the Documentation theme you use and value the most.

The Space Jump macro inserts a link onto the page. When the reader clicks the link, they will jump to a page that has the same name in another space. You specify the space when you insert the Space Jump macro.

**Example:** We use the Space Jump macro to put a standard message at the top of our archive spaces, telling people that they’re reading an old version of the documentation and letting them jump quickly to the same page in the latest documentation. See the words ‘[this page in the current documentation](https://www.confluence.com)’ in the screenshot below.

**Screenshot: One way of using the Space Jump macro**

This documentation relates to an earlier version of Confluence. View this page in the current documentation or visit the current documentation home.

**Configuring the Documentation Theme**

Using the Space Jump macro

**To add the Space Jump macro to a page:**

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

**Speeding up macro entry with autocomplete:** Type `{ and the beginning of the macro name, to see a list of suggested macros. Details are in [Using Autocomplete](https://confluence.atlassian.com/pages/using-autocomplete-103015847.html).

**To edit an existing macro:** Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.
Parameters

Parameters are options that you can set to control the content or format of the macro output. Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Space</td>
<td>None</td>
<td>The space key that contains a page with the same page title that you want the link to jump to. Space keys are case-sensitive.</td>
</tr>
<tr>
<td>Alias</td>
<td>None</td>
<td>The text to display as the hyperlinked text. If you do not supply an alias, Confluence will display the page name.</td>
</tr>
</tbody>
</table>

Notes

What happens if there is no page with the same name in the target space?

For the space jump to work, the target space must contain a page with the same name as the page that renders the Space Jump macro. If the target space does not contain such a page, you will see a broken link. Confluence handles this in its usual manner: the link is coloured red. If you click the link, Confluence offers to create the page for you.

Can I use the Space Jump macro in any space?

Yes. You can use the Space Jump macro in any space, even if that space is not currently using the Documentation theme. Provided that the Documentation theme plugin and its components are installed and enabled on your Confluence site, the Space Jump macro is available in any space.

Code examples

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a Confluence page.

**Macro name:** spacejump

**Macro body:** None.

**Storage format example**

```
<ac:structured-macro ac:name="spacejump">
    <ac:parameter ac:name="alias">My Space</ac:parameter>
    <ac:parameter ac:name="space">
        <ri:space ri:space-key="SS"/>
    </ac:parameter>
</ac:structured-macro>
```

**Wiki markup example**

```
{spacejump:alias=my link|space=ds}
```

**Spaces List Macro**

The Spaces List macro displays a list of spaces, similar to the list of spaces seen on the dashboard.
Using the Spaces List macro

To add the Spaces List macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Speeding up macro entry with autocomplete: Type `{` and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

Parameters

Parameters are options that you can set to control the content or format of the macro output. Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Required?</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
</table>
| Scope of spaces    | no        | all     | The view from which spaces are listed. Available options are:  
  - **all** – All spaces in the Confluence installation.  
  - **category** – Spaces grouped according to space categories.  
  - **favourite** – Spaces which you have added to your favourites list.  
  - **new** – New spaces which have been created within the last 7 days.  

  This parameter is unnamed in wikimarkup and storage format.
| Width of List (width) | no       | 100%    | The width of the spaces list, specified as a percentage (%) of the window width. |

Code examples

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a Confluence page.

**Macro name:** spaces

**Macro body:** None.

**Storage format example**

```xml
<ac:structured-macro ac:name="spaces">
  <ac:parameter ac:name="width">80%</ac:parameter>
  <ac:parameter ac:name="">favourite</ac:parameter>
</ac:structured-macro>
```

**Wiki markup example**

```
{spaces:favourite|width=80%}
```

**Status Macro**

The Status macro displays a coloured lozenge (a rounded box) that is useful for reporting project status. You can choose the colour of the lozenge and the text that appears inside the lozenge. The macro also displays its current status in the editor, and you can change the status directly in the editor.
Using the Status macro

To add the Status macro to a page using the Macro Browser:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Speeding up macro entry with autocomplete: Type `{` and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

Parameters

Parameters are options that you can set to control the content or format of the macro output. Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Colour (colour)</td>
<td>Grey</td>
<td>The colour of the lozenge. The following colours are available: Grey, Red, Yellow, Green and Blue.</td>
</tr>
<tr>
<td>Title (title)</td>
<td>The colour that you select.</td>
<td>The text that will appear inside the lozenge. If you do not specify any text, the title will be the colour of the lozenge, that is ‘Grey’, ‘Red’, ‘Yellow’, ‘Green’ or ‘Blue’.</td>
</tr>
<tr>
<td>Use outline style (subtle)</td>
<td>False</td>
<td>The style of the lozenge and its border. The default style lozenge is a solid background colour with white text. The outline style lozenge is white with a coloured border and coloured text as shown here</td>
</tr>
</tbody>
</table>

Code examples

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a Confluence page.

Macro name: status

Macro body: None.

Storage format example
<ac:structured-macro ac:name="status">
  <ac:parameter ac:name="colour">Green</ac:parameter>
  <ac:parameter ac:name="title">On track</ac:parameter>
  <ac:parameter ac:name="subtle">true</ac:parameter>
</ac:structured-macro>

Wiki markup example

{status:colour=Green|title=On track|subtle=true}

Table of Contents Macro

The Table of Contents macro scans the headings on the current Confluence page to create a table of contents based on those headings. This helps readers find their way around lengthy pages, by summarising the content structure and providing links to headings.

Using the Table of Contents macro

**Hint:** For quick access from the editor toolbar, choose Insert > Table of Contents.

**To add the Table of Contents macro to a page:**

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

**Speeding up macro entry with autocomplete:** Type `{ and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

**To edit an existing macro:** Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

Macro parameters

Parameters are options that you can set to control the content or format of the macro output. Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Output Type</strong> (type)</td>
<td>list</td>
<td>• list — produces a typical list-type table of contents.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• flat — produces a horizontal menu-type series of links.</td>
</tr>
<tr>
<td><strong>Display Section Numbering</strong> (outline)</td>
<td>clear</td>
<td>Select the check box to apply outline numbering to your headings, for example: 1.1, 1.2, 1.3.</td>
</tr>
</tbody>
</table>
| **List Style** <br>(style) | disc | Select the style of bullet point for each list item. You can use any valid CSS style. For example:  
- none — no list style is displayed  
- circle — the list style is a circle  
- disc — the list style is a filled circle. This is the typical bullet list, and is used for this example list.  
- square — the list style is a square  
- decimal — the list is numbered (1, 2, 3, 4, 5)  
- lower-alpha — the list is lower-case, alphabetised (a, b, c, d, e)  
- lower-roman — the list style is lower roman numerals (i, ii, iii, iv, v, vi)  
- upper-roman — the list style is upper roman numerals (I, II, III, IV, V, VI) |
<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Heading Indent</strong> &lt;br&gt;(indent)</td>
<td></td>
<td>Sets the indent for a list according to CSS quantities. Entering 10px will successively indent heading groups by 10px. For example, level 1 headings will be indented 10px and level 2 headings will be indented an additional 10px.</td>
</tr>
</tbody>
</table>
| **Separator** <br>(separator) | brackets | This parameter applies to flat lists only. You can enter any of the following values:  
- brackets — Each item is enclosed by square brackets: [ ].  
- braces — Each item is enclosed by braces: { }.  
- parens — Each item is enclosed by parentheses: ( ).  
- pipe — Each item is separated by a pipe:  
- anything — Each item is separated by the value you enter. You can enter any text as a separator, for example "**". If using a custom separator, be aware that text displays exactly as entered, with no additional white space to further separate the characters. |
| **Minimum Heading Level** <br>(minLevel) | 1 | Select the highest heading level to start your TOC list. For example, entering 2 will include levels 2, and lower, headings, but will not include level 1 headings. |
| **Maximum Heading Level** <br>(maxLevel) | 7 | Select the lowest heading level to include. For example, entering 2 will include levels 1 and 2, but will not include level 3 headings and below. |
| **Include Headings** <br>(include) |  | Filter headings to include according to specific criteria. You can use wildcard characters. See Sun's Regex documentation for examples of constructing regular expression strings. |
| **Exclude Headings** <br>(exclude) |  | Filter headings to exclude according to specific criteria. You can use wildcard characters. See Sun's Regex documentation for examples of constructing regular expression strings. |
| **Printable** <br>(printable) | checked | By default, the TOC is set to print. If you clear the check box, the TOC will not be visible when you print the page. |
| **CSS Class Name** <br>(class) |  | If you have custom TOC styles in your CSS style sheet, use this parameter to output the TOC inside <div> tags with the specified class attribute. |
| **Absolute URL** <br>(absoluteURL) |  | By default, the links in the TOC are relative URLs pointing to the current page. If checked, the links in the TOC will be full URLs. This setting is useful when you are including a page with a Table of Contents in another page, and want to control where the links should take the user. |
Examples

The examples below are based on this table of contents:

- Places
  - Favourite Places
  - Unknown Places
- Foods
  - Favourite Foods
  - Unknown Foods
- Things
  - Favourite Foods
  - Unknown Foods

Filtered Table of Contents

This example filters the headings to include those that contain 'Favourite', but excludes headings which end with 'Things'. The list is styled with Roman numerals.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>List Style</td>
<td>upper-roman</td>
</tr>
<tr>
<td>Include Headings</td>
<td>Favourite.*</td>
</tr>
<tr>
<td>Exclude Headings</td>
<td>.*Things</td>
</tr>
</tbody>
</table>

The resulting table of contents is:

1. Favourite Places
2. Favourite Foods

Flat List

This example filters all headings to render a flat list of 'Unknowns' enclosed in square brackets (the default list style).

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Output Type</td>
<td>flat</td>
</tr>
<tr>
<td>Maximum Heading Level</td>
<td>2</td>
</tr>
<tr>
<td>Include Headings</td>
<td>Unknown.*</td>
</tr>
</tbody>
</table>

The resulting table of contents is:

[ Unknown Places ] [ Unknown Foods ] [ Unknown Foods ]

Notes

- When you use a Table of Contents macro in a template, you will see an error when you preview the template itself. But the Table of Contents macro works on the pages that people create from the template – the table of contents shows up after they have saved the page. (This is probably because the
Due to an outstanding issue in the Table of Contents macro (CONF-10619), the macro browser's Refresh function does not render any parameter modifications. Currently, the rendering of parameter value modifications to the Table of Contents macro occurs only after the page is saved.

Using HTML heading markup with the Table of Contents macro

The Table of Contents macro cannot handle HTML heading markup on its own. Hence, if you use the HTML and HTML Include macros to render HTML heading markup in a Confluence page, the Table of Contents macro will not create a contents list out of these headings. (For more information about this issue, please refer to TOC-93.) However, if you insert an HTML anchor into each HTML heading on your page (based on the following syntax), the Table of Contents macro will incorporate these headings into your contents list.

```html
<h2><a name="pagename-headingname"></a>Heading Name</h2>
```

The syntax for the anchor name is the page name and heading name separated by a hyphen. Remove all spaces and convert all text to lower case. Convert all punctuation marks to their URL-encoded equivalent.

Code examples

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a Confluence page.

**Macro name:** toc

**Macro body:** None.

**Storage format example**

This example shows a list-type table of contents.

```xml
<ac:structured-macro ac:name="toc">
  <ac:parameter ac:name="printable">true</ac:parameter>
  <ac:parameter ac:name="style">square</ac:parameter>
  <ac:parameter ac:name="maxLevel">2</ac:parameter>
  <ac:parameter ac:name="indent">5px</ac:parameter>
  <ac:parameter ac:name="minLevel">2</ac:parameter>
  <ac:parameter ac:name="class">bigpink</ac:parameter>
  <ac:parameter ac:name="exclude">[1//2]</ac:parameter>
  <ac:parameter ac:name="type">list</ac:parameter>
  <ac:parameter ac:name="outline">true</ac:parameter>
  <ac:parameter ac:name="include">.*</ac:parameter>
</ac:structured-macro>
```

This example shows a flat table of contents.

```xml
<ac:structured-macro ac:name="toc">
  <ac:parameter ac:name="maxLevel">2</ac:parameter>
  <ac:parameter ac:name="minLevel">2</ac:parameter>
  <ac:parameter ac:name="class">bigpink</ac:parameter>
  <ac:parameter ac:name="exclude">[1//2]</ac:parameter>
  <ac:parameter ac:name="type">flat</ac:parameter>
  <ac:parameter ac:name="outline">true</ac:parameter>
  <ac:parameter ac:name="separator">pipe</ac:parameter>
  <ac:parameter ac:name="include">.*</ac:parameter>
</ac:structured-macro>

Wiki markup example

This example shows a list-type table of contents.

```
{toc:printable=true|style=square|maxLevel=2|indent=5px|minLevel=2|class=bigpink|exclude=[1//2]|type=list|outline=true|include=.*}
```

This example shows a flat table of contents.

```
{toc:printable=true|maxLevel=2|minLevel=2|class=bigpink|exclude=[1//2]|type=flat|outline=true|separator=pipe|include=.*}
```

Table of Content Zone Macro

You can use the Table of Content Zone macro to mark out a section (zone) within the page from which to create a table of contents. You can style the headings as a flat list, and place the list of links at the top and bottom of the section or page, to provide navigation bars similar to web navigation.

Using the Table of Content Zone macro

**To add the Table of Content Zone macro to a page:**

1. In the Confluence editor, choose **Insert > Other Macros**.
2. Find and select the required macro.

**Speeding up macro entry with autocomplete:** Type `{` and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

**To edit an existing macro:** Click the macro placeholder and choose **Edit**. A macro dialog window will open, where you can edit the parameters of the macro.

Parameters

Parameters are options that you can set to control the content or format of the macro output. Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (**example**).

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>location (location)</td>
<td>both</td>
<td>Specifies where in the zone the output list is displayed: <strong>top</strong>, <strong>bottom</strong>, or <strong>both</strong>, which encloses the page zone content.</td>
</tr>
<tr>
<td>Output Type (type)</td>
<td>list</td>
<td>Specifies the layout for the table of contents:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• list – produces a vertical list, typical of a TOC.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• flat – produces a horizontal menu-type series of links, for example: [Heading 1] [Heading 2] [Heading 3].</td>
</tr>
<tr>
<td>Display Section Numbering (outline)</td>
<td>false</td>
<td>Select to apply outline numbering to your headings, for example: 1.1, 1.2, 1.3.</td>
</tr>
</tbody>
</table>
| **List Style**<br>(style) | none | Specifies the style of bullet point for each list item. You can use any valid CSS style. For example:
- none — no list style is displayed
- circle --- the list style is a circle
- disc — the list style is a filled circle. This is the typical bullet list, and is the one we're using for this example list
- square — the list style is a square
- decimal — the list is numbered (1, 2, 3, 4, 5)
- lower-alpha — the list is lower-case, alphabetised (a, b, c, d, e)
- lower-roman — the list style is lower roman numerals (i, ii, iii, iv, v, vi)
- upper-roman — the list style is upper roman numerals (I, II, III, IV, V, VI) |
<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Heading Indent</strong>&lt;br&gt;(indent)</td>
<td></td>
<td>Sets the indent for a list output type, according to CSS quantities. Entering &quot;10px&quot; will successively indent list heading levels by 10px. For example, h1 headings will be indented 10px and h2 headings will be indented an additional 10px.</td>
</tr>
</tbody>
</table>
| **Separator**<br>(separator) | brackets | Only applies to the flat output type. Specifies the display style of the links. You can enter any of the following values:
- brackets — Each item is enclosed by square brackets: [ ].
- braces — Each item is enclosed by braces: { }. 
- parens — Each item is enclosed by parentheses: ( ).
- pipe — Each item is separated by a pipe:
- anything — Each is separated by the value you enter. You can enter any text as a separator, for example "***". If using a custom separator, be aware that text displays exactly as entered, with no additional white space to further separate the characters. |
| **Minimum Heading Level**<br>(minLevel) | 1 | Select the largest heading level to start your TOC list. For example, 2 will list h2, h3, and h4 headings, but will not include h1 headings. |
| **Max Heading Level**<br>(maxLevel) | 7 | Select the smallest heading level to include in the TOC. For example, 2 will list h1 and h2, but will not include h3 and below. |
| **Include Headings**<br>(include) | | Filter the included headings according to specific criteria. You can use wildcard characters. See Sun's Regex documentation for examples of constructing regular expression strings. |
| **Exclude Headings**<br>(exclude) | | Exclude headings according to specific criteria. You can use wildcard characters. See Sun's Regex documentation for examples of constructing regular expression strings. |
| **Printable**<br>(printable) | true | By default, the TOC is set to print. If you clear this parameter, the TOC will not be visible when you print the page. |
| **CSS Class Name**<br>(class) | | If you have a custom TOC in your CSS style sheet, you can use this parameter to output the TOC with the specified "class" attribute. |
The examples are based on a page with the following headings:

- **Places**
  - Favourite Places
  - Unknown Places
- **Foods**
  - Favourite Foods
  - Unknown Foods
- **Things**
  - Favourite Foods
  - Unknown Foods

### Filtered Table of Contents

This example will filter all headings to include those that contain "Favourite", but will exclude any heading which ends with the word "Things". The list is styled with upper-case Roman numerals.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Output Type</td>
<td>list</td>
</tr>
<tr>
<td>List Style</td>
<td>upper-roman</td>
</tr>
<tr>
<td>Include Headings</td>
<td>Favourite.*</td>
</tr>
<tr>
<td>Exclude Headings</td>
<td>.*Things</td>
</tr>
</tbody>
</table>

**Screenshot: Filtered TOC 'zone' headings**

I. Favourite Places  
II. Favourite Foods

### Flat List

This example will filter all headings to render a flat list of "Unknowns" enclosed in square brackets.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Output Type</td>
<td>flat</td>
</tr>
<tr>
<td>Separator</td>
<td>brackets</td>
</tr>
<tr>
<td>Max Heading Level</td>
<td>2</td>
</tr>
<tr>
<td>Include Headings</td>
<td>Unknown.*</td>
</tr>
</tbody>
</table>

**Screenshot: Filtered TOC 'zone' headings displayed as a flat list**

[Unknown Places] [Unknown Foods] [Unknown Foods]

### Notes

- Due to an outstanding issue in the Table of Content Zone macro (CONF-10619), the Macro Browser's Refresh function does not render any parameter modifications. Currently, the rendering of parameter value modifications to the Table of Content Zone macro occurs only after the page is saved.
- Using HTML heading markup with the Table of Content Zone macro — The Table of Content Zone macro cannot handle HTML heading markup on its own. Hence, if you used the HTML and HTML Include macro
s to render HTML heading markup in a Confluence page, the Table of Content Zone macro will not create a contents list out of these headings. (For more information on about this issue, please refer to TOC-93.)

However, if you insert an HTML anchor into each HTML heading on your page (based on the following syntax), the Table of Content Zone macro will incorporate these headings into your contents list.

```html
<h2><a name="pagename-headingname"></a>Heading Name</h2>
```

The syntax for the anchor name is the page name and heading name separated by a hyphen. Remove all spaces and convert all text to lower case. Convert all punctuation marks to their URL-encoded equivalent.

**Code examples**

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a Confluence page.

**Macro name:** toc-zone

**Macro body:** Accepts rich text.

**Storage format example**

```xml
<ac:structured-macro ac:name="toc-zone">
    <ac:parameter ac:name="printable">false</ac:parameter>
    <ac:parameter ac:name="maxLevel">2</ac:parameter>
    <ac:parameter ac:name="minLevel">2</ac:parameter>
    <ac:parameter ac:name="location">top</ac:parameter>
    <ac:parameter ac:name="type">flat</ac:parameter>
    <ac:parameter ac:name="outline">true</ac:parameter>
    <ac:parameter ac:name="separator">pipe</ac:parameter>
    <ac:rich-text-body>
        Only headings within this block are included in the table of contents.
    </ac:rich-text-body>
</ac:structured-macro>
```

**Wiki markup example**

```
{toc-zone:printable=false|maxLevel=2|minLevel=2|location=top|type=flat|outline=true|separator=pipe}
Only headings within this block are included in the table of contents.
{toc-zone}
```

**Tip Macro**

Using the Tip macro, you can highlight a helpful tip on a Confluence page. The macro creates a green-coloured box surrounding your text as shown below.

**Tip Macro Example**

This text is displayed inside the tip macro.
Using the Tip macro

To add the Tip macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Speeding up macro entry with autocomplete: Type { and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

Parameters

Parameters are options that you can set to control the content or format of the macro output. Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
</table>
| **Optional Title**  
(title)          | none    | The title of the tip. If specified, it will be displayed in bold next to the icon. |
| **Show Tip Icon**  
(icon)           | true    | If cleared, the icon will not be displayed.|

Code examples

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a Confluence page.

**Macro name:** tip

**Macro body:** Accepts rich text.

**Storage Format example**

```xml
<ac:structured-macro ac:name="tip">
  <ac:parameter ac:name="icon">false</ac:parameter>
  <ac:parameter ac:name="title">My title</ac:parameter>
  <ac:rich-text-body>
    <p>This is my hint.</p>
  </ac:rich-text-body>
</ac:structured-macro>
```

**Wiki markup example**

```
{tip:icon=false|title=My title}
This is my hint.
{tip}
```

User List Macro
The User List macro displays a list of Confluence users, based on their group membership. The macro can also indicate when users are online or offline.

Using the User List macro

To add the User List macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Speeding up macro entry with autocomplete: Type { and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

Parameters

Parameters are options that you can set to control the content or format of the macro output. Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Group(s)</strong> (groups)</td>
<td>none</td>
<td>Specify the group name. Specify multiple groups separated by a comma, or use * to show all users in Confluence.</td>
</tr>
</tbody>
</table>
| **Display Online/Offline Users** (online) | All registered users | List online or offline users. Leave blank to show all users, irrespective of status. Accepted values:
  * Unspecified – The macro will show all registered users.
  * true – The macro will show only online users.
  * false – The macro will show only offline users.

See below for information on how to configure this macro to display online/offline users.

Configuring the User List macro

In order to use the Display Online/Offline Users parameter to indicate whether users are currently logged in to Confluence, you will need to enable the User Log In Listener component in the add-on that provides this macro. You'll need Confluence Administrator permissions to do this.

To enable the Display Online/Offline Users filter in the User List macro:

1. Go to
   ![Add-ons](https://example.com/add-ons)
2. Select System from the drop down and search for the User Lister add-on
3. Expand the add-on and enable the User Log In Listener module.
4. Restart Confluence for the change to take effect.

Code examples

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a Confluence page.

**Macro name:** userlister

**Macro body:** None.
Storage format example

```xml
<ac:structured-macro ac:name="userlister">
  <ac:parameter ac:name="groups">confluence-users</ac:parameter>
  <ac:parameter ac:name="online">false</ac:parameter>
</ac:structured-macro>
```

Wiki markup example

```
{userlister:groups=confluence-users|online=false}
```

User Profile Macro

The User Profile macro displays a short summary of a given Confluence user's profile. This is the same summary that appears in a Hover Profile, which appears whenever you mouse over a user's name in the Confluence interface.

**Screenshot: Example of the User Profile macro**

Using the User Profile macro

**To add the User Profile macro to a page:**

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

**Speeding up macro entry with autocomplete:** Type `{ and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

**To edit an existing macro:** Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

Parameters

Parameters are options that you can set to control the content or format of the macro output. Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Username (<code>user</code>)</td>
<td>none</td>
<td>The username of the Confluence user whose profile summary you wish to show.</td>
</tr>
</tbody>
</table>

Code examples

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a Confluence page.
Macro name: profile

Macro body: None.

Storage format example

```xml
<ac:structured-macro ac:name="profile">
    <ac:parameter ac:name="user">
        <ri:user ri:userkey="12345678912345678912345678912345"/>
    </ac:parameter>
</ac:structured-macro>
```

Wiki markup example

`{profile:user=admin}`

User Status List Macro

The User Status List macro displays a history of a given Confluence user's status updates. This is the same history that appears in the user's Status Updates view.

Screenshot: Example output of the User Status List macro

```
“Time to look at networks
   Clear · Delete · Feb 15, 2013

“Updating my profile picture
   Delete · Feb 15, 2013

“Making Confluence sing...
   Delete · Feb 15, 2013
```

Using the User Status List macro

To add the User Status List macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Speeding up macro entry with autocomplete: Type { and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

Parameters

Parameters are options that you can set to control the content or format of the macro output. Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
</table>

Created in 2015 by Atlassian. Licensed under a Creative Commons Attribution 2.5 Australia License.
Username (username)

none

The username of the Confluence user whose history of status updates you wish to show.

Notes

**Hint:** If you wish to list status updates made by more than one user, you can use the Recently Updated macro with the following parameter values:

- Include these Content Types Only: status
- Author(s) by username: The user(s) whose status updates you want to include in the list. If you leave this field blank, the status updates of all users will be included.

Code examples

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a Confluence page.

**Macro name:** status-list

**Macro body:** None.

**Storage format example**

```xml
<ac:structured-macro ac:name="status-list">
  <ac:parameter ac:name="username">
    <ri:user ri:userkey="12345678912345678912345678912345"/>
  </ac:parameter>
</ac:structured-macro>
```

**Wiki markup example**

```
{status-list:username=admin}
```

**View File Macro**

The View File macros allow you to embed an Office or PDF document on a page. First attach the document to a page and then use one of the View File macros to display the document's content.

When people view the page, they will see the content of the Office or PDF document. They do not need to have Office installed in order to see the content of the file.

For a full list of Office Connector prerequisites and limitations, please refer to:

- Office Connector Prerequisites
- Office Connector Limitations and Known Issue

**Displaying an Office or PDF Document in Confluence**

To display an Office or PDF document in a page, use one of the following View File macros in the macro browser:

- Office Excel
- Office PowerPoint
- Office Word
- PDF

To add one of the View File macros to a page:
1. In the Confluence editor, choose **Insert > Other Macros**.
2. Find and select the required macro.

**Speeding up macro entry with autocomplete:** Type `{` and the beginning of the macro name, to see a list of suggested macros. Details are in **Using Autocomplete**.

**To edit an existing macro:** Click the macro placeholder and choose **Edit**. A macro dialog window will open, where you can edit the parameters of the macro.

**Parameters for the Office and PDF macros**

Parameters are options that you can set to control the content or format of the macro output. Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).

<table>
<thead>
<tr>
<th>Macro</th>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>All View File macros</td>
<td>Page Name</td>
<td>The page which contains the macro</td>
<td>Enter a page name, if you wish to display a document which is attached to another Confluence page.</td>
</tr>
<tr>
<td></td>
<td>File Name</td>
<td>none</td>
<td>The file name of the Office or PDF document to be displayed. The document must be attached to a page on your Confluence site.</td>
</tr>
<tr>
<td>Office Excel</td>
<td>Show Grid?</td>
<td>true</td>
<td>Select to show grid lines around each cell of the Excel spreadsheet. Clear to hide these grid lines.</td>
</tr>
<tr>
<td></td>
<td>Worksheet Name</td>
<td>Last worksheet viewed in the spreadsheet</td>
<td>The name of the worksheet that you want displayed.</td>
</tr>
<tr>
<td></td>
<td>Last Row</td>
<td>Last row with content</td>
<td>The number of the last row you want displayed, starting from '0' as the first row.</td>
</tr>
<tr>
<td></td>
<td>Last Column</td>
<td>Last column with content</td>
<td>The number of the last column you want displayed, starting from '0' as the first column.</td>
</tr>
<tr>
<td></td>
<td>Height</td>
<td>Specify the height of the display, in pixels (default) or as a percentage of the window's height.</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Slide Number</td>
<td>none</td>
<td>Specify the number of the slide that you want displayed on the Confluence page, where the first slide is numbered zero. Instead of a slide show, the page will display just the single slide, represented as a JPEG image. If not specified, all slides display as a slideshow.</td>
</tr>
<tr>
<td></td>
<td>Width</td>
<td>Specify the width of the display, in pixels (default) or as a percentage of the window's width.</td>
<td></td>
</tr>
</tbody>
</table>

**Editing an Office document**

You can launch your Office application and edit Office documents displaying in the view file macros directly from your Confluence page.

- **Word** and **Excel** - choose the **Edit Document** link above the content.
- **PowerPoint** - choose the edit icon on the viewer.

You will find more information and other methods for editing attached Office documents in **Editing Office Files**.

**Troubleshooting**

Problems? Please refer to our guide to the **Office Connector limitations and known issues**.

**Code examples**

Refer to the page for each macro to see storage format and wikimarkup examples.

- **Office Excel Macro**
- **Office PowerPoint Macro**
- **Office Word Macro**
- **PDF Macro**

**Warning Macro**

The Warning macro is useful for highlighting a warning on a Confluence page. The macro creates a red-coloured box surrounding your text as shown below.

**Example of a Warning Macro**
This text appears inside the Warning macro.

**Using the Warning macro**

**To add the Warning macro to a page:**

1. In the Confluence editor, choose **Insert > Other Macros**.
2. Find and select the required macro.

**Speeding up macro entry with autocomplete:** Type `{` and the beginning of the macro name, to see a list of suggested macros. Details are in **Using Autocomplete**.

**To edit an existing macro:** Click the macro placeholder and choose **Edit**. A macro dialog window will open, where you can edit the parameters of the macro.

**Parameters**

Parameters are options that you can set to control the content or format of the macro output. Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Optional Title</td>
<td>none</td>
<td>The title of the warning note. If specified, will be displayed in bold next to the icon.</td>
</tr>
<tr>
<td>(title)</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Show Warning Icon</td>
<td>true</td>
<td>If &quot;false&quot;, the icon will not be displayed.</td>
</tr>
<tr>
<td>(icon)</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

**Code examples**

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a Confluence page.

**Macro name:** warning

**Macro body:** Accepts rich text.
Storage format example

<ac:structured-macro ac:name="warning">
  <ac:parameter ac:name="icon">false</ac:parameter>
  <ac:parameter ac:name="title">This is my title</ac:parameter>
  <ac:rich-text-body>
    <p>This is <em>important</em> information.</p>
  </ac:rich-text-body>
</ac:structured-macro>

Wiki markup example

{warning:icon=false|title=This is my title}
This is _important_ information.
{warning}

Widget Connector Macro

The Widget macro, or Widget Connector, allows you to embed certain multimedia content from other web sites into your Confluence page.

It supports the following content:

- Gadgets and other widgets: Google Gadgets, Widgetbox.
- Videos: YouTube, MySpace Video, Yahoo Video, Dailymotion, Episodic, Vimeo, Metacafe, blip.tv, Viddler.
- Photos and images: Flickr, Skitch.com.
- Micro-blogging: Twitter, FriendFeed, BackType.
- Documents and presentations: SlideShare, SlideRocket, Scribd, presentations on Google Docs. **Note:** The integration with Google Docs is currently broken. Please refer to CONF-24927 for details of the issue.
- Calendars: Google Calendar.
- Forms and online databases: Wufoo HTML Form Builder and Wufoo Reports.
- Support and customer satisfaction: Get Satisfaction.

There are live examples of many of these on the widget examples page. If you wish to extend the functionality of this plugin, please see Extending the Widget Connector.

On this page:

- Using the Widget Connector
- Parameters
- Examples of macro sources
- Troubleshooting
- Code examples
  - Storage format example
  - Wiki markup example

Related pages:

- Working with Macros
- Confluence User's Guide

Using the Widget Connector

**To add the Widget Connector to a page:**

1. In the Confluence editor, choose **Insert > Other Macros**.
2. Find and select the required macro.
**Speeding up macro entry with autocomplete:** Type `{` and the beginning of the macro name, to see a list of suggested macros. Details are in Using Autocomplete.

**To edit an existing macro:** Click the macro placeholder and choose Edit. A macro dialog window will open, where you can edit the parameters of the macro.

### Parameters

Parameters are options that you can set to control the content or format of the macro output. Where the parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro browser, it will be listed below in brackets (example).

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Web Site's Widget URL (url)</td>
<td>This is the URL provided by the external web site for embedding content from that web site onto another web page.</td>
</tr>
<tr>
<td>Pixel Height (Value Only) (height)</td>
<td>Specify the height of the display, in pixels.</td>
</tr>
<tr>
<td>Pixel Width (Value Only) (width)</td>
<td>Specify the width of the display, in pixels.</td>
</tr>
</tbody>
</table>

### Examples of macro sources

**Google Gadgets**

You need to find the URL for the Google Gadget you want to display.

Here is one way to find a gadget's URL:

1. Go to the [Google Gadgets directory](#).
2. Find the gadget you want then click its name, such as 'Spider'.
3. The gadget's summary page will open. Copy the URL from your browser's address bar. The URL looks something like this one:


You can also use the URL of the 'add gadget' page. The page is called 'Add "gadgetx" to your iGoogle page':

1. There are a couple of ways to get to the 'add gadget' page:
   - Click a '+Google' button underneath the gadget when displayed on a page somewhere.
   - Or click 'Add Stuff' on your iGoogle page.
2. Copy the URL from your browser's address bar. The URL would look something like this one:

   **http://www.google.com/ig/adde?synd=open&source=ggyp&moduleurl=abowman.googlepages.com/spider.xml**

**Widgetbox widgets**

You will need to find the URL for the Widgetbox widget you want to display.

Here is one way to find a widget's URL:
1. Ensure you are logged in to Widgetbox and that you are viewing the Widgetbox Gallery.
2. Find the widget you want then click its name, such as 'cyber-pet'.
3. The widget's summary page will open. Within the Get Widget section, click the Atlassian Confluence icon.
   - The Widgetbox Add to Confluence dialog box appears, containing the URL required for the Widget Macro.
   - If you cannot see this icon, click the more... link to reveal it.
4. In the Widgetbox Add to Confluence dialog box, click Copy.
5. Copy the URL from your browser's address bar. The URL looks something like this:

   http://widgetbox.com/confluence/b8327e33-c8eb-4a38-b842-fba866ffdd28

### YouTube

You will need to find the URL for the YouTube video that you want to display.

To find a YouTube video's URL:

1. Go to YouTube and search for the video you want.
2. Click the title of the video, such as 'Wikis in Plain English'.
3. The video's summary page will open on YouTube. Choose Share.
4. Choose Options, located under the video's URL.
5. Choose Long link, then copy the long URL. It looks something like this:

   http://au.youtube.com/watch?v=-dnL00TdmLY

**Note:** You must use the long YouTube URL. The shortened URL (like this one: http://www.youtu.be /<video_key>) does not work in the widget connector. If you are unable to view the video in some browsers, use https: rather than http in your link.

### MySpace Videos

You will need to find the URL for the MySpace video that you want to display.

To find a MySpace video's URL:

1. Go to MySpace Video and search for the video you want.
2. Click the title of the video, such as 'Glacier Creek Confluence Time Lapse'.
3. The video's summary page will open. Copy the URL from your browser's address bar. The URL looks something like this:

   http://vids.myspace.com/index.cfm?fuseaction=vids.individual&videoid=3376248&searchid=20c789f6-laee-459a-bfec-75efcfc2847c

### Yahoo Video

You will need to find the URL for the Yahoo video that you want to display.

To find a Yahoo video's URL:

1. Go to Yahoo Video and search for the video you want.
2. Click the title of the video, such as 'Wiki Technology Trend: Past, Now and Future'.
3. The video's summary page will open. Copy the URL from the address bar of your browser. The URL looks something like this:
http://video.yahoo.com/watch/423158/2424140

If you are unable to obtain a unique URL from your browser’s address bar, click the envelope (Share) icon on the lower section of the video screen and copy the contents of the Link field.

**Dailymotion Video**

You will need to find the URL for the Dailymotion video that you want to display.

To find a Dailymotion video’s URL:

1. Go to [Dailymotion](http://www.dailymotion.com) and search for the video you want.
2. Click the title of the video, such as ‘Wiki Technology Trend: Past, Now and Future’.
3. The video’s summary page will open. Copy the URL from the address bar of your browser. The URL looks something like this:

   http://www.dailymotion.com/user/spacevidcast/video/x7zevj_spacevidcast-2009-promo-video_tech

   If you are unable to obtain a unique URL from your browser’s address bar, click **Menu** at the lower right section of the video screen, select **URL & Embed Code** and copy the contents of the **Link** field.

**Episodic**

You will need an Episodic user account if you want to create and distribute videos via Episodic.

To embed an Episodic video onto a Confluence page:

1. Find the video and copy the URL from the address bar of your browser. The URL looks something like this:

   http://app.episodic.com/shows/13/episodes/493

2. Paste the URL into the **Web Site's Widget URL** box in the Macro Browser.

**Vimeo**

You will need to find the URL for the Vimeo video that you want to display.

To find a Vimeo video’s URL:

1. Go to [Vimeo](http://www.vimeo.com) and search for the video you want.
2. Click the title of the video, such as ‘The Wiki Show - Allison the Russian High Kicker’.
3. The video’s summary page will open. Copy the URL from the address bar of your browser. The URL looks something like this one:

   http://www.vimeo.com/909808

**Metacafe**

You will need to find the URL for the Metacafe video that you want to display.

To find a Metacafe video’s URL:

1. Go to [Metacafe](http://www.metacafe.com) and search for the video you want.
2. Click the title of the video, such as ‘Wikis In Plain English (How To)’.
3. The video’s summary page will open. Copy the URL from the address bar of your browser. The URL looks
something like this one:

http://www.metacafe.com/watch/679493/wikis_in_plain_english_how_to/

blip.tv

This integration is currently broken. Please refer to CONF-27266 for details of the issue.

Viddler

This integration is currently broken. Please refer to CONF-27267 for details of the issue.

Flickr

You can embed a slide show of photos from Flickr by supplying a URL that specifies one of the following:

- Photos with a specific tag.
- Photos belonging to the photostream of a specific Flickr user.
- A set of photos as defined by the Flickr user.
- A user's photostream starting at a specific photo.

If you want to do something else, we suggest that you try any Flickr URL. It should work.

Below are some examples of the Widget macro code for embedding Flickr images.

Flickr Photos with a Specific Tag

This URL displays a slide show of Flickr photos that are tagged with the word 'Atlassian':

http://www.flickr.com/photos/tags/atlassian/

Flickr Photos from a Specific User

This URL displays a slide show of photos from the Flickr photostream of user 'Atlassian':

http://www.flickr.com/photos/atlassian/

Flickr Photos from a Specific Set

This URL displays a slide show of Flickr photos from the set 'Melbourne Cup - November 2008' created by user 'Atlassian':

http://www.flickr.com/photos/atlassian/sets/72157608657271078/

A Specific Flickr Photo

This URL displays a slide show of photos from the Flickr photostream of the user 'Atlassian', starting with a specific photo:

http://www.flickr.com/photos/atlassian/3003538919/

Skitch.com

You will need to find the URL for the Skitch image that you want to display.

To embed a Skitch image onto a Confluence page:

2. Find the image and copy the URL from the address bar of your browser. The URL looks something like this:

http://skitch.com/atlassian/411g/example-image

Note: Skitch is now integrated with Evernote, as described in this blog post from The Next Web: Evernote is bringing Skitch into its core service, Skitch.com will be archived. As a result, private images on Skitch.com are no longer accessible and will not work in the Confluence widget connector. Existing public images on Skitch.com will remain available.

Twitter
Note: Due to a recent change to the Twitter API, the process for displaying Tweets has changed. The following instructions relate to v 2.1.6 of the Widget Connector plugin. Earlier versions of the Widget Connector no longer display tweets correctly.

To embed a single tweet:

1. In Twitter, navigate to the tweet you wish to embed and choose Details to display just that tweet in your browser.
2. Copy the page URL (the URL should be in the following format, https://twitter.com/atlassian/status/346976521250037760).
3. In Confluence, paste the URL into the Widget Connector.
4. The single tweet will display, like the one below.

To embed a dynamic list of tweets:

1. In Twitter, create a Widget (go to Settings > Widgets).
2. Configure the widget to display the tweets you wish to embed (for example, a user timeline, list of tweets or hashtag search).
3. Save the widget, then copy the page URL (the URL should be in the following format, https://twitter.com/settings/widgets/354381809263472640/edit).
4. In Confluence, paste the URL into the Widget Connector.
5. The list of tweets will display, like the one below.

FriendFeed

To display the latest messages from a FriendFeed user, add the user's FriendFeed link as the URL in the Widget macro. For example:
**BackType**

To display the latest blog or website comments from a BackType user, add the user’s BackType widget link as the URL in the Widget macro. For example:

```
http://www.slideshare.net/jleyser/using-jira-greenhopper-for-agile-development
```

**SlideShare**

You will need to find the URL for the SlideShare presentation that you want to display.

To find a SlideShare presentation’s URL:

1. Go to SlideShare and search for the presentation you want.
2. Click the title of the presentation, such as ‘Using JIRA & Greenhopper for Agile Development’.
3. The presentation’s summary page will open. Copy the URL from the address bar of your browser. The URL looks something like this:

   `http://www.slideshare.net/jleyser/using-jira-greenhopper-for-agile-development`

**SlideRocket**

You will need to find the URL for the SlideRocket presentation that you want to display.

To find a SlideRocket presentation’s URL:

1. Log in to SlideRocket and go to your library of presentations.
2. Copy the ‘web link’ for the presentation you want to display. This will give you a URL that looks something like this:

   `http://app.sliderocket.com/app/FullPlayer.aspx?id=132f9db7-b0fb-4f51-b974-36652774971b`

3. Paste the URL into the Widget macro code on your Confluence page.

**Scribd**

You will need to find the URL for the Scribd presentation that you want to display.

To find a Scribd presentation’s URL:

1. Go to Scribd and search for the presentation you want.
2. Click the title of the presentation, such as ‘My Sea Friends Coloring Book’.
3. The presentation’s summary page will open. Copy the URL from the address bar of your browser. The URL looks something like this:


4. Paste the URL into the Widget macro code on your Confluence page.

**Google Docs Presentations**

This integration is currently broken. Please refer to 🕵️ CONF-24927 for details of the issue.

**Google Calendar**

You can embed a Google Calendar into your page and to do this, you will need to add the URL for the Google Calendar that you want to display.

To find the URL for a Google Calendar:
1. Log in to Google Calendar.
2. In the calendar list on the left side of the page, ensure the appropriate calendar is selected, click the down-arrow button next to the calendar name and then select the Calendar settings option. (Alternatively, if available, click the Manage Calendars link at the bottom of the calendar list and then click the name of the appropriate calendar.)
3. In the Calendar Address section, click the HTML button. A pop-up message with your calendar's public URL appears.
4. Copy the URL from this pop-up message. The URL looks something like this:

   http://www.google.com/calendar/embed?src=somebody@example.com&ctz=Australia/Sydney

5. Paste the URL into the Widget macro code on your Confluence page.

**Wufoo HTML Form Builder**

To display an HTML form built in the Wufoo HTML Form Builder, add the form's link as a URL to the Widget Macro. For example:

http://examples.wufoo.com/forms/contact-form/

**Wufoo Reports**

To display a Wufoo Report built using the Wufoo Report Manager, add the report's link as a URL to the Widget Macro. For example:

http://examples.wufoo.com/reports/example-satisfaction-survey-report/

**Get Satisfaction social support application**

To display a feedback form for a Get Satisfaction community, add the community or company link as a URL to the Widget Macro. For example:

http://getsatisfaction.com/atlassian

**Troubleshooting**

If the URL given in the Widget Connector macro does not work, the macro displays an icon and the base URL. For example, the following code:

http://example.com/invalid

will result in an image like the one below:
Code examples

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a Confluence page.

**Macro name:** widget

**Macro body:** None.

Storage format example

```xml
<ac:structured-macro ac:name="widget">
  <ac:parameter ac:name="height">480</ac:parameter>
  <ac:parameter ac:name="width">640</ac:parameter>
  <ac:parameter ac:name="url">
    <ri:url ri:value="http://youtube.com/watch?v=23pLByj_q5U"/>
  </ac:parameter>
</ac:structured-macro>
```

Wiki markup example

```
{widget:height=400|width=400|url=http://www.google.com/ig/directory?synd=open&num=2
4&url=http://www.gadzi.com/gadgets/monkey.xml&output=html}
```

Widget Connector Examples

This page contains working examples of some services currently supported by the Widget Connector. This page lets you preview what each widget will look like and see how to interact with it. For detailed usage, see Widget Connector Macro.

**Flickr**

http://www.flickr.com/photos/tags/atlassian

http://www.flickr.com/photos/atlassian/

http://www.flickr.com/photos/atlassian/sets/72157608657271078/

http://www.flickr.com/photos/atlassian/3003538919/
On this page:
- Flickr
- Google Docs
- YouTube
- MySpace
- Vimeo
- BlipTV
- Viddler
- Skitch
- Twitter
- FriendFeed
- SlideShare
- SlideRocket
- Scribd
- Wufoo
- Example of widget error message

Related pages:
- Widget Connector Macro
- Working with Macros
- Confluence User's Guide

Google Docs

This integration is currently broken. Please refer to 👤 CONF-24927 for details of the issue.

YouTube

http://au.youtube.com/watch?v=-dnL00TdmLY

Note: You must use the long YouTube URL, available under Share > Options. For detailed instructions, see the user's guide to the widget macro.

MySpace


Vimeo

http://www.vimeo.com/909808

BlipTV

This integration is currently broken. Please refer to CONF-27266 for details of the issue.

Viddler

This integration is currently broken. Please refer to CONF-27267 for details of the issue.

Skitch
Skitch is now integrated with Evernote, as described in this blog post from The Next Web: Evernote is bringing Skitch into its core service, Skitch.com will be archived. As a result, private images on Skitch.com are no longer accessible and will not work in the Confluence widget connector. Existing public images on Skitch.com will remain available.

**Twitter**

![Twitter Logo](http://twitter.com)

http://twitter.com/mcannonbrookes

**FriendFeed**

![FriendFeed Logo](http://friendfeed.com)

http://friendfeed.com/mynname

**SlideShare**

![SlideShare Logo](http://www.slideshare.net)

http://www.slideshare.net/jleyser/using-jira-greenhopper-for-agile-development-presentation

**SlideRocket**

![SlideRocket Logo](http://app.sliderocket.com)

http://app.sliderocket.com/app/FullPlayer.aspx?id=132f9db7-b0fb-4f51-b974-36652774971b

**Scribd**

![Scribd Logo](http://www.scribd.com)


**Wufoo**
Example of widget error message

This is an example of the error message you will see, if the Widget connector cannot find the URL or service specified.

http://example.com

http://example.com/invalid

Working with Files

Share your team's PDFs, Office documents, images, and more in one place by uploading your files to Confluence. Automatic versioning, instant previews, permissions, and full-text search, means shared network drives can be a thing of the past for your team.

When you upload a file it is attached to the current page or blog post. This is why files are often referred to as attachments in Confluence.

You can attach anything from project plans and design mockups to video and audio files. You and your colleagues can also collaborate by commenting on files displayed on Confluence pages.

Using Files

- Displaying Files and Images
- Uploading Files
- Managing Files
- Collaborating on Files
- Office Connector Prerequisites
- Editing Office Files

Permissions

The 'Add Attachment' and 'Delete Attachment' permissions are used to control who can upload and delete attachments in a space.

Users with 'Add Page' or 'Add Blog' permissions can insert existing attachments to their pages, but not upload new attachments unless they also have the 'Add Attachment' permission.

There is no permission that controls downloading attachments. See our knowledge base article about disabling the download of attachments if you need to do this.

Displaying Files and Images

Files can be displayed on a page as a thumbnail, a link or embedded using a macro. There are a few different ways to Upload Files.

How files are displayed depends on the type of file you uploaded.

Displaying images
Add interest to your pages by adding images. You can display all common image types including .jpeg, .png, .gif and .bmp (depending on browser support).

Inserting an image

There's a few ways you can insert an image into your page:

- Go to Insert > Files and Images on the editor toolbar and then either upload some files or select existing files, or
- Drag the image file directly into the editor, or
- Type ! and choose an attached image from the autocomplete drop down.

Inserting an image attached to a different page

You can display an image that is attached to a different page of the same Confluence site, if you know the name of the image.

To display an image attached to a different page:

1. Go to Insert > Files and Images and choose the Search on other pages.
2. Enter the name of the image.
3. Choose whether to search the current space or All Spaces and choose Search.
4. Select the required image from the search results and choose Insert.

Alternatively, you can cut and paste the image from another page (the image will still be attached to the original page).

Inserting an image from the web

You can display an image from a remote web page on your Confluence page, without needing to attach it to your page. You need to know the URL for the image, not for the web page it appears on.

To display an image located on a web page:

1. While editing the page, position the cursor where you want to place the image.
2. Choose Insert > Files and Images and choose Images from the web.
4. Choose Preview to check that the URL and image are correct.
5. Choose Insert.

Alternatively, you can simply copy and paste the image from a web page.

Changing the image appearance

When editing the page, select the image to show the image properties panel. The panel allows you to set the display size, add a border and effects and link the image to other pages.
From the image properties panel you can:

- Choose a **preset size** for the image
- Enter a **width** for the image (between 16px and 900px)
- Add a **border** around the image
- **Link** the image to a page or URL
- **Align** the image (you can use the left and right align buttons to make the text wrap around the image too)
- Add a title, which is shown when you hover over the image (go to **Properties > Title**)
- Add alt text, which is used by screen readers and when the image can't be shown (go to **Properties > Title**)
- Add **effects** to the image such as drop shadow or snapshot (go to **Properties > Effects**).

**To add a caption to an image using the Instant Camera effect:**

- Choose **Effects** in the image properties panel and choose the **Instant Camera** image effect.
- Save the page.
- Go to *** > Attachments** to go to the 'Attachments' view of the page.
- Choose **Properties** next to the image file.
- Add a **comment** to the attachment. The text in your comment will appear as the image caption.

You will need to re-enter the comment each time you upload a new version of the image.

Note: The Instant Camera effect only works with Latin character languages, due to a lack of handwriting style fonts in multi-byte languages.

**Deleting images**

If you delete an image on a page, the attached file will not be deleted from the page. Go to *** > Attachments to delete the attachment completely from the page.

Seeing an 'unknown attachment' placeholder on your page? This means that the attached file has been deleted from the page (or another page).

**Previewing images and PDFs**

Click an image or PDF link when viewing a page to launch the preview.

The preview includes images from the web that are displayed on the page, or images and PDFs that are attached to the page (even if they are not currently displayed on the page).

In the preview you can:

- Download the image file.
- Upload a new version of the file.
• Comment on the file.
• Zoom in, out or fit the image to the width of your browser.
• Browse like a slideshow using the next and back buttons.
• See other files attached to the page and select a thumbnail to preview that file.

Note: Internet Explorer 9 may preview PDF files in low quality. You can download the file to view the original version.

Displaying multimedia files

You can display multimedia files (such as video, audio and animation) that are attached to your page using the Multimedia Macro.

Display online multimedia (such as YouTube or Vimeo videos) using the Widget Connector Macro.

Displaying Office files and PDFs

Inserting a file in a page is a great way to make useful documents, spreadsheets, presentations and other files available to your team.

There are several ways you can display an office or PDF file on a page:

• as a link - people can click the link and download the file.
• as a thumbnail - people can click the thumbnail to preview (Office and PDFs) or download the file (other file types).
• embedded in the page - people can view the content of the file without leaving the page.

Displaying a file as a thumbnail or a link

In the editor go to Insert > Files and select a file to insert. The file will appear on your page as a thumbnail.

Click the thumbnail to resize it or to switch to showing the file as a link.

Embedding a file in the page

You can embed PDFs, presentations, spreadsheets and other Office documents into your page using a View File macro.

Drag a PDF or Office file into the editor to automatically upload it and embed it into the page.

See View File Macro to find out more.

Displaying other file types

Other file types can be uploaded and displayed on the page as a link or with a placeholder thumbnail.

Displaying a list of files on a page

There are several ways you can display a list of files on a page. You can:

• Use the Attachments Macro to show files attached to the current page.
• Use the Space Attachments Macro to show all files in a space.
• Use the Gallery Macro to show thumbnails of images attached to a page.

You can also use the File List blueprint for uploading, viewing and managing lists of files.
Notes

**Image effects**

Displaying image effects can be resource intensive. Confluence limits the threads that are dedicated to displaying image effects so that it does not impact your whole instance. If a thread is not available, Confluence will display the image without the effect.

The following knowledge base article provides information if you need to adjust the number of threads - *Image effects are not displayed in Confluence 5.5 or later.*

**Uploading Files**

When you upload a file, such as an image or document, it will be attached to the current page.

You can then choose to display the file on the page as a link, an image or embed it in the page (using a macro).

To upload a file you'll need the ‘Add Attachments’ space permission.

**Uploading a file**

There are many ways to attach a file to a page.

In the editor you can:

- Drag the file directly onto the page.
- Go to **Insert > Files and images** and upload a file.

When viewing a page you can:

- Drag the file directly onto the page.
- Go to ***** > Attachments** and upload a file.

You can attach multiple files at a time.

**Accepted file types**

Confluence allows you to attach most file types, but you cannot attach a folder of files (including folders created by applications like Keynote - you’ll need to export your presentation to zip or other format).

Although just about any file type can be attached to a page, not all file types can be displayed on or embedded in a page. See **Displaying Files and Images** to find out more.

**File versions**

If you upload a file with the same name as an existing attachment on the same page, Confluence will overwrite the existing attachment. Version history is kept for all attachments. See **Managing Files** to find out more.

Any changes you make to the source file will not affect the copy that was uploaded to Confluence. To update the Confluence copy, you need to upload the new version of the file.

**Notes**

⚠️ We recommend you don't use special characters in page or attachment names, as the page or attachment may not be found by Confluence search, and may cause some Confluence functions to behave unexpectedly.
Managing Files

Files are attached to Confluence pages. See Uploading Files to find out about attaching files to pages.

Once attached you can download, delete and edit these files, for example if you need to upload a new version of the file, or change the page it is attached to.

Download attached files

Any user with permission to view a page can also download any files attached to that page.

To download an individual file:

- Click the Download button in the file preview, or
- Go to *** > Attachments
- and then right click on the file name and save the link.

To download all files attached to a page as a zip file:

1. Go to *** > Attachments
2. Click Download All.

There's no option to download all attachments in a space.

Delete an attached file

You'll need the 'Delete Attachment' space permission to delete an attached file.

To delete all versions of an attached file:

1. Go to the page that contains the attachment.
2. Go to *** > Attachments
3. Choose Delete next to the attachment you want to delete.
4. Choose Delete to confirm your action.

Space Admins can also delete a specific versions of an attachment:

1. Go to *** > Attachments
2. Click the expand arrow next to the attachment name to see the list of attachment versions
3. Choose Delete next to the version you want to delete.

Screenshot: Attachments and attachment versions

### Attachments

<table>
<thead>
<tr>
<th>Name</th>
<th>Size</th>
<th>Creator</th>
<th>Creation Date</th>
<th>Labels</th>
<th>Commeter</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="attachment" alt="penguin.png" /></td>
<td>5 kB</td>
<td>Rach Admin</td>
<td>Feb 15, 2013 15:33</td>
<td>penguin, chocolate</td>
<td>Updated</td>
</tr>
<tr>
<td>Version 2 (current)</td>
<td>5 kB</td>
<td>Rach Admin</td>
<td>Feb 15, 2013 15:33</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Version 1</td>
<td>5 kB</td>
<td>Josh User</td>
<td>Feb 14, 2013 10:58</td>
<td></td>
<td></td>
</tr>
<tr>
<td><img src="attachment" alt="IBugs.gif" /></td>
<td>22 kB</td>
<td>Josh User</td>
<td>Feb 15, 2013 14:51</td>
<td>useful, logo</td>
<td></td>
</tr>
<tr>
<td><img src="attachment" alt="site-logo.png" /></td>
<td>2 kB</td>
<td>Josh User</td>
<td>Feb 15, 2013 14:51</td>
<td>logo, confluence</td>
<td></td>
</tr>
</tbody>
</table>
Upload a new version of an attached file

There are two ways up upload a new version of an attached file. You can:

- Upload a file with the same file name to the page.
- Use the **Upload a new version** button in the file preview to upload a file with a different name (for images and PDFs only).

To view attachment versions:

- Go to *** > Attachments
- Click the expand arrow next to the attachment name.

All earlier versions of the file will appear.

You can’t revert to an earlier version of the file, but you can choose to remove earlier versions if you have Space Administrator permissions.

Move a file to another page

You’ll need the ‘Add Page’, ‘Add Attachment’ and ‘Remove Attachment’ space permissions to move an attached file to another page.

To change the page that a file is attached to:

- Go to *** > Attachments
- Choose Properties next to the attachment you want to move.
- Enter the name of the page you want to move the attachment to (for example My Destination Page).
- Choose Save.

If you want to move the file to a page in another space, add the space key before the page name (for example DOC:My Destination Page).

Edit properties of an attached file

You’ll need the ‘Add Attachment’ permission in the space to edit the file properties.

To edit the properties of an attached file:

- Go to *** > Attachments
- Click Properties beside the attachment you want to edit.

You can:

- change the file name
- add a comment (used in the version list and also by the Snapshot image effect)
- change the MIME type
- move the attachment to another page
- add a label.

Changing the MIME type may cause your file to display incorrectly.

View all attached files in a space

There are two ways you can view all files in a space. You can:

- Use the Space Attachments macro to display the list of files on a page.
- Go to the space and choose Space tools > Content Tools from the bottom of the sidebar Then choose Attachments.

If your space uses the Documentation theme go to Browse > Space Operations > Attachments.

You can use the filters to only show files with a particular label or file extension.

**Screenshot: Space attachments macro**
Collaborating on Files

Collaboration doesn't just happen on pages. Often you'll need to collaborate with your team on documents, presentations, images and spreadsheets. Whether it's mockups for a new marketing campaign or a full project plan, you can simplify your team's feedback loop by working together on files in Confluence.

Share a file

Do you have lots of files on a page and want to get a team member's input on just one of them? You can share the file with them directly.

It works just like sharing a page:

1. Click the thumbnail or link to preview the file
2. Choose the Share button
3. Enter an email address, user name or group name, add your message and send.

Your team members will get an email with your message and a link to view the file.

Notifications are only sent by email, they won't appear in the workbox.

Comment on a file

Whether it's an image – like a mockup of the new marketing campaign that needs feedback – a PDF, a presentation, or any other file you can display in Confluence, you can drop a pin anywhere on the preview and add your comment to start a conversation.

To comment on a file:

1. Click the thumbnail or link to preview the file.
2. Drag the pin icon from the bottom of the preview and drop it where you want to comment.
3. Add your comment and Save.

Pinned comments work just like inline comments on pages. You can use @mentions, links, and macros, and drop as many pins as you need on any part of the file. Anyone with permission to add comments to the page can add and reply to comments on a file.
When you preview a file, you'll see pins for any existing comments. Select a pin to view the comment. Once the conversation is finished, you can resolve the comment to hide it (and any replies) from view. If you need to see resolved comments again, you can reopen them. Go to ☰ > Resolved comments in the preview.

You can't comment on or upload a new version of files that are hosted on a web server and added to Confluence using their URL.

Edit a file

Need to go beyond commenting on files? You can even edit some files right from the Confluence page. See Editing Office Files to find out about supported file types and applications.

Office Connector Prerequisites

Share and collaborate on documents, spreadsheets and presentations with your team.

The Office Connector allows you to embed, import, and edit office documents (such as Word, Excel and PowerPoint) within Confluence.

The browser, operating system and applications required depend on what you are trying to do with an office file.

Viewing Office and PDF files

Office and PDF files are embedded onto a page using the View File Macro. The macro can display files
compatible with Microsoft Office 97-2013, and PDF files, of the following types:

- .doc and .docx
- .xls and .xlsx
- .ppt and .pptx
- .pdf

You do not need to have an Office application installed on your computer in order to view Office files in Confluence.

**Importing Word documents as pages**

Confluence can import the content from Microsoft Word 97-2013 documents (.doc and .docx).

**Editing Office files attached to a page**

The Office Connector allows you to edit Office files that are attached to pages.

You'll need to use a browser, operating system and application (either Microsoft Office or OpenOffice) as described in the compatibility matrix below.

Here's a few common issues:

- **Using Chrome?** You can't edit Office documents as Chrome does not support WebDAV clients. See CONF-23322.
- **Using Firefox?** You'll need to install the WebDAV add-on. See Installing the Firefox Add-On for the Office Connector.
- **Using Internet Explorer?** You can only edit documents in Microsoft Office. OpenOffice is not supported.
- **Using Mac OSX or Linux?** You can only edit documents in OpenOffice. Microsoft Office is not supported. See CONF-17250.
- **Not seeing the Office Connector options?** Your system administrator may have disabled all or part of the Office Connector. See Configuring the Office Connector.

**Configuration matrix**

You need one of the following software combinations to edit Office files from your Confluence page.

<table>
<thead>
<tr>
<th>Software</th>
<th>Operating System</th>
<th>Browser</th>
</tr>
</thead>
<tbody>
<tr>
<td>Microsoft Office 2013</td>
<td>• Windows 7&lt;br&gt;• Windows 8</td>
<td>• Internet Explorer 11&lt;br&gt;Firefox – latest stable version</td>
</tr>
<tr>
<td>Microsoft Office XP, 2003, 2007, 2010</td>
<td>• Windows 7&lt;br&gt;• Windows Vista&lt;br&gt;• Windows XP (Service Pack 2 or 3)</td>
<td>• Internet Explorer [supported versions]&lt;br&gt;Firefox – latest stable version</td>
</tr>
<tr>
<td>OpenOffice 2.x – 3.x</td>
<td>• Windows 7&lt;br&gt;• Windows Vista&lt;br&gt;• Windows XP (Service Pack 2 or 3)&lt;br&gt;• OS X&lt;br&gt;• Linux</td>
<td>• Firefox – latest stable version&lt;br&gt;Internet Explorer [supported versions]&lt;br&gt;(Windows Platforms only)</td>
</tr>
</tbody>
</table>

Note: The only known supported Office editor for Linux is OpenOffice. But in theory it should work with any WebDAV-aware application.

If you experience problems editing documents using the Office Connector (using an application, operating
system and browser combination above) please raise an issue and tell us as much as you can about your operating system, application version, document version (if its different to the version of Office / Open Office you’re using to open the document) and browser.

Troubleshooting

Having problems with the Office Connector?

- The WebDAV plugin must be enabled, because the Office Connector uses WebDAV to transfer information to and from Office documents. The WebDAV plugin is bundled with Confluence, and can be enabled or disabled by the System Administrator. If necessary, refer to the instructions on enabling plugins and configuring the WebDAV options.
- Ensure that your Confluence server's base URL is set correctly (see Configuring the Server Base URL to find out how to check this). When a user edits a Confluence page in Word and then uploads the page back to the Confluence server, the base URL determines where the document will be saved. If the base URL is incorrect, the documents may be saved to a different Confluence server.

See the Office Connector Limitations and Known Issues knowledge base article for more troubleshooting tips.

Installing the Firefox Add-On for the Office Connector

If you are using Firefox as your browser, you will need to install an add-on into Firefox (the Firefox WebDAV Launcher) in order to use some features of the Office Connector. You will be prompted to install the add-on the first time you try to use a function which requires it.

For more information on the browsers, operation systems and application combinations required to use the Office Connector see Office Connector Prerequisites.

Installing the Firefox Add-On

The first time you try to edit an attached Office document in Firefox you'll be prompted to install a WebDAV add-on for your browser. Without this add-on you can't edit Office documents from Firefox.

1. Choose Edit in Office or Edit Document next to the document you wish to edit. You'll see a prompt to download the add-on.

2. Choose OK.

   Your browser will ask you to confirm that you want to allow the add-on.

3. Choose Allow.

   An installation dialog like the one below will appear.
4. Choose **Install Now**.
   Once the installation is complete you'll be prompted to restart Firefox. Make sure you've saved any open pages or other work in your browser before you restart.
5. Next you need to configure the add-on, and tell it which applications to use.

### Configuring the Add-On

After installing the add-on you need to configure it, to tell the add-on which desktop applications to launch for each file type.

Configuring the add-on is slightly different in each operating system.

#### Configuring the add-on in Windows

In most cases the add-on will automatically configure itself, based on information from the system registry. The first time you edit a new file type, the add-on will look up the default editor for that file type and make that the permanent setting.

If you want to override the registry settings, or the automatic configuration is not working, you can configure the Firefox add-on manually.

1. In Firefox locate the **WebDAV Launcher** add-on and choose **Options**.
   The WebDAV Launcher Options dialog, like the one below, will appear.
2. Enter a file extension in the **File Extension** field.
   For example, to associate the 'doc' file extension with Microsoft Word 2003 you would type **doc** in the **File Extension** field.

   **Using Office 2007 or later?**
   You should configure the WebDAV launcher to open both Office 2003 file extensions (doc, ppt and xls) and Office 2007 and later file extensions (docx, xlsx and pptx).

3. Enter the **Application Path** - you can either:
   - Choose **Auto** to load the associated application from the Windows registry, or
   - Choose **Browse** to find the application on your computer, or
   - Manually enter the path to the application's executable file.
4. Choose Add to add the file extension association to the list. Repeat this process for all the file extensions you need.

Configuring the Add-On in Mac OS X

The configuration procedure is similar to Windows, as shown above. Note that there is no 'Auto' button in Mac OS X.

Configuring the Add-On in Linux

The only known supported Office editor for Linux is OpenOffice (see Office Connector Prerequisites). There is no automatic configuration on Linux. You will need to associate each file type with your Office editor in Firefox. Note that there is no 'Auto' button in Linux.

The configuration procedure is similar to Windows. For both Ubuntu and OpenSUSE, the configuration will look something like this:

<table>
<thead>
<tr>
<th>File Extension</th>
<th>Application Path</th>
</tr>
</thead>
<tbody>
<tr>
<td>doc and docx</td>
<td>/usr/bin/oowriter</td>
</tr>
<tr>
<td>ppt and pptx</td>
<td>/usr/bin/ooimpress</td>
</tr>
</tbody>
</table>
Security Risks

Please be aware that there are security risks in installing this add-on to Firefox. Internet Explorer is exposed to the same risks, because it can directly open Office documents.

Summary of the risks:

- Office documents can contain macro viruses. Before opening an Office document, make sure that you trust the source of the document.
- There are known flaws in the Office file formats and Microsoft Office that an attacker can exploit to gain control of your machine. Microsoft has fixed the known exploits in the latest Service Packs for all Microsoft Office versions, but new exploits may arise at any time. Be sure that you trust the source of a document before opening it.

The add-on reduces the risk by supporting:

- **Same origin policy** - the add-on can only open documents from the same host that initiated the action.
- **Digital signature** - the add-on is digitally signed. When you install the add-on please verify that it is signed by Atlassian.
- **Prompt the user for confirmation** - You will always be warned before a file is opened. Please read these warnings carefully before opening a file. The warning tells you the complete URL of the file as well as the complete application path of the application opening the file.

Information about this Firefox add-on

<table>
<thead>
<tr>
<th>Add-on name:</th>
<th>WebDAV Launcher</th>
</tr>
</thead>
<tbody>
<tr>
<td>Description:</td>
<td>Adds the ability to launch a WebDAV URL directly in a WebDAV-aware client.</td>
</tr>
<tr>
<td>Latest version:</td>
<td>See the WebDAV Launcher add-on page at Mozilla</td>
</tr>
<tr>
<td>Compatible with:</td>
<td>All versions of Firefox, up to and including the latest stable version.</td>
</tr>
<tr>
<td>Author:</td>
<td>Atlassian Pty Ltd</td>
</tr>
</tbody>
</table>

Editing Office Files

The Office Connector allows you to edit attached office files in their native application (such as Word, Excel, PowerPoint or OpenOffice) and save the file right back to the Confluence page. No need to download and re-upload the file.

The Office Connector is only available for some browsers, operating systems and applications, check the Office Connector Prerequisites before you start for the combination that will work best for you.

Editing an attached document

To edit an Office document attached to a Confluence page:

1. Go to *** > Attachments
2. Choose **Edit in Office** beside the attachment you want edit.
   
   Your browser will ask you to confirm that you want to open the file.
3. Choose **OK**.
You may also see a security warning or be asked to log in to your Confluence server - enter your Confluence username and password, then choose OK.

4. The file will open in your Office application - make your changes then save the document. It will be saved back to Confluence

**Screenshot: Edit in Office option on the attachments page**

Other ways to edit

Edit options also appear when a page has:

- an Attachments macro (choose **Edit in Office** beside each attached office file)
- the Office Word macro or the Office Excel macro (choose **Edit Document** at the top of the embedded content)
- the Office PowerPoint macro (choose the edit icon ![edit](icon) at the bottom of the viewer).

**Screenshots: Edit links on embedded files**

Troubleshooting

Check out the **Office Connector Prerequisites** for the combinations of browsers, operating systems and office applications that are supported. Here's some common issues:

- **Using Chrome?** You can't edit Office documents as Chrome does not support WebDAV clients. See CONF-23322.
- **Using Firefox?** You'll need to install the WebDAV add-on. See Installing the Firefox Add-On for the Office Connector.
- **Using Internet Explorer?** You can only edit documents in Microsoft Office. OpenOffice is not supported.
- **Using Mac OSX or Linux?** You can only edit documents in OpenOffice. Microsoft Office is not supported. See CONF-17250.
- **Not seeing the Office Connector options?** Your system administrator may have disabled all or part of the Office Connector. See Configuring the Office Connector.

You can find more troubleshooting info in the **Office Connector Limitations and Known Issues** knowledge base article.

Sharing Content

Confluence is all about encouraging team collaboration, to get the best results, so we've built in a number of ways you can notify other people about content that may be of interest to them.

You can:

- **Share a link** to a page or blog post via email
- **Mention** a user when you write a page, blog post, comment, or add a task
- **Update your user status** so that it appears in Confluence activity
Streams
- Like a page, blog post or comment

Whenever you mention another user, they'll receive an email notification; if you like a page, blog post, or comment, the author will be notified that you like the content.

Other users can also find out about changes to content in Confluence by watching pages and spaces.

Another way to share Confluence content is by exporting it to other formats such as XML, HTML, Microsoft Word and PDF.

Network Overview

You can create a network of users who are important to you, to make sure you’re always up-to-date with their Confluence activity. You might want to follow your boss or teammates, to see what they’re working on, or whoever creates the most entertaining blog posts.

When someone’s part of your network, you’ll be able to see when they:
- Add or edit pages or blog posts
- Comment on a page or blog post or edit existing comments
- Update their user status
- Update their user profile

Follow another user

You can follow another user by using either their Hover Profile or your Network view.

To follow a user with their Hover Profile, hover your mouse over their profile picture when it appears in a page and choose Follow.

To follow a user from your Network view:

1. Choose your profile picture at top right of the screen, then choose Network
   Alternatively, choose More in the Network section of your profile sidebar.
2. Search for and select the user in the Following field
3. Choose Follow

If you now refresh or revisit your Network view, the profile picture(s) of the user(s) you just followed will appear within the Following list on the right. Their tracked activities will also start appearing in the Recent Activity list.

Access your network view

If you want to see what’s been happening in your network, access your network view as described above.

You can access another user's Network view using the Hover Profile by choosing More > Network Page.

Screenshot: Example of the Network view
Notes

- **RSS feeds**: you can subscribe to any Confluence user's network RSS feed and receive summaries on the activities of other users they're following in their network. See [Subscribing to a Network RSS Feed](#).
- **Email notifications**: you can request email notifications of any activity in your network. See [Subscribing to Email Notifications of Updates to Confluence Content](#).

### Likes and Popular Content

Has someone written a good blog post or page on Confluence? Or made a comment you agree with? Click the **Like** button to let them know. 📣 Like

When you like a page, blog post or comment, the author of the content receives a notification. If enough people like the content, it'll appear on the **Popular** tab of the **Dashboard**.

#### Disabling the 'like' feature

The **like** functionality is provided by a plugin called the 'Confluence Like Plugin'. To remove the **like** functionality from your site, [disable the plugin](#).

#### Disabling notifications when your content is 'liked'

There are two ways to turn the 'someone likes your page' notifications off.

Do either of the following:

- Open an email notification of a like, and click **Manage Notifications**
- Go to `<your confluence URL>/plugins/likes/view-notifications.action`
User Status Updates

You can set your 'user status' to let other Confluence users know what you're thinking about right now, or to broadcast any other short message (as long as it's less than 140 characters). Other users can see your status in recent activity stream on the dashboard, or on their network page if they're following you in Confluence.

Your current status message appears on the profile popup that appears when people hover over your username or profile photo in Confluence.

Setting or updating your status

To set or update your status:

1. Choose your profile picture at top right of the screen, then choose Update Status (the 'What are you working on' dialog will open)
2. Enter a short message (140 characters maximum)
3. Choose Update

Mention another person in your status update
You can include another person's Confluence username in your status update, using square brackets and the tilde sign in the format \[~username\]. Confluence will send that person an email message with your status update.

**Note:** Mentions in status updates don't appear as notifications in the Confluence workbox.

**Viewing status updates**

Your 'Status Updates' view shows a history of your status updates. To view your status updates, choose your profile picture at top right of the screen, then choose Status Updates. View another user's status by going to their profile.
You can also clear your latest status update, or delete older updates from this view.

Enabling and disabling status updates

The status update functionality is provided by a plugin called 'User Status'. To remove the status updates functionality from your site, you can disable the plugin.

You can also set the Confluence site permissions to determine which users can use status updates. By default, users will not have permission to use this feature. See Global Permissions Overview.

Using Mentions

Mentions (often known as @mentions) are a seamless way of drawing someone’s attention to a page or comment, or assigning a task to them. When you mention a user, they’ll receive a notification by email and in their workbox; if you mention them in a task, the task is assigned to them and appears in their tasks list.

There are two ways to mention someone: using autocomplete, or via the Insert menu in the editor toolbar.

Use autocomplete

To mention someone using autocomplete, type '@' in the editor then start typing their name. Choose the person you want to mention from the list of suggestions.

Screenshot: Autocomplete for mentions

Use the Insert menu

If you’d rather use the Insert menu, choose Insert > User Mention then search for and select the user you want to mention.

Notes

- Disable the user mention feature – The functionality is provided by a plugin called the 'Confluence Mentions Plugin'. If you need to remove the user mention functionality from your site, you can disable
the plugin. See Disabling or Enabling a Plugin.

- **Mentioning groups** – You can only mention individual users. There’s a feature request to allow mentions for groups: [CONF-23015 - Extend 'Mentions' to work with groups as well](CONFLUENCE_LINK)
- You can Mention people in status updates. See User Status Updates.
- **Link to a user profile** – You can use a square bracket `[]` and a person’s name to trigger Confluence autocomplete and link to a person’s user profile or personal space. Confluence will send the person a notification just as if you had used @mention (unless the administrator has disabled the user mention feature).

### Share a Page or Blog Post

You can use the 'Share' option in Confluence to email anyone a link to a page or blog post. The recipients can be Confluence users or any email address(es).

#### To share a link to a Confluence page or blog post:

1. Go to the page or blog post you wish to share
2. Choose Share

   - The Share button will only visible if your Confluence administrator has configured an outgoing mail server for your Confluence site.
3. Enter a username, group or email address, and select the appropriate user, group or email address from the list of suggestions
4. Repeat this process to add multiple recipients to the list.
5. Enter an optional message into the Note box
6. Choose Share to send the link via email

In addition to an email, Confluence users will also receive a notification in their Confluence workbox. See Managing Notifications in Confluence.

   - To remove a recipient from the list, choose the delete icon to the right of the recipient.

### Commenting on pages and blog posts

Comments are a great way to bring others into the conversation about a page or blog post. They allow you to remark on content, add important
information, or ask questions, and generally drive collaboration and teamwork. You can add a comment at the bottom of any page or blog post, or add an inline comment to specific text on the page.

Page comments are displayed at the bottom of the page, below the page content, and inline comments are displayed to the right of the page adjacent to the highlighted text.

Add a page or blog post comment

1. Type your comment in the comment field at the bottom of the page
2. Optionally, choose Preview to see how your comment will appear
3. By default, Watch this page is ticked (This means you’ll start receiving notifications about the page. Uncheck it if you don’t want to watch the page.)
4. Choose Save

Other users can reply and/or like your comment, and you or a space administrator can edit your comment(s).

Add an inline comment

1. Highlight the text you want to comment on
2. Choose the add comment button that appears above the highlighted text
3. Type your comment and choose Save

The selected text will appear with a yellow highlight indicating an inline comment; choose any highlighted text on the page to display the related comment(s).

Inline comments might look simple, but they support rich text – like bold, underline, and italics – links, and @mentions. Just like page and blog post comments, others can reply to, or like, your inline comments, and you’ll be notified when they do.

You can also resolve inline comments once the conversation’s finished, and reopen them at any time if they’re needed.

If you don’t see a popup when you highlight text, check that Text Select is enabled in your profile settings.

View and reopen resolved comments

If you want to view and/or reopen resolved comments on a page or blog post, choose *** > Resolved comments, then choose Reopen.

Link to a comment

You can link directly to a comment on a page. See Working with Links for more information.
Comment permissions

- **Add a comment** – You need the ‘Add Comments’ permission in the space.
- **Edit a comment** – You need the ‘Add Comments’ permission. Space administrators can edit all comments within their space. The date on a comment always indicates the time the comment was last edited.
- **Delete a comment** – You need the ‘Remove Comments’ permission. Deleted comments cannot be restored. If you don’t have the ‘Remove Comments’ permission, you can delete your own comments, but only if there are no replies to your comment.
- **Disable comments** – If you don’t want comments in a particular space, remove the ‘Add Comments’ permission from the ‘confluence-users’ or ‘users’ group, anonymous users and all other users and groups. The option to add comments will no longer appear on pages or blog posts in that space.

See [Space permissions](#) for more information. There is no permission that controls comments across the entire site.

Notes

- Choose **Watch** at the top-right of the page to receive an email notification whenever anyone edits or adds a comment to the page.
- On blog posts only, an ‘Author’ lozenge will appear on any comments made by the original author of the post.
- It’s not possible to delete all comments on a page simultaneously, or change the order of comments.

### Exporting Content to Word, PDF, HTML and XML

You can export all or part of a Confluence space to various formats, including Microsoft Word, HTML, PDF and XML. Use the panel on

To use the space export functionality, you need the ‘Export Space’ permission. See the guide to [space permissions](#).

**Export single pages to Word or PDF**

If you need to send content to people who don’t have access to Confluence, you can export a single page as a Word document or a PDF. You can also export a single blog post to PDF.

If you’ve got permission to view the page in Confluence, you’ll be able to export it in this way; go to the page and choose either **Tools > Export to Word** or **Tools > Export to PDF**.

When you export a single page to PDF, the PDF stylesheet customisations are applied, but any PDF layout customisations aren’t. To make your PDF layout customisations apply to a single page exported to PDF, you’ll need to use the ‘multiple page’ method described below to export the single page. See [Customising Exports to PDF](#).

**Export to HTML, XML, or PDF**

If you want to export a space – or selected pages in a space – to HTML, XML, or PDF, Confluence can create a zipped archive of the HTML or XML files, or a single, downloadable PDF file.

The HTML export is useful if you want convert your space into a static website, or you can use the XML export option if you need to import the space into another Confluence site, or use the data from the space in
another application. You might use the PDF option if you're producing a user manual from your technical documentation in Confluence.

To export pages to HTML, XML, or PDF:

1. Go to the space and choose **Space tools > Content Tools** from the bottom of the sidebar
2. Choose **Export**
3. Select either **HTML**, **XML**, or **PDF**, then choose **Next**
4. Select either a normal or custom export for HTML or PDF, or a Full or Custom XML export:
   - **Normal Export (HTML and PDF)** – to produce an HTML file containing all the pages that you have permission to view.
   - **Full Export (XML)** – to produce an XML file containing all the pages in the space, including those that you do not have permission to view.
   - **Custom Export** – if you want to export selected pages only, or if you want to exclude comments from the export.
5. Choose **Export**

Blog posts aren't included when exporting to PDF using this method, and comments are never included when exporting to PDF.

When the export process has finished, you can download the zipped archive or PDF.

If your space uses the Documentation theme, choose **Browse > Space Operations**, then choose either **HTML**, **XML**, or **PDF Export** from the left menu, and follow the steps above to export the Space.

Customising the appearance of PDF exports

You can add a title page, table of contents, and customised headers and footers to the PDF output. For more advanced customisations, you can apply Cascading Style Sheet (CSS) modifications. These customisations are specific to each space, and you need the ‘Space Administrator’ permission to apply these customisations. For more information, see Customising Exports to PDF.

Notes on PDF exporting

- To export a PDF containing international text, you need to [install a Unicode font in Confluence](https://confluence-atlassian.readthedocs.io/en/latest/customizing-exports-to-pdf.html).
- Confluence’s PDF export feature is designed to handle a wide variety of content, but on rare occasions the PDF Export process may fail due to an unrecognised customisation. If that happens, the PDF export screen will indicate the title of the page in which the problem occurred, to help you diagnose the cause of the failure.

Notes on HTML exporting

- In the zip file, page attachments are placed in individual folders with names in the following format: `...\download\attachments\xxxxxx` where 'xxxxxx' is the page ID of the page containing the attachments.
- Blog posts aren't included in the HTML export. See the feature request: [CONF-14684 - Export news to HTML](https://confluence-atlassian.readthedocs.io/en/latest/customizing-exports-to-pdf.html).
- To customise the HTML output, you'll need to modify the file `confluence-x.y.z-jar/com/atlassian/confluence/pages/Page.htmlexport.vm`. To learn how to repackage this file, see [How to Edit Files in Confluence JAR Files](https://confluence-atlassian.readthedocs.io/en/latest/customizing-exports-to-pdf.html).

Notes on XML exporting

- See [Restoring a Space](https://confluence-atlassian.readthedocs.io/en/latest/customizing-exports-to-pdf.html) for notes on restrictions when importing a space.
- If you're doing the export for backup purposes, consider another means of backup. See [Production Backup Strategy](https://confluence-atlassian.readthedocs.io/en/latest/customizing-exports-to-pdf.html).
- If you are running Confluence behind Apache HTTP Server and are facing timeout errors, please consider creating the export directly from Tomcat, instead of going through Apache. This will speed up the process and prevent timeouts.

Customising Exports to PDF
Confluence administrators and space administrators can customise the PDF exports for individual spaces.

Please note:

- PDF customisations are unique to each space.
- PDF customisation only applies to space exports (not single page exports via Tools > Export to PDF).
- Confluence's PDF customisations use a combination of HTML and CSS (Cascading Style Sheets).
- To achieve a particular requirement in the exported PDF file, you make changes in one or both of the following:
  - The PDF Layout, where HTML is used to define the structure of the exported content, including features such as the title page, headers and footers.
  - The PDF Stylesheet, where CSS is used to define the style of elements in the exported content, such as page size and margins, font, colour, and list numbering.

For further customisations, see the Advanced PDF Export Customisations page.

Customising the PDF Layout

You can add your own HTML to customise the title page, page headers and page footers in the PDF output.

**Setting a global PDF layout**

1. Choose the cog icon 🔄, then choose **General Configuration** under Confluence Administration.
2. Choose **PDF Layout**. You can enter HTML and CSS that will be rendered on the PDF title page, as well as page headers and footers.

**Setting the PDF layout at space level**

1. Go to the space and choose **Space tools > Look and Feel** from the bottom of the sidebar. You'll need **Space Admin permissions** to do this.
2. Choose **PDF Layout**.
3. Choose **Edit**.

If your space uses the Documentation theme:

1. Choose **Browse > Space Admin** from the header.
   
   **Note:** The **Space Admin** option appears only if you have **space admin permissions**, or if you're part of the 'confluence-administrators' group.

2. Choose **PDF Layout** in space administration options.
3. Choose **Edit**.

You can customise the HTML that is generated for the following areas when the space is exported to PDF:

- **PDF Space Export Title Page** – title page.
- **PDF Space Export Header** – page headers.
- **PDF Space Export Footer** – page footers.

Enter your customisations into each text box as required. The PDF layout section accepts HTML code. You can include inline CSS in the HTML too.
Customising the PDF Stylesheet

You can adjust the appearance of the PDF pages by customising the CSS in the PDF Stylesheet screen.

To get started, download the default CSS rules for the PDF stylesheet - `confluencedefaultpdf.css`.

Any rule defined in this file can be customised and added to the PDF Export Stylesheet section. Your customisations override any default CSS rule. If no customisations are defined, the default CSS rules will be applied.

By default, the export does not include a title page, headers or footers. You can define these in the PDF layout.

To customise the PDF Stylesheet:

**Setting a global PDF Stylesheet**

1. Choose the cog icon, then choose **General Configuration** under Confluence Administration.
2. Choose **Look and Feel > PDF Stylesheet**. The following screen allows you to enter and save CSS code that will render content on each page.

**Setting a space PDF stylesheet**

1. Go to the space and choose **Space tools > Look and Feel** from the bottom of the sidebar. You'll need **Space Admin permissions** to do this.
2. Choose **PDF Stylesheet**.
3. Choose **Edit**.
4. Enter your customisations.

If your space uses the Documentation theme:

1. Choose **Browse > Space Admin** from the header

   **Note:** The **Space Admin** option appears only if you have **space admin permissions**, or if you're part of the 'confluence-administrators' group.
2. Choose **PDF Stylesheet** in the space administration options.
3. Choose **Edit**.
4. Enter your customisations.
The PDF Export Stylesheet field accepts Cascading Style Sheets (CSS) rules. The 'PDF Export Stylesheet' page shows the current (e.g. customised) contents of your PDF stylesheet.

Example Customisations

This section provides examples of typical customisations that you can add. See also Advanced PDF Customisations.

**Page Size**

The default page size is based on the location of your Confluence server. For example, if this server is located in the US then the default paper size of your PDF export will be US Letter (8.5 inches wide by 11 inches long). If the server is located in Australia, the default paper size will be A4 (210 mm wide by 297 mm long). More information about paper sizes can be found on Wikipedia.

To modify the page size to A4, edit the PDF Stylesheet to add a `size` property to the `@page` rule, like this:

```CSS
@page
{
/*The A4 paper size is 210 mm wide by 297 mm long*/
size: 210mm 297mm;
}
```

**Page Orientation: Landscape or Portrait**

To change the page orientation of your PDF document, simply reverse the order of the values declared in the `@page` rule's `size` property. The first and second values of this property represent the width and height of the page, respectively.

For example, to generate PDF space exports in A4-sized landscape orientation, your `@page` rule might look like this:

```CSS
@page
{
/*A4-sized pages in landscape orientation are 297 mm wide by 210 mm long*/
size: 297mm 210mm;
}
```

**Page Margins**

To set all margins to 15 mm, with a paper size of A4, edit the CSS `@page` rule in the PDF Stylesheet, like this:

```CSS
@page
{
/*The A4 paper size is 210 mm wide by 297 mm long*/
size: 210mm 297mm;
margin: 15mm;
}
```

To set the margins independently, edit the `@page` rule as follows:
To set margins to provide a gutter for binding a printed document, use the :left and :right pseudo-classes, as follows:

```css
@page :left
{
  margin-left: 4cm;
  margin-right: 3cm;
}
@page :right
{
  margin-left: 3cm;
  margin-right: 4cm;
}
@page :first
{
  margin-top: 10cm /* Top margin on first page 10cm */
}
```

Note the use of the :first pseudo-class in the example above to define distinct margins for a cover or title page.

**Page Breaks**

By default, Confluence pages are exported without page breaks, so that shorter pages will appear on the same PDF page.

To make each Confluence page appear on a separate page in the PDF file, add the following rule in the PDF Stylesheet:

```css
.pagetitle
{
  page-break-before: always;
}
```

**Title Page**

You can add a title page to your PDF document by adding HTML to the Title Page section of the PDF Layout screen. The following example creates the title page and adds a title:
Use CSS rules in the PDF Stylesheet to control the appearance of the title page and the title text:

```css
.fsTitlePage
{
    margin-left: auto;
    margin-top: 50mm;
    margin-right: auto;
    page-break-after:always
}
/fsTitle
{
    font-size: 42px;
    font-weight: bold;
    margin: 72px 0 4px 0;
    text-align:center;
}
```

**Adding an Image to the Title Page**

In the example above, the title page includes an image called 'titlepage.png', centred in the middle of the page. The "590719" in the src attribute is the ID number of the page to which the image is attached.

Follow these instructions to include an image on your title page:

1. Attach the image to a Confluence page.
2. View the list of attachments on that page, then right-click the image and copy its location.
3. Paste the link into the appropriate src="" attribute in your PDF Stylesheet, as shown above.
4. Edit the image URL so that it is relative, by removing the first part of the URL before /download/....

**Table of Contents**

By default, a table of contents will be generated after the title page, or at the beginning of the PDF document if no title page is defined in the PDF Layout. To see the default CSS rules applied to the table of contents, download the default CSS rules (confluencedefaultpdf.css) and examine the specific rules with toc in their name.

To make changes to the appearance of the table of contents, define CSS rules in the PDF Stylesheet.

**Disabling the Table of Contents**

To prevent the table of contents from being generated in your PDF document, add the div.toc-macro rule to the PDF Stylesheet and set its display property to none:
Changing the Leader Character in the Table of Contents

The leader character is used to link a heading in the table of contents with its page number. By default, the leader character is the '.' (dot) character. Leader values of dotted, solid and space are allowed. You can also use a string, for example leader(". . . ").

To change the leader character to a solid line, modify the leader() value on the content property of the CSS rule as follows:

```
span.toclead:before
{
  content: leader(solid);
}
```

Headers and Footers

You can add headers and footers to your PDF pages using the 'Header' and 'Footer' sections of the PDF Layout screen. By default, headers and footers only apply to a space export and not to exports of single pages (however, see Advanced PDF Export Customisations). The following example adds a simple copyright notice.

```
Copyright © 2013, Atlassian Pty Ltd.
```

Page Numbering

To add page numbering, you need to combine customised HTML in the PDF Layout with customised CSS in the PDF Stylesheet.

1. PDF Layout HTML: In the Footer section (or the Header section), use an empty span element with a unique ID, for example pageNum, to act as a place holder for the page number.

```
<span id="pageNum"/>
```

2. PDF Stylesheet CSS: Create the following CSS selector rule for the empty span:
## Analysing the above CSS selector rule in more detail:

- The `#pageNum` rule selects the HTML element with the specified ID of "pageNum", which is the span element we created for the header or footer.
- The `:before` part of the selector is a pseudo class that allows the insertion of content before the span element is processed.
- The `counter(page)` is a function that returns the current page number as its content.
- The `content` property tells the CSS processor that dynamic content (that is, an incrementing page number) is to be inserted at the span tag.

### Wrapping Long Words

In order to break long words or words that are not separated by whitespace, add a selector to the PDF stylesheet containing the `word-wrap` property with a value of `break-word`:

```css
CSS - PDF Stylesheet

div
{
  word-wrap: break-word;
}
```

### General Formatting

You can use the stylesheet to customise the output of just about anything else that will influence the look and feel of the final document. This includes fonts, tables, line spacing, macros, etc. The export engine works directly from the HTML output produced by Confluence. Therefore, the first step in customising something is to find a selector for the HTML element produced by Confluence or the Confluence macro. Then add a CSS rule to the PDF stylesheet. Your customisation will appear in the PDF export.

### Notes

- **Demotion of heading elements: h1, h2, and so on.** Due to the hierarchical manner in which a space is exported, Confluence will modify the heading elements to generate a uniform appearance for the entire space export. This means that headings will be demoted. This will affect the application of custom PDF Stylesheets. It is possible to calculate the amount by which a heading will be demoted in order to have the correct CSS styling applied. A heading will be demoted by the value of its depth in the export tree. A page at the first level will be demoted by 1 (all `<h1>` elements will become `<h2>` elements, and so on). A page at the second level will be demoted by 2, and so on.

- **Atlassian support for PDF customisation is limited.** We support the mechanism for customising the PDF layout with HTML and CSS, and we will help if the mechanism is broken or does not work as we say it should in our published examples. But, since custom HTML and CSS offer potentially limitless possibilities, Atlassian will not support issues that are caused by or related to PDF customisations.

### Related Topics

- Advanced PDF Export Customisations
- Advanced PDF Export Customisations
This page provides information about 'advanced' PDF export customisations. These expand upon the regular customisations described in Customising Exports to PDF.

⚠️ The information below is for advanced users. Customisations are not supported by Atlassian. Be aware that the advanced customisations described below require knowledge of certain parts of Confluence, and of CSS and HTML. This documentation is intended for advanced users. Some of the suggestions below are moderately complex, or irregular in nature. If you are having trouble understanding them we strongly suggest you ask an expert. We do not support any of the customisations described below. This means that the Atlassian support engineers will not be able to help you with these modifications.

**On this page:**
- Header and Footer
  - Adding Headers and Footers to Single Page Exports
  - Adding Images to Headers and Footers
- Incorporating Other Fonts
- Adding a Dynamic Title to the Title Page
- Hiding Text from the PDF Output
- Indexing
- Notes

**Related pages:**
- Customising Exports to PDF
- Confluence User's Guide

---

**Header and Footer**

**Adding Headers and Footers to Single Page Exports**

Single page exports don't support adding HTML headers and footers via the PDF Layout page, but you can use CSS rules in the PDF Stylesheet page (Space tools > Look and Feel > PDF Stylesheet) to produce headers and/or footers for a single page export.

For custom headers, define any of the following rules within your `@page` rule: `@top-left`, `@top-center`, and `@top-right`. These rules allow you to define the content of the left-hand side, centre and right-hand side of your page's header area, respectively.

For custom footers, define `@bottom-left`, `@bottom-center` and `@bottom-right` rules within your `@page` rule.

For example, the following rules add a document title at the centre of the header and a page number at the centre of the footer:
CSS - PDF Stylesheet

@page
{
    @top-center
    {
        content: "Document Title Goes Here"; /* This is the content that will
        appear in the header */
        font-family: ConfluenceInstalledFont, Helvetica, Arial, sans-serif;
        font-size: 8pt;
    }
    @bottom-center
    {
        content: "Page " counter(page); /* This is the content that will appear in
        the footer */
        font-family: ConfluenceInstalledFont, Helvetica, Arial, sans-serif;
        font-size: 8pt;
    }
    /* Any other page-specific rules */
}

Notes:

- The font-family and font-size properties ensure that the header and footer text is rendered in the same default font style used for the body text, based on the default CSS rules.
- It is not possible to use this method to insert images (stored as attachments within your Confluence instance) into the headers and footers of single page exports.

Adding Images to Headers and Footers

To insert an image into the header or footer, add HTML to the Header or Footer section of the PDF Layout screen.

The following example uses an HTML img element with src attribute to add an image to the left of the header. The src attribute refers to an image attached to a Confluence page. The image element is usually placed within a div element container.

```
<div style="margin-top: 10.0mm;">
    <img
        src="https://confluence.atlassian.com/download/attachments/12346/header-image.png"
    />
</div>
```

In the example above, the header includes an image called 'header-image.png'. The "12346" in the src attribute is the ID number of the page to which the image is attached.

Follow these instructions to include an image on your page:

1. Attach the image to a Confluence page.
2. View the list of attachments on that page, then right-click the image and copy its location.
3. Paste the link into the appropriate src="" attribute in your PDF Stylesheet, as shown above.
4. Edit the image URL so that it is relative, by removing the first part of the URL before /download/....

Notes:

- This example uses an inline CSS property margin-top in the style attribute to force the image away from the top of the page by 10mm. This comes in handy when your header image is large enough to
touch or spill over the top of the page.

- Likewise, for footers, you can use the `margin-bottom:XXmm` property to force an image away from the bottom of the page by ‘XX’ mm.
- Very large images can spill over into the body of a page or alter the position of text or other elements used within a header or footer. In such situations, it is recommended that you reduce the size of the image and then attach it to your Confluence page again. If you prefer to keep the image size and want to move the content lower instead, you can do so by configuring the `margin-top` properties in the @page CSS rule.
- By default, a header or footer image is aligned to the left-hand side of the page. However, you can align this image to the centre or right-hand side of a page by adding either the `text-align:center` or `text-align:right` properties to your style attribute. For example, to align the header image to the right-hand side of the page, your style attribute would look similar to this: `style="margin-top:10mm; text-align:right"`.

**Incorporating Other Fonts**

By default, Confluence provides Times New Roman, Helvetica or Courier fonts for use in PDF exports. You can use your own fonts for PDF exports by declaring them in a `@font-face` CSS rule in your PDF Stylesheet.

The following CSS rule example shows how to declare the Consolas font and apply it to some elements for your PDF export:

```
CSS - PDF Stylesheet
@font-face { src: url(file:///usr/share/fonts/Consolas.ttf); -fs-pdf-font-embed: embed; } .code pre, .preformatted pre, tt, kbd, code, samp { font-family: Consolas, monospace; font-size: 9pt; }
```

The font path specified in the CSS must be the path to the font on the Confluence server.

**Adding a Dynamic Title to the Title Page**

When you export an arbitrary set of pages from Confluence, you may like to have a corresponding title added to the cover (or title) page automatically. This can be done (in a somewhat irregular way) by using the top level item from the default table of contents as the title. This method relies on having the exported pages structured as sub-pages of the top-level page. In other words, the pages to be exported should consist of a page (at the top-level) and all of its child pages. The result is that the title that appears on the cover page changes depending on the top-level page that is used for the export.

The CSS below moves, and styles, the top-level TOC item for use as the title on the cover page, and turns off the leader and page number normally associated with this item in the TOC.

```
CSS - PDF Stylesheet
.fsTitlePage { position:relative; left:0px; } /* Turn off the default section numbering for this TOC item */ .toclvl0:before { content: &quot;"; counter-reset: chapter 0; } /* Hide the default page numbering for this TOC item */ .toclvl0 .tocnum { display: none; } /* Move and style this TOC item */ .toclvl0 { position:absolute; top:250px; font-size: 42px; font-weight: bold; margin: 72px 0 4px 0; text-align:center; }
```

**Hiding Text from the PDF Output**

This section describes a way to hide text from your PDF export. In other words, you can have text on the Confluence page that will not appear in the PDF export.

There are three steps:
1. Follow the instructions to define the NoPrint user macro.
2. Use the NoPrint macro to mark some text on a Confluence page.
3. Add the following CSS to your PDF stylesheet to make the PDF export recognise the NoPrint macro:

```
CSS - PDF Stylesheet

.noprint { display: none; }
```

**Indexing**

To obtain an index at the end of the exported PDF file, consider using the Scroll Wiki PDF Exporter plugin that is produced by K15t Software GmbH.

**Notes**

If styling is not working as expected, it is useful to look at the intermediary HTML source to which the CSS is applied. This intermediary HTML is created whenever you create an HTML export that contains multiple pages, and is stored in the temp directory in Confluence's home directory. For example:

```
/temp/htmlexport-20110308-154047-1/export-intermediate-154047-2.htm1
```

**Creating PDF in Another Language**

To export a Confluence page written in a language other than English, you will need the necessary font for that language.

**Related pages:**

- Exporting Content to Word, PDF, HTML and XML

**Uploading a Font File to Confluence**

1. Find the appropriate font file:
   - **Windows users:** All font files in Windows are stored in a directory called:
     - `C:\WINDOWS\Fonts`
   - **Unix users:** All font files in Unix are stored in:
     - `/usr/share/fonts`

   - Microsoft True Type core fonts such as Verdana can be downloaded from this page: [http://corefonts.sourceforge.net/](http://corefonts.sourceforge.net/)

2. Copy the font file into a temporary folder, for example a folder on your desktop.
3. Choose the cog icon, then choose General Configuration under Confluence Administration and then choose PDF Export Language Support.
4. Upload the file you copied in step 2.
5. Choose Install.

**Notes**

- The only font files supported are true type fonts and true type collections. The accepted file extensions are ".ttf" and ".ttc."
Confluence can only store one font file at any one time. Please create a collection to install more than one *.ttf files.

We recommend that you use Unicode font Verdana for correct character encoding and exporting to PDF.

If the font file size is bigger than your current attachment size limit, you will not be able to upload it. Please increase the attachment size limit temporarily and re-upload again. An improvement of the error messaging is tracked at [CONF-24706 RESOLVED]

To make use of an installed font in your PDF Export style sheet (CSS) refer to it by the font-family ConfluenceInstalledFont.

Your Confluence

Confluence is very flexible; not only in the many ways you can create and share content, but also in how you can tailor your own Confluence experience. Things like your profile picture, favourite spaces and pages, and your personal space can say a lot about you, and can also make navigating Confluence much quicker and easier. Even a simple thing like adding shortcut links to the sidebar of your personal space, can save you a lot of time in finding the things you use all the time.

Set up your personal space, and take a look at any of the pages below, to start making Confluence feel like home.

- Change Your Password
- Edit Your User Settings
- Your User Profile
- Set Your Profile Picture
- Favourite Spaces and Pages
- View and Revoke OAuth Access Tokens
- Request Add-ons
- Choose Your Home Page

Change Your Password

There are two scenarios where you may want to change your Confluence password:

- You're logged in, but you want or need to change your password
- You've forgotten your password and can't log in, so you need to reset your password

Change your password when you're logged in:

1. Choose your profile picture at top right of the screen, then choose Profile
2. On your Profile tab, click Password in the left-hand column
3. Enter your current password and your new password in the form displayed
4. Click Submit

Reset your password from the login page:

If you've forgotten your password and need to reset it, you can do so from the Confluence login page. Choose the 'Forgot your password?' link and Confluence will step you through the process to reset your password.

Edit Your User Settings

If you want to make Confluence fit you, like a well-worn pair of sneakers, you can set some preferences that will make you feel more at home:

- General preferences such as home page, language and time zone
- Editor settings
- Email settings for subscriptions to email reports.
- OAuth access tokens that you have granted from your Confluence user account.

Related Topics:
- Your User Profile
- Set Your Profile Picture
- Create a Personal Space

Related pages:
- Managing Changes and Notifications and Tasks
- Create a Personal Space
- Confluence User's Guide
General User Preferences

To edit your general user settings:

1. Choose your profile picture at top right of the screen, then choose Settings.
2. Choose Edit and update the settings
3. Choose Submit

<table>
<thead>
<tr>
<th>Setting</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Site Homepage</td>
<td>Select the page that you would like to see whenever you log into Confluence.</td>
</tr>
<tr>
<td>Language</td>
<td>Select your language. See below.</td>
</tr>
<tr>
<td>Time zone</td>
<td>Select your time zone.</td>
</tr>
<tr>
<td>Use Keyboard Shortcuts</td>
<td>Enable keyboard shortcuts, other than for the editor.</td>
</tr>
<tr>
<td>Text select</td>
<td>Turn off the popup options panel when highlighting text.</td>
</tr>
</tbody>
</table>

Screenshot: Editing your user profile settings
More about Language

Setting your language preference in your user profile is described in the section above. This section gives more information about that setting and other settings that affect the language Confluence will use.

Individual users can choose the language that Confluence will use to display screen text and messages. Note that the list of supported languages depends on the language packs installed on your Confluence site.

The language used for your session will depend on the settings below, in the following order of priority from highest to lowest:

- The language preference defined in your user profile. Note that you need to be logged in for this...
setting to take effect.

- The language that you choose by clicking an option at the bottom of the Confluence login screen. Confluence stores this value in a cookie. When the cookie expires, the setting will expire too.
- The language set in your browser. The browser sends a header with a prioritised list of languages. Confluence will use the first supported language in that list. Your Confluence administrator can disable this option by setting a system property.
- The default language for your site, as defined by your Confluence site administrator.

Editor Preferences

You can set some options that determine the way the Confluence editor works. Note that these settings affect only you. Other people using Confluence can enable or disable the settings on their user profiles independently.

To change your editor preferences:

1. Choose your profile picture at top right of the screen, then choose Settings.
2. Click Editor under 'Your Settings' in the left-hand panel
3. Click Edit and make your changes
4. Click Submit

<table>
<thead>
<tr>
<th>Setting</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Disable Autocomplete</td>
<td>Select to disable autocompletion when you press one of the trigger characters.</td>
</tr>
<tr>
<td>Disable Autoformatting</td>
<td>Select to disable autoformatting when you type wiki markup in the editor. Click ? on the editor toolbar to learn more.</td>
</tr>
</tbody>
</table>

Screenshot: User settings for the editor
Your User Profile

Your user profile contains basic information about you, which other Confluence users can see. It's also displayed to other users when they click your name in the People Directory, if you haven't set up your personal space.

In your own profile, you can access account management features and update information about yourself, like your name, email address, and password. You can also view other users' profiles.

Find your user profile

To find your user profile:

Choose your profile picture at top right of the screen, then choose Profile, or choose the Profile link in the sidebar of your personal space.

To find someone else's user profile:

Hover your mouse pointer over a user's linked name or profile picture and choose the user's linked name to open their user profile. Alternatively, you can choose the Profile link in the sidebar of their personal space, or go directly to this URL:

http://MY.CONFLUENCE.COM/users/viewuserprofile.action?username=USERNAME

Screenshot: User profile screen for the current user

From your user profile, you can access the following:
Profile

- View and edit your personal details, such as your name and email address details and optionally, your photograph and other personal information. Note that as a security precaution, in order to change your email address, you will be required to re-enter your password.
- Upload a profile picture (optional).
- Change your password.

Network

- View the recent activity of users that you are following via the Network view.
- Follow other users from this view.

Status Updates

- View your history of status updates.

Favourites

- View a list of your favourite spaces.

Watches

- View a list of the pages and spaces you are currently watching.

Drafts

- Retrieve any pages you were in the process of editing. See Working with Drafts.

Settings

- Edit your General Settings (homepage, language and timezone).
- Subscribe to email notifications.
- View and revoke your OAuth access tokens.

Edit your user profile

1. Choose your profile picture at top right of the screen, then choose Profile.
   Or, choose the Profile link in the sidebar of your personal space.
2. Choose Edit Profile.
3. Enter details about yourself in the form displayed.
4. Choose Save.

Fields in your user profile:

<table>
<thead>
<tr>
<th>Detail</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Full Name</td>
<td>Your name as you’d like it to appear in your profile.</td>
</tr>
<tr>
<td>Email</td>
<td>Your email address that will be used to send you mail notifications.</td>
</tr>
<tr>
<td>Phone</td>
<td>Your phone number.</td>
</tr>
<tr>
<td>IM</td>
<td>Your Instant Messenger (IM) details.</td>
</tr>
<tr>
<td></td>
<td>To suit a variety of IM applications, this option accepts any string value.</td>
</tr>
<tr>
<td></td>
<td>For example, you can enter IM details in the form of an email address, or</td>
</tr>
<tr>
<td></td>
<td>a user ID, like ‘123456789’.</td>
</tr>
<tr>
<td>Website</td>
<td>Your website's URL.</td>
</tr>
<tr>
<td>About me</td>
<td>Information about yourself that other users can view (such as your professional information, hobbies, and other interests). You can use Confluence wiki markup in this field.</td>
</tr>
<tr>
<td>Position</td>
<td>Your title or position within your organisation.</td>
</tr>
<tr>
<td>Department</td>
<td>The name of your department or team.</td>
</tr>
<tr>
<td>Location</td>
<td>Your location. This can be your town, city, region or country.</td>
</tr>
</tbody>
</table>

Handy Hint

Confluence administrators can configure Confluence to mask email addresses (e.g. ‘example at atlassian dot com’), protecting your email address from search engine spiders and the like.
Notes

The 'Administer User' link is visible to Confluence administrators only. The administrator can click this link to go directly to the user management screen in the Administration Console.

Set Your Profile Picture

Your profile picture is used as the icon for your personal space, to represent you in the People Directory, and to illustrate your comments. It also appears in various other places next to your name, such as in the list of recent updates on the dashboard.

When you upload your profile picture, you can resize and reposition it to make sure it looks great.

Upload and adjust your profile picture:

1. Choose your profile picture at top right of the screen, then choose Profile
2. Choose Picture on the left
3. Choose Upload image > Upload an image
4. Locate and select the picture on your computer or file server
5. Adjust the size and position of your photo, then choose Save

Screenshot: Choosing a profile picture

Screenshot: Resize your profile picture

Favourite Spaces and Pages

Marking a pages or spaces as a favourites means you'll be able to access them quickly from the dashboard, spaces directory, or from your profile. It's a great way to get to the content you access every day.

Add favourite pages and spaces

To add a page as a favourite:

1. Go to the page
2. Choose *** > Favourite
   The menu item will change to Remove Favourite, so that you can
remove the page form your favourites if you want to later.

**To add a space as a favourite:**

1. Choose **Spaces > Space directory** in the Confluence header
2. Choose the star icon next to the space name in the list of spaces

The star icon will change to dark grey to indicate that you've added the space as a favourite. You can choose the star again to remove the space as a favourite.

**To add someone's personal space as a favourite:**

If a user has set up a personal space, you can mark it as a favourite in the same way you mark other spaces as favourites. When you're in the Space Directory, choose **Personal Spaces** to view all the personal spaces in your Confluence site.

**View your favourites**

To view your favourite spaces and pages, try any of the following:

- Scroll to the bottom-left of the **dashboard** – you'll see tabs for your favourite spaces and pages, as well as your **network**.
- Go to **Spaces > Space Directory** in the Confluence header, then choose **Favourite Spaces** on the left – this one's for favourite spaces only.
- Choose **your profile picture** at top-right of the screen, then choose **Favourites** – there's a list of your favourite spaces and pages.

Recently updated content in your favourite spaces is also listed in the **Favourite Spaces** tab of the recent activity feed on the dashboard.

*Screenshot: Viewing your favourites in your profile*
View and Revoke OAuth Access Tokens

OAuth access tokens allow you to use a Confluence gadget on an external web application or website (also known as the ‘consumer’) and grant this gadget access to Confluence data which is restricted or privy to your Confluence user account.

OAuth access tokens will only appear in your user profile if the following conditions have been met:

1. Your Confluence Administrator has established an OAuth relationship between your Confluence site and the consumer. Confluence Administrators should refer to Configuring OAuth for more information about establishing these OAuth relationships.
2. You have accessed a Confluence gadget on the consumer and have conducted the following tasks:
   a. Logged in to your Confluence user account via the gadget and then,
   b. Clicked the ‘Approve Access’ button to allow the gadget access to data that is privy to your Confluence user account.

Confluence will then send the consumer an OAuth ‘access token’, which is specific to this gadget. You can view the details of this access token from your Confluence site’s user account.

An OAuth access token acts as a type of ‘key’. As long as the consumer is in possession of this access token, the Confluence gadget on the consumer will be able to access Confluence data that is both publicly...
available and privy to your Confluence user account. As a Confluence user, you can revoke this access
token at any time. Furthermore, all access tokens expire after seven days. Once the access token is revoked
or has expired, the Confluence gadget will only have access to publicly available Confluence data.

View your OAuth Access Tokens

To view all of your Confluence user account's OAuth access tokens:

1. Choose your profile picture at top right of the screen, then choose Settings.
2. Click View OAuth Access Tokens. A view similar to screenshot below is displayed. Refer to OAuth
   Access Token Details below for information on interpreting this table.

   If no access tokens have been set, then 'None specified' is shown.

Screenshot: Viewing your OAuth Access Tokens

<table>
<thead>
<tr>
<th>Authorised Applications</th>
</tr>
</thead>
<tbody>
<tr>
<td>The following applications are using your account to access Confluence data:</td>
</tr>
</tbody>
</table>
| ![Table of Authorised Applications](image)

OAuth Access Token Details

Your list of OAuth access tokens is presented in a tabular format, with each access token presented in
separate rows and each property of these tokens presented in a separate columns:

<table>
<thead>
<tr>
<th>Column Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Consumer</td>
<td>The name of the Confluence gadget that was added on the consumer.</td>
</tr>
</tbody>
</table>
| Consumer Description | A description of this consumer application. This information would have been obtained from the
consumer's own OAuth settings when an OAuth relationship was established between
Confluence and that consumer. |
| Issued On    | The date on which the OAuth access token was issued to the consumer by Confluence. This
would have occurred immediately after you approved this gadget access to your Confluence
data (privy to your Confluence user account). |
| Expires On   | The date when the OAuth access token expires. This is seven days after the 'Issued On'
date. When this date is reached, the access token will be automatically removed from this list. |
| Actions      | The functionality for revoking the access token. |

Revoke your OAuth Access Tokens

To revoke one of your OAuth access tokens:

1. View your Confluence user account's OAuth access tokens (described above).
2. Locate the Confluence gadget whose OAuth access token you wish to revoke and click Revoke
   OAuth Access Token next to it.
The gadget's access token is revoked and the Confluence gadget on the consumer will only have access to publicly available Confluence data.

**Request Add-ons**

The [Atlassian Marketplace](https://marketplace.atlassian.com) website offers hundreds of add-ons that the administrator of your Atlassian application can install to enhance and extend Confluence. If the add-on request feature is enabled for your Confluence instance, you can submit requests for add-ons from the Marketplace to your Confluence administrator.

The 'Atlassian Marketplace for Confluence' page provides an integrated view of the Atlassian Marketplace from within your Confluence instance. The page offers the same features as the Marketplace website, such as searching and category filtering, but tailors the browsing experience to Confluence.

This in-product view of the Marketplace gives day-to-day users of the Atlassian applications, not just administrators, an easy way to discover the add-ons that can help them work. When you find an add-on of interest, you can submit a request with just a few clicks.

**Submit an add-on request**

To browse for add-ons in the Atlassian Marketplace, follow these steps:

1. Choose **your profile picture** at top right of the screen, then choose **Atlassian Marketplace**.
2. In the Atlassian Marketplace page, use the search box to find add-ons or use the category menus to browse or filter by add-ons by type, popularity, price or other criteria. You can see what your fellow users have requested by choosing the **Most Requested** filter.
3. When you find an add-on that interests you, click **Request** to generate a request for your administrator.
4. Optionally, type a personal message to your administrators in the text box. This message is visible to administrators in the details view for the add-on.
5. When ready, click **Submit Request**.
6. **Click Close** to dismiss the ‘Success!’ message dialog box.

At this point, a notification appears in the interface your administrators use to administer add-ons. Also your request message will appear in the add-on details view, visible from the administrator's 'Find New Add-ons' page. From there, your administrator can purchase the add-on, try it out or dismiss requests.

**Update an add-on request**

After submitting the request, you can update your message at any time. Click the **Update Request** button next to the listing in the Atlassian Marketplace page to modify the message to your administrator.

The administrator is not notified of the update. However, your updated message will appear as you have modified it in the details view for the add-on immediately.

**Choose Your Home Page**

When you log in to Confluence, the default is to take you to the dashboard. If you want to personalise your Confluence experience, you can choose another space's home page as the first page you see when you log in – this will be your new home page.

**To set your home page:**

1. **Choose your profile picture** at top right of the screen, then choose **Settings**.
2. **Choose Edit**
3. **Choose a page from the Site Homepage drop down**
   Only spaces for which you have 'view' access display.
4. **Choose Submit**

You'll be directed to your new home page, the next time you next log in.

You can still access the site dashboard by clicking the site logo at the left of the Confluence header, or by entering the dashboard URL. It'll look something like this: `https://yoursite.com/wiki/dashboard.action`.

**Screenshot: Profile Settings**
Managing Changes and Notifications and Tasks

Confluence provides several ways in which you can watch for changes to single pages, entire spaces, and all spaces on the site. You can also follow the updates made by specific people. You can only track updates to content that you have permission to see.
Making yourself a watcher of pages or spaces

You can watch a page, blog post or space that you have permission to view. Confluence will then send you an email notification whenever someone adds or updates content on, or adds a comment to, that page or space. See Watching Pages, Spaces and Blogs.

If you have space administrator permissions, you can manage watchers of pages and spaces.

Requesting other notifications

You can configure Confluence to send you various digest reports via email. See Subscribing to Email Notifications of Updates to Confluence Content.

On this page:
- Making yourself a watcher of pages or spaces
- Requesting other notifications
- Tracking updates by specific people
- Managing your notifications
- Using Confluence RSS feeds

Related pages:
- Page History and Page Comparison Views
- View Space Activity
- Working with Tasks

Tracking updates by specific people

You can also follow the activity of people who interest you (see Network Overview) and receive a notification when someone follows you (see Subscribing to Email Notifications of Updates to Confluence Content).

Managing your notifications

There are two ways to manage notifications in Confluence:

- You can manage your email notification settings via the options in your user profile. See Subscribing to Email Notifications of Updates to Confluence Content.
- The Confluence workbox displays all notifications collected from Confluence page watches, shares and mentions. See Managing Notifications in Confluence.

Using Confluence RSS feeds

You can build RSS feeds to monitor content changes in Confluence.

- Create a customised RSS feed using the RSS Feed Builder.
- Subscribe to one of the pre-specified feeds generated by Confluence.

Watching Pages, Spaces and Blogs

You can ‘watch’ a Confluence page, blog post or space. Confluence will then send you a notification email whenever anyone updates your watched content.

You’ll receive email notifications for:

- Edits (unless the author clears the ‘Notify watchers’ check box).
- Deletions.
- Attachments, including new versions or deletions of an existing attachment.
- Comments, including new comments, edits of existing comments or deletions of existing comments.

By default, Confluence will assign you as a watcher of any page or blog post that you create or edit. This behaviour is called ‘autowatch’. You can control
There's no daily digest for email notifications. You'll receive an email notification every time someone makes a change.

You will not receive email notifications for content changes due to the output of a macro, because the page content itself hasn't been edited.

You need 'View' permission for the page, blog post or space to receive notifications.

Watching a page or blog post

To start watching a page or blog post:

1. Log in to Confluence, if you have not already done so.
2. Go to the page or blog post.
3. Choose Watch and select the relevant check box.

To stop watching the page or post, deselect the relevant check box.

Watching an entire space

You can choose to watch all the pages and blog posts in a particular space.

The quickest way is to use the Watch option on a page or blog post, as described above.

To stop watching the space, deselect the relevant check box.
Alternatively, choose **Pages** in the space sidebar, then choose **Watch this space** at the top right.

If your space uses the Documentation theme, choose **Browse > Space Operations.** Then choose **Watch this space** in the left-hand menu.

### Watching for new blog posts in a space

You can choose to receive a notification whenever someone adds a blog post in the space. You will not receive notification of updates to or deletions of blog posts, nor of comments on the blog posts.

To watch for new posts:

1. Log in to Confluence, if you have not already done so.
2. Go to a blog post in the space.
3. Choose **Watch** and select **Watch all blog posts in this space.**

To stop watching for new blog posts, deselect the relevant check box.

Alternatively, choose **Blog** in the space sidebar, then choose **Watch this blog** at the top right.

If your space uses the Documentation theme, choose **Browse > Space Operations.** Then choose **Watch this blog** in the left-hand menu.

### Watching all spaces on the site

You can receive notifications about changes to the content of pages, blog posts and comments from all spaces on a Confluence site.

To start watching for content changes across the whole site:

1. Choose **your profile picture** at top right of the screen, then choose **Settings.**
2. Choose **Email.**
3. Choose **Edit** then choose **Subscribe to daily updates.**
4. Choose **Submit.**

### Watching for all new blog posts on the site

You can choose to watch for all new blog posts in all spaces on the Confluence site. You will not receive notification of updates to or deletions of blog posts, nor of comments on the blog posts.

To start watching for all new blog posts:

1. Choose **your profile picture** at top right of the screen, then choose **Settings.**
2. Choose **Email.**
3. Choose **Edit** then choose **Subscribe to all blog posts.**
4. Choose **Submit.**

### Managing watches from your user profile

The ‘Watches’ page in your user profile displays a list of all pages and spaces you are currently watching.

To manage your watches:

1. Choose **your profile picture** at top right of the screen, then choose **Watches**
2. Choose **Stop Watching** for any unwanted spaces or pages

### Managing watches from the email message

The email notifications that you receive from Confluence have some useful links at the bottom of the email message. The links in each message vary, depending on the context. In general, the links allow you to view the page online, reply to a comment, and so on.

In particular with respect to setting your notification preferences, you will see one or more of the following
Setting autowatch and other notification options

By default, Confluence will assign you as a watcher of any page or blog post that you create or edit. This behaviour is called 'autowatch'. You can turn autowatch on or off, and set other notification options, in the email settings section of your user profile. See Setting User Settings.

Managing Watchers

If you're an administrator of a space, you can manage the watchers for all pages and blog posts in that space. This means that you can:

- View a list of the watchers of a page or blog post.
- View a list of the watchers of the space that contains the page or blog post.
- Add users as watchers of the page or blog post.
- Remove existing watchers of the page or blog post.

You cannot remove watchers of the space.

To manage the watchers of a page or blog post:

1. Go to the page or blog post for which you want to manage the watchers.
2. Choose Watch > Manage Watchers.
3. The 'Manage Watchers' screen will appear. The left-hand column shows the users watching the page or blog post. The right-hand column shows the users watching the space.
   - To remove an existing page watcher, choose the icon (trash can) next to the user's name.
   - To add a user as a watcher of the page, type their username and choose Add.

Related pages:

- Watching Pages, Spaces and Blogs
- Subscribing to Email Notifications of Updates to Confluence Content
- Managing Changes and Notifications and Tasks
- Your Confluence
- Confluence User's Guide.
Subscribing to Email Notifications of Updates to Confluence Content

You can 'watch' a page, blog post or space. Confluence will then send you a notification by email whenever anyone adds or updates content on that page or space. You can also subscribe to daily email reports and other notifications of various updates, as described below.

You will only receive notifications for content that you have permission to view. Users that have been disabled by an administrator will not receive email notifications.

Subscribing to email notifications

You can subscribe to the following email summary reports:

- A daily report of updates to all spaces that you have permission to view.
- An immediate report of all blog posts added or changed, in all spaces that you have permission to view.
- An immediate report of all updates made by the people you are following, in all spaces that you have permission to view.
- An immediate report when someone follows you.
- A daily or weekly report of recommended updates, in all spaces that you have permission to view.

To edit your email notification settings:

1. Choose your profile picture at top right of the screen, then choose Settings.
2. Click Email in the left-hand panel.
3. Click Edit.
Below is an explanation of all the email settings is explained below.

<table>
<thead>
<tr>
<th>Setting</th>
<th>Description</th>
<th>Content</th>
<th>Frequency</th>
</tr>
</thead>
<tbody>
<tr>
<td>Autowatch</td>
<td>Option: Do you want Confluence to automatically add you as a watcher on each page or blog post that you add or update? If you are a watcher of a page or a post, you will receive notification of future changes.</td>
<td>• Pages and blog posts that you create, edit or comment on.</td>
<td>(Not applicable)</td>
</tr>
<tr>
<td>Subscribe to daily updates</td>
<td>Receive email reports showing changes to content in all spaces that you have permission to view. Note: <em>Daily email reports do not include information about attachments on a page or blog post that are added, edited or deleted.</em></td>
<td>• Pages and blog posts that are added, edited or deleted. • Comments on a page or blog post that are added, edited or deleted. • Updates by users who have changed their personal profile.</td>
<td>Daily</td>
</tr>
<tr>
<td>Subscribe to all blog posts</td>
<td>Receive email notifications for changes to blogs in your Confluence installation that you have permission to view.</td>
<td>• Blog posts added, edited or deleted.</td>
<td>Immediately</td>
</tr>
<tr>
<td>Subscribe to network</td>
<td>Receive email notifications for changes to content by all users that you are following, which you have permission to view.</td>
<td>• Pages being added, edited or deleted. • Blog posts being added, edited or deleted. • Comments being added, edited or deleted. • Status updates by the user.</td>
<td>Immediately</td>
</tr>
<tr>
<td><strong>Subscribe to new follower notifications</strong></td>
<td>Receive an email message when anyone chooses to follow you.</td>
<td>Immediately</td>
<td></td>
</tr>
<tr>
<td>---</td>
<td>---</td>
<td>---</td>
<td></td>
</tr>
</tbody>
</table>
| **Notify on my actions** | **Option:** Do you want to receive email notifications for your own changes?  
Note: If you have not subscribed to any email notifications and are not watching any pages/spaces, then selecting 'Notify on my actions' will not do anything. | All pages and spaces that you are watching.  
This affects all subscriptions set. | (Not applicable) |
| **Show changed content** | **Option:** Do you want your notifications to include details of the changes made to the content?  
- If you do not select this option, your notifications will include only the title of the page, and any comment the author made when updating the page.  
- If you do select this option, your notifications will show the differences between the current and previous versions of the page. See [Page History and Page Comparison Views](#). | Edits to pages and blog posts. | (Not applicable) |
### Subscribe to recommended updates

<table>
<thead>
<tr>
<th>Receive an email message showing the top content that is relevant to you from spaces that you have permission to view.</th>
</tr>
</thead>
<tbody>
<tr>
<td>How do you set the frequency of the mail message? A link in the email message allows you to choose daily or weekly notifications.</td>
</tr>
<tr>
<td>How do you enable and disable the notification? You can turn off the notification by clicking a link in the email message. You can also turn the notification on or off by setting the 'Subscribe to recommended updates' option in your user profile.</td>
</tr>
</tbody>
</table>

Confluence chooses the content to display, based on:

- Pages and blog posts that people have recently liked.
- Pages and blog posts that people have recently commented on.
- Pages and blog posts that have recently been created.

'Recent' means any activity that occurred since the last recommended updates message was sent to you.

The activities are listed in order of popularity, with the most popular at the top. Likes, comments and content creations are scored equally. Activity that involves people in your network ranks higher than activity not involving your network. Content in your favourite spaces also ranks higher than content in other spaces.

The recommended updates summary does not include any content that you created yourself, and it gives a lower ranking to content that you have participated in, for example by adding a comment or updating the page.

If there is no activity to report, Confluence will not send the email message.

### Notes for administrators

- To enable Confluence to send email notifications, a System Administrator must configure an email server. See Configuring a Server for Outgoing Mail.
- Confluence Administrators can set the default options for the recommended updates notification. Choose the cog icon, then choose General Configuration under Confluence Administration.

  Click Recommended Updates Email in the left-hand panel. See Configuring the Recommended Updates Email Notification.

### Subscribing to RSS Feeds within Confluence

An RSS feed is a format for delivering summaries of regularly changing web content. Subscribing to an RSS feed allows you to stay informed of the latest content from sites that you are interested in.

RSS is not designed to be read in a regular web browser. Specialised RSS newsreader programs can check RSS files every so often, and tell you what's new on a site. Your reader may be on a website, an add-on to your browser, part of your email program, or a stand-alone program.

Confluence generates its own RSS feeds for tracking updates to content within Confluence. You will need an RSS reader which can grab the RSS feeds from Confluence and display them for you.

Confluence's RSS macro allows you to display the contents of an RSS feed on a Confluence page. The feeds may come from a Confluence feed generator or from external sites. In this way, Confluence can act as an RSS reader.

For a technical description of RSS, read Mark Pilgrim's "What is RSS?" article on XML.com.

### Confluence RSS feeds

RSS feeds allow you to track updates to content within Confluence. You will need an RSS newsreader to read a feed.

You can create a customised RSS feed using the RSS Feed Builder or subscribe to one of the pre-specified...
feeds generated by Confluence.

**What would you like to do?**

- **Create and subscribe to customised RSS feeds using the RSS Feed Builder** – Create a customised RSS feed. For example, you can filter your feed using a label, specify the number of items and days to include in your feed, and so on.
- **Subscribe to pre-specified RSS feeds** – Generate an RSS feed automatically in a minimal number of steps.
- **Subscribe to a feed of any Confluence user's network** – Track the activities of users the selected person is following.

**On this page:**
- Confluence RSS feeds
- RSS newsreaders
- Removing an RSS feed

**Related pages:**
- Managing Changes and Notifications and Tasks
- RSS Feed Macro

### RSS newsreaders

The following are some popular RSS readers for various operating systems. You can find a more comprehensive list on [Google’s open directory](https://toolbar.google.com/).

**Windows**

- SharpReader
- NewsGator
- Syndirella
- FeedDemon
- NewzCrawler

**Mac OS X**

- Safari
- NetNewsWire
- NewsFire
- Shrook

**Multi-platform**

- NewsMonster (Runs in the Mozilla web browser)
- Radio Userland (Windows and MacOS)
- AmphetaDesk (Windows, Unix, Mac OS X)

### Removing an RSS feed

There is no need to try to delete or remove an RSS feed built by the Confluence [RSS feed builder](https://confluence.atlassian.com/content/advancedsearch.cfm?query=RSS+feed+builder).

Explanation: The feeds generated by the RSS Feed Builder are dynamically generated via the parameters included in the feed URL (address). For example, take a look at the following feed URL:

```
http://confluence.atlassian.com/createrssfeed.action?types=page&sort=modified&showContent=true...
```

The above feed URL will generate a list of pages ('types=page'), sorted by the modification date and showing the page content. The feed is generated at the time when the URL is fetched and there is no RSS feed information stored on the database. For that reason, there is no need to remove anything.
Using pre-specified RSS feeds
This page tells you how to get hold of an RSS feed which Confluence has predefined for you.

To subscribe to predefined RSS feeds for a particular space:

1. Go to the space and choose **Space tools > Content Tools** from the bottom of the sidebar
2. Choose **RSS Feeds**.
3. Copy and paste the link for one of the feeds into your RSS newsreader:

If your space uses the Documentation theme:

1. Choose **Browse > Space Operations**
2. Choose **RSS Feeds** in the space operations options.
3. Copy and paste the link for one of the feeds into your RSS newsreader.

Feeds include:
- Pages
- Blog
- Mail
- Comments
- Attachments
- All content

To subscribe to predefined RSS feeds for a particular page (where available):

Note that the word ‘page’ here means a part of the Confluence user interface, rather than a page that contains Confluence content. For example, your **Network** view offers an RSS feed.

1. Go to the page.
2. Locate the following icon, which is available in the top-right corner of certain pages: ![RSS icon](rss.png)
3. Copy and paste the icon's link into your RSS newsreader.

### Related pages:
- Using the RSS Feed Builder
- Managing Changes and Notifications and Tasks
- RSS Feed Macro
- Confluence User's Guide

**Notes**

The predefined RSS feed will return no more than 10 entries within the last 5 days, if you want to customise your Confluence RSS feed (for example, use a label to filter your feed), use the [RSS Feed builder](https://confluence.atlassian.com/pages/using-the-rss-feed-builder-818799032.html) instead of the above instructions.

**Using the RSS Feed Builder**

Using the RSS feed builder, you can create customised RSS feeds to subscribe to changes within Confluence.

Wondering what an RSS feed is? See more information about RSS Feeds.

**Building an RSS feed**

Follow the steps below to build your feed, choosing the type of content and the time period you want to monitor.

**To create a customised RSS feed:**

1. Choose the help icon ![RSS icon](rss.png) at top right of the screen, then choose **Feed Builder**.
2. Select the content types you want in your feed.
   - Check **Mail** if you want to know when the email archive is updated.
   - (See the [overview of mail archives in Confluence](https://confluence.atlassian.com/pages/overview-of-mail-archives-in-confluence-491255221.html).)
3. Select one or more spaces from the list.
4. Click **Advanced Options** to set the following:

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Feed Name</td>
<td>The default name is based on the name of your Confluence installation. For example, 'Extranet RSS Feed'.</td>
</tr>
<tr>
<td>With these labels</td>
<td>Enter one or more labels separated by spaces or commas. Confluence returns all content (of the selected types) that matches one or more of the labels. See the hint below about using labels to customise your feeds.</td>
</tr>
<tr>
<td>Exclude these spaces</td>
<td>Exclude specific spaces from those already selected.</td>
</tr>
<tr>
<td>Sorted by</td>
<td>Sort content by either the date or creation or the date they were last updated.</td>
</tr>
<tr>
<td>Limit to</td>
<td>Specify the number of items returned in your feed.</td>
</tr>
<tr>
<td>Within the last</td>
<td>Specify how old items returned can be.</td>
</tr>
<tr>
<td>Include content for pages</td>
<td>Specify whether the entire page is displayed in the feed.</td>
</tr>
</tbody>
</table>

5. Choose **Create RSS Feed**.

6. Drag or copy the link into your RSS reader.

**Hints**

- **Separate feeds.** Try building separate feeds, one for pages only and one that includes comments as well. This allows you to monitor only pages if you are short of time, and to read the comments when you have more time.

- **Labels to customise your feed.** You can use the RSS feed builder to track updates to labelled pages and comments on those pages. Here is an idea for customising your RSS feed by using your own personal label(s). This is useful if you want to track updates to specific pages or blog posts, and you do not want to deal with emails. You can use this method as an alternative to watching pages.
  - Build an RSS feed that returns pages, blog posts and comments labelled with a personal label, such as `my:feed`.
  - Each time you want to ‘watch’ a page, just label it with ‘my:feed’.
  - All updates and comments will automatically come through your RSS feed.

**Notes**

- **Removing an RSS feed:**

  There is no need to try to delete or remove an RSS feed built by the Confluence **RSS feed builder**.

  Explanation: The feeds generated by the RSS Feed Builder are dynamically generated via the parameters included in the feed URL (address). For example, take a look at the following feed URL:
The above feed URL will generate a list of pages ('types=page'), sorted by the modification date and showing the page content. The feed is generated at the time when the URL is fetched and there is no RSS feed information stored on the database. For that reason, there is no need to remove anything.

- **Feed authentication options**: Confluence can offer you the option of an anonymous feed or a feed that requires authentication.
  - An **anonymous** feed will show only the content that is visible to anonymous users. The feed URL does not contain the &os_authType parameter mentioned below. This feed is useful only if your Confluence site allows anonymous access. If a feed is anonymous, you only get anonymously-viewable content in the feed regardless of whether you are a Confluence user or not.
  - An **authenticated** feed requires you to log in to Confluence before you can retrieve the content. The feed URL contains the following parameter: &os_authType=basic.
  - The option to choose between an anonymous and an authenticated feed is currently not available on the feed builder screen. The feed builder offers only authenticated feeds. See CONFLUENCE-NF-21601 for details and a workaround.

### Subscribing to a Network RSS Feed

You can create an RSS Feed from any user's network view, allowing you to receive summaries on the activities of users they are following in their network. The types of activities tracked in these RSS feed summaries include:

- Additions or edits to pages or blog posts
- Comments added to a page or blog post or edits to existing comments
- Updates to a user's status updates
- Updates to a user's profile

### Subscribing to a user's network RSS feed

1. Locate the RSS icon ![RSS icon](image-url), which is available from the top-right of:
   - The 'Recent activity of the users you are following' section of your network page, or
   - The 'Activity of followed users' section of another user's network page.
2. Copy and paste the icon's link into your RSS newsreader.

### Related pages:
- Network Overview
- Subscribing to RSS Feeds within Confluence
- Confluence User's Guide

### Customising your network RSS feed

Confluence does not provide a way of customising a network RSS feed via the user interface. However, you can modify the maximum number of results and type of content displayed in these feeds by directly editing the RSS feed link in your RSS newsreader.

**To modify the maximum number of results displayed in your RSS feed:**

1. Edit the RSS feed link in your RSS newsreader.
2. Change the value of the `max` parameter from its default value of 40 to a value of your choice. Example: `http://confluence.atlassian.com/feeds/network.action?username=MYNAME&max=60&publicFeed=false`
To modify the type of content displayed in your RSS feed:

1. Edit the RSS feed link in your RSS newsreader.
2. Append the parameter `contentType` to the end of the link, followed by an equals sign (=) and then add the appropriate content type value of your choice:
   - USER_STATUS — restricts the RSS feed to user status updates.
   - PAGE — restricts the RSS feed to page additions or updates.
   - BLOG — restricts the RSS feed to blog post additions or updates.
   - ATTACHMENT — restricts the RSS feed to attachment additions or updates.
   - COMMENT — restricts the RSS feed to comment additions or updates.

   Content type values are case-sensitive. Ensure that each parameter is separated from the other by an ampersand (&).

   Example:
   
   http://confluence.atlassian.com/feeds/network.action?username=ggaskell&max=40&publicFeed=false&os_authType=basic&rssType=atom&contentType=USER_STATUS

3. Save the modified link in your RSS newsreader.

Notes

It is not possible to filter for more than one type of content by adding multiple values to the `contentType` parameter.

Working with Tasks

Keep track of the things that need to get done with tasks. With the ability to give each task an assignee and due date, and plenty of ways to see your tasks, you can make sure nothing slips through the cracks in your project or team.

Creating a task

Tasks are created on pages. For example, you might add tasks under action items on a meeting notes page, or in a project planning page - anywhere you need a lightweight task management solution.

To create a task:

1. In the editor, choose the Task list button or use the keyboard shortcut [ ]
2. Start typing your task - use the @ to assign the task to someone or // to choose a due date.

The first person you mention in a task is the assignee. You can mention more people in the task, but the first person mentioned will be the assignee - you can even assign tasks to yourself.

Note: If you assign a task to someone who does not have permissions to view the page or space, they won't see the task.

Keeping track of tasks

There are a number of ways to keep track of tasks assigned to you, or tasks you've created for others.

On a page

The simplest way to see a task is on the page it was originally created on, for example in a meeting notes page.

It is easy to see if a task is complete, who it is assigned to, and when it is due. If a task is nearing, or has passed its due date, the colour of the date will change (red for overdue, orange for due in the next 7 days).
In your profile

The tasks page in your profile gives you a place to see all the tasks relevant to you in one place. Easily keep track of the status of tasks assigned to you, and tasks you've created and assigned to others.

To view the tasks page, go to Profile > Tasks.

Use the filters to show tasks that were assigned to you or created by you and toggle between complete or incomplete tasks.

In a Task Report

If you're looking for a more custom view of tasks, the Task Report blueprint is a great way to track tasks assigned to a specific team or project.

To create a task report:

1. Choose Create > Task Report
2. Select the type of report:
   - Assigned to my team for tasks assigned to particular people
   - In my project for tasks that appear in a specific space or page, or
   - Custom for a wide range of filtering options, including by date or page label.
3. Follow the prompts to create the report.

This blueprint uses the Task Report macro. You can also choose to use this macro on an existing page, for example, on a project or team space homepage. See Task Report Macro for more about using this macro.
Notes

- The date picker can be triggered by typing // or by typing a date in the format dd/mm/yyyy or dd-mm-yyyy. Typing other date formats in the editor will not trigger the date picker.
- Personal Tasks (created in the Workbox in older versions of Confluence) do not appear in the Tasks view or Task Report. To migrate any incomplete personal tasks, go to Workbox > Personal Tasks and follow the prompts.
- The existing wiki markup based Tasklist Macro has been removed from the macro browser. If you have a Tasklist macro on a page it will continue to work, but you will be unable to add new Tasklists using this macro.

Managing Notifications in Confluence

This page is about the notification-and-task dialog, known as the Confluence 'workbox', which drops down when you choose the icon on the Confluence page header.

Do you want to manage your notification email messages instead? See Subscribing to Email Notifications of Updates to Confluence Content.

Managing your notifications in the Confluence workbox

The workbox displays all notifications collected from Confluence page watches, shares, mentions, and tasks. If your Confluence site is linked to a JIRA issue tracker, you will also see JIRA notifications in your workbox.

You can view your notifications and convert them to personal tasks. Use the inline actions to reply to comments, like a comment or page, or watch a page. Follow the links in a notification to open the relevant page or blog post. With JIRA integration, you can watch or unwatch issues, comment on issues, or follow the link to open the issue in JIRA.

On this page:
- Managing your notifications in the Confluence workbox
- Which notifications are included?
- Keyboard shortcuts
- Managing notifications with Confluence mobile
- Notes

Related pages:
- Configuring Workbox Notifications
- Subscribing to Email Notifications of Updates to Confluence Content
- Watching Pages, Spaces and Blogs
- Likes and Popular Content
The workbox displays your notifications and your personal tasks in separate tabs.

To manage your notifications:

1. Choose the workbox icon 📚 in the Confluence page header.
   - A number may appear on the workbox icon, indicating the number of unread notifications waiting for your attention.
   - You can use the keyboard shortcut: Type `g` then `n`. (When in the Confluence editor, click outside the editor pane before pressing the keyboard shortcut keys.)
2. Choose a notification from the list, to see the notification details. You can then:
   - Open the related page, blog post, or comment.
   - Like or Unlike the page, blog post, or comment.
   - Watch or Stop Watching to receive notifications, or stop receiving notifications, about a page or blog post.
   - Reply a comment, without leaving the workbox.

Screenshot: Your Confluence notifications in the workbox

Which notifications are included?

The workbox displays a notification when someone does one of the following in Confluence:
- Shares a page or blog post with you.
• **Mentions** you in a page, blog post, comment or task.
• Comments on a page or blog post that you are **watching**.
• **Likes** a page or blog post that you are watching.

The workbox does **not** show notifications triggered because you are watching a space. Only watches on pages and blog posts are relevant here.

The notification in your workbox appears as 'read' if you have already viewed the page or blog post.

If your Confluence site is linked to JIRA, you will also see the following JIRA notifications in your workbox:

• Comments on issues that you are watching.
• Mentions.
• Shares of issues, filters and searches.

**Keyboard shortcuts**

<table>
<thead>
<tr>
<th>Shortcut</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>g then n</td>
<td>Open the Confluence workbox.</td>
</tr>
<tr>
<td>j</td>
<td>Move down to the next entry in the notification list.</td>
</tr>
<tr>
<td>k</td>
<td>Move up to the previous entry in the notification list.</td>
</tr>
<tr>
<td>n</td>
<td>Move down to the next notification for a particular page or blog post.</td>
</tr>
<tr>
<td>p</td>
<td>Move up to the previous notification for a particular page or blog post.</td>
</tr>
<tr>
<td>Enter</td>
<td>Open the selected notification.</td>
</tr>
<tr>
<td>u</td>
<td>Return to the notification list after opening a particular notification.</td>
</tr>
</tbody>
</table>

**Managing notifications with Confluence mobile**

You can view and respond to your notifications on your phone or other mobile device too. See [Using Confluence on a Mobile Device](#) for more about mobile platforms.

**Notes**

• Read notifications are automatically deleted after 2 weeks.
• Unread notifications are automatically deleted after 4 weeks.
• You cannot delete your notifications yourself.
• If a new notification arrives while you have workbox open, the count appears on the workbox icon but the notification is not added to the workbox. You need to close workbox and re-open it to see the new notification.

• The ability to receive notifications from JIRA or another Confluence site is available in **Confluence 4.3.3 and later**. To receive JIRA notifications, you need **JIRA 5.2 or later**.

• Administrators can enable and disable the workbox on your Confluence site. They can also connect a JIRA site or another Confluence site, so that notifications from those sites appear in your workbox too. See [Configuring Workbox Notifications](#).

• The Confluence workbox is provided by a set of plugins. To remove the personal notifications and tasks functionality from your site, you can disable the following plugins. See [Disabling or Enabling a Plugin](#) for instructions. Disabling these plugins will disable the entire workbox. It is not possible to disable only tasks or only notifications:
  • Workbox - Common Plugin
  • Workbox - Host Plugin
  • Workbox - Confluence Provider Plugin
• If you want to re-enable the plugins, do so in the following order: Common Plugin, Host Plugin, Confluence Provider Plugin.
• There is no option to disable the workbox for an individual user.

Searching Confluence

Confluence gives you a few ways to find the content you’re looking for. Here’s a basic overview of Confluence search, and a few tips to help you find things more easily.

Confluence quick search

To perform a quick search in Confluence, choose the search field at the top-right of every page, or type **GG** on your keyboard to place your cursor in the search field. Type the name of a page, blog post, person, file/attachment, or space and select from the list of options displayed.

Hover your pointer over the options in the list to see the space they’re in. If you don’t see what you need in the quick search, press **Enter** or choose the **Search for** option at the bottom of the search results to perform a **full search**.

You can also search for administrative options in the quick search. For example, type ‘general’ into the search field to go to the General Configuration screen.

*Screenshot: quick navigation showing titles matching the query ’st’*
More information about quick navigation:

- Matching items are grouped by type so that you can quickly find the type you want. Confluence shows a maximum of 3 administrative items, 6 pages and/or blog posts, 2 attachments, 3 people and 2 spaces.
- Items are ordered with the most recently updated first.
- The part of the title that's matched by the search query is bolded.
- Confluence permissions determine the administrative options that appear in the search results. You will only see the options you have permission to perform.

Perform a full search

When you perform a full search, Confluence will search all content in all spaces (site and personal), mail, personal profiles, attachments and the space description.

To use the full search:

1. Type your query into the search field at the top-right corner of every screen (or at the top of the Search screen)
2. Press the Enter key

   The search screen appears, as shown below. If any Confluence pages or items match your search query, the search screen shows a list of the matching items. Choose an item's title to open it.

   Screenshot: Search results page
In the search results you'll see the following information for each item:

- An icon representing the content type (user profile, space, page, blog post, comment, or attachment).
- The title or name of the content item, linked to the item.
- The most relevant few lines of content from within the item. Any words that match your search query are highlighted within the content.
- The space to which the item belongs, displayed on the last line of the item's text block.
- The date when the content item was last modified.

You'll see only search results which you have permission to view.

On the left of the page are options which allow you to tailor or filter your search results.

⚠️ We recommend you don't use special characters in page or attachment names, as the page or attachment may not be found by Confluence search, and may cause some Confluence functions to behave unexpectedly.
On the left of the search results page are options which allow you to filter the search results.

Define your filter criteria:

- **By** – Restrict your search to content last modified by a particular person. Start typing the person's username or part of their name and Confluence will offer you a list of possible matches. You need to enter at least two letters. For example, if you enter just ‘john s’, the filter will look for users called ‘john’ and will ignore the ‘s’.
- **Space** – Restrict your search to a particular space, your favourite spaces, or choose from a list of suggested spaces. You can also include archived spaces.
- **Last modified** – Restrict your search to content updated within a particular period of time.
- **Type** – Restrict your search to a particular content type.

**Search for labels**

Use the ’labelText:’ prefix to search specifically for content that has a specific label. The table below gives examples of search terms that you can enter into Confluence’s search box, and the search results that you can expect.

<table>
<thead>
<tr>
<th>Searching for ...</th>
<th>Returns content that ...</th>
</tr>
</thead>
<tbody>
<tr>
<td>recipe labelText:chocolate</td>
<td>contains the word 'recipe' or has the label 'chocolate'</td>
</tr>
<tr>
<td>recipe AND labelText:chocolate</td>
<td>contains the word 'recipe' and has the label 'chocolate'</td>
</tr>
<tr>
<td>labelText:cake OR labelText:chocolate</td>
<td>has the label 'cake' or the label 'chocolate'</td>
</tr>
<tr>
<td>labelText:cake AND labelText:chocolate</td>
<td>has both labels 'cake' and 'chocolate'</td>
</tr>
</tbody>
</table>

**Search the content of attachments**

When you search Confluence, by default the search will include the content of the following types of attachments:

- Word
- Text
- PowerPoint
- Excel
- PDF
- HTML

To search the content of other attachment types, you will need to use an attachment content extractor plugin. For more information, take a look at the following:

- Existing extractor plugins which you can install on your Confluence site. See this search on Atlassian Marketplace.
- Guidelines on developing your own attachment content extractor plugin. See our developer documentation on extractor plugins.

**Search options for the Documentation theme**

When using the Documentation theme, the Confluence search offers a few options as described below.

Using the search box at the top right of the page:

- By default, the main Confluence search is configured to search the entire Confluence site.
  - You will see the words ‘Search Confluence’ in the search box at top right of the page.
  - The Confluence search will look for matches in the entire Confluence site. This is the default behaviour for other themes too.
• A space administrator can configure the Documentation theme to restrict the search to the current space.

  • You will see the words ‘Search this space’ in the search box at top right of the page.
  • The search will return results from the current space only.
  • You can override the search restriction. Enter ‘all:’ and your search term to search the entire site. For example, enter the following into the search box at top right of the page to search the entire site for ‘technical writing’:

  all: technical writing

Using the search box in the left-hand panel:

• By default, the Documentation theme’s left-hand panel includes a search box. Enter your search term there, to restrict the search to the current space. Specifically, this will search only the pages that are children of the space’s home page.

• If your administrator has restricted the main search to the current space, there will not be a search box in the left-hand panel.

For screenshots and a full description, see Using the Documentation Theme.

Advanced search syntax

See Confluence Search Syntax for more ways to refine the text you enter in the search field.

Additionally, see Confluence Search Fields for special parameters you can use in the search field to search on various metadata.

Search Confluence from your browser’s search field

If you are using Firefox or Internet Explorer 7 or later, you can add your Confluence site as a search provider, using the dropdown menu next to the browser’s search field.

The example to the right shows the ‘Extranet’ Confluence site offered for inclusion as a search engine in the browser’s search field.

Information about OpenSearch:

• Confluence supports the autodiscovery part of the OpenSearch standard, by supplying an OpenSearch description document. This is an XML file that describes the web interface provided by Confluence’s search function.

• Any client applications that support OpenSearch will be able to add Confluence to their list of search engines.

• Your Confluence Administrator can enable or disable the Open Search feature using the Confluence Administration Console.

Useful plugins

Before installing an add-on (also called a plugin) into your Confluence site, please check the add-on’s information page to see whether it is supported by Atlassian, by another vendor, or not at all. See our guidelines on add-on support. This plugin extends the Confluence search, so that you can search for macro parameter names and values: the Confluence Macro Indexer plugin.

Confluence Search Syntax

This page describes the special words and punctuation marks you can use to refine your search.
Matched phrase search

Use double quotes to search for content that contains the phrase 'cheese one', or a phrase where 'cheese' and 'one' are the major words:

"cheese one"

Note: Confluence will ignore common words (stop words), including 'and', 'the', 'or', and more, even if they are included within double quotes. See the default list of stop words used by Confluence's search engine, Lucene, in the Lucene documentation.

For example:

1. Searching for "cheese one" returns only pages in which 'one' appears as the first word after 'cheese'.
2. Searching for "the one" returns all pages containing 'one' because 'the' is a stop word.

If you'd like to override Lucene's tokenisation and stemming, cast your vote on this improvement request:

CONF-14910 - Provide ability to override Lucene tokenisation and stemming and search for exact text

OR search

To search for content that contains one of the terms, 'chalk' or 'cheese', use the operator OR in capital letters:

chalk OR cheese

AND search

To search for content that contains both the terms 'chalk' and 'cheese', use the operator AND in capital letters:
chalk AND cheese

NOT search
To search for content that contains 'chalk' but NOT 'cheese', use the operator NOT in capital letters:

chalk NOT cheese

Excluded term search
To search for content that contains 'chalk' and 'butter' but not 'cheese':

chalk butter -cheese

Group search terms
To search for content that must contain 'chalk' but can contain either 'cheese' or 'butter', use brackets to group the search terms:

(cheese OR butter) AND chalk

Title search
To search for content with 'chalk' in its title, where 'title' is the field keyword.

title:chalk

Date range search
To search for content created or modified within a certain date range, using the created or modified keywords. The date stamps are in numeric 'yyyymmdd' format:

created:[20000101 TO 20131231]
modified:[20000101 TO 20131231]

Wildcard searches
You can use one or more wildcard characters in your search and place them anywhere in the search string, except at the very beginning. So, you could search for http*.atlassian.*, but you can't search for *.atlassian.* or ??http://confluence.atlassian.*, as they begin with a wildcard.

Wildcards can either replace a single character in your search, or multiple characters.

Single character
To replace a single character in your search, use a question mark (?) as a wildcard. For example, to search
for 'butter', 'bitter', 'better', or 'batter':

b?tter

Multiple characters

To replace multiple characters in your search, use an asterisk (*) as a wildcard. For example, to search for 'chicken' or 'chickpea':

chick*

Multiple wildcards

Use multiple wildcards in your search. The following query will search find 'chick', 'coconut', or 'chickpea':

c*c*

You can also combine wildcard characters in one search. For example, the search term below will return 'chick' but not 'chickpea':

c*c?

Proximity searches

Use a tilde character followed by a number, to find two words within a certain number of words of each other. For example, the following search will return 'Octagon blog post', but not 'Octagon team blog post':

"octagon post"~1

The following search isn't valid, because you can't search for two words within zero words of each other. If you think the words are next to each other, use the matched phrase search.

"octagon post"~0

Range search

Use the operator 'TO', in capital letters, to search for names that fall alphabetically within a specified range:

[adam TO ben]

Note: You can't use the AND keyword inside this statement.

Fuzzy search

Use a tilde (~) character to find words spelled similarly.
If you want to search for octagon, but you’re not sure how it’s been spelt, type the word followed by a tilde:

octog~

Combined search

You can also combine various search terms together:

o?tag* AND past~ AND ("blog" AND "post")

Searching for macros

You can search Confluence content to find where a macro is used. Start your search string with `macroName` and type the macro name after the colon. For example, to search for all excerpt-include macros:

`macroName:excerpt-include*`

For more information about `macroName` and other search fields, see Confluence Search Fields.

Searching for labels

Use the `labelText:` prefix to search specifically for content that has a specific label. The table below gives examples of search terms that you can enter into Confluence’s search box, and the search results that you can expect.

<table>
<thead>
<tr>
<th>Searching for ...</th>
<th>Returns content that ...</th>
</tr>
</thead>
<tbody>
<tr>
<td><code>recipe labelText:chocolate</code></td>
<td>contains the word 'recipe' or has the label 'chocolate'</td>
</tr>
<tr>
<td><code>recipe AND labelText:chocolate</code></td>
<td>contains the word 'recipe' and has the label 'chocolate'</td>
</tr>
<tr>
<td><code>labelText:cake OR labelText:chocolate</code></td>
<td>has the label 'cake' or the label 'chocolate'</td>
</tr>
<tr>
<td><code>labelText:cake AND labelText:chocolate</code></td>
<td>has both labels 'cake' and 'chocolate'</td>
</tr>
</tbody>
</table>

The `labelText:` prefix is an example of a search field. See more about Confluence Search Fields.

Confluence Search Fields

This page gives an overview of the Apache Lucene search fields used in Confluence.

Searching for content in specific fields

Confluence data is stored in fields which can be specified in the search. To search a specific field, type the name of the field followed by a colon `:` and then the term you are looking for.

Preliminary examples:

```plaintext
title:"Some Title"
```
The field specification applies only to the term directly preceding the colon. For example, the query below will look for "Some" in the title field and will search for "Heading" in the default fields.

title:Some Heading

On this page:
- Searching for content in specific fields
- Confluence search fields
  - Personal Information
  - Pages
  - Blog
  - Attachments
  - Mail items
- More examples
  - Searching for labels
- Useful plugins

Related pages:
- Searching Confluence
- Confluence Search Syntax
- Confluence User's Guide

Confluence search fields

Below are the fields which can be searched, listed by content type.

### Personal Information

<table>
<thead>
<tr>
<th>Name</th>
<th>Indexed</th>
<th>Stored</th>
<th>Tokenised</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>handle</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>type</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>urlPath</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>fullName</td>
<td>true</td>
<td>true</td>
<td>true</td>
<td></td>
</tr>
<tr>
<td>title</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>labelText</td>
<td>true</td>
<td>true</td>
<td>true</td>
<td></td>
</tr>
<tr>
<td>modified</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>created</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>contentBody</td>
<td>true</td>
<td>true</td>
<td>true</td>
<td></td>
</tr>
</tbody>
</table>

### Pages

<table>
<thead>
<tr>
<th>Name</th>
<th>Indexed</th>
<th>Stored</th>
<th>Tokenised</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>handle</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>type</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
</tbody>
</table>

Created in 2015 by Atlassian. Licensed under a Creative Commons Attribution 2.5 Australia License.
### The name of a macro used on the page

<table>
<thead>
<tr>
<th>Field</th>
<th>Indexed</th>
<th>Stored</th>
<th>Tokenised</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>urlPath</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>title</td>
<td>true</td>
<td>true</td>
<td>true</td>
<td></td>
</tr>
<tr>
<td>spacekey</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>labelText</td>
<td>true</td>
<td>true</td>
<td>true</td>
<td></td>
</tr>
<tr>
<td>modified</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>created</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>contentBody</td>
<td>true</td>
<td>true</td>
<td>true</td>
<td></td>
</tr>
<tr>
<td>macroName</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td>The name of a macro used on the page</td>
</tr>
</tbody>
</table>

### The name of a macro used in the blog

<table>
<thead>
<tr>
<th>Field</th>
<th>Indexed</th>
<th>Stored</th>
<th>Tokenised</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>handle</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>type</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>urlPath</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>title</td>
<td>true</td>
<td>true</td>
<td>true</td>
<td></td>
</tr>
<tr>
<td>spacekey</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>labelText</td>
<td>true</td>
<td>true</td>
<td>true</td>
<td></td>
</tr>
<tr>
<td>modified</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>created</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>contentBody</td>
<td>true</td>
<td>true</td>
<td>true</td>
<td></td>
</tr>
<tr>
<td>macroName</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td>The name of a macro used in the blog</td>
</tr>
</tbody>
</table>

### Attachments

<table>
<thead>
<tr>
<th>Field</th>
<th>Indexed</th>
<th>Stored</th>
<th>Tokenised</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>handle</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>type</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>urlPath</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>filename</td>
<td>true</td>
<td>true</td>
<td>true</td>
<td></td>
</tr>
<tr>
<td>title</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>comment</td>
<td>true</td>
<td>true</td>
<td>true</td>
<td></td>
</tr>
<tr>
<td>spacekey</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>modified</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>created</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>contentBody</td>
<td>true</td>
<td>true</td>
<td>true</td>
<td></td>
</tr>
</tbody>
</table>

### Mail items
<table>
<thead>
<tr>
<th>Name</th>
<th>Indexed</th>
<th>Stored</th>
<th>Tokenised</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>handle</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>type</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>urlPath</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>title</td>
<td>true</td>
<td>true</td>
<td>true</td>
<td></td>
</tr>
<tr>
<td>spacekey</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>messageId</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>inreplyto</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>recipients</td>
<td>true</td>
<td>true</td>
<td>true</td>
<td></td>
</tr>
<tr>
<td>labelText</td>
<td>true</td>
<td>true</td>
<td>true</td>
<td></td>
</tr>
<tr>
<td>modified</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>created</td>
<td>true</td>
<td>true</td>
<td>false</td>
<td></td>
</tr>
<tr>
<td>contentBody</td>
<td>true</td>
<td>true</td>
<td>true</td>
<td></td>
</tr>
</tbody>
</table>

More examples

Searching for labels

Use the `labelText:` prefix to search specifically for content that has a specific label. The table below gives examples of search terms that you can enter into Confluence's search box, and the search results that you can expect.

<table>
<thead>
<tr>
<th>Searching for ...</th>
<th>Returns content that ...</th>
</tr>
</thead>
<tbody>
<tr>
<td>recipe labelText:chocolate</td>
<td>contains the word 'recipe' or has the label 'chocolate'</td>
</tr>
<tr>
<td>recipe AND labelText:chocolate</td>
<td>contains the word 'recipe' and has the label 'chocolate'</td>
</tr>
<tr>
<td>labelText:cake OR labelText:chocolate</td>
<td>has the label 'cake' or the label 'chocolate'</td>
</tr>
<tr>
<td>labelText:cake AND labelText:chocolate</td>
<td>has both labels 'cake' and 'chocolate'</td>
</tr>
</tbody>
</table>

Useful plugins

Before installing an add-on (also called a plugin) into your Confluence site, please check the add-on's information page to see whether it is supported by Atlassian, by another vendor, or not at all. See our guidelines on add-on support.

This plugin extends the Confluence search, so that you can search for macro parameter names and values: the **Confluence Macro Indexer plugin**.

Searching the People Directory

The people directory displays a list of people who are authorised to log in to your Confluence site.

The people directory includes anybody who has logged into Confluence or who has had a user account created for them in Confluence.

The people directory does not include users who can log into Confluence using external user management if
they have never yet logged in.

Viewing the people directory
Choose **People** at the top of the screen.

Searching for people
To search for a particular person, type their first name and/or last name into the search box and choose **Search**.

- To see everyone who uses your Confluence site, choose **All People**.
- To see just those people who have set up a **personal space**, choose **People with Personal Spaces**.

Following people's activities
Confluence's network features allow you to 'follow' (that is, keep track of) other people's activities in your Confluence site. For more information, please refer to **Network Overview**. You can use the hover profile feature in the people directory to start following other people.

- To start following someone, move your mouse over their name or profile picture and choose **Follow** in their profile popup.
- To stop following someone, move your mouse over their name or profile picture and choose **Stop Following** in their profile popup.

Once you start following another person, their activities will start appearing in your **network view**.

On this page:
- Viewing the people directory
- Searching for people
- Following people's activities
- Notes

Related pages:
- Create a Personal Space
- Editing your User Profile
- Set Your Profile Picture
- Confluence User's Guide

Screenshot: The people directory

---

**People Directory**

<table>
<thead>
<tr>
<th>All People</th>
<th>All People</th>
</tr>
</thead>
<tbody>
<tr>
<td>People with Personal Spaces</td>
<td>People with Personal Spaces</td>
</tr>
<tr>
<td><strong>Josh User</strong></td>
<td><strong>Ewa</strong></td>
</tr>
<tr>
<td><img src="image" alt="Josh User" /> <a href="mailto:sample@email.com.au">sample@email.com.au</a></td>
<td><img src="image" alt="Ewa" /> <a href="mailto:sample@email.com.au">sample@email.com.au</a></td>
</tr>
<tr>
<td><strong>Sophie Staunton</strong></td>
<td><strong>Ract</strong></td>
</tr>
<tr>
<td><img src="image" alt="Sophie Staunton" /> <a href="mailto:sample@email.com.au">sample@email.com.au</a></td>
<td><img src="image" alt="Ract" /> <a href="mailto:sample@email.com.au">sample@email.com.au</a></td>
</tr>
</tbody>
</table>

---

Created in 2015 by Atlassian. Licensed under a Creative Commons Attribution 2.5 Australia License.
Notes

- The people directory uses the hCard microformat for simple integration with a variety of microformat-enabled tools. hCard is an open data format for representing people, companies, organisations, and places. Read more about microformats and hCard.

- By default, deactivated users (disabled user accounts) are excluded from the people directory. You can include them by adding the showDeactivatedUsers parameter to the URL. For example:

  http://my.confluence.com/dopeopledirectorysearch.action?showDeactivatedUsers=true

- By default, externally deleted users (for example, users deleted from an LDAP repository) are excluded from the people directory. You can include them by adding the showExternallyDeletedUsers parameter to the URL. For example:

  http://my.confluence.com/dopeopledirectorysearch.action?showExternallyDeletedUsers=true

- The Confluence administrator can hide the people directory. If it is hidden, you will not see the People Directory option.

Recently Viewed Pages and Blog Posts

The Recently Viewed list in Confluence keeps track of pages and blog posts you've recently visited, and allows you to easily navigate back to them.

To view your recently viewed content:

1. Choose your profile picture at top right of the screen, then choose Recently Viewed
2. Choose the title of the page you want to revisit

To filter the list, type part of a page title or user's name in the Filter field.

Your last ten recently viewed pages also appear when you click in Confluence's Search field before you start typing a search query.
Working with Mail Archives
Confluence allows you to collect and archive mail within each space. It's useful for storing the email messages that relate to a particular project – you can put them in the same Confluence space as the content for that project.

You can download mail from one or more POP or IMAP accounts, or import mail from an mbox file on your local system or on the Confluence server.

You need space administration permissions to manage the mail archives.

Confluence mail archiving is an optional feature. This means that the 'Mail' options may be disabled and will therefore not appear in the Confluence user interface. Mail archiving features are contained in a bundled plugin. To activate mail archiving features in Confluence, enable the plugin – choose > General Configuration > Manage Add-ons. Then choose System in the drop down, and enable the Confluence Mail Archiving Plugin.

To see archived mail:
- Go to a space and choose Space tools > Integrations > Mail
  Or, if your space uses the Documentation theme, choose Browse > Mail in the header.
- Choose a message to see its contents, or choose Next, Previous and other options to navigate around the mail archives.

Managing mail archives:
- Adding a Mail Account
- Delete and Restore Mail
- Import Mail from an mbox

Screenshot: Viewing a message in the mail archive

**Tom's on annual leave today (Monday)**

*Subject:* Tom's on annual leave today (Monday) *(find more)*  
*From:* Tom Davies <tomdavies@example.com> *(find more)*  
*Date:* Oct 22, 2006 16:12

I'll see you all on Tuesday.

Tom

Notes
- Only site spaces – not personal spaces – can store mail archives. See Working with Spaces for information on site and personal spaces.
- You can also search the mail messages and their attachments. See Searching Confluence.
- Confluence mail archiving is an optional feature. This means that the 'Mail' options may be disabled and will therefore not appear in the Confluence user interface. Mail archiving features are contained in a bundled plugin.
a bundled plugin. To activate mail archiving features in Confluence, enable the plugin – choose > General Configuration > Manage Add-ons. Then choose System in the drop down, and enable the Confluence Mail Archiving Plugin.

**Adding a Mail Account**

⚠️ *The information on this page does not apply to Confluence Cloud.*

When you add a mail account, you're configuring Confluence to download mail from that account and archive it within the space.

You need space administration permissions to add a mail account. See Space Permissions Overview.

⚠️ **Note:** Confluence will remove email messages from an email account when it transfers them to the mail archive. You must therefore configure Confluence to poll a **clone** email account rather than the actual account. For example, to archive the actual account `sales@company.com` to your Confluence Sales space, you must first create a clone account such as `confsales@company.com` that contains the same email content.

Add a mail account

**Step 1. Create a clone email account on the mail server**

1. Add a new email account on the mail server with the clone email address.
2. Copy all existing email messages from the actual account to the clone account.
3. Set up the actual account to bcc sent email messages to the clone account.
4. Set up the actual account to forward received email messages to the clone account.
Step 2. Configure Confluence to archive the clone account
1. Go to the 'Mail Accounts' view:
   - Go to the space and choose **Space tools > Integrations** from the bottom of the sidebar. Choose **Mail Accounts**.
   - If your space uses the Documentation theme: Choose **Browse > Space Admin** from the header.

   **Note:** The **Space Admin** option appears only if you have **space admin permissions**, or if you're part of the 'confluence-administrators' group.

   Choose **Integration > Mail Accounts**.

2. Choose **Add mail account**

3. Enter configuration details for the account:
   - **Account Name:** Enter a name for this account by which it will be known in Confluence.
   - **Description:** Provide a description for this account (optional).
   - **Protocol:** Choose from POP, IMAP, POPS or IMAPS.
   - **Hostname:** Enter the host name of the mail server on which the account resides.
   - **Port:** Don't edit this field. The mail server's port number will be displayed by default.
   - **Username:** Enter a username that has permission to retrieve mail from this account.
   - **Password:** Enter the account's password.

4. Choose **Test Connection** to verify the details

5. Choose **Create** to add the account to Confluence

For each mail account you add, you can perform these actions in the **Mail Accounts** tab:

- **Edit:** Change the configuration settings for the mail account.
- **Remove:** Remove the account permanently.
- **Disable/Enable:** Temporarily disable the account, or enable a disabled account.

### Fetching Mail

Confluence automatically fetches mail from the server once every 30 minutes. You can manually retrieve new mail from the configured mail accounts by selecting the **Mail** tab and choosing **Fetch new mail**.

**i** You need to be a space administrator to manually retrieve mail. See **Space Permissions**.

### Notes

- Only **site spaces** – not personal spaces – can store mail archives. See **Working with Spaces** for information on site and personal spaces.
- Confluence mail archiving is an optional feature. This means that the 'Mail' options may be disabled and will therefore not appear in the Confluence user interface. Mail archiving features are contained in a bundled plugin. To activate mail archiving features in Confluence, enable the plugin – choose **Manage Add-ons**. Then choose **System** in the drop down, and enable the **Confluence Mail Archiving Plugin**.
- Once mail is fetched it will be removed from the server.

### Delete and Restore Mail
The information on this page does not apply to Confluence Cloud.

To delete mail from a space, you need 'Delete Mail' permission. 

Only a space administrator can delete all email messages in the space simultaneously.

Delete mail from a space:

1. Go to a space and choose Space tools > Integrations > Mail
   Or, if your space uses the Documentation theme, choose Browse > Mail in the header.
   A list of email messages in the space is displayed in reverse chronological order
2. Do either of the following:
   - Delete an individual email message by choosing the trash icon beside it.
   - Delete all email messages within the space by choosing Delete All.

Email messages deleted using the 'Delete All' option can't be restored.

Space administrators can restore deleted email messages, provided they were deleted individually.

Restore mail that was deleted:

1. Go to the space and choose Space tools > Content Tools from the bottom of the sidebar
2. Choose Trash
   You'll see a list of email messages and other content deleted from the space.
3. Choose Restore beside the email message you want to restore

If your space uses the Documentation theme:

1. Choose Browse > Space Admin from the header

   Note: The Space Admin option appears only if you have space admin permissions, or if you're part of the 'confluence-administrators' group.
2. Choose Trash in the left-hand panel
   You will see a list of email messages and other content deleted from the space.
3. Choose Restore beside the email message you want to restore

Import Mail from an mbox

The information on this page does not apply to Confluence Cloud.

Confluence allows you to import mail from mbox files located either on your local system or in a specified location on the Confluence server. Confluence will store the imported email messages in the space's mail archive.

You need to be a space administrator to import mail for a space. See Space Permissions.

NB: You may need to enable the Confluence Mail Archiving Plugin as it is disabled by default.

To import mail from an mbox file:

1. Go to the space and choose Space tools > Integrations from the bottom of the sidebar.
2. Choose Mailbox Import.
   - To import from a location on your file system: Browse to the location of the mbox file, select the file and then choose Import.
   - To import from the Confluence server: Enter the location of the mbox file on the server, then

On this page:
- Delete mail from a space:
- Restore mail that was deleted:

Related pages:
- Working with Mail Archives
- Confluence User’s Guide

Related pages:
- Working with Mail Archives
- Adding a Mail Account
- Confluence User’s Guide
choose **Import**.

If your space uses the Documentation theme:

1. Choose **Browse > Space Admin** from the header

   **Note:** The **Space Admin** option appears only if you have **space admin permissions**, or if you're part of the 'confluence-administrators' group.

2. Choose **Mailbox Import** in the space administration options.
   - To import from a location on your file system: Browse to the location of the mbox file, select the file and then choose **Import**.
   - To import from the Confluence server: Enter the location of the mbox file on the server, then choose **Import**.

Notes

- Only **site spaces** can store mail archives. Personal spaces cannot. See [Working with Spaces](#) for an explanation of site spaces and personal spaces.
- Confluence mail archiving is an optional feature. This means that the 'Mail' options may be disabled and will therefore not appear in the Confluence user interface. Mail archiving features are contained in a bundled plugin. To activate mail archiving features in Confluence, enable the plugin – choose **> General Configuration > Manage Add-ons**. Then choose **System** in the drop down, and enable the **Confluence Mail Archiving Plugin**.
- For security reasons mail can only be imported from a specified location in the Confluence server's file system. We recommend administrators create a folder in their Confluence home directory, add the system property `confluence.mbox.directory` and specify the location for mailboxes to be imported from. Mail cannot be imported from the server until this system property is set. See [Configuring System Properties](#).

Permissions and Restrictions

As a tool for communication and collaboration, we believe Confluence is at its best when everyone can participate fully. Confluence keeps a history of all changes to pages and other content, so it's easy to see who has changed what, and reverse any changes if you need to.

Confluence does, however, give you the choice to make your site, spaces, and pages as open or closed as you want to.

**Levels of permission**

There are three levels of permissions in Confluence: **Global permissions, space permissions**, and **page restrictions**.

**Global permissions**

**Global permissions** are site-wide permissions, and can be assigned by either a **System** or **Confluence administrator**.

These permissions are pretty broad, and don't really interact with space permissions or page restrictions.

For full details, check out the [overview of global permissions](#) in the **Administrator's Guide**.

**Space permissions**

Every space has its **own independent set of permissions**, managed by the space admin(s), which determine the access settings for different users and
They can be used to grant or revoke permission to view, add, edit, and delete content within that space, and can be applied to groups, users, and even to anonymous users (users who aren't logged in) if need be.

One thing to watch out for is where a user is a member of multiple groups. You may have revoked permission for that individual user to add pages, for example, but if they're a member of a groups that is allowed to add pages, they'll still be able to create new pages in the space.

If you can't get the result you want from space permissions, or you're not sure, check with one of your Confluence administrators to determine what permissions you should apply to individuals and groups.

**Page restrictions**

Page restrictions work a little differently to global and space permissions. Pages are open to viewing or editing by default, but you can restrict either viewing or editing to certain users or groups if you need to.

Don't forget though, every page in Confluence lives within a space, and space permissions allow the space admin to revoke permission to view content for a whole space. Even the ability to set restrictions on pages is governed by the space permission – ‘restrict pages’.

**How do permissions and restrictions interact?**

You can restrict viewing of a page or blog post to certain users or groups, so that even if someone has the ‘view’ permission for the space, they won’t be able to view the content if you’ve restricted them from viewing it.

If someone’s a space admin and you’ve restricted them from viewing a page, they won’t be able to see the page when they navigate to it. As a space admin though, they can view any restricted pages in the space and remove the restrictions.

**What about links?**

Space permissions and page restrictions affect how links between Confluence pages are displayed.
• If a link points to a page in a space to which the visitor doesn’t have the ‘View’ space permission, the link won’t be shown at all.
• If the visitor has ‘View’ space permission, but page restrictions prohibit them from viewing the page, the link will be rendered but an 'Access Denied' message is shown when they click the link.

Links to attachments are also affected. If the visitor doesn’t have permission to view the page the attachment lives on, the link won’t be rendered.

Space Permissions Overview

Each space in Confluence has its own set of permissions, which can be granted and revoked by a space administrator. The user that creates a space, like when you create your personal space, is automatically an administrator of that space, and they can add other space admins if they want to by adding the Space Admin permission to another user or group.

How do you find out who the space admin is for a particular space? Choose Spaces > Space directory in the Confluence header, then choose the Space Details icon beside a space.

If you’re one of those lucky space admins, you can assign permissions for the space to individual users, groups, or anonymous users. To change permissions for a space, choose Space tools > Permissions from the bottom of the sidebar, then choose Edit Permissions to change permission settings.

If your space is using the Documentation theme, choose Browse > Space Admin > Permissions.

Space admins can also manage watchers for that space by choosing Watch at the top-right of any page in the space.

Permissions Summary

The following permissions can be assigned for each space:

<table>
<thead>
<tr>
<th>Permission</th>
<th>The user or group can:</th>
</tr>
</thead>
<tbody>
<tr>
<td>View</td>
<td>View the space’s content, including the space’s details, its pages, and blog posts.</td>
</tr>
<tr>
<td>Pages</td>
<td>Add  Create and edit pages in the space.</td>
</tr>
<tr>
<td></td>
<td>Restrict  Apply page-level restrictions.</td>
</tr>
<tr>
<td></td>
<td>Delete  Delete pages in the space.</td>
</tr>
<tr>
<td>Blog</td>
<td>Add  Add and edit blog posts in the space.</td>
</tr>
<tr>
<td></td>
<td>Delete  Delete blog posts in the space.</td>
</tr>
<tr>
<td>Comments</td>
<td>Add  Make comments in the space.</td>
</tr>
<tr>
<td></td>
<td>Delete  Delete comments from the space.</td>
</tr>
<tr>
<td>Attachments</td>
<td>Add  Add attachments to pages in the space.</td>
</tr>
<tr>
<td></td>
<td>Delete  Delete attachments from pages in the space.</td>
</tr>
<tr>
<td>Mail</td>
<td>Delete  Delete individual mail items.</td>
</tr>
</tbody>
</table>

Related pages:
• Confluence Groups
• Assign Space Permissions
• Page Restrictions
• Global Permissions Overview
<table>
<thead>
<tr>
<th>Space</th>
<th>Export</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Export content from the space via the space-level export screens. Note that this permission doesn't affect the exporting of a single page's content. Anyone who has permission to view the page also has permission to export its content.</td>
</tr>
<tr>
<td>Admin</td>
<td>Administer this space, including granting permissions to other users. This permission can't be granted to anonymous users (users who aren't logged in).</td>
</tr>
</tbody>
</table>

Notes

Confluence administrators aren't necessarily space administrators.

- A user who has the 'Confluence Administrator' global permission isn't automatically a space admin for a particular space. In order for them to be a space admin, they must belong to a group which has space admin and view permission for the space, or their username must be specifically granted space admin and view permission for the space.
- If you deny all admin access to a space by mistake, so that nobody has access to administer the space any more, you'll need to ask someone with Confluence Administrator global permission to restore the permissions for you.
- A user who has the 'System Administrator' global permission does automatically have space admin permissions for all spaces.

Assign Space Permissions

You can assign space permissions to groups or to individual users. You need to be a space administrator to assign space permissions. In addition, Confluence administrators can set the default permissions that will be applied to new spaces as described below.

To access the permissions for a space:

1. Go to the space and choose Space tools > Permissions from the bottom of the sidebar.
2. Choose Edit Permissions

Using the Documentation theme?

1. Go to the ‘Space Permissions’ page:
   - Choose Browse > Space Admin from the header
   
   **Note:** The Space Admin option appears only if you have space admin permissions, or if you’re part of the 'confluence-administrators' group.

   - Choose Permissions from the space administration options.

2. Choose Edit Permissions

The ‘Edit Space Permissions’ page is divided into the following sections:

- **Groups** – A list of groups that already have permissions to access the site.
- **Individual Users** – A list of users who already have permissions to access the site.
- **Anonymous Access** – Space permissions granted to all anonymous users of the site.

Screenshot: Space permissions
Assign space permissions

To add a new user or group to the permissions list, search for either a group or user in their respective sections and choose **Add**. The group or user will appear in the list of groups; select the appropriate checkboxes to assign them permissions, then choose **Save all**.

If you're unsure of a group or user's name, you can search by choosing the **🔍** icon. You can use an asterisk "*" as a wildcard if you need to.
To bulk assign or revoke permissions, choose either **Select All** or **Deselect All** from the **Actions** dropdown list to the right of each user and group.

**Anonymous users**

Anonymous users are users that aren't signed in to your Confluence site, and, by default, they won't have access to any of your content. If you want to grant access to a space for anonymous users, you can edit the 'Anonymous Access' section at the bottom of the permissions page.

Tick or un-tick the checkboxes to suit your preference for anonymous users, then choose **Save All** to apply the changes.

ℹ️ You can't grant space administration rights or page restriction rights to anonymous users.

**Remove space permissions**

To remove a user or group from the space permissions list, deselect all the checkboxes for that user or group and save the changes. The user or group won't appear in the list once you save.

**Set default space permissions**

If you're a **Confluence Administrator**, you can set the default permissions that will be applied to new spaces. Default permissions are configurable for groups only, not for individual users or anonymous users.

**To set the default space permissions:**

1. Choose the cog icon, then choose **General Configuration** under Confluence Administration
2. Choose **Space Permissions** under Security in the sidebar
3. Choose **Edit Permissions**

**Screenshot: Default space permissions**

![Default Space Permissions](image1)

<table>
<thead>
<tr>
<th>All</th>
<th>Pages</th>
<th>Blog</th>
<th>Comments</th>
<th>Attachn</th>
</tr>
</thead>
<tbody>
<tr>
<td>View</td>
<td>Add</td>
<td>Restrict</td>
<td>Delete</td>
<td>Add</td>
</tr>
<tr>
<td>confluence-users</td>
<td>✔️</td>
<td>✔️</td>
<td>✔️</td>
<td>✔️</td>
</tr>
</tbody>
</table>

**Individual Spaces**

These are the current wiki spaces.

<table>
<thead>
<tr>
<th>Name</th>
<th>Key</th>
</tr>
</thead>
<tbody>
<tr>
<td>Demonstration Space</td>
<td>ds</td>
</tr>
<tr>
<td>Confluence Latest</td>
<td>LS</td>
</tr>
</tbody>
</table>

**Manage and Recover Space Admin Permissions**

Users with System Administrator permissions are able to manage permissions for spaces, including adding or removing Space Admin permissions for a space.
To manage space permissions:

1. Choose the cog icon, then choose General Configuration under Confluence Administration
2. Choose Space Permissions under Users & Security in the sidebar
3. Locate the space in the Individual Spaces list and choose Manage Permissions

There may be some instances where a space administrator has removed Space Admin permissions from all other users and groups for a space, meaning no other user can administer the space. Users with Confluence Administrator permissions can recover permissions for the space in this instance.

To recover Space Admin permissions:

1. Choose the cog icon, then choose General Configuration under Confluence Administration
2. Choose Space Permissions under Users & Security in the sidebar
3. Locate the space in the Individual Spaces list and choose Recover Permissions

The user will then be able to choose Manage Permissions, and add any appropriate permissions to the space. Requests to recover permissions are recorded in the Confluence log files.

Notes

There's no way to change a number of space permissions at once in the Confluence user interface. Instead, take a look at the Confluence Command Line Interface. You can use the CLI documentation as a resource, and for an introduction to the CLI, check out this blog post.

Confluence Groups

For Confluence administrators, grouping users in Confluence is a great way to cut down the work required when managing permissions and restrictions. Groups are also very useful, however, to anyone who's a space admin, or can apply page restrictions.

If you're a space admin, you can assign a set of space permissions to a group rather than to each individual user. And as a page creator with 'Add/Delete Restrictions' permission, you can also add and remove page restrictions for groups.

Default Confluence groups

There are some default groups in every Confluence instance but, beyond that, Confluence administrators are free to set up and edit groups in any way they see fit.

On this page:
- Default Confluence groups
- Anonymous Users

Related Pages:
- Space Permissions Overview
- Assign Space Permissions
- Page Restrictions
- Confluence Groups for Administrators
defined for this group will be assigned to all new Confluence users.

Anonymous Users

All users who don't log in when they access Confluence are known as 'anonymous' users. By default, anonymous users don't have access to view or change any content in your Confluence instance, but Confluence admins can assign permissions to this group if it's required.

Overlapping group and user permissions

When a user is assigned more than one permission, the more powerful permission will prevail.

Further explanation:

- A user may be assigned a permission specifically to their username. They may also be assigned a permission by belonging to a group, or even several groups.
- The user will then be able to perform all functions assigned to them.
- So if a user is allowed to do something over and above what the group can do, the user will be able to do it. And if the group is allowed to do something over and above the specific permissions granted to the user, the user will still be able to do it.

Use JIRA and Confluence together

Confluence and JIRA are like bacon and eggs; coffee and cake; Simon and Garfunkel. Separately, they're great, but together, they're amazing!

If you use JIRA, and have your Confluence and JIRA instances connected using Application Links, you can display and create JIRA issues and more from within Confluence. Some of these features require a specific version of JIRA.

Display JIRA issues in Confluence

You can display JIRA issues on a Confluence page using the JIRA Issues macro. Display a single issue, a list of issues, or show the total number of issues.

The simplest way to add a JIRA issue to Confluence is to paste a JIRA URL on a Confluence page. For example:

- `<yourjirasite.com>/browse/CONF-1234` will insert the JIRA Issues macro and display a single issue.
- `<yourjirasite.com>/issues/?filter=56789` will insert the JIRA Issues macro and display a list of issues matching the saved filter.
- `<yourjirasite.com>/issues/?jql=project%20%3D%20CONF` will insert the JIRA Issues macro and display a list of issues matching the JIRA search.

Alternatively, you can add the JIRA Issues Macro to the page and use the macro browser to search for issues directly:
On this page:

- Display JIRA issues in Confluence
- Create JIRA Issues from Confluence
- Creating reports and charts
- Prompt users to add JIRA Issues to a page
- View connections between Confluence and JIRA

Related pages:

- Use JIRA Agile and Confluence together
- Using Confluence as a Knowledge Base
- Use Confluence as your Intranet

1. In the editor choose **Insert > JIRA Issue**
2. Follow the prompts in the macro browser to choose a project and search for an issue – you can even use JIRA Query Language (JQL).

Once you've added the macro, you can customise how the issue or list of issues appears on the page, including how much information to display, how many issues, and more.

**Create JIRA Issues from Confluence**

You can create issues while viewing Confluence a page, or from the within the editor. This is really useful if you use Confluence for requirements gathering.

**To create an issue when viewing a page:**

1. Highlight some text on your page and choose the [Create JIRA issue](#) icon that appears above the highlight
2. Enter or select the following information:
   - Server (if you have multiple instances of JIRA connected to Confluence)
   - Project
To create an issue in the editor:

1. In the editor choose Insert > JIRA Issue > Create new issue
2. Enter or select the following information:
   - Server (if you have multiple instances of JIRA connected to Confluence)
   - Project
   - Issue Type
   - Summary (your highlighted text will populate the issue summary by default)
   - Description (optional)
3. Choose Insert

The issue will be created in JIRA and added to your page.

There are some limitations when creating JIRA Issues from Confluence. The JIRA Issues macro or Create JIRA Issue dialog will notify you if it's unable to create an issue in the selected project. You can find out more in the JIRA Issues Macro page.

Creating reports and charts

Reporting on information stored in JIRA is simple in Confluence. In addition to the JIRA Issues Macro, you can use the JIRA Report blueprint or JIRA Chart macro.

You can:

- Use the JIRA Report blueprint to create a Change Log or Status report.
- Use the JIRA Issues Macro to display a list of resolved issues, for example for use in release notes.
- Use the JIRA Chart Macro to display data as a pie chart.

Prompt users to add JIRA Issues to a page

If you use templates (including templates provided by blueprints), you can add a JIRA Issue placeholder that, when clicked, opens the JIRA Issues macro and prompts users to search for or create a JIRA issue.

For example, the JIRA Issues placeholder is used in the Product Requirements blueprint. See Creating a Template for more information on using instructional text and placeholders.

View connections between Confluence and JIRA

The JIRA Links button gives you quick access to issues connected to the Confluence page you're viewing.

Links are displayed when:

- You've created or added single issues to the page using the JIRA Issues macro in Confluence.
- You have added a link from the issue to the Confluence page in JIRA.

If you use JIRA Agile, sprints and epics will also appear on the JIRA Links button.

The number on the JIRA Links button indicates the total number of issues connected to the page, regardless of whether you have permissions to view the issues. The dropdown will only show issues, epics and sprints that you have permission to view in JIRA.

Note:

- The JIRA Links button only appears in the default theme; it's not available in the Documentation theme.
- The JIRA Links button doesn't detect links from issues displayed in the JIRA Issues macro in table.
Use JIRA Agile and Confluence together

When you use JIRA Agile and Confluence together, you can unleash the potential in your development team. Here are some suggestions to help you get the most out of Confluence and JIRA Agile. The features described on this page require JIRA 6.1.3 and JIRA Agile 6.3.5 and later.

Use Confluence and JIRA Agile to define requirements

Confluence is the perfect place to start defining your requirements. You can use the Product Requirements Blueprint to capture your requirements, and it'll let you create your JIRA epic and other issues right from the requirements page in Confluence.

Here’s how it works:

1. Create a Confluence page using the Product Requirements Blueprint
2. Choose the placeholder text ‘Link to JIRA epic or feature’ and choose Create new issue to create your epic in JIRA
3. Collaborate with your team to define your stories and save the page
4. Highlight text on your requirements page and choose the Create JIRA issue link to create stories in JIRA, and automatically link them to your epic
5. Track the progress of the stories from the Confluence page or from within JIRA

The tight integration between Confluence and JIRA Agile means you can easily access JIRA issues from the Confluence page and see their status at a glance, and from within JIRA you can see links to related Confluence pages. All the information you need is right there.

Use Confluence and JIRA Agile to manage your sprints

There's often a lot of material in Confluence that provides useful context for your team during a sprint. These might be requirements documents, designs, tech specs, customer research and more. By linking these pages to epics, you make them easy for your team to find during the sprint.

Here's how you can use Confluence to support your sprint from within JIRA Agile:
In JIRA Agile, create a Confluence page to plan your sprint. The page is created using the Meeting Notes Blueprint — and handy template that helps capture the details you need — and is automatically linked to the sprint.

- In an epic, link to useful Confluence pages, including requirements, designs, and more.
- Report on your progress to stakeholders using the JIRA Reports blueprint in Confluence.
- Use the Retrospective blueprint in Confluence at the end of your sprint to take stock of what went well and not so well

For users who work primarily in JIRA Agile, the integration means that useful Confluence pages are only a click away.

Viewing links between Confluence and JIRA

Whenever you add a link to JIRA issues in Confluence, or link to a Confluence page from JIRA, the JIRA Links button appears at the top of the Confluence page. This makes it really easy to jump from Confluence to JIRA and vice versa, speeding up your workflow.

The number on the JIRA Links button indicates the total number of issues, epics, and sprints connected to that page, regardless of whether you have permission to view them. The dropdown, however, will only show details of issues, epics, and sprints that you have JIRA permissions to view.

Note:
- The JIRA Links button only appears in the default theme; it’s not available in the Documentation theme.
- The button doesn’t detect links from issues displayed in the JIRA Issues macro in table format.

Using HipChat and Confluence together

This page covers integrations between Confluence Server and HipChat Server and Cloud. If you are using Confluence Cloud, see the following documentation.

HipChat is group and video chat for teams.

Connect Confluence to HipChat to send real time notifications to your team or project’s HipChat room

Don’t have HipChat yet? You can sign up for free and start using HipChat right away.

Connect Confluence and HipChat

First your organisation’s HipChat account needs to be connected to Confluence. It only takes a minute. You’ll need administrator permissions for your HipChat group to do this.

If you’re a Confluence admin go to General Configuration > HipChat Integration and click Connect HipChat to get started.

If you’re a Space Admin you can go to Space Tools > Integration > HipChat to get started.
  > Using the Documentation theme?
    If your space uses the Documentation theme go to Browse > Space Admin > HipChat.

Send space notifications to HipChat

Keep your team in the know by sending notifications about space activities, like new pages and blogs, to your team’s HipChat room. Notifications appear in real-time, and one click takes you straight to Confluence.

To set up space notifications go to Space Tools > Integration > HipChat and add a room to the list.
  > Using the Documentation theme?
If your space uses the Documentation theme go to **Browse > Space Admin > HipChat**.
You'll need Space Admin permissions, and the HipChat room needs to be open to everyone (not private).

---

**Advanced and Special Uses of Confluence**

This section describes the more advanced features of Confluence, and gives guidelines on some specific uses of the wiki.

**Confluence markup formats**

The syntax and usage of Confluence wiki markup and the Confluence XHTML-based storage format – see *[Working with Confluence Markup](#)*.

**Gadgets**

How to add gadgets to a wiki page, or use Confluence gadgets on other sites – see *[Working with Confluence Gadgets](#)*.

**Using Confluence for technical documentation**

A technical communicator's guide to using Confluence – see *[Developing Technical Documentation on Confluence Wiki](#)*.

**Setting up a knowledge base**

A support engineer’s guide to using Confluence as a knowledge base – see *[Using Confluence as a Knowledge Base](#)*.

**Setting up an intranet**

A quick guide to setting up an intranet wiki – see *[Use Confluence as your Intranet](#)*.
Working with Confluence Markup

This section describes two types of markup found in Confluence:

- **Confluence storage format.** Confluence stores the content of pages and blog posts in an XHTML-based format. Advanced users can view the storage format of a page and even edit it, provided their Confluence site is configured to allow that. See Confluence Storage Format for a description of the core elements of the storage format.

- **Wiki markup.** Confluence allows data entry via a shorthand code called wiki markup. Some parts of the Confluence administration interface also accept wiki markup for defining content. For a description of the wiki markup syntax, see Confluence Wiki Markup.

Storage format and wikimarkup code examples for macros can be found in the documentation for each macro.

Confluence Storage Format

This page describes the XHTML-based format that Confluence uses to store the content of pages, page templates, blueprints, blog posts and comments. This information is intended for advanced users who need to interpret and edit the underlying markup of a Confluence page.

We refer to the Confluence storage format as 'XHTML-based'. To be correct, we should call it XML, because the Confluence storage format does not comply with the XHTML definition. In particular, Confluence includes custom elements for macros and more. We're using the term 'XHTML-based' to indicate that there is a large proportion of HTML in the storage format.

You can view the Confluence storage format for a given page by choosing *** > View Storage Format. This option is only available if one of the following is true:

- You are a Confluence administrator.
- Your Confluence site has the Confluence Source Editor plugin installed and you have permission to use the source editor.
- If you would like to edit the storage format for a page, your Confluence system administrator will need to install the Confluence Source Editor plugin.
- Clarification of terminology: If you choose *** > View Source, you'll see the format used within the editor panel, not the storage format of the page.

Macros

Storage format and wiki markup examples have been included in the documentation for each macro.

Headings

<table>
<thead>
<tr>
<th>Format type</th>
<th>In Confluence 3.5 and earlier</th>
<th>In Confluence 4.0 and later</th>
<th>What you will get</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Format type</td>
<td>In Confluence 3.5 and earlier</td>
<td>In Confluence 4.0 and later</td>
<td>What you will get</td>
</tr>
<tr>
<td>-------------</td>
<td>--------------------------------</td>
<td>-----------------------------</td>
<td>-------------------</td>
</tr>
<tr>
<td>strong/bold</td>
<td><em>strong</em></td>
<td>&lt;strong&gt;strong text&lt;/strong&gt;</td>
<td>strong</td>
</tr>
<tr>
<td>emphasis</td>
<td><em>emphasis</em></td>
<td>&lt;em&gt;Italics Text&lt;/em&gt;</td>
<td>emphasis</td>
</tr>
<tr>
<td>strikethrough</td>
<td>-strikethrough-</td>
<td>&lt;span style=&quot;text-decoration: line-through;&quot;&gt;strikethrough&lt;/span&gt;</td>
<td>strikethrough</td>
</tr>
<tr>
<td>underline</td>
<td>+underline+</td>
<td>&lt;u&gt;underline&lt;/u&gt;</td>
<td>underline</td>
</tr>
<tr>
<td>superscript</td>
<td>^superscript^</td>
<td>&lt;sup&gt;superscript&lt;/sup&gt;</td>
<td>superscript</td>
</tr>
<tr>
<td>Feature</td>
<td>Example</td>
<td>HTML Representation</td>
<td></td>
</tr>
<tr>
<td>------------------</td>
<td>------------------</td>
<td>--------------------------------------</td>
<td></td>
</tr>
<tr>
<td>subscript</td>
<td><del>subscript</del></td>
<td><code>&lt;sub&gt;subscript&lt;/sub&gt;</code></td>
<td></td>
</tr>
<tr>
<td>monospace</td>
<td>{{monospaced}}</td>
<td><code>&lt;code&gt;monospaced&lt;/code&gt;</code></td>
<td></td>
</tr>
<tr>
<td>preformatted</td>
<td>n/a</td>
<td><code>&lt;pre&gt;preformatted text&lt;/pre&gt;</code></td>
<td></td>
</tr>
<tr>
<td>block quotes</td>
<td>bq. block quote</td>
<td><code>&lt;blockquote&gt;&lt;p&gt;block quote&lt;/p&gt;&lt;/blockquote&gt;</code></td>
<td></td>
</tr>
<tr>
<td>text colour</td>
<td>{color:red}red text{color}</td>
<td><code>&lt;span style=&quot;color:rgb(255,0,0);&quot;&gt;red text&lt;/span&gt;</code></td>
<td></td>
</tr>
<tr>
<td>small</td>
<td>n/a</td>
<td><code>&lt;small&gt;small text&lt;/small&gt;</code></td>
<td></td>
</tr>
<tr>
<td>big</td>
<td>n/a</td>
<td><code>&lt;big&gt;big text&lt;/big&gt;</code></td>
<td></td>
</tr>
<tr>
<td>center-align</td>
<td>n/a</td>
<td><code>&lt;p style=&quot;text-align: center;&quot;&gt;centered text&lt;/p&gt;</code></td>
<td></td>
</tr>
<tr>
<td>right-align</td>
<td>n/a</td>
<td><code>&lt;p style=&quot;text-align: right;&quot;&gt;right aligned text&lt;/p&gt;</code></td>
<td></td>
</tr>
</tbody>
</table>

Text breaks
### Format type

<table>
<thead>
<tr>
<th>In Confluence 3.5 and earlier</th>
<th>In Confluence 4.0 and later</th>
<th>What you will get</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>New paragraph</strong></td>
<td></td>
<td>Paragraph 1</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Paragraph 2</td>
</tr>
<tr>
<td></td>
<td></td>
<td>(empty line)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Paragraph 2</td>
</tr>
<tr>
<td><strong>Line break</strong></td>
<td></td>
<td>Line 1 \ Line 2</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Line 1 &lt;br /&gt; Line 2</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Note: Created in the editor using Shift + Return/Enter</td>
</tr>
<tr>
<td><strong>Horizontal rule</strong></td>
<td></td>
<td>----</td>
</tr>
<tr>
<td></td>
<td></td>
<td>&lt;hr /&gt;</td>
</tr>
<tr>
<td><strong>— symbol</strong></td>
<td></td>
<td>---</td>
</tr>
<tr>
<td></td>
<td></td>
<td>—</td>
</tr>
<tr>
<td><strong>– symbol</strong></td>
<td></td>
<td>--</td>
</tr>
<tr>
<td></td>
<td></td>
<td>—</td>
</tr>
</tbody>
</table>

### Lists

<table>
<thead>
<tr>
<th>In Confluence 3.5 and earlier</th>
<th>In Confluence 4.0 and later</th>
<th>What you will get</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Unordered list – round bullets</strong></td>
<td></td>
<td>• Round bullet list item</td>
</tr>
<tr>
<td>* Round bullet list item</td>
<td></td>
<td>&lt;ul&gt;</td>
</tr>
<tr>
<td></td>
<td></td>
<td>&lt;li&gt;round bullet list item&lt;/li&gt;</td>
</tr>
<tr>
<td></td>
<td></td>
<td>&lt;/ul&gt;</td>
</tr>
<tr>
<td><strong>Ordered list (numbered list)</strong></td>
<td></td>
<td>1. Ordered list item</td>
</tr>
<tr>
<td># Ordered list item</td>
<td></td>
<td>&lt;ol&gt;</td>
</tr>
<tr>
<td></td>
<td></td>
<td>&lt;li&gt;numbered list item&lt;/li&gt;</td>
</tr>
<tr>
<td></td>
<td></td>
<td>&lt;/ol&gt;</td>
</tr>
</tbody>
</table>
### Task Lists

<table>
<thead>
<tr>
<th>Task list item</th>
</tr>
</thead>
</table>
| <ac:task-list>
  <ac:task>
    <ac:task-status>incomplete</ac:task-status>
    <ac:task-body>task list item</ac:task-body>
  </ac:task>
</ac:task-list> |

### Links

<table>
<thead>
<tr>
<th>Format type</th>
<th>In Confluence 3.5 and earlier</th>
<th>In Confluence 4.0 and later</th>
</tr>
</thead>
</table>
| Link to another Confluence page | [Link to another Confluence page|Page Title]                                                                                                           | <ac:link>
  <ri:page ri:content-title="Page"
  <ac:plain-text-link-body>
    <![CDATA[Link to another Confluence Page]]>
  </ac:plain-text-link-body>
</ac:link> |
| Link to an attachment        | [Link to an attachment^atlassian_logo.gif]                                                                               | <ac:link>
  <ri:attachment ri:filename="atlassian_logo.gif"
  <ac:plain-text-link-body>
    <![CDATA[Link to a Confluence Attachment]]>
  </ac:plain-text-link-body>
</ac:link> |
| Link to an external site     | [Atlassian|http://www.atlassian.com/]                                                                                   | <a href="http://www.atlassian.com">
  Atlassian</a>                                                                                       |
| Anchor link (same page)      | [Anchor Link|#anchor]                                                                                                    | <ac:link ac:anchor="anchor">
  <ac:plain-text-link-body>
    <![CDATA[Anchor Link]]>
  </ac:plain-text-link-body>
</ac:link> |
| Anchor link (another page)   | [Anchor Link|pagetitle#anchor]                                                                                           | <ac:link ac:anchor="anchor">
  <ri:page ri:content-title="pagetitle"
  <ac:plain-text-link-body>
    <![CDATA[Anchor Link]]>
  </ac:plain-text-link-body>
</ac:link> |
A note about link bodies

All links received from the editor will be stored as plain text by default, unless they are detected to contain the limited set of mark up that we allow in link bodies. Here are some examples of markup we support in link bodies.

An example of different link bodies

```xml
<ac:link>
  <!-- Any resource identifier -->
  <ri:page ri:content-title="Home" ri:space-key="SANDBOX" />
  <ac:link-body>Some <strong>Rich</strong> Text</ac:link-body>
</ac:link>

<ac:link>
  <ri:page ri:content-title="Plugin developer tutorial stuff" ri:space-key="TECHWRITING" />
  <ac:plain-text-link-body><![CDATA[A plain <text> link body]]></ac:plain-text-link-body>
</ac:link>

<ac:link>
  <ri:page ri:content-title="Plugin developer tutorial stuff" ri:space-key="TECHWRITING" />
  <!-- A link body isn't necessary. Auto-generated from the resource identifier for display. -->
</ac:link>
```

The markup tags permitted within the `<ac:link-body>` are `<b>`, `<strong>`, `<em>`, `<i>`, `<code>`, `<tt>`, `<sub>`, `<sup>`, `<br>` and `<span>.

Images

<table>
<thead>
<tr>
<th>Format type</th>
<th>In Confluence 3.5 and earlier</th>
<th>In Confluence 4.0 and later</th>
</tr>
</thead>
</table>
Supported image attributes (some of these attributes mirror the equivalent HTML 4 IMG element):

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>ac:align</td>
<td>image alignment</td>
</tr>
<tr>
<td>ac:border</td>
<td>Set to &quot;true&quot; to set a border</td>
</tr>
<tr>
<td>ac:class</td>
<td>css class attribute.</td>
</tr>
<tr>
<td>ac:title</td>
<td>image tool tip.</td>
</tr>
<tr>
<td>ac:style</td>
<td>css style</td>
</tr>
<tr>
<td>ac:thumbnail</td>
<td>Set to &quot;true&quot; to designate this image as a thumbnail.</td>
</tr>
<tr>
<td>ac:alt</td>
<td>alt text</td>
</tr>
<tr>
<td>ac:height</td>
<td>image height</td>
</tr>
<tr>
<td>ac:width</td>
<td>image width</td>
</tr>
<tr>
<td>ac:vspace</td>
<td>the white space on the top and bottom of an image</td>
</tr>
<tr>
<td>ac:hspace</td>
<td>the white space on the left and right of an image</td>
</tr>
</tbody>
</table>

Tables

<table>
<thead>
<tr>
<th>Format type</th>
<th>In Confluence 3.5 and earlier</th>
<th>In Confluence 4.0 and later</th>
<th>What you will get</th>
</tr>
</thead>
</table>

<table>
<thead>
<tr>
<th>Two column, two row (top header row)</th>
<th>Two column, three rows, 2nd and third with merged cells in first row</th>
</tr>
</thead>
<tbody>
<tr>
<td>Table Heading Cell 1</td>
<td>Table Heading Cell 2</td>
</tr>
<tr>
<td>Normal Cell 1</td>
<td>Normal Cell 2</td>
</tr>
<tr>
<td>Table Heading Cell 1</td>
<td>Table Heading Cell 2</td>
</tr>
<tr>
<td>Normal Cell 1</td>
<td>Normal Cell 2</td>
</tr>
<tr>
<td>N/A</td>
<td>Merged Cell</td>
</tr>
<tr>
<td>Normal Cell 1</td>
<td>Normal Cell 2</td>
</tr>
<tr>
<td>Normal Cell 1</td>
<td>Normal Cell 2</td>
</tr>
<tr>
<td>Normal Cell 1</td>
<td>Normal Cell 2</td>
</tr>
</tbody>
</table>

**Page layouts**

Confluence supports page layouts directly, as an alternative to macro-based layouts (using, for example, the section and column macros). This section documents the storage format XML created when these layouts are used in a page.
Notes:

- Page layouts were originally introduced in Confluence 4.2, and are not available in earlier versions of Confluence. If you are using Confluence 4.2 - 5.1 you should refer to the documentation for your version of Confluence:
  - Confluence Storage Format (Confluence 4.2)
  - Confluence Storage Format (Confluence 4.3)
  - Confluence Storage Format (Confluence 5.0)
  - Confluence Storage Format (Confluence 5.1)
- Pages with a layout created in the old format will be converted to 5.2 format.
- Confluence 5.2 provides more flexible layouts with a more concise storage format.

<table>
<thead>
<tr>
<th>Element name</th>
<th>In Confluence 5.2 and later</th>
<th>Attributes</th>
</tr>
</thead>
<tbody>
<tr>
<td>ac:layout</td>
<td>Indicates that the page has a layout. It should be the top level element in the page.</td>
<td>None</td>
</tr>
<tr>
<td>ac:layout-section</td>
<td>Represents a row in the layout. It must be directly within the ac:layout tag. The type of the section indicates the appropriate number of cells and their relative widths.</td>
<td>ac:type</td>
</tr>
<tr>
<td>ac:layout-cell</td>
<td>Represents a column in a layout. It must be directly within the ac:layout-section tag. There should be an appropriate number of cells within the layout-section to match the ac:type.</td>
<td>None</td>
</tr>
</tbody>
</table>

The recognised values of ac:type for ac:layout-section are:

<table>
<thead>
<tr>
<th>ac:type</th>
<th>Expected number of cells</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>single</td>
<td>1</td>
<td>One cell occupies the entire section.</td>
</tr>
<tr>
<td>two_equal</td>
<td>2</td>
<td>Two cells of equal width.</td>
</tr>
<tr>
<td>two_left_sidebar</td>
<td>2</td>
<td>A narrow (~30%) cell followed by a wide cell.</td>
</tr>
<tr>
<td>two_right_sidebar</td>
<td>2</td>
<td>A wide cell followed by a narrow (~30%) cell.</td>
</tr>
<tr>
<td>three_equal</td>
<td>3</td>
<td>Three cells of equal width.</td>
</tr>
<tr>
<td>three_with_sidebars</td>
<td>3</td>
<td>A narrow (~20%) cell at each end with a wide cell in the middle.</td>
</tr>
</tbody>
</table>

The following example shows one of the more complicated layouts from the old format built in the new. The word {content} indicates where further XHTML or Confluence storage format block content would be entered, such as <p> or <table> tags.
Emoticons

<table>
<thead>
<tr>
<th>Format type</th>
<th>In Confluence 3.5 and earlier</th>
<th>In Confluence 4.0 and later</th>
<th>What you will get</th>
</tr>
</thead>
<tbody>
<tr>
<td>Emoticons :)</td>
<td></td>
<td>&lt;ac:emoticon ac:name=&quot;smile&quot; /&gt;</td>
<td>😊</td>
</tr>
<tr>
<td></td>
<td></td>
<td>&lt;ac:emoticon ac:name=&quot;sad&quot; /&gt;</td>
<td>😞</td>
</tr>
<tr>
<td></td>
<td></td>
<td>&lt;ac:emoticon ac:name=&quot;cheeky&quot; /&gt;</td>
<td>😄</td>
</tr>
<tr>
<td></td>
<td></td>
<td>&lt;ac:emoticon ac:name=&quot;laugh&quot; /&gt;</td>
<td>😄</td>
</tr>
<tr>
<td></td>
<td></td>
<td>&lt;ac:emoticon ac:name=&quot;wink&quot; /&gt;</td>
<td>😄</td>
</tr>
</tbody>
</table>
## Resource identifiers

Resource identifiers are used to describe "links" or "references" to resources in the storage format. Examples of resources include pages, blog posts, comments, shortcuts, images and so forth.

<table>
<thead>
<tr>
<th>Resource</th>
<th>Resource identifier format</th>
</tr>
</thead>
<tbody>
<tr>
<td>Page</td>
<td>&lt;ri:page ri:space-key=&quot;FOO&quot; ri:content-title=&quot;Test Page&quot;/&gt;</td>
</tr>
</tbody>
</table>
| Notes:       | • ri:space-key: (optional) denotes the space key. This can be omitted to create a relative reference.  
                • ri:content-title: (required) denotes the title of the page.                          |
| Blog Post    | <ri:blog-post ri:space-key="FOO" ri:content-title="First Post" ri:posting-day="2012/01/30" /> |
| Notes:       | • ri:space-key: (optional) denotes the space key. This can be omitted to create a relative reference.  
                • ri:content-title: (required) denotes the title of the page.                          
                • ri:posting-day: (required) denotes the posting day. The format is YYYY/MM/DD.       |
### Attachment

```
<ri:attachment ri:filename>
  ... resource identifier for the container of the attachment ...
</ri:attachment>
```

**Notes:**
- `ri:filename`: (required) denotes the name of the attachment.
- the body of the `ri:attachment` element should be a resource identifier denoting the container of the attachment. This can be omitted to create a relative attachment reference (similar to `[foo.png]` in wiki markup).

**Examples:**

#### Relative Attachment Reference

```
<ri:attachment ri:filename="happy.gif" />
```

#### Absolute Attachment Reference

```
<ri:attachment ri:filename="happy.gif">
  <ri:page ri:space-key="TST" ri:content-title="Test Page"/>
</ri:attachment>
```

### URL

```
<ri:url ri:value="http://example.org/sample.gif"/>
```

**Notes:**
- `ri:value`: (required) denotes the actual URL value.

### Shortcut

```
<ri:shortcut ri:key="jira" ri:parameter="ABC-123">
```

**Notes:**
- `ri:key`: (required) represents the key of the Confluence shortcut.
- `ri:parameter`: (required) represents the parameter to pass into the Confluence shortcut.
- The example above is equivalent to `[ABC-123@jira]` in wiki markup.

### User

```
<ri:user ri:userkey="2c9680f7405147ee0140514c26120003"/>
```

**Notes:**
- `ri:userkey`: (required) denotes the unique identifier of the user.

### Space

```
<ri:space ri:space-key="TST"/>
```

**Notes:**
- `ri:space-key`: (required) denotes the key of the space.
Template variables

This screenshot shows a simple template:

```
<ri:content-entity ri:content-id="123"/>
```

Notes:
- `ri:content-id`: (required) denotes the id of the content.

The template contains the following variables:

<table>
<thead>
<tr>
<th>Variable name</th>
<th>Type</th>
<th>Values</th>
</tr>
</thead>
<tbody>
<tr>
<td>$MyText</td>
<td>Single-line text</td>
<td></td>
</tr>
<tr>
<td>$MyMulti</td>
<td>Multi-line text</td>
<td>Size: 5 x 100</td>
</tr>
<tr>
<td>$MyList</td>
<td>List</td>
<td>List items: Apples, Pears, Peaches</td>
</tr>
</tbody>
</table>

The XML export produces the following code for the template:
Instructional Text

Instructional text allows you to include information on how to fill out a template for an end-user (the person using creating a page from the template). Instructional text will:

- automatically clear all *instructional text* as the user types in a specific text block, and
- automatically trigger a @mention prompt for user selection (for 'mention' type instructional text).

**Screenshot: Example of instructional text.**

```html
<ul>
  <li>This is an example of instruction text that will get replaced when a user selects the text and begins typing.</li>
</ul>
```

Confluence Wiki Markup

This page describes the wiki markup used on some administration screens in Confluence.

Wiki markup is useful when you want to do one of the following:
• Configure the Documentation theme.
• Type wiki markup directly into the editor. Confluence will convert it to the rich text editor format as you type.
• Create links using the Advanced tab of the Links Browser.
• Insert a block of wiki markup (or markdown) into the Confluence editor. (Choose Insert > Markup.)

**Note: You cannot edit content in wiki markup.** Confluence does not store page content in wiki markup. Although you can enter wiki markup into the editor, Confluence will convert it to the rich text editor format immediately. You will not be able to edit the wiki markup after initial entry.

Can I type wiki markup into the editor?

Yes. You can type wiki markup directly into the editor, and Confluence will convert it as you type. (You cannot edit the wiki markup after conversion.) See it in action in this video:

Read this blog post for more examples: 12 Things You Didn’t Know About the Confluence Editor.

Can I insert markdown?

Confluence supports inserting content in markdown. This is often used in ReadMe files. See [Markdown syntax guide](#guide) for some examples of markdown syntax.

**To insert markdown in the editor:**

1. Choose Insert > Markup
2. Select Markdown
3. Type or paste your text - the preview will show you how it will appear on your page
4. Choose Insert.

As with wiki markup, Confluence will convert your markdown to the rich text editor format. You will not be able to edit your content using markdown.

**On this page:**

- Can I type wiki markup into the editor?
- Can I insert markdown?
- Headings
- Lists
- Tables
- Text Effects
- Text Breaks
- Links
- Images
- Page Layouts
- Macros

### Headings

To format a line as a heading, type "hn." at the start of your line, where n can be a number from 1 to 6.

<table>
<thead>
<tr>
<th>What you need to type</th>
<th>What you get</th>
</tr>
</thead>
<tbody>
<tr>
<td>h1. Biggest heading</td>
<td>Biggest heading</td>
</tr>
<tr>
<td>h3. Big heading</td>
<td><strong>Big heading</strong></td>
</tr>
</tbody>
</table>
Lists

Wiki markup allows you to create bulleted or numbered lists, and is flexible enough to allow a combination of the two list types.

ℹ️ If you need to separate the text within lists using line breaks, make sure you do so using a double slash (//). Empty lines may disrupt the list.

Simple lists

Use the hyphen (-) to create simple lists.
Make sure there is a space between the hyphen and your text.

<table>
<thead>
<tr>
<th>What you need to type</th>
<th>What you will get</th>
</tr>
</thead>
<tbody>
<tr>
<td>- some</td>
<td>• some</td>
</tr>
<tr>
<td>- bullet</td>
<td>• bullet</td>
</tr>
<tr>
<td>- points</td>
<td>• points</td>
</tr>
</tbody>
</table>

Bulleted lists

Use the asterisk (*) to create bullets. For each subsequent level, add an extra asterisk.
Make sure there is a space between the asterisk and your text.

<table>
<thead>
<tr>
<th>What you need to type</th>
<th>What you will get</th>
</tr>
</thead>
<tbody>
<tr>
<td>* some</td>
<td>• some</td>
</tr>
<tr>
<td>* bullet</td>
<td>• bullet</td>
</tr>
<tr>
<td>** indented</td>
<td>• indented</td>
</tr>
<tr>
<td>** bullets</td>
<td>• bullets</td>
</tr>
<tr>
<td>* points</td>
<td>• points</td>
</tr>
</tbody>
</table>

Numbered lists

Use the hash (#) to create numbered lists.
Make sure there is a space between the hash and your text.

<table>
<thead>
<tr>
<th>What you need to type</th>
<th>What you will get</th>
</tr>
</thead>
<tbody>
<tr>
<td># a</td>
<td>1. a</td>
</tr>
<tr>
<td># numbered</td>
<td>2. numbered</td>
</tr>
<tr>
<td># list</td>
<td>3. list</td>
</tr>
</tbody>
</table>

A second level of hashes will produce a sub-list, such as the alphabetical sub-list shown below.

<table>
<thead>
<tr>
<th>What you need to type</th>
<th>What you will get</th>
</tr>
</thead>
</table>
You can use a third level of hashes to produce a sub-sub-list.

<table>
<thead>
<tr>
<th>What you need to type</th>
<th>What you will get</th>
</tr>
</thead>
<tbody>
<tr>
<td># Here's a sentence.</td>
<td>1. Here's a sentence.</td>
</tr>
<tr>
<td>## This is a sub-list point.</td>
<td>a. This is a sub-list point.</td>
</tr>
<tr>
<td>### Another point at the third level.</td>
<td>i. Third list level.</td>
</tr>
<tr>
<td>## And a second sub-list point.</td>
<td>ii. Another point at the third level.</td>
</tr>
<tr>
<td># Here's another sentence.</td>
<td>b. And a second sub-list point.</td>
</tr>
</tbody>
</table>

Here's a sentence.

This is a sub-list point.

And a second sub-list point.

Here's another sentence.

Note: In numbered lists as described above, the format of the 'number' displayed at each list level may be different, depending upon your browser and the style sheets installed on your Confluence instance. So in some cases, you may see letters (A, B, C, etc; or a, b, c, etc) or Roman numerals (i, ii, iii, etc) at different list levels.

Mixed lists

<table>
<thead>
<tr>
<th>What you need to type</th>
<th>What you will get</th>
</tr>
</thead>
</table>
| # Here
| * is
| * an
| * example
| * of
| * a
| * mixed
| * list | 1. Here
| • is
| • an
| 2. example
| • of
| • a
| 3. mixed
| 4. list |

Tables

You can create two types of tables.

Table Type 1

Allows you to create a simple table with an optional header row. You cannot set the width of the columns in this table.

Use double bars for a table heading row.

What you need to type:

<table>
<thead>
<tr>
<th>heading 1</th>
<th>heading 2</th>
<th>heading 3</th>
</tr>
</thead>
<tbody>
<tr>
<td>cell A1</td>
<td>cell A2</td>
<td>cell A3</td>
</tr>
<tr>
<td>cell B1</td>
<td>cell B2</td>
<td>cell B3</td>
</tr>
</tbody>
</table>

What you will get:
You can also use a vertical header.

What you need to type:

```
| heading 1 | col A1 | col A2 | col A3 |
| heading 2 | col B1 | col B2 | col B3 |
```

What you will get:

| heading 1 | col A1 | col A2 | col A3 |
| heading 2 | col B1 | col B2 | col B3 |

Table Type 2

This method allows you to specify the width of the columns in the table.

What you need to type

```
{section:border=true}
{column:width=30%}
Text for this column goes here. This is the smaller column with a width of only 30%.
{column}
{column:width=70%}
Text for this column goes here. This is the larger column with a width of 70%.
{section}
```

What you will get

Text for this column goes here. This is the smaller column with a width of only 30%.
Text for this column goes here. This is the larger column with a width of 70%.

For more details please see the Column Macro and the Section Macro.

Advanced Formatting

Colour and Other Formatting

To add colour and other formatting to your tables, you can use the Panel Macro within columns. More table-formatting options may be available if your Confluence administrator has installed additional macros.

Lists

Here’s an example of how to embed lists in a table:

What you need to type
<table>
<thead>
<tr>
<th>Heading 1</th>
<th>Heading 2</th>
</tr>
</thead>
<tbody>
<tr>
<td>* Item 1</td>
<td>1. Item 1</td>
</tr>
<tr>
<td>* Item 2</td>
<td>2. Item 2</td>
</tr>
<tr>
<td>* Item 3</td>
<td>3. Item 3</td>
</tr>
</tbody>
</table>

### Text Effects

Use the markup shown in the examples below to format text.

<table>
<thead>
<tr>
<th>What you need to type</th>
<th>What you will get</th>
</tr>
</thead>
<tbody>
<tr>
<td><em>strong</em></td>
<td>strong</td>
</tr>
<tr>
<td><em>bold text</em></td>
<td>bold text</td>
</tr>
<tr>
<td><em>emphasis</em></td>
<td>emphasis</td>
</tr>
<tr>
<td><em>italics</em></td>
<td>italics</td>
</tr>
<tr>
<td><strong>citation??</strong></td>
<td>——citation</td>
</tr>
<tr>
<td>-deleted-</td>
<td>deleted</td>
</tr>
<tr>
<td>+inserted+</td>
<td>inserted</td>
</tr>
</tbody>
</table>

**Text with^superscript^**

Hint: There are two ways to make superscripts work, when used directly after another word or character:

- Add a space before the superscript. For example, kg/m \(^3^\) gives you this: kg/m\(^3\)
- Add braces (curly brackets) around the superscript markup. For example, kg/m\(^{3}\) gives you this: kg/m\(^3\)

**Text with~subscript~**


Here’s how you make a paragraph appear as a block quotation.

| (color:red)look ma, red text!(color) | look ma, red text! |

Text Breaks

**Paragraph Break**

In wiki markup, a paragraph is a continuous line of text ending in two carriage returns. This is equivalent to a continuous line of text followed by a blank line.

When rendered into HTML, the result is a line of text wrapped in a set of `<p></p>` tags.

**Line Break**

Confluence provides two options for forcing a line break within a paragraph of text:

- Implicitly, by entering a single carriage return at its end.
- Explicitly, by entering two consecutive backslashes: `\`

When rendered into HTML, the result is a paragraph of text that is split into separate lines by `<br>` tags, wherever a forced line break appears.

For most purposes, explicit line breaks are not required because a single carriage return is enough.

The examples below show how to use explicit line breaks.

<table>
<thead>
<tr>
<th>What you need to type</th>
<th>What you will get</th>
</tr>
</thead>
<tbody>
<tr>
<td>here is some text \</td>
<td>here is some text</td>
</tr>
<tr>
<td>\</td>
<td>divided using line</td>
</tr>
<tr>
<td>\</td>
<td>breaks</td>
</tr>
<tr>
<td>divided \</td>
<td></td>
</tr>
<tr>
<td>using line \</td>
<td></td>
</tr>
<tr>
<td>\</td>
<td></td>
</tr>
<tr>
<td>breaks\</td>
<td></td>
</tr>
<tr>
<td>This is a short list:</td>
<td>This is a short list:</td>
</tr>
<tr>
<td>* Point 1</td>
<td>* Point 1</td>
</tr>
<tr>
<td>Text to go with point</td>
<td>Text to go with point</td>
</tr>
<tr>
<td>1</td>
<td>1</td>
</tr>
<tr>
<td>* Point 2</td>
<td>* Point 2</td>
</tr>
<tr>
<td>\</td>
<td>\</td>
</tr>
<tr>
<td>\</td>
<td>\</td>
</tr>
<tr>
<td>Text to go with point</td>
<td>Text to go with point</td>
</tr>
<tr>
<td>2 with a break</td>
<td>2 with a break</td>
</tr>
</tbody>
</table>

If you wish to use multiple consecutive line breaks, each should be separated by a space character. For example, use this for two consecutive line breaks:

```
\ \ \ \ \ 
```

**Horizontal Rule**

To create a horizontal line across the width of your page or content block, type four dashes (like this: `----`) at the beginning of a line, then press Enter or space.

Make sure that the dashes are on a separate line from the rest of the text.
What you need to type | What you will get
---|---
Here is some text | Here is some text
---|---
divided by a horizontal rule | divided by a horizontal rule

Links

You can use wiki markup to add hyperlinks to your text.

<table>
<thead>
<tr>
<th>What you need to type</th>
<th>What you will get</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="http://confluence.atlassian.com" alt="http://external/image.png!http://external/link.html" /></td>
<td>Displays an external image and links to an external URL.</td>
</tr>
</tbody>
</table>

Note that Confluence treats headings as anchors, so you can link to headings using this pattern: 
[spacekey:pagename#headingname], where headingname is case-sensitive and must be entered without spaces.

For each of these link forms:

- You can prepend a link alias, so that alternate text is displayed on the page. Example: [link
Images

You can display images from attached files or remote sources.

<table>
<thead>
<tr>
<th>What you need to type</th>
<th>What you will get</th>
</tr>
</thead>
<tbody>
<tr>
<td>!<a href="http://www.host.com/image.gif">http://www.host.com/image.gif</a>!</td>
<td>An image from a remote source is displayed on the page. Uses a fully qualified URL.</td>
</tr>
<tr>
<td>!attached-image.gif!</td>
<td>An image file attached to the page is displayed.</td>
</tr>
<tr>
<td>!pageTitle^image.gif!</td>
<td>An image file attached to a different page is displayed.</td>
</tr>
<tr>
<td>!spaceKey:pageTitle^image.gif!</td>
<td>An image file attached to a page in a different space is displayed.</td>
</tr>
<tr>
<td>!/2010/05/23/My Blog Post^image.gif!</td>
<td>An image file attached to a blog post is displayed.</td>
</tr>
<tr>
<td>!image.jpg</td>
<td>thumbnail!</td>
</tr>
<tr>
<td>!image.gif</td>
<td>align=right, vspace=4!</td>
</tr>
</tbody>
</table>

Available HTML image tags include:

<table>
<thead>
<tr>
<th>Image tag</th>
<th>Details</th>
</tr>
</thead>
<tbody>
<tr>
<td>align</td>
<td>Available values are ’left’, ’right’, ’bottom’, ’center’, ’top’.</td>
</tr>
<tr>
<td>border</td>
<td>Specifies the width of the border (in pixels).</td>
</tr>
<tr>
<td>bordercolor</td>
<td>Use with the ’border’ tag. Specify colours by name or hex value.</td>
</tr>
<tr>
<td>hspace</td>
<td>Specifies the amount of whitespace to be inserted to the left and right of the image (in pixels).</td>
</tr>
<tr>
<td>vspace</td>
<td>Specifies the amount of whitespace to be inserted above and below the image (in pixels).</td>
</tr>
<tr>
<td>width</td>
<td>Specifies the width of the image (in pixels). This will override the natural width of the image.</td>
</tr>
<tr>
<td>height</td>
<td>Specifies the height of the image (in pixels). This will override the natural height of the image.</td>
</tr>
<tr>
<td>title</td>
<td>Specifies alternate text for the image, which is displayed when the pointer hovers over the image.</td>
</tr>
<tr>
<td>alt</td>
<td>Specifies alternate text for the image. This text is retrievable via search, and contributes to accessibility of the page for text-only viewing.</td>
</tr>
</tbody>
</table>

Page Layouts

There is no wiki markup representation for page layouts.

Macros

Storage format and wiki markup examples have been included in the documentation for each macro.

Working with Confluence Gadgets
This section introduces the concept of gadgets in Confluence and provides an outline on how to use gadgets in Confluence and other web applications.

Introduction to Gadgets in Confluence

A gadget is a small object (i.e. a piece of functionality) offering dynamic content that can be placed into the page of:

- An Atlassian application's website, such as a Confluence page or blog post or a JIRA 4.0+ dashboard.
- A third-party application's website, such as iGoogle or Gmail. (But see the limitations on using Confluence gadgets in other applications.)

Gadgets allow interactions between Confluence and other compatible websites. Confluence interacts with gadgets that support the OpenSocial specification.

For more information about Atlassian gadgets, please refer to the introduction to Atlassian gadgets and the big list of Atlassian gadgets.

Using Gadgets in Confluence

You can place any gadget that complies with the OpenSocial specification from an external source, such as iGoogle or other Atlassian applications such as JIRA 4.0+, onto a Confluence page or blog post. To add a gadget to a page, use the Confluence macro browser to add a Gadget macro.

See the page on adding JIRA gadgets to a Confluence page.

On this page:
- Introduction to Gadgets in Confluence
- Using Gadgets in Confluence
- Adding Confluence Gadgets in Other Applications
  - Adding a Confluence Gadget to JIRA
  - Adding a Confluence Gadget to Non-Atlassian Web Applications
  - Confluence Gadgets

Related pages:
- Gadget Macro
- Configuring Confluence Gadgets for Use in Other Applications
- Adding a Confluence Gadget to a JIRA Dashboard
- Confluence Gadgets
- All Atlassian gadgets
- External Gadgets

Adding Confluence Gadgets in Other Applications

You can add a Confluence gadget to a JIRA dashboard or another Confluence site. In principle, you can also put a Confluence gadget on any other OpenSocial-compliant website such as iGoogle or Gmail. See the limitations on using Confluence gadgets in other applications.

Adding a Confluence Gadget to JIRA

See Adding a Confluence Gadget to a JIRA Dashboard.

Adding a Confluence Gadget to Non-Atlassian Web Applications

For instructions on how to add Confluence gadgets in another compatible non-Atlassian web application or container, refer to Configuring Confluence Gadgets for Use in Other Applications.

Confluence Gadgets

The Confluence Gadgets topic explains the purpose of the ‘Confluence Gadgets’ window and provides
information about the gadgets which are bundled with Confluence.

Adding a Confluence Gadget to a JIRA Dashboard

JIRA 4.0 is the first major Atlassian application that can incorporate OpenSocial-compliant gadgets, such as Confluence gadgets onto its dashboard. This page explains how to add a Confluence gadget to the dashboard of a JIRA 4.0+ installation.

To add a Confluence gadget to a JIRA dashboard, complete the steps below.

Creating an Application Link between Confluence and JIRA

If your Confluence gadgets need to access user-restricted Confluence data, then your Confluence administrator must first establish an Application Link between your Confluence site and the JIRA site.

If you only need to access anonymously accessible Confluence data, then you can skip the section about adding an Application Link, and go directly to Finding a Confluence Gadget's URL, below.

Finding a Confluence Gadget's URL

A gadget's URL points to the gadget's XML specification file. These URLs look something like this:

http://example.com/my-gadget-location/my-gadget.xml

To find a Confluence gadget's URL:

1. Choose the help icon at top right of the screen, then choose Available Gadgets.
2. Find the gadget you want.
3. Copy the Gadget URL link to your clipboard.

Screenshot: Finding a gadget's URL
To add a Confluence gadget to the gadget directory in JIRA:

1. Go to the dashboard by clicking Dashboard at the top left of the screen.
2. The dashboard will appear. Click Add Gadget.
3. The 'Add Gadget' screen appears, showing the list of gadgets in your directory. See screenshot 1 below. Click Add Gadget to Directory.
   Note: You will only see this button if you have system administrator permissions in JIRA.
4. The 'Add Gadget to Directory' screen appears. See screenshot 2 below. Paste the gadget URL (which you copied to your clipboard above) into the text box.
5. Click Add Gadget.
6. The gadget appears in your gadget directory. (It will be highlighted for a short time, so that you can see it easily.)
Adding a Confluence gadget to the JIRA dashboard
In the procedure below, 'your Atlassian dashboard' and 'your Atlassian application' refers to the JIRA dashboard and application, respectively. You can add a gadget from the directory of gadgets that are available to your Atlassian application.

**To add a gadget to your Atlassian dashboard,**

1. Go to the dashboard by clicking the 'Dashboard' link or the 'Home' link at the top left of the screen.
2. The dashboard will appear, looking something like screenshot 1 below. Click 'Add Gadget'.
3. The 'Add Gadget' screen will display a list of available gadgets in your gadget directory, as shown in screenshot 2 below. Find the gadget you want, using one or more of the following tools:
   - Use the scroll bar on the right to move up and down the list of gadgets.
   - Select a category in the left-hand panel to display only gadgets in that category.
   - Start typing a key word for your gadget in the 'Search' textbox. The list of gadgets will change as you type, showing only gadgets that match your search term.
4. When you have found the gadget you want, click the 'Add it Now' button to add the gadget to your dashboard.

**Screenshot 1: An Atlassian dashboard**

![Add Gadget screen](image)
Note:

- You need administrator privileges to add a gadget to the list of available gadgets. If you have permission to add gadgets to and remove gadgets from the directory itself, you will see the 'Add Gadget to Directory' and 'Remove' buttons on the 'Add Gadget' screen, as shown in the screenshot about. Please refer to the Gadgets and Dashboards Administration Guide.
- In Atlassian OnDemand products, it is not possible for administrators to add gadgets to the directory. If you would like to add an Atlassian gadget to a directory, please contact Atlassian Support.

Configuring Confluence Gadgets for Use in Other Applications

This page tells you how to add a Confluence gadget to another (external) application. The instructions and examples given in this topic focus on adding and using Confluence Gadgets in other web applications.

Atlassian support does not cover gadgets on external sites like iGoogle and Gmail

In principle, you should be able to add Atlassian gadgets to iGoogle, Gmail and other external sites that support OpenSocial gadgets. However, these external integrations are experimental at this stage and we have encountered problems with them. Please do have fun playing around with them, but be aware that Atlassian does not support the use of Atlassian gadgets on iGoogle, Gmail or other external web sites. See the detailed section on gadget limitations.

Gadgets that display information from Atlassian applications, such as Confluence, should be able to run on iGoogle, Gmail and other web applications that provide OpenSocial containers. Below are specific instructions for iGoogle and Gmail. You can experiment by adding a Confluence gadget to other web sites and applications, such as a Ning community like The Content Wrangler.

On this page:

- Overview of Adding a Confluence Gadget to Another Web Application
- Finding a Confluence Gadget's URL
- Adding an Atlassian Gadget to iGoogle
- Adding an Atlassian Gadget to Gmail
- Limitations and Support
- Related Topics
Overview of Adding a Confluence Gadget to Another Web Application

The exact procedure for adding a Confluence gadget depends on the application where you want to add the gadget. The basic steps are the same:

1. Find the Confluence gadget's URL, i.e. the URL for the gadget's XML specification file.
2. Ensure one of the following two mandatory (typically one-off) procedures have been conducted:
   - An OAuth relationship between Confluence (as the 'service provider') and the other web application (as the 'consumer') has been established. Refer to Configuring Authentication for an Application Link for more information about OAuth and instructions on establishing these relationships.
   - A Trusted Applications relationship between Confluence and JIRA has been established. Refer to Configuring Trusted Applications in the JIRA documentation for more information about establishing these relationships.
3. Follow the procedure provided by the external web application where you want to add the Confluence gadget.

Finding a Confluence Gadget's URL

A gadget's URL points to the gadget's XML specification file. These URLs look something like this:

http://example.com/my-gadget-location/my-gadget.xml

To find a Confluence gadget's URL:

1. Choose the help icon at top right of the screen, then choose Available Gadgets.
2. Find the gadget you want.
3. Copy the Gadget URL link to your clipboard.
Adding an Atlassian Gadget to iGoogle

You can customise your iGoogle home page by adding gadgets and moving them around on the page.

To add an Atlassian gadget to your iGoogle page:

1. First find the gadget's URL as described above.
2. Go to iGoogle and log in if you have a username and password.
3. Click Add stuff near the top right of the iGoogle page.
4. The Google gadget directory will appear, showing a list of available gadgets. Click Add feed or gadget in the right-hand panel.

5. A text box will open, as shown above. Enter or paste the gadget's URL from your clipboard into the textbox and click Add.
6. Go back to your iGoogle home page. The gadget will appear on your iGoogle page.

Adding an Atlassian Gadget to Gmail

You can add gadgets to the left-hand panel of your Gmail page.

To add an Atlassian gadget to your Gmail page:

1. First find the gadget's URL as described above.
2. Log in to Gmail.
3. Click Settings near the top right of the Gmail page. The Gmail settings page will appear.
4. Click the Labs tab. The Gmail Labs page will appear. This is a laboratory area or testing ground where Google allows you to use experimental features in Gmail.
5. Scroll down to find the feature called 'Add any gadget by URL'.
6. Select the Enable option, as shown here:

7. Click Save Changes.
8. A new Gadgets tab will appear on your 'Settings' page. Click the Gadgets tab. The 'Gadgets' page will appear, as shown in the screenshot below.
9. Enter or paste your gadget's URL into the Add a gadget by its URL box, then click Add.
10. The gadget will appear in the left-hand panel of your Gmail page, as shown in the screenshot below.

Screenshot: Adding a gadget to Gmail
Limitations and Support

**Atlassian support does not cover gadgets on external sites like iGoogle and Gmail**

In principle, you should be able to add Atlassian gadgets to iGoogle, Gmail and other external sites that support OpenSocial gadgets. However, these external integrations are experimental at this stage and we have encountered problems with them. Please do have fun playing around with them, but be aware that Atlassian does not support the use of Atlassian gadgets on iGoogle, Gmail or other external web sites.

Related Topics
The big list of Atlassian gadgets

Confluence Gadgets
This page describes the purpose of the 'Confluence Gadgets' dialog and how to access it, and provides information about the gadgets that are bundled with Confluence.

Gadgets:
- Interact with and provide access to data in your Confluence installation.
- Can be used externally such as on a JIRA dashboard, a page or blog post of another Confluence site, or any compatible page on a website that accepts gadgets, such as iGoogle. (But see the limitations on using Confluence gadgets in other applications.)

The gadgets dialog

The 'Confluence Gadgets' dialog displays a list of all the Confluence gadgets available in your Confluence installation. The Confluence gadgets bundled with Confluence are described below. Any additional Confluence gadgets installed by your Confluence administrator (typically as Confluence plugins), will also appear in this list.

To access the Confluence Gadgets dialog: Choose the help icon at top right of the screen, then choose Available Gadgets.

You can use a Confluence gadget within the same Confluence site, by adding it to a page or blog post using the gadget macro.

You can also add Confluence gadgets to external applications. See Adding a Confluence Gadget to a JIRA Dashboard and Configuring Confluence Gadgets for Use in Other Applications.

On this page:
- The gadgets dialog
- Confluence gadgets

Related pages:
- Adding a Confluence Gadget to a JIRA Dashboard
- Configuring Confluence Gadgets for Use in Other Applications
- Gadget Macro
- The big list of Atlassian gadgets
- Confluence User's Guide

Screenshot: The 'Confluence Gadgets' dialog
This following table lists the gadgets which are bundled with Confluence. Click the name of the gadget for more information.
<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Confluence Page Gadget</td>
<td>The Confluence page gadget allows you to show content from a page on your Confluence site in a gadget. You can optionally configure the gadget to display links to view and/or edit the page on your Confluence site. The page gadget can also be displayed in canvas view, so that it takes up all of the space provided by your dashboard.</td>
</tr>
<tr>
<td>Activity Stream Gadget</td>
<td>The activity stream gadget is similar to the recently updated macro and shows a list of the most recently changed content within your Confluence site.</td>
</tr>
<tr>
<td>Confluence News Gadget</td>
<td>The Confluence news gadget is an example of a 'news feed' gadget that shows a list of recent Confluence Product Blogs and events at Atlassian.</td>
</tr>
<tr>
<td>Confluence Quicknav Gadget</td>
<td>The Confluence QuickNav gadget provides the Quick Navigation Aid functionality for searching the Confluence site. For more information on how to use this feature, refer to the Quick Navigation Aid section of Searching Confluence.</td>
</tr>
</tbody>
</table>

**Activity Stream Gadget**

The activity stream gadget is similar to the recently updated macro and shows a list of the most recently changed content within your Confluence site.

*For instructions on how to use Confluence gadgets in your applications, please see Confluence Gadgets.*

In addition to showing a list of most recently changed content, the activity stream gadget also groups activities by separate date, and provides an RSS feed link to its content in the top-right corner.

**Activity Stream Gadget Properties**

Properties are settings for Confluence gadgets that allow the user to control the content or presentation of data retrieved by the gadget. These are similar to a Confluence macro’s parameters. The table below lists relevant properties for this gadget.

These properties are located in the preview panel in the macro browser.

<table>
<thead>
<tr>
<th>Property</th>
<th>Required?</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Title</td>
<td>Yes</td>
<td>None</td>
<td>Adds a title to the top of the Activity Stream.</td>
</tr>
<tr>
<td>Global filters</td>
<td>No</td>
<td>None</td>
<td>Allows you to add filters to the gadget including:</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• space</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• username</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• update date</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• JIRA issue key (if your Confluence instance is integrated with JIRA)</td>
</tr>
<tr>
<td>Available streams</td>
<td>Yes</td>
<td>All</td>
<td>If you have application links to other sites. JIRA or another Confluence instance, you can choose to include activity from those streams also.</td>
</tr>
<tr>
<td>Display options: limit</td>
<td>No</td>
<td>10</td>
<td>Specify the maximum number of results to be displayed. A maximum of 10 results will be displayed by default. The maximum value that this property can accept is 100.</td>
</tr>
</tbody>
</table>

Created in 2015 by Atlassian. Licensed under a Creative Commons Attribution 2.5 Australia License.
Confluence News Gadget

The Confluence news gadget is an example of a 'news feed' gadget that shows a list of recent Confluence Product Blogs and events at Atlassian.

For instructions on how to use Confluence gadgets in your applications, please see Confluence Gadgets.

Clicking an item in the Confluence news gadget takes you directly to the selected blog post of the Confluence Product Blogs feed or event details on the events at Atlassian page.

Clicking More news takes you to the Confluence Product Blogs feed page and clicking More events takes you to the events at Atlassian page.

Screenshot: The News Gadget

Confluence: News Gadget Properties

Properties are settings for Confluence gadgets that allow the user to control the content or presentation of data retrieved by the gadget. These are similar to a Confluence macro's parameters. The table below lists relevant properties for this gadget.

<table>
<thead>
<tr>
<th>Property</th>
<th>Required?</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Show News?</td>
<td>No</td>
<td>True</td>
<td>Shows a short list of the most recent Confluence Product Blogs.</td>
</tr>
<tr>
<td>Show Events?</td>
<td>No</td>
<td>True</td>
<td>Shows a short list of the most recent events at Atlassian.</td>
</tr>
<tr>
<td>Show Banners?</td>
<td>No</td>
<td>True</td>
<td>Shows any banner advertisements (if available).</td>
</tr>
</tbody>
</table>

Confluence Page Gadget

The Confluence page gadget allows you to show content from a page on your Confluence site in a gadget. You can optionally configure the gadget to display links to view and/or edit the page on your Confluence site. The page gadget can also be displayed in canvas view, so that it takes up all of the space provided by your dashboard.
For instructions on how to use Confluence gadgets in your applications, please see Confluence Gadgets.

Macros that work with the page gadget
Please note, not all macros work with the page gadget. Please refer to the Working Macros section below for more information.

On this page:
- Confluence Page Gadget Properties
- Working Macros

Related pages:
- Confluence Gadgets
- Confluence User’s Guide

Screenshot: The Confluence page gadget displaying a sample page

Sample Page

Two penguins find themselves together on an ice floe, drifting helplessly into warmer waters. The penguins are very fond of each other. Suddenly the ice floe splits in half, right between the penguins. As they drift apart, one penguin sadly waves a flipper and calls out "Chocolate milk!"

Confluence Page Gadget Properties

Properties are settings for Confluence gadgets that allow the user to control the content or presentation of data retrieved by the gadget. These are similar to a Confluence macro’s parameters. The table below lists relevant properties for this gadget.

<table>
<thead>
<tr>
<th>Property</th>
<th>Required?</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Space</td>
<td>No</td>
<td>None</td>
<td>Specify the space that your desired page is located in. Suggestions will display in a dropdown when you start typing. (Note, this property is only used to make searching for pages easier. It is not required.)</td>
</tr>
<tr>
<td>Page</td>
<td>Yes</td>
<td>None</td>
<td>Specify the page that you want to display in your gadget. Suggestions will display in a dropdown when you start typing.</td>
</tr>
<tr>
<td>Show View Link</td>
<td>No</td>
<td>Yes</td>
<td>Select whether to display a link to view the page on your Confluence site. Clicking the link will open the page in Confluence.</td>
</tr>
<tr>
<td>Show Edit Link</td>
<td>No</td>
<td>No</td>
<td>Select whether to display a link to edit the page on your Confluence site. Clicking the link will open the page for editing in Confluence.</td>
</tr>
<tr>
<td>Refresh Interval</td>
<td>No</td>
<td>Never/false</td>
<td>Specify the time interval between each 'refresh' action undertaken by the page gadget. A refresh makes the activity stream gadget reflect any new activity that has been conducted on the Confluence site.</td>
</tr>
</tbody>
</table>
Working Macros

The Confluence page gadget will only render a subset of the macros that are used in Confluence correctly. Refer to the table below for the list of macros that work and do not work with the page gadget and known limitations.

Some of the issues with macros in the page gadget can be worked around, if you are comfortable developing in Confluence. Please see Troubleshooting Macros in the Page Gadget for more information.

Key:
- ✔ Works with the page gadget
- ✗ Partially works with the page gadget
- ❌ Does not work with the page gadget

<table>
<thead>
<tr>
<th>Macro</th>
<th>Works with page gadget?</th>
<th>Limitations</th>
</tr>
</thead>
<tbody>
<tr>
<td>Activity Stream</td>
<td>✗</td>
<td>You cannot have another gadget embedded within the Confluence Page Gadget</td>
</tr>
<tr>
<td>Anchor (within a page)</td>
<td>✔ ✗</td>
<td>Opens in a new page</td>
</tr>
<tr>
<td>Attachments</td>
<td>✔</td>
<td>N/A</td>
</tr>
<tr>
<td>Blog Posts</td>
<td>✔</td>
<td>N/A</td>
</tr>
<tr>
<td>Chart</td>
<td>✔</td>
<td>N/A</td>
</tr>
<tr>
<td>Children Display</td>
<td>✔</td>
<td>N/A</td>
</tr>
<tr>
<td>Content By Label</td>
<td>✔</td>
<td>N/A</td>
</tr>
<tr>
<td>Content By User</td>
<td>✔</td>
<td>N/A</td>
</tr>
<tr>
<td>Excerpt</td>
<td>✔</td>
<td>N/A</td>
</tr>
<tr>
<td>Gallery</td>
<td>✔</td>
<td>N/A</td>
</tr>
<tr>
<td>Include Page</td>
<td>✔</td>
<td>N/A</td>
</tr>
<tr>
<td>Info</td>
<td>✔</td>
<td>N/A</td>
</tr>
<tr>
<td>Labels List</td>
<td>✔</td>
<td>N/A</td>
</tr>
<tr>
<td>Livesearch</td>
<td>✗</td>
<td>N/A</td>
</tr>
<tr>
<td>Note</td>
<td>✔</td>
<td>N/A</td>
</tr>
<tr>
<td>Metadata</td>
<td>✔</td>
<td>N/A</td>
</tr>
<tr>
<td>Metadata Summary</td>
<td>✔</td>
<td>N/A</td>
</tr>
<tr>
<td>Pagetree Search</td>
<td>✗</td>
<td>N/A</td>
</tr>
<tr>
<td>Component</td>
<td>Status</td>
<td>Description</td>
</tr>
<tr>
<td>------------------</td>
<td>--------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Pagetree</td>
<td>✔</td>
<td>N/A</td>
</tr>
<tr>
<td>Panel</td>
<td>✔</td>
<td>N/A</td>
</tr>
<tr>
<td>Quick Nav</td>
<td>✗</td>
<td>You cannot have another gadget embedded within the Confluence Page Gadget</td>
</tr>
<tr>
<td>Recently Updated</td>
<td>✔</td>
<td>N/A</td>
</tr>
<tr>
<td>RSS Feed</td>
<td>✔</td>
<td>N/A</td>
</tr>
<tr>
<td>Section &amp; Column</td>
<td>✔</td>
<td>N/A</td>
</tr>
<tr>
<td>Spaces List</td>
<td>✔</td>
<td>N/A</td>
</tr>
<tr>
<td>Table of Contents</td>
<td>✔</td>
<td>Works, however links will be opened in a new browser window when clicked.</td>
</tr>
<tr>
<td>Team Calendars</td>
<td>✗</td>
<td>See here for the Improvement Request:</td>
</tr>
<tr>
<td></td>
<td></td>
<td><img src="#" alt="TEAMCAL-862" /> - Make Team Calendars display in a Confluence Page Gadget, for use on a JIRA Dashboard [REOPENED]</td>
</tr>
<tr>
<td>View File (PDF or PPT)</td>
<td>✔</td>
<td>Works, but you may need to refresh the gadget the first time (see CONF-19932).</td>
</tr>
<tr>
<td>Widget Connector</td>
<td>✔</td>
<td>Only works for some content:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- <strong>Works</strong>: blip.tv, Episodic, Flickr, Google Calendar, presentations on Google Docs, MySpace Video, Scribd, Skitch.com, SlideRocket, SlideShare, Viddler, Vimeo, YouTube, Dailymotion, Metacafe, FriendFeed, Yahoo Video, Wufoo HTML Form Builder</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- <strong>Does not work</strong>: FriendFeed, Google Gadgets, Google Video (consumer service discontinued), Twitter, Widgetbox, DabbleDB, BackType</td>
</tr>
</tbody>
</table>

**Confluence Quicknav Gadget**

The Confluence QuickNav gadget provides the Quick Navigation Aid functionality for searching the Confluence site. For more information on how to use this feature, refer to the Quick Navigation Aid section of Searching Confluence.

ℹ️ For instructions on how to use Confluence gadgets in your applications, please see Confluence Gadgets.

Screenshot: Using the QuickNav Gadget
Adding JIRA Gadgets to a Confluence Page

The Confluence Gadget macro is a specific type of macro which is used to display gadgets, including JIRA gadgets, in a Confluence page. Once you have configured external gadgets in the Confluence Administration Console, they will appear in the Macro Browser.

Before you can start adding JIRA Gadgets:

- Your JIRA administrator will need to configure JIRA to trust Confluence via Application Links. (Not required if your JIRA site allows anonymous access)
- Your Confluence administrator will need to add the JIRA gadget URL to the list of authorised external gadgets in Confluence.

To add a JIRA Gadget to a Confluence page:

- Choose Insert > Other Macros.
- Navigate to the gadget you wish to add to the page and choose Insert.

Refer to the Gadget Macro page for more information on adding the macro to your page.

Developing Technical Documentation on Confluence Wiki
Welcome! This is a guide to using Confluence wiki for technical documentation. You will find this guide useful if you want to write a technical manual such as a user's guide, administrator's guide, installation guide, and so on.

Creating your Technical Documentation Space

This guide is for people who want to develop and publish technical documentation on Confluence wiki. You will find it useful if you want to write a technical manual such as a user's guide, administrator's guide, installation guide, and so on. This page is a quick-start guide to creating a wiki space for technical documentation.

Quick guide to creating a technical documentation space:

- Add a space and select the Documentation theme.
- Set the space permissions.
- Change the title and content of the space home page.
- Customise the Documentation theme.
- Create an inclusions library to manage your re-usable content.
- Create the table of contents for your manual or manuals, by adding top-level pages for all the usual sections (user's guide, administrator's guide, and so on).
- Customise your PDF layout and stylesheet, if required.
- Hint: Now that you have a good skeleton for a documentation space, save the space as a template space.

The rest of this page gives more details of the above procedure.

On this page:

- Step 1. Add your space
- Step 2. Set the space permissions
- Step 3. Customise the title and content of the space home page
- Step 4. Customise the Documentation theme
- Step 5. Create an inclusions library
- Step 6. Create the table of contents
- Step 7. (Optional) Customise the PDF layout and stylesheet
- Step 8. Save your new space as a template

Step 1. Add your space

Below is a quick guide to adding a space. See Create a Space for a full description.

1. Go to the Confluence dashboard and choose Create Space > Blank Space.
   Hint: If you cannot see Create Space, this means that you do not have permission to add spaces. Please contact your Confluence administrator.
2. Choose Next then enter a space name and a short, unique space key.
3. Leave the permission settings as default, or choose to allow only yourself to view or contribute content to this space. You can change these settings later and with more flexible options.
4. Choose **Create**.
5. Your new space appears. Choose **Space Tools** in the sidebar.
6. Choose **Look and Feel > Themes** and select the **Documentation** theme.
7. Choose OK.

The home page of your new space will appear. Because you created the space, you are the space administrator. Now you can do some basic configuration, as described in the sections below. From this point on, instructions will refer to navigating in the Documentation theme, which is slightly different to the default theme.

**Step 2. Set the space permissions**

Define the space permissions to determine who can do what in your new space.

1. Choose **Browse > Space Admin** from the header
   
   **Note:** The **Space Admin** option appears only if you have **space admin permissions**, or if you’re part of the ‘confluence-administrators’ group.

2. Choose **Permissions**.
3. Choose **Edit Permissions**.
4. Set the permissions to suit your needs then choose **Save All**.
   - You can add **groups** and/or individual **users** to the list, then select the permissions for each group or user.
   - You can also set the permissions for **anonymous** users – these are people who have not logged in to the wiki. Anonymous access is available only if enabled for the entire Confluence site.
   - Note that you can change these permissions at any time. You may want to restrict the permissions to specific groups now, and later open the space to more people.

**A bit more about permissions**

Confluence has a robust and granular permissions scheme that you can use to determine who can view, comment on and even update the documentation. There are three levels of permissions in Confluence:

- Global permissions apply across the entire site.
- Space permissions apply to a space.
- Page restrictions allow you to restrict the editing and/or viewing of a specific page. Below we discuss a way of using these in the draft, review and publishing workflow.

**Space permissions** in Confluence are simple yet granular enough to be useful for technical documentation. You can:

- Use the permission levels to control who can create pages in the space, delete pages, create comments, delete comments, administer the space, and so on.
- Grant a permission level to one or more users, and/or to one or more groups, and/or to anonymous users.

**Terminology:**

- ‘**Anonymous**’ means people who have not logged in to the wiki.
- The ‘**confluence-users**’ group is the default group into which all new users are assigned (this group may also be called ‘users’). Everyone who can log in to Confluence is a member of this group.

For example, you might allow your team full edit and administration rights while others can only add comments. Or you might grant the general public access to your documentation, while only staff members can update it.
### Groups

These are the permissions currently assigned to groups for this space.

<table>
<thead>
<tr>
<th></th>
<th>All</th>
<th>Pages</th>
<th>Blog</th>
<th>Comments</th>
<th>Ati</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>View</td>
<td>Add</td>
<td>Restrict</td>
<td>Remove</td>
<td>Add</td>
</tr>
<tr>
<td>confluence-users</td>
<td>✔️</td>
<td>✗</td>
<td>✗</td>
<td>✗</td>
<td>✗</td>
</tr>
<tr>
<td>my-team</td>
<td>✔️</td>
<td>✔️</td>
<td>✔️</td>
<td>✔️</td>
<td>✔️</td>
</tr>
</tbody>
</table>

[Edit Permissions]

### Individual Users

These are the permissions currently assigned to individual users for this space.

<table>
<thead>
<tr>
<th></th>
<th>All</th>
<th>Pages</th>
<th>Blog</th>
<th>Comments</th>
<th>Ati</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>View</td>
<td>Add</td>
<td>Restrict</td>
<td>Remove</td>
<td>Add</td>
</tr>
<tr>
<td>Rach Admin (admin)</td>
<td>✔️</td>
<td>✔️</td>
<td>✔️</td>
<td>✔️</td>
<td>✔️</td>
</tr>
</tbody>
</table>

[Edit Permissions]

### Anonymous Access

When a user is using Confluence while not logged in, they are using it anonymously. For example: Enabling anonymous ‘commenting’ permission, allows non-logged-in users to make comments.

<table>
<thead>
<tr>
<th></th>
<th>All</th>
<th>Pages</th>
<th>Blog</th>
<th>Comments</th>
<th>Ati</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>View</td>
<td>Add</td>
<td>Restrict</td>
<td>Remove</td>
<td>Add</td>
</tr>
<tr>
<td>Anonymous</td>
<td>✗</td>
<td>✗</td>
<td>✗</td>
<td>✗</td>
<td>✗</td>
</tr>
</tbody>
</table>
Step 3. Customise the title and content of the space home page

When you created your space, Confluence created a home page with default content and a default title. You will want to change the title and content.

1. Go to your space home page.
2. By default, the page title is 'X Home', where 'X' is the name you gave the space.
3. Choose Edit.
4. The page opens in the editor. Change the title to suit your needs.

5. Update the content to suit your needs.
   
   Hint: If you do not know what to add yet, just add a short description. You can refine the content of the page later. Take a look at an example of a home page.
6. Choose Save.

Step 4. Customise the Documentation theme

When you added the space you chose the Documentation theme, which provides a left-hand navigation bar and a good look and feel for technical documentation. If necessary, you can configure the Documentation theme to add your own page header and footer or to customise the default left-hand navigation bar. These customisations affect the online look and feel of your documentation. See Configuring the Documentation Theme for the full description.

1. Choose Browse > Space Admin. (If you have not yet applied the Documentation theme choose Space Tools > Look and Feel > Themes.)
2. Choose Themes in the left menu.
3. If the space is not yet using the Documentation theme, apply the theme now.
4. Choose Configure theme.
5. The 'Documentation Theme Configuration' screen appears. Customise the left-hand navigation bar, header and footer to suit your needs. Details are in the documentation. Here are some hints:

- The Page Tree check box determines whether your space will display the default search box and table of contents (page tree) in the left-hand panel.
- The Limit search results to the current space check box determines whether Confluence will search only the current space or the whole Confluence site. This setting affects the default search. Viewers can override it each time they do a search.
- Enter text, images, macros and other wiki markup into any or all of the three text boxes for the left-hand navigation bar, header and footer. You can use the Include macro and the Excerpt Include macro to include re-usable content.
- Any content you add to the navigation panel will appear above the default page tree.
- If you like, you can remove the default page tree (by unticking the box) and add your own, customised version of the Pagetree macro instead.

6. Choose Save.

**Example of a customised footer**

Take a look at the footer of a page in the Crowd documentation space.

To produce the above footer, we have the following content in the footer panel in the Documentation theme configuration screen:
Step 5. Create an inclusions library

In Confluence, you can dynamically include content from one page into another page. You can include a whole page into another one, using the Include macro. You can also define an ‘excerpt’ on a page, and then include that excerpted text into another page using the Excerpt Include macro.

To organise your re-usable content, we recommend that you create a set of pages called an ‘inclusions library’.

1. Choose Create and create a new page in your space.
2. Enter a suitable title. We use '_InclusionsLibrary'. The unusual format of the title helps to let people know this page is special.
3. Enter some content and save the page. We enter text explaining the purpose of the inclusions library and how to re-use the content. You can copy our text by clicking through to one of the example pages listed below.
4. Choose Browse > Pages and drag your new page above the space homepage.
5. Go to your new inclusions page and choose Create to add child pages containing your re-usable content. See the examples of our own inclusions libraries listed in the examples below.

Some notes about inclusions libraries:

- The inclusions library is not a specific feature of Confluence. The pages in the inclusions library are just like any other Confluence page.
- The pages are located at the root of the wiki space, not under the home page. This means that they will not appear in the table of contents on the left and they will not be picked up by the search in the left-hand navigation bar either.
- The pages will be picked up by other searches, because they are just normal wiki pages.
- We have decided to start the page name with an underscore. For example, '_My Page Name'. This
indicates that the page is slightly unusual, and will help prevent people from changing the page name or updating the content without realising that the content is re-used in various pages.

**Examples of inclusions libraries**

Here are some examples in our documentation:

- Crowd inclusions library
- Confluence inclusions library

Step 6. Create the table of contents

Create the table of contents for your documentation, by adding the top-level pages for all the usual sections:

- User's guide
- Administrator's guide
- Installation guide
- Configuration guide
- Release notes
- FAQ
- Whatever else you need

Follow these steps to create the table of contents:

1. Go to your space home page.
2. Choose **Create** to add a page as a child of the homepage.
3. Type the page title, 'User's Guide'.
4. Type the content of the page.
   
   **Hint:** If you do not know what to add yet, just add a short description then refine the content of the page later. If you like, you can add the **Children macro**. That will act as a table of contents on the page once you have added child pages.
5. Choose **Save**.

Now do the same for all the sections of your technical document.

Step 7. (Optional) Customise the PDF layout and stylesheet

If you are planning to provide PDF versions of your documentation, you may want to customise the PDF layout and styles for your space. You can skip this step for now and do it later, if you prefer. The instructions are in a separate section of this guide, dedicated to PDF. See **Providing PDF Versions of your Technical Documentation**.

Step 8. Save your new space as a template

This is a useful suggestion. Once you have set up your first documentation space and are more-or-less happy with it, use the **Copy Space add-on** (see notes below) to copy the space while it still has very little content. From this point on, you can copy it each time you want to create a new documentation space.

1. Choose **Browse > Space Admin**
2. Choose **Copy Space** in the left menu
   
   **Hint:** If you cannot see the 'Copy Space' option, this means that the add-on is not installed on your Confluence site. Refer to the documentation on **installing add-ons**. (Not applicable to Confluence Cloud.)
3. The ‘Copy Space’ screen will appear. Enter the details as prompted, to copy your space to another new space.
4. Choose **Save**.

You now have a template space. From this point on, you can use the Copy Space add-on to copy the template space each time you want to create a new documentation space.

**Notes:**

- The Copy Space add-on is not covered by Atlassian support. However, the Atlassian technical writers use it for all our documentation. If you like, you can vote for an comment on the request for Atlassian support to cover this add-on: CONF-14198.
- Your site administrator will need to install the Copy Space add-on into Confluence. Refer to the documentation on installing add-ons. Not applicable to Confluence Cloud.

**Next Steps**

You now have the basic structure and configuration for your technical documentation space. You have also created a handy template to use next time you need a space. What next? Take a look at Using Templates in Technical Documentation.

**Using Templates in Technical Documentation**

This page is part of the guide to developing technical documentation on Confluence Wiki. We have already shown you how to create your technical documentation space. Now we offer an introduction to the templates that Confluence provides.

**Quick guide to templates in Confluence:**
A template is a page with predefined content that can be used as a prototype when creating other pages. Templates are available across the Confluence site (global templates) or per space (space templates). Both 'global templates' and 'space templates', as described on this page, define the content of a page. They do not define the content of an entire space.

To create a template for an entire space, see our guide to creating your documentation space. Confluence blueprints provide predefined templates and added functionality. You can import predefined templates from the Atlassian Marketplace.

**On this page:**
- Deciding where to put your templates
- Creating a global template
- Creating a space template
- Importing templates
- Using templates provided by blueprints
- Using a template to create a page

Deciding where to put your templates

Decide whether your template is useful across more than one space.

- If yes, create a global template. You will need Confluence administrator permissions.
- If no, create a space template.
  - You will need space administrator permissions for the relevant space(s).
  - You may have already saved your documentation space as a template, as described in our guide to creating your documentation space. In that case, it may be useful to save your template page in your template space. When you later copy the space, the template pages will be copied too.

Creating a global template

1. Choose the cog icon, then choose General Configuration under Confluence Administration.
2. Choose Global Templates and Blueprints in the left-hand panel.
3. Choose Add New Global Template.

See Administering Site Templates for more information.

Creating a space template

1. Choose Browse > Space Admin from the header.
   - **Note:** The Space Admin option appears only if you have space admin permissions, or if you're part of the 'confluence-administrators' group.
2. Choose Templates from the space administration options.
3. Choose Create new template.

See Creating a Template for more information.

Importing templates

If you have System Administrator permissions, you can download pre-defined templates from the Atlassian Marketplace in the form of a template bundle. Each template bundle contains one or more templates, created by Atlassian or third parties. See Importing Templates.

Using templates provided by blueprints

A blueprint is a page template with added functionality to help you create, manage and organise content in Confluence.

Confluence ships with some predefined blueprints. You can also download additional blueprints from the Atlassian Marketplace. You can customise the blueprint templates to suit your individual needs and even develop your own blueprints.

See Working with Blueprints.
Using a template to create a page

When people create a page on your Confluence site, they can choose to base their new page on a template.

1. Go to the page that will be the parent of your new page, and choose Create.
2. You will see a list of all available templates. Select a template then choose Next.

Next Steps

You now have a good idea of how Confluence templates work. What next? Take a look at Re-using Content in Technical Documentation.

Re-using Content in Technical Documentation

This page is part of the guide to developing technical documentation on Confluence Wiki. In the page about creating your technical documentation space, we showed you how to set up an 'inclusions library' to contain content that you can re-use on more than one page. Now we offer further guidelines on re-using content in your documentation space.

Your documentation may be about using a software application, or it may be a technical manual for your product range. On this page, we use the term 'widget' to describe the things that you are documenting, such as the screen, form, document, product or object.

Quick guide to re-using content:

- Create an 'inclusions library' to manage your re-usable content. See our guide to creating your technical documentation space.
- Use the excerpt macro to define a re-usable section ('excerpt') on a page, or just decide to re-use the entire content of the page.
- Use the excerpt-include macro to include the excerpt from one page onto another page.
- Use the include macro to include the entire content of a page onto another page.
- Consider installing the Multi Excerpt add-on if you need to define multiple excerpts per page.

The rest of this page gives an overview and more details of the above procedures.

On this page:

- Reasons for re-using content
- Defining an inclusions library
- Working with excerpts and inclusions
  - Using the Include Page macro
  - Using the Excerpt Include macro
  - Using the Multi Excerpt add-on
- An example of content re-use: a glossary
  - Creating a one-page glossary
  - Creating a glossary with child pages
  - Referring to glossary terms
- Further reading

Reasons for re-using content

A golden rule for technical documentation is to write the content only once but allow that content to be used in many places and in many forms.

For example, you may have the following types of content:

- A technical manual that describes each widget in detail.
- Tips and tricks on how to get the most out of the widget.
- A step-by-step user guide for first-time users on how to use the most common widgets.
- A training manual with exercises or videos that people can follow in their own time.
- A one-page cheat sheet for users to stick up on their workstation.
- Text for a sales brochure that is sent out to a print house for production.

Each of these types of content will share common information, such as a glossary entry, a technical or marketing description of the widget, or a step-by-step guide on how to use the widget.

Some initial planning of your technical documentation will allow you to re-use any or all of the content you write.
so there is only ever one place to update the content, and those changes flow through to all of your other documentation.

Defining an inclusions library

We recommend that you create an ‘inclusions library’ to manage your re-usable content. If you have not already done this, see our guide to creating your technical documentation space.

Working with excerpts and inclusions

Excerpts and inclusions (sometimes called ‘includes’) are very useful for re-using content:

- Use the Excerpt macro \(\texttt{excerpt}\) to define a re-usable section (‘excerpt’) on a page.
- Use the Excerpt Include macro \(\texttt{excerpt}\text{-include}\) to include the excerpt on another page.
- Use the Include Page macro \(\texttt{include}\) to include the entire content of a page onto another page.

A simple use case for an inclusion is a note or warning that is used in many places in your documentation. Here is an example:

Example note -- "Draft in progress"
This document is still in draft status. Please treat the content with caution.

Tip: Keep your re-usable pages short and sweet. Do not worry if you find that you need hundreds of pages to hold your inclusions. It helps to keep things separate and organised.

Using the Include Page macro

In this example, we use the Include Page macro to create a note that you can re-use on your documentation pages. The Include Page macro will include the entire content of one page into another page.

1. Create a page in your inclusions library called _Draft Note.
2. Add the content of the page. In this example, we use the Note macro with some text in the title and body:

   \{note\title=Draft in progress\}This document is still in draft status. Please treat the content with caution.\{note\}

3. Use the Include Page macro to include that note in any page in your documentation. For example:

   \{include:_Draft Note|nopanel=true\}

See the documentation on the Include Page macro for more details.

Using the Excerpt Include macro

An excerpt is a section of a page that you can include into another page.

1. Use the excerpt macro to define any content in your page that you want to be able to use elsewhere. This content can be as short as a word or as long as the entire page. For example, let's assume we have a page called 'My Short Poem':

   I really love this poem:
   \{excerpt\}
   Mary had a little lamb
   Its fleece was white as snow
   \{excerpt\}
   And I'm going to use it all over the place.
2. Use the Excerpt Include macro to include the excerpt into another page. For example:

```{excerpt-include:My Short Poem|nopanel=true}
```

You can only define one excerpt on a page. See the documentation on the Excerpt Include macro for more details.

To have multiple excerpts on a page, see the 'Multi Excerpt add-on' below.

**Using the Multi Excerpt add-on**

The Multi Excerpt add-on provides additional macros that enable you to have multiple excerpts on a page. A good example of where you would find this useful is in the glossary page discussed below. If you want to include a single glossary entry or a subset of the glossary entries in another page, then the named excerpts provided by the Multi Excerpt add-on are very useful.

**Notes:**

- The Multi Excerpt add-on is a commercial add-on and is not free.
- Your Confluence system administrator will need to download and install the add-on into your Confluence site before you can use the macros described below. Refer to the documentation on installing add-ons.
- Before installing an add-on (also called a plugin) into your Confluence site, please check the add-on's information page to see whether it is supported by Atlassian, by another vendor, or not at all. See our guidelines on add-on support. Please refer to the Multi Excerpt add-on page for support details.

To have multiple excerpts on a page:

1. Use the following code on the base page containing the content you want to use elsewhere:

```{multi-excerpt:name=ExcerptName1}
Excerpt text 1
{multi-excerpt}
Any other text
{multi-excerpt:name=ExcerptName2}
Excerpt text 2
{multi-excerpt}
```

2. Use the following code on the page where you want to include the named excerpt:

```{multi-excerpt-include:pageTitle=PageName|name=ExcerptName1|nopanel=true}
```

3. You can also include excerpts from other spaces using the following syntax:

```{multi-excerpt-include:spaceKey:pageName|name=excerptName|nopanel=true}
```

See the Multi Excerpt add-on page for more details.

**An example of content re-use: a glossary**

A glossary is something that most technical documentation will require. There are a few ways to set up glossaries in Confluence. These are the most popular:

- All glossary entries on one page.
- Each glossary entry on separate child pages with a main page showing excerpts of the glossary.

Once you have defined the glossary entry, you can refer to it from the main pages of your technical documentation.

**Creating a one-page glossary**
This style of glossary is useful if the glossary entries tend to be short and there are not too many of them. The code blocks below use wiki markup. To insert wiki markup onto your page, open the editor and chose Insert > Wiki Markup.

1. Create a page named **Glossary**.
2. Add an alphabetical index at the top of the page and a heading for each letter of the alphabet:

   ```markdown
   {anchor:A}
h2. A
   {anchor:B}
h2. B
   {anchor:C}
h2. C ...
   ```

3. Enter each glossary entry under the relevant alphabetical heading. Each glossary entry (term) should include:
   - An anchor tag, so that you can link to it from other pages.
   - The term itself.
   - A definition of the term.
   - A link to the page in your technical documentation that explains the term in greater detail, where relevant.

   ```markdown
   {anchor:MyGlossaryTerm}
h4. MyGlossaryTerm
   This is the definition of MyGlossaryTerm. See [Page Name] for more information.
   ```

4. Optionally, include a horizontal line between the terms. This depends on how long each entry is. If your glossary tends to have short entries, it may look too cluttered with horizontal lines.

   ```markdown
   ---
   ```

---

**Creating a glossary with child pages**

This style of glossary is useful if the glossary entries tend to be quite long or have additional information over and above the definition of the term. The code blocks below use wiki markup. To insert wiki markup onto your page, open the editor and chose Insert > Wiki Markup.

1. Create a page named **Glossary**.
2. Create a child page for each glossary entry (term). Each child page should contain:
   - The term as the title of the page.
   - The definition of the term in the body of the page.
   - Excerpt tags (excerpt) tags surrounding the definition.
   - Any additional information after the excerpt tags.

   ```markdown
   (excerpt)
   This is the definition of MyGlossaryTerm
   (excerpt)
   More information to describe MyGlossaryTerm
   ```

3. On the 'Glossary' page, use the children macro to show the excerpts from each child page in a list, with the page name displayed in 'h4' style.
See the glossary in the Crowd documentation for an example of this style of glossary.

**Referring to glossary terms**

In the main pages of your technical documentation, create a link to the glossary page for each glossary term.

_[MyGlossary Term|Glossary#MyGlossaryTerm]_

Note that this is a standard page link with an anchor. We have formatted the link as italics, because it helps to have the glossary links looking different to other page links. Readers can just skip over the glossary link if they are already familiar with the term.

**Further reading**

A blog post about content re-use: Technical Writing in a Wiki - Content Re-use and Structure (November 2010).

**Next Steps**

You now have a good idea of how to re-use content in a Confluence documentation space. What next? Take a look at Managing the Life Cycle of your Technical Documentation.

**Managing the Life Cycle of your Technical Documentation**

This page is part of the guide to developing technical documentation on Confluence Wiki. We have already shown you how to create your technical documentation space, including how to set permissions for your space. Now we offer a quick-start guide to managing the life cycle of your technical documentation in Confluence. The life cycle includes drafting, reviewing and publishing a document, as well as managing documentation that is release-specific.

**Quick guide to managing the technical documentation life cycle:**

- Create draft pages with restricted permissions, to hide them until they are ready for publication.
- Set the permissions to allow reviewers to comment on and/or update the pages.
- When ready, publish the page by removing the permission restrictions.
- Monitor updates to your draft and published pages by watching your space and/or subscribing to RSS feeds.
- Use spaces as a mechanism for matching your documentation version to product releases: one space per major release number.
- Consider installing add-ons for extended workflow and publication management.

The rest of this page gives more details of the above procedures.
Using the built-in Confluence functionality to manage workflow and release cycle

This section describes how to use the built-in Confluence functionality to manage your workflow (draft, review, publish) and to align your documentation version control to the product release cycle.

In this scenario we also assume that you want a live space that always has the same space key and always contains the latest version of your documentation. This scenario suits the requirements of an organisation that wants their technical documentation to be ‘live’. Various groups of people can refine the content as and when required. People can also subscribe to the space, knowing that they will always get the latest version of the documentation and comments.

This is the way we manage our documentation at Atlassian. The content of the wiki is dynamic, continuously updated, commented on, subscribed to and watched by thousands of people all over the world.

**Drafting, reviewing and publishing a page**

The workflow is as follows.

1. Create a page with restricted permissions. For example, you might restrict viewing to a group of people such as your team. On a public wiki, you might restrict viewing to staff members, so that the general public cannot see the page.
2. Write the page content.
3. Ask other people to review the page. They can add comments to the page or simply edit the page content directly.
4. Publish the page when ready, by doing the following:
   - Delete the comments on the page.
   - Remove the permission restrictions on the page. The page has now been published. The space permissions and site permissions now determine who can see and/or update the page.

The screenshot below shows a page under review. Notice the lock icon at top left, indicating that restricted permissions apply to this page.
Keeping track of documentation updates

On a wiki, it is quite usual for a number of different people to update a single page. Technical writers need to know what happens to our documents, both during review and after publication.

Viewing the history of a page

Confluence creates a new version of the page every time someone edits the page. The page history shows all the versions, with date, author, and any comments made on the update.

Go to the page and choose *** > Page History
On the page history view, you can:

- View the content of a specific version of the page.
- Revert to (restore) a specific version.
- Select any two versions and ask for a comparison, to see what has changed between those two versions.

See Page History and Page Comparison Views for detailed information.

It is all very well to go to a specific page and see what has happened to it, but how do you know when to go and look at the page? You need a notification of any changes made to your documentation space.

In Confluence, you can monitor updates to your documentation via email notifications and via RSS feeds.

**Receiving email notification of updates**

You can ‘watch’ a page or an entire space. Whenever anyone updates the page or space, you will receive an email notification.

1. Log in to Confluence, if you have not already done so.
2. Go to the page or blog post.
3. Choose Watch and select the relevant check box.

See Subscribing to Email Notifications of Updates to Confluence Content for details of the various notifications Confluence will send, and how to configure your notification settings.

**Monitoring updates via RSS feeds**

RSS feeds provide another way to keep track of updates. The simplest way to build an RSS feed is to use Confluence’s feed builder. This will give you a URL that you can ping to get the latest updates.

Below we describe how to set up a useful feed for your technical documentation space. Remember that you can adjust the settings to suit your own needs.

1. Choose Help > Feed Builder. The RSS feed builder form appears.
2. Check the boxes to select all the content types. (Even if you are not expecting comments, blog posts or mail in your documentation space, it does no harm to receive notifications if they do arrive.)
   - Pages and the comments and attachments on pages.
   - Blog posts and their comments and attachments.
   - Mail.
3. Select your documentation space from the list. Press Ctrl and click to select multiple spaces.
4. Choose Create RSS Feed.
5. This will take you to a new screen. Drag or copy the link into your RSS reader. The feed URL is linked to the words Drag or copy this link to your RSS reader.
Now that you have set up your RSS feed, you need to decide how to read it. There are various options to choose from. For example:

- Use an RSS reader, such as the Sage add-on for Firefox.
- Use an email client, such as Thunderbird.

See Subscribing to RSS Feeds within Confluence for details.

Release management

Let’s assume that your product goes through a regular release cycle, and that you need to retain separate documentation for each major version of the product.

At Atlassian, we use spaces as our version-control mechanism.

- **Archive spaces.** At each release, we create a new archive space to house the previous version of the documentation.
- **The live space.** The documentation for the latest version of the product resides in the live space. The live space always retains the same space key and is always available for viewing and updating.

Space keys

The live space has just the product name as its space key. For example, for the Bamboo product the space key is ‘BAMBOO’. (See the Bamboo documentation space.)

For the archived versions, we use a combination of the product name plus version number as the space key. For example, we use ‘BAMBOO040’ for the Bamboo 4.0 documentation, ‘BAMBOO041’ for the Bamboo 4.1 documentation, and so on.

The release management process

Here is an overview of the process we follow at Atlassian.

1. **Leading up to release date.** Work with hidden draft pages in the live space. A ‘hidden draft’ is simply a page that has restricted permissions applied:
   - For each new feature, create a new page with restricted permissions.
   - If you need to update existing pages, create a hidden copy of the existing page and apply the updates to the copy.
   - Follow the usual draft and review procedure for each page.
2. **A few days before release date.** Use the Copy Space add-on to copy the live space to a new space. This creates a snapshot of the current documentation, and will act as an archive for the current release which is soon to become the previous release. (We described the use of the Copy Space add-on in the earlier section of this guide: Creating your Technical Documentation Space.)
3. **On release date.** Publish the updated documentation for the new version of the product:
   - Rebrand the live documentation space to reflect the new release number. In other words, change the space name and any other descriptions that include the product release number.
   - Unhide all the new pages, by removing the permission restrictions on each hidden page.
   - Copy the content of the updated pages to the proper pages, then delete the copies.
   - Export the newly updated space to PDF, HTML and XML, for those customers who prefer offline versions of the documentation.

Note that the above process is applicable to major releases of the product. For minor bug-fix releases, we simply update the documentation in the live space. We do not create archive spaces for every minor release.

The example below shows an extract from the dashboard of our documentation wiki, listing the spaces for different versions of the Bamboo documentation. (Bamboo is one of our products.) Each space holds the documentation for a specific major release of Bamboo.

Screenshot: Archive Bamboo spaces and Bamboo Latest for the current version of the documentation.
Other scenarios using the built-in Confluence functionality

It is easy to design other ways of managing your documentation spaces using the built-in Confluence functionality. For example, the simplest scenario is to publish a new space for every new release of your product, using the same Copy Space add-on as described above.

Using add-ons for extended workflow, publication and version management

For advanced workflow features, consider installing the Ad Hoc Workflows add-on onto your Confluence site.

For advanced publication and concurrent version management consider using the Scroll Versions add-on. With Scroll Versions, you can set up and manage concurrent versions of your documentation in a single space. You can manage multiple versions of software, different product variants, and even multiple languages of documentation. Plan your page updates for a specified version and then publish them all at once.

See the documentation of Scroll Versions for more information.

Similarly, consider using the Content Publishing add-on to publish content from a master space to a published space. In this scenario, you will create a master space that contains your drafts in progress and new releases. The master space is visible only to the authors and reviewers. You will periodically publish the master space to a published space. This suits the requirements of an organisation that needs a 'published' or 'official' set of documentation, published only when a new version of the product is released. There is no requirement for continual updating of the documentation.

**Automatic publishing.** The Content Publishing add-on can work together with the Ad Hoc Workflows add-on to publish pages automatically when the page reaches a specified state in the workflow.

Notes
• **Installing add-ons.** If you decide to use additional add-ons, your system administrator will need to install them into your Confluence site. Refer to the documentation on Installing add-ons.

• **Add-on support.**

Before installing an add-on (also called a plugin) into your Confluence site, please check the add-on's information page to see whether it is supported by Atlassian, by another vendor, or not at all. See our guidelines on add-on support.

Next steps

Now you know about managing your workflow and documentation release process on Confluence. What next? Take a look at Providing PDF Versions of your Technical Documentation.

Providing PDF Versions of your Technical Documentation

This page is part of the guide on Developing Technical Documentation on Confluence Wiki.

Confluence is a platform for publishing online documentation. It also provides functionality for producing PDF versions of your documentation, allowing you to print the documentation, or to provide a copy to customers who are unable to access the online version. This guide describes how to export your technical documentation to PDF using Confluence's built-in PDF export. We also introduce a third-party add-on that provides additional PDF layout and style functionality.

Quick guide to PDF exports:

- Customise the PDF layout (title page, header and footer) and style, for use each time you export your documentation.
- Export a single page to PDF.
- Export a selection of pages or an entire space to PDF.
- Consider installing a third-party add-on for advanced PDF export functionality.

The rest of this page gives more details of the above procedures.

On this page:

- Customising the PDF layout and style
  - Editing the PDF layout
  - Setting a global PDF layout
  - Setting the PDF layout at space level
  - Editing the PDF stylesheet
  - Setting a global PDF Stylesheet
  - Setting a space PDF stylesheet
  - Examples of PDF customisation
- Exporting to PDF
  - Exporting a single page to PDF
  - Exporting a selection of pages or a space to PDF
- Using the Scroll PDF Exporter add-on (Not applicable to Confluence Cloud.)
- Notes

Customising the PDF layout and style

If you plan to create PDF versions of your documentation, you may want to customise the PDF layout and styles for your space. These customisations will be applied every time you export documentation to PDF.

Under PDF layout you can add HTML to customise the PDF title page, and the page headers and footers. Under PDF stylesheet, you can adjust the appearance of the PDF pages.

**Editing the PDF layout**

**Setting a global PDF layout**

1. Choose the cog icon , then choose General Configuration under Confluence Administration
2. Choose PDF Layout. You can enter HTML and CSS that will be rendered on the PDF title page, as well as page headers and footers.
Setting the PDF layout at space level

1. Go to the space and choose Space tools > Look and Feel from the bottom of the sidebar. You'll need Space Admin permissions to do this.
2. Choose PDF Layout.
3. Choose Edit.

If your space uses the Documentation theme:

1. Choose Browse > Space Admin from the header.
   Note: The Space Admin option appears only if you have space admin permissions, or if you're part of the ‘confluence-administrators’ group.
2. Choose PDF Layout in space administration options.
3. Choose Edit.

You can customise the HTML that is generated for the following areas when the space is exported to PDF:

- PDF Space Export Title Page – title page.
- PDF Space Export Header – page headers.
- PDF Space Export Footer – page footers.

Enter your customisations into each text box as required. The PDF layout section accepts HTML code. You can include inline CSS in the HTML too.

Editing the PDF stylesheet

Setting a global PDF Stylesheet

1. Choose the cog icon, then choose General Configuration under Confluence Administration.
2. Choose Look and Feel > PDF Stylesheet. The following screen allows you to enter and save CSS code that will render content on each page.

Setting a space PDF stylesheet

1. Go to the space and choose Space tools > Look and Feel from the bottom of the sidebar. You'll need Space Admin permissions to do this.
2. Choose PDF Stylesheet.
3. Choose Edit.
4. Enter your customisations.

If your space uses the Documentation theme:

1. Choose Browse > Space Admin from the header.
   Note: The Space Admin option appears only if you have space admin permissions, or if you're part of the ‘confluence-administrators’ group.
2. Choose PDF Stylesheet in the space administration options.
3. Choose Edit.
4. Enter your customisations.

The PDF Export Stylesheet field accepts Cascading Style Sheets (CSS) rules. The 'PDF Export Stylesheet' page shows the current (e.g. customised) contents of your PDF stylesheet.

Examples of PDF customisation

Below are typical customisations you may want to make for your technical documentation. For more examples, see Customising Exports to PDF.

Adding a title page

You can create a title or cover page to your PDF document using HTML. Use the PDF Space Export Title Page section of the PDF layout to do this.

Adding a New Title Page
The following example uses HTML with an inline CSS rule to generate a title page.

```html
<div class="fsTitlePage"
style="margin-left:auto;margin-top:75mm;margin-right:auto;page-break-after:always">
<img src="/download/attachments/12345/titlepage.png"/>
</div>
```

**Including Content Above Table of Contents in Default Title Page**

The following example includes content above the automatically-generated table of contents that appears on the default title page, so that your title page includes your own content plus the table of contents.

```html
<div class="fsTitlePage"
style="margin-left:auto;margin-top:75mm;margin-right:auto;">
<img src="/download/attachments/12345/titlepage.png"/>
</div>
```

**Adding an Image to your Title Page**

In the examples above, the title page includes an image called 'titlepage.png', centred in the middle of the page. The image is attached to a Confluence page and is referenced via its relative URL (that is, we use only the last part of the URL, excluding the Confluence site's base URL).

Follow these instructions to include an image on your title page:

1. Attach the image to a Confluence page.
2. View the list of attachments on that page.
3. Right-click the image and copy its location.
4. Paste the link into the appropriate `src=""` attribute within your PDF stylesheet, as shown above.
5. Remove the first part of the URL before `/download/`. 

**Adding headers and footers**

You can add headers and footers to your PDF pages using HTML. Use the 'PDF Space Export Header' and 'PDF Space Export Footer' sections of the PDF layout to do this. For simple headers and footers, plain text is enough. The following example adds a simple copyright notice.

Copyright © 2010, Atlassian Pty Ltd.

**Adding page numbers to a header or footer**

To add page numbering, you need to combine customised HTML in the PDF Layout with customised CSS in the PDF Stylesheet.

1. PDF Layout HTML: In the Footer section (or the Header section), use an empty span element with a unique ID, for example `pageNum`, to act as a place holder for the page number.

```html
<span id="pageNum"/>
```

2. PDF Stylesheet CSS: Create the following CSS selector rule for the empty span:
CSS - PDF Stylesheet

```
#pageNum:before
{
  content: counter(page);
}
```

Analysing the above CSS selector rule in more detail:

- The `#pageNum` rule selects the HTML element with the specified ID of "pageNum", which is the span element we created for the header or footer.
- The `:before` part of the selector is a pseudo class that allows the insertion of content before the span element is processed.
- The `counter(page)` function returns the current page number as its content.
- The `content` property tells the CSS processor that dynamic content (that is, an incrementing page number) is to be inserted at the span tag.

Exporting to PDF

You can use the built-in Confluence PDF export to export a single page, a selection of pages or an entire space to a single PDF file.

**Exporting a single page to PDF**

You can export a Confluence page to PDF. This option exports a single page and is available to all users who have permission to view the page.

- Go to a page in the space and choose `*** > Export to PDF` (follow the prompts to export the page)

**Exporting a selection of pages or a space to PDF**

1. Go to the space and choose **Space tools > Content Tools** from the bottom of the sidebar
2. Choose **Export**. This option will only be visible if you have the 'Export Space' permission.
3. Select **PDF** then choose **Next**
4. Decide whether you need to customise the export:
   - Select **Normal Export** to produce a PDF file containing all the pages that you have permission to view.
   - Select **Custom Export** if you want to export a subset of pages.
5. Select the pages you want to export.
   - You have the option to **Select All** or **Deselect All** pages.
   - When you select a page, all its child pages will also be selected. Similarly, when you deselect a page all its child pages will also be deselected.
6. Choose **Export**.
7. When the export process has finished, download and save the PDF file as prompted.

If your space uses the Documentation theme:

1. Choose **Browse > Space Operations**
2. Choose **PDF Export** from the left menu.
3. Follow the steps above to export the Space.
Using the Scroll PDF Exporter add-on (Not applicable to Confluence Cloud.)

The Scroll PDF Exporter provides flexible themes for configuring PDF layout and styles. You can select one of Scroll PDF Exporter’s built-in themes and configure your table of contents, header and title pages. For even more flexibility, see the section How Tos in the Scroll PDF Exporter documentation.

For this advanced PDF export functionality, you will need to install the Scroll PDF Exporter add-on into your Confluence site.

Notes

- **Permissions required to export a space**: To use the space export functionality, you need the ‘Export Space’ permission. See the guide to space permissions.

- **Installing add-ons**: If you decide to use additional add-ons, your site administrator will need to install the
add-ons into your Confluence site. Refer to the documentation on installing add-ons. (Not applicable to Confluence Cloud.)

- **Add-on support:** Before installing an add-on (also called a plugin) into your Confluence site, please check the add-on's information page to see whether it is supported by Atlassian, by another vendor, or not at all. See our guidelines on add-on support.

**Next Steps**

Now you know all about providing PDF versions of your documentation. What next? See other ways of Exporting and Printing Technical Documentation.

**Exporting and Printing Technical Documentation**

This page is part of the guide to developing technical documentation on Confluence Wiki. Confluence is a great tool for writing and maintaining technical documentation. There are times when we need to export the content out of Confluence into other forms, such as PDF, HTML, Microsoft Word and paper.

Confluence itself provides an export to both PDF and HTML. Add-ons provide additional functionality. Below are guidelines on exporting your technical documentation to various formats, including printed output.

**Quick guide to printing and exporting content:**

- Use the browser’s print option to print a single page.
- To print more than one page and for more advanced printing options, export your documentation to PDF.
- Confluence can export your pages to PDF, HTML, Confluence-specific XML and Word.
- Consider installing add-ons to export your pages to PDF (enhanced functionality), DocBook XML, Eclipse Help and JavaHelp.
- Make your exports available to your customers for download by attaching the exported file to a Confluence page.

The rest of this page gives more details of the above procedures.

<table>
<thead>
<tr>
<th>On this page:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Printing</td>
</tr>
<tr>
<td>Exporting to PDF</td>
</tr>
<tr>
<td>Exporting to HTML</td>
</tr>
<tr>
<td>Exporting to Confluence-specific XML</td>
</tr>
<tr>
<td>Exporting to DocBook XML via an add-on</td>
</tr>
<tr>
<td>Exporting to Microsoft Word</td>
</tr>
<tr>
<td>Exporting to Microsoft Word via an add-on</td>
</tr>
<tr>
<td>Exporting to Eclipse Help via an add-on</td>
</tr>
<tr>
<td>Exporting to EPUB via an add-on</td>
</tr>
<tr>
<td>Exporting to HTML via an add-on</td>
</tr>
<tr>
<td>Making the PDF and other exported files available to your readers</td>
</tr>
<tr>
<td>Notes</td>
</tr>
<tr>
<td>Further reading</td>
</tr>
</tbody>
</table>

**Printing**

To print a single Confluence page, just use the browser’s print option. This option is available to all users who have permission to view the page.

To print more than one page and for more advanced printing options, export your documentation to PDF. See Providing PDF Versions of your Technical Documentation.

**Exporting to PDF**

Because this is such an important topic, we have a section of this guide dedicated to PDF. See Providing PDF Versions of your Technical Documentation.

**Exporting to HTML**

Using the built-in Confluence HTML export, you can export a single page, a selection of pages or an entire
space to HTML. Confluence supplies the HTML and associated files in a zip file.

1. Go to the space and choose **Space tools > Content Tools** from the bottom of the sidebar
2. Choose **Export**. This option will only be visible if you have the 'Export Space' permission
3. Select **HTML** then choose **Next**
4. Decide whether you need to customise the export:
   - Select **Normal Export** to produce an HTML file containing all the pages that you have permission to view.
   - Select **Custom Export** if you want to export a subset of pages, or to exclude comments from the export.
5. Select the **Include Comments** check box if you want to include comments for the pages you are exporting
6. Select the pages you want to export
   - You have the option to **Select All** or **Deselect All** pages.
   - When you select a page, all its child pages will also be selected. Similarly, when you deselect a page all its child pages will also be deselected.
7. Choose **Export** (this will create a zipped archive of HTML files)
8. When the export process has finished, download the zipped archive as prompted, and extract the files into a folder.

If your space uses the Documentation theme:

1. Choose **Browse > Space Operations**
2. Choose **HTML Export** from the left menu
3. Follow the steps above to export the Space
**Export HTML Options**

Export content within this space as HTML.

- **Normal Export**
  Generates a HTML file of all pages and blog posts in this space, including comments and attachments.

- **Custom Export**
  Generates a HTML file of selected pages based on options that you choose from below.

**Includes:**

- Include comments

**Choose pages to export:**

Select All  Deselect All

- Crowd Documentation
  - Crowd 101
  - Crowd Administration Guide
  - Getting Started
Exporting to Confluence-specific XML

Confluence provides an XML export. The XML produced is a proprietary format and is intended for backups or for transferring a space from one Confluence site to another. If you write your documentation on Confluence and your customers have Confluence too, then you can export your manuals to XML and customers can upload them onto their own Confluence site.

Exporting to DocBook XML via an add-on

Scroll DocBook Exporter converts Confluence pages to DocBook XML. Your Confluence system administrator will need install the add-on onto your Confluence site.

Exporting to Microsoft Word

Confluence can export a page to Word. (Choose \*** \> **Export to Word** This option performs a basic conversion of wiki content to HTML and applies some Word CSS stylesheets. It processes just one page at a time.

Exporting to Microsoft Word via an add-on

Scroll Office is a Confluence add-on. Once installed, Scroll Office replaces Confluence's built-in 'Export to Word' functionality. You can export a single page or a hierarchy of pages.

You can define your templates in Word in the usual way, and upload them to Confluence as global templates or space templates. When you export your Confluence pages to Word, Scroll Office will use those templates to build native Word documents from the wiki pages.

Scroll Office provides additional features such as enforcing page-breaks, setting the page orientation to landscape or portrait, and ignoring content. The latest version offers a REST-style API for automated export.

Exporting to Eclipse Help via an add-on

Scroll EclipseHelp Exporter provides an export to Eclipse Help format.

You can produce embeddable online help for Eclipse-based applications. Scroll EclipseHelp Exporter converts the Confluence content into EclipseHelp-compatible JAR files to create a standalone online help or a context-sensitive help.

**A hint about the Eclipse Help platform:** You can use a cut-down version of the Eclipse Help platform to provide online documentation for any system. It doesn't have to be an Eclipse tool that you are documenting. For some ideas, take a look at a couple of articles about documenting your project using the Eclipse help system.

Exporting to EPUB via an add-on
The Scroll EPUB Exporter outputs an ebook in the common EPUB format that can be read on iPads, iPhones and any other ebook reader.

Exporting to HTML via an add-on

The Scroll HTML Exporter enables the delivery of Confluence content from a web server. It converts the pages into static HTML pages that can be uploaded to a web server. The output of the Scroll HTML exporter can also be used as an input to produce other HTML-based help formats such as WinHelp and HTML Help.

Making the PDF and other exported files available to your readers

There are a number of ways to make your exported files available to your readers, such as putting the files on a disc and shipping them with your product.

One of the simplest ways is to attach the files to a Confluence page. (See Uploading Files.)

Atlassian uses the out-of-the-box Confluence export functionality to provide PDF, HTML and XML versions of our documentation. People can download the files from our documentation wiki. For example, here are the JIRA documentation downloads and the Confluence documentation downloads.

Notes

- **Permissions required to export a space.** To use the space export functionality, you need the 'Export Space' permission. See the guide to space permissions.

- **Installing add-ons.** If you decide to use additional add-ons, your site administrator will need to install the add-ons into your Confluence site. Refer to the documentation on installing add-ons.

- **Add-on support.** Before installing an add-on (also called a plugin) into your Confluence site, please check the add-on's information page to see whether it is supported by Atlassian, by another vendor, or not at all. See our guidelines on add-on support.

Further reading

- A blog post about exporting and importing content from/to Confluence: Technical Writing in a Wiki - Single Source Publishing (November 2010).
- A good overview of the Scroll Office features in this blog post (August 2010) and the followup post (November 2010).

Next steps

Now you know about a number of ways to get your technical documentation out of Confluence into various formats, for printing or for input into another system or process flow. What next? Take a look at Essential Confluence Features for Technical Documentation.

**Essential Confluence Features for Technical Documentation**

This page is part of the guide to developing technical documentation on Confluence. In this section we highlight the built-in Confluence macros that are most useful in technical documentation. For more information about Confluence macros, see Working with Macros.

**On this page:**

- Auto-generating a table of contents for page content
- Drawing attention to elements of a page
- Putting content inside customisable Panels
- Inserting anchor links on pages
- Structuring content using sections and columns
- Making your documentation more engaging by embedding videos

Auto-generating a table of contents for page content

It is important to make it easy for viewers to jump to the section of a Confluence page that they are most
interested in. The Table of Contents macro helps people navigate lengthy pages by summarising the content structure and providing links to headings used on the page.

2. Each feature in the release is a heading on the page.
3. You can generate a list of hyperlinks to each of the features in the release notes by inserting the Table of Contents macro:

![Table of Contents macro](image)

4. The image below shows the Table of Contents macro inserted at the top of the 'Release Notes' page. Note that we have excluded the 'Highlights of Confluence 4.0' heading from the table of contents by modifying the macro's parameters.
Confluence 4.0 Release Notes

19 September 2011

With great pleasure, Atlassian presents Confluence 4.0. This is one of the most significant updates we've made to Confluence, the most productive and user-friendly version to date.

Table of Contents Macro
- Minimum Heading Level Set to '2'
- Maximum Heading Level set to '7'

Highlights of Confluence 4.0:
- Brand New Editor
- Simplified Editing Experience
- New Macros
- Faster Editing Experience
- Introducing @mentions
- Improved Page Comparison Functionality
- Email Notification Improvements
- New Confluence Installer and Guided Upgrades
- New Editor Plugin Points for Developers
- Other Improvements
- Helping You Transition to Confluence 4.0
- Release Notices

More:
- Read the Upgrade Notes for important information about this release.
- See the full list of issues resolved in this release.

Learn more about Confluence 4.0
Drawing attention to elements of a page

Often when creating documentation there are elements of a page that you want to highlight, or draw the the viewers' attention to. Confluence ships with the following macros that help you focus a viewer's attention to a note, information, tip or warning.

- **Note macro**

<table>
<thead>
<tr>
<th>What is it?</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>The Note macro allows you to highlight a note on a Confluence page.</td>
<td><strong>Draft in progress</strong></td>
</tr>
<tr>
<td>It creates a yellow coloured box surrounding your text, as shown to the right.</td>
<td>This document is a draft and is under development.</td>
</tr>
<tr>
<td>See Note Macro for more examples and instructions.</td>
<td></td>
</tr>
</tbody>
</table>

*Click here to see a common example* >>
### Info macro

<table>
<thead>
<tr>
<th>What is it?</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>The Info macro allows you to highlight helpful information on a Confluence page.</td>
<td></td>
</tr>
<tr>
<td>It creates a blue coloured box surrounding your text, as shown to the right.</td>
<td></td>
</tr>
<tr>
<td>See <a href="#">Info Macro</a> for more examples and instructions.</td>
<td></td>
</tr>
</tbody>
</table>

### Tip macro

<table>
<thead>
<tr>
<th>What is it?</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>The Tip macro allows you to highlight a helpful tip on a Confluence page.</td>
<td></td>
</tr>
<tr>
<td>It creates a green coloured box surrounding your text, as shown to the right.</td>
<td></td>
</tr>
<tr>
<td>See <a href="#">Tip Macro</a> for more examples and instructions.</td>
<td></td>
</tr>
</tbody>
</table>

### Warning macro

<table>
<thead>
<tr>
<th>What is it?</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>The Warning macro allows you to highlight a warning note on a Confluence page.</td>
<td></td>
</tr>
<tr>
<td>It creates a red coloured box surrounding your text, as shown to the right.</td>
<td></td>
</tr>
<tr>
<td>See <a href="#">Warning Macro</a> for more examples and instructions.</td>
<td></td>
</tr>
</tbody>
</table>

---

### Return to top of page

#### Putting content inside customisable Panels

Using the **Panel macro**, you can place content inside a customisable coloured panel. This is particularly useful when you want to clearly separate elements on a page.

> Click here to see a common example >>

1. You are documenting a procedure which involves a number of steps.
2. You want to call out the steps of the procedure from the rest of the page by placing it inside a coloured box, or panel.
3. You can create a coloured panel using the Panel macro.
4. The image below shows the parameters set for the panel using the macro browser.
Inserting anchor links on pages

Anchor links can be especially useful when navigating between sections of a long document or when you want to link to a segment of a page from another page. The Anchor macro allows you to link to specific parts of a page.

Click here to see a common example >>

1. You are documenting part of a user guide.
2. The page is split into multiple sections.
3. After each section you want to provide a link for viewers to click, taking them back to the top of the page.
4. To achieve this you first must create an anchor at the top of the page using the Anchor macro. You can give the anchor any name you like. In the image below, the anchor at the top of the page will be named ‘top’.
5. The anchor placeholder will appear to indicate where your anchor link is located on the page:

![Anchor placeholder]

This guide is for people who want to author and publish technical documentation on Confluence. This page highlights out-of-the-box Confluence macros that you may want to use to create document in Confluence

6. Create a link to the anchor, anywhere on the page, using the Link Browser. The image below shows a link to the anchor called 'top' by using the hash '# followed by the name of the anchor you created earlier, with an alias of 'Return to Top'.
Structuring content using sections and columns

Sometimes it is necessary to structure content into sections and columns. The details are in Working with Page Layouts and Columns and Sections.

- Page layouts allow you to add sections to your page and then apply pre-defined column layouts to each section (for example, 2 column, three column). You can add multiple sections to a page.
- The Section and Column macros allow more flexibility. You can set the width of the columns, and put the sections and columns in any part of the page. Each section can contain any number of columns, created

See Working with Anchors for more examples and instructions.

Return to top of page
Columns can either have a fixed width, specified in pixels, or a dynamic width, specified as a percentage of the page width.

Note: whether you are using page layouts or macros, a column is always created inside a section.

The images below show part of a Confluence page with two sections (outlined in red), each with two columns (blue) of different widths.

1. Section 1:

   - Put a name to your face
   - Learn how content is organized
   - Get familiar with the Confluence screens
   - Start creating content
   - Add a panel to your page

2. Columns in section 1 — left column has a fixed width of 400 pixels:
3. Section 2:

Put a face to your name
Your profile picture is used to identify you across Confluence. Upload your own picture via your Profile.

Dashboard: People: Fred Flintstone: Profile Picture
Help: Browse: Fred Flintstone: Search

Profile
Details
Picture
Password

1. Put a name to your face
2. Learn how content is organised
3. Get familiar with the Confluence screens
4. Start creating content
5. Add a panel to your page

4. Columns in section 2 – left column has a fixed width of 10 pixels:

Put a face to your name
Your profile picture is used to identify you across Confluence. Upload your own picture via your Profile.

Dashboard: People: Fred Flintstone: Profile Picture
Help: Browse: Fred Flintstone: Search

Profile
Details
Picture
Password

1. Put a name to your face
2. Learn how content is organised
3. Get familiar with the Confluence screens
4. Start creating content
5. Add a panel to your page

Making your documentation more engaging by embedding videos

Pictures can be worth a thousand words. The same can be said for videos. Often, it's easy to explain a concept or demonstrate a procedure using a video. The Widget macro allows you to embed web content, including YouTube and Vimeo videos, in a Confluence page.

Click here to see a common example >>

1. You release a new version of your product.
2. You document the release notes on a Confluence page.
3. The marketing team creates a video demonstrating the new features of the release and uploads it to YouTube.
4. You can embed the video in your release notes using the Widget macro, for playback on your Confluence page.
a. Edit the page and choose **Insert > Other Macros** in the editor toolbar.

b. Search for the 'Widget Connector'.
c. Insert the URL of your YouTube video into the **Web Sites Widget URL** field.

![Web Sites Widget](image)

**Insert 'Widget Connector' Macro**

- Web Sites Widget URL
- Pixel Width (Value Only)
- Pixel Height (Value Only)

Choose and save your page.

![Confluence 4.0 Release Notes](image)

- **DOWNLOAD latest version**
- **19 September 2011**
- With great pleasure, Atlassian presents Confluence 4.0. This is one of the most significant updates to Confluence in a wide-ranging user interface improvements, we're confident that Confluence 4.0 is the most productive and user-friendly Confluence ever.

**Highlights of Confluence 4.0:**
- Brand New Editor
- Simplified Editing Experience
- New Macros
- Faster Editing Experience
- Introducing @mentions
- Improved Page Comparison Functionality
- Email Notification Improvements
- New Confluence Installer and Suited Updates
- New Editor Plug Ins for Developers
- Other improvements
- Helping You Transition to Confluence 4.0
- Release Notices

**More:**
- Read the Upgrade Notes for important information about this release.
- See the full list of issues resolved in this release.

**Learn more about Confluence 4.0.**

See **Widget Connector Macro** for information on the supported services and for more examples.

**Return to top of page**

**Next steps**

Take a look at **Confluence Add-ons for Technical Documentation**.

**Confluence Add-ons for Technical Documentation**

This page is part of the guide to developing technical documentation on Confluence. In this section we highlight some of the Confluence add-ons that are useful for technical writers in designing and developing documentation.

An add-on is an extension module that you can add to your Confluence site to extend the wiki's core functionality. It is similar to an add-on for your browser.

An add-on that specifically plugs into an Atlassian application such as Confluence is sometimes called a plugin. The terms 'plugin' and 'add-on' are often used interchangeably. Confluence add-ons may be developed by
Atlassian or by third parties. To find an add-on featured on this page, and other add-ons too, visit the Atlassian Marketplace.

Drawing tools

Below are some popular tools. Search the Atlassian Marketplace to see a full list of drawing and diagram add-ons for Confluence.

**Gliffy**

The Gliffy add-on provides an embedded diagram editor. With Gliffy you can create and edit diagrams directly on a Confluence page. Gliffy supports various diagram types (UML, business process, and so on).

On this page:
- Drawing tools
- Gliffy
- Lucidchart
- Creately
- yWorks Diagrams
- Add-ons for enhanced content manipulation
  - Quick overview of macros
  - Composition add-on
  - Using the Composition add-on to outline text blocks
  - Using the Composition add-on to add tabs to a page
  - Using the Composition add-on to flow your text around images
  - Scaffolding add-on
- Extended version control
  - Scroll Versions
  - Attachment Checkout add-on
- Add-ons featured in other parts of this guide
- Notes
- Further reading

Commercial or free? Commercial.

Alternatives: As an alternative you can use the standalone version of Gliffy available at [http://www.gliffy.com/](http://www.gliffy.com/). Gliffy online has a free basic version.

More information: See the Gliffy add-on page.

**Lucidchart**

Using Lucidchart, you can draw flowcharts, wireframes, UML diagrams, mind maps, and more, inside the web editor, then integrate the diagram with Confluence. Include interactivity such as linking to pages within Confluence or other pages inside the diagram.

Commercial or free? Commercial.

More information: See the Lucidchart add-on page.

**Creately**

Use Creately to draw flowcharts, UML diagrams, database diagrams, wireframes, mindmaps, UI mockups, workflow diagrams, network diagrams, org charts, and Gantt charts.

Commercial or free? Commercial.

More information: See the Creately add-on page.

**yWorks Diagrams**

Use yWorks Diagrams to create and edit diagrams directly inside Confluence.

Commercial or free? Commercial.
More information: See the yWorks Diagrams add-on page.

Add-ons for enhanced content manipulation

All content extensions are provided by macros in Confluence. Some macros are built in to Confluence. Other macros are supplied by add-ons.

Quick overview of macros

Before looking at add-ons, let's take a quick look at macros in general. There are two ways to add a macro to your page:

- Use the macro browser. This is the simplest and recommended way.
- Or insert the macro's name in curly brackets into the text of your page and specify the parameters.

Click here to see an example of a macro >>

The following code uses the (include) macro to insert the text from the page called 'My Page'.

Some content on my page.
{include:My Page}
Some more content on my page.

Let's assume 'My Page' contains just two lines:

I love chocolate.
Chocolate loves me.

The resulting page will look like this:

Some content on my page.
I love chocolate.
Chocolate loves me.
Some more content on my page.

A number of macros are shipped with your Confluence installation by default. See Working with Macros. Below we describe some add-ons that provide additional useful macros for Confluence:

Composition add-on

The Composition add-on provides macros which allow finer control over the layout (composition) of a page. Using these macros, you can:

- Outline your text blocks.
- Add tabs to a page.
- Flow your text around the images or diagrams on the page.

Commercial or free: Commercial.

Using the Composition add-on to outline text blocks

Use the (cloak) macro to outline a text block.

Usage: The following code creates a text block named 'SeeAlso' for the outlined 'See Also' section within a page. The text block with id="SeeAlso" will be hidden after the 'See Also' title:
Alternatives: You can also use the {expand} macro available in Confluence by default, but this macro can outline only text of the same level and cannot hide headings within the text. The {expand} macro does not require parameters and just hides the text placed between the {expand} tags.

Note: If you need to outline a text block containing nested headings, consider the text structure. Maybe the block is too big. You could create a child page from this block to decompose the whole text. Then you can include and outline the text block using the {include} macro within {expand}.

Using the Composition add-on to add tabs to a page

Use the {deck} and {card} macros to separate content between tabs on the same page.

Usage: The following code creates two tabs with client information:

```
{composition-setup}

h1. Client Name
   {deck:id=ClientName}
   {card:label=Basic}
Client Company Name: Company
[Client Web Site|http://url.com]
Our projects: [Project1|Project1 Home]
{card}
   {card:label=Contacts}
Company CEO: John Brown, e_mail: brown@company.com
{card}
{deck}
```

The tabs on a page will look like this:

![Client Name](image)

Using the Composition add-on to flow your text around images

Use the {float} macro to make your text flow around images or diagrams.

Usage: The following code demonstrates how a picture can be surrounded by the description, as often shown in
William Shakespeare (baptised 26 April 1564; died 23 April 1616) was an English poet and playwright, widely regarded as the greatest writer in the English language and the world's pre-eminent dramatist.

For more macros, see the Composition add-on page.

**Scaffolding add-on**

The Scaffolding add-on provides macros for creating 'permanent templates' and editable forms. You can create sophisticated page templates in order to add content easily and fast. Scaffolding templates are suitable for dynamically-filled data and allow people to create pages by completing form fields and selecting values from drop-down lists.

The Scaffolding templates are useful for creating pages with a well-determined structure, such as:

- API methods or property descriptions.
- Constant list.
- Feature description.
- Software requirement specifications.

**Commercial or free:** Commercial.

**Example:** The following Scaffolding template creates a description of an API method:
h3. Method Name
{text-data:methodName|required=true}{text-data}

h3. Method Description
{text-data:methodDescription|type=area|required=true|width=100%}description{text-data}

h3. Parameters
{table-data:parameters}

<table>
<thead>
<tr>
<th>Name</th>
<th>Type</th>
<th>Mandatory</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>{text-data:paramName}ParamName{text-data}</td>
<td>{list-data:paramType}{list-option:Number}Number{list-option}{list-option:String}String{list-option}{list-option:DateTime}DateTime{list-option}{list-option:MACaddress}MACaddress{list-option}{list-option:IPaddress}IPaddress{list-option}{list-data}</td>
<td>{list-data:paramMandatory}{list-option:Required}Required{list-option}{list-option:Optional}Optional{list-option}{list-data}</td>
<td>{text-data:paramDescription</td>
</tr>
</tbody>
</table>

h3. Return Value
The returned value is an XML structure of the following format:

```xml
{code:xml}
{code}
```

Where elements mean:

{table-data:returnValues}

<table>
<thead>
<tr>
<th>Name</th>
<th>Type</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>{text-data:paramName}ParamName{text-data}</td>
<td>{list-data:paramType}{list-option:Number}Number{list-option}{list-option:String}String{list-option}{list-option:DateTime}DateTime{list-option}{list-option:MACaddress}MACaddress{list-option}{list-option:IPaddress}IPaddress{list-option}{list-data}</td>
<td>{text-data:paramDescription}param description{text-data}</td>
</tr>
</tbody>
</table>

h3. Remarks
{text-data:remarks}remarks{text-data}

h3. See Also
API Method demo

Method Name
API Method demo

Method Description

Parameters

<table>
<thead>
<tr>
<th>Name</th>
<th>Type</th>
<th>Mandatory</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Param1</td>
<td>Number</td>
<td>Required</td>
<td>desc description</td>
</tr>
<tr>
<td>Param2</td>
<td>Number</td>
<td>Required</td>
<td>desc description</td>
</tr>
</tbody>
</table>

Return Value

The returned value is an XML structure of the following format:

```
<element1>
  <param description/>
</element1>
```

Where elements mean:

<table>
<thead>
<tr>
<th>Name</th>
<th>Type</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Element1</td>
<td>String</td>
<td>param description</td>
</tr>
</tbody>
</table>
For more information on how to create templates in Confluence, see Creating a Template.

**Alternatives:** Confluence includes built-in templates which as useful for static data and simple text. For more information, see Working with Templates.

**Notes:** The Scaffolding (and any) template changes will affect only new pages created from the modified template. In order to change the existing pages, you need to edit each individual page and add or modify the formatting manually.

For more information on Scaffolding, see the [Scaffolding add-on page](#).

**Extended version control**

**Scroll Versions**

Scroll Versions adds functionality for sophisticated version management, enhanced content reuse, support for context-sensitive help, permalinks, and duplicate page titles. You can set up and manage concurrent versions of your documentation in a single space. Multiple versions of software, different product variants, and even multiple translations of documentation can be managed. Changes to pages are scheduled for a specified version and then published all at once. See the [Scroll Versions documentation](#) for an overview of the key features.

Commercial or free: Commercial.

*Video: Scroll Versions - Version Management for Confluence (4:20)*

**Attachment Checkout add-on**


Commercial or free: Free for up to 50 users, then commercial.

More information:

- Please visit the [Attachments Checkout add-on page](#) for an overview, including a video,
- See the [Attachments Checkout documentation](#) for further reference.

Add-ons featured in other parts of this guide

- [Copy Space add-on](#) – Provides an easy way of copying a space within a Confluence site. Free. See Creating your Technical Documentation Space.
- [Multi Excerpt add-on](#) – Enables you to have more than one excerpt (re-usable chunk) on a page. Commercial. See Re-using Content in Technical Documentation.
- [Content Publishing add-on](#) – Publishes content from a master space to a published space. Commercial no charge. See Managing the Life Cycle of your Technical Documentation.
- [Scroll EPUB Exporter](#) – Outputs an ebook in the common EPUB format that can be read on iPads, iPhones and any other ebook reader. Commercial.
- [Scroll HTML Exporter](#) – Enables the delivery of Confluence content from a web server. It converts the pages into static HTML pages that can be uploaded to a web server. The output of the Scroll HTML exporter can also be used as an input to produce other HTML-based help formats such as WinHelp and HTML Help. Commercial.
- [Scroll EclipseHelp Exporter](#) – Enables you to collaborate and author all your content in your wiki, and
generate embeddable online help for Eclipse-based applications. Commercial.

Notes

- **Add-on support.** Before installing an add-on (also called a plugin) into your Confluence site, please check the add-on's information page to see whether it is supported by Atlassian, by another vendor, or not at all. See our guidelines on [add-on support](#).
- **Installing add-ons.** If you decide to use additional add-ons, your site administrator will need to install the add-ons into your Confluence site. Refer to the documentation on [installing add-ons](#).

Further reading

- A blog post about useful add-ons and tools for exporting and importing content from/to Confluence: [Technical Writing in a Wiki - Single Source Publishing](#) (November 2010).
- Website for exploring and downloading the available add-ons: [Atlassian Marketplace](#).
- Documentation on installing and configuring add-ons: [Universal Plugin Manager documentation](#).
- Documentation on using macros: [Working with Macros](#).
- [Further Reading about Developing Technical Documentation on Confluence](#)

**Further Reading about Developing Technical Documentation on Confluence**

This page is part of the guide to [developing technical documentation on Confluence](#). Once you have absorbed all the information in this guide, you may be ready for more reading.

- The Confluence documentation: [Confluence Latest](#).
- Blog post about using Confluence for online help: [Using a wiki for online help](#).
- Blog posts about version management in Confluence with Scroll Versions plugin:
  - [Announcing Scroll Versions](#).
  - [Version management gets serious with Confluence Scroll Versions plugin](#).
- Now you have your documentation space up and running, it's fun and rewarding to use the full power of the wiki to engage your readers and embed content from other social sites. Here is a blog post and presentation slides on [engaging readers in the documentation](#).
- [Webinar recording: Confluence as a Platform for Technical Documentation](#).

Let us know about more links

We plan to add more links to this page or to the 'Tips of the Trade' page. Let us know of any we have missed.

Using Confluence as a Knowledge Base

A knowledge base is a repository for how-to and troubleshooting information. Knowledge Bases are commonly used by IT Support teams, but can be useful for procedural and troubleshooting information in any organisation or team.

What do people want out of a knowledge base? Using an IT Support team as an example:

- Customers want fast access to a solution, and relevant search results.
- Help desk staff want to be able to create new articles quickly.
- Help Desk team leads want the space to be self curating, and do not want to spend a lot of time manually organising content.
- Everyone wants a way to be notified when articles they are interested in have been updated or important notices are added.

Creating a knowledge base space

⚠️ You'll need the Create Space global permission to do this.
To create your knowledge base space:

1. Create a space using the knowledge base space blueprint (Choose Spaces > Create space > Knowledge base space).
2. Set permissions for the space, including anonymous access (Choose Space Tools > Permissions).
3. Create your first knowledge base article (Choose Create > How-to or Troubleshooting and follow the prompts).

The knowledge base space blueprint includes everything you need to get started, including article templates, and a pre-configured homepage with Livesearch and Content By Label macros.

Page labels are essential in knowledge base spaces. These are used to add topics to your articles, and allows your knowledge base to become self organising over time.

Users will generally find articles by searching, and using the topic navigation on the homepage and end of each article, rather than navigating through a tree-like page hierarchy.

When starting off your knowledge base space, it is a good idea to brainstorm a few topics to get started.

Customising your knowledge base space

⚠️ You'll need Space Admin permissions to do this.

To make it easy for your users to create knowledge base articles (such as your help desk or support team) we recommend customising the how-to and troubleshooting article templates to make them relevant for your organisation. The more guidance and structure you can put in your template, the faster it will be for your team to create great articles.

To edit the article templates:

1. Go to Space Admin > Content Tools > Templates.
2. Edit the How-to or Troubleshooting article templates.
3. Add headings and instructional text (choose Template > Instructional Text).

You can also add additional templates, such as a policy or procedure page templates.

We also recommend customising the look and feel of your space. Simple changes like a space logo and welcome message can make a huge difference.

To change the look and feel:

- Add a space logo and useful shortcuts to the sidebar (choose Space Tools > Configure Sidebar).
- Edit the homepage to add a custom welcome message.
- Edit the colour scheme (choose Space Tools > Look and Feel > Colour Scheme).

Providing communication and notification options

Channels of communication with your audience, internal or external, is essential in a good knowledge base. Here are some out of the box options:

- **Blog** - blog updates and important notices, and encourage people to watch for new blogs in your space.
- **Watch** - encourage people to watch pages that interest them, or watch the entire space.
- **Comments** - allow logged in users (or even anonymous users) to comment on knowledge base articles. This is a simple way to connect with your end users.
- **RSS** - create an RSS feed and add the link to your knowledge base homepage (choose Help > Feed Builder). Alternatively encourage users to create their own feed - useful if they want to keep up with particular topics (labels), rather than receive notifications for the whole space.

Integrating your knowledge base with other Atlassian products

If your Confluence site is connected to another Atlassian product (via an application link), you can make use of these great integration features:
If you use JIRA - add a JIRA Issues macro to your troubleshooting article to provide quick access to known issues. This has the added advantage of automatically updating when an issue is resolved or its status changes. One simple way to do this would be to add some labels to JIRA to indicate the issue should appear in the knowledge base (for example 'printer-krb'), and then add a JIRA Issues macro with a query like 'label = 'printer-krb and status <> resolved'' on all articles with the printer topic.

If you use JIRA Service Desk - specify your Confluence space to be used as a knowledge base. Users can search your knowledge base directly from within the Service Desk customer portal.

If you use Confluence Questions - add a Questions list macro to troubleshooting articles, to highlight the top questions with the same topic as the article, and an Ask a Question button to the knowledge base homepage.

Extending your knowledge base with third party add-ons

The Atlassian Marketplace has a large number of add-ons for Confluence. A common addition to Knowledge Base spaces is a survey or form tool, which enables you to get feedback on the usefulness or usability of your knowledge base articles.

Search for 'knowledge base' on Marketplace and see if there is an add-on that's right for your knowledge base.

Use Confluence as your Intranet

Your intranet is the hub of your organisation. When choosing your intranet platform, you need to ensure that the system is simple enough for non-technical users, information and content can be shared easily, and access is restricted to those within your organisation.

Confluence has a host of great out-of-the-box features that allow you to share and collaborate with your colleagues, while keeping your information secure. Share things like procedures, specifications and important files – or organise company events and functions – and get your teams working together. It's one place to share, find, and collaborate to get work done.

Create your community

It's quick and easy to add users to your Confluence site. Allow people to add themselves as users of the site; invite people to sign up by sending them an invitation link; add new users manually; or use an existing directory – like an LDAP directory – for authentication and to manage users and groups.

Whichever way you choose, you can quickly build a community of Confluence users and give them access to your intranet; you'll also have a ready-made people directory.

Match your company branding

Upload your company logo, and Confluence's auto look and feel will change the colour scheme to match. It'll make your intranet feel more familiar to your colleagues, and help with adoption.

A space for everything, and everything in its space

A Confluence space is essentially a container for a group of pages and blog posts with related content.

When you're starting out with Confluence, the easiest way to organise things is to create a space for each team or department within your organisation. Each team's space is then a place for them to create and share pages, blog posts,
meeting notes, files, and much more – and becomes the place to go for team members to get the information they need.

Just choose Spaces > Create space from the header, and Confluence provides a list of space blueprints to help get you started.

Each space can have its own colour scheme and has a customisable home page, which you can edit to suit your purpose – like displaying and tracking team goals and displaying a list of team members. Use the built-in 'Team Space' template to automatically add all members of the team to the homepage, to help everyone get to know each other.

You can set permissions for each space, so if there's sensitive information that should only been seen by certain users or groups, it's easy to secure it with Confluence.

Don't feel restricted to creating spaces for teams though; you can also create spaces for projects (large or small), events, and anything else where you want to collect information under a common heading or permissions structure.

Once you have some spaces set up, create some pages and blog posts to give your colleagues an example of how Confluence can be used, then invite them to create their own pages and blogs.

Add a personal space

Every Confluence user, including you, can also create their own personal space; it can be a place to keep your own work, add shortcuts to your most used content, and you even get your own blog for sharing your ideas and opinions with the rest of your organisation (or just those that you want to see them).

Create pages, meeting notes and more

You can create pages for anything you want in Confluence - meeting notes, project plans, decisions, and more. Pages are editable so others can contribute and keep them up to date after you create them. Choose Create from the Confluence header and choose a blank page, or use a template to get you started.

Type your page, change its layout, add images and links, and do it all without any specialist skills or training. You can also attach files – allowing everyone in a team access to assets that are critical to the project – like mockups and requirements. You and your colleagues can like the page, and comment on it to start a conversation about the content.

Confluence also offers a series of useful built-in page blueprints, which help you with the content and formatting of the page. The meeting notes and decisions blueprints are two that can be really useful when others need to be in-the-know about what happened, and why it happened.

Avoid the reply-all and blog about it

Each space you create in Confluence has its own blog, where you and your teams can share news and events, discuss important projects and developments, or congratulate a teammate for a special effort; blogging is a great way to foster company culture and celebrate achievements across your organisation.

You can watch any blog to make sure you get updated when there's a new post. Blog posts are automatically organised by date, and grouped by year and month, so they're also easy to find.

Share stuff that matters
If you need to be sure that the right people see a page or blog post, Confluence offers a range of ways to make sure you can get their attention. Type the @ symbol and the name of a Confluence user to mention them in a page, blog post, or comment. They’ll get an email notification that you’ve mentioned them, with a link to the page, post or comment.

There’s also a Share button at the top right of every page. Type the name or email address of a user or group and send them a short message with a link to the content you’re sharing.

Watch and learn

Don't miss out on important updates. Watching spaces, pages, and blogs is a great way to stay up-to-date with what's happening in your own team, or any other team or person you need to keep up with. When you watch something, you’ll get email updates when changes are made or a comment is added.

The Confluence dashboard also has a recent activity feed, which allows you and your team to see what's trending throughout the company or in your network.

Let team collaboration take on a life of its own

If you want to communicate in-the-moment, HipChat — our private service for chat, video, and screen sharing—is built for teams. Share ideas and files in persistent group chat rooms, or chat 1-1 for that personal touch. HipChat integrates with Confluence, so you can get real-time notifications in HipChat whenever new information is shared in Confluence pages and blogs.

Got a question (that's not rhetorical)? Why not ask your team? Confluence Questions is an add-on for Confluence that gives you knowledge sharing with your own Q&A service. Run company-wide polls to gauge reaction to a new marketing initiative, or let people vote on the venue for the Christmas party. Ask questions, get answers, and identify experts.

You can also try Confluence Team Calendars for organising and sharing team events, leave, and other important appointments. Embed each team's calendar on their home page so that everyone knows what's happening, and when.