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Welcome

About

The Confluence User's Guide begins with an overview of the key features of Confluence, and goes on to describe the use of
Confluence as a knowledge management tool and a collaborative environment. If you still have a question that has not been
answered, please ask us.

This guide assumes that your Confluence site uses the default theme. If your site's theme has been customised, menu items,
and the look and feel, may appear differently from those in this guide.

For more documentation please visit Confluence Documentation Home.

Download

You can download the Confluence documentation in PDF, HTML or XML formats.
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Personalising Confluence:

Change your password

Update your User Profile
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Things to do:

Add a page
Add a blog post
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Confluence Icons
Keyboard Shortcuts
Confluence Glossary

Take me back to the Confluence User's Guide.

Dashboard

The dashboard is the front page of a Confluence site. It provides an overview of the site, access to all spaces to which you have 'view'
permission, and displays a list of the most recently updated content within them.

You can go to the dashboard from anywhere in your site by clicking Dashboard at the top-left of the page.

The dashboard is divided into three sections:

® Welcome message — the welcome message for the site. Confluence Administrators can customise this message using the
Administration Console.

® Spaces, Pages, Network — tabs that display your favourite content and people.

® Spaces displays all the spaces to which you have access in the Confluence site, as well as the spaces you have marked as
favourites.

® Pages displays the pages you have marked as favourites.
* Network displays the users that you are following (or who are following you).

® Recent activity — tabs that display recently updated content in All spaces, your Favourite spaces, or by space Categories.
® All Updates displays updates from all spaces that you have permission to view.
® Favourite Spaces displays updates from your favourite spaces.
® Space Categories displays updates from spaces in the category you have selected from the list.

message

X, Dashboard B AddPage [ AddBlog Post
r Ve 1
Welcome to Confluence All Updates  Favourite Spaces = Space Categories -
Confluence combines powerful online authoring capabilities, deep Office Select [ Confluence B
integration and an extensive plugin catalogue to help people work better
together and share information effortlessly. BN Michael Knighten
Get started by adding a new space to create content in. Add a few users B Knighten - Weekly Status - 2011 updated 6 minutes ago (view
to try out Confluence with you. v change)
If you want to display a different message here, you can easily change the
welcome message. $ " Andrew Lui
d % |21 Technical writer peer reviews 2011 updated 7 minutes ago
[ h (view change)
Spaces Pages Network
Jon Silvers
Fo““f% . S Daily Submission Agile 2011 updated 15 minutes ago (view change)
—— Daniel Franz
sername @ .;", Piugin Licensing and Billing updated 17 minutes ago (view change)
Followers
Morgan Friberg
You have no followers .
N ) |£] Surveys updated 19 minutes ago (view change)
\ \ )
~

[ Spaces, Pages, Network ]
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Notes

The dashboard is the only place in Confluence where you can add a new space to the site. Use Add Space on the Spaces tab.
By default, the dashboard is the home page for the Confluence site. However, you can set any other page in Confluence as the
home page using the Space Admin tab or your user profile settings.

Administrators can customise the global dashboard that all users see.

Users can customise the dashboard for themselves.

There are quick Add Page and Add Blog Post buttons at the top right of the dashboard.

Clicking view change beside a page name displays a ‘comparison view' against the content's previous version.

The Feed Builder link is now in the Browse menu.

The People Directory link is now in the Browse menu.

Related Topics

Confluence Glossary
Confluence Icons
Working with Spaces

Take me back to the Confluence User's Guide.

Page Layout in View Mode

The image below shows the menus and other controls on a typical Confluence page.

The byline shows

! . Browse space content such as The User menu gives
Search across
ic‘:?\g];:\rgi':glg?ﬁ:: agde pages, blog posts and access to your personal e g
o et gr g attachments, as well as space profile and activity. and ﬂ?e site
and site admin options lets you log out
attachments
Dashboard * Sample Page Browse * Paul Watson ~ [SiEEE onfluence I
) a Tools for use
* Samp|e Page & Edit [ Share dp Add + £ Tools = 4 with the currant|

~ page

[ Paul Wat Paul Wat view char

Lorem ipsum dolor sit amet, consectetuer adipiscing elit. Aliquam fermentum vestibulyfn est. Cras rhoncug. Pellentesque habitynt morbi tristique

senectus et netus et malesuada fames ac turpis egestas. Sed quis tortor. Donec nogfipsum. Mauris condifnentum, odio nec porly tristique, ante

neque malesuada massa, in dignissim eros velit at tellus. Donec et risus in ligula ejfifend consectetuer. Dpnec volutpat eleifend Sygue. Integer

gravida sodales |eo. Nunc vehicula neque ac erat. Vivamus non nisl. Fusce ac myfgna. Suspendisse euisqhod libero eget mauris.

Labels that are

attached to this
page

edit &2

Edit the Share this

current page

Add a page or blog
post to the space,
or a comment or

page with
another user

attachment to the
page

~ 1 Child Page

{3 Second Page

Paul Watson Use Rich Text Editor
L 3
- Write a comment...

Click 1o add a

comment

Menu or Explanation

option

Browse Gives access to wiki content such as pages, blog posts, etc, and allows you to browse the People Directory. If you are an
administrator, the space and site administration options appear here too.

User After you have logged in, your name will appear at top right of the screen. This is the 'User' menu, and allows you to log out,
access your user profile or view your editing history, personal labels and page watches. You can also retrieve drafts of
pages you are editing.

Search Type into this box and press 'Enter' to search.
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Edit Edit the current page. (Or press 'E')

Share Email a link to the current page to another Confluence user.

Add Add things to a page, or add new a new page or blog post to the space.

Tools Miscellaneous actions relating to the page.

Byline Shows who originally authored, and who most recently edited, the page.

Byline A small padlock icon indicates page restrictions. A paperclip icon indicates that the page has attachments. Both icons are
Icons clickable, leading to the 'Page Information' and 'Attachments' pages, respectively.

Labels Shows labels (or tags) attached to the current page. (Or press 'L'.)

Add a Click in the text box to begin writing a comment. (Or press 'M'.)

Comment

Related Topics

Using the Editor
Overview of Spaces
Overview of Pages

Take me back to Confluence User's Guide

Confluence Glossary

Administration Console
The Administration Console is the interface for the global administration of Confluence.

Only administrators can access the Administration Console.

Administrators
The Confluence permission scheme allows the following main levels of administrator permissions:
® System Administrator — full administrative access to Confluence.
® Confluence Administrator — access to most of the Confluence administrative functions, but excluding those which could compromise

the security of the Confluence system.

Please refer to the overview of global permissions for details of the functions which each level of administrator can perform.

CamelCase

CamelCase is a form of markup commonly used in wikis where words compounded together LikeThis without spaces are used to create
links.

In Confluence, Camelcasing can be turned on from the Administration Console.

Change Comment

A change comment is a short description entered during the edit of a page to record the changes being made in the edit.

Child Pages

Creating child pages is a means of hierarchically organising content in Confluence. A child page can only have one parent page.

Comments

A comment may be a remark, question, or any other additional information you wish to add to a page pertaining to the topic the page covers.
You can comment on any page or news item in Confluence.
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Confluence Administrators
The Confluence permission scheme allows the following main levels of administrator permissions:
® System Administrator — full administrative access to Confluence.
® Confluence Administrator — access to most of the Confluence administrative functions, but excluding those which could compromise

the security of the Confluence system.

Please refer to the overview of global permissions for details of the functions which each level of administrator can perform.

Custom Decorators

Decorator files are used to define layouts in Confluence. They are vmd files and require knowledge of the language, Velocity, to edit.

Dashboard

The dashboard is the front page of a Confluence site. It provides an overview of the site, access to all spaces, and displays a list of the most
recently updated content within them.

Form Field Markup

Form field markup is a specialised markup for creating form fields and is used when creating page templates.

Global Administrators

A global administrator is the same as a system administrator.

Global Spaces
Global spaces contain content on any theme or topic of your choice.

For more information about global spaces and personal spaces, see Working with Spaces.

Hover Profile

The hover profile is the pop-up you see when the mouse pointer pauses over a Confluence user's name. Use the hover profile to follow the
user, visit their profile, and more.

JIRA
JIRA is Atlassian's award winning Issue tracking and project management application.

Visit Atlassian's website to learn more about JIRA.

Labels

Labels are user-defined tag words assigned to pages to categorise content in Confluence.

Macros

A macro is a command wrapped inside curly braces {...} used to perform programmatic functions and generate more complex content
structures in Confluence.

Blog Posts

A blog post may be a journal entry, status report or any other timely information pertaining to a space.

Notifications

A notification is an email message sent to you updating you of changes to pages and spaces you choose to 'watch'.

Orphaned Pages

An orphaned page is a page without any incoming links.



http://jakarta.apache.org/velocity/user-guide.html
http://www.atlassian.com/software/jira/
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Pages

Pages are the primary means of storing information in Confluence and are the building blocks of spaces.

Parent Page

A parent page is a page that has one or more child pages. It may itself be a child of another page.

People Directory

The People Directory contains a list of all users in your Confluence site. Each user's name links to their personal space.

Permalink

A permalink is the url used to link to specific content items like comments.

Personal Spaces
Personal spaces belong to particular users, and rather than being listed on the Dashboard, are available from the People Directory.

For more information about global spaces and personal spaces, see Working with Spaces.

RSS Feeds
An RSS feed is a format for delivering summaries of regularly changing web content. RSS is read by RSS newsreader programs.
You will need an RSS reader to subscribe to feeds within Confluence.

Confluence acts as an RSS reader for feeds from sites outside of Confluence.

RSS Reader

An RSS reader is a specialised RSS program (also called aggregator) that displays the contents of RSS feeds for you. To subscribe to RSS
feeds within Confluence, you will need an RSS reader.

Site Administrators
The Confluence permission scheme allows two levels of administrator permissions:
® System Administrator — full administrative access to Confluence.
® Confluence Administrator — access to most of the Confluence administrative functions, but excluding those which could compromise

the security of the Confluence system.

Please refer to the overview of global permissions for details of the functions which each level of administrator can perform.

System Administrators
The Confluence permission scheme allows two levels of administrator permissions:
® System Administrator — full administrative access to Confluence.
® Confluence Administrator — access to most of the Confluence administrative functions, but excluding those which could compromise

the security of the Confluence system.

Please refer to the overview of global permissions for details of the functions which each level of administrator can perform.

Space Administrators

A space administrator is a user with the 'Space Admin' permission for the space. A user with this permission can perform a host of functions
relating to the management of a space and has complete access to the space regardless of any other control settings or permissions.

Permissions for a space are only assigned and modified by space administrators.

Spaces

A space is an area within Confluence, containing your wiki pages. You can think of each space as a sub-site, or mini-site, each with its own
home page.

There are two types of spaces: global spaces and personal spaces.
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Templates

A template is a pre-defined page that can be used as a prototype when creating pages. Templates are useful for giving pages a common
style or format.

Themes

Themes are pre-defined 'look and feel' styles which are configured from the administration menu and can be applied across Confluence or to
a single space.

Thumbnails

As of Confluence 4.0, all images on the page that aren't links are displayed as thumbnails: when you click on an image the full-size image is
displayed in a pop-up.

Tiny links

A tiny link is the shortened url of a page which is useful when sending links to the page, for example, via email.

Trackback
Trackback is a mechanism by which two sites can stay informed each time one site refers to the other by means of trackback 'pings'.

In Confluence, Trackback is enabled from the Administration Console.

Trackback Autodiscovery

Trackback autodiscovery is a block of code that can be placed in a web-page to describe where trackback pings should be sent for that page.
You can read the technical specification for autodiscovery here.

When Trackback is enabled, Confluence uses Trackback Autodiscovery to ping pages that are linked to, and to advertise its own pages as
being able to receive pings.

Undefined Links

An undefined link is a link to a page that has not yet been created. Clicking on the page link allows you create the page.

User Profile

Every user account in Confluence is linked to a profile that contains user related information and options to configuring user preferences.

Watching a Page or Blog Post

When you watch a page, you are sent an email notification whenever that page has been modified.

Watching a Space

When you watch a space, you are sent an email notification whenever content has been added or modified in that space.

Wiki

Pioneered by Ward Cunningham, and named after the Hawaiian word for 'quick’, a wiki is a website that makes it easy for anyone to
contribute pages, and link them together.

Wiki Markup

This is the markup used to write and edit page templates in Confluence.

Related Topics

Confluence Icons

Take me back to Confluence User's Guide

Confluence Icons


http://www.sixapart.com/pronet/docs/trackback_spec
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Icons are used throughout Confluence to provide quick links and indicators. The most frequently used icons are:

Description

Icon
Indicates that restrictions apply to the current page. Click to see the restrictions and edit them.

=1
E |
Indicates that there are attachments to the current page. Click to open the 'Attachments View'.

d

Go to the people directory.

View a user profile.

k=

't'_ﬂ Go to a personal space.

Go to a global space.

View a space's homepage.

=] View a page.
E3 Add a page.
‘l::"_i,-" Add a child page to the current page.
] View a blog post.
IE‘ Add a blog post.
{1‘_1 This page has been edited since you last viewed it. Click to view the page
[;—] View a comment.
[_L_j;j Add a comment.
View a piece of archived mail that has been imported into Confluence

View a page that has been imported into Confluence.
View an attachment.
This page/space/person is currently a favourite. Click to remove from your favourites

Add this page, space or person to your favourites.

You are currently watching this page or space. Click to stop watching.

Start watching this page or space.

13
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ﬁi‘ Go to the RSS feed builder.

Subscribe to a pre-defined RSS feed.

L-"\l

View a printable version of this page.
Note: From Confluence 2.8, most pages do not show this icon. You can print a Confluence page via your browser's print option.

ap

Export the contents of this space to PDF, HTML and XML.

Define labels.

9 I

[F] Choose a space's theme.
'».d; Choose a space's colour scheme.

Define a layout for a space, its pages and/or blog posts.

|

View space permissions.

@

[ View page permissions.

Related Topics

Dashboard
Confluence Glossary

Take me back to Confluence User's Guide

Keyboard Shortcuts

Confluence provides a number of keyboard shortcuts that you can use to speed up your editing and viewing. This page describes the
keyboard shortcuts for the English language. The shortcut keys (letters of the alphabet) may be different in other languages.

@ Quick guide to keyboard shortcuts

® Press the key combination Shift+? to see all the keyboard shortcuts available in Confluence.

On this page:

® Keyboard Shortcuts
® All Screens

® Editor

® Tables (in the Editor)

® View Screen

® Autocomplete
Viewing a List of Available Keyboard Shortcuts
Disabling and Re-Enabling Keyboard Shortcuts
Notes
Related Topics

Keyboard Shortcuts

The first section below describes the keyboard shortcuts that are available on all Confluence screens. Subsequent sections describe the
shortcuts specific to each type of screen.

All Screens

14
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Windows  Action Mac OS X
/ Enable the quick search /
Ctrl+S Cmd+S

® Submit (where a form is active).
® Editor -- save the Confluence page.
® Qutside the editor -- save the browser page.

GthenD Go to the dashboard GthenD
G then S Browse the current space Gthen S
? Open the Keyboard Shortcut help ?
S Open the status dialog for a status update S
[ Toggle the left-hand navigation bar, when the space is using the Documentation theme. [
Editor
Windows Action
Ctr+Alt+0 Apply the paragraph style.

Ctr+Alt+(1-6)

Ctr+Alt+7

Ctr+Alt+8

Ctrl+Shift+A

Ctrl+B

Ctrl+Shift+B

Ctrl+Shift+D

Ctrl+Shift+E

Ctrl+Shift+F

Ctr+l

Ctrl+Shift+J

Ctri+K

Ctrl+Shift+K

Ctrl+M

Ctrl+Shift+M

Apply a heading level (of the number chosen) to the current line.

Apply the preformatted style.

Apply the block quote style.

Open the Macro Browser.

Make the selected text bold.

Format text as a bulleted list.

Insert wiki markup. (Opens the Wiki Markup dialog.)

Preview the page you are editing.

Toggle full screen mode.

Make the selected text italic.

Insert a JIRA issue. (Opens the Insert JIRA Issue dialog.)

Insert a link. (Opens the Insert Link dialog.)

Suggests a list of pages or other locations to link to from your page. More about autocomplete...

Insert an image. (Opens the Insert Image dialog.)

Suggests a list of images, documents and other files to embed in your page. More about autocomplete...

Mac OS X

Cmd+0

Cmd+(1-6)

Cmd+7

Cmd+8

Cmd+Shift+A

Cmd+B

Cmd+Shift+B

Cmd+Shift+D

Cmd+Shift+E

Cmd+Shift+F

Cmd+l

Cmd+Shift+J

Cmd+K

Cmd+Shift+K

Cmd+M

Cmd+Shift+M
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Ctrl+Shift+N

Ctrl+S

Ctrl+Shift+S

CtrI+Alt+Q

Ctrl+U

Ctrl+Y

Ctrl+Z

Ctrl+Alt+7

Tab

Shift+Tab

Format text as a numbered list.

Save the page you are editing.

Format text with a strike through.

Apply the quote style to the current line.

Make the selected text underlined.

Revert an action that was undone.

Undo the most recent action.

Apply the default paragraph style to the current line.

Indent current line (only in bulleted lists and numbered lists).

'‘Outdent’ current line (only in bulleted lists and numbered lists).

Tables (in the Editor)

Windows

Ctrl+Shift+C

Ctrl+Shift+

Ctrl+Shift+V

Ctrl+Shift+X

Action

Copy the current table row.

Insert a table. (Opens the Insert Table dialog.)

Paste the current table row.

Cut the current table row.

View Screen

Windows

Action

Create a blog post.

Create a child page of your current page.

Mac OS X

Cmd+Shift+C

Cmd+Shift+l

Cmd+Shift+V

Cmd+Shift+X

Edit a page or blog post, or return to Edit mode when previewing.

Open the Link To dialog.

Add or edit labels.

Add a comment to a page or blog post.

View attachments.

Return to page view (only if you are viewing page attachments).

Add or edit watchers.

Mac OS X

Cmd+Shift+N

Cmd+S

Cmd+Shift+S

Cmd+Alt+Q

Cmd+U

Cmd+Y

Cmd+Z

Cmd+7

Tab

Shift+Tab
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Autocomplete

Key Action

[ See a list of suggested pages or other locations to link to from your page.

! See a list of suggested images, multimedia files and documents to embed in your page.
{ See a list of suggestions as you begin typing a macro name.

@ See a list of suggested users to mention.

See more about using autocomplete.

Viewing a List of Available Keyboard Shortcuts

Choose Browse > Keyboard Shortcuts (or press the key combination Shift+?) to show the Keyboard Shortcuts dialog.
In the Keyboard Shortcuts dialog, you can:

® Select the General tab to view global, page and blog post shortcuts.

® Select the Editor tab to view the text editing and formatting shortcuts.

® Select the Editor Autoformatting tab to view the wiki markup and autoformatting shortcuts.

Screenshot: General keyboard shortcuts

Keyboard Shortcuts View All Shortcuts
m [# Enable General Shortcuts
Editor Global Shortcuts Page / Blog Post Actions
Editor Autoformatting Go to Dashboard: g then d Add Page: c
Browse Current Space: g then s Add Blog: b
Open Shortcut Help: ? Edit e
Quick Search ! Comment: m
Update Status: s Edit Labels: |
Edit Watchers: w

View Attachments: t

Link to Page: k

Close

Screenshot: Editor keyboard shortcuts
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Keyboard Shortcuts View All Sherteuts
General
Block Formatting Rich Formatting
[ ]
Editor Autoformatting Faraoraeh B0 Image: E M
Headings 1 to 6: # + 1 to 6 Link: "+ K
Preformatted: ® o+ 7 Wiki Markup: . + Shit + D
Quote: T+ 8 Macro: i+ Shift + A
Bullet list: ® + Shit + B Table: w4+ Shit + |
Numbered list: %+ Shift + N Cut table row: ® + Shift + X
Copy table row #®  + Shit + C
Paste table row: o+ Shit + VWV
Editing Actions
Save: T+ S
Preview: ®  + Shift + E
Insert JIRA issue: ® 4+ Shit + J

Close
Screenshot: Autoformatting keyboard shortcuts
Keyboard Shortcuts View All Shortcuts
General To configure Autocomplete, go to your editor settings
Editor Font Formatting Autocomplete
Editor Autoformatting Bold text *Bold* Image/Media: !
Underline text +Underline+ Link: [
Italic text _Ttalie_ Macro: {
Monospace text {{Monospace}} Mention: @
Tables Styles
first cell [111] + enter Heading hl. Heading
) . Headin h3. Heading
heading heading | |heading| |heading]| | g
| Quote bg. Quote
Emoticons Lists
() 1. list # list
(7] :)  bullets * bullets
Close

Disabling and Re-Enabling Keyboard Shortcuts

Keyboard shortcuts are enabled by default. If required, you can disable general keyboard shortcuts. You cannot disable the editor keyboard
shortcuts.

To disable or re-enable general keyboard shortcuts:
1. Choose Browse > Keyboard Shortcuts (or press the key combination Shift+?).

2. Click the General tab on the left of the Keyboard Shortcuts dialog.
3. Select or clear the Enable General Shortcuts checkbox as required.

Notes

18
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1 Supported Web Browsers
Please ensure that you are using one of the web browsers supported by Confluence. If you are using an unsupported

browser or browser version, some features may not work correctly. You can find the list of supported web browsers and
browser versions on this page: Supported Platforms.

®* The Keyboard Shortcuts dialog also displays the trigger characters for the Confluence autocomplete feature. See Using
Autocomplete.

Related Topics

Confluence keyboard shortcuts are consistent with JIRA keyboard shortcuts. Please see the JIRA documentation: Using Keyboard Shortcuts.
Confluence Wiki Markup
Using Autocomplete

Take me back to Confluence User's Guide

Creating Content

You can create the following types of content in Confluence:

® Pages

® Blog posts

®* Comments
For each of these, you use the editor to enter and format the text, and to embed content, or add links to other pages.
When you first create the page, you can choose a template that the page should be based on.

When you first save the page, you can choose where the page should be located.

You can also import content into Confluence from a variety of other sources.

Related Topics

Organising Content
Managing Users

Take me back to the Confluence User's Guide.

Using the Editor

The editor in Confluence provides an easy and fast way to create and edit Confluence pages, blog posts and comments. It allows you to
enter content as you would in a Word document, to apply formatting simply by clicking buttons on a toolbar, and to embed other content and
files into the page.

You begin an editing session by clicking Edit at the top of a page (or by pressing 'E' on the keyboard) when viewing a Confluence page or
blog post.

ﬂ Permissions

To edit a page, you need the 'Add Pages' permission for that space, which is assigned by a space administrator from the
Space Administration screens. See space permissions or contact a space administrator for more information.

Note that the options available to you when editing depend on the permissions granted to you by the space administrator.
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On this page:

The Toolbar
An Editing Session
Embedding Content in the Page
Things to Help You Work Faster
® Autoformatting
® Autocomplete
® Drag-and-Drop
® Keyboard Shortcuts
® Related Topics

Screenshot: The Confluence Editor

Dashboard p ag ST S TR L IR Search Confluence

Sample Page

Paragraph B I U N A = | = 3= =  link ETable o Insert 7

Lorem ipsum dolor sit amet, consectetuer adipiscing elit. Aliguam fermenturn vestibulum est. Cras rhoncus. Pellentesque habitant morbi tristique senectus et
netus et malesuada fames ac turpis egestas. Sed quis tortor. Donec non ipsum. Mauris condimentum, odio nec porta tristique, ante neque malesuada
massa, in dignissim eros velit at tellus. Donec et risus in ligula eleifend consectetuer. Donec volutpat eleifend augue. Integer gravida sodales leo. Nunc
vehicula neque ac erat. Vivamus non nisl. Fusce ac magna. Suspendisse euismed libero eget mauris.

=" Unrestricted S Attachments @ 1 Label What did you change? ™ MNotify watchers Preview > Save Cancel
W Hint: type "[" to see a list of suggested pages and insert a link. /A
Page Item Explanation
Page title This name is used in links to the page.
Page Type content for the page here.
content
Editor Provides tools to format and colour content, create lists and tables, indent and align text, and insert other content into the
toolbar page such as symbols, links, images, multimedia files and macros.
Restrictions  View the current page restrictions, and control who can view or edit the page.
Attachments  View, and manage, the attached files on the page.
Labels Add labels to a page, to categorise the page content.
Change Type a comment that describes the changes you have made.
comment
Notify When selected, users who are watching the page will be receive email notification of your changes to the page.
watchers
Preview See how your changes will appear, without saving the page.
Save Save the changes you have made to the page. (Ctrl+S)
Cancel End the editing session, without saving any changes.
The Toolbar

The editor toolbar allows you to:

20
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® Apply paragraph styles and character formatting (such as bold, italics, superscript).

® Choose colour for text.

® Create numbered and bulleted lists.

® Set the indenting and alignment for text and images.

® Create links to other pages, attachments, anchors and external resources.

® Add tables, and add, remove, cut and paste rows and columns, highlight cells, rows and columns, and merge and split cells.
® Insert other content into the page, such as images, multimedia, attachments, symbols and wiki markup.

® Use macros to add other types of content, such as a list of JIRA issues or a table of contents.

Screenshot: The Editor Toolbar

Paragraph B I U N A L= 3= £ = = Splink EHTable dpinsert o ?
Paragraph Strikethrough & Image
Headlng 1 Subseript 9 Link
Heading 2 Superscript 3 Attachment
H d 3 Monospace Q Symboal
eading = ;
@ Emoticol
. Clear Formalting = Emaeer
Heading 4 £3 Wiki Markup
Heading 5 Horlzontal rule
Heading 6 ¥ JIRA Issue
Preformatted [“# Gliffy Diagram
Info
Quote '
= Slalus
Gallery
Tasklist
Table of Contents
& Other Macros

An Editing Session

You start an editing session whenever you:

® create a new page, blog post or page comment
® edit an existing page, blog post or comment (by pressing 'E' on the keyboard, or clicking Edit).

While in an editing session, you can also:
®* Name, or rename, a page or blog post. Note that renaming has effects that you should consider.
® Add a comment describing the changes you made.
® Chose whether or not people watching the page get notified of the change you made
® Add labels to the page.

Confluence automatically saves drafts of your page as you work. If another user begins editing the same page as you, Confluence will
display a message, and will try to merge the changes when you save your page.

Click Cancel (at the bottom of the page) if you want to end the session without saving any changes.
The session ends when you click Save.

When you create a new page you can choose the location where the page should be saved. You can also move a page after it has been
saved, to make it a child page of a different page, or to move it to another space.

o To see changes between different versions of the page, look at the history of the page.

Embedding Content in the Page

Click Insert on the editor toolbar to embed any of the following types of content so that they are displayed on your page:
An image.
A link to another Confluence page or external URL, or a link to an attachment or image.

L]

L]

® An emoticon, symbol or horizontal line.

® A macro. Choose either a specific macro, or Other Macros, from the Insert menu.

Things to Help You Work Faster

Autoformatting

You can type Confluence wiki markup directly into the editor to have Confluence "auto-format" your text on the fly. To learn more, click ? on
the editor toolbar and choose the 'Editor Autoformatting' tab.
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Autocomplete

When editing a page or blog post, you can enter a trigger character to show a list of suggested links, media files or macros to add to your
page. This feature is called 'autocomplete' and provides you with a fast editing solution if you prefer to use key strokes rather than pointing
and clicking with the mouse.

Quick summary of autocomplete:

Type: To see suggested:

[ pages and blog posts
! multimedia files

{ macros

@ mentions
For details, see Using Autocomplete.

Drag-and-Drop

You can drag a file such as an image, video, audio file, Office document or PDF file, directly into the editor. The contents of the file will be
embedded into the page or blog post. Please refer to the following pages for more information:

® Using Drag-and-Drop in Confluence — Using Confluence's drag-and-drop feature, including details about its requirements and
configuration.
® Displaying Images — Embedding images onto a Confluence page or blog post.

®* Embedding Multimedia Content — Embedding videos, audio files and other multimedia files onto a Confluence page or blog post.
® Displaying Office Files in Confluence — Embedding Office and PDF files onto a Confluence page or blog post.

Keyboard Shortcuts

You can view the Keyboard Shortcuts dialog by clicking ? on the toolbar.

Related Topics

Page Layout in View Mode
Working with Tables
Displaying Images

Editing and Removing Links
Linking to Images

Linking to Attachments
Inserting Emoticons and Icons
Inserting Symbols

Take me back to Confluence User's Guide

Working with Text Effects

The Confluence editor supports most text effects available in standard text editing applications.
On this page:

® Applying Paragraph Styles

® Applying Character Formats

® Applying Text Colours
® Related Topics

Applying Paragraph Styles
Choose a paragraph style from the editor toolbar, or click in the paragraph and use one of the keyboard shortcuts Ctrl+(0-8) .

Screenshot: Choosing paragraph styles from the editor toolbar
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Paragraph B I |
Paragraph

Heading 1 !
Heading 2
Heading 3

Heading 4

Heading 5

Heading 6

Preformatted

Quote

Applying Character Formats

To apply a character format, select the text and click one of the editor toolbar buttons, or use a keyboard shortcut. Some formats are
available from the 'More' menu.

Screenshot: Text formatting buttons on the editor toolbar

E I U N "A
Format Shortcut Key
Bold Ctrl+B
Italics Ctrl+l
Underline Ctrl+U

Strikethrotgh  Ctrl+Shift+S

SubSCI’Ipt none
Superscript none
Monospace none

o Choose Clear Formatting from the ‘More' menu to remove all formatting.

Applying Text Colours
To apply colour to text, select the text and click the ‘Colour' button. Choose which colour is applied using the 'More colours' button.

Screenshot: Picking colours from the editor toolbar
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Related Topics

Keyboard Shortcuts

Take me back to Confluence User's Guide

Working with Links

Confluence makes adding links as simple as possible. You can link to content anywhere within the Confluence site or on another web site.
You can add links to the following types of content:

Pages in the same space, in another space, or outside Confluence (i.e. webpages)

Blog posts

Pages that haven't yet been created, but for which you require a placeholder on the current page.
Attachments, such as images and multimedia files

User profiles or personal spaces

You can also link from an image, and use a link to begin composing a new email message.
You create all these kinds of links using the 'Insert Link' dialog that is available in the editor (choose Insert > Link). You can also create links:

® using autocomplete as a shorthand way of creating the most common types of links.
® by copying a link from one page and paste it when editing another page.

You can edit and remove links while editing the page, using the link properties panel.

ﬂ Handy Hints
® Links in Confluence will not break even when you rename pages or move them between spaces on your site. This

only works for page links that use the relative link syntax, for example [Renaming a Page].
® Looking for a link type not shown above? You might find a plugin can help you.

Related Topics

Working with Anchors

Trackback

Linking to Confluence Pages from Outside Confluence
Working with Attachments

Take me back to Confluence User's Guide

Linking to Personal Spaces and User Profiles

This page describes how to add a link to a user's personal space or user profile from within another Confluence page.
You can link to a user's personal space (or user profile) easily if you know their username.

If the user does not have a personal space, then the link will go to their user profile.

Linking to a User's Personal Space using Autocompletion

You can use autocomplete to create a link to a user's personal space in the Confluence site. Trigger autocomplete and start typing their
name.

You can type [ to see a list of suggested links. For details, see Using Autocomplete.


https://plugins.atlassian.com/search/with?q=link&amp;product=confluence
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Linking to a User's Personal Space using the Insert Link Dialog

. While editing the page, place your cursor at the point where you want to create the link, or highlight the text that you want linked.

. Click Link in the toolbar, or press Ctrl+K. See keyboard shortcuts for more information.

. Click the Search tab on the left.

. Start typing the user's name into the search field. Confluence will suggest options as you type.

. Select the user from the autocomplete results.

. Enter link text that will be displayed on the page, if required. If you have not highlighted text in the page, and leave the 'Link Text' text
box empty, the link will display the destination page name or URL.

. Click Insert.

OO WNE

~

Related Topics

User Profile Overview
Setting up your Personal Space
Working with Links

Take me back to Confluence User's Guide

Linking from an Image

This page describes how to create a link from an image on one page to another page or URL. When the user clicks the image, they will be
redirected to the linked page or other resource.

To create a link from an image:

1. Display the image on the page. The image can either be attached to the page or available on another page. See Displaying Images.
2. Create the link by clicking on the image and then clicking Link in the properties panel. Specify the link target using the 'Insert Link'
dialog. See Linking to Pages.

You can edit the link by clicking on the image, when editing the page, and clicking Edit Link in the properties panel.

Screenshot: The properties panel for an image

>

128px - = [ Original  Border  SLink

Related Topics

Using Images

Working with Links
Working with Attachments
Displaying Images

Take a look at some plugins too.
First read the warning on support of third-party plugins.

® ImageMap Plugin
® Other image and visualisation plugins

Take me back to Confluence User's Guide

Using a Link to Create a New Email Message
This page describes how to insert a link that, when clicked, launches the default email client.

/' You can provide your own text to use as the link text instead of the 'mailto’ tag.
To insert a link that creates a new email message:
1. Edit the page on which you want to insert the link.

2. Choose Insert > Link and select the Web Link tab.
3. Enter an email address, such as 'jsmith@non.existent.corp.com'.
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4. Enter your own link text, if required.
5. Click Save.

Related Topics
Working with Links

Take me back to Confluence User's Guide

Linking to Attachments

This page describes how to add a text link pointing to a file attached to your Confluence page. When a reader clicks the link, the file is
displayed in the browser.

@ Quick guide to linking to an attachment

1. Click Link on the editor toolbar.
2. Select one of these options:
® Search —to search for and link to any image or file attached to any page in your Confluence site.
® Recently Viewed - to link to a recently visited page.
® Attachments — to link to an image or file attached to the current Confluence page.
® Web Link — to link to any webpage.

On this page:

® Adding a Link using Autocomplete
® Adding a Link using the Link Browser
® Related Topics

Adding a Link using Autocomplete
You can use autocomplete to add a text link to a file or image attached to any Confluence page.

You can type [ to see a list of suggested links. For details, see Using Autocomplete.

Adding a Link using the Link Browser
The 'link browser" is the ‘'Insert Link' or 'Edit Link' dialog that appears when you click Link in the editor toolbar.
To link to a file or image that is attached to the current page:

1. Edit the page where you want to insert the link.
2. Click Link in the editor toolbar, and then the Attachments tab. You will see a list of all files attached to the page. Now you can do
one of the following:
® Click on the file that you want to link to, if it is already attached to the page.
® Attach a new file to the page by clicking Browse and uploading your file.
3. Enter the Link Text. These are the words that will appear as the hyperlink on the page.
4. Click Insert to add the link.

To link to afile or image that is attached to any Confluence page:

1. Edit the page where you want to insert the link.

Click Link in the editor toolbar, and then the Search tab.

3. Start typing the name of the file or image. Confluence will offer a list of matching file names. If the file does not appear, click Search
to find pages that contain the search text.

. Click the required file in the list or the search results.

. Enter the Link Text. These are the words that will appear as the hyperlink on the page.

. Click Insert to add the link.

N
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Screenshot: The link browser, showing autocomplete in the 'Search' option
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Hint: type "[" in the Editor to see a list of suggested pages and insert a link. Insert Cancel

Related Topics

Linking to Images
Editing and Removing Links

Working with Anchors

The Anchor macro allows you to link to specific parts of a page. Anchor links can be especially useful when navigating between sections of a
long document or when you want to link to a segment of a page and not to the page as a whole.

Anchors are invisible to the reader when the page is rendered.
There are two steps to using an anchor:

1. Create the anchor for the content.
2. Create the link to the anchor.

On this page:

Creating an Anchor
Parameter

Notes

Related Topics

Creating an Anchor

You use the Anchor macro to create an anchor for content that you want to be able to link to.
To add the Anchor macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Parameter

When editing, you can click on the macro placeholder and choose Edit to display the parameters for this macro in the Macro Browser.

Parameters are options that you can set for Confluence macros to control the content or format of the macro output. The table below lists
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parameters for this macro that can be set in the Macro Browser.

Parameter Default Description

Anchor Name None; name must be supplied = This is the name of the anchor that you will link to.

The page Linking to Pages does not exist.

Notes

® |f you are adding an anchor to the site welcome message, it can only be linked to from another page. Internal-only links will not
render.

® Page titles and links to other spaces can be combined with anchors and attachments, but you can't use attachments and anchors in
the same link.

Related Topics

Working with Links

Take me back to the Confluence User's Guide.

Linking to Confluence Pages from Outside Confluence

Sometimes you may want to link to a Confluence page from outside of Confluence, such as from another website or from within an email. In
this case, you should consider using a link to a 'permanent' URL (also called a 'permalink’), in case the name of the Confluence page
changes.

o If you are linking to a page from another page in the same Confluence site, it is better to use an internal wiki link rather than a permalink.
Confluence can keep track of internal links and will let you know if the link is broken, such as when someone removes the linked page. See
Linking to Pages. Internal wiki links are automatically updated if the page is renamed. This only works for page links that use the relative link
syntax, for example [Renaming a Page].

To link to a page's permanent URL:

1. Choose Tools > Link to this Page.
2. Copy the Tiny Link and paste it into your email or external web page. This will create a link to the latest version of your Confluence
page.

Related Topics

Linking to Pages
Working with Links

Take me back to Confluence User's Guide

Trackback

Trackback is a mechanism by which two sites can stay informed each time one site refers to the other by means of trackback 'pings'.

In Confluence, Trackback is enabled by a site administrator from the Administration Console. When Trackback is enabled, any time you link
to an external webpage that supports Trackback Autodiscovery, Confluence will send a Trackback ping to that page to inform it that it has
been linked to.

Confluence pages also support Trackback Autodiscovery, and when Trackback is enabled can receive trackback pings sent by other sites.

To see who has sent a Trackback ping to a Confluence page:

1. Go to the page.
2. Choose Tools > Info to go to the 'Information’ view for the page.

Any Trackback pings the page has received will be listed under the page's Incoming Links

1, Confluence incoming trackback pings only work with referenced pages that are public (anonymously viewable)

See more information about the Information View.
Related Topics
Enabling Trackback

Managing External Referrers
Linking to Pages
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Working with Links

Take me back to Confluence User's Guide

Linking to Blog Posts

You can link to blog posts in similar ways to how you link to pages. Only two methods are described on this page.

You can also use the Blog Posts macro to display a dynamic list of blog posts on your page.

) You must create the blog post first

Linking to a blog post that has not been created yet will not result in a link. Blog posts are very tightly bound to the time at
which they were created, so it makes no sense to link to them before they exist.

Linking to a Blog Post using Autocomplete

0 You need to know the title of the blog post.
You can use autocomplete to create a link to any blog post in the Confluence site, if you know the name of the post you want to link to.

You can type [ to see a list of suggested links. For details, see Using Autocomplete.
Linking to a Blog Post using its URL

o You need to know the absolute path to the blog post.
To create alink to a blog post using the the 'Insert Link' dialog:
. While editing the page, place your cursor at the point where you want to create the link, or highlight the text that you want linked.

. Click Link in the toolbar, or press Ctrl+K. See keyboard shortcuts for more information.
. Click Web Link and enter or paste the absolute path to the blog post into the URL text box.

A WN PR

box empty, the link will display the destination page name or URL.
. Click Insert.

(4]

Related Topics
Working with Blog Posts
Working with Links

Blog Posts Macro

Take me back to Confluence User's Guide

Linking to Images
This page describes how to insert a link on your Confluence page that points to an image. Linking to an image is a way to have text on a
page that, when clicked, takes the user to that image.
@ Quick guide to linking to an image
1. Click Link on the editor toolbar.
2. Select one of these options:

® Search — Search for and link to any image or file attached to any page in your Confluence site.
® Attachments — Link to an image or file attached to the current Confluence page.

The rest of this page gives more details of the above procedure and additional options.

On this page:
® Adding a Link with the Link Browser

® Adding a Link using Autocomplete
® Related Topics

Adding a Link with the Link Browser

To link to an image that is attached to the current page:

. Enter link text that will be displayed on the page if required. If you have not highlighted text in the page, and leave the 'Link Text' text
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. Edit the page where you want to insert the link.

. Click Link on the toolbar.

3. Choose the Attachments tab in the left-hand panel. You will see a list of all files attached to the page. Now you can:
® Select an image that is already attached to the page.
® Attach a new image to the page by clicking Browse and uploading your file.

4. Enter the Link Text. These are the words that will appear as the hyperlink on the page.

5. Click Insert.

N

To link to an image that is attached to any Confluence page:

. Edit the page where you want to insert the link.

. Click Link on the toolbar.

. Select the Search option in the left-hand panel.

Start typing the name of the image. Confluence will suggest image files. If the image does not appear in the list, click Search.
Click the image name in the autocomplete results or the search results.

Click Insert.

NG ARNET

Screenshot: The link browser, showing autocomplete in the 'Search' option
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Hint: type “[" in the Editor to see a list of suggested pages and insert a link. Insert Cancel

Adding a Link using Autocomplete

You can use the autocomplete functionality to link to an image attached to any Confluence page.
You can type [ to see a list of suggested links. For details, see Using Autocomplete.

Related Topics

Linking to Attachments
Editing and Removing Links
Displaying Images

Working with Tables
The Confluence editor provides several table editing features.

Inserting a Table
To create a table:

1. While editing the page, place your cursor at the point where you want to insert the table.
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2. Click Table on the toolbar.
3. Click in a cell to set the number of columns and rows for your table.

Table Operations

While editing a page, the following table operations are available from the toolbar.

Table operation Toolbar button
Insert an empty row above the current one jﬁ:
Insert an empty row below the current one 3
+H3
Remove the current row Uy
X

Cut the current row and copy it to the Clipboard 14

Copy the current row to the Clipboard <=
Paste the row from the Clipboard to the current row JB
Insert an empty column to the left of the current one L’JL”
Insert an empty column to the right of the current one LU:J
Remove the current column ._#
Merge the selected cells Ij:j
Split the selected merged cells 5
Highlight the current row @
Highlight the current column

=
Highlight the current cell @
Remove the table é}

Related Topics

Take me back to the Confluence User's Guide.

Using Images
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Confluence allows you to add images to a page, or a blog post, either individually, or as a gallery that can be viewed as a slide show. All
images on the page are displayed as thumbnails: when you click on an image the full-size image is displayed in a pop-up.

In general, you display an image on a page by either of the following:

® Attach the image to the page first, and then edit the page to choose where the image should appear.
® Insert an image on the page, where the image is attached to another Confluence page, or is available on an external webpage.

You can also add text links to a page that point to an image located elsewhere.
More information about using images in Confluence can be found here:

® Displaying an image on a Confluence page.

® Linking from an image.

® Linking to images.

A Confluence Administrator can set the sizes of thumbnails via the Administration Console. This will also affect the images displayed by the
Gallery macro.

Related Topics

Image File Formats

Thumbnail Settings

Choosing a Profile Picture

Working with Attachments

Embedding PowerPoint Presentations in a Page
Gallery Macro

Take me back to Confluence User's Guide

Displaying Images

An image can be displayed on a Confluence page in the following cases:
® the image is attached to the page.
® the image is attached to another page of the same Confluence site, even if in another space.
® the image is on a remote webpage.

Once the image is displayed on the page, you can:

®* move the image to a new position on the page simply by cutting and pasting.
® click on the image to change how it appears on the page.

You can also link from an image to another page.

On this page:

Displaying an image attached to the page
Displaying an image attached to a different page
Displaying an image from a remote webpage
Controlling the image appearance

Related Topics

Displaying an image attached to the page

There are several methods for attaching image files to a page.
Once you have attached an image to a page, there are different methods for choosing where on the page the image should appear:

Using the 'Insert Image' dialog
Once an image is attached to the page, you can edit the page to choose where the image should appear.
To position an attached image on the page:

1. While editing the page, position the cursor where you want to place the image.

2. Choose Insert > Image and click on the Attached Images tab.
3. Select the required image and click Insert (or just double-click on the image).

Using autocomplete

Once an image is attached to the page, you can use autocomplete while editing the page to choose where the image should appear.
To position an attached image on the page:

1. While editing the page, position the cursor where you want to place the image.
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2. Trigger the autocomplete function by typing "
3. Choose the image from the list that appears.

Using drag-and-drop

Depending on the browser you are using, you can attach and position an image in one step. While you are editing a page, simply
drag-and-drop an image file on to the page. The image is attached to the page and is placed at the current cursor position.

Displaying an image attached to a different page

You can display an image that is attached to a different page of the same Confluence site, as long as you know the name of the image. This
approach can make it easier to manage your images by allowing you to keep them all in the same place.

To display an image attached to a different page:

. While editing the page, position the cursor where you want to place the image.
Choose Insert > Image and click on the Search tab.

. Type in the name of the image.

. Choose whether to search the current space or All Spaces and click Search.
. Select the required image from the search results and click Insert.

I SEAN NI

Alternatively, you can simply cut and paste the image from another page.

Displaying an image from a remote webpage

You can display an image from a remote webpage on your Confluence page, without needing to attach it to your page. You need to know the
URL for the image, not for the webpage it appears on. Note that you should have permission to use that image on your page.

To display an image located on a webpage:

. While editing the page, position the cursor where you want to place the image.

Choose Insert > Image and click on From the Web.

. Type in the URL for the image. An example is: http://www.atlassian.com/software/confluence/images/icon_customerslove_big.png
. Click Preview to check that the URL and image are correct.

. Click Insert.
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Alternatively, you can simply cut and paste the image from a webpage.

Controlling the image appearance

When editing the page, click on the image to show the image properties panel. The panel allows you to set the display size for the image and
choose whether the image has a border. See also Linking from an Image.

To set the size of the image, do one of the following:

® Click on one of the size 'preset' buttons (the image width in pixels is displayed to the left).
® Click on the image size text and enter a new image width, in pixels.

Note that images are displayed as thumbnails.
To add a border to the image:
® Click Border in the image properties panel.
To align an image:
® Select the image and use the alignment buttons in the editor toolbar.

Screenshot: The image properties panel beneath an image
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For further information regarding image appearance see Confluence Wiki Markup.

Related Topics
Using Images

Working with Links
Working with Attachments

Image File Formats

Confluence allows you to attach image files of any format to a page. However, your ability to display them depends on the image file formats

supported by the browser you are using.

Confluence supports the following image formats for its Thumbnail and Gallery macros :

® gif
* jpeg
® png
The bmp format is not supported.
Related Topics
Using Images
Displaying images
Gallery Macro

Take me back to Confluence User's Guide

Using Autocomplete

When using the Confluence editor, you can type a trigger character or press a keyboard shortcut to see a list of suggested links, files or
macros to add to your page, or to mention another user (and automatically notify them of this).

On this page:

Summary of Autocomplete
Using Autocomplete for Links

Using Autocomplete for Macros
Using Autocomplete for Mentions
Cancelling Autocomplete

Enabling and Disabling Autocomplete
Related Topics

Using Autocomplete for Images, Videos, Audio Files and Documents

Summary of Autocomplete

What You Want to Do Trigger
Character
Add a link on your page [

Display an image, video, audio file or !
document on your page

Add a macro on your page {

Notify another user by email that you have @
mentioned them on your page

Using Autocomplete for Links

Keyboard

Shortcut

Ctrl+Shift+K

Ctrl+Shift+M

None

None

Description

See a list of suggested pages or other locations to link to
from your page. More...

See a list of suggested images, multimedia files and
documents to embed in your page. More...

See a list of suggestions as you begin typing a macro
name. More...

See a list of suggested users to mention. More...

Type '[, or press Ctrl+Shift+K, to see a list of suggested pages or other locations to link to from your page. You can link to pages, user

profiles, images, documents and other file attachments.
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To autocomplete a link:

1. Edit the page.
2. Click where you want to insert a link and do one of the following:
® Type [ and then the first few characters of the page title, user's name, image name or file name.
® Type the first few characters of the page title, user's name, image name or file name (or select relevant text) and then press
Ctrl+Shift+K.
3. Click the relevant link from the list of suggestions.

If the item you need is not in the list, either:

® Choose Search for 'xxx' to continue looking for the page within Confluence, or
® Choose Insert Web Link to insert a link to an external web page using the Link Browser.

Screenshot: Autocomplete for a Link
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Using Autocomplete for Images, Videos, Audio Files and Documents

You can use the autocomplete as a fast way of embedding images, videos, audio files and documents into your page. Type an exclamation
mark or press Ctrl+Shift+M to see a list of suggested images, multimedia files and documents to display on your page. You can use
autocomplete to embed the following file types:

® Images — any format that Confluence supports. See Image File Formats.

® Videos, audio files and all multimedia formats that Confluence supports. See Embedding Multimedia Content.
L]

L]

Office documents supported by the Confluence Office Connector: Word, Excel and PowerPoint.
PDF files.

o Autocomplete works most efficiently for files that are already attached to the Confluence page. See Attaching Files to a Page.
To embed an image, video, audio file or document:

1. Edit the page.
2. Click where you want to insert the image, video, audio file or document and do one of the following:
® Type '!" and then the first few characters of the image, file or document name.
® Type the first few characters of the name of the image, file or document (or select relevant text) and then press
Ctrl+Shift+M.
3. Choose the relevant file from the list of suggestions.

If the item you need is not in the list, either:
® Choose Open Image Browser to find images and documents using the Image Browser, or
® Choose Insert Other Media to embed videos, audio and other multimedia files using the Macro Browser. Insert the
'‘Multimedia' macro to display your multimedia file.

Screenshot: Autocomplete for an Image or Document

35



Confluence 4.0 Documentation

Rich Text V arkup  Preview Draft saved at 12:56 PM {view change) [ Save l [ Cancel

Paragraph -B I U=A-|H

= i= | 9 | Insert~ == |

Today's meeting was extremely productive, due in no small part to the chocolate on the table.

Here are the meeting notes: | mee
Image suggestions

mockup_Meetings - Add Meeting.png
MeetingPlannerDirectory2009.doc
meetingjpg

meeting,jpag

Meerman.jpg

Meeting Room JPG

3F - meeting.jpo

Open Image Browser

Using Autocomplete for Macros

Type '{' to see a list of suggested macros to add to your page.

Autocomplete provides access to all available macros in your Confluence site, including any user macros that your administrator has added
and made visible to all.

0 You need to know the name of macro. Autocomplete for macros will only match the name of the macro, not the description.
To autocomplete a macro using ‘{":

. Edit the page.

. Click where you want to insert the macro.

Type '{' and then the first few characters of the macro name.

. Choose the relevant macro from the list of suggestions.

. Configure the macro as described in Working with the Macro Browser.

abwN R

If the macro you need is not in the list, select Open Macro Browser in the list of suggestions to continue looking for the macro in the Macro
Browser.

Screenshot: Autocomplete for a Macro

Rich Text arkup  Preview Draft saved at 4:16 PM [ Save ] [ Cancel ]
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Today's meeting was extremely productive, due in no small part to the chocolate on the table.

Here are the meeting notes: { blog|
Macro suggestions

Blog Fosts

Blog posts report
Most blog comments
Most blog posts

Most commented blogs

[T Ny Ly W W

Open Macro Browser

Using Autocomplete for Mentions
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You can use autocomplete to automatically notify another Confluence user that you have mentioned them in a page, blog post, comment or
status update.

Type '@' to see a list of suggested users to mention. When you save the page, an email is automatically sent to the user to notify them that
they have been mentioned on that page (if they have permission to view the page or blog post). This works for new and updated pages, blog
posts, comment and status updates.

o You need to know the user's real name — autocomplete for mentions suggests users' full names only, not their usernames.
To autocomplete a mention using '@":

1. Edit the page.

2. Click where you want to insert a mention and type ‘@' and then the first few characters of the user's real name.

3. Choose the user's name from the list of suggestions.

Screenshot: Autocomplete for mentions

@ edvi

User suggestions

edwin

Edwin

edwin
aedward. bagdonas
edward

Edwin Mens
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Cancelling Autocomplete

The autocomplete starts automatically when you press the trigger characters. You may want to close the autocomplete menu or escape from
autocomplete once it has started.

There are a few different ways to stop the autocomplete once it has started:

® Press the escape key, 'Esc', on your keyboard.

® Click somewhere else in the editor panel.

® Press an arrow key to move out of the autocomplete area.

® For the link autocomplete only: enter a right-hand square bracket, like this: ]

Enabling and Disabling Autocomplete

You can turn off the triggering of autocomplete by the '[' and "' characters. This will prevent the autocomplete from starting automatically
when you press one of the trigger characters. You can also turn it back on again.

Notes:

® This setting does not affect the keyboard shortcuts for autocomplete (Ctrl+Shift+K and Ctrl+Shift+M). Even if the trigger characters
are disabled, you can still use the keyboard shortcuts for autocomplete.

® This setting affects only you. Other people using Confluence can enable or disable the setting on their user profiles independently.

® Note that autocomplete is enabled by default.

To enable or disable the autocomplete trigger characters:

. Go to your name (the ‘User' menu) at the top of the page and choose Settings.
. Choose Editor under 'Your Settings' in the left-hand panel.
. Click Edit.
. Either:
® Disable autocompletion by selecting Disable Autocomplete.
® Enable autocompletion by clearing Disable Autocomplete.
5. Click Submit.

A WNPE

Screenshot: User Settings for the Editor
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Profile § Metwork | Status Updates || Labels | Watches ] Drafts JRElgall m

Gadgets

Editor Settings
View OAuth Access Tokens
Disable Autocomplete
Your Settings Disable Autocomplete in the Editor, where it allows links to be inserted with the
trigger [, images with the trigger ! and user mentions with the trigger @.
General
Email Disable Autoformatting
Editor Disable Autoformatting in the Editor, where it allows wiki-formatted text to be

converted to its Rich Text equivalent (e.g. "h1. title” for a heading).

Edit )

| —

Related Topics
Working with Links
Using Images
Working with Macros
Keyboard Shortcuts
User Profile Overview

Take me back to the Confluence User's Guide.

Using Special Characters

There are different kinds of special characters that you can add to Confluence content (pages, blog posts, comments):
Symbols

Symbols are special characters such as © and ™.

To insert a symbol, choose Insert > Symbol, and click on the required symbol.
Emoticons and Icons

Emoticons and icons are special characters such as = and .

To insert an emoticon or icon, simply type the character combination for it.
Related Topics

How to Disable Emoticons

Take me back to Confluence User's Guide

Inserting Emoticons and Icons

Adding Emoticons
There are two ways to add an emoticon, or smiley, to your Confluence page.
By choosing an emoticon from those available:

1. Choose Insert > Emoticon when editing, to display the available emoticons.
2. Click on an emoticon to insert it.

By typing a character combination:

You can insert emoticons by typing commonly-used character combinations. For example, the following code appears as an emoticon when
the page is rendered.

This example creates this emoticon: =

The emoticons (and other icons) available in Confluence, and the character combinations that create them, are shown in this table:
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Preventing Emoticons from Appearing
To prevent Confluence from turning parts of text into emoticons, 'escape’ the character sequence by inserting a '\' character.
For example, this character sequence contains an emoticon:
(-example_here;)
This example appears as: (-example_here'='.
To 'escape’ the emoticon sequence, insert a slash as in the following example:

..............................................................................................................................................................................

The characters will then appear exactly as typed.

Related Topics

Displaying Images
How to Disable Emoticons

Take me back to Confluence User's Guide

Inserting Symbols

There are various symbols, or special characters, that you can add to your Confluence page.
To insert a symbol:

1. Choose Insert > Symbol. This will display the ‘Insert Custom Character' window.
2. Click on the required symbol to insert it.

Screenshot : Custom Characters

= Insert Custom Character - Windows Internet Explorer

Insert Custom Character
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Related Topics
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Inserting Emoticons and Icons

Take me back to the Confluence User's Guide.

Working with the Macro Browser

The Macro Browser allows you to browse through Confluence's extensive range of macros and to preview them before adding them to your
page.

The Macro Browser provides access to all available macros in your Confluence site, including any user macros and plugins that your
administrator has added and made visible to all.

On this page:

® Accessing the Macro Browser
® Finding a Macro
® Browsing by Category
® Searching
® Adding a Macro to a Page or Blog Post
® Editing a Macro
® Macro Browser Smart Fields
® Macro Placeholders
® Related Topics

Accessing the Macro Browser

You can access the Macro Browser whenever you edit a page, blog post or comment.
To access the Macro Browser:
1. Log in to Confluence, if you have not already done so.
2. Edit a page or blog post.
3. Click where you want to insert the macro.
4. Either choose Insert > Other Macros, or type '{' and choose Open Macro Browser.

Each macro is represented in the Macro Browser by its icon, its name and a brief description of its function.

Screenshot: Macro Browser

Select Macro Search
.Y
Creates an anchor inside the Creates a list of attachments
Administration page, which can be hyperlinked. belonging to this page.
Communication
Confluence Content Blog Posts Bookmarks
Development Lists the most recent news items Includes alist of bookmarks on a
12 in the space. Confluence page.
External Content
Formatting
Navigation Change H_|story . c.hart .
Shows the history of version Displays a chart using data from
Reporting comments for the current page or the supplied table or tables.
news item. I
Visuals & Images
Cheese _D‘i Children Display
Insersthetext 'I like Lists a page’s children and their
cheese!", used fortesting macro descendant pages.
functionality. D D D
.......... Code Block Colour Text 2
Cancel

Finding a Macro

The Macro Browser provides two methods for finding a macro:

® Browsing by category
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® Searching
You can also simply type '{’ to see a list of suggested macros. For more details, see Using Autocomplete.
Browsing by Category
Each macro is assigned to one or more categories. Click a category name to see the macros in that category.

Screenshot: Macro Browser List Restricted by Category

Al Edit in Word Link e ® s JIRA Issues
Display an Edit in Word icon on . *  Displays alist ofissues from a
Administration your page. JIRA site on your Confluence
page.
Communication
Confluence Content JIRA Portlet RSS Feed
_ e Displays a JIRA dashboard portlet Embeds an RSS feed on a page
Development x on your Confluence page. h and displays the contents of
external or internal Confluence
External Content
feeds.
Formatting . .
Tasklist Widget Connector
Navigation Displays a modifiable task list. Embed multi-media content from
other web sites into your
Reporting Confluence page.
Visuals & Images

Searching

Enter a word or words into the search field at the top of the Macro Browser. As you start typing, the macro list is filtered to show only those
macros whose name or description matches the characters you have entered.

Screenshot: Macro Browser List Restricted by Word Search

l offic| I
Excel Pawerpaint
' Embeds an @m Excel document .' Embeds an m Powerpoint
,' '-’: (x5} into your Confluence page. .n'.‘_ document (ppt) into your
Yo & bl Confluence page.

o Ward
r-_l Embeds an(Qfge Word document

o= (.doc)into your Confluence page.

Adding a Macro to a Page or Blog Post

When you choose a macro and add it to a page or blog post, you may need to configure the macro's parameters.
To choose and configure a macro:

1. Access the Macro Browser and browse to the required macro as described above, if you have not already done so.

2. Click the required macro to choose it. The Macro Browser window changes to the 'Edit Macro' mode with a preview pane on the left
and parameter pane on the right.

3. If necessary, modify the macro's parameters in the parameter pane. Some parameters allow auto-completion.

4. Click Refresh to preview the effect of your changes to the macro's parameters.

Any parameters marked by an asterisk (*) are mandatory and must be set before you can preview or insert the macro.
5. Click Insert to add the macro to the page or blog post.
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1. Not all macros can be previewed in the Macro Browser. This is often the case with macros that require the page to be
saved first to render correctly, such as the Table of Contents Macro, or macros that do not generate output, such as the
Anchor Macro. Nevertheless, you can still use the Macro Browser to browse for these macros and set their specific
parameters before inserting them into your page.

Editing a Macro
You can edit a macro that has already been added to a page or blog post, modifying the parameter data and previewing the changes.
To edit a macro:

. Edit the page or blog post containing the macro you wish to edit.

. Click on the macro placeholder and choose Edit.

. Modify the macro's parameters in the parameter pane. Some parameters allow auto-completion.
. Click Refresh to preview the effect of your changes to the macro's parameters.

o Any parameters marked by an asterisk (*) are mandatory and must be set before you can preview or insert the macro.
5. Click Save in the Macro Browser to save your changes.

A WOWN PR

ﬂ To leave the Macro Browser at any time, click its Cancel button or simply press the 'ESC' key.

Screenshot: Editing an Existing Macro with the Macro Browser in 'Macro Preview' Mode

Edit ‘Chart’ Macro
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Display Orientation
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Boots ( $2,062 ) ———— Stacked Values
O

Shows stacked values for bar and area chars.

Show in 3D
O

Width (pixel value only)
500 |

Gancs

Macro Browser Smart Fields

If a macro's parameter requires the entry of a single username, space key or page title, the macro browser provides an ‘auto-complete’
feature to help you enter the correct value. Use the up- and down-arrows on your keyboard to move up and down the dropdown list of
matching items and select the appropriate item. This feature functions similarly to the Quick Navigation Aid when searching Confluence
pages.

Screenshot: Macro Browser Smart Fields
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Macro Placeholders

Macro placeholders are displayed in the editor where you have added a macro to the page.

When editing a page, you can:

® Double-click a macro placeholder to open the Macro Browser (or click on the placeholder and choose Edit), where you can edit the
macro's parameters.

® Select a macro placeholder to cut, copy and paste the macro.

Related Topics
Working with Macros

Take me back to the Confluence User's Guide.

Inserting JIRA Issues

If your Confluence site is connected to a JIRA site using an application link, you can easily insert individual issues from this JIRA site directly
into text on your Confluence page using the 'Insert JIRA Issue' dialog. Each issue inserted onto the page is linked to the issue in JIRA itself.

Using the 'Insert JIRA Issue' dialog, you can also:

® Create a new issue on the JIRA site and insert the issue onto your page.
® |nsert a table of JIRA issues onto your page based on the results of a search (using JIRA Query Language (JQL) syntax).

o If your Confluence site is not connected to any JIRA site via an application link, this feature will not be available. However, you can still
list JIRA issues on a page or blog post using the JIRA issues macro.

On this page:
® Inserting a JIRA Issue from a List of Recently Viewed Issues
® Creating a New JIRA Issue and Inserting it
® Searching for JIRA Issues and Inserting them
®* Notes
® Related Topics

@ Quick guide to inserting JIRA issues

® Choose Insert > JIRA Issuefrom the editor toolbar.
® Toinsert a single issue, use either:
® Recently Viewed — Insert an issue onto your page from a list of issues you have recently viewed
on the JIRA server.
® Create New Issue — Create a new issue on the JIRA server and insert it into your page.
® Search — Use JQL syntax to narrow down a list of issues, from which you can select one to
insert onto a page.
® Toinsert a table of issues:
® Click Search on the 'Insert JIRA Issues' dialog, use JQL syntax to narrow down a list of issues
and choose to insert the list onto a page.

o If Confluence is connected to more than one JIRA server, ensure that you choose the appropriate JIRA server before
using this dialog to select, create or search for issues.
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Inserting a JIRA Issue from a List of Recently Viewed Issues

To insert a JIRA issue onto a page from a list of recently viewed issues on a JIRA site:
1. Choose Insert > JIRA Issue from the editor toolbar.
2. Go to the Recently Viewed tab of the 'Insert JIRA Issue' dialog.

3. If necessary, select a JIRA server from the Server list. See the notes below regarding OAuth outgoing authentication.
4. Select an issue from your list of recently viewed JIRA issues on the JIRA site. The number of items in the list is defined in JIRA.

Creating a New JIRA Issue and Inserting it

o This feature works best with JIRA issue types whose mandatory field requirements have not been altered. With the exception of a JIRA
issue's 'Component/s' or 'Fix Version/s' fields, you cannot use this dialog to add an issue whose issue type has customised mandatory field

requirements upon issue creation.

To create a new JIRA issue on a JIRA site and insert this issue onto a page:

1. Go tothe Create New Issue tab of the 'Insert JIRA Issue' dialog.
2. Complete the dialog:

Setting Description

Server The available JIRA servers. See the notes below regarding OAuth outgoing authentication.
Project The project on the selected JIRA server to which the new issue will be added.

Issue Type The type of issue to log in this project.

Summary A one-line summary for the issue.

Component/s  Choose one or more components which apply to this issue.
Version/s Choose one or more versions in which the issue will be addressed.
Description A more detailed description about the issue.

o Some of these fields may not be visible if they have been customised in your JIRA project.

3. Click Insert to create the JIRA issue and insert it onto the page.

Searching for JIRA Issues and Inserting them

To search a JIRA site for a subset of issues matching a JQL query and insert one or more of these issues:

1. Choose Insert > JIRA Issue from the editor toolbar.
2. Go to the Search tab of the 'Insert JIRA Issue' dialog.
3. Enter a JQL query.
4. If necessary, select the JIRA server whose issues you want to insert.
5. Click Searchto find the issues on the JIRA server which match your JQL query. The first 20 issues retrieved by your JQL query are
displayed.
® Toinsert a single issue, select the issue from your list and click Insert.
® To insert the full list of issues, select the Insert all query results as a table check box before clicking Insert.
Notes

The issues from a JIRA site which you can access in the 'Insert JIRA Issues' dialog depends on the application link's outgoing authentication
used by Confluence to communicate with that JIRA site. While you can always access publicly visible issues:

® |f "Trusted Applications' outgoing authentication is used — you can also view issues restricted to an account on JIRA whose user
name matches your user name in Confluence.

® |f 'OAuth' outgoing authentication is used, you may need to click Login & Approve at this point to gain access to the JIRA server
and restricted issues. You can also view issues restricted to the user account that you 'Login & Approve' (to the JIRA site) on the

'Insert JIRA Issues' dialog.
® |f 'Basic Access' outgoing authentication is used — you can also view issues restricted to the user account configured for the JIRA

site's 'outgoing authentication'.

Related Topics
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JIRA Issues Macro

Working with Drafts

A draft is a 'snapshot' of unsaved page content, which Confluence creates automatically at regular intervals while you are editing a page or

blog post. This can minimise the loss of work if your Confluence site experiences a problem, since you can retrieve the page content from
your last saved draft.

On this page:

How are drafts implemented in Confluence?
Viewing Unsaved Changes

Viewing Drafts

Related Topics

How are drafts implemented in Confluence?

At regular intervals, Confluence automatically saves a draft of the page you are editing. If a network failure or system error prevents you from
saving your page, you can retrieve its last saved draft and continue working on the page from (or almost from) where you left off.

® Drafts are created while you are adding and editing a page or blog post. Each new draft replaces the previously saved draft.
® Each time Confluence saves a draft, it displays a message and the time of the last save near the Save button on the edit screen.

Screenshot: Message displaying the time when the draft was last saved

Draft saved at 11:14 AM (view change) [ Save ] [ Cancel ]

Whenever you edit a page and click one of the other page tabs, Confluence will automatically save a draft. When you click on the 'Edit' tab
again, Confluence will let you know that a version of the page you are editing was not saved and will give you the option to resume editing it.

® By default, Confluence saves a draft of your page once every thirty seconds. However, a Confluence administrator can configure
how often drafts are saved.

Drafts Possess the Following Characteristics

® A user only has access to the drafts of pages they have been working on and whose content has not yet been saved.
® A user cannot create a draft explicitly.

® A user's drafts are listed in the 'Drafts' tab of their profile.

® Once a user has resumed editing a draft, or chosen to discard it, it is removed from their drafts tab.

Viewing Unsaved Changes

While editing a page or blog post, you can view any ‘unsaved' changes you have made since the last automatically saved draft, by clicking
view change (near the Save button).

Screenshot: Segment of the Unpublished Changes Window

Unpublished Changes for 'Working with Drafts Overview'

Key

This was removed. This word was added.
This line was added.
A draft is a snapshot version of a page which Confluence saves automatically at regular
intervals while you are editing the page. Confluence saves these interim versions even if you

do not save the page yourself. This is a useful feature that minimises loss of work if your
Confluence site experiences a problem.

At regular intervals, Confluence will automatically save the page you are editing and maintain
a copy of it as a draft. If some system failure or error prevents you from saving your changes,
you can retrieve the draft and continue working on it.

* Drafts are created while you are adding and editing a page or blog post.
Wi
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Viewing Drafts
Your drafts are listed on the Drafts tab of your user profile.
To see your drafts:

Go to your name (the 'User' menu) at the top of the page and choose Drafts.

Related Topics

Resuming the Editing of a Draft
Configuring the Time Interval at which Drafts are Saved
Concurrent Editing and Merging Changes

Take me back to the Confluence Documentation Home page.

Configuring the Time Interval at which Drafts are Saved

By default, Confluence saves a draft of your page once every thirty seconds. However, as described below, a Confluence administrator can
configure how often drafts are saved.

As a Confluence administrator, you can set the time interval at which drafts are saved as follows:
1. Go to the Confluence 'Administration Console'":
® Choose Browse > Confluence Admin. The 'Administrator Access' login screen will be displayed.
® Enter your password and click Confirm. You will be temporarily logged into a secure session to access the 'Administration
Console'.
2. Click General Configuration in the left-hand panel.
3. Edit the setting for Draft Save Interval.
Related Topics

Working with Drafts
Resuming the Editing of a Draft

Concurrent Editing and Merging Changes

Sometimes, two or more people may edit a page at the same time. When this happens, Confluence will do its best to ensure that nobody's
changes are lost.

How will I know if someone else is editing the same page as | am?

If another user is editing the same page as you, Confluence will display a message above your edit screen letting you know who the other
user is and when the last edit was made.

Screenshot: Notification of Simultaneous Page Editing

! This page is being edited by Widya Madabushi (last edit lesz than a minute 200

What happens if two of us are editing the same page and the other user saves before | do?

If someone else has saved the page before you, when you click 'Save', Confluence will check if there are any conflicts between your changes
and theirs. If there are no conflicting changes, Confluence will merge both the edits successfully. If there are any conflicts, Confluence will
display them for you and give you the option to either '‘Overwrite' the other user's changes, '‘Merge your changes' manually, or '‘Discard'
them.

Screenshot: Notification of Page Editing Conflict

The following error(s) ocourred:
» Tou were editing an outdated version of this page. &nother user has updated this page before you. vour changes
against the now updated version is shown below, Please decide whether your changes should overwrite it or you
wish to discard your changes,

Example Scenario

For example, Alice and Bob both edit the same page at the same time.

If Alice clicks save before Bob, Bob is now effectively editing an out-of-date version of the page. When Bob clicks save, Confluence will
examine his changes to see if any overlap with Alice's. If the changes do not overlap (i.e. Alice and Bob edited different parts of the page),

Bob's changes will be merged with Alice's automatically.

If Bob's changes overlap with Alice's, Confluence will display an error message to Bob showing where Alice has changed the page, and
giving Bob the options to overwrite Alice's changes with his own, to re-edit the document to incorporate Alice's work, or to cancel his own
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changes entirely.

Related Topics

Page History and Page Comparison Views
Viewing Page Information

Working with Drafts

Take me back to Confluence User's Guide.

Resuming the Editing of a Draft

If you have typed some content into a Confluence page or blog post, Confluence will save a draft of it, even if you were not able to
successfully save the page or blog post, or add a title to it.

There are two ways to resume editing an unsaved page or blog post:
A. Using your drafts view. To resume editing a draft from this view:
1. Goto your name (the 'User' menu) at the top of the page and choose Drafts.

2. Click Resume Editing next to the appropriate draft to resume editing that draft.

0 If you had not yet entered a page title, the draft will be listed with the title 'Untitled'.
B. If you had created a new page or blog post but did not save it, then when you next add a page or blog post in that space, Confluence will
ask you if you want to resume editing the page that was not saved. If you click resume editing, the draft and its unsaved content will be
restored, allowing you to continue editing it.

Screenshot: Resume Editing

©®  Aversion of this page you were editing at Nov 17, 2009 10:47 was not saved. Do you want to view the change, resume editing or discard it?

What happens if | am editing the draft of a page that has since been updated?

When this happens, Confluence will display a message informing you that you are editing an outdated page. If there are no conflicts between
the two versions, Confluence will give you the option to Merge and Resume editing.

If there are any conflicts, Confluence will give you the option to View the Conflict or to Discard your changes.

Screenshot: Editing Conflict in Draft

'ﬂ A wersion of this page vou were editing at Dec 19, 2005 09:39 was not saved. The page has since been
updated. The changes made conflict with your changes and cannot be merged, Do you want to view the
conflict or discard your changes?

Related Topics

Working with Drafts

Recording Change Comments

A 'change comment' is a short description that summarises the changes made to a page during an editing session. Change comments are a
useful way of keeping track of the history of a page.

A change comment is not the same as a comment added to a page. Refer to Working with Comments for information about that type of
comment.

Note that once a change comment has been added and the page has been saved, it is not possible to update or remove the change
comment.

On this page:

® Entering a Change Comment

® Viewing a Change Comment

® Viewing a History of Change Comments
® Related Topics

Entering a Change Comment

You can enter change comments in the field located below the edit screen:

Screenshot: Entering change comments
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What did you change?

Viewing a Change Comment

Once a comment has been added, it becomes visible in the view mode of the page, so that users are aware of the most recent changes
made to a page. If a comment has been recorded, you will see a show comment link below the page title. Click the link to view the
comment.

Screenshot: The 'show comment' link

X) Sample page

&1 Added by Administrator, last edited by Administrator on Mar 02, 2011 (view change) show comment

The hide comment link allows you to hide the comment again, so that it does not distract you from the content of the page.

Screenshot: The 'hide comment' link

x, Sample page

&1 Added by Administrator, last edited by Administrator on Mar 02, 2011 (view change) hide comment

Comment: Added the cheese macro.

Viewing a History of Change Comments
The change comments for a page are recorded under the 'Recent Changes' section of the page's 'Info' view and in the page's 'History' view.

Screenshot: History of change comments on Info view

Recent Changes

Since you last logged in:
Administrator made 4 changes. iew)

Time Editor

Mar 02, 2011 17:15 Administrator view changes

Added the cheese macro.

Mar 02, 2011 17:15 Administrator view changes
Mar 02, 2011 17:04 Administrator view changes
Mar 02, 2011 17:04 Administrator view changes

Screenshot: History of change comments on History view

Version Date Changed By Operations
[[] CURRENT (v.12) Mar 02, 2011 17:15 Administrator:
Added the cheese macro.
0 vn Mar 02, 2011 17:15 Administrator Restore this version
B w10 Mar 02, 2011 17:04 Administrator Restore this version

Related Topics

Viewing Page Information
Page History and Page Comparison Views

Take me back to Confluence User's Guide
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Creating a Page
The usual ways to create a page are described below.
Once you create a page, you can:

® add content to it using the editor
® set the page's location in the Confluence site, before you save the page.

You can always move the page to a different location in the page tree, or to a different space, after you have saved the page.

You may like to read about writing blog posts.

ﬂ Permissions

To create a page, you need the 'Create Pages' permission for that space, which is assigned by a space administrator from
the Space Administration screens. See space permissions or contact a space administrator for more information.

On this page:

Add a page from the dashboard

Add a page from any page in a space

Add a page using an undefined link

Notes about Page names

Setting Page Location

Importing an Office Document into One or More Confluence Pages
Related Topics

Add a page from the dashboard

You can quickly add a page from the dashboard without having to browse to a specific space. Confluence adds the new page at the root of
the space.

To add a new page from the dashboard:
1. Click Add Page at the top right of the dashboard.
2. Select the space where you want to add the page and choose a template on which to base the page content. For more details about
using a template, see Creating a Page using a Template.
3. Click Next. Confluence opens the page in 'Edit' mode.

Screenshot: Add Page dialog on the Confluence dashboard

SLSEEEERTI [E] Add Blog Post

Space

My Technical Documentation -
Template

Start with a blank page -

Learn more about templates

Cancel

Add a page from any page in a space
By default, Confluence adds the new page as a child page of the current page.
To add a new page:

1. Go to any page in the space.
2. Choose Add > Page.
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Note that you will only see the Add Page link if you have permission to create pages for the space.
You can also create a page using a template.

ﬁ Pages with large amounts of text content
One user reported having problems saving a page that contained approximately 700 kilobytes (700,000 characters) or
more of text content. Refer to CONF-16467 for more information. Some browsers appear to be more susceptible to this

issue than others. While it is highly unlikely that your page content will ever reach this size, if you work with large pages,
structuring your content into separate pages will help to avoid this issue.

Add a page using an undefined link

You may want to insert a link pointing to a Confluence page that does not yet exist, but which you intend to create later. This type of link is
called an undefined link.

To add an undefined link for later creation of a page:
1. Edit the page in which the link should appear.
2. Type T to trigger autocomplete, and type the name of the undefined page.

3. Choose Insert Link to Create Page.

When you save the page, Confluence colours the undefined link red. When someone clicks on the link, the new page is opened in 'Edit'
mode. You can then enter the page name, add content and save the page, as usual.

Notes about Page names

® Confluence does not accept the following characters in the title of a page:

S T U I 7 2 D I (P S

® A page must not start with the following characters:

$/ eh

® Page names must be unique within a space.
We are aware that this is a limitation, and there's a feature request at CONF-5926. If you like, you can vote for this feature and add
yourself as a watcher for future updates. You can also vote for the improvement request CONF-9458 to remove the restrictions on

characters.

Setting Page Location
While you are editing a new page you can set the page's location to any space of your Confluence site.
To set the location for a new page:

1. While editing the page, click Location.
2. Use the tabs on the left of the 'Set Page Location' dialog to help you find the new space and parent page for your page, that is, the
location where you want to move your page. The 'Current location' and 'New location' breadcrumb trails at the bottom of the dialog

indicate the current parent page and new parent page.
3. If you want to move a page to a different position amongst the child pages, select Reorder to see a list of sibling pages when you

click Move.
4. Click Move.
5. If you are reordering the child pages, click in the list to set the new position for the page and click Reorder.
See also Moving a Page.

Screenshot: Setting page location for a new page
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Set Page Location Help

Specify the new parent page for this page and its children by space and title.

Search

Recently Viewed New space: ) confluence

Browse New parent page: [Z] Confluence - JIRA Linking

Current location:  Paul Watson * Home

New location: Confluence » Confluence - JIRA Linking

—
] Reorder Move | Cancel

Importing an Office Document into One or More Confluence Pages

The Office Connector allows you to import a Word document into Confluence, optionally creating one or more new pages. See Importing an
Office Document into Confluence.

Related Topics

Creating a Page using a Template
Working with Drafts

Linking Pages

Page Restrictions

Working with the Office Connector
Moving a Page

Take me back to Confluence User's Guide

Adding Blog Posts

To add a blog post for a space, you require 'Create Blog' permission which is assigned by a space administrator. See Space permissions or
contact a space administrator for more information.

On this page:

® From the Dashboard
® From Any Page

* Notes

® Related Topics

From the Dashboard

You can add a blog post to any space from the Dashboard, without having to browse to that space.
To add a blog post from the Dashboard:

. Click Add Blog Post at the top right of the Dashboard.

. Select the space where you want to add the blog post.

. Click Next. Confluence will open the Add Blog Post screen in edit mode.
. Type your content as you would for any other page in Confluence.

A WNBE
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5. Preview and click Save when you are finished.

From Any Page

You can add a blog post from any page (other than the Dashboard) in the space.

To add a blog post from any page:

1. Click Add near the top right of the page and choose Blog Post. Confluence will open the Add Blog Post screen in edit mode.
2. Type your content as you would for any other page in Confluence.
3. Preview and click Save when you are finished.

Notes

® Add labels if you want to categorise information this way.

® If you want to backdate your blog post, edit the date in Posting Date. You cannot set a date after today's. Also, you can only set the
date when creating the blog post, not when editing it.

® You can view the blog for the current space by opening the Browse menu and selecting Blog. Your blog post should be listed.
Related Topics

Creating a Page
Working with Blog Posts
Editing Blog Posts
Linking to Blog Posts
Deleting Blog Posts

Take me back to Confluence User's Guide

Working with Templates

When you add a new page, you do not have to write the content from scratch. Instead, you can base your new page on a template. A
template is a Confluence page with predefined content.

Some examples of where templates are useful:

® A software development project may have a template for use cases.
® A systems administration space may have a template for defining what information is kept about each server.

On this page:

Global Templates and Space Templates
Creating a Template

Using a Template

Useful Plugins

Related Topics

Global Templates and Space Templates

In Confluence, there are two places to store your templates:
® Global templates: These are defined by site administrators through the Administration Console and are available in every space.
® Space templates: These are defined by space administrators on the space administration screens, and are only available in the
space in which they are defined.

Site administrators can also import predefined templates.

Creating a Template

You need to be a space administrator to create a space template.

You can write your template using Confluence wiki markup. You can also use special form markup if you wish to define form fields that the
author will complete when adding the page.

See Adding a Template for further information about creating a space template.
See Global Templates for information about creating a global template.

Screenshot: Template variables available when adding a template
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Step 2: Fill in template variables

Choose valuss for the variables in this ternplate, These values will be sutormatically inserted into the tamplate for you in the correct locations.

This is a templabe about (Thirg)
Mame [Hame)
Phone Number [FhaneHumber)
Date of Birth (CrR)
| == Back | | Insert Variables |

Using a Template

Templates are only used when adding a page. Once a page has been created, the template is no longer linked to the page. All further editing
is performed as if the template was never used. Some plugins provide expanded functionality.

See Creating a Page using a Template for further information about using a space template.

Useful Plugins

Before installing a plugin into your Confluence site, please check the plugin's information page to see whether it is supported by Atlassian, by
another vendor, or not at all. See our guidelines on plugin support.

Two popular plugins provide extended template functionality:

® Zones plugin.
¢ Scaffolding plugin.

Below is a comparison:

Field Default Zones Plugin  Scaffolding Plugin
Description Basic Flexible Powerful
Saves page version history

Allows return to form version

(X
Suitable for dynamic data B3 %]
Has a library of examples ﬁ ﬁ

Related Topics

Adding a Template

Form Field Markup for Templates
Global Templates

Importing Templates

Creating a Page using a Template

Take me back to the Confluence User's Guide.

Adding a Template

You need to be a space administrator to create a space template.
To add a template for a space:

1. a. From any page in the space, choose Browse > Advanced.
b. Click Templates in the left-hand panel.
c. Click Add New Space Template.
2. The 'Create Template' screen will appear. Enter a name for your template in the Name text field and an optional description in the
Description text field.
3. Using regular Confluence wiki markup and form field markup (if you are using forms), enter content in the text-entry box as you


https://www.wiki.ed.ac.uk/display/CONF25/Zones+plugin
https://plugins.atlassian.com/plugin/details/190
https://www.wiki.ed.ac.uk/display/CONF25/Zones+plugin
https://plugins.atlassian.com/plugin/details/190
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would in any other Confluence page. See the screenshot below.
4. Click Edit next to 'Labels' if you want to use labels to categorise information. Add your labels. These labels will be included in all
pages created using this template.
5. Preview and click Save. Your template will be added to the list of space templates.
To view the space templates, choose Browse > Advanced > Templates.

Screenshot: creating a Confluence page template

% Preview & Edit Template

Preview start
Customer Order Form

Product Quantity Price Total

fl At I s i ) =
(Produect) (Qty) {Price) {Total)

Hame Description
Order Form Form for customer orders

h3. Customer Order Form

|| Product || Quantity || Price || Total ||
| @Product@® | @Qty@ | @Price@ | @Total@ |

Related Topics

Creating a Page using a Template
Working with Templates

Editing a template

Removing a Template

Browsing a space

Working with Pages

Working with Labels

Take me back to Confluence User's Guide

Creating a Page using a Template

Confluence allows you to create a page based on a global template (available to all spaces) or a space template (available only to that
space). This page is intended for users who have already created a template.

@ Labels are copied from the template

If the template contains labels, the template labels will automatically be included in the new page created from that
template.

To create a page using an existing template:

1. Do either of the following:
® At the top of the Dashboard, click Add Page. Choose the space that contains the template you want to use.
® At the top of any other page, choose Add > Page from template.
This link is only displayed if there are templates already defined. If you do not see this link, then an administrator will have to
create a template before you can use it.
2. Choose a template from the list and click Next. This will display one of the following:
® A new page based on the template, if the template does not contain a form.
® The Template Variables page, if the template contains a form. Type values into the form fields and click Insert Variables.
This will display a new page based on the template, with the variable values you entered.
3. Type a name for the page where you see 'New Page'.
4. Add more content or make further changes as required.
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5. Click Save.

Screenshot: creating a page from a template

x Add Page - Template Variables

Step 2: Fill in template variables

Choose values for the variables in this template. These values will be automatically inserted into the template for you in the correct locations.

- Customer Order Form

Product Quantity Price Total

Unobtainium (Product) 1 oty $5,999.95 Price)  55,999.95 (Total)

<= Back ] ’ Insert Variables

Screenshot: previewing your page

New Page

Paragraph B I U N A .

Customer Order Form

Product Quantity Price Total
Unobtainium 1 $5,999.95 §5,999.95

Related Topics

Adding a Template

Editing a template

Removing a Template

Form Field Markup for Templates
Browsing a space

Working with Templates

Take me back to Confluence User's Guide

Editing a template
You need to be a space administrator to modify a space template.
To edit a template:
1. Choose Browse > Advanced > Templates. A list of templates for the space is displayed.
2. Click the Edit link for the template to be modified.
3. Make changes, or add new content, as you would when creating a template, using form field markup, if required.

4. Click Update to save your changes.
Related Topics
Adding a Template
Creating a Page using a Template

Working with Templates
Working with Pages
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Take me back to Confluence User's Guide

Removing a Template

You need to be a space administrator to remove a space template.

gy Warning

Deleted templates cannot be restored.

To remove a space template:
1. Choose Browse > Advanced and click Templates in the left-hand panel. A list of templates for the space is displayed.
2. Click Remove beside the template you wish to delete.

3. Click OK to confirm the deletion.
Related Topics

Editing a template

Adding a Template

Creating a Page using a Template
Working with Templates

Working with Pages

Take me back to Confluence User's Guide

Confluence Wiki Markup
This page describes the wiki markup used for page templates and in some administration screens in Confluence.

You can use wiki markup to write content for a page template. This content will appear in every page that uses the template. You can also
use special form markup if you wish to define form fields that the page author will complete when adding the page.

Markup is also used in the following places:

® When creating links using the Advanced tab of the Links Browser.
® When using the Wiki Markup dialog in the Confluence editor (choose Insert > Wiki Markup).
® When working with some administration screens, such as the Theme Configuration screen.

On this page:

Headings

Lists

Tables

Text Effects
Text Breaks
Links

Images
Related Topics

Headings
You can use wiki markup to create headings in a page template.

Creating a header is easy. Simply place "hn." at the start of your line (where n can be a number from 1-6).

What you need to type What you will get

hl. Biggest . .
heading Biggest heading

h3. Big heading
Big heading

h5. Small heading
Small heading



Confluence 4.0 Documentation

Note that Confluence treats all headings as anchors.
Lists
Wiki markup allows you to create bulleted or numbered lists, and is flexible enough to allow a combination of the two list types.

o If you need to separate the text within lists using line breaks, make sure you do so using a double slash (//). Empty lines may disrupt the
list.

Simple lists

Use the hyphen (-) to create simple lists.
Make sure there is a space between the hyphen and your text.

What you need to type What you will get
i - some i ¢ some
! - bullet | * bullet
: - : ® points
H points H
Bulleted lists

Use the asterisk (*) to create bullets. For each subsequent level, add an extra asterisk.
Make sure there is a space between the asterisk and your text.

What you need to type What you will get
* some ® some
! bullet * bullet
: ** indented : ® indented
** bullets ® bullets
* points ® points

Numbered lists

Use the hash (#) to create numbered lists.
Make sure there is a space between the hash and your text.

What you need to type What you will get
# a 1. a
! # numbered | 2. numbered
i # list : 3. list

A second level of hashes will produce a sub-list, such as the alphabetical sub-list shown below.

What you need to type What you will get

H # Here's a sentence. H 1. Here's a sentence.
H ## This is a sub-list point. ! a. This is a sub-list point.
## And a second sub-list point. b. And a second sub-list point.

# Here's another sentence. 2. Here's another sentence.
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Try a third level of hashes to produce a sub-sub-list.

What you need to type What you will get

1. Here's a sentence.
a. This is a sub-list point.
i. Third list level.
ii. Another point at the third level.
b. And a second sub-list point.
2. Here's another sentence.

# Here's a sentence.

## This is a sub-list point.

### Third list level.

### Another point at the third level.
## And a second sub-list point.

# Here's another sentence.

. Innumbered lists as described above, the format of the 'number’ displayed at each list level may be different, depending
upon your browser and the style sheets installed on your Confluence instance. So in some cases, you may see letters (A,
B, C, etc; or a, b, ¢, etc) or Roman numerals (i, ii, iii, etc) at different list levels.
Mixed lists
What you need to type What you will get
# Here H 1. Here
| H* ig i ® s
H #* an H ¢ an
i # example i 2. example
: #* of : * of
H H ® g
*
P v a : 3. mixed
i W mixed ' 4. list
i # list ! :
Tables

You can use wiki markup to create tables in a page template.

Confluence allows you to create two types of tables.

Table Type 1

Allows you to create a simple table with an optional header row. You cannot set the width of the columns in this table.
Use double bars for a table heading row.

What you need to type:

| |lheading 1||heading 2| |heading 3| |
|cell Al|cell A2|cell A3]
|cell Bl|cell B2|cell B3|

What you will get:

heading 1 heading2 heading 3

cell A1 cell A2 cell A3

cell B1 cell B2 cell B3

You can also use a vertical header.

What you need to type:
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: | |lheading 1|col Al|col A2|col A3|
: | |lheading 2|col Bl|col B2|col B3|

What you will get:

heading1 colAl colA2 col A3

heading2 colBl1 colB2 col B3

Table Type 2
This method allows you to specify the width of the columns in the table.

What you need to type

{section:border=true}

{column:width=30%}

Text for this column goes here. This is the smaller column with a width of only 30%.
{column}

{column:width=70%}

Text for this column goes here. This is the larger column with a width of 70%.

{column}

{section}

What you will get

Text for this column goes here. This is the smaller column with a width of only 30%.

Text for this column goes here. This is the larger column with a width of 70%.

o For more details please see the Column Macro and the Section Macro.

Advanced Formatting

Colour and Other Formatting

To add colour and other formatting to your tables, you can use the Panel Macro within columns.
More table-formatting options may be available if your Confluence administrator has installed additional macros.

Lists
Here's an example of how to embed lists in a table:
What you need to type
: | |[Heading 1| |Heading 2] |
H |* Item 1
: * Item 2
i * Item 3|# Item 1

# Item 2
# Item 3|

What you will get

Heading 1 Heading 2
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® Jtem1 1. ltem1
® |tem 2 2. Item 2
® jtem3 3. ltem 3

Text Effects

Use the markup shown in the examples below to format the text in your page templates.

What you need to type

*strong*

*bold text*

_emphasis_

_italics_

citation

-deleted-

+inserted+

Text with"superscript®

Text with~subscript~

{{monospaced}}

bg. Here's how you make a paragraph appear as

a block quotation.

{color:red}look ma, red text\!{color}

Text Breaks

Paragraph Break

What you will get
strong

bold text
emphasis

italics
Hint: To italicise parts of a word, add braces (curly brackets) around the
underscore. For example,

Thing{ }x_

gives you this: Thingx
citation
deleted

inserted

Text Withsuperscript

Hint: There are two ways to make superscripts work, when used directly
after another word or character:

® Add a space before the superscript. For example, kg/m *3*
gives you this: kg/m 3
® Add braces (curly brackets) around the superscript markup. For
example,
kg/m{"3"}

gives you this: kg/m3
Text with

subscript

monospaced

Here's how you make a paragraph appear as a block
quotation.

look ma, red text!

In a Confluence page template, a continuous line of text with two carriage returns at its end forms a paragraph. This is equivalent to a
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continuous line of text followed by a blank line.
When rendered into HTML, the result is a line of text wrapped in a set of <p></p> tags.
Line Break
Confluence provides two options for forcing a line break within a paragraph of text:
* Implicitly, by entering a single carriage return at its end.
® Explicitly, by entering two consecutive backslashes: \\

When rendered into HTML, the result is a paragraph of text that is split into separate lines by <br> tags, wherever a forced line break
appears.

o For most purposes, explicit line breaks are not required because a single carriage return is enough.

The examples below show how to use explicit line breaks.

What you need to type What you will get

here is some text here is some text
divided

\\ using line

divided \\ breaks

using line \\ \\

breaks\\

This is a short list: This is a short list:

* Point 1

Text to go with point 1 ® Pointl

* Point 2 Text to go with point 1
® Point 2

AW

Text to go with point 2 with a break
Text to go with point 2 with a break

If you wish to use multiple consecutive line breaks, each should be separated by a space character. For example, use
R\

for two consecutive line breaks.
Horizontal Rule

Use four dashes (----) to create a horizontal rule.
o Make sure that the dashes are on a separate line from the rest of the text.

What you need to type What you will get

here is some text here is some text

- . divided by a horizontal rule
divided by a horizontal rule

Links

You can use wiki markup to create links in a page template.

What you need to type What you will get

[#anchor] A link to an anchor on the same page.
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[Confluence Wiki
Markup”attachment.ext]

[pagetitle]

[pagetitle#tanchor]

[pagetitle"attachment.ext]

[spacekey:pagetitle]

[spacekey:pagetitle#anchor]

[spacekey:pagetitle™attachment.ext]

[/2004/01/12/blogposttitle]

[spacekey:/2004/01/12/blogposttitle]

[/2004/01/12]

[spacekey:/2004/01/12]

[spacekey:]

[~username]

[phrase@shortcut]

[http://confluence.atlassian.com]

[mailto:legendaryservice @atlassian.com]

[file://z:/filelon/network/share.txt]

Alink to a file attached to the page.

A link to a page.

A link to an anchor on another page.

A link to a file attached to another page.

Alink to a page in another space.

A link to an anchor on a page in another space.

A link to a file attached to a page in another space.

A link to a blog post.

A link to a blog post in another space.

A link to a whole day's blog posts.

A link to a whole day's blog posts in another space.

A link to the space homepage (or the space summary page of the space.

A link to the user profile page of a particular user.

A shortcut link to the specified shortcut site. Shortcuts are configured by the site
administrator.

A link to an external resource.

A link to an email address.

A link to a file on your computer or on a network share that you have mapped to a drive. This
only works on Internet Explorer.

Note that Confluence treats headings as anchors, so you can link to headings using this pattern: [spacekey:pagename#headingname], where
headingname is case-sensitive and must be entered without spaces.

For each of these link forms:

® You can prepend a link alias, so that alternate text is displayed on the page. Example: [link alias|pagetitle#anchor]
® You can append a link tip, which appears as a tooltip. Example: [pagetitle#tanchorf|link tip]

Images

Images, from attached files or remote sources, can be displayed in a page template.

What you need to type

Ihttp://www.host.com/image.gif!

lattached-image.gif!

IpageTitleNimage.gif!

IspaceKey:pageTitle*image.gif!

What you will get

An image from a remote source is displayed on the page. Uses a fully qualified URL.

An image file attached to the page is displayed.

An image file attached to a different page is displayed.

An image file attached to a page in a different space is displayed.
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1/2010/05/23/My Blog An image file attached to a blog post is displayed.
Posttimage.gif!

limage.jpg|thumbnail! The image is displayed as a thumbnail on the page (only works with images that are attached to the

page). Users can click on the thumbnail to see the full-sized image. Thumbnails must be enabled by
the site administrator for this to work.

limage.gif|align=right, For any image, you can specify attributes of the HTML image tag as a comma separated list of

vspace=4!

name=value pairs.

Available HTML image tags include:
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Image tag

align

border

bordercolor

hspace

vspace

width

height

title

alt

Details

Available values are 'left', 'right’, '‘bottom’, ‘center’, 'top'".

Specifies the width of the border (in pixels).

Use with the 'border' tag. Specify colours by name or hex value.

Specifies the amount of whitespace to be inserted to the left and right of the image (in pixels).
Specifies the amount of whitespace to be inserted above and below the image (in pixels).
Specifies the width of the image (in pixels). This will override the natural width of the image.
Specifies the height of the image (in pixels). This will override the natural height of the image.
Specifies alternate text for the image, which is displayed when the pointer hovers over the image.

Specifies alternate text for the image. This text is retrievable via search, and contributes to accessibility of the page for
text-only viewing.

Related Topics

Form Field Markup for Templates
Global Templates

Importing Templates

Adding a Template

Creating a Page using a Template

Take me back to the Confluence User's Guide.

Form Field Markup for Templates

.ﬂ. Please note, form field markup should only be used in templates. It does not work in wiki pages.

Templates are written using wiki markup, with special markup to insert form fields. When a user creates a page using a template that
contains form fields, the user will be prompted to key in data. The data will be captured and stored in the new page.

Here are the three kinds of form fields supported and the markup to create them:

Text field

Creates a text input field for a variable called VAR.

@VAR@
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Text area

@VAR |textarea(5,10)@

Drop down

menu
@VAR|list (one, two, three, four)e

Creates a 5 x 10 text-area for a variable called VAR.

Creates a drop-down box containing the values "one", "two",
"three" and "four".

Note: The values in the drop-down list can only contain
letters, numbers and underscores.

The dropdown list values cannot include:

® special characters, such as '&'
® punctuation marks, such as "'
® brackets, such as )’

Every input field must have a unique name. If you have more than one text input field in the same template with the same name, Confluence
will make sure that they all end up with the same value (This is useful if you need the same information in more than one place in the page).

For an example, please see Adding a Template.

gy Warning

There must be no spaces between the @-signs in the markup. This means you can't have items in your drop-down lists

that contain spaces.

Improved Markup

The above formatting is the basic markup bundled with Confluence, but some plugins expand on this markup to provide greater functionality.
Links to these plugins and a comparison can be found in the Working with Templates.

Related Topics

Working with Templates
Scaffolding Plugin

Adding a Template

Editing a template

Creating a Page using a Template

Take me back to Confluence User's Guide

Working with the Office Connector

The Office Connector is bundled with Confluence 2.10 and later. It allows you to:

® |mport an Office document into Confluence format.

® Attach an Office document to a Confluence page and display its content in Confluence, without converting the content.
® Edit the attached document in the Office application, directly from the Confluence page.

ﬁ Please be aware that source code is currently not available for the Confluence Office Connector.

Table of Contents

Office Connector Prerequisites

Displaying Office Files in Confluence

Importing an Office Document into Confluence
Editing an Office Document from Confluence

Editing an Office Spreadsheet from Confluence
Editing an Office Presentation from Confluence
Installing the Firefox Add-On for the Office Connector

Related Topics

View File Macro
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Configuring the Office Connector in the Confluence Administration Guide

Take me back to Confluence User's Guide

Office Connector Prerequisites
The page describes the software and setup you need to use the Office Connector.

o Your System Administrator can enable or disable the Office Connector or parts of it. The Office Connector options can appear in different
places on your Confluence page, depending on the themes and configuration of your Confluence site. Please refer to Configuring the Office
Connector in the Confluence Administration Guide and discuss any configuration problems with your administrator.

On this page:

Overall Prerequisites

Prerequisites for Viewing Office and PDF Files in Confluence

Prerequisites for Importing Office Documents into Confluence
Prerequisites for Editing Office Files Directly From Confluence
Related Topics

Overall Prerequisites

® Ensure that Java 5 (JDK 1.5) or higher is installed on your Confluence server.

® The WebDAYV plugin must be enabled, because the Office Connector uses WebDAV to transfer information to and from Office
documents. Note that the WebDAV plugin is bundled with Confluence, and can be enabled or disabled by the System Administrator.
If necessary, refer to the instructions on enabling plugins and configuring the WebDAYV options.

® Ensure that your Confluence server's base URL is set correctly. (Check it by going to the 'General Configuration' screen in the
Confluence Administration Console, as described in Configuring the Server Base URL.) When a user edits a wiki page in Word and
then uploads the page back to the Confluence server, the base URL determines where the document will be saved. If the base URL
is incorrect, the documents may be saved to a different Confluence server.

Prerequisites for Viewing Office and PDF Files in Confluence
If you want to use the View File macro, or to view Office files attached to a Confluence page, you need the setup described below.

Browsers and Flash Player

You can use any browser to view an Office file on a wiki page or attachment view, provided that you have installed Adobe Flash Player
version 9 or later. You do not need to have an Office desktop application installed on your computer in order to view Office files in
Confluence.

File Types

Confluence can display files compatible with Microsoft Office 97-2007, and PDF files, of the following types:
.doc and .docx

.x1ls and .x1lsx

.ppt and .pptx
.pdf

Prerequisites for Importing Office Documents into Confluence

® Document import can import Microsoft Word documents of the file types .doc and .docx. These must be valid Word 97-2007
format documents.

Prerequisites for Editing Office Files Directly From Confluence

The Office Connector allows you to edit Office files embedded in a wiki page or from the page's attachments view.
To make use of these editing capabilities, you will need the setup described below.

Browsers

® |f you are using Firefox, you will need to install a Firefox add-on. Firefox will prompt you to do this, the first time the add-on is
required. You will find instructions in Installing the Firefox Add-On for the Office Connector.

Office File Editors
To edit Office files, you will need to have Microsoft Office or OpenOffice installed. (See the configuration matrix below.)

® |f you are using Firefox, you can choose which of the above editors you want to use. The Firefox add-on allows you to configure this
option for each file type. See Installing the Firefox Add-On for the Office Connector.
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® |f you are using Internet Explorer, you will need Microsoft Office. You cannot edit Office files in OpenOffice when using Internet
Explorer.

Configuration Matrix

You need one of the following software combinations to edit Office files from your wiki page:

Operating System Office Version Browser
® Windows 7, ® OpenOffice 2.x — 3.x, or ® Internet
® Windows Vista, or ® Microsoft Office XP, 2003, 2007 or 2010 Explorer 8.x
® Windows XP with —9.x, or
Service Pack 2 or ® Firefox 4.x —
3 5.x
® Mac OS X 10.5 ® OpenOffice 2.x — 3.x ® Firefox 4.x —
and 10.6 ® The "Edit in Word" feature is known to work in OpenOffice 3.2.0. 5.x
® Linux ® OpenOffice 2.x — 3.x ® Firefox 4.x —
The only known supported Office editor for Linux is OpenOffice. But in 5.x

theory it should work with any WebDAV-aware application.

Related Topics

Working with the Office Connector

® Office Connector Prerequisites

® Displaying Office Files in Confluence

® Importing an Office Document into Confluence

® Editing an Office Document from Confluence

® Editing an Office Spreadsheet from Confluence

® Editing an Office Presentation from Confluence

® Installing the Firefox Add-On for the Office Connector

Configuring the Office Connector in the Confluence Administration Guide

Take me back to Confluence User's Guide

Displaying Office Files in Confluence

Confluence can display Office files that are attached to a page. If you have an Office application installed, you will also be able to edit these
Office files in your Office application.

These are two of the ways that Confluence can interact with Office files. For an overview of all Office Connector features, please refer to
Working with the Office Connector.

o Your System Administrator can enable or disable the Office Connector or parts of it. The Office Connector options can appear in differen
places on your Confluence page, depending on the themes and configuration of your Confluence site. Please refer to Configuring the Office
Connector in the Confluence Administration Guide and discuss any configuration problems with your administrator.

On this page:

Prerequisites

Attaching and Displaying Office Files and PDF Files
Viewing and Editing the Attached Office Files
Troubleshooting

Related Topics

Prerequisites
If you want to use the View File macro, or to view Office files attached to a Confluence page, you need the setup described below.
Browsers and Flash Player

You can use any browser to view an Office file on a wiki page or attachment view, provided that you have installed Adobe Flash Player
version 9 or later. You do not need to have an Office desktop application installed on your computer in order to view Office files in
Confluence.
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File Types
Confluence can display files compatible with Microsoft Office 97-2007, and PDF files, of the following types:

.doc and .docx
.xlsand .x1lsx
.ppt and .pptx
.pdf

Attaching and Displaying Office Files and PDF Files

There are two ways to do this in Confluence:

® Attach Office files to a page and display them in a Confluence page using the View File or Attachments macros
® Attach an Office or PDF file to a page and embed its contents onto the page by simply dragging and dropping it into the editor
window

To attach and display Office files in Confluence using macros:

1. Attach the Office file(s) to a Confluence page:
® View the Confluence page on which you want to display your document.
® Choose Tools > Attachments.
® Browse for your Office files and upload them to the Confluence page.
Refer to detailed instructions in Attaching Files to a Page.
2. Now you have two options for displaying the attached document:
® You can embed the document into the Confluence page, using one of the Office Word, Office Excel, Office PowerPoint or
View PDF macros. These macros can be found using the macro browser. Refer to the detailed instructions in the View File
macro topic.
® You can display a list of page attachments using the Attachments macro. People viewing the page will be able to click the
View link to see the Office or PDF document in Confluence.

To attach and display an Office file on a Confluence page using 'drag and drop":

® Drag the Office file from your computer and drop it into the editor window. Only one file can be dragged and dropped at a time. The
appropriate View File macro placeholder will appear in the position where you dragged the file. However, the contents of the file will
be rendered in full when you preview, or save and view, the page.

o Older browser versions require Google Gears to have been installed for you to use drag and drop. Refer to Using Drag-and-Drop
in Confluence for information about setting up Google Gears.

Viewing and Editing the Attached Office Files

If an Office document is attached to a Confluence page, you can view the attached Office document from within Confluence. View the Office
document in one of the following ways:

® Search for the Office document by file name, then click View next to the Office document on the Search results page. (See
Searching Confluence.)

® View the list of attachments for a specific Confluence page, then click View next to the Office document on the Attachments page.
(See Viewing Attachment Details.)

® View a list of attachments displayed on a page via the Attachments macro, then click View next to the Office document in the list of
attachments. (See Displaying a List of Attachments in a Page.)

® View a Confluence page which has the Office document embedded in the page via the View File macro. (See View File Macro.)

Any Confluence user who has an Office application installed will also be able to launch their Office editor from within Confluence:

® Editing an Office Document from Confluence.
® Editing an Office Presentation from Confluence.
® Editing an Office Spreadsheet from Confluence.

Troubleshooting

Problems? Please refer to our guide to the Office Connector limitations and known issues.

Related Topics

View File Macro
Working with the Office Connector

® Office Connector Prerequisites

® Displaying Office Files in Confluence

® Importing an Office Document into Confluence

® Editing an Office Document from Confluence

® Editing an Office Spreadsheet from Confluence

® Editing an Office Presentation from Confluence

¢ |Installing the Firefox Add-On for the Office Connector
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Configuring the Office Connector in the Confluence Administration Guide

Take me back to the Confluence User's Guide.

Importing an Office Document into Confluence

The Office Connector in Confluence allows you to import an Office document into Confluence, so that the document's content is copied onto
one or more Confluence pages.

This is just one of the ways Confluence can interact with Office documents. For an overview of all Office Connector features, please refer to
Working with the Office Connector.

o Your System Administrator can enable or disable the Office Connector or parts of it. The Office Connector options can appear in differen
places on your Confluence page, depending on the themes and configuration of your Confluence site. Please refer to Configuring the Office
Connector in the Confluence Administration Guide and discuss any configuration problems with your administrator.

The simplest way to import an Office document is to import the entire content of the document into a single wiki page. By default, the content
of the document will be created as a new wiki page.

More advanced options allow you to import the content into a new page, to split a single document into more than one wiki page, and to
resolve conflicts in the titles of your pages.

These options are described below.

On this page:

Prerequisites

Importing an Office Document

Splitting an Office Document into Multiple Wiki Pages
Related Topics

Prerequisites

Prerequisites for the Office Connector's document import feature:

® Document import can import Microsoft Word documents of the file types .doc and . docx. These must be valid Word 97-2007
format documents.

For a full list of Office Connector prerequisites and limitations, please refer to:

® Office Connector Prerequisites
® Office Connector Limitations and Known Issues

Importing an Office Document

The simplest way to import an Office document is to import the entire content of the document into a single wiki page.
This method will replace any existing content on the wiki page.
To import an Office document onto a single wiki page:

1. Create a page in Confluence (see Creating a Page) or go to an existing page whose content you want replaced.
2. Choose Tools > Import Word Document.

3. Click Browse and find the Office document on your local drive or network.

4. Click the Open or Upload button provided by your browser. The path and file name of the document will now appear in the text box
on the Office Connector import screen.

5. Click Next on the Office Connector import screen. The import document options screen will display.

6. The import document options are:

Option Description

Root page title The title of the wiki page that will contain the information from your imported document.

Import as a new page A new wiki page will be created with the page title specified above.
in the current space



Confluence 4.0 Documentation

69

Replace <pagename>

Delete existing children
of <pagename>

Rename imported
pages if page name
already exists

Replace existing pages
with imported pages of
the same title

Remove existing pages
with the same title as
imported pages

Split by heading

The contents of the existing page will be replaced. The page will be renamed to the page title specified
above.

The existing child pages of the page you are replacing will be deleted.

Assign new names to any new page which would otherwise have a duplicate name. The content of
existing pages will remain unchanged.

If imported pages have titles equal to existing pages, then the content of the Office document will
overwrite the content on the existing page. Page history will be preserved.

If imported pages have titles equal to existing pages, then the existing pages will be deleted. This will
remove the page history as well as the content.

The content of the Office document will be split over multiple wiki pages. If you don't want to split your

document into multiple wiki pages, leave the default Don't split option selected. For more information
on splitting your document, please see below.

7. Click Import.

When the upload has finished, the content of the Office document will have been transformed into Confluence page content. You can now
view and edit this page in the usual way. There is no connection between the original Office document and this wiki page.

Screenshot: Empty page ready for import

s »  Andrew Lui JrEh b -~ [SEELE I

& Edit  dp Add ~

i@ Tools ~

% Chocolate

y Andrew

Add Labels

Child Pages (3) Show Child Pages | Reorder Pages | Add Child Page

Add Comment

Screenshot: Selecting Office document to import

Dashboard » Documentation Testing » Home » Chocolate Tuesday Browse » Andrew Lui JrA20b -~ [EEEUSN

x Chocolate Tuesday

@ View

gk Add ~

& Tools ~

Browse...

Upload

Screenshot: Importing an Office document

oard » Documentation Testing

Browse ~ Andrew Lui JJih b ~ [EEENEN I

% Chocolate Tuesday Jk Add ~ £ Tools ~

@ View
Root page title: Chocolate by Andrew Lui
Import as a new page in the current space

® Replace Chocolate Tuesday
[ Delete existing children of Chocolate Tuesday

@ Rename imported pages if page name already exists
Replace existing pages with imported pages of the same title
Remove existing pages with the same title as imported pages

Split by heading | Dan't split |Z|
Document QOutline
|=] Chocolate by Andrew Lui

Screenshot: Page after import
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Dashboard » Documentation Testing » Home » Chocolate by Andrew Lui Browse » Andrew Lui JJ25b ~ [SEER I

% Chocolate by Andrew Lui & Edit  db Add ~ 8 Tools ~

on May 25, 2010 (view change)

Overview

| like chocolate.

Thesis

I like chocolate. That's a fact.

Conclusions
Andrew likes chocolate.

Add Labels

Child Pages (3) Show Child Pages | Reorder Pages | Add Child Page

Add Comment

Splitting an Office Document into Multiple Wiki Pages

When importing an Office document, you can split a single document into more than one wiki page, based on the heading styles in the
document.

By default, the page names will be the same as the heading text. This may result in a conflict, if a page already exists with the same title. You
can instruct the importer how to handle such conflicts.

To import an Office document into multiple wiki pages:

1. Import an Office document as described above. On the import document options screen, choose how to split your document in the '
Split by heading' field:
® 'Split by heading' — If you want to split the content under each heading in your document into separate child pages, select
the desired heading level to split by. A preview of the page hierarchy that will be created by the split will be displayed under
Document Outline'. Each bullet point in the 'Document Outline' represents a new page after import into Confluence.
2. Click 'Import' to import your document.
3. When the upload has finished, the content of the Office document will have been transformed into Confluence page content. You
can now view and edit this page in the usual way. There is no connection between the original Office document and this wiki page.

Screenshot: Splitting a single Office document into multiple wiki pages

oard » Documentation Testing » Home » ( e y 0 ew Lui b I

% Chocolate Tuesday © view dp Add + £ Tools ~

Root page title: Chocolate by Andrew Lui
7 Import as a new page in the current space
@ Replace Chocolate Tuesday
[T Delete existing children of Chocolate Tuesday

@ Rename imported pages if page name already exists
) Replace existing pages with imported pages of the same title
' Remove existing pages with the same title as imported pages

Split by heading: | Level 1 HeadmgsE
Document Outline
|=] Chocolate by Andrew Lui

=] oveniew

=] Thesis

|=] Conelusions

Related Topics

Working with the Office Connector

® Office Connector Prerequisites

® Displaying Office Files in Confluence

® |mporting an Office Document into Confluence
® Editing an Office Document from Confluence
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® Editing an Office Spreadsheet from Confluence

® Editing an Office Presentation from Confluence

® |Installing the Firefox Add-On for the Office Connector
Configuring the Office Connector in the Confluence Administration Guide

Take me back to Confluence User's Guide

Editing an Office Document from Confluence

When viewing a wiki page that displays an attached Office document, you can launch your Office editor directly from Confluence. This allows
you to edit a Word document from within Confluence and save it back to Confluence.

This is just one of the ways Confluence can interact with Office documents. For an overview of all Office Connector features, please refer to
Working with the Office Connector.

o Your System Administrator can enable or disable the Office Connector or parts of it. The Office Connector options can appear in differen
places on your Confluence page, depending on the themes and configuration of your Confluence site. Please refer to Configuring the Office
Connector in the Confluence Administration Guide and discuss any configuration problems with your administrator.

On this page:

® Prerequisites for Editing an Attached Office Document
® Editing an Office Document in your Office Application
® Troubleshooting

® Related Topics

Prerequisites for Editing an Attached Office Document

The Office Connector allows you to edit Office files embedded in a wiki page or from the page's attachments view.
To make use of these editing capabilities, you will need the setup described below.
Browsers

® If you are using Firefox, you will need to install a Firefox add-on. Firefox will prompt you to do this, the first time the add-on is
required. You will find instructions in Installing the Firefox Add-On for the Office Connector.

Office File Editors
To edit Office files, you will need to have Microsoft Office or OpenOffice installed. (See the configuration matrix below.)
® |f you are using Firefox, you can choose which of the above editors you want to use. The Firefox add-on allows you to configure this
option for each file type. See Installing the Firefox Add-On for the Office Connector.
® |f you are using Internet Explorer, you will need Microsoft Office. You cannot edit Office files in OpenOffice when using Internet
Explorer.

Configuration Matrix

You need one of the following software combinations to edit Office files from your wiki page:

Operating System Office Version Browser
® Windows 7, ® OpenOffice 2.x — 3.x, or ® |nternet
® Windows Vista, or ® Microsoft Office XP, 2003, 2007 or 2010 Explorer 8.x
® Windows XP with —9.x, or
Service Pack 2 or ® Firefox 4.x —
3 5.x
® Mac OS X 10.5 ® OpenOffice 2.x — 3.x ® Firefox 4.x —
and 10.6 ® The "Edit in Word" feature is known to work in OpenOffice 3.2.0. 5.x
® Linux ® OpenOffice 2.x — 3.x ® Firefox 4.x —
The only known supported Office editor for Linux is OpenOffice. But in 5.x

theory it should work with any WebDAV-aware application.

Editing an Office Document in your Office Application
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To edit an Office document in your Office application:

1. There are two ways to do this:

® From an Office document embedded on a page:

a.
b.

C.

Open a Confluence page with an Office document embedded on it.

Move your mouse pointer to the top of the document embedded in the Confluence page, until the hidden title bar
appears.

Screenshot: The title bar showing 'document.doc' above an embedded Office document

.

-
A
—
=]

% Displaying a Word Document & Edt  dhAdd-

&4 Added by Sarah Maddoy, last edited by Sarah Maddox on MNov 11, 2008

document.doc

Sample Word Document

This is a simple document created in Microsoft Word 2007.

Heading Level 1

Lorem ipsum dolor sit amet, consectetuer adipiscing elit. Aliguam fermentum vestibulum est. Cras rhoncus. Pellentesque
habitant morbi tristique senectus et netus et malesuada fames ac turpis egestas. Sed quis tortor.

Click the title bar above the embedded document.

® From an Office document in a list of attachments:

If an Office file is attached to a Confluence page, you can edit this file directly in your compatible Office application,
in one of the following ways:
® View the list of attachments for a specific Confluence page, then click Edit next to the Office file on the
Attachments page. (See Viewing Attachment Details.)
® View a list of attachments displayed on a page via the Attachments macro, then click Edit next to the Office
file in the list of attachments. (See Displaying a List of Attachments in a Page.)

2. A window will pop up, asking you to confirm that you want to open this document.

Screenshot: Confirmation window in Firefox

=

Warning!

X]

@ The following location is going to be opened on your computer:

http://extranet.atlassian.com/plugins/serviet/webdav/Global/DOCT ST/Home/OC/Displaying a Word
Document/document.doc

By the program:
C:\Program Files\Microsoft Office\OFFICE11\WINWORD.EXE

This poses a security risk. If you didn't initiate this action or you don't trust the source of the file,
please click Cancel.

oK | l Cancel
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3.

4.
5.
6.

Screenshot: Confirmation window in Internet Explorer

File Download

X]

or you do not fully trust the source, do not open the file,
You are opening the following file:

File name: document.doc
From: ga-eac.atlassian.com

OK Cancel

:/- Some files can harm your computer. If the file information looks suspicious
-

Click 'OK". Now you may be asked to log in to your Confluence server.

Screenshot: Logging in to Confluence

Connect to extranet.atlas... E

L

The server extranet. atlassian.com at Extranet requires a
username and password,

Warning: This server is requesting that your username and

password be sent in an insecure manner (basic authentication
withaut a secure connection).

Lser name: | | &I

Password:

[ ]remember my password

[ Ok, l [ Cancel

Enter your Confluence username and password, then click 'OK".
The Office document will open in your Office application.

Make the necessary changes, then save the document. It will be saved back into Confluence.

Troubleshooting

Problems? Please refer to our guide to the Office Connector limitations and known issues.

Related Topics

Working with the Office Connector

Office Connector Prerequisites

Displaying Office Files in Confluence

Importing an Office Document into Confluence
Editing an Office Document from Confluence

Editing an Office Spreadsheet from Confluence
Editing an Office Presentation from Confluence
Installing the Firefox Add-On for the Office Connector

Configuring the Office Connector in the Confluence Administration Guide

Take me back to the Confluence User's Guide.

73




Confluence 4.0 Documentation

Editing an Office Spreadsheet from Confluence

When viewing a wiki page that displays an attached Office document, you can launch your Office editor directly from Confluence. This allows
you to edit an Excel spreadsheet from within Confluence and save it back to Confluence.

This is just one of the ways Confluence can interact with Office documents. For an overview of all Office Connector features, please refer to
Working with the Office Connector.

o Your System Administrator can enable or disable the Office Connector or parts of it. The Office Connector options can appear in differen
places on your Confluence page, depending on the themes and configuration of your Confluence site. Please refer to Configuring the Office
Connector in the Confluence Administration Guide and discuss any configuration problems with your administrator.

On this page:

Prerequisites for Editing an Attached Office Spreadsheet
Editing an Office Spreadsheet in your Office Application
Troubleshooting

Related Topics

Prerequisites for Editing an Attached Office Spreadsheet

The Office Connector allows you to edit Office files embedded in a wiki page or from the page's attachments view.
To make use of these editing capabilities, you will need the setup described below.
Browsers

® If you are using Firefox, you will need to install a Firefox add-on. Firefox will prompt you to do this, the first time the add-on is
required. You will find instructions in Installing the Firefox Add-On for the Office Connector.

Office File Editors
To edit Office files, you will need to have Microsoft Office or OpenOffice installed. (See the configuration matrix below.)
® |f you are using Firefox, you can choose which of the above editors you want to use. The Firefox add-on allows you to configure this
option for each file type. See Installing the Firefox Add-On for the Office Connector.
® |f you are using Internet Explorer, you will need Microsoft Office. You cannot edit Office files in OpenOffice when using Internet
Explorer.

Configuration Matrix

You need one of the following software combinations to edit Office files from your wiki page:

Operating System Office Version Browser
® Windows 7, ® OpenOffice 2.x — 3.x, or ® Internet
® Windows Vista, or ® Microsoft Office XP, 2003, 2007 or 2010 Explorer 8.x
® Windows XP with —9.x, or
Service Pack 2 or ® Firefox 4.x —
3 5.x
® Mac OS X 10.5 ® OpenOffice 2.x — 3.x ® Firefox 4.x —
and 10.6 ® The "Edit in Word" feature is known to work in OpenOffice 3.2.0. 5.x
® Linux ® OpenOffice 2.x — 3.x ® Firefox 4.x —
The only known supported Office editor for Linux is OpenOffice. But in 5.x

theory it should work with any WebDAV-aware application.

Editing an Office Spreadsheet in your Office Application

To edit an Office spreadsheet in your Office application:
1. There are two ways to do this:
®* From an Office spreadsheet embedded on a page:
a. Open a Confluence page with an Office document embedded on it.

b. Move your mouse pointer to the top of the spreadsheet embedded in the Confluence page, until the hidden title bar
appears.
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Screenshot: The title bar showing 'spreadsheet.xls' above an embedded Excel spreadsheet

Planning

spreadsheet.xls

5

x, Displaying an Excel Spreadsheet

3

&4 Added by Sarah Maddo, last edited by Sarah Maddox on Nov 11, 2008

& Edit

gF Add ~ £ To

Design

3

5

2

Development

Testing

Admin

Add Labels

Add Comment

c. Click the title bar above the embedded spreadsheet.

®* From an Office spreadsheet in alist of attachments:
® |f an Office file is attached to a Confluence page, you can edit this file directly in your compatible Office application,
in one of the following ways:
® View the list of attachments for a specific Confluence page, then click Edit next to the Office file on the
Attachments page. (See Viewing Attachment Details.)
® View a list of attachments displayed on a page via the Attachments macro, then click Edit next to the Office
file in the list of attachments. (See Displaying a List of Attachments in a Page.)

2. A window will pop up, asking you to confirm that you want to open this document.

Screenshot: Confirmation window in Firefox

Warning!

=]

By the program:

please click Cancel.

\1) The following location is going to be opened on your computer:

http://extranet.atlassian.com/plugins/servlet/webdav/Global/[DOCT ST/Home/OC/Displaying an Excel
Spreadsheet/spreadsheet.xls

C:\Program Files\Microsoft Office\OFFICE11\EXCEL.EXE

This poses a security risk. If you didn't initiate this action or you don't trust the source of the file,

oK

| l Cancel

Screenshot: Confirmation window in Internet Explorer

rFile Download

-

File name: spreadsheet.xds
From: extranet.atlassian.com

You are opening the following file:

P Some files can harm your computer. If the file information looks suspicious
/ or you do not fully trust the source, do not open the file.

OK

Cancel

3. Click 'OK'. Now you may be asked to log in to your Confluence server.
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Screenshot: Logging in to Confluence

Connect to extranet.atlas... E

L
A,

The server extranet. atlassian.com at Extranet reguires a
username and password,

Warning: This server is requesting that your username and
password be sent in an insecure manner (basic authentication
without a secure connection).

User name: | | tl

Password:

[ ]Remember my password

[ Ok ] [ Cancel

4. Enter your Confluence username and password, then click 'OK".
5. The Office spreadsheet will open in your Office application.
6. Make the necessary changes, then save the spreadsheet. It will be saved back into Confluence.

Troubleshooting
Problems? Please refer to our guide to the Office Connector limitations and known issues.
Related Topics

Working with the Office Connector

Office Connector Prerequisites

Displaying Office Files in Confluence

Importing an Office Document into Confluence
Editing an Office Document from Confluence

Editing an Office Spreadsheet from Confluence
Editing an Office Presentation from Confluence
Installing the Firefox Add-On for the Office Connector

Configuring the Office Connector in the Confluence Administration Guide

Take me back to the Confluence User's Guide.

Editing an Office Presentation from Confluence

When viewing a wiki page that displays an attached Office document, you can launch your Office editor directly from Confluence. This allows
you to edit a PowerPoint presentation from within Confluence and save it back to Confluence.

This is just one of the ways Confluence can interact with Office documents. For an overview of all Office Connector features, please refer to
Working with the Office Connector.

o Your System Administrator can enable or disable the Office Connector or parts of it. The Office Connector options can appear in differen
places on your Confluence page, depending on the themes and configuration of your Confluence site. Please refer to Configuring the Office
Connector in the Confluence Administration Guide and discuss any configuration problems with your administrator.

On this page:

® Prerequisites for Editing an Attached Office Presentation
® Editing an Office Presentation in your Office Application
® Troubleshooting

® Related Topics
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Prerequisites for Editing an Attached Office Presentation

The Office Connector allows you to edit Office files embedded in a wiki page or from the page's attachments view.
To make use of these editing capabilities, you will need the setup described below.
Browsers

® |f you are using Firefox, you will need to install a Firefox add-on. Firefox will prompt you to do this, the first time the add-on is
required. You will find instructions in Installing the Firefox Add-On for the Office Connector.

Office File Editors
To edit Office files, you will need to have Microsoft Office or OpenOffice installed. (See the configuration matrix below.)
® |f you are using Firefox, you can choose which of the above editors you want to use. The Firefox add-on allows you to configure this
option for each file type. See Installing the Firefox Add-On for the Office Connector.
® If you are using Internet Explorer, you will need Microsoft Office. You cannot edit Office files in OpenOffice when using Internet
Explorer.

Configuration Matrix

You need one of the following software combinations to edit Office files from your wiki page:

Operating System Office Version Browser
® Windows 7, ® OpenOffice 2.x — 3.x, or ® Internet
® Windows Vista, or ® Microsoft Office XP, 2003, 2007 or 2010 Explorer 8.x
® Windows XP with -9.x, or
Service Pack 2 or ® Firefox 4.x —
3 5.x
® Mac OS X 10.5 ® OpenOffice 2.x — 3.x ® Firefox 4.x —
and 10.6 ® The "Edit in Word" feature is known to work in OpenOffice 3.2.0. 5.x
® Linux ® OpenOffice 2.x — 3.x ® Firefox 4.x —
The only known supported Office editor for Linux is OpenOffice. But in 5.x

theory it should work with any WebDAV-aware application.

Editing an Office Presentation in your Office Application
To edit an Office presentation in your Office application:
1. There are two ways to do this:

® From an Office presentation embedded on a page:
a. Open a Confluence Ea?e with an Office presentation embedded on it.
b. Click the 'Edit' icon on the bottom frame of the slide show.

Screenshot: PowerPoint presentation displayed on a Confluence page


http://www.microsoft.com/office
http://www.openoffice.org/
http://www.openoffice.org/
http://www.openoffice.org/
http://www.openoffice.org/
http://www.openoffice.org/
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x Displaying a PowerPoint Presentation & Edit
&1 Added by Sarah Maddox, last edited by Sarah Maddox on Mov 11, 2008
What Is An Issue
W Bug
= Task
% Requirement
@ Incident
2 Goal
“YOATLASSIAN
g @ i 4 15120 B P Cc=
Add Labels
Add Comment

gF Add v

o0
2T

® From an Office document in a list of attachments:

® |f an Office file is attached to a Confluence page, you can edit this file directly in your compatible Office application,

in one of the following ways:

® View the list of attachments for a specific Confluence page, then click Edit next to the Office file on the

Attachments page. (See Viewing Attachment Details.)

® View a list of attachments displayed on a page via the Attachments macro, then click Edit next to the Office

file in the list of attachments. (See Displaying a List of Attachments in a Page.)

2. A window will pop up, asking you to confirm that you want to open this document.

Screenshot: Confirmation window in Firefox

rWarning!

X]

@ The following location is going to be opened on your computer:

http://extranet.atlassian.com/plugins/serviet/webdav/Global/DOCTST/Home/OC
/Displaying%:20a%20PowerPoint%20Presentation/JIRA%20Webinar¥a20v2.ppt

By the program:
C:\Program Files\Microsoft Office\OFFICE11\POWERPNT.EXE

This poses a security risk. If you didn't initiate this action or you don't trust the source of the file,
please click Cancel.

oK | l Cancel
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4.
5.
6.

Screenshot: Confirmation window in Internet Explorer

= i

X]

or you do not fully trust the source, do not open the file,
You are opening the following file:

File name: JIRA Webinar v2.ppt
From: extranet.atlassian.com

OK Cancel

:/- Some files can harm your computer. If the file information looks suspicious
-

Click 'OK". Now you may be asked to log in to your Confluence server.

Screenshot: Logging in to Confluence

Connect to extranet.atlas... E

L

The server extranet. atlassian.com at Extranet requires a
username and password,

Warning: This server is requesting that your username and

password be sent in an insecure manner (basic authentication
withaut a secure connection).

Lser name: | | &I

Password:

[ ]remember my password

[ Ok, l [ Cancel

Enter your Confluence username and password, then click 'OK".
The presentation will open in your Office application.

Make the necessary changes, then save the presentation. It will be saved back into Confluence.

Troubleshooting

Problems? Please refer to our guide to the Office Connector limitations and known issues.

Related Topics

Working with the Office Connector

Office Connector Prerequisites

Displaying Office Files in Confluence

Importing an Office Document into Confluence
Editing an Office Document from Confluence

Editing an Office Spreadsheet from Confluence
Editing an Office Presentation from Confluence
Installing the Firefox Add-On for the Office Connector

Configuring the Office Connector in the Confluence Administration Guide

Take me back to Confluence User's Guide
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Installing the Firefox Add-On for the Office Connector

If you are using Firefox as your browser, you will need to install an add-on into Firefox (the Firefox WebDAV Launcher) in order to use some
features of the Office Connector. You will be prompted to install the add-on the first time you try to use a function which requires it.

For an overview of all Office Connector features, please refer to Working with the Office Connector.

1, Supported Web Browsers
Please ensure that you are using one of the web browsers supported by Confluence. If you are using an unsupported
browser or browser version, some features may not work correctly. You can find the list of supported web browsers and
browser versions on this page: Supported Platforms.

On this page:

Installing the Firefox Add-On
Configuring the Add-On

Security Risks

Information about this Firefox Add-On
Related Topics

Installing the Firefox Add-On

You will be prompted to install the add-on the first time you try to use a function which requires it. The add-on is required for editing a wiki
page in Office, or for editing an Office document which is displayed on a wiki page.

1. When you choose an option which requires the Firefox add-on, you will see a popup window like this one:

rThe page at http://extranet.atlassian.com says: ﬁﬁ

@ A plugin is required to use this feature. Would you like to downlead it?

0K Cancel

2. Click 'OK'. Some browsers may now ask you to confirm the download with a message bar across the top of the page, beneath the
browser's address bar.

® You may see a message like the yellow bar shown here:

Firefox prevented this site (extranet.atlassian.com) from asking you to install software on your computer. Allow %]

Dashboard * Documentation Testing * ... * OC * Viewfile macro Browse v Sarah Maddox ~ SEEll I"

% Viewfile macro & Edit  4p Add - £ Tools ~

&4 Added by Sarah Maddox, |ast edited by Sarah Maddox on Mov 03, 2008

Click 'Allow".
® Or you may see a similar message with an 'Edit Options' button like this:

Firefox prevented this site (192.168.2.105) from asking you to install software on your computer. [ Edit Options...

Dashboard > Demonstration Space > viewfile demo I Search |ﬂ‘]
1

® |f you see the above message, click 'Edit Options'. You will then see an 'Allowed Sites' window like this one:
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s R e —— |
[+ NN Allowed Sites - Add-ons Installation —)
You can specify which web sites are allowed to install add-ons. Type the exact
address of the site you want to allow and then click Allow.

Address of web site:
192.168.2.105

[ Allow
Site Status
addons.mozilla.org Allow
update.mozilla.org Allow
'r_ Remowve Site “" 'r Remove All Sites “"

A

This window lets you tell Firefox that your Confluence server is allowed to install add-ons into Firefox. The '‘Address
of web site' box should already contain the address of your Confluence server.
® Click the 'Allow' button to add your Confluence server to the list.
® Go back to your Confluence page and try to edit your Office document again, e.g. by clicking 'Edit in Word' again.
Now you will see the option to install the add-on.
3. A'Software Installation' window will appear, asking you to confirm the installation. The window will look something like the one
below, but the URL will be the address of your own Confluence server:

-,

Software Installation E

Only install add-ons from authors whom you trust.

Malicious software can damage your computer or violate your privacy.

You have asked to install the following item:

7. WebDAV Launcher [Benrvan Software Inc.)
http://extranet.atlassian.com/download/resources/com.atlassian.confluence.extra. offic

Install Mows Cancel

4. Click 'Install Now'. The installation will happen and a window will pop up asking you to restart Firefox:
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& Add-ons Q@Eﬂ

E B 2 a

Get Add-ons  Extensions Themes Plugins Installation

i) Restart Firefox to complete your changes. Restart Firefox | E3

L WebDAV Launcher 1.0
Restart to complete the installation.

. Make sure you have saved all your Confluence pages and any other work in your browser, then restart Firefox.

. If Firefox asks you to confirm the restart, confirm it.
. Firefox will close all the browser windows and will then start up again. You will see a window confirming that a new add-on has been

installed, like this:

& Add-ons M=)

S b = a

Get Add-ons ~ Extensions Themes Plugins

~No g

i) 1 new add-on has been installed. (%]

: P English (Australian) Dictionary 2.1.1
I'm sick of all my favoUrite coloUrful language being marked incorrect.

Disable H Uninstall ]

No Squint 1.93.2.1
Manage site-specific full page and text zoom levels

printpdf 0.73
Print web pages to PDF

Web Developer 1.1.6
Adds a menu and a toolbar with various web developer tools.

WebDAV Launcher 1.0
Adds the ability to launch a WebDAV url directly in a WebDAV aware client.

a5 |
/ Sage 1.4.2
A lightweight RSS and Atom feed reader.
-
I:E’ll
[ 1]
E-!_l

Configuring the Add-On

After you have installed the add-on into Firefox, you will need to configure it. Basically, you will associate a desktop application (editor) with
each relevant file type. This tells the Office Connector which application to launch when it encounters a link to an editable file. The
configuration is slightly different for each operating system, as described below.

Configuring the Add-On in Windows

The add-on can will automatically configure itself on Windows via the system registry. The first time you edit a new file type, the add-on will
look up the default editor for that file type and make that the permanent setting.

If you want to override the registry settings, or if for some reason the automatic configuration is not working, you can configure the Firefox
add-on manually.

1. In Firefox, go to the 'Tools menu and select 'WebDAV Launcher Options', as shown in this screenshot:
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¥ Mozilla Firefox Start Page - Mozilla Firefox

File Edit Miew History  Bookmarks Help
Fa | web Search ChFHE
- @ W G-
Downloads Ckrl+1

[] Customize Links | | Free Hotmail || Add-aons

Web |mages Maps Mews Sho

Java Console

Error Console
Javascript Debugger
Page Info

Clear Private Data. .. Ckrl+Shift+Del

WebDay Launcher Options
IE Tab Options

Options. ..

2. A'WebDAV Launcher Options' window will appear, allowing you to associate a specific file type (file extension) with a desktop
application (editor). The window looks like this one:

WehDAY Launcher Options x|

exk | Application path |E|

Add extension

File Extension I Auko |

Application Path I Browse | Add

Save | Cancel

3. In the 'File Extension box, enter the extension for a particular file type. For example, you may want to associate the 'doc' file
extension with Microsoft Word 2003 or earlier. To do this, you would type 'doc' in the File Extension text box.

ﬂ If you use or have recently upgraded to Office 2007

In addition to the original Office 2003 file extensions (that is, ‘doc’, 'ppt' and xIs'), you should additionally configure
the WebDAV launcher to handle the new Office 2007-specific file extensions for Microsoft Word (‘docx’), Microsoft
Excel (‘xIsx') and PowerPoint (‘pptx’).

Screenshot: Configuring the WebDAV Launcher - adding the 'doc' file extension.
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WebDAY Launcher Options |

ek | Application path |E|
Delete
~ &dd extension
File Extension I do Ak |
Application Path I Browse | Add
Save Cancel

4. Enter the 'Application Path — Use one of the following methods to specify the associated application for editing the given file type:
® Click the 'Auto’ button to load the associated application from the Windows registry.
® Alternatively, you can click the 'Browse' button to find the application on your computer.
® Or you can manually type in the path to the application's executable file.

Screenshot: Configuring the WebDAV Launcher - adding the 'Application Path' for the ‘doc' file extension.

WebDAY Launcher Options x|

exk I Application path |E|
Delete
~ &dd extensian
File Extension I doc ! Auko
Application Path I C:\Program FilesiMicrosc Browse | Add
Save | Cancel

ﬂ If you use or have recently upgraded to Office 2007

Follow the instructions in this step to add the path to the relevant Office 2007 application for the Office
2007 file extension you configured above. For example, if you had a typical default installation of Office
2007, you would add the application path 'C:\Program Files\Microsoft Office\Office 122\WINWORD.EXE' to
the 'docx' extension.
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5. Click the 'Add' button. The file extension association will be added to the list. For example, in the picture below you can see that the
'doc' extension has been associated with 'C:\Program Files\Microsoft Office\OFFICE11\WINWORD.EXE'. This is the path to the
Microsoft Word 2003 executable on a specific Windows machine.

Screenshot: Configuring the WebDAV Launcher - configuration of the ‘doc’ file extension complete.

WebDAY Launcher Options

Pl
ext | Application path |E|
doc  C\Program Files\Microsoft OFficel OFFICEL 1\ WINWORD EXE

Delete |

fdd extension

File Extension Iu:lu:u: Auto
Application Path IC:'I,F‘ru:ugram FilesiMicrosc Browse | .......... Add
FETEEEREEERE AR
Save Cancel

Configuring the Add-On in Mac OS X

The only supported Office editor for Mac OS X is NeoOffice. (See Office Connector Prerequisites.)

The add-on will try to configure itself automatically by looking under /Applications/NeoOffice, which is the default installation location
for NeoOffice.

If the automatic configuration does not work, you will need to associate your NeoOffice executable with each file type.

The configuration procedure is similar to Windows, as shown above. Note that there is no 'Auto’ button in Mac OS X.
Configuring the Add-On in Linux

The only known supported Office editor for Linux is OpenOffice. (See Office Connector Prerequisites.)

There is no automatic configuration on Linux. You will need to associate each file type with your Office editor in Firefox. Note that there is no
‘Auto’ button in Linux.

The configuration procedure is similar to Windows, as shown above.

For both Ubuntu and OpenSUSE, the configuration will look something like this:

File Extension  Application Path

doc and docx Jusr/bin/oowriter

ppt and pptx  /usr/bin/ooimpress

x1ls and x1sx  /usr/bin/oocalc

Security Risks

1, Please be aware that there are security risks in installing this add-on to Firefox. Internet Explorer is exposed to the same
risks, because it can directly open Office documents. By installing the add-in into Firefox, you are exposing Firefox to the
same risks.
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Summary of the risks:

® Office documents can contain macro viruses. Before opening an Office document, make sure that you trust the source of the
document.

® There are known flaws in the Office file formats and Microsoft Office that an attacker can exploit to gain control of your machine.
Microsoft has fixed the known exploits in the latest Service Packs for all Microsoft Office versions. But new exploitations may arise at
any time. Again, be sure that you trust the source of a document before opening it.

The add-on tries to reduce the risk by supporting the following:
® Same origin policy — The add-on can only open documents from the same host that initiated the action.

® Digital signature — The add-on is digitally signed. When you install the add-on please verify that it is signed by Benryan Software
Inc.

You have asked to install the following iterm: I

WebDAV Launcherl Benryan Software fnc. | 2
L! k7

from: http:/f192.168.2.105:8080/downlo

!

®* Prompt the user for confirmation — You will always be warned before a file is opened. Please read these warnings carefully
before opening a file. The warning tells you the complete URL of the file as well as the complete application path of the application
opening the file.

wamingt x|

0] The Following location is going ko be opened on wour computer:

2

htkpsflocalhost 5080/ plugins [ servletfeditinmardfdsviewfile+demo, doc
By the program:
:\Program Files\Microsoft Office! OFFICEL 1Y WINWORD,.EXE

This poses a security risk, IF you didn't initiate this ackion or wou don't trust the source of the File,

please click Cancel.
........... T ool |
Lleeeessssnenieninien et

Information about this Firefox Add-On

Add-on name: WebDAYV Launcher
Description: Adds the ability to launch a WebDAV URL directly in a WebDAV-aware client.
Latest version: 1.04

Compatible with:  All versions of Firefox, up to and including 3.6.6

Author: Atlassian Pty Ltd

o We plan to host the add-on at Mozilla. When the add-on has its own page at Mozilla, we will add a link from this page to the Mozilla page.
Please watch CONF-20394 for progress.

Related Topics

Working with the Office Connector

Office Connector Prerequisites

Displaying Office Files in Confluence

Importing an Office Document into Confluence
Editing an Office Document from Confluence
Editing an Office Spreadsheet from Confluence
Editing an Office Presentation from Confluence
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® |[nstalling the Firefox Add-On for the Office Connector
Configuring the Office Connector in the Confluence Administration Guide

Take me back to the Confluence User's Guide.

Importing Content Into Confluence

Confluence 4.0, and later versions, stores all page content as XHTML.

On this page:

Importing Content from Other Confluence Sites
Importing Content from Other Wikis

Importing Content from an Office Document
Importing Web Content

Importing Other Non-Wiki Content

Other Useful Plugins

Note about Plugin Support

Related Topics

Importing Content from Other Confluence Sites

For content originating from other instances of Confluence:

® |f the Confluence major versions are the same, export the space from the originating Confluence site and import it into the
destination Confluence site.
® |f the Confluence major versions are different, you can use an intermediate server to migrate versions.

Page history, attachments, and page content will be preserved and you will be able to do multiple pages at once. The drawbacks are that it

may be inconvenient if the Confluence versions differ, and you cannot have a duplicate space key on the destination instance. (You cannot
import a space with the same space key as a space that already exists.)

Importing Content from Other Wikis

Check whether the Universal Wiki Converter can import the content. See Importing Content from another Wiki.

Importing Content from an Office Document

The Office Connector in Confluence allows you to import an Office document into Confluence, so that the document's content is copied onto
one or more Confluence pages. See Importing an Office Document into Confluence.

Importing Web Content

Here are some options for importing or displaying web content on a Confluence page:

® Use the Widget Macro to display videos, slide shows, twitter chats, documents and more, sourced from other web sites and
displayed on your Confluence page.

® Convert a HTML file to a Confluence page using the HTML To Confluence Converter plugin.

® Embed an external web page into Confluence with the HTML Include macro.

® Use HTML code in a page with the HTML macro.

Importing Other Non-Wiki Content

Importing non-wiki markup into Confluence requires a conversion process:

Text with basic formatting can be pasted directly into the editor. This includes simple Word documents or web pages.
Files such as Microsoft Excel documents can be imported using a content converter plugin.

Confluence pages saved to disk can be imported from disk.

Files can be uploaded in bulk using the Confluence WebDav Plugin.

Full featured customisation is available using the Confluence XML-RPC and SOAP APIs.

Other Useful Plugins

® Content Import Plugin

Note about Plugin Support

Before installing a plugin into your Confluence site, please check the plugin's information page to see whether it is supported by Atlassian, by
another vendor, or not at all. See our guidelines on plugin support.


https://studio.plugins.atlassian.com/wiki/display/UWC/Universal+Wiki+Converter
https://plugins.atlassian.com/search/with?q=converter&amp;product=confluence
https://studio.plugins.atlassian.com/wiki/display/WBDV/Confluence+WebDAV+Plugin
https://plugins.atlassian.com/plugin/details/18345
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Related Topics

Working with the Office Connector
Importing Content from another Wiki

Take me back to Confluence User's Guide

Importing Pages from Disk

Confluence allows you to import text files from a disk or a directory on the Confluence server, and convert them into Confluence pages. Each
file will be imported as a Confluence page that has the same name as the file.

Li ]

® The text file needs to contain Confluence wiki markup to be converted accurately into a Confluence page.

® You need to be a System Administrator to import text files.

® You can import pages from disk into global spaces, but not into personal spaces. Please see Working with Spaces
for information about differences between global spaces and personal spaces.

To import text files:

1. Choose Browse > Space Admin.
o Space Admin is displayed only if you are a space administrator for that space or you are a Confluence system administrator.

2. Click Import pages from disk in the left panel under 'Import'.

. Type the directory's path into the Import directory box.

4. Select Trim file extensions to remove file extensions from the page titles when converting the files to Confluence pages. Note that
the Confluence pages will take their titles from the files' names (including their extensions). So to avoid having page titles with a
suffix like ".txt', make sure you check this box.

5. Select Overwrite existing pages if you want to replace existing Confluence pages with the same page title.

6. Click Import.

w

Screenshot : Importing text files

Import directory:

Trim file extensions: | [

Overwrite existing pages:

s LY by
\Impmt ) \C.ancel )

Related Topics

Take me back to Confluence User's Guide

Sharing Content

Confluence provides a number of ways for you to notify other users about content that may be of interest to them:

® You can share a page link with them.

® You can mention the user when you write a page, blog post or comment. Mentioning a user automatically emails a notification to
them about that content.

® You can broadcast a message that appears in Confluence activity streams.
Other users can also find out about changes to content in Confluence by watching pages and spaces.

You may also be interested in exporting Confluence content to other formats such as XML, HTML, MS Word and PDF.

Related Topics

Creating Content
Watching Changes
Organising Content

Take me back to the Confluence User's Guide.

Network Overview
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The 'network’ feature provides naotifications on the activity of users that you choose to follow. This compares with Confluence's other content
tracking features, which provide notifications on specified types of content updates, made by any user.
The types of activities tracked by the network feature include:

Additions or edits to pages or blog posts
Comments added to a page or blog post or edits to existing comments
Updates to a user's User Status Updates

L]
L[]
L]
® Updates to a user's User Profile

On this page:

Accessing Your Network View
Following Another User

Stop Following a User

Notes

Related Topics

Accessing Your Network View

To see your network view:
® Go to the 'Network' view for your user profile. To do this:

® Go to your name (the 'User' menu) at the top of the page and choose Network.
ﬂ You can also access your 'Network' view by clicking More in the 'Network' section of your Profile Sidebar.

You can access another user's Network view using the Hover Profile or from their Profile Sidebar.

Screenshot: Example of the Network view

' Giles Gaskell

m_l WIS ) Status Updates | Labels | Watches | Drafts § Settings

Recent activity of the users you are following EY Following

You are following 13 users
Per Fragemann

; D Confluence 3 performance release notes updated a minute ago ' E ﬂ-*r
W L™ >y

H
Giles Gaskell B -

Matt Hodges
|=] A little bit of EVA gardening created 20 minutes ago

' Mow working on the Release Notes. & minutes ago -
Joshua Wold |User name |[ Follow ]
':;':' Hand picked by the Father of Java commented 7 minutes ago
L
Followers
Jeremy Largman You have 8 followers
|=] Classpathlltils class attached 16 minutes ago ' - * a
LY i,
1 ¥ 2m
' N

waiting for a call with a dude called Heinz in Switzerland. Maybe he is the man
behind baked beans?
47 minutes ago

Bill Arconati

27 Summit TPS report cover sheet commented about an hour ago

Following Another User

You can follow another user by using either the Hover Profile or your Network view.
To follow a user with the Hover Profile:

1. Open the user's Hover Profile popup. To do this:
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a. Log in to Confluence, if you have not already done so.
b. Move your mouse pointer over a user's linked name or profile picture. Wait until the hover profile popup appears.
2. Click Follow in the popup.

To follow a user from your Network view:
1. Go to the 'Network' view for your user profile. To do this:

® Go to your name (the ‘User' menu) at the top of the page and choose Network.

o You can also access your 'Network' view by clicking More in the 'Network' section of your Profile Sidebar.
2. In the 'Following' section, at the right of the page, type the first few characters of the name (or username) of the user you wish to
follow.
3. Choose the user from the list of suggestions.
4. Click Follow in the popup.

If you now refresh or revisit your Network view, the profile picture(s) of the user(s) you just followed will appear within the 'Following' list on
the right. Additionally, their tracked activities will start appearing in the 'Recent Activity' list on this page.

Stop Following a User

To stop following a user by using the Hover Profile:
1. Open the user's Hover Profile popup. To do this:

a. Log in to Confluence, if you have not already done so.
b. Move your mouse pointer over a user's linked name or profile picture. Wait until the hover profile popup appears.
2. Click Stop Following in the popup.

You can also stop following a user by going to their Profile view.

If you now refresh or revisit your Network view, the profile picture(s) of the user(s) you just stopped following are removed from the
'Following' list on the right. Additionally, their tracked activities will stop appearing in the 'Recent Activity' list on this page.

Notes

Once you are following a user, you can see their activity in a number of ways:

® Your Network view: your Network view shows all the tracked activities that you have permission to view for all the users that you are
following. In the same way, people who follow you will be able to see all your Confluence-based activities on their network views,
provided they have permission to view the content. See below for instructions on accessing your network view.

® RSS feeds: you can subscribe to any Confluence user's network RSS feed and receive summaries on the activities of other users
they are following in their network. See Subscribing to a Network RSS Feed.

® Email notifications: you can request email notifications of any activity in your network. See Subscribing to Email Notifications of
Updates to Confluence Content.

Note that it is not possible to stop another user from following you. If you are interested in the ability to block followers, please watch
CONF-16285 for updates on the feature request.

Related Topics

Network Macro
Subscribing to a Network RSS Feed
Subscribing to Email Notifications of Updates to Confluence Content

Take me back to the Confluence User's Guide.

Subscribing to a Network RSS Feed

You can create an RSS Feed from any user's network view, allowing you to receive summaries on the activities of users they are following in
their network. The types of activities tracked in these RSS feed summaries include:

® Additions or edits to pages or blog posts

® Comments added to a page or blog post or edits to existing comments
® Updates to a user's User Status

® Updates to a user's User Profile

To subscribe to a user's network RSS feed,


http://jira.atlassian.com/browse/CONF-16285
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1. Locate the following icon & | which is available from the top-right of:
®* The 'Recent activity of the users you are following' section of your network page, or
® The 'Activity of followed users' section of another user's network page.
2. Copy and paste the icon's link into your RSS newsreader.
3. To have your newsreader log into Confluence, you can add your username and password to the feed URL.
Please note that if you do this, someone with access to your RSS newsreader configuration can read these
Confluence authentication details.

Customising your Network RSS Feed

Currently, Confluence does not provide a user interface mechanism for customising your network RSS feed. However, you can modify the
maximum number of results and type of content displayed in these feeds by directly editing the RSS feed link in your RSS newsreader.

To modify the maximum number of results displayed in your RSS feed,

1. Edit the RSS feed link in your RSS newsreader.

2. Change the value of the max parameter from its default value of 40 to a value of your choice. The following example
shows this parameter-value combination highlighted in red:
http://confluence.atlassian.com/feeds/network.action?username=ggaskell&max=60
&publicFeed=false&os authType=basic&rssType=atom

3. Save the modified link in your RSS newsreader.

To modify the type of content displayed in your RSS feed,

1. Edit the RSS feed link in your RSS newsreader.
2. Append the parameter contentType to the end of the link, followed by an equals sign (=) and then add the
appropriate content type value of your choice:
® USER_STATUS — restricts the RSS feed to user status updates.
PAGE — restricts the RSS feed to page additions or updates.
BLOG — restricts the RSS feed to blog post additions or updates.
ATTACHMENT — restricts the RSS feed to attachment additions or updates.
COMMENT — restricts the RSS feed to comment additions or updates.

ﬂ Content type values are case-sensitive and when editing the network RSS feed link, ensure that each parameter is
separated from the other by an ampersand (&).
The following example shows the content type parameter-value combination highlighted in red:
http://confluence.atlassian.com/feeds/network.action?username=ggaskell&max=40&publicFeed=1i
&contentType=USER STATUS

3. Save the modified link in your RSS newsreader.

.ﬁ. Filtering for more than one type of content (by adding multiple values to the contentType parameter) is not supported.

RELATED TOPICS

Network Overview
Subscribing to RSS Feeds within Confluence

Take me back to the Confluence User's Guide.

Using Mentions

You can use autocomplete to automatically notify another Confluence user that you have mentioned them in a page, blog post, comment or
status update.

Type '@' to see a list of suggested users to mention. When you save the page, an email is automatically sent to the user to notify them that

they have been mentioned on that page (if they have permission to view the page or blog post). This works for new and updated pages, blog
posts, comment and status updates.

o You need to know the user's real name — autocomplete for mentions suggests users' full names only, not their usernames.
To autocomplete a mention using '@":

1. Edit the page.

2. Click where you want to insert a mention and type '@' and then the first few characters of the user's real name.

3. Choose the user's name from the list of suggestions.

Screenshot: Autocomplete for mentions
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Related Topics
Using Autocomplete
Keyboard Shortcuts

Take me back to the Confluence User's Guide.

Watching Changes

Confluence provides several ways by which you can watch for changes to single pages, entire spaces, and all spaces on the site. When you
watch a page or space, Confluence sends you an email whenever that content changes.

You can also track a particular user's activity on the Confluence site.

o You can only track updates to content that you have permission to see.

Manually Watching Content

You can 'watch' a page or a space that you have permission to view. Confluence will then send you a notification by email whenever anyone
adds or updates content on, or adds a comment to, that page or space.

® There is no daily digest for these notifications. You will receive an email notification every time someone makes a change.
® You can choose the pages and/or spaces that you want to watch. You can ‘'unwatch' a page or a space at any time.

To set up a watch on a specific page or space, see:
® Watching a Page or Blog Post
® Watching a Space

Configuring Watches

All email notification settings can be changed from one location. See Editing User Settings.

Manage Watchers

Space administrators are able to manage watchers of pages and spaces.

@ Using labels and RSS feeds as an alternative to watches
You can use the RSS feed builder to track updates to labelled pages and comments on those pages. Here is an idea for
customising your RSS feed by using your own personal label(s). This is useful if you want to track updates to specific
pages or blog posts, and you do not want to deal with emails. You can use this method as an alternative to watching
pages.

® Build an RSS feed that returns pages, blog posts and comments labelled with a personal label, such as 'my:feed'.
® Each time you want to ‘'watch' a page, just label it with ‘my:feed'.
® All updates and comments will automatically come through your RSS feed.

Confluence RSS Feeds
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You can watch for content changes in Confluence using RSS feeds.
® Create a customised RSS feed using the RSS Feed Builder.

® Subscribe to one of the pre-specified feeds generated by Confluence.

Related Plugins

® The Contributors plugin allows you to list the users, watchers, labels and etc in a page.
® The Autowatch Plugin allows you to automatically watch a page or blog post that you have created or edited. For example, if you
comment on a page, you will be set to watch that page for further updates.

Plugins should be used with care. Please refer to the note on supported plugins.

Related Topics

Page History and Page Comparison Views
Viewing Space Activity

Take me back to the Confluence User's Guide.

Watching a Page or Blog Post

You can ‘'watch' a Confluence page, blog post or space. Confluence will then send you a notification by email whenever anyone updates the
watched content.

You will receive email notifications for:
® Edits (unless the user clears the Notify watchers check box).
® Deletions.
® Attachments, including new versions or deletions of an existing attachment.
® Comments, including new comments, edits of existing comments or deletions of existing comments.

By default, Confluence will assign you as a watcher of any page or blog post that you create or edit. This behaviour is called 'autowatch'. Yot
can control autowatch.

There is no daily digest for email notifications. You will receive an email notification every time someone makes a change.
You will not receive email notifications for content changes due to the output of a macro, because the page content itself has not been

edited.

ﬁ You need 'View' permission for the page, blog post or space to receive notifications.

On this page:

Watching a Page or Blog Post

Setting Autowatch and Other Notification Options
Watching an Entire Space

Watching for New Blog Posts

Managing Watches from your User Profile
Managing Watches from the Email Message
Related Topics

Watching a Page or Blog Post

To start watching a page or blog post:

1. Go to the page or blog post.
2. Choose Tools > Watch.

To stop watching a page or blog post:

1. Go to the page or blog post.
2. Choose Tools > Stop watching.

Setting Autowatch and Other Notification Options

By default, Confluence will assign you as a watcher of any page or blog post that you create or edit. This behaviour is called ‘autowatch'. You
can turn autowatch on or off, and set other notification options, in the email settings section of your user profile. See Setting User Settings.


https://studio.plugins.atlassian.com/wiki/display/CONTRB/Confluence+Contributors+Plugin
http://www.randombits.org/display/CONF/Autowatch+Plugin
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Watching an Entire Space

You can choose to watch all the pages and blog posts in a given space. See Watching a Space.

Watching for New Blog Posts

You can choose to watch for:

® New blog posts in a given space. See Watching a Space.
® All new blog posts in the Confluence site. See Subscribing to Email Notifications of Updates to Confluence Content.

Managing Watches from your User Profile

The 'Watches' page in your user profile displays a list of all pages and spaces you are currently watching.
To manage your watches:
1. Go to the 'Watches' view for your user profile, as follows:

® Goto your name (the 'user' menu) at the top of the page and choose Watches.
2. Click the envelope icon next any unwanted watches to turn them off.

Managing Watches from the Email Message

The email notifications that you receive from Confluence have some useful links at the bottom of the email message. The links in each
message vary, depending on the context. In general, the links allow you to view the page online, reply to a comment, and so on. In particular
with respect to setting your notification preferences, you will see one or more of the following links:

® Stop watching page — Click this link to stop watching the page that triggered the email notification.

® Stop watching space — Click this link to stop watching the space that triggered the email notification.

® Stop following this user — Click this link to stop following the user whose update triggered the email notification.
® Manage Notifications — Click this link to go to the email settings page in your user profile.

Screenshot: Email notification footer showing links

View Online | View Changes | Add Comment Stop watching page | Manage Notifications

This message was sent by Atlassian Confluence 4.0, the Enterprise Wiki

S Reply =P Forward

Related Topics

Watching a Space

Subscribing to Email Notifications of Updates to Confluence Content
Watching Changes

Updating Email Address

Take me back to Confluence User's Guide

Watching a Space

You can ‘'watch' a Confluence page, blog post or space. Confluence will then send you a notification by email whenever anyone updates the
watched content.

You will receive email notifications for:

® Edits (unless the user clears the Notify watchers check box).

® Deletions.

® Attachments, including new versions or deletions of an existing attachment.

® Comments, including new comments, edits of existing comments or deletions of existing comments.

By default, Confluence will assign you as a watcher of any page or blog post that you create or edit. This behaviour is called 'autowatch'. You
can control autowatch.

There is no daily digest for email notifications. You will receive an email notification every time someone makes a change.
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You will not receive email notifications for content changes due to the output of a macro, because the page content itself has not been
edited.

»ﬂ You need 'View' permission for the page, blog post or space to receive notifications.

On this page:

Watching an Entire Space

Watching for New Blog Posts in a Space
Watching all Spaces on the Site

Managing Watches from your User Profile
Managing Watches from the Email Message
Related Topics

Watching an Entire Space
Watch a space if you want to receive notifications of updates to any content in the space.
To start watching a space:
1. Goto a page in the space and choose Browse > Advanced.
2. In the left-hand panel, click Start watching this space (or Start watching all content).
To stop watching a space:
1. Goto a page in the space and choose Browse > Advanced.

2. In the left-hand panel, click Stop watching this space.

Watching for New Blog Posts in a Space

You can choose to receive a notification whenever someone adds a blog post in the space. You will not receive notification of updates to or
deletions of blog posts, nor of comments on the blog posts.

Hint: By default, the option is labelled Start watching space blogs. If you are already watching the entire space, the wording will change to
Only watch space blogs. If you choose that option, you will no longer be watching the entire space.

To start watching for new blog posts in a space:

1. Go to a page in the space and choose Browse > Advanced.

2. In the left-hand panel, click Start watching space blogs (or Only watch space blogs).
To stop watching for new blog posts in a space:

1. Goto a page in the space and choose Browse > Advanced.

2. In the left-hand panel, click Stop watching space blogs.

Watching all Spaces on the Site

You can receive notifications about changes to the content of pages, blog posts and comments from across all spaces on a Confluence site.
To start watching for content changes across the whole site:

Go to your name (the 'User' menu) at the top of the page and choose Settings.
Click Email in the left-hand panel.

Click Edit and select Subscribe to daily updates.

Click Submit.

rPODNPE

Managing Watches from your User Profile

The 'Watches' page in your user profile displays a list of all pages and spaces you are currently watching.
To manage your watches:
1. Go to the 'Watches' view for your user profile, as follows:

® Go to your name (the 'user' menu) at the top of the page and choose Watches.
2. Click the envelope icon next any unwanted watches to turn them off.
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Managing Watches from the Email Message

The email notifications that you receive from Confluence have some useful links at the bottom of the email message. The links in each
message vary, depending on the context. In general, the links allow you to view the page online, reply to a comment, and so on. In particular
with respect to setting your notification preferences, you will see one or more of the following links:

® Stop watching page — Click this link to stop watching the page that triggered the email notification.

® Stop watching space — Click this link to stop watching the space that triggered the email notification.

® Stop following this user — Click this link to stop following the user whose update triggered the email notification.
® Manage Notifications — Click this link to go to the email settings page in your user profile.

Screenshot: Email notification footer showing links

View Cnline | View Changes | Add Comment Stop watching page | Manage Motifications

This message was sent by Atlassian Confluence 4.0, the Enterprise Wiki

* Reply =¥ Forward

Related Topics

Watching a Page or Blog Post

Subscribing to Email Notifications of Updates to Confluence Content
Watching Changes

Updating Email Address

Take me back to Confluence User's Guide

Managing Watchers

If you are a space administrator for a space, you can manage the watchers for all pages and blog posts in that space. This means that you
can:

® View a list of the watchers of a page/blog post.

® View a list of the watchers of the space for that page/blog post.
® Add users as watchers of the page/blog post.

® Remove existing watchers of the page/blog post.

o It is not possible to remove watchers of the space.
To manage your watchers for a page/blog post:

1. Navigate to the page or blog post for which you want to manage the watchers. Note, you must be a space administrator for the
space that the page is in.

2. Choose Tools > Manage Watchers. The 'Manage Watchers' screen will be displayed (see screenshot below). The left-hand column
of the 'Manage Watchers' screen will contain the users watching the page/blog post, the right-hand column will contain the users
watching the space.

® To remove an existing page watcher, click the icon (trash can) next to the user's name.
® To add a user as a watcher of the page, type in the box and choose the user's name from the list.
3. Click Done to save your changes.

Screenshot: Managing Watchers
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Manage Watchers

Watching this page Watching this space

These people are notified when the page is changed. You can These people are notified when any content in the space is
add or remove people from this list. changed. You cannot modify this list.

Full name or username Add @ Rosie Jameson (rosie@atlassian.com)

m Sarah Maddox (smaddox)
& Andrew Lui (alui)

a Tim Moare (tmoore)

Eb

Related Topics

Watching a Space

Watching a Page or Blog Post

Subscribing to Email Notifications of Updates to Confluence Content
Watching Changes

User Profile Overview

Take me back to the Confluence User's Guide.

Subscribing to Email Notifications of Updates to Confluence Content

You can 'watch' a page or a space. Confluence will then send you a notification by email whenever anyone adds or updates content on that
page or space. You can also subscribe to daily email reports and other notifications of various updates, as described below.

Email notifications can be set to show the changes made to the page content. The changes are displayed as rendered page diffs. See Page
History and Page Comparison Views.

On this page:

® Subscribe to email notifications
® Subscribe to RSS feeds
® Related Topics

Subscribe to email notifications

You can subscribe to email notifications about:

® Updates to a particular space or a page.

® Changes in all spaces that you have permission to see.
® Updates made by the people you are following.

® All pages that you create, edit or comment on.

Subscribe to RSS feeds

You can subscribe to Confluence RSS feeds to stay informed about:

New and updated pages

New comments

New news items

New attachments

Updates to and comments on pages that have a given label

Related Topics

Watching Changes
User Profile Overview
Configuring a Server for Outgoing Malil

Take me back to the Confluence User's Guide.

Subscribing to RSS Feeds within Confluence

RSS feeds allow you to track updates to content within Confluence. You will need an RSS newsreader to subscribe to them.
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On this page:

Confluence RSS Feeds
RSS Newsreaders
Removing an RSS Feed
Related Topics

Confluence RSS Feeds

You can create a customised RSS feed using the RSS Feed Builder or subscribe to one of the pre-specified feeds generated by Confluence.
What would you like to do?

® Create and subscribe to customised RSS feeds using the RSS Feed Builder — create a customised RSS feed (e.qg. filter your feed
using a label; specify the number of items and days to include in your feed,; etc.)
E

* Subscribe to pre-specified RSS feeds =4 — generate an RSS feed automatically in a minimal number of steps.
® Subscribe to a feed of any Confluence user's network to track the activities of users they are following in their network.

RSS Newsreaders

The following are some popular RSS newsreader programs for various operating systems. You can find a more comprehensive list on
Google's open directory.

Windows

SharpReader
NewsGator
Syndirella
FeedDemon
NewzCrawler

Mac OS X
® Safari
* NetNewsWire
®* NewsFire
® Shrook
Multi-Platform
* NewsMonster (Runs in the Mozilla web browser)

® Radio Userland (Windows and MacOS)
* AmphetaDesk (Windows, Unix, Mac OS X)

Removing an RSS Feed

There is no need to try to delete or remove an RSS feed built by the Confluence RSS feed builder.

Explanation: The feeds generated by the RSS Feed Builder are dynamically generated via the parameters included in the feed URL
(address). For example, take a look at the following feed URL:

The above feed URL will generate a list of pages (‘types=page"), sorted by the modification date and showing the page content. The feed is
generated at the time when the URL is fetched and there is no RSS feed information stored on the database. For that reason, there is no
need to remove anything.

Related Topics

Watching Changes
Working with RSS Feeds
RSS Feed Macro

Take me back to the Confluence User's Guide.
Using pre-specified RSS feeds

o If you want to customise your Confluence RSS feed (e.g. use a label to filter your feed), use the RSS Feed builder instead.
To subscribe to RSS feeds generated by Confluence, for a particular space:

1. Choose Browse > Advanced from the dropdown list. The '‘Advanced' screen will appear.
2. Click on RSS Feeds in the left-hand column.


http://directory.google.com/Top/Computers/Software/Internet/Clients/WWW/Feed_Readers/
http://www.sharpreader.net
http://www.newsgator.com
http://www.yole.ru/projects/syndirella/
http://www.bradsoft.com/feeddemon/
http://www.newzcrawler.com/
http://www.apple.com/macosx/features/safari/
http://ranchero.com/software/netnewswire/
http://www.newsfirerss.com
http://www.fontandfancies.com/shrook
http://www.newsmonster.org/
http://radio.userland.com
http://www.disobey.com/amphetadesk/
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3. Copy and paste the link for one of the following feeds into your RSS newsreader:
L]

Pages
News

Mail

Comments
Attachments
All content

To subscribe to RSS feeds generated by Confluence, for a particular page (where available):

[

1. Locate the following icon, which is available in the top-right corner of certain pages: o
2. Copy and paste the icon's link into your RSS newsreader.

Related Topics

Using the RSS Feed Builder

Watching Changes

Working with RSS Feeds

RSS Feed Macro

Take me back to the Confluence User's Guide.

Using the RSS Feed Builder

Using the RSS feed builder, you can create customised RSS feeds to subscribe to changes within Confluence.

Wondering what an RSS feed is? See more information about RSS Feeds.

On this page:

Building an RSS Feed

Hint: Using Labels to Customise your Feed
Notes

Related Topics

Building an RSS Feed

Follow the steps below to build your feed, choosing the type of content and the time period you want to monitor.

To create a customised RSS feed:

1. Choose Browse > Feed Builder.

2. Select the content types you want in your feed. Check Mail if you want to know when the email archive is updated. (See the
overview of mail archives in Confluence.)

3. Select one or more spaces from the list.

4. Click Advanced Optionsto set the following:

Option

Feed Name

With these
labels

Exclude
these
spaces

Sorted by

Limit to

Within the
last

99

Description

The default name is based on the name of your Confluence installation, e.g. 'Extranet RSS Feed'

Enter one or more labels separated by spaces or commas. Confluence returns all content (of the selected types)
that matches one or more of the labels. See the hint below about using labels to customise your feeds.

Exclude specific spaces from those already selected.

Sort content by either the date or creation or the date they were last updated.

Specify the number of items returned in your feed.

Specify how old items returned can be.
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Include Specify whether the entire page is displayed in the feed.
content for
pages

5. Click Create RSS Feed to create your feed.
6. Drag or copy the link into your RSS reader.

Tip: Try building separate feeds, one for pages only and one that includes comments as well. This allows you to monitor only pages if
you are short of time, and to read the comments when you have more time.

Hint: Using Labels to Customise your Feed

You can use the RSS feed builder to track updates to labelled pages and comments on those pages. Here is an idea for customising your
RSS feed by using your own personal label(s). This is useful if you want to track updates to specific pages or blog posts, and you do not want
to deal with emails. You can use this method as an alternative to watching pages.

® Build an RSS feed that returns pages, blog posts and comments labelled with a personal label, such as 'my:feed'.
® Each time you want to 'watch' a page, just label it with 'my:feed'.
® All updates and comments will automatically come through your RSS feed.

Notes

® Removing an RSS feed: You need only delete the RSS feed link built by the Confluence RSS feed builder to remove an RSS feed
from your page. This is because the feed is dynamically generated using the parameters in the feed URL.

® Feed authentication options:Confluence can offer you the option of an anonymous feed or a feed that requires authentication.

® An anonymous feed will show only the content that is visible to anonymous users. The feed URL does not contain the
&os_authType parameter mentioned below. This feed is useful only if your Confluence site allows anonymous access. If a
feed is anonymous, you only get anonymously-viewable content in the feed regardless of whether you are a Confluence
user or not.

® An authenticated feed requires you to log in to Confluence before you can retrieve the content. The feed URL contains the
following parameter: &os_authType=basic.

® The option to choose between an anonymous and an authenticated feed is currently not available on the feed builder
screen. The feed builder offers only authenticated feeds. See CONF-21601 for details and a workaround.

Related Topics

RSS Feeds FAQ
Watching Changes
Working with RSS Feeds

Take me back to Confluence User's Guide

Working with RSS Feeds

An RSS feed is a format for delivering summaries of regularly changing web content. Subscribing to an RSS feed allows you to stay informed
of the latest content from sites that you are interested in.

RSS isn't designed to be read in a regular web browser. Specialised RSS newsreader programs can check RSS files every so often, and tell
you what's new on a site. Your reader may be on a website, an addon to your browser, part of your email program, or a stand-alone program.

Confluence works with RSS in two ways:
® Confluence generates its own RSS feeds for tracking updates to content within Confluence. You will need an RSS reader which can
grab the RSS feeds from Confluence and display them for you.
® Confluence's RSS macro allows you to display the contents of RSS feeds on a Confluence page. The feeds may come from a
Confluence feed generator or from external sites. In this way, Confluence can act as an RSS reader.

For a technical description of RSS, read Mark Pilgrim's "What is RSS?" article on XML.com.
Related Topics

Subscribing to RSS Feeds within Confluence

Displaying content from RSS feeds on a Confluence page

Watching Changes

Take me back to Confluence User's Guide

RSS Readers Compatibility

Due to some users having problems with Confluence RSS Feeds, some research was done with several RSS Feed Readers. RSS Feeds
have been created through the feed builder and tested on a Windows machine. For each feed reader they have been tested with both
authentication and public access, checking for the visibilty of content, icons and images. The results are in the tables below:

100


http://jira.atlassian.com/browse/CONF-21601
http://www.xml.com/pub/a/2002/12/18/dive-into-xml.html

Confluence 4.0 Documentation

Feeds with authentication

RSS Feed Reader Content Icons Images Notes

RssReader

1.0.880 ® Shows the entire page (including the header panel & view,edit tabs)

JetBrains Omea

Reader 2.1.6 ® Shows the changes between revisions in the nice red/green colours of
Confluence

IE7.0 ﬁ

® Content is all there however not all html is rendered correctly (for example
.tag {font-style:italic;} is shown in the content as raw text)
® Shows the changes between revisions, but without the red/green colours

Thunderbird

15.0.7 ® Shows the entire page

Bloglines

® Simple online feed reader
® Shows the changes between revisions, but with arrows

Google Reader

® Simple online feed reader
® Shows the entire page

Yahoo E ﬁ ﬁ

® Error message: Invalid URL format

Feeds with public access

RSS Feed Reader Content Icons Images
RssReader 1.0.880

JetBrains Omea Reader 2.1.6

IE7.0

(X
Thunderbird 1.5.0.7

Bloglines

Searching Confluence

The search box at the top right of your Confluence screen allows you to search Confluence wherever you happen to be in the site. It offers
you a quick navigation aid as well as a full site search.

Browse » Log In [SEEly I

You can also search Confluence directly from your browser's search box.
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@ Quick guide to searching in Confluence

® You can search Confluence using your browser's search box (Firefox or Internet Explorer 7 or later). Just add your
Confluence site as a search provider using the dropdown menu in your browser's search box.

® The Confluence search box (top-right corner) suggests search terms as you type. If your desired search term is
suggested, you can open the page simply by clicking on it.

® Performing a full search provides you with more detailed search results, including the ability to preview images and
Office documents.

® The full search also suggests alternative spellings ('Did you mean') as part of your search results.

On this page:

Searching Confluence from your Browser's Search Box
Using the Quick Navigation Aid

Search Options When Using the Documentation Theme
Performing a Full Search

Viewing Attached Office Documents

Accepting 'Did you mean' Suggestions from Confluence
Filtering your Search Results

Advanced Search Syntax

Browsing Related Labels

Searching the Content of Attachments

Related Topics

Searching Confluence from your Browser's Search Box

If you are using Firefox or Internet Explorer 7 or later, you can add add your Confluence site as a search provider, using the dropdown menu
next to the browser's search box.

The example below shows the 'Extranet' Confluence site offered for inclusion as a search engine in the browser's search box.

Screenshot: Adding your Confluence site to your browser's search box

. 2
Google

“W* Yahoo.co.uk

2 Amazon.co.uk

A: Answers.com
Chambers (UK)
@ Creative Commons
Y eBay.co.uk

W Wikipedia (en)

" E@ add "Extranet”

Manage Search Engines...

Information about OpenSearch:
® Confluence supports the autodiscovery part of the OpenSearch standard, by supplying an OpenSearch description document. This
is an XML file that describes the web interface provided by Confluence's search function.

® Any client applications that support OpenSearch will be able to add Confluence to their list of search engines.
® Your Confluence Administrator can enable or disable the Open Search feature using the Confluence Administration Console.

Using the Quick Navigation Aid

The quick navigation aid automatically offers a dropdown list of pages and other items, matched by title to your search query. You can select
one of the offered items or ignore them altogether.

To use the quick navigation aid:
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1. Start typing your query into the search box located at the top right-hand corner of every screen. Confluence matches titles as you
type, showing a quickly-adjusting dropdown list of pages, blog posts, personal profiles, attachments and so on.

0 Press the Enter key if you want to bypass the quick navigation aid and perform a full search, as described below.

. To see the space to which an item belongs, let your mouse pointer hover over the item in the dropdown list.

. Use the up- and down-arrows on your keyboard to move up and down the list of matching titles and select an item.

. Press the Enter key to open the selected item.

. If you do not find what you are looking for, click Search for at the bottom of the list to do a full search. This has the same effect as
pressing Enter immediately after typing your search query. The full search is described below.

abownN

Screenshot: The quick navigation aid showing titles matching the query ‘con'

Browse = Sarah Maddox ~ [y I

Sys-Con

Concepts

Confluence vs Confluence
ConcurrentOperationiap

WY SIWY G Editor for Confluence

by Oy E O O

Concurrency Problems

CON-lcons-04.png

BI BI

CON-lcons-02.png
Jim Conaty
C4 Search for ‘con’

Here is more information about how the quick navigation feature works:

® Confluence will truncate any titles that are too long to be displayed.

® |f atitle is too long to fit the box, hover your cursor over the title to see the full text.

® The matching items are grouped by content type so that you can quickly find the type you want. Confluence shows a maximum of 6
pages and/or blog posts, 2 attachments, 3 people and 2 spaces. If no matches are found in a particular category, then that category
does not appear in the list.

Iltems are ordered with the most recent updates first.

When the matching item is a person's name, their profile picture appears next to their name in the list.

The part of the title that is matched by the search query is highlighted in bold text.

Your Confluence Administrator can enable or disable the quick navigation feature using the Confluence Administration Console.

Search Options When Using the Documentation Theme

When using the Documentation theme, the Confluence search offers a few options as described below.
Using the search box at the top right of the page:

® By default, the main Confluence search is configured to search the entire Confluence site.

® You will see the words 'Search Confluence' in the search box at top right of the page.

® The Confluence search will look for matches in the entire Confluence site. This is the default behaviour for other themes too.
® A space administrator can configure the Documentation theme to restrict the search to the current space.

® You will see the words 'Search this space' in the search box at top right of the page.

® The search will return results from the current space only.

® You can override the search restriction. Enter ‘all:' and your search term to search the entire site. For example, enter the

following into the search box at top right of the page to search the entire site for 'technical writing':

all: technical writing

Using the search box in the left-hand panel:
® By default, the Documentation theme's left-hand panel includes a search box. Enter your search term there, to restrict the search to

the current space. Specifically, this will search only the pages that are children of the space's home page.
® |f your administrator has restricted the main search to the current space, there will not be a search box in the left-hand panel.
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For screenshots and a full description, see Using the Documentation Theme.

Performing a Full Search

When you perform a full search, Confluence will search all content in all spaces (global and personal), mail, personal profiles, attachments
and the space description. The results will appear on a new screen.

#) For the developers

The rendering of search results in Confluence is pluggable. If you are a developer, you may wish to write your own search
result renderer to change how the search results are displayed. For more information, please refer to the following
developer document: Writing a search result renderer.

To use the full search:

1.

2.

Type your query into the search box located at the top right-hand corner of every screen (or type it into the text box at the top of the
Search screen).

Press the Enter key. (This means that you will ignore the dropdown list of titles offered by Confluence's quick navigation aid,
described above.)

. The Search screen appears, as shown below. If any Confluence pages or items match your search query, the Search screen shows

a list of the matching items.

. Click an item's title to open the Confluence page or other item.

Screenshot: Results of searching for 'permissions’

X

Showing 11-20 of 437 for permissions

permissions

|=] Navigating to the Space Permissions View ngﬁ;im Docs 3.1 =
The 'Space Permissions’ view allows a space administrator to determine who can view and modify content in the space.
Go to the 'Space Permissions’ view of the "Space Admin’ function. To do this: Go to a page in the space where you What
want to view or assign permissions. Open the ‘Browse” menu at the top of the screen All Content
Confluence Docs 3.1 Aug 06, 2008
When
=1 Changes to the Page Permission APl in Confluence 2.4 Any date
Confluence 2.4 contains changes to the Confluence AP that will affect any plugins that modify Page Permissions (aka
ContentPermissions). Some methods have ... and edit permissions on a page. The Content Permission AP| allows Who
such a state. but it should be avoided. For example. if a Page has multiple permissions set
Confluence Docs 3.1 May 23, 2007 Content the user has created or edited.
=] new-permissions.png o Clear Filter

26 kB -796x214 Download
Confluence Docs 3.1 = Release Notes 1.3 = Atachments  Nov 30, 2004

=] pagepermission [pg bz;nmtﬁ?ma
12 kB-631x160 Download access
Confluence Docs 3.1 = Space Attachments Directory = Attachments Mow 28, 2005 SBCLIFiQ,{
space
|=] Are all users in LDAP visible in Confluence administration and can they can be assigned confluence

permissions or to groups?

Browse Labels

All LDAP users with ‘Can Use’ permission can be viewed from the user browser, even if they have never logged in.
When an LDAP user logs in for the first time, a Confluence user account is created automatically to store their

On the left of the screen you will see a text block for each item that matched the search criteria, with the following information for each item:

An icon representing the content type (user profile, space, page, blog post, etc). See Confluence Icons.

The title or name of the content item.

For attachments: The size and type of file, with a link to download or view the attachment where relevant. See information on viewing
Office attachments below.

For image files: A thumbnail of the image will display to the right of the file name.

The most relevant few lines of content from within the item. Any words that match your search query are highlighted within the
content.

For personal profile items: The email address.

The space to which the item belongs, displayed on the last line of the item's text block.

The date when the content item was last modified.

You will see only search results which you have permission to view.

On the right of the screen are further options which allow you to tailor or filter your search results. See below.

Viewing Attached Office Documents

When the search results include an attached Office document, you will see a View link as shown in the screen snippet below.
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Screenshot: Search results include an attached Office document with ‘View' link

% spreadsheet.xls task

Showing 1-4 of 4 for spreadsheet.xls task

. Where
E spreadsheet.xls All Spaces ™
20 kB Excel Spreadsheet View Download T
Task Monday Tuesday Wednesday Thursday Friday Saturday Sunday Total 39755 What
39756 39757 39758 39759 39760 39761 Planning 5 3 Design 3 5 2 Development 6 5 5 All Cantent ™
Testing 2 3 Admin 1 —
Documentation Testing = Displaying a Word Document = Attachments Mowv 11, 2008 When
. Any date ™
& spreadsheet.xls o

20 kB Excel Spreadsheet View Download Whao
Task Monday Tuesday Wednesday Thursday Friday Saturday Sunday Total 39755
397596 39757 39758 39759 39760 39761 Planning 5 3 Design 3 5 2 Development 6 5 5

Testing 2 3 Admin 1 Clear Filter

Documentation Testing = Displaying an Excel Spreadsheet = Attachments MNov 11, 2008

Click the View link to view the content of the Office document within Confluence. If you have an Office application installed, you will also be
able to launch your Office editor from within Confluence. See Displaying Office Files in Confluence and Working with the Office Connector.

Accepting 'Did you mean' Suggestions from Confluence

When you perform a full Confluence search, as described above, Confluence may offer you an alternative spelling of your search query. The
alternative spelling will appear next to the words 'Did you mean', as shown in the example below.

To accept an alternative spelling suggestion:

1. Type your query into the search box.

2. Press the Enter key.

3. Confluence will analyse the wiki content, to determine whether an alternative spelling of your search query occurs more often in the
wiki content. If this is the case, the words 'Did you mean' will appear on the screen, along with an alternative spelling for your search
query.

4. If you want to try the alternative spelling, click the word showing the suggested spelling. In the example below, you would click
confluence.

Screenshot: The Search screen with 'Did you mean' offering a corrected spelling

% cnofluence

Did you mean: confluence

Where
Mo results found for cnofluence. Please try one of the following suggestions: All Spaces 54l
+ Use more general search terms What -
« [fyou are filtering by space, content, last modification date or contributor, try All Content 54l
remaving or adjusting the filter
When -
Any date B4
Who

Clear Filter

Here is more information about how the 'Did you mean' feature works:

® Confluence uses both a dictionary (bundled with Confluence) and words mined from the content on your system to work out the best
alternative spellings of your search terms. Practically, this means that Confluence can provide spelling corrections for specialised
jargon that may not appear in a standard dictionary. In general, when deciding between alternative spellings, Confluence will favour
words that appear more often in your content.

® |n some cases, the 'Did you mean' suggestion may appear even when there are Confluence pages, etc, which match your search
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query. In other cases, there will be no items which match your search criteria. In both cases, Confluence will offer a 'Did you mean'
suggestion if there is a word which will help you find more relevant content.

® The 'Did you mean' feature may offer more than one suggestion.

® The 'Did you mean' suggestion may even offer an incorrect spelling. This would happen if the incorrect spelling occurs many times
within your Confluence site. This is intentional, because the aim of the 'Did you mean' feature is to help you find content, not to
correct your spelling.

® Your Confluence Administrator can enable or disable the 'Did you mean' feature using the Confluence Administration Console.

Filtering your Search Results

The Search screen, pictured above, appears when you do your first search. By default, Confluence will search all content across your
Confluence site, including all spaces, mail archives, attachments and all other content types.

On the right of the screen are options which allow you to tailor or filter the search results.

Where

|AII Spaces [V]
What

|AII Content [V]
When

|Any date [V]
Wha

Clear Filter

Enter your filter criteria as described below, then click Filter.

® Where — Restrict your search results to a particular space, or to your favourite spaces, global spaces or personal spaces.
® What — Restrict your search results to a particular content type (pages, blog posts, mail, etc).
® When — Restrict your search results to content modified within a particular period of time (today, yesterday, within the last week or
within the last month).
® Who— Restrict your search results to content last modified by a particular user. You can start typing the person's username or part
of their name into the text box as follows:
® Type the username (e.g. ‘jsmith’).
® Or start typing the person's first name (e.g. john’)
® Or their last name (e.g. 'smith’).
® Or another part of their name, such as a middle name.
Confluence will offer you a list of possible matches. Use your mouse to select the person you want, then press the Enter key
to filter the search results.

Screenshot: Filtering your search results by user

Whao:
iol

Jonathan Malen (jnolen)
Joshua Mah (jnah)
Josh Spear (jspear)

Jo Perrett (jperrett)

Joshua Wold (jwold)

More information about the user-matching filter:

® The user-matching filter is not case sensitive. You can enter upper or lower case letters and will receive the same results.

® When looking for users to match the name you entered, Confluence divides a person's name into logical units corresponding to first
name, middle name (one or more) and last name. It matches the letters of each unit in the name you entered against the letters of
each unit in the user directory. For example, you can enter 'jo sm' to look for John Smith. The search is triggered after you have
entered at least two letters.

® For each part of the name, you need to enter at least two letters. For example, if you enter just 'john s', the filter will look for users
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called 'john" and will ignore the 's'. Similarly, if you enter 'j smith' you will see everyone with the name 'smith’ even if their first name
does not start with a 'j'.

® You are not forced to use the auto-complete list. You can just type ‘jsmith' or 'jo sm' and filter on that without choosing a match from
the dropdown list. Confluence will warn you if there is more than one user corresponding to the name you have entered.

Click Clear Filter if you want to remove all your filters and perform the same search again but without the filter.

Advanced Search Syntax

See Confluence Search Syntax for more ways to refine the text you enter into the search box.

Additionally, see Confluence Search Fields for special parameters you can use in the search box to search on various metadata.

Browsing Related Labels

Also on the right of the Search screen, Confluence will offer a list of labels which are related to your search query. See the screenshot above.

You can click a label to see all pages and blog posts tagged with that label. See Navigating Pages by Label.

Searching the Content of Attachments

When you search Confluence, by default the search will include the content of the following types of attachments:

Word

Text
PowerPoint
Excel

PDF

HTML

To search the content of other attachment types, you will need to use an attachment content extractor plugin. For more information, take a
look at the following:

® Existing extractor plugins which you can install on your Confluence site.
® Guidelines on developing your own attachment content extractor plugin.

Related Topics

Confluence Search Syntax

Confluence Search Fields

Ranking of Search Results

Text Tokenisation and Filtering

Search Macro

Livesearch Macro

Pagetree Macro (includes an optional search box)
Viewing Labelled Pages

Searching the People Directory

Take me back to the Confluence User's Guide.

Confluence Search Fields

ﬂ Purpose of this document

This page is intended for developers and advanced users of Confluence. It gives an overview of the Apache Lucene
search fields used in Confluence.

On this page:

® Searching for Content in Specific Fields
® Confluence Search Fields

® Personal Information

® Pages

® Blog

® Attachments

® Mail ltems
® Related Topics

Searching for Content in Specific Fields
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Confluence data is stored in fields which can be specified in the search. To search a specific field, type the name of the field followed by a
colon "' and then the term you are looking for.

Examples:
i title:"Some Title" i
H labelText :chalk H

The field specification applies only to the term directly preceding the colon. For example, the query below will look for "Some" in the title field
and will search for "Heading" in the default fields.

o
-
o
e
o
9]
0
3
o
Jos]
)
Q
Q.
s
o]
Q

Confluence Search Fields

Below are the fields which can be searched, listed by content type.

Personal Information

Name Indexed Stored Tokenised Notes
handle true true false
type true true false
urlPath true true false
fullName true true true
username true true true
title true true false
label Text true true true
modified true true false
created true true false
userpermission  true true false
contentBody true true true
Pages
Name Indexed Stored Tokenised Notes
handle true true false
type true true false
urlPath true true false
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title true true true

spacekey true true false

labelText true true true

modified true true false

created true true false

userpermission  true true false

contentBody true true true

lastModifiers true true false Username of the user who last updated the page.

creatorName true true false Username of the user who added the page.

macroName true true false The name of a macro used on the page
Blog

Name Indexed Stored Tokenised Notes

handle true true false

type true true false

urlPath true true false

title true true true

spacekey true true false

labelText true true true

modified true true false

created true true false

userpermission  true true false

contentBody true true true

lastModifiers true true false Username of the user who last updated the blog post.

creatorName true true false Username of the user who created the blog post.

macroName true true false The name of a macro used in the blog
Attachments

Name Indexed Stored Tokenised Notes
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handle true true false
type true true false
urlPath true true false
filename true true true
title true true false
comment true true true
spacekey true true false
modified true true false
created true true false
userpermission true true false
contentBody true true true
Mail Items
Name Indexed Stored Tokenised Notes
handle true true false
type true true false
urlPath true true false
title true true true
spacekey true true false
messageid true true false
inreplyto true true false
recipients true true true
labelText true true true
modified true true false
created true true false
userpermission true true false
contentBody true true true
lastModifiers true true false The username of the user who did the mail import, not the person who sent the

email message.
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creatorName true true false The username of the user who did the mail import, not the person who sent the
email message.

Related Topics

® Searching Confluence

Confluence Search Fields
Confluence Search Syntax
Ranking of Search Results
Searching the People Directory
Text Tokenisation and Filtering

Confluence Search Syntax

Here's how you can refine your search. Confluence will ignore common words like "the" unless you place your query within quotes.
Exact phrase search

To search for content that contains the exact phrase "chalk and cheese"

o Confluence will ignore common words (stop words) like "and" above. This is the default list of stop words used by lucene. Please cast
your vote towards this improvement request.
For eg:

1. Searching for "The One" returns all pages containing "One" because "The" is a stop word.

2. Searching for "Cheese One" would only return pages in which "One" appears as the first word (other than stop words) after
"Cheese". So it would return "Cheese for One" or "Cheese to One" or "Cheese One". It would not match "One Cheese" or "Cheese
Flamingo One"

Or Search

To search for content that contains one of the terms, "chalk" OR "cheese"

And Search

To search for content that contains both the terms "chalk" AND "cheese"

H chalk AND cheese
Not search

To search for content that contains "chalk” but NOT "cheese"

H chalk NOT cheese

Excluded Term search

Similar to the NOT search, to search for content that contains “chalk" and "butter" but NOT "cheese"

Q
=3
o
o
~
o
c
=4
ot
[0}
a}
1
Q
=3
10}
10}
w
1)

Grouping Search

To search for content that MUST contain "chalk" but CAN contain either "cheese" or "butter" use the search:
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Q
=
[0}
[0}
[0}
1)
o
=
o
c
o
o
10}
i
]
Q
=
@
o
=

Title Search

To search for content with "chalk" in its title, where title is the field keyword.

o
-
P
=
0}

Q

=g
@

=
~

Wild card searches
Single character

To search for "butter” or "batter" you can use the search:

H b?tter

Q
a3
-
Q
~
*

ﬂ Wildcards can be used anywhere within a word, except at the very beginning.

For example:
: *chick

is an invalid search term.
Multiple characters

To search for "chick" or "chickpea":

Q
*
Q
*

Q
*
Q
J

) Case Sensitivity in wildcard searches
Since the fix for CONF-13846 Confluence is case sensitive for wildcard searches.

You should note that all the example searches given previously search across the default set of fields which are stored as
lower case and therefore all searches of that style should be given lower case search terms (as shown in the examples).

However, if you were to search one of the case sensitive fields, such as ‘content-name-untokenized' the case of your
search term would need to match the document you are searching for.

Proximity searches

ﬂ This search ensure that the two words specified must be within a certain number of words of each other to be included.
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[0}
Q
b3
o
Q
¢}
5]
o]
e}
[0}
ot
2
A

H "octagon post"~0

is an invalid search term.

Range search

o Searches for names that fall alphabetically within the specifed range.

N
Q.
o
3
ot
o
o
10}
2

Note: You can't use the AND keyword inside this statement.

Fuzzy search

a This search looks for words spelled similarly.

To search for octagon, if unsure about spelling:

.
; :
: :
: octogan~
H H
: :
: :
H H
i

will correctly return "octagon"
Combined search

You can also combine various search terms together:

i o?tag* AND past~ AND ("blog" AND "post")

Related Topics

Searching Confluence
Confluence Search Fields

Take me back to Confluence User's Guide

Ranking of Search Results

When you perform a search in Confluence, it is likely that there will be many pages or other content items that match your search terms.
Confluence will rank the matching items by evaluating their relevance. This should mean that the items most relevant to you will appear at
the top of the search results list, so that you can quickly select the item you need.

Below is an overview of the method Confluence uses to determine the relevance of the items returned by the search, i.e. to rank the search
results.

On this page:

Philosophy behind the Ranking
Summary of the Ranking Method
Weighting of Content Types
Weighting of Fields

Weighting Based on Age
Simplified Example

Related Topics

Philosophy behind the Ranking
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Confluence gives highest priority to personal information i.e. documents which take you to a user's profile when you click on them.
Collaboration is a primary function of a wiki, so Confluence makes it easy to find people.

For example, if you search for 'John Smith’, the first results you see will be for John Smith's user profile and personal space. There may also
be other content (wiki pages, email messages, etc) which contain the words 'John Smith'. These other content types may even have 'John
Smith' as the page title and repeated multiple times in the content, but they will still appear lower down in the list of search results.

Matching terms found in the title of a page, or in the title of any content type, are considered a strong match. So are matches found in labels,
because when someone applies a label it means that they think the content is particularly relevant to the labelled term.

Matches found in the content body are of average importance. If the matched term appears more than once, the document will be given a
proportionately higher ranking.

We also assume that information created recently is slightly more relevant than older information.

Summary of the Ranking Method

When displaying the results of a search, Confluence applies a weighting to each of the content items returned.
To determine the weighting:

1. For each content item, Confluence first applies three weightings based on the following:
a. The content type of the item returned — user profile, page, blog post, attachment, etc. (More details below.)
b. The type of field in which the search term was found — title, name, label, or content body. (More details below.)
c. The age of the item returned. (More details below.)

2. Confluence then combines the three weightings to arrive at a single weighting for the content item.

The item with the heaviest weighting will appear at the top of the list of search results, and the other items will appear below in descending
order of weighting.

Weighting of Content Types

Content Type Weighting
User Profile 9

Page 8

Blog 7
Attachment 6
Comment 5

Mail 0.5

Space Description 0.4

9 Simple example

If the search returns 7 matching items, and each item is one of the above types, then the items will be presented in the
above order on the results screen. (This example assumes that the search term is found in the same field in each item —
see more about fields below.)

Weighting of Fields

Field Name Weighting
Title 9

Full name 8
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Label text 7

Content 5

Note that 'content’ above could be the content of a page, or the content of a comment, or the body of any other content type. See more about
content types above.

@ Simple example

A match for a search term in the title of a document is 1.8 times (9/5) more important than a match in the content.

Weighting Based on Age

This weighting is based on the age of the item returned in the search results. The age of the item is calculated from the creation date of the
item. The age intervals are quite coarse-grained, as shown in the table below.

When the Item was Created Weighting

Today 15
Yesterday 1.3
Up to 1 week ago 1.25
Up to 1 month ago 1.2
Up to 3 months ago 1.15
Up to 6 months ago 1.10
Up to 1 year ago 1.05
Beyond a year 1

The weighting is fairly small, so will not have a large effect. When an item is more than a year old, the age weighting is just '1'i.e. it has no
effect.

& Simple example

® |f two documents match in all other ways then the newer one will be presented first.
® |f the two documents being compared are both older than a year then their relative age does not matter.

Simplified Example
Let's assume you search for a single term.

Confluence finds a match in the title of an email message created today:

Weighting for the content type (email) 0.5

Weighting for field (title) 9
Weighting for age (today) 15
Total weighting 6.75
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Confluence also finds a match in the content of a comment created three weeks ago:

Weighting for the content type (comment) 5

Weighting for field (content) 5
Weighting for age (up to 1 month ago) 1.2
Total weighting 30

Result: The comment (weighting 30) will be appear higher in the search results than the e-mail (6.75).

o Confluence uses the Apache Lucene search engine library. Lucene's score calculation has a number of additional terms, not mentioned
in the above example. We have simplified above, for purposes of illustration. If you are interested, you can see more information in the
Lucene documentation.

Related Topics

Searching Confluence

Confluence Search Syntax

Confluence Search Fields

Text Tokenisation and Filtering

Search Macro

Livesearch Macro

Pagetree Macro (includes an optional search box)

Take me back to Confluence Documentation Home

Searching the People Directory

The people directory displays a list of people who use your Confluence site.

The people directory includes anybody who has logged into Confluence or who has had a user account created for them in Confluence. The
people directory does not include users who can log into Confluence using external user management if they have never yet logged in.

Viewing the People Directory
Choose Browse > People Directory.

o The Confluence administrator can hide the people directory. If it is hidden, you will not see the People Directory link in the Browse
menu.

Screenshot: The People Directory
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Dashboard » ) wee i I

% People Directory

s

Show: All People | People with Personal Spaces

Found 20 result(s) for query e®

Audra Eng 2 Boots Wang
aeng@atiassian.com boots{@atlassian.com
F

Dylan Etkin WY Edoardo Causarano
dylani@atlassian.com ecausaranoi@atlassian.com

Edwin Dawson Edwin Wong
el edawson@atlassian.com edwin@atlassian.com
! -,

==

Searching for People
To search for a particular person, type their first name and/or last name into the search box and click Search.

® To search everyone who uses your Confluence site, click All People.
® To search just those people who have set up a personal space, click People with Personal Spaces.

Following People's Activities

Confluence's network features allow you to ‘follow' (that is, keep track of) other people's activities throughout a Confluence site. For more
information, please refer to Network Overview. Using the hover profile feature, the people directory is a convenient area from which you can
start following other people throughout your Confluence site.

® To start following another person's activities, move your mouse over a user's name or profile picture and in their hover profile popup,

click Follow.
® To stop following another person's activities, move your mouse over a user's name or profile picture and in their hover profile popup,

click Stop Following.

Once you start following another person, their activities will start appearing in your network view.

ﬁ People Directory provides hCard microformat

The people directory uses the hCard microformat for simple integration with a variety of microformat-enabled tools. hCard
is an open data format for representing people, companies, organisations, and places. Read more about microformats and

hCard.

Related Topics

Setting up your Personal Space
Editing your User Profile
Choosing a Profile Picture

Take me back to the Confluence User's Guide.

Text Tokenisation and Filtering

When searching for content based on search terms entered by the user, Confluence splits the text of the content into tokens, and then filters
and modifies those tokens according to the following rules.

117


http://microformats.org/
http://microformats.org/wiki/hcard

Confluence 4.0 Documentation

Tokenisation

Confluence uses Lucene's Standard Tokenizer. This splits the text into tokens as follows:

® Splits words at punctuation characters, removing punctuation. However, a dot that's not followed by white space is considered part
of a token.

® Splits words at hyphens, unless there's a number in the token, in which case the whole token is interpreted as a product number and
is not split.

® Recognises email addresses and internet host names as one token.

o An example: The string 'foo-bar5' won't be split into 'foo' and 'bar5', so a search for 'bar5' or 'bar*' will not find any results.

Filtering
Confluence then:

Removes "'s" from the ends of words.

Removes the dots from acronyms, e.g. [.B.M. becomes IBM.

Converts everything to lower case.

Removes common words like ‘the' and 'or' are removed.

Converts words to their stems. For example, ‘fishing' and ‘fishes' both become 'fish'.

Related Topics

Searching Confluence

Organising Content

Confluence provides a number of ways for organising and structuring content in the wiki:
® Spaces allow you to group content according to major categories.
® Pages are used for discrete topics, and can be structured into page trees to show the relation between them.
® Favourites are particular pages or spaces that have been bookmarked by a user, to make them easy to find again.
® Labels are user-defined tags that are added to related pages in order to categorise them in some way.

® Attachments to a page can include images, multimedia, Office and PDF files, and provide a way to include other forms of content in
the wiki.

® Email can be collected and archived within each space individually, to manage all mail related to a project.

Related Topics

Creating Content

Searching Confluence

Take me back to the Confluence User's Guide.

Working with Pages

Pages are the primary means of storing and sharing information in Confluence. Pages are contained within spaces.

® Use spaces to organise your wiki content into your primary logical groups. For example, you could have a space per team, per
product or per department.

® Use pages to organise your content into lower-level groups. For example, you could have a page for a particular team activity, or for
a feature in a product, or for a chapter in a book. Add more child pages to contain lower-level details if necessary.

Things you can do with pages in Confluence:

Create a new page from anywhere within the site.

Write content using the editor.

Rename a page.

Copy an existing page.

Organise pages hierarchically via parent-child relationships.

Move pages while editing a page or while viewing the space's Tree view.
Navigate within and between spaces through flexible linking.
Collaborate via comments on a page.

Control access through page security restrictions.

Monitor page updates and other activity through page notifications.

118


http://lucene.apache.org/java/2_0_0/api/org/apache/lucene/analysis/standard/StandardTokenizer.html

Confluence 4.0 Documentation

View page history and link to older versions.

Search page content, including attachments.
Export pages to PDF, WORD, HTML or XML.
Email page content.

Related Topics

Creating a Page

Working with Page Families
Working with Drafts

Working with the Office Connector
Recently Viewed Content

Take me back to Confluence User's Guide

Moving a Page

This page describes how to move a page. You can move a page:
® to a different space, with a new parent
® to have a different parent page, within the same space

® to reorder sibling pages that are children of a common parent.

When you move a page, all of the page content such as attachments and comments will be moved with the page. Additionally, all child and
descendent pages and their page content will also be moved.

You can also copy a page, and move an attachment.

On this page:
® Moving a Page to a Different Space

® Moving a Page within a Space
® Related Topics

) Permissions
To move a page, you need the following permissions:
® 'Edit' permission on the page you are moving, and
® 'View' permission on the page's parent page. So if you are moving the page to a different parent, you need 'View'
permission on the new parent.

To move a page into a different space, you will also need:

® 'Remove' permission on the space you are moving from, and
® 'Create' permission on the space you are moving to.

Moving a Page to a Different Space

You can move a page, along with its child pages, to a different space. Any links to a moved page from the current space will automatically be
renamed to point to the page in the new space.

To move a page to another space in your Confluence site:

1. Go to the page and choose Tools > Move.
2. Use the tabs on the left to help you find the new space and parent page for your page, that is, the location where you want to move

your page. The ‘Current location' and 'New location' breadcrumb trails at the bottom of the dialog indicate the current parent page
and new parent page.

3. If you want to move a page to a different position amongst the child pages, check Reorder to see a list of sibling pages when you
click Move.
4. Click Move.

5. If you are reordering the child pages, click in the list to set the new position for the page and click Reorder.
Moving a Page within a Space

You can move a page to a different position in the page tree. This allows you to:

® Move a single page, or a family of pages, to have a different parent within the space.
® Reorder sibling pages that are children of a common parent.
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Any links to the page are maintained. When a page that is itself a parent (that is, it has one or more child pages) is moved, the entire
hierarchy of child pages of the moved page (including comments and attachments) is maintained.

To move a page using the space's 'Tree' view:

. From any page, choose Browse > Pages.
. Click Tree.
. Find the page you want to move.
. Drag the page up or down the tree.
. While dragging the page, you see one of the following:
® A thin line between existing pages — this indicates the potential new position for the page. Release the mouse button when
the page is where you want it.
* A wide highlight over one or more existing pages — this indicates that you can drop the page into a page family. Release
the mouse button to add the page to the family. The page will appear either in alphabetical sequence or as the last page in
the family, depending on the family's sequential order.
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The new position of the page is saved as soon as you release the mouse button.
o To cancel the move while still holding down the mouse button, press the 'Esc' key.

Related Topics

Moving an Attachment
Copying a Page

Deleting a Page
Sequential Order of Pages
Overview of Pages

Take me back to the Confluence User's Guide.

Working with Page Families

A 'page family' is simply the parent and child pages in a part of the page hierarchy.
Things you can do with page families in Confluence:

® View a page's family.

® View the hierarchy of all pages within a space.
® Move and re-order pages.

® Order the pages in a page family alphabetically.

Related Topics

Managing Orphaned Pages

Working with Pages
Working with Spaces

Take me back to Confluence User's Guide
Viewing a Page's Family
To view a page's family, go to the page and choose Tools > Info.

The page's parent and children, if any, are listed under 'Hierarchy'.

Screenshot : Viewing a page's family

Hierarchy

Parent Page
Horme

Children (5]
Choose a Page
Move an attachrnent from one space to another
Move a family of pages from one space to another
Move a page from one space to another
Page Farmilies

Notes

® |f there are more than 10 children, only the first 10 will be shown by default. To view all the children, click Show all....
® If no parent is displayed for the page, either the page sits in the root directory of the space or its parent has been deleted.
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Related Topics

Working with Page Families

View Hierarchy of all Pages within a Space
Managing Orphaned Pages

Take me back to Confluence User's Guide

Setting a Page Family to Alphabetical Order

You can choose to display your Confluence pages in alphabetical or manual order. This page tells you how to set the pages within a family tc
alphabetical order. See Sequential Order of Pages.

On this page:

About the Sequential Order of Pages
Alphabetical versus Manual Order
Changing the Page Order

Setting Page Order to Alphabetical
Related Topics

About the Sequential Order of Pages

Confluence allows you to present your pages in any order (sequence) you choose. The position of a page is reflected in the following places:
The Tree tab on the space's 'Pages' view
Exporting pages to PDF, HTML and XML

The Pagetree macro

[ ]
[ ]
[ ]
® The Children macro

Alphabetical versus Manual Order

By default, Confluence will present your pages in alphabetical order. When you move a page to a different position, the order becomes
manual for the affected page family.

o When ordering pages alphabetically, Confluence actually applies a more sophisticated 'natural’ order rather than a straight alphabetical
order. The natural order handles numeric values correctly when doing string comparisons.

Now let's consider what happens when you add a page to a page family, by creating a new page or by moving or copying a page into the
family:

* |f the page family's order is alphabetical, the new page will appear in alphabetical order too.
® |f the page family's order is manual, the new page will appear at the bottom of the list of pages in the family.

Changing the Page Order

You can change the order of the pages by moving pages within the page tree — see Moving a Page.

You can also change the order of a page-family from manual to alphabetical (see the 'Setting Page Order to Alphabetical' section on Setting
a Page Family to Alphabetical Order).
Setting Page Order to Alphabetical

If the pages in a page family have been ordered manually, you can reset the page order to alphabetical as described below.

A page family is a set of pages under a single parent page. In this section, when we say 'page family' we mean the immediate children of the
parent page, not including the grand-children.

The screenshot below shows a family of pages in non-alphabetical order under the parent ‘Sample Page'. Notice the A icon next to the
parent 'Sample Page', giving you the option to order the pages alphabetically.
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Screenshot: A family of pages in non-alphabetical order with 'Sort Alphabetically' icon

% List Pages - Tree View

BELEERE News [ Labels | Attachments | Bookmarks § Mail | Advanced | Space Admin

Wiew: Recently Updated | Alphabetical | Tree

D _bookmarks You can move any page by dragging itto a new position in the tree.
|2 TreeMNavigation

= & Home
= [£] Sample Page A

[Z] Yet Another Sample Page
|Z] Anather Sample Page

[£] Something wicked this way comes
[£] Testing formats for Release Motes

To set a page family to alphabetical order:

. Go to a page in the space and choose Browse > Pages.
. Go to the Tree tab.
. Expand the branches of the tree to find the page family you want.
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. If the page family is in non-alphabetical (manual) order, the 'Sort Alphabetically’ icon A will appear next to the parent page as
shown in the screenshot above. Click the icon.

W
5. The child pages will shuffle into alphabetical order and the icon will change to the ‘Undo Sorting' icon D) as shown in the
screenshot below.

ﬂ Only the immediate children of the parent page will be affected. The grand-children will not be re-ordered. (If you want to
re-order the grand-children, you need to click the 'Sort Alphabetically' icon next to the parent of those pages i.e. re-ordering happens
for one node at a time.)

Screenshot: A family of pages in alphabetical order with 'Undo Sorting' icon

% List Pages - Tree View

LD News § Labels | Attachments | Bookmarks § Mail | Advanced | Space Admin

View: Becently Updated | Alphabetical | Tree

[£] .bookmarks You can maove any page by dragging it to a new position in the tree.
[£] TreeNavigation
= €% Home

= [ Sample Page
|2 Anather Sample Page

|51 Yet Another Sample Page
(=] Something wicked this way comes

[=] Testing formats for Release Notes

i
If you change your mind, you can click the 'Undo Sorting' icon ) to undo the alphabetical sort. This option is only available while you
remain on the Tree tab and provided that you have not performed any other action on the page family. Once you move away from this screen
or do something else with the page family, such as moving children in or out of the family, the undo option is no longer available.

Related Topics

Moving a Page
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Overview of Pages
Overview of Page Families

Take me back to Confluence User's Guide

Using the Documentation Theme

The Documentation theme is one of the themes bundled with Confluence. It provides an inbuilt table of contents for your wiki space, a
configurable header and footer, and text styles suited to documentation. You can also configure it to restrict the search results to the current
space, rather than searching the entire Confluence site.

This page tells you how to view pages in your Confluence space when your space uses the Documentation theme. For the full list of features
and instructions on applying the theme to a space, see the guide to configuring the Documentation theme.

@ Quick guide to using the Documentation theme
® The left-hand panel contains a page tree. This is a table of contents that shows the pages in the space.

® Click the plus signs in the page tree to see the child pages.

® Drag the thick vertical bar to change the width of the panels.

® Showr/hide the left-hand panel: Click the sidebar icon Dj at top right, next to the search box, to remove the
left-hand panel altogether. Click the icon again to restore the panel.

® Alternatively, press '[' on your keyboard to show/hide the left-hand panel.

Overriding a space-restricted search: If your theme is configured to restrict the search to the current space, you

can enter ‘all:' and your search term to search the entire site.

The rest of this page gives more details of the above guidelines.

On this page:

® Using the Documentation Theme
® Searching the Space or the Site
L]
L]

Hints and Tips
Related Topics

Using the Documentation Theme

By default, the left-hand panel contains a search box and a table of contents (page tree) showing all the pages in your space. Specifically, it
shows the pages that are children of the space's home page.

diagram temporarily disabled {gliffy:name=Documentation Theme Default|align=left|size=L}

Screenshot above: The Documentation theme with default settings
A space administrator can customise the Documentation theme as follows:

® Change the content in the left-hand panel and add a header and footer to the page. This means that your own pages may look
different from the screenshot above.

® Restrict the search so that it will show results from the current space only, not from the entire Confluence site.

diagram temporarily disabled {gliffy:name=Documentation Theme]align=left|size=L}

Screenshot above: The Documentation theme with space-restricted search

Here is a summary of the things you can do on a page that uses the Documentation theme:
® Click the plus signs to open and close the branches of the page tree (table of contents) in the left-hand panel.

® Drag the thick bar between the left-hand panel and the content, to increase or decrease the width of the panel.

Click the sidebar icon Dj at top right, next to the search box, to remove the left-hand panel. This will remove the panel for you only.
Other people will still see it.

Click the sidebar icon Dj again to restore the left-hand panel.

Alternatively, press '[' on your keyboard to show/hide the left-hand panel.

Use the scroll bars to scroll the left-hand and right-hand panels independently of each other.
Search the content of the space or the site. See below.

Searching the Space or the Site

When using the Documentation theme, the Confluence search offers a few options as described below.

Using the search box at the top right of the page:

® By default, the main Confluence search is configured to search the entire Confluence site.
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® You will see the words 'Search Confluence' in the search box at top right of the page.
® The Confluence search will look for matches in the entire Confluence site. This is the default behaviour for other themes too.
® A space administrator can configure the Documentation theme to restrict the search to the current space.
® You will see the words 'Search this space' in the search box at top right of the page.
® The search will return results from the current space only.
® You can override the search restriction. Enter ‘all:' and your search term to search the entire site. For example, enter the
following into the search box at top right of the page to search the entire site for 'technical writing':

all: technical writing

Using the search box in the left-hand panel:
® By default, the Documentation theme's left-hand panel includes a search box. Enter your search term there, to restrict the search to

the current space. Specifically, this will search only the pages that are children of the space's home page.
® |f your administrator has restricted the main search to the current space, there will not be a search box in the left-hand panel.

Hints and Tips
Below are some hints that you may find useful when using the Documentation theme.

Where can | see a working example of the Documentation theme?

The Confluence documentation uses the Documentation theme. If you are reading this documentation online on the Atlassian documentation
wiki, you are seeing a working version of the Documentation theme.

Which pages will appear in the Documentation theme's table of contents?

The theme constructs the page tree in the left-hand panel from all pages that are child pages of the space’s home page. Each space has a
single page designated as the 'Home' page. You can specify the home page in the space administration section.

Help, my pages do not appear in the Documentation theme table of contents

Cause 1: Your pages are not under the space's home page. The most probable reason why your pages do not appear in the page tree in
the left-hand panel is this: The theme constructs that table of contents from all pages that are child pages of the space’s home page. If your
pages are above the home page in the page tree, they will not appear in the left-hand panel.
There are two ways to fix the problem:

® You can change the designated space home page in the space administration section.

® Oryou can drag and drop all your pages to make them children of the current home page. You can drag and drop pages in the

'Pages' section of the space '‘Browse' screen. See Moving a Page.

Cause 2: Problem with upgrade from Confluence 3.1, with Documentation theme as plugin, to Confluence 3.2 or later with
Documentation theme bundled. If your existing Confluence installation already has the Documentation theme plugin installed, you may find

that after upgrading to Confluence 3.2 the left-hand navigation bar is empty in the spaces that use the theme. The fix is to enable all modules
of the Documentation theme plugin. See the knowledge base article.

Help, my left-hand panel has disappeared
If your entire left-hand panel has disappeared when using the Documentation theme, this is probably because you have clicked the sidebar
icon at top right, next to the search box. Click the icon again to restore the panel.

Related Topics

Configuring the Documentation Theme
Space Jump Macro

Take me back to the Confluence User's Guide

Sequential Order of Pages

Confluence allows you to present your pages in any order (sequence) you choose. The position of a page is reflected in the following places:

® The Tree tab on the space's 'Pages' view
® Exporting pages to PDF, HTML and XML
® The Pagetree macro
® The Children macro

Alphabetical versus Manual Order
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By default, Confluence will present your pages in alphabetical order. When you move a page to a different position, the order becomes
manual for the affected page family.

a When ordering pages alphabetically, Confluence actually applies a more sophisticated 'natural’ order rather than a straight alphabetical
order. The natural order handles numeric values correctly when doing string comparisons.

Now let's consider what happens when you add a page to a page family, by creating a new page or by moving or copying a page into the
family:

* |f the page family's order is alphabetical, the new page will appear in alphabetical order too.
® |f the page family's order is manual, the new page will appear at the bottom of the list of pages in the family.

Changing the Page Order

You can change the order of the pages by moving pages within the page tree — see Moving a Page.

You can also change the order of a page-family from manual to alphabetical (see the 'Setting Page Order to Alphabetical' section on Setting
a Page Family to Alphabetical Order).

Related Topics

Overview of Pages
Overview of Page Families
Moving a Page

Take me back to Confluence User's Guide

Viewing Page Information

The 'Information View' for a page shows you various bits of useful information about the page.
To see the Information View for a page:

1. View the page.
2. Choose Tools > Info to go to the 'Information’ view for the page.

The 'Information View' displays the following information:

. Page Details: Title, author, date of creation, date of last modification and the tiny link of the page.

Page Hierarchy: Parent-child relationships of the page.

Page Permissions: Displays page-level security restrictions that apply to the page (if present).

. Recent Changes: Links to the five most recent versions of the page along with the name of the editor and the date of modification.

. View page history: A link to the page history, which displays all the versions of the page in reverse chronological order and allows
you to compare versions or to restore a previous version.

6. Hot Referrers: The external website pages which send the most viewers to the page.
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Screenshot: A page's Information View

x Home @ view  oF Add ~ 8 Tools ~

Title: Home View Source | | Recent Changes

Author: Administrator Apr 30, 2008 Time Editor

Last Changed by: Administrator Apr 30, 2008 Apr 30, 2008 1344 Administrator

Tiny Link: (useful for email) hitp://coopers:8080/x/AwAG View page history
Export As: POF | Word

Operations: Copy

Hierarchy

Children (1)

9 Blue is the new black

Labels

There are no labels assigned to this page.

Hot Referrers

[2) extranet stlassisn. com/displswDOCTSTITest+refensl+totoo .. ban]
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Related Topics

Working with Pages

Take me back to Confluence User's Guide

Copying a Page

You can copy a page, to create a duplicate of the page content. You will need to rename the page, because a page name must be unique
within a space.

You need 'Create Pages' permission, which is assigned by a space administrator from the Space Administration screens. See space
permissions or contact a space administrator for more information.

To copy a page:
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Go to a page in the space and choose Tools > Copy.

Confluence will open a copy of the page in edit mode. By default, Confluence will name the page 'Copy of <<original page name>>'.

. Rename the page and make any other changes required in the body of the page.
. If you need to move the new page to a different space or a different parent, you can edit the Location. Refer to the instructions on

moving a page.

. Click Save.

Copying a page will duplicate all of the original page's attachments and labels, but will not copy comments from the original page.
This method of copying a page does not copy the child pages. Please add your vote to issue CONF-2814 if you'd like to see this

improvement.
You can copy an entire space, including all pages in the space (parents and children) — refer to these instructions on copying a

space.
Consider using the WebDav plugin to move or copy a page hierarchy from one space to another, provided that none of the page

names already exist in the target space.


http://jira.atlassian.com/secure/QuickSearch.jspa?searchString=CONF-2814
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Screenshot: Copying a page

I | Copy of Sample Page

Select a page template to start from.

B 7 U s Fomat- [v|| = iz = is Al —©a =
FY
Start of sample page content
Lorem ipsum dolor sit amet, consectetuer adipiscing elit. Aliquam fermentum vestibulum est. Cras rhoncus.
Pellentesque habitant morbi tristique senectus et netus et malesuada fames ac turpis egestas. Sed quis tortor.
Donec non ipsum. Mauris condimentumn, odio nec porta tristique, ante neque malesuada massa, in dignissim
eras velit at tellus. Donec et risus in ligula eleifend consectetuer. Donec volutpat eleifend augue. Integer gravida
sodales leo. Munc vehicula neque ac erat. Vivamus non nisl. Fusce ac magna. Suspendisse euismod libero
eget mauris.
End of sample page content
w
p

Location: Confluence 2.7 = Linking to Comments EDIT

Restrictions: EDIT
Labels: DONE

Tip: Looking for a label? Just start typing.

Save Cancel

Related Topics

Working with Pages

Take me back to Confluence User's Guide

Working with Comments

A comment is a remark, question, or any other additional information you wish to add to a page. Comments are a means by which a
community of users can interact with each other on the site.

You can add a comment to any page or blog post in Confluence.

Comments are displayed at the bottom of the page, below the page content. Comments in Confluence are displayed in one of two views,
configured globally by a site administrator:

®* Threaded - this view shows the comments in a hierarchy of responses. Each subsequent reply to a comment is indented to indicate
the relationships between the comments.

® Flat - this view displays all the comments in one single list and does not indicate the relationships between comments.
What would you like to do?
Add a comment
Link to a comment
Delete a comment

Edit a comment
Enabling Threaded Comments

Related Topics
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Working with Pages

Take me back to the Confluence User's Guide.

Adding a Comment

You can either add a new comment, or respond to a previous comment, on both pages and blog posts in Confluence.

To add a comment, you require '‘Create Comments' permission which is assigned by a space administrator from the Space Administration
screens. See Space permissions or contact a space administrator for more information.

To add a new comment:

. Choose Add > Comment from the top of the page, or simply click beside your profile picture below the last comment.
. Type in your comment.

. Use Preview to see how your comment will appear.

. Click Save. By default the current page is added to those that you receive notifications about.

A WNPE

To respond to a comment:
1. Click Reply located below the text of a comment.

2. Type in your response.
3. Click Save.

Notes

® You can only respond to a comment when comments are in 'threaded' view.

® You can choose Tools > Watch to receive an email notification whenever anyone edits the page or adds a comment to the page.

® Your profile picture will appear next to each comment that you have added. (This is true if your space uses the Confluence Default
theme.)

Related Topics

Linking to Comments
Deleting Comments
Subscribing to Email Notifications of Updates to Confluence Content
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Deleting Comments

To delete a comment from a page, you require ‘Remove Comments' permission which is assigned by a space administrator from the Space
Administration screens. See Space permissions or contact a space administrator for more information.

Currently, it is not possible to delete all comments for a page simultaneously.
To delete a comment:

1. Go to the page that contains the comment.
2. Click Remove at the bottom of the comments box. This is only displayed if you have permission to remove comments for this page.

gy Warning

Deleted comments cannot be restored.

Related Topics

Adding a Comment
Linking to Comments
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Editing a Comment

o Comments are editable if you are using Confluence version 2.4 or later.

You can edit any comments that you have created. Space administrators can edit all comments within their space. The date on a comment
always indicates the time the comment was last edited.

To edit a comment:
1. Go to the comment and click Edit.

2. Make changes to the comment just as if you were adding a comment.
3. Click Save when you are finished.
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Related Topics

Working with Comments
Linking to Comments
Deleting Comments

Take me back to Confluence User's Guide

Linking to Comments

You can add a link to a comment by making use of the PermaLink associated with each comment.

On this page:

® To link to a comment from within Confluence
® To link to a comment from outside Confluence
® Related Topics

To link to a comment from within Confluence

Right-click on the Permalink icon located at the lower right of the comments box.
Select Copy Link Location from the pop-up menu.

Edit the page from which you want to link to the comment.

Click Link in the toolbar, and select the Web Link tab.

Paste the PermalLink into the address field.

Provide link text if required.

ok wNE

To link to a comment from outside Confluence

1. Right-click on the Permalink icon located at the lower right of the comments box.
2. Select Copy Link Location from the pop-up menu.
3. Use this URL to link to the comment from your web page.

Alternately, click on the Permalink icon and copy the URL displayed in the address bar of your browser.

o The older method of linking to comments (used in Confluence 3.5.x and older) using just the commentid has been removed. If you would
like to see it reinstated, please visit this JIRA issue.

Related Topics

Working with Comments
Adding a Comment
Working with Links

Take me back to Confluence User's Guide

Sample Page

Start of sample page content

Lorem ipsum dolor sit amet, consectetuer adipiscing elit. Aliguam fermentum vestibulum est. Cras rhoncus. Pellentesque habitant morbi
tristique senectus et netus et malesuada fames ac turpis egestas. Sed quis tortor. Donec non ipsum. Mauris condimentum, odio nec porta
tristique, ante neque malesuada massa, in dignissim eros velit at tellus. Donec et risus in ligula eleifend consectetuer. Donec volutpat
eleifend augue. Integer gravida sodales leo. Nunc vehicula neque ac erat. Vivamus non nisl. Fusce ac magna. Suspendisse euismod libero

eget mauris.

End of sample page content
child page
Recently Viewed Content

Confluence keeps track of pages you have recently visited throughout all your accessible spaces within a Confluence installation. This history
is available from the Recently Viewed content view, which you can use to go back to Confluence pages you have recently visited.

To view the list of recently visited pages and go back to one of them:

1. Go to the 'Recently Viewed' content view. To do this:
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® Go to your name (the 'User' menu) at the top of the page and choose Recently Viewed.
2. Click the title of the page you wish to revisit.

Screenshot: Recently Viewed content view

Recently Viewed

4y Navigating to the Your Recent by Giles Gaskell [Atlassian Technical Writer] (4 minutes aga)
History View - copy for Confluence 3.0

=] Mavigating to the Your Recent Histony View by David Soul [Aflassian] (28 Jan)

T Your Becent History - copy for by Giles Gaskell [Atlassian Technical Writer] (11 minutes ago)
Confluence 3.0

E Your Recent History by Giles Gaskell [Atlassian Technical Writer] (13 Jan)

3 Viewing Space Activity - copy by Giles Gaskell [Atlassian Technical Writer] (26 minutes ago)
for Confluence 3.0

|=] Viewing Space Activity by David Chui (12 Oct)

|=] Confluence Usage Tracking Plugin by Philip Cher (30 Nov)

|=] How Do | Get Mare Statistics From Confluence? by Matt Hodges [Atlassian] (06 Apr)

|=] Plugin Repository Macros by Giles Gaskell [Aflassian Technical Writer] (07 Apr)

|=] Popular Plugins Macro by Giles Gaskell [Atlassian Technical Writer] (07 Apr)
Note

This list records up to the last 20 pages visited. However, be aware that it is cleared when you log out of Confluence or your Confluence
session terminates.

Related Topics

Working with Pages
Browsing a space

Take me back to the Confluence User's Guide.

E-mailing a Page

In Confluence, you can easily share a Confluence page or blog post by e-mailing it to recipients of your choice.

On this page:

® E-mailing a link to a Confluence page or blog post
® E-mailing a Confluence page or blog post
® Related Topics

E-mailing a link to a Confluence page or blog post

The 'Share' button provides a quick mechanism for e-mailing a link to a page or blog post to Confluence users or any e-mail addresses.
To e-mail a link to a Confluence page or blog post using the Share button:

1. Go to the page or blog post you wish to share.

2. Click Share at the top-right of the page. A popup for entering recipients and a note will appear.
o The Share button will not be visible if your Confluence administrator has not configured an outgoing mail server for your
Confluence site.

If you want to enable this feature, please ask your Confluence administrator. Instructions for enabling this feature can be found here:
Configuring a Server for Outgoing Mail.
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3. Enter the name or username of a Confluence user or any e-mail address to whom you wish to share the Confluence page. When
you begin entering a name or username, or you have typed a valid e-mail address, an autocomplete dropdown will appear.

4. Use the mouse or cursor + Enter key to select the appropriate user or e-mail address from this dropdown. Use this dropdown to add
multiple recipients to the list.

& Edit  P-OEEICO =b Add i Tools

User name or email

!Jne Blogger (]
nAdministratnr |
: j-citizen@example-company.com [
all-staffi@example-company.com |
Mote
Thought you might be interested in this
page._|

Cancel

0 To remove a recipient from the list, click the 'bin* icon to the right of the recipient.
5. Enter an optional message into the Note box.
6. Click Share to send a link to the page with your note to the recipients listed on the popup.

E-mailing a Confluence page or blog post

The 'Mail Page' feature provides flexible options for e-mailing a page to Confluence users and groups, and/or any e-mail addresses. It also
allows you to add a custom subject line to your e-mail message.

a The 'Mail Page' feature is disabled by default and the options to access it will not be visible if this feature is turned off.
If you want to enable this feature, please ask your Confluence administrator. Instructions for enabling this feature can be found here:
Enabling the 'Mail Page' plugin.

To e-mail a Confluence page or blog post using the '‘Mail Page':

1. Go to the page or blog post you wish to e-mail.
2. Choose Tools > E-mail.
3. On the '‘Mail Page', enter the following e-mail details:
® Recipients: E-mail address(es) — To send the e-mail to someone who is not a Confluence user, type their e-mail address.
You can type multiple addresses, separated by commas.
® Recipients: Confluence Group(s) — Type the name of the Confluence group (or groups, separated by commas); or click

this icon to select a group from the list:
® Recipients: Confluence User(s) — Type the name of the Confluence user (or users, separated by commas); or click this

icon to select a user from the list:

® Subject — (Optional) Type the email's subject line.

®* Notes — (Optional) Type the text (if any) which you want to appear at the top of the e-mail's body. This text will appear
before the contents of the Confluence page.

® Format — Choose whether to send the email in ‘Text' or 'HTML' format.
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Dashboard * Test Space * Home *> Sample page * Mail Page owse Administrator ~ JSEERH) I

a,

% Sample page ® View dF Add v & Tools ~

Recipients: E-mail address(es)

Confluence Group(s)

Q,
Confluence User(s)
Q,
Subject: Sample page
MNotes:
Farmat: @ HTML

Text - Mo formatting or images

4. Click Nextto see a preview of your e-mail.
® To change the Recipients, Subject, Notes or Format, click Edit (at the right of the page).

® To send the e-mail, click Send (at the bottom of the page).

Related Topics

Working with Pages
Working with Blog Posts

Take me back to Confluence User's Guide

Renaming a Page

To rename an existing page, you require 'Edit Pages' permission which is assigned by a space administrator from the Space Administration
screens. See Space permissions or contact a space administrator for more information.

To rename a page:
1. Goto a page in the space, and click Edit at the top to view the page in 'Edit' mode.

2. Change the page title as required.
3. Click Save.

® Confluence will automatically update all internal links to point to your new page title. This only works for page links that use the

relative link syntax, for example [Renaming a Page].
® In macros, page links will not be updated. You need to update these manually.
® Links from external sites will be broken, unless they use the page's permanent URL.

Related Topics

Linking Pages
Working with Pages

Take me back to Confluence User's Guide

Deleting a Page

To delete a page, you require the 'Remove Pages' permission which is assigned by a space administrator from the Space Administration
screens. See Space Permissions or contact a space administrator for more information.

To delete a page:

1. Go to the page.
2. Go to the 'Remove Page' option. To do this:

® Go to a page in the space and choose Tools > Remove. You will be prompted to confirm the action.
o The 'Remove' menu option will only appear if you have permission to remove this page.

Notes

® Pages deleted in this way are stored in the trash and can be recovered by a space administrator. Purge the trash to remove the
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page permanently.

® |f the page you are deleting has any child pages they will be moved to the root of the space.

® Attachments attached to a deleted page will remain in the database (allowing potential retrieval) until the trash is purged. When the
trash is purged, all attachments on that page are pemanently removed.

Related Topics

Restoring a Deleted Page
Purging Deleted Pages

Creating a Page
Editing or Deleting a Page That Won't Render

Take me back to Confluence User's Guide
Purging Deleted Pages

When a user deletes a page from a Confluence space, the page is not permanently removed. Instead, Confluence places the deleted page
into the 'Trash'. The page will remain in ‘Trash' until a space administrator purges the page.

Purging deleted pages permanently clears them from 'Trash'.
You need to be a space administrator to purge deleted pages for a space.
To purge deleted pages:

1. Choose Browse > Space Admin.
0 Space Admin is displayed only if you are a space administrator for that space or you are a Confluence system administrator.

2. Click Trash in the left-hand navigation panel. A list of deleted pages and blog posts for the space is displayed.
3. Click the Purge link beside a page or else click Purge All to permanently clear all deleted pages and news items.

o When the trash is purged, all attachments on purged pages are pemanently removed as well.
Related Topics

Deleting a Page
Restoring a Deleted Page

Take me back to Confluence User's Guide
Restoring a Deleted Page

When you restore a page, you are retrieving it from 'Trash' to the root of the space where it existed before it was deleted.
You need to be a space administrator to restore deleted pages.
To restore a deleted page:

1. Choose Browse > Space Admin.
o Space Admin is displayed only if you are a space administrator for that space or you are a Confluence system administrator.

2. Click Trash from the left panel. A list of deleted pages and emails for the space is displayed.
3. Click Restore beside the page you want to restore.

Note

If a new page has already been created in that space with the same name as the deleted page, you will be given an option to rename the
page before it is restored.

Related Topics

Deleting a Page
Purging Deleted Pages

Take me back to Confluence User's Guide

Page History and Page Comparison Views

Confluence tracks histories of changes to pages by maintaining a version of the page each time it is modified. It is easy to view changes
between different versions and to restore a previous version if required.
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On this page:

Accessing the Page History View
Viewing Changes in a Page History
Page Comparison View

Other Page History View Features
Related Topics

Accessing the Page History View
To view the history of a page:
® Go to the page and choose Tools > Page History.
You can click a version number to view that version. To get back to the page history view, click View Page History.

Screenshot: Page History View

Version Date Changed By Operations
[0 CURRENT (v.41)  Jul 07, 2009 11:33 Giles Gaskell [Atlassian Technical Writer]
0 w40 Jun 18, 2007 11:08 Rosie Jameson [Atlassian Technical Writer] Restore this version
O w39 Jun 18, 2007 10:19 Rosie Jameson [Atlassian Technical Writer] Restore this version

When you are viewing a specific version of the page, the following functions are available:

Function Description

current version View the latest version of the page.

Compare with Current ~ Compare the differences between the version of the page you are viewing and the current version.

Restore this Version Restore the page version you are viewing to be the current version.

View Page History Return to the list of page versions.

<< Previous or Next >>  View the previous or next page version, respectively.

Viewing Changes in a Page History

The page history view and page information view allow you to view recent changes made to a page or to compare the differences between
any two versions of a page.

Viewing Recent Changes

To view recent changes made to a page:

1. Click view change at the top of the page below the page title. The page comparison view is displayed, showing the differences
between the current version and the previous version.
Or:

2. Choose Tools > Info to go to the 'Information’ view for the page.

3. In the section titled 'Recent Changes' you will see the most recent versions of the page, along with the date of their modification and
the name of the modifying author.

4. Click view changes beside the desired version. The page comparison view is displayed, showing the differences between the
selected and previous versions.

Comparing Two Different Versions of a Page
To compare two different versions of a page:
1. Go to the page and choose Tools > Page History.
2. Select the versions you want to compare by selecting the check boxes beside them.

3. Click Compare selected versions. The page comparison view is displayed, showing the text differences between the selected
versions.
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Page Comparison View

The page comparison view shows the differences between selected page versions.

Key

On the page comparison view, the following key indicates the differences between the selected page versions:

Highlight Meaning

Green Added content
Red Deleted content
Blue Changed formatting

Screenshot: Comparing Changes

Versions Compared Key
111 122 This Iine was added.
This line was removed.
1 Edwin Dawson Paul Watson  #

Aug 16, 2011 Aug 19, 2011 Farmatting was changed.

View Page History

Interactive views
When a page comparison view is first displayed, all large sections of unchanged text are hidden and reduced to an ellipsis . . ..

You can view page changes between versions which are adjacent to your current page comparison view. Click the link containing:

® << to view the page comparison with the earlier adjacent version
® >> to view the page comparison with the more recent adjacent version.

For example, if your page comparison view is between v. 30 and v. 34 of a page, you can view changes between:

® v. 29 and v. 30 by clicking << Changes from 29 to 30
® v. 34 andv. 35 by clicking Changes from 34 to 35 >>

Other Page History View Features

You can also use the page history view to:
® View an older version of a page

® Restore an older version of a page
® View change comments

Related Topics

Viewing Page Information
Working with Pages
Tracking Updates

Take me back to the Confluence User's Guide.

Restoring an Older Version of a Page

To restore an an older version of a page:
1. Go to the page and choose Tools > Page History.

2. Click Restore this version beside the version to restore.
3. Change the default comment if desired and click OK.

Notes

® All page history is retained. Restoring an older version creates a copy of that version. For example, in the screenshot below, if you
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selected v.39 and clicked Restore this version, a copy of v.39 would be created. This copy would be v.42 and would become the
current version.

You can click a version number's link to view the contents of that page version.

Select the check boxes of two different versions and click Compare selected versions to view the changes made between them.
If you are viewing a specific page version, you can restore that version of the page by clicking Restore this Version on that page.
To get back to the page history view, click View Page History.

Screenshot: Restoring an Older Version of a Page

[ Compare selected versions ]

Version Date Changed By Operations
[] CURRENT (v. 41) Jul 07, 2009 11:33 Giles Gaskell [Atlassian Technical Writer]
O w40 Jun 18, 2007 11:08 Rosie Jameson [Atlassian Technical Writer] Restore this version
O v.39 Jun 18, 2007 10:19 Rosie Jameson [Atlassian Technical Writer] Restore this version

Related Topics

Page History and Page Comparison Views
Working with Pages

Take me back to the Confluence User's Guide.

Viewing an Older Version of a Page

Confluence keeps a history of all page changes. You can see what any of the previous versions of the page looked like, as well as link to
them.

There are two ways that you can view an older version of a page.
® Using the 'View Change' link — this allows you to quickly check the most recent change to a page and the most recent version of the

page, prior to the current version.
® Using the Page History — this allows you to look for a specific version of the page.

On this page:

® Viewing an Older Version of a Page using the 'View Change' Link
® Viewing an Older Version of a Page using the Page History
® Related Topics

Viewing an Older Version of a Page using the 'View Change' Link

To view an older version of a page using the 'View Change' link:

1. Go to the page and click view change (displayed under the page title).
2. Click the Version ## link in the top left-hand box to show the page content of the previous version.

Notes

® |f you want to view an earlier version of the page, click the < link at the top left.
® |f you want to send this page version to someone, simply copy and paste the URL from your browser. The link will look something
like this: http://confluence.atlassian.com/pages/viewpage.action?pageld=12345.

Viewing an Older Version of a Page using the Page History

To view an older version of a page using the page history:

1. Go to the page and choose Tools > Page History. The 'Page History' view will open. Read more about viewing the page history on
Page History and Page Comparison Views.

2. Click a version number's link to view the contents of that page version. The following header will display across the top of the old
version of the page:

', You are viewing an old version of this page. View the current version.
Compare with Current | Restore this Version | View Page History

=< Previous Version 11 Mext ==

When you are viewing a specific version of the page, the following functions are available:

136



Confluence 4.0 Documentation

Function Description

current version View the latest version of the page.

Compare with Current ~ Compare the differences between the version of the page you are viewing and the current version.
Restore this Version Restore the page version you are viewing to be the current version.

View Page History Return to the list of page versions.

<< Previous or Next >>  View the previous or next page version, respectively.

If you want to send this page version to someone, simply copy and paste the URL from your browser. The link will look something like this:
http://confluence.atlassian.com/pages/viewpage.action?pageId=12345.

Related Topics
Page History and Page Comparison Views

Restoring an Older Version of a Page
Recording Change Comments

Using a WebDAYV Client to Work with Pages

You can access Confluence content via a WebDAYV client, such as ‘My Network Places' in Microsoft Windows. Provided that you have
permission, you will be able to read and write to spaces, pages and attachments in Confluence. You will be asked to log in and the standard
Confluence content access permissions will apply to the equivalent content available through the WebDAYV client.

Please refer to the page on configuring and setting up a WebDAV client.

Working with Blog Posts

You can publish a blog post from any space in Confluence, provided you have permission. Blog posts may be announcements, journal
entries, status reports or any other timely information.

You can view the blog posts for a space by choosing Browse > Blog. Confluence catalogues the blog posts chronologically and allows you
to browse blog posts for the space by navigating a calendar.

Creating and editing a blog post is just as easy as creating and editing any other page in Confluence.
What would you like to do?

View blog posts

Add blog posts

Edit blog posts

Link to blog posts
Delete blog posts

Related Topics

Subscribing to RSS Feeds within Confluence
Watching Changes

Blog Posts Macro

Take me back to the Confluence User's Guide.

Deleting Blog Posts

To delete blog posts, you require 'Remove Blog' permission which is assigned by a space administrator. See Space Permissions or contact a
space administrator for more information.

To delete a blog post:

® Go to the blog post and choose Tools > Remove.
The Remove option is only displayed if you have permission to remove this blog post.
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i Handy Hint

Deleted blog posts are stored in the trash and can be recovered by a space administrator.

Related Topics

Viewing Blog Posts
Adding Blog Posts
Editing Blog Posts
Linking to Blog Posts

Take me back to Confluence User's Guide

Editing Blog Posts

To edit a blog post, you require the 'Create Blog' permission which is assigned by a space administrator. See Space Permissions or contact
a space administrator for more information.

To edit ablog post:

1.

aroON

Navigate to the space that has the blog post and choose Browse > Blog. A list of the most recent blog posts within the space is
presented. A calendar allows you to browse earlier blog posts.

Locate the blog post and click Edit.

Make changes to the blog post.

(optional) Add a comment, in the text box below the editing pane, to describe your changes.

Preview your changes if desired, and click Save.

Editing a blog post is similar to editing any other page in Confluence. However, there are a few things to keep in mind:

® You cannot change the date of an existing blog post. You can only backdate when adding a blog post.
® You cannot move a blog post to another space.
® A blog post has no parent.

Related Topics

Working with Blog Posts
Adding Blog Posts
Deleting Blog Posts
Blog Posts Macro

Take me back to Confluence User's Guide

Viewing Blog Posts

To view the blog posts within a space:

® Navigate to the desired space, and select Browse > Blog.

A list of the most recent blog posts within the space will be displayed, along with the date of each post and the name of its author. The blog
posts for the month will be shown in a panel, next to the list of the most recent blog posts. The panel will also contain links to the previous
and next month (e.g. 'April 2010"), which you can use to browse blog posts from different months.
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Dashboard » Chocolate » Space » Blog from June, 2010 Browse » Andrew Lui v [SEEI

% Chocolate Blog from June, 2010

Pages JE:LAR Labels | Attachments | Bookmarks | Mail | Advanced | Space Admin

ok Add ~

: s Andrew Lui

. Chocolate Tuesday

Search

Blog Posts: June 2010
[E] Chocolate Tuesda

[ Chocolate Art

[E] Chocolate Cafes in the City

=< May 2010

"All you need is love. But a little chocolate now and then doesn't hurt.” Charles M. Schulz

Every Tuesday is Chocolate Tuesday! This week Sarah is going to unleash her decadent "Death by Chocolate”
tart upon us. Ensure that you've booked a gym session later this week to work off the guilt.

MNext week, Charles has kindly volunteered to whip up some mysterious bogus choc-chip cookies for us. I'm
intrigued and scared at the same time.

If you are interested in joining us for a future Chocolate Tuesday, add a comment to this blog post.

[E Health Benefits of Chocolate

Related Topics

Blog Posts Macro
Adding Blog Posts
Linking to Blog Posts
Browsing a space

Take me back to the Confluence User's Guide.

Working with Spaces

In Confluence, content is organised into spaces. There are two types of space:

® Global spaces are areas on your site into which you can group content items (pages, attachments, news, etc) based on any subject
or topic of your choice. For example, you may want separate areas on your site for each team or project within your organisation.

® Personal spaces belong to specific users. They can be kept private, or opened up so the whole world can view and edit them, just
like global spaces. These spaces are listed in the People Directory. They are not listed on the 'All' tab on the dashboard.

On this page:

What is a Space?

Viewing the Spaces in a Confluence Site

Guidelines for Dividing Content into Spaces and Pages
Example — Favourite Spaces as Shown on the Dashboard
Related Topics

What is a Space?

A space is an area within Confluence, containing your wiki pages. You can think of each space as a sub-site, or mini-site, each with its own
home page.

Each space:

® Has its own pages, blog posts, comments, RSS feeds and mail (mail applies to global spaces only).
® Has its own access control settings. You can set different levels of access for different spaces.
® Can be separately exported to PDF , HTML or XML.

There is no limit to the number of global spaces you can create in Confluence.

Viewing the Spaces in a Confluence Site

Confluence displays a list of spaces in the following locations:

®* The dashboard displays a list of all the spaces in the Confluence site that you have permission to see. You can make a space a
favourite, or categorise the space, to get easy access to the content that is most relevant to you. See Customising your Personal

Dashboard.
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® The space directory displays a list of all the global and personal spaces in the Confluence site that you have permission to see.
You can choose to see all spaces, the spaces you have marked as favourite, or the spaces in a given space category. You can
further restrict the number of spaces displayed, by entering a word or words in the Filter box. Confluence will display only the spaces
that have the matching words in the space name or description. See Viewing All Confluence Spaces.

® The people directory displays a list of all Confluence users, including those who have personal spaces. See Searching the People

Directory.

Guidelines for Dividing Content into Spaces and Pages

To ensure maintainable and logical spaces, consider the following points when allocating your content to pages and spaces:

® Group the content by topic, subject, project or team.
® Evaluate permissions across the wiki content. If members require conflicting access, for example John must access content on
topics A and B, while Jane must access content for topics B and C, then the topics should be separated into three spaces.

Useful notes about spaces and pages:

Spaces cannot be nested. You cannot have parent and child spaces, but you can have parent and child pages within a space.
Page permissions can prevent users from accessing a specific page, even though they have permission to access the space.
Page permissions alone cannot keep the existence of a page secret. The page should be in a restricted space instead.

Pages can be moved between spaces.

You can group related spaces, using space categories.

Example — Favourite Spaces as Shown on the Dashboard

The screenshot below shows the area of the Confluence dashboard that displays the spaces that you have marked as favourite:

Spaces | Pages Network

Favourite Spaces
& Angry Nerds
X Confluence
i Faul Watson

¥ Technical Writing

Global Spaces
X, Admin Space
& Angry Nerds
X. Archive

#.  Atlassian Foundation

Add Space

Related Topics

Setting up a New Global Space
Setting up your Personal Space
Viewing All Confluence Spaces
Browsing a space

Moving a Page

Deleting a Space

Viewing Space Activity

Using Labels to Categorise Spaces
Administering Spaces

Take me back to Confluence User's Guide

Viewing Space Activity

Note that the space activity information is disabled by default. See notes below.
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If enabled, the space activity screen displays statistics on the activity in each space. These include:
How many pages and blog posts have been viewed, added or updated over a given period.
Which content is the most popular (most frequently viewed).

Which content is the most active (most frequently edited).
Which people are the most active contributors/editors of content.

L]

L]

L]

L]
To view the activity in a space:

1. Goto a page in the space and choose Browse > Space Admin.

2. Go to the Activity tab.

Confluence will show a graphic display of the number of pages and blog posts that have been viewed, added and edited, showing trends
over a period of time. For example:

(x, Space Activity

Pages | Labels ] Attachments [ Mail F.Y- "Bl Advanced | Space Admin

Activity for week starting 31 December 2006

Period: month | week | day Weelk: =< Previous | Now | Next =>

See also: Global Confluence activity

Viewing

10,000
8,000
8,000
7,000
6,000
5,000
4,000
3,000
2,000
1,000

3 -Decemb... 1-lanuary-2007 2-January-2007 3-January-2007 4-lanuary-2007 S-lanuary-2007 G-January-2007

This graph shows how many times pages and news posts have been viewed over the current time period.

Screenshot 1: Number of viewed pages and blog posts in a week

The top ten most popular and most active pages and/or blog posts will be listed, with a link to each.

Most popular content (Views)

1. @ Confluence Documentation Home (2262)

2. =] Set 1AVA HOME variable in Windows (1180}
3. =] Confluence Installation Guide (687)

4, =] Remote API Specification (467)

5. =] User Macros (436)
B
7
a
9
0

- =] Installing Confluence Standalone (385)
- =] JIRA Issues Macro (370)
- =] Administrators Guide (353)

- =] Cwnamic Tasklist Macro (335)
- =] Freguently Asked Questions (320)

Screenshot 2: Popular content

Notes
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The Confluence Usage Stats plugin, which provides the 'Space Activity' screen, is known to cause performance problems on large
installations. This plugin is disabled by default. A status report on the progress of the performance issues with this plugin is
available in this issue: USGTRK-15.

Your Confluence system administrator can enable the plugin, but please be aware of the possible impact upon your site's
performance.

® The plugin is sometimes called 'Confluence Usage Tracking'.

® |f your Confluence site is clustered, the space activity information will not be available.

Related Topics

Browsing a space

Viewing Space Details

Page History and Page Comparison Views
Watching Changes

Finding Unused Spaces

How Do | Get More Statistics From Confluence?
Installing and Configuring Plugins

Viewing Site Statistics

Take me back to Confluence User's Guide

Viewing All Confluence Spaces

A space is an area within Confluence, containing your wiki pages. You can think of each space as a sub-site, or mini-site, each with its own
home page.

@ Quick guide to viewing Confluence spaces

® The dashboard displays a list of all the spaces in the Confluence site that you have permission to see. You can

make a space a favourite, or categorise the space, to get easy access to the content that is most relevant to you.

See Customising your Personal Dashboard.

The space directory displays a list of all the global and personal spaces in the Confluence site that you have

permission to see. You can choose to see all spaces, the spaces you have marked as favourite, or the spaces in a

given space category. You can further restrict the number of spaces displayed, by entering a word or words in the

Filter box. Confluence will display only the spaces that have the matching words in the space name or description.

See Viewing All Confluence Spaces.

® The people directory displays a list of all Confluence users, including those who have personal spaces. See
Searching the People Directory.

On this page:

Viewing Spaces on the Dashboard

Viewing Spaces in the Space Directory

Viewing Personal Spaces in the People Directory
Notes

Related Topics

Viewing Spaces on the Dashboard

The Confluence dashboard displays a list of spaces that you have permission to view. Remember to log in, so that you can see the complete
list of spaces based on your username's permissions.

The Spaces tab displays all the global spaces on the site, and the spaces you have marked as your favourites, that you have permission to
view.

To see the spaces on the dashboard:

1. Click Dashboard at the top left of your Confluence screen.
2. Scroll down and click on the Spaces tab.

Screenshot: Viewing spaces on the dashboard
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Viewing Spaces in the Space Directory

The space directory displays a list of global and personal spaces that you have permission to view. Remember to log in, so that you can see
the complete list of spaces based on your username's permissions. The order of spaces is random.

Categorising the spaces: The spaces are displayed on a number of tabs, each showing a different sets of spaces, as follows:
® All Spaces — all the global and personal spaces on the site that you have permission to view.
® Favourite Spaces — the spaces that you have marked as your favourites.
® Categories — tabs showing spaces categorised by label. Note that you can add any space category you like. See Using Labels to
Categorise Spaces.

Filtering the list of spaces: To restrict the number of spaces displayed, enter a word or words in the Filter box. Confluence will display only
the spaces that have the matching words in the space name or description.

To see the spaces in the space directory:
1. Choose Browse > Space Directory.

2. Click one of the tabs to see the spaces you want.
3. If you want to restrict the number of spaces shown, entering a word or words in the Filter box.

Screenshot: Viewing favourite spaces in the space directory
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% Space Directory © Add Space

All Spaces Favourite Spaces Filter

Global Spaces
Space Description Categories
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Viewing Personal Spaces in the People Directory
The people directory displays a list of Confluence users, including those who have personal spaces. See Searching the People Directory.
To see the personal spaces in the people directory:

1. Choose Browse > People Directory.

2. Click People with Personal Spaces.

Screenshot: The people directory

Dashboard » People wse e I

% People Directory
Show: All People | People with Personal Spaces b | [ Search ] [Clear]
Found 20 result(s) for query e®.
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[
Dylan Etkin WY Edoardo Causarano
dylan@atlassian.com ecausaranof@atlassian.com
n Edwin Dawson Edwin Wong
;; edawsoni@atlassian.com edwin@atlassian.cam
L]

Notes

® |f you do not log in, you will be treated as an 'anonymous user'. Confluence will display only those spaces that an anonymous user
has permission to access.

® Permission to access a space is granted by a space administrator. See the overview of space permissions.

® You can use the Spaces List macro to display a list of spaces on a Confluence page.

Related Topics

144



Confluence 4.0 Documentation

145

Working with Spaces
Browsing a space

Take me back to Confluence User's Guide
Administering Spaces

This page gives an overview of the administration functions available in global and personal spaces. Note that you need to be a space
administrator to perform space administration functions.

On this page:

® Administering a Global Space
® Administering a Personal Space
® Related Topics

Administering a Global Space

To view the space administration menu:

1. Choose Browse > Space Admin.
o Space Admin is displayed only if you are a space administrator for that space or you are a Confluence system administrator.

2. All the options related to the management of a space are listed in the left-hand panel. Click a link to take you to the corresponding
screen.

For global spaces, the options available are divided the following categories:

® Space Operations
® Space Details — See Editing Space Details.
® Space Labels — See Using Labels to Categorise Spaces.
® Remove Space — See Deleting a Space.
® Trash — See Purging Deleted Pages and Restoring a Deleted Page.
® Security
® Permissions — See Viewing Space Permissions and Assigning Space Permissions.
® Restricted Pages — See Viewing Restricted Pages.
® Mail
® Mail Accounts — See Archiving Mail Overview.
® Mailbox Import — See Importing Mail.
® Look and Feel
® Themes — See Applying a Theme to a Space.
Colour Scheme — See Editing a Space's Colour Scheme.
Layout — See Customising Layouts for a Space.
Stylesheet — See Styling Confluence with CSS.
PDF Layout — See Editing the PDF Stylesheet.
PDF Stylesheet — See Editing the PDF Stylesheet.
Change Space Logo — See Changing a Space's Logo.

—

® Impor

Import Pages from Disk — See Importing Pages from Disk.

Administering a Personal Space

To view the space administration menu:

1. Choose Browse > Space Admin.

Space Admin is displayed only if you are a space administrator for that space or you are a Confluence system administrator.

2. All the options related to the management of a space are listed in the left-hand panel. Click a link to take you to the corresponding
screen.

For personal spaces, the options are divided into the following categories:

® Space Operations
® Space Details — See Editing Space Details.
® Space Labels — See Using Labels to Categorise Spaces.
®* Remove Space — See Deleting a Space.
® Trash — See Purging Deleted Pages and Restoring a Deleted Page.
® Security
® View or set space permissions
® View restricted pages
® Look and Feel
® Themes — See Applying a Theme to a Space.
® Colour Scheme — See Editing a Space's Colour Scheme.
® Layout — See Customising Layouts for a Space.
® Stylesheet — See Styling Confluence with CSS.
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®* PDF Layout — See Editing the PDF Stylesheet.
® PDF Stylesheet — See Editing the PDF Stylesheet.

Related Topics

Browsing a space
Working with Spaces

Take me back to Confluence User's Guide

Deleting a Space

Deleting a space permanently removes the space and all of its contents.

i) Warning

Use caution while deleting a space, and always create an XML Space Backup before proceeding. Once deleted, there is no
way to restore a space unless you have made an XML Space Backup.

You need to be a space administrator to delete a space.
To delete a space:

1. Choose Browse > Space Admin.
o Space Admin is displayed only if you are a space administrator for that space or you are a Confluence system administrator.

2. Click Remove Space in the left panel under the heading 'Space Operations'.
3. Click OK to confirm.

Related Links

Working with spaces

Setting up a New Global Space
Viewing All Confluence Spaces
Browsing a space

Moving a Page

Copying or Renaming a Space

Take me back to Confluence User's Guide

Setting up a New Global Space

To set up a new global space, you require the ‘Create Space' permission. ‘Create Space' is one of the global permissions that can be
assigned by a Confluence administrator. See Security or contact a Confluence administrator for more information.

To create a new global space:

1. Click Add Space located above the list of global spaces on the Dashboard. The 'Create Space' screen appears, as shown below.
2. Enter the following information about your new space:

Setting Description
Space A name for the space. Space names do not have to be unique.
Name

Space Key A simple key to identify your space (A-Z, a-z, 0-9). This key is a shorthand name for the space, used when
linking content between spaces, for web URLs and for reports. For example, a 'Development Space' might have
a space key of 'DEV'. The space key must be unique within the entire Confluence site.

Permissions =~ Choose who can view or contribute content to this space. A space administrator can change the permissions at
any time after creating the space.

Theme The look and feel for your space. A space administrator can change the theme later.

3. Click OK. The 'Home' page for your new space is displayed. Note that the home page will automatically contain any default space
content as defined by your Confluence administrator.
4. Click OK.

Next, you can start adding pages to your space.
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Screenshot: Creating a space

% Create Space

Content in Confluence is organised into spaces.

A space is where your pages live, where your blog is posted, and where your mail is archived. Permissions determine
who can view or contribute to the content of a space.

There is no limit to how many spaces you can create.

Enter a space name

Enter a space key

A space's key is a short version of its name, used to link to it quickly. It must be unique globally.

Example: A Development Space might have a key of DEV.

Who can use this space?

You can customize these permissions once the space is created.

Choose who can view and comment on content: Cheoose who can contribute (create and edit) content:
Vv Me v Me
™ Registered users - anyone logged into Confluence ¥ Registered users - anyone logged into Confluence

Choose Theme

To change the theme of this space, select one below.

I ®) Global Look and Feel
o The globally configured look and feel. You can customise colour-schemes and layouts manually.
rady

I () Documentation Theme
m""‘f""‘" This theme is well suited for structured content, such as documentation. It features a table of
f— contents (page tree) on the left, making it easier to see the structure of a space and move from page
e to page. You can customise the left-hand panel, page header and page footer.

O Easy Reader Theme

iy This is a fixed-width variation of the default Confluence theme. Its larger fonts, smooth gradient
background and comfortable line length make it ideal for displaying and reading longer documents.

Related Topics

Working with Spaces

Setting up your Personal Space
Viewing Space Details

Editing Space Details

Browsing a space

Deleting a Space

Take me back to the Confluence User's Guide.

Setting up your Personal Space

Your personal space is a place where you can publish your own pages and blog posts. Once you have set up your personal space,
Confluence users can reach it by clicking your name in the People Directory.
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On this page:

Creating your personal space

Adding and changing content in your space
Changing the colour scheme of Your Space
Granting access to your space

Notes

Related Topics

Creating your personal space

To set up your personal space, you require the 'Personal Space' permission which is assigned by a Confluence administrator from the
Administration Console. Refer to the Permissions Overview and Global Permissions Overview topics or contact a Confluence administrator

for more information.
To create your personal space:

1. Goto your name at the top of the page. (This is the 'user' menu.)
2. Select Create Personal Space from the dropdown list. The ‘Create Personal Space' view will open.
3. Enter a few details about your space:

® Choose who can view content.

® Choose who can contribute (create and edit) content.

® Choose the Theme (look and feel) for your personal space.
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% Create Personal Space

Your personal space is your own private workspace within Confluence.

You can optionally let other people view or contribute to it.

Who can contribute to your personal space?

You can customize these permissions once the space is created.

Choose who can view and comment on content: Choose who can contribute (create and edit) content:
Me Me
Registered users - anyone logged into Confluence [ Registered users - anyone logged into Confluence

Choose Theme

To change the theme of this space, select one below.

I @ Default Theme
—_— Use the globally configured look and feel. You can customise colour schemes and layouts
manually.
ahy

O Clickr Theme
A simple, clean Confluence theme inspired by Flickr - www flickr.com.

iy

) Modern Confluence Theme
The Confluence default theme with a more modern feel. This theme requires Firefox 3, Internet

Explorer 7+ and Safari 4

I O Left Navigation Theme
Provides a navigation bar on the left hand side of the screen.

I
i

Where is my personal space?
Once created, your personal space will be accessible (to anyone who can view it} at:

$bootstrapManager.domainName/display/~fredfer

Create ] ’ Cancel

4. Click Create.
5. The 'Home' page for your new space is displayed.
Note: Your home page will automatically contain any default space content as defined by your Confluence administrator.

Adding and changing content in your space

Now you can start adding pages to your personal space. You may also want to upload your photo.
Changing the colour scheme of Your Space
If you like, you can modify the colour scheme for your personal space.

Granting access to your space

When you created the space (see above), you made some preliminary decisions about who can view and contribute content to your space.
You can change the permissions on your space at any time.

Notes

® Once you have set up your personal space, you can return to it any time by clicking on your name (at the top of the page) and
choosing Personal Space.
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Related Topics

Working with Spaces
User Profile Overview
Linking to Personal Spaces and User Profiles

Take me back to the Confluence User's Guide.

Exporting Confluence Pages and Spaces to Other Formats

You can convert a part of, or the entire contents of a space to various formats, including Microsoft Word, HTML, PDF and XML. This is called
‘exporting' the space.

What would you like to do?

Exporting Confluence Pages and Spaces to HTML
Exporting Confluence Pages and Spaces to PDF
Exporting to a Word document

Exporting Confluence Pages and Spaces to XML

Related Topics
Browsing a space

Take me back to Confluence User's Guide

Exporting Confluence Pages and Spaces to HTML

Confluence allows you to export part of, or the entire contents of, a space into a zipped archive of HTML files. This is useful if you want
convert your space into a static website.

To use the space export functionality, you need 'Export Space' permission. See the guide to space permissions or contact a space
administrator for more information.

To export pages to HTML:
1. Go to a page in the space and choose Browse > Advanced.

2. Click HTML Export in the left-hand panel.
This option will only be visible if you have 'Export Space' permission.

3. Select the Include Comments check box if you want to include comments for the pages you are exporting.

4. Select the pages you want to export by selecting the check boxes in the tree view of pages displayed. By default, all pages are
selected. You have the option to Select All or Deselect All pages.
If you select the check box of a page that contains one or more child or descendant pages, all of these child and descendant pages
will also be selected. Similarly, if you clear the check box of such a page, all of its child and descendant pages will also be cleared.
This provides a convenient method of exporting subtrees, for example, chapters or sections within a document.

5. Click Export. This will create a zipped archive of HTML files.

6. When the export process has finished, download the zipped archive as prompted and extract the files into a folder.

Screenshot: Selecting pages to export
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% 4F Add ~
¥ Export Space

Blog Labels Attachments Bookmarks Mail Advanced Space Admin

Advanced Export content within this space as HTML.

@ Space Details Export
L.y Orphaned Pages
[ Undefined Pages
LI Templates

Select All Deselect All Include comments

Crowd Documentation
§ Snippet Errors Crowd 101
Crowd Administration Guide
Getting Started
& PDF Export Concepts
. HTML Export Supported Applications and Directories
About the Crowd Administration Console
Managing Directories
Subscribe Using the Directory Browser
Adding a Directory
Configuring an Internal Directory

Export

& XML Export

E) RSS Feeds

Notes

® Page attachments are placed in individual folders with names in the following format:
...\download\attachments\xxxxxx
where 'xxxxxx is the page ID of the page containing the attachments.

® By default, the 'Space Details' page is exported as index.html and displays the space's details as well as a list of all available
pages within it.

® Blog posts are not included in the HTML export. See the feature request: CONF-14684.
Related Topics

Exporting Confluence Pages and Spaces to PDF
Exporting Confluence Pages and Spaces to XML

Take me back to the Confluence User's Guide.

Exporting Confluence Pages and Spaces to PDF

This page explains how you can export individual Confluence pages, entire spaces or selections of pages into a single PDF file.

On this page:

Exporting Single Pages

Exporting Multiple Pages or the Entire Space
Customising the Appearance of PDF Exports
Notes

Related Topics

Exporting Single Pages

You can export a Confluence page to PDF. This option exports a single page and is available to all users who have permission to view the
page:

® Go to a page in the space and choose Tools > Export to PDF. Follow the prompts to export the page.
Exporting Multiple Pages or the Entire Space

Using Confluence's space export functionality, you can convert multiple pages or an entire space to PDF.

To use the space export functionality, you need 'Export Space' permission. See the guide to space permissions or contact a space
administrator for more information.
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To export a space or selected pages to PDF:
1. Goto a page in the space and choose Browse > Advanced.

2. Click PDF Export in the left-hand panel.
This option will only be visible if you have the 'Export Space' permission.
3. Select the pages you want to export.
® You have the option to Select All or Deselect All pages.
® When you select a page, all its child pages will also be selected. Similarly, when you deselect a page all its child pages will
also be deselected.
4. Click Export.
5. When the export process has finished, download and save the PDF file as prompted.

x ok Add ¥
#<> PDF Export

narks Mail Advanced Space Admin

Export content within this space as PDF. You can customise the layout and styling
of this exported PDF in the PDF Stylesheet page.

@ Space Details
Export
I Orphaned Pages

[ Undefined Pages

Advanced

Select All Deselect All

I Templates
§ Snippet Errors Crowd Documentation
Crowd 101
Export Crowd Administration Guide
= PDF Export Getting Started
& HTML Export Concepts

Supported Applications and Directories
About the Crowd Administration Console
Managing Directories

& XML Export

Subscribe
Using the Directory Browser
EJ RSS Feeds Adding a Directory
&3 Stop watching this space Configuring an Internal Directory

Screenshot above: Selecting pages to export

Customising the Appearance of PDF Exports

You can add a title page, a table of contents and customised headers and footers to the PDF output. For more advanced customisations, you
can apply Cascading Style Sheet (CSS) modifications. These customisations are specific to each space. You need the 'Space Administrator'
permission to be able to apply these customisations. For more information, see Editing the PDF Stylesheet.

Notes

Only image attachments that have been inserted into a page are included when exporting to PDF.

To export a PDF containing international text, you need to install a Unicode font in Confluence.

Blog posts are not included within the PDF export. If you like, you can vote for this feature request: CONF-5599.

If you have 'Space Administrator' permissions, the link to customise the PDF Stylesheet is provided at the top of the page tree, as
shown in the screenshot above.

® Confluence's PDF Export feature is designed to handle a wide variety of content. However, on rare occasions the PDF Export
process may fail due to an unrecognised customisation. If that happens the PDF export screen will indicate the title of the page in
which the problem occurred, to help you diagnose the cause of the failure.

Related Topics

Editing the PDF Stylesheet

Creating PDF in Another Language

Exporting Confluence Pages and Spaces to HTML
Exporting Confluence Pages and Spaces to XML
Take me back to the Confluence User's Guide.

Editing the PDF Stylesheet

Confluence administrators and space administrators can customise the PDF exports for individual spaces. Possible customisations include:
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® A title page, which can include images,

® Page headers and footers, each with customisable content such as page numbering,
® Table of contents with page numbering,

® Page and margin sizes.

On this page:

Before You Start

Customising the PDF Layout
Customising the PDF Stylesheet
Default CSS Settings

PDF Export Methods

Examples of Basic Customisations
Notes

Related Topics

Before You Start

Please take note of the following points:

® Most PDF customisations use a combination of HTML and CSS (Cascading Style Sheets). You need to be comfortable with these
technologies before applying any customisations.
® PDF customisations are unique to each space.
® There are two aspects that control Confluence custom PDF exports. You will need to modify each of these to ensure that your PDF
exports are customised to your requirements:
®* The PDF Layout defines the title page, headers and footers.
®* The PDF Stylesheet defines the page size and margins, font, colour, list numbering, and all other style customisations.

Customising the PDF Layout
You can add your own HTML to customise the title page, page headers and page footers in the PDF output.
To customise the PDF layout:

1. Choose Browse > Space Admin.
o Space Admin is displayed only if you are a space administrator for that space or you are a Confluence system administrator.

2. Click PDF Layout in the 'Look and Feel' section of the left-hand panel.
3. Click Edit. You can now customise the HTML that generates following areas in the exported PDF document:
®* PDF Space Export Title Page — title page.
® PDF Space Export Header — page headers.
® PDF Space Export Footer — page footers.
4. Enter your customisations into each text box as required. The PDF layout section accepts HTML code. You can include inline CSS in
the HTML too.
5. Click Save.

Customising the PDF Stylesheet
You can adjust the appearance of the PDF pages by editing the CSS stylesheet.
To customise the PDF Stylesheet:

1. Choose Browse > Space Admin.
o Space Admin is displayed only if you are a space administrator for that space or you are a Confluence system administrator.

2. Click PDF Stylesheet in the left-hand panel. The 'PDF Export Stylesheet' section appears, showing the current contents of your PDF
stylesheet. It contains all CSS rule customisations applied to the pages in the space.

3. Click the Edit.

4. Enter your customisations into the text box as required. The PDF stylesheet section accepts Cascading Style Sheets (CSS) rules.

5. Click Save.

Default CSS Settings

® |f no PDF customisations are defined on the PDF stylesheet screen, the default CSS rules will be applied to your PDF exports. By
default, the export does not include a title page, headers or footers.

® To get started, you can download the default CSS rules of the PDF stylesheet: confluencedefaultpdf.css. Any rule defined in this file
can be customised and added to the 'PDF Export Stylesheet' section.

® You can also make further CSS customisations as required. This means you can override any default CSS rule by redefining it in the
'PDF Export Stylesheet' section with your own customisations.

PDF Export Methods

There are two PDF export methods (see Exporting Confluence Pages and Spaces to PDF):
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® Exporting a single page via the 'Tools' menu on the page or blog post. Only the PDF stylesheet customisations apply to single page
° g(gcc))"rttlsng one or more pages via the space export function. When exporting a space, all your customisations apply, including both
the PDF stylesheet and the PDF layout.
To make your PDF layout customisations apply to a single page exported to PDF, either:
® use the 'space export' method to export that single page only, or

® if your header and footer customisations contain only text, follow the appropriate customisations provided in the advanced PDF
stylesheet customisations.

Examples of Basic Customisations

This section provides examples of typical customisations that you can add to your PDF stylesheet. Once you are familiar these basic
customisations, you may wish to try some advanced customisations.

Page Customisations

Modifications to page and margin sizes are made in the @page CSS rule. To make changes to this rule, implement the following type of code
in the PDF stylesheet.

i /*Page specific styles (that is, customisations of properties) go here*/

Customising the Page Size

The default page size is based on the locale of your Confluence server. For example, if this server is located in the US then the default paper
size of your PDF export will be US Letter size (8.5 inches wide by 11 inches long). If the server is located in Australia, the default paper size
will be A4 (210 mm wide by 297 mm high).

To modify the page size to A4, add a size property to the top of the rule like this:

/*The A4 paper size is 210 mm wide by 297 mm high*/
size: 210mm 297mm;

More information about paper sizes can be found on Wikipedia.
Customising the Page Margins

To add a margin of 15 mm to a paper size of A4, your CSS epage rule would look like this:

size: 210mm 297mm;
margin: 15mm;

Splitting Confluence Pages

By default, short Confluence pages will be grouped together if they can fit into a single PDF page. If you want each of the Confluence pages
to remain as an individual PDF page you can use the code below:

.pagetitle

{

i page-break-before: always;

Customising the Table of Contents

By default, a table of contents will be generated after the title page, or at the beginning of the document if no title page is defined in the PDF
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layout. To make changes to the look and layout of the table of contents, define the appropriate CSS rules in the PDF stylesheet.

For details about the default CSS rules applied to the table of contents, download the default CSS rules (from the link above) and examine
the specific rules with toc in their name.

Disabling the Table of Contents

To prevent the table of contents from being generated in your PDF document, add the div. toc rule to the PDF stylesheet and set its
display property to none:

H div.toc

: { :
H display: none;

: } :

Changing the Leader Character in the Table of Contents

The leader character is used to link the name of a heading in the table of contents with its page number. The page number is usually aligned
to the right-hand margin of the page. By default, the leader character is the '.' (dot) character. You can change it by customising the leader
character CSS rule span.toclead:before and adding this to the PDF stylesheet.

To change the leader character to a solid line, modify the CSS rule to the following:

span.toclead:before

{

content: leader(solid) ;

span.toclead:before

{

content: leader (space) ;

(Be aware that using a space as a leader character can make the table of contents difficult to read.)

Wrapping Long Words

In order to break long words or words that are not separated by whitespace, add a selector to the PDF stylesheet containing the word-wrap
property with a value of break-word:

div {
word-wrap: break-word;

Adding a Title Page

You can create a title or cover page to your PDF document using HTML. Use the PDF Space Export Title Page section of the PDF layout to
do this. Adding a New Title Page

The following example uses HTML with an inline CSS rule to generate a title page.

Including Content Above Table of Contents in Default Title Page

The following example includes content above the automatically-generated table of contents that appears on the default title page, so that
your title page includes your own content plus the table of contents.

Adding an Image to your Title Page

In the examples above, the title page includes an image called 'titlepage.png’, centred in the middle of the page. The image is attached to a
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Confluence page and is referenced via its relative URL (that is, we use only the last part of the URL, excluding the Confluence site's base
URL).

Follow these instructions to include an image on your title page:

. Attach the image to a Confluence page.

. View the list of attachments on that page.

. Right-click the image and copy its location.

. Paste the link into the appropriate src="" attribute within your PDF stylesheet, as shown above.
. Remove the first part of the URL before /download/. . ..

ab~rwWNE

Adding Headers and Footers

You can add headers and footers to your PDF pages using HTML. Use the 'PDF Space Export Header' and 'PDF Space Export Footer'
sections of the PDF layout to do this. For simple headers and footers, plain text is enough. The following example adds a simple copyright
notice.

Adding Page Numbering to a Header or Footer

To add page numbering to your documentation, you need to combine some customised HTML in the header or footer with some customised
CSS in the PDF stylesheet.

1. Create a header or footer with an empty span element and give it a unique ID, for example pageNum. This is a place holder for the
page number in your PDF document.

2. Create the following CSS selector rule for the empty span and add it to the PDF stylesheet:

Analysing the above CSS selector rule in more detail:

® The #pageNum rule selects the HTML element with the specified ID of "pageNum", which is the span element we created for the
header or footer.

® The :before part of the selector is a pseudo class that allows the insertion of content before the span element is processed.

® The counter (page) is a function that returns the current page number as its content.

® The content property tells the CSS processor that dynamic content (that is, an incrementing page number) is to be inserted before
the span tag.

General Formatting

You can use the stylesheet to customise the output of just about anything else that will influence the look and feel of the final document. This
includes fonts, tables, line spacing, macros, etc. The export engine works directly from the HTML output produced by Confluence. Therefore,
the first step in customising something is to find a selector for the HTML element produced by Confluence or the Confluence macro. Then
add a CSS rule to the PDF stylesheet. Your customisation will appear in the PDF export.

Notes

® Demotion of heading elements: hl, h2, and so on. Due to the hierarchical manner in which a space is exported, Confluence will
modify the heading elements to generate a uniform appearance for the entire space export. This means that headings will be
demoted. This will affect the application of custom PDF Stylesheets. It is possible to calculate the amount by which a heading will be
demoted in order to have the correct CSS styling applied. A heading will be demoted by the value of its depth in the export tree. A
page at the first level will be demoted by 1 (all <h1> elements will become <h2> elements, and so on). A page at the second level
will be demoted by 2, and so on.

® Atlassian support for PDF customisation is limited. We support the mechanism for customising the PDF layout with HTML and
CSS, and we will help if the mechanism is broken or does not work as we say it should in our published examples. But, since custom
HTML and CSS offer potentially limitless possibilities, Atlassian will not support issues that are caused by or related to PDF
customisations.

Related Topics

Advanced PDF Stylesheet Customisations

Advanced PDF Stylesheet Customisations

This topic provides information and details on popular PDF stylesheet customisations. These expand upon the basic customisations
described in Editing the PDF Stylesheet.

The information below is for advanced users. Customisations are not supported by Atlassian. Be aware that the advanced
customisations described below require knowledge of certain parts of Confluence, and of CSS and HTML. This documentation is intended fo
advanced users. Some of the suggestions below are moderately complex. If you are having trouble understanding them we strongly suggest
you ask an expert. We do not support any of the customisations described below. This means that the Atlassian support engineers will not be
able to help you with these modifications, because even for them this kind of configuration can be tricky.
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On this page:

® Page Customisations
® Changing the Page Orientation to Landscape or Portrait
® Customising Page Margins Separately
® Page Header and Footer Customisations
® Adding Headers and Footers to Single Page Exports
® Adding Images to Headers and Footers
Page Selector Rules for Left- and Right-Hand Pages
Incorporating Other Fonts
Hiding Text from the PDF Output
Notes
Related Topics

Page Customisations

Modifications to page and margin properties are made in the e@page Cascading Style Sheet (CSS) rule. As described in Editing the PDF
Stylesheet, all CSS rule customisations are implemented in the space's PDF stylesheet.

Changing the Page Orientation to Landscape or Portrait

To change the page orientation of your PDF document, reverse the order of the values declared in the @page rule's size property. The first
and second values of this property represent the width and height of the page, respectively.

For example, to generate PDF space exports in A4-sized landscape orientation, your @page rule might look like this:

/*A4-sized pages in landscape orientation are 297 mm wide by 210 mm high*/
size: 297mm 210mm;

Customising Page Margins Separately

To set the margins of each side of a page independently of the other, you can declare each margin size in the @page rule using the following
properties:

Properties Description

margin-top Margin height at the top of the page.

margin-bottom Margin height at the bottom of the page.

margin-left Margin width on the left of the page.

margin-right Margin width on the right of the page.

For example, to generate PDF space exports with top and bottom margins of 1 inch and left and right margins of half an inch, your @page
rule might look like this:

margin-top: 2.54cm;
margin-bottom: 2.54cm;
margin-left: 1.27cm;
margin-right: 1.27cm;

Page Header and Footer Customisations

Adding Headers and Footers to Single Page Exports

As mentioned in Editing the PDF Stylesheet, custom headers and footers by default, only apply to space export' and not to exports of single
pages. However, it is possible to add CSS rules to your PDF export stylesheet that allow custom headers and footers to appear in single
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page exports.

For custom headers, define @top-left, @top-center and @top-right rules within your @page rule. These rules apply respectively to
content that appears on the left-hand side, centre and right-hand side of your page's header area.

For custom footers, define @bottom-1left, @bottom-center and @bottom-right rules within your @page rule.

Add the following rules to add a document title at the centre of the header and a page number at the centre of the footer:

@page
/* Any page-specific properties */
{
@top-center
{
content: "Document Title Goes Here";
font-family: ConfluencelInstalledFont, Helvetica, Arial, sans-serif;
font-size: 8pt;

@bottom-center

content: "Page " counter (page) ;
font-family: ConfluenceInstalledFont, Helvetica, Arial, sans-serif;
font-size: 8pt;

/* Any other page-specific rules */

® The font-family and font-size properties ensure that the header and footer text is rendered in the same default font style used
for the body text, based on the default CSS rules.

® |tis not possible to use this method to insert images (stored as attachments within your Confluence instance) into the headers and
footers of single page exports.

Adding Images to Headers and Footers

To insert an image into a header or footer, edit the header and footer sections of the PDF layout and use an HTML img element with src
attribute. The src attribute refers to an image attached to a Confluence page. The image element is usually placed within a div element
container.

For example, to add an image to the left of the header:

<div style="margin-top:1l0mm">
<img src="/download/attachments/12346/header-image.png"/>
</div>

In the example above, the header includes an image called 'header-image.png'. The image is attached to a Confluence page and is
referenced via its relative URL (that is, we use only the last part of the URL, excluding the Confluence site's base URL).

Follow these instructions to include an image on your PDF title page:

. Attach the image to a Confluence page.

. View the list of attachments on that page.

. Right-click the image and copy its location.

. Paste the link into the appropriate src="" attribute within your PDF stylesheet, as shown above.
. Remove the first part of the URL before the /download/. . . part.

ab~rwWNE

To add an image to a footer, add similar HTML code consisting of an img element and src attribute. Incorporate the inline CSS property
margin-bottom to separate the image from the bottom of the page if necessary.

Notes:

® This code uses an inline CSS property in the style attribute to set formatting properties specific to this header image.

® The margin-top:10mm property forces the image away from the top of the page by 10mm. This comes in handy when your header
image is large enough to touch or spill over the top of the page.

® Likewise, for footers, you can use the margin-bottom:XXmm property to force an image away from the bottom of the page by 'XX'
mm.

® Very large images can spill over into the body of a page or alter the position of text or other elements used within a header or footer.
In such situations, it is recommended that you reduce the size of the image and then upload it to your Confluence site again. If you
prefer to keep the image size and want to move the content lower instead, you can do so by configuring the margin-top properties
in the epage CSS rule.

® By default, a header or footer image is aligned to the left-hand side of the page. However, you can align this image to the centre or
right-hand side of a page by adding either the text-align:center or text-align:right properties to your style attribute.
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For example, to align the header image to the right-hand side of the page, your style attribute would look similar to this:
style="margin-top:10mm; text-align:right"

Page Selector Rules for Left- and Right-Hand Pages

If your PDF exports are destined for double-sided printed media (for example, books), you can define different customisations for left- or
right-hand pages.

To do this, define two CSS pseudo-class page selectors as separate rules within the PDF stylesheet.

® Use the :left psuedo-class with the @page CSS rule to define customisations for left-hand pages
® Use the : right psuedo-class with @page to define customisations for right-hand pages.

You can use these page selector CSS rules in your PDF stylesheet to define alternating left and right margins to allow room for binding a
double-sided document. For example:

@page :left
margin-left: 3cm;
margin-right: 1.27cm;
/* Any other left-hand page-specific properties and rules */

}

@page :right
margin-left: 1.27cm;
margin-right: 3cm;
/* Any other right-hand page-specific properties and rules */

Incorporating Other Fonts

Out of the box, Confluence provides Times New Roman, Helvetica or Courier fonts for use in PDF exports. You can incorporate your own
fonts for use in PDF exports by declaring them within a @Eont - face CSS rule within your PDF export stylesheet.

The following CSS rule example shows how to embed the Consolas font into your PDF export:

@font-face {
src: url(file:///usr/share/fonts/Consolas.ttf);
-fs-pdf-font-embed: embed;

}

.code pre, .preformatted pre, tt, kbd, code, samp {
font-family: Consolas, monospace;
font-size: 9pt;

The font path specified in the CSS must be the path to the font on the Confluence server.

Hiding Text from the PDF Output

This section describes a way to hide text from your PDF export. In other words, you can have text on the Confluence page that will not
appear in the PDF export.

There are two stages:
1. Follow the instructions to define the NoPrint user macro.

2. Add the following CSS to your PDF stylesheet to make the PDF export recognise the NoPrint macro:

.noprint {
display: none ;

Notes

If styling is not working as expected, it is useful to look at the HTML source to which the CSS is applied. Whenever you create an HTML
export that contains multiple pages, the intermediary HTML is stored in the temp directory in Confluence's home directory. For example:
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<confluence-home>/temp/htmlexport-20110308-154047-1/export-intermediate-154047-2.html

Related Topics
Editing the PDF Stylesheet

Creating PDF in Another Language

To export a Confluence page written in a language other than English, you need to install the necessary font for that language. This means
that you need to upload the font file to Confluence, as described below.

Uploading a Font File to Confluence

1. Find the appropriate font file:
®* Windows users:All font files in Windows are stored in a directory called:

C:\WINDOWS\Fonts

® Unix users:All font files in Unix are stored in:

/usr/share/fonts

® Microsoft True Type core fonts such as Verdana can be downloaded from this page: http://corefonts.sourceforge.net/

Copy the font file into a temporary folder, for example a folder on your desktop.
Go to the 'PDF Export Language Support' screen in the Confluence Administration Console and upload the file you copied in step 2.

. Click Install.

ENFARN

Notes

® The only font files supported are true type fonts and true type collections. The accepted file extensions are *.ttf and *.ttc.
®* We recommend that you use Unicode font Verdana for correct character encoding and exporting to PDF.

Related Topics

Exporting Confluence Pages and Spaces to PDF

Exporting to a Word document

Confluence allows you to export a single page into a Word document. This is extremely useful for emailing around content to non-Confluence
users, printing a document or just creating a backup in Word.

You will require 'Export Pages' permission to export a page to a Word document.
To export to a Word document:
1. Go to the 'Export to Word' option for the page. To do this:

® Go to a page in the space and choose Tools > Export to Word. You will be prompted by a series of dialog boxes.
2. By default, this will create a Word document with the same name as the Confluence page.

Exporting Confluence Pages and Spaces to XML

Confluence allows you to export a part of, or the entire contents of, a space into a zipped archive of XML files.

This is useful if you want to make a backup of the space, export the space to another Confluence instance, or use the data from the space in
another application. Please note that there are a few restrictions when Restoring a Space, and that huge spaces exported for
backup-purposes may benefit from other means of backup. See Production Backup Strategy.

To export to XML, you will need 'Export Space' permission which is assigned by a space administrator. See Space Permissions or contact a
space administrator for more information.

Site administrators can import a space from a zipped XML archive.

To export to XML:

1. Go to a page in the space and choose Browse > Advanced.

2. Click XML Export in the left-hand panel.
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This option will only be visible if you have 'Export Space' permission.

. Select Include Comments if you want to include comments made on the pages you are exporting.

. Select Backup Attachments if you want include the images and other files attached to the pages.

. Select the pages you want to export. Select the relevant check boxes in the tree view of pages displayed. By default, all the pages
are selected. If you select a page that has one or more child or descendant pages, all of these child and descendant pages will also
be selected. Similarly, if you clear the check box of such a page, all of its child and descendant pages will also be cleared. This
provides a convenient method of exporting subtrees, for example, chapters or sections within a document.

6. Click Export. This will create a zipped archive of XML files.

g~ w

Screenshot: Exporting a space with administrator permissions

Export content within this space as XML.

Pages to export: 0 All (includes pages not visible to you)

@ Visible to you

Select All Deselect All Include comments Include attachments

_Inclusions Library
_OAuth Consumer Definition
_OAuth Definition
_OAuth Provider Definition
bookmarks
Google Provisioning AP Developer's Guide Protocol - Google Apps APls - Google Code
Home
Documentation guidelines
How to update documentation
Disclaimer Wording for Beta documentation
Exporting and uploading PDF, HTML and XML versions of the docs
Bookmarklet to toggle checkboxes on Confluence space export

Notes

® |f you are running Confluence behind Apache HTTP Server and are facing timeout errors, please consider creating the export
directly from Tomcat, instead of going through Apache. This will speed up the process and prevent timeouts.

® |f you have Space Administrator or Confluence Administrator permissions, you can export either All pages or those pages
Visible to you. All exports all content in the space, including pages that are protected by page-level restrictions which will prevent
you from viewing the pages themselves. This option is available only to space administrators and Confluence administrators. It
allows you to make a complete and comprehensive export of a space for backup purposes. Visible to you exports only content you
can see. This is the default option.

Related Topics

Browsing a space

Restoring a Space

Exporting Confluence Pages and Spaces to PDF
Exporting Confluence Pages and Spaces to XML

Take me back to the Confluence User's Guide.

Browsing a space

The Browse Space view gives you access to:
® Space-wide views of the content of the space — pages, news, labels, attachments, bookmarks and mail.
® Summary information about the space.
® Advanced space management tools.
® Tools to administer the space (for space administrators only).
The components of the Browse Space view are organised into a number of blue tabs.

Go to a page in the space and choose Browse > Space Admin.

Screenshot: Browsing a space — 'Advanced' tab
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Pages Blog Labels Attachments Bookmarks Mail Advanced Space Admin

Name: Confluence 3.5

Key: DOC

Home Page: ﬁ(:onﬂuence Documentation Home

Created By: Mike Cannon-Brookes (Dec 17, 2003)

[ Undefined Pages Space Labels: (None) [Edi

Space Categories: confluence, documentation [Edif

Description: Documentation for the latest version of the Confluence wiki: Installation Guide, User
Guide, Admin Guide and other technical documentation

LIy Orphaned Pages

Ly Templates
B Snippet Errors

Export // Edit Space Details

& PDF Export

ﬂ The tabs that are displayed will depend on your Confluence site configuration, the type of space you are viewing and the space
permissions granted to you for the space.

Pages

® View pages alphabetically
® View recently updated content
More about Working with pages

Labels

® View labels

Attachments

® Find an attachment
® View details of an attachment
More about Working with attachments

Mail

® View mail for this space
® Fetch new mail
® Delete mail
More about Working with mail

Blog Posts

® View blog posts for this space
More about Working with blog posts

Activity
® View space activity
Advanced

View space details

Edit space details

Manage orphaned pages

Manage undefined pages

Adding a Template

Manage page templates

Export pages to PDF, HTML and XML
Subscribe to RSS feeds within Confluence
Watch a space

Add a space to your favourites

Space Administration
® Space Administration

Related Topics

Working with Spaces

Setting up a New Global Space
Viewing All Confluence Spaces
Moving a Page

Deleting a Space
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Take me back to Confluence User's Guide

Editing Space Details

You need to be a space administrator to edit the details of a space.
To edit the details of a space:
1. Choose Browse > Space Admin.
2. In the 'Edit Space Details' screen which appears you can:
® Enter a different name for the space.
® Enter or modify the space description.

® Select a new home page for the space from the drop-down menu. This is the default page to which users are directed when
they click the link to the space from the Dashboard.

o If you set this field to blank (no selection) then the default home page will be the 'Pages' tab of the 'Browse Space' page.
3. Click Save.

Notes

® You cannot edit the key or the creator's name.
® The Edit Space Details fields do not accept wiki markup. Any wiki markup entered in these fields will be displayed as plain text.

Related Topics

Viewing Space Details
Browsing a space

Take me back to Confluence User's Guide

Managing Orphaned Pages

An orphaned page is a page without any incoming links. What this means is that unless you know that this page exists, you are not likely to
come across it in the space during the natural course of navigation.

When you are working in a large space with a number of pages, it is difficult to keep track of all of them. An orphaned page may be
redundant or need to be referred to from another page. Confluence allows you to view all the orphaned pages in a space so you can "tidy up"
the space by either deleting pages or by reorganising them.

To view the orphaned pages in a space:

1. Choose Browse Space > Advanced.
2. Click on Orphaned Pages in the left panel.

You can:

¢ delete an orphaned page by clicking on the 'trash' icon beside it.
® give an orphaned page a parent — see Moving a Page.

Screenshot: Managing Orphaned Pages

Welcorme Widya Madabushi | History | Profile | Administration | Log Sut &

Atlassian Mews
X)Orphaned Pages - Atlassian News

@ Browse Space | 4 Add Page |G Add News

Attachments TN B ETTHEETE | Advanced | B ET=CRCT T

Advanced Orphaned Pages Report

\gj Space Details . . .
This report shows all the orphaned pages which are not linked to by other pages.

|If Orphaned Pages

[t Undefined Pages Last Updated

Title (space) Creator Created By Updated Operations
Export 1.2.1 HEKjiii (atlassian b sep 21, Mov 04, O
(Atlassian Mews] ANONyMmous 2004 ANONYMOous 2004 / | i)

@
— Export Space

Subscribe

RSS Feeds

nd Start watching this space

Related Topics

Managing Undefined Pages
Browsing a space
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Take me back to Confluence User's Guide

Managing Undefined Pages

In Confluence, you can create links to pages that you intend to create later. This is useful as it allows you to create links first and enter
content for those pages later.

For example, Link to new page is a link to a non-existent page. The link is shown in dark red. (A broken link is shown in grey.)

The Undefined Pages view gives a consolidated report of all undefined pages so that you can manage your space better. The undefined
page links are badged with this % icon to remind you that those pages need to be created.

To view a list of the undefined links in a space:

1. Click on the Browse menu for the space, and choose Advanced.
2. Click on Undefined Pages in the left panel. This will display a list of all the undefined pages in the space.

You can click on the link for an undefined page to create the page and add content to it.
Related Topics

Managing Orphaned Pages
Browsing a space

Take me back to Confluence User's Guide

Viewing Hierarchy of Pages within a Space

The 'Tree' view of the 'List Pages' page displays the hierarchy of the pages within the space. It is a useful way of viewing all the parent-child
relationships between pages in the space at once.

To see the tree view of pages within a space:

1. Choose Browse > Pages.
2. Click Tree.

Screenshot: Tree View
= Documentation Home

Confluence Security Advisory 2005-02-09
RSS

¥ Confluence Plugin Guide

# Importing From JSPWiki

[ Confluence Release Cycle

Setup a8 mail ee=sion in standalone version

Related Topics

Moving a Page
Working with Pages

Take me back to Confluence User's Guide

Viewing Pages Alphabetically

Use this view when you are looking for a specific page in a space and you know its title.
To view the pages in your space alphabetically:

1. Choose Browse > Pages.

2. Click on Alphabetical View.

3. Click on a letter to display all the pages beginning with that letter. Clicking on a page link will take you to that page.
Notes

® If you know the title of a page, you might find it faster using the Quick Search.

Related Topics

View Recently Updated pages
Browsing a space

Take me back to Confluence User's Guide

Viewing Recently Updated Content
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The 'Recently Updated' view is a useful way of keeping track of the changes being made in a space. It displays links to the most recently
added or modified content within the space including pages, blog posts, mail messages and comments.

To view the recently updated content in a space:

1.
2.

Choose Browse > Pages.
Click Recently Updated. A list of the most recently added or modified content in the space is displayed. Clicking on a link will open
up the corresponding document.

Related Topics

Recently Updated Macro
View Pages Alphabetically
Browsing a space

Viewing Space Activity

Take me back to Confluence User's Guide

Viewing Space Details

To view a space's details:

1. Choose Browse > Advanced.
2.
3. Edit the Space details as required. Note that the Edit Space Details fields do not accept wiki markup. On save, any wiki markup

Click Space details and then Edit Space Details. This will open the Edit Space screen.

entered in these fields will display as plain text.

The following details are displayed:

The Name of the space.

The Key used to refer to the space. This key is a shorthand name for the space that is used for web urls, reports, and when linking
content between spaces. Note that personal space keys always contain a '~', whereas global space keys never do.

Any Labels defined for this space. Optional.

The Homepage of the space. Optional. This is the default page to which users are directed when they click on the link to the space
from the dashboard. If this field is empty (not displayed) then the default home page is the Pages tab of the '‘Browse Space' page.
The Creator of the space.

Space Description: Optional. This is a short description of the space used to provide users with an idea of the space's contents.

Here is an example:

Screenshot: Space Details

Mame: Atlassian Mews

Key: NEWS

Home Page: The Atlassian Newsletter
Created By: Charles Miller (fug 24, 2004)
Description:

Mews and Announcements from Atlassian

/ Edit Space Details

Related Topics

Editing Space Details
Browsing a space
Viewing Space Activity

Take me back to Confluence User's Guide

Space Backup and Restore

Confluence can backup all the content, comments and attachments for a space. The process involves converting the data in the space into
XML format. The end product is a zip file that contains XML file(s) and optionally, all the attachments in the space. To transfer this data to
another Confluence site, you simply restore this zip file.

Creating a Space Backup

Instructions on how to create a backup for a space can be found here.

Restoring/Importing a Space Backup
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Instructions on how to restore or import the backup of a space can be found here.

Archiving Mail Overview

Confluence allows you to collect and archive mail within each space individually. This is a useful facility that allows you to archive all emails
pertaining to a particular project on Confluence alongside it in the same space.

You can download mail from one or more pop-accounts. You can also import mail from mbox files either on your local system or on the
Confluence server.

Choose Browse > Mail to see archived mail.

(If you are not a space administrator for the target space, contact your Confluence administrator to request Space Admin permission.)
From here, you can navigate mail easily and also use the Quick Search to search mail and the attachments it contains.

What would you like to do?

Add a Mail Account
Manage Mail accounts
Import Mail

View Mail

Fetch Mail

Delete Mail

Restore Mail

The ability to archive mail applies only to global spaces, not personal spaces. Please see Working with Spaces for
information about the differences between global spaces and personal spaces.

Related Topics

Take me back to the Confluence User's Guide.

Adding a Mail Account

When you add a mail account, you are configuring Confluence to download mail from that account and archive the mail within the space.
Since Confluence removes emails from an email account as it is added to the Mail Archive, Confluence must be set up to poll a clone email
account rather than the actual account. For example, to archive the actual account sales@company . com to your Confluence Sales space,
you must first create a clone account such as conf -sales@company . com that contains the same email content.

Stage 1 - Creating A Clone Email Account

. Add a new email account on the mail server with the clone email address.
. Copy all existing emails from the actual account to the clone account.

. Set up the actual account to bcc sent emails to the clone account.

. Set up the actual account to forward received emails to the clone account.

A WNPE

Stage 2 - Archive Clone Account To Mail Archive

1. If you are not a space administrator for the target space, contact your Confluence administrator to request Space Admin permission.
You need to be a space administrator before you can add a mail account to the space.

. Go to Browse > Mail.

. Click on Mail Accounts under the heading ‘Mail' in the left panel to show the list of existing mail accounts.

. Click Add mail account located at the top of the page.

. Enter configuration details for the account. The protocol may be POP/S or IMAP/S. Click Create when finished.

abowN

Account Name: Enter a name for this account by which it will be known in Confluence.
Description: Provide a description for this account (Optional).

Protocol: Choose from POP, IMAP, POPS or IMAPS

Hostname: Enter the account mail server host name.

Port: The mail server's port number will be displayed by default. Do not edit this field.
Username: Enter a username for this account.

Password: The account's password.

e

Configured accounts will have their mail downloaded and removed from the server, so make sure you are downloading
from a clone account.
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Account Mame: [Sample User
Description: |(Sarmple Users Account
Protocol: |
Hostname:
Port:
Username:

Passwurd. ek sk sk sk rkokok

[ Create ][ Test Connection ][ Cancel ]

i)

Note: The ability to import mail applies only to global spaces, so the 'Import' section in the above screenshot does not appear in the ‘Space
Admin' tab for personal spaces. Please see Working with Spaces for information about the differences between global spaces and personal

spaces.
Related Topics

Archiving Mail Overview

Managing Mail Accounts

Importing Mail

Viewing Mail

Fetching Mail

Deleting Mail

Linking to Mail

How do | check which spaces have email accounts
How do | Disable Automatic Mail Polling?

Take me back to Confluence User's Guide

Deleting Mail

To delete mail for a space, you require 'Remove Mail' permission which is assigned by a space administrator from the Space Administration
screens. See Space Permissions or contact a space administrator for more information.

Only a space administrator can delete all email messages for the space simultaneously.

To delete mail for a space:

1. Go to Browse > Mail.
2. Go to the Mail tab. A list of messages in the space is displayed in reverse chronological order.

3. Delete an individual email by clicking the trash ! icon beside it. Deleted mail is stored under Trash and can be restored by a

space administrator from the ‘Space Admin tab.
If you are a space administrator, you can delete all email messages within a space at once by clicking on the Delete All link at the
top of the mail view.

) Warning

Email messages deleted using the Delete All option cannot be restored.

Related Topics
Restoring Mail

Archiving Mail Overview
Browsing a space

Take me back to the Confluence User's Guide.

Fetching Mail

Confluence fetches mail from the server once every 30 minutes.

You need to be a space administrator to manually retrieve new mail from mail accounts.
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To manually retrieve mail:
1. Go to Browse > Mail.

2. Go to the Mail tab. A list of messages for the space is displayed in reverse chronological order.
3. Click on the Fetch new mail link located above the list of messages. Any new messages will be displayed in order of most recent

first.

ﬁ Note

Once mail is fetched, it will be removed from the server.

Related Topics

Viewing Mail

Archiving Mail Overview

Deleting Mail

How do | Disable Automatic Mail Polling?

Take me back to the Confluence User's Guide.

Importing Mail

Confluence allows you to import mail from mbox files located either on your local system or on the Confluence server and archive it within the
space.

You need to be a space administrator to import mail for a space.
To import mail from mbox files:
1. Go to Browse > Mail.
2. Click on Mail Import under the heading ‘Mail' in the left panel.

® To import from a Local system, click Browse to select the mbox file. Then click Import.
® To import from the Server, enter the location of the mbox file on the server in the Server text field and click Import.

Screenshot : Importing mail

Impaort mail from a standard mbox file by either uploading a local file or specifying its location on the server.

Local

Browse for mbox file on local filesystem:

Filename: Browse... Import |

Server
Specify location of mbox file on server:

| Impaort

The ability to import mail applies only to global spaces, so the ‘Import' section in the above screenshot does not appear in
the 'Space Admin' tab for personal spaces. Please see Working with Spaces for information about the differences between

global spaces and personal spaces.

Related Topics

Archiving Mail Overview

Adding a Mail Account

Importing Mail

Take me back to the Confluence User's Guide.

Managing Mail Accounts

You need to be a space administrator to manage mail accounts for a space.
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To manage mail accounts:

1. Go to Browse > Mail.

2. Click on Mail Accounts under the heading 'Mail' in the left panel. For each of the mail accounts listed, you can:
® Edit : change the configuration settings for the mail account.
®* Remove: remove the account permanently.
¢ Disable: temporarily disable the account.

Screenshot : Managing mail accounts

0O Add Pop Account

Name Description Host Status Operations
conf-user archive Archive of conf-user rmail.atlassian.com (114 Edit | Remove | Disable
ou ui ui DISABLED  Edit | Remove | Enable

Related Topics
Archiving Mail Overview
Adding a Mail Account
Importing Mail

Viewing Mail

Fetching Mail

Deleting Mall

Restoring Mail

Take me back to the Confluence User's Guide.

Restoring Mail
Deleted email messages are stored under ‘'Trash' and can be restored by a space administrator from the Space Administration screens.

o You can only restore an email from trash if it was deleted individually and not using the 'Remove All' operation.

To restore mail,

1. Go to the '‘Space Admin' tab in the '‘Browse Space' view.
Go to a page in the space and choose Browse > Space Admin.

2. Click on 'Trash' in the left panel. A list of pages and emails deleted from the space is displayed.
3. Click on 'Restore' beside the email you want to restore.

To view this email, you will have to go to the 'Mail' tab in the ‘Browse Space' view.
RELATED TOPICS

Viewing Mail

Fetching Mail

Deleting Mail

Browsing a space

Take me back to the Confluence User's Guide.

Viewing Mail

In Confluence, each global space can be set up to archive mail.
To view mail messages archived within a particular space:

1. Goto a page in the space and choose Browse > Space Admin.

2. Click on the Mail tab. The mail is displayed in reverse chronological order with a default of 30 mails per page. You can move

<< Previous and Next >> links or by selecting a particular page number.

between pages by clicking the
3. Click on a mail message to view its contents.

Screenshot : Mail Archive

169



Confluence 4.0 Documentation

170

1|23 Next >> (total: 87)

Sender Subject Date Remove
Mike Cannon-Brookes — [CONF-user] ANN: Atlassian in the Big Apple & jobs available! May 14, 2005 [
forums@atlassian.com [CONF-user] Any way to see "hot" pages? May 14, 2005 [3
forums®@atlassian.com [CONF-user] Re: Resource bundle for Confluence? May 13, 2005 [
forums@atlassian.com Re: [CONF-user] Confluence hosting May 13,2005 [
forums@atlassian.com [CONF-user] Re: Resource hundle for Confluence? May 13, 2005 [

o If you are a space administrator, or have been given permission to delete mail messages, you can also delete emails from here.
Navigating Mail:

Find More These links links at the top of an email message let you search for other emails from the same author or on the same subject.
Attachments This link located below the email body allows you to view mail attachments. The link is only displayed if any attachments exist.
Entire Thread This link allows you to view the mail's thread, if one exists.

The 'Mail Operations' panel is located to the right of the mail view and displays links to:

Entire Thread: View the thread that this mail belongs to. This option is only available when the mail belongs to a thread.
Next By Date: Navigate to the next message.

Previous By Date: Navigate to the previous message.

Remove Mail: Remove the current mail from the space.

Mail Archive: Go to the mail archive view for this space.

Screenshot : Navigating mail

Subject: Sample content for thread demo (find more)
From: Dawvid Loeng <dave@atlassian.com=> (find more)
Date: Now 21, 2004

we need to come up with a sample conversation for the thread demo. Ideas?

Lorem ipsum deolor sit amet, consectetuer adipiscing elit. Aliguam fermentum vestibulum est. Cras rhoncus.
Fellentesgue habitant morbi tristigue senectus et netus et malesuada fames ac turpis egestas. Sed guis
tortor. Donec non ipsum. Mauris condimentum, odiec nec porta tristigue, ante negue malesuada massa, in
dignissim ercs wvelit at tellus. Deonec et risus in ligula eleifend consectetuer. Deonec wolutpat eleifend
augue. Integer gravida sedales lec. Nune wehicula negue ac erat. Vivamus non nisl.

Fusce ac magna. suspendisse euismed liberc eget mauris.

i Handy Hint

Use the Quick Search facility to quickly locate a mail

Related Topics

Archiving Mail Overview

Viewing Mail

Fetching Mail

Deleting Mall

How do | Disable Automatic Mail Polling?

Take me back to the Confluence User's Guide.

Working with Labels

Labels are key words or tags that you can add to pages and spaces. You can define your own labels and use them to categorise, identify or
bookmark content in Confluence.

For example, you could assign the label 'accounting' to all accounts-related pages on the site. You can then browse all pages with that label

in a single space or across the site, or display a list of pages with that label. You can search based on the label, and even use it to filter items
when you subscribe to a Confluence RSS feed.

Because labels are user-defined, you can add any word (or even make up your own) that helps you identify the content in the site.

You can add or remove labels without affecting the page content.



Confluence 4.0 Documentation

On this page:

Page Labels

Space Labels and Space Categories
Advantages of Labels

Related Topics

Page Labels

There are two different types of labels that you can apply to a page:

® Global labels. See Adding a Global Label. A global label is available to all users across the site. Once a global label is added, any
user with permission to view a page can also view its labels. Any user with permission to edit a page can add a global label to a
page. See the global labels at the bottom of this page for examples.

® Personal labels. See Adding a Personal Label. A personal label is only available to the user that created it. Any user with 'view'
permission can add a personal label to a page. The personal labels start with 'ny: ".

Space Labels and Space Categories

You can also apply labels to spaces and use them to categorise your spaces. See Using Labels to Categorise Spaces.

Advantages of Labels

Here are some of the advantages of using labels:

Labels are user-defined which means that you decide what information is relevant to you and how you are going to label it.
You can group pages and spaces without having to restructure the site.

Labels are easy to add and edit, and do not affect the actual content of the page.

You can use labels to filter information during a search.

You can add as many labels as you like to a page or space.

The RSS feed builder allows you to create a news feed based on labels.

Related Topics
No content found for label(s) confluence-label-filter.

Take me back to Confluence User's Guide

Adding a Global Label

This page describes global labels. You may be interested in personal labels.

Any user with 'edit' permission for a page can add a global label to it.

To add a global label:
1. View the page. If the page already has labels, these will be listed at the bottom of the page, below the page content.
2. Click the icon beside the list of labels, or press 'L'.
3. Type in a new label. Existing labels are suggested as you type.

4. Click Add.

Screenshot: Adding a label

Labels Help

Enter labels to add to this page:

i i Y
new label [ Add )
installation ¥ label X example ¥ my:fix X%
Shortcut tip: In page view, pressing | also opens this dialog box Close
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Related Topics

Adding a Personal Label

Removing a Label from a Page

Using Label Macros to Categorise Wiki Content
Using Labels to Categorise Spaces

Take me back to the Confluence User's Guide

Adding a Personal Label

This page describes personal labels. You can also read about global labels.
You can use personal labels to mark content that you personally are interested in. Any user with 'view' permission can add a personal label.
Personal labels are visible only to the user who created them. To differentiate them from global labels, personal labels include the prefix 'my:"
in the label name.
You can view your personal labels from your user profile.
To add a personal label:

1. View the page. If the page already has labels, these will be listed at the bottom of the page, below the page content.

2. Click the icon beside the list of labels, or press 'L".

3. Type in a new label, using the format 'my:label’. Existing labels are suggested as you type.

4. Click Add.

Screenshot: Adding a label

Labels Help

Enter labels to add to this page:

i Y
new label [ Add )
installation X label X example X my:fix X
Shortcut tip: In page view, pressing | also opens this dialog box Close

Related Topics

Viewing Personal Labels

Adding a Global Label

Using Labels to Categorise Spaces

Take me back to the Confluence User's Guide

Using Labels to Categorise Spaces
Confluence provides the following types of space label:
® Space labels. A space label can be used to group related spaces for display by the Content by Label macro, and for ranking search
results. You use space labels in a similar way to global labels.
® Space categories. A 'space category' is a special type of space label that Confluence uses to group spaces in the space directory,
and in the recent activity area of the dashboard. The rest of this page describes space categories.

Note that you can only set up space categories if you are a space administrator for that space, or you are a Confluence system administrator
Using Space Categories

Here is an example of using space categories. Let's assume that you have one or more spaces that your Sales team may be interested in.
You can use the category 'sales' to group those spaces together.

1. First add the 'sales' category to the relevant spaces, as described below.
2. Then, in the space directory, you can click the relevant tab to see only the spaces with the chosen label. See Viewing All Confluence
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Spaces.
3. And, you can see updated content in those spaces by choosing the 'sales' category under the Space Categories tab in the recent
activity area of the dashboard. See Customising your Personal Dashboard.

On this page:

Using Space Categories
Categorising a Space

Removing a Space from a Category
Removing an Entire Space Category
Related Topics

Categorising a Space

When you categorise a space, you add a 'space category' to the space. A category cannot exist if there are no spaces labelled with that
category.

To categorise a space:

1. Choose Browse > Space Admin.
0 Space Admin is displayed only if you are a space administrator for that space or you are a Confluence system administrator.

2. Click Space Labels in the left-hand panel.

3. Under 'Space Categories', enter your category name and click Add.
Alternatively, click a category in the list of 'Suggested Space Categories' displayed on the screen.

Removing a Space from a Category
Removing a space from a category is the same thing as removing the category from the space.
To remove a space from category:

1. Choose Browse > Space Admin.
o Space Admin is displayed only if you are a space administrator for that space or you are a Confluence system administrator.

2. Click Space Labels in the left-hand panel.
3. Click the x next to the space category.

Removing an Entire Space Category

To remove a whole space category from Confluence, just remove that category from all spaces, as described above. A category cannot exist
if there are no spaces labelled with that category. The space category will disappear from the dashboard and space directory.

To remove an entire space category from Confluence:
1. Choose Browse > Space Directory.
2. Click the tab corresponding to the space category that you want to remove.
3. You will see a list of all spaces in that category. Click the spaces one by one, and remove the category from each space, as

described above.

Screenshot: Space labels and space categories
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l; Space Labels 9 Add ~

Pages Blog Labels Attachments Bookmarks Mail Advanced Space Admin

D sl Space Categories

4 Space Details
Space Categories will appear inside the categaries tab on your dashboard

and as tabs in the space directory. They can be used to group together

“. Space Labels

@ Remaove Space related spaces
i Trash
sdles ¥
Security
5 Permissions Add
[@] Restricted Pages Suggested Space Categories
chocolate
Mail
Space Labels
B2 Mail Accounts P
[ Mailbox Import You can group this space with other content you've labelled in Confluence
using the box below
Look and Feel ]
No Space Labels added to this space.
Fell Themes
& Colour Scheme Add
AT Layout Suggested Space Labels
87 Stylesheet dev , spec . specification , josh . hr , administrators , navigation , quicknav
& PDF Layout advanced , sales , demonstration

Related Topics

Working with Labels
Viewing All Confluence Spaces

Take me back to the Confluence User's Guide.

Navigating Pages by Label

This page describes how to navigate Confluence pages by label. To start, you should open the 'View Labels' page.
Browsing Labels on the View Labels Page

Click a label on a Confluence page to see a list of all pages in the space with that label. Click See content from all spaces to include
content from all spaces of the Confluence site..

Adding a Label to the Results

If you click a label from the Related Labels list (at the top left), a new page loads, showing pages that contain both of the labels. You can
continue to add labels to the results in this way.

Subtracting a Label From the Results

Once two labels are in use, links to subtract a label from the search appear at the end of the labels list. These are easily identified because
these links have a preceding minus sign, like so:

..............................................................................................................................................................................
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Typing URLs To Find Labelled Pages
Here is an alternative method for quickly searching for labelled pages:
To search labelled pages by typing a URL:

1. Open a new web browser window.
2. In the address bar of your web browser, type an URL such as:

http://CONFLUENCE HOSTNAME/label/foo+bar
3. Press Enter.

4. The 'View Labels' page will load, showing search results for pages with the labels ‘foo’ and 'bar'.

Screenshot: The View Labels page

Dashboard > Labels > fedex Edwin Dawson ~  [SEEl
% Label: fedex
View: Popular Labels | All Labels
Recent
Labels
All content with label fedex. seraph
Related Labels: lucene , clover , comments , shipping , specification , project , howto , shipment | atlassian-
html . gadget , javascript . bittarrent , zen , realtime , fedex5 , |abel , feed . constraints , ideas . more seraph
P release
module
12 3 45 6 7.9 Next>> <ofmmen
maore »
|=] 20% Time Ideas (David Taylor)
Batch labeling qultiple pages/blogs inlspace} User activity d.ata: . . Popular
http:/fwww.codinghorror.com/blog/archives/001063_html Logging to separate files, with rolling for Labels
support confluence
[E] Add To Google plugin (Dushan Hanuska) timesheet
| just blogged about my Fedex project on Dev Blog £
http://blogs_atlassian.com/developer/2007/05/addtogoogleplugin html. Read my entry here Suppor
http://blogs.atlassian.com/developer/2007/05/addtogoogleplugin. html | customerstory
jiraissuenavigatoraddtogoogle png! ljiraissuesscreenshoticons._png! For interested parties: docs an mare s
the gadget are at JIRA Issues Gadget ...

Screenshot: Label Links on the View Labels Page

x Label: fedex+ideas

View: Popular Labels | All Labels

All content with label fedex+ideas.

Related Labels: lucene |, clover , comments , shipping , specification , project , howto , shipment |
html . dao . gadget . javascript . bittorrent | things-that-suck . zen . realtime | fedex5 | label | feed |
more = ( - fedex , - ideas )

Related Topics

Adding a Global Label

Adding a Personal Label

Using Labels to Categorise Spaces
Navigating Pages by Label
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Removing a Label from a Page

Using Label Macros to Categorise Wiki Content
Viewing Global Labels

Viewing Labelled Pages

Viewing Personal Labels

Viewing Popular Labels

Take me back to Confluence User's Guide

Removing a Label from a Page

Labels are key words or tags that you can add to pages and spaces. You can define your own labels and use them to categorise, identify or
bookmark content in Confluence.

You can see the existing labels, and the pages which contain the labels, by Viewing Global Labels.

To remove a label from a page:

Go to the page that contains the label. All labels are displayed at the bottom of the page below the page content.
Click the icon beside the list of labels, or press 'L".

In the Labels dialog, click on the X for a label to remove it.

. Click Close.

rwnp

Related Topics
Working with Labels

Take me back to Confluence User's Guide

Using Label Macros to Categorise Wiki Content

Using labels, you can categorise pages and refer to content across multiple categories, pages and even spaces.

Example

For the purpose of this example, imagine we have a space with pages of content on various type of vehicles. Pages are shown in bold text,
while the labels are in blue.

® Cars vehicle-type
® Toyota Prius vehicle car
® Honda Civic vehicle car
® Porshe Carrera vehicle car
* Motorbikes vehicle-type
® Harley Davidson Sportster vehicle motorbike
® Suzuki GSX-R vehicle motorbike

This page hierarchy can then be categorised using labels, with pages referenced using the Content by Label Macro.

If you want to You would use this These would be the pages that you would get:

list... label:

Vehicle types vehicle-type Cars, Motorbikes

All vehicles vehicle Toyota Prius, Honda Civic, Porshe Carrera, Harley Davidson Sportster, Suzuki
GSX-R

All cars car Toyota Prius, Honda Civic, Porshe Carrera

Label Macros

Navmap Macro

The Navmap Macro renders the list of pages associated with a specified label as a navigation map.

Related Labels Macro

The Related Labels Macro lists labels commonly associated with the current page's labels.

Content by Label Macro
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The Content by Label Macro displays a list of content marked with specified labels.

Labels List Macro

The Labels List Macro lists all labels of a space, grouped alphabetically.

Recently Used Labels Macro

The Recently Used Labels Macro lists labels most recently used in a specified scope (global, space, or personal).
Popular Labels Macro

The Popular Labels Macro displays popular labels in a list or in a heatmap (also called a cloud).

Related Topics

Working with Labels
Working with Macros

Take me back to the Confluence User's Guide.

Content by Label Macro

The Content by Label macro shows links to content which has been tagged with specific labels.

On this page:

Using the Content by Label Macro
Working Example of Usage
Parameters

Related Topics

Using the Content by Label Macro

To add the Content by Label macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Working Example of Usage
Below is a working example of the Content by Label macro, displaying content with the label "LDAP".

No content found for label(s) LDAP.

Parameters

When editing, you can click on the macro placeholder and choose Edit to display the parameters for this macro in the Macro Browser.

Parameters are options that you can set for Confluence macros to control the content or format of the macro output. The table below lists
parameters for this macro that can be set in the Macro Browser.

Parameter  Default Description

Label(s) None Filter by label(s) — only that content tagged with the label(s) specified is displayed.
This parameter is required. Specify one or more labels, separated by a comma or a single space.

® To exclude content which matches a given label, put a minus sign (-) immediately in front of that label
value. For example: If you specify a label value of -badpage you will get only content which is not
labelled with ‘badpage’.

® To indicate that the results must match a given label value, put a plus sign (+) immediately in front of
that label value. For example: If you specify a label value of +superpage, +goodpage you will get
only content which has at least two labels, being 'superpage’ and ‘goodpage’.
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Author(s)

Include
this
Content
Type Only

Show
Labels for
Each
Page

Show
Space
Name for
Each
Page

List Title

Maximum
Number
of Pages

Display
Excerpts

Restrict
to these
Spaces

Operator

None

all

true

true

None

15

false

@all

OR

Filter by author — only that content created or updated by the author(s) specified is displayed.

Specify one or more authors, separated by a comma.

Filter by content type — only content of the type specified is displayed.
Specify one or more content types, separated by a comma or a space.

To exclude content of a given content type, put a minus sign (-) immediately in front of that content type. For
example: If you specify a content type of -blogpost you will get pages and all other content except for blog
posts.

Available values:

® page — Pages.
® blogpost or news — Blog posts, also known as news items.

Show or hide labels for results.

Show or hide spaces for results.

Adds a title or heading to the list.

Limits the maximum number of results to be displayed. Note that the results are sorted first, and then the
maximum parameter is applied.

Includes excerpts from each page listed. Note that you must have defined excerpts on each of those pages, by
adding the excerpt macro to the page. Only the first few lines of the excerpt for each page are displayed.

Filter by space — only that content which belongs to the space(s) specified is displayed.
You can specify one or more space keys, separated by a comma or a space.

® To exclude content in a specific space, put a minus sign (-) immediately in front of that space key. For
example: If you specify a space key of -BADSPACE you will get only content which is not in the
BADSPACE.

® To indicate that the results must come from a specific space, put a plus sign (+) immediately in front of
that space key. For example: If you specify a space key of +GOODSPACE you will get only content in
GOODSPACE. (Note that this is not particularly useful, because each content item belongs to one
space only. If you put a plus sign next to one space key and list other space keys too, the other space
keys will be ignored.)

Special values:

@self — The current space.

@personal — All personal spaces.

@global — All global spaces.

@favorite — The spaces you have marked as favourite.
@favourite — The same as efavorite above.

@all — All spaces in your Confluence site.

* — The same as @all above.

o When specifying a personal space, remember to use the tilde (~) sign in front of the username, such as
~jbloggs or ~jbloggs@example.com.
The operator to apply to the labels specified in Label(s):

® OR — Pages with any of the non-prefixed labels are listed.
* AND — Pages with all of the specified non-prefixed labels are listed.

o Note that this parameter only modifies the behaviour of the Label(s) parameter and only affects
label values without a plus (+) or minus (-) sign prefix.
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Sort By modified  Specify how the results should be sorted.

Values:

® title — Sort alphabetically by title.
® creation — Sort by the date on which the content was added.
* modified — Sort by the date on which the content was last updated.

Note: If this parameter is not specified, the sort order defaults to descending order based on the last
modification date (i.e. latest first). To change the sort order from ascending to descending, use the Reverse
Sort parameter.

Reverse false

Sort

Select Reverse Sort to change the sort from descending to ascending. Use this parameter in conjunction with
the Sort By parameter — Reverse Sort is ignored if Sort By is not specified.

Related Topics

Related Labels Macro
Navmap Macro

Recently Used Labels Macro
Working with Labels
Working with Macros

Take me back to the Confluence User's Guide.

Labels List Macro

The Labels List macro displays a hyperlinked alphabetical index of all labels within the current space.

The label index generated consists of numerous cells, each beginning with one or more letters of the alphabet or a number. Each label within
the space is grouped alphanumerically into its appropriately headed cell.

Each label in the Labels List macro links directly to its Labels page, that lists the pages on which the label occurs within the current space.

Screenshot: Labels List Macro segment

access, accessibility, account,
active, activedirectory, ad,

added, address, admin, administration,

admin-macros, admin-other, admin-
support, aggregatar, all, analyser,
analyzer, ancestor, anchor,
anonymiser, apache, api, app,

application, appserver, architecture,
archive, at, atlassianuser, atlassian-

user, attachment, attachments, audit,
authentication, auto-startup. awstats,
axis

E daily-backup, data, database,
database-configuration. data-
storage, date, db, db?, dbZ-setup, db-

setup, deactivate, debug, debugging,

delete, demos, dependency, details,

E backup, bandana, base, best-
practices, bindexception, blob,
blog, bookmark, bottormn, browser,
build, builder, bulk, bundled

eap, gar-war, easy, editable,

editor, email, embed, enable,
encoding, entry, error,
SITOr_Messages, euro, events,
example, excel, exception, explorer,

developer, development, diagnostics,

export, extension, external, external-

diagram, directory, disable, do, doc,
documenation, decumentation, dump,

duplicate, dynamic

usermanagement

Below are the 582 labels used in Confluence Docs 2.10 listed alphabetically. Click on a label to see its associated content.

cache. camelcasing, case,
cashing, cause, certificate,
change, character, check, class,
clone, cloud, cluster, clustered, code,
codes, coherence, column,
commenting, comments, component,
compression, configuration,
configuring, confluence, confluenceid,
confluence?0, confluence?q,
confluence?? confluence?3,
confluence?4 confluence?s,
confluence?8, confluence-
documentation,
confluence fag_support,
confluencehome, confluence-jira,
confluence-label-filter, confluence-
usermanagement, confluence-users,
connector, console, content,
contentbylabel, contents, cookies,
copy, corrupt, corruption, cpu, create,
55, customn, custorisation,
customising-ooknfeel, customising-
tag, customize

fag, fag_conf_dev, fast, fatal,

favourite, feed, file,
fileappender, files, filetype, filterbylabel,
filter-common-tasks, firefox, fixed,
flags, folksonomy, font, format, forms,
forum, freeze, front-end, frozen, fun,

gmail, group, guide, guideline, gzip

On this page:
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® Parameters
® Related Topics

Usage with the Macro Browser

To insert the Labels List macro into a page using the Macro Browser:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.
Parameters

This macro has no parameters.

Related Topics

Working with Macros

Take me back to the Confluence User's Guide.

Navm ap Macro
The Navmap macro displays the list of pages associated with a specified label as a navigation map.
A label must be specified for this macro.
On this page:
® Usage with the Macro Browser

® Parameters
® Related Topics

Usage with the Macro Browser

To insert the navmap macro into a page using the Macro Browser:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Parameters
When editing, you can click on the macro placeholder and choose Edit to display the parameters for this macro in the Macro Browser.

Parameters are options that you can set for Confluence macros to control the content or format of the macro output. The table below lists
parameters for this macro that can be set in the Macro Browser.

Parameter  Required? Default Description

Label yes none Specify the label associated with the pages you want to show in the navigation map.
Map Title no none Specify a title for the navigation map.
Number of  no 5 Specify the number of cells in a row
Cells Per

Row

Cell Width  no 90 px Specify the cell width

(Pixels)

Cell no 60 px Specify the cell height

Height

(Pixels)
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Navigation = no Confluence Define a theme for the navmap.

Ma

Thsme If you want to create your own navmap 'look and feel' (for example, one with rounded
corners), you need to add a customised navmap macro theme file to the
WEB-INF/classes/templates/macros directory. The file name convention to use is
navmap-mytheme . vim. Use the name of your choice for the mytheme part of the file name,
which is also the value you use for this parameter. Hence, if your theme was called
navmap-roundededges . vm, use the value of roundededges for this parameter.

Related Topics

Related Labels Macro
Content by Label Macro
Recently Used Labels Macro
Working with Labels
Working with Macros

Take me back to the Confluence User's Guide.

Popular Labels Macro

The Popular Labels macro displays the most popular labels used throughout your Confluence site or within a space.

On this page:

® Usage with the Macro Browser
® Parameters
® Related Topics

Usage with the Macro Browser

To insert the popular labels macro into a page using the Macro Browser:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Parameters

When editing, you can click on the macro placeholder and choose Edit to display the parameters for this macro in the Macro Browser.

Parameters are options that you can set for Confluence macros to control the content or format of the macro output. The table below lists
parameters for this macro that can be set in the Macro Browser.

Parameter Required? Default Description

Number of no 100 Specifies the total number of labels to display in the heatmap.

Labels to
Display

Restrict no none Restricts the list of popular labels to the specified space.

Labels to this
Space Key

Displays the popular labels as a bulleted list or as a ‘heatmap'. The list style orders labels by

Style of no list
Labels popularity (highest first). The heatmap style uses different font sizes for each label depending
on the label's popularity, ordered by label names.

Related Topics

Using Label Macros to Categorise Wiki Content
Related Labels Macro

User-contributed extension: Sortable Popular Labels

Take me back to the Confluence User's Guide.
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Recently Used Labels Macro

The Recently Used Labels macro displays a list of the most recently used labels in a specified scope (Global/Space/Personal).

On this page:

® Usage with the Macro Browser

® Parameters
® Related Topics

Usage with the Macro Browser

To insert the recently used labels macro into a page using the Macro Browser:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Parameters

When editing, you can click on the macro placeholder and choose Edit to display the parameters for this macro in the Macro Browser.

Parameters are options that you can set for Confluence macros to control the content or format of the macro output. The table below lists
parameters for this macro that can be set in the Macro Browser.

Parameter

Number of Labels to
Display

Scope for Retrieving
Labels

List Style

Title

Related Topics

Related Labels Macro
Content by Label Macro

Required?

no

no

no

no

Recently Used Labels Macro

Working with Labels
Working with Macros

Default

10

global

list

none

Take me back to the Confluence User's Guide.

Related Labels Macro

Description

Specifies the total number of labels to display in the list.

Specifies the scope of labels to be displayed in the list. Valid values include:

® global — covers all non-personal spaces in the Confluence installation.
® space — the current space.
® personal — your own personal space.

® |ist —displays the list of labels horizontally.
table — includes additional information such as the page to which the label
was added and the user who added it.

Adds a title to the top of the list in table style. Titles are only visible when the List Style
parameter has been set to table.

The Related Labels macro lists all tagged labels from every page which has one or more labels in common with the current page.

On this page:

® Usage with the Macro Browser

® Parameters
® Related Topics

Usage with the Macro

Browser

To insert the related labels macro into a page using the Macro Browser:

1. In the Confluence editor, choose Insert > Other Macros.
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2. Find and select the required macro.

Parameters
When editing, you can click on the macro placeholder and choose Edit to display the parameters for this macro in the Macro Browser.

Parameters are options that you can set for Confluence macros to control the content or format of the macro output. The table below lists
parameters for this macro that can be set in the Macro Browser.

Parameter Required? Default Description

Specify the labels for which you want to view related labels. For example,

Restrict to these no none
documentation,my:stuff.

Labels

Related Topics

Navmap Macro

Content by Label Macro
Recently Used Labels Macro
Working with Labels
Working with Macros

Take me back to the Confluence User's Guide.

Viewing Global Labels
Any page that has labels will have them listed together in a block at the bottom of the page, with the heading ‘Labels'.

Global labels are visible to all users with 'view' permission and personal labels are only visible to the user that created them.

To view global labels:

1. If you are in a page that has labels, clicking on a label will take you to the 'Label' tab of the '‘Browse Space' view where all pages in
the space with that label will be listed.

Click See content from all spaces to view all pages with the same label across the site.
2. Go to a page in the space and choose Browse > Space Admin.

3. Click on the Labels tab. You have the option to view labels in one of two ways:

® Click All labels to view all labels in the space. From this view, you can click on a link to view an alphabetical listing of all
labels across the site. Clicking on a label will list all content in the space with that label. It will also display any related labels
if they exist. Related labels are labels that frequently appear on pages together. For Example, if pages labelled with 'sales'

also tend to have the label ‘'marketing’, these will be displayed as related labels.
® Click Popular Labels to view a list of the most frequently used labels in that space. From here, you can also view the most

popular global labels across the site.

Confluence defaults to one of these views when you go to the ‘Labels' tab based on your preference on your last visit to the

site.
Each of these views also displays a list of up to fifteen most ‘Recent Labels' or 'Popular Labels' in the space.

Screenshot: Labels as they are displayed on a page

Labels Edit

gxciting rhinocerous

Screenshot: Viewing all labels
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IG Al Labels

Wiew: Popular Labels | all Labels

Below are the 186 most recently used labels, listed
alphabetically. Chcl: on a label to see its associated

content,
about, are, ante, a, blabla,
api, and, admin, baz, bar,
ADOSEFYELR, blah,
asdfasdfasdf, agile beeren, bee,

baby, blog, bora,
bug, bible, build

Related Topics

Viewing Labelled Pages
Viewing Personal Labels
Viewing Popular Labels
Navigating Pages by Label

Take me back to Confluence User's Guide

Viewing Labelled Pages

The easiest way to find labelled content is to do a quick search for it. If there is a label matching your query, it will be listed above the search
results. Clicking on the link will display all content in the site with that label. (Clicking additional labels on the following page will conduct
another search, adding that label to your existing search. See also Navigating Pages by Label.)

® You can view all labelled content for a space by going to the 'Label' tab in the 'Browse Space' view of a space.
® You can view content labelled with personal labels by going to your Profile and clicking on the Label tab.

Screenshot: Viewing labelled content

Searched for database in all spaces excluding Mail.
There are 201 matches in Mail. Include these matches.
Matching labels: database

Related labels: oracle, appserver

LI Results 1 - 10 of 225 for database,

|- ] Migrate to another database (Confluence)

... docurnent will autline the steps to mowve yvour existing Confluence data from
one database to another, This is relevant to all users who previously used the
embedded database far their evaluation {ar longer) and would like to move to a
rnare robust external database (such as Oracle, Postgres ...

Jul 20, 2005

Advanced label searching

Using the Search Box to find labelled pages

In the search box, you can use the 'labelText:' prefix to search specifically for page labels.
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Searching for ... Returns content that ...

confluence labelText:plugin contains the word confluence or has the label plugin
confluence AND labelText:plugin contains the word confluence and has the label plugin
labelText:import labelText:plugin has the label import or has the label plugin

labelText:import AND labelText:plugin has the label import and has the label plugin

Typing URLSs to find labelled pages

In the URL bar of your web browser, you can type URLSs like the following to search for multiple labels in pages:

..............................................................................................................................................................................

..............................................................................................................................................................................

On pressing enter, the 'View Labels' page will load, showing search results on pages with the labels foo and bar.

Also see Navigating Pages by Label

Related Topics

Viewing Global Labels
Viewing Personal Labels
Viewing Popular Labels
Searching Confluence

Take me back to Confluence User's Guide

Viewing Personal Labels

Any page that has labels (global or personal) will have them listed at the bottom of the page. Personal labels are only visible to the user that
created them.

To view your personal labels:
® Go to your name (the 'user' menu) at the top of the page, and choose Labels.

The 'Labels' view displays all content with personal labels. You will also see a list of your personal labels along with the number of pages that
contain the label. Click a link to see all content with that label.

Screenshot: Viewing personal labels

Profile § Network § Status Updates JRELECAN Watches § Drafts | Settings

See the personal labels you have created, and the other labels which you have
used recenthy.

Your Labels All labelled content
draft 2 |='] Drafts for Confluence 2.10.3 forum by Giles Gaskell (15 Apr)
favourite 3 announcements

D Supplementary 3.0 Security Advisory by Giles Gaskell (09 Jun)
forum announcements

|| Testing page by Giles Gaskell (02 Jun)
(/1 Giles Gaskell by Giles Gaskell (20 Mov)
B Staff Induction - Sysadmin by Dave Cheney (02 Apr)
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i) Another way to get to your personal labels

If you are on a page that has personal labels, click on a label to go to the ‘Labels' tab of your profile, described above.

Related Topics

Adding a Personal Label
Viewing Labelled Pages
Viewing Global Labels

Viewing Popular Labels

Take me back to the Confluence User's Guide.

Viewing Popular Labels

Popular labels are those labels that are more frequently used. Confluence allows you to view the popular labels both within a space and
across the site.

To view popular labels:

1. Choose Browse > Labels.
2. Click Popular Labels, if necessary. This will list the most popular labels in the space and also display a link to view all global

popular labels (across the site).

® Clicking on a label will display all the content in the site with that label.
® Click global popular labels to view the most popular global labels in the site.

In both these views, you have the option to sort the listing of labels to display them alphabetically or in order of their popularity.

The bigger the font size, the more popular the label.

Screenshot: Viewing popular labels

View: Popular Labels | all Labels szzemit Lelbels

test

Below are the 6 most popular labels used in Documentation Staging 2. The bigger the text, the documentation
g

rmore popular the label. Click on a label to see its associated content, =

gxample
See also: global popular labels. installation

More %

Order: alphabetically | by popularity
. . Popular Labels
documentation e example installation iabel test installation
test
label
gxample
E

more %

Related Topics

Viewing Labelled Pages
Viewing Global Labels
Viewing Personal Labels

Take me back to Confluence User's Guide

Working with Favourites

The Favourites feature provides a convenient way to quickly access specific pages or spaces that interest you, as soon as you log in to
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Confluence. Pages and spaces that you have added to your list of favourites are easily accessible from your Dashboard and from within your
user profile area.

What do you want to do?
Adding Favourites

Viewing Favourites
Removing Favourites

Related Topics

Dashboard
User Profile Overview

Take me back to the Confluence User's Guide.

Adding Favourites

To add a page as a favourite:

1. Go to the page.
2. Choose Tools > Favourite.

This will change to “~ Favourite (when you next open the Tools menu) to indicate that you have added this page as a favourite.
To add a global space as a favourite:

1. Go to the Dashboard.
2. Click the Spaces tab.

3. Click the star icon ' = ' located beside the space name in the list of global spaces.
This will change to ' =~ ' to indicate that you have added this global space as a favourite.

To add a personal space as a favourite:

o If a person has not yet created a personal space, then you will not be able to perform this procedure. Furthermore, these options will not
be available to you.

. Choose Browse > People Directory.
. Click on a person's name or profile picture to view their personal space.
. Go to a page in the space and choose Browse > Advanced.

A WNPE

. Click on 4 Add Space to Favourites in the left-hand panel.

This will change to “~ Remove Space from Favourites to indicate that you have added that person's personal space as a
favourite.

Once you have added a personal space to your list of favourites, that personal space will be added to your list of favourite spaces, which can
be accessed from the dashboard or your profile.

For more information about global spaces and personal spaces, see Working with Spaces.

Related Topics
Viewing Favourites
Searching the People Directory

Take me back to the Confluence User's Guide.

Removing Favourites

To remove a page as a favourite:

1. Go to the page.
2. Choose Tools > = Favourite.

This will change to = Favourite to indicate that you have removed this page from your favourites.
To remove a global space as a favourite:

1. Go to the dashboard.
2. Click on the staricon - located beside the space in the list of spaces displayed.

This will change to “~ to indicate that you have removed this global space as a favourite.
To remove a personal space as a favourite:

1. Go to the People Directory.
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2. Click on a person's name or profile picture to view their personal space.
3. Goto a page in the space and choose Browse > Advanced.

4. Clickon -+ Remove Space from Favourites in the left-hand panel.

This will change to “* Add Space to Favourites to indicate that you have removed that person's personal space as a favourite.

Related Topics

Viewing Favourites
Spaces Cannot be Unmarked as Favourites

Take me back to the Confluence User's Guide.

Viewing Favourites

Once you add a spaces or pages as favourites, you can see them on your dashboard or in your profile.

The Dashboard
On the left-hand side of the Dashboard, you can see:

® your favourite spaces in the Spaces tab.
® your most recently added favourite pages in the Pages tab.

Recently updated content in your favourite spaces will be listed on the Favourite Spaces tab at the top right of the dashboard.

Screenshot: Viewing your favourites on your dashboard

Spaces | Pages MNetwork

Favourite Spaces

& Angry Nerds i
X, Confluence o7
i Paul Watson o7
®. Technical Writing s
Global Spaces Add Space

X, Admin Space
& Angry Nerds Yy
X, Archive

& Atlassian Foundation

Your Profile

To view your favourites in your profile:
1. Log into Confluence, if you have not already done so.
2. Go to your name (the 'User' menu) at the top of the page and choose Labels.
3. Click on favourite (under "Your Labels') to see the list of your favourite spaces and pages.

Screenshot: Viewing your favourites in your profile
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[E:1.1:00 \Watches | Drafts § Settings | Extensions
See the personal labels you have created and the number of pages that contain them. Click a label to see all content containing that label.

Your Labels Content labelled with “favourite"

o favourite 11 @ Angry Nerds by Ryan Anderson (20 Apr)
|=] Tech writer brilliance kickoff by Sarah Maddox 7 (6 hours ago)
=] Atlassian Partner Milestones! by Todd Revolt (28 Apr)
[E] Egg-citing New Frontlines Reports by Christina Bang (25 Apr)
|| Sales Q3 Release Notes by Joshua Waold (20 Apr)
@ World Saved, Services Will Now Resume As Usual by Edwin Dawson (02 May)
[E] Rise of the Machines Part 5 - Development in the World of Tomorrow by Tim Moore (02 May)
@ Technical Writing by Sarah Maddox ' (30 Sep)
@ Confluence by Matt Ryall (24 Mar)
@ Home by Andrew Lui (16 Jan)

1 2 Next >>

Related Topics

Adding Favourites
Removing Favourites
Working with Favourites

Working with Labels

Working with Attachments

An attachment is any file that is included with your page. Examples of attachments are images, screenshots, photographs, Word documents,
presentations, and PDF, multimedia and sound files.

& Quick guide to attachments

®* Goto Tools > Attachments to view and attach files to a Confluence page. See Attaching Files to a Page.

® [f you attach a file with the same name as an existing attachment, Confluence will create a new version of the
existing attachment.

® Once you have attached a file, you can then create a link to it on a Confluence page. When a user clicks the link,
the attachment will open, provided that the user has the software application needed to open the attachment.

® You can display attached images and multimedia content on the page.

® |f the attachment is an Office document, use the View File macro to display the content of the document on the
Confluence page. If you have an Office application installed, you will also be able to launch your Office editor from
within Confluence. See Displaying Office Files in Confluence and Working with the Office Connector.

Attachments are useful when you want to share information that exists in another file format. If you want an attachment to be displayed on
more than one page, you may wish to consider creating a special page to hold such attachments. This special page could be part of an '
inclusions library'.

In Confluence you can attach files to any page or blog post, provided you have permission to do so.

When a page you are viewing contains attachments, a small paperclip icon &1 appears next to the page byline. Clicking the paperclip will
take you to the 'Attachments' view, where the full list of attachments is displayed.

Working with attachments:

Using Drag-and-Drop in Confluence
Attaching Files to a Page

Attachment Versions

Deleting an Attachment

Displaying a List of Attachments in a Page
Downloading Attachments

Editing Attachment Properties

Embedding Multimedia Content
Embedding PowerPoint Presentations in a Page
Finding an Attachment

Moving an Attachment

Viewing Attachment Details

Related Topics
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Displaying Images

Configuring Attachment Size
Configuring your Attachment Storage
Working with the Office Connector

Take me back to the Confluence User's Guide.

Using Drag-and-Drop in Confluence

This page describes Confluence's drag-and-drop feature and provides details of its requirements.

On this page:

® Overview of the Drag-and-Drop Feature

® Requirements for the Confluence Drag-and-Drop Feature
® Disabling Drag-and-Drop

® Related Topics

Overview of the Drag-and-Drop Feature

Confluence's drag-and-drop feature allows you to drag files from your computer or file system onto your browser and attach them to your
Confluence pages or blog posts. You can drag-and-drop:

® multiple files at once.
® image, multimedia and PDF files, and Office documents.

When you drag-and-drop files onto the different Confluence views, you get the following results:

Confluence View Result

Attachments Files are attached
Page Files are attached
Edit Files are attached, and embedded at the cursor position

Requirements for the Confluence Drag-and-Drop Feature

® Confluence's drag-and-drop feature relies on your browser's support for the drag-and-drop functionality of HTMLS5.

® Some browsers, such as Internet Explorer 9, Firefox 3.5 and Safari 4 do not support the drag-and-drop functionality of HTML5. For
these browsers, Confluence will attempt to use the drag-and-drop functionality provided by Google Gears.

® The first time you try to drag and drop a file into one of these browsers, Confluence will prompt you to install Google Gears
into your browser. Refer to the prompt below for more information. For more details on the installation requirements for
Google Gears, refer to Google's own How to install instructions.

® Please check the Google Gears website for the most up-to-date browser support details.

To check if Google Gears is already installed on your computer, refer to Google's own How to check if Gears is installed
instructions.

Supported Web Browsers

Please ensure that you are using one of the web browsers supported by Confluence. If you are using an
unsupported browser or browser version, some features may not work correctly. You can find the list of
supported web browsers and browser versions on this page: Supported Platforms.

® Some older Confluence themes do not support Confluence's drag-and-drop feature.
® Supported themes: Confluence Default theme, Documentation theme, Easy Reader theme.

®* Themes that are not supported: Left Navigation theme, Clickr theme. You cannot drag and drop attachments into spaces
that use these themes.
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Prompt to Install Google Gears
If you are using a browser that does not support the drag-and-drop feature, and Google Gears has not yet been installed:
® When you attempt to drag and drop a file into Confluence (but not the editor), you will be prompted with the following message:

Screenshot: Generic Confluence Prompt to Install Google Gears

The page at https://extranet.atlassian.com says:

To enable drag-and-drop, you need to install Google Gears. Confluence has detected that you do
not have itinstalled. Would you like to proceed to the website to install it now?

0K l [ Cancel

Click OK to proceed with the Google Gears installation.
® When you attempt to drag and drop a file into the editor, you will be prompted with the following message:

Screenshot: Confluence Prompt to Install Google Gears

Installing Drag and Drop

Dragging and dropping files requires installation of the Google Gears browser
plugin. Since you may have unsaved changes we recommend saving them to a
draft first so you can easily resume editing after installation. We've made this easy
for you

Save Changes to Draft

If the draft saves successfully, you can proceed with the installation

/v, Save any drafted content before continuing with the installation of Google Gears. The installation process will
replace your current Confluence page and you will need to restart your browser after the Google Gears installation
has completed.

Click Proceed with Installation to install Google Gears.

Initial Use with Google Gears

When adding an attachment to a page or blog post in your Confluence site for the first time (after Google Gears has been installed), you will
be prompted to allow Google Gears to trust your Confluence site as shown in the following screenshot. If this warning message appears,
select the | trust this site. Allow it to use Gears check box and click Allow.

Screenshot: Google Gears Security Prompt
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Gears Security Warning

The website below wants to store information on
your computer using Gears.

Confluence

https://extranet. atlassian.com

Allow Confluence to use Google Gears to
perform drag-and-drop file uploads?

| trust this site. Allow it to use Gears.

MNewver allow this site Allow Deny

Q Google Gears is not supported on Safari. See CONF-20032 for updates.

Disabling Drag-and-Drop

If you are a Confluence administrator and wish to disable Confluence's drag-and-drop feature for any reason, please refer to Disabling
Drag-and-Drop for details.

Related Topics

Attaching Files to a Page

Add many files to a page at once
Using the Editor

Displaying Images

Working with Links

Disabling Drag-and-Drop

Attaching Files to a Page

An attachment is any file that is included with your page. Images, word documents, presentations and PDF, multimedia and sound files are

some examples of attachments. Attachments are useful when you want to share information that exists in another file format. Read more in
Working with Attachments.

When you attach a file to a page, Confluence makes a copy of the file and stores it on the server. Page attachments in Confluence are
managed using the 'Attachments' view of the page.

To attach a file, you need the 'Create Attachments' permission which is assigned by a space administrator from the Space Administration
screens. See Space Permissions or contact a space administrator for more information.

On this page:

® Attaching files

® Attachment Versions

® Attachment Information Icon
® Related Topics

Attaching files

There are several ways to attach files to a Confluence page:
® Drag-and-dropping files on to a Confluence page.

® By browsing to, and uploading files from, your computer or network.

To attach a file to a page using drag-and-drop:
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1. View the page to which you want to attach files.
2. Drag one or more files from your computer onto the page. The 'Attach File(s)' message box appears, indicating the upload status of
the files being attached to your page.

o You cannot drag-and-drop a folder onto a page.

¥ Expand this section to see other ways to drag-and-drop a file on to a page...
You can also drag-and-drop files:

® directly on to the 'Attachments' view for the page
¢ directly on to the editor view of the page
® on to any tab of the Edit Link or Insert Image dialogs, which are available from the Insert menu while editing.

To attach afile to a page from the computer's (or network's) file system:
1. Choose Tools > Attachments to go to the 'Attachments' view for the page.

. Click Browse... and navigate to the file.

. Select the file and click Open.

Add a descriptive comment for the file (optional).
. Click Attach more files if required.

. Click Attach.

oA wWN

¥ Expand this section to see other ways to upload a file to a page...
You can also browse for, and upload, a file from:

® the Attachments tab of the Edit Link dialog (while editing the page, click on Link in the toolbar)
® the Attached Images tab of the Insert Image dialog (while editing the page, go to Insert > Image)

Attachment Versions

If you upload a file with the same name as an existing attachment, Confluence will rename the old file and maintain a version of it on the
server. Read more about Attachment Versions and Viewing Attachment Details.

o Please note that changes you make to the source file don't affect the copy that was uploaded to Confluence. To update the Confluence
copy, you need to upload the new version of the file.

Attachment Information Icon

The page Working with Attachments Overview does not exist.

Related Topics

Working with Attachments
Displaying Images
Attachment Versions
Deleting an Attachment

Take me back to the Confluence User's Guide.

Attachment Versions

When viewing a list of attachments, a new version of an existing attachment can be added simply by uploading an attachment with the
same filename on the attachment view. Click the blue arrow next to an attachment to display previous versions of the attachment.

Existing files will be kept with the name 'Version x', where the value of 'x' increments with each upload of an attachment with the same
filename.

Screenshot: Attachment versions

Attached Files
Hame Size Creator Creation Date Last Mod. Date ¥  Comment
4 Example PDF Document. pdf 105 kB FEred Ferdinando MNov 11, 2009 13:45  Nov 11, 2009 13:59 PDF Sample Praperties | Remove | View
¥ |my Example Word 2007 Document.docx 10kB  Ered Ferdinando MNov 11, 2009 13:46 Nov 11, 2009 13:59  Word Doc Sample Praperties | Remove | Edit | View
Version 2 10kB  Administrator MNov 11, 2009 13:32  Nov 11, 2009 13:32
Version 1 10kB  Fred Ferdinando Mov 11. 2009 11:52  Nov 11, 2009 11:52
¥ |m| Example Excel 2007 Document.xlsx 8 kB Fred Ferdinando Mov 11, 2009 13:47  Nov 11, 2009 13:59  Excel Sample Properties | Remove | Edit | View
Version 1 5 kB Fred Ferdinando Mov 11, 2009 11:52  Nov 11, 2009 11:52
] Example PowerPaint 2007 Document pp 35 kB Ered Ferdinando Mov 11, 2009 11:52  Nov 11, 2009 11:52 Properties | Remove | Edit | View

Some additional notes:
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® You cannot remove specific versions of an attachment — if you remove an attachment, all versions will be removed as well. (See

feature request CONF-3079.)

® You cannot revert to a previous version of an attachment. (See feature request CONF-1943).

® By default, attachments and their versions are stored in the <confluence home>/attachments directory. (See Attachment
Storage Configuration in the Administrator's Guide.) There is no limit to the number of attachments/versions, provided that there is

enough disk space.

Related Topics

Attaching Files to a Page
Moving an Attachment
Viewing Attachment Details
Working with Attachments

Take me back to the Confluence User's Guide.

Deleting an Attachment

To delete an attachment, you require 'Remove Attachments' permission which is assigned by a space administrator from the Space
Administration screens. See Space permissions or contact a space administrator for more information.

To delete an attachment:

1. Go to the page that contains the attachment.
2. Choose Tools > Attachments to go to the 'Attachments' view for the page.

This will display a list of the attachments in the page. Click Remove beside the attachment you want to delete.
3. Click OK to confirm your action.

Related Topics

Working with Attachments
Finding an Attachment

Take me back to the Confluence User's Guide.

Displaying a List of Attachments in a Page

Use Confluence's Attachments macro to display a list of the files attached to the current page.
It will generate a table similar to that in the screenshot below.

On this page:

Using the Attachments Macro

Parameters

Viewing and Editing Files from the Attachments Macro
Attachment Information Icon

Notes

Related Topics

Using the Attachments Macro

To add the Attachments macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Parameters
When editing, you can click on the macro placeholder and choose Edit to display the parameters for this macro in the Macro Browser.

Parameters are options that you can set for Confluence macros to control the content or format of the macro output. The table below lists
parameters for this macro that can be set in the Macro Browser.

Parameter Default Description

Filename Patterns all Filters the attachments to display, using a comma-separated list of regular expressions. So, to
match a file suffix of 'jpg’, use . *jpg, not *. jpg.
Here's a detailed tutorial on regular expressions.
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Include Old false Include previous attachment versions in the list.
Attachment Versions

Sort By date Specifies the sort order for attachments. Note that people viewing the page can change the sort
order by clicking the column headings. Valid values are:
® date — sorts by reverse chronological order (newest first)

® size — sorts largest to smallest
® name — sorts alphabetically

Allow Upload false Provides the ability to browse for, and attach, new files.

Viewing and Editing Files from the Attachments Macro

If an attachment is an Office or PDF file, you will see a View link as shown in the screen snippet below. Furthermore, if the attachment is an
Office file, it will also have an Edit link.

Screenshot: Office and PDF file page attachments showing the 'View' and 'Edit' links

Name Size Creator Creation Date Last Mod. Date ¥  Comment

2 Example PDF Document pdf 105 kB Administrator Mov 11, 2009 15:11  Mov 11, 2009 15:11 Properties | Remove | View

|2 Example PowerPoint 2007 Document.pp 35kB  FEred Ferdinando Maov 11, 2009 11:52  Maov 11, 2009 14:49  PowerPoint Sample Properties | Remove | Edit | View
@y Example Word 2007 Document doex 10 kB  FEred Ferdinando Mov 11, 2009 13:46  Mov 11, 2009 14:20  Word Doc Sample Properties | Remove | Edit | View
| Example Excel 2007 Document.xdsx 8 kB Fred Ferdinando  Mov 11, 2009 13:47  MNov 11, 2009 13:59  Excel Sample Properties | Remove | Edit | View

Click View to view the content of the Office file within Confluence.

Click Edit to edit the content of the Office file in your Office application. You must have a compatible Office application installed to do this.
Refer to Working with the Office Connector for more information.

Attachment Information Icon

When a page you are viewing contains attachments, a small paperclip icon &1 appears next to the page byline. Clicking the paperclip will
take you to the 'Attachments' view, where the full list of attachments is displayed.

Notes

The macro can only list the attachments on the current page. It is not possible to display attachments from another page. If you are interested
in this feature request, please watch or vote for CONF-6351.

Related Topics

Working with Attachments
Working with Macros

Take me back to the Confluence User's Guide.

Downloading Attachments

To download a single attachment of a page:
1. Choose Tools > Attachments to go to the 'Attachments' view for the page.
2. Right-click the link on the attachment name, and select Save Link As, Save Target As or a similar option provided by your browser.
This will open a 'Save' dialog.
3. Select the directory into which you want to download the file and click Save.
To download all the attachments of a page:

1. Choose Tools > Attachments to go to the 'Attachments' view for the page.

2. Click the Download All button at the end of the page to download a zipped file of all the page's attachments.
Related Topics

Working with Attachments
Viewing Attachment Details

Take me back to the Confluence User's Guide.

Editing Attachment Properties
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To edit an attachment's properties, you need 'Create Attachments' permission which is assigned by a space administrator from the Space
Administration screens. See Space Permissions or contact a space administrator for more information.

To edit the properties of an attachment:

1. Go to the page that contains the attachment.
2. Choose Tools > Attachments to go to the 'Attachments' view for the page.

3. Click the Properties link beside the attachment. This will display a new screen.
4. Make your changes:
® File Name — Rename or modify the name of the attachment.
®* New Comment — Update the existing comment or enter a new comment.

®* New Content Type — Change the content type of the attachment by entering a valid MIME type.
®* Page — Move the attachment to another page.
5. Click OK.

Screenshot: Editing an Attachment's Properties

% Properties: confluence-3-1-editing-attachment-details.png

Added on Jan 18, 2008 14:09 by Sarah Maddox [Atlassian Technical Writer], last edited on Mow 11, 2009 16:36

File Hame
confl'.:.ence—3—:L—editing—attac'nment—details.png{

New Comment
Updated for Confluence 3.1

New Content Type
image/png

Page

&

Specify the page you want to move the attachment to

Save Cancel

Related Topics

Moving an Attachment
Viewing Attachment Details
Working with Attachments

Take me back to the Confluence User's Guide.

Embedding Multimedia Content

Using multimedia files you can display movies, animations and videos, and embed audio files on your Confluence page.

There are several methods for attaching files to a page. Once you have attached the multimedia file to a Confluence page, you then edit the
page to set where the multimedia content should appear.

In the example below, we display a Flash file that is attached to this page.

Confluence supports the following multimedia formats:

Adobe Flash (.swf)

Apple QuickTime (.mov)

Windows Media (.wma, .wmv)

Real Media (.rm, .ram)

MP3 and MP4 files (.mp3, .mp4)

MPEG files (.mpeg, .mpg)

AVl files (.avi) You may need to enable an avi decoder within your browser.
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On this page:

Displaying a multimedia file attached to the page
Multimedia macro parameters

Notes

Related Topics

@ Quick guide to displaying multimedia content on a page
Choose one of these methods:

® Add the macro yourself: Attach the multimedia file to the page in the usual way. Add the Multimedia macro using
the macro browser.

® Autocomplete: Attach the multimedia file to the page in the usual way. Type '!" in the editor and choose the
multimedia file from the list that appears.

® Drag and drop: Drop the video or other file into the editor. Confluence will attach the file and insert the Multimedia
macro for you.

® Adjust parameters if necessary: Click on the Multimedia macro placeholder to set options for the macro, such as
adjusting the width or height of the display, or setting autoplay on.

Displaying a multimedia file attached to the page

Once you have attached a multimedia file to a page, there are different methods for choosing where on the page the multimedia content
should appear:

Inserting the Multimedia macro yourself

You can add the Multimedia macro to the page yourself using the Macro Browser. This allows you to display a multimedia file that is attached
to either the current page or to another page in the Confluence site.

To insert the Multimedia macro on the page at the current cursor position:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Using autocomplete

Once a multimedia file is attached to the page, you can use autocomplete, while editing the page, to choose where the multimedia content
should appear.

To position an attached multimedia file on the page using autocomplete:

. While editing the page, position the cursor where you want to place the multimedia content.

. Trigger the autocomplete function by typing 'I".

. Choose the multimedia file from the list that appears.

. If necessary, click on the Multimedia macro placeholder and choose Edit to set various options such as the width, height or
autoplay.

A WN PR

Using drag-and-drop
Depending on the browser you are using, you can attach and position a multimedia file in one step using drag-and-drop.
To attach and position multimedia content using drag-and-drop:
1. While you are editing a page, simply drag-and-drop the multimedia file on to the page. Confluence will attach the file to the page and
insert the Multimedia macro at the current cursor position for you.

2. If necessary, click on the Multimedia macro placeholder and choose Edit to set various options such as the width, height or
autoplay.

Multimedia macro parameters

When editing, you can click on the macro placeholder and choose Edit to display the parameters for this macro in the Macro Browser.

Parameters are options that you can set for Confluence macros to control the content or format of the macro output. The table below lists
parameters for this macro that can be set in the Macro Browser.

Parameter Default Description
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Page Name  Current page Name of the page to which the multimedia file is attached. If you are using the Macro Browser,
just start typing the name of the page and then select it from the dropdown list that appears.
The page can be in the same space or another space.

Attachment None File name of the multimedia file.

Width If not specified, the Width of the movie window to be displayed on the page. By default, this value is specified in
browser will determine  pixels. You can also choose to specify a percentage of the window's width, or any other value
the width based onthe  accepted by HTML.

file type.

Height If not specified, the Height of the movie window to be displayed on the page. By default, this value is specified in
browser will determine  pixels. You can also choose to specify a percentage of the window's height, or any other value
the height based on accepted by HTML.
the file type.

Autoplay False If this option is checked (that is, if the parameter is set to 'true') then the video or audio file will

start playing as soon as the page is loaded. If this option is not checked (set to 'false’) then the
file will not play until the user clicks the icon or image on the page. See the note about autoplay
below.

Notes

®* The multimedia file must be attached to a Confluence page. For security reasons, files located on remote servers are not
permitted. See the Widget Connector for displaying live content from external sites.

® You will need the relevant multimedia plugin for your browser. Your browser (Firefox, Internet Explorer, Safari and others)
needs a plugin to play the video or audio file on a Confluence page. For example, to play a Flash movie you need the Flash plugin.
Many plugins are shipped with the major browsers by default. If a user does not have the required plugin installed and enabled in
their browser, they will not be able to view the multimedia files on the page.

® Autoplay may not always work as expected. You can set autoplay on, so that your video or audio file should start playing as soon
as the page is loaded into the browser. (See parameters.) However, this setting may not always work as expected. Confluence will
send an instruction to the browser plugin that plays the multimedia file. Different browsers and different media plugins behave in
different ways, and not all of them respect such instructions.

® Use the Office Connector to display Office documents. Take a look at the Office Connector for embedding Word documents,
presentations and other Office documents onto your Confluence page.

® |f you get the error, 'Unable to embed content of type application/octet-stream’, this means the MIME type is not recognised.
® Advanced users can try styling via CSS. By default, each embedded object is wrapped in a div tag. If you wish to style the div

and its contents, override the embeddedObject CSS class. Specifying an ID as a property also allows you to style different
embedded objects differently. CSS class names in the format embeddedObject - ID are used.

Related Topics

Working with Macros

Widget Macro

Working with the Office Connector
Working with Attachments

Take me back to Confluence User's Guide

Embedding PowerPoint Presentations in a Page

Below are some ideas on how your wiki page can include information from a Microsoft PowerPoint presentation.

On this page:
® Option 1 — Office Connector for Confluence
® Option 2 — Gallery or Slide Show of JPEG or PNG Images
® Option 3 — Convert PowerPoint to HTML
L]

Related Topics

Option 1 — Office Connector for Confluence

The Office Connector provides the most straightforward way to display PowerPoint slides.
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To attach and display a PowerPoint presentation in Confluence:
1. Attach the presentation to a Confluence page:
® View the Confluence page where you want to display your presentation.
® Open the 'Tools' menu and select 'Attachments'.
® Browse for your PowerPoint presentation and upload it to the Confluence page.
You will find detailed instructions in Attaching Files to a Page.

2. Now you can display the document embedded into the Confluence page, using the View File macro.
Refer to the detailed instructions for the View File macro.

The Office Connector is shipped with Confluence 2.10 and later. The Office Connector plugin is supported for Confluence
versions 2.8.0 and later.

Option 2 — Gallery or Slide Show of JPEG or PNG Images

1. Convert your PowerPoint pages into JPEG or PNG images, using 'save as' from PowerPoint (slidel.jpg, slide2.jpg...).
2. Upload the image files as attachments to your Confluence page. To upload in bulk, use the WebDAV plugin.
3. Use the Gallery macro or the Slideshow plugin to render the images as a slide show in Confluence.

Optionally, you could create a page template or a user macro that uses the Slideshow plugin, so that you do not have to code this into
the wiki page each time you create a new show.

@ The Slideshow plugin is not supported by Atlassian. Please weigh up your options carefully before deciding which way to
go.

Option 3 — Convert PowerPoint to HTML

You can convert the PowerPoint file to web page format and embed the page inside your Confluence document.

v If you accept page edits or comments from untrustworthy users, you should not attempt this process, due to a risk of
malicious user attacks via the html - include macro.

1. Review the risks associated with enabling the html-include macro here.

2. If you decide to proceed, follow the instructions to enable embedded HTML pages using the macro.

3. Select an PowerPoint converter. There are at least two applications that can convert PPT to HTML:

® Producer for PowerPoint.
® |f you do not have the PowerPoint application on your machine, you can use the Internet Assistant for Powerpoint instead.

4. Download and install your chosen converter.

5. Follow the converter documentation to perform the HTML conversion. An Internet Assistant conversion guide can be found here. The
conversion process will create a small collection of HTML pages. Each slide will have its own page, plus an index page with buttons
to let you switch between slide pages.

6. If you wish, you can test the HTML presentation now by loading the index page in your browser.

7. Place the HTML files into their own directory, named uniquely by the title of your presentation.

8. Find a suitable location to host these files within your web server. Confluence hosts all files within the
<my-install-directorys>/confluence/ directory, so a good example location for Confluence standalone users is to go to
<my-install-directorys>/confluence/pages/ and create a subdirectory called powerpoint.

9. Move the HTML directory into the PowerPoint folder, e.g.
<my-install-directory>/confluence/pages/powerpoint/<my-presentation-names> containing index.html,
slideO1l.html... or similar.

10. Edit or create the page where you wish to embed the PowerPoint presentation. Add the HTML Include macro pointing to the index

page of your slides. Remember that URLs are case sensitive.
11. Save the page. The index page to your slides should now appear.

Related Topics

Working with the Office Connector
Working with Attachments

Take me back to Confluence User's Guide

199


http://www.microsoft.com/office/powerpoint/producer/prodinfo/overview.mspx
http://www.pcworld.com/downloads/file_description/0,fid,1615,00.asp
http://www2.uca.es/taller-html/software/ia4ppt95.htm

Confluence 4.0 Documentation

Finding an Attachment

To find an attachment, you can search the list of attachments in a space or the attachments on a specific page.

To find an attachment associated with a space:

1. Go to a page in the space and choose Browse > Attachments.

2. This will display a list of all attachments in the space.
3. Browse through the list to locate the attachment.
4. You can choose to view only files of a particular type:

® Type the last part of the file name in the Filter By File Extension box. For example, enter ‘gif' to see only image files of the

GIF format.
® Click Filter.

5. You can view the attachment itself or the page to which it is attached by clicking on the corresponding link.

Screenshot : Space Attachments

lg List Attachments

Filter By File Extension: | | Filter |

Pages | Blog | Labels JENGIIUELENR Bookmarks | Mail | Advanced | Space Admin

1 2 3 4 58 6 MNext ==
Name Size Creator Creation Date Last Mod. Date Attached To
w1 Example Waord 2007 Document docx 10 kB  Ered Ferdinando Mov 11, 2009 13:46  MNov 11. 2009 13:46 5 Sample Page
2 Example PDF Document.pdf 105 kB Fred Ferdinando Mov 11, 2009 13:45  Mov 11, 2009 13:45 7 Sample Page
|2 Example PowerPoint 2007 Document pptx 35 kB Fred Ferdinando Mov 11, 2009 11:52  Mov 11, 2009 11:52 4 Sample Page
=] Example Excel 2007 Document. xlsx g kB Fred Ferdinando  Mov 11, 2009 13:47  Mov 11, 2008 13:47 'y Sample Page

To find attachments associated with a page:

1. Choose Tools > Attachments to go to the 'Attachments' view for the page.

2. This will display a list of all files attached to the page.
3. Click the attachment's linked name to view its contents in your computer's associated application.

o This is different from clicking an Office or PDF file's View link, which opens the file for viewing in Confluence itself.

Screenshot : Page Attachments

Attached Files
Hame Size Creator Creation Date Last Mod. Date ¥  Comment
24 Example PDF Document. pdf 105 kB  Fred Ferdinando Mov 11, 2009 13:45  Nov 11, 2009 13:59 PDF Sample Properties | Remove | View
¥ |my Example Word 2007 Document.docx 10kB  Fred Ferdinando Mov 11, 2009 13:46  Nov 11, 2009 13:59  Word Doc Sample Properties | Remaove | Edit | View
Version 2 10kB  Administrator Mov 11, 2009 13:32  Nov 11, 2009 13:32
Version 1 10kB  Fred Ferdinando Mov 11. 2009 11:52  Nov 11, 2009 11:52
¥ |mj| Example Excel 2007 Document.xlsx 5 kB Fred Ferdinando Mov 11, 2009 13:47  Nov 11, 2009 13:59  Excel Sample Properties | Remove | Edit | View
Version 1 5 kB Fred Ferdinando Mov 11, 2009 11:52  Nov 11, 2009 11:52
] Example PowerPaint 2007 Document pp 35 kB Ered Ferdinando Mov 11, 2009 11:52  Nov 11, 2009 11:52 Properties | Remaove | Edit | View

i Handy Hint

If you know the title of an attachment, you might find it faster by doing a Quick Search.

Related Topics

Working with attachments
Attaching Files to a Page
Viewing Attachment Details
Deleting an Attachment
Browsing a space

Take me back to Confluence User's Guide

Moving an Attachment
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You can move an attachment from its current location to any page within the site.
To move an attachment, you need the following permissions:

® Edit page permission on the page where the attachment currently exists.

® Create attachment permission on the space into which you are moving the attachment.
Space permissions are assigned by a space administrator from the Space Administration screens. See Space permissions or
contact a space administrator for more information.

To move an attachment:

Go to the page that contains the attachment.
Choose Tools > Attachments.
Click the Properties link beside the attachment. This will display a new screen, where you can edit the properties of an attachment.
Select the page where you want to move the attachment by either:
® Entering the page's title into the Page field
® Clicking the Choose a Page icon and using the 'Choose a Page' pop-up window to choose a page within the site.
5. Click OK.

El N

Screenshot : Moving an attachment

% Properties: confluence-3-1-editing-attachment-details.png

Added an Jan 18, 2008 14:09 by Sarah Maddox [Atlassian Technical Writer], last edited on Mov 11, 2009 16:36

File Hame
conflaence—3—1—editing—attachment—details.pnﬁ

New Comment
Updated for Confluence 3.1

New Content Type
image/png

Page

&

Specify the page you want to move the attachment to

Save Cancel

Related Topics
Moving a Page

Take me back to Confluence User's Guide

Choose a Page

The 'Choose a Page' window allows you to locate a page in your Confluence site. The window appears when you are moving an attachment.

To choose a page:

1. Click the page picker icon 2] to display the 'Choose a Page' window. You will see the following tabs:
Search: Allows you to search for your page in all Confluence spaces.

History: Displays a list of pages recently visited by you.

Recently Modified: Displays pages most recently modified by you.

Referring Pages: Displays a list of all pages that refer to the current page.

2. Select the required page from the list of pages in one of the tabs.
Related Topics
Moving an Attachment

Take me back to Confluence User's Guide

Viewing Attachment Details

There are two places in Confluence where you can view attachment details:
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* View the list of attachments in a space — this will show all files/images attached to all pages in the space.
® View the list of attachments for a specific page.

On this page:

Viewing Attachments in a Space
Viewing Attachments on a Page
Attachment Details

Viewing and Editing Attached Files
Attachment Information Icon
Related Topics

Viewing Attachments in a Space

To view the attachments associated with a space:
1. Goto a page in the space and choose Browse > Attachments.

This displays a list of all the attachments in the space, along with their details and the pages they are attached to.
2. You can choose to view only files of a particular type:
® Type the last part of the file name in the Filter By File Extension box. For example, enter 'gif' to see only image files of the
GIF format.
® Click Go.

Screenshot: Space Attachment Details

l’; List Attachments

Pages | Blog | Labels JEisl=ylhiC0 Bookmarks § Mail | Advanced § Space Admin
Filter By File Extension: D

1 2 3 4 58 6 MNext ==
Name Size Creator Creation Date Last Mod. Date Attached To
| Example Waord 2007 Document docx 10 kB  Ered Ferdinando Mov 11, 2009 13:46  Mov 11. 2009 13:46 5 Sample Page
2 Example PDF Document.pdf 105 kB Fred Ferdinando Mov 11, 2009 13:45  Mov 11, 2009 13:45 7y Sample Page
|2 Example PowerPaoint 2007 Document pptx 35 kB Fred Ferdinando  Mov 11, 2009 11:52  Nov 11, 2009 11:52 {3y Sample Page
|z Example Excel 2007 Document. xlsx 8 kB Fred Ferdinando  Mov 11, 2009 13:47  MNov 11, 2009 13:47 'y Sample Page

Viewing Attachments on a Page

To view the attachments associated with a page:

1. Go to the page.
2. Choose Tools > Attachments to go to the 'Attachments' view for the page.

This will display a list of all the attachments in the page along with their details. For each attachment, links are also provided to edit
the attachment's details and to delete the attachment.

Screenshot: Page Attachment Details

Attached Files
Hame Size Creator Creation Date Last Mod. Date * Comment
4 Example PDF Document. pdf 105 kB  FEred Ferdinando Mov 11, 2009 13:45  Nov 11. 2009 13:59 PDF Sample Properties | Remove | View
¥ |mj Example Word 2007 Document.docx 10kE  Ered Ferdinando Mov 11, 2009 13:46  Nov 11, 2009 13:59 Word Doc Sample Praperties | Remove | Edit | View
Version 2 10kB  Administrator MNov 11, 2009 13:32  Nov 11, 2009 13:32
Version 1 10kB  Fred Ferdinando MNov 11, 2009 11:52  Nov 11, 2009 11:52
¥ |m| Example Excel 2007 Document.xlsx 8 kB Fred Ferdinando Mov 11, 2009 13:47  Nov 11. 2009 13:59  Excel Sample Properties | Remove | Edit | View
Version 1 5 kB Fred Ferdinando Mov 11, 2009 11:52  Nov 11, 2009 11:52
|z} Example PowerPoint 2007 Document pp.. 35 kB Fred Ferdinando  Nov 11, 2009 11:52  Nov 11, 2009 11:52 Propedies | Remove | Edit | View

In the screenshot above, Fred Ferdinando created the first version of Example Word 2007 Doc.docx, Administrator uploaded the second
version and Fred Ferdinando added the third (current) version.

Attachment Details

The attachment views show the following fields. (The page view shows a different subset of fields from the space view.)
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Name is the name of the attached file.

Size tells you how much space the attachment takes up. You can sort by size by clicking the column title.

Creator is the user who attached this file. The person who uploaded each new version of a file will be acknowledged as the creator
of that version. Clicking on the link takes you to their profile.

Creation Date is the date the file was attached. You can sort by date by clicking the column title.

Last Mod. Date is the date the file was last modified. Please refer to definition of Last Modifier for a list of actions that qualify as a
modification.

Attached To (in the space view) tells you which page contains the attachment.

Comment (in the page view) is a short description of the attachment.

The Properties link (in the page view) lets you edit the attachment details.

The Remove link (in the page view) lets you delete the attachment.

The Edit link (in the page view) only appears next to Office files and lets you edit that attachment directly from the list of
attachments. See Viewing and Editing Attached Files.

The View link (in the page view) only appears next to Office and PDF files and lets you view that attached attachment directly from
the list of attachments. See Viewing and Editing Attached Files.

Viewing and Editing Attached Files

If an attachment is an Office or PDF file, you will see a View link as shown in the screen snippet below. Furthermore, if the attachment is an
Office file, it will also have an Edit link.

Screenshot: Office and PDF file page attachments showing the 'View' and 'Edit' links

Name Size Creator Creation Date Last Mod. Date ¥  Comment

% Example PDF Document pdf 105 kB Administrator Mov 11, 2009 15:11  Mov 11, 2009 15:11 Properties | Remove | View

E] Example PowerPoint 2007 Document.pp 35 kB Fred Ferdinanda  Mov 11, 2009 11:52  Mov 11, 2009 14:49  PowerPoint Sample Properties | Remave \ Edit | View
@y Example Word 2007 Document.docx 10kB  Fred Ferdinando  Mov 11, 2009 13:46  Mov 11, 2008 14:20  Word Doc Sample Properties | Remove | Edit | View
= Example Excel 2007 Document.xdsx 8 kB Fred Ferdinando  Mov 11, 2009 13:47  Nov 11, 2009 13:59  Excel Sample Properties | Remave \ Edit | View

Click View to view the content of the Office file within Confluence.

Click Edit to edit the content of the Office file in your Office application. You must have a compatible Office application installed to do this.
Refer to Working with the Office Connector for more information.

Attachment Information lcon

When a page you are viewing contains attachments, a small paperclip icon 71 appears next to the page byline. Clicking the paperclip will
take you to the 'Attachments' view, where the full list of attachments is displayed.

Related Topics

Working with Attachments

Displaying a List of Attachments in a Page
Finding an Attachment

Editing Attachment Properties

Deleting an Attachment

Browsing a space

Take me back to the Confluence User's Guide.

Customising Confluence

You can customise or configure many aspects of Confluence:

The look and feel of any Confluence space.

Personal aspects, including your personal profile and homepage.
Setting up your user profile.

User access, including permissions and page restrictions.
Add-ons such as gadgets and macros.

Customisations for specific uses of Confluence.

Related Topics

Configuring Confluence

Configuring Confluence Security

Take me back to the Confluence User's Guide.

Personal Customisations

There are several ways that you can customise the way that Confluence works for you, personally, including:
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Your personal homepage
Your personal dashboard
Your personal profile
Your email notifications
Your RSS Feed settings

Related Topics

Customising Confluence

User Profile Overview

Each Confluence user has a User Profile area, where numerous account management features can be accessed.

Finding your User Profile

Go to your name (the 'User' menu) at the top of the page and choose Profile.

The profile view is divided into tabs, each of which is described in a separate section below.

On this page:

Finding your User Profile
Profile

Network

Status Updates

Labels

Watches

Drafts

Settings

Screenshot: User profile

' Giles Gaskell

JPruﬁIe Network | Status Updates | Labels | Watches || Drafts | Settings

Pmﬁ'e_— Touching up Community-based features. Personal
E ﬁ yesterday at 1:53 PM | Clear E:.:Lih::ame:
O Password About Me Edit :JJ:one:

Website:

I'm a Technical Writer at Atlassian. | started working at
Atlassian back in December 2008 and focus mainly on Company
documenting new features for Confluence. In my spare time,  pgsition:

| enjoy participating in traditional Indonesian ‘gamelan’

profile updated less than a minute ago
|=] reong.png
attached 19 minutes ago
Touching up Community-based features

yesterday at 1:53 P

[£] Drafts for Confluence 3.0 forum announcements -

including Advanced Warnings
updated May 25

3 AODC conference happened and was good
commented May 25

o L Department:
orchestra groups. This is one of my favourite instruments - Location:
the reong” ocation:
Activity
L. Giles Gaskell

Giles Gaskell
ggaskell@atlassian.com
+E5E BRER

gg@chat example.com
http-/fwww.atlassian.com

Technical Writer
Development
Sydney

m
=
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The 'Administer User' link is visible to Confluence administrators only. The administrator can click this link to go directly to
the user management screen in the Administration Console.

Profile

® View and edit your personal details, such as your name and email address details and optionally, your photograph and other
personal information. Note that as a security precaution, in order to change your email address, you will be required to re-enter your
password.

Upload a profile picture (optional).

Change your password.

Network

® View the recent activity of users that you are following via the Network view.
® Follow other users from this view.

Status Updates
® View your history of status updates.
Labels
® View your personal labels.
Watches
® View a list of the pages and spaces you are currently watching.
Drafts
® Retrieve any pages you were in the process of editing. See Working with Drafts.
Settings
® Edit your General Settings (homepage, language and timezone).

® Subscribe to email notifications.
® View and revoke your OAuth access tokens.

Related Topics

Watching Changes
Setting up your Personal Space

Take me back to the Confluence User's Guide.

Changing Password

To change your Confluence password:

. Go to your name (the 'User' menu) at the top of the page and choose Profile.
. On your Profile tab, click Password in the left-hand column.

. Enter your current password and your new password in the form displayed.

. Click Submit.

A WN P

Related Topics

Viewing User Profile

Editing Your User Profile
Choosing a Profile Picture
Setting up your Personal Space
Updating Email Address

Email Address Privacy

Take me back to the Confluence User's Guide.

Editing User Settings
You can set various Confluence preferences that affect your personal session:
® General preferences such as home page, language and time zone, as described below.

® Editor settings, as described below.
® Email settings for subscriptions to Email Reports.
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® OAuth access tokens that you have granted from your Confluence user account. Please refer to Viewing and Revoking OAuth
Access Tokens.

On this page:

General User Preferences
Language

Editor Preferences

Email Notification Settings
Related Topics

General User Preferences
To edit your general user settings:

1. Goto your name (the 'User' menu) at the top of the page and choose Settings.
2. Click Edit and make general settings:

Setting Description

Site Homepage Select the page that you would like to see whenever you log into Confluence.
Language Select your language. See below.

Time zone Select your time zone.

Use Keyboard Shortcuts =~ Enable keyboard shortcuts, other than for the editor.

3. Click Submit.
Screenshot: Editing your user profile settings
Profile | Metwork J Status Updates [ Labels | Watches [ Drafts JREulylsi]
Gurnets Settings
View OAuth Access Tokens (
Site Homepage | Site Default (Dashboard) 3
Your Settings 0 -
Language | Automatically detect browser setting v ]
General Additional language packs are available from Atlassian Translations. Contact your administrator
Email about installing additional language packs.
Editor
Time zone | Site Default (US/Central) o ]
# Use Keyboard Shortcuts
Enable keyboard shortcuts (does not apply to editor shortcuts). Select "Keybeard Shortcuts”
from the Browse menu to see available shortcuts.
{ N { ]
[ Submit ) ( Cancel )
Language

Setting your language preference in your user profile is described in the section above. This section gives more information about that setting
and other settings that affect the language Confluence will use.

Individual users can choose the language that Confluence will use to display screen text and messages. Note that the list of supported
languages depends on the language packs installed on your Confluence site.

The language used for your session will depend on the settings below, in the following order of priority from highest to lowest:

® The language preference defined in your user profile. Note that you need to be logged in for this setting to take effect.
® The language that you choose by clicking an option at the bottom of the Confluence login screen. Confluence stores this value in a
cookie. When the cookie expires, the setting will expire too.
® The language set in your browser.
® Note that your Confluence administrator can disable this option by setting a system property.
® The browser sends a header with a prioritised list of languages. Confluence will use the first supported language in that list.
® The default language for your site, as defined by your Confluence site administrator.
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Editor Preferences

You can set some options that determine the way the Confluence editor works. Note that these settings affect only you. Other people using
Confluence can enable or disable the settings on their user profiles independently.

To change your editor preferences:

1. Go to your name (the 'User' menu) at the top of the page and choose Settings.
2. Click Editor under 'Your Settings' in the left-hand panel.

3. Click Edit.
Setting Description
Disable Select to disable autocompletion when you press one of the trigger characters.

Autocomplete

Disable Select to disable autoformatting when you type wiki markup in the editor. Click ? on the editor toolbar to
Autoformatting learn more.
4. Click Submit.

Screenshot: User settings for the editor

Gadgets

View OAuth Access Tokens

Your Settings

General
Email
Editor

Profile § Metwork | Status Updates || Labels | Watches ] Drafts JRelgullsi

Editor Settings

Disable Autocomplete
& in the Editor, where it allows links to be inserted with the
the trigger ! and user mentions with the trigge

Disable Autoc
trigger [, images w

0l

Disable Autoformatting

Disable Autcformatting in the Editor, where it allows wiki-formatted text to be
converted to its Rich Text equivalent {e_g. "h1. title” for a heading).

Email Notification Settings

You can ‘watch' a page, a blog post or a space. Confluence will then send you a notification by email whenever anyone adds or updates
content on that page, blog post or space. You can also subscribe to daily email reports and other notifications of various updates, as
described below. See Watching Changes.

You will only receive notifications for content that you have permission to view. Users who have been disabled by an administrator will not

receive email notifications.

For instructions on configuring an email server so that Confluence can send email notifications, see the administrator's guide to Configuring a

Server for Outgoing Mail.

To edit your email notification settings:

1. Goto your name (the 'User' menu) at the top of the page and choose Settings.
2. Click Email in the left-hand panel.

3. Click Edit.

Each email setting is explained below:

Setting Description

Content

Autowatch Automatically watch content for future changes.

207

® Pages and blog posts
that you create, edit or

comment on.

Frequency

Immediately



Confluence 4.0 Documentation

Subscribe to
daily updates

Subscribe to all
blog posts

Subscribe to
network

Subscribe to
new follower
notifications

Notify on my
actions

Show changed
content

Related Topics

Receive email reports showing changes to content in all spaces
that you have permission to view. .

Note: Daily email reports do not include information about

attachments on a page or blog post that are added, edited or .
deleted.

Receive email notifications for changes to blogs in your
Confluence installation that you have permission to view. .

Receive email notifications for changes to content by all users
that you are following, which you have permission to view. .

Receive an email when anyone chooses to follow you.

Receive email notifications for your own changes.

Note: If you have not subscribed to any email notifications and
are not watching any pages/spaces, then selecting ‘Notify on my .
actions' will not do anything.

Notifications will include details of the changes made to the
content. See Page History and Page Comparison Views .

Editing Your User Profile
Choosing a Profile Picture
Setting up your Personal Space
Email Address Privacy

Using Autocomplete

Take me back to the Confluence User's Guide.

Editing Your User Profile

Pages and blog posts
that are added, edited
or deleted.

Comments on a page or
blog post that are
added, edited or
deleted.

Updates by users who
have changed their
personal profile.

Blog posts added,
edited or deleted.

Pages being added,
edited or deleted.

Blog posts being added,
edited or deleted.
Comments being
added, edited or
deleted.

Status updates by the
user.

All pages and spaces
that you are watching.
This affects all
subscriptions set.

Edits to pages and blog
posts.

Daily

Immediately

Immediately

Immediately

Immediately

Immediately

Your user profile contains basic information about you. If you do not have a personal space, your user profile will be displayed when anyone
clicks your name in the People Directory.

To edit your user profile:

1. Goto your name (the 'User' menu) at the top of the page and choose Profile.
2. On your Profile view, click Edit in the Personal details section.
3. Enter details about yourself in the form displayed.
4. Click Save.
Detail Description
Full Name Your name as you would like it to appear in your profile.
Email Your email address which will be used to send you mail notifications.
Phone Your phone number.
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Website
Position
Department
Location

About me

Your Instant Messenger (IM) details.

ﬂ To suit a variety of IM applications, this option accepts any string value. For example, you can enter IM details in the
form of an email address, such as ' or a user ID, like '123456789'.

Your website's URL.

The title of your position within your organisation.

The name of your department within your organisation.
Your location. This could be a town, city, region or country.

Information about yourself that other users can view (such as your professional information, hobbies, and other interests).
You can use Confluence wiki markup in this field.

ﬂ Note that your Username cannot be changed.

Screenshot: Edit profile

Profile § Network | Labels | Watches ]| Drafts | Settings

Personal

Full Name:
Email:
Phone:

In:
Website:

About Me:

Company

Position:

Department:

Location:

Fred Ferdinando

|Fred Ferdinando ‘

| fredfer@example-company.com ‘

| +61 0 1234 5678 |

| fredfer@chat_example-company.com ‘

| http:/fwww example-company.com/ ‘

| completed a Masters in Mathematical Linguistics at the University of Cape
Yark.

| Production Manager ‘

|I"u"|anagement ‘
|Sydney ‘
’ Save ] ’ Cancel l
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Related Topics

Viewing User Profile

Choosing a Profile Picture
Setting up your Personal Space
Email Address Privacy

Take me back to the Confluence User's Guide.

Email Address Privacy

Confluence can mask the email addresses of users to protect them from mail spammers.

This is done by a Confluence administrator and is configured through the Administration Console. The Confluence administrator has three
options for email address privacy:

® Public: email addresses are displayed publicly.
® Masked: email addresses are still displayed publicly, but masked in such a way to make it harder for spam-bots to harvest them.
® Private: only Confluence administrators can see the email addresses.
For more information on setting these options, which are configured using the Administration Console, refer to User Email Visibility.
Related Topics
Editing Your User Profile
Viewing User Profile

User Email Visibility

Take me back to the Confluence User's Guide.

Updating Email Address

The email address you specify in your profile settings is used for your mail notifications and is also displayed in your profile description.
To update your email address:

. Go to your name (the 'User' menu) at the top of the page and choose Profile.

. Click Edit in the 'Personal’ section.

. In the Email field, specify your new email address which will be used when sending you mail notifications.
. Click Save.

A WOWNPE

Related Topics

Changing Password
Editing Your User Profile

Take me back to the Confluence User's Guide.

Choosing a Profile Picture

Your profile picture is used as the icon for your personal space, to represent you in the People Directory, and to illustrate your comments. It
also appears in various other places next to your name, such as in the list of recent updates on the dashboard.

You can upload your own profile picture or use one of the images provided by Confluence. If you upload your own profile picture, you will
have an opportunity to crop (trim) the picture.

To choose a profile picture:

1. Goto your name (the 'User' menu) at the top of the page and choose Profile.

2. Click Picture on the left.

3. Choose one of the following two options:
® Upload a new picture: Click Browse to locate your picture, then click Upload to upload it from your computer or file server.
® Or select one of the default icons provided.

4. Click Set Profile Picture.

Screenshot: Choosing a profile picture
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n Sarah Maddox

Prof B0 Network | Status Updates || Labels | Watches § Drafts | Settings

Profile Your profile picture is used as the icon for your personal space, and to represent you in Confluence.
You can upload your own profile picture, or you can choose from one of our standard icons.

Details

Picture Upload a Profile Picture: Upload your own profile picture. Profile pictures
will be resized to 48 x 48 pixels.

Password

-U pload

Choose a Profile Picture: n “ g u
=)

Delete [ Set Profile Picture ]

If you upload a profile picture that is larger than 48x48 pixels, the 'Edit My Profile Picture' screen will appear. You can select part of the
picture or the entire picture, to be used as the final image for your profile. Note that the size of the final image will always be scaled down to
48x48 pixels.

To edit your profile picture:
1. Click and drag the centre of the superimposed square to select the centre of the new image.
2. Click the corners of the square to resize the area for your new image.
3. Click Save.
4. The image from your selected area will be cropped, resized to 48x48 pixels and saved.

Screenshot: Trimming a profile picture
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ﬂ Sarah Maddox

JPmﬁIe Network | Status Updates § Labels § Watches § Drafts | Settings

Profile
Select the area you want to -
Details use as your profile picture.
Picture
Password

Related Topics

Deleting a Profile Picture
Editing Your User Profile
Setting up your Personal Space

Take me back to the Confluence User's Guide
Deleting a Profile Picture
You can delete the profile picture images that you have uploaded to Confluence.
To delete a profile picture:
. Go to your name (the 'User' menu) at the top of the page and choose Profile.

1
2. Click Picture on the left.
3. Locate and select the picture file you wish to delete, then click Delete.

ﬂ Note that you can only delete images that you have uploaded to Confluence. The standard icons cannot be deleted.
4. Click Delete to confirm the action. The picture is permanently removed from the server.

Screenshot: Deleting a Profile Picture
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Fred Ferdinando

JPruﬁIe Network | Labels | Watches | Drafts | Settings

Profile Your profile picture is used as the icon for your personal space, and to represent
you in Confluence. You can upload your own profile picture, or you can choose
from one of our standard icons.

0O Details
O Picture

O Password . . )
Upload a Profile Picture: Upload your own profile picture. Profile pictures

will be resized to 48 x 48 pixels.

| |[ Browse_

Choose a Profile Picture:

-
a
i

e & §2 O
S & §2 0o
o 0o B 69

[ Delete ] [ Set Profile Picture

Related Topics

Choosing a Profile Picture
Editing Your User Profile
Setting up your Personal Space

Take me back to the Confluence User's Guide.

Viewing User Profile

A Confluence User's Profile view shows details about that person and lists their recent activity. If you are viewing your own Profile view, you
can also update your profile picture and login password. If you are viewing another user's Profile view, you can add them to your Network of
users you are following and if they have set up a Personal Space, you can add this to your list of Favourites.
To access your User Profile view:

® Go to your name (the 'User' menu) at the top of the page and choose Profile.

Screenshot: User Profile View
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' Giles Gaskell

JPrnﬁIe Network | Status Updates J Labels | Watches | Drafts | Settings

Personal
reie Touching up Community-based features.

m
=]

O Details B Full Name: Giles Gaskell
O Picture yesterday at 1:53 PM | Clear Email: ggaskell@atlassian.com
O Password .
[N About Me Edit Phone: +5665 5655
1M: gg@chat.example.com
I'm a Technical Writer at Atlassian. | started working at Website: http:i -atlassian.com
Atlassian back in December 2008 and focus mainly on Company
dncumentin.g.nev.v fe.atures.f.or Conﬂuence., In my spare time,  pgsition: Technical Writer
| enjoy participating in traditional Indonesian 'gamelan Department: Development
orchestra groups. This is one of my favourite instruments - .
the 'reang" Location: Sydney
Activity
£\ Giles Gaskell

profile updated less than a minute ago
|=] reong.png
attached 19 minutes age
Touching up Community-based features
yesterday at 1:53 PM
[£1 Drafts for Confluence 3.0 forum announcements -

including Advanced VWarnings
updated May 25

7 AODC conference happened and was good

commented May 25

Updating your Profile
You can update the following aspects of your Profile from this view:
® Information about yourself - to modify these details, see Editing Your User Profile.

® Your Profile picture - to change your Profile picture or upload a new one, see Choosing a Profile Picture.
® Your login password - to change your login password, see Changing Password.

You can switch between your Profile, Profile picture update and login password update views by clicking the 'Details’, '
Picture' and 'Password' links in the left-hand column, respectively.

Related Topics

Editing Your User Profile

Take me back to the Confluence User's Guide.

Viewing and Revoking OAuth Access Tokens

This page describes the purpose of OAuth access tokens which have been issued on behalf of your Confluence user account and provides
instructions on how to revoke them.

On this page:
® OAuth Access Tokens
® Viewing your OAuth Access Tokens

® OAuth Access Token Details
® Revoking your OAuth Access Tokens

OAuth Access Tokens

OAuth access tokens allow you to use a Confluence gadget on an external web application or website (also known as the ‘consumer') and
grant this gadget access to Confluence data which is restricted or privy to your Confluence user account.
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OAuth access tokens will only appear in your user profile if the following conditions have been met:

1. Your Confluence Administrator has established an OAuth relationship between your Confluence site and the consumer. Confluence
Administrators should refer to Configuring OAuth for more information about establishing these OAuth relationships.
2. You have accessed a Confluence gadget on the consumer and have conducted the following tasks:
a. Logged in to your Confluence user account via the gadget and then,
b. Clicked the '‘Approve Access' button to allow the gadget access to data that is privy to your Confluence user account.
0 Confluence will then send the consumer an OAuth 'access token', which is specific to this gadget. You can view the
details of this access token from your Confluence site's user account.

An OAuth access token acts as a type of 'key'. As long as the consumer is in possession of this access token, the
Confluence gadget on the consumer will be able to access Confluence data that is both publicly available and privy to your
Confluence user account. As a Confluence user, you can revoke this access token at any time. Furthermore, all access
tokens expire after seven days. Once the access token is revoked or has expired, the Confluence gadget will only have
access to publicly available Confluence data.

Viewing your OAuth Access Tokens

To view all of your Confluence user account's OAuth access tokens:

1. Goto your name (the 'User' menu) at the top of the page and choose Settings.

2. Click View OAuth Access Tokens. A view similar to screenshot below is displayed. Refer to OAuth Access Token Details below for
information on interpreting this table.

a If no access tokens have been set, then 'None specified' is shown.

Screenshot: Viewing your OAuth Access Tokens

a
“ OAuth Access Tokens

Your Settings

OAuth Access Tokens

General
Email You have allowed the following gadgets/applications to access Confluence data
using your account
Gadgets
View OAuth Access Consumer Consumer Description Issued on Expires on  Actions
Tokens

Confluence QuickMav Atlassian JIRA at http://blowfly:8080 Dec 02, 2009 Dec 09, 2009 Revoke OAuth Access Token
Activity Stream Atlassian JIRA at http://blowfly:8080 Dec 02, 2009 Dec 09, 2009 Revoke OAuth Access Token

OAuth Access Token Details

Your list of OAuth access tokens is presented in a tabular format, with each access token presented in separate rows and each property of
these tokens presented in a separate columns:

Column Description
Name

Consumer  The name of the Confluence gadget that was added on the consumer.

Consumer A description of this consumer application. This information would have been obtained from the consumer's own OAuth
Description  settings when an OAuth relationship was established between Confluence and that consumer.

o If the consumer is another Atlassian application, this information is obtained from the Consumer Info tab's 'Description'
field of the OAuth Administration settings. The application's administrator can customise this Consumer Info detail.

Issued On The date on which the OAuth access token was issued to the consumer by Confluence. This would have occurred
immediately after you approved this gadget access to your Confluence data (privy to your Confluence user account).

Expires On = The date when the OAuth access token expires. This is seven days after the 'Issued On' date. When this date is reached,
the access token will be automatically removed from this list.

Actions The functionality for revoking the access token.
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Revoking your OAuth Access Tokens
To revoke one of your OAuth access tokens:

1. View your Confluence user account's OAuth access tokens (described above).

2. Locate the Confluence gadget whose OAuth access token you wish to revoke and click Revoke OAuth Access Token next to it.

The gadget's access token is revoked and the Confluence gadget on the consumer will only have access to publicly available
Confluence data.

Choosing Your Homepage

By default, all users are directed to the Dashboard after logging in. However, you can choose to be redirected to the home page of any space
on the Confluence site after logging in.

To set the home page:

1. Click on your name (the ‘'user' menu) at the top of the page and choose Settings.
2. Click Edit.
3

. Use the Site Homepage list to select a space. Note that only the list of spaces to which you have 'view' access is displayed here.
You will be directed to the home page of the selected space when you next log in.
4. Click Submit.

Screenshot: General Preferences Settings

Profile | Network J§ Status Updates J Labels | Watches [ Drafts Settings|

Gadgets

Settings
View OAuth Access Tokens
Site Homepage | Site Default (Dashboard) | ]
Your Settings
Language | Automatically detect browser setting | % ]
General Additional language packs are available from Atlassian Translations. Contact your administrator about installing
Email additienal language packs.
Editor

Time zone | (GMT+1000) Sydney, Canberra, Melbourne

ar

# Use Keyboard Shortcuts

Enable keyboard shortcuts (does not apply to editor shortcuts). Select "Keyboard Shortcuts” from the Browse
menu to see available shortcuts.

[ N )
([ Submit ) ( Cancel )

Related Topics

User Profile Overview
Space Homepage

Take me back to Confluence User's Guide

Customising your Personal Dashboard

You can customise the Confluence dashboard to provide access to the content on the site that is most relevant to you. The options describec
on this page will change your own personal dashboard, but will not affect the dashboard that other people see.

If you are a Confluence Administrator, you can change the global dashboard, as seen by all Confluence users. See the administrator's guide
to customising the dashboard.

On this page:

® Displaying your Favourite Spaces
® Categorising your Spaces

® Displaying your Favourite Pages
® Related Topics

Displaying your Favourite Spaces

Mark some spaces as favourites. You can now click the Spaces tab on the dashboard to see a list of your favourite spaces. You can also
click the Favourite Spaces tab at the top right of the dashboard to see recently updated content from just your favourite spaces.

Categorising your Spaces

To help keep Confluence spaces organised, you can label spaces with different space categories. See Using Labels to Categorise Spaces.
Space categories are used to group related spaces.
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For example, you might want to group spaces on your Confluence site by applying the following space categories to the relevant spaces:

® ‘design’ (for spaces relevant to a design team), and
® 'development’ (for spaces relevant to a development team).

If a subset of these spaces is relevant to both teams, apply both the 'design' and 'development' categories to each of these spaces to make
the spaces appear in both groups.

Once you have added space categories, you can click the Space Categories tab at the top right of the dashboard and select a category from
the drop-down menu to display only spaces belonging to that category.

Displaying your Favourite Pages

Mark some pages as favourites. You can now click the Pages tab on the dashboard to see a list of your favourite pages.

Screenshot: The dashboard, showing favourite pages and space categories

% Dashboard [& AddPage [B Add Blog Post
Welcome to Confluence All Updates  Favourite Spaces | Space Categories =gp
Confluence combines powerful online authoring capabilities, deep Office Select: | Confluence B

integration and an extensive plugin catalogue to help pecple work better

together and share information effortlessly. Stefan Saasen &

Get started by adding a new space to create content in. Add a few users
to try out Confluence with you.

If you want to display a different message here, you can easily change the ﬁ Jay Rogers
|
D

|=] Launchd & launchctl updated 43 minutes ago (view change)

welcome message.
' ssag =] Summit 2011 Customer Interviews updated about 3 hours ago
(view change)
Spaces | Pages Network
Giles Gaskell

Favourite Pages 3 Re: Why | might start to look a bit funny... commented about

= . 12 hours ago

[®] Egg-citing New Frontlines Reports S )

Congratulations to both you and Frank Agnes!
[E] World Saved, Services Will Now Resume As Usual g

Rosie Jameson

& Re: Why | might start to look a bit funny... commented about
12 hours ago

Tomorrow A
Congratulations Agnes — lovely news!

[E] Sales Q3 Release Notes

[£] Tech writer brilliance kickoff Stefan Saasen

|E] Home T @
[E Rise of the Machines Part 5 - Development in the World of e

%) Atlassian Partner Milestones! |=] Test 3 updated about 18 hours ago (view change)

Related Topics

Working with Labels

Working with Favourites
Configuring the Site Home Page
Customising the Dashboard

Take me back to the Confluence User's Guide.

Customising the Look and Feel

Confluence allows you to customise the 'look and feel' of an individual space on the Confluence instance through options available in the
Space Administration menu. By default, the look and feel of a space is based on global settings configured from the Administration Console

You need to be a space administrator to edit the look and feel of a space.

Applying a Theme to a Space
Changing a Space's Logo

Changing the Confluence Browser Icon
Customising Layouts for a Space
Editing a Space's Colour Scheme
Styling Confluence with CSS

Related Topics

Browsing a space
Administrator's Guide - Design and Layout

Take me back to the Confluence User's Guide.

Applying a Theme to a Space
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Themes allow you to personalise the 'look and feel' of Confluence. You can apply a theme to your entire Confluence site and to individual
spaces. Choose a specific theme if you want to add new functionality or significantly alter the appearance of Confluence.

Confluence comes with a selection of themes. In addition, a site administrator can install new themes as plugins via the Confluence
Administration Console. Provided that the theme is installed into your Confluence site, any space administrator can apply a theme to a
space.

By default when you create a new space, the space will have the Confluence default theme.

To apply atheme to a space:

1. Choose Browse > Space Admin.
o Space Admin is displayed only if you are a space administrator for that space or you are a Confluence system administrator.

Click Themes in the left-hand panel under 'Look and Feel'.
Select a theme option.
Click Confirm.

Ao

Screenshot: Applying a theme

% Space Theme 4k Add -
Pages || Blog | Labels | Attachments | Calendar | Bookmarks | Mail | Advanced 3TN0 L]
Help Tips
Space Operations
P P Current Theme Themes are Confluence plugin
// Space Details The current theme controls the layout and colours of this space. modules that customise the look
Q Space Labels of the space. You can learn
p s Global Look and Feel more about how to find or create
@ Calendar —_— The globally configured look and feel. You can customise Confluence themes in the online
@ Remove Space colour-schemes and layouts manually. documentation.
g Trash e If you select a theme, then any
colours or page layouts defined
Security in that theme will be applied
8 Permissions Choose New Theme across this space.
# Restricted Pages . If you do not select a theme. the
18] g To change the theme of this space, select one below. globally configured look and feel
Mail ®D tation Th will be used in this space, or
S - ocumgn ation . eme you may customise the space's
2, Mail Accounts This theme is well suited for structured content. such as appearance manually through

documentation. It features a table of contents (page tree) on
the left, making it easier to see the structure of a space and
move from page to page. You can customise the left-hand
Look and Feel panel, page header and page footer. This theme supports

Firefox. Safari and Internet Explorer 7+.
Themes

& Colour Scheme ) Easy Reader Theme ) )
; Stvleshest This is a fixed-width variation of the default Confluence gel s sion B
yleshes

theme. Its larger fonts, smooth gradient background and Exchange. You will need to
2 POF Layout

colour-scheme and layout
customisation.

[l%

[ Mailbox Import

Get More Themes

You can download more themes

comfortable line length make it ideal for displaying and ;or:tal;::hyourmm
H Iinsta em.
= PDF Stylesheet reading longer documents.

L&

filfmi

& Change Space Logo

Related Topics

Applying a Theme to a Site
Editing a Space's Colour Scheme
Customising the Look and Feel

Take me back to Confluence User's Guide

Configuring the Documentation Theme
The Documentation theme is one of the themes bundled with Confluence. (See availability below). The theme is designed for spaces

containing technical documentation, but you may find it useful for other types of content too. It provides an inbuilt table of contents for your
wiki space, a configurable header and footer, and text styles suited to documentation. (See features below.)
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@ Quick guide to applying and customising the Documentation theme

® Go to Space Admin and click Themes.
® Select Documentation Theme and click Confirm.

® |f you want to customise the theme, click Configure theme.

® Select or deselect the default page tree.

® Select or deselect the space-restricted search.
® Enter the text and wiki markup for your custom left-hand panel header and footer.
® Click Save.

The rest of this page gives more details of the above procedure.

On this page:

Applying the Documentation Theme to your Space
Applying the Documentation Theme to your Site
Customising the Documentation Theme

Features of the Documentation Theme

Availability of the Theme
Hints and Tips

Related Topics

Screenshot: A wiki page using the Documentation theme

Search
EE Developing Plugins for Crowd
Component Plugin Modules
Event Listeners
Password Encoders
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Applying the Documentation Theme to your Space

You need space administrator permissions to apply a theme to a space.

Follow the steps below to apply the ‘Documentation Theme' to your space. All pages in the space will start using the theme immediately.

To apply a theme to a space:

1. Choose Browse > Space Admin.

o Space Admin is displayed only if you are a space administrator for that space or you are a Confluence system administrator.

219




Confluence 4.0 Documentation

2. Click Themes in the left-hand panel under ‘Look and Feel'.
3. Select a theme option.
4. Click Confirm.

Screenshot: Applying a theme
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Applying the Documentation Theme to your Site

If you have site administrator permissions, you can apply the theme at site level. It will then be the default theme for all spaces in the site.
See the administrator's guide to applying a theme.

Customising the Documentation Theme

The theme works well without any customisation. If necessary, you can restrict the search to just one space, change the content of the
left-hand navigation panel and add your own header and footer.

To customise the Documentation theme:

1. Choose Browse > Space Admin.
o Space Admin is displayed only if you are a space administrator for that space or you are a Confluence system administrator.

. Click'Themes in the left-hand panel under the heading 'Look and Feel'.
. If the space is not yet using the Documentation theme, apply the theme as described above.
. Click Configure theme'in the yellow area of the '‘Current Theme' section at the top of the page. See screenshot below. The
'Documentation Theme Configuration' screen appears. See screenshot below.
5. Select or deselect the Page Tree check box. This determines whether your space will display the default search box and table of
contents (page tree) in the left-hand panel.
6. Select or deselect the Limit search results to the current spacecheck box.
® |f you select the check box:
® The Confluence search will look for matches only in the current space by default. Users can override this restriction
when entering their search term. See Using the Documentation Theme.
® The default page tree in the left-hand panel will not include a search box.
® |f you do not select the check box:
¢ The Confluence search will look for matches in the entire Confluence site. This is the default behaviour for other
themes too.
® The default page tree in the left-hand panel will include a search box, which restricts search results to the current
space.
7. Enter text, images, macros and other wiki markup into any or all of the three text boxes.

a You can use the Include or Excerpt Include to include re-usable content into your footer. See hint below.
® 'Navigation' — This text box contains content for the left-hand panel.
® |f the Page Tree check box is selected, the navigation panel contains the default search box and page tree. Any
content you enter into the 'Navigation' text box will appear above the page tree and search box.
® You can include your own content underneath the page tree as well as above. See hint below. In summary:

A wWN
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Deselect the Page Tree check box. Insert your own page tree using the Pagetree macro, then add your own
content under the macro.
® 'Header' — This text box contains content for a page header that will appear above the page title on all pages in the space.
See example screenshot below.
® ‘'Footer' — This text box contains content for a page footer that will appear after the comments and above the site footer, on
all pages in the space. See example screenshot below.
8. Click Save.

Screenshot: The 'Configure theme' option
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Screenshot: Customising the Documentation theme
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Customising the Theme at Site Level

If you have site administrator permissions, you can apply and customise the theme at site level. The customisation options are the same as
the space level options, as described above.

Features of the Documentation Theme

Screenshot: A customised header, footer and left-hand panel
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The {spacejump} macro. Customisable header. The sidebar icon.
This is how we use it to link from one This one is yellow because Click it to hide/show the
space to the same page in another space. we used a fwaming} macro.) left-hand panel.

\

View this page in the current documentation or visit the curent documentation home.

The search box.

to the current space.

In most cases, your usemame will be defined in one directory only. But some organisations may have mare than one user
directory. For example, your usemame may be defined in Crowd for JIRA use, and also in another Crowd-connected directory (e.g
LCWAP) for use in another application. If you change or reset your password, the new password will apply only in one directory — the
directory mapped to the ‘crowd application and defined as first in the directory sequence. Your Crowd administrator can define the
order of the directories, as described in the Crowd Administration Guide

Membershig

RELATED TOPICS

Logging in to Crowd
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Children (2) Show Children | View

Add Comment
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The above screenshot shows a wiki space with a customised left-hand panel, header and footer.

Here is a summary of the features that the Documentation theme provides:
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By default, the left-hand panel contains a search box and a table of contents (page tree) showing all the pages in your space.
Specifically, it shows the pages that are children of the space's home page.

The left-hand panel is fully customisable. You can choose to include or exclude the search box and page tree. You can enter your
own text, images and wiki markup.

People viewing the page can drag the thick bar between the left-hand panel and the content, to increase or decrease the width of the

panel. They can also remove the panel altogether, by clicking the sidebar icon Dj at top right, next to the search box.

The left-hand and right-hand panels scroll independently of each other.

The page title is neatly above the page content, and not uncomfortably above the navigation panel as tends to happen when you
insert the navigation panel yourself.

Because the left-hand panel is part of the theme, it will be upgraded whenever Confluence is upgraded. There is no need to remove
and then re-apply your customisations on each upgrade, as you would do if you added your own left-hand navigation bar.

The theme also provides a customisable header and footer, which will appear at the top and bottom of every page.

The text and heading styles are designed to enhance the content typically found in a documentation space.

You can use the Space Jump macro to link from a page in one wiki space to a page with the same name in another space, without
knowing the name of the page when you create the link.

You can limit the Confluence search results to the current space. If you choose this option, the Confluence search will look for
matches only in the current space by default. Users can override the restriction. See Using the Documentation Theme.
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Availability of the Theme

Confluence Versions

The Documentation theme is bundled with Confluence 3.2 and later. If you have Confluence 3.1, your Confluence Administrator can
download the theme from the Atlassian Plugin Exchange and install it as a plugin.

The theme is not available for versions of Confluence earlier than Confluence 3.1.

Hints and Tips

Below are some hints that you may find useful when using the Documentation theme. Where can | see a working example of the
Documentation theme?

The Confluence documentation uses the Documentation theme. If you are reading this documentation online on the Atlassian documentation
wiki, you are seeing a working version of the Documentation theme.
Which pages will appear in the Documentation theme's table of contents?
The theme constructs the page tree in the left-hand panel from all pages that are child pages of the space’s home page. Each space has a
single page designated as the 'Home' page. You can specify the home page in the space administration section.
Help, my pages do not appear in the Documentation theme table of contents
Cause 1: Your pages are not under the space's home page. The most probable reason why your pages do not appear in the page tree in
the left-hand panel is this: The theme constructs that table of contents from all pages that are child pages of the space’s home page. If your
pages are above the home page in the page tree, they will not appear in the left-hand panel.
There are two ways to fix the problem:

® You can change the designated space home page in the space administration section.

® Oryou can drag and drop all your pages to make them children of the current home page. You can drag and drop pages in the

'Pages' section of the space 'Browse' screen. See Moving a Page.

Cause 2: Problem with upgrade from Confluence 3.1, with Documentation theme as plugin, to Confluence 3.2 or later with
Documentation theme bundled. If your existing Confluence installation already has the Documentation theme plugin installed, you may find
that after upgrading to Confluence 3.2 the left-hand navigation bar is empty in the spaces that use the theme. The fix is to enable all modules
of the Documentation theme plugin. See the knowledge base article.

Help, my left-hand panel has disappeared

If your entire left-hand panel has disappeared when using the Documentation theme, this is probably because you have clicked the sidebar

icon Dj at top right, next to the search box. Click the icon again to restore the panel.

Hiding Pages from the Left-Hand Table of Contents

You can 'hide' pages by putting them at the same level as or higher than the space home page.

Each space has a single page designated as the '"Home' page. You can specify the home page in the space administration section.

The theme constructs the page tree in the left-hand panel from all pages that are child pages of the space’s home page.

If your documentation pages are at the same level as the space home page, they will not appear in the left-hand navigation bar. So you can
'hide' pages by putting them at the same level as or higher than the space home page. The pages will show up in the search results and
people can see the content if they open the page, but the pages will not appear in the left-hand panel.

More detail: The theme uses the Pagetree macro to produce the table of contents. When entering the Pagetree macro, you can choose the
top page in the page tree. The Documentation theme chooses the space home page as the top page.

Using reusable Content in your Header, Footer or Left-Hand Panel

You can use any text or wiki markup in your theme header, footer or left-hand panel. One useful hint is to use the Include or Excerpt Include
to include re-usable content into your footer.

The screenshot above shows the theme customisation options, with examples of the macros used to include content from other pages. And
the example screenshot also above shows the resulting header, footer and left-hand panel.
Adding Content Below the Page Tree in your Left-Hand Panel

If you want to include your own content underneath the page tree, you can deselect the 'Page Tree' check box, add your own page tree
using the Pagetree macro in the 'Navigation' text box, and then add your own content under the macro.
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The screenshot above shows the theme customisation options, with the default page tree deselected and a custom page tree inserted, along
with additional content in the left-hand panel. The example screenshot also above shows the resulting left-hand panel.
Adding Underlines to your Links

By default, the Documentation theme does not underline hyperlinks. If you prefer to have your links underlined, you can edit the CSS
stylesheet for your space and add the following CSS code:

.wiki-content a:1link, .wiki-content a:visited, .wiki-content a:active {
text-decoration: underline;

}

To edit a space's CSS style sheets:

1. Choose Browse > Space Admin.
o Space Admin is displayed only if you are a space administrator for that space or you are a Confluence system administrator.

Click Stylesheet in the left-hand panel under the heading ‘Look and Feel".
Click Edit.

Paste your custom CSS into the text field.

Click Save. The new CSS will be visible on all content pages in the space.

arwN

Jumping to the Same Page in Another Space

The {spacejump} macro is provided along with the Documentation theme. You can use space jumping to link from a page in one wiki space
to a page with the same name in another space, without knowing the name of the page when you create the link. When a reader is viewing a
page and clicks the link provided by the macro, they will go to a page with the same name, but in the space specified in the macro. See more
about the Space Jump macro.

Related Topics

Using the Documentation Theme
Space Jump Macro

Applying a Theme to a Space
Applying a Theme to a Site
Editing a Space's Colour Scheme
Customising the Look and Feel

Take me back to Confluence User's Guide

Configuring the Easy Reader Theme

The Easy Reader theme is one of the themes bundled with Confluence. This is a fixed-width variation of the default Confluence theme. Its
larger fonts, smooth gradient background and comfortable line length make it ideal for displaying and reading longer documents.

@ Quick guide to applying the Easy Reader theme
1. Choose Space Admin > Themes.

2. Select Easy Reader Theme.
3. Click Confirm.

The rest of this page gives more details of the above procedure.
On this page:

Applying the Easy Reader Theme to your Space
Customising the Look and Feel of the Easy Reader Theme

Hints and Tips

L]
°
L]
® Related Topics

Screenshot: A wiki page using the Easy Reader theme
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Dashboard » Documentation Testing » Home » A long policy document Browse - Sarah Maddo: Search r

A long policy document & Edt  dkAdd + £ Tools ~

Added by Sarah Maddox 27, last edited by Sarah Maddox © on Mar 01, 2010

Summary

s We encourage and display customer comments and votes openly in our issue tracking systems, hitp./jira atlassian.com and
hitp-//studio atlassian.com.

« We do not publish roadmaps.

s Product Managers review our most popular voted issues on a regular basis.

* We schedule features based on a variety of factors.

s Our Support:Atlassian Bug Fixing Policy is distinct from our Feature Request process.

= Aflassian provides consistent updates on the top 20 feature/improvement requests (in our issue tracker systems).

How to Track what Features are Being Implemented

When a new feature or improvement is scheduled, the 'fix-for' version will be indicated in the JIRA issue. This happens for the upcoming release
only. We maintain roadmaps for more distant releases internally, but because these roadmaps are often pre-empted by changing customer
demands, we do not publish them.

How Atlassian Chooses What to Implement
In every major release we aim to implement highly requested features, but it is not the only determining factor. Other faciors include:

* Direct feedback from face to face meetings with customers, and through our support and sales channels.

« Availability of staff to implement features.

* Impact of the proposed changes on the application and its underlying architecture.

« How well defined the requested feature is (some issues gain in popularity rapidly. allowing little time fo plan their implementation).
« Our long-term strategic vision for the product.

How to Contribute to Feature Development

Influencing Atlassian's release cycle
We encourage our customers to vote on feature requests in JIRA. The current tally of votes is available online in our issue tracking systems,

o You need space administrator permissions to apply a theme to a space.

Applying the Easy Reader Theme to your Space

Follow the steps below to apply the 'Easy Reader Theme' to your space. All pages in the space will start using the theme immediately.
To apply atheme to a space:

1. Choose Browse > Space Admin.
0 Space Admin is displayed only if you are a space administrator for that space or you are a Confluence system administrator.

Click Themes in the left-hand panel under 'Look and Feel'.
Select a theme option.
Click Confirm.

O

Screenshot: Applying a theme
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% Space Theme 9F Add ~
Pages || Blog | Labels | Attachments | Calendar | Bookmarks | Mail § Advanced JE3GTERN ]
Help Tips
Space Operations
P P Current Theme Themes are Confluence plugin
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Q Applying the theme to your entire Confluence site

If you have site administrator permissions, you can apply the theme at site level. It will then be the default theme for all
spaces in the site. See the administrator's guide to applying a theme.

Customising the Look and Feel of the Easy Reader Theme

You can customise the space CSS style sheets to change the colours, background image and other styles in the theme. See the guide to
using CSS to customise the Easy Reader theme.

Hints and Tips

If a page has content that is very wide, it will either:

® cause a scroll bar to appear, or
® break out, i.e. the content will extend over the right-hand border of the page.

Related Topics

Applying a Theme to a Space
Applying a Theme to a Site
Customising the Look and Feel

Take me back to the Confluence User's Guide

Changing a Space's Logo

In Confluence, you can replace the default logo for a space with a logo of your own choice.

You need to be a space administrator to replace a space's logo.

0 The instructions below refer to global spaces. For your personal space, your profile picture is used as the space icon.
To change a space's logo:

1. Choose Browse > Space Admin.
o Space Admin is displayed only if you are a space administrator for that space or you are a Confluence system administrator.

2. Click Change Space Logo in the left panel under the heading 'Look and Feel'. See the screenshot below.
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3. Use the browse option to locate the new logo and click Upload.

Screenshot: Changing a space's logo
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Upload Logo

Current
(default)

b 4

Image Data
H: 30
Wz

GIF

Related Topics
Customising the Look and Feel

Take me back to Confluence User's Guide

Changing the Confluence Browser Icon

The Confluence logo ﬂ is displayed in the user's browser to identify the Confluence browser tab. To use a custom image for your
Confluence site:

1. Obtain or create an image in PNG file format. To maximise browser compatibility, it should be 32x32 pixels in size, 71x71 DPI (dots

per inch) and have an 8 bit colour depth.
. In your Confluence installation, find the . . .\confluence\images\icons directory.

2
3. Back up the file favicon.png.
4. Replace the favicon.png file with your custom PNG image.

o You may also need to back up and replace the following images in your Confluence installation:

® ...\confluence\images\icons\favicon.ico
® ...\confluence\favicon.ico
® . ..\confluence\images\logo\confluence 16.png (Reduce thisimage to 16x16 pixels.)

5. Restart your application server.

Users may need to clear their browser cache before they will see the new image.

) Converting an icon to a PNG

To create an ICO out of your PNG image, you can use the freeware tool png2ico or the the online tool at
http://converticon.com/.

Related Topics

Customising the Look and Feel

Customising Layouts for a Space

Confluence's look and feel can be modified by editing the ‘decorator’ (layout) files. Modifying these files allows you to change the look and
feel of:

® The Confluence site as a whole, which includes all spaces within the Confluence site.
® An individual space within the Confluence site.

This page tells you how to customise the layout files for a space. To perform these customisations, you will require space administrator
permissions for that space.
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.. For security reasons, you must also have Confluence system administrator permissions to modify any space layout
throughout your Confluence site.

A feature request (CONF-5808) has been submitted to allow space administrators (who are not system administrators) to
access and modify space layouts. Please feel free to vote on this issue if you would like to see this feature implemented.

Confluence system administrators can also customise the layout of their entire Confluence site as a whole. For more information, please refer
to Customising Layouts.

o Be aware that site layout file customisations modify the default layout files of all spaces in the Confluence site. However, any space
layout file customisations will override the equivalent site layout file customisations.

.a If you modify the look and feel of Confluence by following these instructions, you will need to update your customisations
when upgrading Confluence. The more dramatic the customisations are, the harder it will be to reapply your changes when
upgrading. Please take this into account before proceeding with any customisations. For more information on updating your
customisations, please refer to Upgrading Custom Layouts.

Confluence is built on top of the Open Source SiteMesh library, a web-page layout system that provides a consistent look and feel across a
site. SiteMesh works through 'decorators' that define a page's layout and structure.

To edit the layout of Confluence, you will need to modify these decorator files. A decorator file is a vmd file and is written in a very simple
programming language called Velocity. Learn more about Velocity. Once you become familiar with Velocity, you can edit the decorator files
to personalise the appearance of Confluence.

These decorator files are grouped into:

® Site layouts : These are used to define the controls that surround each page in the site. For example, if you want to make changes
to the header and the footer, you will need to modify these layouts.

® Content layouts : These control the appearance of content such as pages and blog posts: they don't change the way the pages
themselves are displayed, but they allow you to alter the way the surrounding comments or attachments are shown.

® Export Layouts: These control the appearance of spaces and pages when they are exported to HTML. If you are using Confluence
to generate a static website, for example, you will need to modify these layouts.

Learn more about using decorators.
To edit a decorator file:

1. Choose Browse > Space Admin.
0 Space Admin is displayed only if you are a space administrator for that space or you are a Confluence system administrator.

2. Click the Layout link in the left panel under the heading 'Look and Feel'. A list of the layouts for the space is listed.

o Layout is only displayed if you are a Confluence system administrator.
® Click View Default to view the vmd file.
® Click Create Custom to edit the default vmd file. This will open up the vmd file in edit mode.
Make changes and click Update.

Screenshot : Edit Layouts Example

Decorator Operations
Space Export Layout < default = | Create custom | Wiew Default
when you export a space to HTML, this layout iz used te create the index
page.
Page Export Lavout < default = | Create custom | Wiew Default

Wwhen you perform an expaort, each page is converted to HTML using this
layout,

Click the thumbnail to see an example of a vmd file:
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Related Topics

Customising the Look and Feel
Applying a Theme to a Space
Administrator's Guide - Design and Layout

Take me back to the Confluence User's Guide.

Editing a Space's Colour Scheme

Confluence allows you to customise the colour scheme of a space. By default, a space's colour scheme is based on global settings
configured from the Administration Console.

You need to be a space administrator to edit a space's colour scheme.

To change the colour scheme for a space:

1.

Choose Browse > Space Admin.
o Space Admin is displayed only if you are a space administrator for that space or you are a Confluence system administrator.

Click Colour Scheme in the left-hand panel under the heading Look and Feel.
Click Select next to a colour scheme under Custom Colour Scheme (if not already selected).

Click the Edit link. This will bring up a new screen. See screenshot below.

Enter standard HTML/CSS2 colour codes, or use the colour-picker ] to choose a new colour from the palette provided. Any
changes you make will immediately be reflected in this space.

The colour scheme applies to the following Ul elements:

Top Bar - the bar across the top of the page that contains the breadcrumbs

Tab Navigation Background - the background colour of the tab navigation menus

Tab Navigation Text - the text of the tab navigation menus

Breadcrumbs Text - the breadcrumbs text in the top bar of the page

Space Name Text - the text of the current space name located above the page title

Heading Text - all heading tags throughout the space

Links - all links throughout the space

Borders and Dividers - table borders and dividing lines

Tab Navigation Background Highlight - the background colour of the tab navigation menu when highlighted

Tab Navigation Text Highlight - the text of the tab navigation menu when highlighted

Top Bar Menu Selected Background - the background colour of the top bar drop down menu when selected

Top Bar Menu Item - the text colour of the menu items in the top bar drop down menu

Page Menu Selected Background - the background colour of the drop down page menu when selected

Page Menu Item Text - the text of the menu items in the drop down page menu

Menu Item Selected Background - the background colour of the menu item when selected (applies to both the top bar and page
drop down menus)

Menu Item Selected Text - the text colour of the menu item when selected (applies to both the top bar and page drop down menus)

Please note that some Ul elements are specific to the default theme and may not take affect for other themes.

Screenshot : Editing a space's colour scheme
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Custom Colour Scheme
A custom colour scheme which can be edited.

Eﬂ--DDD----:I-----D Selected

The following colours can be customised for this colour scheme.

Top Bar [ [#0033¢66
Tab Navigation Background - [#3c78b5

Tab Navigation Text FELEEEE
Breadcrumbs Text |#ffffff

Space Name Text [#999999
Heading Text [ [#00336¢6

Links [ [#003365

Borders and Dividers - [#3c78b5

Tab Navigation Background Highlight - |#00 3366
Tab Mavigation Text Highlight |_| |#ffffff

Top Bar Menu Selected Background - [#336699
Top Bar Menu Item Text [JJJJjj [#0033566

Page Menu Selected Background - [#6699cc
Page Menu Item Text [l [#535353

Menu ltem Selected Background - [#6699cc
Menu Item Selected Text|  |[#ffffff

HEEBEEHEEEEEE BB BHH 8

Reset | Save | Cancel |

i Handy Hint

If you mess things up, just click the Reset button and then try again.

Related Topics

Customising the Look and Feel

Take me back to Confluence User's Guide

Styling Confluence with CSS

This page explains the facility for making visual changes to the look and feel of Confluence with CSS.
On this page:

Introduction

Considerations for Using Custom CSS
Getting Started

CSS Resources

Related Pages

Introduction

Cascading Style Sheets (CSS) are an industry-standard way of styling a web page. The content of a page is rendered with HTML, and its
look and feel is determined by CSS files.

With the release of Confluence 2.10, you can upload a CSS text file and apply it to a space or even a whole Confluence instance.
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" This function is turned off by default. To allow space administrators to edit stylesheets, go to the security configuration
section of the Confluence Administration Console and turn on ‘Enable Custom Stylesheets for Spaces'.

Creating CSS styles that work seamlessly across different browsers is a delicate task for basic web sites, and reasonably challenging when
customising web applications like Confluence. It is important to test each change that you make and ensure it works as expected in all areas
of Confluence — for example, on the Confluence Dashboard as well as on regular pages.

In order to get you started, we have compiled this introduction, a basic styling tutorial and a more advanced tutorial.
Considerations for Using Custom CSS

CSS Knowledge is Required

If you are not familiar with CSS, see the links in the CSS Resources section below. You should spend some time to become confident with
Cascading Style Sheets before you start editing your Confluence style sheets.

Security
Custom CSS can be used to inject scripts into a page, opening the risk of cross-site scripting (XSS) attacks. With this feature enabled, space
administrators could upload styles that steal other users' login credentials, trick their browsers into performing actions on the wiki without their

knowledge, or even obtain global administration privileges. As such, this feature is disabled by default. Confluence administrators should only
enable custom CSS if they are comfortable with the risks listed in this paragraph.

Scaling
Each page needs to scale. Depending on the resolution of the user's screen, the content should render intelligently. Your designs needs to

degrade gracefully. Try resizing each page that exists in Confluence. There are quite a few pages in the browse-space-section, like drafts,
labels, page hierarchy, and so on. Your style has to work everywhere, not just in the first page you happen to be looking at.

Features Cannot Be Disabled
It is easy to turn off certain links, headers, or even menu items by simply setting their style to ‘hidden'. This can help you to roll out
Confluence to users that may not be very Wiki-savvy yet. The simpler the Ul, the easier it may be for them to use. However, please

remember that removing the link to a part of the application does not mean that the functionality is not available. Every user can still change
their style from within their browsers, or access the URL directly. Don't rely on CSS to disable parts of Confluence.

Features Should Not Be Disabled
Users familiar with Confluence will expect to find the same controls that they are accustomed to. Removing buttons or controls from the

interface is not advised as it may frustrate your users and cause them to circumvent your design by using direct URL access, as mentioned
above.

Confluence Version Compatibility
Be aware of any plans to upgrade your Confluence instance. Future versions of Confluence may not be compatible with your custom CSS —

this may cause your CSS to break, requiring maintenance when Confluence is upgraded. Ask your Confluence administrator for more
information.

Test on Different Web Browsers
As a rule you should test your modifications on different web browsers. Internet Explorer, Firefox, Opera and Safari (on Mac OS X) are some

of the more popular browsers.

1. Supported Web Browsers

Please ensure that you are using one of the web browsers supported by Confluence. If you are using an unsupported
browser or browser version, some features may not work correctly. You can find the list of supported web browsers and
browser versions on this page: Supported Platforms.

CSS Customisation is Not Supported

As creating custom CSS has potentially limitless possibilities, Atlassian will not support issues that are caused by or related to CSS
customisation.

Getting Started

Editing the CSS
To edit a space's CSS style sheets:
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1. Choose Browse > Space Admin.
o Space Admin is displayed only if you are a space administrator for that space or you are a Confluence system administrator.

. Click Stylesheet in the left-hand panel under the heading ‘Look and Feel'.
. Click Edit.

. Paste your custom CSS into the text field.

. Click Save. The new CSS will be visible on all content pages in the space.

abwiN

Follow the Tutorial

Follow the examples in the Basic Styling Tutorial or the more advanced Styling Tabs in Confluence to get started.

CSS Resources

W3C CSS Standards
W3schools CSS Introduction
Mozilla Developer Network
Wa3resource.com

Related Pages

Basic Styling Tutorial

Styling Tabs in Confluence

Styling Fonts in Confluence

Including Cascading Stylesheets in Themes

Basic Styling Tutorial
This page contains instructions on how to get started with custom CSS styling in Confluence.
On this page:

® CSS Editing Quick-Start
® Tutorial: Changing the Header Background
® CSS Editing Tips
® Begin With a Space Stylesheet
® Use the Right Tools
® Edit Simple Elements First
® Related Topics

CSS Editing Quick-Start
To edit a space's CSS style sheets:

1. Choose Browse > Space Admin.
a Space Admin is displayed only if you are a space administrator for that space or you are a Confluence system administrator.

. Click Stylesheet in the left-hand panel under the heading ‘Look and Feel'.
. Click Edit.

. Paste your custom CSS into the text field.

. Click Save. The new CSS will be visible on all content pages in the space.

abwiN

Tutorial: Changing the Header Background

The header is the menu area at the top of a default Confluence page where the Breadcrumb Links, Browse menu, User menu and the
Quick Search box reside. In this example, we are going to change the background of the header to include a custom graphic.

. Create a custom graphic. For this example, we created a custom header graphic of 1046 x 61 pixels.

. Upload the custom graphic to a page in the space that you are customising.

Note the page ID of the page where you uploaded the new graphic. (in this example, the page ID was '658833839'.

Compose your custom CSS for the header. The example below loads the new graphic (called 'header.png’) from a specific page
(denoted by page ID '658833839') in the same space.

#header {
background-image:url ('../download/attachments/658833839/header.png') ;
background-repeat: no-repeat;

. Log in as the Space Administrator.

. Open the Space Admin page.

. Click Stylesheet.

. Click Edit to change the code in the text field.

0 ~NOo O
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9. Paste your custom CSS into the text field.
10. Click Save and then reload the page (you may have to shift-reload). The background of the header will change.
11. The custom header will be visible on all content pages in the space. To revert your change, simple delete the custom code from the
'Stylesheet' page and click Save.

CSS Editing Tips
Begin With a Space Stylesheet

A space stylesheet is a good starting point for CSS customisation, as it already includes all of the elements that can be changed. When you
work on the space stylesheet it styles all content pages in the space. Build and test it at space-level, before considering applying the new
stylesheet to your entire site. Once you are satisfied with your space design, test it thoroughly until you are confident that it has no problems.
Then, you can look into advanced customisation of the Confluence CSS such as adjusting the Search page, the Dashboard and other
integral pages.

Use the Right Tools

As the Confluence CSS is reasonably sophisticated, web development applications will help you to understand how the page styles have
been created. In particular, you will need to view the existing source for the pages you're starting to work on. If you don't already have some,
tools such as the following free applications will allow you to do this.

1. Firebug
Firebug, a plugin for the Firefox web browser, allows you to take a look at the style of each element on your page. This is very useful to see
what styles are currently applied, for example styles applied to the header only.

2. Web Developer
The Web Developer plugin for Firefox allows you to edit CSS inline and create new page designs.

3. CSS Edit
CSS Edit is a stand-alone CSS editor for Macintosh that extracts all existing styles from a given page and allows you to overwrite these.

Edit Simple Elements First

Begin by editing simple elements and checking that they work. By making changes, then checking that each one worked, you can easily
isolate any CSS code that is causing problems. Be aware that some page elements are more suited to customisation than others. For
example, adding a gradient to the toolbar is less likely to 'break’ the page than changing the page width. Editing reasonably static elements

such as background graphics will render more predictably than designs which attempt to completely change the user interface or the
Javascript-powered drop-down menus (which we don't recommend editing).

Related Topics

Styling Confluence with CSS
Styling Tabs in Confluence
Including Cascading Stylesheets in Themes

Styling Fonts in Confluence

Confluence provides the ability to adjust its visual style via Cascading Style Sheets (CSS). With this feature, it is very easy to change the look
and feel of Confluence.

This tutorial shows you to change the fonts of a normal Confluence page. We will show how to change the font and font sizes with a few lines
of CSS.

Screenshot 1: Default Font in a Confluence Page

Dashboard » People » Mall Ryall » Home

9

by nama is Matt Ryall. I'm a developer on the Conflusnce team, and | started at Atlassian in Januany
2006

I'm very intengsted in web development, specilically accessible and semantic sile design. Wikis ane
actually one of the most interesting areas of web developmant, | believe, because thay're a fotally new
torm of content. Blogs came Irom the idea of personal jounals, mos! static websites ok ke
rrarketing brochunes, bul iheme's nothing comparablis 10 a wiki in the physical wod. On & wiki you can
creale an amay of linked and searchable content, then anyone can improve on the words you've
written, callaborating on whabewer you wanl

Bedow are some of the pages on this wiki where 1've made a significant contribution

(and the other Confluence Internals documents)

Screenshot 2: Custom Font in a Confluence Page
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Dashboard » People *+ Mait Byall » Home

in Home

My name is Matt Rvall. I'm a developer on the Confluence team, and 1 started at Atlassian
in January 2006

I'm very interested in web development, specifically accessible and semantic site design.
Wikis are actually one of the most interesting areas of web development. [ believe, becayse
they're a tofally new form of content. Blogs came from the idea of personal pournals, maost
static websites look like marketing brochures, but there's nothing comparable to a wiki in
the physical world, On a wiki vouw can create an array of linked and searchable content,
then anyone can improve on the words you've written, collaborating on whatever you want.

Eelow are some of the pages on this wiki where I've made a significant contribution;
i (and the other Confluence Intemals documents)

» Bunning Confluognce behind Apache
s Unider -1.|I'||.||f||_' |'~.|,'|' 5\.1:||I.|'._'l_"|'|'||.‘l'|l in f'lli‘ll’llh"l'll.'{'

At the bottom of this page you can find the code for the custom font. Simply copy and paste it into the Space Stylesheet form within the
Space Administration section.

Changing the fonts

In order to customise the fonts in Confluence, you first need to set the body font to the font you want. Second, you may want to adjust the
font size to account for the fact that different fonts have different relative sizes.

The relevant CSS is shown below, and can be configured in Space Admin > Stylesheets. These styles change Confluence's font from its
default of Helvetica/Arial — sans serif fonts — to Times/Times New Roman — serif fonts. To adjust for the fact that Times is a bit smaller than
Helvetica, we increase the font size to 14 pixels.

body {
font-family: Times, "Times New Roman", serif;
font-size: 1l4px;

.wiki-content,
.wiki-content p,
.wiki-content table,
.wiki-content tr,
.wiki-content td,
.wiki-content th,
.wiki-content ol,
.wiki-content ul,
.wiki-content 1i {
font-size: 1l4px;

The many styles which include 'wiki-content' are necessary to change the font-size for all the tags in the wiki content.

Related Topics

Basic Styling Tutorial
Styling Tabs in Confluence
Including Cascading Stylesheets in Themes

Styling Tabs in Confluence

Confluence provides the ability to adjust its visual style via Cascading Style Sheets (CSS). With this feature, it is very easy to change the look
and feel of Confluence.

This tutorial shows you to change the look and feel of Confluence. We will address the Confluence tabs in this tutorial and how we can
change their look completely with a few lines of CSS.

Let's take a look at what we are trying to achieve. Notice the dark blue tabs in Screenshot 1? Our goal is to blend them into the background
and change the text style as in Screenshot 2.

Screenshot 1: Default Confluence Tabs in Admin Screen
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Screenshot 2: Customised Confluence Tabs in Admin Screen
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At the bottom of this page you can find the code for the custom tabs. Simply copy and paste it into the Space Stylesheet form within the
Space Administration section. Let's discuss each selector in detail:

Container Style

#navigation, #tab-navigation{ i
border-bottom: 1lpx solid #CCC; H
background-color: transparent;
margin: lem 0 2em -5px;

Lets start with the container around the tabs. We don't want a background-color for the tabs and the container, therefore we will set the
color to be transparent. With the border-bottom attribute we will create a thin grey line at the bottom to separate the navigation from the rest
of the page. Lastly we adjust the margins of the container to create some space around the tabs.

Tab Style

H .tab-navigation .tab a { H
H font-weight: normal; H
! color: #999999; !
i background-color: transparent; i
; border: none; ;

Then we style each link within the tab. We set the font-weight to normal, to make the tabs less dominant and change the color to a dark
grey. We also have to specify the border and background-color attributes explicitly to overwrite the default styles in Confluence. If we don't
specify the background color for example, the blue color of the default style will be applied.

Hover Style
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.tab-navigation .tab a:hover {
font-weight: normal;
color: #0088CC;
background-color: transparent;
border: none;

Now we want to specify the hover attributes of the links. Note that we have to overwrite the background-color and the border attributes
again, otherwise the default styles will be applied. We also change the color of the text for the hover effect of the link.

Currently Selected Element Style

ul.tab-navigation .current a:hover, ul.tab-navigation .current a {
color:#000000;
background-color: transparent;
border:none;

The last selector we will need to customise is the element with the class current. Note that we use a more specific selector this time. The
reason we are doing this is because these specific selectors are used in the default CSS stylesheet. If we were to use more general
selectors, like we did above (ignoring the ul), the default style would still be applied since more specific selectors are rendered with a higher
priority. We want to keep the general style of the other links but simply change the color of the text to black.

Complete CSS Style

Simply copy and paste the code below to change the look of the tabs in Confluence.

/* @group Tab Styles */

.tab-navigation .tab a {
font-weight: normal;

color: #999999;
background-color: transparent;
border: none;

}

.tab-navigation .tab a:hover {
font-weight: normal;

color: #0088CC;
background-color: transparent;
border: none;

.

#navigation, #tab-navigation({
border-bottom-color:#CCC;
margin: lem 0 2em -10px;
background-color: transparent;

}

ul.tab-navigation .current a:hover, ul.tab-navigation .current a {
background-color: transparent;
border:none;
color:#000000;

}

/* @end */

Related Topics

Basic Styling Tutorial
Styling Tabs in Confluence
Including Cascading Stylesheets in Themes
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Using CSS to Customise the Easy Reader Theme

This page gives some hints on using the space CSS style sheets to customise the Easy Reader theme.

You can customise the Easy Reader theme using CSS at space or site level. A common modification is to change or remove the background
image.

|-=

CSS elements are specific to each theme

You will need to match your theme choice and custom CSS. If you want to use the CSS on this page, you will need to apply
it to a space that is using the Easy Reader theme. If you apply the CSS at site level, then your entire site must use the
Easy Reader theme.

Editing the CSS

To edit a space's CSS style sheets:

1. Choose Browse > Space Admin.
o Space Admin is displayed only if you are a space administrator for that space or you are a Confluence system administrator.

Click Stylesheet in the left-hand panel under the heading ‘Look and Feel'.
Click Edit.

Paste your custom CSS into the text field.

Click Save. The new CSS will be visible on all content pages in the space.

gk

Simple CSS Customisations for Easy Reader Theme
To change the background image:
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Remember to set an appropriate background colour to extend past the left and right edges of the image. In the example we use colour code
#ccce. This colour should match the last pixel on the left and right of your background image.

@ Upload your background image as a page attachment

You can upload your background as a page attachment. Make sure that you restrict editing (but not viewing) of that page to
yourself or the space/site administrators.

To replace the theme's gradient image with your choice of background colour:

H body { background: #ccc; }
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Related Topics

Configuring the Easy Reader Theme
Styling Confluence with CSS

Permissions Overview

Confluence gives you the choice to make the site as open or as closed as you wish. Here are some points to consider:

® As atool for communication and collaboration, Confluence is at its best when all your users can participate fully.

® So it's advisable not to restrict users unless you have a good reason for doing so.

® Confluence keeps a history of all changes to pages and other content. So it is easy to see who has changed what, and to reverse
any edits if required.
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On this page:

® |evels of Permission
® Global Permissions
® Space Permissions
® Page Restrictions
® More Information
® How do space permissions and page restrictions work together?
® How do space permissions and page restrictions affect links?
® Related Topics

Levels of Permission

There are three levels of permissions in Confluence.

Global Permissions

Global permissions are site-wide permissions, and are assigned by administrators. Confluence allows two levels of administrator
permissions:

® System Administrator - Users with this permission can perform all the Confluence administrative functions.
® Confluence Administrator - Users with this permission can perform most of the Confluence administrative functions, but excluding
those functions which could compromise the security of the Confluence system.

Users with 'System Administrator' or 'Confluence Administrator' permission can assign permissions to other users. For full details, please
refer to the overview of global permissions in the Administrator's Guide.

Space Permissions

The permission to create a new space or to administer one is granted by a Confluence Administrator from the global Administration Console.
Every space has its own independent set of permissions. These permissions determine the access settings for different users of the space.
In order to assign these permissions to other users, a user must be a space administrator i.e. must have the '‘Admin’ permission for that
space.

See Users and Groups to learn how these permissions are assigned.

Page Restrictions
You can set page-level restrictions, if you have the 'Restrict Pages' permission within the space concerned.

Page restrictions allow you to control who can view or edit individual pages. To set page restrictions, edit the page and use the page
restriction options below the text-entry box.

More Information

How do space permissions and page restrictions work together?

Example: In the HR (Human Resources) space, everyone in the organisation has the 'View' space permission, but only the HR team has
the 'Pages --> Create' space permission (i.e. the ability to create and edit pages in the space). A member of the HR team starts to create a
new page called 'Annual Leave Policy'. Because the page is not yet finished, she sets the 'Viewing' page restriction so that only the HR
team can view the page. When the page is finished, she will remove the 'Viewing' restriction so that everyone in the company can see the

page.
How do space permissions and page restrictions affect links?
Space permissions and page restrictions affect how links between pages are displayed to a visitor:
¢ if the link points to a page in a space to which the visitor does not have 'View' space permission, the link will not be rendered at all.
* if the visitor has 'View' space permission, but page restrictions prohibit her from viewing the page, the link will be rendered but an
'Access Denied' message will be displayed when she clicks the link.
® if the visitor has 'View' space permission, and is not restricted from viewing the page, the link will display and behave as normal.

Links to attachments are also affected:

® if the visitor does not have permission to view the page to which the attachment is attached, the link will not be rendered.
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i) Warning

If you misconfigure a space so that nobody has access to administer it any more, you will need to have someone in the '
confluence-administrators' group fix the permissions for you.

Related Topics

Users and Groups

Global Permissions Overview
Space Permissions Overview
Page Restrictions

Configuring Confluence Security
Confluence Security

Take me back to Confluence User's Guide

Page Restrictions

Page restrictions allow you to control who can view or edit individual pages. You set the page restrictions using the Page Restrictions dialog,
either directly by choosing Tools > Restrictions, or when editing a page.

For instructions on using the Page Restrictions dialog, refer to Setting a Page's Restrictions.

el
When a page you are viewing has restrictions applied, a small padlock icon = appears next to the page byline. Clicking the padlock will
open the Page Restrictions dialog, where full details on the page restrictions are displayed.

On this page:

The Confluence Permissions and Page Restrictions Hierarchy
Requirements for Setting Restrictions

Page Security Rules

Inherited Restrictions and Child Pages

Example of Child Page Restrictions

How to Open Part of a Space

Related Topics

Screenshot: The Confluence Page Restrictions dialog

Page Restrictions

{*) Restrict viewing of this page () Restrict editing of this page

To: & Me ,& Person... @, Group... Enter user or group name ("Restrict )

@ No view restrictions are defined for this page

& No edit restrictions are defined for this page

The Confluence Permissions and Page Restrictions Hierarchy

Permissions and page restrictions in Confluence work within a hierarchical manner. For example, users who can access and modify global
permissions (for instance, Confluence Administrators) can define which users can access and modify space level permissions (that is, space
administrators). Space administrators can then define which users have access to create and modify pages. These users in turn can then

apply viewing and editing restrictions to a page. By inheritance, these restrictions will also be applied to any child or descendant pages which
are then added to that page.
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See the diagram below for an illustration.

Diagram: Confluence Restrictions Hierarchy

Users with global
permissions

Users with space
level permissions

Users who can set
page restrictions

Inherited pages

Requirements for Setting Restrictions

In order to set or modify page restrictions, you need to have both:
® 'Restrict Pages' permission in the space to which the page belongs (since page restrictions operate within the bounds of space
permissions).

® Permission to edit the page itself. That is, if a user is prevented from editing a page through page restrictions, they are also
prevented from changing the restrictions themselves.

Page Security Rules

Users can only view page or space content for which they (or a group they are in) have 'View' permission. Pages that a user does not have
'View' access to are referred to as ‘inaccessible’ pages. Visit Inaccessible Page to see how Confluence deals with pages a user cannot view:

® Anonymous users are directed to the login page.
® |Logged-in users are shown a permissions error page.

It is not possible to conceal the existence of pages, though you can restrict 'View' access to page content.
ﬂ Users will still be able to find the page if they know its URL. But they will not be able to view the content if they don't have the correct
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permissions.

Inherited Restrictions and Child Pages

If a page has its 'View' restriction set, that restriction will be inherited by all its children (and their children, and so on). If a 'View' restriction is
added to a page that has already inherited page restrictions from its parent, users must satisfy both restrictions in order to see the page.

'Edit' restrictions are not inherited from the parent page, only from the space.

Example of Child Page Restrictions

Consider the page 'Documents’, with a child page 'Executive’, which itself has a child page 'Payroll'. To begin with, anyone who can view the
space to which these pages belong can see all three pages.

For security reasons, 'View' restrictions are set on the 'Executive’ page, restricting it to the 'mycompany-management group'. At this point,
anyone can still see the 'Documents' page, but you must be in the 'mycompany-management group' in order to view either 'Executive' or
'‘Payroll'.

Since 'Payroll' information is considered particularly private, the 'Payroll' page then has its page restrictions set to only allow members of the
'mycompany-financial’ group to view it. At this point, anyone can see the 'Documents’ page, only members of ‘'mycompany-management' can
see 'Executive’, and only users who are members of both the 'mycompany-management' and 'mycompany-financial' groups can view
'Payroll'.

How to Open Part of a Space

v If designing a large site implementation with this strategy, consult Page Restrictions Performance Considerations.

Often there are cases for which a section of a space should be opened to a group or set of users (for this example, we'll call them group B),
but the rest of the space should not be visible to your main users (for this example, we'll call them group A). In this case:

1. Add 'view' permission for both groups A and B in space permissions.

2. Move the page to be opened to the root of the space. When browsing the pages in the space, your normal space home page and
this page should both be at the root level.

3. Add a page restriction to allow Group A and B to see this page.

4. Add a page restriction to your main landing page for Group A, thereby excluding this set of pages from Group B.

You can repeat this with any page hierarchy.

#) Administrators
® Space administrators are responsible for the management of a space and its contents. They therefore have the
ability to remove all restrictions from a page (as described in ‘Viewing Restricted Pages'). This means that space
administrators can view and edit all content in the space.
® Users who are members of the ‘confluence-administrators' group (‘super-users') cannot immediately see pages

from which they are excluded by page restrictions. Also, to be able to edit the page, you will need to remove the
restriction from it first — go to Space Administration > Restricted Pages.

) You cannot exclude yourself
As creator or editor of a page, you cannot use page restrictions to deny yourself access to the page. Confluence will

automatically add your username into the list of users/groups allowed to view/edit the page. If you remove your username,
Confluence will put it back again.

Related Topics

View a Page's Restrictions

Set a Page's Restrictions

View All Restricted Pages

Page Restrictions Performance Considerations
Working with Pages

Take me back to the Confluence User's Guide.

Setting a Page's Restrictions

Page restrictions control who may view or edit a specific page, within the bounds of the space permissions:
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® View restrictions make the page invisible to everyone except the chosen users and groups.
® Edit restrictions prevent everyone except the chosen users and groups from editing the page.

You can restrict the page to as many users and groups as you like.

o In order to set or modify page restrictions, you need to have the 'Restrict Pages' permission in the space to which the page belongs, as
well as permission to edit the page itself.

Setting Page Restrictions

To set restrictions on a page:

(]
1. Choose Tools > Restrictions. The Page Restrictions dialog opens. You can also click the padlock icon = in the page's byline (if
available), or click either Unrestricted or Restricted when editing the page.
2. Select the restriction option required.
3. Choose the users and groups who you want to be able to view or edit the page:
® To choose just yourself, click Me.
® To choose a particular user or group, type the user's username (or their full name), or the group name, into the Enter ...
name box, and click Restrict. You can enter multiple user and group names, when separated by commas.
® To search for a user or group (if you are unsure of the name), click Person... or Group... (You can read more about
searching for users.)
4. Click Save.

Screenshot: The Confluence Page Restrictions dialog

Page Restrictions

(=) Restrict viewing of this page (0 Restrict editing of this page

To: & Me L. Person... &, Group... Enter user or group name (Restrict )

@ No view restrictions are defined for this page

& No edit restrictions are defined for this page

Removing Page Restrictions

To remove restrictions on a page:

(&}
1. Choose Tools > Restrictions. The Page Restrictions dialog opens. You can also click the padlock icon == in the page's byline (if
available), or click either Unrestricted or Restricted when editing the page.
2. Click Remove restriction next to the appropriate users or groups.
3. Click Save.

ﬁ You can both set and remove restrictions for different users or groups when using the Page Restrictions dialog.

Notes

(&}
When a page you are viewing has restrictions applied, a small padlock icon == appears next to the page byline. Clicking the padlock will
open the Page Restrictions dialog, where full details on the page restrictions are displayed.

View and edit restrictions apply to all users including space administrators. However, space administrators can remove any restriction on a
page. See Viewing Restricted Pages.

Related Topics

Space Permissions Overview
Viewing a Page's Restrictions
Viewing Restricted Pages
Working with Pages
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Take me back to the Confluence User's Guide.

Viewing a Page's Restrictions

Viewing page restrictions in View mode

When a page you are viewing has restrictions applied, a small padlock icon B appears next to the page byline. Clicking the padlock will
open the Page Restrictions dialog, where full details on the page restrictions are displayed.See Setting a Page's Restrictions for instructions
on how to change these.

Viewing page restrictions in Edit mode
You can view a page's restrictions when editing the page. You can only edit the page if you have permissions to do so.
To view the restrictions that apply to a page:

* When editing the page, click Restrictions. See Setting a Page's Restrictions for instructions on how to change these.

Related Topics

Setting a Page's Restrictions
Viewing Restricted Pages
Working with Pages

Take me back to the Confluence User's Guide.

Viewing Restricted Pages

Restricted pages are pages that have 'View' or 'Edit' restrictions applied to them through page-level restrictions.
You need to be a space administrator to view the list of restricted pages in a space.

To view restricted pages:

1. Choose Browse > Space Admin for the space.
2. Click Restricted Pages in the left panel under 'Security'. A list of all restricted pages in the space is displayed.

3. Click on the 'lock’ E' icon to remove restrictions for the page.

Here's an example:

x, Restricted Pages

Pages | Blog ]| Labels | Attachments | Bookmarks | Mail | Advanced JRJGI=RG0T]

Space Operations : . ! .
- - This report shows all the pages where access is restricted to specific groups or users by

# Edit Space Details page level permissions
4 Edit Space Labels )
@ Remove Space Title (Space) Type Eigrnﬂlit:i?]p Creator Created Operations
Trash
ﬁ D Examples (4 . . Joseph Dec 08, _
. K View |bloggs Webb =]
= : Mew Space) 2009
ecurity Bloggs
8 Permissions [ Tutarial (4 ' ) doseph Dec 08, -
[ Restricted Pages Mew Space) View Ibloggs Webb 2009 =
! Bloggs
Mail [] Advanced Joseph Dec 08
£, Mail Accounts '[EIQICS..I_.-*. Mew View ibloggs Webb 2009 =]
Space) Bloggs

2y Mailbox Import

Look and Feel

Related Topics

Viewing a Page's Restrictions
Setting a Page's Restrictions
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Working with Pages

Take me back to the Confluence User's Guide.

Site Administrators and their Permissions

All site administrative functions are performed from the Administration Console. You need to have System Administrator or Confluence
Administrator permissions to access the Administration Console.

The Confluence permission scheme allows the following levels of administrator permissions:
® Super-User — full administrative access to Confluence, plus visibility to all the content.
® System Administrator — full administrative access to Confluence.

® Confluence Administrator — access to most of the Confluence administrative functions.

Please refer to the overview of global permissions in the Administrator's Guide for full details.
Related Topics

Users and Groups

Take me back to Confluence User's Guide

Contacting Confluence Administrators

If you receive an error message from Confluence, the error page may offer you a link to click in order to contact the administrators of the
Confluence site.

When you click the link to contact the Confluence administrators, you will see an administrator contact page with the title 'Contact Site
Administrators'. By default, the administrator contact page looks like the screenshot below.

Screenshot: The administrator contact screen

% Contact Site Administrators

Please enter information about your request for the site administrators. If you are reporting an error please be sure you include information on what you
were doing and the time the problem occurred.

0. Confluence Administrators

From:  admintest@atlassian.com

Subject: | Administrator Request

Request Details:

- N ~
| Send ) | Cancel )

The screen may look different

In certain configurations of Confluence, you will not be able to use the form shown in the screenshot above. Instead, you will see a message
telling you about one of the following conditions:

® |f your Confluence administrator has not configured a mail server for Confluence, this means that Confluence will not be able to send
an email message to the administrators.
® |f none of the Confluence administrators has an email address, Confluence will not be able to send an email message to them.
® |f there are no Confluence administrators defined to Confluence, Confluence will not be able to send an email message to them.
® The Confluence administrator can disable the form and specify a different message to be displayed on the above screen instead of
the default message and form. See the administrator's guide.
Related Topics

Configuring the Administrator Contact Page

Space Administrators and their Permissions
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A space administrator is a user with the 'Space Admin' permission for a space. This permission itself is assigned from the Space
Administration screens by a space administrator.

Who is a space administrator?

The person who creates a space is automatically the administrator of that space. That person can then assign other space administrators as
required.

o Confluence administrators are not necessarily space administrators.

® A user who has the 'Administer Confluence' permission is not automatically a space administrator for a particular space. In order for
them to be a space administrator, they must belong to a group which has space administration rights on the space, or their
username must be specifically granted space administration rights on the space.

® Users who are members of the ‘confluence-administrators' group do automatically have space administration permissions for all
spaces.

Refer to the Administrator's Guide for more details about Confluence administrator permissions.

What can a space administrator do?

A space administrator has permission to do anything in the space regardless of any other setting. Space administrators are responsible for
the management of a space and its contents. Note that page permissions affect space administrators differently from other users.

Space administrators can:

® view all content in the space. If there are page permissions that restrict the viewing of a page to a single user, or to a group to which
the space administrator doesn't belong, a space administrator can still view the page by removing the restriction.

edit all content on any page in the space.

remove restrictions from any page in the space (using the Space Administration interface).

manage the watchers for any page in the space (but not watchers of the space).

grant themselves any other space permissions (e.g. permission to set restrictions on a particular page).

All space administration functions, with the exception of managing watchers, are performed from the 'Space Admin' tab (choose Browse >
Space Admin). You need to be a space administrator to access the Space Administration screens.

Related Topics

Space Permissions Overview

Take me back to Confluence User's Guide

Space Permissions Overview

Every space has its own independent set of permissions.

Space permissions can only be granted by a space administrator. A space administrator has permission to do anything in the space
regardless of any other setting.

Permissions can be assigned to any group, to any individual user in the Confluence-User group, and to users in the Anonymous group.
These are the different permissions that can be assigned at the space level:

® View: user can view this space's content, including the space's details, and its pages and news items (blog posts)
® Pages:
® Create — user may create and edit pages in this space.
® Export — user may export pages in this space.
® Restrict — user may apply page-level restrictions.
® Remove — user may remove pages in this space.
® Blog:
® Create — user may add and edit blog posts in this space.
® Remove — user may remove blog posts in this space.
¢ Comments:
® Create — user may make comments in this space.
® Remove — user may remove comments from this space.
® Attachments:
® Create — user may add attachments in this space.
® Remove — user may remove attachments from this space.
® Mail:
® Remove — user may delete individual mail items.
® Space:
® Export — user may export content from this space.
® Admin — user has administrative permissions over this space.
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* Warning

If you deny all administrative access to a space by mistake, so that nobody has access to administer the space any more,
you will need to ask someone in the confluence-administrators group to fix the permissions for you.

Related Topics

Space Administrators and their Permissions
Users and Groups

Viewing Space Permissions

Assigning Space Permissions

Revoking Space Permissions

Page Restrictions

Take me back to Confluence User's Guide

Assigning Space Permissions

Space permissions can be assigned to user groups or to individual users of Confluence. You need to be a space administrator to assign
space permissions.

These are the different permissions that can be assigned at the space level:

® View: user can view this space's content, including the space's details, and its pages and news items (blog posts)
® Pages:
® Create — user may create and edit pages in this space.
® Export — user may export pages in this space.
® Restrict — user may apply page-level restrictions.
® Remove — user may remove pages in this space.
® Blog:
® Create — user may add and edit blog posts in this space.
® Remove — user may remove blog posts in this space.
® Comments:
® Create — user may make comments in this space.
®* Remove — user may remove comments from this space.
® Attachments:
® Create — user may add attachments in this space.
® Remove — user may remove attachments from this space.
* Mail:
® Remove — user may delete individual mail items.
® Space:
® Export — user may export content from this space.
® Admin — user has administrative permissions over this space.

' Warning

If you deny all administrative access to a space by mistake, so that nobody has access to administer the space any more,
you will need to ask someone in the confluence-administrators group to fix the permissions for you.

To access the space permissions:
a. Go to the 'Space Permissions' view. To do this:

i. Go to a page in the space where you want to view or assign permissions.
ii. Choose Browse > Space Admin.

o Space Admin is displayed only if you are a space administrator.
ii. Click Permissions in the 'Security' section of the left-hand panel.
b. Click the 'Edit Permissions' button.
The'

Edit Space Permissions' screen appears, as shown below.

To assign space permissions to groups:

1. Access the 'Edit Space Permissions' screen as described above.
The Groupssection shows a list of groups which already have permissions to access the site.
® To assign permissions, check the box next to the relevant group, for each of the required permissions.
® To deny a permission, uncheck the relevant box.
®* To add a new group to the list, type the group name into the text box labelled 'Grant permission to' and click the 'Add’

246



Confluence 4.0 Documentation

button. The group will appear in the list of groups and you can then assign the permissions.

® To bulk assign or revoke group member permissions, from the Actions drop-down list, choose either Select All or Deselect
All.

® To search for a group:

Click the {k icon.
In the 'Group Search' window, enter all or part of the group name. You can use an asterisk *' as a wild card.
Check the boxes to select the required group(s).
Click the 'Select Groups' button. The group name(s) will appear in the 'Grant permission to' text box.
® Click the 'Add' button.
Click 'Save All' to apply the permissions.

To assign space permissions to users:

1. Access the 'Edit Space Permissions' screen as described above.
The Individual Userssection shows a list of users who already have permissions to access the site.

® To assign permissions, check the box next to the relevant user, for each of the required permissions.

® To deny a permission, uncheck the relevant box.

® To add a new user to the list, type the username into the text box labelled 'Grant browse permission to' and click the '‘Add’
button. The user will appear in the list of users, with 'View' permission assigned, and you can then add more permissions if
necessary.

® To bulk assign or revoke individual user permissions, from the Actions drop-down list, choose either Select All or Deselect
All.

® To search for a user:

Click the Ck icon.

The 'User Search' window will appear. You can read more about searching for users.

Check the boxes to select the required user(s).

Click the 'Select User(s)' button. The username(s) will appear in the 'Grant browse permission to' text box.
® Click the 'Add' button.

Click 'Save All' to apply the permissions.

To assign space permissions to anonymous users:

1. Access the 'Edit Space Permissions' screen as described above. The Anonymous Accesssection shows the space permissions
granted to all anonymous users of the site.
® To assign permissions, check the box for the required permission.
® To deny a permission, uncheck the relevant box.
® To bulk assign or revoke anonymous user permissions, from the Actions drop-down list, choose either Select All or
Deselect All.
2. Click 'Save All' to apply the permissions.

ﬂ You cannot grant space administration rights or page restriction rights to anonymous users.

Screenshot : Editing space permissions

You can edit the current space permissions here. Permissions can be granted to specific users or groups. You can also grant p to users. users refers to all users that are not logged in. For information
about the individual permissions that can be assigned, please see the permissions guide
Soe i
Groups
These groups have access to this space in Confluence - that means they can view the pages, comments and news items within it
Pages Blog Comments Attachments Space
I e o o o LV s o |
&, confluence-users [} ] o ] [} o o o o o o o E=2e
a
Individual Users
These individual users have access to this space in Confluence - that means they can each view the pages, comments and news items within it
Pages Blog Comments Attachments Space
view [RS8 Export  |Restriot  |Remove  |Ads Remove  |ada Remove  |nda Remove AR A ciions |
£\ Andrew Lui (alui} ] ] ] ] ] ] ] ] ] ] ] ] ] o
24 Giles Gaskell (ggaskel) EN
£ Sally Hawse (shawse)
Q Deselect All
Anonymous Access
When a user is using Confluence while not logged in. they are using it anonymously.
For example: Enabling allows non-logged-in users to make in this space
Pages Blog Comments Attachments Space
I e o o o LV s o |
&, Anonymous ] [} ] o ] [} o o o o o o o o E=2e
Save Al

Notes about some error messages you may see

In Confluence 2.7.2 and later, Confluence will let you know if there is a problem with some permissions. In rare situations, you may see the
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following error messages below a permission:

® ‘'User/Group not found' — This message may appear if your LDAP repository is unavailable, or if the user/group has been deleted
after the permission was created.
® 'Caseincorrect. Correct case is: xxxxxx' — This message may appear if the upper/lower case in the permission does not match
the case of the username or group name. If you see a number of occurrences of this message, you should consider running the
routine supplied to fix the problem.
Related Topics

Space Permissions Overview
Viewing Space Permissions
Revoking Space Permissions
Users and Groups

Take me back to Confluence User's Guide

Revoking Space Permissions

You need to be a space administrator to remove or revoke space permissions.
To revoke space permissions:

1. Choose Browse > Space Admin.
ﬂ Space Admin is displayed only if you are a space administrator for that space or you are a Confluence system administrator.

2. Click Permissions in the left-hand panel under the heading 'Security'. This will display the space's current permissions assigned to
the different groups and users.

. Click Edit permissions. See screenshot below.

. Uncheck the permissions you which to revoke.

. To bulk assign or revoke permissions for groups or individual users, from the Actions drop-down list, choose either Select All or
Deselect All.

Removing the View permission for a user or group will remove all access to that space for the user or group.
6. Click Save All to apply the permissions.

g b~ w

i Quick removal of permissions

To remove all permissions for a user or group, just remove the View permission. The user or group will disappear from the
list when you save the permission updates. There's no need to clear all the permissions for that user or group.

Screenshot : Assigning or Revoking Space Permissions

You can edit the curent space permissions here. Permissions can be granted to specific users or groups. You can also grant to users users refers to all users that are not logged in. For information

about the individual permissions that can be assigned, please see the permissions guide
Emy

Groups

These groups have access 1o this space in Confluence - that means they can view the pages, comments and news items within it

Pages Blog Comments Attachments Space
T T T e o e o e v
]} ] =]} ] ]} =]} ]} ] 0 ]} ]} ]} f=2d

o (1)

£ confluence-users

Individual Users

These indivicual users have access to this space in Confluence - that means they can each view the pages, comments and news items within it

Pages Blog Comments Attachments Space
R e R S R e PP e e i
] ] ] ] ] ] ] ] ] ] ] ]

ons
A\ Andrew Lui (alui) ] o2
£ Giles Gaskell(ggaskel) Ex
£, sally Hawse (shawse)

O‘ Deselect All

Anonymous Access

When a user is using Canfluence while not logged in, they are using it anonymausly.

For example: Enabling allows non-logged-in users to make in this space
Pages Blog Comments Attachments Space
o — - - = = = = m———
&, Anonymous ] m ] ] ] ] ] = ] ] ] ] ] ] fo 2
Emy

Related Topics

Space Permissions Overview
Assigning Space Permissions
Viewing Space Permissions
Users and Groups

Take me back to Confluence User's Guide

Viewing Space Permissions
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You need to be a space administrator to view the permissions assigned for a space.
To view the permissions assigned for a space:
1. Choose Browse > Space Admin. This tab is only displayed if you are a space administrator.

2. Click Permissions in the left-hand panel under the 'Security' heading. This will display all the permissions assigned to the different
groups and users for this space.

Below is an example. The ticks in the boxes indicate which permissions have been granted. The crosses indicate which permissions have
been denied.

Screenshot : Viewing space permissions

Groups

These are the permissions currently assigned to groups for this space

Comments |Attachments|Mail |Space
Export| Restrict| Remowe | Create | Remowve | Create | Remowe | Create | Remowve | Remowe | Export| Admin

&, confluence-administrators [ ] (v ] ] (] (] (/] (] ] ] 2 D
& confluence-users 2 9 9 Q@ 9 9 9 @ 9 9 9 | 9 9 @O

[ Edit Permissions l

Individual Users

These are the permissions currently assigned to individual users for this space

N Comments |Attachments|Mail |Space
View Export| Restrict| Remowve | Create | Remowve | Create | Remowe | Create | Remove | Remowe | Export| Admin

L4 Admin @ 9 9 9 0 @ 0 0 9 9 9 @9 9|9

[ Edit Permissions l

Anonymous Access

When a user is using Confluence while not logged in, they are using it anonymously
For example: Enabling anonymous ‘commenting’ permission, allows non-logged-in users to make comments in this space

Comments |Attachments|Mail |Space
View |Create | Export| Restrict| Remowve | Create | Remowve | Create | Remowe | Create | Remove | Remowve | Export| Admin

4 Anonymous @ 080 80 80 B8/ 8068 68 o0 a8 e/ a

[ Edit Permissions l

Notes about some error messages you may see

In Confluence 2.7.2 and later, Confluence will let you know if there is a problem with some permissions. In rare situations, you may see the
following error messages below a permission:

® 'User/Group not found' — This message may appear if your LDAP repository is unavailable, or if the user/group has been deleted
after the permission was created.
® 'Caseincorrect. Correct case is: xxxxxx' — This message may appear if the upper/lower case in the permission does not match
the case of the username or group name. If you see a number of occurrences of this message, you should consider running the
routine supplied to fix the problem.
Related Topics
Space Permissions Overview
Users and Groups
Assigning Space Permissions
Page Permissions

Take me back to Confluence User's Guide

Users and Groups

A 'user' is the account for an individual who accesses Confluence.

New users are created by a Confluence administrator via the Administration Console. See Searching For and Managing Users for more
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information.

A Confluence administrator can also group users together into user groups for more convenient administration. This means that any
permissions you assign at the site, space and page levels can be assigned to a whole group. A user in one of these groups will automatically
be granted all permissions granted to the group.

There are two special groups in Confluence:

® Confluence-Administrators - This is a 'super-group’ and a user from this group has permission to do anything in the site regardless
of any other setting.

® Confluence-Users - This is the default group into which all new users are assigned. Permissions you assign to this group will be
assigned to all newly signed-up users of Confluence.

Anonymous Users

Confluence treats all users who do not log in when they access Confluence as being 'Anonymous'. Administrators can assign permissions to
this group separately.

#) Overlapping group and user permissions
When a user is assigned more than one permission, the most powerful permission will prevail.
Further explanation:

® A user may be assigned a permission specifically to their username. They may also be assigned a permission by
belonging to a group, or even several groups.

® The user will then be able to perform all functions assigned to them.

® So if a user is allowed to do something over and above what the group can do, the user will be able to do it. And if
the group is allowed to do something over and above the specific permissions granted to the user, the user will still
be able to do it.

Related Topics

Space Permissions Overview

Viewing Space Permissions

Assigning Space Permissions

Page Permissions

The Administrator's Guide to User Management in Confluence

Take me back to Confluence User's Guide

Searching for Users

This page describes how to use the ‘User Search' window, which appears when you click Choose Users or a user search % icon on a
Confluence page.

On this page:

Accessing the User Search

Using the Simple User Search

Using the Advanced User Search
Searching for Users in One or More Groups
Selecting One or More Users

Notes

Related Topics

Accessing the User Search

To access the 'User Search' window:

1. Click the user search link or icon when you are performing one of the following actions:
® When assigning space permissions, click the Q@ icon in the users section.

® When adding members to a group, click the Q‘ icon.
2. The simple 'User Search' window will appear, as shown below.

Using the Simple User Search

To search via the simple user search:
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. Select the User tab on the 'User Search' screen. (See above for instructions on accessing the screen.)

. If the Simple link is showing, click it. (If you see the Advanced link instead, then you're fine. The simple search is already active.)
. The simple user search screen will appear, as shown below.

Type some information about the user into the 'Search' box. You can type all or part of their username, full name or email address.
. Click Search.

. Confluence will return a list of matching users. See below for instructions on selecting one or more users.

oA WN R

Screenshot: Simple user search

User Search

User | QLN UG, T

User Details

Search for users by their user details eq: bob, Bob Smith, bob@example.com
Advanced

Using the Advanced User Search

The advanced user search allows you to specify the field in which your search term appears, i.e. username, full name or email address. You
may find this useful if you need to limit the number of users appearing in the search results.

To search via the advanced user search:

. Select the User tab on the 'User Search' screen. (See above for instructions on accessing the screen.)
. If the Advanced link is showing, click it. (If you see the Simple link instead, then you're fine. The advanced search is already active.)
. The advanced user search screen will appear, as shown below.
. Complete one or more of the following fields:
® User Name — Enter all or part of the person's username i.e. their login id, e.g. 'joe’, or 'bloggs'.
® Full Name — Enter all or part of the person's name, e.g. 'joe bloggs', or 'bloggs', or ‘joe'.
® E-Mail — Enter all or part of the person's email address, e.g. ‘acme'
5. Click Search.
6. Confluence will return a list of matching users. See below for instructions on selecting one or more users.

A WN B

Screenshot: Advanced user search

User Search

User | L UTETEL T

User Details
User Name Full Name E-Mail
Simple

Searching for Users in One or More Groups
You can also list the users who appear in a particular group or in a set of groups.
To search for users in a particular group:

. Select the Membership tab on the 'User Search' screen. (See above for instructions on accessing the screen.)

The 'Group Membership' search screen will appear, as shown below.

. Type all or part of a group name into the 'Search' box.

. Click Search.

. Confluence will return a list of users belonging to any groups which match your search term.

In the example screenshot below, we entered a group name of 'dev'. The search results show all users belonging to the group
'developers' and all users belonging to the group 'developers-mates'.

abhwN R
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6. Now you can select one or more users, as described below.

Screenshot: Searching for users in a group

User Search

I!m Membership

Group Membership

Enter a group to list all its members

Listing members of developers, developers-mates

Check All [] User Full name Email
[ connie Connie Best connie@example.com
O =ally Sally Smith sally@example com
O jenny Jenny James Jenny@example.com

Select User(s) ]

Selecting One or More Users
After searching for users and receiving a list of names from Confluence, as described above, you can now select the user(s) you need.

To select one or more users:

1. Click the box next to the username(s) to select or unselect one or more users.
You can click Check All to select or unselect all users.

2. Click Select User(s).
3. The 'User Search' window will close and the selected users will appear on the screen which you were using before you accessed the

user search.

Screenshot: Selecting one or more users

User Search

User | giE ]800

User Details

o

Search for users by their user details eg: bob, Bob Smith, bob@example.com

Advanced

Check All ] User Full name Email
O cadmin Confluence Administrator admin@example com
O connie Connie Best connie@example.com
O jenny Jenny James Jenny@example.com
O sally Sally Smith sally@example.com

[ Select User(s) ]
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Notes

® Case sensitivity: The search is not case sensitive. You can enter either upper- or lower-case text, and it will make no difference to
the search results.
® Wild cards: The search allows the asterisk as a wild card, but you do not need to use it. The search results will be the same
whether you use a wild card or not. The wildcard functionality remains available for compatibility with older versions of Confluence.
® Multiple user directories: You may define multiple user directories in Confluence, so that Confluence looks in more than one place
for its users and groups. For example, you may use the default Confluence internal directory and also connect to an LDAP
directory server. In such cases, you can define the directory order to determine where Confluence looks first when processing
users and groups. Here is a summary of how the directory order affects the processing:
® The order of the directories is the order in which they will be searched for users and groups.
® Changes to users and groups will be made only in the first directory where the application has permission to make changes.

See Managing Multiple Directories.
® Crowd and the user search: If you are using Atlassian's Crowd for user management, you will need Crowd 1.5.1 or later to use the

'Simple’ option in the user search. If your version of Crowd does not support the simple user search, you will see only the 'Advanced’
search form.

Related Topics

Searching Confluence

Setting a Page's Restrictions
Assigning Space Permissions
Adding or Removing Users in Groups

Take me back to Confluence User's Guide

Working with Confluence Gadgets

This section introduces the concept of gadgets in Confluence and provides an outline on how to use gadgets in Confluence and other web
applications.

On this page:
® [ntroduction to Gadgets in Confluence
® Using Gadgets in Confluence
® Adding Confluence Gadgets in Other Applications
® Adding a Confluence Gadget to JIRA
® Adding a Confluence Gadget to Non-Atlassian Web Applications

® Confluence Gadgets
® Related Topics

Introduction to Gadgets in Confluence

A gadget is a small object (i.e. a piece of functionality) offering dynamic content that can be placed into the page of:
® An Atlassian application's website, such as a Confluence page or blog post or a JIRA 4.0+ dashboard.
® A third-party application's website, such as iGoogle or Gmail. (But see the limitations on using Confluence gadgets in other
applications.)

Gadgets allow interactions between Confluence and other compatible websites. Confluence interacts with gadgets that support the
OpenSaocial specification.

For more information about Atlassian gadgets, please refer to the introduction to Atlassian gadgets and the big list of
Atlassian gadgets.

Using Gadgets in Confluence

You can place any gadget that complies with the OpenSocial specification from an external source, such as iGoogle or other Atlassian
applications such as JIRA 4.0+, onto a Confluence page or blog post. To add a gadget to a page, use the Confluence macro browser to add
a Gadget macro.

See the page on adding JIRA gadgets to a Confluence page.

Adding Confluence Gadgets in Other Applications

You can add a Confluence gadget to a JIRA dashboard or another Confluence site. In principle, you can also put a Confluence gadget on
any other OpenSocial-compliant website such as iGoogle or Gmail. See the limitations on using Confluence gadgets in other applications.

Adding a Confluence Gadget to JIRA
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See Adding a Confluence Gadget to a JIRA Dashboard.

Adding a Confluence Gadget to Non-Atlassian Web Applications

For instructions on how to add Confluence gadgets in another compatible non-Atlassian web application or container, refer to Configuring
Confluence Gadgets for Use in Other Applications.

Confluence Gadgets

The Confluence Gadgets topic explains the purpose of the ‘Confluence Gadgets' window and provides information about the gadgets which
are bundled with Confluence.

Related Topics

Gadget Macro

Working with the Macro Browser

Configuring Confluence Gadgets for Use in Other Applications
Adding a Confluence Gadget to a JIRA Dashboard
Confluence Gadgets

Configuring OAuth

All Atlassian gadgets

External Gadgets

Adding a Confluence Gadget to a JIRA Dashboard

JIRA 4.0 is the first major Atlassian application that can incorporate OpenSocial-compliant gadgets, such as Confluence gadgets onto its
dashboard. This page explains how to add a Confluence gadget to the dashboard of a JIRA 4.0+ installation.

To add a Confluence gadget to a JIRA dashboard, complete the sections below in order.
On this page:

Create an Application Link Between Confluence and JIRA

Finding a Confluence Gadget's URL

Adding a Confluence Gadget to a JIRA server's Gadgets Directory
Adding a Confluence Gadget to the JIRA Dashboard

Related Topics

Create an Application Link Between Confluence and JIRA

If your Confluence gadgets need to access user-restricted Confluence data, then your Confluence administrator must first establish an
Application Link between your Confluence site and the JIRA site. For more information about configuring an Application Link between
Confluence and other web applications, refer to Configuring OAuth Authentication for an Application Link.

If you only need to access anonymously accessible Confluence data, then you can proceed to Finding a Confluence Gadget's URL, below.

Finding a Confluence Gadget's URL

The Confluence gadget's URL is the gadget's XML specification file. These URLs look something like this:

..............................................................................................................................................................................

To find a Confluence gadget's URL:

1. Choose Browse > Confluence Gadgets. The 'Confluence Gadgets' window will open.
The 'Confluence Gadgets' window displays a list of available Confluence gadgets in your Confluence installation, as shown in the
screenshot below.
o By default, Confluence only includes a few gadgets. However, if your Confluence administrator has installed more Confluence
gadgets (typically as Confluence plugins), these will also appear in this list. If a scrollbar is available, use it to find the gadget you
want.

2. After finding your gadget, use the Gadget URL link to copy the gadget's URL to your clipboard. Many operating systems and
browsers allow you to do this by right-clicking the Gadget URL link and copying it using the context menu.

Screenshot: Finding a gadget's URL
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Confluence Gadgets

Using Confluence gadgets

This list shows the gadgets
currently available in your
Confluence site. You can embed
these gadgets into any other
website like JIRA 4, iGoogle, Gmail
or another Confluence site using the
gadget's URL. These websites must

be OpenSocial-compliant.

Using a Gadget's URL

To embed one of these gadgets into
another application, copy the
gadget's URL from its ‘Gadget URL
link. For example, right-click on the
link and copy it using the context
menu. Then, paste that URL into the
appropriate configuration area of the
other application.

(See our documentation for more
information).

Activity Stream
Gadget URL
By Atlassian

Gadget URL
By Atlassian

5 Quick and Eagy JG Fenctin

% Guick feterencs

® fuden 'S

applications.

&,’ Confluence: News

Gadget URL
By Atlassian Software

News about Confluence

Confluence QuickNav

Lists recent activity in a single project, or in all projects.

This gadget allows you to embed the Confluence QuickMav into other

Adding a Confluence Gadget to a JIRA server's Gadgets Directory

To add a Confluence Gadget to the Gadgets Directory in JIRA:

1. Go to the dashboard by clicking Dashboard at the top left of the screen.
2. The dashboard will appear. Click Add Gadget.
3

. The 'Add Gadget' screen appears, showing the list of gadgets in your directory. See screenshot 1 below. Click Add Gadget to

Directory.

B You will only see this button if you have administrator permissions for your dashboard.

4. The 'Add Gadget to Directory' screen appears. See screenshot 2 below. Paste the gadget URL (which you copied to your clipboard

above) into the text box.
5. Click Add Gadget.

6. The gadget appears in your gadget directory. (It will be highlighted for a short time, so that you can see it easily.)

Screenshot 1: Gadget directory with '‘Add Gadget to Directory' button

Gadget Directory

Charts (1)
Confluence (2)
JIRA(5)

Other (50)

Add Gadget to Directory

Dynamic Height
Gadget URL

Author unknown
Description not available

Hello World!
Gadaget URL
Author unknown
dezcription is here

JIRA Category

Gadget

Gadaget URL

By Atlaz=ian

JIRA Category Gadget
description

Learn more about gadgets Create your own gadget

Search

Fish
Gadget URL | Homepage

By evervdavgadget

Add a touch of nature to your
page with these hungry little
fish. Watch how they eagerhy
swim toward your mouse
hoping that you'll drop a few

118n Test

Gadaget URL

By Atlazsian
Dee=cription not available

JIRA Issues

Gadaget URL

By Atlassian

A list of recently created JIRA
lzsues

)

v
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Screenshot 2: Adding a gadget to the directory

Add Gadget to Directory

By adding a gadget to the directory, you are making the gadget available for people to use on their dashboards.
Only add gadgets that you trust! Gadgets can allow unwanted or malicious code onto your web page.

You can add gadgets from Atlassian applications such as Confluence, JIRA and athers. You can also add gadgets
from other websites such as iGoogle. Many public gadgets will work on an Atlassian dashboard. Some gadgets may
rely on specific iGoogle features that will not work properly on Atlassian dashboards. In that case, you can simply
remove the gadget from the directory.

A gadgets URL looks something like this: hitp://fexample com/my-gadget-location/my-gadget xmi

Type or paste the gadget's URL below.
-ation-gadget-spec-provider/application-gadget.xml|

Find more gadgets to add. | You can create your own gadgets! Learn how.

Adding a Confluence Gadget to the JIRA Dashboard

In the procedure below, 'your Atlassian dashboard' and 'your Atlassian application' refers to the JIRA Dashboard and
application, respectively.

You can add a gadget from the directory of gadgets that are available to your Atlassian application.

To add a gadget to your Atlassian dashboard,

WN P

. Go to the dashboard by clicking the '‘Dashboard’ link or the 'Home' link at the top left of the screen.
. The dashboard will appear, looking something like screenshot 1 below. Click 'Add Gadget'.
. The 'Add Gadget' screen will display a list of available gadgets in your gadget directory, as shown in screenshot 2

below. Find the gadget you want, using one or more of the following tools:
® Use the scroll bar on the right to move up and down the list of gadgets.
® Select a category in the left-hand panel to display only gadgets in that category.
® Start typing a key word for your gadget in the 'Search' textbox. The list of gadgets will change as you type,
showing only gadgets that match your search term.

. When you have found the gadget you want, click the 'Add it Now' button to add the gadget to your dashboard.

Screenshot 1: An Atlassian dashboard
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Add Gadget at
Reference Implementation
Admin Gadget URL -
By Atlassian
Bamboo Atesting gadget provided
by the Atlassian Gadgets
Charts Reference Implementation
Clover
Confluence n oy ) Date & Time
D ! oer Gadaet URL
Crowd * ™. 29 By James L.
Crucible Tog 8 Add a clock to your page.

Click editto change itto the

External Content color of your choice.
Remaove
S

JIRA Directory Gadget

Gadget URL

By Atlassian
Directory Gadget
description

Other

Add Gadget to Directory

257



Confluence 4.0 Documentation

-ﬂ Adding a Gadget to the Directory of Available Gadgets

You need to have administrator privileges to add a gadget to the list of available gadgets. If you have permission to add
gadgets to and remove gadgets from the directory itself, you will see the 'Add Gadget to Directory' and 'Remove’ buttons
on the '‘Add Gadget' screen. Please refer to the Gadgets and Dashboards Administration Guide.

Related Topics

All Atlassian gadgets

Configuring Confluence Gadgets for Use in Other Applications

This page tells you how to add a Confluence gadget to another (external) application. The instructions and examples given in this topic focus
on adding and using Confluence Gadgets in other web applications.

1. Atlassian support does not cover gadgets on external sites like iGoogle and Gmail

In principle, you should be able to add Atlassian gadgets to iGoogle, Gmail and other external sites that support
OpenSocial gadgets. However, these external integrations are experimental at this stage and we have encountered
problems with them. Please do have fun playing around with them, but be aware that Atlassian does not support the use of
Atlassian gadgets on iGoogle, Gmail or other external web sites. See the detailed section on gadget limitations.

Gadgets that display information from Atlassian applications, such as Confluence, should be able to run on iGoogle, Gmail and other web
applications that provide OpenSocial containers. Below are specific instructions for iGoogle and Gmail. You can experiment by adding a
Confluence gadget to other web sites and applications, such as a Ning community like The Content Wrangler.

On this page:

Overview of Adding a Confluence Gadget to Another Web Application
Finding a Confluence Gadget's URL

Adding an Atlassian Gadget to iGoogle

Adding an Atlassian Gadget to Gmail

Limitations and Support

Related Topics

Overview of Adding a Confluence Gadget to Another Web Application

The exact procedure for adding a Confluence gadget depends on the application where you want to add the gadget. The basic steps are the
same:

1. Find the Confluence gadget's URL, i.e. the URL for the gadget's XML specification file.
2. Ensure one of the following two mandatory (typically one-off) procedures have been conducted:
® An OAuth relationship between Confluence (as the 'service provider') and the other web application (as the ‘consumer') has
been established. Refer to Configuring OAuth for more information about OAuth and instructions on establishing these
relationships.
® A Trusted Applications relationship between Confluence and JIRA has been established. Refer to Configuring Trusted
Applications in the JIRA documentation for more information about establishing these relationships.
3. Follow the procedure provided by the external web application where you want to add the Confluence gadget.

Finding a Confluence Gadget's URL

The Confluence gadget's URL is the gadget's XML specification file. These URLs look something like this:

To find a Confluence gadget's URL:

1. Choose Browse > Confluence Gadgets. The '‘Confluence Gadgets' window will open.
The 'Confluence Gadgets' window displays a list of available Confluence gadgets in your Confluence installation, as shown in the
screenshot below.
o By default, Confluence only includes a few gadgets. However, if your Confluence administrator has installed more Confluence
gadgets (typically as Confluence plugins), these will also appear in this list. If a scrollbar is available, use it to find the gadget you
want.

2. After finding your gadget, use the Gadget URL link to copy the gadget's URL to your clipboard. Many operating systems and
browsers allow you to do this by right-clicking the Gadget URL link and copying it using the context menu.
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Screenshot: Finding a gadget's URL

Confluence Gadgets

Using Confluence gadgets

This list shows the gadgets
currently available in your
Confluence site. You can embed
these gadgets into any other
website like JIRA 4, iGoogle, Gmail
or another Confluence site using the
gadget's URL. These websites must

be OpenSocial-compliant.

Using a Gadget's URL

To embed one of these gadgets into &L
another application, copy the
gadget's URL from its ‘Gadget URL
link. For example, right-click on the
link and copy it using the context
menu. Then, paste that URL into the
appropriate configuration area of the
other application.

(See our documentation for more
infarmation).

Activity Stream

Gadaget URL

By Atlassian

Lists recent activity in a single project, or in all projects.

Confluence QuickNav

Gadget URL

By Atlassian

This gadget allows you to embed the Confluence QuickMav into other
applications.

Confluence: News

Gadget URL
By Atlassian Software

MNews about Confluence

Adding an Atlassian Gadget to iGoogle

You can customise your iGoogle home page by

adding gadgets and moving them around on the page.

To add an Atlassian gadget to your iGoogle page:

A WNPE

. First find the gadget's URL as described above.

. Go to iGoogle and log in if you have a username and password.
. Click Add stuff near the top right of the iGoogle page.

. The Google gadget directory will appear, showing a list of available gadgets. Click Add feed or gadget in the right-hand panel.

£ Add feed or gadget
Type or paste the URL below:

http://

Information for Feed owners - Developers

5. A text box will open, as shown above. Enter or paste the gadget's URL from your clipboard into the textbox and click Add.

6.

Adding an Atlassian Gadget to Gmail

Go back to your iGoogle home page. The gadget will appear on your iGoogle page.

You can add gadgets to the left-hand panel of your Gmail page.

To add an Atlassian gadget to your Gmail page:

. Log in to Gmail.

A WNPE

experimental features in Gmail.

o o

. First find the gadget's URL as described above.

. Click Settings near the top right of the Gmail page. The Gmail settings page will appear.
. Click the Labs tab. The Gmail Labs page will appear. This is a laboratory area or testing ground where Google allows you to use

. Scroll down to find the feature called 'Add any gadget by URL".
. Select the Enable option, as shown here:

Add a gadget by its URL;

Add

Add any gadget by URL
by Dan P and Dong C

Adds a "Gadgets” tab to Settings, where you'll be able to specify the
URL of any gadget. This gadget will show in a box in the left
column.

ﬂ Enable

(7| Disable

Send feedback

7. Click Save Changes.

8. A new Gadgets tab will appear on your 'Settings' page. Click the Gadgets tab. The ‘Gadgets' page will appear, as shown in the
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screenshot below.
9. Enter or paste your gadget's URL into the Add a gadget by its URL box, then click Add.
10. The gadget will appear in the left-hand panel of your Gmail page, as shown in the screenshot below.

Screenshot: Adding a gadget to Gmail
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Limitations and Support

& Atlassian support does not cover gadgets on external sites like iGoogle and Gmail
In principle, you should be able to add Atlassian gadgets to iGoogle, Gmail and other external sites that support
OpenSocial gadgets. However, these external integrations are experimental at this stage and we have encountered

problems with them. Please do have fun playing around with them, but be aware that Atlassian does not support the use of
Atlassian gadgets on iGoogle, Gmail or other external web sites. See the detailed section on gadget limitations.

Related Topics

The big list of Atlassian gadgets

Confluence Gadgets

This page describes the purpose of the 'Confluence Gadgets' dialog and how to access it, and provides information about the gadgets that
are bundled with Confluence.

Gadgets:
® Interact with and provide access to data in your Confluence installation
® Can be used externally such as on a JIRA 4+ server's dashboard, a page or blog post of another Confluence server, or any
compatible page on a web site that accepts gadgets, such as iGoogle. (But see the limitations on using Confluence gadgets in other
applications.)
On this page:
® The Confluence Gadgets Dialog

® Confluence Gadgets
® Related Topics
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The Confluence Gadgets Dialog

The 'Confluence Gadgets' dialog displays a list of all the Confluence gadgets available in your Confluence installation. The Confluence
gadgets bundled with Confluence are described below. Any additional Confluence gadgets installed by your Confluence administrator
(typically as Confluence plugins), will also appear in this list.
To access the Confluence Gadgets dialog:

® Choose Browse > Confluence Gadgets. The ‘Confluence Gadgets' dialog will open.
Refer to Adding a Confluence Gadget to a JIRA Dashboard or Configuring Confluence Gadgets for Use in Other Applications for more

information on adding Confluence gadgets to external applications. A Confluence gadget can also be used within the same Confluence
installation, by adding it to a page or blog post using the gadget macro.

Screenshot: The Confluence Gadgets dialog

Confluence Gadgets

Using Confluence gadgets s Activity Stream
s - Gadaet URL
This list shows the gadgets By Atlassian

currently available in your
Confluence site. You can embed
these gadgets into any other
website like JIRA 4, iGoogle, Gmail Al o 1 confluence QuickNav
or another Confluence site using the ] Quict s Gadget URL

Lists recent activity in a single project, or in all projects.

gadget’s URL. These websites must By Atlassian

be OpenSocial-compliant. This gadget allows you to embed the Confluence QuickNav into other
applications.

Using a Gadget's URL

To embed one of these gadgets into L Confluence: News

another application, copy the * Gadget URL

gadget's URL from its ‘Gadget URL' By Atlassian Software

link. For example, right-click on the News about Confluence

link and copy it using the context
menu. Then, paste that URL into the
appropriate configuration area of the
other application.

(See our documentation for more
infarmation).

Confluence Gadgets

This following table lists the gadgets which are bundled with Confluence. Click the name of the gadget for more information.
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Name Description

Confluence The Confluence page gadget allows you to show content from a page on your Confluence site in a gadget. You can

Page optionally configure the gadget to display links to view and/or edit the page on your Confluence site. The page gadget can
Gadget also be displayed in canvas view, so that it takes up all of the space provided by your dashboard.

Activity The activity stream gadget is similar to the recently updated macro and shows a list of the most recently changed content
Stream within your Confluence site.

Gadget

Confluence The Confluence news gadget is an example of a 'news feed' gadget that shows a list of recent Confluence Product Blogs
News and events at Atlassian.
Gadget

Confluence The Confluence QuickNav gadget provides the Quick Navigation Aid functionality for searching the Confluence site. For
Quicknav more information on how to use this feature, refer to the Quick Navigation Aid section of Searching Confluence.
Gadget

Related Topics
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Adding a Confluence Gadget to a JIRA Dashboard

Configuring Confluence Gadgets for Use in Other Applications

Gadget Macro

The big list of Atlassian gadgets

Activity Stream Gadget

The activity stream gadget is similar to the recently updated macro and shows a list of the most recently changed content within your
Confluence site.

o For instructions on how to use Confluence gadgets in your applications, please see Confluence Gadgets.

In addition to showing a list of most recently changed content, the activity stream gadget also provides the following features:

® The ability to add comments to pages and blog posts, by clicking the '‘add comment' icon at the top-right of an added or edited page
or blog post in the activity stream.
® The ability to reply to a comment by clicking the 'add comment' icon at the top-right of a comment in the activity stream.

® Activities are grouped by separate date.

® An RSS feed link to its content in the top-right corner of the gadget.

Screenshot: Adding a Comment in the Activity Stream Gadget
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Activity Stream Gadget Properties

Properties are settings for Confluence gadgets that allow the user to control the content or presentation of data retrieved by the gadget.
These are similar to a Confluence macro's parameters. The table below lists relevant properties for this gadget.

Property

Title

Projects

Username

Number
of Entries

Refresh
Interval

Required?

Yes

No

No

No

No

Default

None

None specified
(i.e. display
content in all
spaces)

None specified
(i.e. display
content by all
users)

10

Never/false

Confluence News Gadget

Description

Adds a title to the top of the Activity Stream.

Filters the content by space. This gadget will display only the pages etc. which belong
to the space(s) you specify here.

Filters the results by user. The macro will display only the pages etc. which were last
modified by the user(s) you specify here.

You can specify one or more user, separated by a comma or a space.

Specify the maximum number of results to be displayed. A maximum of 10 results will
be displayed by default. The maximum value that this property can accept is 100.

Specify the time interval between each 'refresh' action undertaken by the activity
stream gadget. A refresh makes the activity stream gadget reflect any new activity that
has been conducted on the Confluence site.

The Confluence news gadget is an example of a 'news feed' gadget that shows a list of recent Confluence Product Blogs and events at

Atlassian.

o For instructions on how to use Confluence gadgets in your applications, please see Confluence Gadgets.

Clicking an item in the Confluence news gadget takes you directly to the selected blog post of the Confluence Product Blogs feed or event
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details on the events at Atlassian page.

Clicking More news takes you to the Confluence Product Blogs feed page and clicking More events takes you to the events at Atlassian
page.

Screenshot: Using the News Gadget
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Confluence: News Gadget Properties

Properties are settings for Confluence gadgets that allow the user to control the content or presentation of data retrieved by the gadget.
These are similar to a Confluence macro's parameters. The table below lists relevant properties for this gadget.

Property Required? Default Description

Show News? No True Shows a short list of the most recent Confluence Product Blogs.
Show Events? No True Shows a short list of the most recent events at Atlassian.

Show Banners? No True Shows any banner advertisements (if available).

Confluence Page Gadget

The Confluence page gadget allows you to show content from a page on your Confluence site in a gadget. You can optionally configure the
gadget to display links to view and/or edit the page on your Confluence site. The page gadget can also be displayed in canvas view, so that i
takes up all of the space provided by your dashboard.

o For instructions on how to use Confluence gadgets in your applications, please see Confluence Gadgets.

=

Macros that work with the page gadget

Please note, not all macros work with the page gadget. Please refer to the Working Macros section below for more
information.
On this page:

® Confluence Page Gadget Properties
® Working Macros
® Related Topics

Screenshot: The Confluence page gadget displaying a sample page
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Chocolate

Recently Updated

Chocolate is a popular ingredient and available in many
types. Different forms and flavors of chocolate are
produced by varying the quantities of the different
ingredients. Other flavors can be obtained by varying the
time and temperature when roasting the beans.

©® Unsweetened chocolate
Unsweetened chocolate is pure chocolate liquor,
also known as bitter, baking chocolate or cooking
chocolate, mixed with some form of fat to produce a
solid substance. It is unadulterated chocolate: the
pure, ground, roasted chocolate beans impart a
strong, deep chocolate flavor. With the addition of
sugar, however, it is used as the base for cakes,
brownies, confections, and cookies.

|j Chocolate updated by Andrew Lui (view change) 2 minutes ago

|j Doc Sprint chocolate updated by Andrew Lui (view change) 2 minutes ago

|&] Chocs1. jpg attached by Andrew Lui 16 minutes ago
Mare

@ View ¢ Edit

Confluence Page Gadget Properties

Properties are settings for Confluence gadgets that allow the user to control the content or presentation of data retrieved by the gadget.
These are similar to a Confluence macro's parameters. The table below lists relevant properties for this gadget.

Property Required? Default

Space No None

Page Yes None
Show No Yes

View

Link

Show No No

Edit

Link

Refresh No Never/false
Interval

Working Macros

Description

Specify the space that your desired page is located in. Suggestions will display in a dropdown
when you start typing.
(Note, this property is only used to make searching for pages easier. It is not required.)

Specify the page that you want to display in your gadget. Suggestions will display in a dropdown
when you start typing.

Select whether to display a link to view the page on your Confluence site. Clicking the link will
open the page in Confluence.

Select whether to display a link to edit the page on your Confluence site. Clicking the link will
open the page for editing in Confluence.

Specify the time interval between each 'refresh’ action undertaken by the page gadget. A refresh
makes the activity stream gadget reflect any new activity that has been conducted on the
Confluence site.

The Confluence page gadget will only render a subset of the macros that are used in Confluence correctly. Refer to the table below for the
list of macros that work and do not work with the page gadget and known limitations.
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Some of the issues with macros in the page gadget can be worked around, if you are comfortable developing in
Confluence. Please see Troubleshooting Macros in the Page Gadget for more information.

Key:

Works with the page gadget

* Partially works with the page gadget
E Does not work with the page gadget

Macro Works Limitations
with
page
gadget?
Activity ﬁ You cannot have another gadget embedded within the Confluence Page Gadget
Stream
Anchor * Opens in a hew page
(within a
page)
Attachments N/A

Blog Posts N/A
Chart N/A
Children N/A
Display

Content By N/A
Label

Content By N/A
User

Excerpt N/A
Gallery N/A
Include N/A
Page

Info N/A
Labels List N/A
Livesearch E N/A
Note N/A
Metadata N/A
Metadata N/A
Summary
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Pagetree ﬁ N/A

Search

Pagetree N/A

Panel N/A

Quick Nav ﬁ You cannot have another gadget embedded within the Confluence Page Gadget
Recently N/A

Updated

RSS Feed N/A

Section & N/A

Column

Spaces List N/A

Table of * Works, however links will be opened in a new browser window when clicked.
Contents

Tasklist * Tasks can be viewed but not added/edited.

View File * Works, but you may need to refresh the gadget the first time (see CONF-19932).
(PDF or

PPT)

Widget * Only works for some content:

Connector

® Works: blip.tv, Episodic, Flickr, Google Calendar, presentations on Google Docs, MySpace Video,
Scribd, Skitch.com, SlideRocket, SlideShare, Viddler, Vimeo, YouTube, Dailymotion, Metacafe,
FriendFeed, Yahoo Video, Wufoo HTML Form Builder

® Does not work: FriendFeed, Google Gadgets, Google Video (service discontinued), Twitter,
Widgetbox, DabbleDB, BackType

Related Topics

Confluence Gadgets

Confluence Quicknav Gadget

The Confluence QuickNav gadget provides the Quick Navigation Aid functionality for searching the Confluence site. For more information on
how to use this feature, refer to the Quick Navigation Aid section of Searching Confluence.

o For instructions on how to use Confluence gadgets in your applications, please see Confluence Gadgets.

Screenshot: Using the QuickNav Gadget
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|Examp|e|

Example Page
Example Human Resources Page
Examples

Example Sales Team Page
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Example Development Team Page

Example Excel 2007 Document.xlsx

iz

Example PDF Document. pdf

&

Example Space

‘=4, Search for ‘Example’

Confluence QuickNav Gadget Properties

This gadget has no properties and cannot be customised.

Adding JIRA Gadgets to a Confluence Page

This is a summary of steps of the steps required to add a JIRA gadget to a Confluence page:
® |f your JIRA site does not allow anonymous access, your JIRA administrator will need to configure JIRA to trust Confluence via
Application Links. See the JIRA administrator's guide.
® Your Confluence administrator will need to add the JIRA gadget URL to the list of authorised external gadgets in Confluence. See
the Confluence administrator's guide.
* Now you can add the gadget to a wiki page in Confluence using the Macro Browser. See the Confluence user's guide to the Macro
Browser and the Gadget macro.

Note that the Confluence Gadget macro is a specific type of macro which is used to display a gadget in a Confluence page - so once you
have configured external gadgets in the Confluence Administration Console, they will appear in the Macro Browser.

Related Topics

All Atlassian gadgets

External Gadgets

Working with Macros

Using a macro, you can add extra functionality or include dynamic content in a page. For example, the Attachments macro will list a page's
attachments in the page itself, so that readers do not have to visit the Attachments tab.

On this page:

Including a Macro in your Page

Macros Shipped with your Confluence Installation
Information about Other Macros

Writing your own Macros

Related Topics

Including a Macro in your Page

Including Macros with the Macro Browser

To insert a macro into a page using the Macro Browser:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.
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For a complete description of the macro browser, see Working with the Macro Browser.

Macro Parameters

Many macros allow you to include optional parameters to control the macro's output.

With the Attachments Macro, for instance, you have two optional parameters:

® To specify the file formats of the attachments displayed.
® To choose whether or not you want old versions of the attachments displayed.

Macro Placeholders

Macro placeholders are displayed in the editor where you have added a macro to the page.

When editing a page, you can:

® Double-click a macro placeholder to open the Macro Browser (or click on the placeholder and choose Edit), where you can edit the

macro's parameters.

® Select a macro placeholder to cut, copy and paste the macro.

Macros Shipped with your Confluence Installation

When you download your Confluence installation file, many macros are shipped with the download. Below is a list of the macros currently
shipped with Confluence. Click a macro name for details of the usage, including optional parameters and examples.

Attachments Macro

Blog Posts Macro

Change-History Macro

Chart Macro

Cheese Macro

Children Display Macro

Code Block Macro

Column Macro

Content by Label
Macro

Create Space Button
Macro

Excerpt Macro

Excerpt Include Macro

Expand Macro

Favourite Pages Macro

Gallery Macro

Global Reports Macro

HTML Macro
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Displays a list of attachments belonging to the current page.

Lists the most recent news items in the space.

Displays a history of updates made to a page.

Displays a chart based on tabular data.

Displays the words "I like cheese!"

Displays the children and descendants of the current page.

Displays code in your document with the appropriate syntax highlighting.

Used with the Section Macro. Defines columns within the page.

Renders a list of content associated with specific labels.

Renders a create space button linked to the create space page.

Define a part of a page as the page's 'excerpt' which can then be displayed in another page.

Allows you to display an excerpt from another page within the current page.

Displays an expandable/collapsible section of text.

Displays a list of your favourite pages.

Forms a thumbnail gallery of all images attached to a page.

Renders a list of links to global reports within a table.

Renders your specified HTML code within the current page.
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HTML Include Macro

IM Presence Macro

Include Page Macro

Info Macro

JIRA Macro

JIRA Issues Macro

JIRA Portlet Macro

JUnit Report Macro

Livesearch Macro

Loremipsum Macro

Multimedia Macro

Navmap Macro

Noformat Macro

Note Macro

Panel Macro

Pagetree Macro

Pagetree Search Macro

Profile Picture Macro

Recently Updated
Macro

Recently Used Labels

Macro

Related Labels Macro

RSS Feed Macro

Search Macro

Section Macro

Space Details Macro

Spaces List Macro

Includes the content of an external HTML file into a Confluence page.

Displays graphically when a contact is online.

Inserts the contents of the specified page into the current one.

Displays a block of text in a blue highlight box.

Displays one or more JIRA issues on your Confluence page.

Displays a list of JIRA issues in a page.

Displays a JIRA dashboard portlet in Confluence.

Display a summary of JUnit test results.

Add a dynamic search box to a wiki page.

Display a few paragraphs of pseudo-Latin text.

Displays videos, animations and more, sourced from a file attached to a Confluence page and displayed on
your page.

Renders the list of pages associated with a specified label as a navigable map.

Displays a block of text in monospace font.

Displays a block of text in a yellow highlight box.

Displays a block of text within a fully customisable panel.

Displays a dynamic, hierarchical list of pages starting from a specified parent (root) page.

Adds a search box to your Confluence page and searches a hierarchy of pages starting from a specified
parent (root) page.

Displays a user's profile picture on a page.

Displays a list of recently changed content (pages, news items, comments, etc).

Lists labels most recently used in a specified scope (Global, Space, or Personal)

Lists labels frequently appearing on the same pages as the current page's labels.

Displays the contents of an RSS feed.

Searches Confluence, and includes the results in the page.

Used with the Column Macro to define columns within the page.

Includes the summary of a Confluence space in the page.

Displays a list of all spaces visible to the user.
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Status Macro Displays a coloured lozenge, useful for reporting project status.
Table of Contents Displays a table of contents from your page headings.
Macro

Table of Contents Zone  Displays a table of contents from a defined page 'zone'.

Macro

Tasklist Macro Displays a dynamic task list which can be modified in ‘'view' mode.

Tip Macro Displays a block of text in a green highlight box.

Userlister Macro Displays a list of Confluence users, from an optional group.

View File Macro Embeds an Office document into your Confluence page.

Warning Macro Displays a block of text in a red highlight box.

Web-Widget Macro Same as the Widget macro.

Welcome Message Includes the Confluence site welcome message.

macro

Widget Macro Displays videos, slide shows, twitter chats, documents and more, sourced from other web sites and

displayed on your Confluence page.

Information about Other Macros

Macros Provided by Plugins or User Macros

Other macros are available as plugins or as user macros, and can be installed by your Confluence administrator.
Customers using Adaptavist macros or plugins might be interested in the Adaptavist's Confluence user guide.
Some examples are:

® {sp-list} macro, provided by the Confluence SharePoint Connector — full documentation in the SharePoint Connector space.
® {float} macro and others, provided by the Composition plugin — full documentation by CustomWare.

Macros that Do Not Work

Some macros were never intended for external use, and we have always recommended that you do not add them to a wiki page.
Nevertheless, it is possible that some Confluence sites have these macros on some pages. Please note that these macros no longer work in
Confluence 3.4 onwards. They were part of the Plugin Repository, which we have now replaced with a new plugin manager.

These macros no longer work:

{repository-plugin}
{recentlyupdated-plugins}
{popular-plugins}
{download-stat}
{confluence-status}
{plugin-status}
{plugin-repository}
{plugins-supported}

Writing your own Macros

To learn how to write your own macro, take a look at the following documentation:

® User macros are simple template-like macros that allow you to create simple formatting macros using the Confluence web interface.
Read more about Writing User Macros.
® The Confluence Plugin Guide tells you how to develop a plugin for Confluence.

Related Topics
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Working with the Macro Browser
Atlassian Plugin Exchange
Installing Plugins and Macros

Take me back to the Confluence User's Guide.

Anchor Macro

ﬁ The Anchor Macro is documented in Working with Anchors.

Attachments Macro
See Displaying a List of Attachments in a Page.

Blog Posts Macro

The Blog Posts macro allows you to display blog posts on a Confluence page. Clicking on a title takes you to the blog post. The Blog Posts
macro generates output like that in the screenshot below:

On this page:

® Using the Blog Posts Macro
® Parameters
® Related Topics

Using the Blog Posts Macro
To add the Blog Posts macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Parameters

When editing, you can click on the macro placeholder and choose Edit to display the parameters for this macro in the Macro Browser.

Parameters are options that you can set for Confluence macros to control the content or format of the macro output. The table below lists
parameters for this macro that can be set in the Macro Browser.

Parameter  Default Description

Content entire Available values:

Type to

Display ® titles — Display a list of blog posts, showing titles only.

® excerpts — Display short excerpts from each blog posts. ‘Read more..." links to the full blog
post, if the content is more than 500 characters long.

Time no limit Specify how far back in time Confluence should look for the blog posts to be displayed.
Frame

Available values:

m — Minutes
h — Hours, so '12h' displays blog posts created in the last twelve hours.

d — Days, so '7d' displays blog posts created in the last seven days.
w — Weeks

271


https://plugins.atlassian.com/

Confluence 4.0 Documentation

Restrict
to these
Labels

Restrict
to these
Authors

Restrict
to these
Spaces

Maximum
Number
of Blog
Posts

Sort By

Reverse
Sort

None

None

@self, i.e. the
space which
contains the
page on which
the macro is
coded

15

creation

false

Related Topics

Working with Macros
Working with Blog Posts

Filter the results by label. The macro will display only the blog posts which are tagged with the label(s)
you specify here.

You can specify one or more label values, separated by a comma or a space.

® To exclude content which matches a given label, put a minus sign (-) immediately in front of that
label value. For example: If you specify a label value of -badpage you will get only content
which is not labelled with ‘badpage’.

® To indicate that the results must match a given label value, put a plus sign (+) immediately in
front of that label value. For example: If you specify a label value of +superpage, +goodpage
you will get only content which has at least two labels, being 'superpage' and ‘goodpage’.

Filter the results by author. The macro will display only the blog posts which are written by the author(s)
you specify here.

You can specify one or more authors, separated by a comma.

This parameter allows you to filter content by space. The macro will display only the pages which belong
to the space(s) you specify here.

You can specify one or more space keys, separated by a comma or a space.

® To exclude content in a specific space, put a minus sign (-) immediately in front of that space
key. For example: If you specify a space key of -BADSPACE you will get only content which is
not in the BADSPACE.

® To indicate that the results must come from a specific space, put a plus sign (+) immediately in
front of that space key. For example: If you specify a space key of +GOODSPACE you will get
only content in GOODSPACE. (Note that this is not particularly useful, because each content
item belongs to one space only. If you put a plus sign next to one space key and list other space
keys too, the other space keys will be ignored.)

Special values:

® @self — The current space.

® epersonal — All personal spaces.

® @global — All global spaces.

® efavorite — The spaces you have marked as favourite.
® @favourite — The same as efavorite above.

® @all — All spaces in your Confluence site.

® « — The same as @all above.

o When specifying a personal space, remember to use the tilde (~) sign in front of the username, such
as ~jbloggs or ~jbloggs@example. com.

Specify the maximum number of results to be displayed. Note that the results are sorted first, and then
the maximum parameter is applied.

Specify how the results should be sorted. If this parameter is not specified, the sort order defaults to
descending order (newest first) based on the creation date.

Values:

® title — Sort alphabetically by title.
® creation — Sort by the date on which the content was added.
®* modified — Sort by the date on which the content was last updated.

Select to change the sort from descending to ascending order (oldest first). Use this parameter in
conjunction with the Sort By parameter. This parameter is ignored if the Sort By parameter is not
specified.

Take me back to the Confluence User's Guide.

Change-History Macro

The Change-History macro shows the history of updates made to a page — version number, author, date and comment. It displays this
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information inline, as shown in the following screenshot.

Screenshot: The Change-History Macro in Confluence

Version Date Comment

Current Version (v. 3) Apr 01, 2009 16:55 Conf Admin

v 2 Apr 01, 2009 13:09 Conf Admin

vl Apr 01, 2009 11:03 Conf Admin
On this page:

® Using the Change-History Macro
* Notes
® Related Topics

Using the Change-History Macro

To add the Change-History macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Notes

There are no parameters for this macro.

Related Topics

Working with Macros

Take me back to the Confluence User's Guide.

Chart Macro

The Chart macro allows you to display a chart based on tabular data. When you add the macro to a page, you:

® supply the data to be charted by the macro as a table in the placeholder of the macro.
® edit the macro parameters in the Macro Browser to configure the format of the chart.

Screenshots: A table of data in the Chart macro placeholder, and the resulting chart image.
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On this page:

® Using the Chart Macro
® Parameters
® Examples
® Pie Chart
Bar Chart
3D Bar Chart
Time Series Chart
XY Line Chart
XY Area Chart
® Area Charts
® Related Topics

Using the Chart Macro

To add the Chart macro to a page:

1. When editing the page, use autocomplete to add the Chart macro to the page. (Type '{’ then begin typing the name of the macro,
and choose it from the list of suggestions.)

. Enter your chart data as one or more tables in the body of the macro placeholder (see the screenshot above)

. Edit the macro and select a chart type using the Type parameter (see below).

. Make other parameter settings, in the Macro Browser, as described below.

. Click Preview to check that the chart appears as you expect.

. Finally, click Save to add the chart to your page.

O wWN

Parameters

Chart Type Parameters | Display Control Parameters | Title and Label Parameters | Data Specification Parameters | Colour Parameters |
Axis Parameters | Pie Chart Parameters | Attachment Parameters

Chart Type Parameters

These parameters determine the type of chart to display and the way the chart looks.

Parameter Default Description

Type pie The type of chart to display. XY charts have numerical x- and y-axes. The x values may
optionally be time-based (see the Time Series parameter).

Standard — pie, bar, line, area
XY Plots — xyArea, xyBar, xyLine, xyStep, xyStepArea, scatter, timeSeries
Other — gantt (beta)

Display vertical Applies to area, bar and line charts.

Orientation
® vertical — y-axis is vertical
® horizontal — x-axis is vertical

Show in false Applies to area, bar and line charts.
3D
Stacked false Applies to area and bar charts.
Values
Show true Applies to line charts. Shapes are shown at each data point.
shapes
Opacity A percentage value between O (transparent) and 100 (opaque) that determines how
® 75 percent for 3D opaque the foreground areas and bars are.
charts

® 50 percent for
non-stacked area
charts

® 100 percent for all
other charts

Display Control Parameters

Parameter Default Description
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Width

Height

300

300

Display rendered false

data

Image format

png

Title and Label Parameters

Parameter
Chart Title

Chart Subtitle

Horizontal-axis Label

Vertical-axis Label

Show Legend

Data Specification Parameters

The width of the chart in pixels.
The height of the chart in pixels.

Sets whether to display the rendered body of the macro (usually the data tables). By default, the chart
data table isn't rendered.

® before — the data are displayed before the chart.
® after — the data are displayed after the chart.

The image format to be used for the chart.

* png
* ipg

Default Description

none The title of the chart.

none A subtitle for the chart, using a smaller font than for Title.
none The label for the x-axis (domain).

none The label for the y-axis (range).

true Show a legend or key.

The data for the chart is taken from tables found when the macro body is rendered. These options control how this data is interpreted. By
default, numeric and date values are interpreted according to the Confluence global default language (locale) formats. If conversion fails,
other languages defined in Confluence will be tried. Additional conversion options can be specified using the parameters below.

Parameter

Tables

Columns

Content
Orientation

Time
Series

Date
format

Time
Period

Language

Country
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Default

all first level
tables

all columns

horizontal

false

Confluence
language
defined
date
formats

Day

none

none

Description

Comma separated list of table ids and/or table numbers (starting at 1) contained within the body of the
macro that will be used as the data for the chart. If data tables are embedded in other tables, then table
selection will be required. This occurs when more complex formatting is done (for example using section
and column macros).

Comma separated list of column labels and/or column titles and/or column numbers for tables used for
chart data. This applies to all tables processed. Columns are enumerated starting at 1. Column label is the
text for the column in the header row. Column title is the (html) title attribute for the column in the header
row.

® vertical — data table columns will be interpreted as series.
® horizontal — data tables rows will be interpreted as series.

® true — the x values in an XY plot will be treated as time series data and so will be
converted according to date formats.

For time series data, the date format allows for additional customization of the conversion of data to date
values. If a Date format is specified, it will be the first format used to interpret date values. Specify a format
that matches the time series data. See simple date format.

The time period for time series data. Defines the granularity of how the data is interpreted. Valid values are:
Millisecond, Second, Minute, Hour, Day, Week, Month, Quarter, Year.

Use in combination with the Country parameter to form a locale. These additional number and date
formats will be used for data conversion before the default languages.
Valid values are 2 character ISO 639-1 alpha-2 codes.

Use in combination with the Language parameter to form a locale. Valid values are 2 character ISO 3166
codes.
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http://en.wikipedia.org/wiki/ISO_3166-1_alpha-2#Current_codes
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Forgive

true

Colour Parameters

® true — the macro tries to convert numeric and date values that do not totally match any of
the default or user-specified formats.

® false — enforce strict data format. Data format errors will cause the chart to not be
produced.

Colours are specified using hexadecimal notation or HTML colour names.

Parameter

Background Colour

Border Colour

Colours

Axis Parameters

Default Description
White Background of the chart.
no border  Border around the chart.

Comma-separated list of colours used to customise category, sections, and series colours.

Depending on the chart type, the range and domain axis may be customised. These values are automatically generated based on the data
but can be overridden by specifying one or more more of these parameters.

Parameter

Range
Minimum
Value

Range
Maximum
Value

Range
Axis Tick
Unit

Range
Axis
Label
Angle

Domain
Axis
Lower
Bound

Domain
Axis
Upper
Bound

Domain
Axis Tick
Unit

Domain
Axis
Label
Angle

Category
Label
Position

Date Tick
Mark
Position
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Default

none

none

none

none

none

none

none

none

none

start

Description

Range axis lower bound.

Range axis upper bound.

Range axis units between axis tick marks.

Angle for the range axis label in degrees.

Only applies to XY plots. Domain axis lower bound. For a date axis, this value must be expressed in the date
format specified by the Date format parameter.

Only applies to XY plots. Domain axis upper bound. For a date axis, this value must be expressed in the date
format specified by the Date format parameter.

Only applies to XY plots. Domain axis units between axis tick marks. For a date axis, this value represents a
count of the units specified in the Time Period parameter. The Time Period unit can be overridden by specifying
a trailing character: y (years), M (months), d (days), h (hours), m (minutes), s (seconds), u (milliseconds).

Only applies to XY plots. The angle for the domain axis label, in degrees.

Placement of the axis label text for categories.

up45 — 45 degrees going upward
up90 — 90 degrees going upward
down45 — 45 degrees going downward
down90 — 90 degrees going downward

Placement of the date tick mark.

® start — tick mark is at the start of the date period.
® middle — tick mark is in the middle of the date period.
® end — tick mark is at the end of the date period.
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Pie Chart Parameters

Parameter Default Description
Pie Section Show only the pie section Format for how pie section labels are displayed. The format uses a string with special
Label key value replacement variables:

® %0% is replaced by the pie section key.
® %1% is replaced by the pie section numeric value.
® %2% is replaced by the pie section percent value.

Example 1: "%0% = %1%" would display something like "Independent = 20"
Example 2: "%0% (%2%)" would display something like "Independent (20%)"

Pie Section No exploded sections Comma separated list of pie keys that are to be shown exploded. Note: requires
Explode jFreeChart version 1.0.3 or higher.

Attachment Parameters

These are advanced options that can be used for chart versioning, to enable automation and to improve performance. Use these options
carefully! Normally, the chart image is regenerated each time the page is displayed. These options allow for the generated image to be saved
as an attachment and have subsequent access re-use the attachment. This can be useful especially when combined with the Cache Pluginto
improve performance. Depending on the options chosen, chart images can be versioned for historical purposes.

Parameter Default Description

Attachment none The name and location with which the chart image will be saved as an attachment. The user must be
authorised to add attachments to the page specified.

® MattachmentName.png — the chart is saved as an attachment to the current page.

® page”attachmentName.png — the chart is saved as an attachment to the page name
provided.

® space:page”attachmentName.png — the chart is saved as an attachment to the page name
provided in the space indicated.

Attachment new Defines the the versioning mechanism for saved charts.
Version
® new — creates new version of the attachment.
* replace — replaces all previous versions of the chart. To replace an existing attachment, the
user must be authorized to remove attachments for the page specified.
® keep — only saves a new attachment if an existing export of the same name does not exist.
An existing attachment will not be changed or updated.

Attachment none Comment used for a saved chart attachment.
Comment
Thumbnail false

® true — the chart image attachment will be shown as a thumbnail.

Chart Type Parameters | Display Control Parameters | Title and Label Parameters | Data Specification Parameters | Colour Parameters |
Axis Parameters | Pie Chart Parameters | Attachment Parameters

Examples
Pie Chart

Parameters in Macro Browser Data Table in Macro Placeholder Rendered Chart

Type pie

Fish Type 2011
Chart Title Fish Sold 2011 o
Show Legend true Herring 9,500

Salmon 2,900

Tuna 1,500
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Fish Sold 2011

Herring salmon

Tuna

B Herring {9,500 - 68%)
mSalmon (2,200 - 21%) mTuna (1,500 - 11%)

Bar Chart

Parameters in Macro Browser Data Table in Macro Placeholder Rendered Chart

Type - Fish Sold

Fish Type 2010 2011

Chart Title Fish Sold
Show Legend true Herring 9,500 8,300 9,000
8,000
Salmon 2,900 4,200 7,000
Tuna 1,500 1,500 6,000
5,000
4,000
3,000
2,000
1,000
0
2010 2011
B Herring M Salmon W Tuna
3D Bar Chart
Parameters in Macro Data Table in Macro Placeholder Rendered Chart
Browser
Type bar
Show in 3D true 2009 | 2010 | 2011
Opacity 50 Revenue 124 318 411
Show Legend true

Expense 436 418 311
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Time Series Chart

Parameters in Macro

Browser

Type

Date
Format

Time
Period

Data
Orientation

Range
Axis

Lower
Bound

Show
Legend

XY Line Chart

Data Tables in Macro Placeholder

Time
Series Month
MMlyyyy
1/2011
Month
2/2011
vertical
3/2011
0
4/2011
5/2011
true
6/2011
7/2011
8/2011
9/2011

Revenue

31.8

41.8

51.3

33.8

27.6

49.8

51.8

77.3

73.8

10/2011 97.6

11/2011 101.2

12/2011 113.7

Parameters in Macro Browser

Type

xyLine

Month

1/2011

2/2011

3/2011

4/2011

5/2011

6/2011

7/2011

8/2011

9/2011

10/2011

11/2011

12/2011

2009

2010 2011

W Revenue W Expense

Rendered Chart

Expenses 110
1a0
41.1 a0
B0
43.8 70
&0
45.3 50
40
45.0
30
20
44.6
10
43.8 0
=
o
51.8 =
52.3
53.8
55.6
61.2
63.7

Data Table in Macro Placeholder = Rendered Chart

12

14

23

02jzo11y

10720114

11720114
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Show Legend true 45
Revenue 411 31.8 124

40
Expense 31.1 418 436 35
30
25
20
15

10

12 13 14 15 16 17 18 19 20 21 22 23

— R EvEnle = Expense

XY Area Chart

Parameters in Macro Browser Data Table in Macro Placeholder Rendered Chart
Type xyArea 45
12 14 23

Show Legend true
9 40

Revenue 41.1 318 124 35
Expense 31.1 41.8 436 30
25
20
15

10

12 13 14 15 16 17 18 19 20 21 22 23

& Fevenue & Expense

Area Charts
Example 1
Parameters in Macro Data Table in Macro Placeholder Rendered Chart
Browser
Type area
tisfacti 2 201 2011
Show Legend true Satisfaction 009 010 0
Width 300 Very satisfied 20 23 34
Height 300
Opacity 50 Satisfied 40 34 23

Dissatisfied 25 26 25
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Very 15 17 18
dissatisfied
2009 2010 2011
mVery satisfied m Satisfied m Dissatisfied
Very dissatisfied
Example 2
Parameters in Data Table in Macro Placeholder Rendered Chart
Macro Browser
Type area
i i 1a0
Show Legend frue Satisfaction 2009 2010 2011
90
Height 300 satisfied
il
Stacked Values true Satisfied 1 34 36 60
50
Dissatisfied 4 6 22 40
Very 2 7 12 A0
dissatisfied 20
10

2009 2010 2011

mVery satisfied m Satisfied m Dissatisfied
Very dissatisfied

Related Topics

Working with Macros

Take me back to the Confluence User's Guide.

Cheese Macro
The Cheese macro simply displays the words "I like cheese!"

You can use this macro to test the Confluence macro functionality. 6

Using the Cheese Macro
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To add the Cheese macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

The cheese macro renders the following message on the page: | like cheese!

There are no parameters for this macro.

Related Topics

Working with Macros

Take me back to the Confluence User's Guide.

Children Display Macro

Use the Children Display macro to display the child pages of a page and the descendents (childrens' children). Links to the children are
displayed as in the screenshot below:

Screenshot: The Children Display Macro in Confluence
Confluence allows you to collect and archive mail within each space individually.
all emails pertaining to a particular project on Confluence alongside it in the sam

Adding a Mail Account
Deleting Mail

Fetching Mail

Importing Mail

Linking to Mail
Manadging Mail Accounts
Restoring Mail

Viewing Mail

o Note that only pages for which you have 'View' permission will be displayed.

On this page:

® Using the Children Display Macro
® Parameters
® Related Topics

Using the Children Display Macro

To add the Children Display macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Parameters

When editing, you can click on the macro placeholder and choose Edit to display the parameters for this macro in the Macro Browser.

Parameters are options that you can set for Confluence macros to control the content or format of the macro output. The table below lists
parameters for this macro that can be set in the Macro Browser.

Parameter Default Description
Show false Select to display all descendents.
Descendants
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Parent Page current Specify the page to display children for, from either the current space or a
different space. Enter:

® /' —+to list the top-level pages of the current space, i.e. those
without parents.

® 'pagename' — to list the children of the specified page.

® 'spacekey:' — to list the top-level pages of the specified space.

® 'spacekey:pagename' — to list the children of the specified page
in the specified space.

Number of none Restrict the number of children displayed at the top level.
Children

Depth of none Enter a number to specify the depth of descendents to display.
Descendants

Heading Style none Choose the style used to display descendents.

Include false Display excerpts for the child pages, if they exist.

Excerpts

Sort Children Manual if manually ordered, Optional. Choose:

By otherwise alphabetical

® creation — to sort by content creation date
® title — to sort alphabetically on title
®* modified — to sort of last modification date.

Reverse Sort false Use with the Sort Children By parameter. When set, the sort order changes
from ascending to descending.

Related Topics

Working with Page Families
Working with Macros

Take me back to the Confluence User's Guide.

Child Page 1
Grandchild
Child Page 2

This page is used to test the {children} macro.
Related Topics

Children Display Macro

Code Block Macro

The Code Block macro allows you to display source code in your document with the appropriate syntax highlighting. The code block displays
on the page as shown below:

..............................................................................................................................................................................

public static void main(String[] args)

{

System.out.println("Hello World!") ;

On this page:

® Using the Code Block Macro
® Parameters
® Related Topics
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Using the Code Block Macro

To add the Code Block macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

You can now type the code block directly into the macro placeholder in the editor. Note that any white space contained in the placeholder is
not manipulated in any way by the Code Block macro. This is to provide the writer with flexibility over code indentation.

Parameters

When editing, you can click on the macro placeholder and choose Edit to display the parameters for this macro in the Macro Browser.

Parameters are options that you can set for Confluence macros to control the content or format of the macro output. The table below lists
parameters for this macro that can be set in the Macro Browser.

Parameter Default
Syntax java
highlighting

Title none
Collapsible  false
Show line false
numbers

First line 1
number

Theme Default

284

Description

Specifies the language (or environment) for syntax highlighting. The default language is Java but you can
choose from one of the following languages/environments:

actionscript3
bash
csharp (C#)
coldfusion
cpp (C++)
css

delphi

diff

erlang
groovy
html/xml
java

javafx
javascript
none (no syntax highlighting)
perl

php
powershell
python
ruby

scala

sql

vb

Adds a title to the code block. If specified, the title will be displayed in a header row at the top of the code
block.

If selected, the code macro's content will be collapsed upon visiting or refreshing the Confluence page. Clicking
the expand sour ce link allows you to view this content. If false, the code macro's content is always displayed
in full.

If selected, line numbers will be shown to the left of the lines of code.

When Show line numbers is selected, this value defines the number of the first line of code.

Specifies the colour scheme used for displaying your code block. Many of these themes are based on the
default colour schemes of popular integrated development environments (IDEs). The default theme is
Confluence (also known as Default), which is typically black and coloured text on a blank background.
However, you can also choose from one of the following other popular themes:

DJango
Emacs
FadeToGrey
Midnight
RDark
Eclipse
Confluence
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Related Topics

Working with Macros

Take me back to the Confluence User's Guide.

Column Macro
The Column macro allows you to define a single column in a page.

Columns must be defined within a 'section’ of a page. So, to display columns correctly in a page, the Column macro placeholders must be
inserted within a Section macro placeholder.

Once you have defined the columns inside a Section macro, you can add content to each of the Column macro placeholders.

On this page:

® Using the Column Macro
® Parameters
® Related Topics

The following screenshot shows two columns defined within a section of a page:

== Saction

Column

The content of column one is entered within the placeholder of the first Column macro placeholder here.

Column

The content of column two is entered within the placeholder of the second Column macro placeholder here.

which renders on the page like this:

The content of column one is entered within the placeholder of the first Column macro placeholder here.

The content of column two is entered within the placeholder of the second Column macro placeholder here.

Using the Column Macro

To add the Column macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Column macros must be inserted within a Section macro for columns to be displayed correctly on a page.

Parameters

When editing, you can click on the macro placeholder and choose Edit to display the parameters for this macro in the Macro Browser.

Parameters are options that you can set for Confluence macros to control the content or format of the macro output. The table below lists
parameters for this macro that can be set in the Macro Browser.

Parameter Default Description
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Column 100% of the page width, divided equally by

The width of the column. Can be specified either in pixels (e.g. 400px) or
Width the number of columns in the section.

as a percentage of the available page width (e.g. 50%).
Related Topics

Working with Macros
Working with Tables

Take me back to the Confluence User's Guide.

Content by User Macro

The Content by User macro generates a tabulated list of the content items, throughout the Confluence installation, that have been created by

a specified Confluence user. The list includes all current pages, comments and spaces created by the user. Each item in the table is linked tc
its corresponding page, page comment or space dashboard.

Note that items for page comments contain a link to the page, followed by a second link to the comment itself, with these separated by a
greater-than sign (>).

On this page:

® Using the Content by User Macro
® Parameters
® Related Topics

Using the Content by User Macro
To add the Content by User macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Parameters

When editing, you can click on the macro placeholder and choose Edit to display the parameters for this macro in the Macro Browser.

Parameters are options that you can set for Confluence macros to control the content or format of the macro output. The table below lists
parameters for this macro that can be set in the Macro Browser.

Parameter Default Description

Username none The Confluence username for a person who has created content.

Related Topics

Working with Macros

Take me back to the Confluence User's Guide.

Contributors Macro

The Contributors macro displays a list of Confluence users who have made a contribution of some type to a page. It can also be used to list
watchers of this page.

The scope of this macro can be extended to include the immediate children or descendants of the specified page. The list of contributors can
be based on people who have:

® authored or edited the page(s)
® contributed comments or added labels to the page(s), or
® are simply watching the page(s).

On this page:

® Using the Contributors Macro
® Parameters
® Related Topics
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Screenshot: Example list of Contributors

Sarah Maddox
Edwin Dawson
Giles Gaskell
Eosie Jameson
Andrew Lui
Charles Miller

In this example, the Display Format parameter has been set to list.

Using the Contributors Macro

To add the Contributors macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Parameters

When editing, you can click on the macro placeholder and choose Edit to display the parameters for this macro in the Macro Browser.

Parameters are options that you can set for Confluence macros to control the content or format of the macro output. The table below lists
parameters for this macro that can be set in the Macro Browser.

Parameter Default Description

Contribution Type  authors Filters by either the type of contribution made to a page (and optionally its descendant pages), or
the watches on the page. Contribution types are:

authors - includes people who created or have edited the page(s)
comments - includes people who have added comments to the page(s)
labels - includes people who have added labels to the page(s)
watches - includes people who are watching the page(s).

You can specify one or more contribution types, each of which must be separated by a
comma.

Sort By count Specifies the criteria used to sort contributors. Sort criteria are:
® count - sorts people based on the total number of contributions to the page(s)

® name - sorts people into alphabetical order
® update - sorts people based on the date of their last contribution to the page(s).

Reverse Sort false Reverses the sort order of contributors in the list. Must be used in conjunction with the Sort By
parameter.

Maximum Number  no limit Limits the number of contributors in the list. If a number is not specified, all contributors are

of Contributors included.

Display Format inline Sets how the list of contributor's names is formatted:

® inline — a comma-separated list
® list — a bullet-point list.

Show Anonymous  false Sets whether to include those who contributed anonymously to a page.
Contributions?

Show Count? false Sets whether to show the number of times each person made a contribution of the specified
Contribution Type.

Show Last false Sets whether to show the last time each person made a contribution of the specified
Contribution Contribution Type.
Time?
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Page Name

Label(s)

Space(s)

Content Type

Blog Post Date
Include Page
Hierarchy
Show Selected

Pages

Custom "None
Found" Message

Related Topics

current

none

current

both pages
and blog
posts

none

specified
page only

false

default
message

Contributors Summary Macro

Working with Macros

Specifies the page to use when generating the list of contributors. If Page Name and Space(s)
are left blank, the current page is assumed.

Filters the list of contributors to those who created the specified labels from a page. You can
specify one or more labels, each of which must be separated by a comma.

Specifies the space key of the Confluence space that contains the page set in Page Name or
alternatively, specifies the spaces to search. Space keys are case-sensitive.
This parameter also takes special values, including:

® @global — All global spaces.

® @personal — All personal spaces.
® @all — All spaces in your Confluence site.

You can specify one or more space keys or special values, each of which must be
separated by a comma.

If no Page Name and Label(s) are specified, all pages from the specified set of spaces
are included.

Restricts the content type to use when generating the list of contributors:

® pages — pages

® blogposts — blog posts.
Specifies the publish date for a blog post. The date format required is: YYYY/MM/DD.
Specifies additional pages to include when generating the list of contributors:

® children — just the child pages of the specified page

* descendants — all descendants of the specified page.

Sets whether to show a list of the pages used to generate the list of contributors.

Specifies the message to be used to override the default message that is displayed when no
contributors are found.

Take me back to the Confluence User's Guide.

Contributors Summary Macro

The Contributors Summary macro displays a table of contribution-based statistics for a set of pages. These statistics can be grouped
according to individual pages or individual contributors.

The default scope for this macro is an individual page, but this can be extended to include the immediate children or descendants of a
specified page. The statistics cover the following types of contributions:

edits to the page(s)

labels added to the page(s)

L]
® comments added to the page(s)
L]
L]

people watching the page(s)

On this page:

® Using the Contributors Summary Macro
® Parameters
® Related Topics

A simple example of the Contributors Summary macro is shown in the screenshot below. It lists statistics for the number of times each
contributor has edited, added comments and added labels to this page.
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Screenshot: Example Contributors Summary table of statistics

User Edits Comments Labels
Sarah Maddox 2 P 0
Edwin Dawson 2 0 0
Giles Gaskell 2 0 0
Rosie Jameson | 2 0 0
Andrew Lui 2 0 1
Charles Miller 1 0 0
Andrew Prentice 0 0 1

In this example, all default parameter settings are used. For more information about this macro's parameters, refer to the Parameters section
below.

Using the Contributors Summary Macro

To add the Contributors Summary macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Parameters

When editing, you can click on the macro placeholder and choose Edit to display the parameters for this macro in the Macro Browser.

Parameters are options that you can set for Confluence macros to control the content or format of the macro output. The table below lists
parameters for this macro that can be set in the Macro Browser.

Parameter Default Description

Group By contributors Specifies the basis for grouping contribution-based statistics:

® contributors — group by the people who have contributed
® pages — group by the pages used to find contributors.

Columns to edits,comments,labels  Sets the columns that should appear in the table. The statistics or type of information
Display presented depends on the basis for grouping set with the Group By parameter. Statistics
may be calculated for:

® edits — the number of times each contributor has edited the page(s) or the
number of edits made to each page.

® edited — alist of the pages edited by each contributor or a list of contributors
who have edited each page.

® comments — the number of times each contributor has added comments to the
page(s) or the number of comments on each page.

® commented — a list of pages to which each contributor has added comments or a
list of contributors who have commented on each page.

® labels — the number of times each contributor has added labels to the page(s)
or the number of labels on each page.

® labeled — alist of pages to which each contributor has added labels or a list of
contributors who have added a label to each page.
labellist — alist of labels either added by each contributor or on each page.

® watches — the number of pages being watched by each contributor/person or the
number of contributors/people watching each page.

®* watching — a list of pages being watched by each contributor/person or a list of
contributors/people watching each page.

® lastupdate — the last time each contributor made an update or when each page
was last updated. Valid updates can include edit, comment or label modifications to
a page.

One or more columns can be used.
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Sort By

Reverse Sort

Maximum
Number of
Items

Show
Anonymous
Contributions?

Show Zero

Counts?

Page Name

Label(s)

Space(s)

Content Type

Blog Post Date

Include Page
Hierarchy

Related Topics

Contributors Macro
Working with Macros

Take me back to the Confluence User's Guide.

Create Space Button Macro

count

false

no limit

false

false

current

none

current

both pages and blog
posts

none

specified page only

Sets the criterion used for sorting items in the table. The items sorted depend on the basis
for grouping set with the Group By parameter. Sort criteria are:

® edits — sorts items in the table based on the total number of edits made, either
by a contributor or to a page.

® name — sorts items in the table in alphabetical order, either by contributor or page
name.

® editTime — sorts items in the table based on when the contributor last edited a
page (or a specified set of pages) or when the page was lasted edited.

® update — sorts items in the table based on when the contributor last made any
contribution to a page (or a specified set of pages) or when the page last had any
contribution made to it.

Reverses the sort order of items in the table, as specified using the Sort By parameter.
(Used only in conjunction with the Sort By parameter.)

Limits the number of contributors or pages in the table to the value specified. If no number
is specified, all items are included.

Includes individuals who have made anonymous contributions to a page.

Sets whether contributors or pages are included for which a calculated statistic is zero.

Sets the page for which to calculate the contribution-based statistics. If no values for Page
Name and Space(s) are specified, the current page is assumed.

Restricts the contribution-based statistics to the specified labels only. You can specify one
or more labels, each of which must be separated by a comma.

Specifies the space key of the Confluence space which contains the specified page name
or alternatively, specifies a scope of spaces to search. Space keys are case-sensitive.
This parameter also takes special values, including:

® @global — All global spaces.

® @personal — All personal spaces.

® @all — All spaces in your Confluence site.

You can specify one or more space keys or special values, each of which must be
separated by a comma.

If no Page Name and Label(s) are specified, all pages from the specified set of
spaces are included.

Restricts page types to either pages (pages) or blog posts (blogposts). If no value is
specified in the Macro Browser, both pages and blog posts are included.

Specifies the publish date for a blog post. The date format required is: YYYY/MM/DD.

Includes either the immediate children or all descendants of the specified page. If no
value is indicated in the Macro Browser, only the specified page is included.

The Create Space Button macro renders a create space icon that links to the 'Create Space' page. The icon appears as rendered below.
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Screenshot: The Create Space Button in Confluence

P

&

To display this icon, you require 'Create Space' permission which is assigned by a site administrator from the Administration Console.
See Security or contact your site administrator for more information.

On this page:

® Using the Create Space Button Macro
® Parameters
® Related Topics

Using the Create Space Button Macro

To add the Create Space Button macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Parameters

When editing, you can click on the macro placeholder and choose Edit to display the parameters for this macro in the Macro Browser.

Parameters are options that you can set for Confluence macros to control the content or format of the macro output. The table below lists
parameters for this macro that can be set in the Macro Browser.

Parameter Default Description

Icon Size large Specify whether to use large or small icon:

® large
®* small

Related Topics

Setting up a New Global Space
Working with Macros

Take me back to the Confluence User's Guide.

Documentation Link Macro

The Documentation Link macro generates a customisable text link to a page on http://confluence.atlassian.com/.
This macro accepts a relative link value and automatically prefixes that value with the URL:
http://confluence.atlassian.com/

For example, if you use the following relative link:

display/DOC/Working+with+Macros

then the resulting URL is:

http://confluence.atlassian.com/display/DOC/Working+with+Macros

The text that will be hyperlinked is the macro's body text (that is, the text between the macro tags). See the example below.

On this page:

Usage with the Macro Browser
Usage with the Wiki Markup Editor
Parameters

Related Topics
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Usage with the Macro Browser

To insert the Documentation Link macro into a page using the Macro Browser:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Usage with the Wiki Markup Editor

Example of what you need to type What you will get

{doc:display/DOC/Working+with+Macros}this link{doc} this link

Parameters

When editing, you can click on the macro placeholder and choose Edit to display the parameters for this macro in the Macro Browser.

Parameters are options that you can set for Confluence macros to control the content or format of the macro output. The table below lists
parameters for this macro that can be set in the Macro Browser.

Parameter Required in Wiki Default Description

Markup?
Relative yes none The relative link (that is, the URL portion after http://confluence.atlassian.com/
Link ) that leads to the required page on

http://confluence.atlassian.com/

Related Topics

Working with Macros

Take me back to the Confluence User's Guide.
Excerpt Include Macro
The Excerpt Include macro is used to display 'excerpted' (that is, a segment of) content from one page in another.

o To use this macro, the excerpt must have been defined using the Excerpt macro and both pages must exist in the same space. Note tha
you can have more than one Excerpt Include macro on a page (although you can have only one Excerpt macro on a page).

The excerpt appears as shown below:

On this page:

® Using the Excerpt Include Macro
® Parameters
® Related Topics

Excerpt Macro
Use the Excerpt macro to mark a part of a page's content for re-use.

For this example, we are taking content from a page called 'Excerpt Macro', where the Excerpt macro has already been placed. The title of
the page is shown at the top of the panel and the content within the body of the macro placeholder is rendered in the panel.

Using the Excerpt Include Macro

To add the Excerpt Include macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.
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Parameters
When editing, you can click on the macro placeholder and choose Edit to display the parameters for this macro in the Macro Browser.

Parameters are options that you can set for Confluence macros to control the content or format of the macro output. The table below lists
parameters for this macro that can be set in the Macro Browser.

Parameter Default Description

Page Containing the none Specifies the page that contains the excerpt to be displayed.

Excerpt

Remove Surrounding false Controls whether the panel border around the excerpt and the page title should be hidden. By
Panel default, the panel is always shown.

Related Topics

Excerpt Macro
Working with Macros

Take me back to the Confluence User's Guide.
Excerpt Macro

The Excerpt macro is used to mark a part of a page's content for re-use. By itself, the Excerpt macro does not change the display of a page.
However, defining an excerpt enables other macros, such as the Excerpt Include and Blog Posts macros to display the marked content

elsewhere.

o You can only define one excerpt per page. In other words, you can only add the Excerpt macro once to a page.

On this page:

® Using the Excerpt Macro
® Parameters
® Related Topics

Using the Excerpt Macro

To add the Excerpt macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

You can then add content to the body of the Excerpt macro placeholder.

Parameters
When editing, you can click on the macro placeholder and choose Edit to display the parameters for this macro in the Macro Browser.

Parameters are options that you can set for Confluence macros to control the content or format of the macro output. The table below lists
parameters for this macro that can be set in the Macro Browser.

Parameter Default Description
Hide Excerpted false Controls whether the page content contained in the Excerpt macro placeholder is displayed on the
Content page.

Related Topics

Excerpt Include Macro
Working with Macros

Take me back to the Confluence User's Guide.

Expand Macro

293



Confluence 4.0 Documentation

The Expand macro displays an expandable/collapsible section of text on your page.
Here is an example:

* Click here to expand...
This text is hidden until you expand the section.

On this page:

Using the Expand Macro
Parameters

Notes

Related Topics

Using the Expand Macro

To insert the Expand macro into a page using the Macro Browser:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Parameters

When editing, you can click on the macro placeholder and choose Edit to display the parameters for this macro in the Macro Browser.

Parameters are options that you can set for Confluence macros to control the content or format of the macro output. The table below lists
parameters for this macro that can be set in the Macro Browser.

Parameter Default Description
Title Click here to expand...  Defines the text that appears next to the expand/collapse icon.
Notes

® HTML exports do not show the expanded text. When you export the page to HTML, the text between the macro tags is not
visible. Nothing happens when readers click the 'expand' icon. This issue is logged as CONF-21092. If you like, you can vote for the
issue or 'watch' it to keep informed of progress.

® Textis expanded in PDF exports. When you export the page to PDF, the text between the macro tags is expanded so that readers
can see it on the PDF page.

Related Topics

Working with Macros

Take me back to the Confluence User's Guide.

Favourite Pages Macro
Use the Favourite Pages macro to display a list of your favourite pages.
The output of the Favourite Pages macro appears as in the following screenshot.

Screenshot: The Favourite Pages Macro in Confluence

Favourite Pages

Displaying pages recently added to your favourites list.

#% Home o

|=] Macro Testing Page e

On this page:

® Using the Favourite Pages Macro
® Related Topics
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Using the Favourite Pages Macro

To insert the favourite pages macro into a page using the Macro Browser:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

There are no parameters for this macro.

Related Topics

Working with Favourites
Working with Macros

Take me back to the Confluence User's Guide.

Gadget Macro

Gadgets are small applications that can offer dynamic content. They are typically served from a web application server and can be re-used ir
many other web applications. In Confluence, add gadgets to pages or blog posts with the gadget macro.

Confluence comes bundled with a few of its own gadgets which can be added to your pages or blog posts using the gadget macro via the
macro browser. Refer to Confluence Gadgets for more information. However, you can access additional gadgets in this list if your Confluenct
Administrator has:

® |nstalled additional gadgets locally within your Confluence installation (typically as a Confluence plugin) or
® Registered gadgets served from an external web application or website (such as those from a JIRA installation or iGoogle) via the
External Gadgets page.

Unlike other macros in the macro browser, the name of each gadget macro in the macro browser is typically unique and follows the
convention " '<gadget-name>' macro", where <gadget-name> is the name supplied by the gadget itself.

On this page:

Inserting Gadgets into a Confluence Page or Blog Post
Editing Gadgets on a Confluence Page or Blog Post
Parameters

Contents of a Gadget Macro

Related Topics

Inserting Gadgets into a Confluence Page or Blog Post

To insert a gadget into a page using the Macro Browser:

1. Edit your page or blog post.
2. Choose Insert > Other Macros.
3. Click External Content to see a list of gadgets configured for use in your Confluence installation.

o Some Confluence macros like the JIRA Issues, JIRA Portlet, RSS Feed, Tasklist and Widget Connector macros also appear in
this category because they can also access external content.
4. Click on the desired gadget to access its parameters and properties and preview any changes to these values.
o Almost all gadgets allow you to set basic parameters (listed below), which appear on the right of the Macro Browser. Each
gadget may also have its own set of modifiable properties.
5. Set the gadget's parameters and properties to your requirements.
® Click Refresh to update the gadget with any changes to parameters, properties or external data.
6. Click Insert when finished.

Editing Gadgets on a Confluence Page or Blog Post

To edit an existing gadget on a page or blog post using the Macro Browser:

1. Edit your page or blog post.
2. Double-click on the Gadget macro placeholder.
3. Set the gadget's parameters and properties to your requirements.
® Click Refresh to update the gadget with any changes to parameters, properties or external data.
4. Save the gadget.

o Almost all gadgets allow you to set basic parameters (listed below), which appear on the right of the Macro Browser. Each gadget may
also have its own set of modifiable properties.
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Parameters
Parameters are settings for Confluence gadgets, controlling presentation.

Parameter Default Description

Width 450 Expands or shrinks the size of the gadget to match the specified width. The width can be specified in pixels
pixels (using px or plain numbers, for example, 500px or 500), as a percentage of the page width (using %, for
example, 50%), or automatically resized to fit 100% of the page width (using the value auto).
Border false

Places a thin grey border around the perimeter of the gadget.

Contents of a Gadget Macro

The body of a gadget macro contains 'parameter-like’ content, which represents specific property settings that are particular to each gadget.

Hence they are not documented here. Typically, this content would only be changed by customising the gadget's default properties using the
macro browser.

Related Topics

The big list of Atlassian gadgets
Gallery Macro

The Gallery Macro displays a gallery of thumbnail images in a table, based on the images attached to a Confluence page. When viewing the
page, a user can click a thumbnail image to zoom into the full-size image and then view the images as a slide show.

See below for instructions on how to add the gallery macro to your page.

The gallery macro appears as in the screenshot below.

On this page:

® Using the Gallery Macro
® Parameters
® Related Topics

Screenshot: The Gallery Macro in Confluence

Some office photos, and a waterfall

Here is the waterfall photo

Using the Gallery Macro

To insert the Gallery macro into a page:
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1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Parameters

When editing, you can click on the macro placeholder and choose Edit to display the parameters for this macro in the Macro Browser.

Parameters are options that you can set for Confluence macros to control the content or format of the macro output. The table below lists
parameters for this macro that can be set in the Macro Browser.

The full list of parameters is shown in the following table.

Parameter

Gallery
Title

Number of
Columns

Images to
Exclude

Include
these
Images
Only

Use
Images in
these
Pages

Sort
Images By

Reverse
Sort

Default

Nothing

No exclusions i.e. include all the pictures on the
page.

Include all the pictures on the page.

If no page is specified, the gallery macro displays
the images attached to the page on which the
macro is used.

None, i.e. the sort order is unspecified and
therefore unpredictable.

Off, i.e. sort order is ascending

Description

Specify a title for your gallery.

Specify the number of columns for your table.

The gallery will ignore any pictures specified. You can specify more
than one picture, separated by commas.

Please note, the filename and filetype for this parameter are
case-sensitive, i.e. 'my picture.PNG' will not be recognised as 'my
picture.png'.

If you specifically include one or more pictures, the gallery will show
only those pictures. You can specify more than one picture, separated
by commas.

Please note, the filename and filetype for this parameter are
case-sensitive, i.e. 'my picture.PNG' will not be recognised as 'my
picture.png'.

Specify the title of the page which contains the images you want
displayed. To specify a page in a different space, use the
SPACEKEY:Page Title syntax.

Specify an attribute to sort the images by. Sort order is ascending,
unless you select the Reverse Sort parameter (see below). Options
are:

name - file name.

comment — comment linked to the attached file.
date — date/time last modified.

size — size of the attached file.

Used in conjunction with the Sort Images By parameter above. Use
Reverse Sort to reverse the sort order, from ascending to
descending.

If the name of an attached file or page contains a comma, you can refer to it in the relevant parameters above by enclosing
it in single or double quotes, for example "this, that.jpg", theother.png.

297



Confluence 4.0 Documentation

) Considerations for using the gallery macro

®* The images shown in the gallery are taken from the files attached to the Confluence page. You can also specify a
different page where the attachments are located. For information about attaching images to a page, see Attaching

Files to a Page.
® The comments below the images are drawn from the comments on the attachments. For information about adding

comments to attachments, see Attaching Files to a Page.
® By default, the gallery will include all the images attached to the page. You can also exclude or include images

using parameters.
® Only the following file formats are supported: gif, png, jpeg. The bmp format is not supported.
® You can sort your images into a particular order.
® You can specify a title for the gallery and also configure how many columns you want for the table in which your

images are displayed.

Related Topics

Displaying Images

Attaching Files to a Page
Editing Attachment Properties
Working with Macros

Take me back to the Confluence User's Guide.

Global Reports Macro

The Global Reports macro renders a list of links to global reports.
This includes a list of new or updated pagesManaging Undefined Pages on the site and RSS feeds for new pages and blog posts.
The Global Reports macro appears as shown in the screenshot below.

Screenshot: The Global Reports macro in Confluence

Global Reports

|_If New or updated pages since your last login.
Feed for new pages and blogs.

Using the Global Reports Macro

To add the Global Reports macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Parameters
When editing, you can click on the macro placeholder and choose Edit to display the parameters for this macro in the Macro Browser.

Parameters are options that you can set for Confluence macros to control the content or format of the macro output. The table below lists
parameters for this macro that can be set in the Macro Browser.

Parameter Default Description

Width of Table 99% Specifies the width of the table in which the links are displayed, as a percentage of the window width.

Related Topics

Subscribing to RSS Feeds within Confluence
Working with Macros

Take me back to the Confluence User's Guide.
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HTML Include Macro

The HTML Include macro allows you to include the contents of an external HTML file in a Confluence page.

@ CAUTION: Including unknown HTML inside a webpage is dangerous.
HTML can contain active scripting components. This means that it would be possible for a malicious attacker to present a

user of your site with script that their web browser would believe came from you. Such code could be used, for example, to
steal a user's authentication cookie and give the attacker their Confluence login password.

Using the HTML Include Macro

To insert the HTML Include macro into a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Parameters

When editing, you can click on the macro placeholder and choose Edit to display the parameters for this macro in the Macro Browser.

Parameters are options that you can set for Confluence macros to control the content or format of the macro output. The table below lists
parameters for this macro that can be set in the Macro Browser.

Parameter Default Description

HTML Page's URL  None The URL of the page to include.

Troubleshooting

® The HTML Include macro will only be available if it has been enabled by your Confluence administrator. Also, your Confluence
Administrator can define a whitelist of trusted URLs. You will see an error message on the Confluence page if the included URL is
not in the whitelist.

® You can only use the HTML Include macro for pages with absolute links. If you use the macro to include an HTML page that has
relative links, navigating those links in the wiki results in a 'Page Not Found' error. See CONF-6567.

Related Topics
HTML Macro

Working with Macros
Configuring a URL Whitelist

Take me back to Confluence User's Guide

HTML Macro

The HTML macro allows you to add HTML code to a Confluence page.

o Note that the HTML macro will only be available if it has been enabled by your System Administrator.

Using the HTML Macro

To add the HTML macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

There are no parameters for this macro.

Enter the HTML code into the body of the macro placeholder.

Related Topics

HTML Plugin (has better security than the HTML macro)
HTML Include Macro (embeds remote HTML or pages)
Working with Macros

Enabling HTML macros

Take me back to Confluence User's Guide
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IM Presence Macro

The IM Presence macro indicates graphically when a contact is signed into an Instant Messaging (IM) service. The IM Presence macro
appears as a small icon on the page, like this image: .

Using the IM Presence Macro

To add the IM Presence macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Parameters
When editing, you can click on the macro placeholder and choose Edit to display the parameters for this macro in the Macro Browser.

Parameters are options that you can set for Confluence macros to control the content or format of the macro output. The table below lists
parameters for this macro that can be set in the Macro Browser.

Parameter Description

User ID/Screen Name ldentify the user by their ID, account name or screen name.
Service aim — AOL Instant Messenger

gtalk — Google Talk

icq —1CQ

jabber — Jabber

msn — MSN Instant Messenger

sametime — IBM Lotus Sametime

skype — Skype

skypeme — Skype

wildfire — Openfire Server

yahoo — Yahoo! Messenger

Show User ID Shows or hides the User ID of the contact.

Related Topics

Working with Macros

Take me back to the Confluence User's Guide.
Include Page Macro

You can use the Include Page macro to display the contents of one Confluence page or blog post in another page or blog post.

Using the Include Page Macro

To add the Include Page macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Parameters
When editing, you can click on the macro placeholder and choose Edit to display the parameters for this macro in the Macro Browser.

Parameters are options that you can set for Confluence macros to control the content or format of the macro output. The table below lists
parameters for this macro that can be set in the Macro Browser.
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Parameter Default Description

Page to None This is the name of the Confluence page or blog post that you want to include in the current page.

Include
® |f the page or blog post is located in another space, add the space key and a colon in front of the page

name. For example, DOC:My page name.

® Toinclude a blog post, specify the date as well as the title of the blog post. For example:
/2010/12/01/My blog post.

® The space key is case sensitive.

® You can include pages from personal spaces using ~username as the space key, where 'username' is
the person's username. For example, ~jsmith:My page name.

Notes
® If you want to include part of a page rather than the whole page, use the Excerpt and Excerpt Include macros.
® To display a page's contents, you need 'View' permission for that page. Similarly, people who view the page will need View'
permissions for the embedded page as well as the page into which it is embedded. See space permissions or contact your
Confluence space administrator for more information.
® |f someone changes the name of the included page after you have added the macro to your page, the page name does not change

automatically in the macro. You will need to change the page name manually in the macro parameters.
* If you want to embed an external page into a Confluence page, you need the HTML Include Macro.

Related Topics

Working with Macros

Take me back to the Confluence User's Guide.
Sample Include Page

Start of sample page content

Lorem ipsum dolor sit amet, consectetuer adipiscing elit. Aliguam fermentum vestibulum est. Cras rhoncus. Pellentesque habitant morbi
tristique senectus et netus et malesuada fames ac turpis egestas. Sed quis tortor. Donec non ipsum. Mauris condimentum, odio nec porta
tristique, ante neque malesuada massa, in dignissim eros velit at tellus. Donec et risus in ligula eleifend consectetuer. Donec volutpat
eleifend augue. Integer gravida sodales leo. Nunc vehicula neque ac erat. Vivamus non nisl. Fusce ac magna. Suspendisse euismod libero
eget mauris.

End of sample page content
Info Macro

The Info macro allows you to highlight helpful information on a Confluence page.

It creates a blue-coloured box surrounding your text, as shown below.

-ﬂ Info Macro Example

This text is rendered inside the info macro.

Using the Info Macro

To add the Info macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Parameters
When editing, you can click on the macro placeholder and choose Edit to display the parameters for this macro in the Macro Browser.

Parameters are options that you can set for Confluence macros to control the content or format of the macro output. The table below lists
parameters for this macro that can be set in the Macro Browser.

Parameter Default Description
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Optional Title none The title of the information box. If specified, the title text will be displayed in bold next to the icon.

Show Information Icon  true If "false", the icon will not be displayed.

Related Topics

Working with Macros

Take me back to the Confluence User's Guide.

JIRA Issues Macro

JIRA is the issue tracking and project management system supplied by Atlassian. The JIRA Issues macro allows you to display a list of
issues from a JIRA site on a Confluence page.

This macro allows you to list publicly accessible issues from any JIRA site, as well as issues restricted to your user account on a JIRA site,
assuming:

® You are logged in to both the JIRA and Confluence sites, and
® Your usernames on both of these sites match.

You can also create, find and insert JIRA issues directly within text on a Confluence page or blog post. For more information, refer to
Inserting JIRA Issues.

Screenshot: Example of JIRA Issues shown on a Confluence page

% Example of the JIRA Issues macro ¢ Edit  =F add - €% Tools ~

Added by Sarah Maddoy, last edited by Sarah Maddox on Oct 03, 2008 (view change)

Below is a list of issues from the Atlassian public JIRA site, displayed on this Confluence page:

Jira Issues =
Type HKey Summary

COMF-1181 Parse exception in jiraissues

COMNF-2746 jiraissues macro flaky

COMNF-4472 jiraissues macro is broken in Preview mode
COMF-3729 robust (and safer) {jiraissues} macro authentication
COMNF-6878 jiraissue macro not including desired columns

COMNE-1415 iraissues macro custom icons break

COMF-854 ParseException when trying to use rss / jiraissues macro

COMF-11829 jiraissues macro issues when multiple on page

COMNFE-7322 Jiraissues macro doesn't show icons or timestamps

COMNF-2711 Better authentication method for jiraissues and jiraportlet macros

& [e) &) &) [8) ) () [&) [8) [8)

=

4 Page 1 of13 b Pl 2 Displaying 1 to 10 of 125 items

The list of issues above is generated by the {jiraissues} macro.

Add Labels

Add Comment

On this page:

® Usage with the Macro Browser
® Usage with the Wiki Markup Editor
® Displaying a List of JIRA Issues from any accessible JIRA site
® Parameters
® |ssues Displayed a Page at a Time

® Example

® Displaying Issues which have Restricted Viewing
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® Troubleshooting
® Related Topics

Usage with the Macro Browser

To insert the JIRA issues macro into a page using the Macro Browser:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Once you've found the JIRA issues macro, click Insert to add it to your page.

Usage with the Wiki Markup Editor

To show a list of issues from any JIRA site to which you and your readers have access, the syntax is:

OR:

Refer to the instructions below for details on obtaining this URL.

Displaying a List of JIRA Issues from any accessible JIRA site

Step 1 — Obtain the URL of the Issue Filter

1. Log in to your JIRA system.
2. Go to the 'Issues' screen and create a new filter. Do not modify an existing filter.

a This is the 'Find Issues' screen in JIRA 3.13.x and earlier.
3. Set up your search parameters and use 'View' to check the issues returned.
4. Once the filter is finished, go to the Filter's 'View' tab/section in the top-left area of the JIRA interface.
5. Copy the XML link. To do this, follow the appropriate steps below:
® If you are using JIRA 4.0.x or later:
® Choose Views, right-click on XML, and choose Copy Link Location.

: - 1,
@ Views ~ JESEEIGIERS

Frintable
8 9 MNex==
Full Content
Updated Votes
HML
18/0cti09 Cpen Link in Mew Window
Cpen Link in Mew Tab
ap/augios | | 153 (1SS
) ) R55 (Cq Bookmark This Link
Ha e Save Link As...
21/DecD8 Word Send Link...
Copy Link Location
— Excel (Al
2o Properties
o Excel (C
21/oens Inspect Element
17/5ep/08 Charts 0 .
06/0ct/08 0 5 v

® If you are using JIRA 3.13.x or earlier:
a. Locate the 'Current View' links section (see example below) and find the XML link.
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Current View:
Browser ( Current Fields | Printable | Full Content ) | XML | RSS (Issues | Comments )| Word | Excel (Al fields | Currentfields )| Cf

b. Right-click on XML and choose Copy Link Location.

Full Cantent }|ML=I RSS (Issues | Comments ) | Word | Excel
Open Link in Mew Window
Open Link in Mews Tab her
hould include Bookmark This Link... v Jensen [Afl
to the FAQ Save Link As...
 (not system Send Link... 1L
thange paramete i -
huration Copy Link Location
5 dlie DEIHQ Prupertieg nko [."!'.ﬂEISSia
metimes when a | ——
precified Web Developer r

Step 2 — Embed the Issue Filter URL onto your Confluence Page
. Log in to your Confluence system.

1
2. Edit the page where you wish to display the list of JIRA issues.
3. Type the following text into a new line at the appropriate location:

: {jira:CONTENT}

. Replace 'CONTENT" with the JIRA filter URL from your clipboard.
. Customise the macro output by adding optional parameters. See below.
. Save the Confluence page.

o0

Parameters

When editing, you can click on the macro placeholder and choose Edit to display the parameters for this macro in the Macro Browser.

Parameters are options that you can set for Confluence macros to control the content or format of the macro output. The table below lists
parameters for this macro that can be set in the Macro Browser.

The JIRA Issues macro allows the following parameters:

Parameter Required Default Description

Anonymous  no false If this parameter is set to 'true’, JIRA will return only the issues which allow
Retrieval unrestricted viewing i.e. the issues which are visible to anonymous viewers, as
(anonymous determined by JIRA's viewing restrictions. If this parameter is omitted or set to
) ‘false’, then the results depend on how your administrator has configured the

communication between JIRA and Confluence. By default, Confluence will show
only the JIRA issues which the user is authorised to view. See more details below.

(baseurl) no The value of the 'url'  If you specify a 'baseurl’, then the link in the header, pointing to your JIRA site, will
parameter use this base URL instead of the value of the 'url' parameter. This is useful when
Confluence connects to JIRA with a different URL from the one used by other users.
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JIRA Field
Columns to
Display
(columns)

Display
Total
Numbers
Only
(count)

Cache
(cache)

Height
(Pixel Value
Only)
(height)

(

renderMode

)

Title
(title)

URL
(url)

Width
(width)

no

no

no

no

no

no

yes

no

By default, the
following columns
are shown:

type

key
summary
assignee
reporter
priority
status
resolution
created
updated
due

false

on

480

In formats not
mentioned below,
the default is
‘dynamic’.

The default is 'static'
when the JIRA
issues are displayed
in a PDF or Word
document, in an
email message or in
an RSS feed.

JIRA Issues

none

100%

Issues Displayed a Page at a Time

A list of JIRA column names, separated by semi-colons (;). Example columns are:
key, summary, type, created, fixversion, updated, due, assignee, reporter, priority,
status and resolution. You can include any columns recognised by your JIRA site,
including custom columns. See the JIRA documentation for a list of names.

If this parameter is set to 'true’, the issue list will show the number of issues in JIRA.
The count will be linked to your JIRA site.

The macro maintains a cache of the issues which result from the JIRA query. If the
‘cache' parameter is set to 'off', the relevant part of the cache is cleared each time
the macro is reloaded. (The value 'false’ also works and has the same effect as
'off".)

The height in pixels of the table displaying the JIRA issues.
Note that this height specification is ignored in the following situations:

® |f you set the 'renderMode' parameter (see below) to 'static'.
®* When the JIRA issues are displayed in a PDF or Word document, in an
email message or in an RSS feed.

By default, the JIRA Issues macro offers a dynamic display with the following
features:

Click the column headers to sort the output.

Drag and drop the columns into a different order.

Temporarily remove a column from the display.

View a page of issues at a time, for faster response times.

Set the 'renderMode’' parameter to 'static' if you want to disable the dynamic
display features.

You can customise the title text at the top of the JIRA issues table with this
parameter. For instance, setting the title to '‘Bugs-to-fix' will replace the default 'JIRA
Issues' text. This can help provide more context to the list of issues displayed.

The URL of the XML view of your selected issues in JIRA Issue Navigator.

Note: If the URL in the 'url' parameter does not contain a tempMax argument, then
the value of tempMax will default to 500. If your JIRA server is version 3.12 or
earlier, this means that the JIRA Issues macro will return a maximum of 500 issues.
If your JIRA server is version 3.13 or later, a value of 500 means that the JIRA
Issues macro will return a maximum of 500 issues per page.

The width of the table displaying the JIRA issues. Can be indicated either as a
percentage (%) or in pixels (px).

If you are using JIRA 3.13 or later, the JIRA Issues macro will retrieve and show a 'page’ of issues at a time. The buttons underneath the
table allow you to move to the next or previous page, or to the start or end of the list. The number of issues retrieved per page is determined
by the url parameter — see the description of the macro parameters above.

If your version of JIRA is 3.12 or earlier, the JIRA Issues macro will retrieve all the issues at once and display them as a single 'page’.
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Below is an example of some macro markup code, requesting a list of issues from the Atlassian public JIRA site:

{jira:anonymous=true|url=
http://jira.atlassian.com/sr/jira.issueviews:searchrequest-xml/temp/SearchRequest.xml?jglQuery=g
| columns=type;key; summary}

The example code contains three parameters (see above parameter table for their meanings):

® anonymous=true

® url=<along URL derived from the XML view of a JIRA filter>
® columns=type;key;summary

Below are the results of the above macro markup, displayed on this Confluence page:

JIRA Issues (10 issues)

Type Key Summary

CONF-1181 Parse exception in jiraissues

CONF-4472 jiraissues macro is broken in Preview mode

CONF-3729 robust (and safer) {jiraissues} macro authentication
CONF-6878 jiraissue macro not including desired columns
CONF-854 ParseException when trying to use rss / jiraissues macro
CONF-11829 jiraissues macro issues when multiple on page
CONF-7322 Jiraissues macro doesn't show icons or timestamps
CONF-16617 PDF export ignore jiraissues macro in included page

@ CONF-967 Make {jiraissues} macro's output column sortable
CONF-2711 Better authentication method for jiraissues and jiraportlet macros

Displaying Issues which have Restricted Viewing

Maybe your JIRA instance is not visible to anonymous visitors — everyone has to log in before they can see JIRA issues. Or maybe some of
the JIRA issues are restricted to viewing by certain users only. This section explains how to handle JIRA issues that have restricted viewing.

Using Confluence-to-JIRA Trusted Communication (Recommended)
For Confluence 2.7.0 and later and JIRA 3.12 and later, your administrator can set up trusted communication between Confluence and
JIRA. The entire process is described in the Confluence Administrator's Guide. Provided that your administrator has set up trusted
communication, you don't need to add any extra parameters. Confluence and JIRA will work out the security between them, ensuring that the
user will see only the issues they are authorised to see. Read the section below if you want more detail.
@ Remove the username and password from your macro markup code
Prior to Confluence 2.7, you needed to include a username and password in the macro markup code if you wanted to

display JIRA issues which had restricted viewing. Once your administrator has set up trusted communication between
Confluence and JIRA, you no longer need to include a username and password in the markup code for your JIRA macros.

The following options are available for determining the issues which will be retrieved from JIRA and displayed on the Confluence page:

What you want to do Macro URL parameter Comments
parameter
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Display the JIRA
issues which the
logged-in user is
authorised to see. And
if the user is not
logged in, display only
issues which allow
unrestricted viewing.

Ensure that anonymous
Confluence will display

only the JIRA issues

which allow

unrestricted viewing.

Use a pre-determined &0s_username=MYNAME&os password=MYPASSWORD
username and

password to access

the JIRA issues.

Troubleshooting

HTTPS

Do not specify any authentication
parameters. In this case, the
behaviour depends on the way your
administrator has set up trusted
communication between JIRA and
Confluence. Here is a summary of
the behaviour. If trusted
communication is enabled, the
authorisation will work seamlessly.
When a logged-in user views your
page, they will see only the JIRA
issues they are allowed to see. And
if they are not logged in, they will
see only the issues which allow
unrestricted viewing. If trusted
communication is disabled, the
Confluence page will show only the
JIRA issues which allow
unrestricted viewing.

Regardless of who the user is
(logged in or not), the Confluence
page will show only
anonymously-visible issues.
Confluence will not attempt to set
up a trusted communication link
with JIRA in this case.

Not recommended. Prior to
Confluence 2.7, this was the only
way of displaying issues with
restricted viewing. For Confluence
2.7 and later, this method will still
work. Confluence will not attempt to
set up a trusted communication link
with JIRA in this case.

The JIRA Issues macro can access a JIRA instance running under SSL as long as the Confluence server is set to accept the JIRA SSL
certificate. Refer to the Confluence Knowledge Base article for more information about problems connecting to SSL services.

And see also:

® Troubleshooting Trusted Communication between JIRA and Confluence

Related Topics

Inserting JIRA Issues

JIRA Portlet Macro

Working with Macros

In the Administrator's Guide:

® Configuring JIRA with Confluence
® Setting Up Trusted Communication between JIRA and Confluence

Take me back to the Confluence User's Guide.

JIRA Macro

See Inserting JIRA Issues.

JIRA Portlet Macro

The JIRA Portlet macro, for JIRA 3.x and earlier, allows you to display a JIRA dashboard portlet on a Confluence page. JIRA is the issue

tracking and project management system supplied by Atlassian.

Using JIRA 4.0 and Later
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Setting up new JIRA portlets will not work when using JIRA 4.0 and later. Please consider using a JIRA gadget instead of a JIRA Portlet
macro.

® Gadgets replaced portlets in JIRA 4.0 and Confluence 3.1.

® Existing JIRA portlet macros based on earlier versions of JIRA will continue to work in Confluence.

® However, due to architectural changes in JIRA 4.0, the ability to create new JIRA portlet macros in Confluence is not available.
Please refer to JRA-19285 and JRA-18521 for more information.

On this page:

® Using JIRA 4.0 and Later
® Using JIRA 3.x
Obtaining the JIRA Portlet URL
Usage with the Macro Browser
Parameters
Displaying Issues which have Restricted Viewing
® Using Confluence-to-JIRA Trusted Communication
® Troubleshooting
® |deas for new features or want more tips?
® Logging Bugs and Requesting Support
® Known Limitations when used with JIRA Calendar
® Related Topics

Using JIRA 3.x

The JIRA portlet macro appears as shown in the screenshot below.

Statistics: Confluence (Fix For Versions (non-archived)) Total Issues: 4,028
#29 2 |

9291 14 |

4 210 24 | 1%

Unscheduled 3092 [ 99%

Screenshot above: The JIRA Portlet Macro in Confluence

Obtaining the JIRA Portlet URL

The JIRA Portlet macro requires the URL of the JIRA portlet you wish to show on a Confluence page.
To obtain the JIRA portlet URL:

1. Log in to your JIRA system.

2. Add the portlet you wish to include in Confluence to your JIRA dashboard. (Once you have copied the portlet's URL into Confluence,
you can remove it from your JIRA dashboard.)

3. Click On beside 'Configure' on your JIRA dashboard. (If you don't see this link, you need to click the 'Manage Portal' link, click the
‘Configure’ button and then return to the dashboard.)

4. Right-click the title located at the top-left corner of the portlet and copy its link location. See Screenshot 1.

Screenshot 1: Copy link location

i @ ®f

Cpen Link in Mew Window
Ta:  Open Linkin Mew Tab

El}

Pre Bookmark, This Link. .. N
Usi  SavelinkAs... Lps or create a new User.

Send Link. ..
Dl e : JIRA data as XML

Copy Link Location

nodify global permissions.

Properties

Licemnse orEErETETETTErTOmmercial Server License (viewy details)

(Support and upgrades available until 10/ Janf0E)

Usage with the Macro Browser

To add the JIRA Portlet macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.
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Parameters

When editing, you can click on the macro placeholder and choose Edit to display the parameters for this macro in the Macro Browser.

Parameters are options that you can set for Confluence macros to control the content or format of the macro output. The table below lists
parameters for this macro that can be set in the Macro Browser.

Parameter Required Default Description
JIRA Portlet yes none URL of the JIRA portlet, as described above.
URL o Certain JIRA portlets may require user authentication details in order to display their content.

Hence you may need to append:
&0s_username=yourJiraUsername&os_password=yourJiraPassword to the end of this url.

Anonymous  no false For Confluence 2.7.0 and later. If this parameter is selected, JIRA will return only the issues

Retrieval which allow unrestricted viewing i.e. the issues which are visible to anonymous viewers, as
determined by JIRA's viewing restrictions. If this parameter is not set, then the results depend on
how your administrator has configured the communication between JIRA and Confluence. By
default, Confluence will show only the JIRA issues which the user is authorised to view.
See more details below.

Base URL no none If Confluence retrieves the JIRA portlet from some other URL than JIRA's public URL, you should
supply JIRA's public URL in the baseurl parameter.

Displaying Issues which have Restricted Viewing

This section explains how to handle JIRA issues that have restricted viewing. Maybe your JIRA instance is not visible to anonymous visitors -
everyone has to log in before they can see JIRA issues. Or maybe some of the JIRA issues are restricted to viewing by certain users only.

Using Confluence-to-JIRA Trusted Communication

Your administrator can set up trusted communication between Confluence and JIRA. The entire process is described in the Confluence
Administrator's Guide.

Here is a relevant extract from the above page:

@ Remove the username and password from your macro markup code
Prior to Confluence 2.7, you needed to include a username and password in the macro markup code if you wanted to

display JIRA issues which had restricted viewing. Once your administrator has set up trusted communication between
Confluence and JIRA, you no longer need to include a username and password in the markup code for your JIRA macros.

The following options are available for determining the issues which will be retrieved from JIRA and displayed on the Confluence page:

What you want to do Macro URL parameter Comments

parameter
Display the JIRA Do not specify any authentication
issues which the parameters. In this case, the
logged-in user is behaviour depends on the way your
authorised to see. And administrator has set up trusted
if the user is not communication between JIRA and
logged in, display only Confluence. Here is a summary of
issues which allow the behaviour. If trusted
unrestricted viewing. communication is enabled, the

authorisation will work seamlessly.
When a logged-in user views your
page, they will see only the JIRA
issues they are allowed to see. And
if they are not logged in, they will
see only the issues which allow
unrestricted viewing. If trusted
communication is disabled, the
Confluence page will show only the
JIRA issues which allow
unrestricted viewing.
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Ensure that
Confluence will display
only the JIRA issues
which allow
unrestricted viewing.

anonymous

Use a pre-determined
username and
password to access
the JIRA issues.

&0s_username=MYNAME&os password=MYPASSWORD

Regardless of who the user is
(logged in or not), the Confluence
page will show only
anonymously-visible issues.
Confluence will not attempt to set
up a trusted communication link
with JIRA in this case.

Not recommended. Prior to
Confluence 2.7, this was the only
way of displaying issues with
restricted viewing. For Confluence

2.7 and later, this method will still
work. Confluence will not attempt to
set up a trusted communication link
with JIRA in this case.

Troubleshooting

Ideas for new features or want more tips?

If you have an idea for a new feature, please log it on our JIRA site.

You will also find many hints and tips on Atlassian Answers. Try asking a question or sharing your ideas with other Confluence users.

Logging Bugs and Requesting Support
If you have found a bug in this macro, please log it on our JIRA site.

If you encounter a problem using this macro, please raise a ticket on our Support site.

Known Limitations when used with JIRA Calendar

If you are using the JIRA Portlet macro in combination with the JIRA Calendar, paging will work only if your Confluence and JIRA sites are
running on the same host. Otherwise, you see error messages like Access to restricted URI.

Reason: the Calendar portlet communicates with JIRA via AJAX requests. Because of security concerns, browsers by default do not allow
requests to any host different from the one the page was originally downloaded from.

There is a workaround. If you wish, you can turn off this security check in your browser. The exact way depends on your browser version, so
Google for hints.
Please consider all implications of turning off this security check before you perform this action.

a There is an existing request to develop support for proxying of the AJAX requests from Confluence to JIRA. If you need this feature,
please vote for this issue: JCAL-64.

Related Topics

JIRA Issues Macro
Working with Macros

In the Administrator's Guide:

® Configuring JIRA with Confluence
® Setting Up Trusted Communication between JIRA and Confluence

Take me back to the Confluence User's Guide.

JUnit Report Macro

The JUnit Report macro displays a summary of JUnit test results from a directory accessible by the Confluence server. JUnit is a unit testing
framework which allows programmers to ensure that individual units of Java source code are functioning correctly.

The JUnit Report macro appears as shown in the screenshot below.

Screenshot: The JUnit Report macro in Confluence

Test Time Messages
MoneyTest 100% _ 00:03.391 Tests:Failures:Exceptions:
1 0 0
[~ testAdd 00:03.0
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o When generating reports from the JUnit Report macro, set the Apache Ant formatter to 'XML".

Using the JUnit Report Macro

To add the JUnit Report macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Parameters
When editing, you can click on the macro placeholder and choose Edit to display the parameters for this macro in the Macro Browser.

Parameters are options that you can set for Confluence macros to control the content or format of the macro output. The table below lists
parameters for this macro that can be set in the Macro Browser.

Parameter Default Description

URL of the test result  None URL of a particular test result XML file. Is overridden by the Directory (URL) of your test result
XML file files parameter if you use both.

Example, from a Confluence instance:
http://yourConfluenceInstance.com/download/attachments/<page id>/file.xml

For Confluence installations without anonymous user access, you can specify logon credentials as
part of this parameter in the form of URL parameters:

® os_username — The username of a Confluence user with permission to access to the
JUnit test results.
®* os password — The password of the Confluence user specified in the os_username

parameter.
Directory (URL) of None URL of a directory containing your test result files. This must be a directory name and not the XML
your test result files file itself. Overrides the URL of the test result XML file parameter if you use both.

Example, for a local drive: file:///C:/TEMP/

Example, for a network drive: http://*host*/*path*
Report Detail all Detail for the report. Can be all, fixture, summary or failuresonly.

Debug None Shows the content of failures, as well as the error messages.

Related Topics

Working with Macros

Take me back to the Confluence User's Guide.

Livesearch Macro

The Livesearch macro allows you to add a search box to a Confluence page. When users enter a search term into the search box,
Confluence will dynamically display matching results as they type.

Using the Livesearch Macro

To add the Livesearch macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Parameters

When editing, you can click on the macro placeholder and choose Edit to display the parameters for this macro in the Macro Browser.

311



Confluence 4.0 Documentation

Parameters are options that you can set for Confluence macros to control the content or format of the macro output. The table below lists
parameters for this macro that can be set in the Macro Browser.

Parameter Default Description

ID none Uniquely identifies the Livesearch when there are multiple Livesearch macros in one page.

Restrict to this Space Key all spaces Specify a space key to limit the search to the given space. Case-sensitive.

Related Topics
Searching Confluence
Search Macro
Working with Macros

Take me back to the Confluence User's Guide.

Loremipsum Macro

The Loremipsum macro displays paragraphs of pseudo-Latin text (more information). You can use this macro to generate more-or-less
meaningless text for demonstration purposes in pages showing a draft layout or arrangement of page elements. The text is deliberately
non-meaningful so that it does not influence the viewer's perception of the page arrangement or design.

A basic example of the Loremipsum text:

Lorem ipsum dolor sit amet, consectetuer adipiscing elit. Aliguam fermentum vestibulum est. Cras rhoncus. Pellentesque
habitant morbi tristique senectus et netus et malesuada fames ac turpis egestas. Sed quis tortor. Donec non ipsum. Mauris
condimentum, odio nec porta tristique, ante neque malesuada massa, in dignissim eros velit at tellus. Donec et risus in ligula
eleifend consectetuer. Donec volutpat eleifend augue. Integer gravida sodales leo. Nunc vehicula neque ac erat. Vivamus non
nisl. Fusce ac magna. Suspendisse euismod libero eget mauris.

Using the Loremipsum Macro

To add the Loremipsum macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Parameters
When editing, you can click on the macro placeholder and choose Edit to display the parameters for this macro in the Macro Browser.

Parameters are options that you can set for Confluence macros to control the content or format of the macro output. The table below lists
parameters for this macro that can be set in the Macro Browser.

Parameter Default Description

Number of Paragraphs 3 The amount of pseudo-Latin (space-filler) text to display.

Related Topics

Working with Macros

Take me back to the Confluence User's Guide.

Metadata Macro

The Metadata macro allows you to embed metadata into pages and blog posts for presentation with the Metadata Summary Macro. Each
metadata item consists of a field name and an associated value. When a metadata macro is rendered on a page, each metadata item is
presented on a single line, starting with the name of the field, followed by its value, for example:

Is-Secret Yes

Author-Nickname  Banana Split
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Each metadata macro is 'labelled’, allowing you to:

® insert multiple Metadata macros on a single page or blog post, each with a different label
® use the Metadata Summary macro to generate a summary based on Metadata macros tagged with a specific label.

Metadata macro ‘label's are completely unrelated to page labels. A Metadata macro's label is only used by the Metadata
Summary macro for the purpose of generating its summary.

As far as the Metadata Summary macro is concerned, each field only possesses a single value. Hence, if you added multiple values to a
field (for example, by separating each value with a comma), the Metadata Summary macro treats this as a single value and presents it as
such.

On this page:
® Usage with the Macro Browser

® Usage with the Wiki Markup Editor
® Parameters

Usage with the Macro Browser

To insert the metadata macro into a page using the Macro Browser,
1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Once you've found the metadata macro, click 'insert' to add it to your page.

Usage with the Wiki Markup Editor

H {details:label=test} H
H Is-Secret: Yes H
i Author-Nickname: Banana Split i
i {details} i

Each metadata item is added on a separate line. Separate each field and value with a colon (:) followed by a space. For example: colour:
Red.

In the example above,
® test is the label of this metadata macro, which can be identified uniquely on a page in a metadata summary

® |s-Secret is a field of value Yes
® Author-Nickname is another field with a value of Banana Split.

Parameters

When editing, you can click on the macro placeholder and choose Edit to display the parameters for this macro in the Macro Browser.

Parameters are options that you can set for Confluence macros to control the content or format of the macro output. The table below lists
parameters for this macro that can be set in the Macro Browser.

Parameter Required in Default Description

Wiki Markup?
Metadata yes none Used by the Metadata Summary macro to generate a summary based on all Metadata
Label macros tagged with this label throughout the current space.
(label)
hidden no false Controls whether the text between the details tags will appear on that page when users
(hidden) read it.

RELATED TOPICS

Working with Macros
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Take me back to the Confluence User's Guide.

Metadata Summary Macro

The Metadata Summary macro presents a tabulated summary of selected metadata, which has been embedded using the Metadata Macro
on any page or blog post in the current Confluence space.

The left-most column of the metadata summary shows the name of each page or blog post within current space that contains the selected
metadata. Each page or blog post is presented on a single row and is hyperlinked to its appropriate destination page.

Each subsequent column represents a unique field within the selected metadata. The value associated with each metadata field on a page or
blog post is presented in the appropriate cell of the metadata summary table. For example, the following Metadata Summary macro shows all
Metadata macros tagged with the 'test' label in the current space.

Author-Firstname Author-Nickname Is-Secret
Metadata Macro <p>Banana Split</p> <p>Yes</p>
Metadata Summary Macro | <p>Fred</p> <p>Strawberry Sundae</p>

Metadata macro 'label's are completely unrelated to page labels. A Metadata macro's label is only used by the Metadata
Summary macro for the purpose of generating its summary.

On this page:
Usage with the Macro Browser
Usage with the Wiki Markup Editor

Parameters
Another Metadata Macro Example

°
L]
°
L]
Usage with the Macro Browser

To insert the metadata summary macro into a page using the Macro Browser,

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Once you've found the metadata summary macro, click 'insert' to add it to your page.

Usage with the Wiki Markup Editor

: {detailssummary:label=test}

This shows a metadata summary based on all Metadata macros in pages or blog posts of the current space, which have been labelled with
‘test'.
Parameters

When editing, you can click on the macro placeholder and choose Edit to display the parameters for this macro in the Macro Browser.

Parameters are options that you can set for Confluence macros to control the content or format of the macro output. The table below lists
parameters for this macro that can be set in the Macro Browser.

Parameter Required in Default Description
Wiki Markup?
Metadata yes none Restricts the Metadata Summary macro to summarise the contents of Metadata macros
Label throughout the current space, which have been tagged with this label only.
(1abel)

Another Metadata Macro Example

The following Metadata macro example generates the second line in the Metadata Summary macro (above).
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Author-Nickname  Strawberry Sundae

Author-Firstname  Fred

RELATED TOPICS

Working with Macros

Take me back to the Confluence User's Guide.

Multimedia Macro

See Embedding Multimedia Content.

Network Macro

The Network macro displays a list of Network interactions between users in your Confluence site, on a Confluence page or blog post.

The Network macro allows you to specify the user whose network interactions you wish to show. These interactions include the users that
the specified user is following or users who are following the specified user. The Network macro shows each listed user by their profile

picture. It also provides a choice of two themes and the ability to limit the number of users in the list.

Screenshot: Network Macro

Following

You are following 10 users

Bfim© ¥2
248 @] )

|Username H Follow ]

Using the Network Macro

To add the Network macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Parameters
When editing, you can click on the macro placeholder and choose Edit to display the parameters for this macro in the Macro Browser.

Parameters are options that you can set for Confluence macros to control the content or format of the macro output. The table below lists
parameters for this macro that can be set in the Macro Browser.

Parameter Default Description

Username  current user's The username of the Confluence user whose network interactions you wish to show. If no username is
username specified, then current user's (that is, your) network interactions are shown.

Mode following Determines which users are listed, with respect to the specified user:

* following — those who the user is following.
* followers — those who are following the user.
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Theme full Determines how the user's network is displayed:

® full — shows a large version of user's profile pictures and, if the following mode is set,
provides an entry field function to follow more users.
® tiny — shows only the small version of user's profile pictures.

Maximum  no limitimposed = Restricts the number of users displayed. If the number of users exceeds the specified maximum, then a
Results uptoa Show All link is provided. This link leads to the specified user's Network view, showing the complete list
maximum of 30 of network interactions.

Related Topics

Working with Macros

Take me back to the Confluence User's Guide.

Noformat Macro

The Noformat macro displays a block of text in monospace font with no other formatting.
Using the Noformat Macro

To add the Noformat macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Enter the content that is to be unformatted into the body of the macro placeholder.
Parameters

When editing, you can click on the macro placeholder and choose Edit to display the parameters for this macro in the Macro Browser.

Parameters are options that you can set for Confluence macros to control the content or format of the macro output. The table below lists
parameters for this macro that can be set in the Macro Browser.

Parameter Default Description

No Panel False Removes the panel around the content.

Related Topics
Working with Macros

Take me back to the Confluence User's Guide.

Note Macro

The Note macro allows you to highlight a note on a Confluence page.

It creates a yellow-coloured box surrounding your text:

1. Note Macro Example

This text is rendered inside the Note macro.

Using the Note Macro

To add the Note macro to a page:
1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Add the text of the note to the body of the macro placeholder.
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Parameters

When editing, you can click on the macro placeholder and choose Edit to display the parameters for this macro in the Macro Browser.

Parameters are options that you can set for Confluence macros to control the content or format of the macro output. The table below lists
parameters for this macro that can be set in the Macro Browser.

Parameter Default Description
Optional Title none If specified, the title is displayed in bold next to the icon.

Show Exclamation Mark Icon  true
® true — displays the warning icon
® false —the icon is not displayed

Related Topics

Working with Macros

Take me back to the Confluence User's Guide.

Page Index Macro

The Page Index macro creates a hyperlinked alphabetical index of all pages within the current space.

The top section of the Index contains a cell for letter of the alphabet, including separate cells for numbers and symbols. Each of these cells
indicates the number of pages in which the first letter of the title matched the corresponding letter, number or symbol in the cell.

The lower section is effectively an extended version of the top section. However, each cell shows the page name followed by the first few
sentences of content on that page.

Each letter, number or symbol in the top section is hyperlinked and leads to its corresponding cell in the lower section. Additionally, each
page title in the lower section is hyperlinked and leads to its corresponding page in the space.

Screenshot: Index Macro segment
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Space Index
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interface might be a little hard to
navigate at first. We think that the
new design is a vast improvement,
bt it's inevitable that people who
have used the application since its
release will be wondering where ...
|5 2.2.5 Security Patch
patch fixes a minor security
vulnerabhility regarding the
administration of space mail
accounts. It affects only Confluence
2.2.5 Toinstall this patch please
download the three files attached to
this page, stop Confluence and copy
them to your {{\WWEBIMF/classesicom

09 .2 A B4 B...12 C ... 283
F...13 E...19 H.. 93 I...109
L..# M .39 M ... 36 o...10
B ... 193 5...80 T.. 46 u... 59
K2 Y. £..0 li@#s .0
0-9 A
|2 1.4 Interface - Where Did Everything | [Zf] Access Log Scripts
Go? access log scripts are attached to this page Access Log ScriptsAtl

the 7z file. # Copy all the daily access logs to a folder called {{logs]
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D Accessing Confluence Components From Plugin Modules
Confluence is built around Spring hitp/www.springframework.org
you are familiar with Spring, then you may only wish to know that C
classes) are autowired by name. Thus, if you wantto access ..

D Activating External User Management
your user management is being handled outside of Confluence by
option in Confluence, from the Administration Console. Running ©
user management outside of Confluence ..

|=] Add Confluence EAR-WAR to JIRA Standalone
document will assist you in adding Confluence to your existing JIR
This guide is for experts only. If you run into any difficulties with thig
limited assistance outside ...

|=] Add LDAP Integration
Atlassian's Crowd hitp:ifwww.atlassian.com/software/crowd! is a v
application provisioning and identity management. Confluence carn
group memhberships to set the users Confluence access ..
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Management in Confluence hitpiconfluence atlassian.comidispla
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05Useruser management, described in this document, has beer

On this page:
® Usage with the Macro Browser

® Usage in Wiki Markup
® Parameters

Usage with the Macro Browser

To insert the Page Index macro into a page using the Macro Browser,

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Once you've found the Page Index macro, click 'insert' to add it to your page.

Usage in Wiki Markup

What you Segment of what you will get

need to
type
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{index} Space Index
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youre used to the Confluence the 7z file. # Copy all the daily access logs to a folder called flogs}
Classicinterface, the new 1.4 generate a {{csvii file called {{summary.csv}} and several directorig
interface might be a little hard to D Accessing Confluence Components From Plugin Modules
navigate at first. We think that the Confluence is built around Spring http:lwww.sprinaframewaork.arg
new design is a vast improvement, you are familiar with Spring, then you may only wish to know that C
but it's inevitable that people who classes) are autowired by name. Thus, if you want to access
have used the application since its D Activating External User Management
release will be wondering where ... your user management is being handled outside of Confluence by
D 2.2.5 Security Patch option in Conflugnce, from the Administration Console. Running C
patch fixes a minor security user management outside of Confluence .
vulnerability regarding the D Add Confluence EAR-WAR to JIRA Standalone
administration of space mail document will assist you in adding Confluence to your existing JIR
accounts. It affects only Confluence This guide is for experis only. If you run into any dificulties with this
2.2.5. To install this patch please limited assistance outside ...
download the three files attached to D Add LDAP Integration
this page, stop Confluence and copy Atlassian's Crowd hitp:/fwww.atlassian.comisoftware/crowd/ is a v
them to your {{WEBINF/classesicom application provisioning and identity management. Confluence can
group memberships to setthe users Confluence access ...
[ Add LDAP Integration For User Authentication Only
Caonfluence 2.7.0 and abave, all user managementis performed b
Management in Confluence hitp:/confluence. atlassian.comidispla
DoCUnderstandingUserManagementinConfluence#Understand
QO5lser user management, described in this document, has been
Parameters

This macro accepts no parameters.

RELATED TOPICS
Working with Macros

Take me back to the Confluence User's Guide.

Pagetree Macro

The Pagetree macro displays a dynamic, hierarchical list of pages starting from a specified parent (root) page. You can embed the page tree
into your Confluence page, where it can act as a table of contents or a list of related topics.

When viewing the page tree, your reader can click a link to open the relevant page. The page's current position is highlighted in the page
tree.

Below we tell you how to add the Pagetree macro to your page.

o Creating a navigation panel for your space

The Pagetree macro is used in the Confluence Documentation theme, to create a navigation panel showing a table of
contents for your space. Read the instructions on Configuring the Documentation Theme.
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On this page:

Usage with the Macro Browser
Usage with the Wiki Markup Editor
Macro Parameters
Examples
® All Parameters
Specifying the Parent Page by Name
Showing All Pages in the Space
Setting the Current Page as the Parent Page
Showing Excerpts from Each Page
Allowing your Readers to Expand or Collapse All Branches
Including a Search Box
Sorting the Pages in Reverse Natural Order

Usage with the Macro Browser
To insert the Pagetree macro into a page using the Macro Browser,

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Once you've found the Pagetree macro and have added the required parameter values, click 'insert' to add it to your
page.
Usage with the Wiki Markup Editor

Include the following markup in your page:

{pagetree}

There are more examples below.

Macro Parameters

When editing, you can click on the macro placeholder and choose Edit to display the parameters for this macro in the Macro
Browser.

Parameters are options that you can set for Confluence macros to control the content or format of the macro output. The table below
lists parameters for this macro that can be set in the Macro Browser.

Parameter Required? Default Description

Include Excerpts in no false Set this value to 'true’ if you want the page tree to show excerpts from each
Page Tree page. The excerpts must be defined on each page by the Excerpt macro.
(excerpt)

Show no false Set this value to 'true’ if you want to display the 'expand all' and ‘collapse all’
Expand/Collapse links at the top of your page tree. Your readers can click these links to open
Links or close all branches of the tree at once.

(

expandCollapseAll

)

Reverse Order no false Use this parameter in combination with the sort parameter described below.
(reverse) Set this value to 'true’ if you want the pages displayed in descending order

rather than ascending order.
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Root Page no The
(root) home
page of
the
space
Include Search Box no false
above Page Tree
(searchBox)
Sort Pages By no position
(sort)
Start Depth no 1
(startDepth)
Examples

All Parameters

Here's an example using all the parameters:

{pagetree:root=Page

Specify the parent page for the page tree. The tree will include all children of
the given page, plus their children and grand-children etc. The tree will not
include the root page itself.

Specify the page title or a special value as follows:

® Your page title — Page tree shows all pages under the specified
page.

® '@home' — Page tree shows all pages under the home page of the
space (default).

* '@self' — Page tree shows all pages under the current page.

® '@parent' — Page tree shows all pages under the parent of the
current page, including the current page.

®* '@none' — Page tree shows all pages in the space, including
orphaned pages and the home page.

Set this value to 'true' if you want to include a search box above the page
tree. The search box allows your readers to enter a search term, and then
searches within the page tree for the specified value.

Specify the order to display the pages in the tree. This sort order is for display
purposes only. It does not permanently re-arrange the page order. The value
may be one of the following:

® ‘bitwise' — Display the pages using standard alphabetical sorting,
such as: titlel, title10, title2.

® 'creation' — Display the pages in order of date created.

* 'modified' — Display the pages in order of date last modified.

® ‘natural' — Display the pages in ‘natural’ alphabetical order, such as:
titled, title2, title10.

® 'position' — Display the pages using the default Confluence sorting
rules. If your pages have been ordered manually, this sort will respect
the defined order. Otherwise the pages will be displayed in the
'natural’ alphabetical order, such as: titlel, title2, title10.

Enter any number greater than 0, indicating how many levels of children the
tree should show when it opens for the first time.

Name | sort=natural |excerpt=true|reverse=false|startDepth=3|expandCollapseAll=true|searchBox=tz

Specifying the Parent Page by Name

Use the following code to specify a page name for the parent or root of the tree. The tree will include all children and grand-children
of the specified root. The tree will not include the specified root page itself.

What you need to type

{pagetree:root:Pagetree
Macro}

What you will get

The above example is a 'live' example. It uses the child pages of this page to form the page tree.

Showing All Pages in the Space

Use the following code to make the page tree show all pages in the space, including orphaned pages and the home page.
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Setting the Current Page as the Parent Page

What you need to type What you will get

{pagetree:root=@self}

The above example is a 'live' example. It uses the child pages of this page to form the page tree.
Showing Excerpts from Each Page

Use the following code if you want your page tree to include excerpts from each page. The excerpts must be defined on each page
by the Excerpt macro.

What you need to type What you will get

{pagetree:root=@self |excerpt=true}

The above example is a 'live' example. It uses the child pages of this page to form the page tree.
Allowing your Readers to Expand or Collapse All Branches

Use the following code if you want to show the 'expand all' and 'collapse all' links at the top of your page tree.

What you need to type What you will get
Collapse all
{pagetree:root=@self |expandCollapseAll=true} Expand all Collapse all

The above example is a 'live' example. It uses the child pages of this page to form the page tree.
Including a Search Box

Use the following code if you want to include a search box at the top of your page tree.

What you need to type What you will get

{pagetree:root=@self |searchBox=true}

The above example is a 'live' example. It uses the child pages of this page to form the page tree.

Sorting the Pages in Reverse Natural Order

Use the following code if you want to show the pages in reverse natural order.

What you need to type What you will get
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{pagetree:root=@self |sort=natural |reverse=true}

The above example is a 'live' example. It uses the child pages of this page to form the page tree.
RELATED TOPICS

Pagetree Search Macro
Adding a Navigation Sidebar
Working with Macros

Take me back to the Confluence User's Guide.

Sample Page Tree

This page is a sample, used to demonstrate the Pagetree macro.

For more information, take a look at the main page on the Pagetree Macro.

What you need to type What you will get

{pagetree:root=@parent|expandCollapseAll=false}

Another Sample Page Tree

We're using this page to demonstrate the Pagetree macro.

For more information, take a look at the main page on the Pagetree Macro.

What you need to type What you will get

{pagetree:root=@parent|expandCollapseAll=true}  Collapse all
Expand all Collapse all

Sample Page Tree 2

This is another sample page, used to demonstrate the Pagetree macro.

For more information, take a look at the main page on the Pagetree Macro.

What you need to type What you will get

{pagetree:root=@parent|expandCollapseAll=true}  Collapse all
Expand all Collapse all

Pagetree Search Macro

The Pagetree Search macro allows you to add a search box to your Confluence page. When a viewer enters a search term,
Confluence will search a hierarchy of pages starting from a specified parent (root) page and return the search results on a new
screen.

Below we tell you how to add the Pagetree Search macro to your page.
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#) Youmay beinterested in the Pagetree macro

You can also add a search box as part of a dynamic page tree, which looks like a table of contents. Read the
instructions on the Pagetree macro.

On this page:
® Usage with the Macro Browser

® Usage with the Wiki Markup Editor
® Macro Parameters

Usage with the Macro Browser
To insert the Pagetree Search macro into a page using the Macro Browser,

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Once you've found the Pagetree Search macro and have added the required parameter values, click ‘'insert' to add it
to your page.
Usage with the Wiki Markup Editor

Include the following markup in your page:

What you need to type  What you will get

{pagetreesearch}

Macro Parameters
When editing, you can click on the macro placeholder and choose Edit to display the parameters for this macro in the Macro
Browser.

Parameters are options that you can set for Confluence macros to control the content or format of the macro output. The table below
lists parameters for this macro that can be set in the Macro Browser.

Parameter Required? Default Description
Name of no none The name of the root page whose hierarchy of pages will be searched by this macro. If
Root Page this not specified, the root page is the current page.

(rootPage)

RELATED TOPICS

Pagetree Macro
Adding a Navigation Sidebar
Working with Macros

Take me back to the Confluence User's Guide.

Panel Macro

The Panel Macro allows you to display a block of text within a customisable panel, like a text box.

On this page:

Usage with the Macro Browser
Usage with the Wiki Markup Editor
Parameters

Notes

Related Topics

Usage with the Macro Browser
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To insert the Panel macro into a page using the Macro Browser,

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Usage with the Wiki Markup Editor

What you need to type What you will get
{panel} A simple

A simple panel panel

{panel}

{panel:titte=My My Title
Title|borderStyle=dashed|borderColor=blue|titteBGColor=#00a400|titleColor=white|bgColor=#72bc72} Y

A formatted panel PA
{panel} i formatted |

i panel ]

Parameters

When editing, you can click on the macro placeholder and choose Edit to display the parameters for this macro in the Macro
Browser.

Parameters are options that you can set for Confluence macros to control the content or format of the macro output. The table below
lists parameters for this macro that can be set in the Macro Browser.

Parameter Required? Default Description
Panel Title no none The title of the panel. If specified, this title will be displayed in its own title
(title) row.
Border Style no solid The style of the panel's border. Accepted values are 'solid', 'dashed' and
(borderstyle) other valid CSS border styles.
Border Colour no The colour of the panel's border.
(borderColor)
Border Pixel Width no The width of the panel's border (in pixels).
(Value Only)
(borderwidth)
Background Colour no The background colour of the panel.
(bgColor)
Title Background no The background colour of the title row of the panel.
Colour
(titleBGColor)
Title Text Colour no The colour of the text in the title row of the panel.
(titleColor)
Notes

® You can use panels within columns and table cells.

Related Topics

Working with Macros

Take me back to the Confluence User's Guide.

Profile Macro
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The Profile macro displays a short summary of any Confluence user's profile on your Confluence page or blog. This is the same
summary that appears in a Hover Profile, which appears whenever you mouse-over any user's name in the Confluence interface.

ﬂ The information contained within your own summarised profile can be edited using your User Profile view.

Screenshot: Example of the Profile Macro

Giles Gaskell

goaskell@atlassian.com

Working on final User Profile updates .’
Website: http: /o atlassian.com

Position: Technical Writer
Department: Development
Location: Sydney

On this page:
® Usage with the Macro Browser

® Usage with the Wiki Markup Editor
® Parameters

Usage with the Macro Browser

To insert the Profile macro into a page using the Macro Browser:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Once you've found the Profile macro and have added the required parameter values, click ‘insert' to add it to your page.
Usage with the Wiki Markup Editor

What you need to type Example of what you will get

{profile:user=ggaskell}

Giles Gaskell

ggaskelli@atlassian.com

“Waorking on final User Profile updates.”
Website: http:/fwww atlassian.com

Position: Technical Writer
Department: Development
Location: Sydney

Parameters

When editing, you can click on the macro placeholder and choose Edit to display the parameters for this macro in the Macro
Browser.

Parameters are options that you can set for Confluence macros to control the content or format of the macro output. The table below
lists parameters for this macro that can be set in the Macro Browser.

Parameter Required in Wiki Default Description

Markup?
Username yes none The username of the Confluence user whose profile summary you wish to
(user) show.
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RELATED TOPICS
Working with Macros

Take me back to the Confluence User's Guide.

Profile Picture Macro
The Profile Picture macro displays a user's profile picture on a page.

® When viewing the page, mouse-over the picture to see the Hover Profile for the user.
® When editing the page, click on the picture and choose View User Profile to see the profile for the user.

Edit View User Profile Remove

The Profile Picture macro is useful for such tasks as creating Team Pages that show all members of a project team.

On this page:

® Using the Profile Picture Macro
® Parameters
® Related Topics

Using the Profile Picture Macro

To add the Profile Picture macro to a page using the Macro Browser:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Parameters

When editing, you can click on the macro placeholder and choose Edit to display the parameters for this macro in the Macro
Browser.

Parameters are options that you can set for Confluence macros to control the content or format of the macro output. The table below
lists parameters for this macro that can be set in the Macro Browser.

Parameter Default Description

User none The username, or real name, of a Confluence user.

Related Topics

Working with Macros

Take me back to the Confluence User's Guide

Recently Updated Dashboard Macro

The Recently Updated Dashboard macro displays a list of the most recently changed content within Confluence. It is similar to the
Recently Updated macro but is intended for use on the Confluence dashboard.

On this page:
® Usage with the Macro Browser

® Parameters
® Related Topics

Usage with the Macro Browser

To insert the Recently Updated Dashboard macro into a page using the Macro Browser:
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1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Parameters

When editing, you can click on the macro placeholder and choose Edit to display the parameters for this macro in the Macro
Browser.

Parameters are options that you can set for Confluence macros to control the content or format of the macro output. The table below
lists parameters for this macro that can be set in the Macro Browser.

Parameter Default Description

Space(s) The space which Filter content by space. The macro will display only the pages etc which belong to the
contains the page space(s) you specify here. You can specify one or more space keys, separated by commas.
on which the macro ~ "*" means all spaces.
is added

Include all types Filter content by type. You can specify one or more types, separated by commas. Available

these types are: page, blogpost or news, spacedesc, attachment, comment, mail, userinfo.

Content

Types

Only

Label(s) none Filter content by label. The macro will display only the pages etc which are tagged with the

label(s) you specify here. You can specify one or more labels, separated by commas.

If there are no pages matching any of the specified labels, then Confluence will ignore
the labels and will list all recently updated pages, as well as showing a message, "These
labels don't exist and were ignored: xxx ". This unexpected behaviour is noted in issue

CONF-10167.
Width of 100% Specify the width of the macro display, as a percentage of the window width.
Table
Show false Select whether profile pictures of the users who updated the content are displayed.
User
Profile
Pictures

Related Topics

Recently Updated Macro
Viewing Recently Updated Content
Working with Macros

Take me back to the Confluence User's Guide.

Recently Updated Macro
The Recently Updated macro displays a list of the most recently changed content within Confluence.

0 The Recently Updated Dashboard macro is similar to this macro, but is intended for display on the Confluence dashboard.
On this page:

® Usage with the Macro Browser
® Usage with the Wiki Markup Editor
® Working Example of Usage
® Recently Updated
® Parameters
® Examples
® 1. Include content from all spaces
. Include content from specific spaces
. Specify the width of the display
. Filter content using labels
. Filter by content type
. Change the number of results in the list
. Display profile pictures
. Display recent comments, including profile pictures and text

O~NO U WNPE

Usage with the Macro Browser
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To insert the recently updated macro into a page using the Macro Browser:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Once you've found the recently updated macro and have added the required parameter values, click ‘insert' to add it to your
page.

Usage with the Wiki Markup Editor

{recently-updated}

Working Example of Usage

Below is a working example of the 'Recently Updated' macro which by default, lists 15 results.

What you need to type  What you will get

{recently-updated}
Recently Updated

* No recent updates found.

Parameters

When editing, you can click on the macro placeholder and choose Edit to display the parameters for this macro in the Macro
Browser.

Parameters are options that you can set for Confluence macros to control the content or format of the macro output. The
table below lists parameters for this macro that can be set in the Macro Browser.

Parameter Required? Default Description
Author(s) by no None Filter the results by author. The macro will display only the pages etc
username specified which were last modified by the author(s) you specify here.
(author) ie.
display You can specify one or more authors, separated by a comma or a
all space.
content
Label(s) no None Filter the results by label. The macro will display only the pages etc
(1abel) or ( specified which are tagged with the label(s) you specify here.
labels) ie.
display You can specify one or more label values, separated by a comma or a
all space.
content

® To exclude content which matches a given label, put a minus
sign (-) immediately in front of that label value. For example: If
you specify a label value of -badpage you will get only
content which is not labelled with 'badpage’.

® To indicate that the results must match a given label value,
put a plus sign (+) immediately in front of that label value. For
example: If you specify a label value of
+superpage, +goodpage you will get only content which has
at least two labels, being 'superpage' and 'goodpage’.

o If there are no pages matching any of the specified labels, then
Confluence will ignore the labels and will list all recently updated
pages, as well as showing a message, "These labels don't exist and
were ignored: xxx ". This unexpected behaviour is noted in issue

CONF-10167.
Maximum no 15 Specify the maximum number of results to be displayed. If this
Number of parameter is omitted, then a maximum of 15 results are displayed. The
Results theoretical maximum value that this parameter can accept is 2 to the
(max) or ( power of 31, minus 1 (or 2147483647), though this has been limited to
maxResults) 200 in the code, for performance reasons. More details are here.
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Show User no
Profile Pictures
(

showProfilePic

)

Space(s) no
(space) or (
spaces)

Include these no
Content Types

Only

(type) or (types)

Width of Table no
(width)
theme no
(theme)

false

@self,
i.e. the
space
which
contains
the page
on which
the
macro is
used

all types

100%

‘concise’
with the
heading
'Recently
Updated'

Specify showProfilePic=true to display the profile pictures of the
users who updated the content.

This parameter allows you to filter content by space. The macro will
display only the pages etc which belong to the space(s) you specify
here.

You can specify one or more space keys, separated by a comma or a
space.

® To exclude content in a specific space, put a minus sign (-)
immediately in front of that space key. For example: If you
specify a space key of -BADSPACE you will get only content
which is not in the BADSPACE.

® To indicate that the results must come from a specific space,
put a plus sign (+) immediately in front of that space key. For
example: If you specify a space key of +GOODSPACE you will
get only content in GOODSPACE. (Note that this is not
particularly useful, because each content item belongs to one
space only. If you put a plus sign next to one space key and
list other space keys too, the other space keys will be ignored.)

Special values:

@self — The current space.

@epersonal — All personal spaces.

@global — All global spaces.

@favorite — The spaces you have marked as favourite.
@favourite — The same as @efavorite above.

@all — All spaces in your Confluence site.

* — The same as @all above.

o When specifying a personal space, remember to use the tilde (~)
sign in front of the username, such as ~jbloggs or
~jbloggs@example.com.

This parameter allows you to filter content by content type. The macro
will display only the content of the type you specify here.

You can specify one or more types, separated by a comma or a space.

To exclude content of a given content type, put a minus sign (-)
immediately in front of that content type. For example: If you specify a
content type of -blogpost you will get pages and all other content
except for blog posts.

Available values:

page — Pages

blogpost or news — Blog posts, also known as news items.
comment — Comments on pages and blog posts.
attachment — Attachments.

status — Status updates made by other users.

Specify the width of the macro display, as a percentage of the window
width.

Choose the appearance of this macro:

® concise — the default list, showing the names of pages
which were updated or commented on, the users who made
the page modifications and time when the modifications
occurred.

® social — lists recent modifications in reverse chronological
order, but groups them by user into short time segments. A
'sub’ list appears within each user's time segment, showing the
names of pages which they updated or commented on and
time when these modifications occurred.

® sidebar — lists recent updates in reverse chronological
order, showing the names of pages which were updated or
commented on and time when the page modifications
occurred. This theme does not show authorship.
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Examples

1. Include content from all spaces

The code below will show all the pages from all the spaces that have been recently updated:

: {recently-updated:space=@all}

2. Include content from specific spaces

Use the code below to specify the spaces for which you want to view recently updated content:

: {recently-updated:space=SPACEKEY1, SPACEKEY2}

3. Specify the width of the display

Use the code below to limit the width of the display to 50% of the window:

H {recently-updated:width=50%} H

4. Filter content using labels

The code below will include recently updated content labelled with 'timesheets' or 'summaries', from the 'sales' and
'marketing' spaces, provided that the content is not labelled with 'obsolete":
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5. Filter by content type

Use the code below to show pages only (not news items, comments or any other content type):

i {recently-updated:type=page}

6. Change the number of results in the list

The code below changes the number of results listed (from the default value of 15) to 8:
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7. Display profile pictures

The code below will display the profile picture of the user who most recently updated the content.
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8. Display recent comments, including profile pictures and text

The code below will display recent comments in the current space, showing the profile picture of the users who made the
comments, plus the first line or two of the comment text.

B This is the only way to ensure that the text of the comments is displayed, using this macro.

: {recently—updated—dashboard:types:comment|showProfilePic=true}
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@ Customising the wording

If you would like to change the wording displayed by the 'Recently Updated' macro, please refer to the
document on modifying the Confluence interface text.

Related Topics

Recently Updated Dashboard Macro
Viewing Recently Updated Content
Working with Macros

Take me back to the Confluence User's Guide.

RSS Feed Macro

The RSS feed macro embeds an RSS feed on a page. It can display the contents of external feeds, or of internal feeds
generated by Confluence. To display blog posts or to list recently updated pages in a space, use the Feed Builder to create
an internal feed, then render it using this macro.

.a CAUTION: Including unknown HTML inside a webpage is dangerous.

HTML inside an RSS feed can contain active scripting components. This means that it would be possible
for a malicious attacker to present a user of your site with script that their web browser would believe
came from you. Such code could be used, for example, to steal a user's authentication cookie and give
the attacker their Confluence login password.

The RSS macro will only be available if it has been enabled by your Confluence administrator. Also, your Confluence
Administrator can define a whitelist of trusted URLs. You will see an error message on the Confluence page, if the included
URL is not in the whitelist.

On this page:

Usage with the Macro Browser
Usage with the Wiki Markup Editor
Parameters
Examples
¢ 1. Limit the number of entries displayed
® 2. Show only the RSS feed titles
® 3. Hide the feeds titlebar
Working Example
How Up to Date is the Feed?
What Happens to a Page Containing a Disallowed URL?
Authentication
Accessing Internal HTTPS Feeds
Related Topics

Usage with the Macro Browser
To insert the RSS feed macro into a page using the Macro Browser,

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Once you've found the RSS feed macro and have added the required parameter values, click ‘insert' to add it
to your page.

Usage with the Wiki Markup Editor
Use the Wiki Markup editor to edit the page and insert the RSS macro. Replace the

http://www.example.com/rss/

" URL with your own feed link in this example:
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Parameters

When editing, you can click on the macro placeholder and choose Edit to display the parameters for this macro in the Macro
Browser.

Parameters are options that you can set for Confluence macros to control the content or format of the macro output. The
table below lists parameters for this macro that can be set in the Macro Browser.

Parameter Required? Default Description
RSS Feed URL yes none The URL of the RSS feed link you want to show.
(url)
Maximum Number of Entries no 15 Limit the number of entries displayed.
(max)
Show Item Titles Only no false Show only the titles of the news items, not the content.
(showTitlesOnly)
Show Name/Title of RSS Feed no true Hide the feeds title bar.
(titleBar)
Examples

1. Limit the number of entries displayed

r

—~
s
n
n
c
R
s
I
=
(s
T
Qg
~
S~
=
0
n
u
Q
o
3
S~
]
(0]
(]
%
3
=
r
b
o
o
o
@
Q
R
I
&
Q@
o
(]
o

Working Example

What you need to type:
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What you will get:

Error rendering macro 'rss' : null

How Up to Date is the Feed?

By default, the RSS Feed macro caches the feed results for 60 minutes before fetching the data again.

If you wish to change the default caching, use the {cache} macro to define how often the RSS Feed macro fetches the feed
updates. You may want to set the cache to a longer period, so that your page loads faster. Or you may want to retrieve feed
results more often, if you need to see the updates sooner. You will need to install the Cache plugin page onto your
Confluence site.

To enable caching:
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1. Using the Confluence Repository, install the ‘Scripting Plugin' and the 'Utilities Plugin'.
2. For each RSS macro that you wish to cache, surround your RSS macro with a Cache macro. For example, to cache
feeds for 30 minutes:

{cache:refresh=30m}
{rss:url=http://rss.news.yahoo.com/rss/stocks|max=5}

{cache}

The Cache plugin page provides more information on customising the cache behaviour.

What Happens to a Page Containing a Disallowed URL?

Your Confluence Administrator can set up a whitelist of allowed URLSs. If this is the case, you may see an error on the pages
which contain the RSS macro.

A user can add the RSS macro or the HTML-include macro to a Confluence page. The macro code includes a URL from
which the content is drawn. When the page is displayed, Confluence will check the URL against the whitelist. If the URL is
not allowed, Confluence will display an error message on the page.

The error message says that Confluence "could not access the content at the URL because it is not from an allowed source"
and displays the offending URL. If the person viewing the page is a Confluence Administrator, they will also see a link to the
Administration page where they can configure the URL whitelist.

Here is an example of the error message, including the link shown only to Confluence Administrators:

Could not access the content at the URL because it is not from an allowed source.
http://ffeathers wordpress.com

Configure whitelist ==

Here is an example of the error message, but without the link.

Could not access the content at the URL because it is not from an allowed source.

http:/fffeathers wordpress_com

You may contact your site administrator and request that this URL be added to the list of allowed sources.

Authentication

Private Feeds from External Sites

RSS feeds which require authentication cannot be accessed using the RSS Macro.

Accessing Internal HTTPS Feeds

This applies only to Confluence instances which have enabled HTTPS for all content. If your site is fully HTTPS, the RSS
macro cannot access internal feeds. To enable the RSS macro to access internal feeds without affecting your HTTPS setup,
enable local-only HTTP access:

1. Shut down Confluence.

2. Consult the SSL guide to enable HTTP access to Confluence. You'll want to ensure that you have an HTTP
connector and an SSL connector, both commented in. This means that Confluence will be accessible via both
HTTP and HTTPS. However, you should not have a redirect port, nor rules in web.xml to redirect all traffic.

3. Instead of using web.xml to redirect traffic, insert a firewall rule to redirect all HTTP requests not from the
Confluence server to the equivalent HTTPS URL. This ensures that users will only be able to access Confluence
via HTTPS, as intended. If you have still left HTTP access for attachments enabled (to avoid the IE download bug)
you must selectively enable those URLS as well.

4. Modify your Confluence RSS macro feed link to use the HTTP URL, and restart Confluence.

Related Topics

Subscribing to RSS Feeds within Confluence
Watching Changes

Working with Macros

Configuring a URL Whitelist
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Return to the Confluence User's Guide.

Search Macro

The Search macro searches your Confluence site based on search terms specified in the macro code, and displays the
results on the wiki page.

On this page:

® Usage with the Macro Browser
® Usage with the Wiki Markup Editor
® Found 0 search result(s) for my_query.
® Parameters
1. Setting a limit to the number of search results displayed
2. Specifying the key of the space you want to search
3. Specifying the content type
4. Specifying a time period in which the content was last modified
5. Limiting the search results to content created or modified by a specific user

Usage with the Macro Browser
To insert the search macro into a page using the Macro Browser,

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Once you've found the search macro and have added the required parameter values, click 'insert' to
add it to your page.

Usage with the Wiki Markup Editor

In the example below, we assume that you want to search for all pages and other content types which contain the
term 'my_query".

What you need to type What you will get

{search:query=my_query}
Found 0 search result(s) for my_query.

Parameters

When editing, you can click on the macro placeholder and choose Edit to display the parameters for this macro in
the Macro Browser.

Parameters are options that you can set for Confluence macros to control the content or format of the macro output.
The table below lists parameters for this macro that can be set in the Macro Browser.

Parameter Required? Default Description
Search Terms yes none The search terms which this macro will use to generate its results.
(query)

You can refine your search query by using operators such as 'AND’
and 'OR'. For example:

® |n the macro browser Search Terms entry box:
my queryl AND my query?2

® In wiki markup editor: {search:query=my queryl AND
my query2}

For more information, take a look at the documentation on
the Confluence search syntax.

Maximum no 10 Set a limit to the number of search results displayed.

Number of
Results
(maxLimit)
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Restrict to this  no all Specify the key of the space you want to search in. Note that this is
Space Key case sensitive.

(spacekey)

Content Type no all Specify the content type. The content types are: page, comment,
(type) blogpost, attachment, userinfo (the content of user profiles only),

spacedesc (the content of space descriptions only) and mail.

Last Modified no all Specify a period of time in weeks, days, hours and/or minutes, to
( see the content modified within that time frame. For example:
lastModified

) ® 2h 35m

3d 30m

These are the values you can use:

w = weeks

d = days

h = hours

m = minutes

If no time category is specified, Confluence assumes
minutes.

If you specify more than one time period (e.g. weeks and
days), the periods must be separated by a space and they
can come in any order.

The time categories are not case sensitive e.g. '4d' is the

same as '4D'.
Restrict to this ~ no all Specify the username of a Confluence user, to show only content
Username created or updated by that user.
(contributor
)

1. Setting a limit to the number of search results displayed

Display a maximum of 20 results.
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2. Specifying the key of the space you want to search

Global space: Search within the Doctemp space only.
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3. Specifying the content type

Search within comments only.

o
I}
9
I
Q
5
Q
c
o
5
T
3
|“<
\Q
c
o
i
<
or
~
o]
1
Q
E
3
O
5
=4

4. Specifying a time period in which the content was last modified

Search for content modified in the last one week and two days.
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5. Limiting the search results to content created or modified by a specific user
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Search within content created or updated by jsmith only.

ﬁ Permissions

When a user views the page containing the Search macro, the search results will show only
pages and other content types for which the user has 'View' permission.

RELATED TOPICS

Livesearch Macro
Searching Confluence
Working with Macros

Take me back to the Confluence User's Guide.

Section Macro

The section macro allows you to define a section of a page in which you can insert one or more columns across
the page.

To add sections and columns to a page:
1. Insert a pair of section macro elements to define the section of page that will contain your set of columns.
2. Within this pair of section macro elements, insert a pair of column macro elements. Please note, all content
within your section elements must be enclosed by a pair of column macro elements. If you do not do this,
the section macro will not work.
3. Repeat step 2 for each column you want to insert across this section of the page.
On this page:
® Usage with the Macro Browser

® Usage with the Wiki Markup Editor
® Parameters

Usage with the Macro Browser
To insert the section macro into a page using the Macro Browser,

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Once you've found the section macro and have added the required parameter values, click 'insert' to
add it to your page.

Usage with the Wiki Markup Editor

What you need to type What you will get

{section:border=true}
{column}Column one text goes here{column}

Column one text
{column}Column two text goes here{column}

goes here
{section}
Column two text
goes here
Parameters
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When editing, you can click on the macro placeholder and choose Edit to display the parameters for this macro in
the Macro Browser.

Parameters are options that you can set for Confluence macros to control the content or format of the macro output.
The table below lists parameters for this macro that can be set in the Macro Browser.

Parameter Required? Default Description

Show no false Determines whether to draw a border around the section and
Border columns.

(border)

RELATED TOPICS

Working with Macros
Working with Tables

Take me back to the Confluence User's Guide.

Space Details Macro

The Space Details macro renders the space's details in a table within the page.
On this page:

® Usage with the Macro Browser
® Usage with the Wiki Markup Editor
® Parameters

Usage with the Macro Browser
To insert the space details macro into a page using the Macro Browser,

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Once you've found the space details macro, click 'insert' to add it to your page.

Usage with the Wiki Markup Editor

What you What you will get
need to type

space-details
tsp } Name: Confluence 4.0

Key: DOC

Home Page: Home page: Confluence Documentation Home

Created By: Mike Cannon-Brookes (Dec 17, 2003)

Space Labels: (None)

Space Categories: (None)

Description: Documentation for the latest version of the Confluence wiki: Installation Guide,
User Guide, Admin Guide and other technical documentation

Parameters

When editing, you can click on the macro placeholder and choose Edit to display the parameters for this macro in
the Macro Browser.

Parameters are options that you can set for Confluence macros to control the content or format of the macro output.
The table below lists parameters for this macro that can be set in the Macro Browser.

Parameter Required? Default Description

Width of no 100% The width of the space details table, specified as a percentage (%) of
Table the page width.

(width)
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RELATED TOPICS

Viewing Space Details
Editing Space Details
Working with Macros

Take me back to the Confluence User's Guide.

Space Jump Macro

This page describes the Space Jump Macro, provided with the Documentation theme. You can use space jumping
to link from a page in one space to a page with the same name in another space, without knowing the name of the
page when you create the link.

The Space Jump macro inserts a link onto the page. When the reader clicks the link, they will jump to a page that
has the same name in another space. You specify the space when you insert the Space Jump macro.

Example: We use the Space Jump macro to put a standard message at the top of our archive spaces, telling
people that they’re reading an old version of the documentation and letting them jump quickly to the same page in
the latest documentation. See the words 'this page in the current documentation' in the screenshot below.

Screenshot: One way of using the Space Jump macro

This documentation relates to an earlier version of Crowd.
View this page in the current docum 8 tation or wisit the current documentation home

x .—// Edit gk Add ~ £ Toc
Changmg or Resettlng your Password

Sarah Maddox [Allassian Technical W Sarah Maddox [Alassian Technical Writer]

If you are authorised to use Crowd, you can log in to Crowd's Self-Senice Console and change your password

On this page:

Usage with the Macro Browser
Usage with the Wiki Markup Editor
Parameters

Examples

More Information

Usage with the Macro Browser
To insert the Space Jump macro into a page using the Macro Browser,

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Usage with the Wiki Markup Editor

What you need to type What you will get
{spacejump:CONF31|alias=This page in the Confluence 3.1 This page in the Confluence 3.1
documentation} documentation

Parameters

When editing, you can click on the macro placeholder and choose Edit to display the parameters for this macro in
the Macro Browser.

Parameters are options that you can set for Confluence macros to control the content or format of the macro output.
The table below lists parameters for this macro that can be set in the Macro Browser.

Parameter Default Description

Alias None The text to display as the hyperlinked text. If you do not supply an alias, Confluence will
(alias) display the page name.
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Examples

To jump to a page in the 'MYSPACE' space, displaying the page name as the linked text:

{spacejump:MYSPACE}

To jump to a page in the 'MYSPACE' space, displaying 'another version of this page' as the linked text:

{spacejump:MYSPACE|alias=another version of this page}

More Information

What happens if there is no page with the same name in the target space?
For the space jump to work, the target space must contain a page with the same name as the page that renders the
{spacejump} macro. If the target space does not contain such a page, you will see a broken link. Confluence

handles this in its usual manner: the link is coloured red. If you click the link, Confluence offers to create the page
for you.

Can | use the Space Jump macro in any space?

Yes. You can use the Space Jump macro in any space, even if that space is not currently using the Documentation
theme. Provided that the Documentation theme plugin and its components are installed and enabled on your
Confluence site, the Space Jump macro is available in any space.

RELATED TOPICS

Configuring the Documentation Theme
Working with Macros

Take me back to the Confluence User's Guide.

Spaces List Macro

The Spaces List Macro is used to display a list of spaces from within a page, similar to the list of spaces seen on
the dashboard.

On this page:

® Usage with the Macro Browser

® Usage with the Wiki Markup Editor
® Parameters

® Related Topics

Usage with the Macro Browser

To insert the spaces list macro into a page using the Macro Browser:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Usage with the Wiki Markup Editor

What you What you will get

need to

type

{spaces} ® All

or ® Spaces: kayourite
{spaces-list} ® Category
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Space:

Space:

Space:

Space:

Space:

Space:

Space:

Space:

Space:

Space:

Space:

Space:

Application Links 1.x

Documentation for AppLinks version

1.x

Application Links 2.0
Documentation for AppLinks 2.0

Application Links 2.1
Documentation for AppLinks 2.1

Application Links 3.0
Documentation for AppLinks 3.0

Application Links 3.2
Documentation for AppLinks 3.2

Application Links 3.3
Documentation for AppLinks 3.3

Application Links 3.4
Documentation for AppLinks 3.4

Application Links 3.5

Documentation for the latest version of

AppLinks.

Application Links 3.5 Archive
Documentation for AppLinks 3.5

AtlasCamp 2010

AtlasCamp 2011

Atlassian Bonfire

Documentation for the latest version of

Bonfire

Browse the "APPLINKSO011" space You don't
have permission to add pages to
"APPLINKSO011"

Remove "Application Links 1.x" from your
favourites Add "Application Links 1.x" to your
favourites Loading

Browse the "APPLINKS020" space You don't
have permission to add pages to
"APPLINKS020"

Remove "Application Links 2.0" from your
favourites Add "Application Links 2.0" to your
favourites Loading

Browse the "APPLINKS021" space You don't
have permission to add pages to
"APPLINKS021"

Remove "Application Links 2.1" from your
favourites Add "Application Links 2.1" to your
favourites Loading

Browse the "APPLINKSO030" space You don't
have permission to add pages to
"APPLINKS030"

Remove "Application Links 3.0" from your
favourites Add "Application Links 3.0" to your
favourites Loading

Browse the "APPLINKSO032" space You don't
have permission to add pages to
"APPLINKS032"

Remove "Application Links 3.2" from your
favourites Add "Application Links 3.2" to your
favourites Loading

Browse the "APPLINKS033" space You don't
have permission to add pages to
"APPLINKS033"

Remove "Application Links 3.3" from your
favourites Add "Application Links 3.3" to your
favourites Loading

Browse the "APPLINKS034" space You don't
have permission to add pages to
"APPLINKS034"

Remove "Application Links 3.4" from your
favourites Add "Application Links 3.4" to your
favourites Loading

Browse the "APPLINKS" space You don't have
permission to add pages to "APPLINKS"
Remove "Application Links 3.5" from your
favourites Add "Application Links 3.5" to your
favourites Loading

Browse the "APPLINKSO035" space You don't
have permission to add pages to
"APPLINKS035"

Remove "Application Links 3.5 Archive" from
your favourites Add "Application Links 3.5
Archive" to your favourites Loading

Browse the "ATL" space You don't have
permission to add pages to "ATL"
Remove "AtlasCamp 2010" from your
favourites Add "AtlasCamp 2010" to your
favourites Loading

Browse the "CAMP" space Add a page to
"CAMP"

Remove "AtlasCamp 2011" from your
favourites Add "AtlasCamp 2011" to your
favourites Loading

Browse the "BONFIRE" space You don't have
permission to add pages to "BONFIRE"
Remove "Atlassian Bonfire" from your
favourites Add "Atlassian Bonfire" to your
favourites Loading
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Space:

Space:

Space:

Space:

Space:

Space:

Space:

Space:

Space:

Space:

Space:

Space:

Space:

Atlassian Customer Resources

Atlassian Developer Network

For the community of developers
modifying and extending Atlassian
products.

Atlassian Development

Atlassian Developers. Because they're
just too good to be kept hidden in an
office in Sydney.

Atlassian Documentation

Information about and links to the
Atlassian product documentation,
including downloadable documentation

Atlassian Events

Atlassian IDE Connectors
Documentation for the Atlassian
Connectors for Eclipse and IntelliJ
IDEA

Atlassian Integration Guide

The ways your Atlassian applications
work together and how you can make
it happen

Atlassian KnowledgeBase

Atlassian OnDemand
The current documentation for
Atlassian OnDemand

Atlassian OnDemand Test Space
Documentation for the current version
of JIRA Studio.

Atlassian Partner Wiki

Atlassian Presentations

Atlassian Training

Browse the "CUST" space You don't have
permission to add pages to "CUST"

Remove "Atlassian Customer Resources" from
your favourites Add "Atlassian Customer
Resources" to your favourites Loading

Browse the "DEVNET" space You don't have
permission to add pages to "DEVNET"
Remove "Atlassian Developer Network" from
your favourites Add "Atlassian Developer
Network" to your favourites Loading

Browse the "DEV" space You don't have
permission to add pages to "DEV"

Remove "Atlassian Development" from your
favourites Add "Atlassian Development" to your
favourites Loading

Browse the "ALLDOC" space You don't have
permission to add pages to "ALLDOC"
Remove "Atlassian Documentation” from your
favourites Add "Atlassian Documentation” to
your favourites Loading

Browse the "EVENTS" space You don't have
permission to add pages to "EVENTS"
Remove "Atlassian Events" from your
favourites Add "Atlassian Events" to your
favourites Loading

Browse the "IDEPLUGIN" space You don't
have permission to add pages to "IDEPLUGIN"
Remove "Atlassian IDE Connectors" from your
favourites Add "Atlassian IDE Connectors" to
your favourites Loading

Browse the "ATLAS" space You don't have
permission to add pages to "ATLAS"
Remove "Atlassian Integration Guide" from
your favourites Add "Atlassian Integration
Guide" to your favourites Loading

Browse the "KB" space You don't have
permission to add pages to "KB"

Remove "Atlassian KnowledgeBase" from your
favourites Add "Atlassian KnowledgeBase" to
your favourites Loading

Browse the "AOD" space You don't have
permission to add pages to "AOD"

Remove "Atlassian OnDemand" from your
favourites Add "Atlassian OnDemand" to your
favourites Loading

Browse the "AODTest" space You don't have
permission to add pages to "AODTest"
Remove "Atlassian OnDemand Test Space"
from your favourites Add "Atlassian OnDemand
Test Space" to your favourites Loading

Browse the "APW" space You don't have
permission to add pages to "APW"

Remove "Atlassian Partner Wiki" from your
favourites Add "Atlassian Partner Wiki" to your
favourites Loading

Browse the "ATLP" space You don't have
permission to add pages to "ATLP"

Remove "Atlassian Presentations" from your
favourites Add "Atlassian Presentations" to your
favourites Loading

Browse the "Training" space You don't have
permission to add pages to "Training"
Remove "Atlassian Training" from your
favourites Add "Atlassian Training" to your
favourites Loading
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Space:

Space:

Space:

Space:

Space:

Space:

Atlassian Translations

Atlassian t-shirt Competition

Atlassian User Group

Atlassian User Interface (AUI)

Atlassian User Management 1.0
Documentation for version 1.0 of the
Atlassian user management interface,
as used in Confluence and JIRA.

Atlassian User Management 2.0
Documentation for version 2.0 of the
Atlassian user management interface,
as used in Confluence and JIRA.

Atlassian User Management 3.0
Documentation for the latest version of
the Atlassian user management
interface, as used in Confluence and
JIRA.

Atlassian Webinars

Bamboo 1.0
Documentation for Bamboo 1.0

Bamboo 1.1
Documentation for Bamboo 1.1

Bamboo 1.2
Documentation for Bamboo 1.2

Bamboo 2.0
Documentation for Bamboo 2.0

Bamboo 2.1
Documentation for Bamboo 2.1

Browse the "TRANS" space You don't have
permission to add pages to "TRANS"

Remove "Atlassian Translations" from your
favourites Add "Atlassian Translations" to your
favourites Loading

Browse the "tshirt" space You don't have
permission to add pages to "tshirt"

Remove "Atlassian t-shirt Competition" from
your favourites Add "Atlassian t-shirt
Competition" to your favourites Loading

Browse the "AUG" space Add a page to "AUG"
Remove "Atlassian User Group" from your
favourites Add "Atlassian User Group" to your
favourites Loading

Browse the "AUI" space You don't have
permission to add pages to "AUI"

Remove "Atlassian User Interface (AUI)" from
your favourites Add "Atlassian User Interface
(AUI)" to your favourites Loading

Browse the "USERMANO10" space You don't
have permission to add pages to
"USERMANO10"

Remove "Atlassian User Management 1.0"
from your favourites Add "Atlassian User
Management 1.0" to your favourites Loading

Browse the "USERMANO020" space You don't
have permission to add pages to
"USERMANO020"

Remove "Atlassian User Management 2.0"
from your favourites Add "Atlassian User
Management 2.0" to your favourites Loading

Browse the "USERMAN" space You don't have
permission to add pages to "USERMAN"
Remove "Atlassian User Management 3.0"
from your favourites Add "Atlassian User
Management 3.0" to your favourites Loading

Browse the "WEBINAR" space You don't have
permission to add pages to "WEBINAR"
Remove "Atlassian Webinars" from your
favourites Add "Atlassian Webinars" to your
favourites Loading

Browse the "BAMBOOO010" space You don't
have permission to add pages to
"BAMBOOO010"

Remove "Bamboo 1.0" from your favourites
Add "Bamboo 1.0" to your favourites Loading

Browse the "BAMBOOO011" space You don't
have permission to add pages to
"BAMBOOO11"

Remove "Bamboo 1.1" from your favourites
Add "Bamboo 1.1" to your favourites Loading

Browse the "BAMBOOO012" space You don't
have permission to add pages to
"BAMBOOO012"

Remove "Bamboo 1.2" from your favourites
Add "Bamboo 1.2" to your favourites Loading

Browse the "BAMBOOO020" space You don't
have permission to add pages to
"BAMBOOO020"

Remove "Bamboo 2.0" from your favourites
Add "Bamboo 2.0" to your favourites Loading

Browse the "BAMBOOO021" space You don't
have permission to add pages to
"BAMBOOO021"

Remove "Bamboo 2.1" from your favourites
Add "Bamboo 2.1" to your favourites Loading
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Space:

Space:

Space:

Space:

Space:

Space:

Space:

Space:

Space:

Space:

Space:

Space:

Bamboo 2.2
Documentation for Bamboo 2.2

Bamboo 2.3
Documentation for Bamboo 2.3

Bamboo 2.4
Documentation for Bamboo 2.4

Bamboo 2.5
Documentation for Bamboo 2.5

Bamboo 2.6
Documentation for Bamboo 2.6

Bamboo 2.7
Documentation for Bamboo 2.7

Bamboo 2.7 Archive Backup

Archived Documentation for Bamboo
2.7 (supersedes BAMBOOO027 space)

Bamboo 3.0
Documentation for Bamboo 3.0

Bamboo 3.1
Documentation for Bamboo 3.1

Bamboo 3.2

Documentation for the latest version of

Bamboo

Bamboo Development

Bamboo Extensions

Bamboo Knowledge Base

Troubleshooting and support tips for

Bamboo

Browse the "BAMBOO022" space You don't
have permission to add pages to
"BAMBOOO022"

Remove "Bamboo 2.2" from your favourites
Add "Bamboo 2.2" to your favourites Loading

Browse the "BAMBOO023" space You don't
have permission to add pages to
"BAMBOO023"

Remove "Bamboo 2.3" from your favourites
Add "Bamboo 2.3" to your favourites Loading

Browse the "BAMBOO024" space You don't
have permission to add pages to
"BAMBOO024"

Remove "Bamboo 2.4" from your favourites
Add "Bamboo 2.4" to your favourites Loading

Browse the "BAMBOOO025" space You don't
have permission to add pages to
"BAMBOOO025"

Remove "Bamboo 2.5" from your favourites
Add "Bamboo 2.5" to your favourites Loading

Browse the "BAMBOOO026" space You don't
have permission to add pages to
"BAMBOO026"

Remove "Bamboo 2.6" from your favourites
Add "Bamboo 2.6" to your favourites Loading

Browse the "BAMBOOO027" space You don't
have permission to add pages to
"BAMBOOO027"

Remove "Bamboo 2.7" from your favourites
Add "Bamboo 2.7" to your favourites Loading

Browse the "BAMBOOO027A" space You don't
have permission to add pages to
"BAMBOOO027A"

Remove "Bamboo 2.7 Archive Backup" from
your favourites Add "Bamboo 2.7 Archive
Backup" to your favourites Loading

Browse the "BAMBOOO030" space You don't
have permission to add pages to
"BAMBOOO030"

Remove "Bamboo 3.0" from your favourites
Add "Bamboo 3.0" to your favourites Loading

Browse the "BAMBOOO031" space You don't
have permission to add pages to
"BAMBOOO031"

Remove "Bamboo 3.1" from your favourites
Add "Bamboo 3.1" to your favourites Loading

Browse the "BAMBOO" space You don't have
permission to add pages to "BAMBOOQO"
Remove "Bamboo 3.2" from your favourites
Add "Bamboo 3.2" to your favourites Loading

Browse the "BAMBOODEV" space You don't
have permission to add pages to
"BAMBOODEV"

Remove "Bamboo Development" from your
favourites Add "Bamboo Development" to your
favourites Loading

Browse the "BAMEXT" space You don't have
permission to add pages to "BAMEXT"
Remove "Bamboo Extensions" from your
favourites Add "Bamboo Extensions" to your
favourites Loading

Browse the "BAMKB" space You don't have
permission to add pages to "BAMKB"

Remove "Bamboo Knowledge Base" from your
favourites Add "Bamboo Knowledge Base" to
your favourites Loading
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Bitbucket
Documentation for Atlassian Bitbucket

Bitbucket Knowledge Base
Troubleshooting and support tips for
Bitbucket

Clover 2.0
Documentation for Clover 2.0

Clover 2.1
Documentation for Clover 2.1

Clover 2.3
Documentation for Clover 2.3

Clover 2.4
Documentation for Clover 2.4

Clover 2.5
Documentation for Clover 2.5

Clover 2.6
Documentation for Clover 2.6

Clover 3.0
Documentation for Clover 3.0

Clover 3.1
Documentation for the latest version of
Clover

Clover Knowledge Base
Troubleshooting and support tips for
Clover

Codegeist
Atlassian's Codegeist! :)

Confluence 1.4 User Guide
User Guide for Confluence 1.4

Confluence 2.0
User Guide for Confluence version 2

Browse the "BITBUCKET" space You don't
have permission to add pages to "BITBUCKET"
Remove "Bitbucket" from your favourites Add
"Bitbucket" to your favourites Loading

Browse the "BBKB" space You don't have
permission to add pages to "BBKB"

Remove "Bitbucket Knowledge Base" from your
favourites Add "Bitbucket Knowledge Base" to
your favourites Loading

Browse the "CLOVERO020" space You don't
have permission to add pages to
"CLOVERO020"

Remove "Clover 2.0" from your favourites Add
"Clover 2.0" to your favourites Loading

Browse the "CLOVERO021" space You don't
have permission to add pages to
"CLOVERO021"

Remove "Clover 2.1" from your favourites Add
"Clover 2.1" to your favourites Loading

Browse the "CLOVERO023" space You don't
have permission to add pages to
"CLOVER023"

Remove "Clover 2.3" from your favourites Add
"Clover 2.3" to your favourites Loading

Browse the "CLOVERO024" space You don't
have permission to add pages to
"CLOVERO024"

Remove "Clover 2.4" from your favourites Add
"Clover 2.4" to your favourites Loading

Browse the "CLOVERO025" space You don't
have permission to add pages to
"CLOVERO025"

Remove "Clover 2.5" from your favourites Add
"Clover 2.5" to your favourites Loading

Browse the "CLOVERO026" space You don't
have permission to add pages to
"CLOVERO026"

Remove "Clover 2.6" from your favourites Add
"Clover 2.6" to your favourites Loading

Browse the "CLOVERO030" space You don't
have permission to add pages to
"CLOVERO030"

Remove "“Clover 3.0" from your favourites Add
"Clover 3.0" to your favourites Loading

Browse the "CLOVER" space You don't have
permission to add pages to "CLOVER"
Remove "Clover 3.1" from your favourites Add
"Clover 3.1" to your favourites Loading

Browse the "CLOVERKB" space You don't
have permission to add pages to "CLOVERKB"
Remove "Clover Knowledge Base" from your
favourites Add "Clover Knowledge Base" to
your favourites Loading

Browse the "CODEGEIST" space Add a page
to "CODEGEIST"

Remove "Codegeist" from your favourites Add
"Codegeist" to your favourites Loading

Browse the "CONF14" space You don't have
permission to add pages to "CONF14"
Remove "Confluence 1.4 User Guide" from
your favourites Add "Confluence 1.4 User
Guide" to your favourites Loading

Browse the "CONF20" space You don't have
permission to add pages to "CONF20"
Remove "Confluence 2.0" from your favourites
Add "Confluence 2.0" to your favourites
Loading
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Space:

Space:

Space:
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Confluence 2.10
Complete documentation for
Confluence version 2.10

Confluence 2.5
Complete documentation for
Confluence versions 2.0 to 2.5.3.

Confluence 2.5.6
Complete documentation for

Confluence versions 2.5.4 to 2.5.8.

Confluence 2.6
Complete documentation for
Confluence version 2.6

Confluence 2.7
Complete documentation for
Confluence version 2.7

Confluence 2.8
Complete documentation for
Confluence version 2.8

Confluence 2.9
Complete documentation for
Confluence version 2.9

Confluence 3.0
Complete documentation for
Confluence version 3.0

Confluence 3.1
Complete documentation for
Confluence version 3.1

Confluence 3.2
Complete documentation for
Confluence version 3.2

Confluence 3.3
Complete documentation for
Confluence version 3.3

Confluence 3.4
Complete documentation for
Confluence version 3.4

Confluence 3.5
Complete documentation for
Confluence version 3.5

Browse the "CONF210" space You don't have
permission to add pages to "CONF210"
Remove "Confluence 2.10" from your favourites
Add "Confluence 2.10" to your favourites
Loading

Browse the "CONF25" space You don't have
permission to add pages to "CONF25"
Remove "Confluence 2.5" from your favourites
Add "Confluence 2.5" to your favourites
Loading

Browse the "CONF256" space You don't have
permission to add pages to "CONF256"
Remove "Confluence 2.5.6" from your
favourites Add "Confluence 2.5.6" to your
favourites Loading

Browse the "CONF26" space You don't have
permission to add pages to "CONF26"
Remove "Confluence 2.6" from your favourites
Add "Confluence 2.6" to your favourites
Loading

Browse the "CONF27" space You don't have
permission to add pages to "CONF27"
Remove "Confluence 2.7" from your favourites
Add "Confluence 2.7" to your favourites
Loading

Browse the "CONF28" space You don't have
permission to add pages to "CONF28"
Remove "Confluence 2.8" from your favourites
Add "Confluence 2.8" to your favourites
Loading

Browse the "CONF29" space You don't have
permission to add pages to "CONF29"
Remove "Confluence 2.9" from your favourites
Add "Confluence 2.9" to your favourites
Loading

Browse the "CONF30" space You don't have
permission to add pages to "CONF30"
Remove "Confluence 3.0" from your favourites
Add "Confluence 3.0" to your favourites
Loading

Browse the "CONF31" space You don't have
permission to add pages to "CONF31"
Remove "Confluence 3.1" from your favourites
Add "Confluence 3.1" to your favourites
Loading

Browse the "CONF32" space You don't have
permission to add pages to "CONF32"
Remove "Confluence 3.2" from your favourites
Add "Confluence 3.2" to your favourites
Loading

Browse the "CONF33" space You don't have
permission to add pages to "CONF33"
Remove "Confluence 3.3" from your favourites
Add "Confluence 3.3" to your favourites
Loading

Browse the "CONF34" space You don't have
permission to add pages to "CONF34"
Remove "Confluence 3.4" from your favourites
Add "Confluence 3.4" to your favourites
Loading

Browse the "CONF35" space You don't have
permission to add pages to "CONF35"
Remove "Confluence 3.5" from your favourites
Add "Confluence 3.5" to your favourites
Loading
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Space:

Space:

Space:

Space:

Space:

Space:

Confluence 4.0

Documentation for the latest version of
the Confluence wiki: Installation Guide,
User Guide, Admin Guide and other
techn...

Confluence Development

Confluence Evaluator Resources

Confluence Extensions

Confluence Homepage Image

Confluence Hosted Evaluator
Resources

Confluence Knowledge Base
Troubleshooting and support tips for
Confluence

Confluence SharePoint Connector 1.0
Documentation for version 1.0.x of the
Confluence SharePoint Connector.

Confluence SharePoint Connector 1.1
Documentation for version 1.1.x of the
Confluence SharePoint Connector.

Confluence SharePoint Connector 1.2
Documentation for the Confluence
SharePoint Connector 1.2. This
product integrates Confluence with
Microsoft SharePoint.

Confluence SharePoint Connector 1.3
Documentation for the Confluence
SharePoint Connector 1.3. This
product integrates Confluence with
Microsoft SharePoint.

Confluence SharePoint Connector 1.4
Documentation for the Confluence
SharePoint Connector 1.4. This
product integrates Confluence with
Microsoft SharePoint.

Browse the "DOC" space You don't have
permission to add pages to "DOC"

Remove "Confluence 4.0" from your favourites
Add "Confluence 4.0" to your favourites
Loading

Browse the "CONFDEV" space You don't have
permission to add pages to "CONFDEV"
Remove "Confluence Development" from your
favourites Add "Confluence Development" to
your favourites Loading

Browse the "CONFDEVAL" space You don't
have permission to add pages to
"CONFDEVAL"

Remove "Confluence Evaluator Resources"
from your favourites Add "Confluence Evaluator
Resources" to your favourites Loading

Browse the "CONFEXT" space You don't have
permission to add pages to "CONFEXT"
Remove "Confluence Extensions" from your
favourites Add "Confluence Extensions" to your
favourites Loading

Browse the "ConHome" space You don't have
permission to add pages to "ConHome"
Remove "Confluence Homepage Image"” from
your favourites Add "Confluence Homepage
Image" to your favourites Loading

Browse the "CONFHOST" space You don't
have permission to add pages to "CONFHOST"
Remove "Confluence Hosted Evaluator
Resources" from your favourites Add
"Confluence Hosted Evaluator Resources" to
your favourites Loading

Browse the "CONFKB" space You don't have
permission to add pages to "CONFKB"
Remove "Confluence Knowledge Base" from
your favourites Add "Confluence Knowledge
Base" to your favourites Loading

Browse the "SPCONO010" space You don't have
permission to add pages to "SPCONO010"
Remove "Confluence SharePoint Connector
1.0" from your favourites Add "Confluence
SharePoint Connector 1.0" to your favourites
Loading

Browse the "SPCONO011" space You don't have
permission to add pages to "SPCONO011"
Remove "Confluence SharePoint Connector
1.1" from your favourites Add "Confluence
SharePoint Connector 1.1" to your favourites
Loading

Browse the "SPCONO012" space You don't have
permission to add pages to "SPCONO012"
Remove "Confluence SharePoint Connector
1.2" from your favourites Add "Confluence
SharePoint Connector 1.2" to your favourites
Loading

Browse the "SPCONO013" space You don't have
permission to add pages to "SPCONO013"
Remove "Confluence SharePoint Connector
1.3" from your favourites Add "Confluence
SharePoint Connector 1.3" to your favourites
Loading

Browse the "SPCON" space You don't have
permission to add pages to "SPCON"
Remove "Confluence SharePoint Connector
1.4" from your favourites Add "Confluence
SharePoint Connector 1.4" to your favourites
Loading
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Space:

Space:

Confluence User Community

This space is for discussing ideas,
new features and suggestions for
Confluence.

Crowd 1.0
Documentation for Crowd version 1.0.x

Crowd 1.1
Documentation for Crowd version 1.1.x

Crowd 1.2
Documentation for Crowd version 1.2.x

Crowd 1.3
Documentation for Crowd version 1.3.x

Crowd 1.4
Documentation for Crowd version 1.4.x

Crowd 1.5
Documentation for Crowd version 1.5.x

Crowd 1.6
Documentation for Crowd version 1.6.x

Crowd 2.0
Documentation for Crowd version 2.0.x

Crowd 2.1
Documentation for Crowd version 2.1.x

Crowd 2.2
Documentation for Crowd version 2.2.x

Crowd 2.3

Documentation for the latest version of
Crowd single signon and identity
management

Crowd Development

Crowd Extension

Crowd Knowledge Base
Troubleshooting and support tips for
Crowd

Browse the "DISC" space Add a page to
"DISC"

Remove "Confluence User Community" from
your favourites Add "Confluence User
Community" to your favourites Loading

Browse the "CROWDO010" space You don't
have permission to add pages to "CROWDO010"
Remove "Crowd 1.0" from your favourites Add
"Crowd 1.0" to your favourites Loading

Browse the "CROWDO011" space You don't
have permission to add pages to "CROWDO011"
Remove "Crowd 1.1" from your favourites Add
"Crowd 1.1" to your favourites Loading

Browse the "CROWDO012" space You don't
have permission to add pages to "CROWDO012"
Remove "Crowd 1.2" from your favourites Add
"Crowd 1.2" to your favourites Loading

Browse the "CROWDO013" space You don't
have permission to add pages to "CROWD013"
Remove "Crowd 1.3" from your favourites Add
"Crowd 1.3" to your favourites Loading

Browse the "CROWDO014" space You don't
have permission to add pages to "CROWD014"
Remove "Crowd 1.4" from your favourites Add
"Crowd 1.4" to your favourites Loading

Browse the "CROWDO015" space You don't
have permission to add pages to "CROWDO015"
Remove "Crowd 1.5" from your favourites Add
"Crowd 1.5" to your favourites Loading

Browse the "CROWDO016" space You don't
have permission to add pages to "CROWDO016"
Remove "Crowd 1.6" from your favourites Add
"Crowd 1.6" to your favourites Loading

Browse the "CROWDO020" space You don't
have permission to add pages to "CROWDO020"
Remove "Crowd 2.0" from your favourites Add
"Crowd 2.0" to your favourites Loading

Browse the "CROWDO021" space You don't
have permission to add pages to "CROWDO021"
Remove "Crowd 2.1" from your favourites Add
"Crowd 2.1" to your favourites Loading

Browse the "CROWDO022" space You don't
have permission to add pages to "CROWDO022"
Remove "Crowd 2.2" from your favourites Add
"Crowd 2.2" to your favourites Loading

Browse the "CROWD" space You don't have
permission to add pages to "CROWD"
Remove "Crowd 2.3" from your favourites Add
"Crowd 2.3" to your favourites Loading

Browse the "CROWDDEV" space You don't
have permission to add pages to
"CROWDDEV"

Remove "Crowd Development" from your
favourites Add "Crowd Development" to your
favourites Loading

Browse the "CROWDEXT" space You don't
have permission to add pages to
"CROWDEXT"

Remove "Crowd Extension" from your
favourites Add "Crowd Extension" to your
favourites Loading

Browse the "CROWDKB" space You don't have
permission to add pages to "CROWDKB"
Remove "Crowd Knowledge Base" from your
favourites Add "Crowd Knowledge Base" to
your favourites Loading
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Crucible 1.1
Documentation for Crucible 1.1

Crucible 1.2
Documentation for Crucible 1.2

Crucible 1.5
Documentation for Crucible 1.5

Crucible 1.6
Documentation for Crucible 1.6

Crucible 2.0
Documentation for Crucible 2.0

Crucible 2.1
Documentation for Crucible 2.1

Crucible 2.2
Documentation for Crucible 2.2

Crucible 2.3
Documentation for Crucible 2.3

Crucible 2.4
Documentation for Crucible 2.4

Crucible 2.5
Documentation for Crucible 2.5

Crucible 2.6
Documentation for Crucible 2.6

Crucible 2.7

Latest documentation for Crucible: do

your code reviews, your way

Crucible Knowledge Base

Troubleshooting and support tips for

Crucible

Browse the "CRUCIBLEO11" space You don't
have permission to add pages to
"CRUCIBLEO11"

Remove "Crucible 1.1" from your favourites
Add "Crucible 1.1" to your favourites Loading

Browse the "CRUCIBLE012" space You don't
have permission to add pages to
"CRUCIBLE012"

Remove "Crucible 1.2" from your favourites
Add "Crucible 1.2" to your favourites Loading

Browse the "CRUCIBLEO015" space You don't
have permission to add pages to
"CRUCIBLEO15"

Remove "Crucible 1.5" from your favourites
Add "Crucible 1.5" to your favourites Loading

Browse the "CRUCIBLEO016" space You don't
have permission to add pages to
"CRUCIBLE016"

Remove "Crucible 1.6" from your favourites
Add "Crucible 1.6" to your favourites Loading

Browse the "CRUCIBLE020" space You don't
have permission to add pages to
"CRUCIBLE020"

Remove "Crucible 2.0" from your favourites
Add "Crucible 2.0" to your favourites Loading

Browse the "CRUCIBLE021" space You don't
have permission to add pages to
"CRUCIBLEO21"

Remove "Crucible 2.1" from your favourites
Add "Crucible 2.1" to your favourites Loading

Browse the "CRUCIBLEO022" space You don't
have permission to add pages to
"CRUCIBLE022"

Remove "Crucible 2.2" from your favourites
Add "Crucible 2.2" to your favourites Loading

Browse the "CRUCIBLE023" space You don't
have permission to add pages to
"CRUCIBLE023"

Remove "Crucible 2.3" from your favourites
Add "Crucible 2.3" to your favourites Loading

Browse the "CRUCIBLEO024" space You don't
have permission to add pages to
"CRUCIBLE024"

Remove "Crucible 2.4" from your favourites
Add "Crucible 2.4" to your favourites Loading

Browse the "CRUCIBLE025" space You don't
have permission to add pages to
"CRUCIBLEO25"

Remove "Crucible 2.5" from your favourites
Add "Crucible 2.5" to your favourites Loading

Browse the "CRUCIBLE026" space You don't
have permission to add pages to
"CRUCIBLE026"

Remove "Crucible 2.6" from your favourites
Add "Crucible 2.6" to your favourites Loading

Browse the "CRUCIBLE" space You don't have
permission to add pages to "CRUCIBLE"
Remove "Crucible 2.7" from your favourites
Add "Crucible 2.7" to your favourites Loading

Browse the "CRUCKB" space You don't have
permission to add pages to "CRUCKB"
Remove "Crucible Knowledge Base" from your
favourites Add "Crucible Knowledge Base" to
your favourites Loading
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Space:

Space:

Space:

Space:

Space:

Space:

Space:

Space:

Space:

Space:

Space:

Space:

Space:

Demonstration Space
A space which demonstrates
Confluence functionality.

Doc Sprint

Enterprise Hosting

Documentation and resources for

Enterprise Hosted versions of
Confluence and JIRA

Evaluator Resources

FishEye 1.3
Documentation for FishEye 1.3

FishEye 1.4
Documentation for FishEye 1.4

FishEye 1.5
Documentation for FishEye 1.5

FishEye 1.6
Documentation for FishEye 1.6

FishEye 2.0
Documentation for FishEye 2.0

FishEye 2.1
Documentation for FishEye 2.1

FishEye 2.2
Documentation for FishEye 2.2

FishEye 2.3
Documentation for FishEye 2.3

FishEye 2.4
Documentation for FishEye 2.4

Browse the "ds" space You don't have
permission to add pages to "ds"

Remove "Demonstration Space" from your
favourites Add "Demonstration Space" to your
favourites Loading

Browse the "DOCSPRINT" space Add a page
to "DOCSPRINT"

Remove "Doc Sprint" from your favourites Add
"Doc Sprint" to your favourites Loading

Browse the "EHOSTING" space You don't have
permission to add pages to "EHOSTING"
Remove "Enterprise Hosting" from your
favourites Add "Enterprise Hosting" to your
favourites Loading

Browse the "CONFEVAL" space You don't
have permission to add pages to "CONFEVAL"
Remove "Evaluator Resources" from your
favourites Add "Evaluator Resources" to your
favourites Loading

Browse the "FISHEYEO013" space You don't
have permission to add pages to
"FISHEYEO013"

Remove "FishEye 1.3" from your favourites Add
"FishEye 1.3" to your favourites Loading

Browse the "FISHEYEQ014" space You don't
have permission to add pages to
"FISHEYEO014"

Remove "FishEye 1.4" from your favourites Add
"FishEye 1.4" to your favourites Loading

Browse the "FISHEYEOQ15" space You don't
have permission to add pages to
"FISHEYEO015"

Remove "FishEye 1.5" from your favourites Add
"FishEye 1.5" to your favourites Loading

Browse the "FISHEYEOQ16" space You don't
have permission to add pages to
"FISHEYEO16"

Remove "FishEye 1.6" from your favourites Add
"FishEye 1.6" to your favourites Loading

Browse the "FISHEYE020" space You don't
have permission to add pages to
"FISHEYE020"

Remove "FishEye 2.0" from your favourites Add
"FishEye 2.0" to your favourites Loading

Browse the "FISHEYEO021" space You don't
have permission to add pages to
"FISHEYEO021"

Remove "FishEye 2.1" from your favourites Add
"FishEye 2.1" to your favourites Loading

Browse the "FISHEYE022" space You don't
have permission to add pages to
"FISHEYE022"

Remove "FishEye 2.2" from your favourites Add
"FishEye 2.2" to your favourites Loading

Browse the "FISHEYE023" space You don't
have permission to add pages to
"FISHEYE023"

Remove "FishEye 2.3" from your favourites Add
"FishEye 2.3" to your favourites Loading

Browse the "FISHEYE024" space You don't
have permission to add pages to
"FISHEYEO024"

Remove "FishEye 2.4" from your favourites Add
"FishEye 2.4" to your favourites Loading
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Space:

Space:

Space:

Space:

Space:

Space:

Space:

Space:

Space:

Space:

Space:

Space:

Space:

FishEye 2.5
Documentation for FishEye 2.5

FishEye 2.6
Documentation for FishEye 2.5

FishEye 2.7

Latest documentation for FishEye,
your view into your source code
repository

FishEye and Crucible Development
Tutorials and reference for enhancing
and integrating FishEye and Crucible

Fisheye Knowledge Base
Troubleshooting and support tips for
Fisheye

Gadget Development

Gadgets and Dashboards 1.0
Documentation for version 1.0.x of
Atlassian Gadgets and Dashboards

Gadgets and Dashboards 2.0
Documentation for version 2.0.x of
Atlassian Gadgets and Dashboards

Gadgets and Dashboards 3.0
Documentation for the latest version of
Atlassian Gadgets and Dashboards

GreenHopper 3.8
Documentation archive for
GreenHopper 3.8

GreenHopper 4.0
Documentation for GreenHopper 4.0

GreenHopper 4.1
Documentation for GreenHopper 4.1

GreenHopper 4.2
Documentation for GreenHopper 4.2.

Browse the "FISHEYEO025" space You don't
have permission to add pages to
"FISHEYE025"

Remove "FishEye 2.5" from your favourites Add
"FishEye 2.5" to your favourites Loading

Browse the "FISHEYE026" space You don't
have permission to add pages to
"FISHEYE026"

Remove "FishEye 2.6" from your favourites Add
"FishEye 2.6" to your favourites Loading

Browse the "FISHEYE" space You don't have
permission to add pages to "FISHEYE"
Remove "FishEye 2.7" from your favourites Add
"FishEye 2.7" to your favourites Loading

Browse the "FECRUDEV" space You don't
have permission to add pages to "FECRUDEV"
Remove "FishEye and Crucible Development"
from your favourites Add "FishEye and Crucible
Development" to your favourites Loading

Browse the "FISHKB" space You don't have
permission to add pages to "FISHKB"
Remove "Fisheye Knowledge Base" from your
favourites Add "Fisheye Knowledge Base" to
your favourites Loading

Browse the "GADGETDEV" space You don't
have permission to add pages to
"GADGETDEV"

Remove "Gadget Development" from your
favourites Add "Gadget Development" to your
favourites Loading

Browse the "GADGETS010" space You don't
have permission to add pages to
"GADGETS010"

Remove "Gadgets and Dashboards 1.0" from
your favourites Add "Gadgets and Dashboards
1.0" to your favourites Loading

Browse the "GADGETS020" space You don't
have permission to add pages to
"GADGETS020"

Remove "Gadgets and Dashboards 2.0" from
your favourites Add "Gadgets and Dashboards
2.0" to your favourites Loading

Browse the "GADGETS" space You don't have
permission to add pages to "GADGETS"
Remove "Gadgets and Dashboards 3.0" from
your favourites Add "Gadgets and Dashboards
3.0" to your favourites Loading

Browse the "GH038" space You don't have
permission to add pages to "GH038"
Remove "GreenHopper 3.8" from your
favourites Add "GreenHopper 3.8" to your
favourites Loading

Browse the "GH040" space You don't have
permission to add pages to "GH040"
Remove "GreenHopper 4.0" from your
favourites Add "GreenHopper 4.0" to your
favourites Loading

Browse the "GH041" space You don't have
permission to add pages to "GH041"
Remove "GreenHopper 4.1" from your
favourites Add "GreenHopper 4.1" to your
favourites Loading

Browse the "GH042" space You don't have
permission to add pages to "GH042"
Remove "GreenHopper 4.2" from your
favourites Add "GreenHopper 4.2" to your
favourites Loading
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Space:

Space:

Space:

Space:

Space:

Space:

Space:

Space:

Space:

Space:

Space:

Space:

Space:

GreenHopper 4.3
Documentation for GreenHopper 4.3

GreenHopper 4.4
Documentation for GreenHopper 4.4

GreenHopper 5.0
Documentation for GreenHopper 5.0

GreenHopper 5.1
Documentation for GreenHopper 5.1

GreenHopper 5.2
Documentation for GreenHopper 5.2

GreenHopper 5.3
Documentation for GreenHopper 5.3

GreenHopper 5.4
Documentation for GreenHopper 5.4

GreenHopper 5.5
Documentation for GreenHopper 5.5

GreenHopper 5.6

Documentation for GreenHopper 5.6.

GreenHopper 5.7

Documentation for the latest version of

GreenHopper.

GreenHopper Development

GreenHopper Knowledge Base

Integrating with JIRA

Documentation for the latest version of

the JIRA integration interface

Browse the "GH043" space You don't have
permission to add pages to "GH043"
Remove "GreenHopper 4.3" from your
favourites Add "GreenHopper 4.3" to your
favourites Loading

Browse the "GHO044" space You don't have
permission to add pages to "GH044"
Remove "GreenHopper 4.4" from your
favourites Add "GreenHopper 4.4" to your
favourites Loading

Browse the "GH050" space You don't have
permission to add pages to "GH050"
Remove "GreenHopper 5.0" from your
favourites Add "GreenHopper 5.0" to your
favourites Loading

Browse the "GHO051" space You don't have
permission to add pages to "GH051"
Remove "GreenHopper 5.1" from your
favourites Add "GreenHopper 5.1" to your
favourites Loading

Browse the "GH052" space You don't have
permission to add pages to "GH052"
Remove "GreenHopper 5.2" from your
favourites Add "GreenHopper 5.2" to your
favourites Loading

Browse the "GH053" space You don't have
permission to add pages to "GH053"
Remove "GreenHopper 5.3" from your
favourites Add "GreenHopper 5.3" to your
favourites Loading

Browse the "GH054" space You don't have
permission to add pages to "GH054"
Remove "GreenHopper 5.4" from your
favourites Add "GreenHopper 5.4" to your
favourites Loading

Browse the "GH055" space You don't have
permission to add pages to "GHO055"
Remove "GreenHopper 5.5" from your
favourites Add "GreenHopper 5.5" to your
favourites Loading

Browse the "GH056" space You don't have
permission to add pages to "GH056"
Remove "GreenHopper 5.6" from your
favourites Add "GreenHopper 5.6" to your
favourites Loading

Browse the "GH" space You don't have
permission to add pages to "GH"

Remove "GreenHopper 5.7" from your
favourites Add "GreenHopper 5.7" to your
favourites Loading

Browse the "GHDEV" space You don't have
permission to add pages to "GHDEV"
Remove "GreenHopper Development" from
your favourites Add "GreenHopper
Development" to your favourites Loading

Browse the "GHKB" space You don't have
permission to add pages to "GHKB"

Remove "GreenHopper Knowledge Base" from
your favourites Add "GreenHopper Knowledge
Base" to your favourites Loading

Browse the "JIRAHOOKUP" space You don't
have permission to add pages to
"JIRAHOOKUP"

Remove "Integrating with JIRA" from your
favourites Add "Integrating with JIRA" to your
favourites Loading
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Space:

Space:

Space:

Space:

Space:

Space:

Space:

Space:

Space:

Space:

Space:

Space:

Space:

Space:

JIRA 3.x Developer Documentation
Archive
JIRA 3.x developer documentation
archive

JIRA 4.0
Documentation for JIRA 4.0

JIRA 4.1
Documentation for JIRA 4.1

JIRA 4.2
Documentation for JIRA 4.2

JIRA 4.3
Documentation for JIRA 4.3

JIRA 4.4
Documentation for JIRA 4.4

JIRA Community Space

JIRA Development

JIRA Download Evaluator Resources

JIRA Extensions

JIRA Hosted Evaluator Resources

JIRA in JIRA Studio
Documentation for JIRA 4.4

JIRA Knowledge Base
Troubleshooting and support tips for
Jira

JIRA Mobile Connect

Browse the "JIRAO03x" space You don't have
permission to add pages to "JIRA03x"
Remove "JIRA 3.x Developer Documentation
Archive" from your favourites Add "JIRA 3.x
Developer Documentation Archive" to your
favourites Loading

Browse the "JIRA040" space You don't have
permission to add pages to "JIRA040"
Remove "JIRA 4.0" from your favourites Add
"JIRA 4.0" to your favourites Loading

Browse the "JIRA041" space You don't have
permission to add pages to "JIRA041"
Remove "JIRA 4.1" from your favourites Add
"JIRA 4.1" to your favourites Loading

Browse the "JIRA042" space You don't have
permission to add pages to "JIRA042"
Remove "JIRA 4.2" from your favourites Add
"JIRA 4.2" to your favourites Loading

Browse the "JIRA043" space You don't have
permission to add pages to "JIRA043"
Remove "JIRA 4.3" from your favourites Add
"JIRA 4.3" to your favourites Loading

Browse the "JIRA" space You don't have
permission to add pages to "JIRA"

Remove "JIRA 4.4" from your favourites Add
"JIRA 4.4" to your favourites Loading

Browse the "JIRACOM" space Add a page to
"JIRACOM"

Remove "JIRA Community Space" from your
favourites Add "JIRA Community Space" to
your favourites Loading

Browse the "JIRADEV" space You don't have
permission to add pages to "JIRADEV"
Remove "JIRA Development" from your
favourites Add "JIRA Development" to your
favourites Loading

Browse the "JIRADL" space You don't have
permission to add pages to "JIRADL"

Remove "JIRA Download Evaluator Resources
from your favourites Add "JIRA Download
Evaluator Resources" to your favourites
Loading

Browse the "JIRAEXT" space You don't have
permission to add pages to "JIRAEXT"

Remove "JIRA Extensions" from your favourites
Add "JIRA Extensions" to your favourites
Loading

Browse the "JIRAHOST" space You don't have
permission to add pages to "JIRAHOST"
Remove "JIRA Hosted Evaluator Resources"
from your favourites Add "JIRA Hosted
Evaluator Resources" to your favourites
Loading

Browse the "JIRA000" space You don't have
permission to add pages to "JIRA000"
Remove "JIRA in JIRA Studio" from your
favourites Add "JIRA in JIRA Studio" to your
favourites Loading

Browse the "JIRAKB" space You don't have
permission to add pages to "JIRAKB"

Remove "JIRA Knowledge Base" from your
favourites Add "JIRA Knowledge Base" to your
favourites Loading

Browse the "JMC" space You don't have
permission to add pages to "JMC"

Remove "JIRA Mobile Connect" from your
favourites Add "JIRA Mobile Connect" to your
favourites Loading
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Space:

Space:

Space:

Space:

Space:

Space:

Space:

Space:

Space:

Space:

Space:

Space:

Space:

JIRA Staging
Documentation for JIRA 4.4

JIRA Studio
Documentation for the current version
of JIRA Studio.

JIRA Studio Evaluator Resources

Plugin Framework
Documentation for all versions of the
Atlassian Plugin Framework

REST APIs

Security
Security documentation starting point

Shared Access Layer
Documentation for the Atlassian
Shared Access Layer (SAL)

Summit 2011 Speaker Guidelines

Summit 2011 Sponsorship
Learn about becoming a sponsor for
Atlassian Summit 2011

Support
Atlassian's legendary support team's
projects and policy.

Team Calendars

Documentation for Team Calendars for
Confluence, where people, projects
and content meet.

Test space

Test Space
The old, discontinued test space

Test Space

Browse the "JIRASTAG" space You don't have
permission to add pages to "JIRASTAG"
Remove "JIRA Staging" from your favourites
Add "JIRA Staging" to your favourites Loading

Browse the "JIRASTUDIO" space You don't
have permission to add pages to
"JIRASTUDIO"

Remove "JIRA Studio" from your favourites Add
"JIRA Studio" to your favourites Loading

Browse the "STUDEVAL" space You don't have
permission to add pages to "STUDEVAL"
Remove "JIRA Studio Evaluator Resources"”
from your favourites Add "JIRA Studio
Evaluator Resources" to your favourites
Loading

Browse the "PLUGINFRAMEWORK" space
You don't have permission to add pages to
"PLUGINFRAMEWORK"

Remove "Plugin Framework" from your
favourites Add "Plugin Framework" to your
favourites Loading

Browse the "REST" space You don't have
permission to add pages to "REST"

Remove "REST APIs" from your favourites Add
"REST APIs" to your favourites Loading

Browse the "SECURITY" space You don't have
permission to add pages to "SECURITY"
Remove "Security" from your favourites Add
"Security" to your favourites Loading

Browse the "SAL" space You don't have
permission to add pages to "SAL"

Remove "Shared Access Layer" from your
favourites Add "Shared Access Layer" to your
favourites Loading

Browse the "SMT" space You don't have
permission to add pages to "SMT"

Remove "Summit 2011 Speaker Guidelines"
from your favourites Add "Summit 2011
Speaker Guidelines" to your favourites Loading

Browse the "SMT11" space You don't have
permission to add pages to "SMT11"

Remove "Summit 2011 Sponsorship" from your
favourites Add "Summit 2011 Sponsorship" to
your favourites Loading

Browse the "Support" space You don't have
permission to add pages to "Support”
Remove "Support" from your favourites Add
"Support" to your favourites Loading

Browse the "TEAMCAL" space You don't have
permission to add pages to "TEAMCAL"
Remove "Team Calendars" from your
favourites Add "Team Calendars" to your
favourites Loading

Browse the "TESTRSS" space You don't have
permission to add pages to "TESTRSS"
Remove "Test space" from your favourites Add
"Test space" to your favourites Loading

Browse the "TEST" space Add a page to
"TEST"

Remove "Test Space" from your favourites Add
"Test Space" to your favourites Loading

Browse the "TST" space Add a page to "TST"
Remove "Test Space" from your favourites Add
"Test Space" to your favourites Loading
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Space:

Space:

Space:

Space:

Space:

The Confluence Test Space

This is a space dedicated to testing
and playing around with Confluence
features. Everyone is invited to
experiment.

Universal Plugin Manager 1.0
Documentation for the Universal
Plugin Manager 1.0

Universal Plugin Manager 1.2
Documentation for the Universal
Plugin Manager 1.2

Universal Plugin Manager 1.3
Documentation for the Universal
Plugin Manager 1.3

Universal Plugin Manager 1.4
Documentation for the Universal
Plugin Manager 1.4

Universal Plugin Manager 1.5
Documentation for the Universal
Plugin Manager 1.5

Universal Plugin Manager 1.5 Archive
Documentation for the Universal
Plugin Manager 1.5

Browse the "TESTING" space You don't have
permission to add pages to "TESTING"
Remove "The Confluence Test Space" from
your favourites Add "The Confluence Test
Space" to your favourites Loading

Browse the "UPMO010" space You don't have
permission to add pages to "UPM010"
Remove "Universal Plugin Manager 1.0" from
your favourites Add "Universal Plugin Manager
1.0" to your favourites Loading

Browse the "UPMO012" space You don't have
permission to add pages to "UPM012"
Remove "Universal Plugin Manager 1.2" from
your favourites Add "Universal Plugin Manager
1.2" to your favourites Loading

Browse the "UPMO013" space You don't have
permission to add pages to "UPM013"
Remove "Universal Plugin Manager 1.3" from
your favourites Add "Universal Plugin Manager
1.3" to your favourites Loading

Browse the "UPMO014" space You don't have
permission to add pages to "UPM014"
Remove "Universal Plugin Manager 1.4" from
your favourites Add "Universal Plugin Manager
1.4" to your favourites Loading

Browse the "UPM" space You don't have
permission to add pages to "UPM"

Remove "Universal Plugin Manager 1.5" from
your favourites Add "Universal Plugin Manager
1.5" to your favourites Loading

Browse the "UPMO015" space You don't have
permission to add pages to "UPM015"
Remove "Universal Plugin Manager 1.5
Archive" from your favourites Add "Universal
Plugin Manager 1.5 Archive" to your favourites
Loading

Space: Universities Browse the "UNI" space You don't have
permission to add pages to "UNI"
Remove "Universities" from your favourites Add
"Universities" to your favourites Loading

Space: User Group Sponsorship Browse the "UGS" space You don't have

permission to add pages to "UGS"

Remove "User Group Sponsorship" from your
favourites Add "User Group Sponsorship" to
your favourites Loading

Parameters

When editing, you can click on the macro placeholder and choose Edit to display the parameters for this macro in
the Macro Browser.

Parameters are options that you can set for Confluence macros to control the content or format of the macro output.
The table below lists parameters for this macro that can be set in the Macro Browser.

Parameter Required? Default Description
Scope of no all Specify the view from which spaces are listed. Available options are:
spaces

® all — All spaces in the Confluence installation.

® category — Spaces grouped according to space categories.

® team — Same as 'category' above. Space categories were
formerly known as team labels, and this option remains in the
macro to ensure backwards compatibility with earlier versions of
the macro.

® favourite — Spaces which you have added to your favourites list.

® my — Same as 'favourite’ above. This option remains in the
macro to ensure backwards compatibility with earlier versions of
the macro.

® new — New spaces which have been created within the last 7
days.
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Width of no 100% Specify the width of the table. The width of the spaces list table,
List specified as a percentage (%).
(width)

Examples

Display the spaces in a table with a width of 40% of the window size:

: {spaces:width=40%}

i {spaces:team}

Related Topics

Browsing a space
Creating a Page
Working with Macros

Take me back to the Confluence User's Guide

Status Macro

The Status macro displays a coloured lozenge (a rounded box) that is useful for reporting project status. You can
choose the colour of the lozenge and the text that appears inside the lozenge. The macro also displays its current
status in the editor, and you can change the status directly in the editor.

All good!

Screenshot: Click on the Status macro lozenge to change the status.

All good!

Edit Remove

On this page:

® Using the Status Macro
® Parameters
® Related Topics

Using the Status Macro

To add the Status macro to a page using the Macro Browser:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Parameters

When editing, you can click on the macro placeholder and choose Edit to display the parameters for this macro in
the Macro Browser.

Parameters are options that you can set for Confluence macros to control the content or format of the macro output.
The table below lists parameters for this macro that can be set in the Macro Browser.
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Parameter  Default Description

Colour Grey The colour of the lozenge and its border. The border will be a darker version of the
same colour. The following colours are available: Grey, Red, Yellow and Green.

Title The colour The text that will appear inside the lozenge. If you do not specify any text, the title
that you will be the colour of the lozenge, that is 'Grey’, '‘Red’, 'Yellow' or ‘Green'.
select.

Related Topics

Working with Macros

Take me back to the Confluence User's Guide

Table of Contents Macro

The Table of Contents macro scans the headings of the current Confluence page to dynamically create a table of
contents from your page headings. This helps readers navigate lengthy pages by summarising the content structure
and providing links to headings. Headings are indented progressively.

On this page:

® Using the Table of Contents Macro
® Macro Parameters
® Examples
® Filtered Table of Contents
® Flat List
®* Notes
® Related Topics

Using the Table of Contents Macro

To add the 'Table of Contents' macro to a page using the Macro Browser:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

You can also add the macro to a page by choosing Insert > Table of Contents from the editor toolbar.

Macro Parameters

When editing, you can click on the macro placeholder and choose Edit to display the parameters for this macro in
the Macro Browser.

Parameters are options that you can set for Confluence macros to control the content or format of the macro output.
The table below lists parameters for this macro that can be set in the Macro Browser.

Parameter Default Description

Output list ® list — produces a typical list type TOC.

Type ® flat — produces a horizontal menu-type series of links.

Display clear Select the check box to apply outline numbering to your headings, for example: 1.1,
Section 1.2,1.3.

Numbering
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List Style none

Heading
Indent

Separator brackets

Minimum 1
Heading
Level

Maximum 7
Heading
Level

Include
Headings

Exclude
Headings

Printable checked

CSS Class
Name

Examples

Select the style of bullet point for each list item. You can use any valid CSS style.
For example:

® none — no list style is displayed

circle — the list style is a circle

disc — the list style is a filled circle. This is the typical bullet list, and is used
for this example list.

square — the list style is a square

decimal — the list is numbered (1, 2, 3, 4, 5)

lower-alpha — the list is lower-case, alphabetised (a, b, c, d, €)
lower-roman — the list style is lower roman numerals (i, i, iii, iv, v, vi)
upper -roman — the list style is upper roman numerals (I, II, Ill, IV, V, VI)

Sets the indent for a list according to CSS quantities. Entering 10px will successively
indent heading groups by 10px. For example, level 1 headings will be indented 10px
and level 2 headings will be indented an additional 10px.

This parameter applies to flat lists only. You can enter any of the following values:

brackets — Each item is enclosed by square brackets: [ ].

braces — Each item is enclosed by braces: { }.

parens — Each item is enclosed by parentheses: ().

pipe — Each item is separated by a pipe:

anything — Each item is separated by the value you enter. You can enter
any text as a separator, for example "***". If using a custom separator, be
aware that text displays exactly as entered, with no additional white space to
further separate the characters.

Select the highest heading level to start your TOC list. For example, entering 2 will
include levels 2, and lower, headings, but will not include level 1 headings.

Select the lowest heading level to include. For example, entering 2 will include levels
1 and 2, but will not include level 3 headings and below.

Filter headings to include according to specific criteria. You can use wildcard
characters. See Sun's Regex documentation for examples of constructing regular
expression strings.

Filter headings to enclude according to specific criteria. You can use wildcard
characters. See Sun's Regex documentation for examples of constructing regular
expression strings.

By default, the TOC is set to print. If you clear the check box, the TOC will not be
visible when you print the page.

If you have custom TOC styles in your CSS style sheet, use this parameter to output
the TOC inside <div> tags with the specified class attribute.

The examples below are based on this table of contents:
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1. Blaces
1. Favourite Places
2. Unknown Places
2. Foods
1. Favourite Foods
2. Unknown Foods
3. Things
1. Favourite Things
2. Unknown Things

Filtered Table of Contents

This example filters the headings to include those that contain 'Favourite', but excludes headings which end with
'Things'. The list is styled with Roman numerals.

Parameter Value
List Style upper-roman

Include Headings ~ Favourite.*

Exclude Headings = .*Things

The resulting table of contents is:

|. Favourite Places
Il. Eavourite Foods

Flat List

This example filters all headings to render a flat list of 'Unknowns' enclosed in square brackets (the default list
style).

Parameter Value
Output Type flat

Maximum Heading Level 2

Include Headings Unknown . *

The resulting table of contents is:

[ Unknown Places ] [ Unknown Foods ] [ Unknown Things ]

Notes

® Due to an outstanding issue in the Table of Contents macro (CONF-10619), the Macro Browser's Refresh
function does not render any parameter modifications. Currently, the rendering of parameter value
modifications to the Table of Contents macro occurs only after the page is saved.

® Using HTML Heading Markup with the Table of Contents Macro
The Table of Contents macro cannot handle HTML heading markup on its own. Hence, if you use the
HTML and HTML Include macros to render HTML heading markup in a Confluence page, the Table of
Contents macro will not create a contents list out of these headings. (For more information about this issue,
please refer to TOC-93.)
However, if you insert an HTML anchor into each HTML heading on your page (based on the following
syntax), the Table of Contents macro will incorporate these headings into your contents list.
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The syntax for the anchor name is the page name and heading name separated by a hyphen, in which the
page and heading names have all spaces removed and are converted to lowercase. If punctuation marks
occur within a page or heading name, each mark should usually be converted to its URL escape code in
the anchor name.

Related Topics

Table of Contents Zone Macro
Pagetree Macro

Adding a Navigation Sidebar
Working with Macros

Take me back to the Confluence User's Guide.

Table of Contents Zone Macro

The Table of Contents Zone macro enables you to mark out a 'page zone' from which you can use the headings
to create a table of contents. Styling the headings as a flat list enables you to enclose the page text by top and
bottom navigation bars similar to web navigation. When styled as a list, headings are indented progressively.

On this page:
® Usage with the Macro Browser
® Usage with the Wiki Markup Editor
® Macro Parameters
® Examples
® Basic Table of Contents
® Filtered Table of Contents

® Flat List
®* Notes

Usage with the Macro Browser
To insert the Pagetree macro into a page using the Macro Browser,

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Once you've found the Pagetree macro and have added the required parameter values, click 'insert’
to add it to your page.

Usage with the Wiki Markup Editor

Include the following markup in your page:

{toc-zone:type:=[list, flat] |maxLevel=1}
Content in the zone, including other macros and page content.
{toc-zone}

There are more examples below.

Macro Parameters

When editing, you can click on the macro placeholder and choose Edit to display the parameters for this macro in
the Macro Browser.

Parameters are options that you can set for Confluence macros to control the content or format of the macro output.
The table below lists parameters for this macro that can be set in the Macro Browser.

Parameter Required? Default Description

Location no both Use this parameter to specify whether the output list displays at the
(location) top, at the bottom, or encloses the page zone content. By default, the
macro displays headings at both the top and the bottom of the page.
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Output no list
Type
(type)

Display no false
Section

Numbering

(outline)

List Style no
(style)

none

Separator no brackets

(

separator

)

Indent no

Minimum no 1
Heading

Level

(minLevel

)

Maximum no 7
Heading

Level

(maxLevel

)

Include no
Headings
(include)
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Set this to "list" or "flat". Selecting list produces a typical list type
TOC. Selecting flat produces a horizontal menu-type series of links,
for example: [Heading 1] [Heading 2] [Heading 3].

Select the tick box to apply outline numbering to your headings, for
example: 1.1, 1.2, 1.3.

Use this parameter to select the style of bullet point for each list item.
You can use any valid CSS style. For example:

® none — no list style is displayed

® circle - the list style is a circle

® disc — the list style is a filled circle — this is the typical bullet
list, and is the one we're using for this example list

® square — the list style is a square

® decimal — the listis numbered (1, 2, 3, 4, 5)

® lower-alpha — the list is lower-case, alphabetised (a, b, c,

d, e)

® lower-roman — the list style is lower roman numerals (i, ii,
iii, iv, v, vi)

® upper-roman — the list style is upper roman numerals (|, II,
1, 1V, V, VI)

This parameter applies to "flat" lists only. Use this parameter to style
the display of a "flat" or horizontal list. You can enter any of the
following parameters:

brackets — Each item is enclosed by square brackets: [ ].
braces — Each item is enclosed by braces: { }.

parens — Each item is enclosed by parentheses: ().

pipe — Each item is separated by a pipe:

anything — Each is separated by the value you enter. You can
enter any text as a separator, for example "***"_ |f using a
custom separator, be aware that text displays exactly as
entered, with no additional white space to further separate the
characters.

Use this parameter to style the indent for a "list" according to CSS
guantities, entering "10px" will successively indent list heading groups
10px. For example, h1 headings will be indented 10px and h2
headings will be indented an additional 10px.

Use this parameter to select the heading level to start your TOC list.
For example, 2 will list h2, h3, and h4 headings, but will not include hl
headings.

Use this parameter to select the maximum heading levels to include.
For example, 2 will list h1 and h2, but will not include h3 and below.

Use this parameter as a way of filtering to include headings according
to specific criteria. You can use wildcard characters to filter the
headings. See Sun's Regex documentation for examples of
constructing regular expression strings.

1. Because '|'is the macro parameter separator, use a
comma '," where you would normally use a '['. If you
need to match a comma, use its escape code:
'x2c!'.
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Exclude no Use this parameter as a way of filtering to enclude headings according
Headings to specific criteria. You can use wildcard characters to filter the
(exclude) headings. See Sun's Regex documentation for examples of

constructing regular expression strings.

1, Because | is the macro parameter separator, use a
comma ',' where you would normally use a '|'. If you
need to match a comma, use its escape code:

1x2c'.
Printable no true By default, the TOC is set to print. If you set this parameter to false,
(printable) the TOC will not be visible when you print the page.
CSS Class no If you have a custom TOC in your CSS style sheet, you can use this
Name parameter to output the TOC with the specified "class" attribute.
(class)
Examples

The examples are based on a page with the following headings:

hl. Places

h2. Favourite Places
h2. Unknown Places
hl. Foods

h2. Favourite Foods
h2. Unknown Foods
hl. Things

h2. Favourite Things
h2. Unknown Things

Basic Table of Contents

This will display only level 1 headings as a numbered list at the top of the page.

{toc-zone:type|location=top|type=flat|maxLevel=1}
hl. Places

h2. Favourite Places
h2. Unknown Places
hl. Foods

h2. Favourite Foods
h2. Unknown Foods
hl. Things

h2. Favourite Things
h2. Unknown Things
{toc-zone}

Filtered Table of Contents

This example will filter all headings to include those that contain "Favourite", but will exclude any heading which
ends with the word "Things'. The list is styled with Roman numerals. It will not display on the printed page.

{toc-zone:minLevel=2 |maxLevel=4|exclude=Adding your own Tip}
Page zone content
{toc-zone}

You can see this example 'live by visiting the Tips via Twitter page.

Flat List
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This will filter all headings to render a flat list of ‘Unknowns' enclosed in square brackets.

: {toc:type=flat|maxLevel=2|include=Unknown.*}

Screenshot: Filtered TOC 'zone' headings displayed as flat list

[ Unknown Places | [ Unknown Foods ] [ Unknown Things ]

Notes

® Due to an outstanding issue in the Table of Contents Zone macro (CONF-10619), the Macro Browser's
Refresh function does not render any parameter modifications. Currently, the rendering of parameter value
modifications to the Table of Contents Zone macro occurs only after the page is saved.

® Using HTML Heading Markup with the Table of Contents Zone Macro — The Table of Contents Zone
macro cannot handle HTML heading markup on its own. Hence, if you used the HTML and HTML Include
macros to render HTML heading markup in a Confluence page, the Table of Contents Zone macro will not
create a contents list out of these headings. (For more information on about this issue, please refer to
TOC-93.)

However, if you insert an HTML anchor into each HTML heading on your page (based on the following
syntax), the Table of Contents Zone macro will incorporate these headings into your contents list.

A
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o
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s
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Q
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o
=
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N
~
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¥
Vv

The syntax for the anchor name is usually the page name and heading name separated by a hyphen, in
which the page and heading names have all spaces removed and are converted to lowercase. If
punctuation marks occur within a page or heading name, each mark should usually be converted to its URL
escape code in the anchor name.

RELATED TOPICS

Table of Contents Macro
Pagetree Macro

Adding a Navigation Sidebar

Working with Macros

Take me back to the Confluence User's Guide.

Tasklist Macro

The Tasklist macro allows you to create and update a list of tasks on the wiki page. Users viewing the page can
modify the tasks without having to edit the page, provided they have the required permissions to modify the page.

On this page:

Using the Tasklist Macro

Parameters

Editing the Task List while Viewing a Page
Sorting the Tasks

Viewing the Progress on Tasks Completed
Related Topics

Using the Tasklist Macro

To add the Tasklist macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Parameters

When editing, you can click on the macro placeholder and choose Edit to display the parameters for this macro in
the Macro Browser.
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Parameters are options that you can set for Confluence macros to control the content or format of the macro output.
The table below lists parameters for this macro that can be set in the Macro Browser.

Parameter Default Description

Title ‘Task The name of the task list. This is displayed as the title above the list of tasks.
List'
Width of 530px The width of the task list.
List
Enable clear When selected, you can lock individual tasks so that they cannot be changed. See
Locking instructions below on editing the task list.
Prompt on clear When selected, the user must confirm the deletion of a task in the list.
Delete

Editing the Task List while Viewing a Page

While viewing a page, you can change the tasks in a task list as follows:

Action

Adding a task

Completing/uncompleting
a task

Editing a task

Deleting a task

Viewing details of a task

Locking a task

Changing the priority

Assigning the task

Description

Type the task description in the box under the list title, and click Add.

Click the check box next to a task to mark the task as complete. The task name
will become a lighter color and the progress bar will be updated. Clear the check
box to mark the task as uncompleted. You can also click Uncheck all to mark all
tasks as uncompleted.

Move your cursor over the task and click the edit icon (pencil) that appears to the
right of the task. The task name will become editable and the edit icon will be
replaced with a save icon. Make your change and press the 'Enter’ key to save or
click the save icon.

Move your cursor over the task and click the delete icon (trash can) that appears
to the right of the task.

Click the arrow icon to the left of the task name. The task details will open in an
expanded view.

Provided that the Enable Locking parameter has been selected, you can click
the lock icon to prevent the task from being edited, deleted, or otherwise
changed.

When the task details are visible, click the appropriate option — High, Medium
or Low.

When the task details are visible, change the assignee of the task by typing in or
searching for a username.

Screenshot: Task List showing task details
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Planning a Holiday
Add

[] Book tickets
[] Check passport expiry it

Priority: ® High © Medium O Low

Assigned To: | smaddox 4 &

Created: Mar 28, 2008
(] Apply for visa
[ Buy suitcases

Sort by: | Custom il

Sorting the Tasks

There are two ways to sort the tasks in the list:

® Using the Sort by list.
® Using drag and drop.

Select one of the sort options from the 'Sort by’ list:

Option Description
Custom This is the default option.
Priority Sort the list in order of the priority you have allocated to each task.

Date Created  Sort the list in order of the dates upon which the tasks were created.

Completed Move all completed tasks to the bottom or top of the list.
Name Sort the list in order of the task names.
Assignee Sort the list in order of the usernames assigned to the tasks.

Once you have selected a sort option, use the icon beside the Sort by box to reverse the sort order.

Dragging and dropping a task into a new position:

Drag a task up or down the list using the ‘drag me' handle to the right of the task name. Make sure the task is
positioned to the left of the existing tasks. A space will open and you will be able to drop the task into its new
position.

Viewing the Progress on Tasks Completed

The bar at the top of the task list displays two different colours, indicating the percentage of tasks completed.

Screenshot: Progress Bar on Task List
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Planning a Holiday
Add

Buy suitcases
[] Check passport expiry it
Book tickets

[ Apply for visa

[ Uncheck all ] Sort by- | Custom v

Related Topics

Working with Macros

Take me back to the Confluence User's Guide.

Tip Macro

The Tip Macro allows you to highlight a helpful tip on a Confluence page.

It creates a green-coloured box surrounding your text as shown below.

i Tip Macro Example

This text is rendered inside the tip macro.

On this page:
® Usage with the Macro Browser

® Usage with the Wiki Markup Editor
® Parameters

Usage with the Macro Browser
To insert the tip macro into a page using the Macro Browser,

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Once you've found the tip macro, click 'insert' to add it to your page.

Usage with the Wiki Markup Editor

What you need to type What you will get

{tip}Ask a question at Atlassian Answers!{tip}
@ Ask a question at Atlassian Answers!

Parameters

When editing, you can click on the macro placeholder and choose Edit to display the parameters for this macro in
the Macro Browser.

Parameters are options that you can set for Confluence macros to control the content or format of the macro output.

366



Confluence 4.0 Documentation

367

The table below lists parameters for this macro that can be set in the Macro Browser.

Parameter Required? Default Description

Optional Title  no none The title of the tip. If specified, will be displayed in bold next to the
(title) icon.

Show Tip no true If "false”, the icon will not be displayed.

Icon

(icon)

RELATED TOPICS
Working with Macros

Take me back to the Confluence User's Guide.

Userlister Macro

The Userlister macro displays a list of users registered in Confluence, based on their group membership.
On this page:

Usage with the Macro Browser
Usage with the Wiki Markup Editor
Parameters
Examples

® Listing all Users

® Specifying a Group

® Listing Only Online Users

Usage with the Macro Browser
To insert the userlister macro into a page using the Macro Browser,

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Once you've found the userlister macro, click ‘'insert' to add it to your page.

Usage with the Wiki Markup Editor

What you need to type What you will get
{userlister:groups=*} Group: &ll Users
I & deep (de=p)
""""""""""""""""""""""""""""" hidden
L a (abcd)
hidden

L\ Wim De Waele (wirn devaele@ibbt. be)
hidden

A xyz Oxyz y2)
hidden

& 1 (hitp:ffconfluence. atlazsian, commfdozignu
hidden

& lrnrnrn (lrmrnrn]
hidden

Parameters
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When editing, you can click on the macro placeholder and choose Edit to display the parameters for this
macro in the Macro Browser.

Parameters are options that you can set for Confluence macros to control the content or format of the
macro output. The table below lists parameters for this macro that can be set in the Macro Browser.

Parameter Required? Default Description
Group(s) yes none Use parameter name 'group’ or 'groups' to specify one or
(groups) more groups whose Confluence users you want to list, using

a comma-separated list of group names. To see all users
registered in a Confluence installation, specify an asterisk
("*") for this parameter's value.

Display no none Specify 'true’ to generate a list of online users. Specify 'false’
Online/Offline to generate a list of offline users.
Users
(online)
Examples

Listing all Users

Here is an example that lists all the users registered on your Confluence site.
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Specifying a Group

Here is an example that lists the users that belong to the group ‘'my-staff'.
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Listing Only Online Users

0 In order to make this feature functional, a System Administrator needs to enable the User Log In
Listener for your Confluence site.

Here is an example that lists all currently online users in the 'my-staff' group.
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i) Listof online users can be misleading
When the parameter 'online=true’ is used, Confluence uses a context listener to generate
the list of online users. A context listener is a J2EE term for something that listens for
events in the application server. We listen for session open and close events, so a user is
‘online' if they have a session on the application server. Some application servers don't

correctly despatch close events for sessions — in these cases, the list of online users may
be misleading.

RELATED TOPICS

Working with Macros
Configuring the userlister Macro in the Confluence Administrator's Guide

Take me back to the Confluence User's Guide.

User Status List Macro
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The User Status List macro displays a history of any Confluence user's Status Updates on your
Confluence page or blog. This is the same history that appears in the user's Status Updates view.

Screenshot: Example Usage of the User Status List Macro

History of my Status Updates

Working on final User Profile updates.

Clear | Delete | about 2 hours ago

Maoving onto Metwoarks.

Delete | May 06

Well... Just one last status update.

Delete | May 01

Mow venturing off onto other topics.
Delete | April 30

Mow working on User Status Updates. At last._..
Delete | Apnl 30

On this page:
® Usage with the Macro Browser
® Usage with the Wiki Markup Editor

® Parameters
® Related Topics

Usage with the Macro Browser

To insert the User Status List macro into a page using the Macro Browser,

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Once you've found the User Status List macro and have added the required parameter
values, click 'insert' to add it to your page.

Usage with the Wiki Markup Editor

What you need to type Example of what you will get
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h5. History of my Status

Updates .
{status-list:username=ggaskell} HIS":CIF‘_Q’ of my Status Updates

Working on final User Profile updates.

Clear | Delete | about 2 hours ago

Moving onto Networks.

Delete | May 06

Well... Just one last status update.

Delete | May 01

Mow venturing off onto other topics.

Delete | Aprl 30

Mow waorking on User Status Updates. At last..

Delete | April 30

Parameters

When editing, you can click on the macro placeholder and choose Edit to display the parameters for this
macro in the Macro Browser.

Parameters are options that you can set for Confluence macros to control the content or format of the
macro output. The table below lists parameters for this macro that can be set in the Macro Browser.

Parameter Required in Wiki  Default Description

Markup?
Username yes none The username of the Confluence user whose history of
( Status Updates you wish to show.
username
)
" If you wish to list status updates made by more than just one user, you can use the

recently updated macro in conjunction with the following parameter-value combinations:
® Include these Content Types Only — status

® Author(s) by username — the user(s) whose status updates you want to
include in the list. If you leave this field blank, the status updates of all users will

be included.

Related Topics

Working with Macros
User Status Updates

Take me back to the Confluence User's Guide.

View File Macro

The view file macro allows you to embed an Office or PDF document into your Confluence page. First
attach the document to a wiki page and then use the view file macro to display the document's content.

When viewing the page, users will see the content of the Office document. Users do not need to have
Office installed, in order to see the content of the Office document.

Where applicable, users will be able to open the document for editing in their Office application.
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This is just one of the ways Confluence can interact with Office documents. For an overview of all Office
Connector features, please refer to Working with the Office Connector.

The view file macro provides several unique parameter options for some of the types of files it handles.
Hence, to simplify its use, the view file macro is separated into the following four macros in the macro
browser:

Office Word
Office Powerpoint
Office Excel

View PDF

On this page:

Basic Usage without the Macro Browser
Example of Usage
Prerequisites for Viewing and Displaying Office Documents
Displaying a Word Document in Confluence
Usage with the Macro Browser (doc)
Basic Usage with the Wiki Markup Editor (doc)
Parameters (doc)
Editing the Word Document
® Displaying a PowerPoint Presentation in Confluence
® Usage with the Macro Browser (ppt)
® Basic Usage with the Wiki Markup Editor (ppt)
® Parameters (ppt)
® Viewing the Slide Show and Editing the Presentation
® Displaying an Excel Spreadsheet in Confluence
® Usage with the Macro Browser (xIs)
® Basic Usage with the Wiki Markup Editor (xIs)
® Parameters (xls)
® Editing the Excel Spreadsheet
® Displaying a PDF Document in Confluence
® Usage with the Macro Browser (pdf)
® Basic Usage with the Wiki Markup Editor (pdf)
® Parameters (pdf)
® Viewing the PDF Document
® Troubleshooting
® Related Topics

Basic Usage without the Macro Browser

To use the view file macro without the macro browser, enter it directly in the Wiki Markup or Rich Text
editors based on one of the following examples, along with any parameters (described below) that suit the
type of file.

i {viewdoc:name=my document.doc} :
H {viewppt :name=my presentation.ppt} H
{viewxls:name=my spreadsheet.xls}
: {viewpdf :name=my document.pdf } :

#) Editing 'older style’ {viewfile} macros

In Confluence 3.0, the {viewfile} macro's syntax was changed to be file type-specific (as
indicated by the examples above). If your Confluence site was upgraded to Confluence
3.0 and you had existing content which used the 'older style' syntax for this macro
({viewfile}), you can still edit these macros via the macro browser. Just place your cursor

inside the viewfile macro's braces and click the macro browser icon D- to edit it. The
‘edit only' version of the view file macro will open in the macro browser, allowing you to
edit its specific parameters.

Example of Usage

The live example below shows how to display an Excel spreadsheet on a Confluence page. The Excel
spreadsheet is attached to this documentation page.

What you need What you will get
to type
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{viewxls:name=my
spreadsheet.xlIs}

Planning 5 3

Design 3 5 2

Devel opment 6 5
Testing 2
Admin 1

Prerequisites for Viewing and Displaying Office Documents

If you want to use the View File macro, or to view Office files attached to a Confluence page, you need the
setup described below.

Browsers and Flash Player

You can use any browser to view an Office file on a wiki page or attachment view, provided that you have
installed Adobe Flash Player version 9 or later. You do not need to have an Office desktop application
installed on your computer in order to view Office files in Confluence.

File Types

Confluence can display files compatible with Microsoft Office 97-2007, and PDF files, of the following
types:

.doc and .docx
.xlsand .x1lsx
.ppt and .pptx
.pdf

Above are the prerequisites for viewing or displaying Office documents in Confluence. For a full list of
Office Connector prerequisites and limitations, please refer to:

® Office Connector Prerequisites
® Office Connector Limitations and Known Issues

Displaying a Word Document in Confluence

Usage with the Macro Browser (doc)
To insert the Office Word macro into a page using the Macro Browser,

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Once you have found the Office Word macro and have added the required parameter values,
click ‘insert' to add it to your page.

Basic Usage with the Wiki Markup Editor (doc)
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Parameters (doc)

When editing, you can click on the macro placeholder and choose Edit to display the parameters for this
macro in the Macro Browser.

Parameters are options that you can set for Confluence macros to control the content or format of the
macro output. The table below lists parameters for this macro that can be set in the Macro Browser.

Parameter Required? Default Description
File Name yes none The file name of the Office Word document to be displayed.
(name) The document must be attached to a wiki page on your

Confluence site.


http://www.adobe.com/products/flashplayer/
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Page no The page Enter a page name, if you wish to display a document which is

Name which attached to another Confluence page. For example:

(page) contains
the { 1
{viewdoc} : {viewdoc:name=my :
macro document .doc|page=Sample Page}

Space no The Enter a space key, if you wish to display a document which is

Key space of  attached to a page in another Confluence space. For example:

(space) the page S .
which H !
contains : {viewdoc:name=my :
the i document . doc | space=DOC | page=Sample i
{viewdoc} page}
macro i i

Date no none If the Page Name refers to a blog post instead of a

(date) conventional page, enter the date of the post in the form

mm/dd/yyyy.

Editing the Word Document

When viewing a wiki page that displays an attached Office document, you can launch your Office editor
directly from Confluence.

® Move your mouse pointer to the top of the document embedded in the Confluence page, until the
hidden title bar appears. (See the screenshot below.)

® Click the title bar.

¢ Confirm your action and log in as prompted.

® The Office document will open in your Office application. Make any necessary changes, then save
the document. It will be saved back into Confluence.

Screenshot: The title bar showing 'document.doc' above an embedded Office document

% Displaying a Word Document & Edt 9k Add -

&4 Added by Sarah Maddox, last edited by Sarah Maddox on Mov 11, 2008

document.doc

Sample Word Document

This is a simple document created in Microsoft Word 2007.

Heading Level 1
Lorem ipsum dolor sit amet, consectetuer adipiscing elit. Aliquam fermentum vestibulum est. Cras rhoncus. Pel
habitant morbi tristique senectus et netus et malesuada fames ac turpis egestas. Sed quis tortor.

You will find detailed instructions in Editing an Office Document from Confluence.

Displaying a PowerPoint Presentation in Confluence

You can display an PowerPoint presentation on a Confluence page. By default, the presentation will be
displayed as a dynamic slide show, using Adobe Flash Player. You can also choose to display just one of
the slides as a static JPEG image.

Usage with the Macro Browser (ppt)

To insert the Office Powerpoint macro into a page using the Macro Browser,
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1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Once you have found the Office Powerpoint macro and have added the required parameter
values, click ‘insert' to add it to your page.

Basic Usage with the Wiki Markup Editor (ppt)
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Parameters (ppt)

When editing, you can click on the macro placeholder and choose Edit to display the parameters for this
macro in the Macro Browser.

Parameters are options that you can set for Confluence macros to control the content or format of the
macro output. The table below lists parameters for this macro that can be set in the Macro Browser.

Parameter Required? Default Description

File Name yes none This file name of the PowerPoint presentation to be displayed. Tt
(name) document must be attached to a wiki page on your Confluence si
Height no Specify the height of the display, in pixels (default) or as a percer
(height) the window's height. For example, to specify a height of 200 pixe

: {viewppt :name=my
H presentation.ppt|height=200}

: {viewppt :name=my
H presentation.ppt|height=200px}

: {viewppt :name=my
H presentation.ppt|height=10%}

Page no The Enter a page name, if you wish to display a document which is at
Name page to another Confluence page. For example:
(page) which R
contains H
the : {viewppt :name=my
{viewppt} i presentation.ppt |page=Sample Page}
macro H
Slide no none Specify the number of the slide which you want displayed on the
Number Confluence page, starting with '0' for the first slide. Instead of a s
(slide) show, the page will display just the single slide represented as a
image.
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Space no The Enter a space key, if you wish to display a document which is atti
Key space of  a page in another Confluence space. For example:
(space) the page S,
which H
contains : {viewppt :name=my
the H presentation.ppt |space=DOC|page=Sample
{viewppt} i Page}
macro :
Width no Specify the width of the display, in pixels (default) or as a percent
(width) the window's width. For example, to specify a width and height of
pixels:
i {viewppt :name=my
H presentation.ppt |width=200|height=200}
This code also specifies a width and height of 200 pixels:
i {viewppt :name=my
H presentation.ppt|width=200px|height=200px}
This code specifies a width of 10 percent of the window's width:
i {viewppt :name=my
H presentation.ppt|width=10%}
Date no none If the Page Name refers to a blog post instead of a conventional
(date) enter the date of the post in the form mm/dd/yyyy.
Viewing the Slide Show and Editing the Presentation

When you view the PowerPoint presentation on a Confluence page, options on the bottom frame of the
slide show allow you to:

IEI — Download the presentation and save it onto your computer.

? — Edit the presentation in your Office application. You will find detailed instructions in Editing
an Office Presentation from Confluence.

n

Id 4 15720 B DI - o
— Move to the first, previous, next and last slides in the
presentation. Or enter a slide number to move directly to that slide.

— Refresh the display.

(]
— Open the presentation in full-screen mode. To return to normal viewing mode, press the
escape key ('Esc') on your keyboard.

Screenshot: PowerPaint presentation embedded on a Confluence page
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Add Comment

Displaying an Excel Spreadsheet in Confluence
Usage with the Macro Browser (xIs)

To insert the Office Excel macro into a page using the Macro Browser,

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Once you have found the Office Excel macro and have added the required parameter values,
click 'insert' to add it to your page.

Basic Usage with the Wiki Markup Editor (xIs)
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Parameters (xIs)

When editing, you can click on the macro placeholder and choose Edit to display the parameters for this
macro in the Macro Browser.

Parameters are options that you can set for Confluence macros to control the content or format of the
macro output. The table below lists parameters for this macro that can be set in the Macro Browser.
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@ Reducing the size of the spreadsheet

Use the 'Last Column' and 'Last Row' parameters to reduce the size of the spreadsheet
displayed on the wiki page. This is especially useful to prevent the display from showing
empty cells. This will also help to prevent ‘out of memory' errors.

Parameter

File Name
(name)

Last
Column
(col)

Show
Grid?
(grid)

Page
Name
(page)

Last Row
(row)

Worksheet
Name
(sheet)

Space Key
(space)

Date
(date)

Required?

yes

no

no

no

no

no

no

no

Default

none

Last column
with content

true

The page
which
contains the
{viewxIs}
macro

Last row
with content

Last
worksheet
viewed in
the
spreadsheet

The space
of the page
which
contains the
{viewxIs}
macro

none

Editing the Excel Spreadsheet
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Description

This is the file name of the document to be displayed. The
document must be attached to a wiki page on your Confluenc
site.

Enter the number of the last column you want displayed, stari
from '0" as the first column. For example, the following code v
show the first 3 rows and the first 3 columns:

H {viewxls:name=my
H spreadsheet .xls|col=2]|row=2}

Select the check box in the macro browser (true in Wiki Mar
to show grid lines around each cell of the Excel spreadsheet.
the check box in the macro browser (false in Wiki Markup) 1
hide these grid lines.

Enter a page name, if you wish to display a document which i
attached to another Confluence page. For example:

: {viewxls:name=my
H spreadsheet .xls|page=Sample Page}

Enter the number of the last row you want displayed, starting
'0" as the first row. For example, the following code will show
first 3 rows and the first 3 columns:

i {viewxls:name=my
H spreadsheet .xls|col=2|row=2}

Enter the name of the worksheet that you want displayed.

Enter a space key, if you wish to display a document which is
attached to a page in another Confluence space. For exampl

{viewxls:name=my
spreadsheet .x1ls|space=DOC|page=Sample
Page}

If the Page Name refers to a blog post instead of a conventio
page, enter the date of the post in the form mm/dd/yyyy.
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When viewing a wiki page that displays an attached Office spreadsheet, you can launch your Office editor
directly from Confluence.

® Move your mouse pointer to the top of the spreadsheet embedded in the Confluence page, until
the hidden title bar appears. (See the screenshot below.)

® Click the title bar.

® Confirm your action and log in as prompted.

®* The spreadsheet will open in your Office application. Make any necessary changes, then save the
spreadsheet. It will be saved back into Confluence.

Screenshot: The title bar showing 'spreadsheet.xls' above an embedded Excel spreadsheet

X, Displaying an Excel Spreadsheet £ Edt =k Add -

& 4 Added by Sarah Maddox, last edited by Sarah Maddox on Nov 11, 2008

spreadsheet.xls

Planning 5 3

Design 3 5 2

Development 6 5 5
Testing 2 3
Admin 1

Add Labels

Add Comment

You will find detailed instructions in Editing an Office Spreadsheet from Confluence.

Displaying a PDF Document in Confluence

Usage with the Macro Browser (pdf)
To insert the View PDF macro into a page using the Macro Browser,

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Once you have found the View PDF macro and have added the required parameter values,
click 'insert' to add it to your page.

Basic Usage with the Wiki Markup Editor (pdf)

Parameters (pdf)

When editing, you can click on the macro placeholder and choose Edit to display the parameters for this
macro in the Macro Browser.

Parameters are options that you can set for Confluence macros to control the content or format of the
macro output. The table below lists parameters for this macro that can be set in the Macro Browser.

Parameter Required? Default Description

File Name yes none This is the file name of the document to be displayed. The
(name) document must be attached to a wiki page on your Confluence
site.
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Page no The Enter a page name, if you wish to display a document which is

Name page attached to another Confluence page. For example:

(page) which S .
contains H H
the H {viewpdf :name=my H
{viewpdf} document . pdf |page=Sample Page}
macro H H

Space no The Enter a space key, if you wish to display a document which is

Key space of  attached to a page in another Confluence space. For example:

(space) the page S .
which ! i
contains i {viewpdf :name=my H
the i document . pdf | space=DOC | page=Sample i
{viewpdf} Page}
macro i i

Date no none If the Page Name refers to a blog post instead of a

(date) conventional page, enter the date of the post in the form

mm/dd/yyyy-

Viewing the PDF Document

When you view the PDF document on a Confluence page, it is displayed as a slide show. Options on the
bottom frame of the slide show allow you to:

° |§| — Download the PDF file and save it onto your computer.

I 4 15720 B Pl _ , _
. — Move to the first, previous, next and last pages in the
document. Or enter a page humber to move directly to that page.

. — Refresh the display.

. E — Open the document in full-screen mode. To return to normal viewing mode, press the
escape key (‘'Esc') on your keyboard.

Screenshot: PDF document embedded on a Confluence page
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Troubleshooting

Problems? Please refer to our guide to the Office Connector limitations and known issues.

Related Topics

® Working with the Office Connector
® Working with Macros

Take me back to the Confluence User's Guide.

Warning Macro

The Warning Macro allows you to highlight a warning note on a Confluence page.

It creates a red-coloured box surrounding your text as shown below.

@ Warning Macro Example

This text is rendered inside the warning macro.

On this page:
® Usage with the Macro Browser

® Usage with the Wiki Markup Editor
® Parameters

Usage with the Macro Browser
To insert the warning macro into a page using the Macro Browser,

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Once you've found the warning macro and have added the required parameter values, click '
insert' to add it to your page.

Usage with the Wiki Markup Editor

380



Confluence 4.0 Documentation

What you need to type What you will get

{warning}Insert warning message here!
{warning} & Insertwarning message here!

Parameters

When editing, you can click on the macro placeholder and choose Edit to display the parameters for this
macro in the Macro Browser.

Parameters are options that you can set for Confluence macros to control the content or format of the
macro output. The table below lists parameters for this macro that can be set in the Macro Browser.

Parameter Required? Default Description

Optional Title no none The title of the warning note. If specified, will be displayed
(title) in bold next to the icon.

Show Warning  no true If "false”, the icon will not be displayed.

Icon

(icon)

RELATED TOPICS

Working with Macros

Take me back to the Confluence User's Guide.

Web-Widget Macro

The Web-Widget macro is just another name for the Widget macro.

Confluence supports web-widget as an alias for widget. Your System Administrator can enable or
disable one or both these macro names. The alias is useful for Confluence sites which use Adaptavist's
Community Bubbles plugin, to avoid conflict with the ‘widget' macro supplied by that plugin.

If the web-widget alias is enabled on your Confluence site, you can use web-widget instead of widget
in all the examples given in the page about the Widget macro.

RELATED TOPICS

* Widget Macro
® Working with Macros

Take me back to Confluence User's Guide

Welcome Message macro

The Welcome Macro allows you to include the Confluence site welcome message in your page.

The welcome message is configured by a Confluence administrator from the Administration Console.

For more information about editing the Confluence site welcome message, please refer
to Editing the Site Welcome Message in the Confluence Administrators Guide.

On this page:

® Usage with the Wiki Markup Editor
® Looking for the Atlassian product documentation?
® About this Confluence wiki

® Parameters

® Related Topics

Usage with the Wiki Markup Editor
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What you need to What you will get
type

{welcome-message}
Looking for the Atlassian product documentation?
Quick links:

More:

Latest JIRA documentation | Latest Confluence documentation

Atlassian documentation home page

About this Confluence wiki

Confluence is the enterprise wiki designed to make it easy for you and your team t
with the world.

For information on Confluence please check out the feature tour, our competitive ¢
Alternatively, experiment with our public Confluence Sandbox installation, home to

Atlassian produces agile development tools, including the bug tracker (JIRA), an a
(GreenHopper), a source code insight tool (FishEye), a code review tool (Crucible
(Bamboo) and more.

INTRODUCING

JSGONFLUEN

Faster. Richer Simpler. The future of content |
Take a tou

h Test, annotate an
~ the web browser.

forJIRR Download the free 30-

Parameters

This macro accepts no parameters.

Related Topics

Working with Macros

Take me back to the Confluence User's Guide.

Widget Macro

The Widget macro, or Widget Connector, allows you to embed multi-media content from other web sites
into your Confluence page.

It supports content such as:

® Gadgets and other widgets: Google Gadgets, Widgetbox.


http://www.atlassian.com/software/jira/docs/latest
http://www.atlassian.com/software/confluence/docs
http://www.atlassian.com/software/confluence/
http://www.atlassian.com/software/confluence/features
http://www.atlassian.com/software/confluence/pricing.jsp
http://www.atlassian.com/software/confluence/ConfluenceDownloadCenter.jspa
http://sandbox.onconfluence.com/
http://sandbox.onconfluence.com/display/SBOX/Home
http://www.atlassian.com/agile
http://www.atlassian.com/software/jira
http://www.atlassian.com/software/greenhopper
http://www.atlassian.com/software/fisheye
http://www.atlassian.com/software/crucible
http://www.atlassian.com/software/bamboo
http://www.atlassian.com/en/software/bonfire?utm_source=CAC&utm_medium=banner&utm_campaign=bonfire
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® Videos: YouTube, MySpace Video, Google Video, Yahoo Video, Dailymotion, Episodic, Vimeo,
Metacafe, blip.tv, Viddler.

Photos and images: Flickr, Skitch.com.

Micro-blogging: Twitter, FriendFeed, BackType.

Documents and presentations: SlideShare, SlideRocket, Scribd, presentations on Google Docs.
Calendars: Google Calendar.

Forms and online databases: Wufoo HTML Form Builder, Dabble DB.

Support and customer satisfaction: Get Satisfaction.

On this page:

Usage with the Macro Browser

Usage with the Wiki Markup Editor
Parameters

Live Example of Flickr Photos

Live Example of Google Gadget

More Examples of Macro Code

About the Web-Widget and Widget Macros
Troubleshooting

Usage with the Macro Browser
To insert the Widget macro into a page using the Macro Browser,

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Once you've found the Widget macro and have added the required parameter values, click '
insert' to add it to your page.

Usage with the Wiki Markup Editor

Just type the word 'widget' in curly brackets, and give it the URL (web address) of the thing you want to
display.

If the web-widget alias is enabled on your Confluence site, you can use web-widget instead of widget
. See below.

Parameters

When editing, you can click on the macro placeholder and choose Edit to display the parameters for this
macro in the Macro Browser.

Parameters are options that you can set for Confluence macros to control the content or format of the
macro output. The table below lists parameters for this macro that can be set in the Macro Browser.

Parameter Required Default Description

Web Sites  yes This is the URL provided by the external web site for embedding cot
Widget

URL

(url)
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Pixel no
Height

(Value

Only)

(height)

Pixel no
Width

(Value

Only)

(width)

Live Example of Flickr Photos

This example shows the Widget macro in action. It displays all photos from Flickr with the tag 'Atlassian'.

What You Need to Type

What You Will Get

Live Example of Google Gadget

Specify the height of the display, in pixels (default) or as a percentag
height of 200 pixels:

H {widget:url=http://www.flickr.com/photos/tags,

Specify the width of the display, in pixels (default) or as a percentag
and height of 200 pixels:

H {widget:url=http://www.£flickr.com/photos/tags,
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This example shows the Widget macro in action. It lets you play with a Google Gadget, Gadzi's Monkey

Virtual Pet.

What You Need to Type

-

What You Will Get

More Examples of Macro Code

Google Gadgets
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You will need to find the URL for the Google Gadget you want to display.


http://www.flickr.com/photos/tags/atlassian/
http://www.google.com/ig/directory?synd=open&amp;num=24&amp;url=http://www.gadzi.com/gadgets/monkey.xml&amp;output=html
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Here is one way to find a gadget's URL:

1. Go to the Google Gadgets directory.

2. Find the gadget you want then click its name, such as 'Spider'.

3. The gadget's summary page will open. Copy the URL from your browser's address bar. The URL
looks something like this one:

Db st~ o '

e ——

4. Paste the URL into the Widget macro code on your Confluence page.

You can also use the URL of the 'add gadget' page. The page is called 'Add "gadgetx" to your iGoogle
page":

1. There are a couple of ways to get to the ‘add gadget' page:
® Click a '+Google' button underneath the gadget when displayed on a page somewhere.
® Or click 'Add Stuff' on your iGoogle page.
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Widgetbox widgets

You will need to find the URL for the Widgetbox widget you want to display.
Here is one way to find a widget's URL:

1. Ensure you are logged in to Widgetbox and that you are viewing the Widgetbox Gallery.
2. Find the widget you want then click its name, such as ‘cyber-pet'.
3. The widget's summary page will open. Within the Get Widget section, click the Atlassian

Confluence icon . The Widgetbox Add to Confluence dialog box appears, containing the
URL required for the Widget Macro.

o If you cannot see this icon, click the more... link to reveal it.
4. In the Widgetbox Add to Confluence dialog box, click the Copy button.
5. Copy the URL from your browser's address bar. The URL looks something like this one:

http://widgetbox.com/confluence/b8327e33-c8eb-4a38-b842-fbage6ffdd.

6. Paste the URL into the Widget macro code on your Confluence page.

Here is an example of the Widget macro code for embedding a Widgetbox widget:
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YouTube

You will need to find the URL for the YouTube video that you want to display.
To find a YouTube video's URL:

1. Go to YouTube and search for the video you want.

2. Click the title of the video, such as 'Wikis in Plain English'.

3. The video's summary page will open. Copy the URL from your browser's address bar. The URL
looks something like this one:

http://au.youtube.com/watch?v=-dnL00TdmLY

e ——
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4. Paste the URL into the Widget macro code on your Confluence page.

Here is an example of the Widget macro code for embedding a YouTube video:

MySpace Videos
You will need to find the URL for the MySpace video that you want to display.
To find a MySpace video's URL:

1. Go to MySpace Video and search for the video you want.

2. Click the title of the video, such as 'Glacier Creek Confluence Time Lapse'.

3. The video's summary page will open. Copy the URL from your browser's address bar. The URL
looks something like this one:
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4. Paste the URL into the Widget macro code on your Confluence page.

Here is an example of the Widget macro code for embedding a MySpace video:

H {widget:url=http://vids.myspace.com/index.cfm?fuseaction=vids.individuals
Google Video

You will need to find the URL for the Google video that you want to display.
To find a Google video's URL:

1. Go to Google Video and search for the video you want.

2. Click the title of the video, such as 'An Evening With Wiki Inventor Ward Cunningham in
Conversation'.

3. The video's summary page will open. Copy the URL from the address bar of your browser. The
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4. Paste the URL into the Widget macro code on your Confluence page.

Here is an example of the Widget macro code for embedding a Google video:

Yahoo Video

You will need to find the URL for the Yahoo video that you want to display.
To find a Yahoo video's URL:
. Go to Yahoo Video and search for the video you want.

1
2. Click the title of the video, such as 'Wiki Technology Trend: Past, Now and Future'.
3. The video's summary page will open. Copy the URL from the address bar of your browser. The
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a If you are unable to obtain a unique URL from your browser's address bar, click the envelope
(Share) icon on the lower section of the video screen and copy the contents of the Link field.
4. Paste the URL into the Widget macro code on your Confluence page.
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Here is an example of the Widget macro code for embedding a Yahoo video:

H {widget:url=http://video.yahoo.com/watch/423158/2424140}
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Dailymotion Video
You will need to find the URL for the Dailymotion video that you want to display.
To find a Dailymotion video's URL:

. Go to Dailymotion and search for the video you want.

1
2. Click the title of the video, such as 'Wiki Technology Trend: Past, Now and Future'.
3. The video's summary page will open. Copy the URL from the address bar of your browser. The

,............

a If you are unable to obtain a unique URL from your browser's address bar, click Menu at the
lower right section of the video screen, select URL & Embed Code and copy the contents of the
Link field.

4. Paste the URL into the Widget macro code on your Confluence page.

Here is an example of the Widget macro code for embedding a Dailymotion video:

H {widget:http://www.dailymotion.com/user/spacevidcast/video/x7zev]_spacevi

Episodic
You will need an Episodic user account if you want to create and distribute videos via Episodic.
To embed an Episodic video onto a Confluence page:

1. Find the video and copy the URL from the address bar of your browser. The URL looks something

http://app.episodic.com/shows/13/episodes/493

r

2. Paste the URL into the Widget macro code on your Confluence page.

Here is an example of the Widget macro code for embedding an Episodic video:

i {widget:url=http://app.episodic.com/shows/13/episodes/493}
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Vimeo
You will need to find the URL for the Vimeo video that you want to display.
To find a Vimeo video's URL:

. Go to Vimeo and search for the video you want.

1
2. Click the title of the video, such as 'The Wiki Show - Allison the Russian High Kicker'.
3. The video's summary page will open. Copy the URL from the address bar of your browser. The

http://www.vimeo.com/909808

e ——

4. Paste the URL into the Widget macro code on your Confluence page.

Here is an example of the Widget macro code for embedding a Vimeo video:
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; {widget:url=http://www.vimeo.com/909808} i
Metacafe

You will need to find the URL for the Metacafe video that you want to display.
To find a Metacafe video's URL:

1. Go to Metacafe and search for the video you want.

2. Click the title of the video, such as 'Wikis In Plain English (How To)'".

3. The video's summary page will open. Copy the URL from the address bar of your browser. The
URL looks something like this one:

http://www.metacafe.com/watch/679493/wikis_in plain english how to!

4. Paste the URL into the Widget macro code on your Confluence page.

Here is an example of the Widget macro code for embedding a Metacafe video:

H {widget:url=http://www.metacafe.com/watch/679493/wikis_in plain english h

blip.tv
You will need to find the URL for the blip.tv video that you want to display.
To find a blip.tv video's URL:

. Go to blip.tv and search for the video you want.

1
2. Click the title of the video, such as 'River cruising on the Rhine'.
3. The video's summary page will open. Copy the URL from the address bar of your browser. The
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4. Paste the URL into the Widget macro code on your Confluence page.

Here is an example of the Widget macro code for embedding a blip.tv video:

i {widget:url=http://blip.tv/file/996864/}

Viddler

You will need to find the URL for the Viddler video that you want to display.
To find a Viddler video's URL:

1. Go to Viddler and search for the video you want.

2. Click the title of the video, such as 'Gliffy Diagramm in Conflu...".

3. The video's summary page will open. Copy the URL from the address bar of your browser. The
URL looks something like this one:

http://www.viddler.com/explore/Markus_Z/videos/1/

ke e e e e e e e e e e e e e e e e e e mm e mm e —m e m i ———————————————————————————— i

4. Paste the URL into the Widget macro code on your Confluence page.

Here is an example of the Widget macro code for embedding a Viddler video:

H {widget:url=http://www.viddler.com/explore/Markus_Zz/videos/1/}
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Flickr
You can embed a slide show of photos from Flickr by supplying a URL that specifies one of the following:

Photos with a specific tag.

Photos belonging to the photostream of a specific Flickr user.
A set of photos as defined by the Flickr user.

A user's photostream starting at a specific photo.

If you want to do something else, we suggest that you try any Flickr URL. It should work.
Below are some examples of the Widget macro code for embedding Flickr images.
Flickr Photos with a Specific Tag

This example displays a slide show of Flickr photos that are tagged with the word 'Atlassian’.

H {widget:url=http://www.flickr.com/photos/tags/atlassian/}

Flickr Photos from a Specific User

This example displays a slide show of photos from the Flickr photostream of user 'Atlassian'.

H {widget:url=http://www.flickr.com/photos/atlassian/}

Flickr Photos from a Specific Set

This example displays a slide show of Flickr photos from the set ‘Melbourne Cup - November 2008' created
by user 'Atlassian’.

H {widget:url=http://www.flickr.com/photos/atlassian/sets/72157608657271078

A Specific Flickr Photo

This example displays a slide show of photos from the Flickr photostream of the user 'Atlassian’, starting
with a specific photo.

H {widget:url=http://www.flickr.com/photos/atlassian/3003538919/}

Skitch.com

You will need to find the URL for the Skitch image that you want to display.
To embed a Skitch image onto a Confluence page:

1. Go to Skitch.com.
2. Find the image and copy the URL from the address bar of your browser. The URL looks something

r

3. Paste the URL into the Widget macro code on your Confluence page.

Here is an example of the Widget macro code for embedding a Skitch image:

H {widget:url=http://skitch.com/atlassian/411g/example-image}
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Twitter

Use a Twitter link in the Widget macro to display a dynamic list of the latest tweets sent by a user or
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matching a Twitter search.

To display the latest messages from a Twitter user, add the user's Twitter link as a URL in the Widget

macro.
i {widget:url=http://twitter.com/username} H

H {widget:url=http://twitter.com/mcannonbrookes} H

To display the latest messages resulting from a Twitter search, add the Twitter search link as a URL in the
Widget macro.

¢ Make sure you use the supported format of the search URL:

http://search.twitter.com/search?g=my search term
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Format

H {widget:url=http://search.twitter.com/search?g=my search term} H
The example below will display the most recent tweets containing the word 'AtlassianDragons'

H {widget:url=http://search.twitter.com/search?g=AtlassianDragons} H

FriendFeed

To display the latest messages from a FriendFeed user, add the user's FriendFeed link as a URL in the
Widget macro. For example:

H {widget:url=http://friendfeed.com/myname}

BackType

To display the latest blog or website comments from a BackType user, add the user's BackType widget link
as a URL in the Widget macro. For example:

i {widget:url=http://www.backtype.com/myname } :
SlideShare

You will need to find the URL for the SlideShare presentation that you want to display.
To find a SlideShare presentation's URL:

1. Go to SlideShare and search for the presentation you want.
2. Click the title of the presentation, such as 'Using JIRA & Greenhopper for Agile Development'.
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3. The presentation's summary page will open. Copy the URL from the address bar of your browser.
The URL looks something like this one:
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4. Paste the URL into the Widget macro code on your Confluence page.

Here is an example of the Widget macro code for embedding a SlideShare presentation:

SlideRocket
You will need to find the URL for the SlideRocket presentation that you want to display.
To find a SlideRocket presentation's URL:

1. Log into SlideRocket and go to your library of presentations.

2. Copy the ‘web link' for the presentation you want to display. This will give you a URL that looks
something like this one:
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3. Paste the URL into the Widget macro code on your Confluence page.

Here is an example of the Widget macro code for embedding a SlideRocket presentation:
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Scribd
You will need to find the URL for the Scribd presentation that you want to display.
To find a Scribd presentation's URL:

1. Go to Scribd and search for the presentation you want.

2. Click the title of the presentation, such as 'My Sea Friends Coloring Book'.

3. The presentation's summary page will open. Copy the URL from the address bar of your browser.
The URL looks something like this one:

http://www.scribd.com/doc/5683554/My-Sea-Friends-Coloring-Book

e —

4. Paste the URL into the Widget macro code on your Confluence page.

Here is an example of the Widget macro code for embedding a Scribd presentation and displaying it with a
height of 600 pixels:
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Google Docs Presentations

You can embed presentations from Google Docs, but not other document types. You will need to find the
URL for the Google Docs presentation that you want to display.

To find the URL of a Google Docs presentation:
1. Publish your presentation in Google Docs.

2. View your published document, then copy the URL from your browser's address bar. The URL wiill
look something like this:
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3. Paste the URL into the Widget macro code on your Confluence page.

Here is an example of the Widget macro code for embedding a Google Docs presentation

Google Calendar

You can embed a Google Calendar into your page and to do this, you will need to add the URL for the
Google Calendar that you want to display.

To find the URL for a Google Calendar:

1. Log into Google Calendar.

2. In the calendar list on the left side of the page, ensure the appropriate calendar is selected, click
the down-arrow button next to the calendar name and then select the Calendar settings option.
(Alternatively, if available, click the Manage Calendars link at the bottom of the calendar list and
then click the name of the appropriate calendar.)

3. Inthe Calendar Address section, click the HTML button. A pop-up message with your calendar's
public URL appears.

4. Copy the URL from this pop-up message. The URL looks something like this:
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5. Paste the URL into the Widget macro code on your Confluence page.

Here is an example of the Widget macro code for embedding a Google Calendar:
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Wufoo HTML Form Builder

To display an HTML form built in the Wufoo HTML Form Builder, add the form's link as a URL to the
Widget Macro. For example:
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Dabble DB online database builder

To display a shared page built in Dabble DB, add the page's link as a URL to the Widget Macro. For
example:

o The Widget Macro supports shared Dabble DB view and form pages. You can insert a Dabble DB
data entry form into a Confluence page. On the same page or another page, you can use a a Dabble DB
view to display data submitted via the form.

Get Satisfaction social support application

To display a feedback form for a Get Satisfaction community, add the community or company link as a
URL to the Widget Macro. For example:
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About the Web-Widget and Widget Macros

Confluence supports web-widget as an alias for widget. Your System Administrator can enable or
disable one or both these macro names. The alias is useful for Confluence sites which use Adaptavist's
Community Bubbles plugin, to avoid conflict with the ‘widget' macro supplied by that plugin.

If the web-widget alias is enabled on your Confluence site, you can use web-widget instead of widget
in all the examples above.

Troubleshooting

If the URL given in the Widget macro does not work, the Widget macro displays an icon and the base URL.
The icon will be linked to the full URL given in the macro code.

For example, the following code:
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will result in an image like the one below:

RELATED TOPICS
® Working with Macros

Take me back to the Confluence User's Guide.

Widget Connector Examples

This page contains a working example of some services currently supported by the
Widget Connector. This page lets you preview what each widget will look like and see
how to interact with it.

Flickr

Google Video
Google Docs
YouTube
MySpace
Episodic
Vimeo

BlipTV

Viddler

Skitch

Twitter
FriendFeed
SlideShare
SlideRocket
Scribd

Wufoo

Error Message
Related Content
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{widget:url=http://www.£flickr.com/photos/atlassian/}

{widget:url=http://www.flickr.com/photos/atlassian/sets/72157608657271078

{widget:url=http://www.£flickr.com/photos/atlassian/3003538919/}

Google Video

J‘ Get ADOBE® 4
FLASH® PLAYER

{widget:url=http://video.google.com/videoplay?docid=-7739076742312910146&

Google Docs

{widget:url=https://docs.google.com/present/view?id=dgjvr7tq 243fjgwnvEix}

YouTube

{widget:url=http://au.youtube.com/watch?v=-dnL00TdmLY}

MySpace

J‘ Get ADOBE 4
FLASH* PLAYER

{widget:url=http://vids.myspace.com/index.cfm?fuseaction=vids.individualsg

Episodic

J‘ Get ADOBE 4
FLASH* PLAYER

{widget:url=http://app.episodic.com/shows/13/episodes/493}

FLASH* PLAYER

{widget:url=http://www.vimeo.com/909808}
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FLASH* PLAYER

{widget:url=http://blip.tv/file/996864/}

Viddler

J‘ Get ADOBE o
FLASZH® PLAYER

{widget:url=http://www.viddler.com/explore/Markus_Zz/videos/1/}

Skitch

{widget:url=http://skitch.com/jnolen/bbybm/skitch.com-jnolen}

Twitter

{widget:url=http://twitter.com/mcannonbrookes}

{widget:url=http://search.twitter.com/search?g=AtlassianDragons}

FriendFeed

{widget:url=http://friendfeed.com/myname}

SlideShare

J‘ Get ADOBE A
FLASH® PLAYER

{widget:url=http://www.slideshare.net/jleyser/using-jira-greenhopper-£for-

SlideRocket

{widget:url=http://app.sliderocket.com/app/FullPlayer.aspx?id=132£9db7-b0

Scribd

{widget:url=http://www.scribd.com/doc/28967704/How-did-Shakespeare-change



http://get.adobe.com/flashplayer/
http://get.adobe.com/flashplayer/
http://get.adobe.com/flashplayer/

Confluence 4.0 Documentation

: {panel :borderColor=#CCCCCC |bgColor=#FFFFFF } :
: {widget:url=http://atlassian.wufoo.com/forms/let-us-know-what-you-think-¢

Error Message

Related Content

® Working with Macros

Guides to Specific Uses of Confluence

This section of the Confluence user's guide contains a number of targeted guides showing you how to use
Confluence for a specific purpose. Each guide:

® Shows you how to set up a Confluence space to suit your purpose.

® Gives an overview of the Confluence functionality that you will find most useful in that particular
usage of the wiki.

® Mentions plugins that you may find useful to extend Confluence's core functionality.

Contents

® Developing Technical Documentation on Confluence Wiki
® Developing a Knowledge Base on Confluence Wiki
® Developing an Intranet on Confluence Wiki

RELATED TOPICS

Take me back to the Confluence User's Guide.

Developing Technical Documentation on Confluence Wiki

Welcome! This is a guide to using Confluence wiki for technical documentation. You will find this guide
useful if you want to write a technical manual such as a user's guide, administrator's guide, installation
guide, and so on.

Creating your Technical Documentation Space

Using Templates in Technical Documentation

Re-using Content in Technical Documentation

Managing the Life Cycle of your Technical Documentation

Providing PDF Versions of your Technical Documentation

Exporting and Printing Technical Documentation

Essential Confluence Features for Technical Documentation

Confluence Plugins for Technical Documentation

Further Reading about Developing Technical Documentation on Confluence

RELATED TOPICS

Confluence User's Guide
Confluence Administrator's Guide

Creating your Technical Documentation Space

This guide is for people who want to develop and publish technical documentation on Confluence wiki. Yot
will find it useful if you want to write a technical manual such as a user's guide, administrator's guide,
installation guide, and so on. This page is a quick-start guide to creating a wiki space for technical
documentation.
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@ Quick guide to creating a technical documentation space

Add a space and select the Documentation theme.

Set the space permissions.

Change the title and content of the space home page.

Customise the Documentation theme.

Create an inclusions library to manage your re-usable content.

Create the table of contents for your manual or manuals, by adding top-level
pages for all the usual sections (user's guide, administrator's guide, and so on).
® Customise your PDF layout and stylesheet, if required.

® Hint: Now that you have a good skeleton for a documentation space, save the
space as a template space.

The rest of this page gives more details of the above procedure.

On this page:

® Step 1. Add your Space
® Step 2. Set the Space Permissions

® A Bit More about Permissions

® Step 3. Customise the Title and Content of the Home Page

Step 4. Customise the Documentation Theme
® Example of a Customised Footer
Step 5. Create an Inclusions Library
® Examples of Inclusions Libraries

® Step 6. Create the Table of Contents
® Step 7. (Optional) Customise the PDF Layout and Stylesheet
® Step 8. Save your New Space as a Template Space

Step 1. Add your Space

Below is a quick guide to adding a space. See Setting up a New Global Space for a full description.

1.

4.
&,

Go to the Confluence dashboard and click the 'Add Space' link located above the
list of spaces.

& Add Space

E) Feed Builder

& People Directory

Spaces: EEWLUTGCE RIEWALIE| Global

&) Demonstration Space

An example of a Confluence space with a
tutorial and sample content

Hint: If you cannot see the 'Add Space' link, this means that you do not have
permission to add spaces. Please contact your Confluence administrator.

. The 'Create Space' screen appears. Enter a space name and a short, unique

space key.

. Leave the permission settings as default, or choose to allow only yourself to view or

contribute content to this space. You can change these settings later and with more
flexible options.

Select the 'Documentation Theme'.

Click 'OK".

The home page of your new space will appear. Because you created the space, you are the space
administrator. Now you can do some basic configuration, as described in the sections below.

Step 2. Set the Space Permissions

Define the space permissions to determine who can do what in your new space.
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1. Open the '‘Browse' menu and select 'Space Admin'.

Browse = Trillian ~ 1l EEELHS

3

Fages in

Blog id ~ &% Tools ~
tion Labels

Attachments
14, 20| Bookmarks
e Mﬂll

bourite Advanced

Feople Directory

pistrater | Keyboard Shortcuts
flay at 5:

start creating pages,

m

Confluence Gadgets

Confluence Admin

fay at 5:

Click 'Permissions’ in the left-hand panel.
Confirm your administrator access as prompted.
Click 'Edit Permissions'.
Set the permissions to suit your needs then click 'Save All'.
® You can add groups and/or individual users to the list, then select the
permissions for each group or user.
® You can also set the permissions for anonymous users — these are people
who have not logged in to the wiki. Anonymous access is available only if
enabled for the entire Confluence site.
® Note that you can change these permissions at any time. You may want to
restrict the permissions to specific groups now, and later open the space to
more people.

G0 = @

A Bit More about Permissions

Confluence has a robust and granular permissions scheme that you can use to determine who can view,
comment on and even update the documentation. There are three levels of permissions in Confluence:

® Global permissions apply across the entire site.

® Space permissions apply to a space.

® Page restrictions allow you to restrict the editing and/or viewing of a specific page. Below we
discuss a way of using these in the draft, review and publishing workflow.

Space permissions in Confluence are simple yet granular enough to be useful for technical
documentation. You can:

® Use the permission levels to control who can create pages in the space, delete pages, create
comments, delete comments, administer the space, and so on.

® Grant a permission level to one or more users, and/or to one or more groups, and/or to
anonymous users.

Terminology:

® 'Anonymous' means people who have not logged in to the wiki.
®* The ‘confluence-users' group is the default group into which all new users are assigned.
Everyone who can log in to Confluence is a member of this group.

For example, you might allow your team full edit and administration rights while others can only add
comments. Or you might grant the general public access to your documentation, while only staff members
can update it.
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| Example: Allow |
: team full edit anc
Attachments I Bookmarks I Mail IAdvanced [ Activity [ Space Admin rlghts Whlle Othe

Groups . temesshenemoememeeneed

These are the permissions currently assigned to groups for this space

ge eWS Comments |Attachments|Mail |Sp

Create | Export|Restrict| Remove |Create | Remove | Create | Remove | Create |Remove | Remowve | Ex

Bconfencewses @ O © © O B O © © O O @ E
&y my-team @ @ 9 9 9 9 9 ¢ 9 9 @ @ «

Edit Permi

Individual Users

These are the permissions currently assigned to individual users for this space

ge ] Comments |Attachments|Mail |S
Create | Export| Restrict| Remowe | Create | Remowe | Create | Remowe | Create | Remowve | Remowe | Ex

A\ Administrator (admin) @ @ @ @ o 9O O o 9 9 o o ¢

Edit Permi

Anonymous Access

When a user is using Confluence while not logged in, they are using it anonymously
For example: Enabling anenymous ‘commenting’ permission, allows non-logged-in users to make comments in this ¢

ge e Comments |Attachments|Mail |Sp
View |Create | Export| Restrict| Remove | Create| Remove | Create | Remowve | Create | Remove | Remowve | Ex)

& Anonymous B 80 80 8B 8 8 8 8B 80 8 B8 B8 E

For detailed information, see the documentation on:

® Global permissions
® Space permissions
® Page restrictions
® Users and groups

Step 3. Customise the Title and Content of the Home Page

When you created your space, Confluence created a home page with default content and a default title,
'Home'. You will want to change the title and content.
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1. Go back to your space home page, by clicking the space name in the breadcrumbs
at the top of the screen. In the example below, the space name is 'MyProduct

Documentation':
Dashboard * MyProduct Documentation * Space Administration * V

% View Space Permissions

2. The space home page appears. By default, the page title is 'Home'.

Dashboard * MyProduct Documentation * Home

Search

% Home

Administrator

3. Click 'Edit'.
4. The page opens in edit mode. Change the title to suit your needs.

Dashboard * MyProduct Documentation * Home * Edit Page

x MyProduct Documentation Home

Rich Text
Paragaph -~ B 7 U #= A~ |4

This is the home of the MyProduct Documentation space.

5. Update the content to suit your needs.
Hint: If you do not know what to add yet, just add a short description. You can refine

the content of the page later. Take a look at an example of a home page.
6. Click 'Save'.

Step 4. Customise the Documentation Theme

When you added the space you chose the Documentation theme, which provides a left-hand navigation
bar and a good look and feel for technical documentation. If necessary, you can configure the
Documentation theme to add your own page header and footer or to customise the default left-hand
navigation bar. These customisations affect the online look and feel of your documentation. See
Configuring the Documentation Theme for the full description.
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. Open the 'Browse' menu and select 'Space Admin'.

. Click 'Themes' in the left-hand panel.

. If the space is not yet using the Documentation theme, apply the theme now.

. Click 'Configure theme' in the yellow area of the '‘Current Theme' section at the top
of the page.

A WN P

Current Theme

The current theme controls the layout and colours of this space.

Documentation Theme

This theme is well suited for structured content
documentation. It features a table of contents ||
the left, making it easier to see the structure of
move from page to page. You can customise th
panel, page header and page footer. This thems
Firefox, Safari and Internet Explorer T+.

| l‘ll

Configure theme - further customise this theme's options

5. The 'Documentation Theme Configuration' screen appears. Customise the
left-hand navigation bar, header and footer to suit your needs. Details are in the
documentation. Here are some hints:

® The 'Page Tree' check box determines whether your space will display the
default search box and table of contents (page tree) in the left-hand panel.

® The 'Limit search results to the current space' check box determines
whether Confluence will search only the current space or the whole
Confluence site. This setting affects the default search. Viewers can
override it each time they do a search.

® Enter text, images, macros and other wiki markup into any or all of the three
text boxes for the the left-hand navigation bar, header and footer. You can
use the Include macro and the Excerpt Include macro to include re-usable
content.

® Any content you add to the navigation panel will appear above the default
page tree.

® |f you like, you can remove the default page tree (by unticking the box) and
add your own, customised version of the Pagetree macro instead.

6. Click 'Save'.

Example of a Customised Footer
Take a look at the footer of a page in the Crowd documentation space.

e

Log a reguest with our support Raise an issue for our See answers from the Blog and
team. developers. community. documr

Except where otherwise noted, content in this space is licensed under a Creative Commons Attribution 2.5 Australia

Powered by Atlassian Confluence 3.4.1, the Enterprise Wiki | Report a bug | Atlassian News

To produce the above footer, we have the following content in the footer panel in the Documentation theme
configuration screen:

Footer {include: Documentation Footerlngpanel=true}
{include:ALLDOC: Copyright Motice|ngpanel=true}

Here it is in text form:
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{include: Documentation Footer|nopanel=true}
{include:ALLDOC: Copyright Notice|nopanel=true}

The above content consists of two Include macros.

® The first macro includes a page called _Documentation Footer. This page contains the big blue
buttons and hyperlinked text.

® The second macro includes a page from a different space, the ALLDOC space, called _Copyright
Notice. This page includes our standard copyright notice, used in all our documentation spaces.

Step 5. Create an Inclusions Library

Using Confluence, you can dynamically include content from one page into another page. You can include
a whole page into another one, using the Include macro. You can also define an ‘excerpt’ on a page, and
then include that excerpted text into another page using the Excerpt Include macro.

To organise your re-usable content, we recommend that you create a set of pages called an 'inclusions
library'.

1. Open the 'Browse' menu and select '‘Pages’.

2. The 'List Pages' screen will appear. Open the 'Add' menu and select 'Page'.
This will add a page at the root of the space, at the same level as the home page.

3. Enter a suitable title. We use '_InclusionsLibrary'. The unusual format of the title
helps to let people know this page is special.

4. Enter some content on the page. We enter text explaining the purpose of the

inclusions library and how to re-use the content. You can copy our text by clicking

through to one of the example pages listed below.

% _InclusionsLibrary

Rich Text
Paragraph B I U= A-|4

The children of this page contain information which is included in

5. Add child pages containing your re-usable content. See the examples of our own
inclusions libraries listed below.

Some notes about inclusions libraries:

® The inclusions library is not a specific feature of Confluence. The pages in the inclusions library
are just like any other Confluence page.

®* The pages are located at the root of the wiki space, not under the home page. This means that
they will not appear in the table of contents on the left and they will not be picked up by the search
in the left-hand navigation bar either.

® The pages will be picked up by other searches, because they are just normal wiki pages.

®* We have decided to start the page name with an underscore. For example, '_My Page Name'. This
indicates that the page is slightly unusual, and will help prevent people from changing the page
name or updating the content without realising that the content is re-used in various pages.

Examples of Inclusions Libraries

Here are some examples in our documentation:

® Crowd inclusions library
® Confluence inclusions library

Step 6. Create the Table of Contents

Create the table of contents for your documentation, by adding the top-level pages for all the usual
sections:
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User's guide
Administrator's guide
Installation guide
Configuration guide
Release notes

FAQ

Whatever else you need

1. Go back to your space home page, by clicking the space name in the breadcrumbs
at the top of the screen.

2. Open the 'Add' menu and select 'Page’. This will add the page as a child of the
home page.

3. Enter the page title, 'User's Guide'.

4. Enter the content of the page.
Hint: If you do not know what to add yet, just add a short description then refine the
content of the page later. If you like, you can add the Children macro. That will act as
a table of contents on the page once you have added child pages.

5. Click 'Save'.

Now do the same for all the sections of your technical document.

Step 7. (Optional) Customise the PDF Layout and Stylesheet

If you are planning to provide PDF versions of your documentation, you may want to customise the PDF
layout and styles for your space. You can skip this step for now and do it later, if you prefer. The
instructions are in a separate section of this guide, dedicated to PDF. See Providing PDF Versions of your
Technical Documentation.

Step 8. Save your New Space as a Template Space
This is a useful suggestion. Once you have set up your first documentation space and are more-or-less

happy with it, use the Copy Space plugin (see notes below) to copy the space while it still has very little
content. From this point on, you can copy it each time you want to create a new documentation space.
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1. Open the '‘Browse' menu and select 'Space Admin'.
2. Click 'Copy Space' in the left-hand panel.

Space Operations

& Space Details
@ Space Labels
@ Remove Space
@ Copy Space
i Trash

Hint: If you cannot see the '‘Copy Space' option, this means that the plugin is not
installed on your Confluence site. Refer to the documentation on installing plugins.

3. The 'Copy Space' screen will appear. Enter the details as prompted, to copy your
space to another new space.

Copy Space

You are about to copy this space. Please fill in the new key and space

Name: Template for Documenta
Key: TEMPLATE
Use existing authors and dates:
Copy comments:
Copy attachments:
[

Copy personal labels:

[ Save H Cancel

4. Click 'Save'.

You now have a template space. From this point on, you can use the Copy Space plugin to copy the
template space each time you want to create a new documentation space.

Notes:

® The Copy Space plugin is not covered by Atlassian support. However, the Atlassian technical
writers use it for all our documentation. If you like, you can vote for an comment on the request for
Atlassian support to cover this plugin: CONF-14198.
® Your site administrator will need to install the Copy Space plugin into Confluence. Refer to the
documentation on installing plugins.
Next Steps

You now have the basic structure and configuration for your technical documentation space. You have also

created a handy template to use next time you need a space. What next? Take a look at Using Templates
in Technical Documentation.

Using Templates in Technical Documentation

This page is part of the guide to developing technical documentation on Confluence Wiki. We have already

shown you how to create your technical documentation space. Now we offer an introduction to the
templates that Confluence provides.
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@ Quick guide to templates in Confluence

® Atemplate is a page with predefined content that can be used as a prototype
when creating other pages.

® Templates are available across the Confluence site (global templates) or per
space (space templates).

® Both ‘global templates' and ‘space templates', as described on this page, define
the content of a page. They do not define the content of an entire space.

® You can import predefined templates, including those shipped with Confluence
and additional templates from the Atlassian Plugin Exchange.

® To create a template for an entire space, see our guide to creating your
documentation space.

On this page:

® Deciding Where to Put Your Templates
® Creating a Global Template

® Creating a Space Template

® Importing Templates

® Using a Template to Create a Page

Deciding Where to Put Your Templates

In Confluence, there are two places to store your templates:
® Global templates: These are defined by site administrators through the Administration Console
and are available in every space.
® Space templates: These are defined by space administrators on the space administration
screens, and are only available in the space in which they are defined.

Decide whether your template is useful across more than one space.

® |[f yes, create a global template. You will need Confluence administrator permissions.
® |f no, create a space template.
® You will need space administrator permissions for the relevant space(s).
® You may have already saved your documentation space as a template, as
described in our guide to creating your documentation space. In that case, it
may be useful to save your template page in your template space. When
you later copy the space, the template pages will be copied too.

Creating a Global Template

1. Choose Browse > Confluence Admin.

2. Enter your password and click Confirm. You will be temporarily logged into a secure
session to access the 'Administration Console'.

3. Select Global Templates in the left-hand panel.

4. Click Add New Global Template.

See Global Templates for more information.

Creating a Space Template

1. From any page in the space, choose Browse > Advanced.
2. Click Templates in the left-hand panel.
3. Click Add New Space Template.

See Adding a Template for more information.

Importing Templates

Confluence ships with a number of templates, including the 'Charts', 'Document List' and 'Meeting Notes'
templates. These templates are not available for use by default. However, if you have the appropriate
permissions to access the Administration Console, you can import any of these templates to be used
globally or within a specific space. In addition, you can find more template bundles on the Atlassian Plugin
Exchange.

. Go to the 'Confluence Administration Console' and click Import Templates.

. Select the templates that you want to import.

. Choose which space to import the templates to, or whether to import them as global
templates.

4. Click Import.

WN -

Using a Template to Create a Page
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When people add a page on your Confluence site, they can choose to base their new page on a template.

Dashboard * Confluence 3.4 » Add Page

b 4

Select a page template to start from

Browse * Sarah Maddox [Atlassian Technical Writer] ~ [EEEESRSHlTE

| { Base your new page on a
i template (optional)

__-:!___
o
]

Text Iformatting

Wiki Markup Save | | Cancel ‘| *bold* bold

= 1i italic

=» [ i
under

Headings

hl. Large heading

h3. Medium heading
h5. Small heading

Next Steps

You now have a good idea of how Confluence templates work. What next? Take a look at Re-using
Content in Technical Documentation.

Re-using Content in Technical Documentation

This page is part of the guide to developing technical documentation on Confluence Wiki. In the page abot
creating your technical documentation space, we showed you how to set up an 'inclusions library' to
contain content that you can re-use on more than one page. Now we offer further guidelines on re-using
content in your documentation space.

Your documentation may be about using a software application, or it may be a technical manual for your
product range. On this page, we use the term 'widget' to describe the things that you are documenting,
such as the screen, form, document, product or object.

@ Quick guide to re-using content

® Create an 'inclusions library' to manage your re-usable content. See our guide to
creating your technical documentation space.
Use the excerpt macro to define a re-usable section (‘excerpt’) on a page, or
just decide to re-use the entire content of the page.
Use the excerpt-include macro to include the excerpt from one page onto
another page.
Use the include macro to include the entire content of a page onto another
page.
Consider installing the Multi Excerpt plugin if you need to define multiple
excerpts per page.

The rest of this page gives an overview and more details of the above procedures.

On this page:

® Reasons for Re-Using Content
® Defining an Inclusions Library
Working with Excerpts and Inclusions
® Using the Include Page Macro
® Using the Excerpt Include Macro
® Using the Multi Excerpt Plugin
® An Example of Content Re-Use: A Glossary
® Creating a One-Page Glossary
® Creating a Glossary with Child Pages
® Referring to Glossary Terms
® Further Reading

Reasons for Re-Using Content

A golden rule for technical documentation is to write the content only once but allow that content to be used
in many places and in many forms.

For example, you may have the following types of content:

® A technical manual that describes each widget in detail.
® Tips and tricks on how to get the most out of the widget.
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A step-by-step user guide for first-time users on how to use the most common widgets.
A training manual with exercises or videos that people can follow in their own time.

A one-page cheat sheet for users to stick up on their workstation.

Text for a sales brochure that is sent out to a print house for production.

Each of these types of content will share common information, such as a glossary entry, a technical or
marketing description of the widget, or a step-by-step guide on how to use the widget.

Some initial planning of your technical documentation will allow you to re-use any or all of the content you

write, so there is only ever one place to update the content, and those changes flow through to all of your
other documentation.

Defining an Inclusions Library

We recommend that you create an ‘inclusions library' to manage your re-usable content. If you have not
already done this when creating your documentation space, see our guide to creating your technical
documentation space.

Working with Excerpts and Inclusions

Excerpts and inclusions (sometimes called ‘includes') are very useful for re-using content:
® Use the Excerpt macro (excerpt) to define a re-usable section (‘excerpt’) on a page.
® Use the Excerpt Include macro (excerpt-include) to include the excerpt on another page.
® Use the Include Page macro (include) to include the entire content of a page onto another page.

A simple example of an inclusion is a note or warning that is used in many places in your documentation.
Here is an example:
' Example note -- "Draft in progress"
s

This document is still in draft status. Please treat the content with caution.

Tip: Keep your re-usable pages short and sweet. Do not worry if you find that you need hundreds of pages
to hold your inclusions. It helps to keep things separate and organised.

Using the Include Page Macro
In this example, we use the Include Page macro to create a note that you can re-use on your

documentation pages. The Include Page macro will include the entire content of one page into another
page. (See the 'Excerpt' macro below for including parts of a page.)

1. Create a page in your inclusions library called _Draft Note.
2. Add the content of the page. In this example, we use the Note macro with some text
inthetileandbody: ,
{note:title=Draft in progress}This document is
still in draft status. Please treat the content

with caution.{note}

3. Use the Include Page macro to include that note in any page in your documentation.
For example:

e e I ,

: {include: Draft Note|nopanel=true}
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See the documentation on the Include Page macro for more details.
Using the Excerpt Include Macro

An excerpt is a section of a page that you can include into another page.



Confluence 4.0 Documentation

1. Use the excerpt macro to define any content in your page that you want to be able
to use elsewhere. This content can be as short as a word or as long as the entire
page. For example, let's assume we have a page called 'My Short Poem":

I ,

I really love this poem:

{excerpt}

Mary had a little lamb

Its fleece was white as snow

{excerpt}

And I'm going to use it all over the place.

2. Use the Excerpt Include macro to include the excerpt into another page. For
example:
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You can only define one excerpt on a page. See the documentation on the Excerpt Include macro for
more details.

To have multiple excerpts on a page, see the 'Multi Excerpt plugin' below.

Using the Multi Excerpt Plugin

The Multi Excerpt plugin provides additional macros that enable you to have multiple excerpts on a page. A
good example of where you would find this useful is in the glossary page discussed below. If you want to
include a single glossary entry or a subset of the glossary entries in another page, then the named
excerpts allowed by the Multi Excerpt plugin are very useful.

Notes:

® The Multi Excerpt plugin is a commercial plugin and is not free.

® Your Confluence administrator will need to download and install the plugin into your Confluence
site before you can use the macros described below. Refer to the documentation on installing
plugins

® Before installing a plugin into your Confluence site, please check the plugin's information page to
see whether it is supported by Atlassian, by another vendor, or not at all. See our guidelines on
plugin support. Please refer to the Multi Excerpt plugin page for support details.

1. Use the following code on the base page containing the content you want to use
elsewhere:

{multi-excerpt:name=ExcerptNamel}
Excerpt text 1
{multi-excerpt}
Any other text
{multi-excerpt:name=ExcerptName2}
Excerpt text 2
{multi-excerpt}

2. Use the following code on the page where you want to include the named excerpt:

{multi-excerpt-include:pageTitle=PageName |name=ExcerptN:

; {multi-excerpt-include:spaceKey:pageName |name=excerptNar

See the Multi Excerpt plugin page for more details.

An Example of Content Re-Use: A Glossary

A glossary is something that most technical documentation will require. There are a few ways to set up
glossaries in Confluence. These are the most popular:

® All glossary entries on one page.
® Each glossary entry on separate child pages with a main page showing excerpts of the glossary.
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Once you have defined the glossary entry, you can refer to it from the main pages of your technical
documentation.

Creating a One-Page Glossary

This style of glossary is useful if the glossary entries tend to be short and there are not too many of them.

1. Create a page named Glossary.
2. Add an alphabetical index at the top of the page and a heading for each letter of the

alphabet: ,
i [A[#A] | [B[#B] |[Cl|#C] §
H {anchor:a}
i h2. A
: {anchor:B}
i h2. B
i {anchor:c}
h2. C ...

3. Enter each glossary entry under the relevant alphabetical heading. Each glossary
entry (term) should include:
® An anchor tag, so that you can link to it from other pages.
® The term itself.
® A definition of the term.
® Alink to the page in your technical documentation that explains the term in

H {anchor:MyGlossaryTerm} H
H h4. MyGlossaryTerm H
i This is the definition of MyGlossaryTerm. See i
: [Page Name] for more information. i

4. Optionally, include a horizontal line between the terms. This depends on how long
each entry is. If your glossary tends to have short entries, it may look too cluttered
with horizontal lines.

See the glossary in the Confluence documentation for an example of this style of glossary (without the
alphabetical index).

Creating a Glossary with Child Pages

This style of glossary is useful if the glossary entries tend to be quite long or have additional information
over and above the definition of the term.

1. Create a page named Glossary.

2. Create a child page for each glossary entry (term). Each child page should contain:
® The term as the title of the page.

The definition of the term in the body of the page.

Excerpt tags (excerpt) tags surrounding the definition.

Any additional information after the excerpt tags.

H {excerpt} H
H This is the definition of MyGlossaryTerm H
: {excerpt} i
: More information to describe MyGlossaryTerm :

3. On the 'Glossary' page, use the children macro to show the excerpts from each
child page in a list, with the page name displayed in 'h4' style.
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See the glossary in the Crowd documentation for an example of this style of glossary.
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Referring to Glossary Terms

In the main pages of your technical documentation, create a link to the glossary page for
each glossary term.

Note that this is a standard page link with an anchor. We have formatted the link as italics, because it helps
to have the glossary links looking different to other page links. Readers can just skip over the glossary link
if they are already familiar with the term.

Further Reading

® A blog post about content re-use: Technical Writing in a Wiki - Content Re-use and Structure
(November 2010).
Next Steps

You now have a good idea of how to re-use content in a Confluence documentation space. What next?
Take a look at Managing the Life Cycle of your Technical Documentation.

Managing the Life Cycle of your Technical Documentation

This page is part of the guide to developing technical documentation on Confluence Wiki. We have already
shown you how to create your technical documentation space, including how to set permissions for your
space. Now we offer a quick-start guide to managing the life cycle of your technical documentation in
Confluence. The life cycle includes drafting, reviewing and publishing a document, as well as managing
documentation that is release-specific.

@ Qumk guide to managing the technical documentation life cycle

Create draft pages with restricted permissions, to hide them until they are ready
for publication.

® Set the permissions to allow reviewers to comment on and/or update the pages.

® When ready, publish the page by removing the permission restrictions.

® Monitor updates to your draft and published pages by watching your space
and/or subscribing to RSS feeds.

® Use spaces as a mechanism for matching your documentation version to
product releases: one space per major release number.

® Consider installing plugins for extended workflow and publication management.

The rest of this page gives more details of the above procedures.

On this page:

® Using the Built-In Confluence Functionality to Manage Workflow and Release Cycle
® Drafting, Reviewing and Publishing a Page
® Keeping Track of Documentation Updates
® Viewing the History of a Page
® Receiving Email Notification of Updates
® Monitoring Updates via RSS Feeds
® Release Management
® Space Keys
® The Release Management Process
® Other Scenarios using the Built-In Confluence Functionality
® Using Plugins for Extended Workflow and Publication Management
® Notes

Using the Built-In Confluence Functionality to Manage Workflow and Release Cycle

This section describes how to use the built-in Confluence functionality to manage your workflow (draft,
review, publish) and to align your documentation version control to the product release cycle.

In this scenario we also assume that you want a live space that always has the same space key and
always contains the latest version of your documentation. This scenario suits the requirements of an
organisation that wants their technical documentation to be 'live'. Various groups of people can refine the
content as and when required. People can also subscribe to the space, knowing that they will always get
the latest version of the documentation and comments.

This is the way we manage our documentation at Atlassian. The content of the wiki is dynamic,

continuously updated, commented on, subscribed to and watched by thousands of people all over the
world.


http://blogs.atlassian.com/confluence/2010/11/confluence-wiki-technical-writing-content-reuse.html
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Drafting, Reviewing and Publishing a Page

The workflow is simple.

1. Create a page with restricted permissions. For example, you might restrict viewing to
a group of people such as your team. On a public wiki, you might restrict viewing to
staff members, so that the general public cannot see the page.

2. Write the page content.

3. Ask other people to review the page. They can add comments to the page or simply
edit the page content directly.

4. Publish the page when ready, by doing the following:

® Delete the comments on the page.

® Remove the permission restrictions on the page. The page has now been
published. The space permissions and site permissions now determine who
can see and/or update the page.

The screenshot below shows a page under review. Notice the lock icon at top left, indicating that restricted
permissions apply to this page.

Dashboard * Documentation Demo * Home  Introducing workflow Browse v Ed ~ [SEEIS)

% Introducing workflow g Edt  dpAdd~ £
{8 Added by Sarah, last edited by Ed on Jan 12, 2009 (view change) hide comment E_KEE)}H[_T-]E\

Comment: Added note about plugin support _
Confluence does not have any builtt-in workflow. . ==777=7/—==77™
It does have the features and plugin points to let you design a workflow to suit your needs.

Interesting plugins already created:

» Approvals Workflow Plugin: http://confluence atlassian.com/display/CONFEXT/Approvals+Waorkflow+Plugin
* Content Publishing Plugin: http://confluence. atlassian.com/display/CONFEXT/Content+Publishing+Plugin

o= —————
© Atlassian does not officially support these plugins _ E Page Upd
Please refer to the guidelines on Atlassian plugin support. ] the reVieU
[ eyl

Add Labels

Comments (1) Hide Comments | Caollapse All | Add Comment

I‘ Andrew says:
o m——————
| think we should tell them that not all plugins are supported. | i A comme
Edit | Remove | Reply i_the reVieV

Keeping Track of Documentation Updates

On a wiki, it is quite usual for a number of different people to update a single page. Technical writers need
to know what happens to our documents, both during review and after publication.

Viewing the History of a Page

Confluence creates a new version of the page every time someone edits the page. The page history shows
all the versions, with date, author, and any comments made on the update.

Go to the page and choose Tools > Page History.

Version Date Changed By Operatic
[] CURRENT (v. 41) Jul 07, 2009 11:33 Giles Gaskell [Atlassian Technical Writer]

0 w40 Jun 18, 2007 11:08 Rosie Jameson [Atlassian Technical Writer] Restore

0 «39 Jun 18, 2007 10:19 Rosie Jameson [Atlassian Technical Writer] Restore

On the page history view, you can:

® View the content of a specific version of the page.

® Revert to (restore) a specific version.

® Select any two versions and ask for a comparison, to see what has changed between those two
versions.

See Page History and Page Comparison Views for detailed information.
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Itis all very well to go to a specific page and see what has happened to it, but how do you know when to go
and look at the page? You need a notification of any changes made to your documentation space.

In Confluence, you can monitor updates to your documentation via email notifications and via RSS feeds.

Receiving Email Notification of Updates

You can ‘watch’ a page or an entire space. Whenever anyone updates the page or space, you will receive
an email notification.

To watch a page:

Open the 'Tools' menu and select 'Watch'.

To watch a space:

1. Goto a page in the space and choose Browse > Advanced.

2. In the left-hand panel, click 'Start watching this space'.

See Subscribing to Email Notifications of Updates to Confluence Content for details of the various
notifications Confluence will send, and how to configure your notification settings.

Monitoring Updates via RSS Feeds

RSS feeds provide another way to keep track of updates. The simplest way to build an RSS feed is to use
Confluence’s feed builder, accessible from the dashboard. This will give you a URL that you can ping to get
the latest updates.

Below we describe how to set up a useful feed for your technical documentation space. Remember that
you can adjust the settings to suit your own needs.

1. Choose Browse > Feed Builder. The RSS feed builder form appears.

2. Check the boxes to select all the content types. (Even if you are not expecting
comments, blog posts or mail in your documentation space, it does no harm to
receive notifications if they do arrive.):

® Pages and the comments and attachments on pages.
® Blog posts and their comments and attachments.
® Mail.

3. Select your documentation space from the list. Press Ctrl and click to select multiple
spaces.

4. Click the Create RSS Feed button to create your feed.

5. This will take you to a new screen. Drag or copy the link into your RSS reader. The
feed URL is linked to the words Drag or copy this link to your RSS reader.

Now that you have set up your RSS feed, you need to decide how to read it. There are various options to
choose from. For example:

® Use an RSS reader, such as the Sage add-on for Firefox.
® Use an email client, such as Thunderbird.

See Subscribing to RSS Feeds within Confluence for details.

Release Management

Let's assume that your product goes through a regular release cycle, and that you need to retain separate
documentation for each major version of the product.

At Atlassian, we use spaces as our version-control mechanism.

® Archive spaces. At each release, we create a new archive space to house the previous version of
the documentation.

®* The live space. The documentation for the latest version of the product resides in the live space.
The live space always retains the same space key and is always available for viewing and
updating.

Space Keys

The live space has just the product name as its space key. For example, for the Crowd product the space
key is 'CROWD'. (See the Crowd documentation space.)

For the archived versions, we use a combination of the product name plus version number as the space

key. For example, we use 'CROWDO020' for the Crowd 2.0 documentation, 'CROWDO016' for the Crowd 1.6
documentation, and so on.

The Release Management Process


https://addons.mozilla.org/en-US/firefox/addon/77/
http://www.mozillamessaging.com/en-GB/thunderbird/
http://confluence.atlassian.com/display/CROWD
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Here is an overview of the process we follow at Atlassian.

1. Leading up to release date. Work with hidden draft pages in the live space. A
‘hidden draft' is simply a page that has restricted permissions applied:
® For each new feature, create a new page with restricted permissions.
® |f you need to update existing pages, create a hidden copy of the existing
page and apply the updates to the copy.
® Follow the usual draft and review procedure for each page.

2. A few days before release date. Use the Copy Space plugin to copy the live space
to a new space. This creates a snapshot of the current documentation, and will act
as an archive for the current release which is soon to become the previous release.
(We described the use of the Copy Space plugin in the earlier section of this guide:
Creating your Technical Documentation Space.)

3. On release date. Publish the updated documentation for the new version of the
product:

® Rebrand the live documentation space to reflect the new release number. In
other words, change the space name and any other descriptions that
include the product release number.

® Unhide all the new pages, by removing the permission restrictions on each
hidden page.

® Copy the content of the updated pages to the proper pages, then delete the
copies.

® Export the newly updated space to PDF, HTML and XML, for those
customers who prefer offline versions of the documentation.

Note that the above process is applicable to major releases of the product. For minor bug-fix releases, we
simply update the documentation in the live space. We do not create archive spaces for every minor
release.

The example below shows an extract from the dashboard of our documentation wiki, listing the spaces for

different versions of the Crowd documentation. (Crowd is one of our products.) Each space holds the
documentation for a specific major release of Crowd.

% Dashboard

Confluence is the enterprise wiki designed to make it
easy for you and your team to share information with
each other, and with the world.

Spaces: | All

@ Application Links 1.1 @

@ Crowd 1.3 @

Documentation for Crowd version 1.3.x

- - .
@) Crowd 1.4 i Archive spaces
Documentation for Crowd version 1.4 _x i suchas CROWD(

@ Crowd 1.5 Q@

Documentation for Crowd version 1.5.x

' Live CROWD spa
contains current re

@ Crowd 1.6
Documentation for the latest version of
Crowd single signon and identity
management
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Other Scenarios using the Built-In Confluence Functionality

It is easy to design other ways of managing your documentation spaces using the built-in Confluence
functionality. For example, the simplest scenario is to publish a new space for every new release of your
product, using the same Copy Space plugin as described above.

Using Plugins for Extended Workflow and Publication Management

For advanced workflow features, consider installing the Ad Hoc Workflows plugin onto your Confluence
site.

Similarly, consider using the Content Publishing plugin to publish content from a master space to a
published space. In this scenario, you will create a master space that contains your drafts in progress and
new releases. The master space is visible only to the authors and reviewers. You will periodically publish
the master space to a published space. This suits the requirements of an organisation that needs a
'published’ or 'official' set of documentation, published only when a new version of the product is released.
There is no requirement for continual updating of the documentation.

. Install the Content Publishing plugin.

. Create a space for your master content.

. Create a space for your published content.

. When the content in the master space is ready to publish, go to the ‘Advanced' tab
in the 'Space Admin' section of the master space.

. Click 'Publish Space' to configure the settings and then publish your space. See the
plugin documentation to choose the options best for your needs.

6. Click "Publish’.

A WOWN PP

(4]

o Automatic publishing. The Content Publishing plugin can work together with the Ad Hoc Workflows
plugin to publish pages automatically when the page reaches a specified state in the workflow.

Notes

® Installing plugins. If you decide to use additional plugins, your site administrator will need to
install the plugins into your Confluence site. Refer to the documentation on installing plugins.
® Plugin support. Before installing a plugin into your Confluence site, please check the plugin's
information page to see whether it is supported by Atlassian, by another vendor, or not at all. See
our guidelines on plugin support.
Next Steps

Now you know about managing your workflow and documentation release process on Confluence. What
next? Take a look at Providing PDF Versions of your Technical Documentation.

Providing PDF Versions of your Technical Documentation

This page is part of the guide to developing technical documentation on Confluence Wiki. Confluence itself
is an excellent platform for publishing online documentation. In some cases, though, you may need to
produce PDF versions of your documentation for printing, or to supply to customers who cannot access the
online version.

Confluence itself provides an export to PDF. Plugins provide additional functionality.

i) Quick guide to PDF exports
® Customise the PDF layout (title page, header and footer) and stylesheet, for use
each time you export your documentation.
® Export a single page to PDF.
® Export an entire space or a selection of pages to PDF.
® Consider installing a third-party plugin for advanced functionality.

The rest of this page gives more details of the above procedures.

On this page:

® Customising the PDF Layout and Stylesheet
® Editing the PDF Layout
® Editing the PDF Stylesheet
® Some Useful Examples
® Adding a Title Page
® Adding Headers and Footers
® Adding Page Numbering to a Header or Footer
® Exporting a Single Page to PDF
® Exporting a Space or a Selection of Pages to PDF
® Exporting a Spaces or Pages to PDF via a Plugin
® Notes
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Customising the PDF Layout and Stylesheet

If you are planning to provide PDF versions of your documentation, you may want to customise the PDF
layout and styles for your space. These customisations will apply each time you export your documentation
to PDF.

In the PDF layout, you can add your own HTML to customise the title page, page headers and page
footers in the PDF output. In the PDF stylesheet, you can adjust the appearance of the PDF pages.

Editing the PDF Layout

1. Choose Browse > Space Admin.

o Space Admin is displayed only if you are a space administrator for that space or
you are a Confluence system administrator.

2. Click PDF Layout in the 'Look and Feel' section of the left-hand panel.
3. Click Edit. You can now customise the HTML that generates following areas in the
exported PDF document:
® PDF Space Export Title Page — title page.
®* PDF Space Export Header — page headers.
® PDF Space Export Footer — page footers.
4. Enter your customisations into each text box as required. The PDF layout section
accepts HTML code. You can include inline CSS in the HTML too.
5. Click Save.

Editing the PDF Stylesheet

1. Choose Browse > Space Admin.

ﬂ Space Admin is displayed only if you are a space administrator for that space or
you are a Confluence system administrator.

2. Click PDF Stylesheet in the left-hand panel. The 'PDF Export Stylesheet' section
appears, showing the current contents of your PDF stylesheet. It contains all CSS
rule customisations applied to the pages in the space.

3. Click the Edit.

4. Enter your customisations into the text box as required. The PDF stylesheet section
accepts Cascading Style Sheets (CSS) rules.

5. Click Save.

Some Useful Examples

Below are the typical customisations you may want to make for your technical documentation. For more
examples, see Editing the PDF Stylesheet.

Adding a Title Page

You can create a title or cover page to your PDF document using HTML. Use the PDF Space Export Title
Page section of the PDF layout to do this. Adding a New Title Page

The following example uses HTML with an inline CSS rule to generate a title page.

Including Content Above Table of Contents in Default Title Page

The following example includes content above the automatically-generated table of contents that appears
on the default title page, so that your title page includes your own content plus the table of contents.

Adding an Image to your Title Page

In the examples above, the title page includes an image called 'titlepage.png’, centred in the middle of the
page. The image is attached to a Confluence page and is referenced via its relative URL (that is, we use
only the last part of the URL, excluding the Confluence site's base URL).

Follow these instructions to include an image on your title page:

. Attach the image to a Confluence page.

. View the list of attachments on that page.

. Right-click the image and copy its location.

. Paste the link into the appropriate src="" attribute within your PDF stylesheet, as shown above.
. Remove the first part of the URL before /download/. . ..

abrwWNPE

Adding Headers and Footers
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You can add headers and footers to your PDF pages using HTML. Use the 'PDF Space Export Header'
and 'PDF Space Export Footer' sections of the PDF layout to do this. For simple headers and footers, plain
text is enough. The following example adds a simple copyright notice.

Adding Page Numbering to a Header or Footer

To add page numbering to your documentation, you need to combine some customised HTML in the
header or footer with some customised CSS in the PDF stylesheet.
1. Create a header or footer with an empty span element and give it a unique ID, for example
pageNum. This is a place holder for the page number in your PDF document.

Analysing the above CSS selector rule in more detail:

® The #pageNum rule selects the HTML element with the specified ID of "pageNum", which is the
span element we created for the header or footer.

®* The :before part of the selector is a pseudo class that allows the insertion of content before the
span element is processed.

® The counter (page) is a function that returns the current page number as its content.

® The content property tells the CSS processor that dynamic content (that is, an incrementing
page number) is to be inserted before the span tag.

Exporting a Single Page to PDF

You can export a Confluence page to PDF. This option exports a single page and is available to all users
who have permission to view the page:

® Goto a page in the space and choose Tools > Export to PDF. Follow the prompts to export the
page.

Exporting a Space or a Selection of Pages to PDF

Using the built-in Confluence PDF export, you can export a single page, a selection of pages or an entire
space into a single PDF file.

1. Go to a page in the space and choose Browse > Advanced.

2. Click PDF Export in the left-hand panel.
This option will only be visible if you have the 'Export Space' permission.
3. Select the pages you want to export.
® You have the option to Select All or Deselect All pages.
® When you select a page, all its child pages will also be selected. Similarly,
when you deselect a page all its child pages will also be deselected.
4. Click Export.
5. When the export process has finished, download and save the PDF file as
prompted.
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% PDF Export

Advanced

Advanced Export content within this space as PDF. You can customise the layou
of this exported PDF in the PDF Stylesheet page.
@ Space Details

Export
I Orphaned Pages

% Undefined P
(. Undefined Pages Select All | Deselect All

Iy Templates

§ Snippet Errors Crowd Documentation
Crowd 101

Export

Crowd Administration Guide

. PDF Export Getting Started
&, HTML Export Concepts
Supported Applications and Directories
About the Crowd Administration Console
Subscribe Managing Directories

Using the Directory Browser

E) RSS Feeds Adding a Directory
&3 Stop watching this space Configuring an Internal Directory

& XML Export

Exporting a Spaces or Pages to PDF via a Plugin

For advanced PDF export, consider installing the Scroll Wiki Exporter plugin onto your Confluence site.
Scroll provides flexible themes for configuring PDF layout and styles. You can select one of Scroll's built-in
themes and configure your table of contents, header and title pages.

Advanced techniques for Scroll Wiki Exporter. For even more flexibility, you can add your own theme
plugins. Scroll supports themes based on DocBook XSL stylesheets. See the Scroll developer's guide.

Notes

® Permissions required to export a space. To use the space export functionality, you need 'Export
Space' permission. See the guide to space permissions or contact a space administrator for more
information.

Installing plugins. If you decide to use additional plugins, your site administrator will need to
install the plugins into your Confluence site. Refer to the documentation on installing plugins.
Plugin support. Before installing a plugin into your Confluence site, please check the plugin's
information page to see whether it is supported by Atlassian, by another vendor, or not at all. See
our guidelines on plugin support.

Next Steps

Now you know all about providing PDF versions of your documentation. What next? See other ways of
Exporting and Printing Technical Documentation.

Exporting and Printing Technical Documentation

This page is part of the guide to developing technical documentation on Confluence Wiki. Confluence is a
great tool for writing and maintaining technical documentation. There are times when we need to export the
content out of Confluence into other forms, such as PDF, HTML, Microsoft Word and paper.

Confluence itself provides an export to both PDF and HTML. Plugins provide additional functionality. Below
are guidelines on exporting your technical documentation to various formats, including printed output.

@ chk guide to printing and exporting content

Use the browser's print option to print a single page.

To print more than one page and for more advanced printing options, export your

documentation to PDF.

® Confluence can export your pages to PDF, HTML, Confluence-specific XML and
Word.

® Consider installing plugins to export your pages to PDF (enhanced functionality).
Word (enhanced functionality), DocBook XML, Eclipse Help and JavaHelp.

® Make your exports available to your customers for download by attaching the
exported file to a Confluence page.
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The rest of this page gives more details of the above procedures.

On this page:

Printing

Exporting to PDF

Exporting to HTML

Exporting to Confluence-Specific XML
Exporting to DocBook XML via a Plugin
Exporting to Microsoft Word

Exporting to Word via a Plugin
Exporting to Eclipse Help via a Plugin
Exporting to JavaHelp via a Plugin
Making the PDF and Other Exported Files Available to your Readers
Notes

Further Reading

Printing

To print a single Confluence page, just use the browser's print option. This option is available to all users

who have permission to view the page.

To print more than one page and for more advanced printing options, export your documentation to PDF.

See Providing PDF Versions of your Technical Documentation.

Exporting to PDF

Because this is such an important topic, we have a section of this guide dedicated to PDF. See Providing

PDF Versions of your Technical Documentation.

Exporting to HTML

Using the built-in Confluence HTML export, you can export a single page, a selection of pages or an entire

space to HTML. Confluence supplies the HTML and associated files in a zip file.

1.

2.

Go to a page in the space and choose Browse > Advanced.

Click HTML Export in the left-hand panel.
This option will only be visible if you have 'Export Space' permission.

. Select the Include Comments check box if you want to include comments for the

pages you are exporting.

. Select the pages you want to export by selecting the check boxes in the tree view of

pages displayed. By default, all pages are selected. You have the option to Select
All or Deselect All pages.

If you select the check box of a page that contains one or more child or descendant
pages, all of these child and descendant pages will also be selected. Similarly, if you
clear the check box of such a page, all of its child and descendant pages will also be
cleared. This provides a convenient method of exporting subtrees, for example,
chapters or sections within a document.

. Click Export. This will create a zipped archive of HTML files.
. When the export process has finished, download the zipped archive as prompted

and extract the files into a folder.
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% Export Space

narks Mail Advanced Space Admin

Advanced Export content within this space as HTML.

@ Space Details

L.y Orphaned Pages
[ Undefined Pages
LI Templates

Select All Deselect All Include comments

Crowd Documentation
§ Snippet Errors Crowd 101
Crowd Administration Guide
Getting Started
& PDF Export Concepts
. HTML Export Supported Applications and Directories
About the Crowd Administration Console
Managing Directories
Subscribe Using the Directory Browser
Adding a Directory
Configuring an Internal Directory

Export

& XML Export

E) RSS Feeds

Exporting to Confluence-Specific XML

Confluence provides an XML export. The XML produced is a proprietary format and is intended for
backups or for transferring a space from one Confluence instance to another. If you write your
documentation on Confluence and your customers have Confluence too, then you can export your manuals
to XML and customers can upload them onto their own Confluence site.

Exporting to DocBook XML via a Plugin

Scroll Wiki Exporter converts Confluence pages to DocBook XML. Your Confluence system administrator
will need install the plugin onto your Confluence site.

Exporting to Microsoft Word

Confluence can export a page to Word. (Select 'Export to Word' from the ‘Tools' menu.) This option
performs a basic conversion of wiki content to HTML and applies some Word CSS stylesheets. It
processes just one page at a time.

Exporting to Word via a Plugin

Scroll Office is a Confluence plugin. Once installed, Scroll Office replaces Confluence's built-in 'Export to
Word' functionality. You can export a single page or a hierarchy of pages.

You can define your templates in Word in the usual way, and upload them to Confluence as global
templates or space templates. When you export your Confluence pages to Word, Scroll Office will use
those templates to build Word documents from the wiki pages.

Scroll Office provides additional features such as enforcing page-breaks, setting the page orientation to

landscape or portrait, and ignoring content. The latest version offers a REST-style API for automated
export.

Exporting to Eclipse Help via a Plugin

Scroll Wiki Exporter provides an export to Eclipse Help format.

A hint about the Eclipse Help platform: You can use a cut-down version of the Eclipse Help platform to
provide online documentation for any system. It doesn't have to be an Eclipse tool that you are

documenting. For some ideas, take a look at a couple of articles about documenting your project using the
Eclipse help system.

Exporting to JavaHelp via a Plugin

Scroll Wiki Exporter also converts Confluence pages to JavaHelp format.


http://www.k15t.com/display/web/Scroll+Wiki+Exporter
http://www.docbook.org/
http://www.k15t.com/display/web/Scroll+Office
http://k15t.com/display/OFCE/Enforcing+Page-Breaks
http://k15t.com/display/OFCE/Controlling+the+Page+Orientation
http://k15t.com/display/OFCE/Ignoring+Content
http://www.k15t.com/display/web/Scroll+Wiki+Exporter
http://www.ibm.com/developerworks/opensource/library/os-echelp/
http://www.ibm.com/developerworks/opensource/library/os-echelp/
http://www.k15t.com/display/web/Scroll+Wiki+Exporter
https://javahelp.dev.java.net/
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Making the PDF and Other Exported Files Available to your Readers

There are a number of ways to make your exported files available to your readers, such as putting the files
on a disc and shipping them with your product.

One of the simplest ways is to attach the files to a Confluence page. (See Attaching Files to a Page.)

For example, Atlassian uses the out-of-the-box Confluence export functionality to provide PDF, HTML and
XML versions of our documentation. People can download the files from our documentation wiki. For
example, here are the JIRA documentation downloads and the Confluence documentation downloads.

For those people who would like to use the XML files to recreate the documentation on their own
Confluence sites, we provide instructions on setting up your own local documentation.

Notes

® Permissions required to export a space. To use the space export functionality, you need 'Export
Space' permission. See the guide to space permissions or contact a space administrator for more
information.

Installing plugins. If you decide to use additional plugins, your site administrator will need to
install the plugins into your Confluence site. Refer to the documentation on installing plugins.
Plugin support. Before installing a plugin into your Confluence site, please check the plugin's
information page to see whether it is supported by Atlassian, by another vendor, or not at all. See
our guidelines on plugin support.

Further Reading

® A blog post about exporting and importing content from/to Confluence: Technical Writing in a Wiki -
Single Source Publishing (November 2010).

® A good overview of the Scroll Office features in this blog post (August 2010) and the followup post
(November 2010).
Next Steps

Now you know about a number of ways to get your technical documentation out of Confluence into various
formats, for printing or for input into another system or process flow. What next? Take a look at Essential
Confluence Features for Technical Documentation.

Essential Confluence Features for Technical Documentation
This page is part of the guide to developing technical documentation on Confluence. In this section we

highlight the built-in Confluence macros that are most useful in technical documentation. For more
information about Confluence macros, see Working with Macros.

o To add a macro to a Confluence page, use the Macro Browser.

On this page:

Auto-Generating a Table of Contents for Page Content

Drawing Attention to Elements of a Page

Putting Content inside Customisable Panels

Inserting Anchor Links on Pages

Structuring Content using Sections and Columns

Making your Documentation more Engaging by Embedding Videos

Auto-Generating a Table of Contents for Page Content

It is important to make it easy for viewers to jump to the section of a Confluence page that they are most
interested in. The Table of Contents macro helps you navigate lengthy pages by summarising the content
structure and providing links to headings used on the page. Headings are indented progressively.

™ Click here to see a common example >>

1. You document the Release Notes for the latest version of your product in a
Confluence page.

2. Each feature in the release is a heading on the page.



http://blogs.atlassian.com/confluence/2010/11/technical-writing-wiki-single-source-publishing.html
http://blogs.atlassian.com/confluence/2010/11/technical-writing-wiki-single-source-publishing.html
http://blogs.atlassian.com/confluence/2010/08/technical-project-documentation-wiki-export-microsoft-word-templates.html
http://blogs.atlassian.com/confluence/2010/11/microsoft-word-wiki-export-scroll-office.html
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3. You can generate a list of hyperlinks to each of the features in the release notes by

inserting the Table of Contents macro:

Paragraph - B 7 U #¢ A -| A | i= i= | 9

. The image below shows the Table of Contents macro inserted at the top of the

'Release Notes' page. Note that we have excluded the 'Highlights of Confluence 3.4
heading from the table of contents by modifying the macro's parameters.

X, Confluence 3.4 Release Notes

#10 Sarah Maddox [Atlassian Technical Writer] Sarah M|
now"lo“. 12 October 2010
latest version With great pleasure, Atlassian presents Confl
laces quickly.

Highlights of this Release:

New Keyboard Shortcuts, Mac-Friendly Too
Keyboard Shertcut Dialog

User Macros in Macro Browser and Autocomplete
New Plugin Manager

Improved Performance

Other Improvements
nfrastructure Changes

Table of Contents Macro
- Minimum Heading Level set to 2"
Maximum Heading Level set to '7'

® s 8 8 8 8 @

+ Read the release notices for important information about this release.
+ See the full list of issues resolved in this release.

p g to your F

+ Over 180 votes satisfied.
« Thank you for all your issues and votes. Keep logging issues to help
us keep improving!

Heading Style 1 Highlights of Confluence 3.4

Heading Style 2 | 1 New Keyboard Shortcuts, Mac-Frie

Confluence has a number of new keyboard shortcuts to aid b)

we have made an effort to be as consistent as possible. Con|
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5. The image below shows the macro parameters specified in the Macro Browser. Note
the 'Minimum Heading Level' and 'Maximum Heading Leve' parameters.

Edit ‘Table of Contents’ Macro

- List Style
Preview 5 Refresh = kd
~
|
o New Keyboard Shoricuts, Mac-Friendly Too |
e Keyboard Shorcut Dialog |
o User Macros in Macro Browser and Autocomplete |
» New Plugin Manager |
* Improved Performance : The amount by
+ Other Improvements | CSS units). Exy
 Infrastructure Changes
| Separator
]
| brackets
§| The type of sef
§| to'flat'. Exampl
|
| | [Minimum Hea)
W] 2
The minimum K

example, 3" wil
not 'hi.'or 'h2."
Maximum Hez
4

The maximum
HII"H P 'i'I‘l

Return to top of page

Drawing Attention to Elements of a Page

Often when creating documentation there are elements of a page that you want to highlight, or draw the the
viewers attention to. Confluence ships with the following macros that help you focus a viewer's attention to
a note, information, tip or warning.

™ Click here to see common examples >>
Note Macro

What is it? Example

The Note macro allows you to highlight a note on a
Confluence page.

-

Draft in progress

It creates a yellow coloured box surrounding your This document is a draft and
text, as shown to the right. is under development.

See Note Macro for more examples and instructions.

Info Macro

What is it? Example

The Info macro allows you to highlight helpful information on a

Confluence page. o Did you know?
It creates a blue coloured box surrounding your text, as Confluence is the
shown to the right. best wiki ever.

See Info Macro for more examples and instructions.

Tip Macro

What is it? Example
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The Tip macro allows you to highlight

a helpful tip on a Confluence page. .@. Learn more

It creates a green coloured box Check out this blog post: Technical Writing
surrounding your text, as shown to the in a Wiki: Technical Communicators Explain
right. How & Why?

See Tip Macro for more examples and instructions.

Warning Macro

What is it? Example

The Warning macro allows you to highlight a

warning note on a Confluence page. e Draft

It creates a red coloured box surrounding your This page is a draft in progress

text, as shown to the right. and visible to Atlassian staff
only.

See Warning Macro for more examples and instructions.

Return to top of page

Putting Content inside Customisable Panels

The Panel macro allows you to place content inside a customisable coloured panel. This is particularly
useful when you want to clearly separate elements on a page.

* Click here to see a common example >>

1. You are documenting a procedure which involves a number of steps.

2. You want to call out the steps of the procedure from the rest of the page by placing it
inside a coloured box, or panel.

3. You can create a coloured panel using the Panel macro.

4. The image below shows the parameters set for the panel using the Macro Browser.

Insert ‘Panel’ Macro

Preview ¥, Refresh  Displays a bl
Documentatig

| BodyText

1. You are documenting a procedure which involves a number of steps. which invo
2. You want to call out the steps of the procedure from the rest of the page # You want
by placing it inside a coloured box, or panel. Eg;epgzcﬁ
3 Youlcan create a coloured panel using the Panel macro. . box, or pa
4. The image below shows the parameters set for the panel using the # You can
Macro Browser. using the
# The imag]
parameters
the [Macro
the Macro

m

Panel Title

Border Style

Examples: ag

Border Coloul

Border Pixel V

Back

Return to top of page

Inserting Anchor Links on Pages

Anchor links can be especially useful when navigating between sections of a long document or when you
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want to link to a segment of a page from another page. The Anchor macro allows you to link to specific
parts of a page.

¥ Click here to see a common example >>

1. You are documenting part of a user guide.

2. The page is split into multiple sections.

3. After each section you want to provide a link for viewers to click, taking them back to
the top of the page.

4. To achieve this you first must create an anchor at the top of the page using the
Anchor macro. You can give the anchor any name you like. In the image below, the
anchor at the top of the page has been named 'top'.

Paragraph - B I U # A- |

{anchor:top}

This guide is for people who want to author and publish technical documentation on Coenfluenc
on. This page is highlights out-of-the-box Confluence macros that you may want to use to cres
document in Confluence.

| B

T

{tip:title=Featured in this guide}
{toc:maxLevel=2}
{tip}

The rest of this page gives more details of the macros listed above.

5. Create a link to the anchor, anywhere on the page, using the Link Browser. The
image below shows a link to the anchor called 'top', with an alias of '‘Return to top of
age'.

i Insert Link

Search URL: TOpI
Recently Viewed Link Text: | Return io"fop o.f-page
Attachments

Hint: type " in the rich text editor to see a list of suggested pages and insert a link.

See Working with Anchors for more examples and instructions.

Return to top of page

Structuring Content using Sections and Columns

Sometimes it is necessary to structure content into sections and columns.

® You can create any number of sections on a Confluence page using the Section macro.

® Each section can contain any number of columns, created using the Column macro.

® Columns can either have a fixed width, specified in pixels, or a dynamic width, specified as a
percentage of the page width.

® Note: A column must be created inside a section

* Click here to see a common example >>

The images below show part of a Confluence page with two sections (red), each with two
columns (blue) of different widths.
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1. Section 1:
1. Put a name to your face : -
2. Leam how content is organised . Tweet it!
3. Get familiar with the Confluence screens
4. Start creating content =
5. Add a panel to your page

2. Section 1 columns — left column has a fixed width of 400 pixels:

. Put a name to your face : -
Learn how content is organised : Tweet it!
. Get familiar with the Confluence screens

. Start creating content =
. Add a panel to your page f Share It!

oo
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3. Section 2:

n Put a face to your name
Your profile picture is used to identify you across Confluence. Upload your own picture via your Profile.
b Leamn More >>

Dashboard » People » Fred Flintsone » Profile Picture Help ~ Browse ~ FredH

& Fred Flintsone
I vevor ] et upctes [ Lot wetons J et  setins= [

Profile Your profile picture is used as the icon for your personal space, and to represe
your own profile picture, or you can choose from one of our standard icons.

Details
Picture Upload a Profile Picture: Upload your own profile picture. Profile pictures
will be resized 1o 48 x 48 pixels.
Password
( Browse... )
Upload
Upload

4. Section 2 columns — left column has a fixed width of 10 pixels:

. Put a name to your face 0
. Leamn how content iz crganised m

. Get familiar with the Confluence screens
. Start creating content

n Put a face to your name

[ R

Your profile picture is used to identify you across Confluence. Upload your own picture via your Profile.

b Leamn More >>

Dashboard » People » Fred Flintsone » Profile Picture Help ~ Browse ~ FredH

& Fred Flintsone
I vevor ] et upctes [ Lot wetons J et  setins= [

Profile Your profile picture is used as the icon for your personal space, and to represe
your own profile picture, or you can choose from one of our standard icons.

Details
Picture Upload a Profile Picture: Upload your own profile picture. Profile pictures
will be resized 1o 48 x 48 pixels.
Password
( Browse... )
Upload
Upload

Return to top of page

Making your Documentation more Engaging by Embedding Videos

Pictures can be worth a thousand words. The same can be said for videos. Often, it's easy to explain a
concept or demonstrate a procedure using a video. The Widget macro allows you to embed web content,
including YouTube, Episodic and Vimeo videos, in a Confluence page.

™ Click here to see a common example >>

1. You release a new version of your product.

2. You document the Release Notes on a Confluence page.

3. The marketing team creates a video demonstrating the new features of the release
and uploads it to YouTube.

4. You can embed the video in your Release Notes using the Widget macro, for
playback on your Confluence page.

426



Confluence 4.0 Documentation

427

a. Select 'Widget' from the 'Insert' menu in the Rich Text Editor toolbar.

Paragraph - B 7 U ¢ A~ |4

Rich Text J Make Rich Text Default

e

Hint: press 38 4+K after a word to find and link to relevant pages. Press it again for more sugg

b. Insert the URL of your YouTube video into the 'Web Sites Widget URL'

field.
Insert “Widget Connector’ Macro

Preview

Er
st
we

=
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c. Click 'Insert' and save your page.

% Confluence 3.4 Release Notes

#10

Sarah Maddox [Atlassian Technical Writer] Sarah Maddox [Atlassian Ted
show comment

12 QOctober 2010
DOWNLOAD
latest version With great pleasure, Atlassian presents Confluence 3.4, with mo|

and go places quickly.

Highlights of this Release: Video of What's Ne

* New Keyboard Shortcuts, Mac-Friendly Too

+ Keyboard Shortcut Dialog

+ User Macros in Macro Browser and Autocomplete
+ New Plugin Manager
.

mproved Performance
Other Improvements
nfrastructure Changes

More:

* Read the release notices for important information about this
release.
« See the full list of issues resolved in this release.

Responding to your Feedback:

« Over 180 votes satisfied. i
« Thank you for all your issues and votes. Keep logging issues | K 3| o0/ 51
to help us keep improving!

See Widget Macro for information on the supported services and for more usage examples.
Return to top of page
Next Steps

Take a look at Confluence Plugins for Technical Documentation.

Confluence Plugins for Technical Documentation

This page is part of the guide to developing technical documentation on Confluence. In this section we

highlight some of the Confluence plugins that are useful for technical writers in designing and developing
documentation.

A plugin is an extension module that you can add to your Confluence site, to extend the wiki's core
functionality. It is similar to an add-on for your browser. Confluence plugins may be developed by Atlassian

or by third parties. To find the plugins featured on this page, and other plugins too, visit the Atlassian Plugil
Exchange.

This page features plugins that provide the following extended capabilities:

® Extended Wiki Markup Features
® Quick Overview of Macros
Composition Plugin
Using the Composition Plugin to Outline Text Blocks
Using the Composition Plugin to Add Tabs to a Page
Using the Composition Plugin to Flow your Text around Images
® Scaffolding Plugin
® Extended Version Control
® Attachment Checkout Plugin
® Drawing Tools
® Gliffy Plugin
®* Notes
® Further Reading

@ Quick guide to the plugins featured below

® Composition plugin — Provides macros which allow finer control over the
layout (composition) of a page. For example, outline text; add tabs to
your page; flow your text around diagrams. This plugin is free.

® Scaffolding plugin — Provides macros for creating '‘permanent templates'
and editable forms. Free.

® Attachment Checkout plugin — Adds check-out/check-in functionality for
Confluence attachments. Free.

® Gliffy plugin — Provides an embedded diagram editor. Commercial.
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@ Pluglns featured in other parts of this guide

® Copy Space plugin — Provides an easy way of copying a space within a
Confluence site. Free. See Creating your Technical Documentation
Space.

® Multi Excerpt plugin — Enables you to have more than one excerpt
(re-usable chunk) on a page. Commercial. See Re-using Content in
Technical Documentation.

® Ad Hoc Workflows plugin — Provides advanced workflow features.
Commercial. See Managing the Life Cycle of your Technical
Documentation.

® Content Publishing plugin — Publishes content from a master space to a
published space. Commercial. See Managing the Life Cycle of your
Technical Documentation.

® Scroll Wiki Exporter — Provides advanced PDF export features, as well
as export to DocBook XML, Eclipse Help, JavaHelp. Commercial. See
Providing PDF Versions of your Technical Documentation and Exporting
and Printing Technical Documentation.

® Scroll Office — Provides advanced features for export to Microsoft Word.
Commercial. See Exporting and Printing Technical Documentation.

On this page:

® Extended Wiki Markup Features
® Quick Overview of Macros
Composition Plugin
Using the Composition Plugin to Outline Text Blocks
Using the Composition Plugin to Add Tabs to a Page
Using the Composition Plugin to Flow your Text around Images
® Scaffolding Plugin
® Extended Version Control
® Attachment Checkout Plugin
® Drawing Tools
® Gliffy Plugin

Extended Wiki Markup Features

All wiki markup extensions are provided by macros in Confluence. Some macros are built in to
Confluence. Other macros are supplied by plugins.

Quick Overview of Macros

Before looking at plugins, let's take a quick look at macros in general. There are two ways to add a macro
to your page:

® Use the Macro Browser. This is the simplest and recommended way.

® Orinsert the macro's name in curly brackets into the text of your page and specify the parameters.
¥ Click here to see an example of a macro >>
The following code uses the {include} macro to insert the text from the page called 'My Page'. The text will
appear on the page where the macro is used:

Page text... H
{include:My Page} H
page text... i

The resulting page will look like this:

Page text...
<text from the 'My Page' page>
page text...

A number of macros are shipped with your Confluence installation by default. See Working With Macros.
Below we describe some plugins that provide additional useful macros for Confluence:

Composition Plugin

The Composition plugin adds some formatting features to compose a page in a more flexible way. Using
the macros provided by the Composition plugin, you can:

® Outline your text blocks.
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® Add tabs to a page.
® Flow your text around the images or diagrams on the page.

Using the Composition Plugin to Outline Text Blocks

Use the {cloak} macro to outline a text block.

Usage: The following code creates a text block named 'SeeAlso’ for the outlined 'See Also' section within a
page. The text block with id="SeeAlso' will be hidden after the 'See Also' title:

i {composition-setup} i
| h2. {toggle-cloak:id=SeeAlso} See Also |
i {cloak:id=SeeAlso} i
i h3. Working With Macros: i
[Link 1]
[Link 2]
i h3. Working with Rich Text Editor: i
: [Link 3] E
i [Link 4] §
i {cloak} i
L

Alternatives: You can also use the {expand} macro available in Confluence by default, but this macro can
outline only text of the same level and cannot hide headings within the text. The {expand} macro does not
require parameters and just hides the text placed between the {expand} tags.

Note: If you need to outline a text block containing nested headings, consider the text structure. Maybe the
block is too big. You could create a child page from this block to decompose the whole text. Then you can
include and outline the text block using the {include} macro within {expand}.

Using the Composition Plugin to Add Tabs to a Page

Use the {deck} and {card} macros to separate content between tabs on the same page.

Usage: The following code creates two tabs with client information:

{composition-setup}
hl. Client Name
{deck:id=ClientName}

{card:label=Basic}

Client Company Name: Company

[Client Web Site|http://url.com]

Our projects: [Projectl|Projectl Home]
{card}

{card:label=Contacts}
Company CEO: John Brown, e mail: brown@company.com

{card}

{deck}

The tabs on a page will look like this:

Added by Ekatering Stepaling, last edited by Ekatering Stepaling on Moy 08, 2010 {view change)

Client Name

Client Cormpany Mame: Company
Clignt YWeb Site
Cur projects: Project]
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Using the Composition Plugin to Flow your Text around Images

Use the {float} macro to make your text flow around images or diagrams.

Usage: The following code demostrates how a picture can be surrounded by the description, as often
shown in printed publications:

{composition-setup}

{float:left}

I'shakespeare.jpg!

{float}

William Shakespeare (baptised 26 April 1564; died 23 April 1616) was
an English poet and playwright, widely regarded as the greatest
writer in the English language and the world's pre-eminent dramatist.

The page will look like this:

Floating Text demo £ Edt 4k ado

&1 Added by Ekaterina Stepalina, last edited by Ekaterina Stepalinag on Moy 08, 2010 fview change)

William Shakespeare (baptised 26 April 1564; died 23 April 1616) was an English post and
playwright, widely regarded as the greatest writer in the English language and the waorld's
pre-eminent dramatist. He is often called England's national poet and the "Bard of Avan”. His
surviving works, including some collaborations, consist of about 38 plays, 154 sonnets, two
long narrative poems, and several other poems. His plays have been translated into every
major living language and are performed more often than those of any other playwright.

Shakespeare was born and raised in Stratford-upon-Awvon. At the age of 18, he married Anne
Hathaway , with whom he had three children: Susanna, and twins Hamnet and Judith. Betwer
1535 and 1592, he began a successful career in London as an actor, writer, and part owner ¢
a playing company called the Lord Chamberlain's Men, later known as the King's Men. He
appears to have retired to Stratford around 1613, where he died three years later. Few record
of Shakespeare's private life survive, and there has been considerable speculation about such matters as his physic
appearance, sexuality, religious beliefs, and whether the warks attributed to hirm were written by others.

Shakespeare produced most of his known work between 1589 and 1613.nb 4 His early plays were mainly comedies
and histories, genres he raised to the peak of sophistication and artistry by the end of the 16th century. He then
wrote mainly tragedies until about 1603, including Hamlet, King Lear, and Macheth, considered some of the finest
works in the English language. In his last phase, he wrote tragicomedies, also known as romances, and collaborate
with other playwrights.

For more macros, see the Composition plugin page.

Scaffolding Plugin

The Scaffolding plugin allows you to create sophisticated page templates in order to add content easily and
fast. Scaffolding templates are suitable for dynamically-filled data and allow people to create pages by
completing form fields and selecting values from drop-down lists.

The Scaffolding templates are useful for creating pages with a well-determined structure, such as:
® API methods or property descriptions.
® Constant list.
® Feature description.
® Software requirement specifications.

Example: The following Scaffolding template creates a description of an API method:


https://plugins.atlassian.com/plugin/details/245
https://plugins.atlassian.com/plugin/details/190
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h3. Method Name
{text-data:methodName|required=true}{text-data}

h3. Method Description

{text-data:methodDescription|type=area|required=true|width=100%}descripti
Parameters

{table-data:parameters}

|| Name || Type || Mandatory || Description ||

| {text-data:paramName}ParamName{text-data} |
{list-data:paramType}{list-option:Number}Number{list-option}{list-option:
|
{list-data:paramMandatory}{list-option:Required}Required{list-option}{lis
| {text-data:paramDescription|type=area}param description{text-data}

{table-data}
h3. Return Value
The returned value is an XML structure of the following format:

\ {code :xm1\}
\{code\}

Where elements mean:

{table-data:returnvalues}

|| Name || Type || Description ||

| {text-data:paramName}ParamName{text-data} |
{list-data:paramType}{list-option:Number}Number{list-option}{list-option:
| {text-data:paramDescription}param description{text-data} |

{table-data}

h3. Remarks

{text-data:remarks}remarks{text-data}

h3. See Also

This template will look like this:
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Search

Hotation Guide

| EditDats |

APl Method demo

Save Cancel

Method Name
IAF‘\ Method demmo

Method Description

Return Value

Where elements mean

The returned value is an =ML structure of the following format:

desription
Parameters
Name Type Mandatory Description
o IF'aram1 INumber j IRequiredj param description
N |Param2 |Number j EReqmredﬂ param descrption
OEliDﬂﬁ|
&*

Iremarks

Name Type Description
N |Element1 String j |param description
Remarks

For more information on how to create templates in Confluence, see Adding a Template.

Alternatives: Confluence includes built-in templates which as useful for static data and simple text. For
more information, see Working with Templates.

Notes: The Scaffolding (and any) template changes will affect only new pages created from the modifed
template. In order to change the existing pages, you need to edit each individual page and add or modify

the formatting manually.

For more information on Scaffolding, see the Scaffolding plugin page.

Extended Version Control

Attachment Checkout Plugin

The Attachment Checkout plugin adds check-out/check-in functionality for Confluence attachments. It
allows you to control the versions of the documents attached to a page with the same file name.

Attachment checkout allows Confluence to warn contributors that the document is being edited by
someone else. Note that there are no merge features for attachments.

Example: To store and control the versions of Project Vision documentation received from a customer on

the Confluence page:

Name Size Creator (Last Modifier) )' Comment
(@ Client! Project! “ision.doc 30 kB  Ekaterina Stepalina

Yarsion 2 (30 kB - Ekaterina Stepalina - Mov 8, 2010 11:19:45 A MEK)
Yarsion 1 (30 kB - Ekaterina Stepalina - Mov 8, 2010 11:19:03 A MEK)

\ Checkout | E

For information on working with attachments, see Working with Attachments.

For information on attachment versioning, see Attachment Versions.

Drawing Tools
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Gliffy Plugin

The Gliffy plugin provides an embedded diagram editor. Gliffy allows you to create and edit diagrams
directly from a Confluence page. It supports various diagram types (UML, business process, and so on).

Alternatives: As an alternative you can use the standalone version of Gliffy available at
http://www.gliffy.com/. Gliffy online has a free basic version.

For more information, see the Gliffy plugin page.

Notes
® |nstalling plugins. If you decide to use additional plugins, your site administrator will need to
install the plugins into your Confluence site. Refer to the documentation on installing plugins.
® Plugin support. Before installing a plugin into your Confluence site, please check the plugin's
information page to see whether it is supported by Atlassian, by another vendor, or not at all. See
our guidelines on plugin support.
Further Reading
® A blog post about useful plugins and tools for exporting and importing content from/to Confluence:
Technical Writing in a Wiki - Single Source Publishing (November 2010).
® Website for exploring and downloading the available plugins: Atlassian Plugin Exchange.
® Documentation on installing and configuring plugins: Installing and Configuring Plugins using the
Universal Plugin Manager.
® Documentation on using macros: Working With Macros.
® Further Reading about Developing Technical Documentation on Confluence

Further Reading about Developing Technical Documentation on
Confluence

This page is part of the guide to developing technical documentation on Confluence. Once you have
absorbed all the information in this guide, you may be ready for more reading. =

The Confluence documentation: Confluence 4.0.

Tips from other technical writers, in the Confluence documentation: Tips of the Trade.

Blog post about using Confluence for online help: Using a wiki for online help.

Now you have your documentation space up and running, it's fun and rewarding to use the full
power of the wiki to engage your readers and embed content from other social sites. Here is a blog
post and presentation slides on engaging readers in the documentation.

@ Let us know about more links

We plan to add more links to this page or to the 'Tips of the Trade' page. Let us know of
any we have missed.

Developing a Knowledge Base on Confluence Wiki

Welcome! This is a guide to using Confluence as a knowledge base. You will find this guide useful if you
want to produce a knowledge base with a survey, content curation, intelligent search and standardized
templates.

In these pages, we'll show you how to use Confluence to achieve a high-functioning knowledge base,
including these features:

Using Templates

Subscriptions (RSS or Email)

Exporting articles (PDF or Word)

Organizing content (hierarchically or by label)

Involving Customers (using comments)

Populating data

Scripts to update content programatically

A "Was This Helpful?" survey

Intelligent searching algorithms (higher ranked articles are promoted in search results)
Targeted searching across specified Confluence spaces and content types
How to show related content

Extensive metrics and reporting

Maintenance

PAGES IN THE GUIDE

® Creating Your Knowledge Base Space

® Using Templates and Formatting Macros in a Knowledge Base
® Proactive Communications in a Knowledge Base

¢ Additional Plugins for a Knowledge Base

RELATED TOPICS
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Confluence User's Guide
Confluence Administrator's Guide

Creating Your Knowledge Base Space

This guide is for people who want to develop and publish a knowledge base using Confluence. You'll find
Confluence useful because it combines professional web publishing features with the ease-of-use and
flexibility of a wiki - requiring a low barrier to entry, but high quality output for all your team members.
Confluence provides all of the collaborative features for your reports (such as automatic versioning,
granular enterprise security, email and RSS subscriptions, and JIRA integration). This page is a quick-start
guide to creating a wiki space for a knowledge base.

@ Quick guide to creating a knowledge base space

Add a Space and Select the Documentation Theme

Set the Space Permissions

Customise the Title and Content of the Homepage

Customise the Documentation Theme

Create an Inclusions Library to Manage Reusable Content

Create the Table of Contents

Make your Knowledge Base Proactive with a Subscribable RSS Feed
Insert Google Analytics Code into Confluence's Custom HTML

Set up Atlassian's Content Survey and Reporting Plugin

The rest of this page gives more details of the above procedure.

On this page:

Step 1. Add a Space and Select the Documentation Theme

Step 2. Set the Space Permissions

Step 3. Customise the Title and Content of the Homepage

Step 4. Customise the Documentation Theme

Step 5. Create an Inclusions Library to Manage Reusable Content

Step 6. Create the Table of Contents

Step 7. Make your Knowledge Base Proactive with a Subscribable RSS Feed
Step 8. Insert Google Analytics Code into Confluence's Custom HTML

Step 9. Set up Atlassian's Content Survey and Reporting Plugin

Note about Plugin Support

Step 1. Add a Space and Select the Documentation Theme

Below is a quick guide to adding a space. See Setting up a New Global Space for a full description.

1. Go to the Confluence dashboard and click Add Space located on the 'Spaces' tab.
Hint: If you cannot see the Add Space link, this means that you do not have
permission to add spaces. Please contact your Confluence administrator.

2. In the 'Create Space' screen, enter a space name and a short, unique space key.

3. Leave the permission settings as default, or choose to allow only yourself to view or
contribute content to this space. You can change these settings later and with more
flexible options.

4. Select the Documentation Theme.

5. Click OK.

The homepage of your new space will appear. Because you created the space, you are the space
administrator. Now you can do some basic configuration, as described in the sections below.

Step 2. Set the Space Permissions

Define the space permissions to determine who can do what in your new space.

Choose Browse > Space Admin.
Click Permissions in the left-hand panel.
Confirm your administrator access as prompted.
Click Edit Permissions.
Set the permissions to suit your needs then click Save All.
® You can add groups and/or individual users to the list, then select the
permissions for each group or user.
® You can also set the permissions for anonymous users — these are people
who have not logged in to the wiki. Anonymous access is available only if
enabled for the entire Confluence site. We recommend this setting if you are
using this space for Technical Documentation or for a Knowledge Base.
® Note that you can change these permissions at any time. You may want to
restrict the permissions to specific groups now, and later open the space to
more people.

agrwbdpE
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A Bit More about Permissions

Confluence has a robust and granular permissions scheme that you can use to determine who can view,
comment on and even update the documentation. There are three levels of permissions in Confluence:

® Global permissions apply across the entire site.

® Space permissions apply to a space.

® Page restrictions allow you to restrict the editing and/or viewing of a specific page. Below we
discuss a way of using these in the draft, review and publishing workflow.

Space permissions in Confluence are simple yet granular enough to be useful for technical documentation.
You can:

® Use the permission levels to control who can create pages in the space, delete pages, create
comments, delete comments, administer the space, and so on.

® Grant a permission level to one or more users, and/or to one or more groups, and/or to
anonymous users.

Terminology:

® 'Anonymous' means people who have not logged in to the wiki. These are users that won't affect
your the number permitted by your license.

® The 'confluence-users' group is the default group into which all new users are assigned. Everyone
who can log in to Confluence is a member of this group.

For example, you might allow 'Anonymous' users specific view and content creation rights so that they can
access and engage with your knowledge base while your team lead (Bill) maintains full Space
Administration rights.

r N NN BN N
§ Example:Allow ar
| usersispecific.edi

Individual Users m rights;andiyour ac
m accesstothe spa

These are the permissions currently assigned to individual users for this space. [ B
Il I I I

Blog Comments|Attachments | Mail

View | Add |[Export | Restrict|Remove |Add |Remove|Add |Remove|Add |Remove |Remo:

£ Bill (admin) © 99 9 9 9 9 ¢ 9 9 9o o

(Editf
Anonymous Access

When a user is using Confluence while not logged in, they are using it anonymously.
For example: Enabling anonymous 'commenting' permission, allows non-logged-in users to make comme
space.

Blog Comments| Attachments|Mail

View | Add |[Export | Restrict|Remove Add |Remove| Add |Remove|Add |Remove |Remo:

& Anonymous © oo 0 Do O 9B 9 O @

For detailed information, see the documentation on:

® Global permissions
® Space permissions
® Page restrictions
® Users and groups

Step 3. Customise the Title and Content of the Homepage

When you created your space, Confluence created a homepage with default content and a default title,
'Home'. You will want to change the title and content.


http://confluence.atlassian.com/x/1R0C
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1. Go back to your space homepage, by clicking the space name in the breadcrumbs
at the top of the screen. In the example below, the space name is 'My Knowledge
Base':

Dashboard » My Knowledge Base » Space Administration »

View Space Permissions

2. The space homepage appears. By default, the page title is 'Home'.

Dashboard » My Knowledge Base » Home

Search

X

[

. Click Edit.

. Change the title to suit your needs.

. Update the content to suit your needs.
Hint: If you do not know what to add yet, just add a short description. You can refine
the content of the page later. Take a look at an example of a homepage.

6. Click Save.

g b w

Step 4. Customise the Documentation Theme

When you added this space you chose the Documentation theme, which provides a left-hand navigation
bar and a good look and feel for a knowledge base. If necessary, you can configure the Documentation
theme to add your own page header and footer or to customise the default left-hand navigation bar. These
customisations affect the online look and feel of your knowledge base. See Configuring the Documentation
Theme for the full description in our product documentation.
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. Choose Browse > Space Admin.

. Click Themes in the left-hand panel.

. If the space is not yet using the Documentation theme, apply the theme now.

. Click Configure theme in the yellow area of the '‘Current Theme' section at the top
of the page.

A WN P

Current Theme

Documentation Theme

¥
Wi

l

The current theme controls the layout and colours of

I This theme is well suited for s
such as documentation. It fea

contents (page tree) on the le
to see the structure of a spaci
page to page. You can custor
panel, page header and page
supports Firefox, Safari and Ii

Configure theme - further customise this theme's

5. The 'Documentation Theme Configuration' screen appears. Customise the left-hand
navigation bar, header and footer to suit your needs. Details are in the
documentation. Here are some hints:

® The Page Tree check box determines whether your space will display the
default search box and table of contents (page tree) in the left-hand panel.

® The Limit search results to the current space check box determines
whether Confluence will search only the current space or the whole
Confluence site. This setting affects the default search. Viewers can
override it each time they do a search.

® Enter text, images, macros and other wiki markup into any or all of the three
text boxes for the the left-hand navigation bar, header and footer. You can
use the Include macro and the Excerpt Include macro to include re-usable
content.

® Any content you add to the navigation panel will appear above the default
page tree.

® |f you like, you can remove the default page tree (by unticking the box) and
add your own, customised version of the Pagetree macro instead.

6. Click Save.

Example of a Customised Footer

Take a look at the footer of a page in the Crowd documentation space.

P T
Get Support ;‘.,5 Report a Bug ‘i Get Answers

Log a request with our support team. Raise an issue for our developers. See answers from the community.

Except where otherwise noted, content in this space is licensed under a Creative Commons Attribution 2.5 Australia License.

G

Tweet,
4

To produce the above footer, we have the following content in the footer panel in the Documentation theme

configuration screen:

Footer {include:_Documentation Footer|nopanel=true}

Here it is in text form:


http://confluence.atlassian.com/x/kQq6D
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{include: Documentation Footer|nopanel=true}
{include:ALLDOC: Copyright Notice|nopanel=true}

The above content consists of two Include macros.

® The first macro includes a page called _Documentation Footer. This page contains the big blue
buttons and hyperlinked text.

® The second macro includes a page from a different space, the ALLDOC space, called _Copyright
Notice. This page includes our standard copyright notice, used in all our documentation spaces.

® In each include macro, the content has been drawn from an inclusions library, a hidden content
repository, from which you can store frequently and reusable content throughout your knowledge
base space.

Step 5. Create an Inclusions Library to Manage Reusable Content

Using Confluence, you can dynamically include content from one page into another page. You can include
a whole page into another one, using the Include macro. You can also define an ‘excerpt’ on a page, and
then include that excerpted text into another page using the Excerpt Include macro.

To organise your re-usable content, we recommend that you create a set of pages called an ‘inclusions
library'.

1. Choose Browse > Pages.

2. Choose Add > Page. This will add a page at the root of the space, at the same level
as the homepage.

3. Enter a suitable title. We use '_InclusionsLibrary'. The unusual format of the title
helps to let people know this page is special.

4. Enter some content on the page. We enter text explaining the purpose of the
inclusions library and how to re-use the content. You can copy our text by clicking
through to one of the example pages listed below.

5. Add child pages containing your re-usable content. See the examples of our own
inclusions libraries listed below.

Some notes about inclusions libraries:

® The inclusions library is not a specific feature of Confluence. The pages in the inclusions library
are just like any other Confluence page.

®* The pages are located at the root of the wiki space, not under the homepage. This means that they
will not appear in the table of contents on the left and they will not be picked up by the search in
the left-hand navigation bar either.

®* The pages will be picked up by other global searches, because they are just normal wiki pages.

® We have decided to start the page name with an underscore. For example, '_InclusionLibrary'.
This indicates that the page is slightly unusual, and will help prevent people from changing the
page name or updating the content without realising that the content is re-used in various pages.

Examples of Inclusions Libraries
Here are some examples in our documentation:

® Crowd inclusions library
® Confluence inclusions library

Step 6. Create the Table of Contents

Create the table of contents for your knowledge base, by adding the top-level pages for all the usual
sections. For instance, our Technical Support Team designed the following pages in the Confluence
Knowledge Base on our public wiki:

Browse Atrticles by Label

Browse Articles by Top Ranked Content
Browse Articles by Page Tree Hierarchy
Browse Articles by Version

Subscribe to Proactive Announcements
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1. Go back to your space homepage, by clicking the space name in the breadcrumbs
at the top of the screen.

. Choose Add > Page. This will add the page as a child of the homepage.

. Enter the page title, for instance: '‘Browse Articles by Label'.

. Enter the content of the page.

® Hint: If you do not know what to add yet, just add a short description then

refine the content of the page later. If you like, you can follow a similar
outline as the Confluence Knowledge Base and add the Label List macro.
This displays a hyperlinked alphabetical index of all labels within the current
space. As you create content in this space and apply appropriate labels, the
macro will update this page automatically.

Browse Content by Label

A WN

Click on one of the labels below to find related content:

Below are the 181 labels used in Confluence Knowledge B:
a label to see its associated content.

m apache, cache,
applinks, calendar,
appserver, camelcase,
attachments, backup, camel_case,

bamboo, build captcha,
case_sensitivity,

L T e T e T

5. Click Save.

Now do the same for all the sections of your Knowledge Base that you wish to appear in the left-navigation
bar of the Documentation theme. Below is what the Table of Contents looks like for our Confluence
Knowledge Base:

Search the Knowledge Base and Documentation
Spaces

Search Confluence

Browse Content
Browse Articles by Label
Browse Articles by Top Ranked Content
[# Browse Articles by Page Tree Hierarchy
# Browse Articles by Version

[# Subscribe to Proactive Announcements

Step 7. Make your Knowledge Base Proactive with a Subscribable RSS Feed

Let's populate the knowledge base homepage with content by creating an RSS feed that your coworkers
and customers can subscribe to and receive important updates on your knowledge base and technical
alerts on your products.

This is a strategy that Atlassian's Technical Support Team uses to create a proactive knowledge base that
provides technical alerts to customers and coworkers and helps solve support issues before they're even
created.

By following the quick guide below, you'll create a homepage similar to the one Atlassian's Technical
Support Team has created for the Confluence Knowledge Base on our public wiki and turn your knowledge
base from reactive to proactive:
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Technical Announcements

Copy the RSS feed into your favourite RSS reader:

Blog Posts
|%] End of Support and New Support Announcements for Confluence 3.5 and Coni
4.0 created by
Sarah Maddox [Atlassian Technical Writer] Confluence Knowledge Ba:

|%] Welcome to the Confluence Technical Announcements Blog created by
Jeremy Largman [Atlassian] Confluence Knowledge Bas

@ Technical Alert for Confluence 3.4 - Login Errors when Delegating to Crowd cre

Adam Laskowski [Atlassian] Confluence Knowledge Ba:

View more recent blog posts

=

Creating your RSS Feed

Confluence can filter spaces by content type. To filter your knowledge base for 'blog post'
content, do the following:

1. Choose Browse > Blog Posts.

Browse =+ Administrator + 1l

Pages

Labels

Attachments

2. Copy this URL to your clipboard.
3. Create an RSS feed for the URL of your knowledge base space.
ﬂ Now your RSS feed will consist of any blog posts created in the knowledge base
space.

Highlighting Your Technical Announcement RSS Feed

1. Go to your space homepage by clicking the appropriate breadcrumb in the top-left of

your screen.

. Click Edit.

. Insert an 'h2' heading, such as 'Important Technical Announcements'.

. Insert bold text that reads something like, 'Copy the RSS feed into your favourite

RSS reader:'.

5. Choose Insert > Other Macros to open the Macro Browser.

6. Select the 'Panel' macro in the Macro Browser and specify your desired macro
preferences. We recommend that you change the Panel Title, Border Style, and
Background Color to further highlight the panel on the page.

7. Click Insert.

A wWN
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Insert a Blog Posts Macro

1. Click in the Panel macro placeholder and choose Insert > Other Macros to open
the Macro Browser again.

2. Select the '‘Blog Posts' macro in the Macro Browser and specify the following
preferences:

Blog Posts
Lists the most recent news items in

1 2 the space.

Content Type to Display: Title
Restict to These Spaces: Your knowledge base Spacekey
Maximum Number of News Items: 5
Sort By: Creation
® Reverse Sort: Tick the box
3. Click Insert to insert the Blog Posts macro onto the page inside your Panel macro.

ﬂ Now your panel will display the last 5 blog posts created in your knowledge base
space.

Inserting your RSS Feed into your ‘Technical Announcement' Panel

First, let's create a link so that your coworkers and customers can view all of the blog posts in
your knowledge base space. See Working with Links for a full description in our product
documentation.

1. Place your cursor after/below the Blog Posts macro in the Panel macro placeholder.
2. Type: 'View more recent blog posts'.
3. Highlight this text and click Link on the editor toolbar.

Insert Link

Search URL: http://

Recently Vieweo Link Text: |View m

Attachments

Web Link

4. Select 'Web Link' and paste the link you copied to create your RSS Feed.
5. Click Insert.

Now, let's insert your RSS Feed into your panel by linking an image. See Linking an Image
for a full description in our product documentation.

1. Attach an RSS Icon to the page by dragging and dropping it into

the editor (preferably below the link you just created). See Drag-and-Drop for a full
description in our product documentation.

. Click the RSS Icon image and then click the 'Align right' button on the editor toolbar.

. Click Border in the image properties panel.

. Link the RSS Icon by selecting the image and then clicking Link on the editor
toolbar.

5. Click the 'Web Link' tab and insert the RSS Feed URL you created.

6. Click Insert to link your RSS Feed to the RSS Icon image.

7. Click Save to save your page and test your RSS Icon.

A wWN

Congratulations! You have successfully created a proactive knowledge base.

Step 8. Insert Google Analytics Code into Confluence's Custom HTML

Now that you have a strong foundation for a knowledge base, it's critical to assess how effectively it
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services your customers. Google Analytics is a tool that gives you rich insights into your website traffic and
marketing effectiveness. You are going to want to understand how your customers are accessing the
resources in your knowledge base. This is a quick guide to inserting Google Analytics HTML code into
Confluence so you can measure your knowledge base traffic.

1. If you don't have one already, create a Google Account and then create a Google
Analytics Account using your Confluence instance's URL.
. Copy the Google Analytics code to your clipboard.
Log into Confluence as a System Administrator or Confluence Administrator.
. Go to the Confluence 'Administration Console'. To do this:
a. Choose Browse > Confluence Admin.
b. Enter your password and click Confirm. You'll be temporarily logged into a
secure session to access the '‘Administrator Console'.
. Click Custom HTML under 'Look and Feel'.
. Click Edit to insert custom HTML into your Confluence instance.

INYANN)

[N

Insert Custom HTML

At end of the HEAD

At beginning of the BODY

At end of the BODY

‘Save) (Cancel )
p " . "

7. Paste your Analytics code you have saved to your clipboard into the table labeled At
end of the BODY.
8. Click Save.

You can now monitor the activity and traffic for every page you create in your Confluence instance and
Knowledge Base.

Hint: If your knowledge base only represents a space within your greater Confluence instance, you can
search Google Analytics for activity in the specific space by exclusively filtering for the space key.

contairning

Filter Page: | MYHKE Go | Advanced Filter

Filter“Top/Content*usingjaiSpace Key

0 Read David Simpson's blog post about Tracking Confluence Usage with Google Analytics for more
information.

Step 9. Set up Atlassian's Content Survey and Reporting Plugin

Now that you can monitor the traffic and activity of your knowledge base, let's measure its effectiveness.
When the Content Survey and Reporting Plugin is activated for a space, it will generate a report that
includes:

® Direct feedback from customers about article quality

* Amalgamated "composite score" results

® Answers to secondary questions, such as "Was the info complete?" or "Was the article
well-written?".

® Rollup at-a-glance view of the metrics for the whole space.

Lastly, the Content Survey and Reporting Plugin will institute ‘intelligent searching' which means that based
on the results of the surveys, higher ranked pages are promoted in search results, so your best and most
popular pages are found easiest. This is a quick guide for how to set up the Content Survey and Reporting
Plugin.

o This plugin only functions properly if the Documentation Theme is applied to the space.
Let's install the Content Survey and Reporting Plugin using Confluence's Universal Plugin Manager.


http://davidsimpson.me/2009/03/18/tracking-atlassian-confluence-usage-with-google-analytics/
https://plugins.atlassian.com/plugin/details/24440
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Installing the Content Survey and Reporting Plugin

1. Log into Confluence as a System Administrator or Confluence Administrator.
2. Go to the Confluence 'Administration Console'. To do this:
a. Choose Browse > Confluence Admin.
b. Enter your password and click Confirm. You'll be temporarily logged into a
secure session to access the 'Administrator Console'.
3. Click Plugins under 'Configuration’
4. Click the Install tab of the UPM and search for the ‘Content Survey and Reporting
Plugin'.

A% Install

The Universal Plugin Manager allows you to view, manage and upgrade your ins
new ones from the Atlassian Plugin Exchange.

Manage Existing = Upgrade (5) | Install | Confluence Upgrade Check

Plugins to show: | Search results B content surve

Plugins matching "content survey and reporting p

2 Content Survey and Reporting Great for a Knowledge Base, Documentatic
Plugin includes space-wide configurable surveys, |
algorithms, top articles and dynamic conten

multi-space QuickNav searching.

5. Click Install Now.

Now that you've installed the Content Survey and Reporting Plugin, let's configure a survey:

Configuring a Survey

1. Go to your space homepage by clicking the appropriate breadcrumb in the top-left of
your screen.
2. Choose Browse > Space Admin.
3. Click Configure Survey under '‘Knowledge Base Survey'. Here you can:
® Add a question
® Edit a question's text
® Activate or deactivate a question
® Edit the response text
4. Configure a 'Primary Question' for the survey

Primary Question: \Was this helpful?

Add an Additional Question:

Edit Survey Completed Response (anonymous): [ Thanks!

Edit Survey Completed Response (user): [Thanks!

5. Click Save.

Now that you've added a primary question, let's test out the plugin by adding it to the footer of the
Documentation theme so that every page within your Knowledge Base space includes your survey.
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Invoking the Content Survey and Reporting Macro

1. Go to your space homepage by clicking the appropriate breadcrumb in the top-left of
your screen.
. Choose Browse > Space Admin.
. Click Themes under ‘Look and Feel'".
. Click Configure theme in the yellow area of the ‘Current Theme' section at the top
of the page.
5. Visit the 'Footer' section of the 'Documentation Theme Configuration' page and insert
this recommended markup to achieve a nice layout of the Content Survey and
Reporting Plugin:

{section}
{column:width=5%}
{column}
{column:width=90%}

{panel}
{kbsurvey}

{panel}

{column}
{column:width=5%}
{column}
{section}

A WOWN

6. Click Save and go to your space homepage to view your Content Survey and
Reporting Plugin in the footer of the page.

With the Content Survey and Reporting Plugin you can dramatically improve the quality of our knowledge
base and the efficiency with which your team creates and maintains it. Here is an example of how our
Technical Support Team uses the Content Survey and Reporting Plugin in the Confluence Knowledge
Base:

Help us improve!
Is this article helpful? O Yes O No
Is the content complete? (O Yes O No

Is it well written? O Yes O No

Content Survey and Reporting Plugin Results:
Survey results are viewable by Space Administrators only. The plugin develops three results:

® Pages with Results - Determine page-by-page, which are you most effective knowledge base
articles and which ones need improvement.
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View: Pages with Results | Pages without Results | Rollup Report Direct/Feedback S?RQQQ?LH}"
Contluence Knowledge Base Bt oo ] hophr complewt
Cannot Save Large Pages with Owver 700,000 Characters 2 6 l 100% (2/2) 100% (1/1)
Unable to Export to HTML due to Page Title with * Symbol 2 6 100% (2/2) 100% (1/1)
Unable to Download Attachments in |E over SSL 2 4 100% (2/2) 100% (2/2)
MySQL Table is Marked as Crashed and Should be Repaired 1 3 100% (1/1) 100% (1/1)
ClientAbortException java.net.SocketException Broken Pipe 1 3 100% (1/1) 100% (1/1)
Getting PacketTooBigException Error 'Packet for query is too large' 1 3 100% (1/1) 100% (1/1)
Cluster Panic due to Multiple Deployments 1 3 100% (1/1) 0% (0/0)
Page Footer Appears in the Middle of the Page 1 3 100% (1/1) 0% (0/0)
Confluence Fails to Process Index Queue Automatically 1 3 100% (1/1) 0% (0/0)
Fatal JVM Crash - 'java.lang.OutOfMemoryError .. Out of Swap Space? 1 3 100% (1/1) 100% (1/1)
';[?;::L\.i;;ls SPS Single Sign-on failed' Due to Invalid Credentials in the 1 2 100% (11) 100% (11)
Database Deadlock on Microsoft SQL Server 2 2 50% (1/2) 0% (0/2)
Cluster Panic due to Multicast Traffic Communication Problem 2 2 50% (1/2) 0% (0/0)
Confluence Rebuild Indexing task fails to complete. 1 2 100% (1/1) 100% (1/1)
gz:c:emneiz:gt?oia%ﬁ:x‘:u;:‘;izisabled Velocity Helper Module in 1 A % (/1) 0% (0/1)

As you can see, the plugin develops a 'Composite Score' which ranks articles in search, so your highest
scoring (best) content can be found most easily. The score is based on the last 32 votes cast, using the
global search configuration. See Confluence Content Survey and Reporting Plugin for a full description on
how Global Search boosting works.

® Pages without Results - These are the pages in you knowledge base without survey results.
® Rollup Report - This is the summary of all survey results. The report can be used to determine
how effective your overall knowledge base content is.

Number of Pages in Space Total Ballots Cast Is this article helpful? Is the content complete’

645 29 59% (17/29) 61% (11/18)

Searching Multiple Spaces from your Knowledge Base

As mentioned, the Content Survey and Reporting Plugin generates a composite score that ranks pages
and articles within your knowledge base to make the highest (most well regarded) pages more retrievable
by visitors. The plugin also improves Confluence search by allowing users to search multiple spaces
without ever leaving your knowledge base space. This is really helpful for users that are unfamiliar with
Confluence because they can keep the knowledge base as a point of reference within the greater instance
of Confluence.

At Atlassian, our product knowledge bases and product documentation exist in the same Confluence
instance so that we can make both available to 'Anonymous' users. Our Technical Support team uses the
Content Survey and Reporting Plugin to allow visiting users to search for Confluence resources in the
product documentation space from the Confluence Knowledge Base space. This provides the visitor twice
the chances of finding an answer to their question.

In the image below, you can see the space specific search used in the left-navigation bar to find content

related to Confluence in both the 'Documentation' and 'Knowledge Base' spaces. Pages in the
'Documentation’ space are listed first and pages in the 'Knowledge Base' space are listed second.
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Spaces

Search the Knowledge Base and Documentation

[ confluence|

=F

[ B

=F

[ B

Confluence Security
Confluence Glossary
Confluence lcons
Confluence 101
Confluence Cookies

Configuring Confluence

| r'| Confluence Emoticons
%] Confluence 1.4-RC1 Released

E.' Confluence 1.4.1 Released Knawledge
ET Confluence 1.3-DR1 Released ﬂm

%] Confluence 1.3.1 Released Search

E.' Confluence 1.3.6 Released —R'-—%g—lll-t—%

ET Confluence 1.4.4 Released

%] Confluence 1.3 Released

(_{ Search for ‘confluence’

Product:
Documentation
Search

Results

If a user doesn't choose one of the recommendations from the quick search drop-down menu, the plugin
will display a search results page inside the Knowledge Base space rather than directing them to the
Confluence global search page. By keeping the visitor in the same space, it will help new users find the
information they need and only navigate to pages they intend to, minimising confusion and the number of
times a user has to hit the '‘Back’ button in their browser.

Search the Knowledge Base and D

[£] Confluence Can't Start and Doesn't Create Logfiles due to CATALINA_HOME Being Set (Confluence |

Spaces

Search Confluence

Browse Content
Browse Articles by Label
Browse Articles by Top Ranked Content
& Browse Articles by Page Tree Hierarchy
# Browse Articles by Version

@ Subscribe to Proactive Announcements

Confl Can't Start and Doesn't Create Logfiles due to CATALINAHOME Being Set Symptoms ...
Jan 09, 201
Labels: tomcat, startup

| Getting '501 Syntactically invalid HELO argument’ Error when Sending Mail From Conﬂuenc4(0unr\w
... 501 Syntactically invalid HELO argument' Error when Sending Mail From Confluence Symptoms Whi
argument(s)}} error. The atlassianconfluence.log file ..

11 = 2
Cem—— Without: L?V|n?~thle knowleggg#asg,g%?
- canjsearch multiple;spaces)within/Con
[2) Confiuence 101 cansearchimuipie,spaces wontl
using Confluencé: (1) Are you Using Confluence Hosted hitp:/iwww.atl 1.COMISO fluen
EHOSTING:Enterprise Hosting Resources instead. Getting Started 1 ... ...

Nov 28, 2010
Labels: resources, starter, confluence

[2) Integrating JIRA and Confluence (Confluence 3.4)

... groups of issue: CONF open improvements@JIRA will link to a list of all open issues in the Confluent
JIRA content in Confluence Using Gadgets: Confluence 3.1 and JIRA 4.0 Several Confluence ...

Dec 16, 2010

Labels: integration, confluence-jira

Note about Plugin Support

Before installing a plugin into your Confluence site, please check the plugin's information page to see
whether it is supported by Atlassian, by another vendor, or not at all. See our guidelines on plugin support.

Next Steps

See Using Templates and Formatting Macros in a Knowledge Base for next steps.

Using Templates and Formatting Macros in a Knowledge Base

This page is part of the guide to developing a knowledge base on Confluence Wiki. We have already
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shown you how to create your knowledge base space. Now we offer an introduction to the templates that
Confluence provides.

@ Quick guide to templates in Confluence

® Atemplate is a page with predefined content that can be used as a prototype
when creating other pages.

®* Templates are available across the Confluence site (global templates) or per
space (space templates).

® Both 'global templates' and 'space templates', as described on this page, define
the content of a page. They do not define the content of an entire space.

® You can import predefined templates, including those shipped with Confluence
and additional templates from the Atlassian Plugin Exchange.

® To create a template for an entire space, see our guide to creating your
documentation space.

Space Information Design

One question that comes up is whether a knowledge base should be implemented as a decision matrix,
with a multi-select or other list. We knew that most of our users visit our documentation directly from search
engines. Early on, we learned that at least for us, Google Analytics was showing that most traffic was
coming from search engines, not from within our site. See Metrics for a discussion on that. So, we knew to
focus on optimising page titles and tags rather than focus on a decision matrix.

Confluence's Built-in Feature Set
Page Templates
Confluence's Page Templates are an easy place to start. Begin by choosing how you want your templates

to look. Here's how we made our page template:

h3. Symptoms
FILL IN SYMPTOMS HERE

h3. Cause

FILL IN CAUSE HERE

FILL IN RESOLUTION HERE
{htmlcomment }

ENTER SUPPORT TICKET LINKS
{htmlcomment }

: h3. Resolution
L

@ The {htmlcomment} macro is part of Adaptavist's Content Formatting Macros, a handy
plugin.

You might consider the scaffolding plugin or Form Field Markup for filling out forms. Our support engineers
are quite used to using wiki markup (we live and breathe Confluence!), so we left this template as is.

Construct a Home Page: Section, Panels, RSS, and Notifications

Check out the Confluence Knowledge Base Home. The colored content in the middle of the page is an
amalgamation of panel, rss and attahment macros. Go to Tools >> Wiki Markup to see.

@ Wondering how we just made Tools >> Wiki Markup in a different font in the
sentence above? Use the {{ }} notation to get the courier font, which you can use for
breaking out text. And this would be, of course, a {tip}. Remember, you can visit Tools
>> Wiki Markup on this page as well!

The wiki markup there is a little confusing, but it breaks down like this:

A Section macro, defining the top and bottom of the page

Column macros, dividing the panels into three

Panel macros, with hot, hot, hot html colours

Content By Label Macros

An RSS Icon, embedded as an attachment, with a link to the RSS feed. Notice the magic on this
one:

arONE
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o That's a link, with the attachment as the alias, an alignment parameter, and the URL to the
RSS feed. Cool, right?
Exporting Pages

These are built-in Confluence features. Check Page Exports. You can learn how to customise the PDF
export as well.

Content Macros

Besides the ones listed above, some favourite macros for formatting content around the site are the Tip,
Info, Warning, and Note Macros, ad the Code macro. They make things look great. We also use
Adaptavist's Content Formatting Macros when we really want to bring our A-game.

r

Every once in a while we get mileage out of the {nomarkup} user macro, when we want
to discuss using a macro itself. | suppose that's because Confluence is one of the
products we support! It might be useful for other reasons...

JIRA Issues Macro
Using JIRA for bug tracking? You can't expect your users to necessarily have exactly the right JQL filters to

show the appropriate topics. We have some nice JIRA Issues Macros on display. One of my favourites is in
the JIRA KB's Causes for OutOfMemory Errors:
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Notice the JQL there including components and sorting, plus the specific columns.
Labels

Sometimes, an article needs to be cross listed. For that we label our articles. Some great macros to use for
this are {contentbylabel}, {listlabels} and the {dynamiccontentbylabels} macro in the Content Survey Plugin.

Next Steps

You now have a good idea of how Confluence templates work. What next? Take a look at Proactive
Communications in a Knowledge Base.

Proactive Communications in a Knowledge Base

This page is part of the guide to developing a knowledge base on Confluence Wiki. We have already
shown you how to create your knowledge base space and how to use templates and formatting macros.
We touched a bit on creating proactive communications in Creating your Knowledge Base Space, and
discuss a bit further here.

@ Quick guide to proactive communications
* Atemplate is a page with predefined content that can be used as a prototype
when creating other pages.
® Confluence can either produce or consume rss feeds
® Both the rss and blog-posts macro are a good way to show summaries

Proactive Alerts

Sending technical alerts to customers is a great way to keep customers and staff informed, and good way
to reduce support load. At Atlassian we use the Knowledge Base both to consume and produce proactive
content for which customers can opt in. This page describes how to achieve that.

Using Confluence as a producer

® The Working with Blog Posts describes how to produce blog posts from Confluence.
® E-mailing a Page is a great way to send mass emails to users or an email distribution list.

Using Confluence as a consumer

Even if your Confluence instance isn't producing your proactive content, it can consume and display it in a
prominent way:
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® The RSS Feed Macro can consume content from any RSS feed on the Internet.
® We use the Blog Posts Macro for It looks especially handsome in a panel, accentuated by an RSS
image in a link. Here's the wiki markup:

h4. Technical Alerts

{panel:title=Important Technical Alerts for Confluence|
borderStyle=solid| borderColor=#ccc| titleBGColor=#£93 |
bgColor=#fc9}
{blog-posts:content=title|max=>5|sort=modified|spaces=CONFKB|time=3
more recent blog
posts|http://confluence.atlassian.com/pages/viewrecentblogposts.ac
Knowledge Base

Home”rss20.gif|align=right! |http://confluence.atlassian.com/create

r

Note that the blog posts macro can display mail! Use it to highlight mail you've
sent as alerts, after archiving mail.

Next Steps

You now have a good idea of how to do proactive communications. Next up, consider Additional Plugins for
a Knowledge Base in more detail.

Additional Plugins for a Knowledge Base

This page is part of the guide to developing a knowledge base on Confluence Wiki. This page includes
additional plugins that might expand your usage.

Useful Plugins for a Knowledge Base

These are some great plugins for Confluence as a Knowledge Base:

® The Content Survey and Reporting Plugin gives a good report on popular and unpopular content.

® The Archiving Plugin flags old content.

®* The Ad Hoc Workflows Plugin or Content Publishing Plugin, which manages workflows and a
review process.

Note about Plugin Support

Before installing a plugin into your Confluence site, please check the plugin's information page to see
whether it is supported by Atlassian, by another vendor, or not at all. See our guidelines on plugin support.

Bye

Hope you enjoyed the tutorial! Have a chocolate, and please share with us your experiences. You can
comment directly on this page or email us at .

Developing an Intranet on Confluence Wiki

This guide is for people who are using Confluence as a platform for an intranet. You will find this guide
useful if you want to create a space where your team can collaborate and share information.

@ Quick guide to creating an intranet space

Add a space.

Set the space permissions.

Customise the title and content of the home page.

Subscribe to email notifications for any updates made to the space.
Manage your existing Office documents.

Import page templates.

Set up your personal space.

Publish a blog post.

The rest of this page gives more details of the above procedures.

Step 1. Add a Space

Below is a quick guide to adding a space for your team.
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4.
5.

. Go to the Confluence dashboard and click the '‘Add Space' link.
. The 'Create Space' screen appears. Enter a space name and a short, unique

space key.

. Leave the permission settings as default, or choose to allow only yourself to view or

contribute content to this space. You can change these settings later and with more
flexible options.

Select a theme. We recommend the 'Global Look and Feel' theme for an intranet.
Click 'OK" to add the space to your Confluence site.

The home page of your new space will appear. Because you created the space, you are the space
administrator. Now you can do some basic configuration, as described in the sections below.

Step 2. Set the Space Permissions

Define the space permissions to determine who can do what in your new space.

abwiN

1.

Open the 'Browse' menu and select 'Space Admin'.

Browse » Administrator =

Pages
Elog %‘ Add

Labels

Attachments
Bookmarks
Mail

Advanced

Space Admin

People Directory
Space Directory
Keyboard Shortcuts
Confluence Gadgets

Confluence Admin

. Click 'Permissions' in the left-hand navigation panel.

. Confirm your administrator access as prompted.

. Click 'Edit Permissions'.

. Set the permissions to suit your needs then click 'Save All'.

® You can add groups and/or individual users to the list, then select the
permissions for each group or user.

® You can also set the permissions for anonymous users — these are people
who have not logged in to the wiki and will not count towards the number
allocated by your license. Anonymous access is available only if enabled for
the entire Confluence site. However, it is unlikely you will need anonymous
users for your intranet.

® Note that you can change these permissions at any time. You may want to
restrict the permissions to specific groups now, and later open the space to
more people.

More about Permissions




Confluence 4.0 Documentation

452

Confluence has a robust and granular permissions scheme that you can use to determine who can view,
create content and comment within your intranet. There are three levels of permissions in Confluence:

® Global permissions apply across the entire site.
® Space permissions apply to a space.
® Page restrictions allow you to restrict the editing and/or viewing of a specific page.

Space permissions in Confluence are simple yet granular enough to be useful for an intranet. You can:

® Use the permission levels to control who can create pages, delete pages, create comments, delete
comments, administer the space, and so on.

® Grant a permission level to one or more users, and/or to one or more groups, and/or to
anonymous users. A space administrator has complete control.

Terminology:

® 'Anonymous' means people who have not logged in to the wiki.
® The 'confluence-users' group is the default group into which all new users are assigned.
Everyone who can log in to Confluence is a member of this group.

For example, you might allow the ‘confluence-users' group permission to create and edit comments, but
reserve full editing rights for your team members. Let's assume your team members are all members of the
'dev-team' group. The example below shows that members of the 'dev-team' group have all permissions
except space administration, but 'Ryan Reynolds' only has a few editing rights.

\bels | Attachments | Bookmarks | Mail | Advanced JE-ELRL G

N I
Example:;Allow:Cont

I users §nmele:.:||t':r!gh
your'team maintains

Groups I rights for.content cre
ﬂ_1e;snace
These are the permissions currently assigned to groups for this space. _‘; R —
Pages Blog Comments |Attachments
mwwmmmm Remove|Add  |Remove|Re

&, confluence-users o0 O B9 BQO 9 8 9 O 9
£ dev-team Q0 9 O 9 9 9 9 9 9 9 9o

L Edit F

Individual Users

These are the permissions currently assigned to individual users for this space.

Pages Blog Comments |Attachments

L Administrator (admin) & & & ©@ & & © © © © © ©
e meoy @ © 8 B D OB © B © 0O B

(randerson @atlassian.com

For detailed information, see the documentation on:

® Global permissions
® Space permissions
® Page restrictions
® Users and groups

Step 3. Customise the Title and Content of the Home Page

When you created your space, Confluence created a home page with default content and a default title,
'Home'. You will want to change the title and content to suit your team.
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1. Go back to your space home page, by clicking the space name in the breadcrumbs
at the top of the screen. In the example below, the space name is ‘Development
Team Space":

Dashboard » Development Team » Space Administration » View Space P

B 4 View Space Permissions

Pages || Blog | Labels ] Attachments | Bookmarks § Mail

2. The space home page appears. By default, the page title is 'Home".

Dashboard » Development Team * Home

b 4 Home

&4 Added by Administrator, last edited by Administrator on Jan 28, 2011

3. Click 'Edit".
4. The page opens in edit mode. Change the title to suit your needs.

Dashboard » Development Team » Home » Edit Page

Development Team Space
Wiki I".I'Iarkupl

o [ad T

This is the home of the Development Team space.

5. Update the content to suit your needs.
Hint: If you do not know what to add yet, just add a short description. You can refine
the content of the page at any time.

6. Click 'Save' to save your home page.

Step 4. Subscribe to Email Notifications for Updates Made to the Space
You can configure your email notifications to suit your needs: Subscribe to all blog posts from Confluence,

subscribe to your network, or stay informed about any changes in a specific space. Below is a quick guide
to monitoring a space's content. See Watching a Space for a full description.
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1. Open the 'Browse' menu and select 'Advanced'.

Browse = Administrator = [EEE)

Pages

Hl Add

Blog

Labels
Attachments
Bookmarks

Mail

Advanced

Space Admin

2. Click 'Start watching this space' in the bottom section of the left-hand navigation
panel.

If at any time you wish to stop watching the space, just click 'Stop watching this space'.

Example of an Email Notification

Here is an example of the email notification you will receive when someone adds a comment to a page:

Confluence @atlassian.com| to me

Spend 5 minutes. Save a heck of a lot more.

Blog post comment added by Ryan Reynolds

Required Reading. Auto-complete rocks. Nice video!

View Online | Eeply To This

+ Reply =¥ Forward

More about Notifications
You can specify the notifications you want to receive on a global, space and page level. The quick guide

above demonstrated how to set up notifications for a space. Now we will show you how to configure your
notifications on the global and page levels.

Global Notifications

Global notification settings determine the overall behaviour of the notifications you receive from
Confluence.
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1. Open the 'User' menu (Your name) and select 'Settings'

Administrator ~ BlEle)

Update Status...

Create Personal Space

Recently Viewed

Profile

Network

Status Updates
Labels
Watches

Drafts

Log Out

2. Click 'Email" in the left-hand navigation panel.

3. Click 'Edit'".

4. Change the default settings to suit your needs. You can alter these email settings at
any time.

5. Click 'Submit' to save your changes.

Page and Blog Post Notifications

Follow the quick guide below to receive notifications from Confluence about changes to and comments on
a specific page or blog post. See Watching a Page or Blog Post for a full description.

You can watch any given page or blog post that you have permission to view. We will use your space's
home page as an example.
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1. Open the home page of your space.
2. Open the 'Tools' menu and select 'Watch'.

SSNCRA ) Tools ~

& Attachments (0)
~) Page History
B Restrictions

iw Edit in Word

v Favourite

=2 Manage Watchers

You are now watching the current page and Confluence will notify you about any updates made or
comments added.

Note that Confluence will not notify you about content changes that are due to the output of a macro. For
example: The output of the Children macro will change if someone adds a child page. The page containing
the Children macro will show the new child page. But the page content itself has not been edited, so no
notifications will be sent.

You can stop watching a page or blog post at any time. Just open the page, go to the 'Tools' menu and
click 'Stop Watching'.

Step 5. Attach or Import Office Documents if Applicable

Below are some guidelines on managing your existing Office documents in Confluence. You can choose to
attach them to a Confluence page, so that team members can view and access them in Confluence. Or
you can import the documents into Confluence, converting the content to wiki format.

Attaching Office Documents to a Page

You can use Confluence as a central repository for your team's the Microsoft Office documents. This
means that you can share your Office documents without having to email them to your teammates. People
can view the Office documents even if they do not have Office installed on their computers.
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C.

1. Go to your space home page, by clicking the space name in the breadcrumbs at the
top of the screen.
2. Hovering over the 'Tools' menu and click 'Attachments'.
3. Choose one of the following methods for attaching files to the page:
® Use the 'Attachments' view's 'browse and attach' feature to attach one or
more file(s):
a.
b.

Click the 'Browse' button.

Browse through your files and select the file that you would like to
attach to the page.

Enter a description for the attachment in the '‘Comment' text field
(optional).

. Click 'Attach more files' if required. More attachment entry fields

will appear, allowing you to attach more files.

. Click the 'Attach’ button.

Attach File

You cannot attach files with names containing '+' or '8

( Attach ) Attach more files
R

® Alternatively, use the drag-and-drop feature to attach one or more file(s):
Drag one or more file(s) accessible from your computer and drop them onto
the 'Attachments' view. The 'Attach File(s)' message box appears, indicating
the upload status of the file(s) being attached to your page.

Attach File(s)
Example of Image.png

478.73 Kb of 478.73 Kb

Excel Spread Sheet.xls

515.23 Kb of 36.50 Kb

Microsoft Word.docx

672.22 Kb of 156.99 Kb

PowerPoint.pptx

805.72 Kb of 229.96 Kb

Importing Existing Word Documents into Confluence

You can also import content from Microsoft Word into Confluence, so that it becomes a wiki page. See
Importing an Office Document into Confluence for a full description.
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1. Go to your space home page, by clicking the space name in the breadcrumbs at the
top of the screen.

2. Open the 'Tools' menu and select 'Import Word Document'. The Office Connector
import screen will appear.

3. Click the 'Browse' button and find the Office document on your local drive or
network.

4. Click the 'Open’ or 'Upload' button provided by your browser. The path and file
name of the document will now appear in the text box on the Office Connector
import screen.

5. Click the 'Next' button. The import document options screen will display.

Development Team Space

Import Word Document: Configuration

Root page title:  Microsoft Word

Where to import: @ Import as a new page in the current space
Replace Development Team Space

Delete existing children of Developmen

Title conflicts: ® Rename imported pages if page name alre
Replace existing pages with imported pag

! Remove existing pages with the same title

Split by heading: Can't split this document. If confains no Headi

|'-’I \I
| Import )

6. Enter the following information:
® 'Root page title' — The title of the wiki page that will contain the information
from your imported document.
® 'Import as a new page in the current space' — A new wiki page will be
created with the page title specified above.
® Choose what you want the importer to do if there are page title conflicts, by
selecting one of the following options:
® 'Rename imported pages if page name already exists' — Confluence will
assign new names to any new page which would otherwise have a duplicate
name. The content of existing pages will remain unchanged.
® 'Split by heading' — Use this field to split your document into multiple wiki
pages. If you do not want to split your document into multiple wiki pages,
leave the default 'Don't split' option selected.
7. Click 'Import' to import your document.

When the upload has finished, the content of the Office document will have been transformed into
Confluence page content. You can now view and edit this page in the normal way, using the Confluence
Rich Text Editor or Wiki Markup. There is no connection between the original Office document and this wiki
page.

Step 6. Import Page Templates

In order for an intranet to be effective, people need to use it. One way to spur new user adoption is to
provide your team mates with templates so that they can focus more on content creation and less on page
format. Confluence offers a number of templates, including a template for ‘Meeting Notes' and a
‘Three-Column Layout', to help your team get started populating your intranet and improving its
productivity. See Importing Templates for a full description.
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1. Log in to Confluence as an administrator and go to the Confluence '‘Administration
Console'.

2. Click 'Import Templates' in the left-hand navigation panel. The ‘Import Templates'
screen will appear, listing the template packages deployed to your Confluence
instance (for example, 'Default Templates Package') and the templates included in
each package.

Dashboard » Administration » Import Templates

B 4 Import Templates

Security The following template package plug
templates, tick the checkboxes for th

Security to import the templates to, and click

Configuration
Manage Users
Manage Groups
Global Permissions Default Templates Package (

User Directories

[ Charts
Configuration [l Document List
General - Meeting Notes
Configuration [ Multimedia Content
Daily Backup Admin ] RSS News Feed
[ Tasklist

Manage Referrers

. [ Three-Column Layout
Plugins —

] Two-Column Layout
Languages

Shortcut Links

External Gadgets Import To: | Global Templates 4

Global Templates (Import)
| S MR

Import Templates

3. Select the templates you want by ticking the check boxes next to the template
names.

Note: You can view a preview of the template by clicking the template name.

4. Select the import destination for the templates in the ‘Import To' dropdown. If you
want the templates to be available to a specific space only, select the name of the
space, otherwise select ‘Global Templates' to make the templates available to all
spaces.

5. Click the 'Import' button to import the selected templates.

How Users will Find Templates

Now that you have made Confluence's templates available to your site or space, other Confluence users
will be able to choose a template when they want to create a page.

Choosing a Template from the Dashboard

When you add a page from the Confluence dashboard, you will be able to select the template and space
for the new page at the same time.
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1. Go to the Confluence Dashboard by clicking ‘Dashboard' from the breadcrumbs at
the top left of your screen.
2. Click the 'Add Page' button. The 'Add Page' dialog appears.

SPLGLEZEGEE (& Add Blog Post

Space

[ Development Team
Template

[ Start with a blank page
Learn more about templates

{ Next) Cancel

3. Select the space where you want to add the page.
4. Select the template you want to use to populate your page.

SPLGLREGEE (& Add Blog Post

ar
—

Ak
4

Space

a
L

[ Development Team
Template

¥ Start with a blank page A |
Space Templates
Global Templates
Charts
Document List @ Cancel
Meeting Notes
Multimedia Content
RSS News Feed
Tasklist
Three-Column Layout
Two-Column Layout

P

5. Click 'Next' to create the page.

Choosing a Template from within the Editor

Often you will add a page from within a space, or as a child of another page. This guide shows you how to
choose a template from within the Confluence editor.

1. Go to your space home page, by clicking the space name in the breadcrumbs at the
top of the screen.
2. Hover over the 'Add' menu and click '‘Page’. This will launch the Confluence editor.
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3. To populate the editor from a template, click the 'Select a page template to start

from' link below the 'Title' field. This will launch the 'Page Template Wizard'.

b 4

' |
= (O
Select a page template to start from. - E;:]
H —
o
[ Rich Text | (DAY (.

Paragraph ~ B Z U ¢ A~ |4
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4. Choose a page template from those available in the list.

Page Template Wizarc

Step 1: Choose a page template

Please choose a template from below:

Name
O Charts
O Document List
O Meeting Notes
O Multimedia Content
O RSS News Feed
O Tasklist
O Three-Column Layout
O Two-Column Layout

‘Back ) (Next>>

5. Click 'Next' to populate the editor with the selected template.

Step 7. Set Up your Personal Space

Now that you have created a space for your team, let's create your personal space. This is a place where
you can publish your own pages and blog posts. Once you have created it, Confluence users can reach
your personal space by clicking your name in the People Directory or by searching for your name via the
quick navigation search box.
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1. Go to your name at the top of the page and select 'Create Personal Space' from
the dropdown list.

Administrator ~ ElElgs)

Update Status...

Bi

Create Personal Space

Recently Viewed

Profile

Network

2. Enter a few details about your space:

® Choose who can view content.

® Choose who can contribute (create and edit) content.

® Choose the 'Global Look and Feel' for your personal space.
3. Click the 'Create' button.
4. The 'Home' page for your new space is displayed.

Step 8. Publish a Blog Post

Blog posts are a good way of letting your team mates and the company know your news. People can blog
about product and strategic ideas, team updates, and things they want to get ideas about. New employees
can write blog posts introducing themselves. People write about getting married or the birth of a child. Blog
posts are a great way for people to share their visions, get to know their c-oworkers and start lively
discussions.

Remember to set your email notifications to alert you about the blog posts published within Confluence, as
described in an earlier step.

See Working with Blog Posts for a full description of adding, editing, viewing and linking to blog posts.

. Go to a page in your space.

. Hover over the 'Add"' menu and select 'Blog Post'.
. Change the title to suit your needs.

. Update the content to suit your needs.

. Click 'Save' to publish your blog post.

abhwNPE

Related Topics

Setting up a New Global Space
Global Permissions Overview
Assigning Space Permissions
Setting a Page's Restrictions
Users and Groups
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